AutoCAD® provides tracking and object snap tools to help you draw quickly and accurately. By using these tools, you can draw precisely without having to enter coordinates or perform tedious calculations. You can also use AutoCAD inquiry methods to quickly display information about drawings and drawing objects.
Adjusting Snap and Grid Alignment

Snap and grid settings help you create and align objects. You can adjust the snap and grid spacing to intervals useful for specific drawing tasks. The grid is a visual guide displaying points at user-specified intervals, like customizable grid paper. Snap spacing restricts cursor movement to specific intervals. When you turn on Snap mode, the cursor “snaps” to spaced coordinates as if they were cursor magnets. You can rotate snap and grid alignment or set snap and grid to isometric mode to simulate 3D views in 2D space. The grid and snap share the same base point and rotation. Their spacing is often the same, but it can be set to different values. (See “Setting Snap Spacing” on page 72.)

Changing the Snap Angle and Base Point

To draw objects along specific alignments or angles, you can rotate the snap angle, which rotates the crosshairs and the grid. Then, if Ortho mode is on, AutoCAD constrains cursor movement to the new snap angle and its perpendicular angle.

Changing the snap angle changes the grid angle. You can see the new snap alignment.

The following example shows a snap angle adjusted to match the angle of the anchor bracket. With this adjustment, the grid becomes a more effective visual aid for drawing objects at a 30-degree angle.

To rotate the snap angle

1. From the Tools menu, choose Drafting Settings.
2. On the Snap and Grid tab in the Drafting Settings dialog box, enter a snap angle.
   For example, to rotate the snap angle 30 degrees, enter 30.
Adjusting Snap and Grid Alignment

Command line  DSETTINGS

Shortcut menu  Right-click Snap on the status bar and choose Settings.

The origin of the rotated snap angle is the base point. You can offset the base point by changing the X or Y base (set to 0.0000 by default). Offsetting the X or Y base point is useful when you want to align the grid with complex patterns.

To change the snap angle base point

1. From the Tools menu, choose Drafting Settings.
2. On the Snap and Grid tab in the Drafting Settings dialog box enter new X and Y coordinates in X base and Y base.
3. Choose OK.

Command line  DSETTINGS displays the Drafting Settings dialog box. SNAP and GRID adjust the base point.

Shortcut menu  Right-click Snap or Grid on the status bar and choose Settings.

System variables  SNAPSHOT and SNAPBASE set the snap angle and snap base. If you set the system variables directly, you can use your pointing device to specify the snap angle and base point.
Using Snap Mode with Polar Tracking

If you use polar tracking (see “Using AutoTrack” on page 178), you can change Snap mode so that while you specify points in a command, Snap mode snaps along the polar tracking angle instead of snapping to a grid.

To set Snap mode for polar tracking

1. From the Tools menu, choose Drafting Settings.
2. On the Snap and Grid tab in the Drafting Settings dialog box, under Snap Style & Type, select Polar Snap.
3. Choose OK.

Setting Snap and Grid to Isometric Mode

Isometric Snap/Grid mode helps you create 2D drawings that represent 3D objects, such as cubes. Isometric drawings are not true 3D drawings. They simulate a 3D object from a particular viewpoint by aligning along three major axes. If the snap angle is 0, the axes of the isometric planes are 30 degrees, 90 degrees, and 150 degrees. When you set Snap mode to isometric, use the F5 key (or CTRL+E) to change the isometric planes to left, right, or top orientations:

- **Left**: Orients the snap and grid alignment along 90- and 150-degree axes.
- **Right**: Orients the snap and grid alignment along 90- and 30-degree axes.
- **Top**: Orients the snap and grid alignment along 30- and 150-degree axes.

Choosing an isometric plane realigns the snap intervals, grid, and crosshairs along the corresponding isometric axes. AutoCAD restricts certain point selections to two of three axes under certain conditions. For example, if you turn on Ortho mode, the points you select align along the axis of the plane on which you are drawing. Therefore, you can draw the top plane of a model, switch to the left plane to draw another side, and switch to the right plane to complete the drawing.
Planes of a model

To turn on an isometric plane

1. From the Tools menu, choose Drafting Settings.
2. On the Snap and Grid tab in the Drafting Settings dialog box under Snap Style & Type, select Isometric Snap.
3. Choose OK.

Command line: DSETTINGS, SNAP
Shortcut menu: Right-click Snap on the status bar and choose Settings.
Related: ISOPLANE sets the isometric plane.

Snapping to Points on Objects

During drawing commands, you can snap the cursor to points on objects such as endpoints, midpoints, centers, and intersections. For example, you can turn on object snaps and quickly draw a line to the center of a circle, the midpoint of a polyline segment, or the apparent intersection of two lines.

You turn on object snaps in one of two ways:
- **Single point (or override) object snaps**: Sets an object snap for one use.
- **Running object snaps**: Sets object snaps until you turn them off.

To snap to a point on an object

1. Start a command requiring you to specify a point (for example, ARC, CIRCLE, COPY, LINE or MOVE).
2. When the command prompts you to specify a point, choose an object snap using one of the following methods:
   - Click a toolbar button on the Standard toolbar Object Snap flyout or on the Object Snap toolbar.
   - Press SHIFT and right-click in the drawing area, and choose an object snap from the shortcut menu.
   - Enter an object snap abbreviation on the command line.
3. Move your cursor over the snap location and click.
After you click to the snap point, the object snap clears. If you select any point other than the object snap point, AutoCAD displays an invalid point message. The following table shows the AutoCAD object snaps, the toolbar buttons, and command line abbreviations you can use to start them. See “Object Snap Descriptions” on page 171.

<table>
<thead>
<tr>
<th>Object snap</th>
<th>Toolbar</th>
<th>Command line</th>
<th>Snaps to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Endpoint</td>
<td>END</td>
<td></td>
<td>Object endpoints</td>
</tr>
<tr>
<td>Midpoint</td>
<td>MID</td>
<td></td>
<td>Object midpoints</td>
</tr>
<tr>
<td>Intersection</td>
<td>INT</td>
<td></td>
<td>Object intersections</td>
</tr>
<tr>
<td>Apparent Intersection</td>
<td>APP</td>
<td></td>
<td>Apparent intersection of objects</td>
</tr>
<tr>
<td>Extension</td>
<td>EXT</td>
<td></td>
<td>Object extension paths</td>
</tr>
<tr>
<td>Center</td>
<td>CEN</td>
<td></td>
<td>Center points of circles, arcs, or ellipses</td>
</tr>
<tr>
<td>Node</td>
<td>NOD</td>
<td></td>
<td>Point objects drawn with the POINT command</td>
</tr>
<tr>
<td>Quadrant</td>
<td>QUA</td>
<td></td>
<td>Closest quadrant of arcs, circles, or ellipses</td>
</tr>
<tr>
<td>Insertion</td>
<td>INS</td>
<td></td>
<td>Insertion point of a block, shape, text, attribute, or attribute definition</td>
</tr>
<tr>
<td>Perpendicular</td>
<td>PER</td>
<td></td>
<td>Object points forming a perpendicular (normal) alignment</td>
</tr>
<tr>
<td>Parallel</td>
<td>PAR</td>
<td></td>
<td>Point on an alignment path that is parallel to the selected object</td>
</tr>
<tr>
<td>Tangent</td>
<td>TAN</td>
<td></td>
<td>Point on a circle or arc that, when connected to the last point, forms a line tangent to the object</td>
</tr>
</tbody>
</table>
Setting Running Object Snaps

In addition to single-point object snaps, you can turn on running object snaps. Running object snaps stay on until you turn them off. You can also turn on more than one running object snap at a time.

To set running object snaps

1. From the Tools menu, choose Drafting Settings.

2. On the Object Snap tab in the Drafting Settings dialog box, select Object Snap On.

3. Select the running object snaps you want, and then choose OK.

Command line  DSETTINGS, OSNAP

Shortcut menu  Right-click Osnap on the status bar and choose Settings.
Changing Object Snap Settings

Object snaps include a visual aid, called AutoSnap™, to help you see and use object snaps more efficiently. AutoSnap includes the following elements:

- **Markers:** Indicate the object snap type by displaying a symbol at the object snap location.
- **Tooltips:** Identify the object snap type at the object snap location below the cursor.
- **Magnet:** Moves the cursor automatically to lock it onto a snap point when the cursor nears the point.
- **Aperture box:** Surrounds the crosshairs and defines an area within which, as you move the cursor, AutoCAD evaluates objects for object snaps. You can choose to display or not display the aperture box, and you can change the aperture box size.

After you set running object snaps, click Osnap on the status bar to turn all of them on and off without displaying the Drafting Settings dialog box (or press CTRL + F or F3). If no running object snaps are set, the Drafting Settings dialog box is displayed when you click Osnap.

The AutoSnap markers, tooltips, and magnet are turned on by default. You can change AutoSnap settings in the Options dialog box.

**To change AutoSnap settings**

1. From the Tools menu, choose Options.
2. In the Options dialog box, choose the Drafting tab.
3. On the Drafting tab, select and clear AutoSnap settings. You can change the AutoSnap marker size and color, and adjust the aperture box size.
4. Choose OK.

**Command line**

```
OPTIONS
```

When multiple running object snaps are on, you can press TAB to cycle through available snap points when the object snap aperture box is on an object. For example, if the Quadrant and Center snaps are on, and the aperture box is on a circle, pressing TAB cycles through the circle’s object snap points: four quadrants and the center.
Object Snap Descriptions

The object snap buttons are located on the Object Snap flyout on the Standard toolbar. Object snaps generally are applicable to objects visible on the screen, including objects on locked layers, floating viewport boundaries, solids, and polyline segments. You cannot snap to objects on turned-off or frozen layers.

Endpoint

Endpoint snaps to the closest endpoint of objects such as lines or arcs.

If an object has thickness, you can snap to its edges. Endpoint also snaps to the edges of 3D solids, bodies, and regions. For example, you can snap to the endpoint (vertex) of a box.

Midpoint

Midpoint snaps to the midpoint of objects such as lines or arcs.

On construction lines (see “Creating Construction Lines” on page 190), Midpoint snaps to the first point defined (the root). When you select a spline or an elliptical arc, Midpoint snaps to a point on the object that is halfway between the start point and the endpoint.

If a line or arc has thickness, you can snap to the midpoints of the edges. Midpoint also snaps to the edges of 3D solids, bodies, and regions.
**Intersection**

Intersection snaps to the intersection of objects, such as arcs, circles, ellipses, elliptical arcs, lines, multilines, polylines, rays, splines, or construction lines (xlines). Intersection snaps to the edges of regions and curves, but does not snap to the edges or corners of 3D solids.

You can also use Intersection to snap to

- The corners of objects that have thickness. If two thickened objects extend in the same direction and have intersecting bases, Intersection snaps to the intersection of the edges. If objects have different thicknesses, Intersection uses the lesser thickness as the intersection point.
- Line intersections within blocks. If a block is uniformly scaled, you can snap to intersections of arcs and circles contained in the block.
- The intersection of two objects if each were extended. (This intersection is only shown when you enter Intersection as a single point (override) object snap.)

**Apparent Intersection**

In 3D models, two objects may appear to intersect in one view, but when seen in another view, they clearly do not intersect. You can use Apparent Intersection to snap to points where objects appear to intersect. If you enter Apparent Intersection as a single point (override) object snap, you can snap to the apparent extended intersections, that is, the points where objects would appear to intersect if they were extended.

Apparent Intersection snaps to edges of regions and curves, but not to edges or corners of 3D solids.
Center snaps to the center of an arc, circle, or ellipse.

Center also snaps to the center of circles that are part of solids, bodies, or regions. To snap to a center point, move the cursor over the circle, arc, or ellipse, and then click when the Center snap is displayed.
Quadrant

Quadrant snaps to the closest quadrant of an arc, circle, or ellipse (the 0-, 90-, 180-, and 270-degree points).

The current user coordinate system (UCS) orientation sets the snap location of the quadrant points for circles and arcs. (To display Quadrant snaps, the normal of the circle or arc must be in the same direction as the Z axis of the current UCS.) If the arc, circle, or ellipse is a member of a rotated block, the quadrant points rotate with the block.

Node

Node snaps to points drawn with the POINT command or placed by the DIVIDE and MEASURE commands.

Points included in a block can function as convenient snap points.

Insertion

Insertion snaps to the insertion point of a block, shape, text, attribute, or attribute definition.
If you select an attribute within a block, AutoCAD snaps to the insertion point of the attribute, not the block. If a block consists entirely of attributes, you can snap to the block’s insertion point only if it coincides with an attribute insertion point.

**Perpendicular**

Perpendicular snaps to a point perpendicular to an arc, circle, construction line, ellipse, elliptical arc, line, multiline, polyline, ray, solid, or spline. Perpendicular can also snap to perpendicular points on apparent extensions of an object.

When you use Perpendicular to specify a first point, AutoCAD asks you to specify a point on an object. When you use Perpendicular to specify a second point, AutoCAD snaps to the point that creates a perpendicular relationship with the object or the apparent extension of the object.

For spline curves, Perpendicular snaps to points where the perpendicular vector passes through the specified point. The perpendicular vector snaps to tangent points on the spline. If the specified point lies on the spline, Perpendicular snaps to the point. In some cases, Perpendicular object snaps are not obvious or may not exist.

If Perpendicular needs more than one point to create a perpendicular relationship, AutoCAD displays a deferred Perpendicular AutoSnap marker and tooltip and prompts you to enter a second point.

**NOTE** Deferred Perpendicular object snap does not work with ellipses or splines.

Perpendicular snaps to arcs and circles if they are part of a uniformly scaled block and the direction of the object’s thickness is parallel to the current UCS. The perpendicular relationship created for 3D splines is relative to a plane defined by the tangent of the curve at the snap point.
**Parallel**

You can apply the Parallel snap to straight-line segments. To apply a single-point object snap, specify a From point, choose Parallel object snap (or turn on the Parallel running object snap), and then pause over the line you want to use to draw a parallel object. The line must be the only object under the aperture box. A small parallel line symbol is displayed, indicating that the line has been selected. Move the cursor parallel to the object. A parallel alignment path is displayed as a dashed line. The parallel alignment path is based on the object and the command’s From point. You can use Parallel with Intersection or Apparent Intersection object snaps to find where the parallel line intersects another object.

**Tangent**

Tangent snaps to the point on a circle or arc that, when connected to the last point, forms a line tangent to that object. For example, when you use the three-point method to draw a circle, you can use Tangent to construct a circle tangent to three other circles.

If Tangent needs more than one point to create a tangent relationship, AutoCAD displays a deferred Tangent AutoSnap marker and tooltip and prompts you to enter a second point. You can use deferred Tangents to create two- or three-point circles when the circle you want to draw is tangent to two or three other objects.

You can apply Tangent object snaps to arcs and circles in blocks if the block is uniformly scaled and the direction of the object’s thickness is parallel to the current UCS. For splines and ellipses, the other point you specify must be on the same plane as the snap point.

**NOTE** If you use the From option with the Tangent snap to draw objects other than lines from arcs or circles, the first point drawn is tangent to the arc or circle in relation to the last point selected in the drawing area.
Nearest

Nearest snaps to the location on the object that is closest to the specified point.

None

None turns off running object snaps for one point.

Extension

You can use the Extension object snap to extend a line or an arc. You can also use it with Intersection or Apparent Intersection to get extended intersections. To use Extension, pause over the end point of a line or arc. A small plus sign (+) is displayed, signifying that the line or arc has been selected for extension. Move along the extension path to display a temporary extension path. If Intersection or Apparent Intersection is on, you can find the extended intersection of a line or arc with another object.

Creating Temporary Reference Points

You can use the From method with object snaps and relative coordinates to set temporary references for specifying subsequent points. For example, at a polyline prompt, you can enter `fro` and `mid`, at the From and Base Point prompts, select a line, and then enter `@2,3` to locate a point two units to the right and three units up from the midpoint of the line.

Here is the command line sequence:

Command: `pline`
Specify start point: `fro`
Base point: `mid`
of: `Select the line`
of `<Offset>`: `@2,3`

You can specify an absolute coordinate as a base point; however, specifying an absolute coordinate for the offset essentially cancels the From method and locates the point at the specified coordinate.
Using AutoTrack

AutoTrack™ helps you draw objects at specific angles or in specific relationships to other objects. When you turn on AutoTrack, temporary alignment paths help you create objects at precise positions and angles. AutoTrack includes two tracking options: polar tracking and object snap tracking. You can toggle AutoTrack on and off with the Polar and Otrack buttons on the status bar. Object snap tracking works in conjunction with object snaps. You must set an object snap before you can track from an object’s snap point; the AutoSnap aperture settings control how close you must be to the alignment path before the path is displayed. (See “Changing Object Snap Settings” on page 170).

Tracking Along Polar Angles

Use polar tracking to track the cursor along temporary alignment paths defined by polar angles relative to a command’s From or To points. For example, in the following illustration you draw a two-foot line from point 1 to point 2, and then draw a two-foot line to point 3 at a 45-degree angle to the line. If you turn on the 45-degree polar angle increment, AutoCAD displays an alignment path and tooltip when your cursor crosses the 0- or 45-degree angles. The alignment path and tooltip disappear when you move the cursor away from the angle.

You can use polar tracking to track along polar angle increments of 90, 60, 45, 30, 22.5, 18, 15, 10, and 5 degrees, or you can specify other angles. The following illustration shows the alignment paths displayed as you move your cursor 90 degrees with the polar angle increment set to 30 degrees.
To turn on polar tracking

- Press F10, or click Polar on the status bar.

To draw objects using polar tracking

1. Turn on polar tracking and start a drawing command, such as ARC, CIRCLE, or LINE.
   You can also use polar tracking with editing commands, such as COPY and MOVE.
2. Specify a From point.
3. Specify a To point.
   As you move your cursor, alignment paths and tooltips are displayed when you move the cursor near polar angles. The default angle measurement is 90 degrees. Use the alignment path and tooltip to draw your object. You can use polar tracking with Intersection and Apparent Intersection object snaps to find the point where a polar alignment path intersects with another object.

Ortho mode restricts the cursor to horizontal or vertical (orthogonal) axes. Because you cannot have Ortho mode and polar tracking turned on at the same time, AutoCAD turns polar tracking off when you turn on Ortho mode. If you turn polar tracking back on, AutoCAD turns Ortho mode off.

To turn on Ortho mode

- Click Ortho on the status bar.

Changing Polar Tracking Settings

By default, polar tracking is set to a 90-degree (orthogonal) increment angle. You can change the polar increment angle and set the increments at which the cursor snaps along polar alignment paths when polar tracking and Snap mode are both on.

You can also change how AutoCAD measures polar angles. Absolute polar angle measurement bases polar angles on the X and Y axes of the current UCS. Relative polar angle measurement bases polar angles on the X and Y axes of the last line created (or the line between the last two created points) during an active command. If you start a line at the end, mid, or near object snap of a line, the polar angle is relative to that line.
To change polar settings

1. From the Tools menu, choose Drafting Settings.

2. On the Polar Tracking tab in the Drafting Settings dialog box, select Polar Tracking On to turn on polar tracking.

3. Under Increment Angle, select an increment angle.

4. If you created additional angles (see “Adding and Deleting Polar Angles” on page 181), select Additional Angles to display them during polar tracking.

5. Under Polar Angle Measurement, select a measurement method:
   - **Absolute**: Bases polar tracking angles on the X and Y axes of the current UCS.
   - **Relative**: Bases polar tracking angles on the X and Y axes of the line formed by the last two object points created. If you start a line on the end-, mid-, or near point of a line, the angle is based on the X and Y axes of that line.

6. Choose OK.

**Command line**  DSETTINGS

**Shortcut menu**  Right-click Polar on the status bar and choose Settings.

**System variables**  POLARADDANG, POLARANG
Adding and Deleting Polar Angles

AutoCAD provides nine incremental polar angles that you can use with AutoTrack. You can add non-incremental angles. For example, if you want to track at 66 degrees, you can add 66 as an additional polar angle.

To add or delete polar angles

1. From the Tools menu, choose Drafting Settings.
2. On the Polar Tracking tab in the Drafting Settings dialog box under Additional Angles, do one of the following:
   ■ To add an angle, choose New, and then enter a new angle.
   ■ To delete an angle, select an angle, and then choose Delete.

   **Command line**  DSETTINGS
   **Shortcut menu** Right-click Polar on the status bar and choose Settings.
   **System variables** POLARADDANG stores added polar angles.

Using Polar Angle Overrides

You can enter a polar tracking angle that is valid for specifying one point. To enter a polar override angle, enter an angle preceded by a left angle bracket (<) whenever a command asks you to specify a point. The command prompt sequence below shows a 33-degree override entered during a LINE command.

Command:  line
Specify first point:  Specify a start point for the line
Specify next point or [Undo]: <33
Angle Override:  33
Specify next point or [Undo]:  Specify a point

Tracking to Points on Objects

Use object snap tracking to track along alignment paths that are based on object snap points. For example, you can select a point along a path based on an object endpoint or midpoint or an intersection between objects.

To turn on object snap tracking

1. Turn on an object snap (single point or running object snap).
2. Press F11, or click Otrack on the status bar.
To use object snap tracking

1. Start a drawing command.
   You can also use object snap tracking with editing commands, such as COPY or MOVE.

2. Move the cursor over an object snap point to temporarily acquire it. Do not click the point; pause over the point briefly to acquire it.
   Acquired points display a small plus sign (+), and you can acquire more than one. After you acquire a point, horizontal, vertical, or polar alignment paths relative to the point are displayed as you move the cursor over their drawing paths.

In the following illustration, the Endpoint object snap is on. You start a line by clicking its start point (1), move the cursor over another line’s endpoint (2) to acquire it, and then move the cursor along the horizontal alignment path to locate the endpoint you want for the line you are drawing (3).

To make object points available for object snap tracking

- Set one or more object snaps (see “Snapping to Points on Objects” on page 167). You can use the Endpoint, Midpoint, Center, Node, Quadrant, Intersection, Insertion, Parallel, Extension, Perpendicular, and Tangent object snaps. If you use Perpendicular or Tangent, AutoCAD tracks to alignment paths perpendicular to, or tangent to, the selected object.

To acquire a point

- When a command prompts you to specify a point, move the cursor over the object point and pause briefly (do not click the point). A small plus sign (+) is displayed after AutoCAD acquires the point. The temporary alignment path is displayed as you move the cursor away from the acquired point.

To clear an acquired point

- Move the cursor back over the point’s acquisition marker. Acquired points also clear automatically with each new command prompt. Toggling Otrack on the status bar clears acquired points also.
Changing Object Snap Tracking Settings

By default, object snap tracking is set to orthogonal. Alignment paths are displayed at 0, 90, 180, and 270 degrees from acquired object points. However, you can use polar tracking angles instead.

To change object snap tracking settings

1 From the Tools menu, choose Drafting Settings.
2 On the Polar Tracking tab in the Drafting Settings dialog box, under Object Snap Tracking Settings, select one of the following options:
   - **Track Orthogonally Only**: Displays only orthogonal (horizontal/vertical) tracking paths from an acquired object point.
   - **Track Using All Polar Angle Settings**: Applies polar tracking settings to object snap tracking. For example, if you select the 30-degree polar angle increment, object tracking alignment paths display in increments of 30 degrees.
3 Choose OK.

**Command line**  
DSETTINGS

**Shortcut menu**  
Right-click Polar on the status bar and choose Settings.

Changing AutoTrack Settings

You can change how AutoTrack displays alignment paths, and you can change how AutoCAD acquires object points for object snap tracking. By default, alignment paths stretch to the end of the drawing window. You can change their display to abbreviated lengths, or no length. For object snap tracking, AutoCAD automatically acquires object points. However, you can choose to acquire points only when you press SHIFT.

To change AutoTrack settings

1 From the Tools menu, select Options.
2 In the Options dialog box, choose the Drafting tab.
3 Under AutoTrack Settings, select or clear the following alignment path display options:

- **Display Polar Tracking Vector:** Controls alignment path display for object snap tracking. When cleared, no polar tracking path is displayed.
- **Display Full Screen Tracking Vector:** Controls alignment path display for object snap tracking. When cleared, an alignment path is displayed only from the object snap point to the cursor.
- **Display AutoTrack Tooltip:** Controls the display of AutoTrack tooltips. Tooltips tell you the type of object snap (for object snap tracking), alignment angle, and distance from the previous point.

4 Under Alignment Point Acquisition, select a method for acquiring object points for object snap tracking:

- **Automatic:** Acquires object points automatically. If you select this option, you can press SHIFT to not acquire an object point.
- **Shift to Acquire:** Acquires object points only when you press SHIFT while the cursor is over an object snap point.

**System variables**

- TRACKPATH stores alignment path display settings.
- POLARMODE stores the alignment point acquisition method.

**AutoTrack Tips**

As you use AutoTrack, you will discover techniques that make specific design tasks easier. Here are a few you might try.

- Use Perpendicular, End, and Mid object snaps with object snap tracking to draw to points that are perpendicular to the end and midpoints of objects.
- Use the Tangent and End object snaps with object snap tracking to draw to points that are tangent to the endpoints of arcs.
- Use object snap tracking with temporary tracking points. At a point prompt, enter **tt**, then specify a temporary tracking point. A small + appears at the point. As you move your cursor, AutoTrack alignment paths are displayed relative to the temporary point. To remove the point, move the cursor back over the +.
- After you acquire an object snap point, use direct distance to specify points at precise distances along alignment paths from the acquired object snap point. To specify a point prompt, select an object snap, move the cursor to display an alignment path, then enter a distance at the Command prompt.
- Use the Automatic and Shift to Acquire options set on the Drafting tab of the Options dialog box to manage point acquisition. Point acquisition is set to Automatic by default. When working in close quarters, press SHIFT to temporarily not acquire a point.
**Using Point Filters**

You can use point filters to specify one coordinate value at a time while temporarily ignoring other coordinate values. When used with object snaps, point filters can extract coordinate values from an existing object so you can locate another point.

Specifying a point filter limits the next entry to a specific ordinate value, such as the X or the Y value, or an X,Y coordinate value. You also can specify Z values (typically for 3D models). After you specify the first value, AutoCAD prompts you for the remaining values.

**To use point filters to specify points**

1. From the Draw menu, choose Point ➤ Single Point.
2. Specify a point or choose an object snap and select an object.
3. At the prompt for the next coordinate value(s), specify a point or choose an object snap and select an object.
   - If you specified an X value, the coordinate of the new point matches the X value of the first point and the Y,Z value of the second point.

**Command line** POINT specifies a point. At the prompt, enter .x or .y to indicate the value you want to specify.

**Shortcut menu** Hold down SHIFT and right-click in the drawing area, and then select a filter from the Point Filters cascading menu.

In the following illustration, the hole in the holding plate was centered in the rectangle by extracting the X,Y coordinates from the midpoints of the plate’s horizontal and vertical line segments.

Here is the command line sequence:

**Command:** circle
**Specify center point for circle or [3P/2P/Ttr (tangent tangent radius)]:** .x of: mid of: Select the horizontal line on the lower edge of the holding plate of: (need YZ): mid of: Select the vertical line on the left side of the holding plate of: Diameter/<Radius> Specify the radius of the hole
Specifying Measurements and Divisions

Sometimes you need to create points or insert blocks at specific intervals on an object. For example, you may need to snap to points at half-unit intervals or insert markers on an object to identify five equal segments. You can use one of the following commands:

- To specify the length of each segment, use MEASURE.
- To specify the number of equal segments, use DIVIDE.

You can measure or divide lines, arcs, splines, circles, ellipses, and polylines. With both methods, you can identify the intervals by inserting either a point or a named set of objects known as a block.

By specifying points, you can use the Node object snap to align other objects at even intervals on the measured or divided object. By specifying blocks, you can create precise geometric constructions or insert custom markers. You can align blocks with a selected object at each insertion point.

To be inserted, blocks must already be defined within the drawing. Any variable attributes within the block are excluded from the insertion. For more information about blocks, see “Working with Blocks” on page 444.

The start point for measurements or divisions varies with the object type. For lines or polylines, segments start at the endpoint closest to the selection point. Segments in closed polylines begin at the polyline’s start point. Segments in circles start at the angle from the center point that is equivalent to the current snap angle. For example, if the snap angle is 0, the circle segments start at the three o’clock position and continues in a counterclockwise direction.

Points or blocks drawn using MEASURE or DIVIDE are placed in the Previous selection set. Therefore, if you want to edit them immediately, you can select them by using the Previous option.
Specifying Measured Intervals on Objects

Use MEASURE to mark measured intervals on an object. You can mark the intervals with either points or blocks.

To insert points at measured intervals on an object
1 From the Draw menu, choose Point ➤ Measure.
2 Select a line, arc, spline, circle, ellipse, or polyline.
3 Enter an interval length or specify points on the screen to indicate a length. AutoCAD places points on the object at the specified intervals.

Command line MEASURE

Related DDPTYPE controls the size and style of print markers.

To insert blocks at measured intervals on an object
1 If necessary, create the block you want to insert (see “Defining Blocks” on page 447).
2 From the Draw menu, choose Point ➤ Measure.
3 Select the object you want to measure.
4 Enter b (Block).
5 Enter the name of the block you want to insert.
To specify the block orientation, do one of the following:

- Enter `y` to rotate the block at its insertion point so that the horizontal alignment of each inserted block is tangent to the divided object.
- Enter `n` to use a rotation angle of 0 degrees.

Enter an interval length or specify points on the screen to indicate a length. AutoCAD inserts blocks on the object at the specified intervals.

**Command line**  
**MEASURE**

**Dividing Objects into Segments**

Use the `DIVIDE` command to create a number of points or blocks equally spaced on an object. This command does not actually break the object into individual objects; it only identifies the location of the divisions so that you can use them as geometric reference points.

To insert points at a specified number of intervals on an object

1. From the Draw menu, choose Point ➤ Divide.
2. Select a line, arc, spline, circle, ellipse, or polyline.
3. Enter the number of intervals you want to represent.
   AutoCAD places a point at each interval on the object.

**Command line**  
**DIVIDE**

**Related**  
**DDPTYPE** controls the size and style of print markers.
To insert blocks at a specified number of intervals on an object

1. If necessary, create the block you want to insert (see “Defining Blocks” on page 447).
2. From the Draw menu, choose Point ➤ Divide.
3. Select a line, arc, spline, circle, ellipse, or polyline.
4. Enter b (Block).
5. Enter the name of the block you want to insert.
6. To specify the block orientation, enter one of the following options:
   - Enter y to rotate the block at its insertion point so that the horizontal alignment of each inserted block is tangent to the divided object.
   - Enter n to use a rotation angle of 0 degrees.
7. Enter the number of intervals you want to represent.
   AutoCAD inserts a block at each interval on the object.

Command line  DIVIDE

Drawing Construction Lines

You can create construction lines that extend to infinity in one or both directions. The term construction line usually refers to xlines, which extend to infinity in both directions. Construction lines that extend to infinity in only one direction are called rays.

You can use construction lines as references for creating other objects. For example, you can use construction lines to find the center of a triangle, prepare multiple views of the same item, or create temporary intersections that you can use for object snaps.

Construction lines do not change the extents of the drawing; therefore, their infinite dimensions have no effect on zooming or viewpoints. You can move, rotate, and copy construction lines just as you move, rotate, and copy other objects. You may want to create construction lines on a construction line layer that can later be frozen or turned off, so that the construction lines are not plotted (see “Freezing and Thawing Layers” on page 320).
Creating Construction Lines

You can place construction lines (xlines) anywhere in 2D and 3D space, and they extend to infinity in both directions. To orient construction lines, you generally specify two points, though you can use other orientation methods.

Commands that display the drawing extents ignore construction lines. You can create construction lines in several other ways.

To create a construction line by specifying two points

1. From the Draw menu, choose Construction Line.
2. Specify a point to define the root of the construction line (1).
3. Specify a second point through which the construction line should pass (2).
4. Continue to specify construction lines as needed.
5. Press ENTER to end the command.

Command line  XLINE
**Horizontal and Vertical**

The horizontal and vertical methods create construction lines that pass through a point you specify (1) and are parallel to the X or Y axis of the current UCS.

**Angle**

The angle method creates a construction line in one of two ways. You can select a reference line and then define the angle of the construction line from that line. To create a construction line at a specific angle to the horizontal axis, you specify an angle and then specify a point through which the construction line should pass (1). The construction line always is parallel to the current UCS.
Bisector
The bisector method creates a construction line that bisects an angle you specify. You specify the vertex (1) and the lines that create the angle (2 and 3).

Offset
The offset method creates a construction line parallel to a baseline you specify. You specify the offset distance, select the baseline (1), and then indicate on which side of the baseline the construction line is located (2).

Creating Rays
A ray is a line in 3D space that starts at a point you specify and extends to infinity in only one direction. As a result, rays help reduce the visual clutter caused by numerous xlines. Rays are ignored by commands that display the drawing extents.

To create a ray
1. From the Draw menu, choose Ray.
2. Specify a start point for the ray (1).
3 Specify a point through which the ray should pass (2). Continue to specify points to create additional rays as needed (3 and 4).

4 All subsequent rays pass through the first point specified.

5 Press ENTER to end the command.

**Command line**  RAY

### Calculating Points and Values

By entering a formula on the command line, you can quickly solve a mathematical problem or locate points on your drawing. The **CAL** command runs the AutoCAD 3D calculator utility to evaluate vector expressions (combining points, vectors, and numbers) and real and integer expressions. The calculator performs standard mathematical functions. It also contains a set of specialized functions for calculations involving points, vectors, and AutoCAD geometry. With the **CAL** command, you can

- Calculate a vector from two points, the length of a vector, a normal vector (perpendicular to the XY plane), or a point on a line.
- Calculate a distance, radius, or angle.
- Specify a point with the pointing device.
- Specify the last-specified point or intersection.
- Use object snaps as variables in an expression.
- Convert points between a UCS and the WCS.
- Filter the X, Y, and Z components of a vector.
- Rotate a point around an axis.

The following sections describe two ways to use **CAL**. For more information, see **CAL** in the *Command Reference*. 
Evaluating Expressions

CAL evaluates expressions according to standard mathematical rules of precedence.

### Mathematical operators in order of precedence

<table>
<thead>
<tr>
<th>Operator</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>( )</td>
<td>Groups expressions</td>
</tr>
<tr>
<td>^</td>
<td>Indicates numeric exponent</td>
</tr>
<tr>
<td>*, /</td>
<td>Multiplies and divides numbers</td>
</tr>
<tr>
<td>+, –</td>
<td>Adds and subtracts numbers</td>
</tr>
</tbody>
</table>

To evaluate an expression
1. At the Command prompt, enter `cal`.
2. Enter an expression, following the rules of precedence described in the table. For example, enter `(53*12)/2` to multiply 53 by 12 and then divide the result by 2. You can add spaces as needed without ending the command.
3. Press ENTER. AutoCAD displays the result of the calculation.

Calculating Points

You can use CAL whenever you need to calculate a point or a number within an AutoCAD command.

To calculate a point
1. From the Tools menu, choose Inquiry ➤ ID Point.
2. When prompted for a point, enter `cal` to run the command transparently.
3. Using a combination of mathematical operators and object snaps, enter an expression to specify an object snap point. For example, you enter `(mid+cen)/2` to specify a point halfway between the midpoint of a line and the center of a circle.

The following example uses CAL as a construction tool. It locates a center point for a new circle, and then calculates one fifth of the radius of an existing circle.
Calculating Distance and Angle

You can quickly display the following information for two points you specify:

- The distance between them in drawing units
- The angle between the points in the XY plane
- The angle of the points from the XY plane
- The delta X, Y, and Z distance between the designated points

You can use this information to determine the relationship between the two points that you have specified.

To calculate a distance

1. From the Tools menu, choose Inquiry ➤ Distance.
2. Specify the first and second points of the distance you want to calculate. AutoCAD displays a brief report.

**Command line**  DIST

If you enter a single number or fraction at the First Point prompt, AutoCAD displays that number in the current unit of measurement. For example, if units are set to Decimal (four places) and you enter 1/2, AutoCAD displays 0.5000.
Calculating Areas

You can display the area and perimeter of several types of objects or of a sequence of points. If you need to calculate the combined area of more than one object, you can keep a running total as you add or subtract areas from the selection set.

Calculating a Defined Area

You can measure an arbitrary closed region defined by the 2D or 3D points you specify. The points must lie on a plane parallel to the XY plane of the current UCS.

To calculate an area you define

1. From the Tools menu, choose Inquiry ➤ Area.
2. Select points in a sequence that defines the perimeter of the area to be measured. Then press ENTER.
   AutoCAD connects the first and last points to form a closed area and displays the area and perimeter measurements.

   Command line  AREA

Calculating the Area Enclosed by an Object

You can calculate the enclosed area and perimeter, or circumference, of circles, ellipses, polylines, polygons, splines, regions, and solids. The information displayed depends on the object you select.
### Calculating areas

<table>
<thead>
<tr>
<th>Object</th>
<th>Information displayed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circles, ellipses, planar closed spline curves</td>
<td>Area and circumference or length.</td>
</tr>
<tr>
<td>Closed polylines and polygons</td>
<td>Area and perimeter. For wide polylines, the area is defined by the center of the width.</td>
</tr>
<tr>
<td>Open objects, such as open spline curves and open polylines</td>
<td>Area and perimeter. The area is computed as though a straight line connected the start point and endpoint.</td>
</tr>
<tr>
<td>Regions</td>
<td>Combined area for objects in the region.</td>
</tr>
<tr>
<td>Solids</td>
<td>Surface area of the 3D model.</td>
</tr>
</tbody>
</table>

How areas are calculated for various types of objects

![Diagram of area calculations for different types of objects](image)
To calculate the area of an object

1. From the Tools menu, choose Inquiry ➤ Area.
2. Enter o (Object).
3. Select an object.
   AutoCAD displays the area and perimeter.

Command line  AREA

Related  PROPERTIES displays an object’s area and other information in the Properties window. MASSPROP displays additional information about solids and regions.

Adding and Subtracting Areas

You can measure more than one area either by specifying points or by selecting objects. For example, you can measure the total area of rooms in a floor plan.

To add areas as you calculate

1. From the Tools menu, choose Inquiry ➤ Area.
2. To add an area to the calculation, enter a (Add).
3. Specify a point or enter o (Object).
4. Depending on which method you choose, either specify points and press ENTER or select the objects you want to measure.
   AutoCAD displays the measurements of each new area and a running total of all areas.
5. Press ENTER twice to complete the command.

Command line  AREA

You can also subtract one or more areas from a combined area that you have already calculated. In the following example, the area of the floor plan is first measured, and then a room is subtracted.
To subtract areas from a calculation

1. While the combined area is still displayed, enter s (Subtract).
2. Specify a point (1) or enter o (Object).
3. Specify points (2, 3, and 4) or select objects to define the areas to be subtracted.
   AutoCAD updates the running total as you define new areas.
4. Press ENTER to complete the command.

**Command line**  AREA

In the following example, the closed polyline represents a metal plate with two large holes. You can calculate the area by measuring the polygon and then subtracting the holes.
Here is the command line sequence:

Command:  `area`
Specify first corner point or [Object/Add/Subtract]:  `a`
Specify first corner point or [Object/Subtract]:  `o`
(ADD mode) Select objects:  *Select the polyline (1)*
Area = 0.34,  Perimeter = 2.71
Total area = 0.34
(ADD mode) Select objects:  *Press ENTER*
Specify first corner point or [Object/Subtract]:  `s`
Specify first corner point or [Object/Add]:  `o`
(SUBTRACT mode) Select objects:  *Select the lower circle (2)*
Area = 0.02,  Circumference = 0.46
Total area = 0.32
(SUBTRACT mode) Select objects:  *Select the upper circle (3)*
Area = 0.02,  Circumference = 0.46
Total area = 0.30
(SUBTRACT mode) Select circle or polyline:  *Press ENTER*
Specify first corner point or [Object/Add]:  *Press ENTER*

You can also use REGION to convert the plate to a region, subtract the holes, and then use the AREA Add and Subtract options to measure the plate.

## Displaying Coordinates and Locating Points

You can display the coordinate of a designated point in a drawing or visually locate a point by specifying its coordinate.

**To display a coordinate**

1. From the Tools menu, choose Inquiry ➤ ID Point.
2. Select the point you want to identify.

For 3D objects, use an object snap to display the Z coordinate value. Otherwise, the Z value reflects the current elevation.
To visually locate a point

1. From the Tools menu, choose Inquiry ➤ ID Point.
2. Enter the coordinate of the point you want to locate.

If the BLIPMODE system variable is on, a blip (a small cross) is displayed at the point location.

**Command line**  ID

**System variables**  LASTPOINT stores the last point specified.

### Inquiry Methods

You can display a variety of information regarding your drawing and the objects it contains, including:

- Database information for selected objects
- Drawing status
- Time spent working on the drawing

The information is displayed in the command history area of the command window. Press F2 to switch between a large and small text window as needed.

### Listing Database Information for Objects

You can display database information for any objects in your drawing. The information varies according to the object. All listings display the following information:

- Object type
- XYZ position relative to the current UCS
- Layer
- Whether model space or paper space is current
The following information may also appear:

- Thickness, if greater than zero
- UCS coordinates if an object’s extrusion direction differs from the Z axis (0,0,1) of the current UCS
- How color, linetype, linetype scale, and lineweight are specified (if they are not specified by layer)

The following example shows the information typically listed for a circle.

```
Command: list
Select objects: 1 found
Select objects: CIRCLE Layer: 0
                      Space: Model space
                      Handle: HE
                      center point: X= 6.2174 Y= 4.9861 Z= 0.0000
                      radius: 1.7327
                      circumference: 10.6159
                      area: 9.1472
```

To list an object’s database information

1. From the Tools menu, choose Inquiry ➤ List.
2. Select the objects for which you’re seeking information.

   The text window displays a report.

   **Command line**  LIST

   **Related**  DBLIST lists information on every object in the drawing.

### Displaying the Drawing Status

You can display general information about the current drawing, including

- Current drawing extents
- Settings of various drawing modes and parameters
- Free physical memory and disk space
To display a drawing's status information

- From the Tools menu, choose Inquiry ➤ Status.
  AutoCAD displays the report.

Command line  STATUS

Tracking Drawing Time

You can track the time you’ve spent on a drawing by displaying the time of creation and revision, total editing time, and elapsed time for the current drawing session. The screen also displays the current time and the time of the next automatic saving of the drawing file.

The timer feature is on by default. You can turn it off or reset it.

To display drawing time and set time variables

1. From the Tools menu, choose Inquiry ➤ Time.
   AutoCAD displays the report.

2. Enter d to redisplay the time status, on or off to turn the timer on and off, or r to reset it to zero.

Command line  TIME
Displaying Drawing Properties

You can display the properties you assigned to a drawing, including the following types of information:

- **Summary**: Displays predefined properties such as author, title, and subject.
- **Custom**: Displays custom file properties, including any value you assigned.
- **Statistics**: Displays data such as file size and the dates that files are created and last modified. AutoCAD maintains these file properties automatically.

You can enter information, such as keywords and name of author, and custom data in the Properties dialog box. See “Viewing and Updating Drawing Properties” on page 86.

**To display drawing properties for the active drawing**

1. From the File menu, choose Drawing Properties.
2. In the Drawing Properties dialog box, choose tabs to view the different types of information.

**Command line**  DWGPRTOS

**System variables**  TDCREATE, TDINDWG, TDUCREATE, TDUPDATE, and TDUUPDATE store values for time created, last modified, and total editing time.