AutoCAD® offers two approaches to editing: you can start a command first and then select the objects to edit, or you can select the objects first and then edit them. This chapter describes how to select objects, view and edit object properties, and perform both general and object-specific editing operations.
Selecting Objects

Before you can edit objects, you need to create a selection set of the objects. A selection set can consist of a single object, or it can be a more complex grouping: for example, the set of objects of a certain color on a certain layer. You can create the selection set either before or after you choose an editing command. If the HIGHLIGHT system variable is on, AutoCAD highlights selected objects. You can make several changes to the same selection set. Use one of the following methods to create selection sets.

■ Choose an editing command. Then select the objects and press ENTER.
■ Enter select. Then select the objects and press ENTER. (See SELECT in the Command Reference.)
■ Select the objects with the pointing device. Then choose an editing command. (In order to use this method, Noun/Verb Selection must be turned on. See “Customizing Object Selection” on page 237.)
■ Define groups.

Whichever method you use, AutoCAD prompts you to select objects and replaces the crosshairs with a pickbox. You select individual objects with the pointing device or by using the methods described in this section.

You can respond to the Select Objects prompt in various ways. You can select the most recently created object, the previous selection set, or all objects in the drawing. You can add objects to and remove objects from a selection set. You can also use more than one selection method to make a selection. For example, to select most of the objects in the drawing area, select all objects and then remove the objects you don’t want selected.

Using Selection Windows

You can select objects by enclosing them in a selection window. A selection window is a rectangular area that you define in the drawing area by specifying two corner points at the Select Objects prompt. The order in which you specify the points makes a difference. Dragging from left to right (window selection) selects only objects entirely within the selection area. Dragging from right to left (crossing selection) selects objects within and objects crossing the selection area. Objects must be at least partially visible to be selected.

In general, you must include the entire object within the selection window to select it. However, you can include objects with noncontinuous linetypes by including any complete, visible portion of the linetype within the selection window. For example, if a line has a dashed linetype, you can select the
entire line by including one or more complete dashes within the selection window.

If the PICKDRAG system variable is on, you can hold down the pick button while you create the rectangular selection area. If PICKDRAG is off, specify the area’s corners individually. PICKDRAG is off by default.

To select objects within an irregularly shaped area, enclose them in a polygon selection window. A window polygon selects only objects it encloses entirely, and a crossing polygon selects objects it encloses or crosses. Create the window by specifying points to enclose the area. The order in which you specify points defines a window or a crossing polygon.

In the following example, you use a window polygon to select all the bricks entirely within an irregularly shaped area.
To select objects within an irregularly shaped area

1. At the Select Objects prompt, enter `cp` (Crossing Polygon).
2. Specify points from left to right to define an area that entirely encloses the lines you want to select.
3. Press ENTER to close the polygon and complete the selection.

The following illustration shows the result of specifying the same selection area as a crossing polygon.

![Crossing Polygon](image1)

**Using Selection Fences**

You can select nonadjacent objects in a complex drawing most easily with a selection fence. A fence is a line that selects all the objects it passes through. This circuit board illustration shows a fence selecting several components.

![Fence Selection](image2)

To select nonadjacent objects with a fence

1. At the Select Objects prompt, enter `f` (Fence).
2. Specify the fence points.
3. Press ENTER to complete the selection.
Selecting Objects that Are Close Together

Selecting objects that are close together or directly on top of one another is often difficult. When objects are close together, you can press CTRL and click to cycle through selection of these objects until you reach the one you want.

In the following example, two lines and a circle all lie within the scope of the selection pickbox.

To cycle through objects for selection
1 At the Select Objects prompt, hold down CTRL and select a point as near as possible to the object you want.
2 Click your pointing device repeatedly until the object you want is highlighted.
3 Press ENTER to select the object.

Customizing Object Selection

You can control how objects are selected by choosing the selection mode, pickbox size, and object sorting method. For more information about these options, see OPTIONS in the Command Reference.

To use the object selection settings
1 From the Tools menu, choose Options.
2 To modify the object sorting method, choose the User Preferences tab, and then select the methods you want.
3 To modify the selection mode and pickbox size, choose the Selection tab, and then select the selection mode.
4 Choose OK.

Command line OPTIONS
Filtering Selection Sets

Using either the Quick Select or Object Selection Filters dialog box, you can filter selection sets by property (such as color) and by object type. For example, you can select all of the red circles in a drawing without selecting any other object; or you can select all objects except the red circles.

With Quick Select, you can quickly define a selection set based on filtering criteria that you specify. With Object Selection Filters, you can name and save filters for future use.

With either method, if you want to filter your selection set based on color, linetype, or lineweight, first consider whether these properties are set to BYLAYER for any objects in your drawing. For example, an object may appear red because its color is set to BYLAYER, and the layer color is red. To create a filter recognizing this object, design the filter to look for objects that either exist on that layer or that have a color value of BYLAYER, not red. For information about assigning properties by layer, see “Working with Layers” on page 316.

For partially opened drawings, Quick Select does not consider objects that are not loaded.

Once you create a selection set, you can use the Object Properties toolbar or the Properties window to view or modify properties of the selected objects. For more information, see “Editing Object Properties” on page 249.

In the following example, you use Quick Select to select the red objects in a drawing.
To create a selection set using Quick Select

1. From the Tools menu, choose Quick Select.

2. In the Quick Select dialog box under Apply To, select Entire Drawing.
3. Under Object Type, select Multiple.
5. Under Operator, select Equals.
6. Under Value, select Red.
7. Under How to Apply, select Include in New Selection Set.
8. Choose OK.

AutoCAD selects all red objects in the drawing and closes the Quick Select dialog box.

Command line  QSELECT

Shortcut menu  End any active commands. Right-click in the drawing area, and choose Quick Select.

You can exclude objects from a current selection set by using the Exclude from New Selection Set option. In the following example, you exclude all circles with a radius greater than 1 from a set of objects already selected.
To exclude objects from the selection set

1. On the Tools menu, choose Quick Select.
2. In the Quick Select dialog box under Apply To, select Current Selection.
3. Under Object Type, select Circle.
5. Under Operator, select Greater Than.
6. Under Value, enter 1.
7. Under How to Apply, select Exclude from New Selection Set.
8. Choose OK.
   
   AutoCAD removes all circles with a radius greater than 1 from the selection set and closes the Quick Select dialog box.

**Command line**  `QSELECT`

**Shortcut menu**  End any active commands, right-click in the drawing area, and choose Quick Select.

You can also use Quick Select to append objects to a current selection set. In the following example, you keep the current selection set and append all objects in the drawing that contain hyperlinks whose names begin with `bld1_`.

To append objects to the selection set

1. On the Tools menu, choose Quick Select.
2. In the Quick Select dialog box, select Append to Current Selection Set.
3. Under Object Type, select Multiple.
5. Under Operator, select `*Wildcard Match`.
6. Under Value, enter `bld1_*`.
7. Under How to Apply, select Include in New Selection Set.
8. Choose OK.

**Command line**  `QSELECT`

**Shortcut menu**  End any active commands, right-click in the drawing area and choose Quick Select.

**Related**  FILTER names and saves filters and provides options for more complex filtering.
To name and save a filtered list
1. At the Command prompt, enter `filter`.
2. In the Object Selection Filters dialog box under Select Filter, select Line.
3. Choose Add to List.
4. Under Save As, enter a filter name such as Linefilter.
5. Choose Save As.
6. Choose Apply.
   AutoCAD applies the filter so you can select only lines in the drawing. If you select objects with a window, AutoCAD applies the filter to all objects in the window.

You can restore a saved selection set by selecting the filter name under Current in the Object Selection Filters dialog box.

Removing Objects from a Selection Set

After you create a selection set, you can choose to remove individual objects from that set. For example, you can select an entire group of densely grouped objects, and then remove specific objects within the group to leave only the objects you want to be in the set. You can choose to remove objects only while object selection is already in progress or when objects in a selection set are highlighted and have grips.

To remove objects while creating a selection set
1. Select some objects.
2. At the Select Objects prompt, enter `remove`.
3. At the Remove Objects prompt, select the objects you want to remove from the selection set.
4. To return to adding objects to the selection set, enter `add`.
   You can also remove an object from a selection set by pressing SHIFT as you select the object.
Using Groups

A group is a named selection set of objects. Unlike unnamed selection sets, groups are saved with the drawing. Group definitions are maintained when you use a drawing as an external reference or insert it in another drawing. However, until you have bound and exploded external references or exploded blocks, you cannot directly access groups that have been defined in an external reference or block.

When you create or edit a group, you can specify whether it is selectable. If a group is selectable, selecting one of its members selects all members in the current space that meet the selection criteria (for example, members on locked layers are not selectable). The ability to select groups is also affected by the PICKSTYLE system variable. When PICKSTYLE is off for group selection, you can individually select group members.

An object can be a member of more than one group. You can list all the groups to which a selected object belongs by using the Find Name option in the Object Grouping dialog box. Highlight all the members of a specified group with the Highlight option. Group members are numerically ordered and can be reordered. Reordering may be useful in some batch operations on objects or when it’s important which object is “on top” for display purposes.

Creating Groups

When you create a group, you can give the group a name and description. If you copy a group, the copy is given the default name A and is considered unnamed. Unnamed groups are not listed in the Object Grouping dialog box unless you select Include Unnamed.

If you choose a member of a selectable group for inclusion in a new group, all members of that selectable group are included in the new group. In the following example, you create a group consisting of the objects in the window. This group can then be copied multiple times.
To create a group

1. At the Command prompt, enter `group`.

2. In the Object Grouping dialog box under Group Identification, enter a group name and a description.

3. Choose New.
   The dialog box closes temporarily.

4. Select objects and press ENTER.

5. Choose OK.

   **Related** - `GROUP` displays options on the command line.
Selecting Groups

You can select groups by name at the Select Objects prompt. If the PICKSTYLE system variable is set to 1 or 3 and you select any member of a selectable group, AutoCAD selects all group members that meet the selection criteria. You can also toggle group selection on and off by pressing CTRL + A.

All members of selectable groups are also selected when you use object selection cycling (for example, if you want to select an object that lies directly behind another object). See “Selecting Objects that Are Close Together” on page 237. Selecting an object that is a member of more than one selectable group selects all the members of all the groups that contain that object. To select groups for editing with grips, use the pointing device to select the group at the Command prompt.

The following example shows the object selection process when the object you select belongs to a selectable group.

To cycle through object and group selection

1. At the Command or Select Objects prompt, press CTRL and select an object. Object cycling is activated.
2. Now select any point. An object within the original pickbox is selected. Click repeatedly until the objects you want are highlighted.
3. Press ENTER to turn off object cycling.

You can now continue to select objects normally.

Editing Groups

At any time, you can add or remove group members and rename groups. You can also copy, mirror, and array groups. Erasing a group member deletes that object from the group definition. When a group member is included in a deleted block, the object is deleted from the drawing and also from the
group. If deleting an object or removing it from a group leaves the group empty, the group remains defined. You can remove the group definition by exploding the group. Exploding a group deletes it from a drawing. Objects that were part of the group remain in the drawing.

You can alter the group's member order (the order in which the objects were selected), its description, and whether it's selectable. You can reorder group members in two ways: either change the numerical position of individual or ranges of group members or reverse the order of all members. The first object in each group is number 0, not number 1.

To delete a named group

1. At the Command prompt, enter `group`.
2. In the Object Grouping dialog box, select the group name from the list of groups.
3. Under Change Group, choose Explode.
4. Choose OK.
   The group is deleted.

   **Command line**  
   `GROUP`

   **Related**  
   `-GROUP` displays options on the command line.

To reorder group members

1. At the Command prompt, enter `group`.
2. In the Object Grouping dialog box under Change Group, choose Re-Order.
3. In the Order Group dialog box under Group Name, select the group to reorder.
4. To view the current order of this group, choose Highlight.
5. In the Object Grouping dialog box, choose Next or Previous to view the objects. Choose OK when you have finished viewing the order of the objects.
6. In the Order Group dialog box under Remove From Position, enter an object number.
7. Then under Enter New Position Number for the Object, enter a new position.
8. Under Number of Objects, enter the object number or range of numbers to reorder. Then choose Re-Order.
9. Choose OK to close each dialog box.
Editing with Grips

If grips are turned on, when you select objects with the pointing device before starting a command, AutoCAD marks the selected objects with grips. (Noun/Verb Selection must be turned on in order to select objects first. See “Customizing Object Selection” on page 237.)

Grips mark control locations on a selected object. For example, selecting a line turns on grip points at each endpoint and at the midpoint. When you select a group, each member of the group is marked with its own grips. Selecting a block turns on a grip at its insertion point, as shown in the illustration.

Examples of grip locations

With grips you can use the pointing device to combine several of the most common editing commands with object selection to edit more quickly. When grips are turned on, you select the objects you want before editing. You can then manipulate the objects.

To turn on grips
1. From the Tools menu, choose Options.
2. In the Options dialog box, choose the Selection tab.
3. Under Grips, select Enable Grips and make any changes to color or size.
4. Choose OK.
**Command line**

**OPTIONS**

**System variables**

GRIPBLOCK controls the assignment of grips within blocks. When GRIPBLOCK is 1, grips are assigned to all objects in the block. When GRIPBLOCK is 0, a single grip is assigned to the block’s insertion point.

The following two illustrations show the difference between selecting and clearing Enable Grips within Blocks.

To use grips for editing, select a grip to act as the base point. This selected grip is known as the *base grip*. Then select one of the grip modes: Mirror, Move, Rotate, Stretch, or Scale. You can cycle through these modes with the SPACEBAR or ENTER keys or keyboard shortcuts. For example, for Stretch, enter `st` or keep pressing ENTER until Stretch appears.

You can use multiple grips as the base grips and keep the geometry intact between the selected grips, by holding down SHIFT as you select the grips.

You can also choose a grip mode, or any of the options available for the current mode, from a shortcut menu by right-clicking in the drawing area while the grip is selected.

To remove a specific object from a selection set that displays grips, hold down SHIFT as you select the object. Objects removed from the selection set are no longer highlighted, but their grips remain active. To exit grip modes and return to the Command prompt, enter `x` (Exit) or press ESC.

For descriptions of each grip mode, see the following sections:

- “Mirroring with Grips” on page 274
- “Moving Objects” on page 278
- “Rotating with Grips” on page 281
- “Stretching with Grips” on page 284
- “Scaling with Grips” on page 286
Using Multiple Copy Mode

If you press SHIFT as you select the first new coordinate location, you can make multiple copies. For example, with Stretch mode, Multiple Copy mode stretches the object, such as a line, and copies it to a location you specify. Another way to activate Multiple Copy mode is to use the Copy option at the Command prompt and select a point or enter a coordinate for each copy’s destination. Multiple Copy mode remains active until you either select another option from the current Grip mode or press ENTER to exit.

Using Multiple Copy Mode and Offset Snap Locations

If you press SHIFT while selecting multiple copy points, the cursor snaps to offset points based on the first two points you selected. For example, in the following illustration, the midpoint of line 1 is at the coordinate 8,5. Based on that midpoint, line 2 was copied using SHIFT with Stretch mode; its midpoint is at 9,5. Line 3 snaps to an offset based on these two coordinates, 10,5.
Editing Object Properties

AutoCAD provides two main tools that you can use to easily edit object properties such as layers, colors, linetypes, and lineweights.

- **Object Properties toolbar**: Provides options for viewing or changing the object properties that are common to all objects, including layers and layer properties, colors, linetypes, lineweights, and plot style.
- **Properties window**: Provides a complete list of properties for any object. You can view an object’s properties and modify the ones that can be changed.

For detailed information about layers, colors, linetypes, and lineweights, see chapter 10, “Using Layers and Object Properties.”

In order to view or change object properties with the Object Properties toolbar or the Properties window, you need to be able to select objects without having to first activate a command.

When the PICKFIRST system variable is on (set to 1), you can select an object with the pointing device before entering a command. When an object is selected with PICKFIRST turned on, the object is highlighted and grips appear at key points, as shown in the following example (unless you have turned off grips).

The PICKADD system variable controls how you add objects to your selection set while PICKFIRST is on. If PICKADD is set to 0, you must hold down the SHIFT key while clicking with your pointing device to add objects to the selection set.
Using the Object Properties Toolbar

You can use the controls on the Object Properties toolbar to quickly view or change an object’s layer, layer properties, color, linetype, lineweight, and plot style. The Object Properties toolbar consolidates the commands needed to view and edit these object properties. Selecting an object when no command is active dynamically displays these properties in the controls on the toolbar. You cannot change the properties of objects on locked layers.

All controls on the Object Properties toolbar support character matching: instead of scrolling through the lists to make a selection, you can enter the first character of the property name to select it. If the name is too long to be displayed within the control, it is shortened with an ellipsis (…) in the middle of the name. You can view the complete name by positioning your pointer over the control and displaying the text tip.

Because blocks are distinct objects, it is important to understand that, although each object that composes the block maintains its own object properties, the Object Properties toolbar reflects only the object properties for the block, not its individual parts. This is likewise true for xrefs, because xrefs are simply external blocks. For more information, see chapter 13, “Using Blocks and External References.”

The layer, color, linetype, and lineweight values for a block are the layer, color, linetype, and lineweight values that were current at the time you inserted the block, unless you manually assigned other values to the block after insertion. For an individual object contained within a block, the layer
on which AutoCAD draws the object is always the layer on which the object existed at the time you created the block. The color, linetype, and linewidth in which AutoCAD draws the individual objects is described in the following table.

<table>
<thead>
<tr>
<th>Setting at creation of block</th>
<th>Result in drawing at insertion of block</th>
</tr>
</thead>
<tbody>
<tr>
<td>BYLAYER</td>
<td>The color, linetype, or linewidth is that of the current layer, as indicated in the Layer Properties Manager. Changing the color, linetype, or linewidth of an inserted block’s layer affects only BYLAYER objects in the block.</td>
</tr>
<tr>
<td>BYBLOCK</td>
<td>The current color, linetype, or linewidth is the current value, as indicated by the corresponding control on the Object Properties toolbar. Changing an inserted block’s color, linetype, or linewidth affects only BYBLOCK objects in the block.</td>
</tr>
<tr>
<td>Any value other than BYLAYER or BYBLOCK</td>
<td>Unchanged. The object retains its original color, linetype, or linewidth. Changing the color, linetype, or linewidth of an inserted block or an inserted block’s layer has no effect on these objects.</td>
</tr>
</tbody>
</table>

Before working with the Object Properties toolbar, ensure that PICKFIRST is on for object selection, as described in “Editing Object Properties” on page 249.

**Editing Layers**

With the layer buttons and the layer control, you can view a selected object's layer, change an object's layer, make a layer current, change a layer's properties, and access the Layer Properties Manager. The layer name and properties displayed in the Layer control depend on the current selection set:

- **No objects selected**: Displays the current layer name and layer properties. When you create new objects, the layer on which those objects are created is the layer that you have made current. See “To make a layer current” on page 252.
- **One object selected**: Displays the selected object’s assigned layer and layer properties.
- **Multiple objects selected**: If all selected objects are on the same layer, displays the common layer name and layer properties. If any of the selected objects are on different layers, the Layer control is blank.

You can use the Layer control to transfer objects to locked, frozen, or turned-off layers, but you cannot transfer an object to an xref-dependent layer (any layer that is defined within an inserted xref). Xref-dependent layers are displayed as unavailable in the list because you cannot make them current.
and you cannot edit objects on those layers. You can, however, still modify the properties of xref-dependent layers by clicking icons in the Layer control. In the Layer Properties Manager, if you turn on a filter and apply it to the Object Properties toolbar, the Layer control does not list layers that match the filter. In this case, when you position your pointer over the Layer control, the tooltip indicates either “Filter applied” or “Inverted filter applied,” rather than the full layer name.

The following procedures describe how to work with layers from the Object Properties toolbar. For more detailed information about layers, see “Working with Layers” on page 316.

To change an object’s layer

1. Select the objects whose layers you want to change.
2. On the Object Properties toolbar, choose the Layer control.
   
   Because you cannot transfer objects to xref-dependent layers, their names are displayed as unavailable in the Layer control.
3. Choose a layer.
   
   AutoCAD applies the chosen layer to all selected objects.

To make a layer current

1. With no objects selected, on the Object Properties toolbar, choose the Layer control.
2. Choose the layer you want to make current.
   
   Because you cannot make frozen and xref-dependent layers current, their names are displayed as unavailable in the Layer control.

To make an object’s layer current

1. Select the object whose layer you want to make current.
2. On the Object Properties toolbar, choose Make Object’s Layer Current.
To change a layer’s properties

1. On the Object Properties toolbar, choose the Layer control.
2. Click the layer property icon that you want to toggle.
   You cannot change a layer’s color from the Layer control. (Use the Layer Properties Manager, as described in the following procedure.)
3. Choose the Layer control again to collapse the list.

To access the Layer Properties Manager

- On the Object Properties toolbar, choose Layers.

For more information about the Layer Properties Manager, see “Working with Layers” on page 316.

Editing Colors

With the Color control, you can view the current color of a selected object, change the color of an object, and make a color current.

The Color control lists BYLAYER, BYBLOCK, seven standard colors, and the four most recently used nonstandard colors. If the color you want is not on the list, choose Other and choose the color in the Select Color dialog box.

The color displayed in the Color control depends on the current selection set:

- No objects selected: Displays the current color. When you create new objects, the color applied to those objects is the color that you have made current.
- One object selected: Displays the selected object’s assigned color.
- Multiple objects selected: If all selected objects are of the same color, displays that color. If the selected objects are of various colors, the Color control is blank. If the color of all selected objects is BYLAYER, the Color control displays BYLAYER, but only displays a color swatch if all layers represented in the selection set are the same color.

The BYLAYER and BYBLOCK color values are dynamic, depending on the drawing environment.

- BYLAYER: The object’s color is determined by the color assigned to the object’s layer.
- BYBLOCK: The object’s color is determined by the color assigned to the object’s block. If the object is not yet a part of an inserted block, its color is the default color (white or black, depending on your configuration). If the object is part of an inserted block, its color is the color that was current when you inserted the block.
The following procedures describe how to work with the Color control on the Object Properties toolbar. For more detailed information about colors, see “Working with Colors” on page 331.

To change an object’s color

1 Select the objects whose colors you want to change.
2 On the Object Properties toolbar, choose the Color control.

3 Choose a color.
4 If you do not see the color that you want, choose Other.

5 In the Select Color dialog box, select the color that you want. You can select a color from one of the palettes or enter an AutoCAD Color Index (ACI) color number under Color.
6 Choose OK. AutoCAD applies the chosen color to all selected objects.
To make a color current

1. With no objects selected, on the Object Properties toolbar, choose the Color control.
2. Choose a color from the list.
3. If you do not see the color that you want, choose Other.
4. In the Select Color dialog box, select the color that you want and choose OK.
   
   You can select a color from one of the palettes or enter an ACI color number under Color.

**Command line** COLOR

**Editing Linetypes**

With the Linetype control, you can view a selected object’s linetype, change an object’s linetype, make a linetype current, and access the Linetype Manager. You cannot make xref-dependent linetypes current or assign them to objects, so their names are not displayed in the Linetype control.

The Linetype control displays BYLAYER, BYBLOCK, CONTINUOUS, and any linetypes that you have loaded. If the linetype you want is not listed, access the Linetype Manager as described in this section to load additional linetypes.

The linetype displayed in the Linetype control depends on the current selection set:

- **No objects selected**: Displays the current linetype. When you create new objects, the linetype applied to those objects is the linetype that you have made current.
- **One object selected**: Displays the selected object’s assigned linetype.
- **Multiple objects selected**: If all selected objects are of the same linetype, displays that linetype. If the selected objects are of various linetypes, the Linetype control is blank. If the linetype of all of the selected objects is BYLAYER, the Linetype control displays BYLAYER, but only displays a sample of the linetype if all layers represented in the selection set are the same linetype.

The BYLAYER and BYBLOCK linetype values are dynamic, depending on the drawing environment.

- **BYLAYER**: The object’s linetype is determined by the linetype assigned to the object’s layer.
- **BYBLOCK**: The object’s linetype is determined by the linetype assigned to the object’s block. If the object is not yet a part of an inserted block, its linetype is CONTINUOUS. If the object is part of an inserted block, its linetype is the linetype that was current when you inserted the block.
The following procedures describe how to work with the Linetype control on the Object Properties toolbar. For more detailed information about linetypes, see “Working with Linetypes” on page 333.

To change an object’s linetype
1 Select the objects whose linetypes you want to change.
2 On the Object Properties toolbar, choose the Linetype control.
3 Choose a linetype.
4 If you do not see the linetype that you want, choose Other.
   In the Linetype Manager, you can load additional linetypes.
5 Choose the linetype that you want and choose OK.
   AutoCAD applies the chosen linetype to all selected objects.

To make a linetype current
1 With no objects selected, on the Object Properties toolbar, choose the Linetype control.
2 Choose the linetype you want to make current.
3 If you do not see the linetype that you want, choose Other.
   In the Linetype Manager, you can load additional linetypes.
4 Choose the linetype that you want and choose OK.

Editing Lineweights
With the Lineweight control, you can view the current lineweight of a selected object, change an object's lineweight, and make a lineweight current.

The Lineweight control displays BYLAYER, BYBLOCK, and all of the available lineweights. The six most recently used lineweights appear at the top of the list.

The lineweight displayed in the Lineweight control depends on the current selection set:

- No objects selected: Displays the current lineweight. When you create new objects, the lineweight applied to those objects is the lineweight that you have made current.
- One object selected: Displays the selected object's assigned lineweight.
Multiple objects selected: If all selected objects are of the same lineweight, displays that lineweight. If the selected objects are of various lineweights, the Lineweight control is blank. If the lineweight of all of the selected objects is BYLAYER, the Lineweight control displays BYLAYER, but only displays a sample of the lineweight if all layers represented in the selection set are the same lineweight.

The BYLAYER and BYBLOCK lineweight values are dynamic, depending on the drawing environment.

BYLAYER: The object’s lineweight is determined by the lineweight assigned to the object’s layer.

BYBLOCK: The object’s lineweight is determined by the lineweight assigned to the object’s block. If the object is not yet a part of an inserted block, its lineweight is 0, which is the thinnest line that the plotting device can plot. AutoCAD displays the 0 lineweight at 1 pixel. If the object is part of an inserted block, its lineweight is the lineweight that was current when you inserted the block.

The following procedures describe how to work with the Lineweight control on the Object Properties toolbar. For more detailed information about line-weights, see “Working with Lineweights” on page 339.

To change an object’s lineweight

1 Select the objects whose lineweights you want to change.
2 On the Object Properties toolbar, choose the Lineweight control.
3 Choose a lineweight.

AutoCAD applies the chosen lineweight to all selected objects.

System variables If LWDISPLAY is set to 0 (off), lineweights are not displayed in the drawing area. You can toggle this system variable using the Lwt button on the status bar.
To make a lineweight current
1 With no objects selected, on the Object Properties toolbar, choose the Lineweight control.
2 Choose the lineweight that you want to make current.

Command line      LWEIGHT

Editing Plot Styles
AutoCAD 2000 provides a new object property called plot style that can change the way a plotted drawing looks. By modifying an object’s plot style, you can override that object’s color, linetype, and lineweight. You can also specify end, join, and fill styles as well as output effects such as dithering, gray scale, pen assignment, and screening. You can use plot styles if you need to plot the same drawing in different ways. You can apply plot styles to objects or layers. Plot styles are defined in plot style tables. You can view the current plot style of a selected object, change the plot style of an object, and make a plot style current.

For more detailed information about plot styles, see “Using Plot Styles” on page 553.

To change an object’s plot style
1 Select the objects whose plot styles you want to change.
2 On the Object Properties toolbar, choose the Plot Style control. The Plot Style control is unavailable if you are working in color-dependent mode.

3 Choose a plot style.
4 If you do not see the plot style that you want, choose Other.
In the Select Plot Style dialog box, select the plot style you want.

If you want to access the plot styles from another plot style table, choose Active Plot Style Table and select another table.

Choose OK.

AutoCAD applies the chosen plot style to all selected objects.

**Command line**

PLOTSTYLE

**To make a plot style current**

1. With no objects selected, on the Object Properties toolbar, choose the Plot Style control. The Plot Style control is unavailable if you are working in color-dependent mode.
2. Choose a plot style.
3. If you do not see the plot style that you want, choose Other.
4 In the Current Plot Style dialog box, select the plot style you want.
5 If you want to access the plot styles from another plot style table, choose Active Plot Style Table and select another table.
6 Choose OK.

Command line  PLOTSTYLE

Using the Properties Window

When you enter PROPERTIES, AutoCAD displays the Properties window. While the Object Properties toolbar provides convenient access to the properties that are common to all objects, the Properties window is the main method you use to modify the complete set of object-specific properties, including properties that you have defined.

The Properties window lists the current settings for all object properties when a single object or multiple sets of objects are selected. From the Properties window, you can modify any property that can be changed. To modify properties using the Properties window select the object whose properties you want to change and use one of the following methods:

- Enter a new value.
- Select a value from a list.
- Change the property value in a dialog box.
- Use the Pick Point button to change a coordinate value.
You can leave the Properties window open while you work. When you select an object, the Properties window displays the properties of that object. When multiple objects are selected, the Properties window displays the general properties and any other properties that are common among objects in the selection set. The general properties are as follows:

- **Color**: Displays or sets the color.
- **Layer**: Displays or sets the layer.
- **Linetype**: Displays or sets the linetype.
- **Linetype scale**: Displays or sets the linetype scale.
- **Plot style**: Displays or sets the plot style.
- **Lineweight**: Displays or sets the lineweight.
- **Hyperlink**: Displays or sets the hyperlink.
- **Thickness**: Displays or sets the thickness.

Right-click in the Properties window and choose Allow Docking or Hide from the shortcut menu, or drag the Properties window to another location. To close the Properties window from the command line, enter PROPERTIESCLOSE. You can also turn off the property description below the list.
Using Keyboard Shortcuts in the Properties Window

There are several ways to control focus and navigate from the keyboard in the Properties window. Use the TAB key to cycle focus. Use the arrow keys and PGUP or PGDN to move vertically in the window. Use CTRL + Z to undo, and CTRL + X, CTRL + C, and CTRL + V to cut, copy, and paste, respectively.

You can also use the keyboard shortcuts shown in the following table.

<table>
<thead>
<tr>
<th>Keys</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + 1</td>
<td>Displays or closes Properties window</td>
</tr>
<tr>
<td>HOME</td>
<td>Moves to first property in the list</td>
</tr>
<tr>
<td>END</td>
<td>Moves to last property in the list</td>
</tr>
<tr>
<td>CTRL + SHIFT + [alpha character]</td>
<td>Moves to the next property that begins with the alphabetical character</td>
</tr>
<tr>
<td>ESC</td>
<td>Cancels a property change</td>
</tr>
<tr>
<td>ALT + DOWN ARROW</td>
<td>Opens settings list</td>
</tr>
<tr>
<td>ALT + UP ARROW</td>
<td>Closes settings list</td>
</tr>
</tbody>
</table>

Viewing Properties of One or More Objects

Use the Properties window to view the properties of one selected object or a selection set.

To view the properties of one or more objects

1. From the Modify menu, choose Properties.
2. In the drawing area, select one or more objects whose properties you want to view.
3. In the Properties window, choose All or an individual object.
   Choosing All lists the general properties of that set of selected objects.

   **Command line**  
   PROPERTIES

   **Shortcut menu**  
   Select one or more objects, right-click in the drawing area, and choose Properties.
**Editing Properties of a Single Object**

You can select a single object and change its properties.

To change a single object’s properties

1. From the Modify menu, choose Properties.
2. Select the object whose properties you want to change.
   
   The Properties window lists all of the object’s properties. Use the Alphabetic or Categorized tabs to see properties listed accordingly.
3. In the Properties window, select the property you want to change and either enter a new value and press ENTER or select a value from a settings list to apply the change.

   **Command line**  PROPERTIES

   **Shortcut menu**  Select one or more objects, right-click in the drawing area and choose Properties.

**Editing Properties of Multiple Objects**

You can select multiple objects and change the properties they share.

To change properties of multiple objects

1. From the Modify menu, choose Properties.
2. Select the objects whose properties you want to change.
   
   The Properties window lists all of the object set’s common properties. Use the Alphabetic or Categorized tabs to see the properties listed accordingly.
3. In the Properties window, select the properties you want to change and either enter a new value and press ENTER or select a value from a settings list to apply the change.

   **Command line**  PROPERTIES

   **Shortcut menu**  Select one or more objects, right-click in the drawing area, and choose Properties.

**Matching Properties of Other Objects**

You can copy some or all properties of one object to one or more objects using MATCHPROP. Properties that can be copied include color, layer, linetype, linetype scale, linewidth, thickness, plot style, and in some cases, dimension, text, and hatch.
The following table lists the properties you can copy for each AutoCAD object.

<table>
<thead>
<tr>
<th>Object</th>
<th>Color &amp; layer</th>
<th>Linetype &amp; linetype scale</th>
<th>Lineweight</th>
<th>Thickness</th>
<th>Text</th>
<th>Dimension</th>
<th>Hatch</th>
<th>Plot style</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D face</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Arc</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Attdef</td>
<td>x</td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Body</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Circle</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Dimension</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Ellipse</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Hatch</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Image</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Insert</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Leader</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Line</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Mtext</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>OLE object</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Point</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>2D polyline</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>3D polyline</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>3D mesh</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Place mesh</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Ray</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
</tbody>
</table>
To copy properties from an object to one or more objects

1. From the Modify menu, choose Match Properties.
2. Select the object whose properties you want to copy (1).
3. Select the objects to which you want to apply the properties (2).

By default, all applicable properties are automatically copied from the source object to the destination object.

**Command line** MATCHPROP
Some properties are copied to the destination object but are not visible after they are copied. For example, it is possible to copy a linetype to a text object and not see the text object updated with the linetype you copied. However, when the LIST command is used on the text object, you will see the copied linetype associated with the text.

Use the Settings option of MATCHPROP to specify the properties that are copied.

To change the settings for matching properties

1. At the Command prompt, enter `matchprop`.
2. Select the object whose properties you want to copy.
3. Enter `settings`.
4. In the Property Settings dialog box, select properties you want to match and clear properties you do not want to change.
5. Choose OK.

The property settings are maintained until you change them.

**Copying Objects**

You can copy single or multiple objects within the current drawing, and you can copy between drawings or applications.

**Copying Within a Drawing**

To copy objects within a drawing, create a selection set and specify a start point and an endpoint for the copy. These points are called the base point and the second point of displacement, respectively, and can be anywhere within the drawing.
To copy a selection set once

1. From the Modify menu, choose Copy.
2. Select the objects to copy, and press ENTER.
3. Specify the base point (1).
4. Specify the second point of displacement (2).

Command line  COPY

Shortcut menu  Select the objects to copy, right-click in the drawing area, and choose Copy Selection.

To copy a selection set multiple times

1. From the Modify menu, choose Copy.
2. Select the objects to copy, and press ENTER.
3. Enter m (Multiple).
4. Specify the base point.
5. Specify the second point of displacement.
6. Specify the next point of displacement. Continue inserting copies, or press ENTER to end the command.

Command line  COPY

Shortcut menu  Select the objects to copy, right-click in the drawing area, and choose Copy Selection.

To arrange multiple copies in a rectangular or circular pattern, see “Arraying Objects” on page 275.
Multiple Copying Using Grips

You can create multiple copies in any of the Grip modes (see “Editing with Grips” on page 246). For example, you can rotate a selection set, leaving copies of the set at each location you specify with the pointing device. You can also make multiple copies of selection sets, which is a quick and simple way to create small arrays.

To make multiple rotated copies
1. Select the objects to rotate.
2. Select a base grip on one of the selected objects.
3. Enter ro to switch to Rotate mode.
4. Enter copy.
5. Drag the objects to a new location and click.
   The objects are copied and rotated around the base point.
6. Continue to drag and click for multiple copies, or press ENTER to end the command.

You can place multiple copies at regularly spaced intervals by creating an offset snap. The offset is defined by the distance between the original object and the first copy. In the following lighting layout, the first copy of the light fixture symbol is placed at an offset of two units. All subsequent copies are then placed two units apart.

To create an offset snap for multiple copies
1. Select the objects to copy.
2. Select a base grip (1).
3. Enter mo (Move mode).
4. Enter c (Copy).
5. Select the first copy offset (2).
   The offset snap is the distance between points 1 and 2.
6 Hold down SHIFT and place additional copies (3 and 4). These copies are placed at the same offset from each other.

7 Press ENTER to exit Grip mode.

**Copying with the Clipboard**

When you want to use objects from another AutoCAD drawing or from a file created with another application, cut or copy these objects to the Clipboard and then paste them from the Clipboard into your drawing. Copying to and pasting from the Clipboard is different from copying objects from one location to another within a single drawing. The color of the object doesn’t change when copied to the Clipboard. For example, if the objects are white, and they are pasted into a drawing or other file with a white background, the objects won’t be visible. Use the WMFBKGDND system variable to control whether the background for the metafile format of objects placed on the Clipboard and pasted into other applications is transparent.

**Cutting to the Clipboard**

Cutting deletes the selected objects from the drawing and stores them on the Clipboard.

To cut objects to the Clipboard

1 Select the objects you want to cut.
2 From the Edit menu, choose Cut, or press CTRL + X.

**Command line** CUTCLIP

**Shortcut menu** End any active commands, right-click in the drawing area, and choose Cut.

**Copying to the Clipboard**

Use the Clipboard to copy part or all of a drawing to another application. Updating the original does not update the embedded copy. Compare copying with linking, which is discussed in “Copying Views to the Clipboard” on page 270.

To copy objects to the Clipboard

1 Select the objects you want to copy.
2 From the Edit menu, choose Copy, or press CTRL + C.

**Command line** COPYCLIP

**Shortcut menu** End any active commands, right-click in the drawing area, and choose Copy.
Copying Views to the Clipboard

The COPYLINK command copies the current view to the Clipboard, rather than copying selected objects. If you select a viewport, AutoCAD copies the viewport contents. Otherwise, it copies the drawing area.

You can copy the current AutoCAD view and link it to another file. Unlike embedding, linking creates a reference to the source. If the source view is updated, you have to update only the link to update all linked copies of the view. See “Linking and Embedding Information” on page 750.

To copy a view to the Clipboard

1. Select a viewport or display the view you want to copy.
2. From the Edit menu, choose Copy Link.

Command line  COPYLINK

Pasting Objects

Applications use different internal formats to store information. When you copy objects to the Clipboard, AutoCAD stores information about all available formats. When you paste the Clipboard contents into an AutoCAD drawing, AutoCAD uses the format that retains the most information. However, you can override this setting and convert pasted information to AutoCAD format.

The AutoCAD format is the preferred format for copying objects to and from AutoCAD, because it is the easiest format to edit and retains all relevant object information, including block references and 3D aspects.

ASCII text (in TXT files) is copied to AutoCAD as paragraph text. Paragraph breaks are retained, and the text can be edited using the Multiline Text Editor. To retain the font and style characteristics of formatted text, use the Multiline Text Editor or specify Windows metafile format (WMF) before inserting into the drawing.

The WMF format, or picture format, contains screen vector information and can be scaled and printed without loss of resolution. Use this format to paste objects into Microsoft® Windows® applications that support WMF files. Metafiles pasted into AutoCAD are of higher resolution than bitmap images but are less easily manipulated than AutoCAD objects. Use the WMFBKGND system variable to control whether the background for the metafile format of objects placed on the Clipboard and pasted into other applications is transparent.

Bitmapped images are raster images consisting of a pattern of pixels and are commonly used by paint applications. Bitmaps may lose clarity when scaled, so this format is pasted only if AutoCAD cannot correctly handle the format in another way. AutoCAD recognizes the standard Windows device-independent bitmap format (BMP files).
To paste objects from the Clipboard

- From the Edit menu, choose Paste, or press CTRL + V.
  The objects currently on the Clipboard are pasted into the drawing.

**Command line**  PASTECLIP

**Shortcut menu**  End any active commands, right-click in the drawing area, and choose Paste.

**Converting to AutoCAD Format**

When you convert a Windows metafile from another application to AutoCAD format, you can edit the file in the same way that you edit AutoCAD objects.

**To convert pasted information to AutoCAD format**

1. Copy the metafile to the Clipboard.
2. From the Edit menu, choose Paste Special.
3. In the Paste Special dialog box, select Paste.
4. Select Picture in the list of formats.
5. Choose OK.

**Command line**  PASTESPEC
**Pasting to the Command Line**

You can paste single- or multiline text from the Clipboard to the command line. For example, you could copy and paste a long command or text string to avoid entering it again. Right-click in the command window and choose Paste from the shortcut menu.

**Editing Pasted Information**

If you convert pasted information to AutoCAD format, the pasted information becomes a true AutoCAD object and can be edited as such. The same is true for unformatted text and objects already in AutoCAD format. You cannot use all of the AutoCAD editing commands when modifying information in other formats.

**Offsetting Objects**

Offsetting creates a new object that is similar to a selected object but at a specified distance. You can offset lines, arcs, circles, 2D polylines, ellipses, elliptical arcs, xlines, rays, and planar splines. Offsetting circles creates larger or smaller circles depending on the offset side. Offsetting outside the perimeter creates a larger circle. Offsetting inside creates a smaller one.

For information about offsetting splines, see “Editing Splines” on page 298.

**To offset an object by specifying a distance**

1. From the Modify menu, choose Offset.
2. Use the pointing device to specify the offset distance, or enter a value.
3. Select the object to offset.
4. Specify which side to offset.
5. Select another object to offset, or press ENTER to end the command.

**Command line**

OFFSET

**System variables**

OFFSETDIST stores the current offset value. OFFSETGAPTYPE controls how to offset polylines when a gap is created as a result of offsetting individual polyline segments.
In the following example, you offset the polyline border of the room so that the wall aligns with the door frame.

To offset an object through a point
1. From the Modify menu, choose Offset.
2. Enter t (Through).
3. Select the object to offset.
4. Specify the offset point (1).
5. Press ENTER to end the command.

OFFSET cannot be used on 3D faces or objects.

**Mirroring Objects**

You mirror objects around a mirror line, which you define with two points, as shown in the following illustration. You can delete or retain the original objects. Mirroring works in any plane parallel to the XY plane of the current UCS. Although you can mirror a viewport object in paper space, doing so has no effect on its model space view or model space objects.
To mirror objects

1. From the Modify menu, choose Mirror.
2. Select the objects to mirror with a window (1 and 2).
3. Specify the first point of the mirror line (3).
4. Specify the second point (4).
5. Press ENTER to retain the original objects.

**Command line**  MIRROR

**Shortcut menu**  Select the objects to mirror, right-click in the drawing area and choose Mirror.

**Mirroring Text and Attributes**

When you mirror text, attributes, and attribute definitions, they are reversed or turned upside down in the mirrored image. These mirrored objects are true mirror images of the original section of the object and follow the mathematical rules for reflection.

To prevent mirrored text from being reversed or turned upside down, set the MIRRTEXT system variable to 0 (off). By default, MIRRTEXT is set to 1 (on). If you turn it off, the text has the same alignment and justification as before the mirroring. Compare the following illustrations.

![Before MIRROR](image1.png)  ![After MIRROR (MIRRTEXT = 1)](image2.png)  ![After MIRROR (MIRRTEXT = 0)](image3.png)

MIRRTEXT affects only text created with the TEXT or MTEXT commands, attribute definitions (user-defined data), and variable attributes (user-defined changeable data). Text and constant attributes (user-defined fixed data) within an inserted block are mirrored as a consequence of mirroring the entire block. These objects are inverted regardless of the MIRRTEXT setting. See chapter 13, “Using Blocks and External References.”

**Mirroring with Grips**

In the following example, you draw a valve by mirroring one half of the valve and retaining the original. Turning Ortho on helps you draw a vertical mirror line so that the object is mirrored horizontally.
To mirror an object and retain the original

1. Select the original objects with a window (1 and 2).
2. Select the base grip (3).
3. Enter mirror (Mirror Grip mode).
4. Turn on Ortho mode.
5. Hold down SHIFT and specify the second point of the mirror line (4). Select anywhere above or below the base point (on the vertical line of the crosshairs shown in the illustration).

Because Ortho is on, the mirror line is vertical and the object is mirrored horizontally.

Arraying Objects

You can copy an object or selection set in polar or rectangular arrays (patterns). For polar arrays, you control the number of copies of the object and whether the copies are rotated. For rectangular arrays, you control the number of rows and columns and the distance between them.

Creating Polar Arrays

In the following example, you surround a circular table with chairs by making a polar array of the original chair and rotating the copies as they are arrayed. Whether the array is drawn counterclockwise or clockwise depends on the Direction Control setting in the Units Control dialog box.
To create a polar array
1. From the Modify menu, choose Array.
2. Select the original object (1) and press ENTER.
3. Enter p (Polar).
4. Specify the center point of the array (2).
5. Enter the number of items in the array, including the original object.
6. Enter the angle the array is to fill, from 0 through 360.
   The default setting for the angle is 360 degrees.
7. Press ENTER to rotate the objects as they are arrayed.

Command line  ARRAY

Creating Rectangular Arrays

In the following example, you make a rectangular array of the chair. The array has two rows and four columns.

To create a rectangular array
1. From the Modify menu, choose Array.
2. Select the chair (1).
3. Enter r (Rectangular).
4. Enter the number of rows.
5. Enter the number of columns.
6. Enter the distance between the rows.
7. Enter the distance between the columns.
Creating Rotated Rectangular Arrays

AutoCAD builds a rectangular array along a baseline defined by the current snap rotation angle. This angle is zero by default, so the rows and columns of a rectangular array are orthogonal with respect to the $X$ and $Y$ drawing axes. However, you can change this angle and create a rotated array. Setting the snap rotation angle to a nonzero value rotates the screen crosshairs accordingly. You can consider all rectangular arrays to be constructed parallel to the crosshairs. Rows align with the $X$ crosshair, and columns align with the $Y$ crosshair.

In the following example, you rotate a rectangular array of chairs.

![Diagram of a rotated rectangular array](image)

**To rotate a rectangular array**

1. From the Tools menu, choose Drafting Settings.
2. In the Drafting Settings dialog box, choose the Snap and Grid tab.
3. On the Snap and Grid tab under Snap Angle, enter the angle at which you want to rotate the array.
4. Create the rectangular array.

**Command line**  
DSETTINGS

**Shortcut menu**  
Right-click Snap on the status bar and choose Settings.

**System variables**  
SNAPANG changes the array rotation angle.
Moving Objects

When you move objects, you can rotate or align them or move them without changing orientation or size. Use snap mode, coordinates, grips, and object snap modes to move objects with precision.

In the following example, you move the window.

To move an object

1. From the Modify menu, choose Move.
2. Select the object to move (1).
3. Specify the base point for the move (2).
4. Specify the second point of displacement (3).

Command line  MOVE
Shortcut menu  Select the objects to move, right-click in the drawing area, and choose Move.

When you use grips to move an object, the base grip acts as the default base point for the move.

To move an object using grips

1. Select the object so that grips are displayed.
2. Select the base grip so it is highlighted.
3. Enter mo (Move mode).
4. Drag to move the object to a new position.
Rotating Objects

You rotate objects by choosing a base point and a relative or absolute rotation angle. Specify a relative angle to rotate the object from its current orientation around the base point by that angle. Whether the objects are rotated counterclockwise or clockwise depends on the Direction Control setting in the Units Control dialog box. Specify absolute angles to rotate objects from the current angle to a new absolute angle.

In the following example, you rotate the plan view of a house, using the default relative angle method.

To rotate an object

1. From the Modify menu, choose Rotate.
2. Select the object to rotate (1).
3. Specify the base point for the rotation (2).
4. Specify the angle of rotation (3).

Command line  ROTATE
Shortcut menu  Select the objects to rotate, right-click in the drawing area, and choose Rotate.
Related  UNITS sets the direction in which objects are rotated.

Rotating by Reference

Sometimes it’s easier to rotate with absolute angles. For example, to align two objects when you know the absolute angles of both, use the current angle of the object to be rotated as the reference angle, and use the angle of the other object as the new angle. An easier way is to use the pointing device to select the object that you want to rotate and the object you want to align it with.
In the following example, you specify the reference angle by selecting two points on the object to rotate. The Intersection and Endpoint object snaps help you to select precise points on this object. You then specify the new angle by selecting the object you want to align with.

To rotate by reference

1. From the Modify menu, choose Rotate.
2. Select the object to rotate (1).
3. Select the object again to specify the base point for the rotation.
4. Enter `r` (Reference).
   Now define the reference and new angles by selecting the objects you're aligning.
5. Enter `int` (Intersection object snap), and select the intersection point (2) to begin defining the reference angle.
6. Enter `endp` (Endpoint object snap), and select the endpoint of the object you are rotating (3) to complete definition of the reference angle.
7. Enter `endp` again, and select the endpoint of the object to align with (4).

**Command line**  
`ROTATE`

**Shortcut menu**  
Select the objects to rotate, right-click in the drawing area, and choose Rotate.
Rotating with Grips

In the following example, you rotate a polygon using grips.

To rotate a polygon using grips
1 Select the object so that grips are displayed (1).
2 Select the base grip so it is highlighted (2).
3 Enter ro (Rotate mode).
4 Drag (3) to rotate the object and then click or enter an angle to place the object in the new position.

Aligning Objects

You can move, rotate, or tilt an object so it aligns with another object. In the following example, align the pieces of piping using a window selection box to select the object to be aligned. Use the Endpoint object snap to align the pieces precisely.
To align two objects

1. From the Modify menu, choose 3D Operation ➤ Align.
2. Select the objects you want to align (1 and 2).
3. Specify the first source point (3) and then the first destination point (4).
   If you press ENTER now, the objects are moved from the source point to the destination point.
4. Specify the second source point (5), and then the second destination point (6).
5. Specify the third source point, or press ENTER to continue.
6. Specify whether you want to scale objects to the alignment points.
   The objects are aligned (moved and rotated into position), and then scaled.
   The first destination point is the base point of the scale, the distance between the first and second source points is the reference length, and the distance between the first and second destination points is the new reference length.

Erasing Objects

You can erase objects using all the available selection methods (see “Selecting Objects” on page 234). In the following example, you use window selection to erase a section of piping. Only objects enclosed by the window are erased.

To erase a selection set

1. From the Modify menu, choose Erase.
2. Using window selection, select the objects to erase (1 and 2).
3. Press ENTER.
   Command line ERASE
   Shortcut menu Select the objects to erase, right-click in the drawing area, and choose Erase.
   Related OOPS restores all objects erased by the most recent use of ERASE.
   Enter 1 (Last) at the Select Objects prompt to erase the last object drawn.
Resizing Objects

You can resize objects by stretching, scaling, extending, lengthening, and trimming them.

Stretching Objects

To stretch an object, you specify a base point for the stretch and then two points of displacement. You can also select the object with a crossing selection and combine grip editing with object snaps, grip snaps, grid snaps, and relative coordinate entry to stretch with greater accuracy.

In this example, you stretch the plan view of a house.

To stretch an object

1. From the Modify menu, choose Stretch.
2. Select the object using a crossing selection (1 and 2).
3. Specify the base point (3).
4. Specify the point of displacement (4).

Moving by Stretching

In the following example, you move a door from one part of a wall to another by stretching. Turning on Ortho mode helps you move the object in a straight line.
To move by stretching

1. Using a crossing selection, select the object to move (1 and 2).
2. Enter ‘ortho’ to turn on Ortho mode transparently.
3. Drag the object and click to place it in the new position (3 and 4).

The door and the door endpoint lie entirely within the selection window and thus move to the new location. The wall lines, on the other hand, merely cross the selection window and stretch in accordance with the movement of the door.

Stretching with Grips

You stretch an object by moving selected grips to new locations. Some grips move the object rather than stretching it. This is true of grips on text objects, blocks, midpoints of lines, centers of circles, centers of ellipses, and point objects.

To stretch an object using grips

1. Select the object so grips are displayed.
2. Specify the base point by selecting a grip so it is highlighted.
3. Specify the new location to which you want the object stretched.

Before you start the grip modes and if you plan to use Stretch grip mode, you can select more than one grip to stretch. In the following example, you stretch both lines that represent the pipe.

To stretch more than one grip

1. Select both lines so grips are displayed (1 and 2).
2. Hold down SHIFT and select both end grips so they are highlighted (3 and 4).
3. Release SHIFT and select either grip as the base grip (3).
4. Specify the new location for the objects.
Scaling Objects

You scale selection sets using the same scaling factor in the X and Y directions. Thus, you can make an object larger or smaller, but you cannot alter its aspect ratio. You can scale it by specifying a base point and a length, which is used as a scale factor based on the current drawing units, or by entering a scale factor directly. You can also specify the current length and a new length for the object.

Scaling by a Scale Factor

Scaling by a scale factor changes all dimensions of the selected object. A scale factor greater than 1 enlarges the object. A scale factor less than 1 shrinks the object. In the following example, you decrease the size of the block by half, scaling it by a factor of 0.5.

![Object selected, Object scaled by factor of 0.5, Result]

To scale a selection set by a scale factor

1. From the Modify menu, choose Scale.
2. Select the object to scale (1).
3. Specify the base point (2).
4. Enter .5 (the scale factor).

Command line  SCALE

Shortcut menu  Select the objects to scale, right-click in the drawing area, and choose Scale.

Scaling by Reference

When you scale by reference, you use the size of an existing object as a reference for the new size. To scale by reference, specify the current scale and then the new scale length. For example, if one side of an object is 4.8 units long and you want to expand it to 7.5 units, use 4.8 as the reference length and 7.5 as the new length. You can also specify the reference length by selecting a base point and two reference points and dragging to specify the new scale. A quick way to change the length of open objects such as lines, arcs, polylines, elliptical arcs, and splines is to lengthen them (see “Changing the Length of Objects” on page 289).
You can use the Reference option to scale an entire drawing. For example, use this option when the original drawing units are inappropriate. Select all objects in the drawing. Then use Reference to select two points and specify the intended distance. All the objects in the drawing are scaled accordingly.

To scale by reference

1. From the Modify menu, choose Scale.
2. Select the object to scale (1).
3. Specify the base point (2).
4. Enter r (Reference).
5. Select the first and second reference points (3 and 4), or enter a value for the reference length.
6. Drag the object and select a point (5), or enter a value for the new length.

Command line  SCALE

Shortcut menu  Select the objects to scale, right-click in the drawing area, and choose Scale.

Scaling with Grips

You can use the Scale grip mode to scale objects. For example, you can increase the size of a circle by dragging outward from the base grip or decrease the size by dragging inward. Alternatively, you could enter a value for relative scaling. In the following example, the outlet symbol, which is defined as a block, is scaled down. When selected, blocks have a single grip at the insertion point. To scale the block, you select the insertion point as the base grip and move the cursor to resize the block.
To scale a block using grips

1. Select the block with a crossing selection (1 and 2). A single grip is displayed at the block’s insertion point.
2. Select the insertion point as the base grip (3).
3. Enter `sc` or cycle by pressing ENTER to get to Scale grip mode.
4. Move the cursor to reduce the size of the block. Then click to specify the new size (4).

### Extending Objects

You can extend objects so they end precisely at a boundary defined by other objects. You can also extend objects to where they *would* intersect a boundary. This is called extending to an implied boundary. In the following example, you extend the lines precisely to a circle, which is the boundary.

To extend an object

1. From the Modify menu, choose Extend.
2. Select the object for the boundary.
3. Select the objects to extend and press ENTER.

**Command line**  
`EXTEND`
Extending to an Implied Boundary

In this example, you extend the three horizontal lines to an implied boundary, which is where they would intersect the single line if it were extended.

To extend to an implied boundary

1. From the Modify menu, choose Extend.
2. Select the object for the implied boundary and press ENTER.
3. Enter `e` (Edge).
4. Enter `e` (Extend), or press ENTER if Extend is the current option.
5. Select the lines to be extended and press ENTER.

Extending Polylines

You can extend only open polylines (unjoined first and last line or arc polyline segments). Either the first or the last edge extends as if it were a line or arc object.

Wide polylines extend so the centerline intersects the boundary. Because the ends of wide polylines are at a 90-degree angle, part of the end extends past the boundary if the boundary is not perpendicular to the extended segment. If you extend a tapered polyline segment, the width of the extended end is corrected to continue the original taper to the new endpoint. If this correction gives the segment a negative ending width, the ending width is forced to 0.
Extending Infinite Lines
You can extend rays, but you cannot extend an xline. Like a circle, an xline is unbounded and has no endpoint. A ray is semibounded; therefore, a ray can be extended to a new start point.

Changing the Length of Objects
You can change the angle of arcs, and you can change the length of open lines, arcs, open polylines, elliptical arcs, and open splines. The results are similar to both extending and trimming. You can alter the length in several ways:

- Dragging an object's endpoint (dynamically)
- Specifying a new length as a percentage of the total length or angle
- Specifying an incremental length or angle measured from an object's endpoint
- Specifying the object's total absolute length or included angle

To change an object’s length by dragging

1. From the Modify menu, choose Lengthen.
2. Select an object, or enter dy to enter Dynamic Dragging mode.
3. Select the object to lengthen.
4. Drag the endpoint closest to the point of selection, and specify a new endpoint.

**Command line** LENGTHEN

Trimming Objects
You can cut an object precisely at an edge defined by one or more objects. Objects you define as the boundary edges or cutting edges do not have to intersect the object being trimmed; you can trim back to an implied intersection. Cutting edges can be lines, arcs, circles, polylines, ellipses, splines, xlines, rays, and viewports in paper space. Wide polylines are cut along their centerline.
In the following example, you join two walls smoothly by trimming the section where they intersect.

To trim walls where they intersect
1. From the Modify menu, choose Trim.
2. Select the cutting edges with a crossing selection (1 and 2) and press ENTER.
3. Select the section of the wall you want trimmed (3) and press ENTER.

Command line TRIM

Trimming to an Implied Intersection
An implied intersection is the point where two objects would intersect if they were extended. You can trim objects using their implied intersection as the cutting edge. In the following example, you trim the vertical wall back to its implied intersection with the horizontal wall.

To trim to an implied intersection
1. From the Modify menu, choose Trim.
2. Select the cutting edge (1) and press ENTER.
3. Enter e (Edge).
4. Enter e (Extend), or press ENTER if Extend is the current option.
5. Select the object to trim on the side you want trimmed (2) and press ENTER.
**Trimming Complex Objects**

An object can be one of the cutting edges and one of the objects being trimmed. For example, in the light fixture illustrated, the circle is a cutting edge for the construction lines and is also being trimmed.

![Diagram of a light fixture showing cutting edges and objects to trim](image)

When trimming complex objects, using different selection methods can help you choose the right cutting edges and objects to trim. In the following example, the cutting edges are selected with a crossing window.

![Diagram of a light fixture showing cutting edges selected with crossing selection](image)

In the following example, fence selection is used to select a series of objects for trimming.

![Diagram of a light fixture showing objects to trim selected with fence selection](image)

In paper space, you can use viewport borders as cutting edges. However, you cannot trim the viewports themselves.
Trimming to the Nearest Intersection

You can trim objects to their nearest intersection with other objects. When you select the objects to trim, AutoCAD automatically chooses the nearest selected objects as cutting edges. In the following example, the walls are trimmed so that they intersect smoothly.

Inserting Breaks in Objects

You can remove part of an object with the BREAK command. You can break lines, circles, arcs, polylines, ellipses, splines, xlines, and rays. When breaking an object, you can either select the object at the first break point and then specify a second break point, or you can select the entire object and then specify the two break points.

To break an object

1. From the Modify menu, choose Break.
2. Select the object to break (1).
   By default, the point you select on the object will be the first break point. To choose a different first break point, enter f (First) and specify the new first break point.
3. Specify the second break point (2).

Command line BREAK
Exploding Objects

Exploding objects converts single objects to their constituent parts but has no visible effect. For example, exploding forms simple lines and arcs from polylines, rectangles, donuts, and polygons. It replaces a block reference or associative dimension with copies of the simple objects that compose the block or dimension. Groups explode into their member objects or into other groups.

To explode an object

1. From the Modify menu, choose Explode.
2. Select the objects to be exploded.

An exploded object doesn't look any different, but the colors, linetypes, and linewidths of objects can change. Component objects of a block assume their original properties.

When you explode a polyline, AutoCAD discards the associated width information. The resulting lines and arcs follow the polyline's centerline. If you explode a block that contains a polyline, you need to explode the polyline separately. However, a nonuniformly scaled block can be exploded during an insert. If you explode a donut, its width becomes 0.

Blocks inserted with unequal $X$, $Y$, and $Z$ scale factors may explode into unexpected objects. You cannot explode xrefs and their dependent blocks. If you explode a block with attributes, the attributes are deleted, but the attribute definitions from which they were created remain. The attribute values and any modifications made by the ATTEDIT command are lost. For more information, see EXPLODE in the Command Reference.

Editing Polylines

You can edit polylines by closing and opening them and by moving, adding, or deleting individual vertices. You can straighten the polyline between any two vertices and toggle the linetype so that a dash appears before and after each vertex. You can set a uniform width for the entire polyline or control the width of each segment. You can also create a linear approximation of a spline from a polyline.

2D and 3D polylines, rectangles, and polygons and 3D polygon meshes are all polyline variants and are edited in the same way. For information about editing 3D polylines and polygon meshes, see “Editing in 3D” on page 639.
To modify a polyline

1. From the Modify menu, choose Polyline.
2. Select the polyline to modify.
3. Choose an option to modify the polyline.

    **Command line**  PEDIT

    **Shortcut menu**  Select the polyline to modify, right-click in the drawing area, and choose Polyline Edit.

    **System variables**  SPLFRAME, SPLINESEGS, and SPLINETYPE control spline-fit polylines.

In the following illustration, each polyline segment has a different start and end width, resulting in a taper.

To taper the width of individual polyline segments

1. From the Modify menu, choose Polyline.
2. Select the polyline to edit.
3. Enter **e** (Edit Vertex).
   The first vertex is marked with a cross.
4. Enter **w** (Width).
5. Enter different start and end widths.
   Press ENTER to move to the next vertex or enter **n** (Next).
6. Repeat steps 4 through 6 for each segment.
7. Enter **x** (Exit) to apply the new widths to all segments.

    **Related**  PFACE creates polyface meshes.
**Editing Fit and Spline Polylines**

AutoCAD recognizes both fit polylines and spline-fit polylines. A *spline-fit polyline* uses a curve fit, similar to a B-spline. There are two kinds of spline-fit polylines, *quadratic* and *cubic*. Both of these polylines are controlled by the SPLINETYPE system variable. A *fit polyline* uses standard curves for curve fit and utilizes any tangent directions set on any given vertex. You can change the splined polyline back to a polyline using the Decurve option. The illustration shows a polyline edited with the Spline option.

![Polyline](image1.png)

However, some editing actions, such as trimming, breaking, and any grip editing, remove the spline definition of a fit or splined polyline. For this reason, it is better to use a true spline, which maintains its spline definition.

**Joining Polylines**

You can join a line, arc, or other polyline to an open polyline if their ends touch. If a line crosses the end of a polyline in a T shape, the objects can’t be joined. If two lines meet a polyline in a Y shape, AutoCAD selects one of the lines and joins it to the polyline. Joining also causes an implicit decurve, with AutoCAD discarding the spline information of the original polyline and any polylines being joined to it. Once the joining is completed, you can fit a new spline to the resulting polyline.
Editing Multilines

You can edit a multiline by adding and deleting vertices and controlling the display of corner joints. You can make multilines intersect in various ways. You can also edit multiline styles to change the properties of individual line elements or the end caps and background fill of future multilines.

Adding and Deleting Multiline Vertices

You can add or delete any vertex in a multiline. In the following example, you delete a vertex from a multiline. Adding vertices works similarly.

To delete a vertex from a multiline

1. From the Modify menu, choose Multiline.
2. In the Multiline Edit Tools dialog box, select Delete Vertex (in the bottom row of images), and then choose OK.
3. In the drawing, specify the vertex to delete and press ENTER.

Command line MLEDIT

Related -MLEDIT edits multilines from the command line.

Editing Multiline Intersections

If you have two multilines in a drawing, you can control the way they intersect. Multilines can intersect in a cross or a T shape, and the crosses or T shapes can be closed, open, or merged.

- closed cross
- open T
- merged cross
To create a closed cross intersection

1. From the Modify menu, choose Multiline.
2. In the Multiline Edit Tools dialog box, click Closed Cross (in the top row of images), and then choose OK.
3. Select the multiline for the foreground.
4. Select the multiline for the background.

The intersection is modified. You can continue selecting intersecting multilines to modify, or press ENTER to end the command. Press ENTER again to redisplay the Multiline Edit Tools dialog box.

Editing Multiline Styles

Multiline styles control the number of line elements in a multiline and the color, linetype, linewidth, and offset from the multiline origin of each element. You can change any of these properties. You can also modify the display of joints, end caps, and background fill. A modified multiline style retains the changes permanently.

You cannot edit the element and multiline properties of the STANDARD multiline style or any multiline style being used in the drawing. If you try to edit the options in either the Element Properties dialog box or the Multiline Properties dialog box, the options are unavailable. To edit an existing multiline style, you must do so before you draw any multilines in that style.

If you use MLSTYLE to create a multiline style without saving it, and then select another style or create a new style, the first MLSTYLE properties are lost. To maintain the properties, save each multiline style to an MLN file before creating a new one.

In the following example, you delete a line element, modify the angle of the end cap lines, and change the background fill of a multiline.

To edit a multiline style

1. From the Format menu, choose Multiline Style.
2. In the Multiline Styles dialog box, choose the style name from the list. Choose a style with more than two elements.
3. Choose Element Properties.
4. In the Element Properties dialog box under Elements, select the line element to delete, select Delete, and choose OK.
5. In the Multiline Styles dialog box, choose Multiline Properties.
6. In the Multiline Properties dialog box under Caps, enter the new angle for the start and end cap lines.
Chapter 9 Editing Methods

7 Under Fill, choose Color and select a new color from the Select Color dialog box, and then choose OK twice.
8 In the Multiline Styles dialog box, choose Save to save the changes to the style in the MLN file.
9 Choose OK to save the modified symbol table entry and exit the dialog box.

Command line MLSTYLE

Editing Splines

You can delete fit points of a spline, add fit points for greater accuracy, or move fit points to alter the shape of a spline. You can open or close a spline and edit the spline start and end tangents. Spline direction is reversible. You can change the tolerance of the spline also. Tolerance refers to how closely the spline fits the set of fit points you specify. The lower the tolerance, the more closely the spline fits the points.

You can refine a spline by increasing the number of control points in one portion of the spline or by changing the weight of specific control points. Increasing the weight of a control point pulls the spline more towards that point. You can also refine a spline by changing its order. A spline’s order is the degree of the spline polynomial + 1. A cubic spline, for example, has order 4. The higher a spline’s order, the more control points it has.

Consider the following example. You have created a spline to represent a geographic contour. Grips are turned on, and you need to move the fourth fit point to increase accuracy. When you select the spline, grips appear at the control points. If you created the spline by fitting it through a set of points, and you haven’t purged this information using the Purge option of the SPLINEDIT command, and you select the Fit Data option, grips appear at the fit points on the selected spline instead of at the control points.
To move a spline fit point

1. From the Modify menu, choose Object ➤ Spline.
2. Select the spline.
3. Enter f (Fit Data).
4. Enter m (Move Vertex).
5. Repeatedly enter n (Next) to select the next vertex until you get to the highlighted control point that you want to move.
6. Move the vertex with the pointing device or by entering the coordinate of the new location.
7. Enter x three times to exit the command.

If any three consecutive control points are located at the same position, bad data is created. In this situation, it is not possible to calculate a tangent at that position. AutoCAD can only offset curves that have a nonzero-length tangent vector at each point.

Command line SPLINEDIT
Shortcut menu Select the spline to modify, right-click in the drawing area, and choose Spline Edit.

Chamfering Objects

Chamfering connects two nonparallel objects by extending or trimming them to intersect or to join with a beveled line. You can chamfer lines, polyline, xlines, and rays. With the distance method, you specify the amount that each line should be trimmed or extended. With the angle method, you can also specify the length of the chamfer and the angle it forms with the first line. You can retain the objects as they were before the chamfer or trim or extend them to the chamfer line.
If both objects being chamfered are on the same layer, the chamfer line goes on that layer. Otherwise, the chamfer line goes on the current layer. The same rules apply to chamfer color, linetype, and lineweight.

If no intersection point is within the drawing limits and if limits checking is turned on, AutoCAD rejects the chamfering. For information about chamfering solids, see chapter 17, “Working in Three-Dimensional Space.”

**Chamfering by Specifying Distances**

The chamfer distance is the amount each object is trimmed or extended to meet the chamfer line or to intersect the other object. If both chamfer distances are 0, chamfering trims or extends the two objects until they meet but does not draw a chamfer line.

The default setting for the first distance is the last distance specified. The default setting for the second distance is whatever you choose for the first distance, because symmetrical distances are common. However, you can reset the chamfer distances.

In the following example, you set the chamfer distance to 0.5 for the first line and 0.25 for the second line. After you reset the distances, you are returned to the Command prompt.
To chamfer by specifying distances

1. From the Modify menu, choose Chamfer.
2. Enter d (Distance).
3. Enter the first chamfer distance.
4. Enter the second chamfer distance.
5. Press ENTER to reenter the CHAMFER command.
6. Select the lines for chamfering.

**Command line**  CHAMFER

**System variables**  Set CHAMMODE to 0 for the distance method. CHAMFERA and CHAMFERB store the first and second chamfer distances.

To chamfer two nonparallel lines

1. From the Modify menu, choose Chamfer.
2. Set the chamfer distances.
3. Select the first line.
4. Select the second line.

**Command line**  CHAMFER

**Chamfering by Specifying Length and Angle**

You can chamfer two objects by specifying where on the first selected object the chamfer line starts. Then specify the angle the chamfer line forms with this object. In the following example, you chamfer two lines so that the chamfer line starts 1.5 units along the first line and forms an angle of 30-degrees with this line.
To chamfer by specifying chamfer length and angle

1. From the Modify menu, choose Chamfer.
2. Enter a (Angle).
3. Enter the chamfer length.
4. Enter the chamfer angle.
5. Press ENTER to reenter the CHAMFER command.
6. Select the first line and then the second line.

**System variables**  Set CHAMMODE to 1 for the angle method. CHAMFERC stores the chamfer length. CHAMFERD stores the chamfer angle.

**Trimming Chamfered Objects**

By default, objects are trimmed when chamfered, but you can use the Trim option to specify that they remain untrimmed.

To chamfer without trimming

1. From the Modify menu, choose Chamfer.
2. Enter t (Trim).
3. Enter n (No Trim).
4. Select the first line and then the second line.
   The chamfered object is untrimmed.

**System variables**  Set TRIMMODE to 1 to trim the objects after chamfering. Set it to 0 to leave the objects untrimmed. A new setting takes effect with the next chamfer.

**Chamfering Polylines and Polyline Segments**

If the two objects you select are segments of a polyline, they must be adjacent or separated by one arc segment.

You can chamfer an entire polyline so each intersection is chamfered. For best results, keep the chamfer distances equal. In the following example, you chamfer a closed polyline by setting both chamfer distances to equal values.
To chamfer an entire polyline

1. From the Modify menu, choose Chamfer.
2. Enter p (Polyline).
3. Select the polyline.

   The polyline is chamfered using the current chamfer method and the default distances or angle.

When you chamfer an entire polyline, AutoCAD chamfers only the segments that are long enough to accommodate the chamfer distance. In the following illustration, some polyline segments were too short to be chamfered.

Chamfers added to a polyline become new segments of that polyline, even if the chamfer distance is 0.
Filleting Objects

Filleting connects two objects with a smoothly fitted arc of a specified radius. Although an inside corner is called a fillet and an outside corner is called a round, AutoCAD treats both as fillets.

If both objects being filleted are on the same layer, the fillet line goes on that layer. Otherwise, the fillet line goes on the current layer. The same rules apply to fillet color, linetype, and linewidth.

You can fillet pairs of line segments, polyline line (not arc) segments, splines, xlines, rays, circles, arcs, and true (not polygon) ellipses. Lines, xlines, and rays can be filleted when parallel. You can fillet every vertex of a polyline at the same time. You can fillet a combination of lines and polylines and all true solids. See chapter 17, “Working in Three-Dimensional Space.”

Setting the Fillet Radius

The fillet radius is the radius of the arc that connects filleted objects. By default, the fillet radius is 0.500 or the last radius set. Changing the radius affects subsequent fillets but not existing ones.

To set the fillet radius

1. From the Modify menu, choose Fillet.
2. Enter r (Radius).
3. Specify the fillet radius.
4. Press ENTER to reenter the FILLET command.
5. Select the objects to fillet.

System variables

FILLETRAD stores the current fillet radius.
The following example shows two filleted line segments.

![Diagram of two filleted line segments](image)

**To fillet two line segments**
1. From the Modify menu, choose Fillet.
2. Select the first line.
3. Select the second line.

**Command line**  
FILLET

**Trimming Filleted Objects**
By default, all objects except circles, full ellipses, closed polylines, and splines are trimmed when filleted. You can use the Trim option to specify that filleted objects remain untrimmed.

![Diagram of two filleted lines with Trim option set](image)

**To fillet without trimming**
1. From the Modify menu, choose Fillet.
2. Enter t (Trim).
3. Enter n (No Trim).
4. Select the first line and then the second line.
   The filleted object is untrimmed.

**System variables**  
Set TRIMMODE to 0 to leave the objects untrimmed. A new setting takes effect with the next fillet.
Filleting Circles and Arcs

You fillet circles and arcs in the same way as lines. Depending on the points you specify, more than one possible fillet can exist between the objects. AutoCAD chooses the endpoints closest to the points you use to select the objects. Compare the following fillets.

Filleting Line and Polyline Combinations

For you to fillet line and polyline combinations, the line must intersect (or intersect when extended) one of the polyline’s line segments. If the Trim option is turned on, the filleted objects and fillet arc join to form a single new polyline.

The illustration shows a fillet of a line and polyline with a fillet radius of 0.25 and the Trim option on.
**Filleting an Entire Polyline**

You can fillet an entire polyline or remove fillets from a polyline. The polyline can contain arc segments, which have the same fillet radius as line segments in the polyline.

If you set a nonzero fillet radius, AutoCAD inserts fillet arcs at each vertex where two line segments meet if the segments are long enough to accommodate the fillet radius.

![polyline selected for filleting](image1)

![result](image2)

**To fillet an entire polyline**

1. From the Modify menu, choose Fillet.
2. Enter `p` (Polyline).
3. Select the polyline.

If two polyline line segments are separated by one arc segment and the two line segments converge as they approach the arc segment, AutoCAD removes the arc segment and replaces it with a fillet arc.

![polyline selected for filleting](image3)

![result—fillet arc replaces arc segment](image4)

If you set the fillet radius to 0, no fillet arcs are inserted. If two polyline line segments are separated by one arc segment, AutoCAD removes that arc and extends the lines until they intersect.
This method provides a quick way to join two endpoints. However, if the lines do not converge as they approach the arc segment, no change occurs.

**Filleting Parallel Lines**

You can fillet parallel lines, xlines, and rays. Because two parallel lines uniquely determine a plane, the fillet arc is placed on that plane. The first selected object must be a line or ray, but the second object can be a line, xline, or ray. The fillet arc connects as shown in the following illustration.

![Polyline selected for filleting](image1)  ![Result—zero radius fillet replaces arc segment](image2)

The diameter of the fillet arc is always equal to the distance between the parallel lines. The current fillet radius is ignored and remains unchanged.

**Editing Hatches**

You can edit both hatch boundaries and hatch patterns. If you edit the boundary of an associative hatch, the pattern is updated as long as the editing results in a valid boundary (see “Editing Hatch Boundaries and Patterns” on page 309). Associative hatches are updated even if they’re on layers that are turned off. You can modify hatch patterns or choose a new pattern for an existing hatch. You also can explode a hatch (see EXPLODE in the Command Reference).

**WARNING!** Editing multiple associative hatch blocks can produce unpredictable results. For best results when editing hatched geometry, edit the boundary.
Selection of associative hatches and their boundaries depends on the setting of the PICKSTYLE system variable. To select an associative hatch without its associated boundary, set PICKSTYLE to 0 or 1. To select an associative hatch with its boundary, set PICKSTYLE to 2 or 3.

**Removing Hatch Associativity**

You can use the HATCHEDIT command to remove hatch associativity at any time.

**To remove hatch associativity**

1. From the Modify menu, choose Hatch.
2. Select an associative hatch object.
3. In the Hatch Edit dialog box, choose the Advanced tab.
4. Under Composition, choose Nonassociative.

**Command line**  HATCHEDIT

**Shortcut menu**  Select an associative hatch object, right-click in the drawing area, and choose Hatch Edit.

**Editing Hatch Boundaries and Patterns**

Hatch boundaries can be copied, moved, stretched, and so on. Associative hatches are updated to match any changes made to their boundaries. Non-associative hatches are not updated.

If you select a hatch pattern itself when editing its boundary geometry, the hatch pattern will disassociate unless the entire boundary is selected. If you want the hatch pattern to remain associative, you must select only the boundary geometry, not the hatch pattern.

If you delete the interior boundary geometry of an associative hatch, the hatch automatically updates. If all or part of the exterior boundary geometry is deleted, the hatch always disassociates. When you copy the polyline boundary of a hatch created with the Retain Boundaries option selected, the polyline is copied but the original boundary is not.

You can change the angle or spacing of an existing hatch pattern or replace it with a solid fill or one of the predefined patterns that AutoCAD offers. The Pattern option in the Boundary Hatch dialog box displays a list of these patterns. You can also define new hatch patterns. To reduce file size, the hatch object is defined in the drawing as a single graphical object. You can explode hatch patterns into their composite lines using the EXPLODE command.
Changing Existing Hatch Patterns
You can change the angle and spacing of a hatch. In the following example, you change the angle of the hatch.

NOTE  If you edit hatch patterns that were created using a version of AutoCAD that is Release 12 or earlier, associativity is removed from the hatch pattern.

To change the angle of a hatch
1. From the Modify menu, choose Hatch.
2. Select the associative hatch object.
3. In the Hatch Edit dialog box, choose the Quick tab.
4. Under Angle, select a value from the list or enter a new angle.
5. Choose OK.

Command line  HATCHEDIT
Shortcut menu  Select an associative hatch object, right-click in the drawing area, and choose Hatch Edit.

Erasing Hatch Patterns
Select hatch patterns for erasing with any of the standard selection methods. If the hatch is associative and the PICKSTYLE system variable is set to 2 or 3, you will also erase the boundary. If you want to retain the boundary, set PICKSTYLE to 0 or 1.
To erase a hatched area

1. From the Modify menu, choose Erase.
2. Select the hatch pattern to erase.
3. Press ENTER.

**Command line**  
ERASE

**Shortcut menu**  
Select the hatch pattern to erase, right-click in the drawing area, and choose Erase.

**Editing Hatches with Grips**

Using grips, you can stretch, move, rotate, scale, and mirror hatch boundaries and their associated hatches just as you can other objects. If the editing results in a valid boundary, the associative hatch is updated.

See “Editing with Grips” on page 246.

---

**Using Partial Open and Partial Load**

If you work with large drawings, you can use the Partial Open option to select which view and layer geometry (graphical objects only) that you want to work with in a drawing. For example, if you load geometry from the EXTENTS view and the SITE layer, AutoCAD loads into the drawing everything on the SITE layer that falls within the Extents view.

You can only edit and work with what is loaded into the drawing file, but all the drawing's named objects are available in the partially open drawing. Named objects include layers, views, blocks, dimension styles, text styles, viewport configurations, layouts, UCSs, and linetypes. See “Working with Named Objects” on page 157.

By organizing large drawings into sectored views, you can load and edit only what you need. For example, if you work with a city plan and need to edit only the southeast sector (sector D3 in the illustration), you can load this drawing area by specifying the predefined view. If you only need to edit the city plot numbers, you can load just the geometry on this specific layer.
After a drawing is partially open, you can load additional geometry from a view, selected area, or layer into the drawing by using PARTIALOAD. The Partial Open option is available only for drawings in AutoCAD 2000 format.

To partially open a drawing

1. From the File menu, choose Open.
2. In the Select File dialog box, select a drawing file and then choose Partial Open.
3 In the Partial Open dialog box, select a view; the default view is EXTENTS. You can load only geometry from model space views that are saved in the current drawing.

4 Select one or more layers. If you do not select a layer or layers to load, no layer geometry is loaded into the drawing but all drawing layers exist in the drawing. If no layer geometry is specified to load into the drawing, no geometry is loaded even if the geometry from a view is specified to load. If you draw objects on a layer that is not loaded, you may be drawing on top of existing geometry that is not loaded in the drawing.

NOTE Xref-dependent layers are displayed in the Layer Geometry to Load list only if the selected drawing was last saved with the VISRETAIN system variable set to 1. Any layers created in the xref since the xref was loaded into the drawing are not displayed in the Layer Geometry to Load list.

5 If the drawing contains a spatial index, you can select the Use Spatial Index option. A spatial index is a list that organizes objects based on their location in space. AutoCAD uses a spatial index to locate the portion of the drawing that is read; this minimizes the time required to open the drawing.

6 If the drawing contains xrefs but you don’t want to load them, select Unload All Xrefs on Open.

NOTE If you partially open a drawing that contains a bound xref, only the portion of the xref that is loaded (defined by the selected view) is bound to the partially open drawing.

7 Choose Open.

You can choose to load additional information into the current drawing as long as the drawing is partially open.

Command line PARTIALOPEN

Related See OPEN and PARTIALOAD in the Command Reference.
To load additional geometry into a partially open drawing

1. From the File menu, choose Partial Load.
   The Partial Load option is available only if the current drawing is a partially open drawing.

2. In the Partial Load dialog box, select a view or choose Pick Window to define a view.

   ![Partial Load dialog box]

   The default view is Extents. You can load only geometry from model space views that are saved in the current drawing.

3. Select one or more layers.
   If you do not select a layer or layers to load, no layer geometry is loaded into the drawing but all drawing layers exist in the drawing. If no layer geometry is specified to load into the drawing, no geometry is loaded even if the geometry from a view is specified to load. If you draw objects on a layer that is not loaded, you may be drawing on top of existing geometry that is not loaded in the drawing. You cannot unload any geometry that is loaded in the current drawing.

4. Choose Open.

   **Command line** PARTIALOAD