Using Layers and Object Properties

Layers are like transparent overlays on which you organize and group different kinds of drawing information. The objects you create have common properties including colors, linetypes, and lineweights. An object can assume these properties from the layer it is drawn on, or properties can be specifically assigned to individual objects. Color helps you distinguish similar elements in your drawings, while linetypes help you differentiate easily between different drafting elements, such as centerlines or hidden lines. Lineweights represent the size or type of an object through width, enhancing your drawing and increasing legibility. Organizing layers and the objects on layers makes it easier to manage the information in your drawings.
Working with Layers

You always draw on a layer. It may be the default layer or a layer you create. Each layer has an associated color, linetype, linewidth, and plot style. You can use layers to organize drawings into groups of objects as well as to identify different objects with varying colors, linetypes, and linewidths.

For example, you can create a layer for centerlines. You assign the properties you want for centerlines (color, linetype, linewidth) to the layer. When you want to draw a centerline, you switch to the centerline layer and begin drawing. You do not need to specify a linetype, linewidth, and color every time you draw a centerline.

You can also assign a plot style to a layer. Plot styles control how your drawings are plotted. For example, you can plot a drawing with all the centerlines at a 50 percent value (or “screened”) by assigning a plot style to that layer. Using layers is a major advantage of creating drawings with AutoCAD® instead of with paper and pencil.

In a layout (paper space), you can specify layer visibility individually for each viewport. If you do not want to display or plot a certain layer, you can turn off that layer or turn off plotting for that layer. The same drawing limits, coordinate system, and zoom factor apply to all layers in a drawing.

If you consistently use a specific layering scheme, you can set up a template drawing with layers and their associated linetypes, linewidths, colors, and plot styles already assigned. Layers are one of many nongraphical objects saved in a drawing. See “Working with Named Objects” on page 157.

Creating and Naming Layers

You can create and name a layer for each conceptual grouping (such as walls or dimensions) and assign common properties to those layers. By grouping objects into layers, you can control their display and make changes quickly and efficiently.

When you begin a new drawing, AutoCAD creates a special layer named 0. By default, layer 0 is assigned color number 7 (white or black depending upon your background color), the CONTINUOUS linetype, a linewidth of DEFAULT (the default setting for DEFAULT is .01 inch or .25 mm), and the Normal plot style. Layer 0 cannot be deleted or renamed.

You can create new layers and assign color, linetype, linewidth, and plot style properties to those layers. To assign properties to objects individually, see “Using the Object Properties Toolbar” on page 250 and “Using the Properties Window” on page 260.
To create a new layer

1. From the Format menu, choose Layer.

2. In the Layer Properties Manager, choose New.
   A new layer is displayed in the list with the temporary name LAYER1.

3. Enter a new name.

4. To create more than one layer, choose New again, enter the new layer name, and press ENTER.

5. Choose OK.

**Shortcut menu**   Right-click in the layer list in the Layer Properties Manager, and choose New Layer.

Each new layer is numbered sequentially, LAYER1, LAYER2, and so on. You can rename a layer after it is created. The default color assigned to the new layer is color 7 (white or black depending on the background color), and the default linetype is CONTINUOUS. The default lineweight is DEFAULT (the default setting for DEFAULT is .01 inch or .25 mm), and the default plot style is Normal. You can accept the default settings or specify other colors, linetypes, lineweights, and plot styles.
If an existing layer is selected when you create a new layer, the new layer inherits the properties of the selected layer. You can modify the properties of the new layer as necessary.

If you use a specific layering scheme, you can make a copy of the layer list in your drawing and print it out for future reference.

To make a copy of a drawing layer list
1. Enter `-layer` at the Command prompt.
2. To get a list of layers in the current drawing, enter `?`.
3. Press ENTER to select all layers in the current drawing.
   All the layers and layer properties are listed in the AutoCAD text window.
4. In the AutoCAD text window, scroll to the top of the layer list and select all the layers.
5. To copy the layer list, press CTRL+C.
6. Open a text editor and paste the layer list into a text file by pressing CTRL+V.
7. Print the text file.

**Making a Layer Current**

You are always drawing on the current layer. When you make a layer current, you can create new objects on that layer. If you make a different layer current, any new objects you create are created on that new current layer and use its color, linetype, lineweight, and plot style (as long as all the object properties maintain the default setting of BYLAYER). You cannot make a layer current if it is frozen or is an xref-dependent layer.

To make a layer current
1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select a layer and choose Current.
3. Choose OK.

You can also make a layer current by double-clicking its name in the Layer Properties Manager.

**Command line**  `LAYER`

**Shortcut menu**  Right-click a layer name in the Layer Properties Manager and choose Make Current.

**System variables**  `CLAYER` sets the current layer. `-LAYER` changes the current layer from the command line.
Making an Object’s Layer Current

To make the layer that is associated with an object the current layer, select the object and then choose Make Object’s Layer Current on the Object Properties toolbar. The layer of the object you select becomes the current layer. You can also change the current layer by first choosing Make Object’s Layer Current on the Object Properties toolbar and then selecting an object.

Sorting Layers

Once you’ve created layers and assigned them colors, linetypes, lineweights, and plot styles, you can sort layers by property in the Layer Properties Manager. Layers can be sorted by name, visibility properties, color, lineweight, plot style, or linetype. Click the column head to sort layers by the property in that column. Layer names can be sorted in ascending or descending alphabetical order.

Controlling Layer Visibility

AutoCAD does not display or plot the objects drawn on invisible layers. Layers that are frozen or off are invisible in the drawing. If you need an unobstructed view when working in detail on a particular layer or set of layers, you can turn off layers or freeze layers. You can also freeze, turn off layers, or turn off plotting for visible layers if you don’t want to plot certain details such as construction or reference lines.

The method you choose to control a layer’s visibility depends on how you work and the complexity of your drawing. You can freeze layers that you want to be invisible for long periods of time. Frozen layers are not calculated when you regenerate, hide, or render objects. You can turn layers off rather than freeze them if you plan to switch layers frequently from visible to invisible.

You can only plot layers that are on and thawed. You can also control whether the layer is plotted or not plotted.

Turning Layers On and Off

Turned-off layers are regenerated with the drawing but are not displayed or plotted. By turning layers off instead of freezing them, you avoid regenerating the drawing every time you thaw a layer. When you turn a layer on that has been turned off, AutoCAD redraws the objects on that layer.

NOTE  Circles and 2D and 3D surfaces drawn on layers that are off are invisible, but these objects still hide other objects when you use HIDE, RENDER, or SHADEMODE.
To turn a layer on or off

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select the layers you want to turn on or off. From the shortcut menu, you can use Select All to select all layers simultaneously or Select All But Current to select all layers except the current drawing layer. Invert Selection selects all layers not currently selected and Clear All clears all selections. (Right-click to display the shortcut menu.)
3. Click the On/Off icon on or off.
4. Choose OK.

Command line  LAYER

Related  -LAYER turns layers on and off on the command line.

Freezing and Thawing Layers

You can freeze layers to speed up ZOOM, PAN, and VPOINT, improve object selection performance, and reduce regeneration time for complex drawings. AutoCAD does not display, plot, or regenerate objects on frozen layers. Freeze layers that you want to be invisible for long periods. When you “thaw” a frozen layer, AutoCAD regenerates the drawing and displays the objects on that layer.

To freeze or thaw a layer

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select the layers you want to freeze or thaw.
3. Click the Freeze in All Viewports icon to turn it on or off (on to freeze a layer and off to thaw a layer).
Command line  

**Related** - `LAYER` displays the Freeze and Thaw options on the command line. `VPLAYER` freezes and thaws layers in floating viewports (see “Controlling Layer Visibility” on page 319).

**Freezing or Thawing Layers in the Active Viewport**

You can freeze or thaw layers in the active floating viewport without affecting other viewports. (Floating viewports are displayed in layouts; tiled viewports are displayed in model space.) Frozen layers are invisible. They are not regenerated or plotted. This feature is useful, for example, if you want to create an annotation layer that is visible only in a particular viewport. Thawing restores the layer’s visibility (and regenerates the drawing). For more detailed information about defining layer properties for plotting, see “Controlling Visibility in Floating Viewports” on page 534.
To freeze or thaw layers in the active floating viewport

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select the layers to freeze or thaw and choose Show Details.
3. Select or clear Freeze in Active Viewport.
4. Choose OK.

**Command line**  
`LAYER`

**System variables**  
`MAXACTVP` sets the maximum number of floating viewports.

**Related**  
`VPLAYER` freezes and thaws layers in floating viewports.

### Freezing or Thawing Layers in New Viewports

You can set visibility defaults for specific layers in new floating viewports. For example, if all dimensions are on a layer named `DIMENSIONS`, you can restrict the display of dimensions by freezing the `DIMENSIONS` layer in all new floating viewports. If you create a viewport that requires dimensions, you can override the default setting by changing the setting in that viewport. Changing the default for layers in new viewports does not affect layers in existing viewports. For more detailed information about defining layer properties for plotting, see “Controlling Visibility in Floating Viewports” on page 534.

To freeze or thaw layers in new viewports

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select the layers to freeze or thaw and choose Show Details.
3. Select or clear Freeze in New Viewports.
4. Choose OK.

**Command line**  
`LAYER`

**System variables**  
`MAXACTVP` sets the maximum number of floating viewports.

**Related**  
`VPLAYER` freezes and thaws layers in floating viewports.

### Turning Plotting On or Off for a Layer

You can turn plotting on or off for visible layers. If a layer contains reference information only, for example, you can specify that the layer is not plotted. If you turn off plotting for a layer, the layer is displayed but is not plotted.
For example, you can create a layer for construction lines only and specify no plotting. At plot time, you do not have to turn off the layer before you plot the drawing.

To turn plotting on or off for a layer

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select the layers you do or do not want to plot.
3. Click the Plot icon on or off.
4. Choose OK.

Command line

LAYER

Related

-LAYER turns plotting on and off for a layer on the command line.

Locking and Unlocking Layers

Locking layers is useful when you want to edit objects associated with particular layers but also want to view but not edit objects on other layers. You cannot edit or select the objects on a locked layer; however, the objects are still visible if the layer is on and thawed. You can make a locked layer current, and you can draw new objects on the locked layer.

You can also use inquiry commands (such as LIST) and apply object snaps to objects on locked layers. You can freeze and turn off locked layers and change their associated properties.

To lock or unlock layers for editing

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select the layers to lock or unlock.
3. Click the Lock/Unlock icon on or off.
4. Choose OK.

Command line

LAYER

Related

-LAYER locks and unlocks layers on the command line.

Assigning Color to a Layer

You can assign a color to a layer using the Layer Properties Manager. For example, you can assign the color red to a layer named HVAC to help you identify the mechanical equipment in your drawing.
To assign a color to a layer

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select a layer and click the Color icon.
3. In the Select Color dialog box, select a color.
4. Choose OK.

**Command line**  
LAYER

### Assigning a Linetype to a Layer

When you're defining layers, linetypes provide another way to convey visual information. A linetype can be a straight line or a repeating pattern of dashes, dots, and blank spaces that you can use to distinguish the purpose of one line from another.

The linetype name and definition describe the particular dash-dot sequence, the relative lengths of dashes and blank spaces, and the characteristics of any included text or shapes.

To assign a linetype to a layer

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select a layer and then click the linetype associated with that layer.
3 In the Select Linetype dialog box, do one of the following:
   ■ Select a linetype from the list
   ■ Choose Load to load a linetype from a file (see “To load a linetype” on page 333).
4 Choose OK to exit each dialog box.

**Command line**  
**LAYER**

**Assigning a Lineweight to a Layer**

Lineweights add width to your objects. All objects can be displayed and plotted with lineweights except True Type® fonts, raster images, points, and solid fills (or 2D solids). By assigning lineweights to layers and objects, you can represent the width of objects on screen as well as on paper. You can improve the visual quality of your presentation drawings by assigning varying lineweights to objects and layers. AutoCAD provides a number of available lineweights, including DEFAULT, which is the default. The default value of DEFAULT is .01 inch or .25 mm. (This value is set by using the LWDEFAULT system variable or in the Lineweight Settings dialog box.)

**To assign a lineweight to a layer**

1 From the Format menu, choose Layer.
2 In the Layer Properties Manager, select a layer and then click the lineweight associated with that layer.
In the Lineweight dialog box, select a lineweight from the list.

Choose OK to exit each dialog box.

**Command line**  
**LAYER**

**Assigning a Plot Style to a Layer**

AutoCAD 2000 provides a new object property called *plot style* that can change the way a plotted drawing looks. By modifying an object’s plot style, you can override that object’s color, linetype, and lineweight. You can also specify end, join, and fill styles as well as output effects such as dithering, gray scale, pen assignment, and screening. You can use plot styles if you need to plot the same drawing in different ways. Objects in a drawing are associated with the default plot style setting of BYLAYER. Layer 0 defaults to a plot style of NORMAL. A layer that is assigned a NORMAL plot style assumes the properties that have already been assigned to that layer. You can apply plot styles to objects or layers. Plot styles are defined in plot style tables. You can view the current plot style of a selected object, change the plot style of an object, and make a plot style current. However, if the current drawing you are working in is in color-dependent mode (**PSTYLEPOLICY** is set to 1) as opposed to named plot styles mode (**PSTYLEPOLICY** is set to 0), you cannot assign a plot style to a layer. For more information about creating plot styles and plot style tables, see “Using Plot Styles” on page 553.

**To assign a plot style to a layer**

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select a layer and then click the plot style associated with that layer.
3 In the Current Plot Style dialog box, select a plot style from the list.
4 Choose OK to exit each dialog box.

**Command line** LAYER

**Filtering Layers**

Sometimes you may want only certain layers to be listed. For instance, if you are working in a drawing that contains various layers of electrical information, you can limit the layer names displayed in the Layer Properties Manager to those electrical layers. Listing only specific layers makes it easier to select or clear all layers with specific names or properties.

You can filter layers based on

- Names, colors, linetypes, lineweights, and plot styles
- Visibility
- Freeze or thaw status
Locked or unlocked status
Plot or don’t plot status
Whether the layer contains objects or does not contain objects
Dependency on externally referenced (xref) drawings

To filter layers based on layer properties

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager under Named Layer Filters, choose the [...] button.
3. In the Named Layer Filters dialog box, select or enter layer property settings.
4. Enter a name in Filter Name to save the filter.
5. Choose Close.
6. In the Layer Properties Manager, choose the filter from the Named Layer Filters list.

Command line  LAYER

Shortcut menu  Right-click the list in the Layer Properties Manager and choose Layer Filters.

For layer names, colors, linetypes, lineweights, and plot styles, you can enter a specific name or you can use a combination of wild-card symbols, numbers, or characters to filter similarly named objects all at once. See the table “Valid wild-card characters” on page 160.
You can filter layers by using wild-card searches. For example, if you want to display only layers that start with the word `mech`, you can enter `mech*` in the Named Layer Filters list, and then press ENTER.

You can also filter layers inversely, which is useful for viewing layers containing all but one property. For example, if all the site plan information for a drawing is contained in multiple layers that include the word `site` as a part of the layer names, you can easily display all information except site plan information by filtering for `*SITE*` in the Layer Name option and selecting Invert Filter in the Layer Properties Manager. You can also right-click the layer list and choose Invert Layer Filter.

The Named Layer Filters list displays default filters and any named filters that you create and save in the current drawing. Three default filters are displayed in the Named Layer Filters list:

- **Show All Layers**: Displays all the layers in the current drawing.
- **Show All Used Layers**: Displays all the layers on which objects in the current drawing are drawn.
- **Show All Xref Dependent Layers**: Displays all the layers being referenced from another drawing.

Once you have saved a filter, it is displayed in the Named Layer Filters list in the Layer Properties Manager. Saved filters are stored in the drawing file. The new filter name is displayed in the Named Layer Filters list in the Layer Properties Manager or when you choose Named Filters from the shortcut menu. You can use the filter anytime you are working in the drawing it was created in.

### Renaming Layers

You may want to rename a layer to better define how it's used in your drawing. You can rename a layer at any time during a drawing session. You cannot rename layer 0 or an xref-dependent layer.

#### To rename a layer

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select a layer to rename, select the layer name, and enter the new name.
3. Choose OK.

**Related**

`RENAME` renames a layer. `-RENAME` renames a layer on the command line.
Deleting Layers

You can delete a layer at any time during a drawing session. You cannot delete the current layer, layer 0, an xref-dependent layer, or a layer that contains objects.

NOTE Layers referenced by block definitions, along with the special layer named DEFPOINTS, cannot be deleted even if they do not contain visible objects.

To delete a layer

1. From the Format menu, choose Layer.
2. In the Layer Properties Manager, select one or more layers, and then choose Delete.
3. Choose OK.

Related PURGE deletes layers that are not used in a drawing.

Using Layer Properties

You can assign properties to layers as well as to individual objects in a drawing. When you draw on a layer, the default setting for new objects is BYLAYER for color, linetype, lineweight, and plot style. Objects with a BYLAYER setting for any property assume the property of the layer upon which they are drawn. For example, if you draw on a layer assigned the color green, the linetype CONTINUOUS, the lineweight 0.25 mm, and the plot style Normal, the object drawn has all these properties. Using the default object property setting of BYLAYER for color, linetype, lineweight, and plot style helps to maintain an organized drawing. If you organize your layers in conceptual groupings (such as bolts, washers, or part numbers), you can easily recognize an object by the properties of its layer.

If you want a specific object to have a different color, linetype, lineweight, or plot style than the layer it is drawn on, you can change the object property setting. An object property can be set to a specific property value (such as red for color) or to a setting of BYLAYER or BYBLOCK. The object-specific property setting overrides the layer property settings unless the value is set to BYLAYER. See “Using the Object Properties Toolbar” on page 250 and “Using the Properties Window” on page 260.

If you choose BYBLOCK as an object property setting, new objects are drawn with the default property setting until they are grouped into a block. When objects are grouped into a block, the objects in the block inherit the property settings of the layer the block is inserted on.
For example, a block named CHAIR is made up of two objects, the seat and the back of the chair. The seat object is drawn on a layer named SEAT and the back object is drawn on a layer named BACK. The block CHAIR is inserted on a layer named CHAIR that is assigned the color magenta. If the layers SEAT and BACK are assigned a color setting of BYLAYER, each object is displayed with the color assigned to its layer, regardless of the layer the block is inserted on. If the layers SEAT and BACK are assigned a color setting of BYBLOCK, each object is displayed with the color assigned to the layer that the block is inserted on (all objects in the block CHAIR are displayed as magenta). See “Working with Blocks” on page 444.

**Working with Colors**

You can assign colors to layers as well as to individual objects in a drawing. Each color is identified by a name or an AutoCAD Color Index (ACI) number. The ACI number is an integer from 1 through 255. Any number of objects and layers can have the same color number. You can assign each color number to a different pen in a pen plotter or use the color numbers to identify certain objects in the drawing. All previous versions of AutoCAD support ACI Color options. You can now use plot styles to control the color of objects when you plot a drawing. See “Using Plot Styles” on page 553.

**Specifying Colors**

When specifying a color, you can enter the name of the color or its ACI number. Standard color names are available for ACI colors 1 to 7.

<table>
<thead>
<tr>
<th>Colors 1 to 7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color number</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
</tbody>
</table>

The default color is 7, black or white (depending on the background color). All other colors must be specified by an ACI number (8 through 255).
Setting the Current Color

You can assign a color to a layer, set the current color for new objects that you create (including BYLAYER or BYBLOCK), or change the color of existing objects in your drawing. To use a color to draw, you must choose a color and make it current. All newly created objects are drawn using the current color. See “To assign a color to a layer” on page 324. For information about changing the color of existing objects, see “Using the Object Properties Toolbar” on page 250 and “Using the Properties Window” on page 260.

To make a color current

1. From the Format menu, choose Color.
2. In the Select Color dialog box, select a color name or enter a color number in the Color box.
3. Choose OK.

**Command line**  COLOR, LAYER

**System variables**  CECOLOR sets the color for new objects on the command line.
Working with Linetypes

A linetype is a repeating pattern of dashes, dots, and blank spaces. A complex linetype is a repeating pattern of symbols along with dashes, dots, and blank spaces. The linetype name and definition describe the particular dash-dot sequence, the relative lengths of dashes and blank spaces, and the characteristics of any included text or shapes. You can create your own linetypes.

Examples of linetypes

To use a linetype you must first load it into your drawing. A linetype definition must exist in an LIN library file before a linetype can be loaded into a drawing.

To load a linetype

1. From the Format menu, choose Linetype.
2. In the Linetype Manager, choose Load.
In the Load or Reload Linetypes dialog box, select one or more linetypes to load and then choose OK.

To select or clear all linetypes simultaneously, right-click the linetypes list and choose Select All or Clear All from the shortcut menu.

The linetypes you select are displayed in the linetype list in the Linetype Manager and in the Linetype control on the Object Properties toolbar.

Choose OK.

**Command line**  LINETYPE

**Related**  -LINETYPE loads a linetype on the command line.

**WARNING!** The linetypes used internally by AutoCAD should not be confused with the hardware linetypes provided by some plotters. The two types of dashed lines produce similar results. Do not use both types at the same time, however, because the results can be unpredictable.

### Making a Linetype Current

You can assign a linetype to a layer, set the current linetype for new objects that you create (including BYLAYER or BYBLOCK), or change the linetype of existing objects in your drawing. All newly created objects are drawn using the current linetype (except for text and inserted blocks). You must choose a linetype and make it current if you want new objects (except text and inserted blocks) to be drawn with a new linetype. See “To assign a linetype to a layer” on page 324. For information about changing the linetype of existing objects, see “Using the Object Properties Toolbar” on page 250 and “Using the Properties Window” on page 260.

**NOTE**  Xref-dependent linetypes cannot be made current.

**To make a linetype current for objects**

1. From the Format menu, choose Linetype.
2. In the Linetype Manager, select a linetype and choose Current.
3. Choose OK.

**Command line**  LINETYPE, LAYER

**System variables**  CELTYPE sets the linetype for new objects.

**Related**  -LINETYPE changes the current linetype.
Renaming Linetypes

You may want to rename a linetype to better identify how it’s used. You can rename a linetype at any time during the drawing session.

When you rename a linetype, you rename only the linetype definition in your drawing. The name in the LIN library file is not updated to reflect the new name.

**NOTE** You cannot rename linetypes BYLAYER, BYBLOCK, or CONTINUOUS or xref-dependent linetypes.

Linetypes can be sorted by name and description. When linetypes are sorted, BYLAYER and BYBLOCK always appear at the top of the list. Linetype names can be sorted in ascending or descending alphabetical order.

To rename a linetype

1. From the Format menu, choose Linetype.
2. In the Linetype Manager, select a linetype to rename, select the name, and then enter a new name.
3. Choose OK.

**Command line** LINETYPE

**Related** RENAME

Displaying Linetypes

You can associate linetypes with all AutoCAD objects, but they are not displayed with text, points, viewports, xlines, rays, 3D polylines, and blocks. If a line is too short to hold at least one dash sequence, AutoCAD draws a continuous line between the endpoints.

Short hidden and center linetypes continuous between endpoints
Displaying Polyline Linetypes

You can specify whether a linetype pattern is centered on each segment or continuous throughout the entire length of a 2D polyline. You do this by setting the PLINEGEN system variable. Compare the following illustrations.

PLINEGEN = 0

linetype centered on each 2D polyline segment

PLINEGEN = 1

linetype continuous throughout the 2D polyline

The linetype is plotted the way it is displayed in the drawing.

To set the linetype display of existing 2D polylines

1. On the command line, enter plinegen.
2. Enter 1 to make the linetype continuous throughout the 2D polyline. Enter 0 to center the linetype on each segment.

To change the linetype display of existing 2D polylines

1. From the Modify menu, choose Properties.
2. Select the 2D polyline whose linetype display you want to change.
3. In the Properties window, select the linetype generation property and choose Enable. (Linetype is continuous for 2D polylines.)
4. Choose OK.

Command line  PROPERTIES

Shortcut menu  Select the 2D polyline, right-click in the drawing area, and choose Properties.

Related  PEDIT changes the polyline linetype display.

Deleting Linetypes

You can delete a linetype at any time during a drawing session; however, some linetypes cannot be deleted, including BYLAYER, BYBLOCK, CONTINUOUS, the current linetype, xref-dependent linetypes, and linetypes that are being used by objects in the drawing. Also, linetypes referenced by block definitions cannot be deleted, even if they contain no visible objects.
**NOTE** When a linetype is deleted in the Linetype Manager, it is deleted from the current drawing and not from the LIN library file.

To delete a linetype

1. From the Format menu, choose Linetype.
2. In the Linetype Manager, select one or more linetypes, and then choose Delete.
3. Choose OK.

**Command line**  LINETYPE

**Related**  PURGE deletes linetypes that are not used in a drawing.

**Changing Linetype Descriptions**

Linetypes can have a description associated with them. The description provides an ASCII representation of the linetype (which can include standard alphanumeric text characters). You can assign or change a linetype description in the Linetype Manager.

To change a linetype description

1. From the Format menu, choose Linetype.
2. In the Linetype Manager, select a linetype and choose Show Details.
3. In the Details section under Description, enter a new description for the linetype.
4. Choose OK.

**Filtering Linetypes**

Sometimes you may want only certain linetypes to be listed. You can use the Filter option to limit which linetypes are displayed in the Linetype Manager. You can filter linetypes based on whether they’re currently in use or whether they’re xref-dependent.

To filter a linetype

1. From the Format menu, choose Linetype.
2. In the Linetype Manager under Linetype Filters, choose a linetype filtering option.
3. Choose OK.
Specifying Global Linetype Scale

You can set the global linetype scale for objects that you create. The smaller the scale, the more repetitions of the pattern are generated per drawing unit. By default, AutoCAD uses a global linetype scale of 1.0 in the current drawing units.

Objects with different linetype scales

To set the linetype scale for new objects
1. From the Format menu, choose Linetype.
2. In the Linetype Manager, choose Show Details.
3. Under Details, enter the global scale factor and current object scale.
The global scale factor changes the scale factor for all new and existing linetypes. The current object scale modifies the linetype scale of any subsequently drawn objects relative to the current global scale setting.

4 If you use International Standards Organization (ISO) standards, specify the ISO pen width by selecting a width from the list. The ISO pen width sets the linetype scale to one of a list of standard ISO values. The resulting scale is the global scale factor multiplied by the object’s scale factor. The ISO pen width list is available only for ISO linetypes. To activate the ISO pen width setting, the linetype must be set to current.

NOTE ISO linetypes are scaled larger than non-ISO linetypes. ISO linetypes are for use in metric drawings with an appropriate ISO pen-width setting.

5 To activate paper space linetype scaling, select Use Paper Space Units. When Use Paper Space is selected, AutoCAD automatically adjusts the scaling of linetypes in floating viewports. See “Scaling AutoCAD Linetypes in Paper Space” on page 539 or see the PSLTSCALE system variable in the Command Reference.

6 Choose OK.

Command line LINETYPE

System variables CELTSCALE sets the linetype scale for newly created objects. LTSCALE globally changes the linetype scale of existing objects as well as new objects. PSLTSCALE controls scaling of linetypes in paper space.

Working with Lineweights

Lineweights add width to your objects, both on screen and on paper. Using lineweights, you can create heavy and thin lines to show cuts in sections, depth in elevations, dimension lines and tick marks, and varying object thicknesses in details. By assigning varying lineweights to different layers, you can easily differentiate between new, existing, and demolition construction. Just as heavy and thin lead weights are used in manual drafting, lineweights can be used to graphically represent different objects and types of information. You should not use lineweights, however, to represent the exact width of an object. For example, if you want to draw an object with a real-world width of 0.5 inches, you should not use a lineweight; instead, use a polyline with a width of 0.5 inches to represent the object accurately.
Objects with a lineweight plot with the exact width of the assigned lineweight value. Lineweight values consist of standard settings including BYLAYER, BYBLOCK, and DEFAULT. Values are displayed in either inches or millimeters, with millimeters being the default. DEFAULT is the default value for layers. For information on the DEFAULT lineweight value, see “Using the Default Lineweight” on page 342. A lineweight value of 0 is displayed as one pixel in model space and plots at the thinnest lineweight available on the specified plotting device. Any object with a lineweight of 0.01 inches (0.025 mm) or less is displayed with a width of one pixel in model space. Lineweight values that you enter on the command line are rounded to the nearest predefined value.

You can export drawings to other applications or cut objects to the Clipboard and retain lineweight information. You can also set the lineweight units and the default value in the Lineweight Settings dialog box. You can access the Lineweight Settings dialog box by using the LWEIGHT command, right-clicking the LWT button on the status bar and choosing Settings, or choosing Lineweight Settings on the Display tab in the Options dialog box.

**NOTE** If you save an AutoCAD drawing in the format for a previous release, the drawing preview displays lineweights even though the pre-AutoCAD 2000 drawing does not display lineweights.

**System variables**  
- LWUNITS sets the units in which lineweight is displayed and applied to newly created objects and layers, millimeters or inches. LWEIGHT sets the default value of DEFAULT for lineweights.

The following table shows the valid lineweight values used in AutoCAD (not including the values of BYLAYER, BYBLOCK, DEFAULT, and 0) as well as associated industry standards. You can also customize lineweights to plot at whatever value you want by using the Plot Style Table Editor.

<table>
<thead>
<tr>
<th>Lineweight</th>
<th>Millimeters</th>
<th>Inches</th>
<th>Points</th>
<th>Pen size</th>
<th>ISO</th>
<th>DIN</th>
<th>JIS</th>
<th>ANSI</th>
</tr>
</thead>
<tbody>
<tr>
<td>.05</td>
<td>.002</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>.09</td>
<td>.003</td>
<td>1/4 pt.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>.13</td>
<td>.005</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>.15</td>
<td>.006</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Customizing Lineweights

You can also plot objects in your drawing with custom lineweight values. Use the Plot Style Table Editor to adjust the fixed lineweight values to plot at a new value. See “Editing Lineweights” in chapter 16, “Plotting Your Drawings.”
Using the Default Lineweight

DEFAULT is the default lineweight setting for new layers in a drawing. The default setting for this value is 0.01 inches or 0.25 mm. DEFAULT is controlled by the LWDEFAULT system variable. The default setting for DEFAULT is the default value for plotting objects in earlier releases of AutoCAD (pen table settings were not customized). All values equal to or lesser than 0.01 inches or 0.025 mm default to a display value of one pixel when the lineweight display scale is not adjusted. If DEFAULT is changed to a value higher than 0.01 in. or 0.025 mm, the display value is also increased in pixels and AutoCAD display regeneration time increases. See “Displaying Lineweights” on page 343.

Making a Lineweight Current

You can assign a lineweight to a layer, set the current lineweight for new objects that you create (including BYLAYER or BYBLOCK), or change the lineweight of existing objects in your drawing. To use a lineweight to draw, you must choose a lineweight and make it current. All newly created objects are drawn using the current lineweight. Objects in drawings created in an earlier release of AutoCAD are assigned the lineweight value of BYLAYER, with all layers defaulting to a lineweight value of DEFAULT. Lineweight assigned to objects is displayed as a solid fill drawn in the object’s assigned color. All objects except True Type fonts, raster images, points, and solid fills (2D solids) can display lineweight. Floating viewports can only display lineweight if you clip them to another object, such as a polyline. For information about clipping floating viewports to objects, see “Creating Nonrectangular Viewports” on page 542. Polylines with width only display lineweights when the polyline has a non-zero thickness value and is being viewed in a view other than Plan. In general, polylines with width override any width value applied by a lineweight.

NOTE Lineweight applied to the frames of raster images is displayed. The internal contents of raster images cannot display lineweights.

See “To assign a lineweight to a layer” on page 325. For information about changing the lineweight of existing objects, see “Using the Object Properties Toolbar” on page 250 and “Using the Properties Window” on page 260.
To make a lineweight current for creating objects

1. From the Format menu, choose Lineweight.

2. In the Lineweight Settings dialog box, select a lineweight.

3. Choose OK.

Command line  LWEIGHT, LAYER

System variables  CELWEIGHT sets the lineweight for new objects on the command line.

Related  -LWEIGHT changes the current lineweight.

Displaying Lineweights

Lineweights are displayed differently in model space than in a paper space layout. In model space, lineweights are displayed in relation to pixels. In a paper space layout, lineweights display in the exact plotting width. Lineweights should be used for the graphic representation of different objects and types of information, and are, therefore, displayed in model space in proportional pixel values. You can recognize that an object has a thick or thin lineweight in model space but the lineweight does not represent an object’s real-world width. A lineweight of 0 will always be displayed on screen with the minimum display width of one pixel. All other lineweights are displayed using a pixel width in proportion to its real-world unit value.
In model space, lines displaying lineweights that are joined (two consecutive lines) form a beveled joint with no end caps. A beveled joint merges the two lines at a slant to fit them together. End caps are styles that can be applied to the endpoints of lines like round caps or butt caps. You can use plot styles to apply different joins and end cap styles to objects with lineweights. See “Editing Plot Styles” on page 562.

**NOTE** Use REGEN or REGENALL to display the joins of objects with lineweight correctly.

Lineweights display in model space does not change with the zoom factor. For example, a lineweight value that is represented by a width of four pixels is always displayed using four pixels regardless of how far you zoom into your drawing.

You can set the display scale of lineweights if you want the lineweights on objects to appear thicker or thinner in the Model tab. Changing the display scale does not affect the lineweight plotting value. However, AutoCAD regeneration time increases with lineweights that are represented by more than one pixel. If the display scale is not adjusted, all lineweight values that are less than or equal to 0.01 in. or 0.25 mm are displayed at one pixel and do not slow down performance in AutoCAD. If the lineweight display scale is adjusted, the values represented by one pixel change. If you want to optimize AutoCAD performance when working in the Model tab, set the lineweight display scale to the minimum value or turn off lineweight display altogether.

**To set the display scale of lineweights in the Model tab**

1. From the Format menu, choose Lineweight.
In the Lineweight Settings dialog box, under Adjust Display Scale, move the slider to change the scale. If you move the slider to the right, lineweights are displayed at a larger scale in the Model tab. If you move the slider to the left, lineweights are displayed at a smaller scale in the Model tab. The Lineweight list displays the line-weights at the current display scale.

Choose OK.

Shortcut menu Right-click Lwt on the status bar and choose Settings.

In layouts and plot preview, lineweights are displayed in real-world units, exactly as they are plotted, and lineweight display changes with the zoom factor. On the Plot Settings tab in the Plot dialog box, you can control line-weight plotting in your drawing.

In model space, you can turn lineweights on or off by

- Toggling Lwt on the status bar
- Selecting or clearing Display Lineweight in the Lineweight Settings dialog box
- Setting the LWDISPLAY system variable to 0 or 1 to turn lineweight display off or on

In layouts in paper space, you can turn the display of lineweights on or off by toggling Lwt on the status bar. This setting does not affect whether line-weights are plotted or not plotted in a drawing. See “To create a layout to plot” on page 519.