Adding Text to Drawings

Text conveys important information in your drawing. You use text for title blocks, to label parts of the drawing, to give specifications, or to make annotations.

AutoCAD® provides various ways to create text. For short, simple entries, use line text. For longer entries with internal formatting, use multiline text. Although all entered text uses the current text style, which establishes the default font and format settings, you can customize the text appearance.
Using Line Text

The text you add to your drawings conveys a variety of information. It may be a complex specification, title block information, a label, or even part of the drawing. Use the TEXT command to create line text for short entries that do not require multiple fonts, such as labels.

Use MTEXT to create long, complex, multiline entries (see “Using Multiline Text” on page 353).

Creating Line Text

Using TEXT you can create one or more lines of text and end each line when you press ENTER. Each text line is a separate object that you can relocate, reformat, or otherwise modify.

To create line text

1. From the Draw menu, choose Text ➤ Single Line Text.
2. Specify the insertion point for the first character. Press ENTER to locate the new text immediately below the last text object you created, if any.
   If the text height is set to 0 in the current text style, you are prompted to specify the height of the text. (See “Working with Text Styles” on page 370.)
3. Set the text height by dragging the pointing device until the distance between the cursor and the insertion point indicates the text height you want.
   or
   On the command line, enter a value in drawing units.
   (See “Setting Text Height” on page 376.)
4. Set a text rotation angle by dragging the pointing device until the angle between the cursor and the insertion point represents the text rotation angle you want.
   or
   On the command line, enter the X,Y coordinate.
Enter the text. Press ENTER to end one line of text and begin another. The TEXT command displays the text in the drawing as you type. Each line of text is a separate object. If you select another point in the drawing while TEXT is active, the cursor moves to that point, and you can continue entering text from there.

Press ENTER on a blank line to end text creation.

**Command line** TEXT

**Formatting Line Text**

You can format text as you create it using the options on the command line. Justify determines how the characters in the text line align with the insertion point. Style sets the default format characteristics.

You cannot apply formats to individual words and characters using TEXT. If you want to apply formats to individual words and characters, use MTEXT (see “Using Multiline Text” on page 353).

**Aligning Line Text**

As you create text, you can align it horizontally. That is, you can justify it using one of the alignment options shown in the following illustration. Left alignment is the default. To left-align text, do not enter an option at the Justify prompt.

You can also fit line text between points that you specify. This option stretches or squeezes the text to fill the designated space. All of these alignment options are useful for creating text that must align with a specific insertion point or within geometric constructions.
To align line text as you create it

1. From the Draw menu, choose Text ➤ Single Line Text.
2. Enter j (Justify).
3. Enter an alignment option.
   Each alignment option prompts you for information, such as a middle point of text for Middle alignment or a first and second endpoint for Fit alignment.
4. Enter the alignment information by using your pointing device, or by entering the X,Y coordinate on the command line.
5. Set the text height by dragging the pointing device until the distance between the cursor and the insertion point indicates the text height you want.
   or
   On the command line, enter a value in drawing units.
   (See “Setting Text Height” on page 376.)
6. Set a text rotation angle by dragging the pointing device until the angle between the cursor and the insertion point represents the text rotation angle you want.
   or
   On the command line, enter the X,Y coordinate.
7 Enter the text. Press ENTER to end one line of text and begin another.
The TEXT command displays the text in the drawing as you type. The align-
ment of the text doesn’t show on screen until you exit the command.
8 Press ENTER on a blank line to end text creation.

**Command line**  TEXT

**Assigning a Style to Line Text**
All text in a drawing has a style associated with it that sets the font, size,
angle, orientation, and other text characteristics. When you enter text, the
TEXT command uses the current text style. You can assign a different, existing
style by entering its name at the Style prompt.

For information about creating, modifying, and assigning styles, see “Work-
ing with Text Styles” on page 370.

**To specify a style when you create line text**
1 From the Draw menu, choose Text ➤ Single Line Text.
2 Enter s (Style).
3 At the Style Name prompt, enter an existing style name.
   or
   Enter ? for a list of available styles, and then enter a style name.
4 Continue creating text. See “To create line text” on page 348. Begin with step
   2.

**Command line**  TEXT

**Changing Line Text**
Like any other object, line text objects can be moved, rotated, erased, and
copied. You can also mirror, or make a reverse copy of text. See chapter 9,
“Editing Methods.” If you do not want the text to be reversed when you
mirror it, you can set the MIRRTEXT system variable to 0.

Text objects also have grips for stretching, scaling, and rotating. A line text
object has grips at the lower-left corner of the baseline and at the alignment
point. The effect of a command depends on which grip you choose.
You can change line text with the DDEDIT and PROPERTIES commands. For line text, DDEDIT displays the Edit Text dialog box, in which you can edit only the text content. PROPERTIES displays the Properties window, in which you can change the text content, insertion point, style, justification, size, and other properties.

To edit line text content only
1. From the Modify menu, choose Text.
2. Select the line text object you want to edit.

**NOTE** Each line of text is a separate object, so you can edit only one line at a time.

3. In the Edit Text dialog box, enter the new text. Choose OK.
4. Select another text object to edit, or press ENTER to exit the command.

**Command line** DDEDIT

**Shortcut menu** Select the line text object to edit, right-click in the drawing area, and choose Text Edit.

To modify line text object properties
1. From the Modify menu, choose Properties.
2. Select a line text object.
1. In the Properties window, change the contents and other properties as needed. These changes affect all the text in the text object.
2. Choose OK.

**Command line**  PROPERTIES

**Shortcut menu**  Select the line text object to edit, right-click in the drawing area, and choose Properties.

**Related**  CHANGE modifies text properties from the command line.

---

### Using Multiline Text

For long, complex entries, create multiline text using MTEXT. Multiline text fits a specified width but can extend vertically to an indefinite length. You can format individual words or characters within a multiline text object.

Multiline text consists of any number of text lines or paragraphs that fit within a width you specify. Unlike single-line text, multiline text includes as part of the same mtext object all text lines or paragraphs created in a multiline text editing session. You can move, rotate, erase, copy, mirror, stretch, or scale mtext objects (see chapter 9, “Editing Methods”).

Multiline text has more editing options than single-line text. Using the Multiline Text Editor, you can apply underlining, fonts, color, and text height changes to individual characters, words, or phrases within a paragraph.

You can also use the Properties window to change all properties of multiline text objects. See “Using the Properties Window” on page 260.
Creating Multiline Text

You can create text in the Multiline Text Editor, on the command line, or with a third-party text editor. You specify a third-party text editor in the Options dialog box or with the MTEXTED system variable.

The Multiline Text Editor provides a quick way to set properties that affect the entire text object or formats that affect only selected text.

Before creating the text, you must define the paragraph’s width. When text entry is complete, AutoCAD inserts the text entered in the dialog box within this width limit. You can apply the text height, justification, rotation angle, style and line spacing to the text object, or apply character formatting to specific characters. Justification determines where the text is inserted with respect to the text boundaries (see “Formatting Multiline Text” on page 356).

The height of the multiline text object you create with \texttt{MTEXT} depends on the amount of text you enter, not the height you specify when defining the boundary box.

To enter text in the Multiline Text Editor, you can use the standard Windows control keys described in the following table. See “Formatting Multiline Text” on page 356.

<table>
<thead>
<tr>
<th>Control keys used to edit text</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + A</td>
<td>Selects all text in the Multiline Text Editor</td>
</tr>
<tr>
<td>CTRL + B</td>
<td>Applies or removes bold format for selected text</td>
</tr>
<tr>
<td>CTRL + C</td>
<td>Copies selected text to the Clipboard</td>
</tr>
<tr>
<td>CTRL + I</td>
<td>Applies or removes italic format for selected text</td>
</tr>
<tr>
<td>CTRL + SHIFT + I</td>
<td>Converts selected text to lowercase</td>
</tr>
</tbody>
</table>
Using Multiline Text

The following procedure describes how to create multiline text using the default properties and formats. For information about changing text style and format, see “Formatting Multiline Text” on page 356.

To create multiline text

1. From the Draw menu, choose Text ➤ Multiline Text.
2. At the Specify First Corner prompt, use your pointing device to specify the corner.
   or
   Enter coordinate values on the command line.
3. At the next prompt, define the text width by using your pointing device to specify the opposite corner of the boundary box.
   or
   Enter a width value on the command line.
   If you choose to enter options on the command line, AutoCAD continues to display prompts on the command line until you specify the opposite corner of the boundary box.
   The Multiline Text Editor is displayed after you specify the second corner of the boundary box.

The Multiline Text Editor is displayed after you specify the second corner of the boundary box.

Arrows inside the boundary box indicate the flow of the entered text based on the current justification setting.
4 In the Multiline Text Editor, enter the text.
   Text that extends beyond the boundary box width wraps to the next line.
5 To apply formatting to words or characters, see “Formatting Multiline Text” on page 356.
6 To use stacked text, see “Creating Stacked Text” on page 359.
7 To convert text to uppercase as you enter it, double-click AutoCAPS.
8 Choose OK.

**Command line** MTEXT

**Related** -MTEXT creates and formats multiline text on the command line only.

**Formatting Multiline Text**

New text created in the Multiline Text Editor automatically assumes the characteristics of the current text style. You can change the format of multiline text in the following ways:

- In the Multiline Text Editor, change selected text or apply a different style to the text object.
- Modify the current text style. See “Creating and Modifying Text Styles” on page 371 for more information.

You can also edit the content and change the properties of an mtext object in the Properties window. See “Using the Properties Window” on page 260.

You can override the current text style by applying format changes to selected text in the Multiline Text Editor. If the text style is changed later, any formatting you have applied is retained.

You can use the Multiline Text Editor to format text as you create it, or edit existing multiline text. See “To create multiline text” on page 355.

**To format existing multiline text in the Multiline Text Editor**

1 From the Modify menu, choose Text.
2 Select the multiline text object you want to edit.
3 In the Multiline Text Editor, highlight the text you want to edit.
4 Enter replacement text, if necessary.
To use formatting options, choose one of the following tabs:

- **Character**: Provides options that apply to words and characters within a text object, including fonts, text height, italics, and color. See “Applying Formatting to Characters” on page 357.
- **Properties**: Provides options that apply to the entire mtext object, including style, width, and justification. See “Changing the Properties of an Mtext Object” on page 362.
- **Line Spacing**: Provides options for defining line spacing. See “To change the line spacing of the multiline text object” on page 366.
- **Find/Replace**: Finds text within an mtext object and replaces it. See “Finding and Replacing Multiline Text” on page 366.

Choose OK.

**Command line**  DDEDIT

**Shortcut menu**  Select the multiline text object to edit, right-click in the drawing area and choose Mtext Edit.

**Related**  PROPERTIES edits multiline text object properties (see “Using Text Editors for Multiline Text” on page 387).

**Applying Formatting to Characters**

To apply formatting to selected text within an mtext object, use the options on the Character tab in the Multiline Text Editor.

You can change the font and text height; apply boldface, italics, underlining, and color; stack text; and insert special characters using the options on the Character tab. The format changes you apply affect only the characters you select. The current text style is not changed.

**To format characters in existing text using the Multiline Text Editor**

1. From the Modify menu, choose Text.
2. Select the mtext object you want to edit.
3. In the Multiline Text Editor, select text using one of the following methods:
   - To select characters, click and drag the pointing device over the characters.
   - To select a word, double-click the word.
   - To select a paragraph, triple-click the paragraph.
4 Choose the Character tab, and change the formatting of selected text as follows:

- To change the font, select a font.
- To change the height, enter a new value.
- To format text with boldface or italics (TrueType fonts only), or to underline text, choose the corresponding button on the toolbar.
- To create stacked text, see “Creating Stacked Text” on page 359.
- To uppercase or lowercase text, right-click in the Multiline Text Editor and choose Change Case ➤ Uppercase or Change Case ➤ Lowercase.

- To apply color, choose a color from the color box or choose Other. In the Select Color dialog box, select a color and choose OK. The most recently used colors are displayed in the Text Color list.
To add special characters to the text, choose Symbol. Then choose Degrees, Plus/Minus, Diameter, or Non-breaking space to insert the special character in the text. To add a special character from the Unicode Character Map dialog box, choose Other. Choose one of the special characters from the dialog box and choose Close. To use GDT symbols in your mtext object, select the GDT font.

**NOTE** To access the Unicode Character Map dialog box, you must have charmap.exe installed. See Windows Help for adding programs to your system.

5. To import text from another file, click Import Text and select a file to import. (See “Using External Text Files” on page 368.)

6. Choose OK.

**Command line**  
MTEXT

**Creating Stacked Text**

Stacked text is text or fractions that indicate tolerances or measurements. You use the special characters slash (/), pound (#), and carat (^) to indicate where selected text should be stacked. The slash defines a vertical stack separated by a horizontal line. The pound sign defines a diagonal stack separated by a diagonal line. The carat defines a tolerance stack, which is not separated by a line.
NOTE

Previous releases of AutoCAD do not support diagonal fractions. If you save your drawing in an earlier AutoCAD format, diagonal fractions are converted to vertical fractions. All fractions are converted to diagonal fractions when the drawing is reopened in AutoCAD 2000, even if an mtext object contained both vertical and diagonal fractions before being saved in an earlier format.

You can automatically stack fractions as you enter text. AutoStack automatically stacks numeric characters entered before and after the slash, pound sign, or carat. For example, if you enter 1\#3 followed by a nonnumeric character or space, AutoStack automatically stacks the text as a diagonal fraction. You can also automatically remove blanks between a whole number and a fraction.

You can specify how you want AutoStack to convert the slash character: to a vertical fraction, or to a diagonal fraction. The pound sign is always converted to a diagonal fraction, and the carat is always converted to a tolerance format.

AutoStack stacks only numeric characters immediately before and after the slash, pound sign, and carat. To stack nonnumeric characters or text that includes spaces, select the text and choose Stack on the toolbar on the Character tab in the Multiline Text Editor.
To create stacked text
1. From the Modify menu, choose Text.
2. Select the mtext object you want to edit.
3. In the Multiline Text Editor, choose the Character tab if it is not already displayed.
4. Enter the text you want to stack separated by one of the following characters:
   - Slash: Stacks text vertically, separated by a horizontal line.
   - Pound sign: Stacks text diagonally, separated by a diagonal line.
   - Carat: Creates a tolerance stack, which is not separated by a line.

If you enter numbers separated by stack characters and then enter a nonnumeric character or press SPACEBAR, the AutoStack Properties dialog box is displayed. You can choose to automatically stack numbers (not nonnumeric text) and to remove leading blanks. You can also specify whether the slash character creates a diagonal fraction or creates a vertical fraction. If you do not want to use AutoStack, choose Cancel to exit the dialog box.
5. Select the text that you want to stack, and choose Stack on the toolbar.
6. Choose OK.

Editing Stacked Text
When you edit stacked text, you can change the upper text and lower text independently. You can also restore previous default values to the current stacked text or save the new settings as defaults.

To edit stacked text
1. From the Modify menu, choose Text.
2. Select the mtext object you want to edit.
3. In the Multiline Text Editor, highlight the stacked text.
4. Right-click and select Properties from the shortcut menu.
In the Stack Properties dialog box under Text, enter new text for the upper or lower parts of the stacked text.

Under Appearance, select a style: Tolerance, Fraction (Horizontal), or Fraction (Diagonal).

Under Position, select one of the following options:

- **Top**: Aligns the top of the fraction with the top of the text line.
- **Center**: Centers the fraction vertically to the center of the text line. This is the default position.
- **Bottom**: Aligns the bottom of the fraction with the text baseline.

Under Text Size, select a size for each character in the stacked text as a percentage of the size of the current text style. The default size for stacked text is 70 percent.

To save the current settings as the default, or to restore the settings to the current default settings, choose Default. Choose OK to exit the dialog boxes and apply the changes.

**NOTE** The Multiline Text Editor does not display the stacked text aligned by the position option you select. For example, if you chose Top, the stacked text does not appear to be aligned to the top of the text line. When you close the Multiline Text Editor, the stacked text is displayed in your drawing aligned to the top of the text line.

**Changing the Properties of an Mtext Object**

You can change the style, justification, width, and rotation of the multiline text object by using the options on the Property tab. These changes affect the entire mtext object. Multiline text objects also have general object properties, such as color and layer, that you can change using the Properties window. See “Using the Properties Window” on page 260.

You can use grips to move, rotate, erase, or copy a multilime text object. A multiline text object that has a nonzero width has grips at the four corners of the text boundary and, in some cases, at the justification point. A multiline text object that has an unspecified width has a single grip at the justification point. The effect of a command depends on which grip you choose.
To change the style of the multiline text object

1. From the Modify menu, choose Text.
2. Select the mtext object you want to edit.
3. In the Multiline Text Editor, choose the Properties tab.
4. Select a style from the style list.
5. Choose OK.

Command line  MTEXT

The Properties tab displays the justification, width, and rotation settings for the new text style. To define and name a new text style, use the STYLE command. When you change the style of a multiline text object, any character formatting is retained, not overridden, by the new text style.

NOTE  When you open drawings from previous AutoCAD releases, mtext objects with character format overrides may not be displayed properly. To reset character formatting, open the objects in the Multiline Text Editor and save them again.

Justification
Justification controls the text alignment and the direction of text flow as you enter text. Text is justified with respect to the left and right text boundaries. Spaces entered at the end of a line are included as part of the text and affect the justification of the line. Text flows from the middle, top, or bottom of the paragraph with respect to the top and bottom text boundaries. AutoCAD offers nine justification settings: Top Left (TL), Top Center (TC), Top Right (TR), Middle Left (ML), Middle Center (MC), Middle Right (MR), Bottom Left (BL), Bottom Center (BC), and Bottom Right (BR).
To change the justification of the multiline text object

1. From the Modify menu, choose Text.
2. Select the mtext object you want to edit.
3. In the Multiline Text Editor, choose the Properties tab.
4. Select an option from the Justification list.
5. Choose OK.

Command line  MTEXT, DDELETE

Shortcut menu  Select the multiline text object, right-click in the drawing area, and choose Mtext Edit.

Width
The width property defines the width of the entire multiline text object, not of individual characters.
To change the width of the multiline text object

1. From the Modify menu, choose Text.
2. Select the mtext object you want to edit.
3. In the Multiline Text Editor, choose the Properties tab.
4. In Width, select an option or enter a value in drawing units.
5. Choose OK.

Command line  MTEXT

To change the rotation of the multiline text object

1. From the Modify menu, choose Text.
2. Select the mtext object you want to edit.
3. In the Multiline Text Editor, choose the Properties tab.
4. In Rotation, select an option or enter a value.
5. Choose OK.

Command line  MTEXT

Line Spacing
You can set the line spacing for new or existing multiline text objects using the options on the Line Spacing tab of the Multiline Text Editor.

The line spacing increment for multiline text is the amount of space between the bottom (baseline) of one line of text and the baseline of the next line of text.

The line spacing increment applies to the entire mtext object and not to selected lines.

You can set the spacing increment to a multiple of single line spacing, or as an absolute value. Single spacing is 1.66 times the height of the text characters. Options include Single (1x), 1.5 lines (1.5x), and Double (2x).

You can select an option from the list or enter a number followed by x to indicate a multiple of single spacing. For example, select or enter 1x in the Spacing Factor list to specify single spacing, enter 3x to specify triple spacing, and so on. Or, specify an absolute value such as .5.
The default At Least option automatically adjusts line spacing to accommodate characters that are too large to fit the line spacing increment you set for the mtext object. Use the Exactly option when you want uniform line spacing in the text object, for example, in a table.

To change the line spacing of the multiline text object

1. From the Modify menu, choose Text.
2. Select the mtext object you want to edit.
3. In the Multiline Text Editor, choose the Line Spacing tab.
4. In Line Spacing, choose one of the following:
   - **At Least**: Adjusts lines of text automatically based on the height of the largest character in the line. More space is added between lines of text with taller characters. This is the default setting.
   - **Exactly**: Forces the line spacing to be the same size for all lines of text in the mtext object regardless of format differences, such as font or text height. The amount of space between the lines is determined by Spacing Factor. Use Exactly to line up text in tables. To ensure that line spacing is identical in multiple mtext objects, use Exactly and set Spacing Factor to the same value in each mtext object. Using Exactly can cause text in lines located above or below lines with large font characters to overlap the larger characters.
5. Select a spacing increment from the list, or enter a value. You can enter a multiple of single spacing, for example 2x or 3x, or an absolute value, such as .5.
6. Choose OK.

**Command line**  
MTEXT

**Finding and Replacing Multiline Text**

To quickly search for and replace multiline text word by word, use the find and replace feature in the Multiline Text Editor. Replacement is based on text content only; character formatting and text properties are unchanged. For information about finding and replacing text contained in objects other than multiline text objects, such as line text and block attributes, see “Finding and Replacing Text” on page 382.
To find multiline text

1. From the Modify menu, choose Text.
2. Select a multiline text object.
3. In the Multiline Text Editor, choose the Find/Replace tab.

4. Enter the word that you want to change in Find.
   - To match the case of letters in a word, select Match Case.
   - To find text that is not part of another word, select Whole Word.

5. To locate the word in the selected text object, choose Find.

   When the text object has been completely searched, a message is displayed at the bottom of the dialog box to indicate that the search is resuming at the beginning of the text object.

To replace text

1. From the Modify menu, choose Text.
2. Select a multiline text object.
3. In the Multiline Text Editor, choose the Find/Replace tab.

4. Enter the word that you want to change in Find.
   - To match the case of letters in a word, select Match Case.
   - To find text that is not part of another word, select Whole Word.

5. In Replace, enter the word with which you want to replace the word in Find.

6. To locate the word in the Find box, choose Find.

7. When you find the word you want to replace, choose Replace.

8. Repeat steps 6 and 7 for each occurrence of the word you want to change.

9. Choose OK.
Changing Multiline Text Location

To move multiline text, you can use the drag-and-drop method, the MOVE command, or the Properties window (see “Using the Properties Window” on page 260).

To move a multiline text object using drag and drop
1. Select the mtext object.
2. Click the object and hold down the button on your pointing device. The cursor changes to an arrow and a small box. The boundary box around the mtext object is highlighted.

**NOTE** Selecting a corner grip resizes the boundary box of the mtext object; it does not move the object.

3. Drag the mtext object to the new location and release the button on your pointing device.

**Related** MOVE can be used to relocate text.

Using External Text Files

You can import ASCII text files created in other word processors or spreadsheet programs into your AutoCAD drawing. You can either import the text file or drag the file from Microsoft® Windows® Explorer.

Importing Text Files

You can save time by importing files from other sources. For example, you can create a text file of standard notes that you include in drawings. Instead of entering this information each time you use it, you can import the file. Imported text files are limited to a maximum size of 16K. To insert a larger text file into your drawing, see “Dragging a Text File into a Drawing” on page 369.

Text imported using the Multiline Text Editor becomes an mtext object, which you can edit as if you created it in AutoCAD. Imported text retains its original formatting properties but can be modified using the Multiline Text Editor.

To import text files
1. From the Draw menu, choose Text ➤ Multiline Text.
2. Specify the text boundary location and other properties as needed.
   See “To create multilineline text” on page 355.
3 In the Multiline Text Editor, to convert the text to uppercase as it is imported, double-click AutoCAPS.

4 Choose Import Text.

5 In the Open dialog box, double-click the file you want to import, or select the file and choose Open.
AutoCAD inserts the text at the cursor location in the Multiline Text Editor.

6 Change the text as needed. Then choose OK.

If the Clipboard contains text, you can choose Paste from the Edit menu to paste the Clipboard contents into your drawing.

**Dragging a Text File into a Drawing**

You can drag text files into a drawing. The width of the boundary box for inserted text files is determined by line breaks and carriage returns in the original document. When you drag a file with a .txt file extension into a drawing, AutoCAD automatically converts it to an mtext object and treats it like imported text (see “Importing Text Files” on page 368). If you insert a text file with a different extension, AutoCAD treats it as an OLE text object.

**To insert a text file by dragging it from Windows Explorer**

1 Open Windows Explorer, but make sure it doesn’t fill the screen.

2 Display the directory that contains the file you want.

3 Drag a text file icon onto the AutoCAD drawing.

AutoCAD places the text object on the drawing where you dropped it. If the object was a .txt file, it is inserted as an mtext object. You can use the Multiline Text Editor to edit these objects (see “Formatting Multiline Text” on page 356).

If the file was not a .txt file, the OLE Properties dialog box is displayed (see “Working with OLE Objects” on page 760).

4 To move a text object, click the object and drag it.

---

**NOTE** Using grips to size an OLE text object may cause the text to become unreadable. See “Working with OLE Objects” on page 760.

For more information about dragging OLE objects into a drawing, see chapter 21, “Creating Compound Documents with OLE.”
Working with Text Styles

All text in an AutoCAD drawing has a text style associated with it. When you enter text, AutoCAD uses the current text style, which sets the font, size, angle, orientation, and other text characteristics. You can create many text styles for use in your drawings. You can reuse the text styles you create by copying the text styles into other drawings using the AutoCAD DesignCenter, see “Managing Content with AutoCAD DesignCenter” on page 491.

Text style controls the attributes listed in the following table.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Style name</td>
<td>STANDARD</td>
<td>Name with up to 255 characters</td>
</tr>
<tr>
<td>Font name</td>
<td>txt.shx</td>
<td>File associated with a font (character style)</td>
</tr>
<tr>
<td>Big Font</td>
<td>none</td>
<td>Special shape definition file used for non-ASCII</td>
</tr>
<tr>
<td></td>
<td></td>
<td>character set, such as Kanji</td>
</tr>
<tr>
<td>Height</td>
<td>0</td>
<td>Character height</td>
</tr>
<tr>
<td>Width factor</td>
<td>1</td>
<td>Expansion or compression of the characters</td>
</tr>
<tr>
<td>Obliquing angle</td>
<td>0</td>
<td>Slant of the characters</td>
</tr>
<tr>
<td>Backwards</td>
<td>No</td>
<td>Backwards text</td>
</tr>
<tr>
<td>Upside down</td>
<td>No</td>
<td>Upside-down text</td>
</tr>
<tr>
<td>Vertical</td>
<td>No</td>
<td>Vertical or horizontal text</td>
</tr>
</tbody>
</table>

The defaults for the current text style are displayed in angle brackets at the prompts on the command line or in the Text Style dialog box. You can use or modify the default style or create and use a new style. Once you’ve created a style, you can modify its attributes, change its name, or delete it when you are no longer using it.

Text styles are one of many nongraphical objects saved in a drawing. See “Working with Named Objects” on page 157.
Creating and Modifying Text Styles

Except for the default STANDARD style, you must create any text style that you want to use. New text inherits height, width factor, obliquing angle, backwards, upside-down, and vertical alignment properties from the current text style. When you create or modify a text style, you assign or change the style name, assign a font and set its width and angle, set the text orientation, and preview the text style.

To create a text style

1. From the Format menu, choose Text Style.

2. In the Text Style dialog box, choose New.

3. In the New Text Style dialog box, enter a name for the text style.
   If you don’t enter a text style name, AutoCAD names the text style Style n, where n is a number starting at 1 and increasing by 1 for each new automatically named style.

4. Choose OK to close the New Style dialog box.

   The Text Style dialog box displays the characteristics of the style you created. You can change the displayed characteristics whenever you want.
5 If you change any style characteristics, choose Apply to save them.
6 After you have made and applied all changes to the text style, choose Close. (Cancel becomes Close after you choose Apply.)

For more information about modifying text style characteristics, see

- “Assigning Fonts” on page 373
- “Setting Text Height” on page 376
- “Setting Obliquing Angle” on page 377
- “Setting Horizontal or Vertical Orientation” on page 378

Command line STYLE displays the Text Style dialog box. -STYLE displays prompts on the command line.

Modifying Text Styles
You can modify an existing text style in the Text Style dialog box by changing the settings. You can also update existing text in that text style to reflect the changes.

If you change an existing text style’s font or orientation, all text using that style is regenerated using the new font or orientation. Changing text height, width factor, and oblique angle does not change existing text but does change subsequently created text objects. However, changes to alignment and width have no effect on multiline text objects (see “Creating Multiline Text” on page 354).

To modify a text style
1 From the Format menu, choose Text Style.
2 In the Text Style dialog box, select a text style name.
3 Under Font and Effects, change any of the options.
   The sample text in the Preview area is updated to show the changes you make to the style.
4 To save the settings to the selected style and to update text in the drawing that uses this style, choose Apply.
   To undo the changes you make to a style, select Undo from the Edit menu.
5 Choose Close.

Command line STYLE or -STYLE
Assigning Fonts

Fonts define the shapes of the text characters that make up each character set. In AutoCAD, you can use TrueType fonts in addition to the AutoCAD compiled shape (SHX) fonts.

A single font can be used by more than one text style. If your company uses a standard font, you can modify other text style settings to create a set of text styles that use a standard font in different ways. The following illustration shows the same font used by different text styles that have different obliquing settings to define the slant of the text.

You can assign a font to a text style by selecting either a TrueType® typeface name and its font style (bold or italic, for instance), or an AutoCAD compiled SHX font.

Using TrueType Fonts

TrueType fonts always appear filled in your drawing, however, when you plot, the TEXTFILL system variable controls whether the fonts are filled. By default TEXTFILL is set to 1 to plot the filled-in fonts. When you export the drawing with PSOUT and print it on a PostScript® device, the font is plotted as designed.

To increase the speed and performance of TrueType fonts in AutoCAD, the Windows operating system draws some TrueType text directly. Due to limitations in Windows, however, AutoCAD must draw TrueType text that is transformed in certain ways; for instance, text that is mirrored, upside-down, backward, oblique, has a width factor not equal to 1, or is in an orientation that is not coplanar with the screen. A general rule is that TrueType text that
looks in AutoCAD as it does in a word processor is drawn by the Windows system; otherwise the TrueType text is drawn by AutoCAD. Text that has been transformed might appear slightly more bold in some circumstances, especially at lower resolutions. This difference is only in the display of the font and does not affect the plotted output. For more information about the effects of TrueType fonts in AutoCAD, see “Setting Text Height” on page 376.

The Multiline Text Editor can display only fonts that are recognized by Windows. Because AutoCAD SHX fonts are not recognized by Windows, AutoCAD supplies a TrueType equivalent in the Multiline Text Editor when you select an SHX or any other non-TrueType font for editing.

**Using Unicode and Big Fonts**

AutoCAD supports the Unicode character-encoding standard. A Unicode font can contain 65,535 characters, with shapes for many languages. Unicode fonts contain many more characters than are defined in your system; therefore, to use a character not directly available from the keyboard, you can enter the escape sequence \U+nnnn, where nnnn represents the Unicode hexadecimal value for the character. All AutoCAD SHX shape fonts are now Unicode fonts.

The SHX fonts used in releases prior to Release 13 do not support the \U+nnnn sequence. However, you can continue to generate accented characters by using characters in the 128 through 256 range.

The text files for some alphabets, such as Kanji, contain thousands of non-ASCII characters. To accommodate such text, AutoCAD supports a special type of shape definition known as a Big Font file. You can set a style to use both regular and Big Font files.

For samples of the standard fonts supplied with AutoCAD, see appendix E, “Standard Libraries,” in the Command Reference. AutoCAD also provides ways to substitute one font for another or to specify a default font (see “Substituting Fonts” on page 380).

When you specify fonts using the -STYLE command on the command line, AutoCAD assumes that the first name is the normal font and the second (separated by a comma) is the Big Font. If you enter only one name, AutoCAD assumes it’s the normal font and removes any associated Big Font. By using leading or trailing commas when specifying the font file names, you can change one font without affecting the other, as shown in the following table.
NOTE Long file names that contain commas are not accepted as font file names. The comma is interpreted as a separator for an SHX font–Big Font pair. For more information, see `STYLE` in the Command Reference.

In the Style dialog box, select Use Big Fonts to specify a Big Font.

**Using Proxy Fonts**
For third-party or custom SHX fonts that have no TrueType equivalent, AutoCAD supplies up to eight different TrueType fonts called proxy fonts. Proxy fonts appear different in the Multiline Text Editor from the font they represent to indicate that they are substitutions for the fonts used in the drawing.

A custom SHX font is not available for character formatting in the Character tab fonts list. To use a custom SHX font, you must define it using the STYLE command, and then apply that style to the text.

**To assign a font to a text style**
1. From the Format menu, choose Text Style.
2. In the Text Style dialog box under Style Name, select a style.
3. Under Font Name, select the name of the font file you want to use.
   - To use a Big Font, select an SHX font file and then select Use Big Font.
   - When you select Use Big Font, Font Style changes to Big Font Name. Only SHX fonts are available for selection, and only Big Font names are shown in the Big Font list.

---

**Specifying fonts and Big Fonts on the command line**

<table>
<thead>
<tr>
<th>Enter this ...</th>
<th>To specify this ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>[font name],[big font name]</td>
<td>Both normal fonts and Big Fonts</td>
</tr>
<tr>
<td>[font name],</td>
<td>Only a normal font (Big Font unchanged)</td>
</tr>
<tr>
<td>[big font name]</td>
<td>Only a Big Font (normal font unchanged)</td>
</tr>
<tr>
<td>[font name]</td>
<td>Only a normal font (Big Font, if any, removed)</td>
</tr>
<tr>
<td>ENTER (null response)</td>
<td>No change</td>
</tr>
</tbody>
</table>

**NOTE** Long file names that contain commas are not accepted as font file names. The comma is interpreted as a separator for an SHX font–Big Font pair. For more information, see `-STYLE` in the Command Reference.
To see the effects on different characters, enter a new text string in the sample text box, and then view the text under Preview.

To update text of the selected style in the drawing, choose Apply.

Choose Close.

**Command line**  STYLE

**Related**  -STYLE sets the style from the command line.

**Setting Text Height**

Text height determines the size in drawing units of the letters in the font you are using. The value usually represents the size of the uppercase letters, with the exception of TrueType fonts.

For TrueType fonts, the value specified for text height might not represent the height of uppercase letters. The height specified represents the height of a capital letter plus an ascent area reserved for accent marks and other marks used in non-English languages. The relative portion of areas assigned to capital letters and ascent characters is determined by the font designer at the time the font is designed and, consequently, vary from font to font.

In addition to the height of a capital letter and the ascent area that comprise the height specified by the user, TrueType fonts have a descent area for portions of characters that extend below the baseline. Examples of such characters are y, j, p, g, and q.

If you specify a fixed height as part of a text style, AutoCAD bypasses the Height prompt when you create line text. When the height is set to 0 in the text style, AutoCAD prompts for the height each time you create line text. Set the value to 0 if you want to change the height as you create text.
To set text height in a text style

1. From the Format menu, choose Text Style.
2. In the Text Style dialog box, select a style from the Style Name list.
3. Under Font, enter the text height (in drawing units) in Height.
4. To update the selected style and the text using the selected style in the drawing, choose Apply.
5. Choose Close.

**Command line**  STYLE or -STYLE

**Setting Obliquing Angle**

The obliquing angle determines the forward or backward slant of the text. The angle represents the offset from 90 degrees.

Text created using various obliquing and rotation angles

Entering a value between -85 and 85 makes the text oblique. A positive obliquing angle slants text to the right. A negative obliquing angle slants text to the left.

To set the obliquing angle in a text style

1. From the Format menu, choose Text Style.
2. In the Text Style dialog box, select a style from the Style Name list.
3. Under Effects, enter an angle in Oblique Angle.
4. To update the selected style and the text using the selected style in the drawing, choose Apply.
5. Choose Close.

**Command line**  STYLE or -STYLE
Setting Horizontal or Vertical Orientation

AutoCAD orients line text as vertical or horizontal. You can only assign vertical orientation to text if the associated font supports dual orientation.

You can create more than one line of vertical text. Each successive text line is drawn to the right of the preceding line. The normal rotation angle for vertical text is 270 degrees.

**NOTE** Vertical orientation is not supported for TrueType fonts.

To set vertical orientation in a text style

1. From the Format menu, choose Text Style.
2. In the Text Style dialog box, select a style from the Style Name list.
3. Choose Vertical.
4. To update the selected style and the text using the selected style in the drawing, choose Apply.
5. Choose Close.

**Command line** `STYLE`

Making Another Text Style Current

If you want to create text using a different text style, you can change the current text style.

To make another text style current

1. From the Format menu, choose Text Style.
2. In the Text Style dialog box, select a style from the Style Name list.
3. Choose Apply.

**Command line** `STYLE` or `-STYLE`

**System variables** `TEXTSTYLE` stores the name of the current text style.
Renaming a Text Style

You can rename an existing text style. Any text using the old name assumes the new text style name.

To rename an existing text style
1. From the Format menu, choose Text Style.
2. In the Text Style dialog box, select a style from the Style Name list.
3. Choose Rename.

The current name is displayed and selected in the Rename Text Style dialog box.
4. Enter a different name in Style Name.
5. Choose OK. Choose Close.

Command line  STYLE

Related  RENAME renames text styles.

Removing Unreferenced Text Styles

You can delete any text styles not referenced in your drawing, except the STANDARD text style. You can delete a text style at any time during your drawing session.

To delete unreferenced text styles
1. From the Format menu, choose Text Style.
2. In the Text Style dialog box, select a style from the Style Name list.
3. Choose Delete.

Command line  STYLE
Using Styles from Previous Releases

In AutoCAD Release 13, you could display PostScript fonts in the drawing. AutoCAD no longer displays PostScript fonts in the drawing. Autodesk has supplied TrueType font equivalents in place of the PostScript fonts supplied with Release 13. The PostScript fonts supported in Release 13 are mapped to the equivalent TrueType file in a font mapping file supplied by AutoCAD. See “Substituting Fonts” on page 380.

Substituting Fonts

You can designate fonts to be substituted for other fonts. The fonts used for the text in your drawing are determined by the text style and, for multiline text, by individual font formats applied to sections of text. Sometimes you might want to ensure that your drawing uses only certain fonts, or perhaps you might want to convert the fonts you used to other fonts. You can use any text editor to create font mapping tables for both of these purposes.

You can use these font mapping tables to enforce corporate font standards, or to facilitate off-line printing. For example, if you share drawings with consultants, you may want to use a font mapping table to specify what font AutoCAD substitutes when it encounters a text object created with another font. Similarly, to edit the drawing using quicker-drawing SHX fonts and then switch to more complex fonts for the final plot, you can set up a font mapping table that converts each SHX font to an equivalent.

The font mapping table is a plain ASCII text (FMP) file containing one font mapping per line. Each line contains the base name of the font file (with no directory name or path) followed by a semicolon (;) and the name of the substitute font file. The substitute file name includes a file extension such as .ttf.

For example, you can enter the following in a font map table to specify that the times.ttf TrueType font file be substituted for the romanc.shx font file:

romanc.shx; times.ttf

AutoCAD comes with a default font mapping table in the acad.fmp file in the Support folder. You can edit this file using any ASCII text editor. You also can specify a different font mapping table file in the Options dialog box, or you can specify the font mapping file using the FONTMAP system variable.

To specify a font mapping table

1. From the Tools menu, choose Options.
2. In the list on the Files tab, click the plus sign next to Text Editor, Dictionary, and Font File Names.
3. Click the plus sign next to Font Mapping File. The acad.fmp file is specified by default.
4. To change the font mapping file, double-click the arrow to specify a new file in the Select a File dialog box.
5. At the Command prompt, enter `regen` to convert existing text to the new font mappings.

**Command line** OPTIONS

**System variables** FONTMAP specifies the name of the current font mapping table.

### Specifying an Alternative Default Font

If your drawing specifies a font that is not currently available on your system, AutoCAD automatically substitutes the font designated as your alternative font. By default, AutoCAD uses the `simplex.shx` file. However, you can specify a different font if necessary. You enter the alternative font file name by changing the FONTALT system variable.

**NOTE** If the font specified by FONTALT cannot be found, the Specify Font for the FONTALT dialog box is displayed. Select an available font.
If you use a text style that uses a Big Font, you can map it to another font using FONTALT. This system variable uses a default font file pair of \texttt{txt.shx}, \texttt{bigfont.shx}.

To specify a default alternative font

1. At the Command prompt, enter \texttt{fontalt}.
2. Enter the name of the font file you want to use as the alternative.

The following table shows the font substitution rules used by AutoCAD when a font file cannot be located when a drawing is opened.

<table>
<thead>
<tr>
<th>File extension</th>
<th>First mapping order</th>
<th>Second mapping order</th>
<th>Third mapping order</th>
<th>Fourth mapping order</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ttf</td>
<td>Use FONTMAP value</td>
<td>Use font defined in text style</td>
<td>Windows substitutes a similar font</td>
<td></td>
</tr>
<tr>
<td>.shx</td>
<td>Use FONTMAP value</td>
<td>Use font defined in text style</td>
<td>Use FONTALT</td>
<td>Prompt for new font</td>
</tr>
<tr>
<td>.pfb</td>
<td>Use FONTMAP value</td>
<td>Use FONTALT</td>
<td>Prompt for new font</td>
<td></td>
</tr>
</tbody>
</table>

Finding and Replacing Text

Using the Find and Replace dialog box, you can find, replace, select, and zoom to any of the following types of text:

- Line text (text created with the \texttt{TEXT} command)
- Multiline text (text created with the \texttt{MTEXT} command)
- Block attribute values
- Dimension annotation text
- Hyperlink descriptions
- Hyperlinks

In your search criteria, you can indicate which types of text to find, whether to find whole words only and whether to match case. AutoCAD can find text in any loaded object in model space and in any layout defined in the current drawing. If you have partially opened the current drawing, the Find and Replace dialog box does not consider objects that you have not loaded. You can also limit the search to a specific selection set.
To find text

1. From the Edit menu, choose Find.

2. In Find Text String, enter the text you want to find.

3. In Search In, choose Entire Drawing or Current Selection to define the scope of your search.

4. Choose Options to specify the types of text to include in the search, whether to find whole words only, and whether to match the case of the specified text.

5. Choose Find.

   AutoCAD displays the found text with its surrounding context in the Context area.

6. To zoom to the found text in the drawing, choose Zoom To.

7. Choose Close.

   Command line FIND
   Shortcut menu End any active commands, right-click in the drawing area, and choose Find.

To replace text

1. From the Edit menu, choose Find.

2. In Find Text String, enter the text you want to find.

3. In Search In, select Entire Drawing or Current Selection to define the scope of your search.
Choose Options to specify the types of text to include in the search, whether to find whole words only, and whether to match the case of the specified text.

5 In Replace With, enter the text with which you want to replace the found text.

6 Choose Find.
   AutoCAD displays the found text with its surrounding context in the Context area.

7 To replace only the found instance of the text string, choose Replace.
   or
   To replace all instances of the text in Find Text String, choose Replace All.
   AutoCAD confirms the replacement in the status area at the bottom of the dialog box.

8 Choose Close.

   **Command line**  FIND

   **Shortcut menu**  End any active commands, right-click in the drawing area, and choose Find.

   **To select all instances of found text**

   1 From the Edit menu, choose Find.
   2 In Find Text String, enter the text you want to find.
   3 Choose the Select Objects button to temporarily close the dialog box and create a selection set of the objects that you want to search for.
   4 Press ENTER when you finish selecting objects.
   5 In the Find and Replace dialog box, choose Options to specify the types of text to include in the search, whether to find whole words only, and whether to match the case of the specified text.
   6 Choose Select All.

   AutoCAD closes the Find and Replace dialog box and selects all objects containing instances of the found text. A message on the command line indicates how many objects AutoCAD found and selected.

   **Command line**  FIND
Checking Spelling

The SPELL command checks the spelling in your drawing, including spelling in dimension text. You use one of several main dictionaries, available in different languages. The main dictionaries use a standard word list, which you can customize.

To check spelling

1. From the Tools menu, choose Spelling.
2. Select the text objects you want to check, or enter all to select all text objects.
3. If AutoCAD does not find any misspelled words, it displays a message. If AutoCAD finds a misspelling, the Check Spelling dialog box identifies the misspelled word.

![Check Spelling dialog box](image)

The misspelled word and the text that surrounds it are displayed under Context.
4. Do one of the following:
   - To correct a word, select an alternative from the Suggestions list or enter a word in Suggestions. Then choose Change or Change All.
   - To leave a word unchanged, choose Ignore or Ignore All.
   - To leave a word unchanged and add it to the custom dictionary, choose Add. (This option is not available unless a custom dictionary is specified.)
5. Choose Cancel to exit the dialog box.

**Command line**  SPELL
Switching Dictionaries

During a spelling check, AutoCAD matches the words in the drawing to the words in the current main dictionary. Any words you add are stored in the custom dictionary that is current at the time of the spelling check. For example, you can add proper names so AutoCAD no longer identifies them as misspelled words.

To check spelling in another language, you can change to a different main dictionary. You also can create any number of custom dictionaries and switch to them as needed.

You can change dictionaries from a dialog box or by specifying the dictionary name in the DCTMAIN or DCTCUST system variable. For a list of the dictionary file names, see DCTMAIN in the Command Reference.

To switch main or custom dictionaries while checking spelling

1. In the Check Spelling dialog box, choose Change Dictionaries.
2. To change the main dictionary, select a dictionary from the Main Dictionary list.
3. To change the custom dictionary, enter a name under Custom Dictionary. To select from a list of dictionaries, choose Browse.
4. Choose OK.

Command line SPELL
Creating and Editing Custom Dictionaries

A custom dictionary is a list of spelling exceptions that you have identified. The files that contain them can be identified by the .cus file extension. You can use any third-party text editor to add and delete words or to combine dictionaries. If a word is preceded by a tilde (~), AutoCAD always flags the word as incorrect.

You also can create and edit dictionaries from inside AutoCAD.

To create or edit custom dictionaries during a spelling check

1. In the Check Spelling dialog box, choose Change Dictionaries.
2. In the Change Dictionaries dialog box under Custom Dictionary, specify the dictionary you want to edit using one of the following methods:
   - To specify a dictionary, enter its name, using the .cus file extension.
   - To select from a list of directories, choose Browse.
   - To create a new custom dictionary, enter a new name. Use the .cus file extension.
3. To add a word, enter it under Custom Dictionary Words. Then choose Add.
4. To remove a word, select it from the list. Then choose Delete.
5. Choose OK.

Command line  SPELL

Related  You also can edit the CUS file (an ASCII file). Each word in the CUS file must be on a line by itself.

Using Text Editors for Multiline Text

The default text editor is the Multiline Text Editor, but you can elect to use a third-party editor by setting the editor in the Options dialog box or the MTEXTED system variable.

Specifying a Multiline Text Editor

Your text editor may offer some formatting options that cannot be changed in the Multiline Text Editor. For best results, use the same text editor to edit text that you used when you created it.
To specify a text editor

1. From the Tools menu, choose Options.
2. In the Options dialog box, choose the Files tab.
3. Click the plus sign next to Text Editor, Dictionary, and Font File Names.
4. Click the plus sign next to Text Editor Application. Then double-click Internal. If you’ve previously changed the MTEXTED system variable to (.) for none, then the arrow is displayed under the Text Editor Application, but Internal is not displayed. Click the arrow and choose Browse to modify the text editor.
5. In the Select a File dialog box, enter the name of the executable file for the third-party text editor you want to use to create multiline text.
6. Choose OK to exit each dialog box and apply changes.

Command line OPTIONS

System variables MTEXTED specifies the name of a third-party text editor to use to create multiline text. To use the AutoCAD internal text editor, specify Internal.
Creating Multiline Text in a Text Editor

If you use a third-party text editor for multiline text, you define general properties on the command line before you enter the text. AutoCAD then opens the text editor for entering text and uses format codes to format individual words and characters. When you close the text editor, AutoCAD inserts the text within the specified width limit.

The following procedure describes how to create multiline text in a third-party text editor using the default properties and formats. For information about applying formats, see “Formatting Multiline Text in a Text Editor” on page 389.

To create multiline text in a third-party text editor

1. From the Draw menu, choose Text ➤ Multiline Text.
2. Specify the first corner of the multiline text rectangle.
3. Specify the opposite corner of the multiline text rectangle.
4. In the text editor, enter the text. Enter \P to end a paragraph and start a new paragraph on the next line. (Be sure to capitalize the P.)
5. When your text entry is complete, save your changes and exit the text editor.

Command line  MTEXT
Related  -MTEXT enters and formats multiline text.

Formatting Multiline Text in a Text Editor

If you choose to use a third-party text editor, you can apply formatting by entering format codes. You can underline text, add a line over text, and create stacked text. You also can change color, font, and text height. You can change the spaces between text characters or increase the width of the characters themselves. To apply formatting, use the format codes shown in the following table.
### Format codes for paragraphs

<table>
<thead>
<tr>
<th>Format code</th>
<th>Purpose</th>
<th>Enter this …</th>
<th>To produce this …</th>
</tr>
</thead>
<tbody>
<tr>
<td>\0...\o</td>
<td>Turns overline on and off</td>
<td>Autodesk \OAutoCAD\o 2000</td>
<td>Autodesk AutoCAD 2000</td>
</tr>
<tr>
<td>\L...\l</td>
<td>Turns underline on and off</td>
<td>Autodesk \LAutoCAD\l 2000</td>
<td>Autodesk AutoCAD 2000</td>
</tr>
<tr>
<td>~</td>
<td>Inserts a nonbreaking space</td>
<td>Autodesk \AutoCAD~ 2000</td>
<td>Autodesk AutoCAD 2000</td>
</tr>
<tr>
<td>\</td>
<td>Inserts a backslash</td>
<td>Autodesk \AutoCAD \ 2000</td>
<td>Autodesk AutoCAD 2000</td>
</tr>
<tr>
<td>{…}</td>
<td>Inserts an opening and closing brace</td>
<td>Autodesk {AutoCAD} 2000</td>
<td>Autodesk (AutoCAD) 2000</td>
</tr>
<tr>
<td>\Cvalue;</td>
<td>Changes to the specified color</td>
<td>Autodesk \C2;AutoCAD 2000</td>
<td>Autodesk AutoCAD 2000</td>
</tr>
<tr>
<td>\File name;</td>
<td>Changes to the specified font file</td>
<td>Autodesk \Ftimes; AutoCAD 2000</td>
<td>Autodesk AutoCAD 2000</td>
</tr>
<tr>
<td>\Hvalue;</td>
<td>Changes to the text height specified in drawing units</td>
<td>Autodesk \H2;AutoCAD 2000</td>
<td>Autodesk AutoCAD 2000</td>
</tr>
<tr>
<td>\Hvaluex;</td>
<td>Changes the text height to a multiple of the current text height</td>
<td>Autodesk AutoCAD \H3x;2000</td>
<td>Autodesk AutoCAD 2000</td>
</tr>
<tr>
<td>\S...^...;</td>
<td>Stacks the subsequent text at the , #, or ^ symbol</td>
<td>1.000\S+0.010^0.000; 1.000 -0.010 0.000</td>
<td></td>
</tr>
<tr>
<td>\Tvalue;</td>
<td>Adjusts the space between characters, from .75 to 4 times</td>
<td>\T2;Autodesk</td>
<td>Autodesk AutoCAD 2000</td>
</tr>
<tr>
<td>\Qangle;</td>
<td>Changes obliquing angle</td>
<td>\Q20;Autodesk</td>
<td>Autodesk</td>
</tr>
<tr>
<td>\Wvalue;</td>
<td>Changes width factor to produce wide text</td>
<td>\W2;Autodesk</td>
<td>Autodesk</td>
</tr>
<tr>
<td>\A</td>
<td>Sets the alignment value; valid values: 0, 1, 2 (bottom, center, top)</td>
<td>\A1;1\S1/2</td>
<td>$\frac{1}{2}$</td>
</tr>
<tr>
<td>\P</td>
<td>Ends paragraph</td>
<td>Autodesk \PAutoCAD 2000</td>
<td>Autodesk AutoCAD 2000</td>
</tr>
</tbody>
</table>
Multiline text objects use word wrap to break long lines into paragraphs. If you want AutoCAD to break lines automatically, you can create continuation lines by ending lines with either a backslash (\) or a space character.

For example, if you enter the following text into the text editor, AutoCAD treats the text as one long line and breaks the line based on the width allowed for the multiline text object:

```
Note:
See drawing C-12 for detail
where curb meets ground.
```

Use curly braces (\{\}) to apply a format change only to the text within the braces, as shown in the following example:

```
Autodesk \{H2\}Times.ttf;AutoCAD} 2000
```

```
Autodesk
AutoCAD 2000
```

Braces can be nested up to eight levels deep.

You also can enter control codes within lines or paragraphs to indicate formatting or special characters, such as tolerance or dimensioning symbols.

**To use a third-party text editor to create text**

```
Big text over text/under text
Baseline: 1 1/2
Center: 1 1/2
Topline: 1 1/2
Tolerances: 1.0000 0.000
Architectural: 9-1/16
```

1. From the Draw menu, choose Text ➤ Multiline Text.
2. On the command line, change the justification, line spacing, rotation, and style as needed.
3. When you finish setting properties, specify an insertion point. Then define the boundary by specifying a second point.
When the text editor opens, enter each line below on a separate line in the text editor:

\{H1.5x; Big text\} A2; over text\A1;/\A0; under text\P
\{A0;Baseline: 1 \S1/2;}\P
\{A1;Center: 1 \S1/2;}\P
\{A2;Topline: 1 \S1/2;}\P
\{Tolerances: \A1;1.000\H.75x;\S+0.010^-0.000;}\P
\{Architectural: 9-\{H.666x;\A2;11\A1;/\A0;16\A2;\}^a\P

Save the changes and exit the text editor.

**Command line**  MTEXT

**Related**  -MTEXT creates and formats multiline text on the command line.

### Changing Text with a Text Editor

You can edit text using a third-party text editor by using the same format codes you used to create the original text. To avoid losing format information when you make changes to the text, use the same text editor you used to create the text.

**To edit multiline text in a text editor**

1. From the Modify menu, choose Text.
2. Select the multiline text you want to edit.
3. Enter the new text. For information about text formats, see “Formatting Multiline Text in a Text Editor” on page 389.
4. When your text entry is complete, save your changes and exit the text editor.

**Command line**  DDEDIT

**Shortcut menu**  Select the multiline text object to edit, right-click in the drawing area, and choose Mtext Edit.

**Related**  PROPERTIES changes the location or properties of multiline text. MTEXTED sets the text editor to use for multiline text objects.