Using Blocks and External References

AutoCAD® provides several features to help you manage objects in your drawings. With blocks you can organize and manipulate many objects as one component. You can also associate items of information with the blocks in your drawings—for example, part numbers and prices—by attaching attributes. Specification sheets or bills of materials can be created using this information.

You can attach or overlay entire drawings in your current drawing by using AutoCAD external references, or xrefs. When you open a drawing that contains xrefs, any changes that have been made in the referenced drawing appear in the current drawing.
Working with Blocks

A block is a collection of objects you can associate together to form a single object, or block definition. You can insert, scale, and rotate a block in a drawing. You can explode a block into its component objects, modify them, and redefine the block. AutoCAD updates all current and future instances of that block based on the block definition.

Blocks streamline the drawing process. For example, you can use blocks to

- Build a standard library of frequently used symbols, components, or standard parts. You can insert the same block numerous times instead of re-creating the drawing elements each time.
- Revise drawings efficiently by inserting, relocating, and copying blocks as components rather than individual geometric objects.
- Save disk space by storing all references to the same block as one block definition in the drawing database.

For information about how to create a block, see “Defining Blocks” on page 447.

When you insert a block in your drawing, you are creating a block instance. Each time you insert a block instance, you assign a scale factor and rotation angle to the inserted block. You can also scale a block instance using different values in any coordinate (X, Y, Z) direction.

![Diagram showing block scaling and rotation examples]

default values
\[X\text{ scale } = 0.5\]
\[Y\text{ scale } = 1\]
rotation
\[\text{angle } = 45\]

Blocks make it possible for you to organize your drawing tasks in a systematic way, so that you can set up, redesign, and sort the objects in your drawings and the information associated with them.
Working with Layers and Properties

Blocks can be defined from objects that were originally drawn on different layers with different colors, linetypes, and lineweights. You can preserve the layer and property information of objects in a block. Then, each time you insert the block, you have each object within the block drawn on its original layer with its original color, linetype, and lineweight.

Layers separated and combined

When a block that consists of objects drawn on layer 0 and assigned the color, linetype, and lineweight BYLAYER is placed on the current layer, it assumes the properties of the current layer.

A block that consists of objects that have color, linetype, or lineweight specified with BYBLOCK is drawn with the properties that are current when the block is inserted.

Nesting Blocks

A block reference can contain other blocks nested within it. For example, you can insert a drawing of a mechanical assembly that contains a housing, a bracket, and fasteners, with each fastener composed of a bolt, washer, and nut. The only restriction on nested blocks is that you cannot insert or create blocks that reference themselves.
Nested blocks

Sometimes a nested block contains objects that are on layer 0 or that have color, linetype, and lineweight specified with BYBLOCK. The properties of these objects are determined by the block that contains them in the nested structure.

Although block nesting can be useful, floating layers, colors, linetypes, and lineweights can make nesting complicated if they aren’t used correctly. To minimize confusion, follow these guidelines:

- If all instances of a particular block need the same layer, color, linetype, and lineweight properties, assign properties individually to all objects in the block (including any nested blocks).
- To control the color, linetype, and lineweight of each block instance by using the properties of the layer on which you insert it, draw each of the block’s objects (including any nested blocks) on layer 0 with all properties set to BYLAYER.
- To control the color, linetype, and lineweight of each block instance using the current properties, draw each of its objects (including any nested blocks) with color, linetype, and lineweight set to BYBLOCK. Before creating a block, you can change the layer, color, linetype and lineweight of its constituent objects with PROPERTIES.

Working with Unnamed Blocks

AutoCAD creates unnamed (also called anonymous) blocks to support hatch patterns, associative dimensioning, and PostScript images imported with PSIN. AutoCAD also creates unnamed blocks for objects that you cannot gain
access to directly. You cannot insert unnamed blocks by name; however, you can create them in AutoLISP®. Creating anonymous blocks with AutoLISP is discussed in the Visual LISP Developer’s Guide.

Defining Blocks

You can group objects to create block definitions in the current drawing, or you can save the block as a separate drawing file. When you define a block, you specify the base point, the objects to group, and whether to retain or delete the objects or convert them to a block in the current drawing. You can also enter a text description and specify an icon used to help identify the block definition in AutoCAD DesignCenter™. Block definitions are one of many nongraphical objects saved in a drawing. See “Working with Named Objects” on page 157.

NOTE You cannot use DIRECT, LIGHT, AVE_RENDER, RM_SDB, SH_SPOT, and OVERHEAD as valid block names.

To create a block definition

1. From the Draw menu, choose Block ➤ Make.

2. In the Block Definition dialog box, enter a name for the block.

3. Under Objects, choose the Select Objects button to use the pointing device to select objects for the block definition.
The dialog box closes temporarily while you select objects for the block. Press ENTER when you are done selecting blocks. The dialog box reopens.

4 If you want to create a selection set, use the Quick Select button to create or define a filter for your selection set. See “Filtering Selection Sets” on page 238.

5 Under Objects, specify whether to retain, convert to a block, or delete the selected objects.

- Retain: Keeps selected objects in the current drawing, in their original state.
- Convert to Block: Replaces selected objects with an instance of the block.
- Delete: Removes selected objects after the block is defined.

6 Under Base Point, enter the coordinate values for the insertion base point or choose the Specify Insertion Base Point button to use the pointing device.

7 Under Description, enter text to help identify the block for easy retrieval.

8 Under Icon, specify whether to create an icon from the block definition.

- Do not include an icon: Omits preview image from block definition.
- Create icon from block geometry: Saves preview image with the block definition.

9 Choose OK.

The block definition is saved in the current drawing.

Command line  BLOCK

Related  –BLOCK creates block definitions on the command line.

NOTE  To generate preview images for blocks you created with Release 14 or earlier, use the BLOCKICON command. The command works on your current open drawing and prompts you for the names of blocks that you want updated with preview images. For information about preview images (or block icons), see BLOCKICON.
To save a block or object as a separate drawing file

1 At the Command prompt, enter **wblock**.

2 In the Write Block dialog box, specify a block or an object to write out as a file.
   - **Block**: Specifies a block to save as a file.
   - **Entire Drawing**: Selects current drawing as a block.
   - **Object**: Specifies objects to be saved as a file.

3 Under Block, select a name from the list to save as a file.
4 Under Base Point, use the Pick Point button to define the base point.
5 Under Objects, use the Select objects button to select the object for the block file.
6 Enter a name for the new file.
   If a block is selected, WBLOCK automatically uses that block's name for the new file.
7 In the Insert Units list, select an insert unit to use in AutoCAD DesignCenter.
8 Choose OK.
   The block definition is saved as a drawing file.

**Command line**  **WBLOCK**
**Inserting Blocks**

You can insert blocks or entire drawings into the current drawing with INSERT. When you insert a block or drawing, you specify the insertion point, scale, and rotation angle. This section explains inserting blocks into your drawing using INSERT. See “Using AutoCAD DesignCenter to Insert Blocks” on page 504.

When you insert an entire drawing into another drawing, AutoCAD treats the inserted drawing like any other block reference. Subsequent insertions reference the block definition (which contains the geometric description of the block) with different position, scale, and rotation settings, as shown in the following illustration. If you change the original drawing after inserting it, the changes have no effect on the inserted block. If you want the inserted block to reflect the changes you made to the original drawing, you can redefine the block by reinserting the original drawing.

If you want to insert a drawing but you don’t want the file name to be the same as the block name, you can insert it using a `blockname = filename` syntax at the Block Name prompt.

By default, AutoCAD uses the coordinate 0,0,0 as the insertion base point for inserted drawings. You can change the insertion base point of a drawing by opening the original drawing and using `BASE` to specify a different insertion base point. AutoCAD uses the new base point the next time you insert the drawing.

If the drawing you insert contains objects created in a paper space layout, those objects are not included in the current drawing’s block definition. To use the paper space objects in another drawing, open the original drawing
and use BLOCK to define the paper space objects as a block. The block is now defined within your drawing. You can insert the drawing into another drawing and insert the block defined in your original drawing in either paper space or model space. With AutoCAD DesignCenter, you can display layouts and drag them into your drawings. See “Working with Drawing Content” on page 492.

**NOTE** After insertion, the external file’s WCS is aligned parallel to the XY plane of the current UCS in the current drawing. Thus, a block reference from an external file can be inserted at any orientation in space by setting the UCS before inserting it.

To insert a block reference

1. From the Insert menu, choose Block.

2. In the Insert dialog box, specify the block name, where you want to insert it in the current drawing, and whether you want to explode it after insertion.

3. If you have modified the original drawing file for a block, you can redefine the block in the current drawing by choosing File to locate the file for the block.

4. Choose OK.
   The block reference is updated in the current drawing.

**Command line**  
INSERT

**Related**  
INSERT inserts a block on the command line. MINSERT inserts a block in a rectangular array.
Exploding a Block

Use EXPLODE to break a block instance. By exploding a block instance, you can modify the block or add to or delete the objects that define it.

To explode a block

1. From the Modify menu, choose Explode.
2. Select the block to explode.
3. The block instance is broken into its component objects; however, the block definition still exists in the drawing’s block symbol table.

Command line EXPLODE

Editing Block Descriptions

You can use BLOCK to edit any text descriptions you have saved with block definitions.

To edit a block description

1. From the Draw menu, choose Block ➤ Make.
   The Block Definition dialog box lists the text descriptions of block definitions in the drawing.
2. Select the block definition whose description you want to edit and enter changes to it.
3. Choose OK.

Redefining a Block

You can redefine a named block using BLOCK, specifying the name of the existing block and selecting the new objects and insertion base point. You can also update the text description and specify a different icon. When you redefine a block, all the references to that block in the drawing are immediately updated to reflect the new definition.

NOTE You cannot redefine a block to contain itself.
To redefine a named block

1 From the Draw menu, choose Block ➤ Make.
2 In the Block Definition dialog box, choose List Block Names or Browse and select the name of the block you want to redefine.
3 Modify the block definition using the dialog box options.
4 Choose OK.

Command line  BLOCK

Related  You can use –BLOCK or INSERT to redefine blocks and attribute definitions.

WARNING! Redefinition affects previous as well as future insertions of a block reference. If the block has attached attributes, constant attributes are lost and replaced by any new constant attributes. Variable attributes remain unchanged, even if the new block definition has no attributes. New variable attributes are not added. If you want existing block insertions to use the new attributes, erase the insertions and insert them again.

Working with Attributes

An attribute provides a label or tag for you to attach text to a block. Whenever you insert a block that has a variable attribute, AutoCAD prompts you to enter the data to be stored with the block. Examples of data are part numbers, prices, comments, and owners’ names.
You can extract attribute information from a drawing and use that information in a spreadsheet or database to produce items such as a parts list or a bill of materials (BOM). You can associate more than one attribute with a block, provided that each attribute has a different tag. AutoCAD prompts you for the value of each attribute when you insert the block. You can also define constant attributes: because they have the same value in every occurrence of the block, AutoCAD does not prompt for a value when you insert the block.

Attributes can be invisible, which means the attribute is not displayed or plotted. However, information on the attribute is stored in the drawing file and written to an extract file by ATTEXT.

Creating Attributes

To create an attribute, you must first use ATTDEF to create an attribute definition, which describes the characteristics of the attribute. The characteristics include the tag, prompt, value information, text formatting, location, and any optional modes.

To create an attribute definition

1. On the command line, enter `attdef`.
2. In the Attribute Definition dialog box, specify the insertion point and set the attribute modes and the tag, prompt, and text options.

3. Choose OK.

After creating the attribute definition, you can select it as an object in a block definition. If the attribute definition is incorporated into a block, whenever you insert the block, AutoCAD prompts you with the text string you specified.
for the attribute. Each subsequent instance of the block can have a different value specified for the attribute.

If you want to use several attributes together, create each one separately and then include them in the same block. To control the order of prompts for multiple attributes, see OPTIONS in the Command Reference.

**System variables**  
AFLAGS sets the ATTDEF mode. ATTDISP globally controls the visibility of attributes. ATTREDEF redefines a block and updates associated attributes.

**Editing Attribute Definitions**

You can use DDEDIT to edit an attribute definition before it is associated with a block.

To edit an attribute definition before it is associated with a block

1. From the Modify menu, choose Text
2. Select the attribute to edit.

   ![Edit Attribute Definition dialog box](image)

   3. In the Edit Attribute Definition dialog box, specify the attribute tag, prompt, and default value. Then choose OK.

**Command line**  
DDEDIT

**Related**  
CHANGE edits attribute definitions.

**Attaching Attributes to Blocks**

You can attach attributes to a block when you define or redefine that block. When AutoCAD prompts you to select the objects to include in the block definition, include the desired attributes in the selection set. The order in which you select the attributes determines the order in which you are prompted for attribute information when you insert the block (see “Defining Blocks” on page 447).
Editing Attributes Attached to Blocks

You can edit attributes that are already attached to a block and inserted in a drawing.

To edit an attribute attached to a block

1. From the Modify menu, choose Attribute ➤ Single.
2. Select a block to edit.
3. In the Edit Attributes dialog box, edit the attribute information as necessary.
4. Choose OK.

To control the order of prompts for multiple attributes, see OPTIONS in the Command Reference.

Command line  ATTEDIT

Related  ATTEDIT edits both attribute values and attribute properties individually or globally, independent of the block. CHANGE changes the characteristics of existing objects.

Extracting Attribute Information

You can extract attribute information from a drawing and create a separate text file for use with database software. Extracting attribute information does not affect the drawing. You must create a template file to tell AutoCAD how to structure the file to contain the extracted attribute information.
Extraction Template File

The extraction template file contains all of the information associated with attribute tags, such as part name, model number, cost, or supplier, as shown in the illustration of blocks with attributes (see “Working with Attributes” on page 453). After you create a template file, AutoCAD uses that file to determine what attribute information to extract from the drawing.

Example of template file information

<table>
<thead>
<tr>
<th>Attribute tag</th>
<th>Character or Numeric data</th>
<th>Maximum field length</th>
<th>Decimal places</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>C</td>
<td>040</td>
<td>000</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>C</td>
<td>006</td>
<td>000</td>
</tr>
<tr>
<td>Model</td>
<td>C</td>
<td>015</td>
<td>000</td>
</tr>
<tr>
<td>Cost</td>
<td>N</td>
<td>005</td>
<td>003</td>
</tr>
</tbody>
</table>

Each field in the template file extracts information from the drawing. Each line in the template file specifies one field to be written in the attribute information file, including the name of the field, its character width, and its numerical precision. Each record of the attribute information file includes all the specified fields in the order given by the template file.

The following template file displays the 15 possible fields.

| BL:LEVEL       | Nnnw000                  | (Block nesting level) |
| BL:NAME        | Cww000                   | (Block name)          |
| BL:X           | Nwwwddd                  | (X coordinate of block insertion point) |
| BL:Y           | Nwwwddd                  | (Y coordinate)        |
| BL:Z           | Nwwwddd                  | (Z coordinate)        |
| BL:NUMBER      | Nww000                   | (Block counter; same for MINSERT) |
| BL:HANDLE      | Cww000                   | (Block handle; same for MINSERT) |
| BL:LAYERN      | Cww000                   | (Block insertion layer name) |
| BL:ORIENT      | Nwwwddd                  | (Block rotation angle) |
| BL:XSCALE      | Nwwwddd                  | (X scale factor)      |
| BL:YSCALE      | Nwwwddd                  | (Y scale factor)      |
| BL:ZSCALE      | Nwwwddd                  | (Z scale factor)      |
| BL:XEXTRUDE    | Nwwwddd                  | (X component of block extrusion direction) |
| BL:YEXTRUDE    | Nwwwddd                  | (Y component)         |
| BL:ZEXTRUDE    | Nwwwddd                  | (Z component)         |
| numeric        | Nwwwddd                  | (Numeric attribute tag) |
| character      | Cww000                   | (Character attribute tag) |

The template file can include any or all of the BL:xxx field names listed. The template file must include at least one attribute tag field. The attribute tag fields determine which attributes, hence which blocks, are included in the
attribute information file. If a block contains some, but not all, of the specified attributes, the values for the absent ones are filled in with blanks (if characters) or zeros (if numeric). Block references that do not contain any of the specified attributes are excluded from the attribute information file. Each field can appear no more than once in the template file.

The comment fields should not be included in the template file.

To create a template file

1. From the Start menu (Microsoft® Windows®), choose Programs.
2. From the Accessories program group, choose Notepad.
   You can use any text editor or word processor that can save a text file in ASCII format.
3. Enter template information in Notepad and save with a .txt file extension.

To extract data about a specific tag, insert the tag name in place of the “numeric” or “character” fields.

**WARNING!** Do not use tab characters when constructing the template file with a word processor. If you use tab character alignment, the attribute information file is not created. To align the columns, insert ordinary spaces by pressing SPACEBAR. The use of tab characters may cause inconsistent alignment.

Attribute Information Files

An attribute is extracted only if its tag name matches the field name specified in the template file. ATTEXT extracts the attribute information using one of the following formats:

- Comma-delimited file (CDF)
- Space-delimited file (SDF)
- Drawing interchange file (DXF)

The CDF format option produces a file containing one record for each block reference in the drawing. A comma separates the fields of each record, and single quotation marks enclose the character fields. Some database applications can read this format directly.

The SDF format option also produces a file containing one record for each block reference in a drawing. The fields of each record have a fixed width and employ neither field separators nor character-string delimiters.

The DXF™ format option produces a subset of the AutoCAD drawing interchange file format containing only block references, attributes, and
end-sequence objects. DXF format extraction requires no template. The file extension .dx is used to distinguish the output file from normal DXF files.

The following is a sample template file.

```
BL:NAME        C008000 (Block name, 8 characters)
BL:X           N007001 (X coordinate, format nnnnn.d)
BL:Y           N007001 (Y coordinate, format nnnnn.d)
SUPPLIER       C016000 (Manufacturer's name, 16 characters)
MODEL          C009002 (Model number, 9 characters)
PRICE          N009002 (Unit price, format nnnnn.dd)
```

Using this template file, you can extract attribute information with ATTEXT.

**To extract attribute information**

1. On the command line, enter `attext`.

2. In the Attribute Extraction dialog box, specify the appropriate file format: CDF, SDF, or DXF.

3. Specify the objects to extract attributes from by choosing Select Objects. You can select a single block or multiple blocks in the drawing.

4. Specify the template file to use by entering the file name or by choosing Template File and browsing.

5. Specify the output attribute information file by entering the file name or by choosing Output File and browsing. If you do not specify any objects, ATTEXT extracts information from any blocks with attributes in the drawing that match the template.

6. Choose OK.

**Command line** ATTEXT

**Related** - ATTEXT extracts attribute information from the command line. You can also associate information with objects using extended data (xdata).
Using External References

An external reference (xref) links another drawing to the current drawing. When you insert a drawing as a block, the block definition and all of the associated geometry are stored in the current drawing database. The block is not updated if the original drawing changes. When you insert a drawing as an xref, however, the xref is updated when the original drawing changes. A drawing containing xrefs always reflects the most current editing in each externally referenced file.

Like a block reference, an xref is displayed in the current drawing as a single object. However, an xref does not significantly increase the file size of the current drawing and cannot be exploded. As with block references, you can nest xrefs that are attached to your drawing.

By attaching xrefs, you can

■ Assemble a master drawing from component drawings that may undergo changes as a project develops.
■ Coordinate your work with the work of others by overlaying other drawings on your drawing to keep up with the changes being made by other users.
■ Ensure that the most recent version of the referenced drawing is displayed. When you open or plot your drawing, AutoCAD automatically reloads each xref, so the drawing reflects the latest changes to the referenced drawing file.
■ Display only a specific section of the xref file in the master drawing by creating clipped boundaries of xrefs.

Updating Xrefs

When you open or plot your drawing, AutoCAD reloads each xref to reflect the latest version of the referenced drawing. After someone makes changes to an externally referenced drawing and saves the file, other users can access the changes immediately by reloading the xref.

Updating Xrefs

xref attached
edited xref file
xref updated
Managing Xrefs

The Xref Manager displays the status of each xref and the relationship of xrefs to one another. You can

- Attach a new xref
- Detach an existing xref
- Reload or unload an existing xref
- Change an attachment to an overlay, or vice versa
- Bind the entire xref definition to the current drawing
- Change the xref path

To open the Xref Manager

- From the Insert menu, choose Xref Manager.

**Command line**  
XREF

**Shortcut menu**  
Select an xref, right-click in the drawing area, and choose Xref Manager.

You can view the xrefs in either a list view or a hierarchical tree view. To choose a view, click either Tree View or List View in the upper-left corner. The list view is displayed by default.

**Displaying List View**

When the Xref Manager is open, you can choose List View to display an alphabetical list of the xref definitions in the current drawing. Each xref is defined by the following:

- Reference name
- Status
- File size
- Xref type (attachment or overlay)
- File date
- Saved path
Click a list column heading to sort the xrefs by the column name. For example, to sort by name, click the Reference Name column heading; to sort by size, click the Size column heading.

Selecting any field in the list highlights the xref name. To edit the xref name, select it again, and then enter a new name. The Status column indicates the state of the xref definitions in the drawing or the action to be taken when you close the dialog box. The following states appear in the Status column:

- **Loaded**: Indicates xref was found when the drawing was opened or reloaded.
- **Unloaded**: Indicates xref was unloaded by user.
- **Unreferenced**: Indicates unreferenced nested xrefs. When an xref with nested xrefs is unloaded, not found, or unresolved, its nested xrefs are unreferenced because the parent xref is no longer present in the drawing. If a parent xref is unloaded, a message is displayed stating that its nested xrefs are “orphaned.”
- **Not found**: Indicates xref was not found when the drawing was opened or reloaded.
- **Unresolved**: Indicates xref file was found but could not be read by AutoCAD.

The Type column indicates whether the xref is an attachment or an overlay. By double-clicking the Type column, you can switch an xref between attachment and overlay. The Date column contains the last date the referenced drawing file was saved. This column is displayed only when the xref is loaded. If an xref is not loaded, not found, or unreferenced, the Date and Size columns are blank. Changes take effect when you close the Xref Manager.
Displaying Tree View

When you click the Tree View icon, a hierarchical representation of the xrefs is displayed. The top level of the tree view is listed in alphabetical order. Xref information displayed includes the levels of nesting within xrefs, their relationship to one another, and whether they have been resolved.

The tree view displays only the relationships between xrefs. It does not display the number of attachments or overlays associated with the drawing. Repeated attachments of the same xref are not displayed in the tree view.

Attaching Xrefs

Attached xrefs are designed to help you build drawings using other drawings. By attaching drawings as xrefs, as opposed to inserting drawing files as blocks, you can display changes to the externally referenced drawing in the host drawing each time it is opened; the host drawing always reflects the latest revisions made to the referenced files.

Xrefs can be nested within other xrefs. You can attach as many xrefs as you want, and each can have a different position, scale, and rotation. You can also control the dependent layers and linetype properties that are defined in that xref.

When you attach an xref, all of its dependent named objects, such as layers, linetypes, dimension styles, blocks, and text styles, are added to the current drawing’s nongraphical object information, prefixed with the xref name and the pipe (|) character. For example, if you have an xref with the name OFFICEBUILDING that has a layer in it named FLOOR ONE, AutoCAD adds the layer to the drawing’s layer nongraphical object information, as OFFICEBUILDING|FLOOR ONE.
The xref you attach to your drawing is included when your drawing is attached as an xref to another drawing. Because the geometry associated with the externally referenced drawing is visible in the current drawing, but stored in the external reference drawing, the drawing size does not increase significantly.

When a drawing references an xref, AutoCAD attaches only the xref definition to the drawing, unlike regular blocks, whose block definition and contents are stored with the current drawing. AutoCAD reads the reference drawing to determine what to display in the current drawing. If the reference file is missing or corrupt, its data is not displayed in the current drawing. Each time you open a drawing, AutoCAD loads all graphical and non-graphical objects (such as layers, linetypes, text styles) from referenced files. If VISRETAIN is on, AutoCAD stores any updated xref-dependent layer information in the current drawing. See “Using AutoCAD DesignCenter to Attach External References” on page 505.

To attach a new xref

1. From the Insert menu, choose External Reference.
2. In the Select Reference File dialog box, select a drawing, and then choose Open.
   After you select a file to attach, the External Reference dialog box is displayed.
3. In the External Reference dialog box under Reference Type, select Attachment.
4. Specify the insertion point, scale, and rotation angle. Choose Specify On-screen to use the pointing device.
5. Choose OK.

Command line XATTACH

Using Xrefs with Drawing Order

If you reference a drawing that has an attached image or other objects that have been edited with the DRAWORDER command, the drawing order within the xref will not be in the original order, even after regenerating the drawing. If you plot the drawing without correcting the drawing order, geometry in the drawing that was intended to be hidden by other objects may be visible. To correct the drawing order, use the following procedure. See “Changing the Drawing Order of Objects” on page 143.
To restore the drawing order of externally referenced images

1. Open the xref file.
2. At the Command prompt, enter `draworder`, and then specify the drawing order of the xref drawing.
3. At the Command prompt, enter `wblock`, and choose the Entire Drawing option in the Write Block dialog box to create a new drawing from the xref file. Choose OK to close the dialog box.
4. At the Command prompt, enter `xattach` to attach the file you created using WBLOCK.

**Overlaying Xrefs**

Overlaying is similar to attaching, except that when a drawing is attached or overlaid, any other overlays nested in it are ignored and, therefore, not displayed. In other words, nested overlays are not read in.

It is recommended that you use overlaying when you are referencing geometry that is not useful for other users to see when they reference your drawing. For example, you may have created a wiring plan for a house and need to reference the floor plan of the house. If you have chosen to overlay (rather than attach) the floor plan, then another user who doesn’t need to see the floor plan could xref your wiring plan without the floor plan attached.

Overlaid xrefs are designed for data sharing. By overlaying an xref, you can see how your drawing relates to other drawings. Also, overlaying an xref reduces the possibility that you might create self-referencing drawings (circular xrefs).

To overlay an xref

1. From the Insert menu, choose External Reference.
   After you select a file to attach, the External Reference dialog box is displayed.
2. In the External Reference dialog box under Reference Type, select Overlay.
3. Specify insertion point, scale, and rotation angle. Choose Specify On-Screen to use the pointing device.
4. Choose OK.

**Command line**  
`XATTACH`
Deciding Whether to Attach or to Overlay an Xref

The following illustrations show the difference between attached and overlaid drawings. The upper illustrations show the type of xref used. The lower illustrations show what you see on your screen when you open each file.

In the “Attached xrefs” illustration, trees.dwg is attached to topo.dwg. topo.dwg is either attached to or overlaid on house.dwg. Notice that when you open house.dwg, you also see both trees.dwg and topo.dwg. You see trees.dwg because it is attached. You see topo.dwg because it is overlaid and is no more than one level of xref from house.dwg.

In the “Overlaid xrefs” illustration, trees.dwg is overlaid on topo.dwg. topo.dwg is either attached to or overlaid on house.dwg. Notice that when you open house.dwg, you see only topo.dwg and house.dwg. You do not see trees.dwg because it is overlaid.
Overlaid xrefs

Detaching Xrefs

Detach removes xrefs from the drawing. When you detach an xref, AutoCAD erases all xref copies, deletes the xref definition, and removes the xref from the tree and list views. All nongraphical information (such as layers and linetypes) is also deleted. You cannot detach nested xrefs, nor can you detach a top-level xref if it is a nested xref of another xref in the xref tree.

To detach an xref

1. From the Insert menu, choose Xref Manager.
2. In the Xref Manager, select an xref and then choose Detach.
3. Choose OK.

Command line  XREF

Shortcut menu  Select the xref to detach, right-click in the drawing area, and choose Xref Manager.

Reloading Xrefs

When you reload an xref, AutoCAD reads the most recently saved version of the referenced file into the drawing and updates the xref definition to ensure that the current version of the reference is loaded.
If demand loading is on when you load the xref, the referenced drawing, or a referenced drawing copy, remains open during the current session. When you reload a demand loaded xref, if the XLOADCTL system variable is set to 1, no one else can access the referenced drawing. If XLOADCTL is set to 2, AutoCAD loads a temporary copy of the most recently saved version of the referenced file. See “Demand Loading and Maximizing Xref Performance” on page 470.

To reload an xref
1. From the Insert menu, choose Xref Manager.
2. In the Xref Manager, select an xref and then choose Reload.
3. Choose OK.

Command line  XREF

Shortcut menu  Select the xref to reload, right-click in the drawing area, and choose Xref Manager.

Unloading Xrefs

When an xref is unloaded from the current drawing, the drawing opens much faster and uses less memory. The xref definition is unloaded from the drawing file, but the pointer to the reference drawing remains. The xref is not displayed, and nongraphical object information does not appear in the drawing. However, you can restore all the information by reloading the xref. If XLOADCTL (demand loading) is set to 1, unloading the drawing unlocks the original file.

You should unload a reference file if it is not needed in the current drawing session but may be used later for plotting. You can maintain a working list of unloaded xrefs in the drawing file that you can load as needed.

To unload an xref
1. From the Insert menu, choose Xref Manager.
2. In the Xref Manager, select an xref and then choose Unload.
3. Choose OK.

Command line  XREF

Shortcut menu  Select the xref to unload, right-click in the drawing area, and choose Xref Manager.
**Binding Xrefs**

Binding an xref to a drawing makes the xref a permanent part of the drawing rather than an externally referenced file. The externally referenced information becomes a block. When the externally referenced drawing is updated, the bound xref is not updated. Use XREF Bind to bind the entire drawing’s database, including all of its non-graphical object information. Use XBIND if you want to pick and choose non-graphical information to bind. For example, you may want to bind xref layers, but not linetypes or text styles.

Binding xrefs to drawings is useful if you’re archiving drawings and want to ensure that the xrefs do not change. It’s also an easy way to send drawings to reviewers. Rather than send a master drawing plus each of the drawings it references, you can use the Bind option to convert those xrefs to blocks in the current drawing.

Only loaded xrefs can be bound. If you select an unloaded xref, the Bind button is unavailable. You must reload the xref to bind it.

When final drawings that have xrefs are ready for archiving, either archive the xref drawing along with the master drawing or bind the xrefs to the master drawing. These procedures prevent unintentional updating of archived drawings by xrefs that are later changed.

You can bind an xref to a drawing using either Bind or Insert. The option you choose determines how named objects, such as linetypes, layers, and text styles (see “Working with Named Objects” on page 157), are integrated into the drawing. If you use Bind, named objects are prefixed with a blockname$x$ string, where $x$ is a number that is automatically incremented to avoid overriding named objects in the drawing.

If you use Insert, named objects are merged into the drawing without any prefixes. If duplicate named objects exist, AutoCAD uses the named objects in the drawing. If you do not know whether duplicate named objects exist, use Bind rather than Insert.

**To bind an xref to a drawing**

1. From the Insert menu, choose Xref Manager.
2. In the Xref Manager, select an xref and then choose Bind.
3. In the Bind Xrefs dialog box, select Bind.
4. Choose OK to exit each dialog box.

**Command line**  XREF

**Shortcut menu**  Select the xref to bind, right-click in the drawing area, and choose Xref Manager.
To bind using the Insert option

1. From the Insert menu, choose Xref Manager.
2. In the Xref Manager, select an xref, and then choose Bind.
3. In the Bind Xrefs dialog box, select Insert.
4. Choose OK to exit each dialog box.

**Command line**  XREF

**Shortcut menu**  Select the xref to bind, right-click in the drawing area, and choose Xref Manager.

The nongraphical object definitions associated with the externally referenced file are merged into the drawing without a prefix.

With XBIND you can bind xref-dependent named objects to the current drawing’s symbol table without binding the entire xref.

The XBind dialog box provides a list of all xref definitions and their dependent symbols in the drawing. Each xref definition can be expanded to show its dependent symbols.

To bind dependent symbols to the current drawing

1. At the Command prompt, enter `xbind`.
2. In the XBind dialog box, expand the xref name and the symbol table.
3. Select the dependent symbol you want to bind, and then choose Add.
   - The dependent symbols you select are added to the Definitions to Bind list.
4. Choose OK.
   - The dependent symbols are added to your drawing and can be used the same way you use other named objects. AutoCAD removes the vertical bar character (|) from each dependent symbol name and replaces it with two dollar signs ($) separated by a number (usually zero), for example, `STAIRS$0$STEEL`.

**Command line**  XBIND

**Demand Loading and Maximizing Xref Performance**

Through a combination of demand loading and saving drawings with indexes, you can increase the performance of drawings with external references. Demand loading works in conjunction with the XLOADCTL and INDEXCTL system variables. When you turn on demand loading, if indexes have been saved in the referenced drawings, AutoCAD loads into memory only the data
from the reference drawing that is necessary to regenerate the current drawing. In other words, referenced material is read in “on demand.”

To realize the maximum benefits of demand loading, you need to save the referenced drawings with layer and spatial indexes. The performance benefits of demand loading are most noticeable when you do one of the following:

- Clip the xref to display a small fraction of it, and a spatial index is saved in the externally referenced drawing.
- Freeze several layers of the xref, and the externally referenced drawing is saved with a layer index.

If demand loading is turned on, and you have clipped xrefs that were saved with spatial indexes, objects in the external reference database that are contained within the clip volume comprise the majority of the objects read into the drawing. If the clip volume is modified, more objects are loaded as required from the reference drawing. Similarly, if you have xrefs with many layers frozen that were saved with layer indexes, only the objects on those thawed layers are read into the current drawing. If those xref-dependent layers are thawed, AutoCAD reads in that geometry from the reference drawing as required.

When demand loading is turned on, AutoCAD places a lock on all reference drawings so that it can read in any geometry it needs to on demand. Other users can open those reference drawings, but they cannot save changes to them. If you want other users to be able to modify an xref that is being demand loaded into another drawing, use demand loading with the Copy option.

If you turn on demand loading with the Enable with Copy option, AutoCAD makes a temporary copy of the externally referenced file and demand loads the temporary file. You can then demand load the xref while allowing the original reference drawing to be available for modification. When you turn off demand loading, AutoCAD reads in the entire reference drawing regardless of layer visibility or clip instances.

Layer and spatial indexes were added in AutoCAD Release 14. If you externally reference a drawing saved in an AutoCAD release previous to Release 14, you do not see the same performance benefit as Release 14 and AutoCAD 2000 drawings saved with the indexes. For maximum performance, use demand loading with referenced Release 14 and AutoCAD 2000 drawings saved with layer and spatial indexes.
To turn on demand loading

1. From the Tools menu, choose Options.
2. In the Options dialog box, choose the Open and Save tab.
3. On the Open and Save tab under External References, select Disabled, Enabled, or Enabled with Copy.
4. Choose OK.

**System variables**  
XLOADCTL set to 1 (the default) turns on demand loading.  
XLOADCTL set to 2 turns on demand loading with the Copy option.  
XLOADCTL set to 0 turns off demand loading.

**Using Layer and Spatial Indexes**

To receive the maximum benefit of demand loading, it is recommended that you save any drawings that are used as xrefs with layer and spatial indexes.

A layer index is a list showing which objects are on which layers. This list is used when AutoCAD is referencing the drawing in conjunction with demand loading to determine which objects need to be read in and displayed. Objects on frozen layers in an external reference are not read in if the external reference has a layer index and is being demand loaded.

The spatial index organizes objects based on their location in 3D space. This organization is used to efficiently determine which objects need to be read in when the drawing is being demand loaded and clipped as an external reference. If demand loading is turned on, and the drawing is attached as an xref and clipped, AutoCAD uses the spatial index in the externally referenced drawing to determine which objects lie within the clip boundary. AutoCAD then reads only those objects into the current session.

Spatial and layer indexes are best used in drawings that will be used as xrefs in other drawings where demand loading is enabled. Drawings that are not going to be used as xrefs will not benefit from layer and spatial indexing or demand loading.

To save a drawing with layer and spatial indexes

1. From the File menu, choose Save As.
2. In the Save Drawing As dialog box, choose Options.
3 In the Saveas Options dialog box, under Index Type, select Layer, Spatial, or Layer & Spatial, and then choose OK.

**NOTE** If you are saving a partially open drawing that does not already contain layer and spatial indexes, this option is disabled. For information on partially opening a drawing, see “Using Partial Open and Partial Load” in chapter 9, “Editing Methods.”

4 Choose Save.

**System variables** INDEXCTL set to 1 creates a layer index. INDEXCTL set to 2 creates a spatial index. INDEXCTL set to 3 creates both layer and spatial indexes. INDEXCTL set to 0 (the default) does not create an index.

**Setting the File Path for Xref Copies**

When you turn on demand loading with copy, the XLOADPATH system variable can be used to indicate the path where copies of externally referenced files are to be placed. The path you specify remains in effect for all drawing sessions until you indicate a different path. If no value for XLOADPATH is specified, the temporary file copies are placed in the standard AutoCAD directory for temporary files.

If you find that referencing drawings over a network is slow, it is recommended that you set XLOADPATH to reference a local directory, and set XLOADCTL to 2 so that the externally referenced files are demand loaded from your local machine. Conversely, to minimize the number of temporary files created by multiple users referencing the same drawing, those users can set XLOADPATH to point to a common directory. In this manner, multiple sessions of AutoCAD can share the same temporary copies of reference drawings.

You can set XLOADPATH in the Options dialog box and indicate the path where copies of externally referenced files are to be placed.
To set the file path for xref copies

1. From the Tools menu, choose Options.
2. In the Options dialog box, choose the Files tab.
3. On the Files tab, select the Temporary External Reference File Location folder.
   The expanded tree view displays the path where copies of xref files are placed.
   If no path is specified, AutoCAD places the temporary copies in the location specified by Temporary Drawing File Location.
4. Edit the path by selecting it and entering a new path.
5. Choose OK (or Apply) to set the path.

Controlling Named Objects in Xrefs

In addition to the drawing’s graphical objects, AutoCAD includes the drawing’s named objects in the xref definition, such as blocks, dimension styles, layers, linetypes, and text styles (see “Working with Named Objects” on page 157). AutoCAD differentiates the named objects in xrefs from those in the current drawing by preceding their names with the name of the externally referenced drawing. For example, a layer named STEEL-HIDDEN in an externally referenced drawing entitled stair.dwg is listed as STAIR|STEEL-HIDDEN.

A named object’s definition can change, or even disappear, if it is purged from the referenced drawing. Therefore, you cannot reference a dependent named object directly. For example, you cannot insert a dependent block or make a dependent layer the current layer and begin creating new objects on it. If you wish to add a dependent symbol to the current drawing, use XBIND.

Although you cannot select named objects, you can control the visibility, color, and linetype of an xref’s layers. The VISRETAIN system variable controls dependent layer properties. If VISRETAIN is set to 0, any changes you make apply only to the current drawing session. In other words, the next time the drawing is opened, the dependent layer settings revert back to the last saved settings in the original referenced file.

By default, VISRETAIN is set to 1, which means any dependent layer attributes set in the current drawing persist from session to session. When you save the file or use the XREF Reload option, the current layer visibility settings for dependent layers are saved with the current drawing. Reloading an xref doesn’t alter layer settings you have overridden in the current drawing.
Changing Xref Paths

If you open a drawing that contains an xref that has been moved to a directory other than the one that was saved with the xref, and it can’t be found in the Project or AutoCAD search paths, the Xref Manager displays its status as “Not found” in the xref list, and the Xref Found At box is blank. When you choose Browse and select a new path and file name in the Select New Path dialog box, the new path and file name are displayed in the Saved Path column in the list view and also in the Xref Found At box.

You can remove the path from the file name or specify a relative path by directly editing the path in the Xref Found At box and then choosing Save Path.

You can change only one xref path at a time. If you select multiple xrefs, you cannot use the Path option.

To change an xref path

1. From the Insert menu, choose Xref Manager.
2. In the Xref Manager, select the xref whose path you want to edit.
3. Choose Browse.
4. In the Select New Path dialog box, enter a new path and then choose Open.
5. Choose OK.

The new path is displayed in the Xref Manager in the Saved Path field of the list view and in the Found At box.

An alternate method of changing an xref path is to edit the path in the Xref Found At box, and then choose Save Path.

Command line  XREF
Shortcut menu  Select the xref, right-click in the drawing area, and choose Xref Manager.

Changing Nested Xref Paths

If the path of a nested xref is changed in the current drawing, the change is saved only if the VISRETAIN system variable is set to 1. If AutoCAD cannot save a changed nested xref path with the current drawing, the following message is displayed:

VISRETAIN must be On to save nested Xref path.
When the drawing is reopened and the nested xref is loaded, AutoCAD attempts to find the xref in the original xref path first. If the xref is not found, AutoCAD searches the Project path and Support File search path saved in the current drawing. This ensures that revisions made to the xref are reflected in the current drawing and also makes it possible for the xref to be found if its path has changed.

For example, the xref tree of the current drawing A is A>B>C, and the owner of drawing B changes the path of xref C to point to C1.dwg. When drawing A is reopened, it reflects the path change in drawing B and displays C1.dwg. However, if C1.dwg is not found, AutoCAD looks for xref C at the last location it was saved in drawing A.

**Using Project Names to Define Xref Paths**

Project names make it easier for you to manage xrefs when drawings are exchanged between customers or if you have different drive mappings to the same location on a server. The project name points to a section in the registry that can contain one or more search paths for each project name defined.

If AutoCAD cannot find an xref at the location specified by the search path, the prefix (if any) is stripped from the path. If the drawing has a PROJECTNAME value set and a corresponding entry exists in the registry, AutoCAD searches for the file along the project search paths. If the xref still is not located, the AutoCAD search path is searched again.

**To display the currently defined project names**

1. From the Tools menu, choose Options.
2. In the Options dialog box on the Files tab, double-click Project Files Search Path.
3. Click each project name folder to display the search paths associated with it.
4. Choose OK (or Apply).

**Creating and Modifying Project Names**

You can add, remove, or modify the project names that exist in the registry. The directory search paths beneath the project name can also be added, removed, or modified.

**To add a project name**

1. From the Tools menu, choose Options.
2. In the Options dialog box on the Files tab, double-click Project Files Search Path, and then choose Add.
   
   A folder named projectx (where x indicates the next available number) is created and indented beneath the project folder.
3 Either enter a new name, or press ENTER to accept projectx.
   The project name must be 31 characters or fewer, and it cannot contain leading spaces or terminating spaces.
4 Choose OK (or Apply).

To remove a project name
1 From the Tools menu, choose Options.
2 In the Options dialog box on the Files tab, double-click Project Files Search Path.
3 Select a project name and then choose Remove.
4 Choose OK (or Apply).

To modify a project name
1 From the Tools menu, choose Options.
2 Select a project name and then enter a new name.
3 Choose OK (or Apply).

   You can also modify a project name by selecting the name in the project folder and pressing F2.

Creating and Modifying Search Paths
The search paths beneath the project name can be added, removed, or modified in the same manner as the project name. The order in which the directories are searched can also be modified. Projects and their search paths can only be edited through the Files tab in the Options dialog box. There is no way to edit project names on the command line.

To add a search path
1 From the Tools menu, choose Options.
2 In the Options dialog box on the Files tab, select a project name, and then choose Add.
3 Add a new search path beneath the project name by entering a new path, or choose Browse and select a new path.
4 Choose OK (or Apply).
   The new path is indented and placed beneath the project name.
To delete a search path

1. From the Tools menu, choose Options.
2. In the Options dialog box on the Files tab, select a project name, and then choose Remove.
3. Choose OK.

To change a search path

1. From the Tools menu, choose Options.
2. In the Options dialog box on the Files tab, select a project name, and then choose Browse.
3. In the Choose Directory dialog box, select a new path.
4. Choose OK to exit each dialog box.

You can also change a search path by selecting the project path and pressing F2.

Setting the Current Project

Once you have established a project name and the search paths you want associated with that project name, you can make that project name the currently active project. AutoCAD searches the paths associated with that currently active project for xrefs that were not found in the full search path, the current drawing directory, or the AutoCAD support paths.

To set a project current

1. From the Tools menu, choose Options.
2. In the Options dialog box on the Files tab, double-click Project Files Search Path.
3. Select a Project name, and then choose Set Current.
4. Choose OK (or Apply).

You can also set a project current by entering `projectname` on the command line and then entering the name of the project.

To clear the current project

1. From the Tools menu, choose Options.
2. In the Options dialog box on the Files tab, click Project Files Search Path.
3. Choose Clear Current.
   This clears the setting for the current drawing.
4. Choose OK (or Apply).

You can clear the current project at the Command prompt by entering `projectname` and then entering a period (.)
Handling Xref Errors

You may encounter two types of error messages when you use the external reference feature: messages indicating missing reference files or circular references.

Missing Reference Files

AutoCAD stores the file name of the drawing used to create the external reference. Each time you open or plot the drawing or use the XREF Reload option to update the external reference, AutoCAD checks the file name to determine the name and location of the associated drawing file. If the name of the drawing associated with the xref has changed, AutoCAD cannot read the external reference. If the drawing has been moved and doesn’t exist in the AutoCAD support path, the current drawing directory, or the directories specified by a current project, AutoCAD cannot resolve the xref.

If AutoCAD cannot load an external reference when it is opening your drawing, it displays an error message. In the following example of an error message, AutoCAD cannot find the xref `house`.

```
Resolve XREF House: \acad\dwg\house.dwg
Can’t find \acad\dwg\house.dwg
```

For each insertion of the unresolved external reference, AutoCAD displays a single piece of text (at the insertion point, scale, and rotation angle of the original reference) that contains the path name of the missing xref, and the Xref Manager displays the xref as “Not found.” You can use the XREF Path option to update or correct the path name.

Circular References

A reference file that contains a sequence of nested references that refers back to itself is considered a circular reference. For example, if drawing A attaches drawing B, which attaches drawing C, which attaches drawing A, the reference sequence A>B>C>A is a circular reference.

If AutoCAD detects a circular reference while attaching an xref, a warning is displayed asking you if you want to continue. If you respond with yes, AutoCAD reads in the xref and any nested xrefs to the point where it detects the circularity. If you respond with no, AutoCAD halts the process and the xref is not attached.

If AutoCAD encounters a circular reference while loading a drawing, it displays an error message and breaks the circular reference for the current session. For example, if you have the circular reference A>B>C>A, and you open `a.dwg`, AutoCAD detects and breaks the circularity between `c.dwg` and `a.dwg`. The following error message is displayed:

```
Breaking circular reference from C to current drawing.
```
Using the Xref Log File

AutoCAD can maintain a log of its actions when attaching, detaching, and reloading xrefs and when it loads a drawing containing xrefs. This log is maintained only if the XREFCTL system variable is set to 1. The system default setting is 0.

The log file is an ordinary ASCII text file. It has the same name as the current drawing, and its file extension is .xlg. If you load a drawing called sample.dwg, for example, AutoCAD searches for a log file named sample.xlg in the current directory. If the file does not exist, AutoCAD creates a new file with that name if XREFCTL is set to 1.

Once a log file has been created for a drawing, AutoCAD continues to append to it. If the log file becomes too large, you can delete it.

AutoCAD writes a title block to the log file each time the file is opened. This title block contains the name of the current drawing, the system date and time, and the operation being performed.

```
Drawing: detail
Date/Time: 09/28/97 10:45:20
Operation: Attach Xref
```

When detaching or reloading xrefs, AutoCAD prints the nesting level of all affected xrefs immediately following the title block. To see a reference tree for a set of xrefs in your current drawing, choose Detach or Reload in the Xref Manager and check the resulting entries in the log file. In the following examples, the xref entry_dr contains two nested xrefs: hardware and panels. The xrefs hardware and panels also each contain two xrefs.

```
Drawing: detail
Date/Time: 10/05/97 15:47:39
Operation: Reload Xref
```

Reference tree for ENTRY_DR:

```
ENTRY_DR       Xref
   —HARDWARE   Xref
   —LOCKSET    Xref
   —HINGES     Xref
   —PANELS     Xref
   —UPPER      Xref
   —LOWER      Xref
```

AutoCAD writes an entry in the log file for each dependent symbol temporarily added to the current drawing and for any errors that occur. Most error messages are written both to the screen and to the log file.
The following example shows a partial listing of the log file entries generated when the external reference stair is attached to the working drawing test.dwg. The log file lists the symbol table affected and the name of the symbol added, along with a status message.

```
Drawing: test
Date/Time: 12/18/97 14:06:34
Operation: Attach Xref

Attach Xref STAIR: \ACAD\DWGS\STAIR.dwg

Searching in ACAD search path

Update block symbol table:
  Appending symbol: STAIR|BOLT
  Appending symbol: STAIR|BOLT-HALF

block update complete.

Update Ltype symbol table:
  Appending symbol: STAIR|DASHED
  Appending symbol: STAIR|CENTER
  Appending symbol: STAIR|PHANTOM

Ltype update complete.

Update Layer symbol table:
  Appending symbol: STAIR|STEEL-HIDDEN
  Appending symbol: STAIR|OAK

Layer update complete.

STAIR loaded.
```

**Clipping Blocks and Xrefs**

After attaching a drawing as an xref or inserting a block, you can define a clipping boundary by using XCLIP. A clipping boundary can define a portion of a block or xref while suppressing the display of geometry outside of the boundary. Clipping applies to an individual instance of an xref, not the xref definition itself. The portion of the xref or block within the clipped boundary remains visible, and the remainder of the xref or block becomes invisible. The referenced geometry is not altered, only the display of the xref is edited.

You can use XCLIP to create a new clipping boundary, delete an existing boundary, or generate a polyline object coincident with vertices of the clipping boundary. Xref clipping can be turned on or off. When a clipping boundary is turned off, the boundary is not displayed and the entire xref is visible, provided that the geometry is on a layer that is on and thawed. When a clipping boundary is turned off, it still exists and can be turned on. However, deleting
Clipping Boundaries

An xref clipping boundary can be specified as a rectangular window or a polygonal boundary. You can also select a polyline to define the clipping boundary. The boundary can be specified anywhere in 3D space, but it is always applied planar to the current UCS. If a polyline is selected, the clipping boundary is applied in the plane of that polyline.

Rectangular Window Clipping Boundary

When you specify a rectangular clipping boundary, you are prompted for the corners of the window. The window is drawn parallel to the current UCS, and the clipping boundary is applied normal to the plane it lies on.

Polygonal Clipping Boundary

When you specify a polygonal clipping boundary, you are prompted to enter points to define the boundary. As you specify the clipping points, AutoCAD sketches the last segment of the polygon so that the boundary is closed at all times. When you apply polygonal clipping to images in externally referenced drawings, the clipping boundary is applied to the rectangular extents of the polygonal boundary, rather than to the polygon itself.

Polyline Clipping Boundary

When you specify a polyline clipping boundary, you are prompted to select a 2D polyline object. The clipping boundary is created coincident with the polyline. Valid boundaries are 2D polylines with straight or spline-curved segments. Polylines with arc segments, or fit-curved polylines, can be used as the definition of the clip boundary, but the clip boundary will be created as a straight segment representation of that polyline. If the polyline has arcs, the clip boundary is created as if it had been decurved prior to being used as a clip boundary. An open polyline is treated as if it were closed.
Defining Clip Depth

The front and back clipping planes for xrefs can be set. The xref must contain a clipping boundary before you can specify a *clip depth*. The clip depth is always calculated normal to the clipping boundary. When defining clip depth, you are prompted to specify a front and back point or distance relative to the clipped plane. Regardless of the current UCS, the clip depth is applied parallel to the clipping boundary.

To clip a reference

1. On the Command line, enter `xclip`.
2. Select a reference.
3. At the prompt, select New Boundary by pressing ENTER.
4. Select a rectangular or polygonal clipping boundary, and then specify the corners or vertices of the boundary.

AutoCAD clips the image based on the area that you specified and hides the portion of the xref outside the clipping boundary.

**Command line**  
`XCLIP`

**Shortcut menu**  
Select the xref to clip, right-click in the drawing area, and choose Xref Clip.

![Diagram of existing drawings and another similar drawing referenced]

-existing drawings

-another similar drawing is referenced

![Diagram of xref clipped to show only the conference table]

-xref is clipped to show only the conference table

![Diagram of resulting clipped xref]

-resulting clipped xref
Editing References in Place

You can modify external references and redefine block definitions from within the current drawing by using in-place reference editing. Both blocks and xrefs are considered references.

Often, a drawing contains one or more xrefs as well as multiple block references. When working with block references, you can select a block, modify it, and update the block definition. When working with xrefs, you can use in-place reference editing to select the reference you want to work with, modify its objects, and save back the changes to the reference drawing. You can make minor changes without having to go back and forth between drawings.

For example, an office building upgrade requires work to both the building and its adjacent site. Most of the work involves providing an accessible route from the parking lot to the main building entrance. Your working drawings include a site plan that references the building floor plan. By editing the reference in place, you can modify the reference within the visual context of your current drawing. You can make both the site modifications and minor changes to the building floor plan from within one drawing, quickly and efficiently.

**NOTE** If you plan to make major changes to a reference, open the reference drawing and edit directly within the file. Using in-place reference editing to make major changes can temporarily increase the size of your current drawing file, causing regeneration time to increase as well.
Editing Blocks and Xrefs

While working in a drawing, you can edit a specific reference by using in-place reference editing. If the reference you select for editing has attached xrefs or block definitions, the reference and its nested references are displayed and available for selection in the Reference Edit dialog box. Nested references are displayed only if the object chosen for selection is part of a nested reference. Only one reference at a time can be selected for editing. If you are editing a reference that contains OLE objects, the OLE objects are displayed but cannot be selected for editing.

If a block reference with attributes is selected for editing, you can choose to display the attribute definitions in the reference and make them available for editing. The attributes are made invisible and the attribute definitions are available for editing along with the selected reference geometry. When changes are saved back to the block reference, the attributes of the original reference remain unchanged. The new or altered attribute definitions only affect subsequent insertions of the block; the attributes in existing block instances are not affected.

**NOTE** You cannot edit a block reference that is inserted using MINSERT.

After selecting a reference, you can specify which objects in the reference to edit. Only the objects that are a part of the selected reference are available for selection in the drawing area. AutoCAD temporarily extracts the objects you choose from the selected reference and makes them available for modification in the current drawing. The set of extracted objects, or the *working set*, can be modified and then saved back to update the xref or block definition. Objects that make up the working set are visually distinct from other objects.
in the drawing. All objects in the current drawing, except objects in the work-
ing set, are faded.

The XFADECTL system variable controls how objects are displayed while a
reference is edited in place. The set of objects extracted from the reference are
displayed normally. All other objects in the drawing, including objects in the
current drawing and in any references not belonging to the working set, are
faded. XFADECTL sets a value ranging from 0 percent to 90 percent, 50 percent
being the default. The value indicates the intensity of display for objects not
in the working set. When you set XFADECTL to 70 percent, all objects not in
the working set are displayed at 30 percent of the intensity of the normal
display. The larger the value is for XFADECTL, the more the objects are faded.

NOTE If SHADEMODE is set to a value other than 2D wireframe during in-place
reference editing, objects outside the working set are not faded.

To edit an xref or block reference in place

1. From the Modify menu, choose In-place Xref and Block Edit ➤ Edit
   Reference.

2. From within the current drawing, select the reference that you would like to edit.
   If the object you select in the reference belongs to any nested references, all the
   references available for selection are displayed in the Reference Edit dialog box.

3. In the Reference Edit dialog box, select the specific reference you want to edit
   by choosing Next to cycle through the references displayed.

   You can also select a reference by selecting a reference name in the list.
   AutoCAD locks the reference file to prevent multiple users from opening the
   file at once. You cannot edit a reference in place if the drawing file is being
   used by another user.
4 Select Enable Unique Layer and Symbol names to display layer and symbol names with a prefix of $#$. 

5 Select Display Attribute Definitions for Editing to make attribute definitions in block references available for selection when editing blocks with attributes. 

6 Choose OK. 

7 Select the objects you would like to edit in the reference. 

**Command line**  REFEDIT 

**System variables**  XEDIT controls whether the current drawing can be edited in place when referenced by another drawing. REFEDITNAME stores the reference file name and indicates whether the current drawing is in an in-place editing session. 

**Adding or Removing Objects from the Working Set**

While editing a reference in place, you can add or remove objects from the working set. If you create a new object while editing a reference in place, it is almost always added to the working set automatically. Objects that are not added to the working set display as faded in the drawing. 

If a new object is created because of changes made to objects outside the working set, the new object is not added to the working set. For example, your drawing contains two lines that are not a part of the working set. If you edit the lines by using FILLET, a new arc is created between the two lines. The arc is not added to the working set. 

When a reference object is part of the working set, you can select the object for editing even if it is drawn on a locked layer in the reference file. You can unlock the object’s layer and make changes to the object. Changes made to the object can be saved, but the layer state remains the same in the reference file, whether it is locked or unlocked. 

An object that is removed from the working set is added to the host drawing and removed from the reference when changes are saved back. An object that is added to the working set is removed from the host drawing and is added to the reference when changes are saved back. If you create or delete objects, they are automatically added to or removed from the working set. For example, if you use ERASE while editing a reference in place, the erased objects are removed from the working set. You can tell whether an object is in the working set or not by the way it is displayed; a faded object is not in the working set.
The Refedit toolbar is displayed when a reference is being edited in place. The name of the selected reference is displayed in the toolbar. The editing buttons on the toolbar (Add objects to the working set, Remove objects from the working set, Discard changes to reference, and Save back changes to reference) are active only during in-place reference editing. The Edit block or xref button is active whenever the toolbar is initiated and a reference editing session is not already in progress within the current drawing. The Refedit toolbar is dismissed automatically after changes made to the reference are saved back or discarded.

To add objects to the working set
1. From the Modify menu, choose In-place Xref and Block Edit ➤ Add to Workset or at the Command prompt, enter refset.
2. If you entered refset at the Command prompt, choose the Add objects to the working set button on the Refedit toolbar.
3. Select the objects you want to add. You can also set PICKFIRST to 1 and create a selection set before using the Add option.

REFSET can only be used with objects in the space in which REFEDIT is initiated, layout (paper) space or model space.

To remove objects from the working set
1. From the Modify menu, choose In-place Xref and Block Edit ➤ Remove from Workset or at the Command prompt, enter refset.
2. If you entered refset at the Command prompt, choose the Remove objects from the working set button on the Refedit toolbar.
3. Select the objects you want to remove. You can also set PICKFIRST to 1 and create a selection set before using the Remove option.

REFSET can only be used with objects in the space (layout or model) in which REFEDIT is initiated.
Saving Back Changes to References

While editing a block reference in place, you can save back or discard changes made to the reference. If you save back changes to a reference, AutoCAD regenerates the drawing.

When AutoCAD saves back changes, the block definition is redefined and all instances of the block are regenerated to reflect the changes. If you choose to discard the changes, the working set is deleted and the block reference returns to its original state.

Similarly, while editing an xref in place, you can save back or discard changes. Objects in the working set that inherit properties not originally defined in the xref retain those new properties. For example, an xref contains layers A, B, and C, and the drawing that references it contains layer D. If new objects are drawn on layer D during in-place reference editing and changes are saved back to the reference, AutoCAD copies layer D to the xref drawing.

If you remove objects from the working set and save changes, the objects are removed from the reference and added to the current drawing. Any changes you make to objects in the current drawing (not in the xref or block) are not discarded. If you delete any object that is not in the working set, the object is not restored even if you choose to discard changes. You can return the drawing to its original state by using UNDO. If you make unwanted changes to an xref and use REFCLOSE to save back the changes, you must use UNDO to undo any changes made during the reference editing session. After you have undone any unwanted changes, use REFCLOSE to save changes to restore the xref file to its original state.

**WARNING!** While editing a reference in place, if you delete an object that is not in the working set, the object is not restored if you discard changes at the closing of the reference editing session.

Objects in the current drawing that inherit properties defined by the xref retain those new properties. Properties taken from the xref drawing are bound to the current drawing. For more information about binding behavior, see “Using External References” on page 460. The xref layer named SITE, for example, appears in the current drawing as $#$SITE when assigned to an object not in the working set. If BINDTYPE is set to 0, a prefix of $#$ is added to the reference name in the current drawing. If BINDTYPE is set to 1, reference names remain unchanged in the current drawing, similar to names of inserted objects.
NOTE When you edit and save an xref in place, the original drawing preview is no longer available unless you open and save the referenced drawing.

To save back changes

- From the Modify menu, choose In-place Xref and Block Edit ➤ Save Reference Edits or choose the Save back changes to reference button on the Refedit toolbar.

  **Command line**  REFCLOSE

  **Shortcut menu**  With no objects selected during in-place reference editing, right-click in the drawing area and choose Close Refedit Session.

To discard all changes

- From the Modify menu, choose In-place Xref and Block Edit ➤ Discard Reference Edits or choose the Discard changes to reference button on the Refedit toolbar.

  **Command line**  REFCLOSE

  **Shortcut menu**  With no objects selected during in-place reference editing, right-click in the drawing area and choose Close Refedit Session.

  **System variables**  BINDTYPE controls how reference names are handled when bound to the current drawing.