Working in Three-Dimensional Space

If you create a three-dimensional (3D) model, you usually set up different two-dimensional (2D) views in order to visualize, draw, and edit geometry easily. AutoCAD® provides tools that you can use to set up different views of the model. You can also assign different user coordinate systems (UCSs) and elevations to the standard orthogonal views and easily switch between views.
Specifying 3D Coordinates

Specifying 3D coordinates is the same as specifying 2D coordinates with the addition of a third dimension, the Z axis. When drawing in 3D, you specify X, Y, and Z values of the coordinate in either the world coordinate system (WCS) or the user coordinate system (UCS). The following illustration shows the X, Y, and Z axes of the WCS.

Using the Right-Hand Rule

The right-hand rule determines the positive axis direction of the Z axis when you know the direction of the X and Y axes in a 3D coordinate system. The right-hand rule also determines the positive rotation direction about an axis in 3D space.

To determine the positive axis direction of the X, Y, and Z axes, place the back of your right hand near the screen. Point your thumb in the direction of the positive X axis. Extend your index and middle fingers as illustrated and point your index finger in the direction of the positive Y axis. Your middle finger indicates the direction of the positive Z axis.

To determine the positive rotation direction about an axis, point your right thumb in the positive direction of the axis and curl your fingers as illustrated. Your fingers indicate the positive rotation direction about the axis.
**Entering X, Y, Z Coordinates**

Entering 3D Cartesian coordinates \((X,Y,Z)\) is similar to entering 2D coordinates \((X,Y)\). In addition to specifying \(X\) and \(Y\) values, you specify a \(Z\) value. In the following illustration, the coordinate 3,2,5 indicates a point 3 units along the positive \(X\) axis, 2 units along the positive \(Y\) axis, and 5 units along the positive \(Z\) axis. You can enter absolute coordinate values, which are based on the origin of the UCS, or relative coordinate values, which are based on the last point entered.

![3D Cartesian coordinate](image)

3D Cartesian coordinate

**Using XYZ Point Filters**

With XYZ point filters, you can extract coordinates from selected points and synthesize a new point using these coordinates. With this method, you can use known points to find an unknown point. On the command line, enter a period followed by one or more of the letters \(X\), \(Y\), and \(Z\). AutoCAD accepts the following filter selections: .\(X\), .\(Y\), .\(Z\), .\(XY\), .\(XZ\), and .\(YZ\). For example, if you enter .\(x\), you are prompted for the \(Y\) and \(Z\) values.
In the following example, you select midpoints on an object and use XYZ point filters to locate the center point of the object’s cavity. In the illustration, HIDE has been used for clarity.

Command: **point**
Point: \( \text{x} \)
of \text{mid}
of **Select a line** (1)
(need YZ): \( \text{y} \)
of \text{mid}
of **Select a line** (2)
(need Z): \text{mid}
of **Select a line** (3)

**Entering Cylindrical Coordinates**

Cylindrical coordinate entry is similar to 2D polar coordinate entry, but with an additional distance from the polar coordinate perpendicular to the XY plane. You locate a point by specifying its distance along an angle relative to the UCS X axis and its Z value perpendicular to the XY plane. In the following illustration, the coordinate 5<60,6 indicates a point 5 units from the origin of the current UCS, 60 degrees from the X axis in the XY plane, and 6 units along the Z axis. The coordinate 8<30,1 indicates a point 8 units from the origin of the current UCS in the XY plane, 30 degrees from the X axis in the XY plane and 1 unit along the Z axis.
Absolute cylindrical coordinates

In the following illustration, the relative cylindrical coordinate @4<45,5 indicates a point 4 units in the XY plane from the last point entered, not from the UCS origin point, at an angle of 45 degrees from the positive X direction. The line extends to a Z coordinate of 5.
**Entering Spherical Coordinates**

Spherical coordinate entry in 3D is also similar to polar coordinate entry in 2D. You locate a point by specifying its distance from the origin of the current UCS, its angle from the X axis (in the XY plane), and its angle from the XY plane, each separated by an open angle bracket (<). In the following illustration, the coordinate 8<60<30 indicates a point 8 units from the origin of the current UCS in the XY plane, 60 degrees from the X axis in the XY plane, and 30 degrees up from the XY plane. The coordinate 5<45<15 indicates a point 5 units from the origin, 45 degrees from the X axis in the XY plane, and 15 degrees from the XY plane.

**Using Standard 3D Views and Projections**

Industrial designers have been trained to visualize 3D models in relation to standard views, like top, front, and side. AutoCAD creates that same environment electronically, and adds significant new capabilities, including the ability to work in multiple views simultaneously. Because 3D design is still based on standard drafting practices, it’s important to review some of these practices. If you’re already familiar with these standards, you may want to skip this section.
**Standard Views**

Any 3D model can be viewed from any direction, but standard views are set for the six orthogonal directions:

- Top
- Bottom
- Right
- Left
- Front
- Back

In AutoCAD, you can display 3D models from any of these standard six views, although three views are usually enough information for you to fully comprehend the model.

![Top view of a car](top_view)

![Front view of a car](front_view)

![Right side view of a car](right_side_view)

**Standard Projections**

Each of the six standard views is a 2D view, showing only two of the object’s three possible measurements: width, length, or height. Whenever multiple views are displayed, either on the screen or on paper, the views must be arranged so that they share one of the two possible measurements. When they
share a common measurement, they are said to “project.” The following illustrations show a correct projection; both views share the height measurement.

The next illustrations show an incorrect projection; the views do not share a measurement.

First angle projection and third angle projection are standard technical drawing methods for presenting views relative to the front view, as shown in the following illustrations.

Isometric Views

An isometric view in a viewport is used primarily as a visual guide. It helps you comprehend your 3D model as you create and edit chiefly in the 2D views. The next illustration shows the relationship between the 2D views and the isometric view.
**The “Glass Box”**

Mentally picturing your 3D model in a glass box helps you understand the relationship of the views and directions. Looking into the glass box from the right side gives you the right-side view; looking from the top gives you the top view; and looking from the front gives you the front view. To understand how the 2D views relate to one another and where the 2D views of the objects should be placed, picture the glass box opening up. When the glass sides are completely folded out, they show the 2D views in correct relationship to one another.

**Defining a User Coordinate System**

You define a user coordinate system (UCS) to change the location of the 0,0,0 origin point and the orientation of the XY plane and Z axis. You can locate and orient a UCS anywhere in 3D space, and you can define, save, and recall as many UCSs as you require. Coordinate input and display are relative to the current UCS. If multiple viewports are active, you can assign a different UCS
to each viewport (see “Working with UCSs in Viewports” on page 117). Each UCS can have a different origin and orientation for various construction requirements.

To indicate the origin and orientation of the UCS, you can display the UCS icon at the UCS origin point using the UCSICON command. See “Displaying the UCS Icon” on page 116.

UCSs are especially useful in 3D. You may find it easier to align the coordinate system with existing geometry than to figure out the exact placement of a 3D point.

Multiple UCSs

You can define a new UCS in paper space just as you can in model space; however, the UCSs in paper space are restricted to 2D manipulation. Although you can enter 3D coordinates in paper space, you cannot use 3D viewing commands such as 3DORBIT, DVIEW, PLAN, and VPOINT. AutoCAD keeps track of the last 10 coordinate systems created in model space and the last 10 in paper space.

The current elevation established by the ELEV command defines the drawing plane of the current UCS and is applied to individual viewports, depending on the setting of the UCSVP system variable. This variable determines whether a UCS is saved and restored in each viewport. When UCSVP = 1, that is, when different UCS settings are saved in individual viewports, the elevation settings are saved with each viewport both in model space and in paper space layouts.

Generally, it is recommended that you leave the elevation set to zero and control the XY plane of the current UCS with the UCS command. See “Setting Elevation and Thickness” on page 630.
You can define a UCS in several ways:

- Specify a new origin, new XY plane, or new Z axis
- Align the new UCS with an existing object
- Align the new UCS with the current viewing direction
- Rotate the current UCS around any of its axes
- Apply a new Z-depth to an existing UCS
- Apply a UCS by selecting a Face

To redefine a named UCS, see “Saving and Restoring a Named UCS” on page 118. For information about the UCS and UCSMAN commands, see the Command Reference.

### Defining a UCS in 3D Space

You can define a UCS in 3D space using the 3 Point option of the UCS command to specify the new UCS origin and the direction of its positive X and Y axes. The Z axis follows by applying the right-hand rule.

**To define a UCS in 3D space**

1. From the Tools menu, choose New UCS ➤ 3 Point.
2. Specify the origin point.
3. Specify a point on the positive portion of the X axis.
4. Specify a point anywhere on the positive Y portion of the new UCS XY plane.

**Command line**

```
UCS
```

### Using a Predefined Orthographic UCS

You can use any of the predefined UCSs listed and displayed on the Orthographic UCSs tab in the UCS dialog box. These UCSs are defined in relation to the WCS, but you can choose to define them in relation to a named UCS. The UCSBASE system variable stores the name of the coordinate system on which an orthographic UCS is based: the WCS or a named UCS.

**To use a predefined orthographic UCS**

1. From the Tools menu, choose Orthographic UCS ➤ Preset.
2. In the UCS dialog box on the Orthographic UCSs tab, select a UCS from the list.
3. To specify a Z-depth value, right-click the UCS that you want to change and choose Depth from the shortcut menu. See “Moving the UCS” on page 592.
4. To orient the selected UCS in relation to a named UCS, select a UCS name from the Relative To list.

By default, an orthographic UCS is based on the WCS.

5. To specify whether the view in the current viewport updates to a plan view after the selected UCS is applied, choose the Settings tab and select Update View to Plan.

6. Choose Details to view the X, Y, and Z coordinate values of the origin and the X, Y, and Z axes of the selected UCS.

7. Choose Set Current.

   The current UCS is indicated by a small pointer beside the UCS name in the list, and the name of the UCS is also displayed in Current UCS.

8. Choose OK.

   **Command line**  UCSMAN

   **System variables**  UCSBASE stores the name of the coordinate system on which an orthographic UCS is based: the WCS or a UCS. UCSFOLLOW controls whether the view in the current viewport is set to a plan view after a UCS is restored.

   **Related**  The Orthographic option of the UCS command provides access to the six predefined orthographic UCSs on the command line.

**Moving the UCS**

The Move option of the UCS command provides an easy method for setting up different construction planes parallel to the XY plane in your UCS.
Defining a User Coordinate System

For example, you might want to draw on one plane of a model and then switch to a different plane and origin with the same orientation. The following illustration shows a coordinate system that has been redefined by changing both the origin and the Z-depth without altering the orientation of the XY plane.

To move the origin or change the Z-depth of a UCS

1. Make sure that the UCS you want to change is current.
2. From the Tools menu, choose Move UCS.
3. At the prompt for a new origin or Z-depth, specify a new origin, or enter z.
4. If you entered z, enter the Z-depth, or the distance you want to move the XY plane along the Z axis.

Command line UCS Move

If the UCS you modify is unnamed, a new unnamed UCS is created. If one of the six orthographic UCSs or a named UCS is modified, the new origin or Z-depth is applied whenever the UCS is restored. To restore a UCS origin to its original setting, use the same procedure to reset the origin value to 0,0,0 and the Z-depth to 0.

If you have previously changed the origin of an orthographic UCS, you can reset the origin to pass through the origin of the base UCS.

To reset the origin of an orthographic UCS

1. From the Tools menu, choose Orthographic UCS ➤ Preset.
2. On the Orthographic UCSs tab in the UCS dialog box, select a UCS on the list.
3. Right-click the selected UCS and choose Reset Origin from the shortcut menu.
4. Choose OK.

Command line UCSMAN
Applying the Current UCS to Other Viewports

You can apply the current UCS setting to a specified viewport or to all active viewports.

To apply the current UCS to other viewports

1. Make sure the UCS that you want to apply to another viewport is current.
2. From the Tools menu, choose New UCS ➤ Apply.
3. At the prompt, click in a viewport to apply the current UCS to that viewport, or enter all to apply the current UCS setting to all active viewports.

Command line UCS Apply

Working with Multiple Viewports in 3D

Multiple viewports provide different views of your model. For example, you might set up viewports that display top, front, right side, and isometric views (see “Defining a User Coordinate System” on page 589). To facilitate editing objects in different views, you can define a different UCS for each view. Each time you make a viewpoint current, you can begin drawing using the same UCS you used the last time that viewport was current.

The UCS in each viewport is controlled by the UCSVP system variable. When UCSVP is set to 1 in a viewport, the UCS last used in that viewport is saved with the viewport and is restored when the viewport is made current again. When UCSVP is set to 0 in a viewport, its UCS is always the same as the UCS in the current viewport.

For example, you might set up three viewports: a top view, front view, and isometric view. If you set the UCSVP system variable to 0 in the isometric viewport, you can use the Top UCS in both the top viewport and the isometric viewport. When you make the top viewport current, the isometric viewport’s UCS reflects the UCS top viewport. Likewise, making the front viewport current switches the isometric viewport’s UCS to match that of the front viewport.

The example is illustrated in the following figures. The first figure shows the isometric viewport reflecting the UCS of the upper-left, or top, viewport, which is current.
The second figure shows the change that occurs when the lower-left, or front, viewport is made current. The UCS in the isometric viewport updates to reflect the UCS of the front viewport.

To set up a viewport to save and restore a UCS setting assigned to it:

1. Make the viewport whose settings you want to change current.
2. From the Tools menu, choose Named UCS.
3. In the UCS dialog box, choose the UCS Settings tab, and then select Save UCS with Viewport.
4. Choose OK.
In previous releases of AutoCAD, the UCS was a global setting for all viewports in either model or paper space. If you want to restore the behavior of AutoCAD Release 14 and previous releases, you can set the value of the UCSVP system variable to 0 in all active viewports.

### Assigning a UCS to a Viewport

With AutoCAD 2000, you can assign different UCSs to different viewports. The viewport retains its assigned UCS independent of the UCS of the current viewport.

To assign a UCS to a viewport

1. Make current the viewport to which you want to assign a UCS.
2. From the Tools menu, choose Named UCS.
3. On the Named UCSs tab in the UCS dialog box, select the name of the UCS you want to assign and choose Set Current.
   The current UCS setting is indicated by a small pointer beside the UCS name in the list, and the UCS name is also displayed in Current UCS.
4. Select Set View to Plan After UCS Is Restored if you want to change to a plan view when the selected UCS is restored.
5. Choose OK to save the new UCS settings.

<table>
<thead>
<tr>
<th>Command line</th>
<th>UCSMAN</th>
</tr>
</thead>
<tbody>
<tr>
<td>System variables</td>
<td>UCSVP determines whether a UCS setting is saved with a viewport.</td>
</tr>
</tbody>
</table>

### Working with Views in 3D

You can view and edit the geometry of your drawing without having to reset the coordinate system settings each time by restoring named and orthographic views to viewports and automatically restoring UCS settings. You can also assign a Z-depth to an orthographic coordinate system relative to the base UCS, which provides different planes to work in and streamlines the drawing process. These features are particularly useful if you require different orthographic views of your drawing, typically used for 3D wireframe and surfacing models. You can

- Save a coordinate system when you save a named view; restore the view, and the UCS settings are restored
- Assign a Z-depth to an orthographic UCS to provide different working planes for the same orthographic view
■ Apply any of six orthographic views to a viewport
■ Restore the corresponding orthographic UCS whenever you assign an orthographic view to a viewport

For more information about saving a coordinate system setting with a named view, see “Saving Views” on page 220.

Using Orthographic Views

You can use the Orthographic & Isometric Views tab of the View dialog box to restore orthographic views. You restore an orthographic view with an orientation relative to a coordinate system, specified by the UCSBASE system variable. By default, this setting is set to World, but you can change it to any of the named coordinate system settings in the current drawing. You can also choose to restore the associated orthographic UCS when you make an orthographic view current. For example, whenever you restore the Front view, you can set up AutoCAD to automatically restore the Front orthographic UCS, which provides an efficient method of switching views and coordinate system settings together.

When an orthographic view is restored, AutoCAD zooms to extents in that view.

To restore an orthographic view

1. Make current the viewport to which you want to apply the view.
2. From the View menu, choose Named Views.

3. On the Orthographic & Isometric Views tab in the View dialog box, select the name of the view that you want to restore and choose Set Current.

The current view setting is indicated by a small pointer beside the view name in the list, and the view name is also in Current View.
4 To display detailed information about an orthographic UCS, such as view height, width, and twist; view direction; and whether clipping is turned on or off, choose the Named Views tab, then Details.

5 To orient the selected view to a named UCS, select a name from the Relative To list.

By default, orthographic views are oriented relative to the WCS.

6 To specify that the associated orthographic UCS is restored when you restore a view, select Restore Associated UCS with View. This option sets the UCSORTHO system variable.

7 Choose OK.

**Command line** VIEW

**System variables** UCSBASE stores the name of the coordinate system on which the view is based: the WCS or a named UCS. UCSORTHO restores the associated orthographic UCS automatically when an orthographic view is restored.

### Setting 3D Graphics Display Options

Graphics configuration settings affect the way that 3D objects are displayed; for example, the shading of 3D objects and the way graphics are displayed when the 3DORBIT command is active. You set these options using the 3D Graphics System Configuration dialog box. These settings do not affect how objects are rendered. For information about shading objects, see “Creating Shaded Images” on page 668. For information about the 3DORBIT command, see “Interactive Viewing in 3D” on page 601.

AutoCAD uses the Heidi® 3D Graphics System developed by Autodesk as the default graphics system. If you want to use a different graphics system, install it according to your display card’s vendor documentation.

**To set 3D graphics system display options**

1 From the Tools Menu, choose Options.

2 In the Options dialog box, choose the System tab.

3 In Current 3D Graphics Display, select your graphics system and then choose Properties.

A 3D graphics system configuration dialog box is displayed. If you are using a graphics display system other than the Heidi system, the options in the dialog box may be different. See your vendor documentation for more information.
Select or change one or more of the options, and then choose Apply & Close.

Command line  OPTIONS

Materials in 3D

When the Enable Materials option is selected in the 3D Graphics System Configuration dialog box, objects to which you have attached materials show the materials in the 3D view. This includes objects in the 3D Orbit view and objects shaded using the SHADEMODE command. See “Creating Shaded Images” on page 668.

If no material is attached to an object, the default global material is used. For more information about Materials, see “Using Materials in Rendering” on page 699.

The following are limitations to the display of materials in 3D Orbit and when objects are shaded using the SHADEMODE command:

- Objects to which you have applied the GLOBAL material colors maintain their object colors. The GLOBAL material color is not shown.
- 2D textures (bitmaps or bitmap blending) are not shown.
- 3D textures (template materials) are not shown.
- Bump maps are not shown.
- Refraction is not shown.
Setting the Camera Position

You use the CAMERA command to change the point from which you view the objects in a 3D view and the point that you are viewing. The point from which you are viewing objects is the camera location, and the point you are viewing is the target location.

When the 3DORBIT command is active, the default target location is the center of the 3D view, which is not always the center of the objects you are viewing. Use CAMERA before starting 3DORBIT to change the camera and target locations for the 3D Orbit view. For more information about 3DORBIT, see “Interactive Viewing in 3D” on page 601.

To change the camera and target locations

1. On the command line, enter `camera`. The current camera and target positions are displayed.
2. Use the pointing device to set the camera location.
   or
   Enter an \(X,Y,Z\) coordinate to specify the camera location.
3. Use the pointing device to set the target location.
   or
   Enter an \(X,Y,Z\) coordinate to specify the target location.

Command line: `CAMERA`
Interactive Viewing in 3D

The 3DORBIT command activates an interactive 3D orbit view in the current viewport. When the 3DORBIT command is active, you use the pointing device to manipulate the view of the model. You can view the entire model or any object in your model from different points around it.

The 3D orbit view displays an arcball, which is a circle divided into four quadrants by smaller circles. While 3DORBIT is active, the point that you are viewing, or the target of the view, stays stationary. The point from which you are viewing, or the camera location, moves around the target. The center of the arcball is the target point.

You can also shade the objects in your drawing while the 3DORBIT command is active (see “Shading Objects in the 3D Orbit View” on page 606).

Using 3D Orbit Commands

You cannot enter commands on the command line while 3DORBIT is active. However, if 3DORBIT is not active, you can enter a command that starts 3DORBIT and activates one of the options at the same time. For example, 3DZOOM starts 3D orbit view and activates the Zoom option. See 3DCLIP, 3DORBIT, 3DPAN, 3DDISTANCE, 3DSWIVEL, and 3DZOOM in the Command Reference.
To start 3DORBIT

1. Select the object or objects you want to view with 3DORBIT.
   You can view your entire model by not selecting any objects. However, viewing only selected objects enhances performance.

   **NOTE** OLE objects and raster objects do not appear in the 3D orbit view.

2. From the View menu, choose 3D Orbit.
   An arcball is displayed within the active viewport. If the UCS icon is on, it appears shaded. If the GRID is on, a 3D line grid replaces the 2D dot grid.

3. Click and drag the cursor to rotate the view. When you move your cursor over different parts of the arcball, the cursor icon changes. The appearance of your cursor when you click to start dragging indicates the rotation of the view as follows:

   - A small sphere encircled by two lines is the cursor icon displayed when you move the cursor inside the arcball. By clicking and dragging when the cursor is a sphere you can manipulate the view freely. It works as if your cursor were grabbing a sphere surrounding the objects and dragging the sphere around the target point. You can drag horizontally, vertically, and diagonally.

   - A circular arrow around a small sphere is the cursor icon displayed when you move the cursor outside the arcball. Clicking outside the arcball and dragging the cursor around the arcball moves the view around an axis that extends through the center of the arcball, perpendicular to the screen. This is called a “roll.”
     If you drag the cursor into the arcball, it changes to a small sphere encircled by two lines and the view moves freely, as described above. If you move the cursor back outside the arcball, you revert to a roll.

   - A horizontal ellipse around a small sphere is the cursor icon displayed when you move the cursor over one of the smaller circles on the left or right side of the arcball. Clicking and dragging from either of these points rotates the view around the vertical or Y axis that extends through the center of the arcball. The Y axis is represented on the cursor by a vertical line.
A vertical ellipse around a small sphere is the cursor displayed when you move the cursor over one of the smaller circles on the top or bottom of the arcball. Clicking and dragging from either of these points rotates the view around the horizontal or X axis that extends through the center of the arcball. The X axis is represented on the cursor by a horizontal line.

**NOTE** You cannot edit objects while 3DORBIT is active. To exit 3DORBIT, press ENTER or ESC, or choose Exit from the shortcut menu.

**Command line** 3DORBIT, 3DO

**Related** CAMERA changes the camera and target locations before you start 3DORBIT.

**Panning and Zooming in the 3D Orbit View**

You can access Pan and Zoom options from the 3D Orbit shortcut menu or on the 3D Orbit toolbar.

**To pan in the 3D orbit view**

1. Start 3DORBIT, right-click in the drawing area, and choose Pan from the 3D Orbit shortcut menu.
   The cursor changes to a hand cursor.
2. Click and drag the cursor to move the view horizontally, vertically, or diagonally.
   The view moves in the direction that you drag the cursor.
   You can use the projection options, shading modes, and visual aids at the same time that you pan and zoom by choosing an option from the 3D Orbit shortcut menu.
3. To stop panning, right-click and choose Orbit or Zoom from the shortcut menu.

**Command line** 3DPAN
To zoom in the 3D orbit view

1. Start 3DORBIT, right-click in the drawing area, and choose Zoom from the shortcut menu.

   The cursor changes to a magnifying glass with plus (+) and minus (−) signs. Zoom simulates the effect of a camera’s zoom lens by making objects appear closer or farther away. Zooming in magnifies the image. If you are using perspective projection, Zoom exaggerates the perspective with which you view the objects. It may slightly distort the display of some objects.

2. Click and drag toward the top of the screen to zoom in. Click and drag toward the bottom of the screen to zoom out.

3. To change the projection or shading mode or use a visual aid, right-click and choose an option from the shortcut menu.

4. To stop zooming, right-click and choose Orbit or Pan from the shortcut menu.

   **Command line** 3DZOOM

To use a zoom window in the 3D orbit view

1. Start 3DORBIT, right-click in the drawing area, and choose More ➤ Zoom Window from the shortcut menu.

   The cursor changes to a window icon, and you can select a specific area that you want to zoom.

2. Click and drag the pointing device to draw a square around the area you want to select.

   When you release the pick button, the drawing is zoomed in, focused on the area you selected.

To zoom to extents in the 3D orbit view

- Start 3DORBIT, right-click in the drawing area, and choose More ➤ Zoom Extents from the shortcut menu.

   The view is centered and sized to display all objects in the 3D view.

To adjust the camera distance in the 3D orbit view

1. Start 3DORBIT, right-click in the drawing area, and choose More ➤ Adjust Distance from the shortcut menu.

   The cursor changes to a line with one arrow pointing up and one pointing down.
2 Click and drag toward the top of the screen to move the camera closer to the objects. Click and drag toward the bottom of the screen to move the camera away from the objects.

Adjust Distance simulates the effect of moving the camera closer to the objects or farther away.

**Command line** 3DDISTANCE

**Using Projection Options in the 3D Orbit View**

You can choose to use a perspective or a parallel projection of the view while 3DORBIT is active.

**To choose a parallel or perspective projection in the 3D orbit view**

1 Start 3DORBIT, right-click in the drawing area, and choose Projection.
2 Choose one of the following options:
   - **Parallel**: Changes the view so that two parallel lines never converge at a single point. The shapes in the drawing always remain the same and do not appear distorted when they are closer. This is the default.
Perspective: Changes the view so that all parallel lines converge at one point. Objects appear to recede into the distance while parts of the objects appear larger and closer to you. The shapes are somewhat distorted when the object is very close. This view correlates most closely to what your eye sees.

A check mark is displayed next to the current projection option.

NOTE When you exit 3D Orbit, the projection that you choose remains current. You cannot edit, pick points, zoom, or pan when viewing objects in perspective projection.

Shading Objects in the 3D Orbit View

Objects in the 3D orbit view are shaded to give them a more realistic 3D appearance. You can change the way objects are shaded using the different shading modes.

To change the shading mode in 3D orbit view

1. Start 3DORBIT, right-click in the drawing area, and choose Shading Modes from the shortcut menu.

2. Choose one of the following options:

   - Wireframe: Displays the objects in the 3D view using lines and curves to represent the boundaries.
- **Hidden**: Displays the objects in the 3D view using wireframe representation with the lines representing the back faces hidden.

- **Flat Shaded**: Shades the objects in the 3D view between the polygon faces. This gives the objects a faceted, less smooth appearance.

- **Gouraud Shaded**: Shades the objects in the 3D view and smooths the edges between polygon faces. This gives the objects a smoother, more realistic appearance.

- **Flat Shaded, Edges On**: Combines the Flat Shaded and Wireframe options. The objects are flat shaded with the wireframe showing through.
- **Gouraud Shaded, Edges On**: Combines the Gouraud Shaded and Wireframe options. The objects are Gouraud shaded with the wireframe showing through.

![Image of Gouraud Shaded, Edges On](image)

**NOTE** When you shade objects in the 3D orbit view, the shading is still applied to the objects after you exit 3DORBIT. Use SHADEMODE to change the shading when 3DORBIT is not active.

### Using Visual Aids in the 3D Orbit View

You can choose to display one or more of the visual aids (compass, grid, and UCS icon) in the 3D orbit view. A check mark is displayed next to the active visual aid option(s). A visual aid that is active when you exit 3DORBIT remains active in the view outside the 3D orbit view unless SHADEMODE is set to 2D Wireframe.

**To display a visual aid**

1. Start 3DORBIT, right-click in the drawing area, and choose Visual Aids from the 3D Orbit shortcut menu.
2. Choose one of the following options:
   - **Compass**: Draws a sphere within the arcball composed of three lines representing the $X$, $Y$, and $Z$ axes.
     ![Compass](image)
   - **Grid**: Draws an array of lines on a plane parallel to the current $X$ and $Y$ axes, perpendicular to the $Z$ axis. You specify the height of the grid display in the ELEVATION system variable.
Before starting 3DORBIT, you can use the GRID command to set system variables that control the grid display. The number of major grid lines corresponds to the value you set using the Grid Spacing option of GRID, which is stored in the GRIDUNIT system variable. Ten horizontal lines and ten vertical lines are drawn between major lines.

When you zoom in and out of the 3D orbit view, the number of grid lines changes to give you a clear view of the lines. Fewer lines are drawn as you zoom out. As you zoom in closer, more grid lines are drawn until the number of lines corresponds again to the number set in GRIDUNIT.

- **UCS Icon:** Turns the display of the UCS icon on and off. If the UCS icon is displayed when you start 3DORBIT, a shaded 3D UCS icon is displayed in the 3D orbit view. On the 3D UCS icon, the X axis is red, the Y axis is green, and the Z axis is blue or cyan. The UCSICON system variable also controls the display of the 3D UCS icon.

**Adjusting Clipping Planes in the 3D Orbit View**

You can set clipping planes for the objects in 3D orbit view. A *clipping plane* is an invisible plane. Objects or parts of objects that move beyond a clipping plane cannot be seen in the view. In the Adjust Clipping Planes window, there are two clipping planes, front and back. The front and back clipping planes are represented as lines at the top and bottom of the Adjust Clipping Planes window.

You use the toolbar buttons or the options on the Adjust Clipping Planes shortcut menu to choose the clipping plane that you want to adjust.

If clipping planes are on when you exit the 3D orbit view, they remain on in the 2D and 3D view.

To adjust clipping planes in the 3D orbit view

1. Start 3DORBIT, right-click in the drawing area, and choose More ➤ Adjust Clipping Planes.

   The Adjust Clipping Planes window displays the objects in the view, rotated at a 90-degree angle. You set the clipping planes in the Adjust Clipping Planes window, and the results are displayed in the main 3D orbit view.

2. Right-click in the Adjust Clipping Planes window and choose one of the following options from the shortcut menu:

   - **Front Clipping On:** Toggles the front clipping plane on or off. When the front clipping plane is on, you can see the results of moving the line that adjusts the front clipping plane as described in step 3.
3 Right-click in the Adjust Clipping Planes window and choose one of the following options to adjust the clipping planes:

- **Back Clipping On**: Toggles the back clipping plane on or off. When the back clipping plane is on, you can see the results of moving the line that adjusts the back clipping plane as described in step 3.

- **Adjust Front Clipping**: Adjusts only the front clipping plane. The line near the bottom of the window adjusts the front clipping plane. If you chose Front Clipping On in step 2, you can see the clipping in the main 3D orbit view as you move the line up or down.

- **Adjust Back Clipping**: Adjusts only the back clipping plane. The line near the top of the window adjusts the back clipping plane. If you chose Back Clipping On in step 2, you can see the clipping in the main 3D orbit view as you move the line up or down.

- **Create Slice**: Causes the back and front clipping planes to move together at a set distance apart. Adjust the front and back clipping planes as described above to set the distance, and then choose Create Slice. This displays a “slice” of the objects in the 3D Orbit view. To see the “slice” in the main 3D orbit view, choose both Front Clipping On and Back Clipping On in step 2.

4 Click and drag the Clipping Plane line to clip the area that you do not want to see in the view.

You can adjust only one clipping plane at a time except when using the Create Slice option. On the toolbar, the depressed button indicates the plane that you are adjusting. When you’ve finished adjusting one plane, you can adjust the other. If the Create Slice button is depressed, you are adjusting both planes at the same time.

**Command line**

```
3DCLIP
```

**Turning the Clipping Planes Off and On**

Closing the Adjust Clipping Planes window does not turn the clipping planes off. You can rotate the 3D orbit view and still see the clipping planes. As you rotate the view, different portions of the objects are clipped as they pass through the clipping planes. You can use the 3D Orbit shortcut menu to turn the clipping planes off and on.

**NOTE** If the clipping planes are on when you exit 3DORBIT, they remain on in the 2D and 3D view.
To turn the clipping planes off and on

1. Start 3DORBIT, right-click in the drawing area, and choose More. A check mark in front of Front Clipping On or Back Clipping On indicates that the clipping plane is on.
2. Choose the option that has a check mark next to it to turn the clipping plane off.

**Using Continuous Orbit**

You can click and drag in the 3D orbit view to start a continuous motion. When you release the pick button on your pointing device, the orbit continues in the direction that you were dragging.

**To start a continuous orbit**

1. Start 3DORBIT, right-click in the drawing area, and choose More ➤ Continuous Orbit. The cursor changes to a small sphere encircled by two lines.
2. Click and drag in the direction that you want the continuous orbit to move.
3. Release the pick button. The orbit continues moving in the direction that you indicated with your pointing device.
4. To change the direction of the continuous orbit, click and drag in a new direction and release the pick button. The direction of the continuous orbit changes.

**Command line** 3DCORBIT

While Continuous Orbit is active, you can change the view by right-clicking in the drawing area and choosing Projection, Shading Modes, Visual Aids, Reset View, or Preset Views from the shortcut menu. You can also turn the front and back clipping planes on and off while Continuous Orbit is active; however, you cannot adjust the clipping planes. If you choose Pan, Zoom, Orbit, or Adjust Clipping Planes from the shortcut menu, Continuous Orbit ends.
Resetting the View and Using Preset Views

While 3DORBIT is active, you can reset the view to the view that was current when you first entered the 3D Orbit view.

To reset the view

- Start 3DORBIT, right-click in the drawing area, and choose Reset View from the shortcut menu.
  The view is reset to the view that was current when you started 3DORBIT.

To use a preset view

1. Start 3DORBIT, right-click in the drawing area, and choose Preset Views.
2. Choose one of the views from the list.
   You can set the view to one of the six standard orthogonal views (see “Standard Views” on page 587), or one of four isometric views. The isometric views are based on a camera location of 0,0,0.

Options for Viewing in 3D

In model space, you can view an AutoCAD drawing from any point. From a selected viewpoint, you can add new objects, edit existing objects, or generate a hidden-line view, shaded view, or rendered view. Also, you can define a parallel projection or perspective view. Use the 3DORBIT command to perform these same actions interactively.

If you are working in paper space, you cannot use the 3DORBIT, DVIEW, PLAN, or VPOINT command to define paper space views. The view in paper space always remains a plan view.

In model space, you can set the viewing direction by changing the viewpoint (DDVPOINT) and using preset viewpoints (VPOINT). A convenient way to view an AutoCAD drawing from any 3D point in model space is to use the compass and axis tripod (see “Setting a View with the Compass and Axis Tripod” on page 615).

Setting a Viewing Direction

Set a viewing direction when you begin work on a model or want to check a completed model from a particular viewpoint.
You can rotate a view using DDVPOINT. The following illustration shows a view defined by two angles relative to the X axis and the XY plane of the WCS.

A viewing direction defined by two angles

To set the viewing direction

1. From the View menu, choose 3D Views ➤ Viewpoint Presets.

2. In the Viewpoint Presets dialog box, select viewing angles relative to the X axis and the XY plane by clicking your pointing device on the sample images, or enter values directly for the X axis and the XY plane.
Chapter 17 Working in Three-Dimensional Space

Viewing angle relative to the \(X\) axis

Viewing angle relative to the \(XY\) plane

To select the plan view of your drawing relative to the current UCS, choose Set to Plan View.

Choose OK.

**Command line**  
DDVPOINT

**Related**  
VPOINT sets the viewing position for a 3D visualization in the current viewport. You can approximate a view using the compass and axis tripod or enter coordinates directly.
Displaying a Plan View

You can change the current viewport to a plan view of the current UCS, a saved UCS, or the WCS in model space.

To change the current viewport to a plan view
1 From the View menu, choose 3D Views ➤ Plan View.
2 Choose either Current UCS (for the plan view), World UCS, or Named UCS (for a saved view).

Command line PLAN

Setting a View with the Compass and Axis Tripod

You can use a compass and axis tripod displayed on the screen to set a viewpoint. The compass represents a flattened globe. The center point of the compass indicates the north pole (0,0,1). The inner ring is the equator (0,1,0). The outer ring is the south pole (0,0,–1). Where you click in the compass determines the viewing angle relative to the XY plane. Where you click relative to the center point determines the Z angle. The axis tripod indicates the rotation of the X, Y, and Z axes as you move the viewpoint on the globe.

Examples of compass and axis tripod for various viewpoints
To set a view with the compass and axis tripod

1. From the View menu, choose 3D Views ➤ VPOINT.
2. Choose a point inside the compass to specify the viewpoint.

   **Command line**  VPOINT

**Defining a 3D View**

You can create either a parallel projection or a perspective view and zoom, pan, and twist views. You can also use DVIEW to remove objects from in front of and behind a clipping plane and to remove hidden lines during a dynamic viewing operation. With DVIEW you can limit the number of objects displayed while creating a view magnification and orientation. When you end the command, all objects are displayed.

To define a view

1. On the command line, enter `dview`.
2. Select the objects to display.
   For example, if you select only the outer walls of a building (not the interior layout plan), you can make adjustments to the perspective view much more quickly. AutoCAD applies the view to the entire model.
   If you press ENTER without selecting objects, DVIEW displays a model of a small house instead of your actual drawing.
3. Enter an option.
4. Adjust the view according to the prompts.
5. To complete the DVIEW command, press ENTER.

   **Command line**  DVIEW
## Removing Hidden Lines

The HIDE command removes hidden lines from the view of a 3D model. This creates a more realistic view.

### To remove hidden lines

1. On the command line, enter `hide`.
2. Select the objects on which to base the hidden-line view.
3. If necessary, set the view as described in “Defining a 3D View” on page 616.
4. Press ENTER to end the command.

   The effect of HIDE is temporary. AutoCAD regenerates the drawing after you exit the command.