Rendering and Imaging

Most drafting time is spent working on wireframe representations of a model. On occasion, however, you might need to see a more realistic image involving color and perspective—for example, when verifying your design or when presenting a final drawing.
Chapter 19  Rendering and Imaging

Using 3D Image Types

Creating realistic three-dimensional (3D) images helps you visualize your final design much more clearly than you can with wireframe representations. In the wireframe, because all edges and tessellation lines (lines that help visualize curved surfaces) are visible, it’s hard to tell whether you’re viewing the model from above or below. The hidden-line image makes it easier to visualize the model because the back faces are not displayed. Shading and rendering can greatly enhance the realism of the image.

Ways to display 3D models

Of the image types, hidden-line images are the simplest. Shading removes hidden lines and assigns flat colors to visible surfaces. Rendering adds and adjusts lights and attaches materials to surfaces to produce realistic effects.

To decide what type of image to produce, you need to consider factors such as purpose and time. For a presentation, a full rendering might be appropriate. If time is limited, or if your display and graphics equipment cannot produce varied gradations and colors, you might not need a detailed rendering. If you want a quick check of the integrity of a design, a simple hidden-line or shaded image is sufficient.
Drawing 3D Models

When performing hidden-line, shading, and rendering operations on 3D objects, AutoCAD® treats different surfaces in different ways. This section discusses surfaces, specifically extrusions, 3D faces, solids, polygon meshes, closed polylines, and text.

Drawing Surfaces

You begin drawing models by using objects that represent surfaces. For example, to draw a cube you could use one of several methods. You could draw six 3D faces, use the BOX command to create a 3D solid, or change the thickness of a 2D solid, trace, or wide polyline segment. But if you draw a cube by using twelve lines, you cannot generate a hidden-line, shaded, or rendered image. The cube would always look like a frame made of wires.

To produce a shaded or rendered image, AutoCAD always goes through a line-hiding process first. The descriptions of hiding lines that follow apply equally to the shading and rendering processes.

Solid 3D objects such as cylinders have top and bottom surfaces. However, AutoCAD puts top and bottom surfaces on some extruded objects but not others. In general, if the 2D extruded object encloses a planar region, and has a top and bottom surface, then AutoCAD treats this object as a solid. If the one- or two-dimensional object is not closed, then its extrusion is considered to be a zero-thickness vertical sheet. A model comprising such objects, such as a cylinder made up of two semicircular arcs with an extruded thickness, would lack a top and bottom.

Drawing Objects with Thickness

Solid fills, traces, circles, and wide polyline segments are treated as surfaces with tops and bottoms when they are given thickness and shaded. The Thickness option of PROPERTIES, CHANGE and CHPROP makes 2D objects look like 3D objects. EXTRUDE creates true 3D solid objects.

A solid fill or trace becomes a prism with three or four faces when given thickness. A circle becomes a vertical pole, and shades as a solid cylinder. Each segment of a wide polyline is treated separately. Segments with nonzero width have tops and bottoms, but those with zero width are represented as the same lines and arcs with thickness.
Chapter 19 Rendering and Imaging

Drawing Solids, 3D Faces, and Polygon Meshes
Visually, AutoCAD treats a cube formed by 3D faces or a 2D solid with thickness as a solid object. A polygon (polyface) mesh or 3D face cannot have a thickness; however, such objects define a surface for hiding, shading, or rendering. All other objects produce one- or two-dimensional surfaces in space. Where such an object touches any other object, hiding lines may produce unexpected results.

Drawing Closed Polylines
No special treatment is given to zero-width closed polylines when thickness is applied to them. During hiding, shading, or rendering, the region bounded by a closed polyline, whether or not it has thickness, is not treated as a top or a bottom surface.

Using Text
Text is ignored by HIDE unless it is given a thickness. The thickness can be as great as you want or as small as 0.00000001 units (or any value other than 0). During regeneration of text, attribute, and attribute definition objects, AutoCAD processes the text without considering its visibility. If you put textual information on distinct layers, you can later suppress it by turning off those layers.

Drawing Abutting and Intersecting Objects
The hiding process may present problems in two cases: objects that exactly abut or objects that intersect in space. Because no two objects can actually occupy the same point, drawings of objects that touch or intersect must allow for the effects of shading or rendering. Many of these problems can be avoided by using Boolean operations with true 3D solid objects.

Drawing Touching Objects
Objects can abut at a point, along a line, or along a plane. However, when two objects occupy the same space, AutoCAD treats one of them as hiding the other.
Even a very small round-off error in calculating the relative positions of two touching objects can result in an incorrect determination of where one obscures the other.

**Drawing Intersecting Objects**

It is common to draw two objects with intersecting boundaries—for example, a cylinder solid intersecting a rectangular solid.

![Drawing intersecting objects](before HIDE after HIDE)

**Intersecting objects**

A very slight round-off error could make the two objects appear to be one object. To compensate for this effect, shorten one of the objects where it would otherwise penetrate the second object, or break one of two intersecting objects into two objects, one on either side of the surface of the intersecting object.

![Intersecting objects](before HIDE after HIDE)

**Broken objects**

Alternatively, separate the objects by reducing or increasing the size of one of the objects by a small amount, such as 0.001 units.

**Drawing Intersecting Lines and Turned-Off Layers**

A drawing of two walls meeting at a corner demonstrates intersecting lines. If hidden lines are being suppressed and the two walls are on the same layer, it doesn’t matter which of the two intersecting edges is hidden. However, objects on layers that are turned off affect the hiding process but do not affect the rendering process. Objects on layers that are invisible obscure objects on visible layers. Objects on frozen layers do not affect hiding.
Creating Hidden-Line Images

When creating or editing a drawing, you work on the wireframe representation of an object or surface and use the hiding process only to verify the current placement of those surfaces. When viewed or plotted as wireframes, complex drawings often appear too cluttered to convey useful information. Hiding background objects that in reality would be obscured by objects in the foreground simplifies the display and clarifies the design.

Not displaying background lines makes the display much clearer; however, you can’t edit hidden-line, rendered views.

Calculating and obscuring hidden lines can be time-consuming, but you can speed up the process in several ways. For example, you can avoid drawing details that won’t be visible at the scale at which you’re displaying or plotting the image. You can also zoom into a part of the drawing that excludes objects from the hiding process.

To hide lines in the whole drawing

- From the View menu, choose Hide.

The lines remain hidden until you perform an action that regenerates the drawing and redisplay a hidden-line wireframe view.

Command line  
```
HIDE
```

Related  You can plot hidden-line views generated by `HIDE` (see “Hiding Lines in Plotted Viewports” on page 535).
Hiding Lines of Selected Objects

To improve performance, you can remove hidden lines on one or more selected objects in a drawing.

To hide lines of selected objects

1. Make current the viewport that contains the objects you want to display with hidden lines.
2. At the Command prompt, enter `dview`.
3. Select the 3D object or objects, whose lines you want to hide.
4. Enter `h` (Hide).

AutoCAD does not display lines hidden by foreground objects. The hidden lines are obscured only temporarily and are redisplayed when you exit DVIEW and the drawing regenerates.

Command line  
DVIEW

Related  
HIDE removes hidden lines on all objects in the drawing.

Hiding Solid Objects

To hide lines on solid objects, AutoCAD creates a mesh image of the object. If the DISPSILH system variable is set to on (1), AutoCAD suppresses drawing the mesh and only draws silhouette lines of the solid.

When the current view is shaded, hiding lines on solid objects also suppresses drawing the mesh image and instead displays the objects using wireframe representation with the back lines hidden. This is the same as choosing the Hidden option of the SHADEMODE command or choosing Hidden from the View ➤ Shade menu.

When the current view is rendered, hiding lines on solid objects creates the mesh image.
Creating Shaded Images

Although hiding lines enhances the drawing and clarifies the design, shading produces a more realistic image of your model. SHADEMODE provides you with options to view and edit your objects in wireframe or shaded representations. The Shade options use light coming from a light source located behind you and over your left shoulder and a fixed amount of ambient light.

Regenerating the drawing does not affect shading. You can edit shaded objects by selecting them as you normally would. When you select a shaded object, the wireframe and grips appear on top of the shading. You can also save your drawing and open it again with objects still shaded.

When you use SHADEMODE to shade objects, you cannot produce highlights, move the light, or add more lights. For greater control over lighting, you must render the model (see “Creating Rendered Images” on page 669).

To create a shaded image

1. Make current the viewport that contains the view you want to shade.
2. From the View menu, choose Shade.
3. Choose one of the following options:
   - 2D Wireframe: Displays the objects using lines and curves to represent the boundaries. Raster and OLE objects, linetypes, and lineweights are visible. Even if the COMPASS system variable is set to on, the compass is not visible in the 2D Wireframe view.
   - 3D Wireframe: Displays the objects using lines and curves to represent the boundaries. Displays a shaded 3D user coordinate system (UCS) icon. Raster and OLE objects, linetypes, and lineweights are not visible. You can set the COMPASS system variable to on to view the compass. Material colors that have been applied to objects are shown.
   - Hidden: Displays the objects using the 3D wireframe representation and hides the lines representing the back faces.
   - Flat Shaded: Shades the objects between the polygon faces. The objects appear flatter and less smooth than Gouraud Shaded objects. Materials that have been applied to objects are shown.
Creating Rendered Images

Rendering can make a design clearer than a simple hidden-line or shaded image can. Traditional rendering of architectural, mechanical, and engineering drawings involves watercolors, colored crayons and inks, and air-brush techniques to produce a final presentation-quality rendering.

Rendering often requires the most computer time in a 3D project. It generally involves four steps:

- Preparing models for rendering includes following proper drafting techniques, removing hidden surfaces, constructing meshes for smooth shading, and setting view resolution.
- Illuminating includes creating and placing lights and creating shadows.
- Adding color includes defining the reflective qualities of materials and associating these materials with the visible surfaces.
- Rendering usually includes rendering objects at intermediate steps to check your preparation, illumination, and colors.

These steps are conceptual and aren’t usually implemented as procedural steps during the rendering process, nor must they occur in the order presented.

**Gouraud Shaded:** Shades the objects and smooths the edges between polygon faces, giving the objects a smooth, realistic appearance. Materials that have been applied to objects are shown.

**Flat Shaded, Edges On:** Combines the Flat Shaded and Wireframe options. The objects are flat shaded with the wireframe showing through.

**Gouraud Shaded, Edges On:** Combines the Gouraud Shaded and Wireframe options. The objects are Gouraud shaded with the wireframe showing through.

**Command line** SHADEMODE

**Related** You can shade your model when the 3DORBIT command is active by choosing an option from the shortcut menu. RENDER uses lights and materials to create a more realistic 3D rendered image.
AutoCAD uses geometry, lighting, and materials to render a realistic image of a model.

**Preparing Models for Rendering**

There are several factors to bear in mind when you are creating a model that you are going to render.

**Drawing Outward-Facing Surfaces and Removing Hidden Surfaces**

An important step in the rendering process is to remove hidden surfaces, because rendering hidden surfaces and back faces wastes time. AutoCAD uses the *normal* on each face to ascertain which is a front face and which is a back face. A normal is a vector that is perpendicular to each polygon face on the model and usually points outward toward space. AutoCAD also provides an Auto Axis option you can use to map materials on *XY*, *YZ*, and *XZ*-oriented surfaces, or only *XY*-oriented surfaces.

**NOTE** Auto Axis does not use polygon normals when calculating material orientations. Instead, polygons facing in positive *XYZ* directions are considered front faces, and those facing in negative *XYZ* directions are considered back faces.
Faces drawn counterclockwise and the resulting normals

Normals are determined by the way a face is drawn in a right-handed coordinate system like the AutoCAD system: if you draw the face counterclockwise, the normals point outward; if you draw the face clockwise, the normals point inward. You should draw faces consistently. Mixing methods produces unexpected results. AutoCAD calculates all the normals in the drawing during rendering. The renderer searches for all normals that point away from the viewpoint and removes the associated polygons from the scene. This step is called back-face removal.

After the back faces have been removed, the renderer uses a Z buffer to compare relative distances along the Z axis. If the Z buffer indicates that one face overlaps another, the renderer removes the face that would be hidden.

To discard faces with normals pointing away from the viewpoint

1. From the View menu, choose Render ➤ Preferences.
2. Under Rendering Options, choose More Options.
3. In the Photo Real Render Options dialog box under Face Controls, select Discard Back Faces.
4. Choose OK to close the dialog boxes.

Command line  RPREF

The back faces are removed because they wouldn’t be visible from your viewpoint. AutoCAD compares relative distances between each surface and your viewpoint, decides which faces obscure other faces, and discards obscured faces.

The time saved is in proportion to the number of faces discarded out of the total number of faces.
Sometimes you may want to skip the back-face removal step and leave back faces in (for example, if an object is transparent, or if you can see two sides of it because of its shape and orientation, or if an open object will be rendered with a view angle that lets you see inside). Transparency also affects whether one face should hide another.

You can also choose to render back faces instead of front faces. Do this by turning off the Back Face Normal Is Negative option, found in the applicable Render Options dialog box under Face Controls. Rendering back faces can be useful if you've created a drawing without being aware of the counterclockwise convention for normals in AutoCAD drawings.

If you're rendering a drawing that wasn’t created with rendering in mind, you might have to leave Discard Back Faces turned off or even turn off Back Face Normal Is Negative.

NOTE Solid objects created with the Advanced Modeling Extension® (AME®) have meshes and normals correctly oriented, which can be an aid to creating models for rendering. See “AME” on page 726.

Following Proper Drafting Techniques

Be consistent in your method of drawing. For example, avoid creating a building with walls that are a mixture of faces, extruded lines, and wireframe meshes.

The more faces a model has, the longer it takes to render. Keep the geometry of your drawing simple to keep rendering time to a minimum. Use the fewest faces possible to describe a plane. The simpler the surface, the less computation time required to calculate the color of each pixel in the face. When you want to display a complicated detail, modeling the detail with a bitmap often renders more quickly than modeling it in the geometry.

The complexity of an AutoCAD object is a function of the number of its vertices and faces. Certain kinds of geometry, described in this section, create special rendering problems. The photorealistic renderers (Photo Real and Photo Raytrace) provide controls for handling such geometry. For more information about creating a model that will render well, see “Constructing Meshes for Smooth Shading” on page 673.

Intersecting faces in a model occur when two faces pass through each other. While intersecting faces are unrealistic in real-world terms, it’s sometimes easier to use them in an AutoCAD model than to ensure that the faces are modeling separate objects. However, they can render incorrectly unless the renderer explicitly checks for them. The photorealistic renderers always
check for intersections; however, rendering artifacts can appear at the intersection points, particularly with low-resolution renderings.

Faces that overlap and lie in the same plane can produce ambiguous results, especially if the materials attached to the two faces differ.

Faces that self-overlap due to a 180-degree twist can also produce ambiguous results, because the normal for the face is not well defined. Avoid this problem by not allowing boundary lines to intersect.

**Constructing Meshes for Smooth Shading**

AutoCAD drawings have two types of faces: a regular face and an $M$-by-$N$ mesh made up of many faces.

Mesh components include normals, vertices, faces, and edges. These components are defined as follows:

- A normal is a vector perpendicular to the face and pointing outward.
- A vertex is a point that forms the corner of a face.
- A face is a triangular or quadrilateral portion of a surface object.
- An edge is the boundary of a face.

In an AutoCAD drawing, all faces have four vertices, except faces in polyface meshes, which are treated as adjoining triangles. For rendering purposes, each quadrilateral face is a pair of triangular faces that share one edge.

If you use the Smooth Shading option for basic rendering in either the Render or the Rendering Preferences dialog box, set the density of the mesh so that the angle between the normals of any two adjoining faces of the mesh is less than the smoothing angle. If the angle is greater than the smoothing angle, an edge appears between those faces when you render your model, even with Smooth Shading turned on. You control Smoothing Angle in the Render dialog box (RENDER) and the Rendering Preferences dialog box (RPREF).

When the Smooth Shading option is turned off, Render assigns a color or material to each face based on the light that strikes the base of the normal (that is, at the face’s centroid). Because this shading is uniform across the faces, edges between faces are often visible.

When Smooth Shading is turned on, AutoCAD can either calculate the shading at each vertex and then average the shading across each face (Gouraud shading) or calculate the shading at each pixel (Phong shading). Phong shading generates more realistic highlights; it is the only method used by the photorealistic renderers.

In addition to hiding and smoothing, the appearance of a face depends on the light that reaches it and the material assigned to it.
You must explicitly turn AutoSurf® surfaces into meshes before you render them, as described in “Mechanical Desktop” on page 726. If the mesh is not dense enough to render well, increase the size of your drawing by a factor of 10 to 50, and then use the Surface Display option on the AutoSurf menu to generate new meshes. The finer meshes will render more smoothly.

**NOTE** If you need to adjust surface smoothness, you can use the FACETRES system variable to control the density of the facets (faces). See “FACETRES System Variable” on page 674.

### Controlling Resolution and Display Accuracy

You can control the display accuracy of circles, arcs, and ellipses using the VIEWRES command and the FACETRES system variable.

**VIEWRES Command**

The value you set with VIEWRES controls the display accuracy of circles, arcs, and ellipses. AutoCAD draws these objects on the screen using many short straight line segments. The higher the value set in VIEWRES, the smoother the arc or circle looks but the longer it takes to regenerate. If the circles look like polygons in the drawing, they'll look like polygons when rendered. To increase performance while you're drawing, set a low value with VIEWRES. However, to make sure you get a good-quality rendering, raise the value before rendering drawings containing arcs or circles.

To raise the resolution value, start VIEWRES and enter a high number (up to 20,000) for Circle Zoom Percent. (You can ignore the prompt about fast zooms if you only want to make circles and arcs in the drawing look better for your rendering.) See VIEWRES in the Command Reference.

**FACETRES System Variable**

FACETRES controls the smoothness of shaded and rendered curved solids. It is linked to the value set by VIEWRES; when FACETRES is set to 1, there is a one-to-one correspondence between the viewing resolution of circles, arcs, and ellipses and the tessellation of solid objects. For example, when FACETRES is set to 2, the tessellation will be twice the tessellation set by VIEWRES. The default value of FACETRES is 0.5. The range of possible values is 0.01 to 10.

When you raise and lower the value of VIEWRES, objects controlled by both VIEWRES and FACETRES are affected. When you raise and lower the value of FACETRES, only solid objects are affected.
Configuring Render for Different Displays

When you first use a rendering command such as LIGHT, RENDER, or SCENE, AutoCAD automatically configures AutoCAD Render. For a full explanation of AutoCAD configuration, see the Installation Guide.

In the Render or Rendering Preferences dialog box, you can choose to render to a viewport, to a separate Render window, or to a file.

Render to the Render window to take advantage of the capabilities of that window. You can copy images to the Clipboard for use in other applications, and you can print easily to the system printer or render to a file using several formats.

Screen resolution is a function of the number of pixels displayed. The resolution is inversely related to the displayed pixel size; that is, the greater the screen resolution, the smaller the pixels (given the same size screen). Like color depth, resolution depends on your display driver.

**NOTE** The highest possible resolution for photorealistic rendering is $4096 \times 4096$ at the maximum color depth for the selected file format (for example, 24 bits for PostScript).

Using Anti-aliasing

Because the image on a monitor is made up of discrete picture elements (or pixels) on a fixed grid, straight or curved edges can appear to be jagged or stepped. This effect is known as aliasing.

The greater the resolution (and thus the smaller the pixels), the less apparent aliasing is. However, it is often best to reduce the effect further by a technique known as *anti-aliasing*. Anti-aliasing shades pixels adjacent to the main pixels that define a line or boundary.

Anti-aliasing involves at least two trade-offs:

- Extra calculation—pixels in the offending line or boundary and neighboring pixels in the background must be analyzed so that intermediate shades can be added.
- Thicker lines—although an anti-aliased line appears smoother, it must be thicker than a jagged one.

You have to decide how much time you want to spend rendering and how good you want the final rendering to be. These trade-offs will depend partly on the hardware you’re using and partly on the audience for your work.
The photorealistic renderers offer four levels of anti-aliasing control. Photo Raytrace provides a further refinement of the speed and quality trade-off called adaptive sampling. (To view these selections, choose More Options in the Render or Rendering Preferences dialog box while Photo Real or Photo Raytrace is the selected rendering type.)

- Minimal: Applies an analytic horizontal anti-aliasing algorithm to each scan line.
- Low: Enhances the horizontal algorithm by computing a maximum of 4 samples for each pixel; the samples are averaged to produce the final pixel value.
- Medium: Further enhances the algorithm by using a greater number of samples (up to 9 per pixel).
- High: Establishes a maximum of 16 samples per pixel.

Each successive level is slower to compute. The anti-aliasing algorithm makes the process more efficient by allowing AutoCAD to decide for any given pixel that fewer samples need to be computed.

With Photo Raytrace, you can specify an adaptive sampling value between 0.0 and 1.0 for the contrast threshold. With a low setting, small differences between initial sample values force more samples to be taken. At a higher setting, the sample value differences must be greater to force more sampling. This increases rendering speed at the expense of image quality.

**Setting Bitplanes**

When you render your objects to a file, you can set a bitplane. The number of bitplanes (also called color depth or pixel depth) refers to the number of bits of information available to define a pixel's shade or color. With a bitplane of 1, a pixel can be only black or white (on or off), and only one bit of information is required to define its state.

With a bitplane of 8, a pixel can be any of 256 shades (calculated by raising 2 to the eighth power), and 8 bits of information are required to define its color state. A bitplane of 24 requires 24 bits of information but can display almost 16.8 million shades (2 raised to the 24th power). A bitplane of at least 8 bits is required for reasonable rendering results, and a bitplane of 24 or 32 bits produces the best results.
Using Render

AutoCAD Render provides three rendering types:

- Render, the basic AutoCAD rendering option for best performance
- Photo Real, the photorealistic scanline renderer, which can display bit-mapped and transparent materials and generate volumetric and mapped shadows
- Photo Raytrace, the photorealistic raytraced renderer, which uses ray tracing to generate reflections, refraction, and more precise shadows

Both photorealistic renderers generate images one horizontal scanline at a time.

Using the basic Render option, you can render your model without applying a material, adding any lights, or setting up a scene. When you render a new model, the AutoCAD renderer automatically uses a virtual “over-the-shoulder” distant light. You cannot move or adjust this light.

Loading, Unloading, and Stopping Render

AutoCAD Render is automatically loaded into memory when you choose an option on the Render toolbar or enter an AutoCAD command such as FOG, LIGHT, RENDER, or SCENE. You can stop the rendering process by pressing ESC. To free memory, you can unload AutoCAD Render.

To unload AutoCAD Render

1. From the Tools menu, choose Load Application.
2. In the Load/Unload Applications dialog box, choose the Loaded Applications tab if it is not already displayed.
3. In the list, select acRender.arx, and then choose Unload.
4. Choose Close.

Render is unloaded.
Setting Rendering Conditions

The following sections describe some of the conditions that can affect rendering quality.

Setting the Rendering Background Color

Rendering to a viewport always renders against the background color you set for the AutoCAD drawing area. The Render window background color matches the AutoCAD background color.

To set the Render window background color

1. From the View menu, choose Render ➤ Preferences.
2. In the Rendering Preferences dialog box, choose Background.
3. In the Background dialog box, select Solid and clear AutoCAD Background.
4. Under Colors, select the color you want to modify (Top), and then use the color controls to specify a color.
   The Middle and Bottom colors can be modified only when Gradient, Image, or Merge is selected. If you use a custom color, choose Select Custom Color and select a color in the Color dialog box.
5. Choose OK to close the dialog boxes.
   To view the new color, you must apply Render to an object or scene. The Render window is displayed with the new background color.
   For more information about setting background types and images, see RENDER in the Command Reference.

Rendering All Objects

The default rendering choice is to render all objects in the current scene in the drawing. If no scene is defined or selected, AutoCAD renders the current view (see “Using Scenes in Rendering” on page 715). The rendering process is faster when you render to a smaller area of the screen. If you have configured AutoCAD to render to a viewport, use VPORTS or MVIEW to make a small viewport for rendering. You can also use the Crop Window option in the Render dialog box to specify a portion of the screen to be rendered. To display the Render toolbar, from the View menu choose Toolbars, and then choose Render.

To render a model

1. Display a 3D view of your model.
2. From the View menu, choose Render ➤ Render.
3. In the Render dialog box, set options or accept the defaults.
Under Rendering Options, select Smooth Shading to smooth the edges between the polygon faces.

Related to Smooth Shading is Smoothing Angle, which sets the angle at which AutoCAD interprets an edge. The default angle setting is 45 degrees. Angles less than 45 degrees are smoothed; angles greater than 45 degrees are considered edges. See “Constructing Meshes for Smooth Shading” on page 673.

Under Rendering Options, choose More Options. Then, in the render options dialog box under Quality, choose Phong or Gouraud shading. Phong shading produces higher-quality renderings with more accurate highlights. Gouraud renderings, available for the basic Render only, are slightly lower in quality but faster. For information about the options in the Render dialog box, see RENDER in the Command Reference.
4 To render the image to the screen, make sure that Destination is set to Render Window or Viewport.
If you set Destination to File, the image is sent directly to a file; there is no screen display.
5 Select a named scene or the current view.
6 Choose Render.
Depending on the size of your drawing, after a short or long pause AutoCAD displays a rendered image of your model.

NOTE If your objects are zoomed out past the limits of the drawing and you are having rendering problems, try scaling the scene or zooming in to at least the limits of the drawing. For more information on scenes, see “Using Scenes in Rendering” on page 715.

Command line  RENDER

Related  RPREF displays the Rendering Preferences dialog box, in which you can choose additional rendering options. STATS displays information about the rendering, such as the time it took to render the image.

Rendering Selected Objects
Rendering can be a time-consuming process. You can save time by first rendering selected objects rather than the whole model.

To render selected objects
1 Display a 3D view of your model.
2 From the View menu, choose Render ➤ Render.
3 In the Render dialog box, select Query for Selections, and then choose Render.
4 Select one or more objects in the drawing.
5 Press ENTER to complete your selection.
AutoCAD renders only the objects you select.

Command line  RENDER
Accessing the Render Window

If your rendering destination is set to the Render window, it displays a bitmap image of your rendering.

For a complete description of the Window menu and the toolbar in the Render window, see RENDER in the Command Reference.

At full-screen display, the AutoCAD drawing area sometimes hides the Render window. In this situation, you cannot select the Render window with your pointing device to bring it to the front. You can press ALT+TAB to select the Render window from the active tasks.

Merging a Rendering with a Background

One method of creating special effects is to merge a rendering of one or more selected objects with a background image. For example, for presentation purposes you might want to import a landscape or a sky scene and use it as a background for your model.
Instead of clearing the image from the display, AutoCAD renders the selected objects against the image. Use REPLAY to display a BMP, TGA, or TIFF image in a viewport. (You cannot merge images in the Render window.)

To merge a rendering with a background image

1. From the View menu, choose Render ➤ Background.
2. In the Background dialog box, select Image.
3. Under Image, choose Find File to specify the background image file to be used.
4. Choose OK.
When you use Merge, the wireframe edge of the object shows against the background image. For additional information about creating and editing landscapes, see LSEDIT, LSLIB, and LSNEW in the Command Reference. You can also use the REPLAY command to import a landscape or sky scene as a background image.

**Changing Color Depth for Rendering**

When you render to the Render window, your rendering may be displayed in fewer colors or be of lower quality than you expect. This probably means that you have 8-bit color depth selected in the Windows Render Options dialog box, or that you have an 8-bit color Windows display. If your system supports it, you may want to change to 16-bit or 24-bit color depth for your Windows display and render using 24-bit color in the Render window.

When rendering to a viewport, Render uses the current Windows color depth.

To change color depth for bitmap files in the Render window

1. From the taskbar, choose the Render button.
2. In the Render window, from the File menu, choose Options.
3. In the Windows Render Options dialog box under Color Depth, select 8-Bit or 24-Bit.
4. Choose OK.

**Using Lights in Rendering**

You are using the real power of rendering when you insert and manipulate lights in your drawing and assign material properties, such as shiny plastic or dull metal, to surfaces in your model.

Adding lights to your drawing is the simplest way to improve the appearance of your models. You can use lights to illuminate a whole model or to highlight selected objects and parts of objects in your drawing.

AutoCAD recognizes four types of light: ambient light, distant light, point lights, and spotlights. Light from these sources passes through faces and by default does not cast shadows. To create shadows, use the Photo Real or Photo Raytrace renderer or 3D Studio.
Using Ambient Light

Light that provides a constant illumination to every surface in a model is ambient light; it comes from no particular source and has no direction.

You can set the intensity of ambient light or turn it off. Keep ambient light low; otherwise, it tends to saturate your image and give it a washed-out look. Turn off ambient light to simulate a dark internal room or a scene at night.

By itself, ambient light does not produce realistic images. Adjoining faces are indistinguishable because all are equally illuminated. Use ambient light to provide fill light to surfaces not directly illuminated by a directional light source such as a spotlight (see the figure “Effects of different types of reflection” on page 693).

Using Distant Light

A distant light emits uniform parallel light rays in one direction only. Light rays extend infinitely on either side of the point you specify as the light source. The intensity of distant light does not diminish over distance; it is as bright at each face it strikes as it is at the source.
The direction of a distant light in a drawing is more critical than its location. All the objects are lighted, including any “behind” the light. A distant light acts as if it were outside the drawing. To avoid confusion, it's recommended that you position distant lights at the extents of your drawing.

Distant lights are useful for lighting objects or a backdrop uniformly and for simulating sunlight. A single distant light simulates the sun. Although the sun radiates in all directions, because of its size and distance, by the time its rays reach the earth they are effectively parallel. Because a distant light is so frequently used to simulate the sun in this way, especially in architectural renderings, the photorealistic renderers provide a special sun angle calculator that calculates the sun’s position based on both the hour of the day and geographic location.

### Using Point Lights

A point light radiates light in all directions from its location. The intensity of a point light diminishes over distance according to its rate of attenuation (see “Understanding Distance of Faces from Lights” on page 690).

A point light is useful for simulating light from a light bulb. Use point lights for general lighting effects. Combine point lights with spotlights for what we generally think of as “lighting effects.” Point lights are an alternative to ambient light for providing fill in a localized area.

### Using Spotlights

A spotlight emits a directional cone of light. You can specify the direction of the light and the size of the cone. Like that of point lights, the intensity of spotlights diminishes over distance (see “Understanding Distance of Faces from Lights” on page 690). Spotlights have hotspot and falloff angles that together specify how light diminishes along the edge of the cone. When light from a spotlight falls on a surface, the area of maximum illumination is surrounded by an area of lesser intensity.
- **Hotspot cone angle**: Defines the brightest part of a light beam. This is also known as the beam angle.
- **Falloff cone angle**: Defines the full cone of light. This is also known as the field angle.

The region between the hotspot and falloff angles is sometimes referred to as the rapid decay area.

The greater the difference between the hotspot and falloff angles, the softer the edge of the light beam. If the hotspot and falloff angles are equal, the edge of the light beam is sharp. Both values can range from 0 to 160 degrees. You cannot set the hotspot angle to be greater than the falloff angle.

Spotlights are useful for highlighting specific features and areas in your model.

### Using Shadows in Rendering

When you create or modify a photorealistically rendered light, you can use the Shadow On option. Lights generate shadows when you render a scene using the Photo Real or the Photo Raytrace renderer—provided the global Shadows option in the Rendering Options section of the Render dialog box is turned on (see RENDER in the Command Reference). Shadows increase rendering time but can also increase a scene's realism.

The photorealistic renderers can generate three different kinds of shadows: volumetric shadows, shadow maps, and raytraced shadows.
Using Volumetric Shadows

The Photo Real and the Photo Raytrace renderers can generate volumetric shadows. The renderers compute the volume of space cast by the shadow of an object and generate a shadow based on this volume.

Volumetric shadows are hard edged, but their outlines are approximate. Volumetric shadows cast by transparent or translucent objects are affected by the color of the object.

To generate volumetric shadows

1. From the View menu, choose Render ➤ Preferences.
2. In the Render Preferences dialog box under Rendering Type, select Photo Real or Photo Raytrace.
3. Under Rendering Options, select Shadows. Then choose OK.
4. From the View menu, choose Render ➤ Light.
5. In the Lights dialog box, select a lighting type. Then choose New.
6. In the New Light dialog box, enter a light name.
8. In the Shadow Options dialog box, select Shadow Volumes/Raytraced Shadows.
9. Choose OK to exit each dialog box.

Using Shadow Maps

The Photo Real and Photo Raytrace renderers can both generate shadow maps during a prerendering pass of the view to render. For each light, you can set the size of the shadow map it generates, from 64 to 4,096 pixels square. The larger the shadow map, the greater its accuracy.

Shadow maps do not show the color cast by transparent or translucent objects, but shadow maps are the only way to generate soft-edged shadows with the photorealistic renderers. You can adjust the softness of the shadow’s edge. (With spotlights, the relationship between the shadow map size and the falloff area determines the final resolution of the shadow.)

To generate a shadow map

1. From the View menu, choose Render ➤ Preferences.
2. In the Render Preferences dialog box under Rendering Type, select Photo Real or Photo Raytrace.
3. Under Rendering Options, select Shadows. Then choose OK.
4 From the View menu, choose Render ➤ Light.

5 In the Lights dialog box, select a lighting type and then do one of the following:

- To create a new light, choose New and then enter a light name.
- To modify an existing light, under Lights, select a light name and then choose Modify.

6 In the New Light or Modify Light dialog box under Shadows, select Shadow On. Then choose Shadow Options.

7 In the Shadow Options dialog box, clear Shadow Volumes/Raytraced Shadows.

   Shadow-mapped shadows override the default shadows (volumetric for Photo Real or raytraced for Photo Raytrace).

8 Adjust the light’s shadow map size if necessary (default is 128).

9 Choose OK to exit each dialog box.

**Raytraced Shadows**

Raytraced shadows (like other raytraced effects of reflection and refraction) are generated by tracing the path of light beams or rays sampled from a light source.

Raytraced shadows have hard edges and accurate outlines; they also transmit color from transparent and translucent objects.

If you’ve selected the Shadows option and you choose the Photo Raytrace renderer, raytraced shadows are generated for each light that has shadows turned on except lights that are set to generate shadow-mapped shadows.

**Shadows and Rendering Speed**

Shadows always increase rendering time, sometimes considerably. Volumetric shadows tend to be quicker than raytraced shadows for simple geometry. For more complex geometry with a large number of faces, however, raytraced shadows can be quicker to generate than volumetric shadows.

Shadow maps are particularly costly in terms of render time. You can save some time by hand-selecting objects for shadow casting (see LIGHT in the Command Reference).
Understanding Lighting Principles

The way light strikes each surface in a model is affected by the angle of the face to the light and, for point lights and spotlights, the distance of the face from the light. Reflection of light from a surface is affected by the reflective qualities you set for the surface's material (see “Defining Materials” on page 701).

Understanding Angle of Faces to Lights

The more a surface inclines away from a light source, the darker the surface appears. Faces perpendicular to a light source appear the brightest; the farther a face is from a 90-degree angle, the darker it is. The following figure illustrates how the angle of a light source affects brightness: each face is the same length; each light source emits eight beams of light. The brightness of each face depends solely on its angle to the light source.

Face 1 is perpendicular to the light source and is struck by all 8 beams of light. It is the brightest of the three faces.

Face 2 is at the greatest angle to the light source and receives only 4 beams of light. It is the darkest of the three faces.

Face 3 is at a slight angle to the light source and receives only 6 beams of light. It is darker than Face 1.

Effects of angle upon brightness
When you use a distant light that emits parallel beams in one direction, all faces that present the same angle to that light have the same brightness.

Object rendered using a distant light source

Understanding Distance of Faces from Lights

Objects far from point lights and spotlights can be defined to appear darker. Objects closer can appear brighter. Distant lights are unaffected by distance. The effect of light diminishing over distance is known as attenuation or falloff. You can choose between two rates of attenuation: inverse linear and inverse square. You can also specify no attenuation.

- **Inverse linear**: Decreases illumination in inverse proportion to the distance from the light source. Thus, as light travels 2, 4, 6, and 8 units, its brightness becomes 1/2, 1/4, 1/6, and 1/8 as strong.
- **Inverse square**: Decreases illumination in inverse proportion to the square of the distance from the light source. Thus, as light travels 2, 4, 6, and 8 units, its brightness becomes 1/4, 1/16, 1/36, and 1/64 as strong.

Objects become darker earlier when you use inverse square as compared with inverse linear. The option you choose depends on the effect you’re trying to achieve. For example, assume you want to produce a brightly lighted surface. If the light-to-object distance is 8 units, and the rate of falloff is inverse linear, you need to set light intensity to 8 for the light to have an intensity of 1 when it strikes the target surface.

Understanding Lighting Color Systems

To set the color of lights and the surface reflection of those lights, you can use one of two color systems: a primary red, green, and blue (RGB) light color system or a hue, lightness, and saturation (HLS) system.

Mixing primary RGB light colors yields the following secondary colors: yellow (red and green), cyan (green and blue), and magenta (red and blue). All light colors together produce white; the absence of any light color
produces black. When you use an HLS system, you choose a color from a range of hues and then vary its lightness (brightness) and saturation (the amount of black the hue contains).

**Understanding Reflection**
Photorealistic rendering uses two kinds of reflection—diffuse and specular.

**Understanding Diffuse Reflection**
Surfaces such as blotting paper or matte-painted walls exhibit diffuse reflection. Light hitting a totally diffuse surface is dispersed equally in all directions. The following figure shows three beams of light hitting a matte surface. The surface reflects light in many different directions. Viewpoints 1, 2, and 3 can all display the reflection of the light.

No matter where your viewpoint is, the reflection of the surface is the same. Therefore, when the Photo Real or Photo Raytrace renderer measures diffuse reflection, it does not adjust for the position of your viewpoint.

**Understanding Specular Reflection**
Specular reflection reflects light in a narrow cone. A beam of light striking a perfectly specular surface, such as a mirror, reflects light in one direction only. In the following figure, only viewpoint 3 can display the reflection of the incoming light beams.
The angle of incidence is the angle between an incoming beam of light and the surface normal. The angle of reflection is the angle between a reflected beam of light and the surface normal. Specular reflection is visible only from a viewpoint where the two angles are equal.

This principle explains why the area of specular reflection is the shiniest spot on an egg, for example, when a light shines on it. If you move around the egg, the highlight—the point of reflection—moves to mirror your viewpoint.

With diffuse reflection, Render considers only the angle of the surface to the light source. With specular reflection (controlled by the Reflection and
Roughness rendering attributes), the angle of the surface to both the light source and your viewpoint is considered.

Effects of different types of reflection

With only ambient light, there is no contrast at all. With only diffuse reflection, there are no highlights. With the model set up for only specular reflection, the image displays highlights but is very dark. The combined effects of ambient, diffuse, and specular reflection produce the greatest realism.

Understanding Roughness

With the photorealistic renderers, you can control the size of the specular reflection area by using a roughness value. You can think of differences in
roughness as the difference between a new, highly polished metal ball bearing and a ball bearing that is used and scuffed. Both surfaces are shiny and exhibit a high degree of specular reflection; however, they have different roughness.

With a photorealistic rendering material, the greater the roughness, the larger the size of the highlight.

Understanding Distance and Attenuation
As light travels from its source, it becomes less bright; therefore, the greater an object’s distance from a light source, the darker it appears. When you use a flashlight in a dark room, objects close to the light are bright; against a distant wall, the light is barely visible. The phenomenon of light diminishing over distance is known as attenuation. The photorealistic renderers calculate attenuation for all light types.

As described in “Understanding Distance of Faces from Lights” on page 690, with the photorealistic renderers you can choose one of three methods for calculating attenuation: no attenuation (None), Inverse Linear, or Inverse Square. Actual light attenuates at the inverse square rate, but this does not always give the rendering effect you want.

Adding Lights
You can add any number of lights to a drawing. You can set the color, location, and direction of each light you create. For point lights and spotlights, you can also set attenuation. When you have multiple drawings open, you can add and save different light settings in each drawing.

To add a new light to the drawing and set its intensity and location

1. From the View menu, choose Render ➤ Light.
2. In the Lights dialog box under Ambient Light, set the ambient light color and intensity.
For most purposes, an intensity value of 0.3 is satisfactory. Setting higher values produces a washed-out, low-contrast image.

3 Select a light type (Point Light, Distant Light, or Spotlight) and choose New. AutoCAD places an unnamed light block at the center of your current view and opens a new light dialog box.

4 In the new light dialog box, enter a name for the light. The name must be unique and have no more than eight characters.

5 Using the Intensity slider, set a light intensity appropriate to the type of light and the conditions you’re trying to simulate. (A value of zero turns a light off.)

The default light intensities are designed to give reasonable illumination to your model. Render first using the defaults and then adjust the lights until you achieve the effect you want.

The default setting for point lights and spotlights is determined by the Attenuation setting and the extents of the drawing. If Attenuation is None, the default intensity is 1. If Attenuation is set to Inverse Linear, the maximum intensity is twice the extent of the drawing. If Attenuation is set to Inverse Square, the maximum intensity is the square of twice the extent of the drawing. Distant lights have no attenuation, and the default intensity is half the maximum intensity (1).

6 Set the appropriate hotspot and falloff angles for spotlights.

To produce a sharp circle of light, make the hotspot cone angle equal to the falloff cone angle. To produce a fuzzy edge to the light, make the falloff angle a few degrees larger than the hotspot angle (see “Using Spotlights” on page 685).

7 For spotlights, accept or change the X,Y,Z coordinate of the Light Target and/or Location. By default, AutoCAD places the light in the center of the current viewport. To change the light position, under Position, choose Modify (see “To change a light’s position” on page 696).

8 Choose OK.

AutoCAD confirms the insertion of the new light by displaying the light name in the center of the light block, returning you to the Lights dialog box, and displaying the name of the new light in the list.

9 Select New again to add another light, or choose OK to close the dialog box.

Command line LIGHT

Related SCENE creates a combination of lights and a named view.

Don’t worry about creating too many lights; you can always delete them, exclude them from the current scene, or turn them off by setting their
intensity to zero. Excluding them from the current scene is the recommended method (see “Defining Scenes” on page 715). To ensure that you do not create lights with duplicate names, do not add lights to blocks.

**Deleting and Modifying Lights**

You can delete a light or modify its position, color, and intensity. The only change you cannot make is to the light type. For example, you cannot change a point light to a spotlight. Instead, you must delete the point light and insert a new spotlight.

**To delete or modify a light**

1. From the View menu, choose Render ➤ Light.
2. In the Lights dialog box under Lights, select one of the lights listed.
3. To delete the light, choose Delete and confirm the deletion.
4. To modify the light, choose Modify.
5. In the Modify Light dialog box, change the values as needed. Then choose OK.
   - To modify the position of a light, see “To change a light’s position.”
6. Select another light and choose Delete or Modify again.
7. Choose OK.

**Command line** LIGHT

**Related** SCENE creates a combination of lights and a named view.

After your initial light setup, you will often want to modify the position of lights in the drawing.

**To change a light’s position**

1. From the View menu, choose Render ➤ Light.
2. In the Lights dialog box, choose Modify.
3. Do one of the following:
   - In the Modify Point Light or Modify Spotlight dialog box under Position, choose Modify.
   - In the Modify Distant Light dialog box under Light Source Vector, choose Modify.

AutoCAD closes the dialog box and displays the drawing. Depending on the type of light you are modifying, AutoCAD displays a vector that stretches from the current light location or light target to the crosshairs. In the case of
a distant light, it shows the light direction. As you move the crosshairs, the vector stretches, helping you to reposition the light accurately.

4 Use your pointing device to change the position of the light. (The default target for distant lights and spotlights matches the current view direction.)

- For a point light, specify a new location for the light.
- For a spotlight, specify a new target for the light. Then specify a new location for the light.
- For a distant light, under To, specify a new target point for the light. Then, under From, specify a new location for the light to determine the direction of the light.

The drawing displays the light in its new position, and AutoCAD redisplay the appropriate modify light dialog box.

5 Choose OK.

After you change the location of the light, you may want to change its intensity.

**Command line**  LIGHT

**Related**  SCENE creates a combination of lights and a named view.

If you have difficulty establishing the correct coordinates for your lights, try using different viewpoints and inserting the lights at those viewpoints. AutoCAD automatically positions the light at the center of your viewpoint.

Using VPORTS, you can also set up different views in different viewports.

**To position a light using views**

1 Use VIEW to save your current viewpoint to a named view.
2 Use 3DORBIT or VPOINT to set up a view that you want the light to see. You can also name and save that view if you wish.
3 Add a light at that position.
   AutoCAD positions the light at the center of your viewpoint.
4 Use VIEW again to return to your original named view.
   You’ll see the light in the position you want, shining on the object you intended it to shine on.
5 To fine-tune the light position, use the Modify Position option in the modify light dialog box.

**Command line**  LIGHT

**Related**  SCENE creates a combination of lights and a named view.
To position a distant light, you can use the Azimuth and Altitude controls in the New Distant Light and Modify Distant Light dialog boxes.

To position a distant light to simulate sunlight
1. Align your model in relation to the points of the compass: North, South, East, and West. By default, the Y axis points north.
2. Add a new distant light.
3. Assuming you want to simulate the sun's position at noon in the northern hemisphere, enter 180 for Azimuth, that is, due south.
4. Enter an appropriate angle for the Altitude of the sun at noon for your particular location. For example, enter 80 to put the sun almost overhead at noon.
Command line  LIGHT

 Related  SCENE creates a combination of lights and a named view.

 To produce the appropriate shadows, you must use the Photo Real or Photo Raytrace renderer.

 Using Materials in Rendering

 To lend still greater realism to your renderings, apply materials such as steel and plastic to the surfaces of your model. You can attach materials to individual objects, all objects with a specific AutoCAD Color Index (ACI) number, blocks, or layers.

 Using materials involves several steps:

 ■ Defining materials, including their color, reflection, or dullness
 ■ Attaching materials to objects in the drawing
 ■ Importing and exporting materials to and from material libraries

 Creating color, shading, and patterning is different on a computer than with traditional media such as paints and crayons.

 Using Color

 When you look at objects around you, most colors you see are pigment colors. When sunlight hits a red rose petal, for example, the petal absorbs all the colors of the spectrum except red, which reflects back to your eyes. If an object reflects the entire spectrum, you see white; if it reflects no color, you see black. The primary pigment colors are red, yellow, and blue. The secondary colors, which are an equal mix of two primary colors, are orange (red and yellow), green (yellow and blue), and purple (red and blue). When painters mix oils on a palette, they are working with pigment color.

 If an object is a source of light, it emanates color rather than reflects it. In a computer monitor, you see not pigment color but light color. The primary light colors are red, green, and blue. For this reason, computer color systems are often referred to as “RGB” systems. The secondary light colors are yellow (red and green), cyan (green and blue), and magenta (red and blue). All light colors together produce white; the absence of any light color is black.

 An addition to the RGB light color system is the HLS system (hue, lightness, saturation). Instead of mixing primary colors, you choose the color from a range of hues and then vary its lightness (brightness) and saturation (purity).
Using Surface Color Variations

One of the key components of materials is their surface color variation.

In the real world, objects of the same color can appear to be different colors depending on how they reflect light. For example, a red spherical or cylindrical object does not appear to be uniformly red. The sides at the most acute angle to the light appear to be a darker red than the sides immediately facing the light. The reflection highlight appears the lightest red. In some cases, highlights on very shiny objects appear to be white no matter what the color of the object. By reproducing these color variations and reflections, AutoCAD adds realism to your models.

AutoCAD is flexible in the way it treats lighting color. You can specify the color of the light reflected from the surface of an object irrespective of the color of the object or the color of the light shining on the object. For example, you can simulate a blue light shining on a red sphere giving off maroon reflection highlights.

Because of surface color variations, each rendered material actually specifies three color variables:

- The object’s main color (also known as its diffuse color)
- Its ambient color, which appears on those faces lighted by ambient light alone
- Its reflection color (or specular color), which is the color of a highlight on a shiny material (the size of the highlight depends on the material’s roughness)

When you define a material, you can adjust all of these variables.

Using Transparency

If you want to make all or part of an object transparent or translucent, you can adjust a material’s degree of transparency from 0 to 1.0. Transparency increases rendering time. Multiple layers of transparent objects increase rendering time for each multilayered transparent pixel.

You can set the refraction index of transparent materials. Photo Raytrace rendering generates refractive effects: bending light rays as they pass through the refractive material and thus shifting the objects that are visible through it.
Defining Materials

You define a material by specifying the color of the material and its reflective qualities, such as shiny or dull, and whether the surface of an object should reflect highlights when the material is applied to that object.

Different types of light and reflection effects

With only ambient light, you see no contrast and no highlights. With only the color attribute, you see no highlights; contrast is due solely to differences in the angle that surfaces present to the light source. With only the reflection attribute, the image displays highlights but is very dark.

When you preview your materials, Preview shows a sample sphere or cube from a default orientation. The sample image does not show you exactly how the material is rendered, but it does give you a good idea.

To define a new material

1. From the View menu, choose Render ➤ Materials.
2. In the Materials dialog box, choose New.
3. In the New Standard Materials dialog box, enter a name in the Material Name box.

   The name must be unique and have no more than 16 characters.
4 Set the color and specify a value for each of the following material attributes: Color/Pattern, Ambient, and Reflection, or specify material attributes for Roughness, Transparency, Refraction, and Bump Map.

You can set the color of each attribute by using the RGB (red, green, and blue) or HLS (hue, lightness, and saturation) sliders, the color wheel, or the AutoCAD Color Index (ACI) number of the object itself. For information about manipulating RGB and HLS color values, see “Understanding Lighting Color Systems” on page 690.

- Set the color and value for Color/Pattern.
  Color is the base color reflected by the object, also known as diffuse reflection. The main (diffuse) color of the material can be viewed in the sample image. You can adjust the color with the Value and Color controls. For a dull, matte-finish effect, set the value for Color to around 0.7 and set the value for Reflection to 0.3.

  Pattern is defined as a bitmap image that consists of an arrangement of pixels (picture elements). Patterns can include any bitmap file types supported by AutoCAD. The supported file types are TGA, BMP, TIFF, JPEG, and PCX. You project a pattern onto an object, and all patterns are repeated within the selected area. You can blend a pattern and color; enter a file name in the Bitmap Blend area. Selected patterns can be viewed in the sample image.

- Set the color and value for Ambient.
  The settings for Ambient adjust the material’s shadow color. The Ambient settings also determine the color reflected from ambient light. Generally, keep the ambient light value in the Lights dialog box below 0.3 (or keep the value at the default setting of 0.1 in the Standard Material dialog box). A high ambient light setting tends to give your renderings a washed-out appearance.

- Set the color and value for Reflection.
  The Reflection settings determine the color of the reflected highlights, also known as specular reflection. The material’s reflective (highlight or specular) color can be viewed in the sample image. You can adjust the color with the Value and Color controls. Shiny surfaces such as polished metals reflect light in a narrow angle. When light shines on a spherical or cylindrical object, the highlight is the shiniest spot on the object.

  For Photo Raytrace, Value specifies the material’s coefficient of reflectivity. This is the amount of a reflected ray’s color to add to a surface where the ray strikes.
For a shiny effect, set the value for Reflection to 0.7, and set the value for Color to 0.3. If you want the color of the highlight to be white, move the Red, Green, and Blue sliders until each has a value of 1.

- Set the value for Roughness.
  The Roughness setting determines the size of the reflected highlight. Roughness is similar to the difference between a highly polished steel ball bearing and one that is scuffed with glass paper. Because a smoother, less rough surface produces a smaller highlight, the lower the roughness value, the smaller the size of the highlight. Roughness values have no effect unless you enter a value for Reflection.

- Set the value for Transparency.
  The Transparency setting can make all or part of an object transparent or translucent. You can adjust a material's degree of transparency from 0 to 1.0. Transparency increases rendering time (see RMAT in the Command Reference for a discussion of bitmap blend).

- Set the value for Refraction.
  The Refraction setting sets a refraction index for transparent materials. Refraction values have no effect unless you enter a nonzero value for Transparency.

- Set the value for Bump Map.
  The Bump Map setting determines the brightness of a bump map object. Bump Map values are translated into apparent changes in the height of the surface of an object.

5 Choose Preview to see if the values you specified produce the effect you want. You can preview a sphere or a cube with the material values that you have specified.

6 Change the values and continue to preview your changes until you're satisfied with the material's appearance. Then choose OK.

**Command line**

RMAT
**Modifying Materials**

You can duplicate and modify a material at any time using Duplicate and Modify in the Materials dialog box. A fast way to define a new material is to select an existing material in the Materials dialog box and choose Duplicate. Then in the New Materials dialog box, provide a new name for the material and modify the fields. You will find it easier to modify the existing fields than to create everything from scratch.

You can easily change the Color and Reflection parameters, for example, to change a material from dull (matte-finish) to shiny.

**To change a material from matte to shiny**

1. From the View menu, choose Render ➤ Materials.
2. In the Materials dialog box, select a material from the Materials list.
3. Choose Modify.
4. In the Modify Standard Material dialog box, enter a low value (0.3 or lower) for Color.
5. Enter a high value (0.7 or higher) for Reflection and a low value (0.3 or lower) for Roughness.
6. Choose Preview to see the difference.
7. Choose OK.

**Command line** RMAT

**Attaching Materials**

Having defined a material, you can apply or attach it to one or more objects in the drawing. You can attach materials to individual objects, to all objects with a specific ACI number, or to layers.

**To attach a material**

1. From the View menu, choose Render ➤ Materials.
2. In the Materials dialog box, select a material from the list or choose Select to select a material already attached to an object in the drawing.
Apply a material directly to an object, to all objects with a specific ACI number, or to all objects on a specific layer.

- To attach a material directly to one or more objects, choose Attach. Then select the objects in the drawing.
- To attach a material to all objects in the drawing with a specific ACI number, choose By ACI. In the Attach by AutoCAD Color Index dialog box, select an ACI number.
- To attach a material to all objects on a specific layer, choose By Layer. In the Attach by Layer dialog box, select a layer.

Choose OK.

Render the model again to see the effect.

**Command line** `RMAT`

To detach a material attached to an object, choose Detach in the Materials dialog box. To detach a material attached by ACI, choose Detach in the Attach by AutoCAD Color Index dialog box. To detach a material attached by layer, choose Detach in the Attach by Layer dialog box.
Using Materials, Blocks, and Layers

AutoCAD renders materials on objects according to a hierarchy based on how the material is attached. Materials explicitly attached have the highest priority, then materials attached by ACI, and finally materials attached by layer. If no material is attached, the global (*GLOBAL*) material is used.

If you attach materials (explicitly, by ACI, or by layer) to objects and then use those objects to form a block, the block is rendered according to the materials of its component objects. For example, a basin with a porcelain material attached and two faucets with a chrome material attached might be combined into a sink block. When the sink block is rendered, the two separate materials are distinctly displayed.

If you then attach a material to the layer on which the sink block resides, the hierarchy ensures that the materials attached to the sink block still are displayed. For example, if the component basin is drawn on a porcelain layer and the component faucets on a chrome layer, and if the sink block is placed on a red layer, the two materials (porcelain and chrome) are still displayed when the sink block is rendered.

If some components of a block have materials attached and other components have no materials attached, attaching a material to the block affects only those objects with no materials attached. For example, assume a stool block is composed of two elements: legs with the metal material attached, and a seat with no material attached. If you attach no material to the chair block, the legs are rendered metal and the seat is rendered with the global material. If you attach red to the block, the legs are rendered metal and the seat is rendered red.

If you’re including blocks with materials attached from another drawing, you must import the materials from that drawing into the list of materials in your current drawing.

You can see the materials you attach to objects in your drawing when you are viewing your model with the 3DORBIT command. However, there are some exceptions. See “Materials in 3D” on page 599 for more information.

Mapping

In the context of rendering, mapping means projecting a 2D image onto the surface of a 3D object. Photorealistic rendering maps are 2D images in one of several file formats, including BMP, TGA, TIFF, PCX, and JPEG.
Mapping coordinates are also referred to as UV coordinates. (The letters UV are used because these coordinates are independent of the XY coordinates used to describe the AutoCAD geometry.) The applied material scales appropriately to the rendered object, and that scaling is based on the AutoCAD default units.

Photorealistic rendering supports the following kinds of maps:

- **Texture maps**: Define surface colors, as if the bitmap image were painted onto the object. For example, you might apply an image of a checkerboard pattern to a horizontal flat surface to create the appearance of a parquet floor.
- **Reflection maps**: Simulate a scene reflected on the surface of a shiny object (also known as environment maps).
- **Opacity maps**: Specify areas of opacity and transparency. For example, if your bitmap image is a black circle in the middle of a white rectangle and you apply it as an opacity map, the surface appears to have a hole in it where the circle maps onto the object.
- **Bump maps**: Create an embossed or bas-relief effect.

For bitmap effects, you must render using the Photo Real or Photo Raytrace renderer.

Mapping involves two steps (performed in either order):

- Attaching a material with bitmaps to an object
- Assigning mapping coordinates to the object so that the renderer can position the maps

Reflection maps do not require mapping coordinates.

**NOTE** The mapping coordinates you assign in the Mapping dialog box apply to the entire selection set and remain with the selection set. When you move the geometry, the mapping coordinates and other mapping attributes (such as bitmap scaling) move with it.

Unless you take advantage of tiling (see “Using Tiling and Cropping” on page 708), try to apply your material maps in a 1:1 relationship (the default) to your geometry so that the map projection is effective and takes less time. Or you can use fixed-scale mapping, which maps material to a fixed scale. See “Setting Mapping Styles” on page 709. For example, if you have a 512 by 480 checkerboard pattern, you should not scale the mapping so small that the
checkerboard merely makes your object seem gray, nor should you scale the mapping so large that the object becomes either all black or all white.

Objects with an assigned object mapper (you create object mappers using the SETUV command) attempt to maintain their material orientations when you change the object using MOVE, ROTATE, MIRROR, SCALE, and other commands. This behavior is desirable for Fit to Object materials. Therefore, use an object mapper with all objects using Fit to Object materials, even if the object mapper is only a default mapper that adds no specific alterations to the bitmap. However, you may not want to use the Fit to Object materials object mapper for fixed scale materials. If not, remove or reset the mapper.

To reset object mappers, change the parallel plane, then immediately change back to the original plane before saving the mapper. In general, you should not assign object mappers to objects using fixed-scale materials unless you need to make specific alterations to the bitmap.

To counter bitmap aliasing when you get close to or far away from a mapped object, the renderer performs some filtering operations to obtain the best appearance. For example, when the viewpoint is close to the mapped object, the renderer interpolates new pixels to smooth out the map’s jagged edges; when the viewpoint is distant, the renderer samples the map to approximate an overall image. (You can select the bitmap sampling technique; see RENDER in the Command Reference.) These filtering operations increase rendering time.

You can apply maps in combination. For example, apply a wood grain bitmap as both a bump map and a texture map on a paneled wall to give the wall both the “feel” and the color of wood. Then apply an opacity map to punch a hole in the wall.

All maps have a blend value that specifies how much they affect the rendering. For example, a texture map with a blend value less than the maximum (1.0) allows some of the material’s surface colors to show through. Lower blend values reduce the bitmap’s effect. For bump maps, a low blend value usually gives the best effect.

**Using Tiling and Cropping**

When you project a bitmap onto an object, you can choose to create either a tiled or a cropped (“decal”) effect if the image is scaled smaller than the object.

If the scale of bitmap to object is less than 1:1, tiling repeats the image or pattern until the entire object is covered. For example, you can use this effect to project a checkerboard onto a sphere with only a 2 by 2 starting image or to wallpaper a room scene with a very small bitmap. Tiling is adjustable to obtain different tiling values along the mapping axes, \( U \) and \( V \).
With cropped projection, you can place an image in a single location on an object. The rest of the object is rendered with the colors of the material—its main color, reflection color, and ambient color. Also, areas within the decal can let the object’s main material color show through. For more information, see RMAT in the Command Reference.

**Setting Mapping Styles**

You map materials to fit the object or a fixed scale. In Fit to Object mapping, you map the material according to the boundaries of the rendered surface, thus the material image is stretched or shrunk to fit the object. In Fixed Scale mapping, you map the material according to a fixed scale, thus the material image is tiled to the surface boundaries, rather than being stretched.

![fit to scale](image1)

![fit to object](image2)

You use Fixed Scale and Fit to Object mapping for different rendering purposes. You can use Fit to Object for rendering landscapes or objects whose material is based on a single graphic image (such as billboards or wall paintings). You can use Fixed Scale for rendering materials built from images containing multiple repeated patterns (such as bricks, stonework, tile, and wallpaper). When you are using Fixed Scale, the scale values you enter in the UV fields control the scale at which the material is tiled onto the objects during rendering. You can select the Fixed Scale and Fit to Object options in the Adjust Material Bitmap dialog box.

**NOTE** Tiled Material Bitmap placements are only available when using Fixed Scale materials. If you select cropped tiling, the material reverts to Fit to Object mapping, which sets the default bitmap placement settings. Therefore you need to adjust the bitmap placement offset and scale values manually.

**Using Texture Maps**

A texture map is the projection of an image (such as a tile pattern) onto an object (such as a table or chair). Because of the interaction of the texture map with an object’s surface characteristics and the light and shadow, this technique can produce highly realistic images.
Using Reflection Maps
A reflection map (also known as an environment map) simulates the effect of a scene reflected on the surface of an object. For reflection maps to render well, the material should have low roughness (see “Understanding Roughness” on page 693), and the reflection bitmap itself should have a high resolution (at least 512 by 480 pixels).

NOTE Reflection maps are distinct from raytraced reflections, which are generated by the Photo Raytrace renderer without mapping.

Using Opacity Maps
Opacity maps are projections of opaque and transparent areas onto objects, creating the effect of a solid surface with holes or gaps. Opacity maps use the brightness value of the mapping image to determine opacity. Pure white areas in an opacity map are completely opaque, while pure black areas are transparent. If an opacity map is in color, the equivalent gray-scale values of the colors supply the opacity translation.

Using Bump Maps
The brightness values of a bump map image are translated into apparent changes in the height of the surface of an object. A simple example is white text on a black background. Bump mapping that image gives the white text the appearance of being raised (or embossed) against a flat background, even though the geometry has not changed.

If the bump map image is in color, the translated gray-scale value of each of the colors is used to supply the height translation. You can select any image for mapping onto an object to create an embossed or bas-relief effect.

Bump mapping increases rendering time significantly.

Using Solid Materials
Photorealistic rendering also supports three special or procedural materials—marble, granite, and wood. At rendering time, these materials generate a 3D pattern in two or more colors and apply it to an object. The pattern is controlled by parameters that vary with the kind of material. These materials are also known as template materials.

WARNING! You cannot export procedural materials to other applications, such as 3D Studio.
Mapping Projection Types

With photorealistic rendering, you can select how to project a map image onto an object. You can use the following projection types:

- Planar
- Cylindrical
- Spherical
- Solid

Generally, the effect is best if the projection type corresponds roughly to the shape of the object onto which you’re mapping, although you might need to experiment to find the best result in different situations. The sample image in the Mapping and Adjust Coordinates dialog boxes can help you see the effect of mapping before you do a full rendering.

When tiling is turned on, the extents of the projection geometry have no effect on projection. This is true even though the Adjust Planar, Cylindrical, and Spherical dialog boxes represent the projection systems by geometry—based either on the extents of the current selection set or on points you specify yourself using the pointing device. They do not limit where the bitmap is rendered, unless you turn on cropping.

Fixed scale materials only work with object mappers that use Planar Projection. If you select another projection type, the selected material reverts to Fit to Object mapping, which sets the default bitmap placement settings. Therefore you need to adjust the bitmap placement offset and scales values manually.

**NOTE** Objects with fixed scale materials using object mappers should be set using the appropriate plane for the mapper projection. This ensures that the object mapper bitmap placement for scale, offset, and rotation work in the correct plane for the object.
Understanding Planar Projection
Planar projection maps the texture onto the object with a one-to-one correspondence, as if you were projecting the texture from a slide projector onto the surface. This does not distort the texture; it just scales the image to fit the object.

Understanding Cylindrical Projection
Cylindrical projection maps an image onto a cylindrical object; the horizontal edges are wrapped together but not the top and bottom edges. The height of the texture is scaled along the cylinder’s axis.

Understanding Spherical Projection
Spherical projection warps the texture both horizontally and vertically. The top edge of the texture map is compressed to a point at the “north pole” of the sphere, as is the bottom edge at the “south pole.”
Understanding Solid Projection
Because solid materials (such as marble, granite, and wood) are three-dimensional, they have three mapping coordinates, $U$, $V$, and $W$, and can be applied from any angle. You do not always need to specify the mapping coordinates for these materials, but you can. For example, you might want to change the material’s orientation for a particular rendering or skew a pattern along one dimension. For more information, see SETUV in the Command Reference.

Importing and Exporting Materials
In a new drawing, only the *GLOBAL* material, the set of default material values, is listed in the Materials List. Rather than create a material from scratch, you might want to import a predefined material from a library of materials supplied with AutoCAD. You can use the material as is or modify it and save it under a new name for use in any drawing.

To import or export a material

1. From the View menu, choose Render ➤ Materials Library.

   In the Materials Library dialog box, the list under Current Drawing contains materials in the drawing; the list under Current Library contains materials in the library.
Choose Preview to see a rendering of the material on a small sphere or cube in the sample image before you import or export the material.

3 To add a material to the list of materials in the drawing, under Current Library, select a material from the library list. Then choose Import.

The material appears in the list under Current Drawing. Importing a material copies that material and its parameters to the list of materials in the drawing; it does not delete the material from the library.

4 To export a material from the drawing to the library of materials, under Current Drawing, select a material from the list. Then choose Export.

The material appears in the list under Current Library.

5 To save the materials in the current drawing to a named materials library (MLI) file that you can use with other drawings, under the Current Library, choose Save.

6 Choose OK.

**Command line**  MATLIB

You can use AutoVision® and 3D Studio® MLI files in AutoCAD. To access other library files, choose Open in the Materials Library dialog box.

**NOTE** Some AutoCAD architectural textures (such as bldgmats, metals, and stones) are in PNG (Portable Network Graphics) format; this format is used for its small file size.
Using Scenes in Rendering

Named views are important to rendering because you can quickly and easily go to preset viewpoint positions. Set up views using 3DORBIT, DVIEW, and VPOINT and save named views using VIEW. (See chapter 8, “Controlling the Drawing Display.”) For rendering purposes, you can also create scenes. A scene is a combination of a named view and one or more lights. When you have multiple drawings open, you can add and save different scenes in each drawing.

Scenes save you time because you don’t have to set up your viewpoint and lights from scratch every time you render.

Defining Scenes

A scene is composed of one named view and one or more lights. You can have up to 500 lights in a scene. You can set the lights in the scene any way you wish, including turning them off.

Before setting up a new scene, create one or more named views using 3DORBIT, DVIEW, VIEW, or VPOINT, and if you haven’t already done so, insert one or more lights in the drawing (see “Adding Lights” on page 694).
To set up a new scene

1. From the View menu, choose Render ➤ Scene.
2. In the Scenes dialog box, choose New.
3. In the New Scene dialog box, enter a name for the scene.
   The name must be unique and have no more than eight characters.
4. Select a named view or CURRENT from the list of views.
5. Select one or more lights or ALL from the list of lights (use the CTRL key to
   select multiple lights). Then choose OK.
6. Choose New again to create another scene, or choose OK to exit the dialog
   box.

Command line  SCENE

Related  LIGHT creates lights. VIEW creates named views.

Deleting and Modifying Scenes

Once you’ve set up a scene, you can delete or modify it at any time. You can
modify the scene by changing its name or its associated view or by changing
the lights in the scene.

To delete or modify a scene

1. From the View menu, choose Render ➤ Scene.
2. In the Scenes dialog box, select one of the scenes listed.
3. To delete the scene, choose Delete and confirm the deletion.
4. To modify the scene, choose Modify.
5. In the Modify Scene dialog box, do any of the following:
   ■ To rename a scene, enter a new scene name.
   ■ To change the scene viewpoint, select another view.
   ■ To add another light to the scene, select a light that is not highlighted (use
     the CTRL key to select multiple lights).
   ■ To turn off a light, click its name in the list. Turning off a light does not
     delete the light from the drawing.
6. Choose OK.

Command line  SCENE

Related  LIGHT creates lights. VIEW creates named views.
Saving and Redisplaying Renderings

After creating a rendering, you can save the image for redisplay at a later time. Rendering can be a time-consuming process, but redisplaying a previously rendered image is instantaneous.

To save a rendered image, you can render directly to a file, or you can render to the screen and then save the image. You can redisplay (replay) these images at any time.

Saving a Rendering Directly to a File

No matter how your display is configured, you can bypass the screen and redirect your rendering to a file. An advantage of not rendering to the screen is that you can render to higher resolutions than your current display configuration permits. You can then replay that image on other systems with higher-resolution displays. You can render your images to several file formats, including BMP, TGA, TIFF, PCX, and PostScript.

To render an image directly to a file

1. From the View menu, choose Render ➤ Render.
2. In the Render dialog box under Destination, select File. Then choose More Options.
3. In the File Output Configuration dialog box, select a file type and the options you want. Then choose OK.
4. In the Render dialog box, choose Render.
5. In the Rendering File dialog box, enter the file name. Then choose OK. After some time, your rendered image is created and saved as a file. There is no screen display.

Command line  RENDER

Related  REPLAY redisplays a BMP, TGA, or TIFF file in a viewport. SAVEIMG saves a rendered screen image in a viewport to a BMP, TGA, or TIFF file.
Saving a Viewport Rendering

After rendering a model to a viewport, you can use SAVEIMG to save the screen image to one of the following file formats: BMP, TGA, or TIFF. You can save the file as either 8 bits or 32 bits per pixel (bpp) depending on your operating system (OS) video color depth setting.

<table>
<thead>
<tr>
<th>OS</th>
<th>Image depth</th>
</tr>
</thead>
<tbody>
<tr>
<td>8-bit</td>
<td>8 bpp</td>
</tr>
<tr>
<td>15-bit</td>
<td>32 bpp</td>
</tr>
<tr>
<td>16-bit</td>
<td>32 bpp</td>
</tr>
<tr>
<td>24-bit</td>
<td>32 bpp</td>
</tr>
<tr>
<td>32-bit</td>
<td>32 bpp</td>
</tr>
</tbody>
</table>

To save a rendered image from the viewport display

1. Render the model to a viewport.
2. From the Tools menu, choose Display Image ➤ Save.
3. In the Save Image dialog box, select a file format: BMP, TGA, or TIFF.
4. Accept the default full screen size or specify the size and offsets for the image. (For an explanation of each option in the Save Image dialog box, see SAVEIMG in the Command Reference.) Then choose OK.
5. In the Image File dialog box, enter a file name. Then choose OK. AutoCAD saves the image in the selected file format.

Command line   SAVEIMG

Related   REPLAY redispaly a BMP, TGA, or TIFF file in a viewport.
To save a rendering directly to a file with no screen display, use RENDER and choose File as the Rendering Destination in the Render dialog box.

Saving a Render-Window Rendering

After rendering a model to the Render window, you can save the rendered image to a bitmap (BMP) file.
To save a rendered image as a bitmap file

1 Select the rendered image.
2 From the File menu, choose Save.
3 In the Save File dialog box, enter a file name.
4 Choose OK.

AutoCAD saves the image in the BMP file format.

To save PostScript format images from the Render window, you must export your image to a PostScript file (see “Saving a Rendered Image in PostScript Format” on page 719).

**Saving a Rendered Image in PostScript Format**

You can save a rendered image as a PostScript file for use in a word processing, desktop publishing, or other application by using the AutoCAD Export Data feature.

To save a rendered image as a PostScript file

1 From the File menu, choose Export.
2 In Enter File Name under Save As Type, select Encapsulated PS (*.eps).
3 Enter a file name.
4 Choose Save.

The image is saved in a PostScript format file.

**Redisplaying a Rendered Image**

Having saved your rendered screen image, you can redisplay that rendering at any time. If you saved the screen image in BMP, TGA, or TIFF format, use **REPLAY** to redisplay the image.

To redisplay a rendered image in a viewport

1 From the Tools menu, choose Display Image ➤ View.
2 In the Replay dialog box, enter a file name or select a file.
3 In the Image Specifications dialog box, accept the default full screen size or specify the size and offsets for displaying the image.
   (To specify size and offsets, see “To crop a rendered image in a viewport” and “To offset a rendered image in a viewport.”)
4 Choose OK.

AutoCAD displays the image.

**Command line**  REPLAY
The default size of the image in the Image box reflects the entire display size measured in pixels. Rather than display the whole image, you can choose a portion of the image to display.

To crop a rendered image in a viewport
1  From the Tools menu, choose Display Image ➤ View.
2  In the Replay dialog box, enter a file name or select a file.
3  In the Image Specifications dialog box under Image, specify two diagonal points to define the area you want to display.

AutoCAD draws a box to mark the bounds of the cropped image.

After cropping the image in the Image box, AutoCAD updates the values of the coordinates and displays a representation of the cropped image in the Screen box in the dialog box.

The X,Y coordinate defines the lower-left corner of the saved image area—by default, 0,0. You can change the location of the image in your display, that is, offset the image.

To offset a rendered image in a viewport
1  From the Tools menu, choose Display Image ➤ View.
2  In the Replay dialog box, enter a file name or select a file.
3  In the Image Specifications dialog box under Image, specify two diagonal points to crop the image and define the area you want to display.

AutoCAD draws a boundary box in the Image box to mark the bounds of the cropped image and displays the reduced image in the Screen box.
Select a point in the Image box to offset the center of the image to that point.

AutoCAD automatically redraws the image size boundaries to mark the new offset.

If you saved the screen image in bitmap file format, use REPLAY or choose the Open option from the Render window File menu to display the bitmap image in the Render window.
To redisplay a rendered image to the Render window

1. In the Render Window, from the File menu, choose Open.
2. In the Select File dialog box, enter the name of the bitmap file, or select a file.
3. Choose OK.

   The image is displayed on screen.

   If you saved your renderings directly to a file format other than BMP, TGA, or TIFF format, see the Installation Guide for more information about importing those files into your drawing.

Copying Images to the Clipboard

You can copy images to the Clipboard from the Render window for use in desktop publishing and other applications.

To copy a rendered image to the Clipboard

1. Select the rendered image.
2. From the Edit menu, choose Copy.

   The bitmap image is copied to the Clipboard.

   To place that image in another application, you don’t need to quit AutoCAD. Simply start another application, open a document, and use that application’s Paste command to insert the image from the Clipboard.

Printing Rendered Images

You can print rendered images that are displayed in the Render window or in a viewport. You can also use other applications to print rendered images that you sent directly to a file.

Printing Render Window Images

You can print any displayed image to your currently configured Microsoft® Windows® printer. To select paper size, paper orientation, and a printer, use the Windows printing controls. For more information, see your Windows documentation.
To print a Render window image

1. Make sure you’ve configured Windows correctly for your printer.
2. Render to the Render window.
3. From the Render window File menu, choose Print.

A small picture of your rendered image is displayed in the Print dialog box on a representation of the paper size using the orientation (portrait or landscape) you selected.

In the Print dialog box, you can alter the image in the following ways:

- By changing the position of the image on the page.
  Click anywhere inside the image area and drag the image to the desired location on the page.
- By changing the size of the image on the page using the resize handles.
  Move the cursor to a handle on the boundary of the image area until the cursor changes shape to a double-headed arrow. Drag to stretch the image to the desired size.
- By printing the image on a single page or by tiling across several pages. Use tiling to print large, poster-size images.
  Select the number of tiled pages by moving the Tile Pages Across and Tile Pages Down sliders. The image is redisplayed, but the aspect ratio of the image is maintained.
After defining the number of tiled pages, move the image and use the handles to stretch or reduce the image until it covers the number of pages you want.

After making your changes, choose OK to print the image.

**Printing Viewport Images**

To print an image that is currently displayed in a viewport, use SAVEIMG to save the image as a BMP, TGA, or TIFF file and then print that file (see “Saving a Viewport Rendering” on page 718). To save to other file formats, you must set Rendering Destination to File in the Render dialog box or the Rendering Preferences dialog box and print directly to a file. The image is not displayed on the screen (see “Saving a Rendering Directly to a File” on page 717).

**Comparing Render Window and Viewport Features**

The availability of several rendering features depends on whether you are rendering to the Render window or rendering to a viewport. For example, you can save to BMP file format from a viewport or from the Render window.

The following table lists features unique to the Render window.

<table>
<thead>
<tr>
<th>Render window features</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Feature</strong></td>
</tr>
<tr>
<td>Copy to Clipboard</td>
</tr>
<tr>
<td>Save image</td>
</tr>
<tr>
<td>Display saved image</td>
</tr>
<tr>
<td>Print</td>
</tr>
</tbody>
</table>
The following table lists features unique to viewports.

<table>
<thead>
<tr>
<th>Viewport features</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Feature</strong></td>
</tr>
<tr>
<td>Save image</td>
</tr>
<tr>
<td>Replay</td>
</tr>
</tbody>
</table>

**Updating Existing Drawings**

You can open a drawing containing AutoShade information, such as lights, scene blocks, and camera blocks.

When you load AutoCAD Render, AutoCAD updates any old block information into the new AutoCAD Render block types and makes the following changes to pre-AutoCAD Release 13 Render blocks (camera, light, scene blocks) in the drawing.

- **Camera**: Converts the information in camera blocks to named views using the camera name and deletes the camera blocks. If a view already exists with the same name, AutoCAD appends numbers automatically until the view name is unique.

- **Overhead, Direct, Sh_Spot**
  - Retains the light blocks as originally inserted. The `overhead.dwg` file is the block for point lights, `direct.dwg` is the block for distant lights, and `sh_spot.dwg` is the block for spotlights.

- **Clapper**: Deletes the clapper blocks.

- **Shot**: Converts the information in shot blocks to defined scenes and deletes the shot blocks.
Using Render with Related Applications

Several Autodesk® products have links with the AutoCAD renderer, including 3D Studio, Advanced Modeling Extension (AME), AutoSurf®, and AutoCAD Designer.

3D Studio

If you want to use AutoCAD geometry and rendering data with 3D Studio, you can export a drawing from the menu File ➤ Export (or 3DSOUT), or import a 3D Studio file from the menu Insert ➤ 3DStudio (or 3DSIN).

AME

If you have drawings that contain AME-created objects, use AMECONVERT to convert them to AutoCAD objects before using AutoCAD Render. You do not have to have AME running to render these objects. Attached AME material definitions are not brought into the drawing with the converted objects. Use RMAT to attach new materials to the objects.

Mechanical Desktop

If you want to use AutoCAD geometry and rendering data with Mechanical Desktop, you can export a drawing using File ➤ Export, or import a file using Insert ➤ Drawing Exchange Binary.