Autodesk®

Civil Design

RELEASE 2

USER'S GUIDE
Configuring the Grading Appearance Settings 42
Calculating General Statistics About a Grading Object 45
Editing Grading Objects 46
Object Locking 47
    Locking a Grading Object 47
AutoCAD Editing Commands and the Grading Object 48
Using Grips to Edit Grading Objects 50
    Using Grips to Edit the Footprint Vertices 50
    Using Grips to Edit the Target Regions 51
    Using Grips to Edit the Slope Tag Locations and Slope Values 51
Editing a Grading Object Using the Shortcut Menu 53
    Add a Vertex Using the Shortcut Menu 53
    Add a Slope Tag Using the Shortcut Menu 54
    Add a Target Region Using the Shortcut Menu 54
    Edit a Vertex Using the Shortcut Menu 54
    Edit a Slope Tag Using the Shortcut Menu 55
    Edit a Target Region Using the Shortcut Menu 55
    Delete a Vertex Using the Shortcut Menu 56
    Delete a Target Region Using the Shortcut Menu 56
    Delete a Slope Tag Using the Shortcut Menu 56
    Use the LIST Command 57
Functionality of Grading Objects in AutoCAD 57
Creating a Surface from a Grading Object 58
Creating Contours from a Grading Object 59
Creating Breaklines from a Grading Object 62
Calculating Volume Data for a Grading Object 63
Grading Object Usage Tips 64
    General Grading Tips 64
    Grading Objects and TIN Surfaces 66
Footprints 66
Slopes 67
Targets 67
Corners 67
Accuracy 71
Daylighting 72
    Selecting the Daylight Surface 72
    Adding Vertices to a Polyline for Daylighting 73
    Calculating Daylight Points Based on Multiple Slopes 74
    Calculating Daylight Points Based on a Single Slope 76
Inserting Daylight Points in the Drawing 77
    Creating Breaklines Between Vertices and Daylight Points 78
Chapter 2  Working with Ponds 83

Overview of Working with Ponds 84
Changing the Pond Settings 85
  Changing the Contour Settings for Ponds 85
  Changing the Slope Control Line Settings for Ponds 88
  Changing the Bench Settings for Ponds 90
Creating Pond Perimeters 91
  Drawing a Pond Perimeter 91
  Changing the Elevation of a Pond Perimeter 92
  Adding Vertices to a Pond Perimeter 93
  Filleting a Pond Perimeter 95
  Converting a 2D Pond Perimeter to 3D 96
  Converting a 3D Pond Perimeter to 2D 97
  Saving a Pond Perimeter 97
  Importing the Existing Pond Perimeter Shapes 98
Defining Ponds 99
  Defining a Pond Perimeter from a Polyline 99
  Defining a Pond Perimeter from Contours 100
  Deleting Ponds 100
Defining Pond Slopes 102
  Applying a Linear Slope to a Pond 103
  Defining the Pond Bottom by Using the Daylight Option 105
  Applying a Slope to a Pond By Specifying the Required Pond Volume 105
  Applying Multiple Linear Slopes to a Pond 107
  Resetting the Pond Pattern Settings 110
  Drawing a Pond Slope Template 111
  Defining a Pond Slope Template 112
  Selecting the Current Pond Slope Template 114
  Applying a Slope Template to a Pond 115
  Applying Multiple Templates to a Pond 116
  Applying Multiple Templates to a Pond - Multiple Option 117
  Applying Multiple Templates to a Pond - Reset Option 118
Shaping Ponds 118
  Creating the Pond Contours 119
  Creating the Pond Slope Control Lines 119
Creating the Pond Bottom 119
Creating All Pond Elements 120
Listing and Labeling Ponds 121
  Listing the Properties of a Pond 121
  Listing the Contour Area of a Pond 122
  Listing the Contour Elevations of a Pond 122
  Listing the Contour Perimeter of a Pond 122
  Listing the Slope and Grade of a Pond 123
  Labeling Ponds 123
Outputting Pond Data 125
  Reporting the Pond Contour Data By Selecting the Pond Perimeter 125
  Pond Output Data Types 127
  Reporting the Pond Contour Data By Selecting the Pond Contours 128
  Generating a Stage-Storage Curve for the Pond 129
Routing Ponds 131
  Calculating the Required Storage Volume for a Detention Basin 132
  Specifying the Drainage Area 135
  Specifying the Peak Outflow 135
  Displaying the Stage Storage Curve 136
Calculating Routing Values for Detention Basins 137
  Storage Indication Method Formula 137
  Creating an .ssc File to Use in Calculations 138
  Creating an .hdc File to Use in Calculations 138
  Creating an .sdc File to Use in Calculations 139
  Specifying Curves to Use in Calculations 142
  Displaying the Calculated Storage Volume Versus the Stage 144
  Displaying the Flow Rate Versus Time Data 145
  Displaying Multiple Hydrographs 146
Adding and Editing Outlet Structures for Ponds 146
Adding and Editing Outlet Structures to a Pond - By Pond 146
  Adding Inflow and Outflow Structures to a Defined Pond 147
  Editing Pond Inflow and Outflow Structures 152
  Deleting Pond Inflow and Outflow Structures 152
  Displaying Data About the Current Pond in the Outflow Editor 153
  Creating a Pond Rating or a Stage-Discharge Curve for the Current Pond 154
Adding and Editing Outlet Structures to a Pond Using a Stage-Storage Curve 155
Changing the Data Created By the Pond Outflow Editor 155
Removing the Profile Definition Block From a Drawing After Deleting a Profile 188
Making a Profile Current 189
Creating the Finished Ground Vertical Alignments 190
Creating the Finished Ground Centerlines 190
Working with the Vertical Alignment Tangents for the Finished Ground Centerline 191
  Setting the Current Layer for the Finished Ground Centerline 191
  Rotating the AutoCAD Crosshairs to Match the Grade of the Finished Ground Centerline 191
  Drawing the Vertical Alignment Tangents for the Finished Ground Centerline 192
  Changing the Grade Going into the PVI for the Finished Ground Centerline 194
  Changing the Grade Coming Out of the PVI for the Finished Ground Centerline 195
  Moving the Point of Vertical Intersection for the Finished Ground Centerline 196
Working with the Vertical Curves for the Finished Ground Centerline 197
  Drawing Vertical Curves for the Finished Ground Centerline 197
    Drawing a Vertical Curve Based on Curve Length 197
    Drawing a Vertical Curve Based on a Minimum K Value 198
    Drawing a Vertical Curve Based on a Passing Sight Distance 199
    Drawing a Vertical Curve Based on a Stopping Sight Distance 201
    Drawing a Vertical Curve Based on an Elevation Point 202
    Drawing a Vertical Curve Through a Point 203
    Drawing a Sag Vertical Curve Based on Headlight Data 204
    Drawing a Sag Vertical Curve Based on a Given Velocity 206
    Defining a Grade Break Without a Vertical Curve 207
    Defining the Finished Ground Centerline as a Vertical Alignment 208
    Editing the Finished Ground Centerline Alignment 209
    Importing the Finished Ground Centerline Alignment 209
    Creating COGO Points on the Plan View of the Centerline Alignment 210
    Listing the Elevation of a Selected Point or Station on a Vertical Alignment 211
Sampling the Existing Ground to Create the Profile Data 212
  Sampling the Existing Ground Profile Data from a Surface 212
  Sampling the Existing Ground from an ASCII File 213
  Sampling the Existing Ground Profile Data from the Processed Cross Sections 214
  Creating the Existing Ground Profile Data by Using the Vertical Alignment Editor 214
Creating Ditches and Transitions 216
Working with Vertical Alignment Tangents for the Ditches and Transitions 216
  Setting the Current Layer for the Ditches and Transitions 216
  Rotating the AutoCAD Crosshairs to Match the Grade of the Ditches and
  Transitions 217
  Drawing the Vertical Alignment Tangents for the Ditches and Transitions
  218
  Changing the Grade Going into the PVI for the Ditches and Transitions
  219
  Changing the Grade Coming Out of the PVI for the Ditches and
  Transitions 220
  Moving the Point of Vertical Intersection for the Ditches and Transitions
  221

Drawing Vertical Curves for Ditches and Transitions 222
  Drawing a Vertical Curve Based on the Curve Length 222
  Drawing a Vertical Curve Based on a Minimum K Value 223
  Drawing a Vertical Curve Based on a Passing Sight Distance 224
  Drawing a Vertical Curve Based on a Stopping Sight Distance 225
  Drawing a Vertical Curve Based on an Elevation Point 226
  Drawing a Vertical Curve through a Point 226
  Drawing a Sag Vertical Curves Based on the Headlight Data 227
  Drawing a Sag Vertical Curve Based on a Given Velocity 228
  Defining a Grade Break Without a Vertical Curve 229
  Listing the Vertical Curve Data 229
  Labeling the Vertical Curves 230

Defining Ditches or Transitions as Vertical Alignments 231

Defining a Ditch or Transition by Offsetting an Existing Vertical Alignment 232
  Creating a Vertical Alignment at a Uniform Offset from the Reference
  Alignment 232
  Creating a Vertical Alignment at an Offset Based on a Horizontal
  Alignment 234
  Editing a Ditch or Transition Vertical Alignment 235
  Importing the Ditch or Transition Vertical Alignments 236
  Listing the Elevation of a Selected Point or Station for the Ditch and
  Transition Alignments 237

Listing and Labeling the Vertical Alignments 238
  Changing the Text Style for the Vertical Alignment Labels 238
  Labeling the Finished Ground Tangents 239
  Labeling the Elevation and Station of a Point On a Profile 240
  Listing the Finished Ground Tangent Data 240
  Listing the Elevation and Station of Any Point In a Profile 241
  Listing the Difference in Elevation of Two Points In the Profile 241
  Listing the Elevations of Points in the Profile in Relation to the Finished
  Ground Centerline 242
Defining Subassemblies 284
  Datum Lines and Top Surface Definitions for Templates and Subassemblies 286
  Attaching the Subassemblies to Templates 287
  Changing the Subassemblies that are Attached to the Template 290
  Drawing Subassemblies 291
Editing Subassemblies 292
  Choosing Which Subassembly Vertex to Edit 292
  Saving the Changes that you Make to the Subassemblies 293
  Deleting the Current Subassembly Vertex 294
  Inserting a Subassembly Vertex 294
  Moving a Subassembly Vertex to a New Location 295
  Redrawing the Subassembly Display 296
  Defining the Subassembly Datum Line 296
  Defining the Subassembly Connection Points 297
  Defining the Subassembly Top Surface 298
  Highlighting the Subassembly Features for Better Viewing 298
  Importing the Subassemblies into a Drawing 299
Defining Templates 300
  Defining Templates 301
    Defining a Template that Only has Normal Surfaces 301
    Defining a Template that has Subgrade Surfaces 304
  Editing Templates 307
    Choosing Which Template Vertex to Edit 308
    Inserting a Vertex into a Template 309
    Moving a Template Vertex to a New Location 310
    Deleting the Current Template Vertex 311
    Drawing a New Template Surface 311
    Moving a Template Surface 312
    Adding a Template Surface to the Template 314
    Deleting a Template Surface 314
    Editing the Template Subgrade Depth and Match Grade 315
    Changing the Material Description of a Template Surface 316
    Adding Template Point Codes to a Template 317
    Deleting Template Point Codes from a Template 318
    Displaying the Template Shoulder Subassembly 318
    Defining or Editing the Template Datum Line 319
    Defining the Template Superelevation Regions 320
    Defining the Template Connection Points 321
    Defining the Template Top Surface Points 322
    Highlighting Template Features for Better Viewing 323
Redrawing the Template Display 324
Importing a Template into a Drawing 325
Creating Finished Ground Cross Sections 326
  Prerequisites for Applying Templates to Existing Ground Cross Sections 326
Designing Roadway Slopes with Templates and Cross Sections 326
  Changing the Slope Settings 326
  Changing the Stepped Slope Settings 329
  Changing the Surface Slope Settings 330
Creating Roadway Transitions with Templates and Cross Sections 332
Defining the Transition Regions on a Template 333
Attaching the Horizontal Alignment Transitions to Cross Sections 338
  Prerequisites for Attaching the Horizontal Transitions to Cross Sections 338
  Attaching the Horizontal Transition Alignments to Cross Sections 339
Attaching the Vertical Transitions to Cross Sections 340
  Prerequisites for Attaching the Vertical Transitions to the Cross Sections 340
  Attaching the Subgrade Vertical Alignments to the Cross Sections 341
Modifying Design Control 341
  Specifying the Design Control Values for Templates 342
  Editing the Transitions 343
  Editing the Template Superelevation Parameters 344
  Specifying the Design Control Values for Ditches 346
  Specifying the Design Control Values for Sideslopes 347
  Specifying the Design Control Values for Benches 351
  Benching Notes 352
  Using Ditch or Transition Profiles when Processing the Cross Sections 353
Creating the Roadway Superelevation with Templates and Cross Sections 354
  Defining the Superelevation Regions on a Template 354
  Changing the Superelevation Control Values 356
  Changing the Superelevation Settings 357
  Superelevation Methods 359
  Editing the Superelevation for One Section at a Time 361
  Editing, Inserting, or Deleting a Superelevated Curve 362
  Importing a Superelevated Horizontal Alignment After Editing It 364
  Importing Superelevation into a Profile 364
  Displaying the Superelevation Methods 365
  Outputting the Superelevation Data 366
  Processing the Cross Sections for a Range of Stations 366
  Resetting the Cross Section Processing Settings Back to the Default Project Settings 367
Superelevating Compound and Reverse Curves 368
  Superelevating Compound Curves 368
  Example of Superelevating Compound Curves Separated by Tangents or Spirals 370
  Example of Superelevating Complex Compound Curves 372
  Superelevating Reverse Curves 372
  Example of Superelevating Reverse Curves Separated by Tangents or Spirals 373
  Example of Superelevating Complex Reverse Curves 375
Displaying and Reporting the Cross Section Control Values 375
  Displaying the Design Control Values for Any Section 375
  Displaying the Actual Control Values for Any Section 376
  Displaying the Control Errors 377
  Outputting the Control Values to a Text File 378
Changing the Slope Control for the Sections 378
Designing and Editing Roadway Ditches with Templates and Cross Sections 379
  Changing the Ditch Control 379
Changing the Ditch Slope 381
Changing the Ditch Elevation 381
Changing the Ditch Width 382
Changing the Ditch Offset and Depth 383
Changing the Match Slope 384
Editing Cross Sections 384
  Using the Edit Design Control Command to Process and Edit the Cross Sections 384
  Prerequisites for Using the View/Edit Sections Command to Edit Cross Sections 385
Using the View/Edit Sections Command to Edit the Cross Sections 385
  Choosing which Cross Section Station to Edit 386
  Identifying the Offset and Elevation of a Point 386
  Changing the Appearance of Cross Sections 386
  Zooming to Cross Sections 388
  Changing the Design Control Values for One Section 389
  Changing the Template Control for One Section 390
Editing the Template Transitions 391
  Changing the Template Transitions for One Section at a Time 391
  Changing the Left and Right Transition Regions for One Section 393
  Changing the Subgrade Transition Regions for One Section 394
Using the Cross Section Elements in a Plan Alignment 395
  Importing a Ditch or Transition from the Sections into the Plan View 395
  Defining a Ditch or Transition as a Horizontal Alignment 396
  Editing a Ditch or Transition Horizontal Alignment 397
Using the Cross Section Elements in a Profile 397
   Importing a Ditch or Transition from the Sections into a Profile 398
   Importing the Superelevation into a Profile 399
   Defining a Ditch or Transition as a Vertical Alignment 399
   Editing a Ditch or Transition Profile Alignment 400
Outputting and Importing Template Points 401
   Importing the Template Points into a Drawing 401
   Outputting the Template Point Data to a File 403
   Outputting Finished Ground Information 404
   Importing the Catch Points and Daylight Lines into the Drawing 405
   Outputting the Catch Point Data to a File 406
Plotting and Outputting the Cross Sections 408
   Changing the Output Settings for Outputting Cross Sections 408
   Changing the Cross Section Plotting Settings 411
   Changing the Section Layout Settings for Plotting Cross Sections 412
   Changing the Page Layout Settings for Plotting Cross Sections 413
   Changing the Text Size for the Plotted Section Labels 415
   Plotting a Single Cross Section 415
   Plotting Multiple Cross Sections 416
   Importing All Plotted Cross Sections into a Drawing 418
   Erasing a Cross Section 419
Section Utilities 419
   Choosing the Current Cross Section by Entering a Station Number 420
   Choosing the Current Cross Section by Picking a Point 420
   Zooming to a Cross Section by Entering a Station Number 421
   Zooming to a Cross Section by Picking a Point 421
   Listing the Offset and Elevation of Cross Section Points 421
   Listing the Slope, Grade, and Elevational Difference on a Cross Section 422
   Listing a Selected Area of a Cross Section 422
Labeling Cross Sections 423
   Changing the Text Size for Cross Section Labels 423
   Labeling the Offset of the Cross Section Points Automatically 424
   Labeling the Offset of the Cross Section Points Manually 425
   Labeling the Elevation of the Cross Section Points Manually 427
   Labeling the Elevation of the Cross Section Points Automatically 428
   Labeling the Difference in Elevation Between Two Cross Section Points Manually 429
   Labeling the Grade Between Two Cross Section Points 430
   Labeling the Slope Between Two Cross Section Points 431
   Labeling a Selected Area on a Cross Section 432
Chapter 5 Working with Hydrology Commands 467

Hydrology Overview 468
Calculating Hydraulic Values for Structural Components 469
Calculating Channel Values 470
   Calculating the Rectangular Channel Values 470
   Calculating Trapezoidal Channel Values 477
   Calculating Channel Values With User-Defined Left and Right Radii and Slopes 478
Calculating Culvert Size and Shape 480
   Changing the Culvert Settings 484
   Specifying the Flowrate Using a Hydrograph (.hdc) File 491
   Displaying a Summary of the Culvert Calculations 492
   Changing the Overtop Flow Values to Use in the Culvert Calculations 494
Calculating Pipe Values 497
Calculating Pipe Flow and Other Hydraulic Values Using the Manning’s n Equations 498
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculating the Hydraulic Values for Circular Pipes Using Manning’s</td>
<td>499</td>
</tr>
<tr>
<td>Equations</td>
<td></td>
</tr>
<tr>
<td>Calculating the Flow for Rectangular Pipes Using Manning's Equations</td>
<td>501</td>
</tr>
<tr>
<td>Calculating the Flow for Elliptical Pipes Using Manning's Equations</td>
<td>503</td>
</tr>
<tr>
<td>Calculating the Flow for Custom Pipes Using Manning’s Equations</td>
<td>505</td>
</tr>
<tr>
<td>Calculating Pipe Flow and Other Hydraulic Values Using the Darcy-Weisbach Equations</td>
<td>506</td>
</tr>
<tr>
<td>Calculating the Flow for Circular Pipes Using the Darcy-Weisbach</td>
<td>507</td>
</tr>
<tr>
<td>Equations</td>
<td></td>
</tr>
<tr>
<td>Calculating the Flow for Rectangular Pipes Using the Darcy-Weisbach</td>
<td>509</td>
</tr>
<tr>
<td>Equations</td>
<td></td>
</tr>
<tr>
<td>Calculating the Flow for Elliptical Pipes Using the Darcy-Weisbach</td>
<td>511</td>
</tr>
<tr>
<td>Equations</td>
<td></td>
</tr>
<tr>
<td>Calculating the Flow for Custom Pipes Using the Darcy-Weisbach</td>
<td>512</td>
</tr>
<tr>
<td>Equations</td>
<td></td>
</tr>
<tr>
<td>Calculating Pipe Flow and Other Hydraulic Values by Using the</td>
<td>513</td>
</tr>
<tr>
<td>Hazen-Williams Equations</td>
<td></td>
</tr>
<tr>
<td>Calculating the Flow for Circular Pipes Using the Hazen-Williams</td>
<td>513</td>
</tr>
<tr>
<td>Equations</td>
<td></td>
</tr>
<tr>
<td>Calculating the Flow for Rectangular Pipes Using the Hazen-Williams</td>
<td>515</td>
</tr>
<tr>
<td>Equations</td>
<td></td>
</tr>
<tr>
<td>Calculating the Flow for Elliptical Pipes Using the Hazen-Williams</td>
<td>517</td>
</tr>
<tr>
<td>Equations</td>
<td></td>
</tr>
<tr>
<td>Calculating the Flow for Custom Pipes Using the Hazen-Williams</td>
<td>518</td>
</tr>
<tr>
<td>Equations</td>
<td></td>
</tr>
<tr>
<td>Calculating Orifice Values</td>
<td>519</td>
</tr>
<tr>
<td>Calculating Weir Values</td>
<td>522</td>
</tr>
<tr>
<td>Calculating Cipolleti Weir Values</td>
<td>523</td>
</tr>
<tr>
<td>Calculating Rectangular Weir Values</td>
<td>525</td>
</tr>
<tr>
<td>Calculating Triangular Weir Values</td>
<td>528</td>
</tr>
<tr>
<td>Calculating Riser Values</td>
<td>530</td>
</tr>
<tr>
<td>Changing the Riser Settings</td>
<td>530</td>
</tr>
<tr>
<td>Calculating Riser Values</td>
<td>530</td>
</tr>
<tr>
<td>Customizing Riser Diameter and Pipe Diameter Tables</td>
<td>534</td>
</tr>
<tr>
<td>Creating and Saving a Rating Curve of Riser Data</td>
<td>536</td>
</tr>
<tr>
<td>Changing the Hydrology Output Settings</td>
<td>539</td>
</tr>
<tr>
<td>Changing the Hydrology Units Settings</td>
<td>539</td>
</tr>
<tr>
<td>Changing the Hydrology Precision Settings</td>
<td>541</td>
</tr>
<tr>
<td>Changing the Hydrology Graph Settings</td>
<td>541</td>
</tr>
<tr>
<td>Changing the Hydrology Plotting Settings</td>
<td>542</td>
</tr>
<tr>
<td>Loading Previously Saved Hydrology Plotting Settings</td>
<td>543</td>
</tr>
<tr>
<td>Saving the Current Hydrology Plotting Settings to a File</td>
<td>544</td>
</tr>
</tbody>
</table>
Specifying Which ASCII Text Editor to Use for Viewing and Editing the Hydrology Files 544
Returning the Hydrology Settings to the Default Prototype Settings 545
Calculating the Runoff from Watershed Areas 545
Selecting a Runoff Calculation Method to Use 546
Selecting the Rainfall Frequency for a County 547
Editing and Defining Rainfall Frequency Values for Counties 549
Selecting the Rainfall Frequency for a County 550
Customizing the Rainfall Distribution File 550
Selecting and Editing the Runoff Curve Numbers for Different Soil Groups and Cover Types 552
Selecting the Runoff Curve Numbers for Different Soil Groups and Cover Types 554
Calculating a Composite (or Weighted) Curve Number for More Than One Watershed or Subarea 554
Time of Concentration and Time of Travel 556
Calculating the Watershed Time of Concentration 557
Specifying the Sheet Flow 558
Specifying the Shallow Flow 560
Specifying the Channel Flow 561
Calculating the Watershed Time of Travel 562
Calculating the Peak Runoff Flow for an Area Using the Rational Method 564
Specifying the Rainfall Intensity 568
Displaying a Graph of the Intensity-Duration Frequency Data 569
Changing the Hydrology Plotting Settings 570
Changing the Main Title Settings 571
Changing the X-Axis Settings 572
Changing the Y-Axis Settings 574
Changing the Border Settings 576
Changing the Grid Settings 577
Changing the Grid Tick Settings 578
Changing the Individual Curve Preferences 579
Changing X,Y Data for an Individual Curve 580
Changing the Hydrology Graph Settings 582
Using the TR-55 Graphical Method to Calculate the Peak Runoff Flow 585
Calculating the Peak Runoff Flow by Using the TR-55 Graphical Method 587
Calculating the Peak Runoff Flow by Using the TR-55 Tabular Method 590
Saving TR-55 Tabular Runoff Calculations 592
Displaying the Calculated Hydrograph Data for Each Subarea and the Entire Watershed 593
Changing the Label Settings for Finished Draft Pipes 639
  Changing the Label Settings for Finished Draft Pipes in Plan View 639
  Changing the Label Settings for Finished Draft Pipes in Profile View 641
Changing the Label Settings for Finished Draft Nodes 643
  Changing the Label Settings for Finished Draft Nodes in Plan View 643
  Changing the Label Settings for Finished Draft Nodes in Profile View 645
Creating and Editing Node Symbols 647
Choosing a Text Editor in Which to Display Pipe Data 649
Importing, Exporting, Resetting, and Auditing Pipe Settings 650
  Export a Pipes DFM File 650
  Import a Pipes DFM File 650
  Resetting the Pipes Settings to Their Original Values 651
  Auditing the Pipe Database 651
Drawing and Defining Conceptual Pipe Runs 651
  Drawing and Defining Pipe Runs 652
  Specifying the Elevation of Pipe Runs Using a Surface 653
  Specifying the Elevation of Pipe Runs Manually 653
  Defining Polylines as Pipe Runs 656
  Displaying the Conceptual Pipe Runs That Exist in a Drawing 658
  Checking for Defined Pipe Runs in a Drawing 659
  Identifying Pipe Runs in a Drawing 659
Importing Conceptual Pipe Runs into a Drawing 659
  Importing Conceptual Pipe Runs into Plan View 659
  Importing Conceptual Pipe Runs into Profile View 660
  Associating Pipe Runs with Horizontal Alignments 661
Editing Conceptual Pipe Runs 661
  Editing Conceptual Pipe Runs in Plan View 662
Editing Conceptual Plan Pipe Runs Using the Pipe Run Editor 663
  Calculating Metric Pipe Sizes and Labeling 663
  Changing the Pipe Run Editor Settings 664
  Changing the Precision Settings 666
  Calculating Hydraulic and Energy Gradelines 667
  Using Contributing Upstream Run Flow Data in Pipe Calculations 668
Editing Conceptual Pipe Runs in Plan View Using the Pipe Run Editor 670
  Editing Conceptual Pipe Runs in Plan View - Column Headings 675
  Copying or Clearing the Fields and Columns in the Pipe Run Editor 679
  Displaying Error Messages in the Pipe Run Editor 680
  Adding Surface Runoff Contributions to Pipe Nodes or Segments 681
  Displaying the Data in a Text Editor 682
  Reversing the Direction of the Flow in a Pipe 683
Creating Finished Draft Runs Using a Symbol Line Type 704
Restoring the Appearance of a Profile After Erasing a Pipe Run 704
Creating Hydraulic Gradelines in Profile View 704
Creating Energy Gradelines in Profile View 705
Identifying and Labeling Areas on a Profile Where a Pipe Run Crosses an Alignment 705
Importing and Exporting Pipe Data 706
  Importing Pipe Files that are in ASCII (ASC) Format 706
  Importing Pipe Files that are in WK1 Format 706
  Importing Pipe Files that are in DB Format 706
  Exporting Pipe Files to ASCII (ASC0 Format 707
  Exporting Pipe Files to ASCII Format 707
  Exporting Pipe Files to WK1 Format 707
  Exporting Pipe Files to DB Format 708
Changing the Order in Which Pipe Parameters Are Output 708
Creating Templates for Outputting Pipe Data 709

Chapter 7   Creating and Plotting Sheets Using Sheet Manager 711

Changing Sheet Manager Preferences 712
  Sheet Manager Settings 712
  Changing the View Definitions Layer 713
  Changing the Model Space Match Line Layer 713
  Changing the Label Frame Layer 715
  Setting the Layout Page Setup Name 715
  Basing the Sheet Layout on Profile or Plan Lengths 716
  Drawing Model Space Match Lines 717
  Changing the Profile Station Offset 718
  Returning to Model Space After Generating Sheets 718
  Controlling Grid Creation During Label Draw 718
  Aligning Grids to Frame Contents 719
  Changing the Block Search Path 720
  Changing the Sheet Style Database Path 721
  Editing the sdsk.dfm File 723
Changing Cross Section Sheet Preferences 724
  Changing the Horizontal Scale 725
  Changing the Vertical Scale 726
  Snapping Sections to a Grid 726
  Changing the Column Spacing 727
  Changing the Row Spacing 727
  Changing the Section Sheet Border Spacing 728
Contents

xxii

Changing the Internal Section Spacing 729
Changing the Horizontal Layout 729
Changing the Vertical Layout 730
Changing the Volume Calculation Method 730
Using Curve Correction 731
Changing the Cut Correction Value 731
Changing the Fill Correction Value 732
Appending Surface Names to EG and Template Layers 732
Changing the Section Sheet Layer Settings 733

Naming a Sheet Series 734
Naming a Plan/Profile Sheet Series 734
Naming a Profile Sheet Series 736
Naming a Section Sheet Series 737

Laying Out a Plan/Profile Sheet Series 738
Changing Plan/Profile Series Layout Options 738
Creating a Plan/Profile Sheet Series Layout 740
Adding a New Sheet to a Plan/Profile Sheet Series Layout 741
Editing a Plan/Profile Sheet Layout 743
Deleting a Plan/Profile Sheet Series Layout 746

Laying Out a Profile Sheet Series 746
Changing Profile Series Layout Options 746
Creating a Profile Sheet Series Layout 747
Adding a New Sheet to a Profile Sheet Series Layout 749
Editing a Profile Sheet Layout 750
Deleting a Profile Sheet Series Layout 752

Generating a Plan/Profile Sheets Series 753
Generating a Single Plan/Profile Sheet 754
Generating a Series of Plan/Profile Sheets 755
Generating a Plan/Profile Sheet Series Automatically 756
Saving a Plan/Profile Sheet 757
Loading a Generated Plan/Profile Sheet 757
Loading a Plan/Profile Sheet Series 758
Rules for Loading a Sheet Series 758
Deleting a Plan/Profile Sheet Series 759

Generating a Profile Sheet Series 759
Generating a Single Profile Sheet 759
Generating a Series of Profile Sheets 760
Generating a Profile Sheet Series Automatically 761
Saving a Profile Sheet 762
Loading a Generated Profile Sheet 763
Loading a Profile Sheet Series 764
Deleting a Profile Sheet Series 764
Generating a Cross Section Sheet Series 764
Saving a Section Sheet 767
Loading a Generated Section Sheet 768
Loading a Section Sheet Series 768
Deleting a Section Sheet Series 769
Creating Plan/Profile Sheets 769
Creating Profile-Only Sheets 771
Creating Plan-Only Sheets 772
Creating Section Sheets 774
Creating Single Sheets 775
Saving a Single Sheet in Paper Space 775
Loading a Single Sheet to Paper Space 776
Working with Sheet Tools 776
Setting the Viewport View Scale 777
Copying Model Space Entities to Paper Space 777
Moving Model Space Entities to Paper Space 777
Copying Paper Space Entities to Model Space 778
Moving Paper Space Entities to Model Space 778
Erasing All Entities in Paper Space 779
Splitting the Plan View 779
Setting the Plan View Angle 780
Rotating the Plan Annotation 780
Restoring Rotated Plan Annotation 782
Splitting the Profile View 782
Changing the Profile View Datum 783
Creating a Layer Report 784
Plotting Sheets 785
Creating a Layout Page Setup Name 785
Batching Plot Sheets 785
Running a Batch Plot Job 786
Hiding Lines for Plotting 786
Working with Sheet Styles 787
Customizing Sheet Manager 788
Using a Sheet Style That Was Included with Sheet Manager 788
Choosing the Current Sheet Style 789
Creating a New Sheet Style 789
Creating a New Plan/Profile Sheet Style 790
Creating a New Plan/Profile Sheet in a Separate Drawing 791
Creating a New Plan/Profile Sheet in the Paper Space of an Existing Drawing 792
Creating a New Profile-Only Sheet Style 792
Creating a New Plan-Only Sheet Style 793
Creating a New Cross Section Sheet Style 795
Creating a New Section Sheet In a Separate Drawing 796
Editing a Sheet Style 797
Choosing a Method for Creating, Opening, and Editing Sheet Style Drawings 797
Creating a Viewport 799
Choosing a Viewport Category 800
Saving a Sheet Style 801
Loading a Sheet Style 803
Working with Frames 804
Drawing Frames for Section Sheets 806
Drawing a Section/View Frame 808
Drawing a Section/Section Frame 809
Drawing a Section/Label Frame 810
Drawing a Section/Table Frame 810
Attaching Labels and Grids to Frames 812
Drawing Frames for Plan/Profile and Profile Sheets 814
Creating a Frame 814
Creating Labels and Grids 817
Creating a Text Label 817
Specifying Which Design Elements the Text Label Will Label 820
Setting the Numeric Format for a Text Label 822
Deleting a Text Label Style 823
Renaming a Text Label Style 824
Copying a Text Label Style 824
Creating Text Labels in Multi-Line Format 830
Converting Values With the Formula Data Option 833
Text Label Formula Function Symbols 834
Creating a Block Label Style 838
Creating a Distance Label Style 840
Exporting a Distance Dimension Style 846
Creating a Grid Style 847
Positioning Labels 851
Attaching Label and Grid Styles to a Frame 851
Deleting a Label or Grid Style That is Attached to a Frame 853
Controlling the Label Placement 854
Choosing the Frame Justification 868
Drawing a Line Marker 869
Setting Horizontal and Vertical Offset Values 869
Updating Labels and Grids 871
  Updating Frame Labels With the Update Frame Labels Command 871
  Updating Frame Labels With the Update All Frame Labels Command 871
  Updating Frame Labels With the Create/Edit Frame Command 871
  Editing a Label or Grid by Selecting It from Screen 872
Importing and Exporting Label and Grid Styles 872
  Importing Label and Grid Styles from Another Database 872
  Exporting Label and Grid Styles to Another Database 873
Attaching Label and Grid Sheets to a Frame 874
  Selecting Sheet Style Frames or Viewports 874
  Updating Grids When Drawing Labels 875
Categories and Codes for Creating Labels 875
  Categories and Codes for Text, Block, and Distance Labels 875

Appendix A  Autodesk Civil Design File List 883

Appendix B  Help Files and Tutorials 889

Index 891
Using the Grading Commands

Use the Grading commands to create finish ground surfaces for a site. You can use the Grading Wizard to create a grading object and edit the grading object using the grading properties and grips. You can create surfaces and breaklines from the grading object and calculate volumes for the grading object.

Use point modification commands to help build a finish ground surface.
Developing Finished Ground Surface Models

When you add or remove soil, rock, and other materials to shape the land for a project, you institute grading to configure the land’s surface. Grading provides tools to model the ground elevations and the inclination of the ground surface.

The Grading commands are designed to help you develop your finished ground surface models. You need to begin your site calculations with an existing ground surface that you created using the commands in the Terrain menu. Then, create your finished ground data, such as grading objects, contours, and points, and build the new finished ground surface.

You should create new layers for your finished ground data. That way, when you are ready to define the surface data that you want to use for creating the new surface, you can freeze or turn off all unnecessary layers and it is easy to select only the information for that surface. You may want to create separate layers for finished ground points, contours, and breaklines, or place them all on the same layer.

Creating Finished Grade Labels

Grade labels are a simple set of commands to allow you to label surface elevations with a leader and text. The text is special because it is recognized by the grading commands and can be updated by point editing commands within the Grading menu. When creating labels, you are given the option of entering an elevation value or retrieving an elevation automatically from a terrain model surface. The commands in the Grading menu allow you to control the settings of the labels, place a label, and edit a label or point elevation.

Changing the Finished Grade Label Settings

You can change the finished grade label settings using the Grade Labels ➤ Settings command on the Grading menu.

To change the finished grade label settings

1. From the Grading menu, choose Grade Labels ➤ Settings to display the Finish Grade Label and Daylighting Settings dialog box.
2 Under Finish Ground Labels, you can select Rounding factor, and enter a factor by which to round the elevation values.

When the Rounding factor check box is selected, the rounding values of elevations and finish ground labels have default settings of 0.05 feet in imperial and 0.005 millimeters in metric. The Finished Grade Points commands apply this value to all point elevations and finished ground labels.

**NOTE** This step is optional. You do not have to enter a rounding factor.

3 In the Layer for labels box, enter the name of the layer on which to place the labels.

The current layer is displayed in this field by default.

4 Under Daylight Settings, select the Continuous daylight polyline check box if you want to draw daylight lines as continuous polylines when you are using the Daylight Polyline command.

The Daylight Polyline command creates a continuous polyline connecting daylight points. If a daylight point cannot be found, then the polyline remains continuous. Instead of breaking, the polyline follows the edge of the finished ground object until it can locate the next daylight point.

If the Continuous daylight polyline check box is cleared, the daylight polyline ends when a daylight point is not found for a particular vertex of your finished ground object. The daylight polyline then starts again at the next daylight point it can locate.

5 Under Slope check, locate daylight points:

- Select Check cut if you want the Daylight commands to look for a surface in a cut direction only.
- Select Check fill if you want the Daylight commands to look for a surface in a fill direction only.
- Select Check cut and fill if you want the Daylight commands to look for a surface in both a cut and fill direction.

6 Under Prompt for daylight points, control the prompt sequence of the Daylight Points command:

- Select Prompt for daylight points if you want the command to prompt you for a number of points to be placed between the polyline vertex of the finished ground object and the daylight point.
- Select Use default value if you want the command to interpolate a set amount of points between the polyline vertex of the finished ground object and the daylight point. Type the value in the Default value box.

7 Click OK to exit the Finish Grade Label and Daylighting Settings dialog box.
Creating Finished Grade Labels

You can create labels in plan view on a finished ground surface with a specified elevation or obtain elevational information from a surface.

To label the finished ground points

1. From the Grading menu, choose Grade Labels ➤ Finish Grade Label.

   The following prompt is displayed:

   **Point (or Surface):**

2. Do one of the following:
   - Select a point to label, and type the elevation for the point.
   - Type `S`, select a surface from the Select Surface dialog box, select a point to label, and press ENTER to accept the surface elevation for that point, or type a new elevation.

   **NOTE** When you use the Surface option, elevations for that surface are turned on until you turn them off by typing `P` at the Surface (or Point) prompt. When selecting the surface option, you are prompted to select the surface to label. That surface becomes the current surface (in Terrain Model Explorer).

3. Select a point to define the label leader.

4. You can continue to select leader points.

   The following prompt is displayed:

   **Rotation angle <0d0 c0 s0>:**

5. At this prompt, do one of the following to specify a rotation angle for the label:
   - Press ENTER to place the label at a zero rotation.
   - Type a new rotation angle using the format `###d##'##", where the pound signs (#) indicate the digits of the rotation angle.
   - Select a point with your pointing device to graphically define the angle.

6. Select another point to label, or press ENTER to end the command.

Editing Grading Points or Finished Grade Labels

You can edit the elevation of a group of point objects or finished grade labels. Point objects or finished grade labels must exist in the drawing.

To edit points or finished grade labels

1. From the Grading menu, choose Grade Labels ➤ Edit Points/FG Labels.

   The following prompt is displayed:

   **Select point or finish ground label:**

2. Select a point object or block or label from your drawing.

3. At the command prompt, type the new elevation for that point or label.

   The command changes the elevation for the label or point.

4. Select another point or finished grade label, or press ENTER to end the command.
Modifying Point Elevations

With the commands on the Modify Point Elevations submenus, you can modify the elevations of finished ground point objects by using a relative or absolute hinge, or by working with a stratum.

The stratum commands update the elevations of selected points based on a defined stratum. You can report NEZ point data based on a stratum and obtain the elevations from a stratum based on specified X, Y coordinates. The elevations retrieved from the stratum can be the elevation of the first surface, the second surface, or the elevation difference between the two surfaces.

All of the commands allow the entry of points by a screen pick on any entity, selecting a point object, entering a point number, or typing Northing/Easting.

To switch point selection modes, type one of the following:
- `.g` at the command prompt to select a point object from the screen
- `.p` to enter a point number
- `.n` to enter a Northing/Easting coordinate

Re-typing `.g`, `.p`, or `.n` accesses the AutoCAD entity selection mode, with the object snap automatically set to “near.”

Changing Elevations of Points by Relative Hinge

You can use a hinge line to edit the elevations of points or finish grade labels. You can define the hinge line by two points and a relative slope or grade. The relative slope or grade adjusts all the points up or down, adding or subtracting the specified slope from the existing slopes of the points. Valid elevations must exist in the drawing.

You select two points to define the hinge line, and then define the slope or grade leading away from the hinge line. The elevations of the points you select are then adjusted based on this slope from the hinge line.

To change the elevations of points or the fg labels

1. From the Grading menu, choose Modify Point Elevations ➤ Modify by Relative Hinge.
   The following prompts are displayed:
   - Select two points to establish hinge line...
   - Select first point:

2. Select two points to define the hinge line.
   The following prompt is displayed:
   - Desired Slope (or Grade) <Infinite>: 

3. Define the slope or grade that is added to, or subtracted from, the existing slope or grade of the points:
   - Type a slope in the format specified.
   - Type G and a positive or negative grade percentage.

4. Select the points to adjust.
Press ENTER to complete the selection set.
The command adjusts the elevations of the points based on the slope or grade. For example, if you selected points that were originally placed at a grade of 1.3%, 1.1%, and 2.1%, and you defined a relative hinge grade of 2%, then the points are now placed at grades of 3.3%, 3.1%, and 4.1%.
The further the point is from the hinge line, the greater the change in elevation. The following illustration shows point elevations adjusted by a relative hinge:

Modify by relative hinge

**Changing Elevations of Points by Absolute Hinge**
You can use a hinge line to edit the elevations of points or finish grade labels. You can define the hinge line by two points and an absolute slope or grade. The absolute slope or grade adjusts the elevation of all the selected points up or down to match the specified slope.
You select two points to define the hinge line, and then define the grade or slope leading away from the hinge line. The elevations of the points you select are then adjusted based on this grade or slope from the hinge line.

**To change the elevations of points or the fg labels**
1. From the Grading menu, choose Modify Point Elevations ➤ Modify by Absolute Hinge.
The following prompt is displayed:
   Select first point:
2. Select the first point to define the hinge line by clicking in your drawing.
The following prompt is displayed:
   Elevation <0.00>:
3. Enter an elevation for the first point.
   You are prompted to select the second point.
4. Select the second point by clicking in your drawing.
   You are prompted to enter an elevation for the second point.
5. Enter an elevation for the second point.

The following prompt is displayed:

Desired Slope (or Grade) <Infinite>:

6. Define the slope or grade at which the points are placed:
   - Type a slope in the format specified.
   - Type G and a positive or negative grade percentage.

7. Select the points to adjust.

8. Press ENTER to complete the selection set.

The command adjusts the elevations of the points to match the specified slope or grade. For example, if you selected points that were originally placed at grades of 2.0% and 2.5%, and you defined an absolute hinge grade of 3%, then all the points are now placed at a grade of 3%.

The following illustration shows point elevations adjusted by an absolute hinge:

![Modify by absolute hinge](image-url)

### Working with a Stratum

You can use the Modify Point Elevations ➤ Select Current Stratum command on the Grading menu to define a stratum based on the existing and finished ground surfaces for calculating volumes. You can also delete a stratum using this command. In all cases, the first surface is considered your existing ground and the second surface is considered your finished ground for volume and elevation comparisons.

### Definition of a Stratum

A stratum defines a group of two surfaces for the purpose of calculating volumes and elevation differences between those two surfaces. In all cases, the first surface is considered the existing ground and the second surface is considered your finished ground for volume and elevation comparisons.

You can also define multiple strata with various types of combinations. For instance, you can establish an existing ground surface, and then create one or more finished ground surfaces to compare with that existing ground surface. You can then define different strata by combining the single existing ground surface and different finished ground surfaces.
When you calculate volume, you are prompted for the stratum to be used for those computations. You must create a surface (or Triangulated Irregular Network) for each surface in the indicated stratum before using any volume calculations.

**Defining a Stratum**

You can define a stratum used to calculate volumes and elevations. For more information, see “Definition of a Stratum” in this chapter.

**To define a stratum**

1. From the Grading menu, choose Modify Point Elevations ➤ Select Current Stratum. Do one of the following:

<table>
<thead>
<tr>
<th>If you…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>haven't defined a stratum</td>
<td>the Define Stratum dialog box is displayed.</td>
</tr>
<tr>
<td>have defined a stratum</td>
<td>the Select Current Stratum dialog box is displayed.</td>
</tr>
<tr>
<td></td>
<td>Click New to continue.</td>
</tr>
</tbody>
</table>

---

**Select Current Stratum**

- Surface 1: eg
- Surface 2: eg
- Basis: blue

**Selection**

Stratum: [ ]

[ ] New...  [ ] Delete

[ ] OK  [ ] Cancel  [ ] Help
2 In the Define Stratum dialog box, type the name of the new stratum in the Name text box.

3 In the Description text box, type the description.

4 Select the two surfaces that make up the stratum by using one of the following methods:
   - In the edit boxes, type the names of the surfaces.
   - Click Select to display the Select Surface dialog box, where you can select the surfaces to use.

5 Click OK to define the stratum and exit the dialog box.

**Selecting the Current Stratum**

*To select the current stratum*

1 From the Grading menu, choose Modify Point Elevations ➤ Select Current Stratum to display the Select Current Stratum dialog box.
2 From the Selection list box, select the stratum to use.
3 Click OK.

**Deleting a Stratum**

*To delete a stratum*

1 From the Grading menu, choose Modify Point Elevations ➤ Select Current Stratum to display the Select Current Stratum dialog box.
2 From the Selection list box, select the stratum to delete.
3 Click Delete. A warning dialog box is displayed.
4 Do one of the following:
   - Click Yes to delete the stratum.
   - Click No to save the stratum.
5 Click OK to exit the Select Current Stratum dialog box.
Updating the Elevations of Selected Points Based on a Stratum

You can update the elevations of selected points based on a stratum with the Modify Point Elevations ➤ Modify By Selection command on the Grading menu.

To update the elevations of selected points based on a stratum

1. Select the current stratum. For more information, see “Selecting the Current Stratum” in this chapter.
2. From the Grading menu, choose Modify Point Elevations ➤ Modify By Selection to display the Random Point Settings dialog box.

   ![Random Point Settings dialog box]

   **NOTE** If you do not have a current stratum selected, then the command displays the Select Current Stratum dialog box.

3. Do one of the following to specify the type of elevation:
   - Select First Surface to use the elevations of the first surface of the stratum that you defined.
   - Select Second Surface to use the elevations of the second surface of the stratum.
   - Select Difference to use the elevational difference between the two surfaces.
4. Click OK to continue. The Terrain Random Points dialog box is displayed.

   ![Terrain Random Points dialog box]

5. Do one of the following to specify the mode for point selection:
   - Click Update to update the point objects that already exist in the drawing.
   - Click Add New to add new point objects on top of those that already exist in the drawing.
   - Click Cancel to exit the command.
6. Select the points to update, using one of the following methods:
   - Select each point with your pointing device.
   - Type **W**, press ENTER, and then draw a selection window around the points.
   - Type **C**, press ENTER, and then draw a crossing selection around the points.

   The command updates the points with the new elevations.
Updating the Elevations of a Range of Points Based on a Stratum

You can update the elevations of a range of points based on a stratum using the Modify Point Elevations ➤ Modify By Range command.

To update a range of points
1 Select the current stratum. For more information, see “Selecting the Current Stratum” in this chapter.
2 From the Grading menu, choose Modify Point Elevations ➤ Modify By Range to display the Random Point Settings dialog box.

   **NOTE** If you do not have a current stratum selected, then the command displays the Select Current Stratum dialog box.

3 Do one of the following to specify the type of elevation:
   - Select First surface to use the elevations of the first surface of the stratum.
   - Select Second surface to use the elevations of the second surface of the stratum.
   - Select Difference to use the elevational difference between the two surfaces.
4 Click OK to continue.

   The Terrain Random Points dialog box is displayed.
5 Do one of the following to specify the mode for point selection:
   - Click Update to update the point objects that already exist in the drawing.
   - Click Add New to add new point objects on top of those that already exist in the drawing.
   - Click Cancel to exit the command.
6 Update the range of points using one of the following methods:
   - Type point numbers individually, separated by commas.
   - Type point numbers in ranges specified with a hyphen (-).
   - Type a combination, such as 10,12-15,17,20.

   The command updates the elevations.

Reporting the Elevations of Selected Points Based on a Stratum

You can report the elevations of selected points based on a stratum using the Modify Point Elevations ➤ Report By Selection command.

To report the elevations of selected points based on a stratum
1 Select the current stratum. For more information, see “Selecting the Current Stratum” in this chapter.
2 From the Grading menu, choose Modify Point Elevations ➤ Report By Selection to display the Random Point Settings dialog box.
NOTE
If you do not have a current stratum selected, then the command displays the Select Current Stratum dialog box.

3 Do one of the following to specify the elevation type:
   ■ Select First surface to use the elevations of the first surface of the stratum.
   ■ Select Second surface to use the elevations of the second surface of the stratum.
   ■ Select Difference to use the elevational difference between the two surfaces.

4 Click OK to continue.

5 Select the points to report using one of the following methods:
   ■ Select each point with your pointing device.
   ■ Type W, press ENTER, and then draw a selection window around the points.
   ■ Type C, press ENTER, and then draw a crossing selection around the points.

6 Press ENTER to complete the selection set.
The Random Points dialog box is displayed, listing the point numbers, northing and easting coordinates, and the elevation.

7 Report the information using one of the following methods:
   ■ Select Print to File and then specify the file name to which to print the information.
   ■ Select Print, and then specify the printer port to use.

8 Click OK to exit the dialog box.

**Reporting the Elevations of a Range of Points Based on a Stratum**

You can report the elevations of a range of points based on a stratum using the Modify Point Elevations ➤ Report By Range command.

To report the elevations of a range of points based on a stratum

1 Select the current stratum. For more information, see “Selecting the Current Stratum” in this chapter.

2 From the Grading menu, choose Modify Point Elevations ➤ Report By Range to display the Random Point Settings dialog box.

NOTE
If you do not have a current stratum selected, then the command displays the Select Current Stratum dialog box.

3 Do one of the following to specify the type of elevation:
   ■ Select First surface to use the elevations of the first surface of the stratum.
   ■ Select Second surface to use the elevations of the second surface of the stratum.
   ■ Select Difference to use the elevational difference between the two surfaces.

4 Click OK to continue.
The following prompt is displayed:

Point numbers:
5 Report the range of points using one of the following methods:
   ■ Type point numbers individually, separated by commas.
   ■ Type point numbers in ranges specified with a hyphen (-).
   ■ Type a combination, such as 10,12-15,17,20.
6 Press ENTER to complete the selection set.
   The Random Points dialog box is displayed, listing the point numbers, northing
   and easting coordinates, and the elevation.
7 Report the information using one of the following methods:
   ■ Select Print to File, and then specify the file name to which to print the
     information.
   ■ Select Print, and then specify the printer port to use.
8 Click OK to exit the dialog box.

**Reporting the NEZ Point Data Based on a Stratum**

You can create a text file of X, Y coordinates, and then use it to generate a
report that lists the northing, easting, and elevation of the points, based on a
stratum you select.

**To report the NEZ point data based on a stratum**

1 Format a text file in X (space) Y format, and save it with the extension .rpt.
2 Select the current stratum. For more information, see “Selecting the Current
   Stratum” in this chapter.
3 From the Grading menu, choose Modify Point Elevations ➤ Report From File to
display the Random Point Settings dialog box.
   
   **NOTE** If you do not have a current stratum selected, the command displays the
   Select Current Stratum dialog box.

4 Do one of the following to specify the elevation type:
   ■ Select First surface to use the elevations of the first surface of the stratum.
   ■ Select Second surface to use the elevations of the second surface of the stratum.
   ■ Select Difference to use the elevational difference between the two surfaces.
5 Click OK to continue.
   The Read Random Point File dialog box is displayed.
Select the file to read, and then click Open to continue.
The Random Points dialog box displays northing, easting, and elevation
information.

Use the pointing device or arrow keys to scroll through the point information.

Click OK to exit the dialog box.

**Obtaining the Elevations from a Stratum Based on the Specified X,Y Coordinates**

You can format a text file with X, Y coordinates, and then read the elevations
from a stratum to create a file that lists X, Y, Z coordinates.

**To obtain the elevations from a stratum based on the specified X,Y coordinates**

1. Format a text file in X (space) Y format, and save it with the extension .rpt.
2. Select the current stratum.
   For more information, see “Selecting the Current Stratum” in this chapter.
3. From the Grading menu, choose Modify Point Elevations ➤ Random Point File
to display the Random Point Settings dialog box.

   **NOTE** If you do not have a current stratum selected, then the command displays
   the Select Current Stratum dialog box.

4. Do one of the following to specify the elevation type:
   - Select First surface to use the elevations of the first surface of the stratum.
   - Select Second surface to use the elevations of the second surface of the
     stratum.
   - Select Difference to use the elevational difference between the two surfaces.
5. Click OK to continue. The command displays the Read Random Point File
dialog box.
6. Select the file to read, and click Open to continue.
   The command calculates the elevations based on the X,Y coordinates in the
   point file, and then displays the Write Random Point File dialog box.
Specify a new name for the file, with an extension of .rpt, and click OK to save it.

Slope Grading

Using the slope grading tools, you can create grading objects. You begin by selecting a footprint, and then you select the target you want to grade to. A footprint can be a 2D or 3D polyline, a line, an arc, or an existing grading object. The target can be a surface, an elevation, or a distance. By using slope tags, you can create slopes that smoothly transition from one grade to another. By using target regions you can grade to multiple targets, such as a surface, an elevation, or a distance.

There are two methods of creating grading objects. You can use the Grading Wizard, which steps you through every setting you must establish, and then creates the grading object. Or, you can use a two-step process of changing the settings, and then use the Apply Grading command. When you create a grading object, it is saved in the drawing.

The grading object is specifically designed to provide a faster, more efficient 3D modeling tool to accurately represent such design elements as roadways, embankments, parking areas, excavations, or ponds. Because the resulting object is a 3D representation of a design, some portions of a 3D grading object may not be appropriate for use in precise 2D geometric layout. Specifically, arcs, which can be used to create the grading object footprint, are broken into a series of 3D straight-line chord segments. However, the endpoints of these segments coincide with the underlying true arc geometry, which is stored within the object itself.

After you create a grading object, you can change its properties, such as the target, the target regions, the slope tags, and so on. In addition, you can use the grading object grips to reposition the footprint, the target region boundaries, and the slope values. Grip editing automatically updates the grading object if it is not locked. If you do not want the grading object to be edited after you create it (for example, you don’t want it to automatically update if you edit a surface), then you can lock the grading object.

NOTE  The commands in the Slope Grading menu in the first release of Civil Design are now located in the Daylighting menu. The Slope Grading menu now contains the grading object commands.

Creating and Stationing the Grading Footprint

To create a grading object, you must first create a footprint. The footprint represents the outline of the object you want to grade from. The footprint does not require an elevation. You can draw a 2D or 3D polyline to use as the footprint, or you can use a line, arc, polyline, or other objects to create the footprint. Footprint vertices have X, Y, and Z values that originate from the object you select to create the footprint. If you select a 2D object for the footprint, then you can assign elevations to the footprint vertices by using the Grading Properties or the Grading Wizard command.
Chapter 1  Using the Grading Commands

You can select only one line, arc, polyline, or existing grading object at a time to create a new grading object. The footprint cannot be constructed of multiple AutoCAD objects.

After you create the footprint, it is recommended that you station the footprint. The grading commands use stations to represent the location of footprint vertices. By creating stations on the footprint, you can graphically see where to place target regions and slope tags.

To station a footprint, define the footprint geometry (the entities you will use to create the grading object) as an alignment, and then on the Alignments menu, choose Station Labels ➤ Create Stations.

Creating Grading Objects

There are two methods you can use to create grading objects:

- Using the Grading Wizard: on the Grading menu, choose Slope Grading ➤ Grading Wizard. You are prompted to select an existing polyline, line, arc, or grading object. Use the Grading Wizard to customize the grading properties as you create a grading object.
- Using the grading settings: on the Grading menu, choose Slope Grading ➤ Apply Grading and select an existing object (such as a footprint drawn as a polyline). Use this method to build a grading object after you establish the initial grading settings.

You can not use circles to create grading objects. However, you can construct an arc or a polyline to reasonably approximate a full circle that you can use as a grading object.

Creating a Grading Object Using the Grading Wizard

The Grading Wizard is the easiest way to create a grading object. You are prompted for all of the required settings and at the end of the Grading Wizard, the command creates the grading object in the drawing. You do not need to establish settings before using the wizard.

To create a grading object using the Grading Wizard

1 From the Grading menu, choose Slope Grading ➤ Grading Wizard.
   The following prompt is displayed:
   Select a polyline, line, arc, or grading object:

2 Select the polyline, line, arc, or existing grading object you would like to grade from. The following prompt is displayed:
   Pick side:

3 Click in the drawing to specify the side of the object you want to grade to.
   The Footprint sheet of the Grading Wizard is displayed.
4 The Grading Wizard steps you through the process of specifying the settings for the selected object. The sheets of the Grading Wizard mirror the Settings and Grading Properties dialog boxes.

On the left side of each sheet in the Grading Wizard there are tips that give you instructions on what settings to enter for the current sheet. Click the Next button to move to the next sheet. Click the Back button to go back to the previous sheet.

For more information about each of these settings, see “Grading Settings” in this chapter.

5 Click Finish when you have completed the Grading Wizard. The following prompt is displayed:

Delete old entity (Yes/No)? <No>: 

6 Type one of the following options:
- Yes to delete the old entity.
- No to keep the old entity.

The object is then graded using the settings you specified in the Grading Wizard.

**Creating a Grading Object Using the Apply Grading Command**

To create a grading object from a polyline, line, arc, or existing grading object you can use the Apply Grading command. The Apply Grading command applies the current grading settings to a selected polyline, line, arc, or grading object and creates the grading object in the drawing.

**To create a grading object using the grading settings**

1 From the Grading menu, choose Slope Grading ➤ Settings. You can enter the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Available Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Footprint</td>
<td>Elevation Step and Coordinate display format</td>
</tr>
<tr>
<td>Targets</td>
<td>Grading Target and Minimum Region Length</td>
</tr>
<tr>
<td>Slopes</td>
<td>Cut Slope and Fill Slope</td>
</tr>
<tr>
<td>Corners</td>
<td>Convex (Outside) Corner Treatment</td>
</tr>
<tr>
<td>Accuracy</td>
<td>Accuracy of Projection Lines</td>
</tr>
<tr>
<td>Appearance</td>
<td>Colors and Linetypes of the grading object components and Grips Display</td>
</tr>
</tbody>
</table>

2 From the Grading menu, choose Slope Grading ➤ Apply Grading. The following prompt is displayed:

Select a polyline, line, arc, or grading object:
3 Select the polyline, line, arc, or existing grading object you would like to grade from. The following prompt is displayed:

```
Delete old entity (Yes/No)? <No>:
```

4 Type one of the following options:
   - Yes to delete the old entity.
   - No to keep the old entity.

The object is graded with the settings you entered. You can customize the properties of the object, if necessary, using the Grading Properties command. The Grading Properties command displays the same tabs as the Settings command. After you enter the original grading settings and use the Apply Grading command the Footprint tab displays coordinate data for the grading object.

**Weeding 3D Polyline Vertices**

In order to optimize the grading object performance and corner cleanup, you can use the Weed 3D Polyline Vertices command to remove extra vertices that were added to 3D polylines with the Daylighting commands.

If you created a 3D polyline using the Daylighting commands, then you may have added vertices to calculate additional daylight lines. If so, then you should weed the added vertices if you want to use this 3D polyline to create a grading object footprint.

Using the Weed 3D Polyline Vertices command you enter three criteria to determine if a vertex should be removed from the 3D polyline. For each of these criteria, the command looks at three consecutive vertices. If the three criteria for the three consecutive vertices are met, the middle vertex is removed, and the command continues to analyze and remove vertices until the end of the 3D polyline is reached. These criteria are as follows:

- **Maximum Horizontal distance:** the XY distance from the first and third vertices must be less than the Maximum (XY) distance
- **Maximum Horizontal deflection angle:** the XY deflection angle between the two segments formed by the three vertices must be less than Maximum (XY) deflection angle
- **Maximum Grade Change (percent):** the vertical grade change between the two segments formed by the three vertices must be less than the Maximum Z percent grade change

**To weed 3D polyline vertices**

1 From the Grading menu, choose Slope Grading ➤ Weed 3D Polyline Vertices.
2 Select the 3D polyline entities you want to weed. The Weed 3D Polyline Vertices dialog box is displayed with the number of valid 3D polyline entities selected. You must select at least one valid 3D polyline entity to use this command.
3 To selectively remove vertices on a 3D polyline, enter the following criteria under Weeding Factors:
- Maximum Horizontal distance
- Maximum Horizontal deflection angle
- Maximum Grade Change (percent)

4 Select or clear the Include Grade Change in Weeding factors check box.
5 Select or clear the Erase Existing 3D Polylines check box.

The program applies the weeding factors on the set of 3D polylines selected and highlights the removed vertices with a temporary red + or x. The original entities are erased. The command line displays the total number of original vertices, the total number of vertices removed, and the number of new vertices.

Grading Settings

Grading objects are created using the settings you specify for the footprint, targets, slopes, corners, accuracy, and appearance. There are three different methods of establishing these settings. The method you choose to access the settings depends on whether you are creating a new grading object or editing an existing grading object.

- If you are creating a new grading object, then you can use the Grading Wizard or the Apply Grading command. Before you use the Apply Grading command, use the Settings command to set up the initial settings.
- If you are editing a grading object, then you can use the Grading Properties command to change the settings.

The grading settings, grading properties, and the Grading Wizard all contain the same settings. However, some areas of the grading settings dialog box display information only after you have created a grading object.

In this manual, each group of settings is described in its own topic. Because you can access these settings from multiple commands, the first step in each topic describes how to access these three commands. In addition, some methods require less steps than others, and the manual indicates which steps to skip in these instances.
Configuring the Grading Footprint Settings

One of the first things you establish for a grading object is the grading footprint settings. The footprint defines the location of the grading object in the drawing. The footprint settings control the grading object name and description, as well as the grading direction, vertex elevations, and coordinate display format. You can also edit the footprint by adding and deleting vertices.

To configure the grading footprint settings

1. Access the grading footprint settings.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Wizard. You are prompted at the command line to select an existing polyline, line, arc, or grading object to start the Grading Wizard. You can also access these settings from the Grading menu, by clicking Slope Grading ➤ Settings. Select the Footprint tab.</td>
</tr>
<tr>
<td>edit an existing grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Properties. You can also select an object in your drawing and right-click to display the shortcut menu, and select Grading Properties. Select the Footprint tab.</td>
</tr>
</tbody>
</table>
2 In the Grading Scheme Name box, type the name for the grading scheme.

3 In the Description box, type a description for the grading scheme.

4 Select the Direction to Grade from Footprint using one of the following options.
   - If the footprint you are grading is closed, select Inside or Outside.
   - If the footprint you are grading is open, select Right or Left.

   **NOTE** Right and left are determined by station progression. The start point of the object you drew is considered the start station. If you stand at the start station and look toward the next station, the right direction corresponds to your right and the left direction corresponds to your left.

In the Footprint Coordinates section of the dialog box, you have two options for editing the elevation values of the footprint. You can adjust the footprint elevation globally by changing the value in the Base Elevation box, or you can adjust the footprint elevations one vertex at a time by changing the elevation values in the spreadsheet section of the dialog box.

The spreadsheet section of the dialog box lists the stations, X and Y coordinates, elevation, and grade of all of the footprint vertices. You can graphically edit the footprint vertices using the vertex grips.

   **NOTE** You can only see vertices and their related information when you are using the Grading Wizard or if you are changing the properties of an existing grading object. You cannot see this information when you are using the grading settings.

5 Change the elevation.

   **If you want to change...** | **Then...**
---|---
the elevation globally | type a new value in the Base Elevation box, or click the up or down arrow.
the footprint elevation one vertex at a time | click in a cell in the elevation column of the spreadsheet and type a new elevation.

   **TIP** To change the amount the Base Elevation is increased or decreased when you click the up or down arrows, change the value in the Elevation Step box. The value in the Elevation Step box is also used when you select the object in the drawing and press Ctrl+ or Ctrl- on the keyboard to change the elevation.

In the Footprint Coordinates section of the dialog box, you have options for editing the footprint. You can use the buttons to add a vertex, delete a vertex, or reset the elevations. The spreadsheet section of the dialog box lists the stations, X and Y (northing-easting) coordinates, elevation, and grade of all of the footprint vertices.

6 To add a vertex, select a vertex in the spreadsheet section of the dialog box and click the Add Vertex button. The Add Vertex dialog box displays and by default
displays the station value of the new vertex at the midpoint between the previous and the next vertices.

Click OK to accept this value or enter a new station value in the Station box (you can also click the up and down arrows to choose the new station value). The elevation of the new vertex is the same as the footprint elevation where the new vertex is added. If you insert a vertex on an arc, the vertex is inserted at the mid point, and two new arcs are created.

7 To delete a vertex, select a vertex in the spreadsheet section of the dialog box and click the Delete Vertex button. You can not delete the first vertex or the last vertex.

8 Click the Assign Elevations button to display the Assign Elevations dialog box. You can select one of the following methods to assign elevations:

- Set Elevations from a Selected Surface: you can specify the surface from the Surface list and assign elevations to all vertices from that specified surface. If you select Actual Elevations then all footprint elevations are raised or lowered to match the surface grade. If you select Average Elevation the elevation of each vertex on the surface is calculated and averaged. This elevation is then applied to the footprint.

- Reset to Constant Elevation: you can enter the elevation and apply it to all vertices.

9 To determine how the coordinates are displayed in the grading settings, select a Coordinate Display Format:

- X-Y
- Northing – Easting
You can configure other grading settings or exit the command.

<table>
<thead>
<tr>
<th>If you want to ...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>configure other grading settings</td>
<td>use the Next or Back button to continue to another sheet in the Grading Wizard. In the grading properties, you can select another tab at the top of the dialog box to continue.</td>
</tr>
<tr>
<td>do not want to configure other grading settings</td>
<td>click finish to close the Grading Wizard or click OK to close the grading properties dialog box.</td>
</tr>
</tbody>
</table>

**Configuring the Grading Targets Settings**

The target settings control what the projection lines from the footprint will intercept. A slope target can be an existing surface (one surface per grading object), an elevation, or an offset distance. When you create a grading object, one target region encompasses the entire footprint. The start station of this target region is at the beginning of the footprint and the end station is at the end of the footprint.

You can add multiple targets and multiple target regions to a grading object, but for each target region there is only one target. Target regions are absolute, meaning that there is no transition from one target to the next.

**NOTE** To create a grading object that grades to a terrain model surface, you must have an existing terrain model surface. You can only grade to one surface per grading object. If there are no surfaces in the current project, then you are prompted to select a target elevation or a target distance when entering the initial grading settings or using the Grading Wizard.

After you have created a grading object you can add target regions. You can change the location of target regions in the spreadsheet section of the Targets tab or you can graphically edit the target regions by dragging the target region grips.

**NOTE** Target regions are independent of slope tags. When you add a region, the new region has a slope that is interpolated from the previous slope tag and the next slope tag. Slope tags can co-exist with target region boundaries, but remain independent.
To configure the grading targets settings

1. Access the grading targets settings.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Wizard. You are prompted at the command line to select an existing polyline, line, arc, or grading object to start the Grading Wizard. You can also access these settings from the Grading menu, by clicking Slope Grading ➤ Settings. Select the Targets tab.</td>
</tr>
<tr>
<td>edit an existing grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Properties. You can also select an object in your drawing and right-click to display the shortcut menu, and select Grading Properties. Select the Targets tab.</td>
</tr>
</tbody>
</table>

The following illustration shows the Targets tab in the Grading Properties dialog box.
2 Under Grading Target, select one of the following as the grading target:

- **Surface**: To grade to a surface, select this option, and then select an existing surface from the Surface list. The grading object’s projection lines are extended until they intersect with the surface. If the footprint is below the surface target you are grading to, then the projection lines go up at the cut slope value you specify in the slopes settings. If the footprint is above the surface target you are grading to, then the projection lines go down at the fill slope value you specify in the slopes settings. You can only select one target surface per grading object.

| NOTE | When you grade to a surface target you will get differing results depending on whether the grading object is contained entirely on the surface or if the grading object is partially off the surface. If the projection lines from the grading object, either originating from a footprint segment or a corner, extend beyond the edge of a surface, then no projection lines are created along the entire segment. target you will get differing results depending on whether the grading object is contained entirely on the surface or if the grading object is partially off the surface. If the projection lines from the grading object, either originating from a footprint segment or a corner, extend beyond the edge of a surface, then no projection lines are created along the entire segment. |

The following illustration shows a surface as a grading target.

![A surface as a grading target](image)

- **Elevation**: To grade to an elevation, select this option, and then enter an elevation to which the grading object’s projection lines are extended. If the footprint is below the elevation target you are grading to, then the projection lines go up at the cut slope value you specify in the slopes settings. If the footprint is above the elevation target you are grading to, then the projection lines go down at the fill slope value you specify in the slopes settings. Select Absolute if you want all of the vertices on the daylight line to be created at the same elevation. Selecting Absolute makes the projection line stop at an elevation relative to the elevation zero. Select Relative if you want all of the vertices on the daylight line to be created the same vertical distance from any location on the grading object. Selecting Relative makes the elevation relative to the footprint at any point where a projection line is calculated.
The following illustration shows an absolute elevation as a grading target.

An absolute elevation as a grading target

The following illustration shows a relative depth as a grading target.

A relative depth as a grading object

- **Distance**: To grade out to a specified distance, select this option, and then enter the horizontal distance that the slopes project to. This forces all vertices on the daylight line to be located at this horizontal distance from the footprint, using the defined slope at any point within that target region. Select Cut if you want the footprint to match up toward the target distance (the footprint is at a lower elevation than the target). Select Fill if you want the footprint to match down toward the target distance (the footprint is at a higher elevation than the target).

The following illustration shows a distance as a grading target.

A distance as a grading target

**NOTE** You can specify the slopes that are used in cut and fill situations in the slope settings.

3 Under Local Overrides of Grading Target (Regions), you can edit target regions and add and delete target regions. Target regions define the area of the footprint.
that daylights to the specified target. For example, part of a footprint (target region 1) could grade to a surface. The other part of the footprint (target region 2) could grade to an elevation.

The following illustration shows slope grading target regions.

Each region has a start station, an end station, and a target. These are shown in the spreadsheet section of the dialog box. By default, a grading object begins with only one region.

<table>
<thead>
<tr>
<th>If you want to …</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a target region</td>
<td>select an existing region by clicking on its row in the spreadsheet section, and then clicking Add Region. The selected region splits into two regions of equal length with the same properties.</td>
</tr>
<tr>
<td>edit the start station or end station of a region</td>
<td>click the cell in the spreadsheet and type a new value.</td>
</tr>
<tr>
<td>change the target for a region</td>
<td>click in the Target column of the region. The Edit Targets dialog box is displayed. For more information, see “Editing Individual Grading Targets” in this chapter.</td>
</tr>
<tr>
<td>delete a region</td>
<td>select a region from the spreadsheet section and click Delete Region.</td>
</tr>
<tr>
<td>reset the grading target values to the default specified under Grading Target</td>
<td>click Reset Regions. For example, if you specified the existing ground surface as the grading target in the Grading Target section of the dialog box, then when you click Reset Regions, all of the regions will use the existing ground surface as the grading target.</td>
</tr>
</tbody>
</table>
Target regions are independent of slope tags. When a target region is inserted, the slope for the region is determined by interpolating the slope for the previous slope tag and the next slope tag.

4 Type the minimum length of a target region in the Minimum Region Length box. This value determines the minimum length of a target region, and how close the target region grips and the slope tag grips can be placed from one another. The distance is in drawing units.

5 You can configure other grading settings or exit the command.

<table>
<thead>
<tr>
<th>If you want to …</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>configure other grading settings</td>
<td>use the Next or Back button to continue to another sheet in the Grading Wizard. In the grading properties, you can select another tab at the top of the dialog box to continue.</td>
</tr>
<tr>
<td>exit the command</td>
<td>click finish to close the Grading Wizard or click OK to close the grading properties dialog box.</td>
</tr>
</tbody>
</table>

**Editing Individual Grading Targets**

You can use the Edit Targets dialog box to change the target for a region and to adjust the target region by changing the station values. When you click in the Target column in the spreadsheet section of the target settings, the Edit Targets dialog box is displayed.

**To edit individual targets in the Edit Targets dialog box**

1 Access the Edit target dialog box by clicking in the Target column of the spreadsheet section in the Targets tab.

2 The target region number is listed in the dialog box, as are the target region’s start station and end station. Verify that the correct target region is selected.

   **NOTE** You can move between regions by clicking the following buttons in the dialog box:

   - `<` Selects the first region
   - `<` Moves back one region
   - `>` Moves forward one region
   - `>` Selects the last region

3 Select a grading target for the region from the following options:

   - **Surface**: To grade to a surface, select this option. The grading object’s projection lines are extended until they intersect with the surface TIN.
   - **Elevation**: To grade to an elevation, select this option, and then enter an elevation to which the grading object’s projection lines are extended. Select Absolute if you want all of the vertices on the daylight line to be created at
the same elevation. Select Relative if you want all of the vertices on the daylight line to be created the same vertical distance from the grading object.

- **Distance**: To grade out to a specified distance, select this option, and then enter the horizontal distance that the slopes project to. This forces all vertices on the daylight line to be located at this horizontal distance from the footprint. Select Cut if you want the footprint to match up toward the target distance (the footprint is at a lower elevation than the target). Select Fill if you want the footprint to match down toward the target distance (the footprint is at a higher elevation than the target).

**NOTE** You cannot combine a distance target with a vertical slope.

4 To change the length or position of the target regions, you can enter new starting and ending stations in the Start Station and End Station boxes at the top-left and top-right of the dialog box.

**NOTE** You cannot edit the Start Station of the first region or the End Station of the last region.

5 Click OK to return to the grading target settings or click Apply and use the arrows to select another target to edit.

## Configuring the Grading Slopes Settings

To define the cut and fill slopes for the grading object, change the grading slopes settings. A grading object can have several different slopes defined for it. Each slope is controlled by its own slope tag. Each slope tag has station, elevation, and cut and fill slope values defined for it. A slope tag controls the slope between the slope tag’s station and the station of the next slope tag (based on station progression). You can choose to represent the slope as a standard ratio, a % grade, horizontal (no slope), or vertical (a wall).

By default, a slope tag is inserted at the start point and end point of the footprint. After you create a grading object, you can add slope tags. You can change the location and value of the slope tags in the spreadsheet section of the Slopes tab or you can graphically edit the slope tags using the slope tag and slope value grips.

Slope tags affect the slope of the projection lines between tags by transitioning. When transitioning from one slope tag to the next, the change in the slope always remains linear to the footprint.
The following illustration shows slopes that transition from 2:1 to 1:1 based on slope tag value.

Transitioning between different slope values

Slopes around corners are created at a constant slope as shown in the following illustration.

Slope value transition around a corner

NOTE You cannot edit the start station of the first slope tag or the end station of the last slope tag. The first and last slope tags will always have the same cut/fill values.
## Configuring the Grading Slopes Settings

1. Access the grading slopes settings.

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Wizard. You are prompted at the command line to select an existing polyline, line, arc, or grading object to start the Grading Wizard. You can also access these settings on the Grading menu, by clicking Slope Grading ➤ Settings. Select the Slopes tab.</td>
</tr>
<tr>
<td>edit an existing grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Properties. You can also select an object in your drawing and right-click to display the shortcut menu, and select Grading Properties. Select the Slopes tab.</td>
</tr>
</tbody>
</table>

The following illustration shows the Slopes tag in the Grading Properties dialog box.

![Grading Properties dialog box](image)

2. Under Cut Slope and Fill Slope, define the initial settings for slopes. You define the cut and fill slopes by specifying slope or grade values.
   - **Slope:** Select the Slope option to specify the slope value as a standard ratio. When you select this option, enter a slope value in the Slope box. For example, enter 1 for a 1:1 slope, 2 for a 2:1 slope, and so on.
   - **% Grade:** Select the % Grade option to specify the slope value as a percent grade. When you select this option, enter a percent grade in the Grade box. For example, for a 3% grade, enter 3.
   - **Horizontal:** Select the Horizontal option to use a 0% grade. A horizontal slope is expressed as an infinite slope.
NOTE Use the Horizontal option instead of selecting % Grade and typing 0.

Vertical: Select the Vertical option to use a zero slope. This option draws a wall at the edge of the object you are grading. A vertical slope is expressed as an infinite grade.

NOTE Use the Vertical option instead of selecting Slope and typing 0. When using vertical slopes, projection line endpoints must be at least 0.0001 horizontal drawing units apart. If TIN points are closer than this distance, one of the points is discarded when you build a surface.

3 Under Local Overrides of Cut and Fill Slope (Tags), you can edit slope tag values and add and delete slope tags. Each slope tag is defined by station, elevation, cut slope/grade, and fill slope/grade. You can edit the station, the cut slope, and the fill slope for each tag.

<table>
<thead>
<tr>
<th>If you want to ...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a slope tag</td>
<td>select an existing tag and click Add Tag. The new tag will be placed mid-point between the selected tag and the one ahead of it.</td>
</tr>
<tr>
<td>edit the station of a slope tag</td>
<td>click in the tag’s Station cell and type a new value.</td>
</tr>
<tr>
<td>edit the cut and fill slope/grade of a slope tag</td>
<td>click in the tag’s Cut Slope/Fill Slope or Cut Grade/Fill Grade cell and type a new value. To enter a vertical slope, type V in these cells. To enter a horizontal slope, type H in these cells.</td>
</tr>
<tr>
<td>delete a slope tag</td>
<td>select the tag from the list and click Delete Tag.</td>
</tr>
<tr>
<td>reset the cut and fill slopes/grades for all of the slope tags to the values you specified at the top of the dialog box in step 2</td>
<td>click Reset Tags.</td>
</tr>
</tbody>
</table>

NOTE The last two columns in the spreadsheet section of the dialog box are named Cut Slope and Fill Slope if you selected the Slope option in step 2. The columns are named Cut Grade and Fill Grade if you selected the % Grade option in step 2.

4 You can configure other grading settings or exit the command.

<table>
<thead>
<tr>
<th>If you want to ...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>configure other grading settings</td>
<td>use the Next or Back button to continue to another sheet in the Grading Wizard.</td>
</tr>
<tr>
<td></td>
<td>In the grading properties, you can select another tab at the top of the dialog box to continue.</td>
</tr>
<tr>
<td>exit the command</td>
<td>click finish to close the Grading Wizard or click OK to close the grading properties dialog box.</td>
</tr>
</tbody>
</table>
Configuring the Grading Corners Settings

To control how the slopes are projected from the footprint when there is a convex (outside) angle in the footprint, change the grading corners settings. In Convex (Outside) Corner Treatment section, you can choose from miter, radial, chamfer, and no cleanup corners settings to specify the global corner treatment setting. This setting is initially applied to all corners on the footprint. In the Local Overrides on Convex (Outside) Corner Treatment section, you can specify the corner treatment setting on a corner-by-corner basis.

**NOTE**
The miter cleanup method is automatically applied to any concave corners on the footprint. Corner cleanup is not applied when a slope tag or target region boundary lies within the corner cleanup area. You must move the target region or slope tag out of the corner cleanup area.

**NOTE**
Corner treatments do not apply to convex or concave arcs along the footprint. You can establish the increments of the radial projection lines of concave and convex arcs in the accuracy settings.

The following illustration shows the corner treatments.

![Corner treatments](image)

To configure the corners settings

1. Access the grading corners settings.

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Wizard. You are prompted at the command line to select an existing polyline, line, arc, or grading object to start the Grading Wizard. You can also access these settings on the Grading menu, by clicking Slope Grading ➤ Settings. Select the Corners tab.</td>
</tr>
<tr>
<td>edit an existing grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Properties. You can also select an object in your drawing and right-click to display the shortcut menu, and select Grading Properties. Select the Corners tab.</td>
</tr>
</tbody>
</table>
The following illustration shows the Corners tab in the Grading Properties dialog box.

- Under Convex (Outside) Corner Treatment, select a corner treatment. For each selection, a corresponding graphic illustrates the selected corner treatment.
  - **Miter Projection**: Miter a convex corner of the grading object by creating a slope projection line at that corner, which bisects the bend angle at that corner. The slope projection line stops at the grading target (daylight). Additional slope projection lines are created that originate from this first slope projection line. The spacing of these additional slope projection lines is based on the Increment Along Straight Line Segments setting in the accuracy settings.
  - **Radial Projection**: Rounds the corner of a grading object by projecting slope lines radially to a target. The spacing of these lines along the daylight line is controlled by the Increment Along Arc Segments setting in the accuracy settings. The number of slope projection lines is based on the average distance between slope projection lines at the daylight line. The average distance is determined by fitting an arc at the beginning and end of the radial slope projection limits, and dividing this arc by the increment setting.
  - **Chamfer**: Chamfers the corners of a grading object by creating two slope projection lines at the corner. The first slope projection line is perpendicular to the segment before the corner, and the second is perpendicular to the segment after the corner. Additional slope projection lines are created from these two slope projection lines. These additional slope projection lines are parallel to the line that bisects the angle formed by the convex corner. The spacing of these additional slope projection lines is based on the Increment Along Straight Line Segments in the accuracy settings.
  - **No Cleanup**: Leaves the corners of a grading object as-is.
NOTE
The number and spacing of the projection lines in the corner treatments depends on the grading accuracy settings. The slope of the projection lines within the corner treatment is the slope calculated at that vertex on the footprint.

3 Under Local Overrides on Convex Corners, you can specify corner treatments on a corner-by-corner basis:

- To change a corner treatment for a vertex, click in the Corner Treatment column of the spreadsheet, the Edit Corners dialog box is displayed. For more information, see “Editing Individual Corner Treatments” in this chapter.
- To change the elevation for a vertex, click in the Elevation column of the spreadsheet and type a new elevation.

NOTE These settings are only available when editing existing grading objects.

NOTE You can click the Reset All button to change the corner treatments for all vertices back to the values set in the Convex (Outside) Corner Treatment section of the dialog box.

4 You can configure other grading settings or exit the command.

<table>
<thead>
<tr>
<th>If you want to …</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>configure other grading settings</td>
<td>use the Next or Back button to continue to another sheet in the Grading Wizard. In the grading properties, you can select another tab at the top of the dialog box to continue.</td>
</tr>
<tr>
<td>exit the command</td>
<td>click finish to close the Grading Wizard or click OK to close the grading properties dialog box.</td>
</tr>
</tbody>
</table>

The following illustration shows a miter corner treatment.

A miter corner treatment
The following illustration shows a radial corner treatment.

![Radial Corner](image)

A radial corner treatment

The following illustration shows a chamfer corner treatment.

![Chamfer Corner](image)

Chamfer corner treatment

**Usage Tips for Mitered Corner Treatments**

**Mitered Corners When a Surface Is the Target**
For mitered convex corners grading to a surface, two miter conditions can exist. If, after calculating the plane to plane intersection for the two sides involved in the miter, the computed catch point along the miter can not be directly projected back to one of the two segments, then the plane-plane miter line is computed.

If the catch point can be projected onto one of the two segments, then the angle bisecting the two segments is used to define the miter lines. The slope of this miter line is such that any lines projecting from the footprint to the miter will be at the specified slope.
**Mitered Convex Corners when Grading Horizontally**
For mitered convex corners grading horizontally, the corner will be horizontal, even when the footprint elevations are not the same. When a miter corner grades horizontally in a situation where the segments in and out of the corner are not at the same grade, a flat corner is produced.

**Concave Interior Miter Cleanup**
Concave interior miter cleanup between a line and a non-tangent arc, or two non-tangent arcs, may not always clean up as expected. In some situations a small jump may occur at the end of the miter line. To accommodate this situation you can adjust the footprint design or explode the object, and then manually clean up the area.

**Interior Corner Cleanup Where Slope Tags and Target Regions Are Located**
If a slope tag or a target region is placed within a concave miter interior corner, the corner will not cleanup properly. To correct this you must move the slope tag or target region out of the corner cleanup area.

**Editing Individual Corner Treatments**
You can use the Edit Corners dialog box to change the corner treatment for the grading object on a corner-by-corner basis. When you click in the Corner Treatment column in the spreadsheet section of the corner settings, the Edit Corners dialog box is displayed.

**NOTE**
The miter corner cleanup method is automatically applied to any concave corners on the footprint. This is not editable.

**NOTE**
Corner cleanup is not applied when a slope tag or target region boundary lies within the corner cleanup. You must move the target region or slope tag out of the corner cleanup area.

**To edit individual corner treatments**
1. Click in the Corner Treatment column in the Corners tab to display the Edit Corner dialog box.
2 Verify the correct corner is selected. The current corner vertex number and its X, Y coordinates and the corner elevation are displayed in the dialog box.

<table>
<thead>
<tr>
<th>TIP</th>
<th>You can move between corners by clicking the following buttons in the dialog box:</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Selects the first corner</td>
</tr>
<tr>
<td>&lt;</td>
<td>Moves back one corner</td>
</tr>
<tr>
<td>&gt;</td>
<td>Moves forward one corner</td>
</tr>
<tr>
<td>&gt;</td>
<td>Selects the last corner</td>
</tr>
</tbody>
</table>

3 Select a corner treatment for the corner:
- Convex Miter Projection
- Convex Radial Projection
- Convex Chamfer
- Convex, No Cleanup - Leaves the edges of your grading object as-is.

4 You can enter a new elevation for the corner in the Elevation box and/or select a new corner treatment.

5 Click OK.

**Configuring the Grading Accuracy Settings**

The location and number of projection lines along the footprint determine the accuracy of the daylight line and the volume calculations. With straight-line segments and concave arcs, the increment distance is the distance between the projection lines on the footprint. With radial corner treatments and convex arcs, the increment distance is applied as an average distance between projection lines at the daylight line. The smaller the increment number, the closer together the projection lines are, giving you increased accuracy of the daylight line and volume calculations.
The following illustration shows the increment distance for straight line segments, concave arcs, and convex arcs.

To configure the grading accuracy settings

1 Access the grading accuracy settings.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Wizard. You are prompted at the command line to select an existing polyline, line, arc, or grading object to start the Grading Wizard. You can also access these settings on the Grading menu, by clicking Slope Grading ➤ Settings. Select the Accuracy tab.</td>
</tr>
<tr>
<td>edit an existing grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Properties. You can also select an object in your drawing and right-click to display the shortcut menu, and select Grading Properties. Select the Accuracy tab.</td>
</tr>
</tbody>
</table>
2 Under Accuracy of Projection Lines, select one of the following methods:

- **Use Fixed Incremental Spacing**: This method places slope projection lines at a fixed spacing. When you choose this method, you must enter an increment at which to draw the projections along straight lines and arc segments (see step 3).

The following illustration shows fixed incremental spacing.

- **Use Automatic Spacing with Increment**: This method places slope projection lines using both the Automatic Spacing option and an increment. For example, when the grading target is a surface, this option creates projection lines everywhere the slope intersects with a TIN line as well as at the vertices of the footprint. This option also creates projection lines using the straight-line and arc increment settings (see step 3).
The following illustration shows automatic spacing with increment.

Automatic spacing with increment

**NOTE** Automatic Spacing will not be applied in the following situations:
- on an arc with different endpoint elevations
- in a slope transition on an arc

In both of these situations, the projection increment defaults to the value you enter in the Increment Along Arc Segments box.

3 Enter the following increment values:
- In the Increment Along Straight-Line Segments box, enter the value in drawing units for the increment you want to use for straight-line segments, and miter and chamfer corners.
- In the Increment Along Arc Segments box, enter the value in drawing units for the increment you want to use for curved segments and radial projections on radial corner treatments.

**NOTE** The increment distance for convex arcs and radial corners is the distance along the daylight line between slope projection lines. The increment distance for concave arcs is the distance between projection lines along the footprint.

4 You can configure other grading settings or exit the command.

<table>
<thead>
<tr>
<th>If you want to ...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>configure other grading settings</td>
<td>use the Next or Back button to continue to another sheet in the Grading Wizard. In the grading properties, you can select another tab at the top of the dialog box to continue.</td>
</tr>
<tr>
<td>exit the command</td>
<td>click finish to close the Grading Wizard or click OK to close the grading properties dialog box.</td>
</tr>
</tbody>
</table>
The following illustration shows corner projection accuracy.

**Configuring the Grading Appearance Settings**

To control the layer, linetypes, colors, and visibility of a grading object, change the grading appearance settings.

**To configure the grading appearance settings**

1. Access the grading appearance settings.

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Wizard. You are prompted at the command line to select an existing polyline, line, arc, or grading object to start the Grading Wizard. You can also access these settings on the Grading menu, by clicking Slope Grading ➤ Settings. Select the Appearance tab.</td>
</tr>
<tr>
<td>edit an existing grading object</td>
<td>from the Grading menu, choose Slope Grading ➤ Grading Properties. You can also select an object in your drawing and right-click to display the shortcut menu, and select Grading Properties. Select the Appearance tab.</td>
</tr>
</tbody>
</table>
NOTE Some of these settings are only available when you edit an existing grading object. If you are editing an existing grading object, then the Grading Scheme Name displays at the top of the dialog box.

2 All of the grading object elements are placed on the same layer. In the Layer list, select a layer for the grading object.

NOTE Click the Details button to display a list of layers in the current drawing and their properties. You can select the layer that you want to use from this dialog box.

3 Under Colors and Linetypes, select the check boxes next to the components you want to be visible in the drawing. The footprint must always be visible.

4 In the Color column, specify colors by doing one of the following:
   - Click on a color tile. The Select Color dialog box is displayed. Select a color for the component and click OK.
   - Type a color number in the right-hand box in the column.

5 In the Linetype column, specify linetypes by doing one of the following:
   - Click in a box to display the Select Linetype dialog box. Select a linetype for the component and click OK.
   - Type a linetype name in the right-hand box in the column.

6 Under Grip Display, select which grading object grips you want to be visible.
   - **Footprint Vertices**: controls the visibility of the grips you use to move the location of a footprint vertex.
   - **Target Region Boundaries**: controls the visibility of the grips you use to move a target region boundary and keep it relative to the footprint.
■ **Slope Tag Locations**: controls the visibility of the grips you use to relocate a slope tag relative to the footprint. Slope tags are placed midway between the footprint and the daylight line.

■ **Slope Values**: controls the visibility of the grips you use to change the slope value for the tag. The slope value grips appear on the daylight line.

**NOTE**  Grips are displayed for the grading object only if the object is unlocked.

**NOTE**  Changes that you make using grip edits are reflected in the Grading Properties dialog box.

The following illustration shows the grading object grips.

You can configure other grading settings or exit the command.

<table>
<thead>
<tr>
<th>If you want to ...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>configure other grading settings</td>
<td>use the Next or Back button to continue to another sheet in the Grading Wizard. In the grading properties, you can select another tab at the top of the dialog box to continue.</td>
</tr>
<tr>
<td>exit the command</td>
<td>click finish to close the Grading Wizard or click OK to close the grading properties dialog box.</td>
</tr>
</tbody>
</table>
Calculating General Statistics About a Grading Object

For each grading object, you can calculate statistics that list station information, such as start and end locations of the footprint, and start and end locations of the grading applied to that footprint. You can also calculate general reference volume statistics for the grading object, which include cut, fill, and net volumes.

If the grading object you created does not meet certain requirements, then the Calculate Volume command and the Statistics property page cannot generate volumes. In this instance, or if you want to verify volume calculations, you can create a surface from the grading object (and add surface information to the interior of the footprint, such as points, contours, or 3D polylines if needed. After you create a surface from the grading object, you can use the Volume commands on the Terrain menu to calculate volumes.

Volumes are only calculated under the following conditions:

- If the target is a surface and the grading direction is to the outside of a closed footprint (volumes are calculated between the object and the surface).
- If the target is an absolute elevation (volumes are calculated between the object and the elevation).

Volumes are not calculated under the following conditions:

- If the grading object has multiple targets.
- If the grading object has a single relative elevation target.
- If the footprint is closed and graded to the inside using a surface target.
- If the daylight line(s) cross and the condition is detected by the program.

**NOTE**

If you make changes to the Grading Properties, you must regenerate the grading object before you can calculate volumes. To regenerate the grading object click OK to exit the Grading Properties dialog box (this updates the grading object with the changes), then open the Statistics tab and run the command.

**NOTE**

Calculating statistics may require a moderate amount of processing time.

**NOTE**

Volumes may not be accurate if a daylight line(s) cross within the object. In most circumstances, the program detects this condition, and no volumes are calculated.
To calculate statistics about a grading object

1. From the Grading menu, choose Slope Grading ➤ Grading Properties. Select the Statistics tab.

2. Click the Calculate button.

   The Stations and Volumes information is displayed below the Calculate button. If you make changes to the grading object the information is erased. You can click Calculate to generate a new statistics report.

**Editing Grading Objects**

After you create a grading object, you can make changes to it by using the Grading Properties command, by grip editing it, or using the shortcut menu commands. To make changes, the grading object must be unlocked.
Object Locking

The grading object reacts differently to the changes you make depending on whether it is locked or unlocked.

- **Unlocked Object**: When the grading object is unlocked, it is reactive to changes and automatically updates. You can change the grading properties, use grip editing on the footprint, slope tags, and region tags, or use the AutoCAD editing commands (move, rotate, copy) and the grading object will automatically update slopes and daylight lines.

- **Locked Object**: When the object is locked, it is not reactive. You can use some AutoCAD editing commands (move, rotate, copy) to modify the grading object, but the object does not update slopes and daylight lines while it is locked. When you unlock the object, the program immediately updates the slopes and daylight lines. You cannot use the grip editing feature on a locked object.

**NOTE**
The AutoCAD LIST command displays the lock status of the selected grading object.

Locking a Grading Object

If you want to change the grading properties or use grip edits, then the grading object must be unlocked. Any changes you make to your project, such as redefining a surface that is used as a grading target, do affect the grading object if it is locked. When you unlock the grading object, it is updated with the changes you made.

**NOTE**
You can use some AutoCAD editing commands to modify the grading object when it is locked. The program automatically updates the grading object with these changes as soon as the object is unlocked.

To lock a grading object

1. Select a grading object in your drawing and right-click to display the shortcut menu.

   **NOTE**
The grading object is unlocked by default.

2. Click on Object Lock. A check mark displays to the left of Object Lock indicating the object is locked.

   **NOTE**
   Click on Object Lock to clear the check mark and unlock the grading object.

   **NOTE**
   If you are using only AutoCAD Land Development Desktop without Autodesk Civil Design, then the lock status of the object displays when you use the AutoCAD LIST command, but you are not able to change the lock status.
# AutoCAD Editing Commands and the Grading Object

The following table lists AutoCAD command behavior in relation to the grading object.

<table>
<thead>
<tr>
<th>Command</th>
<th>Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explode</strong></td>
<td>The grading object is exploded into 3D polyline entities. The elevations of the polylines match those of the grading object. The linetype and color of the resultant entities are as set in the Appearance tab in the grading properties. The layer of the entities is the layer that the grading object resided on when exploded. Projection lines are converted to 3D polylines, each consisting of two vertices, one vertex at the footprint and one at the daylight line. The daylight line is converted to a 3D polyline. The daylight points become the vertices of the new 3D polyline. The daylight lines are broken at the change between cut and fill. The footprint is converted to a continuous 3D polyline. Each vertex coincides with the vertex of a projection line. On radial corners, only the footprint vertex is used. On arcs, the vertices coincide with the projection lines.</td>
</tr>
<tr>
<td><strong>Trim to object</strong></td>
<td>The grading object can be used as a trim edge, but not trimmed.</td>
</tr>
<tr>
<td><strong>Extend to object</strong></td>
<td>The grading object can be used as an extend edge, but not extended.</td>
</tr>
<tr>
<td><strong>Break</strong></td>
<td>The grading object cannot be broken with the BREAK command.</td>
</tr>
<tr>
<td><strong>Offset</strong></td>
<td>The grading object cannot be offset.</td>
</tr>
<tr>
<td><strong>Mirror</strong></td>
<td>When mirrored, the grading object is copied and rotated 180 degrees based on a user defined reference point. All the slope tags and target regions are mirrored along the object and slopes are updated. If the object is locked, the slopes are mirrored, but remain locked.</td>
</tr>
<tr>
<td><strong>Stretch</strong></td>
<td>The grading object cannot be stretched, only grip edited (if unlocked and grips are visible).</td>
</tr>
<tr>
<td><strong>Scale</strong></td>
<td>The grading object can be scaled. When scaled, the slope tags and target regions remain in the same locations relative to the vertices. The object is updated if it is unlocked.</td>
</tr>
<tr>
<td><strong>Copy</strong></td>
<td>The object can be copied to a new location, and searches for new slopes if the original grading object was unlocked. If the original grading object was locked, the slopes/daylight lines of the new grading object do not update until the object is unlocked.</td>
</tr>
<tr>
<td><strong>Move</strong></td>
<td>The object can be moved. If the object is unlocked, the slopes/daylight lines update automatically. If the object is locked, the original slope and daylight lines do not update until the object is unlocked.</td>
</tr>
<tr>
<td><strong>Cut and Paste</strong></td>
<td>Using the Cut and Paste commands from the AutoCAD Edit menu with a grading object produces a block that you must explode prior to regrading.</td>
</tr>
<tr>
<td><strong>Rotate</strong></td>
<td>The object can be rotated. If the object is locked, the original slope and daylight lines do not update until the object is unlocked.</td>
</tr>
<tr>
<td><strong>Erase</strong></td>
<td>You can erase the object, even if it is locked.</td>
</tr>
<tr>
<td><strong>Grip Editing</strong></td>
<td>You can use grips to edit a grading object. There are grips for the footprint vertices, slope values, slope tags, and target region boundaries. Grips are only visible if the grading object is unlocked and the grip check box is selected in the Appearance tab in the Grading Properties dialog box. When you move a vertex grip, the slope and target regions remain a fixed distance relative to the previous vertex.</td>
</tr>
<tr>
<td><strong>Osnap</strong></td>
<td>Snap points are fully enabled for the grading object.</td>
</tr>
<tr>
<td>Command</td>
<td>Behavior</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>AutoCAD List</strong></td>
<td>The LIST command displays the grading object properties. The following is an example:</td>
</tr>
</tbody>
</table>
|                    | Select objects: AECC_GRADE Layer: "0"
|                    | Space: Model space
|                    | Handle = 1A
|                    | Name : Description :
|                    | Accuracy : Automatic With Increment
|                    | Increments : 10.0000 On Lines, 10.0000 On Arcs
|                    | Object Lock : UNLOCKED
|                    | Appearance : Visible Color Linetype
|                    | Footprint: Yes 4 BYLAYER
|                    | Cut Projections: Yes 1 BYLAYER
|                    | Fill Projections: Yes 3 BYLAYER
|                    | Cut Daylight: Yes 1 BYLAYER
|                    | Fill Daylight: Yes 1 BYLAYER
|                    | Grip Visibility: Footprint Vertices: Yes, Slope Tags: Yes, Slope Values: Yes, Target Region Boundaries: Yes
|                    | Region : 1 Target : Surface: EXNEW
|                    | Start Station : 0.0000, Cut Slope : 3.0000, Fill Slope: 3.0000
|                    | End Station : 69.4892, Cut Slope : 3.0000, Fill Slope: 13.7447
|                    | Region : 2 Target : Surface: EXNEW
|                    | Start Station : 69.4892, Cut Slope : 3.0000, Fill Slope: 13.7447
|                    | End Station : 237.3690, Cut Slope : 3.0000, Fill Slope: 13.7447
|                    | Press ENTER to continue:
|                    | Region : 3 Target : Surface: EXNEW
|                    | Start Station : 237.3690, Cut Slope : 3.0000, Fill Slope: 13.7447
|                    | End Station : 991.1204, Cut Slope : 3.0000, Fill Slope: 9.0400
|                    | Region : 4 Target : Relative Elevation, -10.0000
|                    | Start Station : 991.1204, Cut Slope : 3.0000, Fill Slope: 9.0400
|                    | End Station : 1157.3600, Cut Slope : 3.0000, Fill Slope: 8.0024
|                    | Region : 5 Target : Relative Elevation, 10.0000
|                    | Start Station : 1157.3600, Cut Slope : 3.0000, Fill Slope: 8.0024
|                    | End Station : 1258.5179, Cut Slope : 3.0000, Fill Slope: 6.7562
|                    | Region : 6 Target : Relative Elevation, 10.0000
|                    | Start Station : 1258.5179, Cut Slope : 3.0000, Fill Slope: 8.0024
|                    | End Station : 1357.0179, Cut Slope : 3.0000, Fill Slope: 6.7562
|                    | Region : 7 Target : Surface: EXNEW
|                    | Start Station : 1357.0343, Cut Slope : 3.0000, Fill Slope: 6.7562
|                    | End Station : 1958.8278, Cut Slope : 3.0000, Fill Slope: 3.0000
|                    | Footprint Coordinates:
|                    | X=1046972.0854, Y=160615.4064, Z=240.0000, Station=0.0000
|                    | X=1046718.1538, Y=160881.9434, Z=240.0000, Station=368.1349
|                    | X=1046803.8557, Y=161251.6049, Z=240.0000, Station=817.3294
|                    | X=1047200.6239, Y=161059.6348, Z=240.0000, Station=1309.5130
|                    | X=1047140.3151, Y=160624.9256, Z=240.0000, Station=1763.7911
|                    | X=1046972.0854, Y=160615.4064, Z=240.0000, Station=1958.8278

<table>
<thead>
<tr>
<th>Change AutoCAD layer</th>
<th>You can change the object to specified layer. If grading object colors are BYLAYER, then it will honor the new layer’s color.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create UCS</td>
<td>UCS (User Coordinate Systems) are not supported in grading object functionality.</td>
</tr>
<tr>
<td>Ctrl + or Ctrl – on the keyboard when object is selected</td>
<td>Grading object footprint elevation changes by the increment set within the Elevation Step box in the Footprint tab of the Grading Properties dialog box if the object is unlocked.</td>
</tr>
</tbody>
</table>
Using Grips to Edit Grading Objects

You can select an unlocked grading object in your drawing and graphically change the footprint vertices, target regions, and slope tag location and slope tag value. These changes are reflected in the Grading Properties dialog box. The following illustration shows the grading object grip points.

![Grading Object Components](image)

**Grading object grip points**

Using Grips to Edit the Footprint Vertices

Selecting and sliding a vertex grip moves the location of that footprint vertex. All other vertices in the footprint remain at their present locations. Target regions and slope tags always remain at a fixed distance from the nearest footprint vertex. If you use Ctrl + or Ctrl – on your keyboard to change the elevation of the footprint, then the base elevation will change by the amount that you entered in the Elevation Step box in the footprint settings.

**NOTE** You can select which grips you want to be visible in your drawing by changing the appearance settings.

To move a footprint vertex using grip edits

1. Click on a grading object in your drawing.
2. Select a footprint vertex grip.
3. Slide the vertex grip to a new location.

When you access the Grading Properties dialog box, the new location of the footprint vertex displays in the spreadsheet section of the Footprints tab.
Using Grips to Edit the Target Regions

Target regions are sections along the footprint that establish what the slope will project to (a surface, an elevation, or a distance). For example, one target region along the footprint may project to a surface, while the next target region may project to an elevation. You can use grips to change the location of target regions.

The following illustration shows grading target regions.

Target region grips

NOTE You cannot move the target region grip of the first region. This first target region grip is coincident with the first slope tag grip, which cannot be moved either.

To move a target region using grip edits

1. Click on a grading object in your drawing.
2. Select a target region grip.
3. Slide the target region grip to a new location.

NOTE You cannot move a target region tag past a slope tag, or past another target region tag.

When you access the Grading Properties dialog box, the new location of the target region displays in the spreadsheet section of the Targets tab.

Using Grips to Edit the Slope Tag Locations and Slope Values

Slope tags define a location along the footprint where a specific slope is applied. Slope tags affect the slope of the projection lines before and after the tag by transitioning. When transitioning from one slope tag to the next the change in the slope always remains linear to the footprint.
The following illustrations show how slope tags control slope transition values and locations.

Controlling location of slope transition

Adjusting cut/fill slopes by selecting and moving slope value grips

**NOTE** The change in the slope is always linear to the footprint except around convex corners. Around convex corners, the slope is linear along the daylight line.

**To move slope tag locations and control slope tag values**

1. Click on a grading object in your drawing.
2. Select the slope tag location grip. The slope tag location grip is located on the projection line, midpoint between the footprint and the daylight line.

**NOTE** You cannot move the first slope tag location grip on the grading object.

3. Slide the grip along the footprint to a new location. The values for the slope tag remain the same as at its previous location.
4. Select the slope value grip. The slope tag value grip is located on the daylight line.
5. Move the grip toward or away from the footprint to establish the slope for the location of the slope tag. All other slope tags remain the same.
NOTE You cannot move a slope tag location grip past a target region grip or past another slope tag, but you can change the slope tag location in the grading slopes settings. The distance between grips is determined in the Minimum Region Length in the targets settings.

NOTE When you grip edit a slope value tag that is located in a target region that uses Distance as its target, the slope value tag does not actually move in the drawing, and the target distance is not changed by editing the slope tag. However, even though the appearance of the target distance or slope value grip does not change in this situation, the slope value for that particular tag is updated on the Slopes tab in the Grading Properties.

When you access the Grading Properties dialog box, the new slope tag location and slope tag value display in the spreadsheet section of the Slopes tab.

Editing a Grading Object Using the Shortcut Menu

You can use the commands from the Slope Grading shortcut menu to edit the grading object vertices, slope tags, and target regions. The changes you make are immediately reflected in the drawing. To make edits to the grading object it must be unlocked.

Add a Vertex Using the Shortcut Menu

When you select Add Vertex from the shortcut menu, temporary grips display to show the location of the vertices on the grading object.

To add a vertex using the shortcut menu

1 Select a grading object and right click to display the shortcut menu.
2 Click Add Vertex. Grips display at all the vertex locations.
3 At the command line you are prompted to mark the location of new vertex. Select a point in the drawing on or near the grading object where you want to add the vertex.
4 The new vertex is inserted between the two closest vertices at that point. The drawing updates immediately with the new vertex. The elevation for the new vertex is interpolated between the two closest vertices at that point.

Changes you make are reflected in the Footprint tab of the Grading Properties.

NOTE If you snap to a 3D object when you create a new vertex, the vertex will be at that elevation. For example, any screen pick with an elevation of zero will have an interpolated elevation. If a screen pick has a Z value, then the new vertex will inherit that Z value.
**Add a Slope Tag Using the Shortcut Menu**

When you select Add Slope Tag from the shortcut menu, temporary grips display at all slope tag locations on the grading object.

**To add a slope tag using the shortcut menu**

1. Select a grading object and right click to display the shortcut menu.
2. Click Add Slope Tag. Grips display on all the slope tag locations.
3. At the command line you are prompted to mark the location of new slope tag. Select a point in the drawing on or near the grading object where you want to add the slope tag.
4. The new slope tag is inserted between the two closest slope tags at that point. The new slope tag has the slope value you assigned in the grading properties. Changes you make are reflected in the Slopes tab of the Grading Properties.

**Add a Target Region Using the Shortcut Menu**

When you select Add Target Region from the shortcut menu, temporary grips display at all target region locations on the grading object.

**To add a target region using the shortcut menu**

1. Select a grading object and right click to display the shortcut menu.
2. Click Add Target Region. Grips display on all the target region locations.
3. At the command line you are prompted to mark the location of new target region boundary. Select a point in the drawing on or near the grading object where you want to insert the target region.
4. The new target region is inserted between the two closest target regions at that point. The targets on either side of the new target region boundary will be the same as the original target at that location. Changes you make are reflected in the Targets tab of the Grading Properties.

**Edit a Vertex Using the Shortcut Menu**

**To edit a vertex using the shortcut menu**

1. Select a grading object and right click to display the shortcut menu.
2. Click Edit Vertex. Grips display on all the target region locations.
3. At the command line you are prompted to select a vertex to edit. Select the vertex in the drawing and the Edit Vertex dialog box is displayed.
4. You can enter a new elevation and/or corner treatment.
You can move between vertices by clicking the following buttons in the dialog box:

- Selects the first vertex
- Moves back one vertex
- Moves forward one vertex
- Selects the last vertex

Changes you make are reflected in the Footprint tab of the Grading Properties.

### Edit a Slope Tag Using the Shortcut Menu

**To edit a slope tag**

1. Select a grading object and right click to display the shortcut menu.
2. Click Edit Slope Tag. Grips display on all the slope tag locations.
3. At the command line you are prompted to select a slope tag to edit. The Edit Slope Tag dialog box displays with the data for the selected slope tag.
4. You can enter a new station value and new Cut Slope and Fill Slope values. You can move between slope tags by clicking the following buttons in the dialog box:

- Selects the first slope tag
- Moves back one slope tag
- Moves forward one slope tag
- Selects the last slope tag

Changes you make are reflected in the Slopes tab of the Grading Properties.

### Edit a Target Region Using the Shortcut Menu

**To edit a target region**

1. Select a grading object and right click to display the shortcut menu.
2. Click Edit Target Region. Grips display on all the target region locations.
3. At the command line you are prompted to select a target region to edit. The Edit Target dialog box displays the target region number, as well as the target region’s start station and end station.
4. You can enter a new Start Station, End Station and select a new target for the region.
You can move between regions by clicking the following buttons in the dialog box:

| < | Selects the first region |
| < | Moves back one region |
| > | Moves forward one region |
| > | Selects the last region |

Changes you make are reflected in the Targets tab of the Grading Properties.

### Delete a Vertex Using the Shortcut Menu

**To delete a vertex**

1. Select a grading object and right click to display the shortcut menu.
2. Click Delete Vertex. Grips display on all the target region locations.
3. At the command line you are prompted to select a vertex to delete.
4. Click on the vertex you want to delete. The vertex is deleted and the drawing automatically reflects the changes.

Changes you make are reflected in the Footprint tab of the Grading Properties.

### Delete a Target Region Using the Shortcut Menu

**To delete a target region**

1. Select a grading object and right click to display the shortcut menu.
2. Click Delete Target Region. Grips display on all the target region locations.
3. At the command line you are prompted to select a target region to delete.
4. Click on the target region you want to delete. The target region is deleted and the drawing automatically reflects the changes.

Changes you make are reflected in the Targets tab of the Grading Properties.

**NOTE** When you delete a vertex that is preceded or followed by an arc, a new arc is placed between the remaining vertices. This new arc passes through the location of the deleted vertex.

### Delete a Slope Tag Using the Shortcut Menu

**To delete a slope tag**

1. Select a grading object and right click to display the shortcut menu.
2. Click Delete Slope Tag. Grips display on all the slope tag locations.
3. At the command line you are prompted to select a Slope Tag to delete.
4. Click on the slope tag you want to delete. The slope tag is deleted and the drawing automatically reflects the changes.

Changes you make are reflected in the Slopes tab of the Grading Properties.
Use the LIST Command

You can use the AutoCAD LIST command to display all the grading object properties.
To view the grading object properties type LIST at the command line.

Functionality of Grading Objects in AutoCAD

The following table lists how the grading object reacts when the drawing is opened with other versions of AutoCAD.

<table>
<thead>
<tr>
<th>Save/Save As</th>
<th>Open With</th>
<th>Result of Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>R15/R14/R13</td>
<td>R15/R14 (w/ AutoCAD Land Development Desktop and Autodesk Civil Design)</td>
<td>No change in behavior</td>
</tr>
<tr>
<td>R15/R14/R13</td>
<td>R15/R14 (w/ AutoCAD Land Development Desktop only)</td>
<td>Functional grading object, with grip editing enabled; but no access to the grading properties. Respects last set lock setting</td>
</tr>
<tr>
<td>R15/R14/R13</td>
<td>R15/R14 MAP w/ Object Enabler</td>
<td>Non-functional grading proxy-like object showing all graphics that were established in Civil Design; No access to grading properties, no grip editing functions; All applicable AutoCAD commands are honored, i.e. MOVE, ROTATE, ERASE, etc.</td>
</tr>
<tr>
<td>R15/R14/R13</td>
<td>R15/R14 or Map Only</td>
<td>Proxy object (box or graphics)</td>
</tr>
<tr>
<td>R13</td>
<td>R13</td>
<td>Creates AutoCAD “Zombie” object; Non-editable, (except for ERASE)</td>
</tr>
<tr>
<td>R12</td>
<td>R12/R13/R14 (R14 with or without AutoCAD Land Development Desktop)</td>
<td>Save as R12 converts daylight line to 3D polyline; Projection lines and footprint are converted to 3D lines</td>
</tr>
<tr>
<td>DXFOUT R15</td>
<td>DXFIN R15 (with or without AutoCAD Land Development Desktop support/object enabler)</td>
<td>Fully Functional Object</td>
</tr>
<tr>
<td>DXFOUT R14</td>
<td>DXFIN R14 (with or without AutoCAD Land Development Desktop support/object enabler)</td>
<td>Fully Functional Object</td>
</tr>
<tr>
<td>DXFOUT R13</td>
<td>DXFIN R13/R14/15 (with or without AutoCAD Land Development Desktop support/object enabler)</td>
<td>Non-functional</td>
</tr>
<tr>
<td>DXFOUT R12</td>
<td>DXFIN R12</td>
<td>Non-functional</td>
</tr>
</tbody>
</table>
## Functionality of Grading Objects in AutoCAD (continued)

<table>
<thead>
<tr>
<th>Save/Save As</th>
<th>Open With</th>
<th>Result of Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>R15/R14/R13</td>
<td>ADE/Map - Open/Query</td>
<td>Fully functional display/draw and modify (locked) including save back to source</td>
</tr>
<tr>
<td>WBLOCK</td>
<td>R15 (all platforms)</td>
<td>Same as all “Save As R15” functions</td>
</tr>
<tr>
<td>Only R14</td>
<td></td>
<td>Insert as block and explode, object is intact. Insert as exploded .DWG (using *), object is intact; Behavior is same as all “Save As R15/14/R13” functions</td>
</tr>
<tr>
<td>R15/14/R13</td>
<td>R15 INSERT (all platforms)</td>
<td>Insert as block and explode, object is intact. Insert as exploded .DWG (using *), object is intact; Behavior is same as all “Save As R15/14/R13” functions</td>
</tr>
<tr>
<td>R12</td>
<td>R12/R13/R14/R15</td>
<td>Save as R12 converts daylight line to 3D polyline; Projection lines and footprint are converted to 3D lines</td>
</tr>
<tr>
<td>XREF</td>
<td>R15 (with or without AutoCAD Land Development Desktop support/object enabler)</td>
<td>Display works same as all “Save As” functions; Binding the XREF and exploding results in intact grading object</td>
</tr>
<tr>
<td>R13</td>
<td></td>
<td>Display works same as all “Save As” functions; Binding the XREF and exploding results in intact grading object</td>
</tr>
<tr>
<td>R12</td>
<td></td>
<td>Save as R12 converts daylight line to 3D polyline; Projection lines and footprint are converted to 3D lines</td>
</tr>
<tr>
<td>DWF</td>
<td>MSIE 4.0/5.0 and WHIP</td>
<td>Object shows normally</td>
</tr>
</tbody>
</table>

## Creating a Surface from a Grading Object

You can create a surface from a grading object. The surface is created using the 3D information from the grading object footprint, daylight line, and projection lines.

The surface information is determined from the following features:

- **Footprint**: Information from the footprint is gathered from the vertices on the footprint and along arc segments of the footprint. Along arc segments, a point is created on the arc at the location of each projection line.
- **Daylight lines**: Information from the daylight lines is gathered from points at each vertex of the daylight line. The daylight line also becomes the TIN boundary.
- **Projection Lines**: Information from the projection lines is gathered from a point at the beginning and a point at the end of each projection line.

**NOTE** When the surface is created, the footprint and projection lines are treated as breaklines. The daylight line is used as a TIN boundary, to prevent extraneous TIN lines from being drawn outside of the daylight line.
NOTE
In certain situations, when you create a surface from a grading object that has transitions from cut to fill, the surface boundary may not be honored at those locations. You should check for TIN lines outside of the boundary where there is a transition from cut to fill and eliminate these lines by using surface editing functions after creating the surface.

After you have created the surface, it has the same functions as other surfaces and you can manage the surface from within the Terrain Model Explorer.

To create a surface from a grading object

1. From the Grading menu, choose Slope Grading ➤ Create Surface. The following prompt is displayed:
   Select a graded object:

2. Click on a grading object in your drawing to display the New Surface dialog box.

3. Type a name for the surface in the New Surface box. The name is limited to 40 characters.

4. Type a description for the surface in the Description box. The description is limited to 40 characters.

5. Click OK. The command then creates and builds a new surface.

NOTE
The surface created uses only the data obtained from the grading object you selected in step 2. However, you can add additional data to the surface by using the Terrain Model Explorer.

NOTE
If you explode a grading object and build a surface from the exploded objects, then the surface will have the same characteristics of a surface that was created from an unexploded grading object, except for boundary lines.

Creating Contours from a Grading Object

Using the Create Contours command, you can directly create contours from a Grading Object without having to first create a Digital Terrain Model (DTM). When you use the Create Contours command, a DTM is created from the Grading Object only in memory. The daylight line is the boundary...
for the temporary DTM. This DTM in memory is discarded upon completion of the command.

NOTE You can also use the Create Surface command to create a DTM, then create contours from the DTM.

To create contours from a grading object
1 From the Grading menu, choose Slope Grading ➤ Create Contours. At the command line you are prompted to select a grading object.
2 Select the grading object. The Create Contours from Grading Object dialog box is displayed.

![Create Contours from Grading Object dialog box](image)

3 Under Elevation Range, define the range of the surface’s elevation for which you want to create contours by entering values in the From and To boxes. The low and high elevations of the surface are displayed as defaults.

TIP If you change the Elevation Range, then you can return to the default range by clicking the Reset Elevations button.

4 To exaggerate the elevational changes of the contours when you look at them in 3D, enter a value other than one (1) in the Vertical Scale box.

NOTE If you exaggerate the vertical scale, the contours are drawn at an exaggerated elevation and are therefore incorrect when labeling or as a basis for future TIN creation.

5 Under Intervals, select one of the following options:
   - Both Minor and Major
   - Minor Only
   - Major Only

6 Define the contour intervals by entering values in the Minor Interval and Major Interval boxes. For example, if you enter a minor interval of 2, and your
drawing units are meters, then a minor contour is created every place there is a 2-meter change in elevation.

7 Specify the layers for the major and minor contours. By placing the minor and major contours on different layers, you can easily control the contour colors and linetypes. You can select a layer or type in a new layer name.

**NOTE** Layer management for contours is important. For more information, see step 12.

8 Under Properties, select one of the following options:

- Contour Objects: To create contour
- Polylines: To create polyline contours

**NOTE** If you select the Polylines option, then you cannot select a contour style to use.

9 From the Contour Style list, select the contour style to use for the contours.

**TIP** Click the Preview button to see a preview of the contour style.

10 If you need to load a contour style, edit a style, or create a new style, then click the Style Manager button to display the Contour Style Manager overview dialog box.

11 Click OK to generate the contours.

The following prompt is displayed.

Erase old contours (Yes/No) <Yes>:

12 Type one of the following options:

- **Yes**: To erase any existing contours that may be present on the contour layers.
- **No**: To preserve existing contours.

**WARNING!** If you type Yes to erase the old contours, then existing contours on both the major and minor contour layers are erased. When you develop grading plans, pay attention to the layers that the Create Contours command uses so that your existing ground contours are not erased.
Creating Breaklines from a Grading Object

You can create breaklines from a grading object and add them to the current surface, to a new surface, or to any existing surface.

When you create breaklines from a grading object, the breakline information is determined from the following features:

- **Footprint**: A breakline is created from the footprint, using each vertex on the footprint, and a vertex at each projection line location. On arc segments, the breakline vertices correspond to the locations where the projection lines intersect the arc. Arcs become a series of straight line segments.

- **Daylight Lines**: A breakline is created from each cut/fill segment of the daylight line.

- **Projection Lines**: A breakline is created from each projection line.

The following illustration shows footprint and daylight line locations.

![Footprint and daylight breakline vertex locations](image)

**To create breaklines from a grading object**

1. From the Grading menu, choose Slope Grading ➤ Create Breaklines. The following prompt is displayed:

   Surface to add breaklines to (Current/New/Select) <Current>:

2. Type one of the following options:

   - **Current** to add breaklines to the current surface. Select the grading object and enter a description for the breaklines.
   - **New** to add the breaklines to a new surface. The New Surface dialog box is displayed. Enter a name and a description for the new surface and click OK.
   - **Select** to add the breaklines to an existing surface. The Select Surface dialog box is displayed. Select the surface you want the breaklines to be added to and click OK.
NOTE After you create the breaklines, you must build the surface to incorporate the breakline data into that surface.

Calculating Volume Data for a Grading Object

You can use the Calculate Volume command to calculate the cut, fill, and net volumes of a grading object. The composite volume method is used to calculate the volume results. This method compares the grading object with the grading target(s) to determine the volumes.

When you calculate volumes for the grading object, the program creates a temporary DTM of the grading object in memory, and compares it with the target surface. The comparison method used is similar to the composite volume calculation method. The target is treated as existing ground and the grading object is treated as finished ground for the purposes of calculating volumes. In order to calculate volumes for a grading object, the grading target(s) of the grading object must be an existing terrain model surface or an absolute elevation.

If the grading object you created does not meet certain requirements, then the Calculate Volume command and the Statistics property page cannot generate volumes. In this instance, or if you want to verify volume calculations, you can create a surface from the grading object (and add surface information to the interior of the footprint, such as points, contours, or 3D polylines if needed), and then use the Volume commands on the Terrain menu to calculate volumes.

Volumes are only calculated under the following conditions:

- If the target is a surface and the grading direction is to the outside of a closed footprint (volumes will be calculated between the object and the surface).
- If the target is an absolute elevation (volumes will be calculated between the object and the elevation).

Volumes are not calculated under the following conditions:

- If the grading object has multiple targets.
- If the grading object has a single relative elevation target.
- If the footprint is closed and graded to the inside using a surface target.

If the daylight line(s) cross and the condition is detected by the program.

NOTE Calculating statistics may require a moderate amount of processing time.

NOTE Volumes may not be accurate if a daylight line(s) cross within the object. In most circumstances, the program will detect this condition, and no volumes will be calculated.
To calculate volume data for a grading object

1. From the Grading menu, choose Slope Grading ➤ Calculate Volume.
   The following prompt is displayed:
   Select a graded object:

2. Click on a grading object in your drawing.
   The cut and fill volumes are displayed above the command prompt at the bottom of the AutoCAD window.

Grading Object Usage Tips

The grading object represents a major leap in 3D terrain modeling and automated site design. When used in conjunction with the existing daylight and point/contour layout commands, it is the most powerful 3D terrain modeling tool set available today. The grading object calculates numerous grading conditions automatically, and provides real-time feedback and analysis.

The grading object automates virtually all slope calculations where the starting elevation and slope are known, but the resultant daylight (match with existing ground or elevation) is not known. In almost all cases, the grading object will solve these unknowns and provide treatment for exterior and interior corners. However, there are situations where slope projection lines or daylight lines may cross, and situations where a design solution is impossible to calculate.

For the purpose of compatibility and editing, the base entities of an exploded grading object are 100% compatible with the Terrain Model Explorer and the layout and grading commands within AutoCAD Land Development Desktop and Autodesk Civil Design. The resultant entities from an exploded grading object are 3D polylines and 3D lines. In conditions where the grading object can’t retrieve a design solution, you can explode it and manipulate the 3D entities by using the tools available in the Grading menu or AutoCAD editing commands.

General Grading Tips

Unsolved Slope Grading Conditions

Remember that the object cannot solve for all conditions: Although the grading object can solve most grading conditions, there will be situations that require manual editing to produce the desired results. In these cases you can explode the grading object and edit the resultant entities by using the Daylighting commands or simple AutoCAD commands, and then use the entities as surface information in the Terrain Model Explorer.

Know when the grading object is trying to solve impossible grading conditions: The object will not grade to itself, so when two slope lines cross, it is typically because the target at that slope is either too high or too low to solve.

For areas and conditions such as this, you can specify a different target for the object (for instance, you can specify an absolute or relative elevation or a horizontal offset value as the target). If there are areas where no grading is desired, you can define void regions. To define a void region, use a relative
elevation target and set the relative elevation to zero, or use a distance target and set the distance to zero.

**Unexpected Projections**

*When the object has unexpected projections:* The combination of numerous vertices, slopes and/or targets may create a situation that is too difficult to resolve. In these situations, try to analyze for conditions that would normally have no solution.

Remember that each vertex with a deflection angle is treated as a corner, and multiple overlapping corner treatments will not be solved for. It may be necessary to define a void region for the problem area, and grade that area by hand. To define a void region, use a relative elevation target and set the relative elevation to zero, or use a distance target and set the distance to zero.

**Volumes from a Grading Object**

Volumes from a grading object are for quick reference only: When volumes are calculated from the grading object, a temporary TIN is created from the object, and volumes are generated by comparing this TIN with the target used to create the object.

Because there is the potential that this temporary surface may not match your requirements, it is highly recommended that you verify critical volumes by creating a TIN from the object and verifying that this TIN is accurate (ie, create contours and visually review the TIN). You should then calculate volumes using the other volume methods available within the Terrain menu.

**Grouping Grading Objects**

The AutoCAD group command can be applied to a collection of objects: You can use the Group command to define a collection of grading objects as a group. Selecting one of the objects within a group will select all of the items within the group. You can use AutoCAD commands to edit a group of grading objects, and the Ctrl + and Ctrl - to adjust the footprint elevations of a group of grading objects.

Note that you cannot edit the properties of the grouped grading objects; you are limited to changing the properties of one grading object at a time.

For more information about the Group command, see the AutoCAD Land Development Desktop online Help.

**Avoid Using Running Object Snaps When Graphically Editing the Grading Object**

Because the grading object vertex grip points and the grading object itself are sensitive to elevation changes, it strongly recommended that you turn off running Object snaps prior to graphically editing the object. This will prevent the likelihood of inadvertently snapping to the wrong elevation and causing undesirable results.
Grading Objects and TIN Surfaces

TIN Results from a Grading Object
Verify TIN results when creating a surface from the grading object: For most grading objects, the Create Surface command in the Slope Grading menu will create surface TINs that do not require any modifications. However, there may be situations where you may need to clean up the TIN prior to using it for analysis or design. In most cases where there are problems, it is due to crossing daylight lines or TIN lines outside of the daylight line which were not detected for cleanup during the TIN creation process.

It is important to understand that the daylight line is always treated as a boundary, and the footprint is not. In cases where TIN lines need to be edited or deleted (whether within the object or potentially outside of the daylight line), you should edit the TIN using the standard editing commands in the Terrain menu. An alternative solution is to explode the grading object before creating a surface, and then make edits to the resulting entities so that they will create a valid surface.

Grading Objects and Terrain Model Explorer
Grading objects cannot be directly selected as valid Terrain Model data: You can create a terrain model from a grading object, but you cannot directly use a grading object as surface data in the Terrain Model Explorer. However, you can create breakline data from the grading object for any surface by using the Create Breaklines command, or you can explode the grading object into 3D entities and use these entities (in conjunction with other point, contour, and 3D CAD data) to create a surface in the Terrain Model Explorer.

Footprints

Keep the Grading Footprint Simple
Keep your grading footprint as simple as possible: Complex 3D polylines created using the commands in the Daylighting menu typically have far more vertices than are needed to define a grading object. A corner cleanup method is applied to each vertex on a grading object, which requires calculation time. The intent of the projection spacing (accuracy) is to eliminate the need for additional vertices. Also, applying elevation changes to the footprint is easier and more manageable if the footprint has fewer vertices.

Raising and Lowering a Footprint
When using the Ctrl + and Ctrl - keys to raise or lower a footprint, give the program a chance to finish calculating: If you press the keys repeatedly before allowing the program to finish calculating, the keyboard memory buffer may fill up and cause these keypad commands to stop functioning. This may also affect the display of the shortcut menu when you click the right mouse button.

If this happens, it is usually necessary to exit AutoCAD to restore these functions. This will not cause loss of data or inability to save the drawing. Note that all other commands will still be available, and all commands in the shortcut menu can still be accessed through the Grading pull-down menu.
Slopes

Vertical Slopes
Vertical slopes are not truly vertical: If two points used in the creation of a TIN are within 0.0001 drawing units of each other, the Terrain Model Explorer automatically discards one of the points. Because of this, selecting a “vertical” slope for a grading object will always result in a top and bottom point which are offset slightly (by no more than 0.0002 drawing units) in either the X or Y direction. This was done to prevent the Terrain Model Explorer from discarding any of the points in the grading object.

Targets

Grading to a Relative Elevation
Grading to a relative elevation may cause jumps in your daylight line: Due to the geometry involved in cleaning up corners when footprint segments have changing elevations and the target is a relative elevation, “jumps” or “dips” may occur. In this situation, it may be necessary to manually edit the daylight line and projections to achieve the desired results.

Corners

Slope Tags and Target Regions within a Corner Cleanup
Avoid placing slope tags or target region boundaries within a corner cleanup: In most cases this will result in a partial corner cleanup, or prevent a corner cleanup from occurring altogether.

Examples of Interior Corner Cleanup Conditions
The grading object cannot solve all interior corner cleanup conditions: The grading object can resolve most cases of interior corner cleanup. There are instances, however, where no solution can be found. In these cases, it is best to rely on the engineer’s judgement.

To help you understand how and where these instances will occur, it’s helpful to understand how in previous releases the Daylighting commands reacted on interior corners. The following illustration shows the behavior of the Daylighting commands.

Interior corner results using daylighting commands
In comparison, the grading object automatically solves these interior corner cleanups for almost all conditions.

The following illustration shows a line-line interior miter corner cleanup.

The following illustration shows an arc-line interior miter corner cleanup.

The following illustration shows an arc-arc interior miter corner cleanup.
The following illustration shows a line-line-line interior miter corner cleanup.

**Grading object line-line-line interior miter corner cleanup**

In some cases, the grading object will not be able to solve interior corner cleanup.

The following illustration shows a line-line-line interior miter corner cleanup that is not supported (three adjacent planes are overlapping in this situation).

**Unsupported line-line-line interior miter corner cleanup**

This situation is not supported (three adjacent planes are overlapping).
The following illustration shows an arc-line-line interior corner cleanup condition that is not supported (three adjacent planes are overlapping in this situation).

![Unsupported arc-line-line interior miter corner cleanup](image)

This situation is not supported (three adjacent planes are overlapping).

The grading object cannot clean up the corners in these situations because it will only calculate cleanup for two adjacent planes. For each segment of the footprint, a plane at the specified slope is projected to the selected target. This is true even in situations where slope transitions occur. The interior corner cleanup method (Concave Miter) finds the intersecting point of two adjacent planes at the daylight line. It then performs a cleanup by calculating a slope line from the vertex between the two adjacent segments to the intersecting point.

Due to the complexity of calculating the intersecting point of two or more non-adjacent planes, cleanup will not occur if non-adjacent planes intersect. If this situation occurs, you may need to explode the object and manually edit the areas to produce a terrain model with the desired results. Another option is to fillet the corner with an arc of sufficient radius prior to creating the grading object.

For those who would rather not explode the object, you can define a void region that covers the problem area. To define a void region, use a relative elevation target and set the relative elevation to zero, or use a distance target and set the distance to zero. You can then use Daylighting or AutoCAD editing commands to edit the area and create a TIN from the grading object (as breaklines). An alternative may also be to manually edit the grading object's TIN by adding points and lines.
The following illustration shows a grading object with interior miter cleanup and changing footprint vertex elevations. The slope is always constant throughout the corner, so a drop is formed at the center of the cleanup. In this case, the object is behaving as designed.

Grading object with changing vertex elevations

This illustration shows a grading object with changing vertex elevations and an absolute elevation target, showing interior miter corner cleanup. Notice the “drop” at the center of the corner. This is how the object is designed to handle this case.

**Accuracy**

**Fixed Incremental vs. Automatic Spacing**

Although projection line spacing created with the “Use Automatic Spacing with Increment” setting produces the most accurate daylight line, there may be situations where gaps occur in the projection spacing. Although this is rare, it may be solved by changing the accuracy method to “Use Fixed Incremental Spacing.”

**Automatic Spacing and Elevation and Distance Targets**

Automatic spacing does not apply to elevation or distance targets: By definition, automatic spacing finds projection lines where the slope intersects TIN lines of the target surface. With elevation or distance targets, there are no TIN lines to intersect, so the program will apply the specified increment spacing.
Daylighting

The Daylighting commands calculate slope daylighting from a polyline footprint to a surface, based on slope criteria. These commands calculate the daylight match line that is drawn as a 3D polyline. Elevational points and breaklines can also be generated to represent the daylight slopes. All of these elements can be used to generate a surface.

A 2D or 3D polyline with elevational information is used to represent the footprint. Cut and fill slope information is assigned to each vertex on the polyline. Additional vertices can be added to the polyline for increased daylight line sampling. Based on the polyline footprint elevations and the assigned slope information, the daylight line is calculated at each vertex of the footprint polyline for a selected daylight target surface.

Selecting the Daylight Surface

You can select the surface to use for calculating daylight lines. This is the surface that you want the slopes to match into. Surfaces are created from the Terrain menu.

To select the daylight surface

1. From the Grading menu, choose Daylighting ➤ Select Daylight Surface to display the Select Surface dialog box.

2. Select the surface that the slopes intersect.

3. Click OK.
Adding Vertices to a Polyline for Daylighting

You can add vertices to the polyline footprint for calculating a more accurate daylight line. The daylight match line is generated by calculating the match point from each vertex on the polyline. Each daylight line bisects the angle formed by the segments before and after the vertex. If the vertices are closer together a more accurate daylight line can be generated. Vertices are added by specifying the horizontal distance between the vertices around the polyline.

The polyline can have a constant elevation, or it can have varying elevations at its vertices. It can be an opened or closed polyline.

To add vertices to an existing polyline

1. From the Grading menu, choose Daylighting ➤ Add Vertices.
   The following prompt is displayed:
   Select entity (or Points):

2. At this prompt, select the polyline to which to add vertices using one of the following methods:
   - Select a polyline with your pointing device.
   - Type P and select points to define the polyline.

   **NOTE** When you select the points to define the polyline, the following prompt is displayed:

   Establish first point elevation...
   Elevation <0.00>:
   Establish second point elevation...
   Elevation (eXit/Difference/Slope) <0.000>:

3. At this prompt, do one of the following:
   - Type the elevation for the second point.
   - Type D and the difference in elevation between the first and second points.
   - Type S and a slope between the first and second points, or type G and a grade.

4. Specify the distance to set the additional polyline vertices. This is the horizontal distance between the new vertices.
   If you selected a 2D polyline that contains arcs, the following prompt is displayed:

   Additional curve vertices by (Number/Mid/Distance) <Distance>:

5. At the prompt, do one of the following:
   - Type N, and then the number of vertices to add.
   - Type M, and then the mid-ordinate distance.
   - Type D, and then the distance between each vertex.

   The following prompt is displayed:

   Erase old object (Yes/No) <Yes>:

6. At this prompt, press ENTER to erase the old polyline. You can also type No to keep the old polyline.
NOTE
If you do not erase the old polyline, then you may have trouble selecting the new polyline definition because there are now two objects in the same location.

The following illustration is an example of the Add Vertices command:

![Add vertices](image)

**Calculating Daylight Points Based on Multiple Slopes**

The Create Multiple command on the Daylighting submenu reads your footprint polyline and calculates daylight information based on the slopes and daylight surface you have specified. You can specify the fill slope and cut slope at each individual vertex of the entity you select, as well as transition from one slope to another over multiple vertexes on the entity. When the command calculates the daylight information, it does not add anything to your drawing. Rather, it stores the calculated daylight data within the entity you selected.

For a more accurate daylight line definition, you can add additional vertices to the polyline footprint with the Add Vertices command. Daylight points are calculated from each vertex, so the closer they are together, the better the definition is.

To calculate the locations of daylight points using multiple slopes

1. Select the current daylight surface.
   For more information, see “Selecting the Daylight Surface” in this chapter.
2. Use the Add Vertices command to add vertices to the polyline to provide more information for the daylight calculation.
3. From the Grading menu, choose Daylighting ➤ Create Multiple.
4. Select the polyline.
5. Select the side of the polyline to place the daylight points on. A temporary arrow is displayed indicating the daylight point offset direction for the current polyline vertex.

   The following prompt is displayed:

   Enter cut (or Grade) <2.00:1>: 
At this prompt, specify the cut grade or slope for the first vertex using one of
the following methods:

- Type a slope in the format indicated.
- Type G and a grade.

Specify the fill grade or slope, using the same options in step 6.

The command calculates the daylight point for the first vertex on the polyline
you selected, and draws a temporary X to indicate the location of the daylight
point.

The following prompt is displayed:

```
Previous/Next/All/Indiv/Transition/Exit/Slope <Slope>:
```

The temporary arrow indicating the current vertex moves to the next vertex.

Define the cut and fill slope values for each vertex using the following options:

- **Slope:** You can enter new values for both cut and fill slopes. The command
  returns information about the vertex and daylight point elevations, along
  with the new slope, grade, and cut or fill condition. A daylight point is then
  located with an X, drawn as a temporary vector. The prompts continue and
  the temporary arrow advances to the next vertex.
- **Previous:** This option moves the current vertex to the previous vertex on the
  polyline.
- **Next:** This option moves the current vertex to the next vertex on the
  polyline.
- **All:** This option deletes all of the daylighting information that has been
  created so far in the command process.
- **Indiv:** This option deletes the daylighting information for the current vertex.
- **Transition:** You can use the Transition option in areas where you want to
  create a gradual transition from one slope to another between vertices. You
  can use this option to set beginning cut and fill slopes from one vertex and
  ending cut and fill slopes from a subsequent vertex. After you enter the
  ending cut and fill slopes, the command adjusts the cut and fill slopes
  automatically from the vertices between the beginning and ending vertices.

  After you enter the beginning cut and fill slopes, accept the default prompt
  for Next until you reach the ending vertex for the transition region. Type E
  to end the transition, then enter ending cut and fill slopes. Type X to exit
  back to the previous multiple slope prompts.
- **Exit:** Exits the command.

Continue to use the options listed in step 8 to define the slope at each vertex.

Press ENTER repeatedly to end the command.

**NOTE** The Xs that are placed in the drawing with this command indicate the
daylight points are temporary. You can use the REDRAW command to erase
them.

After the daylight match line has been calculated, you can use the Daylight
Points, Daylight Breaklines, Daylight Polyline, or the Daylight All command to
draw the daylight information in the drawing.

If a daylight point cannot be located for one or more vertices, it is because the
point cannot be found based on the vertex elevation and slope information you
have specified. To correct this, you can vary the slope, or adjust the elevation or location of the polyline footprint. You may also need to add additional data to the surface definition.

The following illustration shows an example of how daylight points are located by the Create Multiple command:

![Daylight points based on multiple slopes](image)

### Calculating Daylight Points Based on a Single Slope

The Create Single command on the Daylighting submenu reads the X, Y, and Z coordinates of your footprint polyline and calculates daylight information based on the slopes and daylight surface that you have specified. This command applies a single fill slope and a single cut slope at every vertex on the entity you select. When the command calculates the daylight information, it does not add anything to your drawing. Rather, it stores the calculated daylight data within the entity you select.

For a more accurate daylight line definition, you can add additional vertices to the polyline footprint with the Add Vertices command. Daylight points are calculated from each vertex, so the closer they are together, the better the definition is.

**To calculate the location of daylight points using a single slope**

1. Select the current daylight surface. For more information, see “Selecting the Daylight Surface” in this chapter.
2. Use the Add Vertices command to add vertices to the polyline to provide more information for the daylight calculation.
3. From the Grading menu, choose Daylighting ➤ Create Single.
4. Select the polyline.
5. Select the side of the polyline to place the daylight points on.
6. The following prompt is displayed:

   Enter cut (or Grade) <2.00:1>:

6. At this prompt, specify the cut grade or slope using one of the following methods:
   - Type a slope in the format indicated.
   - Type G and a grade.
Specify the fill grade or slope, using the same options in step 6.

The command calculates the daylight points for each vertex on the polyline you selected, and draws temporary Xs to indicate the locations of the points. It stores the daylight information within the entity you selected.

**NOTE** The Xs that are placed in the drawing with this command indicate the daylight points are temporary. You can use the REDRAW command to erase them.

After the daylight match line has been calculated, you can use the Daylight Points, Daylight Breaklines, Daylight Polyline, or the Daylight All command to draw the daylight information in the drawing.

If a daylight point cannot be located for one or more vertices, it is because the point cannot be found based on the vertex elevation and slope information you have specified. To correct this, you can vary the slope, or adjust the elevation or location of the polyline footprint. You may also need to add additional data to the surface definition.

The following illustration is an example of how daylight points are located by the Create Single command:

![Daylight points based on a single slope](image)

**Inserting Daylight Points in the Drawing**

After you have applied Single or Multiple slope criteria, you can create COGO points with elevations that are added to the drawing and point database. These points are inserted at each vertex on the polyline and at each daylight point, using the current point settings. You are also prompted to place intermediate points between the polyline vertices and their associated daylight points.

After the points are created, you can add them to a point group and use them in Terrain Model Explorer to generate a surface. If necessary, you can add additional points to better define the area within the polyline footprint.

**To insert daylight points in a drawing**

1. Use the Create Multiple or Create Single command to calculate daylighting for a polyline using multiple or single slopes.
2. From the Grading menu, choose Daylighting ➤ Daylight Points.
3 Select the polyline.

The following prompt is displayed:

Enter number of intermediate points <0>:

4 At this prompt, enter a number of intermediate points between the polyline vertices and the daylight points using one of the following methods:

- Type the number of points between the vertex and daylight point, and press ENTER.
- Type 0 to place just the daylight point, and press ENTER.

For each vertex, you are prompted for the number of points to insert.

**NOTE** If you cannot see the points on screen, then make sure that you have selected the Insert to Drawing as Created check box in the Point Settings dialog box.

The following illustration shows how points are added between polyline vertices and daylight points:

![Insert daylight points in drawing](image)

**Creating Breaklines Between Vertices and Daylight Points**

To create a more accurate surface with the daylight information, you can create breaklines that project from the polyline vertices to their associated daylight points for a selected surface. This command creates a breakline for each vertex that has a calculated daylight point. The surface to which the breakline data will be sent must already exist within Terrain Model Explorer, but does not have to be built.

**To create daylight breaklines**

1 Use the Create Multiple or Create Single command to calculate daylighting for a polyline using multiple or single slopes.

For more information, see “Calculating Daylight Points Based on a Single Slope” and “Calculating Daylight Points Based on Multiple Slopes” in this chapter.

2 From the Grading menu, choose Daylighting ➤ Daylight Breaklines to display the Select Surface dialog box.

3 Select the surface name to send the daylight breakline data to, and click OK.
4 Select the polyline.

The command then creates breaklines between the polyline vertices and daylight points, displaying the X,Y,Z coordinates of the end points of each breakline as well as the color of the line.

**NOTE** The breaklines created with this command are not placed into the drawing. You can import the breaklines into the drawing by using the Import Breaklines command in the Terrain Model Explorer.

The polyline footprint and the daylight line can also be defined as breaklines using the Terrain Model Explorer, but this isn’t necessary if the vertex spacing is close together.

The following illustration shows how breaklines are created between the polyline vertices and their daylight points:

![Create breaklines between vertices and daylight points](image)

**Drawing a Daylight Polyline**

You can draw the resultant daylight polyline that connects the daylight points. This is a 3D polyline that represents the match line of the slopes to the surface. It can be used as a breakline and/or a border in surface definition. It can also be used to represent a work limit line.

**To draw a daylight polyline**

1 Use the Create Multiple or Create Single command to calculate daylighting for a polyline using multiple or single slopes.

For more information, see “Calculating Daylight Points Based on a Single Slope” and “Calculating Daylight Points Based on Multiple Slopes” in this chapter.

2 From the Grading menu, choose Daylighting ➤ Daylight Polyline.

The command draws the polyline connecting the daylight points. If there are gaps in the polyline, these are regions where the slopes could not match into the surface.
Inserting Daylight Points, Breaklines, and Polylines into a Drawing

You can insert daylight points, breaklines, and polylines into a drawing simultaneously. The Daylight All command is a combination of the Daylight Points, Daylight Breaklines, and Daylight Polyline commands.

To insert daylight points, breaklines, and polylines

1. Use the Create Multiple or Create Single command to calculate daylighting for a polyline using multiple or single slopes.
   For more information, see “Calculating Daylight Points Based on a Single Slope” and “Calculating Daylight Points Based on Multiple Slopes” in this chapter.

2. From the Grading menu, choose Daylighting ➤ Daylight All to display the Select Surface dialog box.

3. Select the surface to use for the daylight breaklines and click then OK.

4. Select the polyline.

5. Enter the number of intermediate points between each vertex and daylight.

6. Select the name of the surface to send the breakline data to.

**NOTE**
The breaklines created with this command are not placed into the drawing. You can import the breaklines into the drawing by using the Import Breaklines command in the Terrain Model Explorer.

The following illustration indicates the daylight features that can be brought into a drawing by the Daylight All command:

![Example of the daylight all command](image_url)

Listing the Grading Factors of a Selected Point

You can list the elevation of a selected point, as well as the current surface elevation, the difference between the point and surface elevation, and whether the selected point is in a cut or fill condition. Use Object Snaps to select entities and retrieve their elevations.
To list the grading factors of a point

1. From the Grading menu, choose Daylighting ➤ List Random Elev. If no surface is current, the Select Surface dialog box is displayed.
2. Select the surface you want to make current.
3. Select the locations in the drawing to list.

**NOTE** The points selected can be snapped to any AutoCAD entity to retrieve an X,Y,Z coordinate to compare to the current surface. For more information, see “Modifying Point Elevations” in this chapter.

Information similar to the following is displayed:

4. Press ENTER to end the command.

**Creating a Random Daylight Point**

You can create a single daylight point from any location in your drawing, rather than using a polyline.

**To create a daylight point**

1. From the Grading menu, choose Daylighting ➤ Random Daylight.
2. Select the point from which the daylight point will be located. You can enter .G or .P to reference a COGO point, or you can use Object Snaps to accurately select an elevation from an object in the drawing.
3. Select the direction of the point from which the slope or grade will be calculated.
   The elevation of the point you selected is displayed.
4. Press ENTER to accept the elevation, or type a new value.
   The following prompts are displayed:

   Enter cut Slope (or Grade) <2.00:1>:
   Enter fill Slope (or Grade) <3.33:1>:

5. At these prompts, define the cut and fill slope or grade values using one of the following methods:
   - Type slopes in the format indicated.
   - Type G and grade percentages.
   The following prompt is displayed:

   Add interpolated points (Yes/No) <No>:

6. At this prompt, determine whether to add interpolated points between the selected point and the daylight point using one of the following methods:
   - Press ENTER to not add the interpolated points.
   - Type Yes to add interpolated points.
   If you typed Yes to add interpolated points, the following prompt is displayed:

   Enter the number of intermediate points <0>: 
7 Type the number of interpolated intermediate points.
8 Select another random point, or press ENTER to end the command.

The following illustration shows the Random Daylight command parameters:
Working with Ponds

The Grading menu contains a set of commands you can use to design and define ponds. Use these commands along with the pond calculation commands on the Hydrology menu to calculate required storage volumes for a pond, calculate routing values, and also add and edit outflow structures.

In this chapter

- Changing the pond settings
- Creating pond perimeters
- Defining ponds and pond slopes
- Shaping ponds
- Listing and labeling ponds
- Outputting pond data
- Routing ponds
- Adding and editing outlet structures
Overview of Working with Ponds

You can use the Ponds and Hydrology commands in Autodesk Civil Design to create and edit ponds and any type of water-retention structure.

Typically, the first step in a detention design is to use Runoff commands in the Hydrology menu to calculate the runoff from the watershed and to create the inflow hydrograph for the design storms.

You can estimate the size of detention pond you will need by using the Detention Basin Storage method. Based on your inflow runoff and your allowable peak discharge, this gives you a very good estimate for the size of the detention pond needed.

Next, you establish the preliminary pond location and size by drawing and editing the pond perimeter until the pond perimeter shape and size are satisfactory. The pond perimeter is a polyline, and you can calculate subsequent slopes from each vertex in the polyline.

There are four groups of commands on the Grading menu that you can use to define ponds and shape them:

- **Define Pond**: Use these commands to quickly name or rename a pond by selecting a polyline perimeter, to define the 3D pond geometry by selecting existing contours, or to delete a pond from the drawing. You can also define a pond when using the Pond Perimeter and Pond Slopes commands.

- **Pond Perimeter**: Use these commands to draw a pond perimeter, change its elevation, add vertices to the perimeter, fillet the perimeter, and save and import perimeter shapes.

- **Pond Slopes**: Use these commands to grade the bank of the pond. You can create a pond bank template to apply to the pond, or apply linear or multiple slopes to the bank. At the end of these commands, you are prompted to shape the pond (see below). If you respond No to this prompt, then you can use the Shape Pond commands to shape the pond later.

- **Shape Pond**: Use these commands after you have created the pond slope design. Shaping a pond creates the 3D pond data: the pond contours, the pond bottom, and the slope control lines (breaklines). A shaped pond is required when using the Hydrology commands because these commands depend on the 3D pond information. You can also use the Shape Pond commands on the Grading menu to shape a pond.

The next step in pond design is to do a preliminary design of the outflow structures. Then you can calculate routed hydrographs using the Storage Indication Method.

You can use the Storage Indication Method command to perform pond routing with multiple upstream ponds. This command uses a post-development hydrograph, stage-storage curve, and stage-discharge curve (as well as an optional pre-development hydrograph) to route runoff.
Changing the Pond Settings

When you shape a pond (either at the end of using the Pond Slopes commands or by using the Shape Ponds commands) contours, slope control lines, and the pond bottom are created in the drawing. You can use the Pond Settings commands on the Grading menu to change the contour and slope control line settings for the ponds in your drawing. In addition, you can establish bench settings so that as the pond is shaped, benches are created in the pond bank.

Changing the Contour Settings for Ponds

Use the Pond Settings ➤ Contours command to specify the methods of pond contour creation. Contours are created in the drawing when you shape the pond, either at the end of one of the Pond Slopes commands, or by using the Shape Pond commands.
To change the contour settings for ponds

1. From the Grading menu, choose Pond Settings ➤ Contours to display the Pond Contour Settings dialog box.

2. In the Contours section, choose one of the following methods for creating the contours:
   - Select Relative to draw contours at a specific distance below the pond perimeter. (Specify the distance with the Elevation setting.) For example, if the pond perimeter is at an elevation of 781.5 ft, and the Elevation setting is 2 ft, the nearest contour below the pond perimeter is created at 779.5 ft.
   - Select Absolute to draw contours at the nearest whole interval below the pond perimeter. (Specify the intervals with the Elevation setting.) For example, if the pond perimeter is at an elevation of 781.5 ft, and the Elevation setting is 2 ft, the nearest contour below the pond perimeter is at an elevation of 780.0 ft.

   **NOTE** The Relative and Absolute options are used only if the Elevation option is selected. For more information, see the Elevation option below.

   **TIP** Pond volumes are determined from the contours created for the pond. For more accurate pond volume calculations, the contour increment should be set to a maximum of 1'.

3. Configure the settings for either normal or highlighted contours:
   - Select Normal to draw a contour for every interval specified on the left side of the dialog box. (The settings on the left side of the dialog box affect how normal contours are created).
   - Select Highlight to draw a highlighted contour for every interval specified on the right side of the dialog box. (The settings on the right side affect how highlighted contours are created).
4 Type the layer names for the contours in the Layer boxes, or accept the default layers.

5 Specify the colors for the contours in the Contour color boxes. You can type a color number in the box, or you can click on the color tile and select a color from the standard color selection dialog box.

6 Specify how contours are created by selecting one of the following options:

- **Elevation**: Select this option to create contours at specified intervals. Enter the interval in the edit box to the right of the Elevation option. How the elevation is applied to the contours depends on whether you select the Relative or Absolute setting (see step 2). To create continuous contours (unsegmented), select the Continuous check box. If you clear the Continuous check box, and an elevation can't be found at a slope control line, then the contour will stop and start and become segmented, creating multiple contours at a single elevation.

- **Path Distance**: Select this option to create contours at specified intervals along the pond slope template that you apply to the pond. Enter the desired distance between contours in the box to the right of the Path Distance option. These distances are along the slope of the template you specify, not in the direct Z direction. For example, a distance of 5 feet along a template with 1.5:1 slopes will produce contours at a 3-foot interval in the Z direction, based on the 3-4-5 triangle rule. Therefore, it is difficult to create even-elevation contours with this option. Use this option only if you are using a template for slope control. For an illustration of the Path Distance setting, see “Path Distance Setting Illustration” at the end of this topic.

- **Slope Changes (normal contours only)**: Select this option to create contours based on the changes in the slope of a pond template that you apply to the pond. Use this option only if you are using a template for slope control. Do not use this option if the template you are using is one continuous slope because no contours will be created. For an illustration of the Slope Changes setting, see “Slope Changes Setting Illustration” at the end of this topic.

- **NOTE**: These settings are available only if the Normal and/or Highlight option(s) are selected.
7 Click OK.

The following illustration is an example of the Path Distance setting:

![Path distance setting](image)

The following illustration is an example of the Slope Changes setting:

![Slope changes setting](image)

**Changing the Slope Control Line Settings for Ponds**

Use the Pond Settings > Slope Control Lines command to determine pond slope control line settings such as the vertex setting, the layer, color, and line type. Slope control lines are created in the drawing when you shape the pond,
Changing the Pond Settings

either at the end of one of the Pond Slopes commands, or by using the Shape Pond commands.

Slope control lines act as breaklines. You can create a surface from a pond and use the slope control lines as breakline data, along with the pond contour data. Then you can paste the pond into your existing ground surface model.

**NOTE**  
Slope control lines are drawn as heavyweight polylines in the drawing.

**To change the slope control line settings for ponds**

1. From the Grading menu, choose Pond Settings ➤ Slope Control Lines to display the Pond Slope Control Settings dialog box.

2. In the Layer box, type the name of the layer on which the slope control lines will be drawn or accept the default.

3. In the Breakline color box, type a color number for the layer on which the slope control lines will be drawn, or click the colored tile and select a color from the standard Select Color dialog box.

4. Under Breakline type, specify how the vertices of the slope control lines are created:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create the vertices of the slope control lines where the slope control lines cross the normal contour lines</td>
<td>select Normal contours.</td>
</tr>
<tr>
<td>create the vertices of the slope control lines where the slope control lines cross the highlighted contour lines</td>
<td>select Highlighted contours.</td>
</tr>
<tr>
<td>create the vertices of the slope control lines where the slope changes in the pond bank</td>
<td>select Slope changes.</td>
</tr>
</tbody>
</table>

   These options allow for vertices to be placed on the slope control lines where they cross either a normal contour, a highlighted contour, or only at slope changes in the pond banks.
5 Select the Draw to Bottom polyline check box to extend slope control lines to the polyline that represents the bottom of the pond. Clear this check box to end the slope control lines at the lowest pond contour.

6 Click OK.

The following illustration is an example of pond slope control lines:

![Pond slope control lines](image)

**Changing the Bench Settings for Ponds**

To create ponds with benches, use the Pond Settings ➤ Benches command. Use this command to enable benching and to configure the bench depth, slope, and width. Benches can be used to specify deviations in bank slopes when a template is not used.

Benching is performed from the perimeter of the pond all the way to the pond bottom.

**NOTE** Benches are not created when you apply a template to a pond.

**To change the bench settings for ponds**

1 From the Grading menu, choose Pond Settings ➤ Benches to display the Benching Settings dialog box.
2 Under Benching, select the check box to turn on benching. When this check box is selected, benches are created in the pond bank when you shape a pond.

3 In the Slope box, enter the grade for each bench. By default, the value is 0.0001. This value simulates a flat bench. Use this number instead of zero to define a flat bench.

The equivalent slope ratio may also be entered to specify the slope. For example, enter 3:1 into the slope box and press ENTER. The slope is automatically converted to the equivalent grade value of .333. You can also click the Select button and choose the slope from your drawing.

4 In the Depth box, enter the depth for each bench.

You can also click the Select button and choose the depth from your drawing.

5 In the Width box, enter the width for each bench. You can also click the Select button and choose the width from your drawing.

6 Click OK.

---

**Creating Pond Perimeters**

To establish the perimeter of your pond, you can draw the perimeter with a 2D or 3D polyline command, or you can use the Pond Perimeter commands on the Grading menu.

The pond perimeter is a polyline, and slopes can be calculated from each vertex in the polyline. You can add vertices to a pond perimeter for greater accuracy, and you can fillet the perimeter to create pond shapes with rounded corners.

**NOTE**
To shape a pond, the pond perimeter must contain 3 or more vertices.

If you create a pond perimeter that you intend on using often, you can save the pond perimeter geometry as an external file that you can import into a drawing.

**Drawing a Pond Perimeter**

Unless you are defining a pond from existing contours, you must create a perimeter for the pond you are designing. You can use a 2D or 3D polyline command to draw the pond perimeter, or you can use the Pond Perimeter ➤ Draw command to draw the perimeter (as a 3D polyline), assign an elevation to it, and define the perimeter as a pond.

**NOTE**
You can only draw straight line segments when using the Draw command. However, to create curved segments, you can use the Pond Perimeter ➤ Fillet command after drawing the perimeter.

**NOTE**
When you use the Draw command, a <pond name>.pnd file is created in the c:\Land Projects R2\<project name>\hd folder. This file stores the pond perimeter length, the area, and the elevation of the perimeter.
To draw a pond perimeter

1. From the Grading menu, choose Pond Perimeter ➤ Draw to display the Pond Name dialog box.

![Pond Name dialog box]

2. In the Pond Name text box, type a name for the pond, and then click OK. The following prompt is displayed:

   eXit/Elevation <0.0000 ft>:

3. Type an elevation for the pond perimeter, and then press ENTER. You are prompted to select a point in the drawing.

4. Select the start point for the pond. The following prompt is displayed:

   Endpoint of line (Close/Undo):

5. Continue to select points until you are ready to close the polyline, and then type Close to join the start point of the pond with the endpoint.

   **TIP** Type Undo to undo the last segment you drew.

Changing the Elevation of a Pond Perimeter

Use the Change Elevation command to change the elevation of a pond perimeter. If you have already created the pond slope information and shaped the pond, then the Change Elevation command applies the change in the perimeter elevation to all of the pond contours.

**NOTE** You can only use this command on defined ponds.

To change the elevation of a pond perimeter

1. From the Grading menu, choose Pond Perimeter ➤ Change Elevation. The following prompt is displayed:

   Select polyline:

2. Do one of the following to select the pond perimeter:

   - Select the pond perimeter in the drawing.
   - Press ENTER to display the Pond Name dialog box, select a pond name, and then click OK.

   A prompt similar to the following is displayed:

   Elevation (ft) (eXit/Difference/Elevation) <100.0000>: 
3 Do one of the following to change the elevation:
   - Type **Elevation**, and then type the new elevation for the pond perimeter.
   - Type **Difference**, and then type the elevational difference to apply to the perimeter. For example, if you type 10, then ten feet are added to the elevation of the perimeter.
   - Type **eXit** to end the command without changing the pond elevation.

The pond's new elevation is displayed at the command line.

**Adding Vertices to a Pond Perimeter**

The more vertices you assign to a pond perimeter, the more slope control lines are created for the pond when you shape the pond. You can use the slope control lines as breakline data when you define the pond as a surface.

Use the Pond Perimeter ➤ Add Vertices command to add vertices to the pond perimeter at a specified interval. You can use this command to add vertices to straight-line pond perimeters or to curved pond perimeters. You can add vertices to 2D or 3D polylines.

**NOTE**
This command removes all extended entity data for an existing pond. This means that the pond loses its definition and any shaping data applied to it. You must re-create the pond slope data after using this command.

**To add vertices to a pond perimeter**

1 From the Grading menu, choose Pond Perimeter ➤ Add Vertices to display the Confirmation dialog box.

   ![Confirmation dialog box]

2 Click Yes to erase all extended entity data, or No to end the command.

   When you click Yes, the following prompt is displayed:

   `Select (Entity/OPoints):`

3 Do one of the following to select the perimeter:
   - Type **OPoints** to select the perimeter by selecting points.
   - Type **Entity** to select the perimeter by clicking on the entity.

   For more information, see “Adding Vertices By Entity Option” in this chapter.

**Adding Vertices By Points Option**

**To add vertices using the Points option**

1 Select the start and end points of the polyline segment.

   The following prompt is displayed:

   `Distance to set additional tangent vertices <59.5445 m>:`
2 Type a distance or select two points in the drawing to define the distance.
The following prompt is displayed:
First elevation <0.0000 m>:

3 Type the elevation of the first vertex on the perimeter you selected.
The following prompt is displayed:
Second elevation <0.0000 m>:

4 Type the elevation of the last vertex on the perimeter. A new polyline is then
drawn, and the elevation of the polyline is interpolated between the two
elevations you specified.

5 Select another pond perimeter that you want to add vertices to, or press ENTER
to end the command.

**Adding Vertices By Entity Option**

**To add vertices using the Entity option**

1 Select the polyline.
The following prompt is displayed:
Distance to set additional tangent vertices <3.0000 m>:

2 Type a distance or select two points in the drawing to define the distance.
The following prompt is displayed:
Additional curve vertices by (Number/Mid-ordinate/Distance) <Distance>:

3 Do one of the following to define how additional vertices are created on curves:
   - Type **Distance**, and then type a distance or select two points in the drawing
to define the distance.
   - Type **Number**, and then type the number of vertices you want to add to the
curve segments.
   - Type **Mid-ordinate** to add vertices based on the mid-ordinate distance of the
curve.

   **NOTE** This prompt is displayed whether or not there are curves in the pond
   perimeter.

The following prompt is displayed:
Erase old entity? <Yes>:

4 Type **Yes** or press ENTER to erase the old entity, or type **No** to keep the old
entity.

5 Select another pond perimeter that you want to add vertices to, or press ENTER
to end the command.

   **NOTE** The first time you run this command on a selected perimeter, all of the
prompts described in this topic are displayed. However, the second time
you run this command, you are only prompted for a distance to add
additional vertices. You are not prompted to define how additional curve
vertices are created.
In the following illustration, the mid-ordinate of an arc is labeled MC:

![Diagram of pond perimeter with labeled mid-ordinate MC]

**Filleting a Pond Perimeter**

When you draw a pond perimeter using the Pond Perimeter ➤ Draw command, you can only create straight line segments. Use the Pond Perimeter ➤ Fillet command to fillet (round) the pond perimeter at vertices that you select.

**NOTE**
This command removes all extended entity data for an existing pond. This means that the pond loses its definition and any shaping data applied to it. You must re-create the pond slope data after using this command.

**NOTE**
The polyline you fillet must be a 3D polyline. You can use the Convert 2D to 3D command to convert an existing 2D polyline to a 3D polyline. Ponds that you draw with the Pond Perimeter ➤ Draw command are 3D polylines.

**To fillet a pond perimeter**

1. From the Grading menu, choose Pond Perimeter ➤ Fillet to display the Confirmation dialog box.
2. Click Yes to erase all extended entity data, or No to end the command.
   
   When you click Yes, the following prompt is displayed:
   
   Fillet radius <0.0000 ft>:
   
3. Type a fillet radius and press ENTER, or select two points in the drawing to define the radius distance.
   
   A prompt similar to the following is displayed:
   
   Maximum distance to set additional curve vertices <10.0000 ft>: 
   
   Creating Pond Perimeters

95
4 Type the distance at which to set additional curve vertices, or select two points in the drawing to define the distance.

You are then prompted to select the pond perimeter and the vertex you want to fillet.

5 Select the polyline that represents the pond perimeter, and then select the vertex as prompted. The corner is filleted.

6 Select another vertex to fillet, or press ENTER to continue.

You are then prompted to erase the original pond perimeter.

7 Type Yes to erase the original pond perimeter and continue. You can type No to leave the original perimeter in the drawing.

8 Select another pond perimeter to fillet, or press ENTER to end the command.

9 Type Redraw to remove the temporary lines on screen.

**Converting a 2D Pond Perimeter to 3D**

To fillet a polyline, it must be a 3D polyline. Use the Convert 2D to 3D command to convert 2D polylines to 3D polylines.

---

**NOTE**

This command changes light-weight polylines to heavy-weight polylines.

---

**To change a 2D polyline into a 3D polyline**

1 From the Grading menu, choose Pond Perimeter ➤ Convert 2D to 3D.

The following prompt is displayed:

Select by Layer (Selection/Layer):

2 Do one of the following to select a polyline:

- Type Selection, press ENTER, and then select the polyline(s) that you want to convert.
- Type Layer, press ENTER, and then select the polyline on the layer that you want to select.

3 Press ENTER to convert the 2D pond perimeter to 3D and exit the command.
Converting a 3D Pond Perimeter to 2D

You can flatten a 3D polyline by using the Convert 3D to 2D command. This command changes the elevations of the 3D polyline vertices to zero.

To change a 3D polyline into a 2D polyline

1. From the Grading menu, choose Pond Perimeter ➤ Convert 3D to 2D.

   The following prompt is displayed:
   
   Select by Layer (Selection/Layer):

2. Do one of the following to select a polyline:
   - Type Selection, press ENTER, and then select the polyline(s) that you want to convert.
   - Type Layer, press ENTER, and then select the polyline on the layer that you want to select.

3. Press ENTER to convert the 3D pond perimeter to 2D and exit the command.

Saving a Pond Perimeter

To store the geometry of a pond perimeter, you can use the Save Perimeter command. This is a good practice in case you make a mistake on your current pond perimeter and have to redraw it. You can use the Import Perimeter command to import a saved perimeter into the drawing.

This command creates a <pond perimeter name>.psp file in the c:\Land Projects R2\<project name>\hd folder.

WARNING! This file stores only the pond perimeter geometry, and does not store the pond slope data. Pond slope data cannot be re-imported into a drawing; it must be recreated from the pond perimeter.

To save a pond perimeter

1. From the Grading menu, choose Pond Perimeter ➤ Save Perimeter.

   The following prompt is displayed:
   
   Select polyline:

2. Select the pond perimeter in the drawing.

   The Create Pond Shape dialog box is displayed.

3. Type a name for the pond perimeter file.

4. Click OK to save the pond perimeter.
Importing the Existing Pond Perimeter Shapes

If you have saved a pond perimeter with the Save Perimeter command, then you can import the pond perimeter geometry into the drawing and define a pond from it.

To import existing pond perimeter shapes

1. From the Grading menu, choose Pond Perimeter ➤ Import Perimeter to display the Import Pond Shape dialog box.

   ![Import Pond Shape dialog box]

   **NOTE** If there are no pond shapes to import, an Error Message dialog box displays with the message that no files were found.

2. From the Selection list box, select the pond you want to import.

   You can also type the pond name in the Name box. A preview of the selected shape appears to the right of the Selection list.

   The Maximum width and Maximum length labels display the width and length of the currently selected perimeter shape.

   **NOTE** You can delete a pond perimeter shape by picking its name and clicking the Delete button. You are prompted to confirm the deletion.

3. Click OK.

4. Select an insertion point in your drawing for the pond.

   **NOTE** The insertion point is the lower-left corner of the perimeter’s bounding rectangle.

5. Type the elevation for the pond perimeter.

   The pond perimeter is inserted into your drawing as a 3D polyline at the elevation you specified.
Defining Ponds

You can use the Define Pond commands on the Grading menu to define your pond perimeter from an existing polyline, or to define the 3D pond information from existing contours.

The Define Pond ➤ By Polyline command names a pond that you can then select when you are using the Pond Slopes command to define the pond slope information. Use this command in place of the Pond Perimeter commands if you have an existing polyline in your drawing that you want to use as the pond perimeter.

You can also use the By Polyline command to rename an existing pond or define a new pond from an existing pond.

The Define Pond ➤ By Contours command defines existing contours as a pond. The contours you select provide all the data required for creating a pond perimeter, pond slope, and a pond bottom. This command is especially useful if you have an area of depression contours that you want to use as a natural basin structure.

Defining a Pond Perimeter from a Polyline

Use the By Polyline command to create a pond definition from an existing polyline in your drawing. You can use this command in place of using the Pond Perimeter commands. This command names the pond and creates a <pond name>.pnd file in the c:\Land Projects R2\<project name>\hd folder.

To define a pond perimeter from an existing polyline

1. From the Grading menu, choose Define Pond ➤ By Polyline.
   The following prompt is displayed:
   Select polyline:

   **NOTE** Splined polylines are not supported.

2. Select the pond perimeter polyline to display the Pond Name dialog box.

3. In the Pond Name box, enter a name for the pond (up to 8 characters).
4. Click OK to save the pond.

**NOTE** Once .sdb and .dbf files are created using AutoCAD Land Development Desktop Release 2, they may not be used with any earlier version of the Desktop.
Defining a Pond Perimeter from Contours

You can use the By Contours command to base the pond geometry on contours that exist in your drawing, such as contours that represent a natural depression. You can use contours that were generated from a surface or a grading object, or you can use contours that you've drawn using the grading tools. Contour increments should typically not be greater than 1 foot for accurate pond volume calculations, and contours should not contain arcs.

The By Contours command creates all the necessary 3D pond information from the contours you select. The contour with the highest elevation is used as the pond perimeter; the contour with the lowest elevation is used as the pond bottom.

This command creates a <pond name>.pnd file in the c:\Land Projects R2\<project name>\hd folder.

To define a pond perimeter from contours

1. From the Grading menu, choose Define Pond ➤ By Contours to display the Pond Name dialog box.
2. In the Pond Name text box, type a name for the pond (up to 8 characters), and then click OK.
   The following prompt is displayed:
   Select by Layer/<Selection>:

3. Do one of the following to select the contours:
   - Type Selection, press ENTER, and then select the contour(s) that you want to define as the pond.
   - Type Layer, press ENTER, and then select a contour on the layer that you want to select.

4. Press ENTER.
   If you select a contour object, instead of a polyline, then the following prompt is displayed:
   Selection contains Contour entities. Convert? <Yes>:

5. Type Yes to change the contour objects into 3D polylines and add the pond information to them. If you type No, then the command ends and the pond is not defined.

6. Press ENTER to end the command.

Deleting Ponds

Use the Delete Pond command to selectively delete pond elements from your drawing, and to delete the pond definition file or the pond outflow file from the project folder.

When you define a pond, the pond definition data is stored in an external file, <pond name>.pnd, in the c:\Land Projects R2\<project name>\hd folder. This file contains elevation, area, and perimeter data for each pond contour. When you delete a pond, you can choose to delete this file, or to delete the pond rim (perimeter) data, the contours, the slope control lines, the bottom polyline, the outflow file, or all pond elements.
NOTE  The option to delete the outflow file, <pond name>.pda, is available if you used the Pond Outflow Design dialog box to design the pond inflow and outflow structures.

When you select a pond to delete, some of the delete options are not available. For example, when you define a pond from existing contours, you can only choose to delete the pond file. If you define a pond by using the Pond Slopes commands, more pond data is created, and, therefore, more of the pond deletion options are available.

If you delete the pond contours, slope control lines, or bottom polyline, you can recreate these elements by using the Shape Pond commands.

WARNING!  Be careful when choosing to delete the pond files or the pond rim (perimeter). If you use the From File option to delete the pond .pda file, you cannot use the Hydrology commands with the pond. The pond perimeter stores the pond shape information, and if you delete the perimeter, you will have to re-create the pond slope data.

To delete pond elements

1  From the Grading menu, choose Define Pond ➤ Delete Pond.

The following prompt is displayed:

Select polyline:

2  Do one of the following to select the pond perimeter:

- Select the pond perimeter in the drawing.
- Press ENTER to display the Pond Name dialog box, select a pond name, and click OK.

The Delete Pond dialog box is displayed.
3 Select the appropriate check boxes for the elements you want to delete:

<table>
<thead>
<tr>
<th>If you want to delete</th>
<th>Then select…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the pond perimeter from the drawing</td>
<td>Pond Rim.</td>
</tr>
<tr>
<td>the pond contours from the drawing</td>
<td>Contours.</td>
</tr>
<tr>
<td>the pond slope control lines (breaklines)</td>
<td>Slope Control Lines.</td>
</tr>
<tr>
<td>the pond bottom</td>
<td>Bottom Polyline.</td>
</tr>
<tr>
<td>the pond .pnd file that stores the elevation, area, and perimeter data for each contour</td>
<td>From File.</td>
</tr>
<tr>
<td>the pond .pda file that stores inflow and outflow structure data</td>
<td>Outflow File.</td>
</tr>
<tr>
<td>all pond elements</td>
<td>All.</td>
</tr>
</tbody>
</table>

4 Click OK to delete the selected pond elements and exit the command.

**Defining Pond Slopes**

Once you establish a pond perimeter, you can design the pond slopes in a variety of ways.

- You can apply single or multiple slopes or grades to the pond perimeter.
- You can design the pond slopes based on a known required volume. This is useful if you use the Detention Basin Storage command to compute the required storage volume.
- You can also design pond slopes with a template that represents the pond bank. A pond slope template works similarly to a Civil Design roadway template. You draw a cross-sectional view of the pond bank, save it to a file, and then apply it to the pond.

Pond slope, elevation, and depth data is referred to as “pattern” data. Each pond vertex stores its own pattern data. Pattern data is created when you use the Pond Slope commands to design the slope of the pond bank. If you want to remove the pond pattern data from one or more vertices on a pond, then you can use the Reset Patterns command. You can also reset the patterns on selected pond vertices when using the Linear-Multiple command.

**NOTE**

At the end of using the Pond Slopes commands (except the Linear – Multiple command and the Template – Multiple command), you are prompted to shape the pond. If you choose to shape the pond, then pond contours, the pond bottom, and the pond slope control lines are created in the drawing. A shaped pond is required for some of the Hydrology commands. If you choose not to shape the pond at the end of a Pond Slopes command, then you can use the commands in the Shape Pond menu to shape the pond.
Applying a Linear Slope to a Pond

Use the Pond Slopes ➤ Linear command to define a linear slope for the pond and apply it to all the vertices of the pond perimeter. Use this command if you want the pond to have the same slope applied to every vertex.

Two variables are required for this command. You can specify the pond’s elevation, depth, or create daylight lines; and you must specify the slope or grade.

**NOTE**
You can use this command on defined ponds as well as on polylines. If you use it with a shaped pond, then you are prompted to overwrite the pond rim information. The pond rim information is the data that is created by shaping the pond (contours, bottom, and slope control lines).

To apply a linear slope to a pond

1. Draw a pond perimeter. For more information, see “Drawing a Pond Perimeter” in this chapter.
2. From the Grading menu, choose Pond Slopes ➤ Linear.

   The following prompt is displayed:
   
   Select polyline:

3. Select the pond perimeter from your drawing.

   The Pond Name dialog box is displayed. If the pond is named (defined), then the pond name appears in the Pond Name box. If the pond is not named, then the name field is blank. Type a name for the pond.
4. Click OK.

**NOTE**
If you selected an existing pond that has already been shaped, then a message is displayed asking if you want to overwrite the existing pond rim information. You must click Yes to continue the command.

Next, you are prompted to select an offset side.
5 Pick a point inside or outside the pond.

The following prompt is displayed:

Pond elevation <elevation>
dePth (ft) (eXit/Daylight/Elevation/dePth) <0.0000>:

6 Calculate the pond bottom elevation:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then type...</th>
</tr>
</thead>
<tbody>
<tr>
<td>define the pond bottom by specifying a depth</td>
<td>depth, and then type the required pond depth.</td>
</tr>
<tr>
<td>define the pond bottom by specifying the bottom elevation</td>
<td>elevation, and then type the elevation of the pond bottom.</td>
</tr>
<tr>
<td>define the pond bottom by daylighting down to a TIN surface</td>
<td>daylight.</td>
</tr>
<tr>
<td></td>
<td>For more information, see “Defining the Pond Bottom By Using the Daylight Option” in this chapter.</td>
</tr>
</tbody>
</table>

The following prompt is displayed:

Slope-Grade/Slope/<1:1>:

7 Do one of the following to define the slope:

- Type G for Grade and enter a grade value (e.g., 5.00).
- Type S for Slope and enter a ratio (e.g., 20:1).

After you define the slope, the slope pattern is generated. For more information, see “Defining Pond Slopes.”

The following prompts are displayed:

Slope: 20.0000:1, Grade: 5.0000%
Linear slopes attached to all vertices successfully.
Shape Pond - All? <Yes>:

8 Type Yes to import the pond contours, bottom polyline, and slope control lines automatically, or type No to end the command.

If you choose to shape the pond, then the following prompt is displayed:

Close contour lines? Yes/No: <Yes>:

9 Type Yes to create closed contour lines, or type No to draw contours that skip the last segment of the perimeter.

The following prompts are displayed:

Slope: 20.0000:1, Grade: 5.0000%
Linear slopes attached to all vertices successfully.
Shape Pond - All? <Yes>:

NOTE If the Pond Contour Settings are set up to create both normal and highlight contours, then the close contour lines prompt is displayed twice.
Defining the Pond Bottom by Using the Daylight Option

When you select the daylight option, the Select Surface dialog box is displayed. The project must contain a surface in order to use the daylight option.

1. Follow steps 1–6 in “Applying a Linear Slope to a Pond” in this chapter.
2. Select the surface you want the pond perimeter to daylight to, and then click OK.

The following prompt is displayed:

Slope - Grade/Slope/<1.0000:1>:

3. Do one of the following to define the slope or grade:
   - Type G for Grade and enter a grade value (e.g., 5.00).
   - Type S for Slope and enter a ratio (e.g., 20:1).

   After you define the slope, the slope pattern is generated and the following prompts are displayed:

Slope: 20.0000:1, Grade: 5.0000%
Linear slopes attached to all vertices successfully.
Shape Pond - All? <Yes>:

4. Type Yes to import the pond contours, bottom polyline, and slope control lines automatically, or type No to end the command.

   If you choose to shape the pond, then the following prompt is displayed:

Close contour lines? Yes/No: <Yes>:

5. Type Yes to create closed contour lines, or type No to draw contours that skip the last segment of the perimeter.

   NOTE: If the Pond Contour Settings are set up to create both normal and highlight contours, then the close contour lines prompt is displayed twice.

When you use the Daylight option, pond contours and a daylight line are created for the pond. The daylight line is created on the normal contour layer. The daylight line is the lowest contour-looking object that goes entirely around the pond. When you use the LIST command to list its properties, you can see that its vertices are created at different elevations.

Often, the pond contours that are created do not go all the way around the pond. This is because the contours stop when they fail to cross a slope control line at the same elevation. If you select the option to close contour lines, then these contours close back to their start points.

Applying a Slope to a Pond By Specifying the Required Pond Volume

If you know the required storage volume for a detention/retention pond, then you can use this volume to create the pond slope design.

   NOTE: Use the Detention Basin Storage command to determine the required storage volume for a pond based on one or more inflow hydrographs.
To apply slope to a pond by specifying the required pond volume and the pond slope

1. Draw a pond perimeter and calculate the required storage volume for the pond.

2. From the Grading menu, choose Pond Slopes ▶ By Volume.
   The following prompt is displayed:
   
   Select polyline:

3. Select the pond perimeter from your drawing.

   The Pond Name dialog box is displayed. If the pond is named (defined), then the pond name appears in the Pond Name box. If the pond is not named, then the name field is blank. Type a name for the pond.

4. Click OK.

   **NOTE** If you selected an existing pond that has already been shaped, then a message is displayed asking if you want to overwrite the existing pond rim information. You must click Yes to continue the command.

Next, you are prompted to select an offset side.

5. Pick a point inside or outside the pond.

   The following prompt is displayed:
   
   Volume <0.0000 ft³>:

6. Type a volume for the pond.

   The following prompt is displayed:
   
   Slope-Grade/Slope/<1:1>:

7. Do one of the following to define the slope:
   
   - Type G for Grade and enter a grade value (e.g., 5.00%).
   - Type S for Slope and enter a ratio (e.g., 20:1).

   After you define the slope, the depth tolerance is calculated and displayed as follows:
   
   Depth tolerance <0.0833 m>:

   The depth tolerance is the accuracy that is used for calculating the bottom contour elevation. The lower the depth tolerance, the closer the calculation of the final volume will be to the entered volume.

8. Accept the default Depth tolerance value or type a new value.

   The final bottom elevation is displayed at the command line, and the following prompt is displayed:
   
   Shape pond - All? <Yes>/No:

9. Type Yes to import the contours, bottom polyline, and slope control lines automatically, or type No to end the command.

   If you choose to shape the pond, then the following prompt is displayed:
   
   Close contour lines? Yes/No: <Yes>:

10. Type Yes to create closed contour lines, or type No to draw contours that skip the last segment of the perimeter.
NOTE: If the Pond Contour Settings are set up to create both normal and highlight contours, then the close contour lines prompt is displayed twice.

Applying Multiple Linear Slopes to a Pond

Use the Linear-Multiple command to apply different slopes to selected pond perimeter polyline vertices.

You can use this command on defined ponds as well as on polylines. If you use it with a shaped pond, then you are prompted to overwrite the pond rim information. The pond rim information is the data that is created by shaping the pond (contours, bottom, and slope control lines).

NOTE: At the end of this command, you are not prompted to shape the pond, unlike the other Pond Slopes commands. Use the commands in the Shape Pond menu to import the pond contours, slope control lines, and pond bottom into the drawing.

NOTE: Make sure that the Elevation setting is selected in the Contour Settings dialog box when you use this command. You cannot generate pond contours if the Path Distance or Slope Changes option is selected in the Contour Settings dialog box.

To apply multiple linear slopes to a pond

1. From the Grading menu, choose Pond Slopes ➤ Linear – Multiple.

   The following prompt is displayed:

   Select polyline:

2. Select the pond perimeter from your drawing.

   The Pond Name dialog box is displayed. If the pond is named (defined), then the pond name appears in the Pond Name box. If the pond is not named, then the name field is blank. Type a name for the pond.

3. Click OK.

   NOTE: If you selected an existing pond that has already been shaped, then a message is displayed asking if you want to overwrite the existing pond rim information. You must click Yes to continue the command.

Next, you are prompted to select an offset side.

4. Select a point inside or outside the pond.

   Several informational prompts are displayed, and then an arrow indicates the current vertex. If no pattern data (slope, elevation, and depth data) is attached to the current vertex, then the following message is displayed:

   No Pattern data found

   The elevation of the current vertex is then displayed along with the following command options:

   Previous/Next/Reset/Transition/exit/Slope <Next>: 
5 Move to the vertex you want to assign slope data to by using the Next or Previous options.

6 Define the pond slope data for the selected vertex:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then type…</th>
</tr>
</thead>
<tbody>
<tr>
<td>define a slope at the vertex</td>
<td>Slope.</td>
</tr>
<tr>
<td></td>
<td>For more information, see “Applying Multiple Linear Slopes to a Pond – Slope Option” in this chapter.</td>
</tr>
<tr>
<td>create a transition region between two</td>
<td>Transition.</td>
</tr>
<tr>
<td>vertices that have different slopes</td>
<td></td>
</tr>
<tr>
<td>remove the existing slope, elevation,</td>
<td>Reset.</td>
</tr>
<tr>
<td>and depth data from a vertex</td>
<td>For more information, see “Applying Multiple Linear Slopes to a Pond – Reset Option” in this chapter.</td>
</tr>
</tbody>
</table>

Applying Multiple Linear Slopes to a Pond - Slope Option

To apply multiple linear slopes to a pond using the Slope option

1 Follow steps 1–6 of “Applying Multiple Linear Slopes to a Pond.”

When you select the Slope option, the following prompts are displayed:

Pond elevation <elevation>
Slope-Grade/Slope/<Infinite>:

2 Do one of the following to define the slope or grade:

- Type Grade and type a grade value (e.g., 6%)
- Type Slope and type a ratio (e.g., 3:1)
- Type Infinite to define a vertical bank.

The following prompt is displayed:

depth (ft) (exit/Daylight/Elevation/depth) <0.0000>:

3 Calculate the pond bottom from the selected vertex:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then type…</th>
</tr>
</thead>
<tbody>
<tr>
<td>define the pond bottom by specifying a depth</td>
<td>depth, and then type the required pond depth.</td>
</tr>
<tr>
<td>define the pond bottom by specifying the bottom elevation</td>
<td>elevation, and then type the elevation of the pond bottom.</td>
</tr>
<tr>
<td>define the pond bottom by daylighting down to a TIN surface</td>
<td>daylight.</td>
</tr>
</tbody>
</table>
The following data is displayed at the command line:

```
Point elev: -1.0000, Depth: 5.0000, Slope: 3.0000:1, Grade: 33.3333
```

**Applying Multiple Linear Slopes to a Pond - Reset Option**

To apply multiple linear slopes to a pond using the Reset option

1. Follow steps 1–6 of “Applying Multiple Linear Slopes to a Pond” in this chapter. When you select the Reset option, the following prompt is displayed:

   ```
   Reset (eXit/All/Individual/Multiple) <Individual>:
   ```

2. Reset the pattern data:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then type...</th>
</tr>
</thead>
<tbody>
<tr>
<td>remove the pattern data for all pond vertices</td>
<td>All.</td>
</tr>
<tr>
<td>select multiple vertices to reset</td>
<td>Multiple, and then use the Next or Previous options to select the vertices. Type End to finish.</td>
</tr>
<tr>
<td>remove the pattern data from the current vertex</td>
<td>Individual.</td>
</tr>
<tr>
<td>return to the previous set of prompts</td>
<td>eXit.</td>
</tr>
</tbody>
</table>

**Applying Multiple Linear Slopes to a Pond - Transition Option**

You can use the Transition option in areas where you want to create a gradual transition from one slope to another between vertices. You can use this option to set beginning cut and fill slopes from one vertex and ending cut and fill slopes from a subsequent vertex. After you enter the ending cut and fill slopes, the command adjusts the cut and fill slopes automatically from the vertices between the beginning and ending vertices.

To apply multiple linear slopes to a pond using the Transition option

1. Follow steps 1–6 of “Applying Multiple Linear Slopes to a Pond” in this chapter. After choosing the Transition option, you are prompted to specify the slope for the current vertex:

   ```
   Slope - Grade/Slope/<Infinite>:
   ```

2. Do one of the following to define the slope or grade:
   - Type **Grade** and type a grade value (e.g., 5.00%)
   - Type **Slope** and type a ratio (e.g., 20:1)
   - Type **Infinite** to define a vertical bank.

   The following prompt is displayed:

   ```
   dePth (ft) (eXit/Daylight/Elevation/dePth) <0.0000>:
   ```
3 Calculate the pond bottom from the selected vertex:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then type...</th>
</tr>
</thead>
<tbody>
<tr>
<td>define the pond bottom by specifying a depth</td>
<td>depth, and then type the required pond depth.</td>
</tr>
<tr>
<td>define the pond bottom by specifying the bottom elevation</td>
<td>elevation, and then type the elevation of the pond bottom.</td>
</tr>
<tr>
<td>define the pond bottom by daylighting down to a TIN surface</td>
<td>daylight.</td>
</tr>
<tr>
<td>return to the previous set of prompts</td>
<td>eXit.</td>
</tr>
</tbody>
</table>

The following prompt is displayed:

eXit/End/Next/Previous <Next>: 

4 Move to the subsequent vertex you want to transition by using the Next or Previous option.
5 Repeat until you have reached the vertex where you want to end the transition region.
6 Type End to end the transition region.
7 Define the slope and depth/elevation/daylight for the end vertex.
8 Use the eXit option to return to the previous command line prompts.

**Resetting the Pond Pattern Settings**

Use the Reset Patterns command to remove any existing pattern data from the vertices on the pond perimeter you select.

To reset the pattern settings for a pond

1 From the Grading menu, choose Pond Slopes ➤ Reset Patterns.
   The following prompt is displayed:
   Select polyline:

2 Select the pond perimeter.
   The following prompt is displayed:
   All/Multiple/Individual/eXit/Previous/Next <Next>: 

3 Use the Next or Previous options to move to the vertex you want to remove pattern data from (unless you want to use the All option).
Reset the pattern data:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then type…</th>
</tr>
</thead>
<tbody>
<tr>
<td>remove the pattern data for all pond vertices</td>
<td>All.</td>
</tr>
<tr>
<td>select multiple vertices to reset</td>
<td>Multiple, and then use the Next or Previous options to select the vertices; type End to finish.</td>
</tr>
<tr>
<td>remove the pattern data from the current vertex</td>
<td>Individual.</td>
</tr>
</tbody>
</table>

Type eXit to exit the command.

**Drawing a Pond Slope Template**

One method of creating the slope data for a pond is to use a template. A template is a cross-section of the pond bank and is used to define the exact shape and configuration for either all or part of the pond.

Use the Draw Template command to draw a template for the pond as a 2D polyline. The template can be either a single segment or multiple segments with different slopes.

To draw a template, you must:

- Draw the template in an upper-left to lower-right direction.
- Draw the template at a 1:1 scale.
- Draw all segments of the template so that they have a negative slope, or are horizontal or vertical.
- Draw only straight-line segments. A template cannot contain arc segments.

**NOTE**  Pond templates do not use the vertical scale factor like roadway templates do.

When you use the Draw Template command, the template is drawn on the current layer.

**To draw a pond slope template**

1. From the Grading menu, choose Pond Slopes ➤ Draw Template.
   
   The following prompt is displayed:
   
   From point:

2. Select the starting point.
   
   The following prompts are displayed:

   Current line-width is 0.00
   Arc/Close/Halfwidth/Length/Undo/Width/<Endpoint of line>: 
This prompt is the standard PLINE command prompt.

TIP
Use the @ option to draw the template. At the <Endpoint of line> prompt, type @, then the number of units in the X direction you want to draw (a positive number) and the number of units in the Y direction you want to draw (a negative number). For example, type @3,-5 to draw a template that is 4 units long and has a slope of 3:5.

3 To finish drawing the pond slope template, press ENTER.

The following illustration shows a template drawn with one slope and a template drawn with two slopes:

![Pond template illustration]

**Defining a Pond Slope Template**

Use the Define Template command to define an existing 2D polyline as a pond slope template. The pond slope template is saved as a file with an .htp extension in the c:\Land Projects R2\<project name>\hd folder.

NOTE
If you define more than one pond slope template, then use the Set Current command to set the current template before applying a template to a pond perimeter.

**To define a pond slope template**
1 Draw the pond slope template by using the Draw command or the AutoCAD PLINE command.
2 From the Grading menu, choose Pond Slopes ➤ Define Template to display the Define Template dialog box.
3 In the Template name box, type a name for the slope template, and then click OK.

**NOTE** If you enter a pre-existing pond template name, then you are prompted to overwrite the existing file. Click Yes to overwrite the file, or No to return to the Define Template dialog box and enter a different pond template name.

The following prompt is displayed:

Select (Entity/POints) <Entity>:

4 Do one of the following to select the polyline:

- Type **Entity**, press ENTER, and then select the polyline.
- Type **POints**, press ENTER, and then select the start and end points of the polyline.

If the polyline has a positive slope in one of its segments, then the following prompt is displayed:

Slope must be negative.

The positive slope segment is marked with X symbols, drawn with temporary vectors at the beginning and end vertices that define the positive slope. Use the PEDIT command to change the positive slope segment to either a horizontal, vertical, or negative slope segment.

After defining a template, the following prompt is displayed:

Define another template? <Yes>:

5 Type **Yes** to accept the default and define another template, or **No** to end the command.
Selecting the Current Pond Slope Template

Use the Set Current Template command to designate the current template after you have defined pond slope templates. The current template is applied to a pond perimeter when you use the By Template and Template – Multiple commands.

To select the current pond slope template

1. From the Grading menu, choose Pond Slopes ➤ Set Current to display the Import Template dialog box.

   ![Import Template dialog box]

   The Current Template label lists the name of the last template imported during the current drawing session. The Selection list displays the names of the available templates.

2. From the Selection list, select the name of the template you want to use. You can also type the name in the Name text box.

   An illustration of the template appears in the area to the right of the list.

   **NOTE** The template illustration is not drawn to scale. It is meant to give you an idea of what the template looks like so that you can select the correct one.

   The Minimum Slope and Maximum Width labels that appear at the bottom of the dialog box provide data about the currently selected template. This information is based on the dimensions of the template that you drew.

3. To make the selected template current, click OK.

   **NOTE** You can also use this command to delete a defined template. Select the template to delete from the Selection list and click Delete.
Applying a Slope Template to a Pond

To create the pond slopes by using a pre-defined cross-sectional view of the pond bank, use a pond template.

**NOTE** You must draw and define a pond template before using the Pond Slopes ➤ By Template command. It is also recommended that you select the current template before using this command.

**To apply a slope template to a pond**

1. From the Grading menu, choose Pond Slopes ➤ By Template.
   The following prompt is displayed:
   
   Select polyline:

2. Select the pond perimeter from your drawing.
   The Pond Name dialog box is displayed.

3. Do one of the following:
   - If you selected an existing pond, click OK to continue the command.
   - If the pond is not already named, then the name field is blank. Type a name for the pond, and then click OK.

   **NOTE** If you selected a pond that has already been shaped, then a message is displayed asking if you want to overwrite the existing pond rim information. The pond rim information is the data that is created by shaping the pond (contours, bottom, and slope control lines). You must click OK to continue.

   Next, you are prompted to select an offset side.

4. Pick a point inside or outside the pond.
   The following prompt is displayed:
   
   Attach template <template name> to all vertices? <Yes>:

5. Type Yes or No:
   - Type Yes to apply the current slope template to all the vertices in the pond perimeter polyline.
   - Type No and press ENTER to display the Import Template dialog box, which you can use to select a different slope template to use.

   The following prompt is displayed:
   
   Shape pond - All? <Yes>/No:

6. Type Yes to import the contours, bottom polyline, and slope control lines automatically, or type No to end the command.

   **NOTE** Pond benches are not created when you use a pond slope template.

   If you choose to shape the pond, then the following prompt is displayed:
   
   Close contour lines? Yes/No: <Yes>:
7 Type Yes to create closed contour lines, or No to draw contours that skip the last segment of the perimeter.

NOTE If the Pond Contour Settings are set up to create both normal and highlight contours, then the close contour lines prompt is displayed twice.

Applying Multiple Templates to a Pond

If you want to base the pond slopes on more than one pre-defined pond slope template, then use the Template – Multiple command.

NOTE You must draw and define a pond template before using the Pond Slopës ➤ By Template command. It is also recommended that you select the current template before using this command.

To apply multiple templates to a pond

1 From the Grading menu, choose Pond Slopes ➤ Template – Multiple.
   The following prompt is displayed:
   Select polyline:

2 Select the pond perimeter from your drawing.
   The Pond Name dialog box is displayed.

3 Do one of the following:
   ■ If you selected an existing pond, click OK to continue the command.
   ■ If the pond is not already named, then the name field is blank. Type a name for the pond, and then click OK.

NOTE If you selected a pond that has already been shaped, then a message is displayed asking if you want to overwrite the existing pond rim information. The pond rim information is the data that is created by shaping the pond (contours, bottom, and slope control lines). You must click OK to continue.

Next, you are prompted to select an offset side.

4 Select a point inside or outside the pond. The following prompt is displayed:
   Multiple/Template/Previous/Reset/Attach/all-Vertices/eXit/Next <Next>:

5 Use the Next and/or Previous options to move to the vertex where you want to start applying the template.
6 Attach the template to the vertices:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then type…</th>
</tr>
</thead>
<tbody>
<tr>
<td>attach the current template to the current vertex</td>
<td>Attach.</td>
</tr>
<tr>
<td>apply the current template to more than one vertex</td>
<td>Multiple. For more information, see “Applying Multiple Templates to a Pond – Multiple Option” in this chapter.</td>
</tr>
<tr>
<td>attach the current template to all of the pond vertices</td>
<td>Vertices.</td>
</tr>
<tr>
<td>select a different template to use</td>
<td>Template and select the template to use.</td>
</tr>
<tr>
<td>remove the pattern data from one or more vertices</td>
<td>Reset. For more information, see “Applying Multiple Templates to a Pond – Reset Option” in this chapter.</td>
</tr>
</tbody>
</table>

7 To exit the Multiple Template command, type X at the command prompt.

8 After applying multiple template patterns, use the Shape Pond commands to create the contours, slope control lines, and the bottom polyline of the pond.

**NOTE** Pond benches are not created when you use a pond slope template.

**Applying Multiple Templates to a Pond - Multiple Option**

You can use the Multiple option of the Templates – Multiple command to select multiple vertices to which to apply the selected template.

**To apply a slope template to a pond using the Multiple option**

1 Follow steps 1–6 of “Applying Multiple Templates to a Pond” in this chapter. When you select the Multiple option, the following prompt is displayed:

   Use current template <template_name>? <Yes>:  

2 Type Yes to use the current pond template, or No to select a different pond template from the Import Template dialog box. After you select a template, you are prompted to select the vertices to which you want to apply the template.

   An arrow appears on the pond perimeter to indicate the current vertex, and the following prompt is displayed:

   eXit/End/Next/Previous <Next>:  

3 Select the vertices you want to apply the template to by using the Next or Previous option. The template is applied to each vertex you move to.

4 When you have finished applying the template to the vertices, type End.

**NOTE** If you want to cancel, type eXit.
Applying Multiple Templates to a Pond - Reset Option

You can use the Reset option of the Templates – Multiple command to remove the pattern data from one or more vertices in the pond perimeter. For more information, see “Defining Ponds” in this chapter.

To apply a slope template to a pond using the Reset option

1. Follow steps 1–6 of “Applying Multiple Templates to a Pond” in this chapter. When you select the Reset option, the following prompt is displayed:

   Reset (eXit/All/Multiple/Individual) <Individual>:

2. Reset the pattern data:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then type…</th>
</tr>
</thead>
<tbody>
<tr>
<td>remove the pattern data for all pond vertices</td>
<td>All.</td>
</tr>
<tr>
<td>select multiple vertices to reset</td>
<td>Multiple, and then use the Next or Previous options to select the vertices; type End to finish.</td>
</tr>
<tr>
<td>remove the pattern data from the current vertex</td>
<td>Individual.</td>
</tr>
<tr>
<td>return to the previous set of prompts</td>
<td>eXit.</td>
</tr>
</tbody>
</table>

Shaping Ponds

You can use the Shape Pond commands on the Grading menu to create the contours, the slope control lines, and the bottom polyline for an existing pond.

When you create the pond slope information with the Pond Slopes commands, you are prompted to shape the pond at the end of the commands (except the Template – Multiple and Linear – Multiple commands).

If you choose not to shape the pond as you define the slopes, or if you are using one of the Multiple commands, you can use the Shape Pond commands to create the pond elements. In addition, you can use the Shape Pond commands to redraw the pond after you change the contour, bench, and slope control line settings.

NOTE Once .sdb and .dbf files are created using AutoCAD Land Development Desktop Release 2, they may not be used with any earlier version of the Desktop.
Creating the Pond Contours

Use the Contours command to create the pond contours.

**NOTE** Before using the Shape Pond > Contours command, you must use a Pond Slopes command to define the slopes for the pond.

To create pond contours

1. Specify the Pond Contour settings and the Bench settings.
2. From the Grading menu, choose Shape Pond > Contours.
   The following prompt is displayed:
   
   Select polyline:
   
3. Select the pond perimeter.
   The following prompt is displayed for closed pond perimeters:
   
   Close contour lines <Yes>/No:
   
4. Type Yes to create closed contour lines. If you type No, then contour lines are created that skip the last segment of the contours.

**NOTE** If the Pond Contour Settings are set up to create both normal and highlight contours, then the close contour lines prompt is displayed twice.

Creating the Pond Slope Control Lines

Use the Slope Control Lines command to create the slope control lines for a pond.

**NOTE** Before using the Shape Pond > Slope Control Lines command, you must use a Pond Slopes command to define the slopes for the pond.

To create pond slope control lines

1. Specify the Slope Control Line settings.
2. From the Grading menu, choose Shape Pond > Slope Control Lines.
   The following prompt is displayed:
   
   Select polyline:
   
3. Select the pond perimeter.

Creating the Pond Bottom

Use the Bottom Polyline command to create the pond bottom polyline.

**NOTE** Before using the Shape Pond > Bottom Polyline command, you must use a Pond Slopes command to define the slopes for the pond.
To create the pond bottom

1. From the Grading menu, choose Shape Pond ➤ Bottom Polyline.
   The following prompt is displayed:
   Select polyline:

2. Select the pond perimeter.
   The bottom polyline is created automatically based on the pond’s slope and specified depth or volume.

   **TIP**
   The pond bottom polyline is created on the pond’s normal contour layer. You may want to move the polyline to another layer or change its color to distinguish the pond bottom from a normal contour.

Creating All Pond Elements

Use the All command to create the pond contours, the slope control lines, and the bottom polyline.

**NOTE**
Before using the Shape Pond ➤ All command, you must use a Pond Slopes command to define the slopes for the pond.

To create all the elements for a pond

1. Specify the Pond Contour settings, the Slope Control Line settings, and the Bench Settings.
   For more information, see “Changing the Contour Settings for Ponds” and “Changing the Slope Control Line Settings for Ponds” in this chapter.

2. From the Grading menu, choose Shape Pond ➤ All.
   The following prompt is displayed:
   Select polyline:

3. Select the pond perimeter.
   The following prompt is displayed for closed pond perimeters:
   Close contour lines <Yes>/No:

4. Type Yes to create closed contour lines. If you type No, then contour lines are created that skip the last segment of the contours.

   **NOTE**
   If the Pond Contour Settings are set up to create both normal and highlight contours, then the close contour lines prompt is displayed twice.

   **TIP**
   The pond bottom polyline is created on the pond’s normal contour layer. You may want to move the polyline to another layer or change its color to distinguish the pond bottom from a normal contour.
Listing and Labeling Ponds

You can use the List/Label Pond commands on the Grading menu to list information about the ponds in your drawing and to label ponds.

Among other values, the Pond Properties command reports the total pond volume, using both average end area and conic volume calculation methods.

Listing the Properties of a Pond

You can quickly view the volume, perimeter, area, elevation, and maximum depth of a pond by listing its properties.

To list the properties of a pond

1. From the Grading menu, choose List/Label Pond ➤ Pond Properties.
   The following prompt is displayed:
   Select polyline:

2. Do one of the following to select the pond perimeter:
   - Select the pond perimeter in the drawing.
   - Press ENTER to display the Pond Name dialog box, select a pond name, and then click OK.

   The Pond Properties dialog box is displayed.

   ![Pond Properties dialog box](image)

   The following items are listed:
   - **Project**: The AutoCAD Land Development Desktop project that the pond is saved in.
   - **Pond name**: The pond name.
   - **Average area volume**: The pond volume calculated with the Average End Area method.
   - **Conic volume**: The pond volume calculated with the Conic method.
   - **Area**: The area of the pond perimeter.
   - **Perimeter**: The length of the pond perimeter.
   - **Pond elevation**: The elevation of the pond perimeter (rim).
   - **Maximum depth**: The greatest depth of the pond. For example, if you define a pond by assigning it a depth of 8 ft., then the maximum depth does not exceed 8 ft.

3. Click OK to close the dialog box.
**Listing the Contour Area of a Pond**
You can use the Contour Area command to list the area that is enclosed by any pond contour.

**To list the contour area of a pond**
1. From the Grading menu, choose List/Label Pond ➤ Contour Area.
   The following prompt is displayed:
   Select polyline:
2. Select the contour.
   The area value is displayed in the current drawing units at the command prompt.

**Listing the Contour Elevations of a Pond**
You can use the Contour Elevation command to list the elevation of any pond contour.

**To list the contour elevation of a pond**
1. From the Grading menu, choose List/Label Pond ➤ Contour Elevation.
   The following prompt is displayed:
   Select polyline:
2. Select the contour.
   The elevation is displayed in the current drawing units at the command line.

**Listing the Contour Perimeter of a Pond**
You can use the Contour Perimeter command to list the length of the pond perimeter, or any other pond contour.

**To list the contour perimeter of a pond**
1. From the Grading menu, choose List/Label Pond ➤ Contour Perimeter.
   The following prompt is displayed:
   Select polyline:
2. Select the contour.
   The perimeter is displayed in the current drawing units at the command line.
Listing the Slope and Grade of a Pond

Use the Slope/Grade command to display the slope, grade, elevation difference, and horizontal distance between two points that you select on a pond.

To list the slope and grade of a pond
1 From the Grading menu, choose List/Label Pond ➤ Slope/Grade. The following prompt is displayed:
   Select first point:
2 Select the first point.

   NOTE The order in which you select the first and second points determines whether the slope value is positive or negative. The slope value used to create the contours is not displayed. Use object snaps to select the 3D points.

You are prompted to select the second point.
3 Select the second point.

   The Slope/Grade information for the points you selected is displayed at the command prompt. You are prompted to select another point.
4 Select another set of points, or press ENTER if you are finished.

Labeling Ponds

To label ponds, use the Label Pond command.

   NOTE The pond to label must be a defined pond. You cannot use this command to label a polyline that has not been defined as a pond.

To label a pond
1 From the Grading menu, choose List/Label Pond ➤ Label Pond to display the Pond Label Settings dialog box.
2 In the Label layer box, type the name of the layer for the pond label.

3 Select the color of the label by typing a color number in the Text color box, or click the colored tile and select a color from the Select Color dialog box.

4 In the Text height box, type a height for the label text.
   You can also click Select to define the height by selecting the first and second points from the drawing. The Pond Label Settings dialog box displays and the value you selected is displayed in the Text height box.

5 Select which pond data to include in the label by selecting the check boxes at the bottom of the dialog box:
   - **Pond name**: Labels the pond name.
   - **Average volume**: Labels the pond volume calculated with the Average End Area method.
   - **Conic volume**: Labels the pond volume calculated with the Conic method.
   - **Area**: Labels the area of the pond perimeter.
   - **Perimeter**: Labels the length of the pond perimeter.
   - **Rim elevation**: Labels the elevation of the pond perimeter.
   - **Bottom elevation**: Labels the elevation of the pond bottom at its lowest point.

6 Click Label to save the current labeling settings and return to the graphics screen.
   The following prompt is displayed:
   Select polyline:

7 Do one of the following to select the pond perimeter:
   - Select the pond perimeter in the drawing.
   - Press ENTER to display the Pond Name dialog box, select a pond name, and then click OK.
   
   You are prompted to draw a leader for the label.

   **NOTE** Label text is either left- or right-justified, depending on the direction of the leader.

8 Select points to draw a leader for the label, and then press ENTER to end the leader line selection.
   The following prompt is displayed:
   Label rotation <0d0'0>:

9 Specify a rotation angle for the label by typing an angle or by selecting two points in the drawing. The label is placed in the drawing, and the Pond Label Settings dialog box displays for subsequent pond labeling.

10 Click OK to exit the dialog and save the settings.
Outputting Pond Data

To output pond data to files that you can use in other hydrology software programs, you can use the Pond Output commands on the Hydrology menu. You can also use the Pond Output commands to generate and save a stage-storage curve for the pond that you can use for calculating the outflow hydrograph of the detention pond with the Storage Indication Method command.

Reporting the Pond Contour Data By Selecting the Pond Perimeter

Use the Pond Output ➤ Output Editor by Pond command to create a text output file that contains data for each contour in a pond. You can choose which data you want to output, including elevation, area, and volume information.

NOTE  This command is the same as the Output Editor by Contours command except that you select a pond perimeter or a pond name to reach the Output Editor.

To report data about each pond contour

1. From the Hydrology menu, choose Pond Output ➤ Output Editor by Pond. The following prompt is displayed:
   Select polyline:

2. Do one of the following to select the pond perimeter:
   - Select the pond perimeter in the drawing.
   - Press ENTER to display the Pond Name dialog box, select a pond name, and click OK.
The Pond Output Editor dialog box is displayed.

The information at the top of the dialog box displays the data as it will appear in the output file.

3. To specify how the data is separated in the output file, select one of the following Delimiter options:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then select...</th>
</tr>
</thead>
<tbody>
<tr>
<td>separate the data with commas (,)</td>
<td>Comma.</td>
</tr>
<tr>
<td>separate the data with spaces ( )</td>
<td>Space.</td>
</tr>
<tr>
<td>separate that data in columns based on the width values specified in the Field settings in this dialog box</td>
<td>Column.</td>
</tr>
</tbody>
</table>

4. To include a header in the output file, select the Header check box. The following is an example of a header:

```
#Units=Elevation,m,Area,ha,Volume,m3,Volume,m3
# Elev     Area     Cumml Avg     Cumml Conic
# m         ha             m3                        m3
```

5. To determine the data order, column width, and decimal precision used for the columns in the output file, use the following Field settings:

- **1–4**: The field number determines the order in which the data appears. For example, the field you select from the list next to the number 1 appears in the first column, the field you select from the list next to the number 2 appears in the second column, and so on. You can specify up to four fields.
- **Field Lists**: Select the type of pond data you want in each field (1–4).
- **Width**: Enter a width, up to 25 characters, for each field.
- **Prec**: Enter the decimal precision, up to eight places, for each field.
To display the pond output in your currently configured ASCII text editor, click Output.

**NOTE** Once .sdb and .dbf files are created using AutoCAD Land Development Desktop Release 2, they may not be used with any earlier version of the Desktop.

**Pond Output Data Types**

You can select any of the following options when choosing which type of pond data to output:

- **Elevation**: Reports the elevation of the pond contour.
- **Area**: Reports the area of the pond contour.
- **Average Area Volume**: Reports the volume of a pond contour in relation to the contour below it. The bottom of the pond (the last contour listed) does not have a volume. This option uses the Average End Area method of calculating volumes.
- **Conic Volume**: Reports the volume of a pond contour in relation to the contour below it. The bottom of the pond (the last contour listed) does not have a volume. This option uses the Conic method of calculating volumes.
- **Cumulative Average Volume**: Reports the volume (calculated by using the Average End Area method) of each contour in relation to the bottom of the pond. For example, the first contour in a pond (the top of the pond) has a cumulative volume that is equal to the entire pond volume. The second contour in a pond (the first contour that is below the top of the pond) has a cumulative volume that is equal to the full pond volume minus the volume between the first and second contour.
- **Cumulative Conic Volume**: Same as Cumulative Average Volume except it uses the conic method of calculating the volume.
- **Perimeter**: Reports the length of the contour perimeter.
- **None**: Shows no data in the selected column.

The following illustration shows an example of the Average End Area Method for pond volumes:

![Average end area method for pond volumes](image)

*Average end area method for pond volumes*
The following illustration shows an example of the Conic Method for pond volumes:

![Conic Method Diagram]

**Conic method for pond volumes**

### Reporting the Pond Contour Data By Selecting the Pond Contours

Use the Pond Output ➤ Output Editor by Contours command to create a text output file that contains data for each contour in a pond. You can choose which data you want to output, including elevation, area, and volume information.

**NOTE**  
This command is the same as the Output Editor by Pond command except that you select the pond contours to reach the Output Editor.

**To report data about each pond contour**

1. From the Hydrology menu, choose Pond Output ➤ Output Editor By Contours. The following prompt is displayed:

   `Select by Layer (Selection/Layer):`

2. Do one of the following to select the contours:
   - Type *Selection*, press ENTER, and then select the contours.
   - Type *Layer*, and then select a contour on the layer you want to select. Or, you can press ENTER (instead of selecting a contour), and then type the name of the layer to select. Be sure there are no other ponds with contours on the same layer you select.

   The Pond Output Editor dialog box is displayed.

   The information at the top of the dialog box displays the data as it appears in the output file. The other options determine how the pond data appears.
3 Specify how the data is separated in the output file:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then select…</th>
</tr>
</thead>
<tbody>
<tr>
<td>separate the data with commas (,)</td>
<td>Comma.</td>
</tr>
<tr>
<td>separate the data with spaces ( )</td>
<td>Space.</td>
</tr>
<tr>
<td>separate that data in columns based on the width values specified in the Field settings in this dialog box</td>
<td>Column.</td>
</tr>
</tbody>
</table>

4 To include a header in the output file, select the Header check box.

The following is an example of a header:

```
#Units=Elevation,m,Area,ha,Volume,m3,Volume,m3
# Elev   Area  Cumml Avg  Cumml Conic
# m      ha     m3               m3
```

5 To determine the data order, column width, and decimal precision used for the columns in the output file, use the following Field settings:

- **1–4:** The field number determines the order in which the data appears. For example, the field you select from the list next to the number 1 appears in the first column, the field you select from the list next to the number 2 appears in the second column, and so on. You can specify up to four fields.
- **Field Lists:** Select the type of pond data you want in each field (1–4).
- **Width:** Enter a width, up to 25 characters, for each field.
- **Prec:** Enter the decimal precision, up to eight places, for each field.

6 To display the pond output in your currently configured ASCII text editor, click Output.

**Generating a Stage-Storage Curve for the Pond**

A stage-storage curve is a graph that plots a pond's storage volume versus the pond's depth (or “stage”). It shows how much water volume is stored in a pond at any given stage. Use the Pond Output ➤ Stage-Storage Curve command on the Hydrology menu to generate a stage-storage curve for the selected pond.

You can save the stage-storage curve to a file you can use when calculating pond routing and for calculating a pond outflow hydrograph.

**To generate a pond’s stage storage curve**

1 Define a pond by using the pond commands on the Grading menu.
2 From the Hydrology menu, choose Pond Output ➤ Stage-Storage Curve.

   The following prompt is displayed:

   ```
   Select Polyline:
   ```

3 Do one of the following to select the pond perimeter:

   - Select the pond perimeter in the drawing.
   - Press ENTER to display the Pond Name dialog box, select a pond name, and then click OK.
The Select Volume Method dialog box is displayed.

Use this dialog box to determine which method is used to calculate the volume for the Stage/Storage curve.

4 To calculate the pond volume using the average end area method, click Average. Or you can click Conic to calculate the pond volume using the conic method. After you specify a volume method, the Stage-Storage Curve Display dialog box is displayed.

The graph shows you how much volume is contained in the pond at any stage.

5 To save the data to a file you can use when calculating routing and outflow, click the Save button. The Save Stage-Storage Curve dialog box is displayed.

6 Type the name of the file to save in the File name box.
Click Save to save the file. The file is saved with an .scc file extension in the c:\Land Projects R2\<project name>\hd folder, and you are returned to the Stage-Storage Display dialog box.

You can also output the data to a text or .wk1 file, change the graph settings, and plot the graph by using the following guidelines:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then click...</th>
</tr>
</thead>
<tbody>
<tr>
<td>output the data to a text or .wk1 file</td>
<td>Output.</td>
</tr>
<tr>
<td>change the graph settings</td>
<td>Settings.</td>
</tr>
<tr>
<td>plot the graph</td>
<td>Plot.</td>
</tr>
</tbody>
</table>

Click Close to close the Stage-Storage Curve Display dialog box.

**Routing Ponds**

One of the most common requirements for post-development stormwater management is that the post-development discharges do not exceed the pre-development discharges for one or more storm frequencies. The detention basin is generally the least expensive and most reliable measure for controlling post development peak discharges.

When the runoff enters a detention pond, the flow is attenuated, meaning that the peak rate of inflow is "detained." The water flowing out of the pond, therefore, exits at a slower rate. This attenuation of flow is a main goal of stormwater management.

To begin the process of designing a detention pond, you start by calculating the post-development runoff using one of the runoff calculation methods. The hydrograph of the post-development runoff flow is referred to as the inflow hydrograph because it represents the peak flow of water entering the detention pond.

Using this inflow hydrograph (and other runoff data), you can calculate the required storage volume for a pond. In addition, you can generate the outflow hydrograph that represents the rate of discharge of the water flowing out of the detention pond.

This process of calculating the outflow hydrograph for a detention basin based on the inflow is called routing.

Autodesk Civil Design provides two commands you can use to calculate routing data. You can use the Detention Basin Storage command to calculate the required storage volume for a pond, and you can use the Storage Indication Method command to calculate a routed hydrograph.
Calculating the Required Storage Volume for a Detention Basin

The Detention Basin Storage method is a “quick” method for performing stormwater detention design. For smaller sites, you could use this method for sizing the detention pond. For large sites it is good idea to use this method before designing your pond to get an approximate idea of the pond size that will be required.

The Detention Basin Storage method is explained in Chapter 6 of the TR-55 manual. The resulting value from this method is the estimated required storage volume. When using this method you should calculate your peak discharge using TR-55.

Data input required for the Detention Basin Storage method includes the following values:

- Allowable peak discharge
- The peak inflow (cfs)
- The runoff from the drainage area in inches
- The type of storm distribution
- The size of the drainage areas

To calculate the required storage volume for a detention basin

1. You can calculate runoff and save the calculations to a file. This is not required, but if you do not save the data to a file, then you have to manually enter much of the data for calculating the required storage volume.
   - Use the TR-55 Tabular Hydrograph Method to create an inflow hydrograph file (.tab file, an .hdc file, or a .wk1 file).
   - Use the TR-20 Method to create and save an inflow hydrograph file (.hdc or .wk1 file).
   - Use the TR-55 Graphical Peak Discharge Method to create an inflow hydrograph file (gpd file).
   - Use the Combine Hydrographs command to create a composite inflow hydrograph (.hdc file).

2. You can create a rough design of the detention pond, and calculate the stage-storage-curve for the pond. Save the stage-storage-curve as an .ssc file. You can load this data into the Detention Basin Storage dialog box to compare the calculated storage volume with the pond elevation.

3. From the Hydrology menu, choose Routing ➤ Detention Basin Storage to display the Detention Basin Storage dialog box.
You can click Load to load a previously saved detention basin storage file (.bsn file).

The InFlow File label at the top of the dialog box displays the name of the currently loaded runoff file that defines the Peak Inflow value (and other values, depending on the type of inflow file that is loaded).

To enter the data required for calculating the storage volume into the Detention Basin Storage dialog box, you can either load an inflow file, or you can type data into the edit boxes.

4 Load the inflow file:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then click...</th>
</tr>
</thead>
<tbody>
<tr>
<td>load a .tab file that you created by saving a Tabular hydrograph calculation</td>
<td>Data Input.</td>
</tr>
<tr>
<td>load a .gpd file that you created by saving a Graphical hydrograph calculation</td>
<td>Data Input.</td>
</tr>
<tr>
<td>load a hydrograph file (.hdc) that you created by saving a hydrograph</td>
<td>Hydrograph.</td>
</tr>
<tr>
<td>load a .wk1 file that you created by saving a hydrograph</td>
<td>Hydrograph.</td>
</tr>
</tbody>
</table>

Depending on which type of inflow file you select, different fields in the dialog box are filled in with the data from these files.

5 To load a pond definition, click the Pond button and select a pond, or click the SS Curve button and select a stage-storage curve for a pond.
6 Enter data into the Detention Basin Storage dialog box:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>define the rainfall distribution</td>
<td>select type I, IA, II, or III from the Rainfall Distribution list.</td>
</tr>
<tr>
<td>define the rainfall frequency</td>
<td>select 1, 2, 5, 10, 25, 50, and 100 years from the Rainfall Frequency list.</td>
</tr>
<tr>
<td>define the watershed drainage area</td>
<td>type the area into the Drainage Area box or click Select. For more information, see “Specifying the Drainage Area” in this chapter.</td>
</tr>
<tr>
<td>define the peak inflow</td>
<td>type the peak inflow into the Peak Inflow box.</td>
</tr>
<tr>
<td>define the peak outflow</td>
<td>type the peak outflow into the Peak Outflow box, or click Select to display the Outflow Editor where you can attach Inflow and Outflow structures to your pond and determine peak outflows more accurately. For more information, see “Specifying the Peak Outflow” in this chapter.</td>
</tr>
<tr>
<td>define the runoff flow</td>
<td>type the runoff flow depth in the Runoff Flow box.</td>
</tr>
</tbody>
</table>

**NOTE** See the map in the SCS TR-55 document, page B-2, or contact your local SCS office (now NRCS) to determine the appropriate rainfall distribution for your project area and Runoff Flow values (this value is supplied automatically if you use the Tabular or Graphical peak method).

**NOTE** The Select button next to the Peak Outflow box is only available when a pond definition is loaded. In addition, the View button at the bottom of the dialog box is not active until you load a pond definition.

The Runoff Volume label displays the computed runoff volume. The Storage Volume label displays the computed storage volume for the detention pond. The Maximum Storage Elevation label displays the maximum storage elevation of the currently selected pond.

7 Click Save to save the current detention basin storage data to a basin file (.bsn) in the c:\Land Projects R2\<project name>\hd folder.

You can also do one of the following:

- Click New to clear the data from the dialog box.
- Click View to view the currently selected pond’s stage-storage curve. The View button is grayed out unless you select an .ssc file by clicking the SS Curve button or load a pond definition by clicking the Pond button.
- Click Output to display the default text editor with the basin design information. From here, you can print the data to a printer or save it as a text file.

8 Click OK to exit the Detention Basin Storage dialog box.
Specifying the Drainage Area

To specify the drainage area

1. Follow steps 1–6 in “Calculating the Required Storage Volume for a Detention Basin” in this chapter.
2. Click the Select button next to the Drainage Area text box.

   The Detention Basin Storage dialog box closes temporarily and the following prompt is displayed:
   
   Select polyline (or Draw):

3. Do one of the following:
   - Select a closed polyline from the drawing.
   - Type Draw and draw the polyline by selecting points. You can type Close to close the polyline and to return to the Detention Basin Storage dialog box.

   The Detention Basin Storage dialog box displays and the value for the area you select is placed in the Drainage Area text box.

Specifying the Peak Outflow

Use the Peak Outflow Select button to display the Pond Outflow Design dialog box, which you can use to design inflow and outflow structures for the pond to more accurately determine the peak outflow.

To specify peak outflow

1. Follow steps 1–6 in “Calculating the Required Storage Volume for a Detention Basin” in this chapter.
2. Click the Select button next to the Peak Outflow text box to display the Pond Outflow Design dialog box.
NOTE  The Select button is available only when a pond definition is loaded.

3 Use the Pond Outflow Design dialog box to load an outflow file that you previously saved, or to design the outflow structures for the pond. For more information, see “Adding Outlet Structures to a Defined Pond” in this chapter.

4 Click OK to return to the Detention Basin Storage dialog box.

The value you specified is placed in the Peak Outflow text box.

### Displaying the Stage Storage Curve

To view the currently selected pond’s stage-storage curve

1 Click View to display the Stage-Storage Curve Display dialog box.

2 Change the settings, or plot, output or save the curve:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the graph settings</td>
<td>Settings</td>
</tr>
<tr>
<td>plot the curve</td>
<td>Plot</td>
</tr>
<tr>
<td>output the data to an ASCII text or .wk1 file</td>
<td>Output</td>
</tr>
<tr>
<td>save the curve as an .ssc file to the c:\Land Projects R2&lt;project name&gt;\hd folder</td>
<td>Save</td>
</tr>
</tbody>
</table>

NOTE  Use the Save option only if you wish to save a copy of the currently loaded .ssc file under a new name.

3 Click Close to return to the Detention Basin Storage dialog box.
Calculating Routing Values for Detention Basins

Use the Storage Indication Method command to perform routing through a detention pond or other water-storage facility. This command uses a post-development hydrograph, stage-storage curve, and stage-discharge curve (as well as an optional pre-development hydrograph for viewing in the multiple hydrographs plot) to route runoff.

To create the required input files for using the Storage Indication Method, you can use the TR-55 Graphical and Tabular runoff commands, the Rational Method command, the Stage-Storage Curve command, and the Outflow Editor ➤ By Pond command. Or, you can create the files manually.

Storage Indication Method Formula

The following Storage Indication Method formula is used for the routing calculations:

\[ S_2 + \left(\frac{O_2}{2}\right) \Delta t = \left[ S_1 - \left(\frac{O_1}{2}\right) \Delta t \right] + \left[ \left( I_1 + I_2 \right) / 2 \right] \Delta t, \]

where:
- \( S_2 + \left(\frac{O_2}{2}\right) \Delta t \) = Storage characteristic at peak outflow (m³)
- \( S_1 \) = Storage volume at time, \( t_1 \) (m³)
- \( O_1 \) = Outflow rate at time, \( t_1 \) (cms)
- \( \Delta t \) = Routing time period (hrs)
- \( I_1 \) = Inflow rate at time, \( t_1 \) (cms)
- \( I_2 \) = Inflow rate at time, \( t_2 \) (cms)
Creating an .ssc File to Use in Calculations

For calculating pond routing with the Storage Indication Method, a stage-storage curve file (.ssc) is required. From the Hydrology menu, you can create a stage-storage curve by using the Pond Output ➤ Stage-Storage Curve command.

Or, you can use the following method to manually create the stage-storage curve file.

To create a stage-storage curve file for use in routing calculations

1 Open a text editor and create an ASCII text file using the following format:

- Format the first line by starting the line with #Units=. This is an optional comment line.
- Delimit the file data with commas (e.g. 0.1,1.05).
- Precede comment lines with a pound (#) sign (e.g. #Units=Time,hrs,Flowrate, cms).

```
#Units=Elevation,m,Volume,m3
#Stage-Storage Curve Data
#Stage - m  Volume - m3
#----------------------
0.00000000,0.00000000
0.25000000,320.85151904
0.40000000,518.29860768
0.55000000,691.06481024
1.95000000,3183.83430432
2.05000000,3492.34538032
2.15000000,3640.43069680
2.25000000,3961.28221584
```

2 Save the file with a .ssc extension in the folder, c:\Land Projects R2\<project name>\hd folder.

Creating an .hdc File to Use in Calculations

For calculating pond routing with the Storage Indication Method, a post-development hydrograph file (.hdc) is required. You can create a post-development hydrograph file by using the TR-55 Graphical and Tabular methods, the Rational method, or the Combine Hydrographs command. Or, you can use the following method to manually create the .hdc file.

To create a hydrograph data file for use in routing calculations

1 Open a text editor and create an ASCII text file using the following format:

- Format the first line by starting the line with #Units=.
- Delimit the file data with commas (e.g. 0.1,1.05).
- Precede comment lines with a pound (#) sign (e.g. #Units=Time,hrs,Flowrate, cms).

```
#Units=Time,hrs,Flowrate,cms
#Hydrograph Data
#Time - hrs   Flowrate - cms
#------------ ------------
0.0,0.0
0.1,1.05
0.2,3.48
0.3,4.81
. .
0.9,0.17
1.0,0.11
1.1,0.05
1.2,0.0
```
2 Save the file with a .hdc extension in the c:\Land Projects R2\<project name>\hd folder.

Creating an .sdc File to Use in Calculations

For calculating pond routing with the Storage Indication Method, a stage-discharge file (.sdc) or a rating curve file (.rtc) is required. From the Hydrology menu, you can create a stage-discharge curve or a rating curve file using the Outflow Editor ➤ By Pond command (using the Plot button to create the .sdc or .rtc file).

Or, you can use the following method to manually create the .sdc file.

To create a stage discharge curve data file for use in routing calculations

1 Open a text editor and create an ASCII text file using the following format:

```
#Units=Elevation,m,Flowrate,cms
#Stage-Discharge Curve Data
#Stage - m  Discharge - cms
#-------------------------------
0.00000000,0.00000000
0.25000000,0.28303000
0.40000000,0.56606000
0.55000000,0.84909000
1.95000000,5.66060000
2.05000000,6.22666000
2.15000000,6.50969000
2.25000000,7.07575000
```

2 Save the file with a .sdc extension in the c:\Land Projects R2\<project name>\hd folder.

Calculating the Routing Values for a Reservoir or Storage Facility

You can create the routed hydrograph for the detention pond by using the Storage Indication Method.

Calculating the routed hydrograph is an iterative process of trial and error. For example, you may have to return to the Pond Outflow Design dialog box and design different inflow and outflow structures and possibly redesign the pond, and then recalculate the outflow hydrograph in order to achieve the results you want.

TIP

You should use the Pond Outflow Design dialog box to design the outflow structures for the pond before using this command.

To calculate the routing values for a reservoir or storage facility

1 Create the necessary input files:

- Post-development hydrograph file (.hdc). For more information, see “Creating an .hdc File to Use in Calculations” in this chapter.
- Stage-storage curve file (.ssc). For more information, see “Creating an .ssc File to Use in Calculations” in this chapter.
Stage-discharge curve file (.sdc) or a rating curve (.rtc). For more information, see “Creating an .sdc File to Use in Calculations” in this chapter.

In addition, you can optionally use a pre-development .hdc file for viewing the plot of the multiple hydrographs.

2 From the Hydrology menu, choose Routing ➤ Storage Indication Method to display the Storage Indication Method dialog box.

Only the Description and Time Increment fields can be edited. The other fields are for display only. You enter the data into the dialog box by using the Input Curves button.

3 In the Description text box, type a description for the calculation.

4 In the Time Increment text box, type a time increment.

5 Click Input Curves and select the input curves for the calculations.

After you load the input curves, the storage indication method data is automatically compiled. The Peak Time label at the bottom of the dialog box displays the time at which Peak Flow occurs. The Peak Flow label, also at the bottom, displays the maximum flow through the structure at the Peak Time.
NOTE After selecting the input curves you should scroll through the resultant calculations. The Outflow column will show what the outflow data is as the storm is routed through the pond. You should verify that this number is less than your allowable discharge. The H column displays what the water surface elevation is at in the pond. If the pond is too small, then calculations stop when the maximum depth has been reached in the pond.

6 After you use the Input Curves option to input the data, you can review the data by using the following guidelines:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>view the calculated storage volume vs. the stage</td>
<td>Storage Character.</td>
</tr>
<tr>
<td>display the flow rate vs. time</td>
<td>Routed Hydrograph.</td>
</tr>
<tr>
<td>view all hydrographs</td>
<td>Multi-Hydrographs.</td>
</tr>
<tr>
<td>display the storage indication method data in your default editor</td>
<td>Output.</td>
</tr>
</tbody>
</table>

7 Click Save to display the Save Storage Indication Method Data dialog box.

8 Type the name of the file in the File name box, and then click Save.

   The file is saved with a .sim file extension in the c:\Land Projects R2\<current project>\hd folder.

9 Click OK to close the Storage Indication Method dialog box.

   For more information on the display fields in the Storage Indication Method dialog box, see “Storage Indication Method dialog box – display fields” in this chapter.
Storage Indication Method Dialog Box - Display Fields

The following are display fields in the Storage Indication Method dialog box:

- **Time**: Duration of time for the hydrograph in increments.

**NOTE**: The Time column has the only values that you can edit; the rest of the columns have values that cannot be edited.

- **Inflow**: Amount of flow coming into the structure.

- **I1+I2/2**: Average of two flow rates (I1 and I2) calculated at different times. For example, to calculate the I1+I2/2 value for T2 (the second time increment), you convert the Inflow value of T1 and T2 to volume amounts, then divide the total by 2. If the Inflow is in cfs units (cubic feet per second), and the Time increment is one-tenth of a second, then you multiply the Inflow value by 360 to obtain the volume of flow.

- **H1**: Calculated headwater for the structure at the beginning of the time period.

- **S-(0/2)T**: Calculated storage volume for the structure at the beginning of the time period. (S=storage volume at time 1, T=routing time period, and O=outflow rate.)

- **S+(0/2)T**: Calculated storage volume for the structure at the end of the time period. (S=storage volume at time 1, T=routing time period, and O=outflow rate.)

- **H**: Calculated headwater for the structure at the end of the time period.

- **Outflow**: Calculated flow out of the structure.

Specifying Curves to Use in Calculations

Use the Input Curves option to specify the following files for use in the storage indication method calculations:

- Post-development hydrograph file (.hdc)
- Stage-storage curve file (.ssc)
- Stage-discharge curve file (.sdc) or a rating curve (.rtc)

In addition, you can optionally use a pre-development .hdc file for viewing the plot of the multiple hydrographs. All but the pre-developed hydrograph file are required.
To specify which curves to use in calculations

1 From the Storage Indication Method dialog box, click Input Curves to display the Curve Input dialog box.

<table>
<thead>
<tr>
<th>Curve Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pre-Developed Hydrograph</td>
</tr>
<tr>
<td>Post-Developed Hydrograph</td>
</tr>
<tr>
<td>Stage-Storage Curve</td>
</tr>
<tr>
<td>Stage-Discharge Curve</td>
</tr>
</tbody>
</table>

2 Click the Select buttons to load each curve file:
   - Select the appropriate file for each curve (see list above). For example, when you click the Pre-Developed Hydrograph Select button, choose a file with an .hdc extension.
   - Click View to display the hydrograph or curve dialog box. From this dialog box, you can change the hydrograph’s settings, plot the data on a graph and insert the graph in your drawing, or output the data to an ASCII or .wk1 file.

3 Click OK to close the Curve Input dialog box.
Displaying the Calculated Storage Volume Versus the Stage

Use the Storage Character option to view the calculated storage volume versus the stage.

To display the calculated storage volume versus the stage

1. From the Storage Indication Method dialog box, click Storage Character to display the Storage-Characteristics Curves dialog box.

This dialog box shows the calculated storage volume versus the stage for the currently loaded curves.

**NOTE** If you do not see a graph, be sure you have specified the curves to use in the calculations.

2. Do one of the following:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the hydrograph’s settings</td>
<td>Settings.</td>
</tr>
<tr>
<td>plot the data on a graph and insert the graph in your drawing</td>
<td>Plot.</td>
</tr>
<tr>
<td>output the data to an ASCII or .wk1 file</td>
<td>Output.</td>
</tr>
</tbody>
</table>

3. Click OK to close the Storage-Characteristics Curve dialog box.
Displaying the Flow Rate Versus Time Data

To display the flow rate versus the time data

1. From the Storage Indication Method dialog box, click Routed Hydrograph to display the Routed Hydrograph dialog box.

   ![Routed Hydrograph dialog box](image)

   **NOTE** If you do not see a graph, be sure you have specified the curves to use in the calculations.

2. Do one of the following:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then click...</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the hydrograph's settings</td>
<td>Settings</td>
</tr>
<tr>
<td>plot the data on a graph and insert the graph in your drawing</td>
<td>Plot</td>
</tr>
<tr>
<td>output the data to an ASCII or .wk1 file</td>
<td>Output</td>
</tr>
</tbody>
</table>

3. Click OK to close the Routed Hydrograph dialog box.
Displaying Multiple Hydrographs

To compare pre- and post-development hydrographs with the routed hydrograph, use the Multi-Hydrographs option.

To display multiple hydrographs used in the calculations

1 From the Storage Indication Method dialog box, click Multi-Hydrographs to display the Multi-Hydrographs dialog box.

   NOTE If you do not see a graph, be sure you have specified the curves to use in the calculations.

2 Do one of the following:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the hydrograph’s settings</td>
<td>Settings.</td>
</tr>
<tr>
<td>plot the data on a graph and insert the graph in your drawing</td>
<td>Plot.</td>
</tr>
<tr>
<td>output the data to an ASCII or .wk1 file</td>
<td>Output.</td>
</tr>
</tbody>
</table>

3 Click OK to close the Multi-Hydrographs dialog box.

Adding and Editing Outlet Structures for Ponds

Use the Outflow Editor commands on the Hydrology menu to attach inflow and/or outflow structures to a defined pond. You can attach these structures to a defined pond in one of two ways: by specifying a defined pond and by specifying a stage-storage curve data file. You can also directly open a file previously saved through the Pond Outflow Design dialog box using the Outflow Editor ➤ Editor command.

Use the Outflow Editor commands to save the stage-discharge data as a stage-storage curve (sdc file) or as a rating curve (.rtc file). You can use these files to calculate pond routing when using the Storage Indication Method command or the Detention Basin Storage command.

Adding and Editing Outlet Structures to a Pond - By Pond

You can use the Outflow Editor commands to design multiple stage inflow and outflow structures for detention ponds, thus providing the tools required for attenuating different frequency storms. This process is typically one of trial and error. You can begin with approximate sizes of the inflow and outflow structures, and then refine your design by changing the structures’ dimensions or by modifying the shape of the pond.
Inflow structures are typically only used to accommodate base flow that is already flowing into the pond.

You can add multiple structures to the design by using the hydrology calculators. You can use these calculators to calculate the flow rate for the structure, or you can load structure files that you have previously saved.

By default, each structure you add is “active.” This is controlled by the Active check box in the Outflow dialog box. You can clear the Active check box to remove a structure from the current calculations, which is useful when you want to see how the stage-discharge curves and rating curves are affected by different combinations of structures.

When you have completed your design of the inflow and outflow structures, you can save the files as rating (.rtc) or stage-discharge curves (.sdc) to use for calculating the pond routing with the Storage Indication Method command or the Detention Basin Storage command.

NOTE Once .sdb and .dbf files are created using AutoCAD Land Development Desktop Release 2, they may not be used with any earlier version of the Desktop.

Adding Inflow and Outflow Structures to a Defined Pond

To add inflow and outflow structures to a pond

1 From the Hydrology menu, choose Outflow Editor ➤ By Pond to display the Pond Name dialog box.
2 Select the name of the pond, and then click OK.

The Pond Outflow Design dialog box is displayed with the current pond name in the title bar.
TIP  Click the Pond button to view the details of the pond you selected.

3  Click Add to display the Add Structure dialog box.

4  Select a structure from the list, then click OK to display the Calculator dialog box for that structure.
5 Use the calculator to configure the structure or to load a previously saved file, and then click OK to exit the calculator. The Outflow Structure Description dialog box is displayed.

6 In the Description box, type a name for the structure, and then click OK. The Attached Structures list (top left of the dialog box) displays the structures that are defined and attached to the currently selected pond.

7 By default each structure you add is active. You can select the name of an attached structure and clear the Active check box to remove that structure from the stage-discharge calculations. By activating or inactivating different structures, you can see how different combinations of structures affect the stage-discharge calculations.

8 To specify whether the structure is to be used as an inflow structure or an outflow structure, select the structure’s name in the Attached Structures list, and then select the Inflow option or the Outflow option.

9 In the Str. Elevation box, type the absolute elevation at which the structure will be attached. The attachment point for a structure is at the top of the structure – not at the bottom. This varies from structure to structure. The Str. Height displays the height of the currently highlighted structure. The Current Flow label displays the outflow (discharge) rate for the currently selected structure. The Maximum Flow label displays the maximum outflow (discharge) capacity of the currently selected structure.
10 Under Modify Pond, you can type a value for the water surface elevation in the 
Surface Elev box to reflect revised water levels.

11 Click Save to save the current data to a file.

   The data is stored in the c:\Land Projects R2\<project name>\hd folder with 
   the same base name as the pond and a .pda extension.

12 Click Plot to view and save the rating curve and stage-discharge curve.

   The following five illustrations show structure attachment points. The 
   attachment point for each structure is at the top of the structure, and can vary 
   for each type of structure.

   **NOTE** The riser attachment point varies because it must be based on the base 
   flow. An internal rating curve is created and the base of this rating curve is 
   the riser elevation or structure elevation.

   **NOTE** The structure elevation for the rating curve is the x-axis.

The following illustration shows the channel attachment point:

![Channel attachment point](image)

The following illustration shows the culvert attachment point:

![Culvert attachment point](image)
The following illustration shows the orifice attachment point:

![Orifice attachment point](image)

The following illustration shows the pipe attachment point:

![Pipe attachment point](image)

The following illustration shows the weir attachment point:

![Weir attachment point](image)
Editing Pond Inflow and Outflow Structures

After you add inflow and outflow structures to a pond in the Pond Outflow Design dialog box, you can individually edit each structure as needed.

To edit an inflow or outflow structure
1. From the Hydrology menu, choose Outflow Editor ➤ By Pond to display the Pond Name dialog box.
2. Select the name of the pond, then click OK to display the Pond Outflow Design dialog box.
3. Load the file you want to edit by clicking the Load button and selecting the .pda file.
4. From the Attached Structures list (top left of the dialog box), select the structure to edit.
5. Click the Edit button to display the calculator dialog box for that structure.
6. Use the calculator to change the settings for the structure, and then click OK to exit the calculator.
7. Change the other Pond Outflow Design settings as necessary or choose another structure to edit.
8. Click Save to save the current data to a file.
   The data is stored in the c:\Land Projects R2\<project name>\hd folder with the same base name as the pond and a .pda extension.
9. Click Plot to view and save the rating curve and stage-discharge curve.
10. Click OK to close the Pond Outflow Design dialog box.

Deleting Pond Inflow and Outflow Structures

You can delete attached inflow and outflow structures from the Pond Outflow Design dialog box.

NOTE
An alternative to deleting a structure is to make it inactive. If you want to exclude a structure from the stage-discharge calculations, select the structure’s name from the Attached Structures list and clear the Active check box.

To delete a pond inflow or outflow structure
1. From the Hydrology menu, choose Outflow Editor ➤ By Pond to display the Pond Name dialog box.
2. Select the name of the pond, and then click OK to display the Pond Outflow Design dialog box.
3. From the Attached Structures list (top left of the dialog box), select the structure to delete.
4. Click Delete.
   You are asked to confirm that you want to delete the structure.
5. Click Yes to delete the structure.
6 Click Save to save the current data to a file.
   The data is stored in the c:\Land Projects R2\<current project>\hd folder with
   the same base name as the pond and a .pda extension.
7 Click Plot to view and save the rating curve and stage-discharge curve.

**Displaying Data About the Current Pond in the Outflow Editor**

When you run the Outflow Editor ➤ By Pond command, you select a pond for
which you design the inflow and outflow structures. From within the Pond
Outflow Design dialog box, you can view detailed data about the selected pond
by clicking the Pond button.

**To display data about the current pond in the Pond Outflow Design dialog box**

1 From the Hydrology menu, choose Outflow Editor ➤ By Pond to display the
   Pond Name dialog box.
2 Select the name of the pond, and then click OK to display the Pond Outflow
   Design dialog box.
3 Click Pond at the bottom of the dialog box to display the Pond Properties dialog
   box.

![Pond Properties](image)

**NOTE**
This information is for display only. You cannot edit it.

4 Click OK to close the Pond Properties dialog box.

Adding and Editing Outlet Structures to a Pond - By Pond
Creating a Pond Rating or a Stage-Discharge Curve for the Current Pond

While you are designing the inflow and outflow structures for a pond, you can review the resultant stage-discharge and rating curves and you can save them to files that you can use when calculating the pond routing.

To create a pond rating or a stage-discharge curve for the current pond

1. From the Hydrology menu, choose Outflow Editor ➤ By Pond to display the Pond Name dialog box.
2. Select the name of the pond, and then click OK to display the Pond Outflow Design dialog box.
3. Click Plot at the bottom of the dialog box to display the Outflow Curve dialog box.
   The stage-discharge and rating curves plot the depth (or stage) against the flowrate. You can use the Begin Elev and End Elev boxes to define the elevation range for which you want to view the flowrate.
4. In the Begin Elev box, type the elevation at which to begin the elevation range.
5. In the End Elev box, type the elevation at which to end the elevation range.
6. In the Increment box, type the elevation increment for the graph of the rating table curve or stage discharge curve.
7. To retain the outflow curve setup settings made in the Outflow Curve dialog box, select the Keep Settings check box.
8. To display a curve, do one of the following:
   - Click Rating Table to display the composite rating curve.
   - Click Stage-Discharge to display the stage-discharge curve.
9. From the Rating Curve Display dialog box or the Stage-Discharge Curve dialog box, change the graph settings, plot the data, save or output the curve:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the hydrograph’s settings</td>
<td>Settings.</td>
</tr>
<tr>
<td>plot the data on a graph and insert the graph in your drawing</td>
<td>Plot.</td>
</tr>
<tr>
<td>output the data to an ASCII or .wk1 file</td>
<td>Output.</td>
</tr>
<tr>
<td>save the graph</td>
<td>Save.</td>
</tr>
</tbody>
</table>

10. To save the rating curve, click Save Rating Curve to display the Save Rating Curve File dialog box. Save the file to c:\Land Projects R2\<project name>\hd folder. The rating curve file is saved with an .rtc file extension.
11. To save the stage-discharge curve, click Save Stage-Discharge.
    The Save Stage-Discharge File dialog box is displayed. Save the file to c:\Land Projects R2\<project name>\hd folder. The stage-discharge file is saved with an .sdc file extension.
12 Click OK to close the Outflow Curve dialog box and return to the Pond Outflow Design dialog box.

Adding and Editing Outlet Structures to a Pond Using a Stage-Storage Curve

Use the Outflow Editor ➤ By Stage-Storage Curve command on the Hydrology menu to design inflow and outflow structures for a pond that was saved as a stage-storage curve.

This command works the same as the Outflow Editor ➤ By Pond command on the Hydrology menu, except that instead of selecting a pond at the beginning of the command, you are prompted to select a stage-storage curve (.ssc file).

Changing the Data Created By the Pond Outflow Editor

Use the Outflow Editor ➤ Editor command on the Hydrology menu to open a .pda file that you previously saved through the Pond Outflow Design dialog box.

When you select this command, you are prompted to load a .pda file, and then the Pond Outflow Design dialog box is displayed, where you can add, edit, or delete structures for a pond.
Working with Profiles and Vertical Alignments

Use the Profiles commands to create existing and finished ground profiles. You can sample a surface, a file, or sections to obtain surface data from which to generate the existing ground profile. You can design the finished ground profile by drawing tangents and vertical curves, that you can then define as vertical alignments.
Overview of Working with Profiles and Vertical Alignments

Use the Profiles commands to create existing ground and finished ground profiles. You can sample a surface, a file, or cross sections to obtain surface data from which to generate the existing ground profile. You can create a full profile with a grid and labels, or you can create a quick profile without vertical grid lines or station elevations. You can also create profiles that represent subsurfaces.

After you create the existing ground profile, you can design the finished ground profile by drawing tangents and vertical curves to represent the finished ground centerline and/or ditches and transitions. Then you can define these tangents and vertical curves as a vertical alignment.

After you define a vertical alignment, you can edit the alignment from within the Vertical Alignment Editor. The vertical alignment data is used with the horizontal alignment data to define the finished ground cross sections.

Where the Alignment and Profile Data Are Stored

The alignment folder (c:\Land Projects R2\<project name>\align) contains all the files for the horizontal alignments in the project. Each alignment that has a profile or cross sections has a unique folder under the \align folder. This subfolder contains all of the profile and cross section files for the alignment. For example, if you have an alignment called MAIN ST in the project called P101, you can find all of the profile and cross section files in the \P101\ALIGN\MAIN ST folder.


Each profile, when inserted into the drawing, contains a profile block. This invisible block contains attributes that are necessary to locate, draw, and read information from the profile. If you wish to view the attribute block, use the AutoCAD command ATTDISP (attribute display) to turn on the invisible attributes and zoom in to the lower-left corner of the profile.

NOTE To see the block, you may need to zoom in tightly because this block is very small.

Additional profile settings are located in the <dwgname>.dfm file; this file is located in the \<project name>\dwg folder. The profile settings contain the drawing defaults for profile layer names, scales, and label increments.
Changing the Profile Settings

Before you work with profiles, you should set up the profile settings. Profile settings include the following:

- Sampling settings, which control how the existing ground data is sampled.
- Existing ground layer settings, which control the layers on which the existing ground profile graphics and labels are placed.
- Finished ground layer settings, which control the layers on which the finished ground profile graphics and labels are placed.
- Labels and prefix settings, which control the layer prefix to use for profile layers as well as the text that is used for profile labels.
- Values settings, which control label increments and vertical curve K and passing and stopping sight settings, as well as label precision.

Changing the Settings for Sampling Existing Ground Data for Profiles

Before you sample the existing ground to retrieve profile data, you can set up the profile sampling settings. The sampling settings are only used when you sample the existing ground by using the Sample From Surface command on the Profiles ➤ Existing Ground menu.

The sampling settings control:

- how often curves and spirals on the alignment are sampled, if the existing ground is sampled to the left and right of the centerline
- whether sample lines are created that show the limits of the sampled area

To change the settings for sampling existing ground data for profiles

1 From the Profiles menu, choose Profile Settings ➤ Sampling to display the Profile Sampling Settings dialog box.
2 In the Sample offset tolerance box, type the sample offset tolerance.

Profile elevations are calculated at each point that the horizontal alignment crosses a surface triangle edge. To improve profile definition in areas with large surface triangles, this value determines whether supplemental elevations are sampled along curves and spirals.

The sample offset tolerance dictates how large the mid-ordinate distance of a curve or spiral can be between sample points. The default is half a unit. This means that if the traced chord is more than half a foot or meter away from the actual curve, then the command samples additional elevation so that the chord for each curve segment does not exceed the sample offset tolerance (half a foot or meter) away from the curve. This only affects the rate at which the existing ground elevations are sampled on a curve. The actual profile always follows the true surface exactly.

3 Under Sample Lines, select the Import check box to place sample lines in plan view so you can see the locations that are being sampled.

The sample lines are imported onto the specified layer even if the layer is frozen. Importing sample lines is useful to verify that the graphic representation of the alignment in the drawing matches the alignment database file.

When the Import check box is selected, the Layer box becomes active.

4 In the Layer box, type the layer for the profile sample lines.

5 Under Left and Right Sampling, select the Sample left/right check box to sample the left and right offsets of the alignment.

If this box is not selected, then only the profile centerline is sampled.

6 In the Sample left offset and Sample right offset boxes, enter sample offset values.

Normally you enter positive values for left and right sides. If you use a negative value, then the sampling is done on the opposite side of the alignment. For example, if you specify -10 for the left sampling width, then the command samples 10 units to the right of the alignment. The sample offset widths cannot be greater than the smallest radii of the alignment.

When sampling left and right of the alignment, the command gives slightly inaccurate data at PIs (Points of Intersection) that have no horizontal curve due to overlapping or disjunct offset lines.

7 Click OK to save the sampling settings.

**Changing the Existing Ground Layers Settings for Profiles**

To change the existing ground layers for use with the Profiles commands, use the EG Layers command. You can assign each existing ground profile definition to a separate, unique layer. If you intend on having more than one profile in a drawing, then set these layer names to unique names before creating each profile for easier layer management.

These layer settings are stored with the invisible profile block that is created when you generate a profile. You cannot change these settings for a profile after the profile has been created in the drawing. If you want to update a profile with these changes, then you must recreate the profile by using the Full Profile, Surface Profile, or Quick Profile command.
NOTE You can assign each finished ground alignment to a separate layer as well.

To change the existing ground layer settings for profiles
1 From the Profiles menu, choose Profile Settings ➤ EG Layers to display the Existing Ground Layer Settings dialog box.

2 Under Surfaces, type the layer names for the profile centerline and left and right offsets.

   The left and right offsets for the existing ground profile are created if you choose to sample to the left and right of the centerline when you sample the existing ground surface. To bring these offsets into the drawing, you must choose the option to import these sample lines when you sample the profile.

3 Under Text, specify the layer names for the annotation text for the profile in the appropriate boxes:
   ■ In the Station box, type the layer name for the stationing text.
   ■ In the Center box, type the layer name for the text used to label elevations for the profile.
   ■ In the Left and Right boxes, type the layer names for the text used to label elevations for the left and right offsets.

4 Under Base, type the layer names for the horizontal and vertical elements of the profile base.

5 Under Grid, do the following:
   ■ In the Grid box, type the layer name for the elements of the profile grid.
   ■ In the Text box, type the layer name for the text used to annotate the profile grid.

6 Click OK.
The following illustration shows the default layer names for each part of the profile:

![Layer Illustration]

**Base grids and profile surfaces detail**

### Changing the Finished Ground Layers Settings for Profiles

To change the finished ground layers for use with the Profiles commands, use the FG Layers command. You can assign each finished ground profile definition to a separate, unique layer. If you intend on having more than one profile in a drawing, then set these layer names to unique names before creating each profile for easier layer management.

These layer settings are stored with the invisible profile block that is created when you generate a profile. You cannot change these settings for a profile after the profile has been created. If you want to update a profile with these layer changes, then you must recreate the profile by using the Full Profile, Surface Profile, or Quick Profile command.

**NOTE** You can assign each finished ground alignment to a separate layer as well.
To change the finished ground layers settings for profiles

1. From the Profiles menu, choose Profile Settings ➤ FG Layers to display the Finished Ground Layer Settings dialog box.

![Finished Ground Layer Settings dialog box]

2. Under Finished Ground, enter the appropriate layer names:
   - In the Center box, type the layer name for the finished ground centerline.
   - In the Text box, type the layer name for the text used to label elevations for the finished ground centerline.
   - In the Ditch boxes, type the layer names for the left and right ditch profile surfaces.
   - In the 1st - 8th trans boxes, type the layer names for the transition profile surfaces.

3. Click OK.

Changing the Label and Layer Prefix Settings for Profiles

The Labels and Prefix settings control the layer prefix setting and the profile label settings. For easier layer management when working with profiles, you can assign a layer prefix. This layer prefix is appended to all profile layer names associated with the current alignment.

Each type of profile label has a piece of text that is inserted with the label to indicate what type of label it is. You can change these text strings if you have a different convention for labeling profile elements.
To change the labels and prefix settings for profiles

1. From the Profiles menu, choose Profile Settings ➤ Labels and Prefix to display the Profile Labels Settings dialog box.

   ![Profile Labels Settings dialog box]

2. Under Layer Prefix, type the layer prefix in the Layer prefix box.

   The layer prefix is appended to all profile layer names associated with the current alignment. The layer prefix can include any alphanumeric character. To automatically include the current alignment name in the layer prefix, type an asterisk (*). For example, if the current alignment name is 202CL, a layer prefix entered as *- (asterisk, hyphen) forces all profile layers to have the prefix 202CL-.

   **NOTE** The Profiles commands use the setting suffixes you set with the EG Layers and FG Layers commands to create the layer names. For example, if you set a prefix of ROAD and the default suffix is PEGC, the layer name is ROADPEGC. The command uses the default suffix for each surface name if you use multiple surfaces.

3. Under Label Text, change the following label text strings as needed.

   - Beginning vertical curve station label box: Type the text for marking the station at the beginning of a vertical curve.
   - Beginning vertical curve elevation box: Type the text for marking the elevation at the beginning of a vertical curve.
   - Ending vertical curve station label box: Type the text for marking the station at the end of a vertical curve.
   - Ending vertical curve elevation box: Type the text for marking the elevation at the end of a vertical curve.
   - High point label box: Type the text for marking the highest elevation point of a vertical curve.
- Low point label box: Type the text for marking the lowest elevation point of a vertical curve.
- Point of vertical intersection (PVI) box: Type the text for marking the (vertical) intersection of two tangents.
- Algebraic difference (A.D.) box: The label indicates the algebraic difference as a percentage. (Grade of the tangent out of the vertical curve, subtracted from the grade of the tangent into the vertical curve.)
- Curve coefficient (K) box: The label indicates the curve coefficient; also known as the K value of a curve. The K value or curve coefficient is the horizontal distance needed to effect a 1% change in grade on the vertical curve.

### Changing the Values Settings for Profiles

The profile values settings control stationing increments for labels and grid lines, minimum K values for sag and crest vertical curves, sight distance values for vertical curves based on passing height and stopping height, and label precision values.

#### To change the values settings for profiles

1. From the Profiles menu, choose Profile Settings ➤ Values to display the Profile Value Settings dialog box.

   ![Profile Value Settings](image)

2. Under Stationing Increments, do the following:
   - In the Tangent labels box, type the distance between tangent elevation labels.
   - In the Vertical grid lines box, type the vertical grid line increment. This increment is the horizontal distance between vertical grid lines.
   - In the Vertical curve labels box, type the distance between vertical curve elevation labels.
3 Under K Values, do the following:
   - In the Minimum for crest box, type the minimum K value for crest vertical curves. The K value of a vertical curve is the horizontal distance required to affect a 1% change in grade on the vertical curve.
   - In the Minimum for sag box, type the minimum K value for sag vertical curves.

   **NOTE** Vertical curves that do not meet the parameters set in the K value boxes are flagged in the Vertical Curve Detail Window dialog box by placing a *** in front of the Min. Length value.

4 Under Sight Distance Values, do the following:
   - In the Passing eye height box, type the default passing eye height value. This is the height of the eye of the driver of the car doing the passing.
   - In the Passing object height box, type the default passing object height value. This is the height of the object being approached when passing (usually another vehicle).
   - In the Stopping eye height box, type the default stopping eye height value. This is the height of the eye of the driver of the car.
   - In the Stopping object height box, type the default stopping object height value. This is the height of the object being avoided (usually a piece of debris).

5 Under Label Precision Values, set the label precision values for the existing ground and finished ground labels. You can type precision values in the boxes, or you can control the precision by using the slider bars.

6 Click OK.

   **NOTE** If you need to alter values for a profile that you have already plotted, then you can use the Profile Properties command, and then reimport the profile.

---

**Sampling Existing Ground Profile Data from Multiple Surfaces**

To create a profile, you must first define and sample the existing ground from a surface, a file, or from cross sections. When sampling the existing ground data from surfaces, you have the option to sample one or multiple surfaces at the same time. To sample multiple surfaces, you must first create a file of the surface names that you want to sample using the Select Multiple Surfaces command. Then you must enable the use of multiple surfaces before sampling the data using the Toggle Multiple Surfaces command.

**Selecting a Surface to Sample**

To sample profile data from one surface, that surface must be selected as the current surface. Before you sample the existing ground profile, use the Set Current Surface command to select the current surface.
To select a surface to sample

1. From the Profiles menu, choose Surfaces ➤ Set Current Surface to display the Select Surface dialog box.

2. If the current surface list is set to Volume Surface, select the Terrain Surface radio button to change the surfaces that are displayed in the list.

3. In the Select surface to open list, select the surface you want to use.

4. Click OK to set the selected surface as current.

Using Multiple Surfaces when Sampling the Existing Ground Profile Data

You can sample the existing ground surface for profile generation from more than one surface. If you create a file of multiple surfaces using the Select Multiple Surface command, then that list of surfaces is used if multiple surfaces are enabled. To enable the use of multiple surfaces, use the Toggle Multiple Surfaces command. To use multiple surfaces when sampling the existing ground profile data, use the multiple surfaces option.

1. From the Profiles menu, choose Surfaces ➤ Toggle Multiple Surfaces.

   A prompt is displayed on the command line, stating that multiple surfaces are on or off.

   If multiple surfaces are on, then the Sample From Surface commands in the Profiles and Sections menus use all the surface names in the surfaces.txt file created by the Select Multiple Surfaces command. Each surface added to the list is used to define the profile surface and subsurface data. The commands extract elevations for the profile or sections from the surface file associated with each surface name in the list. The Surface Profile command adds the subsurface to an existing profile without adding vertical grid lines or station elevations.
If multiple surfaces are off, then the Sample From Surface commands do not use the surfaces.txt file.

**Creating a File of Multiple Surfaces for Sampling the Existing Ground Profile Data**

If you want to create a profile definition with existing ground subsurface information, then use the Select Multiple Surfaces command. This command creates a file named surfaces.txt that contains the list of surfaces to sample.

This command is intended for use in situations when you want to sample subsurface data as well as the top existing ground surface from multiple terrain surfaces. When you sample a profile from multiple surfaces, the profile contains separate existing profile definitions for each surface. When you create a full profile in the drawing, the command prompts you which existing ground surface to use as the primary existing ground surface. You typically import the top surface first to get the correct profile elevation labels. After that, you can run the Surface Profile command to import the subsurfaces onto the profile. However, subsurfaces are not given elevation labels.

**To create a file of multiple surfaces for sampling the existing ground profile data**

1. From the Profiles menu, choose Surfaces ➤ Select Multiple Surfaces to display the Multiple Surface Selection dialog box.
2. In the Select from list box on the left, hold down the CTRL key and click the names of the surfaces you want to sample.
   - The surface name now appears in the Current list box on the right.
3. You can remove a surface from the Current list by holding down the CTRL key and selecting the highlighted surface name from the Select from list box on the left.
4. Click OK to use all the surfaces listed in the Current list.

Now when you sample the existing ground profile data, the data from all of the selected surfaces is sampled if you used the Toggle Multiple Surfaces command.
Creating Existing Ground Profiles

You can draft an existing ground profile in your drawing, and then add finished ground roadway design geometry to represent what the roadway will look like in profile view.

Before you create a profile, configure the profile settings. For more information, see “Changing the Profile Settings” in this chapter. When you create a profile, an invisible block is inserted at the profile insertion point. This block holds the information specific to that particular plot of the profile including the location in the drawing, the vertical exaggeration, and the layer settings. This block also holds all the Values settings for the profile, which is why the settings must be configured before you use the Full Profile, Surface Profile, or Quick Profile command.

Editing the Vertical Alignments with the Vertical Alignment Editor

You can use the Vertical Alignment Editor to edit or create any existing ground or finished ground vertical alignment. If you have already created the existing ground surface, then you can use this editor to view or edit the information that was generated. You can also use the editor as an alternative to the Sample From File and Sample From Surface commands to create existing ground or as an alternative to the Define FG Centerline and Define Ditch/Transition command to create finished ground information.

Characteristics of the Vertical Alignment Editor Dialog Box

- Unlike the Horizontal Alignment Editor, the Vertical Alignment Editor is not dynamically linked to the drawing entities. From the Profiles menu, you can choose FG Vertical Alignments ➤ Import command (or the DT Vertical Alignments ➤ Import command) to import the changed profile alignments into the drawing.
- The station values must fall within the range of the alignment.
- If a curve length does not meet the required length set for the K value, the minimum curve length is flagged in the Vertical Curve Detail Window section of the Vertical Alignment Editor dialog box. The minimum K values can be adjusted from the Vertical Alignment Editor using the Values button.
- The Edit Vertical Alignment command prompts for an existing ground surface to edit if you sampled multiple existing ground surfaces. Use the arrow keys to select the surface to edit, and then press ENTER. You can edit only one surface at a time. You can access finished ground information no matter which surface you select.
- The Vertical Alignment Editor uses the precision values set by the Drawing Setup command to display the values.
- After you create the profile data with the Vertical Alignment Editor, you can use this information to generate profiles. You can create existing ground center, and left and right profiles with the Full Profile or Quick Profile commands. To import the finished ground centerline into the drawing, click
Vertical Alignments ➤ Import in the FG Centerline section of the Profiles menu. To import any of the finished ground ditch, or left and right profiles, click Vertical Alignments ➤ Import in the Ditches and Transitions section of the Profiles menu.

- You can access the Labels Settings and the Profile Value Settings dialog boxes by clicking Labels and Values in the Vertical Alignment Editor.

To navigate through the information in the vertical alignment editor if there is more than one page of data, use the following buttons:
- Click H to move the display to the first line.
- Click U to move the window up one page.
- Click A to move the display up one line.
- Click V to move the display down one line.
- Click D to move the window down one page.
- Click E to move the display to the last line.

Creating Vertical Alignment Data with the Vertical Alignment Editor

To create and edit the vertical alignment data with the vertical alignment editor

1 Display the Vertical Alignment Editor dialog box in one of the following ways:
   - From the Profiles menu, choose FG Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose DT Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose Existing Ground ➤ Edit Vertical Alignment.

The Vertical Alignment Editor dialog box is displayed.
2 From the Vert. Alignment list, select the alignment to create:

<table>
<thead>
<tr>
<th>If there is...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>no data for a selected alignment</td>
<td>the Vertical Alignment Creation dialog box is displayed.</td>
</tr>
<tr>
<td>data for the selected alignment</td>
<td>the Vertical Alignment Editor dialog box is displayed.</td>
</tr>
<tr>
<td></td>
<td>Under Settings, select the alignment to create. Click Yes to display the Vertical Alignment Editor dialog box.</td>
</tr>
</tbody>
</table>

3 Enter the PVI station and elevation data in the Vertical Alignment Creation Editor dialog box.

The starting and ending points of an alignment are considered PVIs. Tab between columns. The % grade is calculated from the horizontal distance and difference in elevation between the PVIs.

NOTE You cannot edit the % grade field in the Vertical Alignment Creation Editor dialog box. However, you can edit the % grade when you return to the Vertical Alignment Editor dialog box.

4 Click OK to return to the Vertical Alignment Editor dialog box.

5 You can edit the vertical alignment data using the options in the Edit area of the Vertical Alignment Editor.

6 To insert a new PVI, click Insert PVI.

When you select this button, the command adds a new row to the editor above the row where the cursor is located. Press ENTER or Tab to move between the columns. Enter the station and elevation of the PVI. The percent grade is calculated to reflect the new PVI. Enter the vertical curve length, if required.

7 To delete a PVI, place your cursor in the row you want to delete and select Delete PVI.

A confirmation dialog box displays. Click Yes to delete the station. The station, elevation and grade for the remaining PVIs are automatically recalculated to reflect the new PVI coordinates.

### Editing a Vertical Curve with the Vertical Alignment Editor

To edit a vertical curve with the vertical alignment editor

1 Display the Vertical Alignment Editor dialog box in one of the following ways:
   - From the Profiles menu, choose FG Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose DT Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose Existing Ground ➤ Edit Vertical Alignment.

2 From the Vert. Alignment list, select the finished ground alignment to edit (curve data for existing ground alignments is not editable).

3 Place your cursor in the row of the curve to edit, then click Edit Curve.
4 You can edit the following vertical curve parameters:

- Type a Curve Length to define the distance between the PVC (Point of Vertical Curvature) and the PVT (Point of Vertical Tangency).
- Type a K Value to define the K value of a vertical curve is the horizontal distance required to effect a 1% change in grade on the vertical curve. \( K = \frac{\text{Length of curve}}{|\text{Grade in}| - |\text{Grade out}|}. \) |\( X \) refers to Absolute Value.
- Type a High Point Elevation to define the elevation of the highest point on a crest vertical curve.
- Type a High Point Station to define the station of the highest point on a crest vertical curve.
- Type a Low Point Elevation to define the elevation of the lowest point on a sag vertical curve.
- Type a Low Point Station to define the station of the lowest point on a sag vertical curve.
- Type a Passing Sight Distance to define the distance measured to a point where an approaching vehicle comes into view ahead of a driver on an undivided road. This is used to calculate crest vertical curves.
- Type a Stopping Sight Distance to define the distance measured to a point where an object comes into view requiring the driver to stop. This value is used to calculate crest vertical curves.

Not all of these options are available for each type of vertical curve box. All vertical curve variables are interrelated, therefore, any edits you make to the curve data automatically update any corresponding curve data. Use Next and Prev to navigate from curve to curve.

5 Click OK to return to the Vertical Alignment Editor and save the edits.

Copying the Vertical Alignment Surfaces with the Vertical Alignment Editor

To save time creating vertical alignment data, you can use the Vertical Alignment Editor to copy the data from one vertical alignment to another, and then edit that copy.

To copy a vertical alignment surface to another surface or vertical alignment

1 Display the Vertical Alignment Editor dialog box in one of the following ways:
   - From the Profiles menu, choose FG Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose DT Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose Existing Ground ➤ Edit Vertical Alignment.

2 From the Vert. Alignment list, select the alignment to copy.
3 Click Copy Surf to display the Copy Surface dialog box.
4 Using the To Surface list, set the surface to copy the current surface.
   The From Surface label shows the current surface or vertical alignment selected.
5 Click OK to copy the surface.
Changing the Surface Elevations with the Vertical Alignment Editor

You can apply an elevational change to a range of stations on a vertical alignment by using the Vertical Alignment Editor.

To change the surface elevations with the Vertical Alignment Editor
1 Display the Vertical Alignment Editor dialog box in one of the following ways:
   - From the Profiles menu, choose FG Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose DT Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose Existing Ground ➤ Edit Vertical Alignment.
2 From the Vert. Alignment list, select the alignment you want to edit.
3 Click Edit Elevs to display the Edit Surface Elevations dialog box.
4 In the Beginning Station and Ending Station boxes, specify the station range to which the elevation change is applied.
5 In the Elevation Change box, specify the increment by which to change the elevation.
   Enter a positive value to move all the elevations up (do not use a plus sign (+) symbol), or a negative value to lower the elevations to move all the elevations down.
6 Click OK.

Creating Vertical Alignment Reports

From within the Vertical Alignment Editor, you can generate reports that list station, curve, and incremental information about a selected vertical alignment.

Changing the Vertical Alignment Report Settings

To change the vertical alignment report settings
1 Display the Vertical Alignment Editor dialog box in one of the following three ways:
   - From the Profiles menu, choose FG Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose DT Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose Existing Ground ➤ Edit Vertical Alignment.
2 Under Reports, click Settings to display the Output Settings dialog box.
   NOTE The Vertical Alignment Editor always generates the report data to a file, whether or not you select or clear File and Screen under Output Options.
3 Under Output Format, select or clear the appropriate check boxes:
   - **Date**: Select this check box to place the date on the report.
   - **Title**: Select this check box to place a title on the report.
- **Page Breaks**: Select this check box to place page breaks in the report. When you select this check box, and create a Screen report, the text window displays only the first page of the information, and then prompts you to press a key to continue. When you press a key, the next page of the report is displayed.

If you clear this check box, and create a File report, the report is created with page breaks instead of having all the information displayed in one long list. If you select the Sub Headers check box and the Page Breaks check box, then sub headers are placed at the beginning of each page break.

- **Page Numbers**: Select this check box to place page numbers on a report. This setting applies to File output only.

- **Sub Headers**: Select this check box to place sub headers at the beginning of each new page of a report. This setting applies to File output only. You must also select the Page Breaks check box if you want sub headers to appear. The sub headers are placed at the beginning of each page break.

- **Overwrite File**: Select this check box to overwrite a file if it already exists. Clear this check box to append new information to the end of an existing file.

**NOTE** Be sure to also specify the correct Output File Name for the report.

Also under Output Format, specify the following information:

- **Page Length**: Type the number of rows of type you want on each page in this box. The spacing is measured in characters. This setting applies only if the Page Breaks check box is selected and applies only to File output.

- **Page Width**: Type the number of characters you want across each page in this box. This setting applies only to File output and affects the output of the stakeout file. If the page width is too narrow, then the lines wrap.

- **Left Margin**: Type the number of characters you want as a left margin in this box. This setting applies only to File output.

- **Right Margin**: Type the number of characters you want as a right margin in this box. This setting applies only to File output.

- **Top Margin**: Type the number of characters you want as a top margin in this box. The margin is inserted between the page number (if you select the Page Numbers option) and the report title. This setting applies only to File output.

- **Bottom Margin**: Type the number of characters you want as a bottom margin in this box. This setting applies only to File output.

For more information on the format for ASCII output files of profile information, see “Format for the ASCII Output Files of the Profile Information” in this chapter.

4 Type the Output File Name.

**NOTE** Each time you create a new report, be sure to change the default output file name so you do not overwrite the previous report (when the Overwrite File check box is also selected). If you do not change the output file name and the Overwrite File check box is cleared, then no report is created.
You can click Output File Name to specify a folder for the output file. If you do not specify an output folder, the file that is created is placed in the current project folder.

Click OK.

Creating a Vertical Alignment Report at PVI Stations

You can use the Vertical Alignment Editor to generate a report that lists the station, elevation, and curve length at each PVI for the currently displayed vertical alignment. This report also lists the percent grade that exists between each PVI. If a vertical curve exists at a PVI, then the report also lists the vertical curve length.

To create a vertical alignment report at vertices

1. Change the vertical alignment report settings.
   For more information, see “Changing the Vertical Alignment Report Settings” in this chapter.

2. Display the Vertical Alignment Editor dialog box in one of the following ways:
   - From the Profiles menu, choose FG Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose DT Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose Existing Ground ➤ Edit Vertical Alignment.

3. Under Reports, click Station.

4. Type the station at which you want to begin the report.

5. Type the station at which you want to end the report.

6. Type the output file name including path or accept the default by pressing ENTER.
   The report is created in the current project folder.

The following report is an example of a vertical alignment station report:

<table>
<thead>
<tr>
<th>Station</th>
<th>Elevation</th>
<th>Curve Length</th>
<th>Grade</th>
</tr>
</thead>
<tbody>
<tr>
<td>0+00</td>
<td>132.56</td>
<td>-1.60</td>
<td></td>
</tr>
<tr>
<td>0+70</td>
<td>131.44</td>
<td>3.75</td>
<td></td>
</tr>
<tr>
<td>1+75.50</td>
<td>135.40</td>
<td>-2.25</td>
<td></td>
</tr>
<tr>
<td>5+16</td>
<td>127.74</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Creating a Vertical Curve Report

You can use the Vertical Alignment Editor to generate a report that lists the type of vertical curve (crest or sag); PVC, PVI, and PVT stations and elevations; the % grade in; the % grade out; percent grade change; K value, curve length; minimum curve length; station and elevation of the high/low point; passing sight distance; and stopping sight distance.
To create a vertical curve report

1 Change the vertical alignment report settings.
   For more information, see “Changing the Vertical Alignment Report Settings” in this chapter.

2 Display the Vertical Alignment Editor dialog box in one of the following ways:
   ■ From the Profiles menu, choose FG Vertical Alignments ➤ Edit.
   ■ From the Profiles menu, choose DT Vertical Alignments ➤ Edit.
   ■ From the Profiles menu, choose Existing Ground ➤ Edit Vertical Alignment.

3 Under Reports, click Curve.

4 Type the station at which you want to begin the report.

5 Type the station at which you want to end the report.

6 Type the output file name or accept the default by pressing ENTER.
   The report is created in the current project folder.
   The following report is an example of a vertical curve report:

   **Vertical Curve Information: Crest curve**

   PVC Station: 3+28.65 Elevation: 98.38
   PVI Station: 4+22.45 Elevation: 101.99
   PVT Station: 5+16.25 Elevation: 99.31
   Grade in (%): 3.85 Grade out (%): -2.85
   Change (%): -6.70 K-Value: 27.98
   Curve Length: 187.60 Min. Length: 0.00
   HIGH Station: 4+36.42 Elevation: 100.45
   Passing SD: 324.44 Stopping SD: 192.92

Creating a Station and Vertical Curve Report

You can use the Vertical Alignment Editor to generate a report that includes both station and detailed vertical curve data. This report is a combination of the Station report and the Curve report. For each PVI, the report lists the station, elevation, and curve length at each vertical alignment PVI. This report also lists the percent grade that exists between each PVI.

If a vertical curve exists at an alignment PVI, then a report is generated that lists the type of vertical curve (crest or sag); PVC, PVI, and PVT stations and elevations; grade in; grade out; percent grade change; K value; curve length; minimum curve length; station and elevation of the high/low point; passing sight distance; and stopping sight distance.
To create a station and vertical curve report

1. Change the vertical alignment report settings.
   For more information, see “Changing the Vertical Alignment Report Settings” in this chapter.

2. Display the Vertical Alignment Editor dialog box in one of the following ways:
   - From the Profiles menu, choose FG Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose DT Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose Existing Ground ➤ Edit Vertical Alignment.

3. Under Reports, click Sta and Crv.
4. Type the station at which you want to begin the report.
5. Type the station at which you want to end the report.
6. Type the output file name or accept the default by pressing ENTER.
   The report is created in the current project folder.

Creating a Report of Vertical Alignment Data at Increments Along the Centerline

You can use the Vertical Alignment Editor to generate a report based on an entered increment that lists profile information for the range of stations defined (i.e., EGC, EGL, EGR, and FGC).

To create a vertical curve report

1. Change the vertical alignment report settings.
   For more information, see “Changing the Vertical Alignment Report Settings” in this chapter.

2. Display the Vertical Alignment Editor dialog box in one of the following ways:
   - From the Profiles menu, choose FG Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose DT Vertical Alignments ➤ Edit.
   - From the Profiles menu, choose Existing Ground ➤ Edit Vertical Alignment.

3. Under Reports, click By Incr.
4. Type the station at which you want to begin the report.
5. Type the station at which you want to end the report.
6. Type the output file name or accept the default by pressing ENTER.
   The report is created in the current project folder.
The following report is an example of a sample output of the file:

<table>
<thead>
<tr>
<th>Station</th>
<th>EGC</th>
<th>EGL</th>
<th>EGR</th>
<th>FGC</th>
</tr>
</thead>
<tbody>
<tr>
<td>0+00.00</td>
<td>100.00</td>
<td>100.00</td>
<td>100.00</td>
<td>86.06</td>
</tr>
<tr>
<td>0+50.00</td>
<td>100.00</td>
<td>100.00</td>
<td>100.00</td>
<td>87.99</td>
</tr>
<tr>
<td>1+00.00</td>
<td>100.00</td>
<td>100.00</td>
<td>100.00</td>
<td>89.91</td>
</tr>
<tr>
<td>1+50.00</td>
<td>100.13</td>
<td>100.52</td>
<td>100.00</td>
<td>91.84</td>
</tr>
<tr>
<td>2+00.00</td>
<td>103.10</td>
<td>103.48</td>
<td>102.75</td>
<td>93.76</td>
</tr>
<tr>
<td>2+50.00</td>
<td>106.06</td>
<td>106.46</td>
<td>105.69</td>
<td>95.69</td>
</tr>
<tr>
<td>3+00.00</td>
<td>109.02</td>
<td>109.43</td>
<td>108.65</td>
<td>97.61</td>
</tr>
<tr>
<td>3+50.00</td>
<td>112.10</td>
<td>112.57</td>
<td>111.71</td>
<td>99.38</td>
</tr>
<tr>
<td>4+00.00</td>
<td>115.23</td>
<td>115.73</td>
<td>114.86</td>
<td>100.32</td>
</tr>
</tbody>
</table>

Creating and Editing Profiles

From the Profile menu, the Create Profile submenu has commands that create full, surface, quick, and grid profiles. Once you have created a profile, you can make the profile current; list existing ground elevations for the profile centerline; move or export the profile to recreate a profile information block; change profile properties; and remove the profile definition block from a drawing.

Creating Profiles

After you create the existing ground data for an alignment, you can generate a profile. You can create a full profile, which includes a datum line, datum elevation, existing ground, existing ground text, and grid base. Or, you can create a quick profile, which is created without a horizontal or vertical grid base or station elevations. To define the finished ground definition, or to annotate the profile create a full profile.

If you sampled multiple surfaces, then you can create subsurface profiles. Typically you would create a full profile of the existing ground top surface, and then create subsurface profiles for any other subsurfaces you sampled.

When you generate a profile, you have the option to import the left and right profiles (if you sampled left and right offsets for the existing ground). You can also specify the station range and datum elevation for the profile, you can control whether the profile is created from left to right or right to left, and you can control whether a grid is inserted with the profile.

NOTE

By specifying the station range you can import a subset of the entire profile, but for defining the finished ground profile definition you should work with the entire length of the profile. The ability to import a subset of the entire profile is just for plotting purposes.
Be sure to set the profile settings before creating profiles. Many of the profile settings, like layers, are stored with the profile and cannot be changed after the profile is created.

**Creating a Complete Profile**

You can use the Full Profile command to create a profile that includes a datum (base) line, datum elevation, existing ground, existing ground labels, and grid base. If you sampled left and right of the centerline when you sampled the existing ground, then you can also create profiles of these alignments.

**NOTE**

To display multiple surfaces on the profile, you must enable the use of multiple surfaces and you must sample multiple surface data. You can then use the Full Profile command for the first surface. To display any additional subsurfaces, use the Surface Profile command.

To create a complete profile

1. Create a surface, if you haven’t done so already.
2. Create a horizontal alignment, if you haven’t done so already.
3. Using the Profile Settings commands on the Profiles menu, configure the profile settings, if you haven’t done so already.
   For more information, see “Changing the Profile Settings” in this chapter.
4. Using the Sample From Surface, the Sample From File, Sample From Sections, or the Edit Vertical Alignment commands, sample an existing ground surface.
5. From the Profiles menu, choose Create Profile ➤ Full Profile to display the Profile Generator dialog box.

The Full Profile command creates a profile that includes a datum line, datum elevation, existing ground, existing ground text, and grid base. If you sampled
left and right of the centerline when you sampled the existing ground, then you can also create profiles of these alignments with the Full Profile command.

6 Under Station Range, in the Start and End boxes, set the station range. The defaults are the defined starting and ending stations for the current alignment. This range defines the range of the current alignment for which the profile is created.

The Datum Elevation Entry section of the dialog box lists the maximum and minimum elevations for the alignment within the defined station range.

7 In the Datum box, enter the datum elevation. This is the base elevation of the plotted profile.

The datum elevation default is based on the minimum elevation in the profile.

8 Using the Vertical scale box, edit the vertical scale. The vertical scale is compared to the horizontal scale set during the drawing setup to determine the vertical exaggeration of the profile. If the horizontal scale is \(1'=50'\), a vertical scale of 5.00 (1"=5') produces a vertical exaggeration of 10.

9 Under Profile creation parameters, click the appropriate option to specify the direction in which the profile is to be drawn, to the right or to the left.

10 Select the Import Left/Right profiles check box to import the existing ground profiles to the left and right of the centerline.

You can import these profiles only if you selected the Sample left/right check box in the Profile Sampling Settings dialog box before you sampled the profile information. If this check box is cleared, only profile surfaces are imported.

11 Select the Import grid check box to import a profile base grid.

12 Set the horizontal spacing, vertical spacing, and grid height in the appropriate boxes.

13 Click OK.

14 Select a starting point for the profile:

<table>
<thead>
<tr>
<th>If you...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>draw the profile left to right</td>
<td>the starting point of the profile is the lower-left corner of the grid base.</td>
</tr>
<tr>
<td>draw the profile right to left</td>
<td>the starting point of the profile is the lower-right corner of the grid base.</td>
</tr>
<tr>
<td>already generated this profile</td>
<td>enter Y for Yes in response to the Delete existing profile layers prompt.</td>
</tr>
</tbody>
</table>

Entering Yes in response to the Delete existing profile layers prompt, erases all entities on the profile layers defined in the EG Layers and FG Layers commands. Removing the old profile also replaces the profile information block to reflect the new information. Enter N for No if a profile does not exist.
NOTE You can use an asterisk (*) for the layer prefix in the Labels and Prefix Settings to prefix the layer names with the alignment name. This can help to avoid accidentally deleting profiles for other alignments by creating unique layers for each profile.

The following illustration shows examples of vertical exaggeration. The horizontal distance of 50’ in the X direction represents the horizontal distance on the profile (stationing). 50’ of drawing distance = 50 feet of stationing. The vertical distance of 50’ in the Y direction represents the vertical distance on the profile (elevation). Because the vertical scale is 1”=5’, the vertical exaggeration is 10 times. The profile plots with 50’ of drawing distance in the Y axis equaling 5’ of elevation change, as shown:

Vertical exaggeration examples

The following illustration shows a profile imported left to right and right to left:

Imported full profiles
Adding a Subsurface to a Profile

You can add an existing ground subsurface to a profile after it has been created in the drawing by using the Surface Profile command. This command adds the subsurface to an existing profile without adding vertical grid lines or station elevations.

To add an existing ground subsurface to a profile

1. Using the commands from the Profile Settings menu, configure the profile settings, if you haven't done so already.
2. Enable the use of multiple surfaces, select the surfaces to sample, and sample the multiple surfaces, if you haven't done so already.
3. Set the current surface. This is the surface for which you generate a quick or full profile in the next step.
4. Generate a quick or full profile for the specified alignment.
5. From the Profiles menu, choose Create Profile ➤ Surface Profile to display the Profile Surfaces dialog box.
6. Select the subsurface that you want to plot over the existing profile.
7. Click OK.

The subsurface profile is overlayed on the existing profile.

NOTE

The vertical exaggeration of the profile is determined by the horizontal and vertical scale factors of the drawing. After you create the profile, all commands use the vertical exaggeration that the profile was created with, regardless of whether you change the current vertical exaggeration.

For examples of vertical exaggeration, see “Creating a Complete Profile” in this chapter.

The following illustration is an example of a subsurface profile:
Creating a Quick Profile

You can create a quick profile that does not have vertical grid lines or station elevations by using the Quick Profile command. The command draws profile elements on layers set in the EG Layers command.

To create a quick profile

1. From the Profiles menu, choose Create Profile ➤ Quick Profile to display the Profile Generator dialog box.

2. Under Station Range, in the Start and End boxes, set the station range. The defaults are the defined starting and ending stations for the current alignment. This range defines the range of the current alignment for which the profile is created.

   The Datum Elevation Entry section of the dialog box lists the maximum and minimum elevations for the alignment within the defined station range.

3. In the Datum box, enter the datum elevation. This is the base elevation of the plotted profile.

   The datum elevation default is based on the minimum elevation in the profile.

4. In the Vertical scale box, enter the vertical scale.

   The vertical scale is compared to the horizontal scale set during the drawing setup to determine the vertical exaggeration of the profile. If the horizontal scale is 1"=50', a vertical scale of 5.00 (1"=5') produces a vertical exaggeration of 10.

   For examples of vertical exaggeration, see “Creating a Complete Profile” in this chapter.

5. Under Profile creation parameters, click the appropriate option to specify the direction in which the profile is to be drawn, to the right or to the left.
6. Select the Import Left/Right profiles check box to import existing ground profiles to the left and right of the centerline.

You can import these profiles only if you selected the Sample left/right check box in the Profile Sampling Settings dialog box before you sampled the profile information.

7. Select the Import grid check box to import a profile base grid. If this check box is cleared, only profile surfaces are imported.

8. Set the horizontal spacing, vertical spacing, and grid height in the appropriate boxes.

9. Click OK.

10. Select a starting point for the profile.

<table>
<thead>
<tr>
<th>If you…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>draw the profile left to right</td>
<td>the starting point of the profile is the lower-left corner of the grid base.</td>
</tr>
<tr>
<td>draw the profile right to left</td>
<td>the starting point of the profile is the lower-right corner of the grid base.</td>
</tr>
<tr>
<td>already generated this profile</td>
<td>enter Y for Yes in response to the Delete existing profile layers prompt.</td>
</tr>
</tbody>
</table>

If you enter Yes in response to the Delete existing profile layers prompt, this erases all entities on the profile layers defined in the EG Layers and FG Layers commands. Removing the old profile also replaces the profile information block to reflect the new information. Enter N for No if a profile does not exist.

The following illustration shows a quick profile:
Drawing a Grid on a Profile

You can use the Grid command to overlay a grid on the current profile if you didn’t create the grid when you created the profile.

To draw a grid on a profile

1. Select the current profile.
2. From the Profiles menu, choose Create Profile ➤ Grid.
3. Enter the distance for the horizontal spacing. The horizontal spacing is the distance between the grid lines that mark the horizontal distances.
4. Enter the distance for the vertical spacing. The vertical spacing is in relation to the datum elevation and vertical scale.
5. Enter a value for the height of the grid.

The height of the grid above the datum line is the elevation difference between the upper grid base line and the proposed top line of the grid. Even if the datum elevation is an odd value, the grid lines are placed on even elevations above the datum.

The command draws the grid over the current profile.

NOTE You can set the layer for the grid with a dotted linetype or gray color to reduce the emphasis on the grid on the finished plan, or use a thin pen type and different ink color. If the grid location does not overlay the profile correctly, use the Set Current Profile command to re-establish the profile location.

The following illustration shows the parameters for drawing a grid:

Profile grid detail


Listing the Elevations for the Finished Ground Centerline

You can use the List Elevations command to list the elevation of a selected point or station for a selected profile surface. This command lists the elevation of the finished ground centerline at the station (or point) you specify.

To list the existing ground elevations for the profile centerline

1. Select the current profile.
2. From the Profiles menu, choose Create Profile ➤ List Elevations.
3. Select a point using one of the following methods:
   - Pick a point on the profile. The station and elevation of the selected point, as well as the elevation of the current surface at the point’s station, is displayed. Also, the difference in elevation between the vertical alignment and the point selected is displayed.
   - Type $ for Station and enter a station number to display the Finished Centerline Elevation for the specified station.

   **NOTE** If you have not drawn or defined the specified profile, or if the point you select is beyond the profile’s horizontal limits, then the command displays the point or station selected and displays Undefined for the elevation.

4. Select another point to list, or press ENTER to end the command.

Recreating a Profile Information Block After Moving or Exporting the Profile

If you export a profile to another drawing using the WBLOCK command, then use the Define Profile command to recreate the invisible profile information block for the profile. In addition, you can use the Define Profile command if the Set Current Profile command does not recognize the selected plotted profile.

**NOTE** If the profile information block exists, but is not in the correct location because the profile has been moved, then use the Set Current Profile command.

**NOTE** Redefine the profile only if the profile information block does not exist. If the profile information block still exists in the drawing, but you need to redefine the block to update changes you made in the Profile Settings or the datum elevation, use the Undefine Profile command first, and then the Define Profile command.

To recreate a profile information block after moving or exporting the profile

1. From the Profiles menu, choose Create Profile ➤ Define Profile.
2. Select the starting point.
   - At the Select Starting Point prompt, an object snap is automatically set to select the lower corner at the start of the profile. If you have sampled existing ground left or right of the centerline, make sure you select the lower-left corner of the
Creating and Editing Profiles

1. Select the upper end point. This is the upper-right corner of the profile.

The starting and ending points create a bounding region for the profile. Now when you are prompted to select the profile, you can select anywhere within this bounding region.

2. Enter the datum elevation that appears near the lower-left corner of the profile.

3. Enter the beginning and ending stations of the profile. The defaults are the beginning and ending stations of the alignment.

4. Enter the direction of the profile, L or R accordingly. Left means that the profile was drawn from left to right, and Right means that the profile was drawn from right to left.

The following illustration shows points of a profile selected at the lower-left corner of the centerline label box:

![Profile Selection Illustration]

Changing the Profile Labeling Properties After Creating a Profile

After you have created an existing ground profile in the drawing, you can adjust some of the profile properties, such as precision values and increments.

NOTE: You must define a finished ground vertical alignment before this command has any effect on the drawing.

NOTE: You can also use the commands on the Profiles ➤ Label menu to label the profile.
To change the profile labeling properties after creating a profile and vertical alignment

1. From the Profiles menu, choose Create Profile ➤ Set Properties to display the Profile Properties dialog box.

![Profile Properties Dialog Box](image)

The alignment on which the profile is based is listed at the top of the dialog box.

2. In the Station Increment box, you can control how often you label tangents and vertical curves along the profile.

3. In the Tangent Increment box, you can adjust the increment at which the finished ground tangents are labeled with their elevations.
   These labels are placed underneath the profile.

4. In the Curve Increment box, you can adjust the increment at which the vertical curves are labeled with their elevations.
   The incremental labels are placed underneath the profile.

5. Under Label Precision Values, enter precision values for existing and finished ground elevation labels. You can type a number in the boxes, or use the left and right arrows to control the precision value.

6. Click OK.

7. Re-import the profile using the Import commands from either the FG Vertical Alignments or the DT Vertical Alignments submenus.

**Removing the Profile Definition Block From a Drawing After Deleting a Profile**

When you create a profile, a profile definition block is created for that profile. This block stores the profile direction, precisions, datum elevation, labeling increments, starting and ending stations, and layer names. When you erase a profile, the profile definition block is not automatically removed from the drawing. To delete this block, use the Undefine Profile command.

**NOTE**
You can also overwrite this profile block by recreating the profile with one of the Create Profile commands, such as Full Profile.
To remove the profile definition block from a drawing after deleting a profile

1. From the Profiles menu, choose Create Profile ➤ Undefine Profile.
   A prompt similar to the following is displayed:
   
   **Delete profile definition block(s) for alignment <202 CL> (Yes/No) <No>:**
   
2. Type Y, for Yes, to delete the appropriate profile definition block(s).

### Making a Profile Current

If you have more than one profile in a project, then use the Set Current Profile command to set the current profile before using any profile editing, labeling, or listing commands.

In addition, if you move a profile from its original location, then you must use the Set Current Profile command to relocate the invisible profile block.

**NOTE** When redefining a profile’s location, use the Set Current Alignment command to make sure the correct alignment is current.

To make a profile current

1. From the Profiles menu, choose Set Current Profile.
2. Select a point inside the profile you want to make current:

<table>
<thead>
<tr>
<th>If you use...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>this command to set the current profile</td>
<td>the selected point can be any point within the profile’s graphic representation.</td>
</tr>
<tr>
<td></td>
<td>The horizontal and vertical alignments you select also become current.</td>
</tr>
</tbody>
</table>

This uses the current alignment name to indicate which profile to use, and moves the invisible profile data block to the lower-left corner of the profile base. Moving this block is necessary if the profile’s station/elevation data is not reported correctly.

The profile commands now reference the selected profile.
Creating the Finished Ground Vertical Alignments

After you have created the existing ground profile for your alignment, you can use other commands in the Profile menu to create the finished ground profile elements, including the finished ground centerline, offsets, and ditches and transitions.

In the Profile menu, there are two sections you can use for defining the finished ground elements: one section is for creating the Finished Ground Centerline, and the other is for creating Ditches and Transitions. These two sections have almost all the same commands listed under each heading: they both provide commands for drawing tangents and vertical curves and for defining the vertical alignments and listing elevations. However, even though the commands may have the same names, make sure to use the command under the appropriate menu heading for the action you want to take so the database and layer information for the vertical alignments is accurate.

Creating the Finished Ground Centerlines

After drawing the tangents and vertical curves for the finished ground centerline, you need to define it as a vertical alignment. When you define the finished ground centerline, the elevational data is saved to a database that you can then use when creating the profile.
Working with the Vertical Alignment Tangents for the Finished Ground Centerline

You can draw vertical alignment tangents for the finished ground centerline using the FG Centerline Tangents commands on the Profile menu. With these commands, you can perform the following tasks:

- Set the current layer for the finished ground centerline
- Rotate the AutoCAD crosshairs to match the grade of the finished ground centerline
- Draw vertical alignment tangents, change the grade going into and coming out of the finished ground centerline
- Move the point of vertical intersection for the finished ground centerline
- Label the finished ground tangents
- List the finished ground tangent data

Setting the Current Layer for the Finished Ground Centerline

Before drawing vertical tangents and curves to represent the finished ground centerline, use the Set Current Layer command to set the current layer to the default layer that was established.

NOTE When you define the finished ground centerline, all other layers except the finished ground centerline layer are temporarily turned off so you can easily select the tangents and vertical curves.

To set the current layer for the finished ground centerline

- From the Profiles menu, choose FG Centerline Tangents ➤ Set Current Layer.

The current layer is set to the layer designated for the finished ground centerline when the profile was created. If the specified layer does not exist, it is created. The layer set by this command remains current until you set a new layer.

Rotating the AutoCAD Crosshairs to Match the Grade of the Finished Ground Centerline

You can use the Crosshairs @ Grade command to rotate the AutoCAD crosshairs so that they match the grade at which you want to draw the finished ground tangents. This command sets the AutoCAD ORTHO mode on and rotates the AutoCAD crosshairs to a grade based on the entered value and the vertical exaggeration of the current profile. The command works by setting AutoCAD SNAP rotation to the selected grade. This makes it easier to draw lines at the specified grade when you use the AutoCAD LINE command.
To rotate the AutoCAD crosshairs to match the grade of the finished ground centerline

1. From the Profiles menu, choose FG Centerline Tangents ➤ Crosshairs @ Grade.
2. At the Grade in percent prompt, enter the appropriate grade (without the % character).
   A positive value indicates a tangent going up; and a negative value indicates a tangent going down.
3. Before running any other command, reset the SNAP rotation and ORTHO settings.
   You can set the SNAP ROTATION to normal by re-running the command and entering a grade of zero. Reset the ORTHO mode using the AutoCAD ORTHO command, or press Ctrl - O to select the ORTHO mode on or off.
   The following illustration shows rotated AutoCAD crosshairs:

![Rotated AutoCAD crosshairs]

**Drawing the Vertical Alignment Tangents for the Finished Ground Centerline**

To draw vertical alignment tangents for the finished ground centerline, you can use the Create Tangents command.

**NOTE**
You can also use the AutoCAD LINE command to drawing vertical alignment tangents. However, you must use the Vertical Curves commands to create vertical curves.

To draw the vertical alignment tangents for the finished ground centerline

1. Use the Set Current Layer command to set the current layer to the appropriate layer.
2. From the Profiles menu, choose FG Centerline Tangents ➤ Create Tangents.
3 Select the starting point using one of the following methods:
   ■ Select a point from the drawing. You are prompted for the station and elevation. The default station is the station of the point selected. The default elevation is the elevation of the point selected.
   ■ Type S to select a station.
     You are prompted for the station and elevation. The default for the station is the starting station of the profile. The default elevation is the elevation of the existing ground at the station entered.

4 Enter a station and elevation for the starting point of the tangent, or press ENTER to accept the default values.

5 Select a point to end the tangent using one of the following methods:
   ■ Select a point in the drawing.
   ■ Type L to specify a length. The command prompts you to select a grade, elevation, or point to define the elevation of the endpoint of the tangent:
     Grade: The grade option calculates the endpoint of the tangent using the station defined at the previous prompt and an entered grade. Enter the grade in percent. A positive value indicates a tangent going up; and a negative value indicates a tangent going down.
     Elevation: The elevation option calculates the endpoint of the tangent using the station defined at the previous prompt and an entered elevation. Enter the elevation for the endpoint of the tangent.
     Point: Selecting a point at this prompt causes the command to use the elevation of the point selected to determine the endpoint of the tangent.
   ■ Type S to enter a station. The command prompts you to select a grade, elevation, or point to define the elevation of the endpoint of the tangent.

   [NOTE] Type U to erase the previous line drawn and revert to the previous station and elevation entered. Type X to exit the command.

After displaying the station, elevation, and last grade of the current point, the command prompts for another length, station, or point.

6 Press ENTER to end the command.

The following illustration shows some of the parameters used in creating vertical alignment tangents:

![Parameters in a vertical alignment tangent](image-url)
Chapter 3     Working with Profiles and Vertical Alignments

194

Changing the Grade Going into the PVI for the Finished Ground Centerline

To edit the grade going into the PVI for a finished ground tangent, use the Change Grade 1 command. The Change Grade 1 command alters the grade of the tangent coming into the PVI (Point of Vertical Intersection).

To change the grade going into the PVI for the finished ground centerline

1. From the Profiles menu, choose FG CenterlineTangents ➤ Change Grade 1.
2. Select the tangent that represents the grade coming into the PVI. (This is the tangent that has its grade modified).
3. Select the tangent that represents the grade coming out of the PVI.

The following prompt is displayed:

Grade coming into PVI:

4. Enter a value for the new grade in percent, but don’t enter the % character.
5. Select another tangent to continue the command, or press ENTER to end the command. The command holds the start point of the first tangent, as well as the grade and end point of the second tangent. It applies the new grade to the first tangent, calculating the new intersection point with the second tangent to determine the location of the location of the PVI.

If you use this command after you have added a vertical curve to the PVI, the command leaves the vertical curve and any labels in their original positions. Erase the vertical curve, and then recreate it with the Vertical Curve command. The following illustration shows the new location of a PVI after you change the grade in:

Changing the grade in
Changing the Grade Coming Out of the PVI for the Finished Ground Centerline

To edit the grade going out of the PVI for a finished ground tangent, use the Change Grade 2 command.

**To change the grade coming out of the PVI for the finished ground centerline**

1. From the Profiles menu, choose FG Centerline Tangents ➤ Change Grade 2.
2. Select the tangent that represents the grade coming into the PVI.
3. Select the tangent that represents the grade coming out of the PVI. This is the tangent that will have its grade modified.

The following prompt is displayed:

```
Grade coming into PVI:
```

4. Either select the tangent going into the PVI or type the grade of the tangent. The following prompt is displayed:

```
Grade coming out of PVI:
```

5. Enter a value for the new grade out in percent, but don’t enter the % character.

6. Select another tangent to continue the command, or press ENTER to end the command. The command holds the endpoint of the second tangent, as well as the start point and grade of the first tangent. It applies the new grade to the second tangent, calculating the new intersection point with the first tangent to determine the location of the PVI and draws a new tangent based on the grade you entered. The new second tangent is extended until it intersects with the grade defined by the first tangent. This intersection is the location of the new PVI point.

If you use this command after you have added design a vertical curve to the PVI, the command leaves the vertical curve and any labels in their original positions. Erase the vertical curve, and then recreate it with the Vertical Curve command.

The following illustration shows the new location of a PVI after you change the grade out:
Moving the Point of Vertical Intersection for the Finished Ground Centerline

You can move the PVI (Point of Vertical Intersection) of a vertical alignment by using the Move PVI command.

If you use this command after you design a vertical curve, then the command leaves the vertical curve and any labels in their original positions. Erase the vertical curve, and then recreate it with the Vertical Curve command. For more information, see “Working with Vertical Curves for the Finished Ground Centerline” in this chapter.

To move the point of vertical intersection between two tangents

1. From the Profiles menu, choose FG Centerline Tangents ➤ Move PVI.
2. Select the tangents around the PVI you want to move.

Select these tangents in any order, and then press ENTER to continue the command. The following prompt is displayed:

Station/Elevation/Both/Pick <Pick>:

3. Select one of the following methods of moving the PVI:
   - Press Enter to accept the default Pick and select a new point for the PVI.
   - Type S to enter a new station. This option maintains the existing PVI elevation.
   - Type E to enter a new PVI elevation. This option maintains the existing PVI station.
   - Type B to enter both a new station and elevation for the PVI.

4. Enter the station and/or elevation according to the keyword option you use.

The command holds the start point of the first tangent and the endpoint of the second tangent. It modifies the grade values of the tangents for the change in PVI location.

The following illustration shows moving a PVI:

Moving the PVI
Working with the Vertical Curves for the Finished Ground Centerline

Before creating vertical curves, set the current profile and draw the tangents for either the finished ground centerline or ditches and transitions. All vertical curve commands place the curve on the same layer as the selected tangents. While you can draw tangents using regular AutoCAD commands, you should use the FG Vertical Curves command to create vertical curves.

Drawing Vertical Curves for the Finished Ground Centerline

While you can draw vertical alignment tangents using regular AutoCAD commands, you must use the FG Vertical Curves command to draw vertical curves for the finished ground centerline.

Before creating vertical curves, set the current profile and draw the tangents for the finished ground centerline. All vertical curve commands place the curve on the same layer as the selected tangents.

Drawing a Vertical Curve Based on Curve Length

One method of drawing a vertical curve is to specify the curve length.

To draw a vertical curve based on selected tangents and a given horizontal curve length

1 From the Profiles menu, choose FG Vertical Curves to display the Vertical Curves dialog box.

2 In the Description list, select the Length option. You can also click the Length icon, and then click OK.
NOTE If you do not see the graphic representation of the curve type you want to create, then click the Next or Previous button at the bottom of the Vertical Curves dialog box.

3 Select the tangents that represent the grade coming into and out of the PVI.
4 Enter the horizontal length of the curve by typing a value or by picking two points in the drawing.

The following illustration shows a vertical curve based on the curve length:

![Drawing a vertical curve by length](image)

**Drawing a Vertical Curve Based on a Minimum K Value**

One method of drawing a vertical curve is to specify a K value. The K value of a vertical curve is the horizontal distance required to affect a 1% change in grade on the vertical curve. \( (K = \text{Length of curve} / (|\text{Grade in}| - |\text{Grade out}|)) \).

**To draw a vertical curve based on a minimum K value**

1 From the Profiles menu, choose FG Vertical Curves to display the Vertical Curves dialog box.
2 In the Description list, select the K Value option. You can also click the K Value icon, and then click OK.

NOTE If you do not see the graphic representation of the curve type you want to create, then click the Next or Previous button at the bottom of the Vertical Curves dialog box.

3 Select the tangents that represent the grade coming into and out of the PVI.
4 Enter a minimum K value.

This command calculates the necessary length of curve for the given minimum K value, and displays the value at the Length of the curve prompt.

5 Press ENTER to accept the length of curve for the given minimum K value, or type a new value.

If you enter a new length, the command recalculates the K value and draws the curve with the specified length.
The following illustration shows a vertical curve based on the K value:

\[ K = \frac{L_c}{|c_1 - c_2|} \]

Drawing a vertical curve by K value

**Drawing a Vertical Curve Based on a Passing Sight Distance**

One method of drawing a crest vertical curve is to specify a minimum passing sight distance.

**To draw a vertical curve based on a passing sight distance**

1. From the Profiles menu, choose FG Vertical Curves to display the Vertical Curves dialog box.
   
   **NOTE** You can use this option only with a crest curve.

2. In the Description list, select the Passing Sight option. You can also click the Passing Sight icon, and then click OK.
   
   **NOTE** If you do not see the graphic representation of the curve type you want to create, then click the Next or Previous button at the bottom of the Vertical Curves dialog box.

3. Select the tangents that represent the grade into and out of the PVI.
4. Enter a value for the minimum passing sight distance.
5. Press ENTER to accept the default values for Height of eye and Height of object, or enter new values.
   
   The Height of eye is the height of the driver’s line of vision coming down the road; Height of object is the height of a vehicle approaching the driver. The default values are set in the Profile Value Settings dialog box. The length of the curve is calculated.

6. Press ENTER to accept the calculated length of curve value, or type a new value. The passing sight distance is then calculated.
The following illustration shows the parameters used in calculating a vertical curve based on minimum passing sight distance:

The following equations are used to calculate the passing sight distance. If the safe passing distance \((S)\) is less than the length of the curve \((L)\):

\[
L = \frac{AS^2}{100 \times \left( \sqrt{2h_1} + \sqrt{2h_2} \right)^2}
\]

If \((S)\) is greater than \((L)\):

\[
L = 2S - \left( \frac{200 \times \left( \sqrt{h_1} + \sqrt{h_2} \right)^2}{A} \right)
\]

where:

- \(L\) = Length of vertical curve in feet
- \(S\) = Sight distance in feet
- \(A\) = Algebraic difference in grade percent
- \(h_1\) = Height of eye above alignment surface in feet
- \(h_2\) = Height of object above alignment surface in feet
**Drawing a Vertical Curve Based on a Stopping Sight Distance**

One method of drawing a crest vertical curve is to specify a minimum stopping sight distance.

**To draw a vertical curve based on a stopping sight distance**

1. From the Profiles menu, choose FG Vertical Curves to display the Vertical Curves dialog box.
   - **NOTE** You can use this option only with a crest curve.

2. In the Description list, select the Stopping Sight option. You can also click the Stopping Sight icon, and then click OK.
   - **NOTE** If you do not see the graphic representation of the curve type you want to create, then click the Next or Previous button at the bottom of the Vertical Curves dialog box.

3. Select the tangents that represent the grade into and out of the PVI.

4. Enter the value for the minimum stopping distance.

5. Accept the default values for Height of eye and Height of object, or enter new values at the prompts.
   - The Height of eye is the height of the driver's line of vision coming down the road and the Height of object is the height of an object in the road such as an animal, vehicle, or piece of debris. The default values for these heights are set in the Profile Value Settings dialog box. For more information, see “Changing the Values Settings for the Profiles” in this chapter.
   - The length of curve is calculated.

6. Press ENTER to accept the calculate length of curve value, or enter a new value.
   - If you enter a new length, the command recalculates the stopping sight distance and draws the curve with the specified length.

The following illustration shows the factors used in calculating the vertical curve based on stopping sight distance:

![Diagram of vertical curve based on stopping sight distance](image)
The following equations are used to calculate the stopping sight distance. If the safe stopping distance (S) is less than the length of the curve (L):

\[
L = \frac{AS^2}{100 \times \left[ \frac{\sqrt{2h_1^2} + \sqrt{2h_2^2}}{2} \right]^2}
\]

If (S) is greater than (L):

\[
L = 2S - \left( \frac{200 \times \left[ \sqrt{h_1^2} + \sqrt{h_2^2} \right]}{A} \right)
\]

where:

- \(L\) = Length of vertical curve in feet
- \(S\) = Sight distance in feet
- \(A\) = Algebraic difference in grade percent
- \(h_1\) = Height of eye above alignment surface in feet
- \(h_2\) = Height of object above alignment surface in feet

**Drawing a Vertical Curve Based on an Elevation Point**

One method of drawing a vertical curve is to specify a high or low elevation point through which the vertical curve must pass.

**To draw a vertical curve based on an elevation point**

1. From the Profiles menu, choose FG Vertical Curves to display the Vertical Curves dialog box.
2. Select the High/Low Point option by clicking its name in the Description list. You can also click the High/Low Point icon, and then click OK.

   **NOTE** If you do not see the graphic representation of the curve type you want to create, click the Next or Previous button at the bottom of the Vertical Curves dialog box.

3. Select the tangents that represent the grades into and out of the PVI.
4. Specify the high/low point using one of the following methods:
   - Select a point from the screen.
   - Press ENTER and type a numeric value for the elevation.

   The command computes the necessary length of curve to pass exactly through the given elevation.
5. Press ENTER to accept the length of curve required to pass exactly through the given point, or enter a new length.

   If you change the length, the actual curve passes above or below the given point.
The High/Low Point option displays the high/low station and elevation for the curve drawn. If a high or low point cannot be calculated for the selected tangents, a message is displayed that says: No high or low point exists for this curve.

The following illustration shows the parameters used in calculating a vertical curve based on a high/low elevation point:

![Diagram of vertical curve parameters](image)

**Drawing a Vertical Curve Through a Point**

One method of drawing a vertical curve is to specify a point for the vertical curve to pass through.

**To draw a vertical curve that passes through a selected point**

1. From the Profiles menu, choose FG Vertical Curves to display the Vertical Curves dialog box.
2. Select the Through Point option by clicking its name in the Description list. You can also click the Through Point icon, and then click OK.

   **NOTE** If you do not see the graphic representation of the curve type you want to create, then click the Next or Previous button at the bottom of the Vertical Curves dialog box.

3. Select the tangents that represent the grades going into and out of the PVI.
4. Select the point for the vertical curve to pass through, or press ENTER, and then type a station number and elevation. The length of the curve is calculated.
5. Press ENTER to accept the length of curve required to pass exactly through the given point, or enter a new length.
   - Enter a smaller length to have the vertical curve pass above the indicated point in a crest curve, and below the selected point in a sag curve.
   - Enter a greater length to have the vertical curve pass below the indicated point in a crest curve, and above in a sag curve.

If the command cannot construct a vertical curve through the point you selected, an error message appears stating that the function is undefined for the argument.
The following illustration shows the parameters used in calculating a vertical curve based on the Through Point option:

![Diagram of vertical curve parameters](image)

**Drawing a Sag Vertical Curve Based on Headlight Data**

One method of drawing a sag vertical curve is to specify a headlight sight distance.

**To draw a sag vertical curve based on headlight data**

1. From the Profiles menu, choose FG Vertical Curves to display the Vertical Curves dialog box.

   **NOTE** You can only use this command with a sag curve.

2. Select the Headlight option by clicking its name in the Description list. You can also click the Headlight icon, and then click OK.

   **NOTE** If you do not see the graphic representation of the curve type you want to create, then click the Next or Previous button at the bottom of the Vertical Curves dialog box.

3. Select the tangents that represent the grades going into and out of the PVI.

4. Enter the value for the headlight sight distance.

5. Press ENTER to accept the default values for the headlight height above pavement and maximum headlight angle, or enter new values.

   The length of the curve is calculated.

6. Press ENTER to accept the calculated length of curve, or enter a new value.

   If you enter a new length, the Headlight option recalculates the headlight sight distance and draws the curve with the length specified. The final headlight sight distance appears and the command draws the curve.
The following illustration shows the parameters used in calculating a vertical curve based on headlight data:

The following equations are used to calculate the length of curve.
If \((S)\) is less than \((L)\):

\[
L = \frac{AS^2}{200 \times \left[ HH + S \left( \tan \alpha \right) \right]}
\]

If \((S)\) is greater than \((L)\):

\[
L = 2S - 200 - \left( \frac{HH + S \left( \tan \alpha \right)}{A} \right)
\]

where:

- \(A\) = Absolute value of the change in grades
- \(S\) = Sight distance
- \(L\) = Curve length
- \(HH\) = Height of headlight
- \(\alpha\) = Angle of headlight with horizontal
Drawing a Sag Vertical Curve Based on a Given Velocity

One method of drawing a sag vertical curve is to specify a velocity.

**To draw a sag vertical curve based on a given velocity**

1. From the Profiles menu, choose FG Vertical Curves to display the Vertical Curves dialog box.
   
   **NOTE** You can only use this command with a sag curve.

2. Select the Comfort option by clicking its name in the Description list. You can also click the Comfort icon, and then click OK.
   
   **NOTE** If you do not see the graphic representation of the curve type you want to create, then click the Next or Previous button at the bottom of the Vertical Curves dialog box.

3. Select the tangents that represent the grades coming into and out of the PVI.
4. Press ENTER to accept the default design value (55 miles per hour for imperial units and 88.51 kilometers per hour for metric units), or type a new value.
   
   The command calculates the appropriate length of the curve.

5. Press ENTER to accept this length, or enter a new value.
   
   If you enter a new length, the Comfort option recalculates the design velocity and draws the curve with the specified length.

   The following illustration shows the parameters used in calculating a vertical curve based on design velocity:

   ![Designing a vertical curve by velocity](image)

   Designing a vertical curve by velocity

   The following formula is used to calculate the length of the sag vertical curve:

   $$ L = \frac{AV^2}{46.5} $$

   where:

   \( V \) = the design speed (mph)
   
   \( A \) = the grade change (absolute value)
Defining a Grade Break Without a Vertical Curve

You can add a grade break to the PVI (Point of Vertical Intersection) where two tangents meet. When you define a grade break, a PVI symbol is inserted at the PVI and a vertical curve of zero length is assigned to the PVI selected. The PVI block is drawn on the specified finished ground layer (set with the Set Current Layer command).

To define a grade break without a vertical curve

1. From the Profiles menu, choose FG Vertical Curves to display the Vertical Curves dialog box.
2. Select the Grade Break option by clicking its name in the Description list. You can also click the Grade Break icon, and then click OK.

   **NOTE** If you do not see the graphic representation of the curve type you want to create, then click the Next or Previous button at the bottom of the Vertical Curves dialog box.

3. Select a grade break.
   This is the intersection of two vertical tangents. The object snap, intersection, is automatically set so you can easily select the intersection.

   **NOTE** The command reports No intersection found at selected PVI point if the selection point is not the intersection of two lines.

The following illustration shows a grade break selection point:
Defining the Finished Ground Centerline as a Vertical Alignment

After drawing the tangents and vertical curves for the finished ground centerline, you must define the finished ground centerline as a vertical alignment. When you define the finished ground centerline, the elevational data is saved to a database that is used for creating cross sections.

To define the finished ground centerline as a vertical alignment

1. From the Profiles menu, choose FG Vertical Alignments ➤ Define FG Centerline.

   The command turns off all layers except the finished ground layer. If the vertical alignment objects are not visible after you select this command, then cancel the command and move the objects to the correct layer. The correct layer is the layer you defined for finished ground objects when using the FG Layers command. By default, this layer name is PFGC.

   You can set the correct layer current based on your settings by selecting the Set Current Layer command from the FG Centerline Tangents menu.

2. Select the starting point of the alignment.

   This should be the point with the lowest station value. For a left to right profile, it is the left end of the vertical alignment. For a right to left profile, it is the right end. The command sets the object snap to END automatically.

3. Select the objects that make up the alignment. Use a window or crossing to select the entire alignment.

4. Press ENTER.

   The command displays the number of PVIs included in the selection set. The layers are then restored to their original state.

   **NOTE** If the Define FG Centerline command displays the message No vertical exists, then you cannot reference the finished and existing ground information to the same station or location. Use the Set Current Profile command to verify the location of the existing ground data, then define the vertical alignment again.

The following illustration shows the points required to define the finished ground alignment:

![Defining finished ground](image)

Defining finished ground
Editing the Finished Ground Centerline Alignment

You can edit a vertical alignment using the FG Vertical Alignments ➤ Edit command on the Profiles menu. Unlike the DT Vertical Alignments ➤ Edit command, you do not have to first select the vertical alignment you want to edit.

To edit the finished ground centerline alignment

1. From the Profiles menu, choose FG Vertical Alignments ➤ Edit to display the Vertical Alignment Editor.

2. Edit the vertical alignment.

3. Click OK to exit the Vertical Alignment Editor dialog box.

Importing the Finished Ground Centerline Alignment

Any time you change the information in the Vertical Alignment Editor, you must import the definition back into the drawing to update the profile in the drawing with the changes you made. The Vertical Alignment Editor does not automatically update the drawing objects when you change the vertical alignment values.

When you import a vertical alignment, you have the option of inserting updated labels into the drawing at the same time.
To import the finished ground centerline alignment into the drawing

1. From the Profiles menu, choose FG Vertical Alignments ➤ Import.

The following prompt is displayed:

Label tangents and vertical curves (Yes/No) <Yes>:

2. Type Yes to label the vertical tangents and curves. If you do not want to label the alignment objects, type No.

The following prompt is displayed:

Delete finished ground profile layer (Yes/No) <Yes>:

3. Type Yes or No:
   - Type Yes to delete the old finished ground alignment objects and replace them with updated objects. This option does not change any of the information that was used to design the finished ground.
   - Type No if you do not want to delete the existing ground alignment objects. If you select this option, updated objects are inserted into the drawing but the older objects are not deleted.

Creating COGO Points on the Plan View of the Centerline Alignment

After you create a profile, you can create COGO points on the plan view of the alignment by using the Create COGO Points command. These points are created using the existing ground or finished ground elevations established in profile view.

**NOTE**

These COGO points are created using the current point settings (except for point description settings). To view the points when they are created, you must select the Insert to Drawing as Created check box on the Create tab of the Point Settings dialog box. If you also select the option to Use the Current Point Label Style When Inserting Points on the Insert tab of the Point Settings dialog box, the current point label style is used to label the points as they are inserted.

To create COGO points along the plan view of the centerline alignment

1. From the Profiles menu, choose FG Vertical Alignments ➤ Create COGO Points to display the Centerline Point Output dialog box.

2. Under Station Range, type the starting and ending station values. The COGO points are created between these two stations.
3 In the Point Description box, type the description that you want to assign to the points.

4 From the Surface list, do one of the following:
   - Select None to create points without elevational values.
   - Select Existing to create points that use the elevational values of the existing ground profile.
   - Select Finished to create points that use the elevational values of the finished ground centerline.

5 In the Centerline Increment box, type the increment for placing points. For example, if you type 50, then a point is created every 50 units along the centerline.

6 Click OK.
   The points are placed on the current layer unless you are using description keys.

### Listing the Elevation of a Selected Point or Station on a Vertical Alignment

You can use the List Elevations command to list the elevation of a selected point or station for a finished ground centerline. This command lists the elevation of the finished ground centerline at the station (or point) you specify.

**To list the elevation of a selected point or a station for a finished ground centerline**

1 From the Profiles menu, choose FG Vertical Alignments ➤ List Elevations.

2 Do one of the following:
   - Pick a point on the profile. This displays the station and elevation of the selected point, as well as the elevation of the current surface at the point’s station. This command also displays the difference in elevation between the vertical alignment and the point selected.
   - Type S, for Station, and type a station number to display the Finished Centerline Elevation for the specified station.

   **NOTE** If you have not drawn or defined the specified profile, or if the point you select is beyond the horizontal limits of the profile, the command displays the station of the point or station selected and the text Undefined for the elevation.

3 Select another point to list, or press ENTER to end the command.
Sampling the Existing Ground to Create the Profile Data

To create a profile, you must first sample the existing ground from a surface, a file, or from cross sections. You can also create existing ground data in the Vertical Alignment Editor. Sampling the existing ground creates elevational values for the profile.

Sampling the Existing Ground Profile Data from a Surface

If you have an existing ground surface on which the horizontal alignment is located, then you can use this existing ground surface to sample elevations for the profile. The Sample From Surface command accesses the files that were created when you originally generated the surface, and creates a file containing existing ground elevations along the defined alignment. The existing ground elevations are used in creating an existing ground profile.

To sample existing ground data from a surface

1. To sample the existing ground information from a surface, create at least one surface using the Terrain Model Explorer.
2. Define the horizontal alignment with the Define From Entities or Define From Polyline commands.
3. From the Profiles menu, choose Existing Ground ➤ Sample From Surface to display the Select Surface dialog box.
4. Select the surface to sample, and then click OK.
5. Make changes to the sampling settings, and then click OK.
6. Enter the starting and ending stations. The defaults are the starting and ending stations of the alignment.

The command then processes the profile information for the specified station range and displays the distance sampled in a statement similar to the following:

You have sampled profile for 3856.25 feet of alignment

The command creates a file that is named for the current alignment with an extension of .vrt in the c:\Land Projects R2\<project name>\align\<alignment name> folder. If a file with the same name already exists, then the command displays a confirmation prompt to overwrite the previous definition.
Sampling the Existing Ground to Create the Profile Data

If the alignment goes outside of the surface definition and returns, then the Profile Generation command draws a straight line from the point of exit elevation to the point of re-entry elevation.

**Sampling the Existing Ground from an ASCII File**

Use the Sample From File command to sample an existing ground surface from an ASCII text file. This command generates existing ground profile data from the selected text file.

**NOTE** You cannot execute this command multiple times to create multiple surface definitions from multiple ASCII text files because every time the command is run it overwrites any existing vertical alignment information.

**To sample an existing ground surface from an ASCII file**

1. Before using this command, be sure a file exists in the correct format.
2. From the Profiles menu, choose Existing Ground ➤ Sample From File to display the File to Import dialog box.

![](image)

The default folder is the current project folder.

3. Select the correct folder and file to import.
4. Click OK.

The command samples the surface from the text file.

For the Sample From File command to work properly, you must create the file using the correct format. Each line of the file must contain the station value followed by the elevation, separated by a space. The station cannot contain the plus sign (+) character. The following lines are examples that the Sample From File command can use:

```
0 100.23
50 150.2
79.4 109
145.1 115.63
200.5 111.12
```
The file must conform to the following criteria:

- The first line must be the station and elevation for the first station.
- Stations must be in ascending order.
- There can be no leading blank lines or headers.
- There can be no blank lines. Blank lines are read as the end of the file.
- There can be no blank spaces at the beginning of any line.
- The last item must be the elevation for the last station.

### Sampling the Existing Ground Profile Data from the Processed Cross Sections

If you have already generated existing ground cross sections, then you can obtain existing ground data for profiles from the cross sections.

**NOTE** You can use this command in tandem with the Sample From File command on the Cross Sections menu to create profile data. For instance, if you have an ASCII text file with all of your section information, and then sampled this information to create existing ground section information, you can use the Sample From Sections command on the Profiles menu to create profile data based on this section information.

#### To sample profile data from existing ground section information

1. From the Profiles menu, choose Existing Ground ➤ Sample From Sections.

<table>
<thead>
<tr>
<th>If you...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>sampled existing ground data for cross sections from only one surface</td>
<td>the Sample From Sections command retrieves the information for the profile from that surface.</td>
</tr>
<tr>
<td>sampled existing ground data for cross sections from more than one surface</td>
<td>the Select Section Surface dialog box is displayed. Select the surface to sample (for profiles), and then click OK.</td>
</tr>
</tbody>
</table>

**NOTE** If an existing ground profile definition already exists for the current alignment, it is overwritten. A dialog box displays, asking you if you want to keep the finished surfaces. Click Yes to keep the finished ground vertical alignment information, or No to delete the finished ground information.

### Creating the Existing Ground Profile Data by Using the Vertical Alignment Editor

An alternate method of creating existing ground data for profiles is to use the Vertical Alignment Editor. You can use this editor to enter profile data for the existing ground centerline, and left and right offsets. You can also use this dialog box to edit data that you sampled from a surface or a text file.
To create the existing ground data by using the Vertical Alignment Editor

1 From the Profiles menu, choose Existing Ground ➤ Edit Vertical Alignment.

<table>
<thead>
<tr>
<th>If there is…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>no data for a selected alignment</td>
<td>the Vertical Alignment Creation dialog box is displayed.</td>
</tr>
<tr>
<td>data for the selected alignment</td>
<td>the Vertical Alignment Editor dialog box is displayed. Under Settings, select the alignment to create. Click Yes to display the Vertical Alignment Editor dialog box.</td>
</tr>
</tbody>
</table>

2 Enter the PVI station and elevation data in the Vertical Alignment Creation Editor dialog box.

The starting and ending points of an alignment are considered PVIs. Tab between columns. The % grade is calculated from the horizontal distance and difference in elevation between the PVIs.

NOTE The % grade is not an editable field in the Vertical Alignment Creation Editor. However, you can edit the % grade when you return to the Vertical Alignment Editor.

3 When you have finished entering the information, click OK to return to the Vertical Alignment Editor.

4 Click Insert PVI to insert a new PVI.

When you select this button, the command adds a new row to the editor above the row where the cursor is located. Press ENTER or Tab to move between the columns. Enter the station and elevation of the PVI. The percent grade is calculated to reflect the new PVI. Enter the vertical curve length, if required.

5 To delete a PVI, place your cursor in the row you want to delete and select Delete PVI.

A confirmation dialog box displays. Click Yes to delete the station. The station, elevation and grade for the remaining PVIs are automatically recalculated to reflect the new PVI coordinates.

6 You can edit the vertical alignment data using the following options in the Edit area of the Vertical Alignment Editor:

- **PVI Station**: Each PVI (Point of Vertical Intersection) station is listed in this column.
- **Elevation**: This column displays the elevation at the PVI.
- **Curve Length**: This column shows the length of the vertical curve located at the current PVI. Only the finished ground vertical alignments list curve information (no curve data is listed for existing ground vertical alignments).
- **% Grade**: This column shows the calculated slope of the tangent between two PVIs as a percentage. The value is centered vertically between the two PVIs.
Creating Ditches and Transitions

The main difference between the Ditches and Transitions (DT) command and the finished ground centerline (FGC) commands is the first prompt. The first prompt of most ditches and transitions commands asks for which vertical alignment you want to use. This prompt is generally in the following format:

Select profile (Center/Left/Right)<Center>: R
Select right profile (Ditch/1/2/3/4/5/6/7/8)<1>: 

If you press ENTER at the first prompt above, then you can open the finished ground centerline profile. If you type L or R, then you have the choice of which ditch or transition to open. In the example above, the 1 through 8 alignments are the eight offsets available on the right side of the centerline. These alignments are generally used to control the location of key points on cross section templates, such as the right edge of pavement (EOP) and shoulder. The 1 through 8 alignments are also available for the left side of centerline. You can access the left and right ditch profiles by entering the appropriate offset side, and then entering a D for ditch.

NOTE You can also use AutoCAD commands to draw tangents, but you must use the DT Vertical Curves command to create vertical curves.

After you design ditches and transitions, you can apply them to the templates used in cross section design.

Working with Vertical Alignment Tangents for the Ditches and Transitions

You can draw vertical alignment tangents for ditches and transitions using the DT Tangents commands on the Profile menu. With these commands, you can set the current layer, rotate the AutoCAD crosshairs to match the grade of the ditches and transitions, draw vertical alignment tangents, change the grade going into and coming out of the ditches and transitions, and move the point of vertical intersection.

Setting the Current Layer for the Ditches and Transitions

To set the current layer for ditches and transitions

1. From the Profiles menu, choose DT Tangents ➤ Set Current Layer.
2. Choose one of the following options:
   - Type C for the centerline.
   - Type L or R for the Left or Right ditch/transition regions. If you choose Left or Right at the Select profile prompt, the next prompt asks you to select the type of profile you want to set as current.
3 Use any one of the eight transition regions, or specify that the profile is a ditch. If the specified layer does not exist, it is created. The layer set by this command remains current until a new layer is set either with this command or the AutoCAD LAYER command.

**Rotating the AutoCAD Crosshairs to Match the Grade of the Ditches and Transitions**

This command sets the AutoCAD ORTHO mode on and rotates the AutoCAD crosshairs to a grade based on the entered value and the vertical exaggeration of the current profile. The command works by setting AutoCAD SNAP rotation to the selected grade. This makes it easier to draw lines at the specified grade when you use the AutoCAD LINE command.

**To rotate the AutoCAD crosshairs to match the grade of the ditches and transitions**

1. From the Profiles menu, choose DT Tangents ➤ Crosshairs @ Grade.
2. At the Grade in percent prompt, enter the grade (without the % character).
   A positive value indicates a tangent going up, and a negative value indicates a tangent going down.
3. Before running any other command, reset the SNAP rotation and ORTHO settings:
   - Reset the SNAP ROTATION to normal by running the command again and entering a grade of zero.
   - Reset the ORTHO mode by using the AutoCAD ORTHO command or by pressing Ctrl - O to select the ORTHO mode on or off.
   - The following illustration shows rotated AutoCAD crosshairs:
Drawing the Vertical Alignment Tangents for the Ditches and Transitions

To draw the vertical alignment tangents for the ditches and transitions:

1. Use the Set Current Layer command to set the current layer to the appropriate layer.
2. From the Profiles menu, choose DT Tangents ➤ Create Tangents.
3. Select the starting point using one of the following methods:
   - Select a point from the drawing. You are prompted for the station and elevation. The default station is the station of the point selected. The default elevation is the elevation of the point selected.
   - Type $S$ to select a station. You are prompted for the station and elevation. The default for the station is the starting station of the profile; the default elevation is the elevation of the existing ground at the station entered.
4. Enter a station and elevation for the starting point of the tangent, or press ENTER to accept both default values.
5. Select a point to end the tangent using one of the following methods:
   - Pick a point from the drawing.
   - Type $L$ to specify a length. The command prompts you to select a grade, elevation, or point to define the elevation of the endpoint of the tangent.
   - Type $S$ to enter a station. The command prompts you to select a grade, elevation, or point to define the elevation of the endpoint of the tangent.

**NOTE**
Type U to erase the previous line drawn and revert to the previous station and elevation entered. Type X to exit the command.

After displaying the station, elevation, and last grade of the current point, the command prompts for another length, station, or point.

6. Press ENTER to end the command.

The following illustration shows some of the parameters used in creating vertical alignment tangents:
Changing the Grade Going into the PVI for the Ditches and Transitions

To edit the grade going into the PVI for the ditches and transitions, use the Change Grade 1 command.

To change the grade going into the PVI for the ditches and transitions

1 From the Profiles menu, choose DT Tangents ▶ Change Grade 1.
2 Select the tangents that represent the grades coming into and out of the PVI. This is the tangent that will have its grade modified.

The following prompt is displayed:

Grade coming into PVI:

3 Enter a value for the new grade in percent, but do not enter the % character.
4 Select another tangent to continue the command, or press ENTER to end the command.

The command holds the start point of the first tangent, as well as the grade and end point of the second tangent. It applies the new grade to the first tangent, calculating the new intersection point with the second tangent to determine the location of the PVI.

If you use this command after you have added a vertical curve to the PVI, the command leaves the vertical curve and any labels in their original positions. Erase the vertical curve, and then recreate it with the Vertical Curve command.

The following illustration shows the new location of a PVI after you change the grade in:

![Diagram showing the new location of a PVI after changing the grade in](image)
Changing the Grade Coming Out of the PVI for the Ditches and Transitions

To edit the grade coming out of the PVI for the ditches and transitions, use the Change Grade 2 command.

To change the grade coming out of the PVI for the ditches and transitions

1. From the Profiles menu, choose DT Tangents ➤ Change Grade 2.
2. Select the tangent that represents the grade coming into the PVI.
3. Select the tangent that represents the grade coming out of the PVI. This is the tangent that will have its grade modified.

The following prompt is displayed:

Grade coming out of PVI:

4. Enter a value for the new grade out in percent, but do not enter the % character.
5. Select another tangent to continue the command, or press ENTER to end the command.

The command holds the endpoint of the second tangent, as well as the start point and grade of the first tangent. It applies the new grade to the second tangent, calculating the new intersection point with the first tangent to determine the location of the PVI and draws a new tangent based on the grade you entered. The new second tangent is extended until it intersects with the grade defined by the first tangent. This intersection is the location of the new PVI point.

If you use this command after you have added a vertical curve to the PVI, the command leaves the vertical curve and any labels in their original positions. Erase the vertical curve, and then recreate it with the Vertical Curve command.

The following illustration shows the new location of a PVI after you change the grade out:

![Changing grade out](image-url)
Moving the Point of Vertical Intersection for the Ditches and Transitions

You can move the PVI (Point of Intersection) of a vertical curve by using the Move PVI command. If you use this command after you design a vertical curve for the PVI, then the command leaves the vertical curve and any labels in their original positions. Erase the vertical curve, and then recreate it with the Vertical Curve command.

To move the point of vertical intersection for the ditches and transitions

1. From the Profiles menu, choose DT Tangents ▶ Move PVI.
2. Select the tangents around the PVI you want to move.
   Select these tangents in any order, and then press ENTER to continue the command. The following prompt is displayed:
   Station/Elevation/Both/Pick <Pick>:
3. Select the method of moving the PVI.
4. Enter the station and/or elevation according to the keyword option you use.
   The command moves the PVI. The command holds the start point of the first tangent and the endpoint of the second tangent. It modifies the grade values of the tangents for the change in PVI location.

The following illustration shows moving a PVI:
Chapter 3     Working with Profiles and Vertical Alignments

222

Drawing Vertical Curves for Ditches and Transitions

Before creating vertical curves, set the current profile and draw the tangents for ditches and transitions. All vertical curve commands place the curve on the same layer as the selected tangents. Although you can draw tangents using regular AutoCAD commands, use the DT Vertical Curves command to create vertical curves.

Drawing a Vertical Curve Based on the Curve Length

To draw the vertical curves based on the horizontal curve length
1 From the Profiles menu, choose DT Vertical Curves to display the Vertical Curves dialog box.
2 In the Description list, select the Length option. You can also click the Length icon, and then click OK.
3 Select the tangents that represent the grade coming into and out of the PVI.
4 Enter the horizontal length of the curve.

The command draws the vertical curve based on the length value.

The following illustration shows a vertical curve based on the curve length:

Drawing a vertical curve by length
**Drawing a Vertical Curve Based on a Minimum K Value**

This command calculates and drafts a vertical curve with given tangents and a given minimum K value. The K value of a vertical curve is the horizontal distance required to affect a 1% change in grade on the vertical curve: 

\[ K = \frac{\text{Length of curve}}{|\text{Grade in} - \text{Grade out}|} \]

**To draw a vertical curve based on K value**

1. From the Profiles menu, choose DT Vertical Curves to display the Vertical Curves dialog box.

2. In the Description list, select the K Value option. You can also click the K Value icon, and then click OK.

3. Select the tangents that represent the grade coming into and out of the PVI.

4. Enter a minimum K value.

   The command calculates the necessary length of curve for the given minimum K value and displays the value with the prompt Length of the curve.

5. Press ENTER to accept the length of curve for the given minimum K value.

   If you enter a new length, then the command recalculates the K value and draws the curve with the specified length.

The following illustration shows a vertical curve based on the K value:

![Drawing a vertical curve by K value](image-url)
Drawing a Vertical Curve Based on a Passing Sight Distance

To calculate and draft a crest vertical curve that is based on a minimum passing sight distance.

1. From the Profiles menu, choose DT Vertical Curves to display the Vertical Curves dialog box.

   **NOTE** You can only use this option with a crest curve.

2. In the Description list, select the Passing Sight option. You can also click the Passing Sight icon, and then click OK.

3. Select the tangents that represent the grade into and out of the PVI.

4. Enter a value for the minimum passing sight distance.

   To view the equations used to calculate the passing sight distance, see “Drawing the Vertical Curves Based on a Passing Sight Distance” in this chapter.

5. Press ENTER to accept the default values for Height of eye and Height of object, or enter new values.

   The Height of eye is the height of the driver's line of vision coming down the road; Height of object is the height of a vehicle approaching the driver. The default values are set in the Profile Value Settings dialog box.

   The length of curve is calculated.

6. Press ENTER to accept the calculated length of curve value, or enter a new value.

   The passing sight distance is then calculated.

   The following illustration shows the parameters used in calculating a vertical curve based on minimum passing sight distance:

   ![Drawing a vertical curve by passing sight distance](image)

   **Drawing a vertical curve by passing sight distance**
Drawing a Vertical Curve Based on a Stopping Sight Distance

To calculate and draft a crest vertical curve based on a minimum stopping sight distance

1 From the Profiles menu, choose DT Vertical Curves to display the Vertical Curves dialog box.

**NOTE** You can only use this option with a crest curve.

2 In the Description list, select the Stopping Sight option. You can also click the Stopping Sight icon, and then click OK.

3 Select the tangents that represent the grade into and out of the PVI.

4 Enter the value for the minimum stopping distance.

To view the equations used to calculate the stopping sight distance, see “Drawing the Vertical Curves Based on a Stopping Sight Distance” in this chapter.

5 Accept the default values for Height of eye and Height of object or enter new values at the prompts.

The Height of eye is the height of the driver’s line of vision coming down the road and the Height of object is the height of an object in the road such as an animal, vehicle, or piece of debris. The default values for these heights are set in the Profile Value Settings dialog box.

The length of curve is calculated.

6 Press ENTER to accept the calculated length of curve value or enter a new one.

If you enter a new length, the command recalculates the stopping sight distance and draws the curve with the specified length.

The following illustration shows the factors used in calculating the vertical curve based on stopping sight distance:

![Drawing a vertical curve by stopping sight distance](image)

Drawing Vertical Curves for Ditches and Transitions
Drawing a Vertical Curve Based on an Elevation Point

To draft a vertical curve based on an elevation point

1. From the Profiles menu, choose DT Vertical Curves to display the Vertical Curves dialog box.
2. In the Description list, select the High/Low Point option. You can also click the High/Low Point icon, and then click OK.
3. Select the tangents that represent the grades into and out of the PVI.
4. Select the high/low point by doing one of the following:
   - Select a point in your drawing.
   - Press ENTER and entering a numeric value for the elevation.

The command computes the necessary length of curve to pass exactly through the given point.
5. Press ENTER to accept the length of curve required to pass exactly through the given point, or enter a new length.

If you change the length, then the actual curve passes above or below the given point.

The High/Low option then displays the high/low station and elevation for the curve drawn. If you cannot calculate a high or low point for the selected tangents, a No high or low point exists for this curve message appears.

The following illustration shows the parameters used in calculating a vertical curve based on high/low elevation point:

![Drawing a vertical curve by elevation point](image)

Drawing a Vertical Curve through a Point

To draft a vertical curve that will pass through a selected point

1. From the Profiles menu, choose DT Vertical Curves to display the Vertical Curves dialog box.
2. In the Description list, select the Through Point option. You can also click the Through Point icon, and then click OK.
3. Select the tangents that represent the grades going into and out of the PVI.
4. Pick the point the vertical curve will pass through, or press ENTER, and then enter a station number and elevation.

The length of the curve is calculated.
Accept the calculated length of the curve, or enter another one using one of the following methods:

- Enter a smaller length to have the vertical curve pass above the indicated point in a crest curve, and below the selected point in a sag curve.
- Enter a greater length to have the vertical curve pass below the indicated point in a crest curve, and above in a sag curve.

The command draws the curve. If the command cannot construct a vertical curve through the point you selected, an error message appears stating that the function is undefined for the argument.

**Drawing a Sag Vertical Curves Based on the Headlight Data**

To draft a sag vertical curve with given grades, sight distance, and headlight data

1 From the Profiles menu, choose DT Vertical Curves to display the Vertical Curves dialog box.

2 In the Description list, select the Headlight option. You can also click the Headlight icon, and then click OK.

3 Select the tangents that represent the grades going into and out of the PVI.

4 Enter the value for the headlight sight distance.

5 Accept the default values for the headlight height above pavement and maximum headlight angle, or enter new values.

The length of the curve is calculated. To view the formulas used to calculate the length of curve, see “Drawing the Vertical Curves Based on Curve Length” in this chapter.

6 Accept the calculated length of curve, or enter a new value.

If you enter a new length, the Headlight option recalculates the headlight sight distance and draws the curve with the length specified.

The final headlight sight distance is displayed and the curve is drawn.
The following illustration shows the parameters used in calculating a vertical curve based on headlight data:

![Diagram of vertical curve parameters](image)

The command draws the curve and displays the final design velocity. If you use metric units, the command displays a default of 88.51 kmh, the equivalent of 55 mph.

---

**Drawing a Sag Vertical Curve Based on a Given Velocity**

To calculate and draft a sag vertical curve with given grades and design velocity

1. From the Profiles menu, choose DT Vertical Curves to display the Vertical Curves dialog box.

   **NOTE** You can only use this command with a sag curve.

2. Select the Comfort option and click OK.
3. Select the tangents that represent the grades coming into and out of the PVI.
4. Enter the design velocity.
5. Press ENTER to accept the default value, or enter a new value.

   The command calculates the appropriate length of the curve. To view the formula used to calculate the length of the sag vertical curve, see “Drawing the Sag Vertical Curve Based on a Given Velocity” in this chapter.

6. Press ENTER to accept this length, or enter a new value.

   If you enter a new length, the Comfort option recalculates the design velocity and draws the curve with the length specified.

   The command draws the curve and displays the final design velocity. If you use metric units, the command displays a default of 88.51 kmh, the equivalent of 55 mph.
The following illustration shows the parameters used in calculating a vertical curve based on design velocity:

Designing a vertical curve by velocity

**Defining a Grade Break Without a Vertical Curve**

To define a PVI without a vertical curve

1. From the Profiles menu, choose DT Vertical Curves to display the Vertical Curves dialog box.
2. In the Description list, select the Grade Break option. You can also click the Grade Break icon, and then click OK.
3. Select a grade break.
   This is the intersection of two vertical tangents. The object snap, intersection, is automatically set.
   The Grade Break option assigns a vertical curve of zero length to the Point of Vertical Intersection (PVI) selected. The PVI block is drawn on the specified finished ground layer. The command reports No intersection found at selected PVI point if the selection point is not the intersection of two lines.

**Listing the Vertical Curve Data**

You can retrieve vertical curve data by using the List ➤ Vertical Curves command. This command lists the beginning and ending stations of the BVC (Beginning of Vertical Curve), PVI (Point of Vertical Intersection), EVC (End of Vertical Curve), and high point/low point, as well as the grade in, grade out, grade change, curve length, and K value.

To list vertical curve data

1. From the Profiles menu, choose List ➤ Vertical Curves.
2. Select the vertical curve.
3 Select another curve to list, or press ENTER to end the command.

---

**Vertical Curve Information Sample Output**

**Vertical Curve Data**

- **BVC**
  - Station: 14+69.54
  - Elevation: 756.5

- **PVI**
  - Station: 16+69.54
  - Elevation: 758.8

- **EVC**
  - Station: 18+69.54
  - Elevation: 773.8

- **High Point**
  - Station: 18+69.54
  - Elevation: 773.8

Grade in: 1.14, Grade out: 7.50, Grade change: 6.36

Curve length: 400.00, K value: 62.84

---

**Labeling the Vertical Curves**

To create labels for vertical curves, use the Label ➤ Vertical Curves command. These labels show the Beginning of the Vertical Curve (BVC); the End of Vertical Curve (EVC); the length of the vertical curve; the PVI elevation; the Algebraic Difference; the K value; and the high/low point (a tick mark is placed at this point).

When you use this command, the tangents from which the vertical curve was created are broken at the BVC and EVC. Circles are inserted at the BVC and EVC points with a radius of 0.5 units when you plot the drawing. The labels go on the finished ground text layer as specified in the profile settings.

**NOTE**
The vertical curve label command uses the label increment and precision that you set with the Values command. However, once the Values settings are set and the profile is created, you cannot use the Values command to change them. Instead, use the Set Properties command to edit these settings.

---

**To label the vertical curves**

1 Set the label text size.
2 From the Profiles menu, choose Label ➤ Vertical Curves.
3 Select the tangents that represent the grades coming into and out of the PVI. The command uses the PVI station and elevation determined by the tangents.
4 Select the vertical curve. From the selection of the vertical curve, the command determines the station and elevation of the BVC and EVC points and places the labels in the drawing.
5 Select another curve to label, or press ENTER to end the command. The finished ground elevations are inserted along the grid base at the specified increment assigned in the Values command.
NOTE

This command uses the AutoCAD DIM HORIZ command to insert the length marker. To change any factors associated with this label, such as the arrow size, use the AutoCAD dimensioning variables.

The following illustration shows labeling a vertical curve:

![Labeling a vertical curve]

Defining Ditches or Transitions as Vertical Alignments

After drawing the tangents and vertical curves on the profile for a ditch or transition definition, you need to define it as a vertical alignment. The process of defining a vertical alignment for a ditch or transition is almost identical to defining a finished ground centerline. The only difference is that you must specify which alignment you are defining.

To define the ditches or transitions as vertical alignments

1. From the Profiles menu, choose DT Vertical Alignments ➤ Define Ditch/Transition.
2. Specify the profile you want to define: Centerline, Left, or Right.
   If you choose Left or Right, specify which of the eight transition regions or the ditch you want to define. The command turns off all layers except the layer of the alignment you specify. It is very important that the tangents and vertical curves are on the appropriate layer. If the vertical alignment entities are turned off, cancel the command and move the entities to the correct layer.
3. Select the starting point of the alignment (the point with the lowest station value). For a left to right profile, it is the left end of the vertical alignment; for a right to left profile, it is the right end. The command sets the object snap to END automatically.
4. Use a window or crossing to select the entire alignment.
5. Press ENTER after you select all the alignment segments.

The command then displays the number of PVIs included in the selection set.
NOTE

If the Define Ditch/Transition command displays the message “No vertical exists,” you cannot reference the finished and existing ground information to the same station or location. Use the Set Current Profile command to verify the location of the existing ground data then define the vertical alignment.

The following illustration shows the points required to define the finished ground alignment:

Defining finished ground

Defining a Ditch or Transition by Offsetting an Existing Vertical Alignment

As an alternative to drawing ditch or transition alignments, you can use the finished ground centerline (or any other vertical alignment) definition to create ditches and transitions by calculating a change in elevation based on offset and grade. The Define by Offset/Grade command uses a grade and offset value to create a new vertical transition alignment with elevations calculated in relation to an existing vertical alignment.

You can choose to create the new vertical alignment at a uniform offset from the existing alignment, or you can base the offset distance on a horizontal alignment that may have a non-uniform offset distance (such as for a passing lane):

- When you base the offset distance on a uniform offset, you must specify the uniform offset distance you want to use.
- When you base the offset distance on an alignment, you are not prompted for an offset distance. Instead, you must specify which horizontal alignment to use to determine the offset distance.

Creating a Vertical Alignment at a Uniform Offset from the Reference Alignment

Use the Uniform option of the Define by Offset/Grade command to offset a vertical alignment at a constant offset distance. The alignment that you offset
can be the finished ground centerline or any left or right ditch or transition. The alignment that is created can be any left or right ditch or transition.

**To create a vertical alignment at a uniform offset from the reference vertical alignment**

1. Define the vertical alignment that is to be used as the reference definition.
2. From the Profiles menu, choose DT Vertical Alignments ➤ Define by Offset/Grade.
   The following prompt is displayed:
   `Select offset type (Uniform/Alignment) <Alignment>:`

3. Type `U` to select the Uniform offset type.
   The following prompt is displayed:
   `Profile to reference (Center/Left/Right) <Center>:`

4. Select the vertical alignment to offset by doing one of the following:
   - Type `Center` to offset the finished ground centerline alignment.
   - Type `Left` or `Right` to offset a left or right profile. You must specify which left or right profile (or ditch) you want to offset. The following prompt is displayed:
     `Select left profile (Ditch/1/2/3/4/5/6/7/8):`
   - Type `D` for Ditch or a number from 1 to 8.

     When you have selected the vertical alignment to offset, the following prompt is displayed:
     `Profile to create (Left/Right):`

5. Type `Left` to create a left profile, or `Right` to create a right profile.
   A prompt similar to the following is displayed:
   `Select left profile (1/2/3/4/5/6/7/8):`

6. Define the number of the profile to create by typing a number from 1 to 8. This number is assigned to the new offset alignment. Typically, 1 is used as the first offset from the centerline, 2 is used as the second offset from the centerline, and so on.
   The following prompt is displayed:
   `Offset distance:`

7. Type an offset distance or pick two points in the drawing to define the distance.
   The following prompt is displayed:
   `Enter grade %:`

8. Type the grade for the offset (as a percentage). This value is the grade between the existing alignment and the offset that will be created. Type a minus sign for a negative grade.
   The command then determines the offsets to the alignment.
9. Import the offset alignment into the drawing profile in order to view it.
Creating a Vertical Alignment at an Offset Based on a Horizontal Alignment

Use the Alignment option of the Define by Offset/Grade command to offset a vertical alignment based on the offset distance(s) between two selected horizontal alignments. The alignment that you offset can be the finished ground centerline or any left or right ditch or transition. The alignment that is created can be any left or right ditch or transition.

The Alignment option is useful in situations in which a constant offset distance would not work, such as where there are vertical curves in profile view and/or passing lanes (irregular offset distances) in plan view.

To use this option, a horizontal alignment must exist that corresponds to the vertical alignment you want to reference and the one you want to create. These two horizontal alignments are used to calculate the offset distances along the profile that, when applied to the change in grade value, results in the new vertical alignment definition.

To create a vertical alignment at an offset that is based on a horizontal alignment

1. Define a horizontal alignment centerline.
2. Define offsets for the horizontal alignment, such as left and right edges of pavement. You must define these offsets as alignments as they are created.
3. Draw and define at least one finished ground vertical alignment (for example, the finished ground centerline).
4. From the Profiles menu, choose DT Vertical Alignments ➤ Define by Offset/Grade.
   The following prompt is displayed:
   Select offset type (Uniform/Alignment) <Alignment>:
5. Type A to select the Alignment offset type.
   The following prompt is displayed:
   Profile to reference (Center/Left/Right) <Center>:
6. Do one of the following to select the vertical alignment to offset:
   - Type Center to offset the finished ground centerline alignment. If you select this option, then you must select the corresponding horizontal alignment. Either select the alignment from the graphics screen, or press ENTER to access the Alignment Librarian dialog box and select the alignment.
   - Type Left or Right to offset a left or right profile. If you select either Left or Right, then you must specify which left or right profile (or ditch) you want to offset. The following prompt is displayed:
     Select left profile (Ditch/1/2/3/4/5/6/7/8):
   - Type D for Ditch or a number from 1 to 8.

   Next, you must specify which horizontal alignment this profile corresponds to from which to calculate the offsets. Either select the alignment from the graphics screen, or press ENTER to access the Alignment Librarian dialog box and select the alignment.
When you have selected the vertical alignment to offset, the following prompt is displayed:

Profile to create (Left/Right):

7 Type **Left** to create a left profile, or **Right** to create a right profile.

A prompt similar to the following is displayed:

Select left profile (1/2/3/4/5/6/7/8):

8 Define the number of the profile to create by typing a number from 1 to 8. This number is assigned to the new offset alignment. Typically, 1 is used as the first offset from the centerline, 2 is used as the second offset from the centerline, and so on.

A prompt similar to the following is displayed:

Select alignment L2:

9 Select the corresponding horizontal alignment of the profile that you want to create. You can select the alignment from the graphics screen, or press ENTER to access the Alignment Librarian.

For example, if the vertical alignment you are creating is the right edge of pavement, then select the horizontal alignment that you created for the right edge of pavement.

The following prompt is displayed:

Enter grade %:

10 Type the grade for the offset (as a percentage). This value is the grade between the existing alignment and the offset that will be created. Type a minus sign for a negative grade.

The command then determines the offsets to the alignment.

11 Import the offset alignment into the drawing in order to view it.

**Editing a Ditch or Transition Vertical Alignment**

You can use the DT Vertical Alignments ➤ Edit command on the Profiles menu to edit a vertical alignment. This command is almost identical to using the Edit Vertical Alignment command found in the Existing Ground menu.

There are two Edit commands on the Profiles menu: one in the Ditches and Transitions (DT) section, and the other in the Finished Ground Centerline (FGC) section. The major difference between these commands is that the DT Vertical Alignment ➤ Edit command first prompts for the selection of the vertical alignment to edit.
To edit a ditch or transition vertical alignment

1 From the Profiles menu, choose DT Vertical Alignments ➤ Edit to open the Vertical Alignment Editor.

2 Select an alignment to edit.

3 Click OK to exit the Vertical Alignment Editor.

Importing the Ditch or Transition Vertical Alignments

If you use the Vertical Alignment Editor to create or change a vertical alignment, or if you use the Define by Offset/Grade command to create a vertical alignment, then use the Import command to update the profile in the drawing.

NOTE The drawing is not dynamically related to the Vertical Alignment Editor. If you edit the drawing with this editor, use the Import command to import the changes. This keeps the drawing updated and prevents potential confusion.

To import the ditch or transition vertical alignments

1 From the Profiles menu, choose DT Vertical Alignments ➤ Import.

The following prompt is displayed:

Select profile (Center/Left/Right) <Center>: 
2 Select the alignment to import by doing one of the following:

- Type **Center** to import the finished ground centerline.
- Type **Left** or **Right** to import a left or right ditch or transition. When you select either of these options, a prompt similar to the following is displayed:

  Select left profile (Ditch/1/2/3/4/5/6/7/8) <1>:

  - Type **D** for Ditch or type a number from 1 to 8.

  When you have selected the alignment to import, the following prompt is displayed:

  Label tangents and vertical curves (Yes/No) <Yes>:

3 Type **Yes** to label the alignment objects as they are imported, or type **No**. If the finished ground profile already exists in the current drawing, the following prompt is displayed:

  Delete finished ground profile layer (Yes/No) <Yes>:

4 Type **Yes** to erase the existing objects, or type **No** to preserve any objects on the layer.

The command imports the alignment.

**Listing the Elevation of a Selected Point or Station for the Ditch and Transition Alignments**

You can use the List Elevations command to list the elevation of a selected point or station for a selected profile surface. This command lists the elevation of a ditch or transition alignment at the station (or point) you specify.

**To list the elevation of a selected point or station for a ditch or transition alignment**

1 From the Profiles menu, choose DT Vertical Alignments ➤ List Elevations. The following prompt is displayed:

  Select profile (Center/Left/Right) <Center>:

2 Select the profile to use by doing one of the following:

- Type **Center** to select the finished ground centerline.
- Type **Left** or **Right** to select a left or right ditch or transition. When you select either of these options, a prompt similar to the following is displayed:

  Select left profile (Ditch/1/2/3/4/5/6/7/8) <1>:

  - Type **D** for Ditch or type a number from 1 to 8.

  When you have selected the alignment, the reference profile name is displayed at the command line, and the following prompt is displayed:

  Enter station (or Point): 

3 Do one of the following:

- Type **Point**, and then select a point from the drawing. This displays the station and elevation of the selected point, as well as the elevation of the
vertical alignment at the station of the point selected. This command also
displays the difference in elevation between the vertical alignment and the
point selected.
- Type Station, and then type a station number. The elevation for the
specified station is displayed.

**NOTE** If you have not drawn or defined the specified profile, or if the point you
select is beyond the horizontal limits of the profile, the command
displays the station of the point or station selected and the text
Undefined for the elevation.

4 Select another point to list, or press ENTER to end the command.

### Listing and Labeling the Vertical Alignments

Using the Label commands on the Profiles menu, you can change the text style
for vertical alignment labels and label vertical curves, finished ground tangents,
and the elevation and station of a point. With the List commands, you can list
information for vertical curves, finished ground tangents, elevation and station
of any point in a profile, and depth.

### Changing the Text Style for the Vertical Alignment Labels

Vertical alignment labels use the current text style. There can be one current
text style at a time when you are working in AutoCAD. You can use the Set Text
Style command to change the current text style, if needed.

**To set the current text style for labels**

1 From the Profiles menu, choose Label ➤ Set Text Style to display the Text Style
dialog box.

![Text Style Dialog Box](image)

2 Select the style you want to use.

3 Click OK.
Labeling the Finished Ground Tangents

You can label finished ground centerline tangents and ditch and transition tangents with labels that show the percent slope along the tangent and the finished ground elevations. The finished ground elevations are placed along the grid base at the increment you specified with the Values command.

**NOTE** You must label the vertical curves before labeling the tangents, otherwise the tangents will be labeled to the PVI points rather than the start/end of the vertical curves.

To label finished ground tangents

1. Use the Set Current Profile command to set the current profile.
   The program automatically sets the profile based on the current alignment.
2. From the Profiles menu, choose Label ➤ Tangents.
   **NOTE** If you need to change the label increment after you generate a profile, use the Set Properties command.
3. Select the tangent to be labeled.
   The command continues to prompt you for tangents to label.
4. Select each tangent to be labeled, and then press ENTER to end the command.
   The grade and finished ground elevations are placed on the finished ground text layer that you specified using the FG Layers command. The labels are inserted as AutoCAD text objects using the current text style and placed on the defined Finish Ground Text Layer. If the height of the current text style is zero, the labels are inserted with a height of 0.1 times the horizontal scale of the drawing. For example, if the horizontal scale equals 1=50, the text height equals 5 (0.1 × 50).
   The following illustration shows a labeled finished ground tangent:
Labeling the Elevation and Station of a Point On a Profile

To create spot elevation labels that label a point’s station and elevation, use the Label ➤ Spot Elevations command.

To label the elevation and station of a point on a profile

1. From the Profiles menu, choose Label ➤ Spot Elevations.
2. Select the point you want to label. You can use object snaps to select a point.
3. Select additional leader points if needed, and then press ENTER to place the label. The leader and station and elevation text are placed on the finished ground text layer as specified in the FG Layers command.
4. Select another point to label, or press ENTER to end the command.

The following illustration shows a spot label:

![Labeling a spot station and elevation](image)

Listing the Finished Ground Tangent Data

You can list finished ground centerline and ditch and transition tangent data using the List ➤ Tangents command.

To list the finished ground tangent data

1. Use the Set Current Profile command to set the current profile.
   The program automatically sets the profile based on the current alignment.
2. From the Profiles menu, choose List ➤ Tangents.
3. Select the tangent to be listed.

The following information is listed:

<table>
<thead>
<tr>
<th>Tangent Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begin . . . . . . . . Station : 10+00 Elevation: 7651.60</td>
</tr>
<tr>
<td>Grade: 1.00</td>
</tr>
<tr>
<td>End . . . . . . . . . . Station : 26+50 Elevation: 778.10</td>
</tr>
</tbody>
</table>

4. Select another tangent to list, or press ENTER to end the command.
Listing the Elevation and Station of Any Point In a Profile

To list the elevation and station of any point in a profile

1. From the Profiles menu, choose List ➤ Spot Elevations.
2. Select the point to be listed. You can use object snaps to select a point.
   The command lists the elevation and station of the selected point on the screen.
3. Select another point to list, or press ENTER to end the command.

Listing the Difference in Elevation of Two Points In the Profile

You can retrieve depth values from profiles by using the List ➤ Depths command to list the difference in elevation between two points in the profile.

This command uses the vertical exaggeration at which the current profile was created to determine the actual difference in elevation between two points. For example, if the vertical exaggeration is 10, an actual vertical difference of 43.7 is calculated as a 4.37 unit difference in elevation.

To list the difference in elevation between two points in the profile

1. From the Profiles menu, choose List ➤ Depths.
2. Select the two points between which you want to list the depth. You can use object snaps to select the points. The command lists the depth between the two selected points.
3. Continue to pick points, or press ENTER to end the command.
   The following illustration shows the listing of the depth from finished ground for the end of a skewed pipe:

Depth at alignment for end of skewed pipe
Listing the Elevations of Points in the Profile in Relation to the Finished Ground Centerline

You can use the List Elevations command to list the elevation of a selected point or station for a finished ground centerline. This command lists the elevation of the finished ground centerline at the station (or point) you specify.

To list elevations of points in the profile
1. From the Profiles menu, choose List ➤ List Elevations.
2. Select a point using one of the following methods:
   - Select a point on the profile. This displays the station and elevation of the selected point, as well as the elevation of the current surface at the point's station. This command also displays the difference in elevation between the vertical alignment and the point selected.
   - Type S, for Station, and type a station number to display the Finished Centerline Elevation for the specified station.

   **NOTE** If you have not drawn or defined the specified profile, or if the point you select is beyond the horizontal limits of the profile, the command displays the station of the point or station selected and the text Undefined for the elevation.

3. Select another point to list, or press ENTER to end the command.

Creating ASCII Output Files of Profile Information

To create ASCII output files of information taken from profiles, use the Profiles ➤ ASCII File Output command. You can change the output settings for ASCII files using the ASCII File Output ➤ Output Settings command on the Profiles menu.

ASCII output files have been developed to allow custom programs to read data. There are many different output formats that exist worldwide. Some countries have standardized on specific formats for profiles and cross sections, while in other countries the formats can vary greatly from region to region or even between corporations. With these ASCII files, add-on programs are written to take the data generated by Autodesk Civil Design and output in any customized format.
<table>
<thead>
<tr>
<th>Description</th>
<th>Codes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Surface types</td>
<td>Existing ground</td>
</tr>
<tr>
<td></td>
<td>Proposed ground</td>
</tr>
<tr>
<td>Surface codes</td>
<td>Existing ground center</td>
</tr>
<tr>
<td></td>
<td>Existing ground left</td>
</tr>
<tr>
<td></td>
<td>Existing ground right</td>
</tr>
<tr>
<td></td>
<td>Existing subsurface center</td>
</tr>
<tr>
<td></td>
<td>Existing subsurface left</td>
</tr>
<tr>
<td></td>
<td>Existing subsurface right</td>
</tr>
<tr>
<td></td>
<td>Proposed centerline</td>
</tr>
<tr>
<td></td>
<td>Proposed left one</td>
</tr>
<tr>
<td></td>
<td>Proposed left two</td>
</tr>
<tr>
<td></td>
<td>Proposed left three</td>
</tr>
<tr>
<td></td>
<td>Proposed left four</td>
</tr>
<tr>
<td></td>
<td>Proposed left five</td>
</tr>
<tr>
<td></td>
<td>Proposed left six</td>
</tr>
<tr>
<td></td>
<td>Proposed left seven</td>
</tr>
<tr>
<td></td>
<td>Proposed left eight</td>
</tr>
<tr>
<td></td>
<td>Proposed right one</td>
</tr>
<tr>
<td></td>
<td>Proposed right two</td>
</tr>
<tr>
<td></td>
<td>Proposed right three</td>
</tr>
<tr>
<td></td>
<td>Proposed right four</td>
</tr>
<tr>
<td></td>
<td>Proposed right five</td>
</tr>
<tr>
<td></td>
<td>Proposed right six</td>
</tr>
<tr>
<td></td>
<td>Proposed right seven</td>
</tr>
<tr>
<td></td>
<td>Proposed right eight</td>
</tr>
<tr>
<td></td>
<td>Proposed left ditch</td>
</tr>
<tr>
<td></td>
<td>Proposed right ditch</td>
</tr>
<tr>
<td>Points</td>
<td>All points</td>
</tr>
</tbody>
</table>
Changing the ASCII Output Settings for Outputting Profile Data

To change the ASCII output settings for outputting profile data

1. From the Profiles menu, choose ASCII File Output ➤ Output Settings to display the Output Settings dialog box.

2. Under Output Options, do one of the following:
   - Select File to output the information to a text file.
   - Select Screen to output the information to the screen.

3. Under Output Format, select or clear the appropriate check boxes:
   - **Date**: Select this check box to place the date on the report.
   - **Title**: Select this check box to place a title on the report.
   - **Page Breaks**: Select this check box to place page breaks in the report.
     When you select this check box, and create a Screen report, the text window displays only the first page of the information, and then prompts you to press a key to continue. When you press a key, the next page of the report is displayed.
     If you clear this check box, and create a File report, the report is created with page breaks instead of having all the information displayed in one long list.
     If you select the Sub Headers check box and the Page Breaks check box, then sub headers are placed at the beginning of each page break.
   - **Page Numbers**: Select this check box to place page numbers on a report. This setting applies to File output only.
   - **Sub Headers**: Select this check box to place sub headers at the beginning of each new page of a report. This setting applies to File output only. You must also select the Page Breaks check box if you want sub headers to appear. The sub headers are placed at the beginning of each page break.
   - **Overwrite File**: Select this check box to overwrite a file if it already exists. Clear this check box to append new information to the end of an existing file.

   **NOTE** Be sure to also specify the correct Output File Name for the report.

4. Also under Output Format, specify the following information:
   - **Page Length**: Type the number of rows of type you want on each page in this box. The spacing is measured in characters. This setting applies only if the Page Breaks check box is selected and applies only to File output.
   - **Page Width**: Type the number of characters you want across each page in this box. This setting applies only to File output and affects the output of the stakeout file. If the page width is too narrow, then the lines wrap.
   - **Left Margin**: Type the number of characters you want as a left margin in this box. This setting only applies to File output.
   - **Right Margin**: Type the number of characters you want as a right margin in this box. This setting applies only to File output.
- **Top Margin**: Type the number of characters you want as a top margin in this box. The margin is inserted between the page number (if you select the Page Numbers option) and the report title. This setting applies only to File output.

- **Bottom Margin**: Type the number of characters you want as a bottom margin in this box. This setting applies only to File output.

  For more information on the format for ASCII output files of profile information, see the following section, “Formatting for the ASCII Output Files of the Profile Information.”

5. Enter the Output File Name.

6. You can click Output File Name to specify a folder for the output file. If you do not specify an output folder, the file that is created is placed in the current project folder.

7. Click OK.

**Formatting for the ASCII Output Files of the Profile Information**

When you output profile data using the ASCII File Output ➤ Profile command, the data is output in the following format:

```
Alignment name
surface type, number of surfaces of this type
surface code, surface name
number of points for this surface
pt code, internal sta, external sta, elevation, vc length in, vc length out.
```

The internal station is the original station value as the alignment was defined, before using station equations. The external station is the current station value. If you have not used station equations, these values are the same. In the output from all the ASCII File Output commands, any line beginning with either a number character (#) or semicolon (;) is a comment line.
The following file is an example of an ASCII output file:

```
r1
0,3
1,eg
3
0,1642.800000,3000.000000,358.693823,0.000000,0.000000
0,2087.915609,3445.115609,328.725615,0.000000,0.000000
0,2716.439873,4073.639873,337.987848,0.000000,0.000000
2,eg
3
0,1642.800000,3000.000000,358.948705,0.000000,0.000000
0,2087.878787,3445.078787,327.570460,0.000000,0.000000
0,2716.439873,4073.639873,338.083833,0.000000,0.000000
3,eg
3
0,1642.800000,3000.000000,355.951438,0.000000,0.000000
0,2087.878775,3445.078775,328.870119,0.000000,0.000000
0,2716.439873,4073.639873,336.323390,0.000000,0.000000
0,3
4,fg
3
1,0
1,Center
5
0,1630.571608,1630.571608,357.988631,0.000000,0.000000
0,1810.581539,3167.781539,359.745661,100.000000,100.000000
0,2245.246668,3602.446668,312.763310,100.000000,100.000000
0,2453.750994,3810.950994,334.273928,50.000000,50.000000
0,2732.522355,4089.722355,338.235042,0.000000,0.000000
```

**Creating ASCII Output Files of the Profile Information to Use in Other Programs**

You can create ASCII text files of profile data. For example, if you want to use the data in another software program, you can use the ASCII File Output ➤ Profile command.

To view the format for the ASCII text file, see “Format for the ASCII File Output Files of the Profile Information” in this chapter.

For more information on the profile codes used in the ASCII text file, see “Creating ASCII Output Files of Profile Information” in this chapter.

To create ASCII output files of the profile information to use in other programs

1. Set the profile output settings, if you haven't done so already.
2. From the Profiles menu, choose ASCII File Output ➤ Profile.
3. Specify the folder to output the information to. The default is c:\Land Projects R2\<project name>\align\.
4. Specify the filename. When entering the file name, you must include the extension.

If the file already exists, a prompt appears asking whether or not you want to overwrite the file:

- Type Y to overwrite.
- Type N to enter a different filename.

After specifying the filename, a prompt appears showing the current surface.
NOTE The files created by the commands in this menu are output in ASCII format only. These are data files and are not intended to be a report. This command does not use the filename set in the Output Settings dialog box. The filename is specified within the command.
Working with Cross Sections

Use the Cross Sections commands to create existing and finished ground cross sections. You can sample an existing surface or a file to obtain surface data that can be used to create the sections. To design finished ground sections, you can design a template and define ditches, slopes, transitions, and superelevation.
Creating Cross Sections

Use the commands in the Cross Sections menu to design a roadway in cross section view. Cross sections are cut along the horizontal (plan) alignment at station intervals. The cross section X, Y, and Z coordinates are obtained from the horizontal alignment, the profile elevations, and the sampled surface. A completed cross section is composed of existing ground surfaces, a finished ground template, slopes, and optional ditches.

You begin creating cross sections by sampling the existing ground surface along a horizontal alignment. You can then edit existing ground cross sections using the Edit Sections command.

To create finished ground cross sections, you design and apply a roadway template. This represents the chosen design of a road, showing the lane and shoulder widths, ditches, foreslopes, and backslopes in a cross sectional view. Templates are defined from polyline surfaces.

Next, define slope and ditch settings, and then apply superelevation. The slope, superelevation, template, ditch, and transition attachment settings are referred to as “Design Control” and are located in the Design Control submenu.

For a more detailed list that describes the process of creating cross sections, see “The Process of Creating Cross Sections” in this chapter.

Many variables affect how cross sections are created and updated. For a list of actions that affect cross section design control, see “Actions that Affect Cross Section Control” in this chapter.

Prerequisites: Before working with cross sections, you must define the centerline alignment using the Horizontal Alignment commands create the existing ground profile, and define the finished ground centerline profile.

NOTE You can create the existing ground cross sections before the profile, but if you want to apply the design templates to the cross sections, you must create the profiles first.

The Process of Creating Cross Sections

The following steps describe the process of completing the cross section design for an alignment:

1 Create Existing Ground Data: You can create the existing ground data for cross sections in one of three ways. You can sample the data from one or more surfaces, you can import the data from a text file, or you can enter the data into the Existing Ground Section Editor.

2 Create Existing Ground Subsurfaces (optional): There are two methods you can use to create existing ground subsurfaces. You can create them at the same time as the top surface by sampling multiple surfaces or by sampling them from a text file. Alternately, if you create the cross sections from a single existing surface, then you can define the subsurfaces later by entering borehole data with Interpolation Control in the Existing Ground Editor.

3 Draw and Define Templates: A template represents the finished ground surfaces, such as the asphalt and granular surfaces, and may contain predefined subassemblies for curb and shoulder surfaces. There are two types of templates.
Symmetrical, in which you draw just the left side of the template, and asymmetrical, in which you draw the whole template.

4 **Edit Templates:** Use the Edit Template command to add additional information to the templates, including superelevation regions, transition control, and point codes.

5 **Slope Tables:** If you want to use Depth, Stepped or Surface slopes, then you need to fill in the appropriate slope table.

6 **Edit Design Control:** Use the Edit Design Control command to apply the finished ground design—the templates, ditches, and slopes—to the existing ground cross sections. You can apply transition control at this step if you have defined the appropriate horizontal or vertical alignments.

7 **Superelevation (optional):** After you have applied the templates to the cross sections, you can define the superelevation parameters.

8 **View/Edit Sections (optional):** Use the View/Edit Sections command to view the cross sections and to make modifications to the design of individual sections.

**Actions that Affect Cross Section Control**

Many of the results that you achieve with the Cross Section commands are affected by other, interrelated commands in Autodesk Civil Design. Click any item in the following list to see information about how that item affects cross section control.

- **Horizontal Alignment – Station Equations:** If you define a station equation on the centerline alignment after creating cross sections, then you must resample the profile and the existing ground cross sections.
- **Horizontal Alignment – Centerline:** If you modify the centerline horizontal alignment after creating cross sections, then you must recreate the existing ground profile and resample the cross sections.
- **Horizontal Alignment – Transitions and Ditches:** If you attach a horizontal alignment to cross sections for template transitioning, ditch control, or right of way control, and then modify it, then you must re-attach it by using the Edit Design Control command.
- **Profile – Existing Ground:** You can resample the existing ground profile at any time after creating cross sections. This action does not affect the cross section template elevations, but it does affect the cross section volumes.
- **Profile – Finished Ground:** If you modify the finished ground centerline profile, then you should use the Process Sections command to update the template elevations. In addition to the Process Sections command, the Edit Design Control, View/Edit Sections and Section Plot commands also reprocess the sections.
- **Profile – Transitions and Ditches:** If you have modified any of the transitions or ditch profiles, then you must re-attach them by using the Edit Design Control command.
- **Existing Ground – Edit:** After you have applied a template to the cross sections, you can modify the existing ground cross sections with the Edit Sections command. After you make the modifications, you must use the Design Control ➤ Process Range command to update the template slopes.
- **Existing Ground – Resample**: You can resample the existing ground sections (from a surface or a file) after applying templates to the cross sections. If you do this, then you are prompted to overwrite the existing section information. If you respond yes, then the existing ground section information is deleted first, then re-sampled. If you respond no, then the new existing ground information is merged with the previous surface information. 

Re-sampling the existing ground always maintains the finished ground section information. If you used the Existing Ground ➤ Edit Sections command to interpolate subsurfaces, then you must re-interpolate the subsurfaces.

- **Existing Ground – Add Sections**: You can create additional cross sections after you have applied templates, either by re-sampling the sections or by manually entering the information with the Existing Ground ➤ Edit Sections command. A new cross section acquires all of its design control from the section that is immediately before it, except for the template elevation which it extracts from the centerline finished ground profile.

If you have attached any horizontal or vertical alignments to the template, such as transitions, ditches and ROW lines, then you must re-attach them for the new sections by using the Edit Design Control command. You only need to reprocess superelevation if you modify the superelevation parameters with the Superelevation Parameters command. If you do change the superelevation parameters, then you are prompted when exiting the command to reprocess the superelevation information.

- **Template – Edit**: You can make edits to a template, such as adding transitions or superelevation points, after you have applied the template to the cross sections. The Edit Template command automatically reprocesses the cross sections when you exit the command. After you have reprocessed the cross sections, you can use the View/Edit Sections command to see if the modified template has been applied as expected.

- **Slopes – Depth, Step, and Surface**: If you modify a slope table that you have already applied to a template, then use the Process Sections command to update the slopes.

- **Edit Design Control**: You can use the Edit Design Control command at any time to modify the design control for a range of stations (sections). When you modify and re-process a range of stations with this command, only the specific criteria that you modify will be reapplied to the selected range.

For example, if you only modify the ditch width using the Edit Design Control command, then the new width will be applied to the selected range of stations, but nothing else. This is because ranges can overlap and you may have modified individual sections with the View/Edit Sections command.
- **Superelevation Parameters**: You can modify the superelevation parameters at any time. The Superelevation Parameters command automatically reprocesses the cross sections.

- **View/Edit Sections**: You can use the View/Edit Sections command at any time to view the cross sections and to make modifications to the design of individual sections.

### Working with the Cross Section Database Files

Horizontal alignments are defined with a name and stored in the alignment database for reference. All commands that work with alignments refer to the information from this database.

Profile and cross section data is also stored in data files. These data files are stored in `c:\Land Projects R2\<project name>\align\<alignment name>` folder. Cross section settings for options such as the template control, sampling increments, and layers for plotting are stored in `c:\Land Projects R2\<project name>\<dwgname>.dfm` file in the `c:\Land Projects R2\<project name>\dwg` folder along with the rest of the settings for the current drawing.

### Creating Existing Ground Cross Sections

The first step in working with cross sections is to establish the existing ground surface information. You can create the existing ground cross section data in one of three ways. You can sample the data from one or more surfaces, you can import the data from a text file, or you can enter the data manually by using the Existing Ground Section Editor.

### Setting the Current Surface (Cross Sections)

Use the Set Current Surface command to set the current surface for the drawing. The current surface is used when you use the Sample From Surface command to sample cross section data from one surface.

**NOTE** The surface stays current for the drawing session only. You must set a current surface each time you open the drawing.
To set the current surface

1. From the Cross Sections menu, choose Surfaces ➤ Set Current Surface to display the Select Surface dialog box.

2. Do one of the following to filter the listed surfaces:
   - Select Terrain Surface to show the terrain surfaces in the list.
   - Select Volume Surface to show the volume surfaces in the list.

3. Select the surface that you want to make current.

4. Click OK.

Sampling Existing Ground Section Data with and without Multiple Surfaces

To sample existing ground data for cross sections from multiple surfaces, use the Toggle Multiple Surfaces command to enable the use of multiple surfaces. If you subsequently want to sample data for only one surface, then use the Toggle Multiple Surfaces command to disable the use of multiple surfaces.

If multiple surfaces are on, then the Sample From Surface command uses all the surface names in the surfaces.txt file created by the Select Multiple Surfaces command. Each surface is used for each defined section. The command extracts elevations for the section from the surface associated with each surface name in the file. If multiple surfaces are off, then the Sample From Surface command does not use the surfaces.txt file. The current surface is sampled instead.

To select between using one or several surfaces to sample cross section data

- From the Cross Sections menu, choose Surfaces ➤ Toggle Multiple Surfaces.
  - A prompt is displayed that states that multiple surfaces are on or off.
Creating a File of Multiple Surfaces for Sampling the Existing Ground Section Data

To sample cross section data from multiple surfaces, you must enable the use of multiple surfaces and use the Select Multiple Surfaces command to create a list of the surfaces you want to sample. This command creates a surfaces.txt file that is used when you use the Sample From Surface command.

To create a file of multiple surfaces for sampling existing ground section data

1. From the Cross Sections menu, choose Surfaces ➤ Select Multiple Surfaces to display the Multiple Surface Selection dialog box.

2. From the Select from list, select the surfaces you want to use. Use the SHIFT and CTRL keys to select multiple surfaces. Selecting names from this list places the surface names in the Current box.

3. To remove a surface name from the Current list, hold down the CTRL key and click the surface name in the Select from list. Click OK to create the surfaces.txt file that will be used with the Sample From Surface command when the use multiple surfaces is enabled.

Sampling the Existing Ground Section Data from One Surface

You can use the Sample From Surface command to sample the existing ground elevations from a surface along the current alignment. After you sample existing ground section data, you can view the existing ground cross sections by using the View/Edit Sections command if desired.

NOTE: You can also sample existing ground data from multiple surfaces.

NOTE: Any Design Control data that already exists is not deleted when you sample the existing ground sections, even if you are overwriting the existing ground sections.
To sample the existing ground section data from one surface

1. Create and define the horizontal alignment.
   For more information, see the chapter "Alignments" in the *AutoCAD Land Development Desktop User's Guide*.

2. Define a surface.
   For more information, see “Creating Surfaces” in the chapter “Creating Surface Models” in the *AutoCAD Land Development Desktop User's Guide*.

3. From the Cross Sections menu, choose Existing Ground ➤ Sample From Surface to display the Select Surface dialog box.
   The Select Surface dialog box lists all the currently defined surface names.
   
   **NOTE** The Select Surface dialog box is displayed only if there is no current surface selected.

4. Select the desired surface, and then click OK to display the Section Sampling Settings dialog box.

5. Enter the desired settings. All of the options and defaults shown in this dialog box are described in detail in “Changing the Cross Section Sampling Settings” in this chapter.
   If you are using the Sample From Surface command to add another surface definition to the sections, then you may want to make sure that the section sampling settings are such that the stations and width match the current existing ground sections. Enter **No** to overwrite the existing cross section file prompt to add additional surface information.
   To add additional cross sections after they have been sampled from a surface, there are two options you can use. If you do not want to change the cross sections definitions that have already been sampled, but want to add additional stations, you can run the Sample From Surface command again and turn on the Add Specific Stations option. Then click OK. After the station range prompt, enter the new station values to be sampled, and press ENTER.
At the prompt to overwrite the existing cross section, accept the default option No. This adds the new existing ground cross sections to the file without overwriting any that had previously been sampled. The other option is to use the Edit Sections command and insert the new cross sections by entering offset and elevation information.

When resampling from a surface, you can also enter Yes at the prompt to overwrite the previously sampled cross sections if you want to change the swath width and/or the station sampling options, and/or the surface definition was changed. This option completely deletes the previously sampled cross sections and re-samples the cross sections.

6 Click OK to close the Section Sampling Settings dialog box.

The command prompts you to enter the range of stations along the current alignment you want to sample.

7 Type the station of the alignment at which to start sampling the existing ground.

8 Type the station of the alignment at which to end sampling the existing ground. If you selected the Add specific stations check box in the Section Sampling Settings, then the following prompt is displayed:

Enter critical station (or Point):

At this prompt you can include additional sections at specific stations that may not be covered by the intervals specified in the Section Sampling Settings dialog box.

9 Do one of the following:

- Type an additional station to sample. If you must sample more than one station, press ENTER and type the additional station.
- Type Point, and then on the plan view of the alignment, use your pointing device to select the additional station locations you want to sample.

If the existing ground cross section information already exists, then the following prompt is displayed:

Overwrite existing section data (Yes/No) <Yes>:

10 Type Yes or No:

- Type Yes to delete the existing ground cross section information then resample it based on the current settings.
- Type No to keep the existing ground information and merge the new information into the cross sections that were created previously (from a different surface). However, existing ground section data is overwritten if you are sampling the same surface that was sampled previously.
- The command samples the terrain data from the surface. When it is finished sampling, the command displays the amount of the alignment that has been sampled.
NOTE
If a cross section does not cross the surface, then the command displays
the following message:

WARNING: Some sections failed to cross the alignment
and will be missing from output.

When a section is completely outside the surface area, the existing ground
information cannot be calculated so that the section is not created.

**Sampling the Existing Ground Section Data from Multiple Surfaces**

You can sample existing ground elevations along the current alignment from
multiple surfaces by enabling the using of multiple surfaces, selecting the
surfaces to sample, and using the Sample From Surface command.

This command samples the existing ground data for the entire length of the
current alignment.

**To sample existing ground definition from multiple surfaces**

1. Create and define the horizontal alignment.
   For more information, see the chapter “Alignments” in the AutoCAD Land
   Development Desktop User’s Guide.
2. Create the surfaces you want to sample.
3. Enable the use of multiple surfaces.
4. Select the multiple surfaces you want to sample.
5. From the Cross Sections menu, choose Existing Ground ➤ Sample From Surface
to display the Section Sampling Settings dialog box.
6. Enter the settings.
   All of the options and defaults shown in this dialog box are described in detail
   in “Changing the Cross Section Sampling Settings” in this chapter.

   **NOTE**
   If you are using the Sample From Surface command to add another surface
definition to the sections, then you may want to make sure that the section
sampling settings are such that the stations and width match the current
existing ground sections. Enter No to overwrite the existing cross section file
prompt to add additional surface information.

7. Click OK to close the Section Sampling Settings dialog box.
   If you selected the Add specific stations check box in the Section Sampling
   Settings, then the following prompt is displayed:

   Enter critical station (or Point):

   At this prompt you can include additional sections at specific stations that may
   not be covered by the intervals specified in the Section Sampling Settings dialog
   box.
8 Do one of the following:
   - Type an additional station to sample. If you must sample more than one
     additional station, press ENTER and type the additional station.
   - Type "Point", and then on the plan view of the alignment, use your pointing
     device to select the additional station locations you want to sample.

If the existing ground cross section information already exists, then the
following prompt is displayed:

   Overwrite existing section data (Yes/No) <Yes>:

9 Type Yes or No:
   - Type Yes to delete the existing ground cross section information, then
     resample it based on the current settings.
   - Type No to keep the existing ground information and merge the new
     information into the cross sections that were created previously (from a
     different surface). However, existing ground section data will be overwritten
     if you are sampling the same surface that was sampled previously.

   **NOTE**  If a cross section does not cross the surface, then the command displays the
   following message:

   **WARNING:** Some sections failed to cross the alignment and
   will be missing from output.

   When a section is completely outside the surface area, the existing ground
   information cannot be calculated so that the section is not created.

### Changing the Cross Section Sampling Settings

To control how the existing ground is sampled for cross section data when you
use the Sample From Surface command, establish the Section Sampling Settings.
These settings control how much of the existing ground is sampled (the swath
width), whether you are prompted to enter additional stations to sample,
whether sample lines are imported onto the plan view of the alignment, and
more.
To change the cross section sampling settings

1. From the Projects menu, click Drawing Settings to display the Edit Settings dialog box.

2. From the Program list, select Civil Design.

3. In the Settings list, click Cross Section Sampling, and then click Edit Settings to display the Section Sampling Settings dialog box and configure the settings.

   **NOTE** This dialog box is displayed automatically when you are using the Sample From Surface command.

4. Under Swath Width, type values in the Left and Right boxes to control how far to the left or right the existing ground is sampled.

   If you are using a template, then you must set the swath width on both sides to a value that is greater than half the width of the template. If you do not set the swath width correctly, then you get an error when sampling for the template. The error states: "Template larger than cross section" and appears within the Control Processing Errors after having run either the Process Sections or Edit Design Control command.

   The Sample from Surface command calculates the existing ground cross section information by reading the Terrain Surface definition at the station. For each cross section, the offset/elevation points are calculated at the centerline of the cross section, at each point where the cross section intersects a surface triangle edge and at the outer edges of the swath width.

5. Under Sample Increments, type the increments for sampling the tangents, curves, and spirals in the appropriate boxes.

   The sample increments are used to determine how often to sample cross-sections along different object types. For example, if you set the Spiral sample increment to 10, then cross section data is created every 10 units along a spiral.
6 Use the following check boxes to specify additional sampling parameters:

- **PC's/PT's**: Controls whether a section is cut at the beginning and end of all circular curves.
- **TS-SC's/CS-ST's**: Controls whether a section is cut at the beginning and end of all spiral curves.
- **Alignment start**: Controls whether a section is cut at the beginning station of an alignment.
- **Alignment end**: Controls whether a section is cut at the end station of an alignment.
- **Save sample list**: Controls whether a file with an .smp extension is created for the current alignment when you use the Sample From Surface command. This file is placed in the align\<align name> subfolder of the project folder. The file contains the station values of all cross sections that were sampled by the Sample From Surface command. Use this file to sample an alignment again without re-entering all section stations when using the Add specific stations option.
- **Read sample list**: Controls whether station values are read from the \{Alignment Name\} .smp file in the align <align name> subfolder of the project folder. If you select this option, then it overrides any other selections in the Section Sampling Settings dialog box except Add Specific Station selection. If you select this option and the \{Alignment Name\} .smp file does not exist, then the command displays a message stating that the file cannot be opened for reading. The command then continues sampling.
- **Add specific stations**: Controls manual entry of additional station values for section cutting. If you select this option, then the command prompts for the critical point or station after the sample range has been specified. At the default prompt, you can enter the station values or you can type Point to switch to the point option, and then select critical points on the plan view of the alignment. The station for each selected point is calculated. Object snaps are recommended when selecting points you do not have to enter the critical stations in sequential order. They are automatically sorted.

7 Under Sample Lines, you can select the Import check box to import sample lines.

Importing cross section sample lines is useful to check where the section sampling may run off the surface.

8 In the Layer box, type the layer name for the sample lines.

9 Click OK.
Creating the Existing Ground Cross Section Data from a Text File

You can sample the existing ground cross section data from an ASCII text file that contains station, offset, and elevation information.

To sample existing ground cross section data from a text file

1. Create an ASCII text file with station, offset, and elevation information for each section.
2. From the Cross Sections menu, choose Existing Ground ➤ Sample From File to display the File to Import dialog box.

3. Locate the file you want to import, and then click OK.

   If the existing ground cross section information already exists, then the following prompt is displayed:

   Overwrite existing section data (Yes/No) <Yes>:

4. Type Yes or No:
   - Type Yes to delete the existing ground cross section information then resample it based on the selected file.
   - Type No to keep the existing ground information and merge the new information into the cross sections that were created previously.

   **NOTE** If the finished ground information has already been defined then it will be maintained when re-sampling existing ground sections, even if you are overwriting the existing ground sections.

5. If needed, repeat the command to sample cross section data from additional files.
Creating the Existing Ground Cross Section Data from a Text File - ASCII File Format

The files used with the Sample From File command must be set up using the following format:

```
station
S surface name
offset elevation
offset elevation
E
```

The lines beginning with S indicate the start of a new surface. The lines containing an E indicate the end of a station/section.

The following example illustrates a sample file used by the Sample From File command. This example creates cross sections with two existing ground surface definitions, SF1 and SF2. The information in the left column is what you need to include in your text file.

**NOTE** The information in the right column is for explanatory purposes only. Do not include these descriptions in your text file.

```
0.000000 station number
S SF1 surface name
-40.0000 320.0000 offset and elevation
  3.5975 320.0000       "        "
  27.2905 314.6810       "        "
  40.0046 311.2940       "        "
S SF2 surface name
-33.1977 315.0000 offset and elevation
  -31.9301 315.0000      "         "
  -27.8061 315.0000      "         "
  3.5975 315.0000      "         "
  40.0046 306.2940      "         "
E end of station
50.000000 station number
S SF1 surface name
  33.4758 319.8359 offset and elevation
  39.9956 318.4365      "         "
S SF2 surface name
-40.0000 326.2699 offset and elevations
  -2.2744 320.9167      "         "
  39.9956 313.4365      "         "
E end of station
```

The format of this file is very important:

- Station values must be in ascending order.
- Station values must be entered as decimal values. Do not enter stations in the format 10+00.00.
- Blank lines cannot exist at the beginning or end of the file. If there are blank lines, then the Sample From File command reads them as the end of the file.
- Blank spaces cannot exist at the beginning or end of a line.
- Blank leading headers cannot exist in the file.
- The first item of the file must be the first station number.
- The last item of the file must be an E, indicating the end of section.
The surface names and totals must be consistent throughout the file. If two surfaces named SF1 and SF2 exist on the first section, there must be two surfaces named SF1 and SF2 on every section.

The Sample From File command’s overwriting behavior is the same as the Sample From Surface command. At the prompt to overwrite the existing cross section, accept the default option No. This adds the new existing ground cross sections to the file, without overwriting the data that had previously been sampled.

**Editing the Existing Ground Cross Section Data**

After you have sampled the existing ground sections from either a surface or a text file, you can use the Edit Sections command to edit the information. You can also use this command to create new cross sections.

**To edit the existing ground cross section data**

1. From the Cross Sections menu, choose Existing Ground ➤ Edit Sections to display the Existing Ground Section Editor dialog box. This dialog box displays the cross section data for the first station.

   ![Existing Ground Section Editor](image)

   **NOTE** If you have not yet selected a current alignment, then you are prompted to select the current alignment.

   Use this dialog box for editing the offset, elevation, and grade information for individual stations of the surface.

   2. Select the surface to edit (if the section has multiple surfaces) by clicking Select Surface. The Surface Selection dialog box is displayed.
When there is only one existing ground surface, the Select Surface dialog box does not display because the program selects the existing ground automatically.

3 Select the correct surface, and then click OK to return to the Existing Ground Section Editor.

4 Select the station you want to edit by clicking the Prev, Next, or Station buttons.

The Station button displays a dialog box where you can type the station to move to.

5 After you have selected the station you want to edit, you can use the following navigation buttons to move between rows of section information for the selected station:

- \[ \text{A} \text{ and } \text{V} \]: Use these buttons to move up or down one row at a time.
- \[ \text{H} \text{ and } \text{E} \]: Use these buttons to display the very first row (Home) or the very last row (End) of the Offset, Elevation, Grade % values at a time.
- \[ \text{U} \text{ and } \text{D} \]: Use these buttons to move up or down one screen of Offset, Elevation, Grade % values at a time.

TIP Press TAB or ENTER to move through the fields.

6 From the Existing Ground Section Editor, you can do any of the following:

- Add an offset by clicking Insert Offset. This option clears a row above the row your cursor is located in.
- Delete an offset by placing your cursor in the row to delete and clicking Delete Offset.
- Add a station by clicking Insert Station. You are prompted for the station and a new surface name. You are prompted for a surface name because multiple surfaces may exist in the cross section file. Accept the default (the current surface name). With multiple surfaces, enter the data for one surface, click Section View button to accept first surface data. You can then click the Insert Surface button to add additional subsurface definitions.
- Delete a station by clicking Delete Station. You are prompted to confirm the deletion.

NOTE Create cross section data for a new subsurface by clicking Insert Surface. The New Surface Entry dialog box is displayed. Type the name of the surface you want to create cross section data for, and then click OK.

Click Insert Station to begin creating station offset/elevation data. Each time you enter a new station value you are prompted to enter new surface name. Click OK to accept the default, or enter a new surface name. If you want to add additional subsurface data at an already sampled section, select either Prev, Next, or Station, and then click Insert Surface to begin creating station offset/elevation values.

You can use the Insert Surface option to create cross section data for subsurfaces. However, if you have borehole data, then you could use the Interp Control option instead. With the Interp Control option you enter the borehole data. Then you use the Interp Surfaces button to create the subsurfaces for each station based on the borehole data you entered.
Delete cross section data for a surface at this station by clicking Delete Surface. You are prompted to confirm the deletion.

Create interpolation data for a surface by clicking Interp Control to display the Interpolation Control Editor Status dialog box.

Select the surface to which the design template slopes should be matched by clicking Match Surface. If only one surface is defined for the cross sections, then that surface is automatically the match surface. This surface does not have to be the top surface. All templates will be matched to the selected surface in both cut and fill situations.

**TIP**

To view the cross section at the selected station at any time, click Section View to display the Section Viewer. The Section Viewer displays a graphical representation of the cross section so you can determine the edits you need to make at each station.

### Using Borehole Data to Interpolate the Surfaces for Cross Sections

You can use the Existing Ground Section Editor to create borehole data for subsurfaces. This data is useful for creating surface slopes and for calculating subsurface volume data. You can use this method as an alternative to creating multiple subsurfaces for cross sections with the Insert Surface option in the Existing Ground Section Editor. You can view and plot these subsurfaces, apply surface slopes, and calculate the volume of cut and fill for the different subsurfaces.

**To use borehole data to interpolate the surfaces for the cross sections**

1. From the Cross Sections menu, choose Existing Ground ➤ Edit Sections to display the Existing Ground Section Editor.
2. Click Interp Control.
   The Interpolation Control Editor Status dialog box is displayed if no interpolation control has been defined.
3. Click Yes to continue.
   The New Interpolation Values dialog box is displayed.
4 In the Station box, type the first station number.
5 In the Surface name box, type the surface name.
6 In the Thickness box, type the thickness of the material from the first surface (i.e., topsoil) to the second surface (i.e., clay).
7 For the first surface, the Depth value is zero (0).

   The first surface has a thickness value, but not a depth value, because for all surfaces, depth is measured from the top surface down. The thickness value for a surface is the value measured from that surface down to the next surface. For example, the second surface can have depth and thickness values. For the second surface, the depth is measured from the top surface down to the second surface. The thickness for the second surface is measured from the second surface down to the third surface. For the third surface, the depth is measured from the first surface down to the third surface, and the thickness is the measurement between the third and fourth surfaces. The last surface you enter has a thickness of zero (0) to indicate that there are no surfaces below it.

   NOTE
   For the first surface, the Depth box is grayed out. When you begin to enter interpolation values, you can choose to enter the values as depths or as thicknesses. By default you must enter a thickness for the first surface because the first surface does not have a depth value.

8 Click OK to continue.

   The Interpolation Surface Control Editor dialog box is displayed.

9 Choose the subsurface data entry type.

   There are two options at the top of the dialog box for subsurface data entry type: Thickness and Depth. When you select Thickness option, any thickness entry results in the automatic entry of the associated depth data for the particular surface. When you select the Depth option, the opposite is true—any depth entry results in the automatic entry of associated thickness data.

10 Create the interpolation control data. You can use either or both of the following options:
   ■ Click Ins Sta to create interpolation control for a new station. Use this method to create a new station and enter surface depth/thickness data for multiple surfaces. For more information, see “INS Sta Option” in this chapter.
   ■ Place your cursor in the row of an existing station and click Ins Srf. Use this method to enter surface data for an existing station. For more information, see “INS SRF Option” in this chapter.

   NOTE
   Interpolation control MUST span a range of stations. You cannot assign interpolation control to station 0+00 and expect to see those surfaces on the section for station 0+00. For example, you must span stations by assigning the interpolation to station 0+00 and, using the same surfaces, to station 0+50 to be able to see the different surfaces for station 0+00 and 0+50.

11 To edit the values for a station, place your cursor in the row you want to change and click Edit.
12 To delete a row of surface data for a station, place your cursor in the row you want to delete and click Del Surf.
13 To delete all the values for a selected station, place your cursor in one of the rows of data for that station and click Del Sta.

14 At any time you can click Save to save the interpolation control values without exiting the Interpolation Surface Control Editor.

15 When you have finished entering interpolation values in the Interpolation Surface Control Editor, click OK to return to the Existing Ground Section Editor.

16 Click Interp Surfaces to create the subsurfaces for each station based on the data you entered.

NOTE You must click Interp Surfaces in order to create the subsurfaces you entered in the Interpolation Surface Control Editor.

A dialog box is displayed with a warning about overwriting existing sub-surface data.

17 Click Yes or No:

- Click Yes to overwrite existing data. The depths of the material at stations between the control stations are interpolated.
- Click No to abort the command if you clicked Interp Surfaces accidentally. If you click No, then the command does not perform the interpolation.

The information generated in the Interpolation Surface Control Editor dialog box is saved to an ASCII file. This file is named after the current alignment with the extension .icn. This file is saved in the \align subfolder of the project folder. You can edit the information saved in this file using any text editor, and then use it with any other Cross Sections command. You can also add comments to the data. Use a semi-colon (;) or pound sign (#) to indicate the beginning of comment lines.

The following illustration shows a finished ground cross section with a template, ditches, slopes, and superelevation in relation to topsoil, clay, and rock:

![Cross section with subsurfaces](image-url)
The following illustration shows interpolation control values defined for stations along an alignment:

INS Sta option

To use the Ins Sta option
1 Follow steps 1–10 in “Using Borehole Data to Interpolate the Surfaces for the Cross Sections” in this chapter.

When you click the Ins Sta button, the New Interpolation Values dialog box is displayed.
2 In the Station box, type the station that you want to create data for.
3 In the Surface name box, type the name of the surface you want to enter depth/thickness values for, such as Clay or Rock.
4 Do one of the following:
   - In the Thickness box, type a thickness value.
   - In the Depth box, type a depth value.
5 Click OK.

The New Interpolation Control Values dialog box is redisplayed and updated.
6 In the Surface name box, type the name of the next surface you want to enter depth/thickness values for.
7 Do one of the following:
   - In the Thickness box, type a thickness value.
   - In the Depth box, type a depth value.
8 Click OK to insert this data into the Interpolation Surface Control Editor.
9 To enter other subsurface data for that station, repeat steps 15 through 17 of “Using Borehole Data to Interpolate the Surfaces for Cross Sections,” or click Cancel to return to the Interpolation Surface Control Editor.
INS SRF OPTION

To use the Ins Srf option

1 Follow steps 1–10 in “Using Borehole Data to Interpolate the Surfaces for the Cross Sections” in this chapter.

When you place your cursor in a row of station values in the Interpolation Surface Control Editor and click the Ins Srf button, the New Interpolation Values dialog box is displayed. You can use this dialog box to enter depth/thickness values for a specified surface.

**NOTE** The Station box is grayed out. The station value is the station your cursor was located in when you selected the Ins Srf button.

2 In the Surface name box, type the name of the next surface you want to enter depth/thickness values for.

3 Do one of the following:
   - In the Thickness box, type a thickness value.
   - In the Depth box, type a depth value.

4 Click OK to return to the Interpolation Surface Control Editor.

Drawing Templates

You can create template surfaces using the Draw Template command or the AutoCAD PLINE command. The Draw Template command takes the vertical exaggeration of the drawing into account automatically. If you use the AutoCAD PLINE command to draw the template, then you must draw the polylines with the drawing’s vertical exaggeration in mind.

You can use the Draw Template command to draw both templates and subassemblies. This command uses a 2D polyline to draw lines based on offset, depth, grade, and slope parameters. It does not matter whether you draw the template or the subassembly first. However, because the subassembly is attached to the template with the Define Template command, you must define the subassembly first.
Drawing Normal and Subgrade - Symmetrical and Asymmetrical Template Surfaces

When drawing the template surfaces, you must consider whether the surfaces are normal or subgrade. In addition, you must consider whether the template is symmetrical or asymmetrical.

The following illustration shows symmetrical and asymmetrical templates:

Symmetrical and asymmetrical templates

A typical template may be made up of normal surfaces, subgrade surfaces, or a combination of both. You can draw these surfaces symmetrically or asymmetrically, which affects how you define the templates later on. Normal surfaces are the elements of the template that make up the main part of the template such as pavement surfaces, median islands, shoulders and curbs. A typical subgrade surface is made up of granular substances, such as gravel.

The following list contains tips to keep in mind when drawing normal and subgrade templates:

- Both types of surfaces must be drawn with either the Draw Template command or the PLINE command.
- There is no limit to the number of normal surfaces on a template.
- You can only draw one subgrade surface, but it may be composed of multiple layers of material. Each of the subsequent subgrades are defined by their depth below the upper subgrade and their grade to the intersecting slope.
- When normal and subgrade surfaces are both used for a template, the subgrade surface must be drawn below the normal surfaces.
- When drawing the template, you only draw the top part of the subgrade surface. When using symmetrical templates, draw this subgrade surface along the bottom of the normal surfaces starting from the center of the template out to the connection point out. When using asymmetrical templates, draw from connection point to connection point.

Subgrade surfaces are linked to the normal surfaces, but use separate design parameters, which you enter when you define the template. Entering these parameters as numeric values creates dynamic regions that will be automatically adjusted by the program in transitioning and superelevation conditions. You can also control the subgrade depth by using a profile definition.
Drawing a Template Surface - General Procedure

NOTE  The following steps describe how to use the Draw Template command to draw a basic template surface.

To draw a template surface
1  Create and set a new layer for the template items before starting.
2  From the Cross Sections menu, choose Draw Template.
   The following prompt is displayed:
   Starting point:
3  Select the starting point by picking a point in the drawing or entering coordinates at the command prompt.
   After you select the starting point, the following prompt is displayed:
   Select point (Relative/Grade/Slope/Close/Undo/eXit):
4  Do one of the following options to select the second point:
   - Use object snaps or absolute X,Y coordinates to accurately select the point.
   - Type R to select the Relative option. This option changes the command prompt to the following prompt:
     Change in offset: (Grade/Slope/Close/Points/Undo/eXit):
     The Relative option draws a line segment based on an entered change in offset and elevation. For an offset to the left, use a negative value. For an offset to the right, use a positive value. After you enter the offset value, the command prompts for an elevation. For the change in elevation, use a positive value to go up and a negative value to go down.
   - Type G to select the Grade option. This option changes the command prompt to the following prompt:
     Grade (%): (Relative/Slope/Points/Close/Undo/eXit):
     The Grade option draws a line segment based on an entered grade and change in offset. For the grade, use a positive value to go up and a negative value to go down. Do not use the percent sign (%) when entering grades. For example, enter a -2% grade as -2. After entering the grade, the command prompts for the change in offset. For an offset to the right, use a positive value. For an offset to the left, use a negative value.
   - Type S to select the Slope option. This option changes the command prompt to the following prompt:
     Slope (3 for 3:1) (Relative/Grade/Points/Close/Undo/eXit):
     The Slope option draws a line segment based on an entered slope and change in offset. For the slope, use a positive value to go up and a negative value to go down. Do not use a colon (:) when entering slopes. For example, enter a 3:1 slope as 3. After entering the slope, the command prompts for the change in offset. For an offset to the right, use a positive value. For an offset to the left, use a negative value.
- Type C to select the Close option. This option closes the template surface. The Close option draws the final segment from the current point back to the starting point. It is not necessary for all components to be closed (i.e., if they will be mirrored about the centerline).
- Type U to erase the last segment drawn. You can repeat the Undo option until the Draw Template command returns to the starting point.
- Type X to exit the command.

5  Continue picking points until you have finished drawing the template.

Create the surfaces on the left side of the finish ground reference point for symmetrical templates. The Define Template command mirrors the surface about the finished grade reference point. Draw the complete surface as one continuous polyline for asymmetrical templates.

6  Define the template after you have finished drawing it.

**NOTE**  When defining a template or subassembly, the outline of each component must consist of a single 2D polyline for the left side of the template. A subassembly can consist of only one component. A template can consist of more than one surface, each one drawn as a separate polyline.

### Drawing Normal Surfaces for Symmetrical Templates

Follow the general procedures for drawing a template surface, keeping in mind the following points:

- If a template is symmetrical, both the left and right halves of the template are assumed to be identical, and are mirrored when you define the template. Because of this, it is necessary to draw only the surfaces for the left half of the template. When you define the template, the surfaces on the left half are mirrored about the vertical plane that passes through the finished ground reference point.

- A normal surface that has the opening at the mirror plane (the finish ground reference point) is mirrored so it becomes a closed surface. An example of this type of surface is the asphalt surface of a two-lane road.

- When drawing a normal symmetrical surface, start at the centerline (the vertical plane of the finished ground reference point) and draw the surface to the left, in a counter-clockwise direction, until the surface returns to the centerline.

- Any normal surface that does not intersect the mirror plane must be drawn as a closed surface. When you define the symmetrical template, all closed surfaces are mirrored about the vertical plane that passes through the finish ground reference point. An example of this type of surface is a curb surface.

- When drawing a closed surface that does not cross the centerline, start at a point that is nearest the centerline and draw the surface in a clockwise direction.
Drawing Subgrade Surfaces for Symmetrical Templates

Follow the general procedures for drawing a template surface, keeping in mind the following points:

- With subgrade surfaces you draw only the top of the surface definition, between the connection points. The rest of the subgrade surface information is defined with the Define Template command.
- When drawing a subgrade surface for a symmetrical template, you start the surface at the centerline (the vertical plane of the finished ground reference point) and draw it to the left, tracing below the normal surfaces, if they exist, and end the surface at the connection point.
- A template can only have one drawn subgrade surface and it must be below all normal surfaces.
- To define multiple subgrade surfaces draw the one subgrade surface then define the other subgrade surfaces as depths and grades when you use the Define Template command.
- The side slope for the subgrade surface is determined by the slope settings in Design Control when the template is applied to the cross sections.

Drawing Normal Surfaces for Asymmetrical Templates

Follow the general procedures for drawing a template surface, keeping in mind that when drawing normal surfaces for an asymmetrical template, you must draw the entire surface. Start with the top of the surface at the centerline (the vertical plane of the finished ground reference point) and draw to the left, in a counter-clockwise direction until you return to the starting point. All normal surfaces for the asymmetrical template must be drawn so that they close back to their starting point.

Drawing Subgrade Surfaces for Asymmetrical Templates

Follow the general procedures for drawing a template surface, keeping in mind that with subgrade surfaces you only draw the top of the surface definition, between the connection points. The rest of the subgrade surface information is defined with the Define Template command. When drawing a subgrade surface for an asymmetrical template, you start the surface at one of the connection points and draw it, tracing below the normal surfaces, if any, to the other connection point. You can start at either the left or the right connection point.

How Subgrade Surfaces Are Controlled

Subgrade surfaces are controlled by a set of rules that depend on the design situation. In normal situations, the subgrade surfaces extend to the intersecting ditch slope or match slope. If the subgrade does not intersect with either the ditch slope or the design slope, it extends to the lowest point along the ditch slope or design slope, and then ties into the ditch slope or design slope with a vertical line.
The following illustration shows subgrade surfaces in cut and fill situations:

![Subgrade surfaces in cut and fill situations]

**Creating and Editing Templates and Subassemblies**

To create finished ground cross sections, you design a template for the alignment and apply it to the alignment. For curb or shoulder design, you can attach subassemblies to a template.

A template is a typical section representing the finished ground design elements such as asphalt, concrete, and granular materials. After you draw and define the template, you can apply the template to the existing ground cross sections.

All templates have a defined finished ground reference point which is used to position the template on the cross section using the horizontal alignment and the finished ground vertical alignment (the finished ground centerline profile) for control. This reference point is usually the crown of the roadway.

Subassemblies are elements such as a shoulder or curb that you can attach to the template. Subassemblies differ from normal template surfaces in that they will vary depending on whether the template is in a cut or fill situation. After you have created a template, you must edit it to define datum, superelevation, and transition points on it. You can also edit the template to change subgrade depths, to change the shape of the template, and so on.

All templates and subassemblies are stored in the path specified by the Set Template Path command. After you define templates and subassemblies, you can use them for any project you are working on.
Setting the Path for Templates and Subassemblies

Before creating templates or subassemblies, you need to set the location where they are stored by setting the template path. The template path is a project-based setting so that all drawings that are associated with a project use the same path.

To set the path for templates and subassemblies

1. From the Cross Sections menu, choose Set Template Path to display the Template Path dialog box.

2. Select the User Preference Cross Section Template root path check box if you want to set a master folder where all cross section templates will be stored for all projects.

The ADTPL path key defined in the SDSK.DFM file is used to set a master folder where all cross section templates are stored for all projects and is referred to as the Root path. This is common in network environments where all project data is stored on a central file server.

The ADTPL key value can be set by editing the Path Settings using the Projects ➤ User Preferences command. Since the ADTPL key is stored in the SDSK.DFM file, it can be recalled each time a new project is created, making it very easy to specify the template path for each new project. Because of the nature of network environments, it is possible that many people do not use the same drive map for the network volume where the shared template data is stored. In these situations it is possible for each person to set the ADTPL key to the drive that they use to reference the shared project data, since each person has their own SDSK.DFM file.

For example, two people could create two different drive maps to the volume \Engrg. The first person could map drive h:\ to \Engrg and the second person could map drive k:\ to \Engrg. By storing the root path in the sdk.dfm file, each person could define a unique root path pointing to the same template folder. The first person could set the ADTPL key to h:\projects\tplates and the second person could set it to k:\projects\tplates.

Although the ADTPL key can be used in network environments to set a common template root path for shared projects, it is not limited to network environments. The ADTPL key can also be used in single user environments to set a common template root path for all projects on that computer.

3. Enter the name of the folder in which the templates and subassemblies are stored.
You can click Browse to display the Template Path dialog box. Use this dialog path to pick the folder in which the templates and subassemblies are stored. Use the Path edit box to set a folder where cross section templates for the current project are stored. This path can be used alone or in combination with the root path to define the actual template path for the current project. The User Preference Cross Section Templates root path check box determines whether or not you are using a root path:

- When User Preference Cross Section Templates root path check box is selected, the ADTPL key defined in the SDSK.DFM file becomes the root path. Any folder you enter in the Path edit box is appended to the root path. The combination of these two paths become the template path.
- When User Preference Cross Section Templates root path check box is cleared, or if the ADTPL key is not defined in the SDSK.DFM file, the template path will be only the folder you enter in the Path edit box.

Using the Root path in conjunction with the Path is very useful for creating libraries of templates based upon project types, template types or project names. You can set the root path to a common folder on a network file server then set the Path to a specific folder for templates of a similar type or project.

For example, you could set the ADTPL key to h:\projects\plates. Within this folder you could have subdirectories for each type of project you are working on. These subdirectories might include individual directories for various clients, municipalities or DOT’s or even template types such as residential, municipal or highway. Since the ADTPL key already defines the root path as h:\projects\plates, you would only have to enter the subfolder name in the Path edit box to access the templates stored in a specific template folder.

You could also set both the project root path (PROJECT ROOT) and the template root path (ADTPL) to the same folder. This would force all new template directories to be created in the PROJECT ROOT folder. If you create a project called 95893, then a folder by the name of 95893 would be created under the PROJECT ROOT. Since the ADTPL key is set to the PROJECT ROOT folder as well, you would have to enter a folder name of 95893\plates in the Path edit box to force all templates for the project 95893 to be stored in the folder PROJECT ROOT\95893\plates.

NOTE: If the folder name you enter does not already exist, the command creates the folder if you have entered a valid path. The Set Template Path command copies the nullt.tpl and the nulls.sub default templates into the folder as well. These template files must exist in the template folder.

Click OK when you have finished setting the path.
Using the Template Path Edit Box

Use the Template Path dialog box to choose a folder in which to save templates and subassemblies.

**WARNING!** Do not use this option to select a path if you selected the User Preference Cross Section Templates root path check box in the Template Path dialog box. If you selected the User Preference Cross Section Templates root path check box, then you can type the folder name (to be located or created in that Root Path) directly into the Path field of the Template Path dialog box.

**To choose a folder in which to save templates and subassemblies**

1. Click Browse from the Template Path dialog box.

2. Choose a drive from the Drive list.

3. Choose a folder from the list to the right of the dialog box:
   - Double-click the \ symbol to go up to the root folder of the drive.
   - Double-click the .. to go up one folder level from the current folder.

4. Click OK after you have selected the drive.

Using Point Codes and Material Tables

The Material Table is a table of surface material names for use in conjunction with the Define Template, Edit Template, Define Subassembly, or Edit Subassembly commands. Material names are used when creating template surface volume reports.

You can predefine this table using the Edit Material Table command. If you are using a command that requires a Material Table, then the command automatically prompts you to select a material name. If a table does not exist, then you are given the option of creating a Material Table.

You can create a library of tables based on any specifications. For example, you can create Material Tables for different asphalt types, gravel types or structure types such as curbs. Within each table, you can create entries for different materials available for that material type. Each material table is stored in the
template folder specified by the Set Template Path command and has the file extension .mat.

**Defining and Editing a Material Table**

**To edit or create a material table**

1. From the Cross Sections menu, choose Templates ➔ Edit Material Table.

   **NOTE** If you have already created a Material Table, skip to step 5.

   If a Material Table does not exist in your template path folder, the Material Table Selection Status dialog box is displayed.

2. Click Yes to continue.

   The New Surface Material Table dialog box is displayed.

3. Type the name of the new table and click OK to continue.

   The New Material Surface dialog box is displayed.

4. Type the name of the new material, and then click OK.

   If you enter the name of an existing material, an error message is displayed. Enter a different name then click OK again.

   The Material Table Editor is displayed.

5. Use the Table area at the top part of this dialog box to select tables, create new tables, or delete existing tables:
   - To select a different material table, use the Table Name list box. If you have made any edits to the current material table, you are prompted to save your changes. Click the Yes button at the Save material table changes? prompt to save any changes or Click the No button to discard any changes.
   - To create a new material table, click the New button. The New Surface Material Table dialog box is displayed. Enter the name of the new material...
table, and then click OK. If you enter the name of an existing table, an error message is displayed. Enter a different name, and then click OK.

- To delete a material table, click the Delete button. The Deletion Status dialog box is displayed. Click the Yes button to delete the table.

**NOTE** Deleting the Material Table permanently removes the *.mat file.

6. Use the Materials area of the dialog box to control the contents of the selected table. Use this section to add new surface materials to a table, delete materials, or change the name of existing materials:

- To create a new surface material, click the New button. The New Material Surface dialog box is displayed. Enter the name of the new material, and then click OK.
- To delete a surface material, click the Delete button. This removes the material name from the Selection list.
- To change the name of a surface material, click the Edit button. This displays the Edit Material Surface dialog box. Enter the new name of the material, and then click OK.
- To save your changes, click the Save button. This saves the edits without exiting the dialog box.

7. Click OK to exit the dialog box and save your edits, or Cancel to exit the dialog box without saving the changes.

**Template Point Codes**

A point code identifies a specific location on a cross section template with a point code number and description. You can apply the point codes to the template with the Edit Template command and view them with the View/Edit Sections command. You can use the point codes with the Tplate Points to DWG command to import a specific selection of template points into the plan view of your drawing or with the Tplate Points to File command to create a text file of the points. You can use the Sheet Manager utilities to set up a sheet style that labels specific points on the plotted cross sections based on these points with offset or elevation.

The point codes you customize begin with the number 25. Point code numbers 1 through 24 are reserved for the codes that are provided with the program, or that will be included with the program in future releases. These reserved codes are automatically added to every new point code table that you create, and are tracked by the program. Unlike the point codes you customize, you are not able to assign these reserved codes to any points within the template, nor are you able to delete them. You can, however, modify their descriptions. These pre-defined point codes are, for the most part, points on cross sections that cannot be selected when editing the template definition, such as slope or ditch points.

Use the Points option of the Edit Template command to assign the point codes their locations. A point code can be applied to more than one position on the template. A point code with the description EOP, for example, can be applied to the edge of pavement on both the left and right sides of the template. These point locations are transitioned and superelevated along with the cross section template.
NOTE When adding point codes to a template, only the point code number is stored with the template definition. The point code description is retrieved from the current point code table.

When you use a command that requires a point code table, the command automatically prompts you to select a table. If a table doesn’t exist, then you have the option of creating one. The point code tables are saved with a *.pcd extension and reside in the template folder set with the Set Template Path command.

Defining a Template Point Code Table

To edit or create a point code table

1 From the Cross Sections menu, choose Templates ➤ Edit Point Code Table.

NOTE If you have already defined a point code table, then skip to step 4.

If you haven’t defined any point code tables, then the Point Code Table Selection Status dialog box is displayed asking if you would like to create a point code table.

2 Select Yes to continue.

The New Point Code Table dialog box is displayed.

3 Type the name of the new table, and then click OK to continue.

The Point Code Table Editor dialog box is displayed.

The name of the new table is displayed in the Table Name dialog box at the top of this dialog box.

4 Select the point code table you want to use from the dropdown list at the top part of dialog box.
NOTE If you just created a new table in step 3, you can skip this step.

You can also use this section to create new point code tables or delete existing ones:

- To select a different point code table, use the Table Name list box. If any edits have been made to the current table, you will be prompted to save your changes. Click the Yes button at the Save point code table changes? prompt to save any changes, or click the No button to discard any changes.
- To create a new point code table, click the New button. The New Point Code Table dialog box is displayed. Enter the name of the new point code table, and then click OK.
- To delete a point code table, click the Delete button. The Deletion Status dialog is displayed. Click the Yes button to delete the table.

NOTE Deleting the Point Code Table permanently removes the *.pcd file.

5 Use the Point Codes area to edit the selected point code table as follows:

- To create a new point code, click the New button. The New Point Code dialog box is displayed.
- Enter the description and number of the new code, and then click OK. The first point code number defaults to 25. Point code numbers 1–24 are reserved for the codes that are provided with the program. These codes are preceded by an asterisk (*) in the point code table list to distinguish them from your custom point codes. For more information, see “Template Point Codes” in this chapter.
- To delete a point code, click Delete. This removes the point code from the Selection list.
- To change the name of a point code, click Edit. This displays the Edit Point Code dialog box. Enter the new name of the code, and then click OK.
- To save your changes, click Save button. This saves the edits without exiting the dialog box.

6 Click OK to exit the command, or Cancel to cancel the edits you have made.

Pre-assigned Template Point Codes

The following table describes the point codes that are automatically assigned to the Autodesk Civil Design program and are in every point code table. These are for the most part points that can’t be selected when editing a template, such as ditch and slope points. You can edit the description of these points, but you can’t change the definition of the point. You can, for example, change point code #1 from “Centerline” to “CL.”

The following table lists the predefined point codes. On features that have two points, such as a bench ledge, the inner point is the point that is nearest the centerline.
### Predefined Point Codes

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*1</td>
<td>Centerline The finished ground reference point</td>
</tr>
<tr>
<td>*2</td>
<td>Connection The template slope connection points</td>
</tr>
<tr>
<td>*3</td>
<td>Ditch The point on a V shaped ditch, or the inner ditch point with a width</td>
</tr>
<tr>
<td>*4</td>
<td>Ditch width The outer point of a ditch with an applied width</td>
</tr>
<tr>
<td>*5</td>
<td>Bench The inner point of a slope bench</td>
</tr>
<tr>
<td>*6</td>
<td>Bench width The outer point of a slope bench</td>
</tr>
<tr>
<td>*7</td>
<td>Stepped The break point of a stepped slope, the inner point of a stepped bench</td>
</tr>
<tr>
<td>*8</td>
<td>Stepped width The outer point of a stepped slope bench</td>
</tr>
<tr>
<td>*9</td>
<td>Surface The break point of a surface slope, the inner point of a surface bench</td>
</tr>
<tr>
<td>*10</td>
<td>Surface on The intermediate points of a surface bench</td>
</tr>
<tr>
<td>*11</td>
<td>Surface width The outer point of a surface bench</td>
</tr>
<tr>
<td>*12</td>
<td>Subsurface apex The crown of the subgrade surface at its depth point</td>
</tr>
<tr>
<td>*13</td>
<td>Subsurface Median The template subgrade inner superelevation break points</td>
</tr>
<tr>
<td>*14</td>
<td>Subsurface Break The template subgrade outer superelevation break points</td>
</tr>
<tr>
<td>*15</td>
<td>Subsurface inter The template subgrade/side slope intersection points</td>
</tr>
<tr>
<td>*16</td>
<td>Catch The point where the slope matches into existing ground</td>
</tr>
</tbody>
</table>

---

**Working with Subassemblies**

Subassemblies represent design elements such as shoulders or curbs, and are optional. Subassemblies are attached to a template at the connection-point-out of the template. Subassemblies differ from normal template surfaces in that they vary depending on whether the template is in a cut or fill situation.

**NOTE**

You cannot attach subassemblies to a template that uses subgrade surfaces.

The basic process of designing subassemblies includes drawing the subassembly, defining the subassembly, and attaching the subassembly to template.
Defining Subassemblies

If you are using a subassembly, then you must define it before you define the template you will be attaching it to.

When you define a subassembly, you specify the connection-point-in, the surface material, the connection-point-out, and the datum points. The connection-point-in of the subassembly is attached to the connection-point-out on the template. You can attach subassemblies to the connection-point-out on either side of the template.

If a subassembly is attached to a cross section template, then the design slope assigned in the Edit Design Control command is attached to the connection-point-out of the subassembly instead of the connection-point-out of the template.

NOTE Ditches and design slopes are not created as part of the template or subassembly. Define ditches and slopes by using the Edit Design Control command.

Subassembly definition varies from template definition in a number of ways:

- Subassemblies can only use one datum definition.
- Transition points cannot be assigned to subassemblies. Therefore, subassemblies cannot be stretched, but they can be moved. Since a subassembly is attached to the cross section template at the template’s connection-point-out, the subassembly’s final location will be affected by transitioning applied to the template.
- Although you can draw the template and subassembly in any order, you must define the subassembly with the Define Subassembly command before defining the template.

NOTE The Draw Template command aids subassembly creation by taking the vertical scale factor of the drawing into account. For example, if the horizontal scale is set to 1’=40’ and the vertical scale to 1’=20’, then the Draw Template command exaggerates the subassembly by a vertical scale factor of two. The Define Subassembly command compensates for the vertical scale factor of 2:1 and stores the subassembly definition with a scale of 1:1. Do not change the scales between the time the subassembly is drawn and the time it is defined or the subassembly will not be defined properly.

After you have used the Draw Template command to draw the subassembly, use the Define Subassembly command to define the subassembly. When you define a subassembly, you define the connection-point-out, the connection-point-in, the datum points, and specify the surface material.

To define a subassembly

1. You can set the template storage path with the Set Template Path command.
2. Draw the curb, cut shoulder, and fill shoulder subassembly regions as 2D polylines with the Draw Template command or with the AutoCAD PLINE command.
NOTE If you use the PLINE command, then be sure the horizontal and vertical drawing scales are set to 1:1.

3 From the Cross Sections menu, choose Templates ➤ Define Subassembly.

4 Pick the connection point in from the drawing.

This is the point on the subassembly that connects with the connection point out on the cross section template. Use object snaps to accurately pick the point. The Surface Material Names dialog box is displayed.

5 Select the appropriate material table or create a new table, then select the material for the subassembly.

6 Click OK to continue.

7 Pick the polyline that represents the subassembly. This must be a 2D polyline.

8 Select the connection point out.

The connection point out is used to connect a subassembly to another subassembly such as a curb or a shoulder. If no additional subassemblies are connected beyond the current subassembly, the connection point out is used as the point to connect any ditch slopes or design slopes from.

9 Select the datum points.

You must select these points from left to right. Use object snaps to select the datum points accurately.

NOTE Set the running object snaps to Endpoint prior to defining the subassembly. This helps when the select datum point from L to R prompt is displayed.

For more information about datum lines for templates and subassemblies, see “Datum Lines and Top Surface Definitions for the Templates and the Subassemblies” in this chapter.
10 Press ENTER after picking all the datum points. The command prompts you to save the subassembly.

11 Type Yes to save the subassembly, and then type the subassembly name.

   The command stores the subassembly definition in the folder set using the Set Template Path command. It is saved with a file extension of .sub. If the subassembly already exists, then you can either overwrite the existing subassembly or rename the subassembly.

12 Type Y or N:
   - Type Y to overwrite the existing subassembly definition.
   - Type N to enter a new subassembly name.

   After the subassembly has been saved, a prompt is displayed asking if you would like to define another subassembly.

13 Type Y or N:
   - Type Y to define another subassembly.
   - Type N to exit the command.

The following illustration shows places to pick the curb and shoulder connection points:

![Subassembly definition](image)

**Datum Lines and Top Surface Definitions for Templates and Subassemblies**

Subassemblies and templates require a definition for a datum line and a top surface. Both the datum line and the top surface are defined similarly, but differ in how they are used.

The datum line defines the boundary along a cross section template from which cut and fill volumes are calculated. When a subassembly is attached to a cross section template, the datum lines from all subassemblies are combined with the datum line of the cross section template to create a continuous datum line across the entire template assembly.

When the template assembly is applied at a cross section, the datum line is automatically extended along any ditch or design slopes out to the daylight point where the design slope meets the existing ground surface. The entire datum line is then compared against the existing ground surface to generate cut and fill areas for each section, which are used to generate a total volume along the alignment. If the datum line is not defined, then a datum line is automatically generated by connecting the two connection points with a straight line.
NOTE: If subgrades are defined for a template, then you will not be prompted to define a datum line.

The top surface defines a boundary along a cross section template from which finished ground data can be extracted. This data is generally used for visualizing the roadway in its finished state by creating a 3D road grid or building a surface. While defining a subassembly or template, you are prompted to define the datum surface, but not the top surface. You can define the top surfaces for templates and subassemblies by using the Edit Template command and the Edit Subassembly command. If you do not define the top surface, then a top surface is automatically generated by connecting the two connection points with a straight line.

**Attaching the Subassemblies to Templates**

You attach subassemblies to templates during the process of defining the template with the Define Template command.

NOTE: You can also attach subassemblies to templates using the Edit Template command.

NOTE: Subassemblies cannot be used on templates that have subgrades they can only be used with templates that have normal surfaces. If subgrades are defined for a template then you will not be prompted to attach subassemblies.

**To attach subassemblies to normal templates**

1. Use the Define Template command to define a normal template. After you have selected all of the datum line points as part of defining the normal template, the Subassembly Attachments dialog box is displayed.

2. Select the subassembly to attach.

To select a subassembly, either enter the name of the desired subassembly in the appropriate box or click the Select button (to the right of the subassembly name) to access the Subassembly Librarian dialog box.

The two types of subassemblies that you can attach to the left and right of cross section templates are curb and shoulder. For shoulder subassemblies you can choose two different shoulder definitions, one to be applied in cut situations and one for fill situations. Working from the centerline out, the first category of subassembly that is attached to the connection point out is referred to as the curb subassembly. The second category of subassembly that is attached is the shoulder subassembly. Use the NULLS subassembly name in the places where a subassembly is not required.

NOTE: Templates must have subassemblies as well as surfaces. If subassemblies are not required, then you must use the NULLS subassembly name in place of having a subassembly.

The connection-point-out of the shoulder connects either to the ditch foreslope if you are using ditches, or to the design slope if you are not using ditches. You can define two different types of shoulder subassemblies for each side of the
template: one for cut situations and the other for fill situations. If you do not use subassemblies, the slope attaches to the connection point out of the template.

3 Click OK.

After you select the subassembly, the Define Template command prompts you to save the template.

4 Type Y or N:
   - Type Yes to save the template.
   - Type No to start the template definition process over again without saving the previous definition.

5 If you typed Y, enter a template name to save the template.

   Specify a name up to a maximum of eight characters. The Define Template command stores the template in the folder set by using the Set Template Path command with the .tpl file extension.

   If the template already exists, then you can either overwrite the existing template or rename the new template.

   After you have entered a valid template name, the command prompts for another template to define.

6 Type Y or N:
   - Type Y to define another template.
   - Type N to exit the command.

The following illustration shows the categories of subassemblies and connection points:

![Diagram showing subassemblies and connection points]

**Connecting subassemblies to the template**

**Using the Subassembly Attachments Dialog Box**

You can use the Subassembly Attachments dialog box to select curb, fill shoulder, and cut shoulder subassemblies for the left and right sides of a template.

The curb subassembly that you specify is the first subassembly that is connected to the connection-point-out of the template. Curbs are always applied before shoulders. The shoulder subassembly is then connected to the connection-point-out on the curb subassembly. You can use curbs without shoulders, or shoulders without curbs. The same shoulder subassembly can be used for both cut and fill conditions.
You can select two different types of shoulder subassembly for each side of the template: one for cut situations and the other for fill situations. The program determines whether to use cut or fill shoulders based on the position of the connection point that the shoulder is to be attached to. If the connection-point-out of the curb (or the template if you do not specify a curb subassembly) is above the existing ground, then a fill shoulder is applied. If the point is below ground, then a cut shoulder is applied.

The connection-point-out of the shoulder subassembly connects to the ditch foreslope if you are using ditches, or to the design slope if you are not using ditches. If you do not use subassemblies, then the slope attaches to the connection-point-out of the template.

**NOTE** Templates must have subassemblies as well as surfaces. If subassemblies are not required, then you must use the Nulls subassembly name in place of having a subassembly. In addition, if you want to use a shoulder subassembly but not a curb subassembly, then use the Nulls subassembly for the curb subassembly.

**To select subassemblies to attach to templates**

1. In the Subassembly Attachments dialog box, under Left, select the subassemblies you want to attach to the left side of the template. You can type subassembly names into the boxes, or you can click the Select buttons to display the Subassembly Librarian dialog box, from which you can select the subassembly to use. The Subassembly Librarian dialog box provides a graphical display of the subassemblies that are located in the template path.

   When you specify the Left subassemblies in Subassembly Librarian dialog box, their names are copied automatically to the Right section of the dialog box.

2. Under Right, you can select different subassemblies to attach to the right side of the template. The subassemblies you specify for the left and right sides of the template can be the same or different.

3. Click OK when you have finished selecting the subassemblies.

**Using the Subassembly Librarian Dialog Box**

You can use the Subassembly Librarian dialog box to select a subassembly to attach to a template. All of the subassemblies that are located in the template path are listed in the Selection list of this dialog box.

**NOTE** By default, a Nulls subassembly is included in this list. Templates must have subassemblies as well as surfaces. If subassemblies are not required, then you must use the Nulls subassembly name in place of having a subassembly.

**To select a subassembly from the Subassembly Librarian Dialog Box**

1. Click on the name of the subassembly you want to attach to the template. A graphical representation of the subassembly is displayed in the preview window, and the subassembly’s name is listed in the Name box at the bottom of the dialog box.

2. Click OK to select the subassembly.
Changing the Subassemblies that are Attached to the Template

NOTE This option is not available if the template includes a subgrade surface type.

To change the curb and shoulder subassemblies attached to a template

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.

2. Select the name of the template you want to edit.

3. Click OK.

4. Pick an insertion point for the template in the drawing.

   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.

   When the template is inserted, the following prompt is displayed:

   Edsrf/Save/eXit/Assembly/Display/SRfcon/Redraw <eXit>:

5. Type AS for Assembly to change the curb and shoulder subassemblies.

   The Subassembly Attachments dialog box is displayed with the currently attached (if any) curb and shoulder subassemblies.
6 You can change an existing subassembly or subassemblies using one of the following methods:
   - Select the subassembly or subassemblies you want to change and enter a new subassembly file name.
   - Click Select to display the Subassembly Librarian and select the subassembly.
7 Click OK.
The subassembly is automatically inserted into position based on the defined connection points.

NOTE To remove a subassembly, select the “Nulls” subassembly.

8 Type SA to save your changes.

**Drawing Subassemblies**

Subassemblies are similar to template surfaces and are drawn in the same manner as template surfaces. Due to the nature of how you apply subassemblies, you must follow a few different rules when drawing subassemblies:

   - Unlike templates, subassemblies can be either open or closed surfaces.
   - Like templates, subassemblies are drawn as polylines and the process of creating the polyline is exactly the same for both. For more information, see the section “Drawing Templates” in Chapter 5, “Working with Cross Sections.”
   - You must draw subassemblies for the left side of the template only. When you attach a subassembly to a template, it is automatically mirrored to reflect the correct orientation for that side of the template. If you are going to attach a subassembly to the right side of the template only, then you still need to draw and define it as if it is being attached to the left side.
   - When you attach subassemblies, you can use different subassemblies on the left- and right-side of the template.

The following illustration shows examples of how you might draw shoulder and curb subassemblies:

---

**Subassembly creation**
Editing Subassemblies

Use the Edit Subassembly command to modify an existing subassembly or create a new subassembly from an existing subassembly.

NOTE The subassembly you want to edit must exist in the folder specified in the Set Template Path command.

Choosing Which Subassembly Vertex to Edit

To choose which subassembly vertex to edit

1. From the Cross Sections menu, choose Templates ➤ Edit Subassembly to display the Subassembly Librarian.

2. From the Selection list, pick the subassembly you want to edit, and then click OK.

   You are prompted to pick an insertion point in the drawing.

3. Pick an insertion point for the subassembly in the drawing.

   The subassembly is imported into the drawing at the location you picked using the connection-point-in on the subassembly as the point of reference. The command draws the subassembly as a 2D polyline and highlights the datum line on the subassembly in a different color. The command places an X at the first vertex on the polyline. It uses the X to indicate the vertex that can be edited or moved.
After the subassembly is imported into the drawing, the following prompt is displayed:

Delete/Insert/Next/SAve/Previous/SRfcon/Move/Redraw/eXit <Next>:

4 Do one of the following to choose the vertex to edit:
   - Type **Next** to move to the next vertex on the subassembly.
   - Type **Previous** to move to the previous vertex on the subassembly.

5 You can choose from the following tasks:
   - Delete the current subassembly vertex
   - Insert a subassembly vertex
   - Move the subassembly vertex to a new location

**Saving the Changes that you Make to the Subassemblies**

**To save the changes that you make to the subassemblies**

1 From the Cross Sections menu, choose Templates ➤ Edit Subassembly to display the Subassembly Librarian.
2 Pick the subassembly you want to edit, and then click OK.
   You are prompted to pick an insertion point in the drawing.
3 Pick an insertion point for the subassembly in the drawing.
   The subassembly is imported into the drawing at the location you picked using the connection-point-in on the subassembly as the point of reference. The command draws the subassembly as a 2D polyline and highlights the datum line on the subassembly in a different color. The command places an X at the first vertex on the polyline. It uses the X to indicate the vertex that can be edited or moved.

   After the subassembly is imported into the drawing, the following prompt is displayed:

   Delete/Insert/Next/SAve/Previous/SRfcon/Move/Redraw/eXit <Next>:

4 Make your changes to the subassembly.
5 Type **SA** at the command prompt to save any changes you made to the subassembly.
   If the subassembly already exists, then the command prompts to overwrite the subassembly.
6 Type **Y** or **N**:
   - Type **Y** to overwrite the existing subassembly.
   - Type **N** to exit the Save option and return to the main Edit Subassembly command.

If you exit the command without saving, then all edits are lost. The Edit Subassembly command uses the name of the edited subassembly as the default. Accept the default or enter a different name if a new subassembly is to be created from the one just edited. The command stores the subassembly definition in the folder set using the Set Template Path command with the .sub file extension.
Deleting the Current Subassembly Vertex

The Delete option of the Edit Subassembly command removes the current vertex (marked with the X) from the surface definition.

To delete the current subassembly vertex

1. From the Cross Sections menu, choose Templates ➤ Edit Subassembly to display the Subassembly Librarian.
2. Pick the subassembly you want to edit, and then click OK. You are prompted to pick an insertion point in the drawing.
3. Pick an insertion point for the subassembly in the drawing.

The subassembly is imported into the drawing at the location you picked using the connection-point-in on the subassembly as the point of reference. The command draws the subassembly as a 2D polyline and highlights the datum line on the subassembly in a different color. The command places an X at the first vertex on the polyline. It uses the X to indicate the vertex that can be edited or moved.

After the subassembly is imported into the drawing, the following prompt is displayed:

Delete/Insert/Next/SAve/Previous/SRfcon/Move/Redraw/eXit <Next>:

4. Type D for Delete to delete a vertex. The command prompts you to confirm that you want to delete the vertex.

**NOTE**
If the deleted vertex was part of the datum line, use the SRfcon option in the Edit Subassembly command to redefine the datum points.

5. Press ENTER to confirm that you want to delete the vertex from the surface definition.

Inserting a Subassembly Vertex

The Insert option of the Edit Subassembly command adds a new vertex between the current vertex (marked with an X) and the next vertex.

To insert a subassembly vertex

1. From the Cross Sections menu, choose Templates ➤ Edit Subassembly to display the Subassembly Librarian.
2. Pick the subassembly you want to edit, and then click OK. You are prompted to pick an insertion point in the drawing.
3. Pick an insertion point for the subassembly in the drawing.

The subassembly is imported into the drawing at the location you picked using the connection-point-in on the subassembly as the point of reference. The command draws the subassembly as a 2D polyline and highlights the datum line on the subassembly in a different color. The command places an X at the first vertex on the polyline. It uses the X to indicate the vertex that can be edited or moved.
After the subassembly is imported into the drawing, the following prompt is displayed:

Delete/Insert/Next/SAve/Previous/SRfcon/Move/Redraw/eXit <Next>:

4 Type I for Insert to insert a vertex.
You are prompted to enter a new location for the vertex.

5 Select a point in the drawing, or enter the absolute X,Y coordinates for the new vertex location. You can use object snaps to accurately select a point in the drawing. A new vertex is inserted at the point you pick.

**NOTE** Use object snaps to select a point in the drawing accurately.

**NOTE** If the new vertex is part of the datum line, then use the SRfcon option in the Edit Subassembly command to redefine the datum points.

### Moving a Subassembly Vertex to a New Location

The Move option of the Edit Subassembly command relocates the current vertex by selecting a new point.

**To move a subassembly vertex to a new location**

1 From the Cross Sections menu, choose Templates ➤ Edit Subassembly to display the Subassembly Librarian.
2 Pick the subassembly you want to edit, and then click OK.
You are prompted to pick an insertion point in the drawing.
3 Pick an insertion point for the subassembly in the drawing.
The subassembly is imported into the drawing at the location you picked using the connection-point-in on the subassembly as the point of reference. The command draws the subassembly as a 2D polyline and highlights the datum line on the subassembly in a different color. The command places an X at the first vertex on the polyline. It uses the X to indicate the vertex that can be edited or moved.

After the subassembly is imported into the drawing, the following prompt is displayed:

Delete/Insert/Next/SAve/Previous/SRfcon/Move/Redraw/eXit <Next>:

4 Type M for Move to move the current vertex.
The command prompts for the new location of the vertex.
5 Pick a point in the drawing, or enter the absolute X,Y coordinates.

**NOTE** Use object snaps to select a point in the drawing accurately.

The vertex is moved to the point you picked.

**NOTE** If the new vertex is part of the datum line, then use the SRfcon option in the Edit Subassembly command to redefine the datum points.
Redrawing the Subassembly Display

This command redraws the display of the datum line on the subassembly. You can use this option to restore the datum line display after doing an AutoCAD ZOOM or PAN in the middle of the command. Use the Display option to highlight any features of the subassembly, such as the datum line or connection points.

1. From the Cross Sections menu, choose Templates ➤ Edit Subassembly to display the Subassembly Librarian.
2. Pick the subassembly you want to edit, and then click OK.
   You are prompted to pick an insertion point in the drawing.
3. Pick an insertion point for the subassembly in the drawing.
   The subassembly is imported into the drawing at the location you picked using the connection-point-in on the subassembly as the point of reference. The command draws the subassembly as a 2D polyline and highlights the datum line on the subassembly in a different color. The command places an X at the first vertex on the polyline. It uses the X to indicate the vertex that can be edited or moved.

After the subassembly is imported into the drawing, the following prompt is displayed:
Delete/Insert/Next/SAVE/Previous/SRfcon/Move/Redraw/eXit <Next>:

4. Type R for Redraw to redraw the display.

Defining the Subassembly Datum Line

The Datum option is used to redefine the datum line or create a new one if one does not exist. Although templates may have multiple datum lines, only one datum line can be defined per subassembly.

To define the subassembly datum line

1. From the Cross Sections menu, choose Templates ➤ Edit Subassembly to display the Subassembly Librarian.
2. Pick the subassembly you want to edit, and then click OK.
   You are prompted to pick an insertion point in the drawing.
3. Pick an insertion point for the subassembly in the drawing.
   The subassembly is imported into the drawing at the location you picked using the connection-point-in on the subassembly as the point of reference. The command draws the subassembly as a 2D polyline and highlights the datum line on the subassembly in a different color. The command places an X at the first vertex on the polyline. It uses the X to indicate the vertex that can be edited or moved.

After the subassembly is imported into the drawing, the following prompt is displayed:
Delete/Insert/Next/SAVE/Previous/SRfcon/Move/Redraw/eXit <Next>:

4. Type SR for Surface Control to display the following command options:
   Edit (Datum/Connect/Topsurf/eXit/DIplay/Redraw) <eXit>:
Type D for Datum to redefine the Subassembly Datum Line. The command prompts you to pick for the datum points.

Pick the datum points (going from left to right) from the drawing.

NOTE This is easier to do if you set your running object snaps to endpoint prior to entering the Edit Subassembly command. Also, datum points do not need to be physically attached to the subassembly. They can exist in space.

Press ENTER to exit this option after you finish.

Defining the Subassembly Connection Points

The Connect option is used to redefine the subassembly connection points.

To define the subassembly connection points
1 From the Cross Sections menu, choose Templates ➤ Edit Subassembly to display the Subassembly Librarian.
2 Pick the subassembly you want to edit, and then click OK.
   You are prompted to pick an insertion point in the drawing.
3 Pick an insertion point for the subassembly in the drawing.
   The subassembly is imported into the drawing at the location you picked using the connection-point-in on the subassembly as the point of reference. The command draws the subassembly as a 2D polyline and highlights the datum line on the subassembly in a different color. The command places an X at the first vertex on the polyline. It uses the X to indicate the vertex that can be edited or moved.
   After the subassembly is imported into the drawing, the following prompt is displayed:
   Delete/Insert/Next/Save/Previous/SRfcon/Move/Redraw/eXit <Next>: 
4 Type SR for Surface Control.
   The following command options are displayed:
   Edit (Datum/Connect/Topsurf/eXit/Display/Redraw) <eXit>: 
5 Type C for Connect to redefine the connection points.
   The option prompts you to pick the connection point in, and then the connection point out.
6 Pick the connection point in, and then pick the connection point out from the drawing.

NOTE Use object snaps to select top surface points accurately.

For the curb subassembly, the connection-point-in connects to the connection-point-out of the cross section template. The connection-point-out on the curb connects to the connection-point-in on the shoulder subassembly.

For the shoulder subassembly, the connection-point-in connects to the connection-point-out of the curb subassembly. The connection-point-out of the shoulder connects to the ditch foreslope if ditches are used, or to the design slope if ditches are not being used.
Defining the Subassembly Top Surface

To define the subassembly top surface

1. From the Cross Sections menu, choose Templates ➤ Edit Subassembly to display the Subassembly Librarian.
2. Pick the subassembly you want to edit, and then click OK.
   You are prompted to pick an insertion point in the drawing.
3. Pick an insertion point for the subassembly in the drawing.
   The subassembly is imported into the drawing at the location you picked using the connection-point-in on the subassembly as the point of reference. The command draws the subassembly as a 2D polyline and highlights the datum line on the subassembly in a different color. The command places an X at the first vertex on the polyline. It uses the X to indicate the vertex that can be edited or moved.

After the subassembly is imported into the drawing, the following prompt is displayed:

Delete/Insert/Next/Save/Previous/SRfcon/Move/Redraw/eXit <Next>:

4. Type SR for Surface Control.
   The following command options are displayed:
   Edit (Datum/Connect/Topsurf/eXit/Display/Redraw) <eXit>:

5. Type T for Topsurf to redefine the subassembly top surface.
   The Topsurf option defines a top surface for the subassembly. When a subassembly is defined, the top surface is automatically created as a straight line connecting the connection-point-in to the connection-point-out. This top surface needs to be modified if the actual top surface does not follow this path. Each subassembly can only have one top surface.
   The command then prompts you to pick the top surface points from the drawing.
6. Pick all points that define the top surface, from left to right.
   Top surface points do not need to be physically attached to the subassembly. They can exist in space.

   **NOTE** Use object snaps to select top surface points accurately.

7. Press ENTER when you have selected all the points to exit this option.

Highlighting the Subassembly Features for Better Viewing

If you use any AutoCAD commands that redraw the screen (such as ZOOM or PAN), the datum line, top surface, or highlighted connection points are no longer displayed. Use this option to redisplay these features.
To highlight the subassembly features for better viewing

1. From the Cross Sections menu, choose Templates ➤ Edit Subassembly to display the Subassembly Librarian.
2. Pick the subassembly you want to edit, and then click OK.
   You are prompted to pick an insertion point in the drawing.
3. Pick an insertion point for the subassembly.
   The subassembly is imported into the drawing at the location you picked using the connection-point-in on the subassembly as the point of reference. The command draws the subassembly as a 2D polyline and highlights the datum line on the subassembly in a different color. The command places an X at the first vertex on the polyline. It uses the X to indicate the vertex that can be edited or moved.

After the subassembly is imported into the drawing, the following prompt is displayed:
Delete/Insert/Next/SAve/Previous/SRfcon/Move/Redraw/eXit <Next>:

4. Type SR for Surface Control.
   The following command options are displayed:
   Edit (Datum/Connect/Topsurf/eXit/DIsplay/Redraw) <eXit>:

5. Type DI for DIsplay to access the display options.
   The following prompt is displayed:
   Display (Datum/Connect/Topsurf/eXit/Redraw) <eXit>:

6. At the command prompt, do one of the following:
   - Type D for Datum to display the defined datum line. This line is displayed as a highlighted line connecting all the defined datum points.
   - Type C for Connect to display the defined connection-point-in and connection-point-out. Each point is displayed with an "X" in the drawing. There is no distinction between the connection-point-in and the connection-point-out in the display.
   - Type T for Topsurf to display the defined top surface. This line is displayed as a highlighted line connecting all of the defined top surface points.
   - Type R for Redraw to redraw the displayed elements erasing any highlighted lines.

7. Type X to exit the Display options after you have finished.

Importing the Subassemblies into a Drawing

You can use the Import Subassembly command to import a defined subassembly into the current drawing either to view it, or to create a detailed drawing of the subassembly.

This subassembly is inserted as a polyline, placed on the current layer, and is drawn using the vertical scale factor, which is determined by the horizontal and vertical scales set with the Drawing Setup command.

All subassembly features, such as the datum line, are highlighted. The highlights are removed if you use the REDRAW command.
To import a subassembly into a drawing

1. If the subassemblies and templates that you are working with are not in the current path, set the template path.

   **NOTE** You only need to set the template path to import the subassembly if the one you want isn’t in the current path. Subassemblies must be in the same location as the templates that use them.

2. From the Cross Sections menu, choose Templates ➤ Import Subassembly to display the Subassembly Librarian.

3. Select the subassembly you want to import, and then click OK.

4. Pick the insertion point for the subassembly. This point corresponds to the connection-point-in on the subassembly. The command inserts the subassembly into the drawing.

**Defining Templates**

A template is a typical section of the finished design elements such as asphalt, concrete, and granular materials. Templates are made up of two basic elements: normal surfaces and subgrade surfaces. Normal surfaces are the elements of the template that make up the main part of the template such as pavement surfaces, median islands, shoulders and curbs. Subgrade surfaces are linked to the normal surfaces, but use separate design parameters to control the grade and depth of the surface. A typical subgrade surface is made up of granular substances such as gravel.

All templates have a defined finished ground reference point which is used by the Edit Design Control command to position the template on the cross section using the horizontal alignment and the finished ground vertical alignment (the
FGC profile) for control. This reference point is usually the crown of the roadway.

Defining Templates

After drawing the template, use the Define Template command to define it.

You see different prompts when you use this command, depending on whether the template you are defining is composed of normal or subgrade surfaces.

When defining a template with only normal surfaces, you are required to specify a finished ground reference point, a datum line, and connection-points-out. There is also an option to add subassemblies to the template definition.

If you are defining a template with a subgrade surface, then you are not prompted to define the connection points, a datum line, or to attach subassemblies. The connection points are defined automatically at the outer end of the drawn portion of the subgrade and the datum lines are automatically generated along the bottom of each subgrade. Each datum line is numbered in ascending order, starting from the lowest subgrade on the template.

Before defining your templates, be sure to do the following tasks:

- Set the template storage path with the Set Template Path command.
- Draw the template surfaces as 2D polylines, either with the Draw Template command or the AutoCAD PLINE command.
- For templates made up of Normal surfaces only, define any subassemblies to be attached. Subassemblies must be drawn as if they were being attached to the left side of the template.

NOTE Subassemblies cannot be used on templates with subgrades. If subgrades are defined for a template, then you will not be prompted to attach subassemblies.

Defining a Template that Only has Normal Surfaces

To define a template that only has normal surfaces

1. From the Cross Sections menu, choose Templates ➤ Define Template.
2. Pick the finished ground reference point when you are prompted to do so.

This is the point on the template that controls the placement of the template horizontally and vertically on the sections. For a typical road template, the finished ground reference point is the crown of the road. This is the point by which all symmetrical surfaces are mirrored. The point does not have to be on a template surface. To define this point at a physical template location, select it using an appropriate object snap.

The Define Template command displays the following prompt:

Is the surface symmetrical (Yes/No) <Yes>: 
3 Do one of the following:
- Press ENTER if the surfaces are symmetrical and you drew only the left side of the template.
- Type N for No if the surfaces are asymmetrical and you drew the entire template.

**NOTE** Symmetrical surfaces are not physically mirrored at the centerline during the Define Template command. The template must be imported into the drawing using the Import Template or Edit Template command to see the right-hand side.

4 Select all of the objects that make up the template by picking them from the drawing.

You can either select each surface individually or use a window or crossing window to select the template surfaces. Each surface must be made up of a 2D polyline created with either the AutoCAD PLINE command or the Draw Template command.

When you are finished selecting objects, press ENTER at the Select objects prompt.

The command highlights the first surface you selected and displays the following command line prompt:

```
Surface Type (Normal/Subgrade) <Normal>:
```

5 Press ENTER to select Normal.

A material table is displayed, if it exists in the folder set by Set Template Path command. If the material table does not exist, then you are prompted to enter the Material Name (maximum 20 characters) at the command prompt.

6 Select the surface material, and then click OK.

After you select the surface, the command finds the next template surface you selected (if you selected more than one) and highlights it. Repeat steps 5 and 6 until you have specified a surface material for all of your surfaces.

7 After you select the surface materials, the following prompt is displayed:

```
Pick connection point out:
```

Connection points are used to attach the subassemblies, such as a curb or a shoulder, to the template. If no subassemblies are attached, then the connection point out is used as the point from which the ditch slopes or design slopes extend.

If the template is symmetrical, then you define the connection point on the one side of the template and the definition is mirrored to the other side. If the template surface is asymmetrical, then you need to define connection points for each side of the template.

**NOTE** Use object snaps to select the connection point accurately.

After you pick the connection point out from the drawing, the following prompt is displayed:

```
Datum number <1>:
```
Specify the datum number. The default datum number is always one (1).

The datum line is compared against the existing ground surface to calculate the cut and fill areas. The datum can be modified, or additional datum lines can be added with the Edit Template command.

After you enter the datum number, the following prompt is displayed:

Pick datum points (Left to Right):

Pick the datum points from the drawing, being sure to pick them from left to right. Press ENTER after you finish picking the datum points.

**NOTE** Use object snaps to select the datum points accurately.

You can specify more than one datum for any template, but the Define Template command only allows you to define one datum in addition to any datum lines defined automatically by subgrades. To define additional datum lines, use the Edit Template command. The Define Template command uses datum lines for volume calculations. When the completed template is processed, the datum line is compared to the existing ground surface to generate the cut and fill areas for each section.

After you finish picking the datum points, the Subassembly Attachments dialog box is displayed.

Choose the subassemblies you want to attach to the template.

After you attach the subassemblies to the template, the following prompt is displayed:

Save template (Yes/No) <Yes>:

Press ENTER to save the template. You are prompted to enter a name for the template.

Enter a name for the new template and press ENTER. A prompt is displayed asking if you would like to define another template.

Type Y or N:
- Type Y to start from the beginning and define another template.
- Type N to quit the command.

After you have defined a template, you can use it for any project. Be sure to specify the correct template path when using previously defined templates.

To view the completed template, use the Import Template command. Use the Edit Template command to edit a template definition, create a new template, or add datum lines and top surfaces.

The following illustration shows how to pick datum points:
The following illustration shows how connection points are established:

![Establishing connection points](image1)

The following illustration shows symmetrical and asymmetrical templates:

![Symmetrical and asymmetrical templates](image2)

The following illustration shows the finished ground reference point:

![Establishing the finished ground reference point](image3)

**Defining a Template that has Subgrade Surfaces**

**To define a template that has only subgrade surfaces**

1. From the Cross Sections menu, choose Templates ➤ Define Template.
2. Pick the finished ground reference point when you are prompted to do so.

This is the point on the template that controls the placement of the template horizontally and vertically on the sections. For a typical road template, the finished ground reference point is the crown of the road. This is the point by which all symmetrical surfaces are mirrored. The point does not have to be on a template surface. To define this point at a physical template location, select it using an appropriate object snaps.

To see an illustration that shows the finished ground reference point, refer to “Defining a Template that Only has Normal Surfaces” in this chapter.

The Define Template command displays the following prompt:

Is the surface symmetrical (Yes/No) <Yes>: 

---

Chapter 4  Working with Cross Sections

304
3 Do one of the following:
   ■ Press ENTER if the surfaces are symmetrical and you drew only the left side of the template.
   ■ Type N for No if the surfaces are asymmetrical and you drew the entire template.

To view an illustration that shows symmetrical and asymmetrical templates, see “Defining a Template that Only has Normal Surfaces” in this chapter.

   **NOTE** Symmetrical surfaces are not physically mirrored at the centerline during the Define Template command. The template must be imported into the drawing using the Import Template or Edit Template command to see the right hand side.

4 Select all of the objects that make up the template by picking them from the drawing.

You can either select each surface individually or use a window or crossing window to select the template surfaces. Each surface must be made up of a 2D polyline created with either the AutoCAD PLINE command or the Draw Template command. When you are finished selecting objects, press ENTER at the Select objects prompt.

The command highlights the first surface you selected and displays the following command line prompt:

```
Surface Type (Normal/Subgrade) <Normal>:
```

5 Type S and press ENTER to select the subgrade.

The following command prompt is displayed:

```
Subgrade depth:
```

6 Type the depth of the subsurface material at the centerline of the template, and press ENTER.

The following prompt is displayed:

```
Subgrade match grade percent:
```

7 Type the grade percent at which the bottom of the subgrade extends to intersect the ditch slope or design slope, and press ENTER.

The following prompt is displayed:

```
Subgrade match type (Grade/Vertical) <Grade>:
```

The subgrade match type defines how the subgrade will match into the template design slope.

8 Choose the match type option you want:
   ■ Type Grade to draw the subsurface out to the design slope. The Grade option is more appropriate in rural road design where you are matching the subsurface out to where it meets the ditch.
   ■ Type Vertical to also draw the subsurface out to the design slope, but use this option in urban road design situations when you do not want the subsurface to match out to a ditch. Using this option, you can design the template so that the subsurface stops at a specified offset from the connection point out on the template. If you specify the Vertical option, then you are prompted for a subgrade vertical offset modifier. This offset
specifies how far from the connection point out on the template you want to draw the vertical “match” line for the subgrade. This match line matches upwards into the template, using a vertical line, rather than matching out at a grade towards a ditch.

The following prompt is displayed:

Subgrade break match grade percent <5>:

**NOTE** This value is only used if superelevation is applied to the template and the Fixed Break subgrade superelevation option is used. Press ENTER to skip this prompt if you are not using superelevations.

The subgrade break match grade percent is the grade for the bottom of the subgrade, from the outer edge of the superelevation region (plus or minus the modifier) to the side slope.

9 Type a subgrade break match grade percent, and then press ENTER.

The following prompt is displayed:

Subgrade break point offset modifier <0>:

**NOTE** This value is only used if superelevation is applied to the template and the Fixed Break subgrade superelevation option is used. Press ENTER to skip this prompt if you are not using superelevations.

10 Type a Subgrade break point offset modifier and press ENTER.

With the Fixed Break subgrade superelevation option that is available in the Superelevation Parameters command, the subgrade below the template superelevation region superelevates, and the subgrade outside of the superelevation region won’t. The subgrade break point offset modifier option is used to set the location of this break point in relation to the outer superelevation point. If the default of 0.00 is used, then the break point occurs directly below the outer superelevation point. If a positive value is entered, then the break point is shifted by that amount toward the centerline and a negative value shifts it away from centerline.

The material table is displayed, if it exists in the folder set by Set Template Path command. If the material table does not exist then you are prompted to enter the Material Name (max twenty characters) at the command prompt.

11 Select the type of surface material you want to use, and then click OK if a material table exists, or type the name of material at the command prompt.

The command prompts for the next subgrade depth.

12 Continue to enter depths, grades, break point offset modifiers, and materials if more than one subgrade material is desired, or press ENTER to end the command.

After you finish defining the template, the following prompt is displayed:

Save template (Yes/No) <Yes>:

13 Press ENTER to save the template.

You are prompted to enter a name for the template.
14 Enter a name for the new template and press ENTER.

A prompt is displayed asking if you would like to define another template.

15 Type Y or N:
   - Type Y to start from the beginning and define another template.
   - Type N to quit the command.

The following illustration shows subgrade superelevation parameters:

![Subgrade superelevation parameters](image)

The following illustration shows the subgrade parameters:

![Template subgrade parameters](image)

**Editing Templates**

To redefine a cross section template, or to create a new template from an existing template, use the Edit Template command. This command imports the template into the drawing where you can change the connection, superelevation, transition, top surface, and datum points, add or delete surfaces, edit surface points, add point codes, and attach subassemblies.
drawn on the current layer using the vertical scale factor that is determined by the horizontal and vertical scale set with Setup commands.

**NOTE** If you are going to use the Edit Template command to define template features such as point codes, transitions or superelevation, you may first want to set the AutoCAD running object snap to Endpoint to save time. Set the object snap to endp, then when you are finished, you can set object snap back to none.

The Edit Template command creates two polylines for each surface; one for the left side and one for the right side. The command also displays any attached subassemblies, and although they cannot be edited, you can select different subassemblies for the current template. To use this command, the template and its subassemblies must exist in the folder set with the Set Template Path command.

**NOTE** Use the Edit Template command for both symmetrical and asymmetrical templates. The command does not mirror the edits to a surface from the left- to right-side. When editing symmetrical templates, remember to edit both sides of the template if it is to remain symmetrical.

### Choosing Which Template Vertex to Edit

Using the Modify options of the Edit Template command, you can move, insert, or delete template vertices.

**To choose which template vertex to edit**

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2 From the Selection list, select the name of the template you want to edit.
3 Click OK.
4 Pick an insertion point for the template in the drawing.
   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.
   When the template is inserted, the following prompt is displayed:
   Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:
5 Type E for Edsrf to access surface editing commands. The following prompt is displayed:
   Addsrf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:
6 Type M for Modify to modify the template vertices.
   The command prompts you to select the object to edit.
7 Click on the template surface you want to edit.
   Once you select the surface, the command places an X at the first vertex on the polyline and the following prompt is displayed:
   Edit (Next/Previous/Insert/Move/eXit/Delete) <Next>:
8 Enter Next (or Previous) at the command prompt until you go to the right vertex.

**Inserting a Vertex into a Template**

The Insert option adds a new vertex between the current vertex (marked with the X) and the next vertex.

**To insert template vertices**
1 From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2 Select the name of the template you want to edit.
3 Click OK.
4 Pick an insertion point for the template in the drawing.
   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.
   When the template is inserted, the following prompt is displayed:
   Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:
5 Type E for Edsrf to access the surface editing commands.
   The following prompt is displayed:
   Addsrf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:
6 Type M for Modify to modify the template vertices.
   The command prompts you to select the object to edit.
7 Use your pointing device to select the template surface to edit.
    Once you select the surface, the command places an X at the first vertex on the polyline and the following prompt is displayed:

    Edit (Next/Previous/Insert/Move/eXit/Delete) <Next>

8 Enter Next (or Previous) at the command prompt until you go to the right vertex.

9 Enter Insert to insert the template vertex.
    The option inserts a vertex after the currently marked vertex. Select a point in the drawing or enter the absolute X,Y coordinates. Use an object snap to select a point in the drawing accurately. If the new vertex is to be part of the datum line, use the SRfcon option of the Edit Template command to redefine the datum points.

**Moving a Template Vertex to a New Location**

**To move template vertices**

1 From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.

2 Select the name of the template you want to edit.

3 Click OK.

4 Pick an insertion point for the template in the drawing.
    The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.
    When the template is inserted, the following prompt is displayed:

    Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:

5 Type E for Edsrf to access surface editing commands.
    The following prompt is displayed:

    Addsrf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:

6 Type M for Modify to modify the template vertices.
    The command prompts you to select the object to edit.
7 Use your pointing device to select the template surface to edit.
    Once you select the surface, the command places an X at the first vertex on the polyline and the following prompt is displayed:

    Edit (Next/Previous/Insert/Move/eXit/Delete) <Next>:

8 Enter Next (or Previous) at the command prompt until you go to the right vertex.

9 Enter Move to move the vertex.
    You are prompted for the new location.
10 Pick a point in the drawing, or enter the absolute X,Y coordinates for the vertex.
NOTE Use an object snap to select a point in the drawing accurately.

Deleting the Current Template Vertex

To delete template vertices
1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2. From the Selection list, select the name of the template you want to edit.
3. Click OK.
4. Pick an insertion point for the template in the drawing.
   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.
   When the template is inserted, the following prompt is displayed:
   Edsurf/SAvs/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:
5. Type E for Edsurf to access surface editing commands.
   The following prompt is displayed:
   Addsurf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:
6. Type M for Modify to modify the template vertices.
   The command prompts you to select the object to edit.
7. Use your pointing device to select the template surface to edit.
   Once you select the surface, the command places an X at the first vertex on the polyline and the following prompt is displayed:
   Edit (Next/Previous/Insert/Move/eXit/Delete) <Next>:
8. Enter Next (or Previous) at command prompt till you to go to the right vertex.
9. Type Delete at the command prompt to delete the vertex.
   You are asked to confirm that you want to delete the vertex.
10. Do one of the following tasks:
    ■ Press ENTER to delete the vertex from the surface definition.
    ■ Type N for No to exit the Delete option without deleting the vertex.

Drawing a New Template Surface

To draw an additional template surface
1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2. Select the name of the template you want to edit.
3. Click OK.
Pick an insertion point for the template in the drawing.

The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.

When the template is inserted, the following prompt is displayed:

Edsrf/SAv/eXit/ASsemble/Display/SRfcon/Redraw <eXit>:

Type E for Edsrf to access surface editing commands.

The following prompt is displayed:

Addsurf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:

Type A for Addsurf to draw an additional template surface.

The Addsurf option displays the following prompt:

Draw/Move/Select <Select>:

Type D to select the Draw option.

You are prompted for the starting point of the new surface.

Pick a point in the drawing with your pointing device or enter coordinates at the command prompt to display the following prompt:

Select point (Relative/Grade/Slope/Close/Undo/eXit):

Refer to the Draw Template command for details about using these options to draw the additional surface.

Once you've drawn the additional surface, the following prompt is displayed:

Surface type (Sym/Asym):

Type S for symmetrical or A for asymmetrical.

Next, you are prompted to Press any key to select a material name.

Press ENTER to display a Material Table.

Pick the appropriate material name from the list or create a new one as needed.

If there is no material table in your template folder, enter a material surface name, and then press ENTER.

The prompt returns to the Edsrf options.

Press ENTER to exit the Edsrf options, and then type SA to save your changes.

NOTE If the surface is symmetrical, then it is mirrored about the centerline although this is not apparent until you save and re-import the template.

Moving a Template Surface

To add a surface to an existing template

1 From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.

2 Select the name of the template you want to edit.

3 Click OK.
Pick an insertion point for the template in the drawing.
The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.

When the template is inserted, the following prompt is displayed:
Edsurf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:

Type E for Edsurf to access surface editing commands.
The following prompt is displayed:
Addsurf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:

Type A for Addsurf to draw an additional template surface. If the surface to add is symmetrical, draw the left half. If it is asymmetrical, then draw the entire surface.
The Addsurf option displays the following prompt:
Draw/Move/Select <Select>:

The Draw option is used to draw the new surface definition. The Move option is used if a polyline exists for the new surface but is in the wrong location. The Select option is used if a polyline exists for the new surface and is in the correct location to add it to the template.

Type M if the polyline that represents the new surface needs to be moved to the correct location on the template first.

Pick the object in the drawing that you want to move.
The object must be a 2D polyline. Select only the left side of the surface if the surface is symmetrical.

Pick the starting and ending locations as you are prompted to do so.
The starting point should be a point on the template. The ending point is the point that the starting point will be moved to. Use an AutoCAD OBJECT SNAP to accurately pick the locations.

Once you've moved the surface, the following prompt is displayed:
Surface type (Sym/Asym):

Type S for symmetrical or A for asymmetrical.
Next, you are prompted to press any key to select a material name.
Press ENTER to display a Material Table.
Pick the appropriate material name from the list or create a new one as needed.
If there is no material table in your template folder, then enter a material surface name at the command prompt, and then press Enter.
The prompt returns to the Edsurf options.
Press ENTER to exit the Edsurf options, and then type SA to save your changes.
Adding a Template Surface to the Template

To add an existing surface to the template definition.

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2. Select the name of the template you want to edit.
3. Click OK.
4. Pick an insertion point for the template in the drawing.
   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.
   When the template is inserted, the following prompt is displayed:
   
   Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:

5. Type E for Edsrf to access surface editing commands.
   The following prompt is displayed:
   
   Addsurf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:

6. Type A for Addsurf to draw an additional template surface.
   The Addsurf option displays the following prompt:
   
   (Draw/Move/Select) <Select>:

7. Type S to choose the Select option. You are prompted to select a surface.
8. Click the surface you want to add to the template definition. This surface should be a closed 2D polyline.
   Once you’ve selected the surface, the following prompt is displayed:
   
   Surface type (Sym/Asym):

9. Type S for symmetrical or A for asymmetrical.

   **NOTE** If the template is symmetrical, the command mirrors the polyline about the alignment for the right side of the surface.

   Next, you are prompted to Press any key to select material name.
10. Press ENTER to display a Material Table.
11. Pick the appropriate material name from the list or create a new one as needed.
   The command adds this surface to the template definition.
   The prompt then returns to the Edsrf options.
12. Press ENTER to exit the Edsrf options, and then type SA to save your changes.

Deleting a Template Surface

To delete a surface from a template

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2. Select the name of the template you want to edit.
3 Click OK.
4 Pick an insertion point for the template in the drawing.

The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.

When the template is inserted, the following prompt is displayed:

```
Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:
```

5 Type E for Edsrf to access surface editing commands. The following prompt is displayed:

```
Addsrf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:
```

6 Type D for delete surface.

You are prompted to pick the object to delete.

7 Pick the surface to delete from the drawing.

```
NOTE: Subassemblies cannot be selected. Use the Assembly option of the Edit Template command to change subassemblies.
```

You are prompted to confirm that you want to delete the surface.

8 Do one of the following tasks:

- Press ENTER in response to delete the surface and remove both left and right sides of the surface from the template definition.
- Type N for No to exit the Delsurf option without deleting any surfaces.

---

### Editing the Template Subgrade Depth and Match Grade

To make edits to the subgrade depth and match grade

1 From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2 Select the name of the template you want to edit.
3 Click OK.
4 Pick an insertion point for the template in the drawing.

The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.

When the template is inserted, the following prompt is displayed:

```
Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:
```

5 Type E for Edsrf to access surface editing commands.

The following prompt is displayed:

```
Addsrf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:
```
6 Type S for Subgrade to activate the subgrade editing options.
   The command lists the current subsurface depth and gives you the option of
   changing it.
7 Enter a new subsurface depth value or press ENTER to accept the current depth.
   The option displays the current subsurface match grade (percent) and prompts
   for a new value.
8 Enter a new subsurface match grade value or press ENTER to accept the current
   match grade. The next prompt is for the break match grade, which is used when
   the subgrade superelevates with the Fixed Break option.
9 Enter a new break match grade value or press ENTER to accept the current
   value. The next prompt is for the break point offset modifier.
10 Enter a new break point offset modifier value or press ENTER to accept the
    current value.

   **NOTE**  For more information on the subgrade definition options, see “Defining a
   Template that has only Subgrade Surfaces”

   The material name dialog box is displayed with the current name highlighted.
11 Click OK to keep the same material name, or select a different name from the
    list. The prompt returns to the surface editing options.
12 Press ENTER to exit the Edsrf options, and then type SA to save your changes.

### Changing the Material Description of a Template Surface

**To change the material description for a selected surface**

1 From the Cross Sections menu, choose Templates ➤ Edit Template to display
   the Template Librarian.
2 Select the name of the template you want to edit.
3 Click OK.
4 Pick an insertion point for the template in the drawing.
   The Edit Template command inserts the template using the defined finished
   ground reference point as the insertion point. The command draws the
   template components and displays the subgrade surfaces and datum line on the
   template as highlighted, temporary lines.
   When the template is inserted, the following prompt is displayed:
   Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:
5 Type E for Edsrf to access surface editing commands.
   The following prompt is displayed:
   Addsurf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:
6 Type MN for Material Name.
   The following prompt is displayed:
   Pick entity (must be a 2d polyline):
Pick the surface you want to rename.
The Surface Material Names dialog box is displayed.

Use the Surface Material Names dialog box to select a different material name or create a new one as needed.
The prompt returns to the surface editing options.

Press ENTER to exit the Edsrf options, and then type SA to save your changes.

**Adding Template Point Codes to a Template**

To add template point codes

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2. Select the name of the template you want to edit.
3. Click OK.
4. Pick an insertion point for the template in the drawing.
   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.
   When the template is inserted, the following prompt is displayed:
   Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:
5. Type E for Edsrf to access surface editing commands.
   The following prompt is displayed:
   Addsrf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:
6. Type P for Points to access the point code editing options.
   The points that are assigned to the template is displayed along with the following prompt:
   Edit point codes (Add/Delete/eXit) <eXit>:
7. Type A for Add to add point codes.
   The command prompts you to select the point location. Use object snaps to accurately select the point on the template.
8. Pick the point location from the drawing.
   After selecting the point, the Template Point Codes dialog box is displayed, listing the point codes of the current point code table.
9. Select the desired code, and then click OK or create a new code as needed.
   The Points option continues to prompt for more point code locations.
10. Continue to add point codes as necessary.
11. Press ENTER to exit the command loop and return to the Edit Point Codes command prompt.
12. Press ENTER to return to the surface editing options.
13. Press ENTER to exit the surface editing options, and then type SA to save your changes.
Deleting Template Point Codes from a Template

To delete template point codes

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2. Select the name of the template you want to edit.
3. Click OK.
4. Pick an insertion point for the template in the drawing.
   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.
   When the template is inserted, the following prompt is displayed:
   Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:
5. Type E for Edsrf to access surface editing commands.
   The following prompt is displayed:
   Addsrf/Delsurf/Modify/MName/Points/Redraw/Subgrade/eXit <eXit>:
6. Type P for Points to access the point code editing options.
   The points that are assigned to the template is displayed along with the following prompt:
   Edit point codes (Add/Delete/eXit) <eXit>:
7. Type D for Delete.
   The command prompts you to select the point code location to remove. Use object snaps to accurately select the point on the template.
8. Pick the point code location to remove. The Delete option continues to prompt for more point code locations.
9. Continue to delete point codes as necessary.
10. Press ENTER to exit the command loop and return to the Edit Point Codes command prompt.
11. Press ENTER to return to the surface editing options.
12. Press ENTER to exit the surface editing options, and then type SA to save your changes.

Displaying the Template Shoulder Subassembly

To display the cut or fill shoulder subassembly on the template

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2. Select the name of the template you want to edit.
3. Click OK.
4. Pick an insertion point for the template in the drawing.
   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the
template components and displays the subgrade surfaces and datum line on the
template as highlighted, temporary lines.
When the template is inserted, the following prompt is displayed:
Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>: 

5 Type D for Display to display the cut or fill shoulder.
The following prompt is displayed:
Display
(Datum/Connect/Points/Super/SHoulder/Topsurf/TRtransition/eXit/Redraw/TTYpe/) <eXit>: 

6 Type SH for Shoulder to display the template shoulder.
The following prompt is displayed:
Shoulder display (Cut/Fill) <Fill>: 

7 Do one of the following:
- Press ENTER to display the fill shoulder.
- Type C for Cut to display the cut shoulder.

**Defining or Editing the Template Datum Line**
The surface control points control superelevation and transition regions. They
are also the datum points, connection points out, and top surface points. You
can use the SRfcon command to redefine all control points for the surface.

**To redefine the points for the existing datum line or to define a new datum line**
on the template

1 From the Cross Sections menu, choose Templates ➤ Edit Template to display
the Template Librarian.
2 Select the name of the template you want to edit.
3 Click OK.
4 Pick an insertion point for the template in the drawing.
The Edit Template command inserts the template using the defined finished
ground reference point as the insertion point. The command draws the
template components and displays the subgrade surfaces and datum line on the
template as highlighted, temporary lines.
When the template is inserted, the following prompt is displayed:
Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>: 

5 Type SR for Srfcon to activate the Surface Control options.
The following prompt is displayed:
Connect/Datum/Redraw/Super/Topsurf/TRtransition/eXit <eXit>: 

6 Type D for Datum to redefine an existing datum line or to define a new one.
Datum lines are used to calculate the cut and fill earthwork volumes. There is
no limit to the number of defined datums on a template. The defined datum
that is to be used in volume calculations is selected in the Edit Design Control
command.
The command first prompts for the datum number.
7 Enter the datum number and press ENTER.
8 Pick the datum points starting from the left connection point out and going to the right connection point out.

Datum points do not have to be physically attached to the template. They can exist in space. Use AutoCAD object snaps to pick the datum points accurately.
9 Press ENTER to end the prompt cycle.

Use the Display option to view the defined datum. The datum is only defined through the template surfaces and not the subassemblies. The subassembly datum is defined using the Define Subassembly or Edit Subassembly commands. Subassemblies cannot have multiple datum definitions.
10 Press ENTER to exit the surface control options, and then type SA to save your changes.

**Defining the Template Superelevation Regions**

You must define superelevation regions in order to apply superelevation to the template with the Superelevation Parameters command.

**To define the template superelevation regions**

1 From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2 Select the name of the template you want to edit.
3 Click OK.
4 Pick an insertion point for the template in the drawing.

The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.

When the template is inserted, the following prompt is displayed:

Edsurf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>: 

5 Type SR for Srfcon to activate the Surface Control options.

The following prompt is displayed:

Connect/Datum/Redraw/Super/Topsurf/TRansition/eXit <eXit>: 

6 Type S for the Super option.
7 Select the points to define the left and right superelevation regions.

The following prompts are displayed in turn:

Outer left superelevation point:
Inner superelevation reference point:
Outer rollover point:
Outer right superelevation point:
Inner superelevation reference point:
Outer rollover point:

8 Pick the points as you are prompted to do so.

Define the left superelevation region first, followed by the right superelevation region. When defining the region, pick the outer edge of the region, and then
the inner edge using AutoCAD object snaps. All surface segments between these region points will superelevate.

The grade between the two points is used as the base grade for the normal crown condition when calculating superelevation.

After picking the two region points, select the outer edge of the rollover region if required. If the template does not have a shoulder that requires a rollover region, then press ENTER at the rollover prompt for none.

Use the Superelevation Parameters command to define superelevation parameters after defining the template superelevation regions.

Press ENTER to exit the surface control options, and then type SA to save your changes.

The following illustration shows guidelines for picking these points:

Superelevation and rollover points on the template

**Defining the Template Connection Points**

**NOTE** This option is not available if the template includes a subgrade surface type.

To redefine the connection points on the template

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2. Select the name of the template you want to edit.
3. Click OK.
4. Pick an insertion point for the template in the drawing.
   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.
   When the template is inserted, the following prompt is displayed:
   
   Edsr/S/A/Assembly/Display/Srfcon/Redraw <eXit>:

5. Type SR for Srfcon to activate the Surface Control options.
   The following prompt is displayed:
   
   Connect/Datum/Redraw/Super/Topsurf/TR/ 
   Assembly/Display/Srfcon/Redraw <eXit>:
Type C for Connect to redefine the points that are used to connect the template to the subassemblies and slopes.

The connection points on the template are indicated with X markers and the command displays the following prompt:

Side (Left/Right):

Only one side is defined at a time.

Type L or R to select Left or Right.

Even if a template is symmetrical, both sides need to be redefined. Each half of the template is edited separately.

The command prompts for the connection point out.

Select the connection points.

Connection points do not need to reference a point on any of the template entities. They can exist in space. Use AutoCAD object snaps to select connection points accurately.

Once the connection point out is selected, the command prompt redispays the SRfcon options.

Type C for Connect and repeat the process for the other side of the template.

If subassemblies are used, the display showing the subassemblies moves to reflect the new connection point. The connection points can be viewed using the Display option.

Press ENTER to exit the surface control options, and then type SA to save your changes.

### Defining the Template Top Surface Points

This option overwrites all previously defined points with the newly defined points in the selected top surface. The top surface is similar to the datum line except that it cannot be used in volume calculations. The top surface is used to import template points or to create a 3D grid.

**To define the template top surface points**

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2. Select the name of the template you want to edit.
3. Click OK.
4. Pick an insertion point for the template in the drawing.

   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.

   When the template is inserted, the following prompt is displayed:

   Edsr/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>: 

---

Chapter 4  Working with Cross Sections

322
5 Type **SR** for **Srfcon** to activate the Surface Control options. 
The following prompt is displayed:

`Connect/Datum/Redraw/Super/Topsurf/TRansition/eXit <eXit>:`

6 Type **T** for **Topsurf** to define (or redefine) the top surface of the template. 
The command first prompts for a default surface number.

7 Accept the default surface number or enter a new number.

8 Select the top surface points.

   Select these points from the left connection point to the right connection point 
   using AutoCAD object snaps.

9 Press ENTER to end the prompt cycle.

10 Press ENTER to exit the surface control options, and then type **SA** to save your 
    changes.

   The defined top surface can be viewed using the Display option. The top surface 
   is defined through both the template and subassembly surfaces. The top surface 
   of the subassemblies can only be defined or edited using the Edit Subassembly 
   command. Subassemblies cannot have multiple top surface definitions.

**NOTE** Usually the datum represents the bottom of all the template surfaces. In a 
fill situation it represents the top of the fill material on which the bottom 
most template surface lays. The top surface usually represents the very top 
most template surface, which is the finished surface of the template, or the 
template surface that is exposed to the air.

### Highlighting Template Features for Better Viewing

To display the location of template features such as transitions, datum lines, or 
point codes

1 From the Cross Sections menu, choose Templates ➤ Edit Template to display 
   the Template Librarian.

2 Select the name of the template you want to edit.

3 Click OK.

4 Pick an insertion point for the template in the drawing.

   The Edit Template command inserts the template using the defined finished 
ground reference point as the insertion point. The command draws the 
template components and displays the subgrade surfaces and datum line on the 
template as highlighted, temporary lines.

   When the template is inserted, the following prompt is displayed:

   `Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:`

5 Type **D** for Display.

   The following prompt is displayed:

   `Display 
   (Datum/Connect/Points/Super/SHoulder/Topsurf/TRansition/eXit/Redraw/TTy 
   pe/) <eXit>:`
Choose the appropriate option to display the features of the template you want to see.

You have the option of displaying datum lines, connection points, point codes, superelevation, the shoulder, top surface, and transition regions. You also have the option to redraw the display, which removes all highlighted and temporary lines.

Datum and top surface lines are displayed as temporary lines. Each connection point and point code is shown as an X on the screen. Superelevation and transition regions are shown as vertical lines delineating the respective regions. These features are only temporary and disappear if the screen is redisplayed using the Redraw option.

The TType option displays the Section Transition Type dialog box, a listing of all the transition regions that have been defined. This option is only available if transition regions have been defined for the template. Next to each of the possible transition lines is the list of how they were defined: dynamic or pinned, constrained or free, and whether the grade or elevation is held.

### Redrawing the Template Display

The Redraw option redraws the template's datum line and its subassemblies. These two features are always displayed with the template but will disappear if an AutoCAD command, such as Zoom, is executed transparently so that the drawing is redisplayed. The Redraw option redisplay the datum line and any defined subgrades and attached subassemblies.

**To redraw the template display**

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian.
2. Select the name of the template you want to edit.
3. Click OK.
4. Pick an insertion point for the template in the drawing.

   The Edit Template command inserts the template using the defined finished ground reference point as the insertion point. The command draws the template components and displays the subgrade surfaces and datum line on the template as highlighted, temporary lines.

   When the template is inserted, the following prompt is displayed:

   Edsurf/Save/exIt/ASsembly/Display/SRfcon/Redraw <eXit>:

5. Type R for Redraw to redraw the template display.

   The option is used, several lines and point markers are placed in the drawing. Use the Redraw option to clean up the drawing area.

   **NOTE**

   The Display option can be used to redisplay features of the template such as connection points or datum lines. When the options under the Display option are used, several lines and point markers are placed in the drawing.
Importing a Template into a Drawing

To import a template into the drawing

1. Set the template folder using the Set Template Path command if you haven’t done so already.
2. From the Cross Sections menu, choose Templates ➤ Import Template to display the Template Librarian.
3. Select the desired template to import, and then click OK.
4. Pick the insertion point for the template from the drawing. This point corresponds to the finished ground reference point on the template. The command prompts for the type of shoulder to display, cut or fill.
   Shoulder display (Cut/Fill) <Fill>:

   **NOTE** Even if no shoulder subassembly has been attached, you must answer this prompt.

5. Choose the type of shoulder to display by typing either C for cut or F for fill at the command prompt. The command inserts the template with the proper subassemblies into the drawing.
   This template is created from polylines and is placed on the current layer. The template is drawn using the vertical scale factor, which is determined by the horizontal and vertical scales set with the Drawing Setup command. All template features, such as the datum line, are displayed as temporary graphics. These features are erased when commands such as the REDRAW are used.
Creating Finished Ground Cross Sections

After you have created design templates, you need to apply these templates to the existing ground cross sections. Using the Design Control commands, you can apply a selected template or templates to the existing ground surface and match the template into the existing ground.

Prerequisites for Applying Templates to Existing Ground Cross Sections

Before applying the template to the existing ground cross sections, you must have completed the following minimum requirements:

- Define a horizontal alignment
- Sample the existing ground profile from either a surface or from a file
- Create the profile
- Define the vertical alignment for the finished centerline
- Sample the existing ground cross sections from either the surface or a file
- Draw, define, and edit the necessary templates
- Draw, define, and edit the necessary subassemblies

Designing Roadway Slopes with Templates and Cross Sections

You can change the slope settings and the slope control for cross sections by using the Design Control commands. The Depth Slopes command changes the depth slopes settings. The Stepped Slopes command changes the settings for stepped slopes. Use the Surface Slopes command when you want to change the settings for surface slopes.

Changing the Slope Settings

The Edit Design Control command creates cross sections using the information set in the Design Control Editor. When calculating depth slope, stepped slope, or surface slope information, it also uses parameters set with the Depth Slopes, Stepped Slopes, or Surface Slopes commands. For example, a fill situation of eight feet may use a different slope than a fill situation of five feet.
To change the depth slope settings

1. From the Cross Sections menu, choose Design Control ➤ Depth Slopes to display the Depth Control Editor dialog box along with the current depth control values.

These values are used in conjunction with the depth control slope type set using the Edit Design Control command. Depths are measured relative to the existing ground. The first depth should always be zero (0). The slopes that are entered are applied from the depth they are associated with, to the next depth below. Depths are always presented in a sorted order. When you add a new depth, the command automatically inserts it in the proper place.

The typical and maximum slopes for depth slopes work the same as with simple slopes. The typical slope value is used except when ROW control is selected and the slope catch point exceeds the ROW offset. The slope is increased so that the catch point is located at the ROW offset unless it exceeds the maximum slope, in which case the maximum slope is held and the catch point exceeds the ROW offset.

The information generated in the Depth Control Editor dialog box is stored in an ASCII file named after the current alignment with the .dcn file extension. This file is saved in the \align subfolder of the project folder. The information saved in this file can be edited using any text editor, provided it is saved as ASCII text and can be used with any other cross section command. Comments can also be added to the data. Use a semi-colon (;) or a pound sign (#) to indicate the beginning of a comment.

2. Use the Vertical Depth Measure check box to determine how the depth is measured for depth control slopes.

By default, the Vertical Depth Measure check box is cleared:
- When the Vertical Depth Measure check box is cleared, the depth is measured between the connection point out of the template and the catch point. To do this, the typical slope that is entered in the Slope Control dialog box with the Edit Design Control command is used as the initial slope. A depth is calculated along the typical slope then the slope is adjusted based
on the depth control criteria starting with the first slope listed in the Depth Control Editor. It is recommended that the flattest slope in the Depth Control Editor be used for the typical slope.

- When the Vertical Depth Measure check box is selected, the depth that is used to calculate the slope is measured from the connection point out of the template vertically to the existing ground.

3 Use the Pin Override check box to determine how slopes are matched to the existing ground in cases where the specified slope exceeds the edge of existing ground. By default, the Pin Override check box is cleared:

- When the Pin Override check box is cleared, and the starting slope in the Depth Control Editor exceeds the edge of existing ground, the slope is pinned into the edge of existing ground.
- When the Pin Override check box is selected, the command searches through the depth control criteria and applies the first slope that will match into the existing ground without exceeding the edge of existing ground. If no slope is found in the depth control criteria which matches within the edge of existing ground, then the slope is pinned into the edge of existing ground.

4 Enter values for the depth, the fill typical and maximum slopes, and the cut typical and maximum slopes in the Depth Control Editor Table.

Use the following buttons to move around in and edit the table:

- Use the navigation buttons to move through the lines and pages of slope information. For a description of the navigation buttons, see “Editing the Existing Ground Cross Section Data” in this chapter.
- Click Insert to insert a new depth or enter the new depth in a blank field at the end of the list.
- Click Delete to remove a depth and all its associated information. A warning dialog box is displayed before deleting the depth. Click Yes to delete the selected depth.
- Click Save to save changes without exiting the Depth Control Editor dialog box.

5 Click OK to exit the dialog box, or Cancel to exit the command without making changes.

NOTE: If you make changes in the Depth Control Editor, you must reprocess the cross sections using the Process Sections command.
Changing the Stepped Slope Settings

The stepped controlled slope type is similar to the depth type, except instead of using one slope, the stepped type can change the slope as it passes through the depth range and can add benches at set depths.

To change the stepped slope settings

1. From the Cross Sections menu, choose Design Control ➤ Stepped Slopes to display the Stepped Control Editor dialog box along with the current stepped control values.

These values are used in conjunction with the slopes set with the Edit Design Control command. The information generated in the Stepped Control Editor dialog box is stored in an ASCII file named after the current alignment with the extension .pcn. This file is saved in the \align subfolder of the project folder. You can edit the information saved in this file using any text editor, provided the file is saved as ASCII text. This file can also be used with any other cross section command. You can also add comments to the data. Use a semi-colon (;) or a pound sign (#) to indicate the beginning of a comment.

2. Set the Stepped direction using the Stepped direction check box. Select Hinge to Match to apply the depths from the hinge point towards the match surface. The hinge point is the outer edge of the ditch or, if ditches aren’t being used, the connection point on the template.

The changes in elevation that can be created by the optional benches are not counted in the depth calculations. The depth used at each slope segment is the difference of the current depth and the previous depth. For example, if you enter depths of 5-10-15-25 into the table, the depth of the segments is 5-5-5-10 respectively.

**NOTE**

For more information about the Hinge to Match option and the Match to Hinge option, look up “Change the Stepped Slope Settings” in the online help.
3 Use the table to enter the values for the depth, the fill slope, the cut slope, the base width, and the base grade.

The base width and grade are used to create benches with the stepped slope type. The first depth should be zero (0). Benches are applied at the indicated depth and slopes are applied from the depth they are associated with, to the beginning of the next slope segment below. Depths are always presented in a sorted order. When a new depth is added, the command automatically inserts it in the proper place.

Use the following buttons to navigate and edit the table:

- Use the navigation buttons to move through the lines and pages of slope information. For a description of the navigation buttons, see “Editing the Existing Ground Cross Section Data” in this chapter.
- Click Insert to insert a new depth or enter the new depth in a blank field at the end of the list.
- Click Delete to remove a depth and all its associated information. A warning dialog box is displayed before deleting the depth. Click Yes to delete the selected depth.
- Click Save to save changes without exiting the Depth Control Editor dialog box.

4 Click OK to exit the dialog box, or Cancel to exit the command without making changes.

**NOTE** If you make changes in the Stepped Control Editor, then you must reprocess the cross sections using the Process Sections command.

**Changing the Surface Slope Settings**

Surface slope condition is applicable only when the finished ground cross section is in a cut condition and passes through different layers of soil type. For economic design, each layer of soil may specify different side slopes. In this approach, the slope used at various segments of side slope is determined by the surface type through which the cut slope passes. This is useful for situations in which the cut passes through a layer of rock. This ledge can either be set to follow the surface or it can be set to bench at a specified grade.
To change the surface slope settings

1 From the Cross Sections menu, choose Design Control ➤ Surface Slopes to display the Surface Control Editor dialog box.

This dialog box displays the current surface control values. These values are used in conjunction with the slopes set with the Edit Design Control command.

The information generated in the Surface Control Editor dialog box is saved in an ASCII file named after the current alignment with the .scn file extension. This file is saved in the \align subfolder of the project folder. You can edit the information saved in this file using any text editor, provided the file is saved as ASCII text. This file can also be used with any other cross section command. You can also add comments to the data. Use a semi-colon (;) or a pound sign (#) to indicate the beginning of a comment.

2 Do one of the following to change the surface slope settings:
   - Click New to display the New Surface Values dialog box. Enter the surface name, the slope to apply through that surface, and the width for creating a bench where the surface changes. Select the Grade check box if you want the bench to follow a grade rather than the surface, and then enter the grade value in the edit box. If the Grade check box is cleared, the bench follows the surface.
   - Click Edit to display the Edit Surface Values dialog box where you can edit an existing surface.
   - Click Delete to remove the selected surface. This button removes an indicated surface and all its associated information.
   - Click Save to save changes without exiting the Surface Control Editor dialog box.

3 Click OK to exit the dialog box and save the edits, or Cancel to exit the command without making changes.
NOTE
If you make changes in the Surface Control Editor, then you must reprocess the cross sections using the Process Sections command.

The following illustration shows surface control slopes:

![Surface control slopes](image)

Creating Roadway Transitions with Templates and Cross Sections

To create transition regions for a roadway, such as lane widening, use transition lines. An overview of the steps you need to take to create transitioning are described in the following list:

- Use the Edit Template command to define the transition regions of the template.
- Draw and define the plan view transition lines as alignments if you are using horizontal transitioning. Or, use the Edit Design Control command to define these transitions in an editor dialog box. You can also edit the transitioning for each station with the View/Edit Sections command, and then re-import the edited values back into the plan view of the alignment with the Import Plan Lines command.
- Draw and define the profiles of the transition lines if you are using vertical transitioning. Or, use the Edit Design Control command to define these transitions in an editor dialog box. You can also edit the transitioning for each station with the View/Edit Sections command, and then re-import the edited values back into the profile view of the alignment with the Import Profile command.
- Use the Edit Design Control command to attach the offsets from the horizontal alignments and/or the elevations from the vertical alignments. Or, you can define this information manually for each station with the View/Edit Sections command.
Defining the Transition Regions on a Template

Transition regions are used to stretch templates horizontally and/or vertically in order to accommodate areas where the roadway offsets or elevations are irregular, such as when a road widens for a passing lane. By using transition regions on a template, you do not need to have multiple templates to accommodate these varying conditions. You can define up to sixteen transition regions on a template, eight left and eight right.

The basic rules of defining a transition region are as follows:

- The control point is moved to the required offset and/or elevation when transitioning is applied to the template.
- The region point is the outer edge of the template segment that will stretch when the control point moves.
- To achieve the surface modification when a transition is applied to a template, any surface line that is intersected by the vertical plane of the region point will be modified between that point and the next point on the surface toward the centerline.
- The control and region points can be at the same or at different locations.
- The control point can never be closer to the centerline than the region point.
- Only the top of the subgrade surface definition is modified by the transition (the portion that is drawn before the template is defined). The bottom of the subgrade is still calculated based on its depth and grade criteria.
- The Pinned or Dynamic option only applies to the central region between the innermost left and right transitions.
- The template surfaces can cross the centerline only if the innermost left and right transition regions are Dynamic.
- The transition region cannot stretch toward the centerline if the Constrained option is used.
- The Hold Grade or Hold Elevation option is used when the template is modified by a horizontal transition (offset) only. It is disregarded if a vertical transition is applied.

NOTE: If you have already defined transition regions for a template, then you can view this information by using the Display option of the Edit Template command. Under the Display options, select the TType option. For more information, see “Redrawing the Template Display” in this chapter.
To define template transition regions

1. From the Cross Sections menu, choose Templates ➤ Edit Template to display the Template Librarian dialog box.

2. Select the template you want to insert, and then click OK.

3. Pick the insertion point in your drawing.

   The following prompt is displayed:
   
   Edsrf/SAve/eXit/ASsembly/Display/SRfcon/Redraw <eXit>:

4. Type SR (for Srfcon) to display the Surface Control options:
   
   Connect/Datum/Redraw/Super/Topsurf/TRansition/eXit <eXit>:

5. Type TR to activate the TRansition option to define the transition regions of the template:

   Edit transition region (Left/Right/All/eXit) <eXit>:

6. Select the side of the transition region to define:
   
   - **Right**: The command prompts for the right transition region:
     
     Edit left transition region (1/2/3/4/5/6/7/8/eXit) <eXit>:

   - **All**: The command repeats the definition process for all sixteen (16) transitions. If the All option is in use, press ENTER at the Pick (left/right and appropriately numbered) transition region point prompt to skip individual transitions.

7. Type the number of the transition you want to define (if you selected Left or Right in step 6).
8 Pick the transition region point from your drawing.

To define an area on the template to be stretched, you need to pick two key points on the template for each transition region, the region point and the control point:

- The control point determines the place on the template where the horizontal or vertical alignment is attached. It is the point on the template that is moved to the desired offset or elevation.
- The region point determines the outer edge of the region to be stretched. To achieve the surface modification when a transition is applied to a template, any surface line that is intersected by the vertical plane of the region point is modified between that point to the next point on the surface toward the centerline.

In many situations the control point and region point use the same location. For example, the outer edge of pavement of an asphalt surface that leads up into a crown at the centerline would be defined as both the region point and the control point.

If these points are defined at two different locations, then the region point must always be closer to the centerline than the control point. For example, if you want to stretch a center median island that has a curb structure, you need to locate the control and region points at different locations in order to avoid stretching the curb as well as the median.

If the horizontal transition alignment for the median is defined along the path of the edge of pavement where it meets the face of curb, locate the transition control point at this location. However, if you also located the region point at this same location, the curb structure stretches as the median becomes wider, creating an extremely wide curb.

To force the stretch to be applied at the back of curb, define the region point at the back of curb while maintaining the control point at the face of curb. This situation could also be resolved by defining the horizontal transition alignment along the back of curb that would allow you to define both the region point and control point at the back of curb.

**NOTE** When transitioning is applied to a template, everything on the outside of the transition region will move to follow the transition’s change in offset or elevation.

9 Specify which type of surface transition to use: Dynamic or Pinned.

A typical template has a central portion where the surfaces cross the centerline, such as a median or the traveled lanes of a template without a median. Because the surface crosses the centerline, it can have both a left and right transition control affecting it. For this situation, there are two options that control the way in which the transitioning affects the template surface: Pinned and Dynamic. With the Pinned option, the inner vertex of the region segment is always held while the segment is stretched. With the Dynamic option, the grade of all segments between the control points is held. Each half of the central surface is moved to the specified offset or elevation and then the surfaces are joined by trimming off the overlapping segments or by extending the segments so that they meet. The Dynamic option only affects the central portion of the template and the surfaces must cross the centerline. If the transition lines come together so that the surfaces between the inner most transition lines disappear, then the next transition regions can become dynamic.
When deciding whether to use the Dynamic or Pinned options, it is usually best to use the default value of Pinned. The majority of situations work well using the pinned option.

However, there are a couple of situations where you should use the Dynamic option. Use the Dynamic option when the transition alignment crosses the design centerline alignment. If multiple transition alignments cross the design centerline alignment, then only the first transition region should be defined as dynamic. All other transition regions following the first transition region should be defined as pinned regardless of whether they cross the centerline or not.

When you use the Dynamic option, the center portion of the template will be collapsed or forced to disappear if the two opposing transition region points have the same horizontal location. This is helpful in situations where a median island is designed to taper in width and then eventually disappear.

You achieve this by defining opposing transition alignments such as L1 and R1 to follow the proposed edge of median island. If the transition alignments L1 and R1 fall exactly on one another, then the median island is completely removed from the cross sections at these points. Collapsing template areas only works between opposing transition regions such as L1 to R1. If R1 and R2 were defined to fall on top of each other, the template areas do not collapse, but are stretched together to a single point.

**NOTE** The Pinned and Dynamic options only apply to the transition regions between the innermost left and right transitions where the transition region surfaces meet at centerline.

10 Specify a transition region type:

- Type **Free** to specify a region that can move toward or away from centerline.
- Type **Constrained** to specify a region that can only be stretched away from the center of the template and not towards it. This allows minimum widths of regions to be maintained.

11 Pick the transition control point from your drawing.

12 Specify the type of transition to hold:

- Type **Grade** to hold the grade.
  
  Holding the grade is often used for maintaining the cross slope of the traveled lane on a road template when that lane is widened. Press ENTER to select the Grade option.

  The following prompt is displayed:

  **Pick transition reference point:**

  Pick the transition reference point from your drawing. This point is used to determine what grade is held by the template segment as it is being stretched. The transition reference point does not need to reference a point on the template. It can exist in space. Use AutoCAD object snaps to select the transition reference point accurately.

- Type **Elevation** to hold the elevation that stretches the region horizontally along the X-axis and changes the grade of the transition region.

When only horizontal transitioning is applied to a template, the elevation of the control point can be held or the grade of the transition region can be held.
If vertical transitioning is applied, this setting is ignored and both the grade and elevation change as required.

13 Repeat steps 7 through 12 to define the next transition region, or press ENTER twice to exit the command.

If you selected All in step 6, repeat steps 8 through 12 to define the next transition region. Press Esc to exit the command at any point.

The following illustration shows the region point and the control point, as well as the pinned and dynamic options:

![Pinned and dynamic transition options](image)

The following illustration depicts the effects of the Hold Grade and Hold Elevation settings:

![Hold grade and hold elevation](image)
The following illustration shows an example of a median collapsing at the point where the transition regions meet:

![Diagram](image_url)

Dynamic transition where median crosses the centerline

**Attaching the Horizontal Alignment Transitions to Cross Sections**

You can use the Design Control dialog box to attach horizontal transitions to the cross sections.

The alignments you attach can be transition lines, ditches, or right-of-ways. The transition lines are attached to the transition control points you define on the template.

**Prerequisites for Attaching the Horizontal Transitions to Cross Sections**

- In order to attach a horizontal alignment to the cross sections, you must first define a horizontal transition alignment using either the Define From Objects or Define From Polyline command. You draw and define a transition alignment just like you do for a centerline.
- For transitions to be applied to the template, the appropriate transition regions must have been defined on the template using the Edit Template command.
Attaching the Horizontal Transition Alignments to Cross Sections

To attach the horizontal transition alignments to cross sections:

1. From the Cross Sections menu, choose Design Control ➤ Edit Design Control to display the Enter Station Range dialog box.

   ![Enter Station Range dialog box]

2. Enter the station range you want to edit in the Enter Station Range dialog box, and then click OK. The Design Control dialog box is displayed.

   ![Design Control dialog box]

3. Click Attach Alignments from the Design Control dialog box to display Attach Alignments dialog box.

   ![Attach Alignments dialog box]
This dialog box has buttons you can select to attach defined horizontal alignments as transitions, ditches and rights-of-way.

4 Click the button indicating the horizontal alignment transition to attach.

The command changes to the AutoCAD graphics screen and prompts for the selection of the alignment to be attached. The wording of the prompt depends on the transition to be attached. For example, if you selected the One button on the left side of the dialog box, the following prompt is displayed:

Select first left offset alignment:

You can either select the alignment graphically, or press ENTER and select the alignment from the Alignment Librarian dialog box. Select a numbered button to attach a transition line to the numbered transition control point on the template. Selecting the One button on the right side, for example, attaches the alignment you select in the next step to the first transition control point on the right side of the template. ROWs and Ditches are separate because they are not defined as part of the template.

5 Select the alignment to attach.

The Attach Alignments dialog box is redisplayed.

6 Select another transition to attach, or click OK to exit the dialog box.

7 Click OK from the Design Control dialog box to process the sections.

The Process Sections dialog box is displayed.

8 Click OK to exit the command after the sections are processed.

The offsets at each sampled cross section are calculated from the horizontal alignment and stored.

**NOTE** You can turn off an attached alignment using the check boxes in the Transitions dialog box.

The transitions are not dynamically linked to the editor. If you make any changes to an attached alignment, you must re-attach it using the Attach Alignments option.

### Attaching the Vertical Transitions to Cross Sections

Using the Design Control dialog box, you can also attach vertical transitions to the cross sections. These profiles can represent ditches, subgrade surfaces, or any of eight transition regions. For more information, see “Using Ditch or Transition Profiles When Processing the Cross Sections” and “Attaching the Subgrade Vertical Alignments to the Cross Sections” in this chapter.

### Prerequisites for Attaching the Vertical Transitions to the Cross Sections

- Before you can attach a vertical transition line, you need to draw and define it using the Ditches and Transitions section of the Profile menu. Set the current layer, draw the alignment, and define the alignment. This is the way
that the vertical transitions and ditches acquire their unique numbered definitions.

- For transitions to be applied to the template, the appropriate transition regions must have been defined on the template using the Edit Template command.

### Attaching the Subgrade Vertical Alignments to the Cross Sections

You can also draw, define, and attach a vertical alignment to the template subgrade surface apex. The profile does not support subgrade profile definitions, but you can use one of the 16 available transition profile definitions if it’s not being used to control a template transition point.

Draw this alignment for the elevation at the apex of subgrade. Define this alignment as a numbered transition line. To attach the alignment, select the Attach Profiles button. A dialog box displays and you can select the subgrade alignment. You must remember the transition number you used when you defined it.

### Modifying Design Control

To apply design control to the cross sections, you first need to use the Edit Design Control command. When you use the Edit Design Control command, you make edits through the Design Control Editor.

You can use the Edit Design Control command to make changes to a range of stations. When you do this, the values that appear in the dialog are for the first section in the selected range and don’t necessarily apply to the entire range. For example, if the ditch elevations were attached from the profile, each section’s ditch elevation would be different but only the elevation for the first section in the range would be displayed. Therefore, to edit the ditch elevations for the appropriate section, use the View/Edit Sections command.

When you are using the Edit Design Control command, only the parameters that you change are reapplied to every section in the specified range. For example, if you only wanted to change the ditch width, you would select the Edit Design Control command, specify the station range, then select the Ditch option and type in the new width value. When you click OK to exit the command, the program determines the parameters that you have changed and modifies the sections accordingly.

In this example, it changes the ditch width then recalculates the match slopes based on the new width. However, the ditch elevation remains as it was before this command was executed, since you did not change it in the dialog box. This is an important point to understand when working with Edit Design Control and View/Edit Sections commands. Because of this, any edits you make to the ditch elevation at individual stations with the View/Edit Sections command are not overwritten.
NOTE  You can access a similar Control Editor, with options for editing the template, ditch, and slope control, when you use the View/Edit Sections command. You can also use the View/Edit Sections command to make edits graphically by picking points on the display of the cross section. However, the View/Edit Sections command only works on one station at a time.

Specifying the Design Control Values for Templates

To specify the design control values for templates

1. From the Cross Sections menu, choose Design Control ➤ Edit Design Control to display the Enter Station Range dialog box.

2. Enter the station range you want to edit, and then click OK to display the Design Control dialog box.

3. Click the Template Control button to display Template Control dialog box.

Use this dialog box to set the parameters used to apply a template to a range of stations. Any changes made to the settings using this option reprocesses the information for the affected stations. The top frame of this dialog box shows the current station range. The bottom frame displays the options for template control.
4 Select the template you want to use.

In the Template Librarian dialog box, click Select to the right of the Template box and choose a template.

Alternatively, you can type the template name directly in the in the Template box, if you know the name.

**NOTE**

NULLT is a valid template that consists of a single point. Select NULLT if you don’t need to use a template.

When you select the template, the datum line is automatically set to datum #1. This datum line is used for the cut and fill volume calculations. When you defined the template, if it only had normal surfaces, then you were prompted to select the points that defined the datum. If the template had a subgrade surface, the datum line was defined automatically. Use the Edit Template command to add additional datum line definitions to the template.

5 Enter the datum number.

If you have defined more that one datum, do one of the following:

- Click Select to display the Datum Librarian dialog box.

  Alternatively, you can type the datum number directly in the Datum box, if you know what it is.

- Select the datum number you want to use from the scroll list.

  As you select a number, the datum and a graphic representation of the template is displayed in the image tile. This is only a representation of the template and the datum. It is only meant to aid in selecting the correct datum and is not drawn to scale. Click OK to select the datum and return to the Template Control dialog box.

6 Edit the template superelevation parameters, if necessary.

**NOTE** The options in this dialog box are enabled only if the Superelevation Calculations check box is selected in the Superelevation Control dialog box.

7 Edit the template transitions, if necessary.

8 Click OK to return to the Design Control dialog box.

**Editing the Transitions**

**To edit the transitions from the template control dialog box**

1 From the Cross Sections menu, choose Design Control ➤ Edit Design Control to display the Enter Station Range dialog box.

2 Enter the station range, and then click OK to display the Design Control dialog box.

3 Click Template Control to display the Template Control dialog box.

4 Click Edit Transitions at the bottom of the Template Control dialog box to display the Transitions dialog box.

When you use the Edit Design Control command to attach a horizontal or vertical transition alignment to a template, the appropriate check box in the Transitions dialog box is selected and the offset or elevation is listed in the edit
Since this value is for the first station in the station range only, you probably do not want to edit it here. If you do, then the same value is applied to the entire station range. To edit the transition values for individual stations, use the View/Edit Sections command. The Transitions dialog box displays the left and right transition offset and elevation values.

If you attach a horizontal alignment, then the offset value is listed in the First Offset edit box, for the right or left side accordingly. A negative offset causes the transition control point on the template to cross to the opposite side of the centerline.

If you attach a vertical alignment, then the elevation value is listed in the First Elevation edit box.

The Transitions dialog box supports up to eight transitions per side. The initial Transitions dialog box displays the first through fourth transition. Click the More button to work on the fifth through eighth transitions.

The Subgrade transition elevation box in the Transitions dialog box records the elevation of the subgrade at the centerline at the specified station. To transition the subgrade elevation, you can draw a vertical alignment in profile view and define it as a vertical transition line. Then you can attach this alignment to the template using the Attach Profiles option of the Edit Design Control command.

Select or clear the offset distances and elevations using the check boxes. If you clear a check box, the transitioning is not applied when the sections are reprocessed.

Edit the values in the edit boxes to the right of each check box.

The offsets and elevations are used to control the points on the template that you defined as transition points. A negative offset distance value forces that offset to the opposite side of the centerline in order to force features, such as medians, across the centerline. These are actual offsets rather than relative.

Although you can define transition offsets and elevations through the Transitions dialog box, the standard method for defining transitions is to use the Attach Alignments and Attach Profiles dialog boxes that are accessed from the Design Control dialog box. These boxes assign the offset distances and elevations graphically based on defined alignments. Then you can use the Transitions dialog box, accessed through the View/Edit Sections command, to edit individual sections.

Click OK to close the Transitions dialog box. The sections are reprocessed.

Click OK to exit the command when the sections are done processing.

**Editing the Template Superelevation Parameters**

The first time you access the Edit Design Control command to apply the template to the cross sections, the Superelevation options are not accessible until superelevation has been applied to the cross sections with the Superelevation Parameters command.

Use the Edit Design Control command to modify the parameters for a range of stations. You can, in a situation where superelevation wasn’t required, use the Superelevation Parameters command to turn on superelevation but set the method to None for any curves. The Edit Design Control command displays the
grade of the superelevation region which, in turn, can be changed. The template may have been drawn with the grade at 2.0%. You can use this method to change the grade to 1.5%.

**To edit the template superelevation parameters using the Edit Design Control command**

1. Use the Pivot list to set the pivot point.
   You can set the pivot point to the left or right edge of the superelevation zone, or you can set it to the centerline.

2. Set the grades of the template superelevation zones in the Left, Center, and Right boxes.
   Enter these grades as decimal values rather than percentages. The values display as ft/ft (e.g. 0.02 = 2%). A zero value in either the left, center, or right superelevation zones indicates the place where the template is held (hinge point).

   The values for cross grades calculated by the Slope Control dialog box are displayed. The raw condition is used in the cross grades calculations.

3. Select the Rollover check box, and then enter the rollover value in the edit box.
   The rollover rate is the maximum allowable grade change between the superelevation region and the rollover region. Enter the percentage as a decimal value in the center edit box, such as .06 for 6 percent. The Superelevation Rollover scroll box indicates the side of the template that shoulder rollover is applied to.

4. From the Subgrade Superelevation Method list, you can select the following types of superelevation that are applied to the subgrade surface of the template:
   - **None**: The subgrade surface is not superelevated, and maintains its location.
   - **Parallel**: The subgrade surface superelevates parallel with the normal surface of the template for the entire width of the subgrade.
   - **Fixed Break**: Using this option, the subgrade below the template superelevation region superelevates, and the subgrade outside of the superelevation region won’t. When you define a template, you can use the subgrade break point offset modifier option to set the location of this break point in relation to the outer superelevation point. If the default of 0.00 is used, then the break point occurs directly below the outer superelevation point. If a positive value is entered then the break point is shifted by that amount toward the centerline and a negative value shifts it away from centerline.

   **NOTE** Because the subgrade surface is often at a steeper grade than the normal surface, enter values for the Transition In and the Transition Out under in the Superelevation Curve Settings dialog box. These distances control what distance it takes for the subgrade surface to adjust to a grade where it is parallel with the normal surface.
Specifying the Design Control Values for Ditches

**NOTE** When you attach a vertical alignment for a ditch, the ditch elevations are recorded in the Ditch Control Editor. The Ditch Control Editor dialog box is split up into left and right ditches.

**To specify the design control values for ditches**

1. From the Cross Sections menu, choose Design Control ➤ Edit Design Control to display the Enter Station Range dialog box.
2. Enter the station range, and then click OK to display the Design Control dialog box.
3. Click Ditches to display the Ditch Control dialog box.

4. Set the ditch type for each side by using the following **Type** list:
   - **None**: Turns the ditch type off completely.
   - **Cut**: Defines the ditch for a cut situation.
   - **Fill**: Defines the ditch for a fill situation.
   - **Cut/fill situations**: Defines the ditch for a cut and fill situation.

5. Define the ditches using foreslope and centerline offset, or one of these two parameters with either depth or base elevation.
   - Select or clear the foreslope, centerline offset, depth, depth from hinge, or base elevation check boxes. Enter values for the selected boxes:
     - **Foreslope**: Enter the slope from the template connection point to the ditch.
     - **Centerline Offset**: Enter the distance from the centerline to the inner edge of the ditch.
     - **Depth**: Enter the vertical distance of the ditch, which can be measured from either the top of the foreslope or the finished ground reference point of the template. Enter the depth of the ditch as a positive value.
     - **Depth from Hinge**: This check box is used in conjunction with the Depth value and is only available after you have selected the Depth value.
The Depth from Hinge check box controls how the depth of the ditch is measured. When this option is selected, the depth of the ditch is measured down from the top of the ditch foreslope. When this option is cleared, the depth is measured down from the finished ground centerline reference point.

- **Base elevation**: Enter the true elevation of the bottom of the ditch. If you use this option, the elevations are usually retrieved from the profile using the Attach profiles option.
- **Base Width**: Enter the width of the bottom of the ditch.

**NOTE** You can only use two of the ditch parameters at a time (except when the depth from hinge is selected, which makes three items selected.) If you enter less than two parameters, ditches are not applied. If more than two options are selected, then a warning message is displayed and you need to correct the situation. The command automatically calculates the other parameters.

6 When you have entered the ditch parameters, click OK to close the Ditch Control dialog box.

7 Click OK from the Design Control dialog box to process the sections.

The Process Sections dialog box is displayed.

8 Click OK to exit the command.

The following illustration shows the difference in depth calculations based on the setting of this check box:

![Ditch design parameters](image)

**Specifying the Design Control Values for Sideslopes**

Using the Design Control dialog box, you can set design control values for sideslopes. If you plan on using either the stepped, surface, or depth slope types, then you first need to define the required slope tables. For example, if you plan on using depth-controlled slopes, first use the Depth Slopes command to define the slope parameters.
To specify the design control values for sideslopes

1. From the Cross Section menu, choose Design Control ➤ Edit Design Control to display the Enter Station Range dialog box.
2. Enter the station range, and then click OK to display the Design Control dialog box.
3. Click Slopes to display the Slope Control dialog box.

The Slope Control dialog box displays the cross section information for the specified range of stations. Use this dialog box to set the slope parameters for matching the template surfaces to the existing ground. The section processing determines where the end condition lies for each side of the template and applies either the cut or fill information.

4. Select or clear the Match Slopes OFF check box:
   - Clear the Match Slopes OFF check box to turn on all slopes for a specified range of stations. The slopes are turned on by default.
   - Select the Match Slopes OFF check box to turn off all slopes for a specified range of stations.
   
   This option is useful when you are working with elevated roadways where the only volumes of interest are the proposed materials, such as when a section of the roadway passes over a bridge. No cut and fill areas or volumes are generated for the range of stations where the match slope is turned off.

5. Select the Fill type for both the Left and Right slopes:
   - **Simple**: Choose the simple type to use a straight slope from the connection point out of the template or the ditch base to where the slope matches into the existing ground. When dealing with topsoil material, the slope is a straighter line so the soil remains somewhat stationary. Right-of-way control or benching can be applied to simple slopes.
   - **Depth**: Choose the depth type to use a single slope that varies for different depths. For example, a fill situation of eight (8) feet may use a different slope than a fill situation of five (5) feet. Right-of-way control or benching can be
applied to depth control slopes. Enter the depths and slopes using the Depth Slopes command.

- **Stepped**: Choose the stepped type to use variable slopes and benches as the slope passes through different variable depth ranges. When the right-of-way hold is on and the stepped slope exceeds the right-of-way, the stepped slope values are ignored and a simple slope pins into the right-of-way. The benching option (in the Design Control dialog) cannot be applied to stepped slope types because benching is defined as part of the stepped slope criteria. Enter the depths, slopes, bench widths, and bench cross grades using the Stepped Slopes command.

6 Select the Cut type for both Left and Right slopes:

- **Simple**: Choose the simple type to use a straight slope from the connection point out of the template or the ditch base to where the slope matches into the existing ground. When dealing with topsoil material, the slope is a straighter line so the soil remains somewhat stationary. Right-of-way control or benching can be applied to simple slopes.

- **Depth**: Choose the depth type to use a single slope that varies for different depths. For example, a fill situation of eight (8) feet may use a different slope than a fill situation of five (5) feet. Right-of-way control or benching can be applied to depth control slopes. Enter the depths and slopes using the Depth Slopes command.

- **Stepped**: Choose the stepped type to use variable slopes and benches as the slope passes through different variable depth ranges. When the right-of-way hold is on and the stepped slope exceeds the right-of-way, the stepped slope values are ignored and a simple slope pins into the right-of-way. The benching option (in the Design Control dialog box) cannot be applied to stepped slope types because benching is defined as part of the stepped slope criteria. Enter the depths, slopes, bench widths, and bench cross grades using the Stepped Slopes command.

- **Surface**: Use the surface slope type to apply different slope conditions through different types of existing ground material (for example, rock, gravel, and dirt). Multiple existing ground cross section surfaces are defined by sampling from multiple surfaces or by defining subsurface depths with the Edit Sections command. The surface the cut slope is passing through determines the slope used. The surface type can also be used to create ledges at places where the surface changes. This is useful for situations in which the cut is passed through a layer of rock. This ledge can either follow the surface or bench at a set grade.

    When the right-of-way hold is on and the surface slope exceeds the right-of-way, the surface slope values are ignored and a simple slope pins into the right-of-way. Set the surface name, slope, and ledge width using the Surface Slopes command. The benching option (in the Design Control dialog box) cannot be applied to surface slope types since benching is defined as part of the surface slope criteria.

7 If you are using simple slopes, then specify the typical and maximum slope values. These parameters set the slopes for cut and fill situations on the left and right side of the template. The typical and maximum slopes are used by simple slopes. The typical slope is also used to determine the depth criteria in depth-controlled slopes condition. The other two slope options only use these values when the necessary data has not been inserted using the appropriate slope editor. With simple slopes, the typical design slopes are used wherever possible.
NOTE  The maximum design slopes are only used in cases where the typical design slope fails to match to existing ground within the right-of-way when the right-of-way hold is selected. They are also used when the typical design slope fails to match to existing ground within the sample swath width when the right-of-way hold is cleared.

If the design slope fails to match within the limitations of the existing ground, the template is forced to tie into the edge of the existing ground using whatever slope is necessary. If this happens, resample existing ground using a wider swath width and reprocess the cross sections.

If ditches are not used, the slope starts from the outer connection point of the outermost subassembly and matches into the existing surface. If ditches are used, the slope starts from the outer edge of the defined ditch and matches into the existing ground. A slope of zero (0) creates a vertical line.

NOTE  It is advisable to specify proper values of typical and maximum slopes, even if you are using depth controlled slopes – as the depth criteria calculations are based on the typical slopes entered here.

8 Specify the right-of-way values:

- **Hold check box**: Select the Hold check box to use the typical slope, unless it exceeds the right-of-way offset. If this occurs, then the slope matches into the right-of-way line and increases the slope. If the increased slope is steeper than the maximum slope specified, then the right-of-way is ignored and the slope applied becomes the maximum slope specified. Clear the Hold check box to use only the typical slope.

- **Offset**: If you specify an offset distance here, the offset distance remains constant throughout the range of stations. Alternatively, defined horizontal alignments can be specified to graphically indicate the offset distances using the Attach Alignments option from the Design Control dialog box. This is useful not only to define the right-of-way graphically, but also ditches and transition alignments. By attaching alignments to the offset distances, transitioning and stretching can be dealt with graphically rather than mathematically.

- **Type of Hold**: Use maximum slope (default) or Override Maximum Slope. When Use Maximum Slope is selected, the ROW line forces the slope to become steeper and meet existing ground at the ROW line, until the maximum slope is reached. The slope does not become any steeper than the maximum slope, regardless of the ROW width. When Override Maximum Slope is selected, the ROW offset forces the slope to continually become steeper to match existing ground at the ROW line, regardless of what is entered as the Maximum slope value.

NOTE  The right-of-way hold is used in conjunction with the typical and maximum slopes.

9 Click OK to return to the Design Control dialog box.

10 Click OK to process the sections to display the Process Sections dialog box.

11 Click OK to exit the command.
Specifying the Design Control Values for Benches

To specify the design control values for benches

1. From the Cross Section menu, choose Design Control ➤ Edit Design Control to display the Enter Station Range dialog box.
2. Enter the station range, and then click OK to display the Design Control dialog box.
3. Click Benches to display the Bench Control dialog box.

You can use Benches in cut situations, fill situations, cut and fill situations, or turn them off completely. You can apply benches to simple or depth control slopes. Each of the benches are either sloped in or sloped out, depending on the
amount of water present in the area. A bench that slopes inwards “pools” water and drains it off to the side. A bench that slopes outward causes water to dribble down the hill. For more information on benching, see “Benching Notes” in this chapter.

The slopes between benches are defined by the simple or depth slope settings:

- **Type**: Select the type of bench.
- **Height**: Enter an absolute value specifying where to bench (the vertical distance between benches).
- **Width**: Enter the width of the bench.
- **Grade**: Enter the grade along the bench. A positive bench indicates the bench is sloped upwards as the bench moves away from the template. A negative grade indicates the bench is sloped downwards as the bench moves away from the template.

4 Specify the Left and Right Bench values.
5 Click OK to return to the Design Control dialog box.
6 Click OK to process the sections to display the Process Sections dialog box.
7 Click OK to exit the command.

**Benching Notes**
The following are rules applied to benching:

- Benching parameters are ignored if you are using stepped or surface slopes. You can only apply benches to simple or depth slopes.
- If existing ground is crossed in the middle of the bench, the command matches into the existing ground without benching at that point. Therefore, the height at that point may be higher than the defined height.
- If the right-of-way hold is on and the benched typical slope exceeds the right-of-way, and also if only the benched maximum slope fall behind the right-of-way then benches are turned off and simple slopes pin into the right-of-way. In the same case, if benched maximum slope exceeds the right-of-way, then the benches are applied with maximum slope condition.
- If the right-of-way hold is off and the benched typical slope exceeds the edge of existing ground, then benches are turned off and the simple typical slope is used. If the simple typical slope exceeds the edge of existing ground, then the slope is pinned into the edge of existing ground. If this happens, you can resample the alignment from the Cross Sections menu by choosing Existing Ground ➤ Sample From Surface command and specify a larger swath width.
- You can use benches in conjunction with simple and depth slope types. If you are using a depth slope type, the depth determines the slope between benches. Benches are ignored with the stepped and surface slope types. If a stepped or surface slope type is indicated and benching is on, then the benching values are not used. Stepped and surface slopes have their own benching capabilities.
Using Ditch or Transition Profiles when Processing the Cross Sections

Use the Design Control dialog box to attach profile transitions to the cross sections. These profiles can represent ditches, subgrade surfaces, or any of eight transition regions.

To use profiles when processing cross sections

1 Draw and define the vertical transition line using the Ditches and Transitions section of the Profile menu. Set the current layer, and then draw and define the vertical transition lines. This is the way that the vertical transitions and ditches acquire their unique numbered definitions.

2 Define the appropriate transition regions on the template using the Edit Template command.

3 From the Cross Sections menu, choose Design Control ➤ Edit Design Control to display the Enter Station Range dialog box.

4 Enter the station range, and then click OK to display the Design Control dialog box.

5 Click Attach Profiles to display the Attach Profiles dialog box.

You can use this dialog box to import ditch or transitions elevations from an existing profile.

When you defined the vertical ditch or transition line you specified whether it was the right or left ditch, or a numbered transition line. Because of this, you can select the numbered button (or the ditch button) to attach the alignment. In this way, attaching a profile differs from attaching a horizontal alignment, where you select a numbered button, and then you are prompted to select an alignment.

6 Select the button that indicates the transition from which the elevations will be attached.

The command retrieves the elevations from the appropriate profile. The elevations at each sampled cross section are calculated from the transition profile and stored. If a profile has been attached, it can be cleared using the check boxes in the Transitions dialog box.
7 Click Subgrade to attach the subgrade profile.

This task is similar to attaching a horizontal alignment to the cross sections since you are prompted to select the alignment. You can select the subgrade alignment graphically, or press ENTER to choose one from the Alignment Librarian dialog box.

**NOTE** To apply transitions to the template, the appropriate transition regions must have been defined on the template using the Edit Template command.

8 Click OK to exit the Attach Profiles dialog box.

The Design Control dialog box is redisplayed.

9 Click OK to process the sections. The Process Sections dialog box is displayed.

10 Click OK when the sections are processed to exit the command.

**NOTE** The profiles are not dynamically linked to the editor. If you make any changes to the profiles, they must be reattached using the Attach Profile option.

Now that you have attached elevations using the Attach Profiles option, you can edit the transition line elevations for individual sections using the View/Edit Sections command, or for a range using the Edit Design Control command.

To edit the ditch elevations, you can use the ditch editing options of the View/Edit Sections command, or you can use the ditch control editor in the Edit Design Control command.

### Creating the Roadway Superelevation with Templates and Cross Sections

You can use the Templates commands on the Cross Sections menu to create roadway superelevation with templates and cross sections. You can also change the superelevation control values and edit the superelevation for either a range of stations or one section at a time.

### Defining the Superelevation Regions on a Template

You must define superelevation regions in order to apply superelevation to the template with the Superelevation Parameters command.

**To define the superelevation regions on the template**

1. From the Cross Sections menu, choose Templates ➤ Edit Template.
2. Select the template you want to insert and pick an insertion point.

The following prompt is displayed:

```
Edsr/SAve/eXit/ASeembly/Display/SRfcon/Redraw <eXit>:
```
3 Type **SR** to activate the Surface Control options to redefine the template superelevation regions.

The **SRfcon** option displays the following prompt:

```
Connect/Datum/Redraw/Super/Topsurf/TRansition/eXit <eXit>:
```

4 Type **S** for the **Super** option to define the template superelevation regions.

The following prompts are displayed in turn:

```
Outer left superelevation point:
Inner superelevation reference point:
Outer rollover point:
Outer right superelevation point:
Inner superelevation reference point:
Outer rollover point:
```

5 Select the points to define the left and right superelevation regions.

Define the left superelevation region first, followed by the right superelevation region. When defining the region, pick the outer edge of the region, and then the inner edge using AutoCAD object snaps. All surface segments between these region points superelevate.

The grade between the two points is used as the base grade for the normal crown condition when calculating superelevation.

After picking the two region points, select the outer edge of the rollover region if required. If the template does not have a shoulder that requires a rollover region, then click Enter at the rollover prompt for None.

6 Press ENTER to exit the command when you are finished picking the points.
Changing the Superelevation Control Values

To change the superelevation control values

1. From the Cross Sections menu, choose Design Control ➤ Superelevation Parameters to display the Superelevation Control dialog box.

2. Under Superelevation Toggles, select or clear either the Superelevation calculations check box or the Crown removal by runout distance check box.

3. Select one of the following Superelevation Control options:
   - **Edit Data**: For more information, see “Editing, Inserting, or Deleting a Superelevated Curve” in this chapter.
   - **Import Alignment**: For more information, see “Importing a Superelevated Horizontal Alignment After Editing It” in this chapter.
   - **Settings**: For more information, see “Changing the Superelevation Settings” in this chapter.
   - **Methods**: For more information, see “Displaying the Superelevation Methods” in this chapter.
   - **Output**: For more information, see “Outputting the Superelevation Data” in this chapter.

4. Click OK to close the Superelevation Control dialog box.
   
   If you have made any changes through the Superelevation Control dialog box, then you are prompted to save your changes.
Changing the Superelevation Settings

When you change the superelevation settings, you apply a set of instructions going into a curve and another set for coming out of a curve.

To change the superelevation settings

1. From the Cross Sections menu, choose Design Control ➤ Superelevation Parameters to display the Superelevation Control dialog box.
2. Click Settings from the top group of buttons to display the Superelevation Curve Settings dialog box.

3. Under Curve Edit, enter the following settings:
   - **Start sta**: The starting station is dependent on the alignment being edited. Since this dialog box is used for setting information, this value is always zero (0) and cannot be edited.
   - **End sta**: The ending station is dependent on the alignment being edited. Since this dialog box is used for setting information, this value is always zero (0) and cannot be edited.
   - **Method**: This popup list displays the superelevation methods available with Civil Design. For more information, see “Superelevation Methods” in this chapter.
   - **E value**: The value you enter in this edit box is the maximum crossfall value for the fully superelevated template.
   - **Direction**: This popup list displays the directions for the curve. The direction of curvature can be either right or left, and is based on station progression. The direction of curvature should not be edited unless curve information is inserted manually.
   - **Rollover**: To apply rollover to the template, select the Rollover check box and enter the rollover percent grade in decimal form. For example, type a six percent grade as .06. This grade is the maximum difference between the grades of fully superelevated road surface and the shoulder. The shoulder is represented by the rollover points you select when you edit the template to define the superelevation regions.
4 Under Transition In and Transition Out, enter the following values:

- **Runout**: Enter the Transition In and Transition Out runout distance in the respective edit boxes.
- **Runoff**: Enter the Transition In and Transition Out runoff distance in the respective edit boxes. The runoff value controls the distance it takes to transition from the maximum superelevation grade of one curve to the maximum superelevation grade of a second curve. If the maximum superelevation grade for both curves are the same, then 0 can be entered for the runoff distance because no transition is required.
- **% runoff**: Enter the percentage of runoff for the curve in this edit box. The percentage of runoff is the amount of runoff length that occurs before the actual curve is encountered.

5 Choose a Subgrade Superelevation Method from the list. For more information, see “Methods for Superelevating the Subgrade” in this chapter.

6 Under Transition In and Transition Out, enter a distance. These distances control what distance it takes for the subgrade surface to adjust to a grade where it is parallel to the superelevation region. This Transition In distance is applied before the start of the runout and the Transition Out is applied after the end of the runout.

7 Click OK to accept the edits you made in the Superelevation Curve Settings dialog box.

8 Click OK to close the Superelevation Control dialog box.

9 Click Yes to save your changes.

The following illustration shows superelevation parameters:

![Superelevation parameters](image)

**Methods for Superelevating the Subgrade**

- **None**: When this option is selected, the subgrade is not superelevated.
- **Parallel**: When this option is selected, the subgrade surface superelevates parallel to the superelevation region of the template for the entire width of the subgrade, from the center to its outer edge.
- **Fixed Break**: When this option is selected, the subgrade below the template superelevation region superelevates parallel to the superelevation region, and the subgrade outside of the superelevation region does not superelevate. When you define template superelevation regions, you can use the subgrade break point offset modifier option to set the location of this break point in relation to the outer superelevation region point. If the default of 0.00 is
used, then the break point occurs directly below the outer superelevation point. If a positive value is entered, then the break point is shifted by that amount toward the centerline and a negative value shifts it away from centerline.

### Superelevation Methods

- **Superelevation Method A**: This superelevation method revolves a crowned pavement section about the centerline. Both edges of pavement change elevation to attain proper superelevation. The following illustration shows superelevation method A:

![Superelevation Method A Diagram](image)

- **Superelevation Method B**: This superelevation method holds the inside edge of pavement of a crowned pavement section and forces the outside edge of pavement up. The following illustration shows superelevation method B:

![Superelevation Method B Diagram](image)
- **Superelevation Method C**: This superelevation method holds the outside edge of pavement of a crowned pavement section and forces the inside edge of pavement down. The following illustration shows superelevation method C:

![Diagram of Superelevation Method C]

- **Superelevation Method D**: This superelevation method holds the outside edge of a section of non-crowned pavement with a straight cross slope and forces the inside edge of pavement down. The following illustration shows superelevation method D:

![Diagram of Superelevation Method D]
Superelevation Method E: This superelevation method holds the inside edge of a section of a non-crowned pavement with a straight cross slope and forces the outside edge of pavement up. The following illustration shows superelevation method E:

![Superelevation Method E Illustration]

**Editing the Superelevation for One Section at a Time**

**To edit the design control for one section at a time**

1. From the Cross Sections menu, choose View/Edit Sections.
2. You can use the Sta option to move to the cross section you want to edit, and then enter the number of the station to move to. Or, you can use the Next option to move through the stations.
3. Type **E** for Edit.
4. Type **C** for Control to display the Control Editor.
5. Click Template Control to display the Template Control dialog box.
6. In the Superelevation frame, use the popup list to set the pivot point.
7. Select the template you want to use.
8. Enter the datum number.
9. Edit the template superelevation parameters, if necessary. For more information, see “Editing the Template Superelevation Parameters” in this chapter.
10. Edit the template transitions, if necessary.
11. Click OK to return to the Template Control dialog box.
12. Click OK to return to the View/Edit options.
13. Press ENTER to exit the View/Edit options.
Editing, Inserting, or Deleting a Superelevated Curve

To edit, insert, or delete a superelevated curve

1. From the Cross Sections menu, choose Design Control ➤ Superelevation Parameters to display the Superelevation Control dialog box.

2. Under Superelevation Toggles, select the Superelevation calculations check box if you want to superelevate the cross sections.

   If this check box is cleared, the Template Control dialog box displays the superelevation control as unavailable information.

   **NOTE** To apply superelevation, you must select Superelevation calculations. If superelevation is selected and is not being applied correctly, check the superelevation definition of the template using the Edit Template command.

3. Under Superelevation Toggles, select or clear the Crown removal by runout distance check box, depending on your design criteria.

   This check box controls the crown removal point by the runout distance. When you select this check box, the rate the roadway is superelevated between the normal crown and the removed crown, which remains constant.

4. Click Edit Data to display the Superelevation Curve Edit dialog box.

   ![Superelevation Curve Edit Dialog Box]

   The Superelevation Curve Edit dialog box displays one curve at a time. The first area of information displays the assigned curve number and the curve detail information. The curve number is based on station progression and cannot be edited directly. If you add or delete curves, then the curve numbers update to reflect the changes.

   The curve detail information includes the starting and ending stations, radius, length, spiral starting and ending stations (if any), and spiral lengths (if any).
5. Use the Curve Edit Information section of the dialog box to edit the following basic superelevation data:

- **Starting and Ending Stations**: The default to the starting and ending stations of the circular curve, but can be edited. Superelevation can begin on the tangent sections.
- **Method**: This list displays the superelevation methods available with Civil Design. For more information, see “Superelevation Methods” in this chapter.
- **E value**: The maximum crossfall value for the fully superelevated template. This value is initially set the project default setting unless speed tables were used to create the horizontal curvature, in which case the speed table value is used.
- **Direction**: Curvature can be either right or left, and is based on curve direction of the alignment. The direction of curvature should not be edited unless you insert curve information manually.
- **Rollover**: To apply rollover to the template, select Rollover and enter the rollover percent grade in decimal form. For example, type a six percent grade as .06. This grade is the maximum difference between the fully superelevated road surface and the shoulder. The shoulder is represented by the rollover points you select when you edit the template to define the superelevation regions.

6. Set the transition in and out of the curve.

Each transition has a runout and runoff value, and a percentage of runoff. The percentage of runoff is the amount of runoff length that occurs before the actual curve is encountered.

These values are initially set to the project default settings for superelevation parameters. However, if speed tables were used to create the horizontal curvature and spirals were used, the runoff value is set to the spiral length and the percentage runoff is set to 100%.

7. Move between the curves by doing any of the following:

- Click Next to move to the next curve.
- Click Previous to move to the next curve.
- Click Curve # to view information for a specified curve. This option displays a dialog box that prompts for the number of the desired curve. Enter the number of the curve to edit. Curves are numbered sequentially based on station sequence. If you enter a number that is outside the range of curve numbers, an error message is displayed, stating ‘Curve not found’. Click OK to return to the Superelevation Curve Number dialog box.
- Click Station to view information for a curve that falls on an entered station. This option displays a dialog box that prompts for a station. Enter a station value that lies between the defined beginning and ending station of the superelevation. If you enter a station that does not lie within a superelevated area, an error message appears. Click OK to return to the Station dialog box.

**NOTE** The station entered does not have to lie on the curve itself. The superelevation can start before the curve. The Station command uses the stations defined as the beginning and ending of superelevation to determine which curve is to be displayed. For more information, see the Superelevation Curve Edit dialog box.
8 Insert, delete, or view information for the current curve:
   ■ Click Insert Curve to insert a curve. The current curve number (indicated at
     the top of the dialog box) changes to the one you just inserted. For example,
     if you were working on curve #4, the curve you inserted is curve #5.
   ■ Click Delete Curve to delete the current curve. You are asked to confirm that
     you want to delete the curve.
   ■ Click Info to display curve detail information as well as the stations of the
     transitions in and out for the current curve.
9 Click OK to close the Superelevation Curve Edit Dialog box.
10 Click OK to close the Superelevation Control dialog box.
11 Click Yes to save your changes.
   For information on superelevating compound curves, see “Superelevating
   Compound Curves” in this chapter.

Importing a Superelevated Horizontal Alignment
After Editing It

If you modified the horizontal alignment after creating the superelevation
parameters, then it may be necessary to re-import the horizontal alignment.
This option recreates the curves and overwrites all of the superelevation
parameters with the default project settings for superelevation.

To import a superelevated horizontal alignment after editing it
1 From the Cross Sections menu, choose Design Control ➤ Superelevation
   Parameters to display the Superelevation Control dialog box.
2 Click Import Alignment.
   This imports the curve data from the alignment. You need to do this step before
   you can do any superelevation editing and if you are going to apply
   superelevation to the sections. A message is displayed, asking for confirmation
   to overwrite the existing superelevated curve information.

   **NOTE**  The Superelevation Parameters command is not dynamically linked to the
   Horizontal Alignment commands. If you subsequently make any changes to
   the horizontal alignment, then re-import the curve information by clicking
   Import Alignment. In addition, you have to repeat any edits you made in
   the Superelevation Curve Edit dialog box.

Importing Superelevation into a Profile

Profiles do not directly support superelevation because superelevation is based
on grade, not elevation. However, you do have the option of converting the
superelevation information to a transition so that you can import it to the
profile. By using this option you can either plot the superelevation for viewing
purposes, or you can edit the profile and attach it to the template as a
transition.
**To import superelevation into a profile**

1. Define a transition point at the same location as the superelevation region point.
2. From the Cross Sections menu, choose Design Control ➤ Superelevation Parameters to display the Superelevation Control dialog box.
3. Under Superelevation Toggles, clear the Superelevation calculations check box.
   This allows the outer edge of the superelevation region to be completely controlled by the transition profile elevations.
4. Click OK to display the Save Status dialog box.
5. Click Yes. If there are errors, the Section Processing Status dialog box is displayed.
6. Click OK until you exit the Superelevation Control dialog box.
7. From the Cross Sections menu, choose Ditch/Transition ➤ Import Profile.
   The following prompt is displayed:
   ```
   Profile to draw [Left/Right]:
   ```
8. Enter *L* for Left.
   The following prompt is displayed:
   ```
   Left profile to draw [Ditch/Super/1/2/3/4/5/6/7/8]:
   ```
9. Enter *S* for Superelevation.
   If you specify *S* for Superelevation, and if you specified Left, the following prompt displays for the left side:
   ```
   Profile layer to use (L1/L2/L3/L4/L5/L6/L7/L8):
   ```
10. Specify the transition layer to use.

   These layer names represent the transition regions you define on the template with the Edit Template command. Because the superelevation control point and the transition control point have to be in the same location on the template in order for this to work, you must specify the number of the transition region you are using for this purpose.

   When you import a ditch or transition into the plan view, you can also define it as an alignment if required since the transitions and ditches are imported as line entities. This step isn’t necessary if you imported the lines for viewing or plotting purposes only.

   You can make edits to these lines before defining the alignment or you can go directly to defining and alignment.

**Displaying the Superelevation Methods**

There are five superelevation methods supported by Autodesk Civil Design. These methods are designated by letters rather than formal names.

**To display the superelevation methods**

1. From the Cross Sections menu, choose Design Control ➤ Superelevation Parameters to display the Superelevation Control dialog box.
2. Click Methods to display the Superelevation Methods dialog box.
All of the superelevation method names and brief descriptions of each are listed.

3 Click OK to return to the Superelevation Control dialog box.

**Outputting the Superelevation Data**

To output the superelevation data

1 From the Cross Sections menu, choose Design Control ➤ Superelevation Parameters to display the Superelevation Control dialog box.
2 Click Output to generate the report.
   
   The command prompts for the output file name.
3 Accept the default output file name, or enter a new name. This file is located in the current project folder.
   
   The command prints the report to the file and the Superelevation Control dialog box is redisplayed.
4 Click OK to exit the command.

**Processing the Cross Sections for a Range of Stations**

You can use the Process Sections command if you’ve made changes to the depth, stepped, and surface slope control editor files. The Process Sections command is also useful if you’ve made changes outside of the Edit Design Control command, such as editing the vertical alignment with Profile commands, editing the template definition using the Edit Template command, or re-sampling the existing ground sections.

To process the cross sections for a range of stations

1 From the Cross Sections menu, choose Design Control ➤ Process Sections to display the Enter Station Range dialog box.
2 Enter the starting and ending stations of the range to be edited, and then click OK.

The range can be any subset of the entire alignment. Use a subset of the alignment to apply different templates to different ranges of stations or to do specialty transitions. The defaults are the starting and ending stations of the current alignment. The stations that determine the desired range must be entered as decimal values.

If you enter a station that was not sampled with the Sample From Surface command or Sample From File command, the command defaults to the next existing station.

**NOTE** Do not enter a plus sign (+) in the station value. For example, enter 1000 for station 10+00 or 1+000.

After entering the starting and ending stations, the Process Status dialog box is displayed. This is strictly an informational dialog box that displays information about the current alignment, station range, and processing station.

3 Review the information, and then click OK to continue. If errors occur during the section processing, the Section Processing Status dialog box is displayed.

4 If the Section Processing Status dialog box displays, you can do the following:
   - Click the View Errors button to display the error(s) that occurred during the section processing, or click OK to continue.
   - Print the errors to a file by clicking the Print to File button on the Control Processing Errors dialog box.

### Resetting the Cross Section Processing Settings Back to the Default Project Settings

To reset the cross section processing settings back to the default project settings

1 From the Cross Sections menu, choose Design Control ➤ Reset Section Control to display a Warning dialog box.

![Warning dialog box](image)

2 Click Yes or No:
   - Click Yes to reset the control values with default project settings. All Design Control information that has been applied to the templates is overwritten by the values set for Design Control with the Project Settings. All stations in the alignment now use the default values for applying the template to cross sections.
   - Click No to end the command without resetting the values.

**NOTE** You must reprocess the cross sections with the Process Sections command before the new values take effect.
Superelevating Compound and Reverse Curves

You can use the Superelevation Curve Edit dialog box to establish settings for compound and reverse curves that you want to superelevate.

Superelevating Compound Curves

In order to superelevate compound curves, the end station of curve 1 must be the same as the start station of curve 2. When these stations match, all Transition Out data for curve 1 is ignored and the runout for the Transition In for curve 2 is ignored. The Transition In data for curve 2 controls the superelevation transition from curve 1 to curve 2.

To superelevate compound curves

1. From the Cross Sections menu, choose Design Control ➤ Superelevation Parameters to display the Superelevation Control dialog box.
2. Select the Superelevation calculations check box to superelevate the cross sections.
3. Click the Edit Data button to display the Superelevation Curve Edit dialog box for curve 1.
4. In the Curve Edit Information section of the dialog box, edit the superelevation data.
   For more information, see “Editing the Superelevation for One Section At a Time” in this chapter.

5. Under Transition In, enter values for Runout, Runoff, and % runoff for curve 1.
6. Under Transition Out, enter 0 for the Runout, Runoff, and % runoff for curve 1.
NOTE  Autodesk Civil Design ignores all Transition Out data for curve 1. Therefore, it is better to set these values at 0 for the sake of clarity.

7 Click the Next button to display the Superelevation Curve Edit dialog box for curve 2.
8 Repeat step 4 for curve 2.
9 Repeat Transition In by doing the following for curve 2:
   - Set the Runout to 0.
   - Set Runoff to a runoff distance of your choice.
   - Set % runoff to a runoff percentage of your choice.
10 Under Transition Out, you can enter values for Runout, Runoff, and % runoff for curve 2.
11 Click OK to exit the Superelevation Curve Edit dialog box.
12 Click OK to exit the Superelevation Control dialog box.
13 Click Yes to save your changes.

For information on how to superelevate compound curves that are separated by tangents or spirals, see “Example of Superelevating Compound Curves Separated by Tangents or Spirals” in this chapter.

The following shows the superelevation data entered for curve 1 in the Superelevation Curve Edit dialog box:
The following shows the superelevation data for curve 2 entered into the Superelevation Curve Edit dialog box:

![Superelevation Curve Edit](image)

**Example of Superelevating Compound Curves Separated by Tangents or Spirals**

If you are working with compound curves where the point of tangency (PT) of curve 1 is not the same station as the point of curvature (PC) of curve 2, superelevation cannot be applied correctly in the transition between curve 1 and curve 2. Examples in which this may occur is when a tangent or spiral separates curve 1 from curve 2.

In these situations, you can modify the End Station of curve 1 and the Start Station of curve 2 to match so that the superelevation is being applied correctly. If you modify the Start or End Stations of the curve data in the Superelevation Curve Edit dialog box, it does not affect the horizontal geometry of the alignment definition. The data in the dialog box is for superelevation purposes only.
The following example depicts a compound curve separated by a 40m tangent. The PT of curve 1 is 20+00 and the PC of curve 2 is 20+40. The End Station of curve 1 and the Start Station of curve 2 have been changed to 2020, which forces Autodesk Civil Design to treat the curve-tangent-curve as a compound curve with the 0% cross slope applied at 20+20.

The following show the Superelevation Curve Edit dialog box with data for curve 1 and curve 2, respectively:

For information on superelevating complex compound curves, see “Example of Superelevating Complex Compound Curves” in this chapter.
Example of Superelevating Complex Compound Curves

In complex compound curves, there is a combination of alignment entities between curve 1 and curve 2. This situation may occur during the design of complex highway exit ramps where curve 1 and curve 2 are separated by a spiral-tangent-spiral.

You can superelevate a complex compound curve by modifying the End Station of curve 1 and the Start Station of curve 2 to match a common station within the spiral-tangent-spiral.

For information on superelevating compound curves, see “Example of Superelevating Compound Curves Separated by Tangents or Spirals” in this chapter.

Superelevating Reverse Curves

In order to superelevate reverse curves, the end station of curve 1 must equal the start station of curve 2. When these stations match, Runout and % Runoff are ignored and a 0% cross slope is applied at the point of reverse curvature, where curve 1 meets curve 2.

To superelevate reverse curves

1. From the Cross Sections menu, choose Design Control ➤ Superelevation Parameters to display the Superelevation Control dialog box.
2. Select the Superelevation calculations check box to superelevate the cross sections.
3. Click the Edit Data button to display the Superelevation Curve Edit dialog box for curve 1.
4. In the Curve Edit Information section of the dialog box, edit the superelevation data.
5. Under Transition In, enter values for Runout, Runoff, and % runoff for curve 1.
6. Under Transition Out, do the following for curve 1:
   - Set the Runout to 0.
   - Set the Runoff to a runoff distance of your choice.
   - Set the % runoff to 0.

   NOTE Autodesk Civil Design ignores Runout and % runoff at the point of reverse curvature. Therefore, it is better to set these values to 0 for the sake of clarity.

7. Click the Next button to display the Superelevation Curve Edit dialog box for curve 2.
8. Repeat step 4 for curve 2.
9. Under Transition In, do the following for curve 2:
   - Set Runout to 0.
   - Set Runoff to a runoff distance of your choice.
   - Set % runoff to 0.
10 Under Transition Out, you can enter any values for Runout, Runoff, and % runoff.
11 Click OK to exit the Superelevation Curve Edit dialog box.
12 Click OK to exit the Superelevation Control dialog box.
13 Click Yes to save your changes.

For information on superelevating reverse curves that are separated by tangents or spirals, see “Superelevating Reverse Curves Separated by Tangents or Spirals” in this chapter.

The following shows the settings to superelevate reverse curves in the Superelevation Curve Edit dialog box:

![Superelevation Curve Edit](image)

**Example of Superelevating Reverse Curves Separated by Tangents or Spirals**

If you are working with reverse curves where the point of tangency (PT) of curve 1 is not the same station as the point of curvature (PC) of curve 2, superelevation is not applied correctly in the transition between curve 1 and curve 2. This situation may occur when a tangent or spiral separates curve 1 from curve 2.

You can modify the End Station of curve 1 and the Start Station of curve 2 to match, resulting in an accurate superelevation. If you modify the Start and End Stations of the curve data in the Superelevation Curve Edit dialog box, then the horizontal geometry of the alignment definition is not affected. The data in this dialog box is for superelevation purposes only.
The following example depicts a reverse curve separated by a 40m tangent. The PT of curve 1 is 20+00 and the PC of curve 2 is 20+40. The End Station of curve 1 and the Start Station of curve 2 have been changed to 2020, which forces Autodesk Civil Design to treat the curve-tangent-curve as a reverse curve with the 0% cross slope applied at 20+20.

The following illustrations show the Superelevation Curve Edit dialog box with data for curve 1 and curve 2, respectively:

For information on superelevating complex reverse curves, see “Example of Superelevating Complex Reverse Curves” in this chapter.
**Example of Superelevating Complex Reverse Curves**

Complex reverse curves are a combination of alignment entities that exist between two curves. An example of complex reverse curves occurs when designing complex highway exit ramps, where curve 1 and curve 2 are separated by a spiral-tangent-spiral. You can superelevate a complex reverse curve by modifying the End Station of curve 1 and the Start Station of curve 2 to equal a common station within the spiral-tangent-spiral.

For information on superelevating complex reverse curves, see “Example of Superelevating Reverse Curves Separated By Tangents or Spirals” in this chapter.

**Displaying and Reporting the Cross Section Control Values**

You can use the Design Control submenu on the Cross Sections menu to display and output the design and actual control values used in creating finished ground cross sections. You can also report any errors that occurred while processing the sections.

**Displaying the Design Control Values for Any Section**

To display the design control values for any section

1. From the Cross Sections menu, choose Design Control ➤ Display Design Control to display the Design Control Parameters dialog box.
NOTE The values in this dialog box are for display only, you cannot edit them.

2 Click the Next, Previous, and Station buttons to move between stations. When you click Station, the Station Entry dialog box is displayed. Type the value for the station you want to see, and then click OK.

3 Click Benches to view the left and right bench information. In the Benches dialog box, click the Next, Previous, and Station buttons to move between stations. When you click Station, the Station Entry dialog box is displayed. Type the value for the station you want to see then click OK. Click OK in the Benches dialog box after finishing the review of bench values.

4 Click Transitions to view information about the left and right transitions. The first through fourth transitions are displayed in the initial Transitions dialog box. Click More to display the fifth through eighth transitions. Click the Next, Previous, and Station buttons to move between stations. When you click Station, the Station Entry dialog box is displayed. Type the value for the station you want to see, and then click OK. Click OK in the Transition dialog box to return to the Design Control Parameters dialog box.

5 Click OK to exit the command.

Displaying the Actual Control Values for Any Section

To display the actual control values for any section

1 From the Cross Sections menu, choose Design Control ➤ Display Actual Control to display the Actual Control Parameters dialog box.

This dialog box shows you the actual control parameters that were applied at each station, including catch point offsets and elevations. The top portion of the dialog box displays the alignment name, current station, template name, and centerline elevation. The cut and fill areas are also displayed.
NOTE  The values in this dialog box are for display only; you cannot edit them.

2 Click the Next, Previous, and Station buttons to move between stations. When you click Station, the Station Entry dialog box is displayed. Type the value for the station you want to see, and then click OK.

3 Click OK to exit the command.

Displaying the Control Errors

To display any error messages that have been generated while processing sections

1 From the Cross Sections menu, choose Design Control ➤ Display Control Errors to display the Control Processing Errors dialog box.

2 Use the scroll bar to the right of the error messages to move through the list of messages.

The following is a list of all possible error messages:

Warning: Station: (Station) Left slope pinned to ROW
Warning: Station: (Station) Left slope pinned to end
Warning: Station: (Station) Left slope pin override used
Warning: Station: (Station) Right slope pinned to ROW
Warning: Station: (Station) Right slope pinned to end
Warning: Station: (Station) Right slope pin override used
Warning: Station: (Station) Template larger than cross section
Warning: Station: (Station) No vertical exists
Warning: Station: (Station) No valid template assigned
Station: (Station) No cross section defined
Station: (Station) No crown or left EOP found, super set to 0.
Station: (Station) No crown or right EOP found super set to 0.
Template (Template) not found in template subdirectory.
Datum surface <(Datum)>, not found.
Top surface <(Top Surface)>, not found.
If the “Warning: Station: {Station} No vertical exists” error message is displayed, then a finished ground vertical alignment is not defined at that station. If the "Station: {Station} No cross section defined" error message is displayed, then ground cross section information does not exist. To remedy this error, use the Sample From Surface or Sample From File command to sample the cross section information.

3. Click Print To File to print the error messages to a file. A prompt is displayed for the file name. Enter a file name in an appropriate location, save, and exit the Output File selection dialog box, or click Cancel to exit the Print to File command.

4. Click OK to exit the Control Processing Errors dialog box.

**Outputting the Control Values to a Text File**

To output the control values to a text file

1. From the Cross Sections menu, choose Design Control ➤ Output to File. You are prompted for a file name.

2. Enter the file name, including the file extension. You are prompted for the station range. The default values are the beginning and ending stations of current alignment.

3. Enter the range of stations for the output. You are prompted to choose the type of report you would like to print.

4. Enter the type of report to print: design or actual. The command creates the report.

**Changing the Slope Control for the Sections**

You can make changes to a single section or a range of sections. Generally, you use the View/Edit commands to change single section and use the Edit Design Control commands to make changes to a range of sections.

To change the slope control for one section

1. From the Cross Sections menu, choose View/Edit Sections.

2. View the station at which you want to make the edits by choosing the Sta option at the command prompt, and then entering the station value.

3. Type E for Edit to access the editing options. The following prompts are displayed:

   Sta: 0+000   Section Edit & Display commands
   Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:

   **NOTE** Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4. Type C for Control to display the Control Editor dialog box.

5. Use the options in Control Editor dialog box to edit the cross section for the current station.
The Control option uses a screen similar to the one used by the Edit Design Control command, except that here it only affects the current station. Another difference is that profiles and alignments cannot be attached in this screen. You can make edits to the template, ditch, benches, or slope control.

Designing and Editing Roadway Ditches with Templates and Cross Sections

To design and edit ditches, use the View/Edit Sections command on the Cross Sections menu. With this command, you can change the control, slope, elevation, width, offset, and depth of a single section of a ditch. Use the Design Control ➜ Edit Design Control command to change a range of sections.

Changing the Ditch Control

You can make changes to a single section or a range of sections. Generally, you use the View/Edit Sections commands to change single section and use the Edit Design Control commands to make changes to a range of sections.

To change the ditch control for one section

1. From the Cross Sections menu, choose View/Edit Sections.
2. View the station at which you want to make the edits by choosing the Sta option at the command prompt, and then entering a station value.
3. Type E for Edit to access the editing options.
   The following prompts are displayed:
   Sta:  0+000  Section Edit & Display commands
   Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:
   
   **NOTE** Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4. Type C for Control to display the Control Editor dialog box.
5. Click Ditches to display the Ditch Control Dialog box.
6. In the Type list, select the ditch type for each side.
7. Define the ditches using foreslope and centerline offset, or one of these two parameters with either depth or base elevation.
8. Select or clear the foreslope, centerline offset, depth, depth from hinge, or base elevation check boxes. Enter each value in the edit box to the left of the check box:
   - **Foreslope**: Enter the slope from the template connection point to the ditch.
   - **Centerline Offset**: Enter the distance from the centerline to the inner edge of the ditch.
   - **Depth**: Enter the vertical distance of the ditch, which can be measured from either the top of the foreslope or the finished ground reference point of the template. Enter the depth of the ditch as a positive value.
   - **Depth from Hinge**: This check box is used in conjunction with the Depth value and is only available after you have selected the Depth value.
The Depth from Hinge check box controls how the depth of the ditch is measured. When this option is selected, the depth of the ditch is measured down from the top of the ditch foreslope. When this option is cleared, the depth is measured down from the finished ground centerline reference point.

- **Base elevation**: Enter the true elevation of the bottom of the ditch. If you use this option, the elevations are usually retrieved from the profile using the Attach profiles option.
- **Base Width**: Enter the width of the bottom of the ditch.

**NOTE**
You can only use two of the ditch parameters at a time (except when the depth from hinge is selected, which makes three items selected.) If you enter less than two parameters, ditches are not applied. If more than two options are selected, then a warning message will be displayed and you need to correct the situation. The command calculates the other parameters automatically.

9 When you have entered the ditch parameters, click OK to close the Ditch Control dialog box.

10 Click OK on the Control Editor dialog box to update the section view with new ditch values.

11 Type X to exit the command.

If you want to change ditch parameters at any another station view that station with the Sta option and repeat steps 2 to 9. Or, type X to exit the View/Edit Sections command.

The following illustration shows ditch design parameters:
Changing the Ditch Slope

You can make changes to a single section or a range of sections. Generally, you use the View/Edit Sections commands to change single section and use the Edit Design Control commands to make changes to a range of sections.

To change the ditch slope for one section

1. From the Cross Sections menu, choose View/Edit Sections.
2. View the station at which you want to make the edits by choosing the Sta option at the command prompt and entering a station value.
3. Type E for Edit to access the editing options.

The following prompts are displayed:

Sta: 0+000   Section Edit & Display commands
Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:

NOTE Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4. Type D for the Ditch option.

The following prompt is displayed:

Actual/Control/dSlope/dElev/dWidth/dPos/Id/Mslope/eXit/Undo/Zoom/<eXit>:

5. Type S for dSlope (Ditch Slope) to graphically edit the foreslope of the ditch.
6. Select two points on the screen to represent the slope. The dSlope option displays the value of that slope.
7. Press ENTER to accept the slope, or enter a new value for a different slope.

This option only edits the ditch on the side of the alignment where you selected the points. Repeat for the other side, if necessary.

8. Press ENTER twice to select any other station to edit and repeat steps 2 to 6, or press ENTER repeatedly until you have exited the View/Edit Sections command.

Changing the Ditch Elevation

You can make changes to a single section or a range of sections. Generally, you use the View/Edit Sections commands to change single section and use the Edit Design Control commands to make changes to a range of sections.

To change the ditch elevation for one section

1. From the Cross Sections menu, choose View/Edit Sections.
2. View the station at which you want to make the edits by choosing the Sta option at the command prompt and entering a station value.
3. Type E for Edit to access the editing options.

The following prompts are displayed:

Sta: 0+000   Section Edit & Display commands
Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:
Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4 Type D for the Ditch option.

The following prompt is displayed:

Actual/Control/dSlope/dElev/dWidth/dPos/Id/Mslope/eXit/Undo/Zoom/<eXit>:

5 Type E for dElev (Ditch Elevation) to graphically edit the elevation of the ditch.

6 Select a point on the screen that is at the desired elevation.

The dElev option displays the value of the elevation you selected.

7 Press ENTER to accept the elevation, or enter a new value for a different elevation.

The dElev option edits only the ditch on the side of the alignment where you selected the point. Repeat, as needed, for the other side.

8 Press ENTER twice to select any other station to edit and repeat steps 2 to 6, or press ENTER repeatedly until you have exited the View/Edit Sections command.

Changing the Ditch Width

You can make changes to a single section or a range of sections. Generally, you use the View/Edit Sections commands to change single section and use the Edit Design Control commands to make changes to a range of sections.

To change the ditch width for one section

1 From the Cross Sections menu, choose View/Edit Sections.

2 View the station at which you want to make the edits by choosing the Sta option at the command prompt and entering a station value.

3 Type E for Edit to access the editing options.

The following prompts are displayed:

Sta: 0+000 Section Edit & Display commands
Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:

Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4 Type D for the Ditch option.

The following prompt is displayed:

Actual/Control/dSlope/dElev/dWidth/dPos/Id/Mslope/eXit/Undo/Zoom/<eXit>:

5 Type W for dWidth (Ditch Width) to graphically edit the width of the ditch.

6 Select two points on the screen to represent the width. The dWidth option displays the value of the width.
Changing the Ditch Offset and Depth

You can make changes to a single section or a range of sections. Generally, you use the View/Edit Sections commands to change single section and use the Edit Design Control commands to make changes to a range of sections.

To change the ditch offset and depth for one section
1. From the Cross Sections menu, choose View/Edit Sections.
2. View the station at which you want to make the edits by choosing the Sta option at the command prompt and entering a station value.
3. Type E for Edit to access the editing options.
   The following prompts are displayed:
   Sta:  0+000   Section Edit & Display commands
   Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:
   
   **NOTE** Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.
4. Type D for the Ditch option.
   The following prompt is displayed:
   Actual/Control/dSlope/dElev/dWidth/dPos/Id/Mslope/eXit/Undo/Zoom/ <eXit>:
5. Type P for dPos (Ditch Position) to graphically edit the offset and depth of the ditch.
6. Select the point on the screen at the desired location for the toe of the foreslope.
   The ditch position displays the values for the alignment offset and depth of that point.
7. Press ENTER to accept the values for the new position, or enter new values for a different alignment offset and depth.
   The dPos option edits only the ditch on the side of the alignment where you selected points. Repeat, as needed, for the other side.
8. Press ENTER twice to select any other station to edit and repeat steps 2 to 6, or press ENTER repeatedly until you have exited the View/Edit Sections command.
Changing the Match Slope

You can make changes to a single section or a range of sections. Generally, you use the View/Edit Sections commands to change single section and use the Edit Design Control commands to make changes to a range of sections.

To change the match slope for one section
1 From the Cross Sections menu, choose View/Edit Sections.
2 View the station at which you want to make the edits by choosing the **Sta** option at the command prompt and entering a station value.
3 Type **E** for Edit to access the editing options.
   The following prompts are displayed:
   
   Sta:  0+000   Section Edit & Display commands
   Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:

   **NOTE** Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4 Type **D** for the Ditch option.
   The following prompt is displayed:
   
   Actual/Control/dSlope/dElev/dWidth/dPos/Id/Mslope/eXit/Undo/Zoom/ <eXit>:

5 Type **M** for Mslope (Match Slope) to graphically edit the match slope of the template.
6 Select two points on the screen to represent the slope.
   The Mslope option displays the value of the slope.
7 Press ENTER to accept the value, or enter a new slope to round off the value.
   The Mslope option only edits the slope on the side of the alignment where you selected points. Repeat as needed for the other side.
8 Press ENTER twice to select any other station to edit and repeat steps 2 to 6, or press ENTER repeatedly until you have exited the View/Edit Sections command.

Editing Cross Sections

There are two commands available for editing your cross sections: Edit Design Control and View/Edit sections.

Using the Edit Design Control Command to Process and Edit the Cross Sections

To apply a design template with corresponding slopes and ditches to the existing ground cross sections for a range of stations, use the Edit Design Control command. Use this command to define the parameters used to apply a finished ground template to the existing ground cross sections. When you make
edits with this command, the command automatically processes the design cross sections.

Use this command alternately with the View/Edit Sections command to edit the cross sections. Whereas you specify a range of stations to edit with the Edit Design Control command, you can edit each section individually with the View/Edit Sections command.

**Prerequisites for Using the View/Edit Sections Command to Edit Cross Sections**

To define a template for cross sections
1. Define the horizontal alignment.
2. Generate the existing ground profile.
3. Define the finished ground centerline for the profile, if you want to view the template.
4. Sample the existing ground cross sections.
5. Define the necessary templates with all the required features.
6. Run the Edit Design Control command to apply the templates to the existing ground sections unless you want to view or edit existing ground sections only.

**Using the View/Edit Sections Command to Edit the Cross Sections**

After you create sections with the Edit Design Control command, you can view and edit individual sections using the View/Edit Sections command.

NOTE This command does not plot the sections. Rather, it displays the sections on screen as temporary vectors for viewing and editing purposes. As soon as you exit the command, the view returns to the AutoCAD screen. To plot cross sections, use the Section Plot commands in Cross Sections menu.

You can use the View/Edit Sections command to step through the sections or move directly to a specific station. The design criteria that is applied to the section can be displayed as well as the actual parameters that were used to create the current section.

The following illustration shows the cross section view:
Choosing which Cross Section Station to Edit

To choose which cross section station to edit

1. From the Cross Sections menu, choose View/Edit Sections to display the cross section for the first station and the following prompt:
   
   Actual/Design/Edit/Id/Next/Previous/eXit/Sta/View/Zoom <Next>:

2. Do one of the following to choose the cross section station that you want to edit:
   - Type P for Previous to view the cross section for the previous station. When you select the Previous option, it replaces Next as the default option.
   - Type N for Next to display the cross section for the next station. When you select the Next option, it replaces Previous as the default option.
   - Type S for Station to display a selected cross section station, then enter the number of the station you want to view. If you enter a station value where existing ground was not sampled, the command defaults to the next available station.

3. To exit the command, type X.

Identifying the Offset and Elevation of a Point

To identify the offset and elevation of any point selected on the screen

1. From the Cross Sections menu, choose View/Edit Sections to display the cross section for the first station and the following prompt:
   
   Actual/Design/Edit/Id/Next/Previous/eXit/Sta/View/Zoom <Next>:

2. Type Id for Identify.

3. Pick a point on the cross section to identify.

   The command returns the information to the screen. A positive offset indicates the point is on the right side of the alignment centerline and a negative offset indicates the point is on the left side of the centerline.

   **NOTE**

   Do not use AutoCAD object snaps to select a point. The section view is not composed of AutoCAD entities and is not part of the drawing.

   The option continues to prompt for points as long as they are selected.

4. Press ENTER to exit back to the previous options list.

Changing the Appearance of Cross Sections

To change the view of the cross sections

1. From the Cross Sections menu, choose View/Edit Sections to display the cross section for the first station and the following prompt:
   
   Actual/Design/Edit/Id/Next/Previous/eXit/Sta/View/Zoom <Next>:
2 Type V for View to display the Template View Settings Editor dialog box.

![Template View Settings Editor](image)

3 Under Toggles, do the following to control the components that are displayed in the View/Edit Sections command:

- Select Existing Ground to view the existing ground. The number displayed in the edit box next to this check box indicates the color this item is displayed with.

  **NOTE** To set the colors for the cross section components, type the color numbers between 0 and 255 directly into the edit boxes to the right of each of the cross section components. Alternatively, you can click the color box to display the AutoCAD color palette, where you can select a color.

- Select Datum to view the datum. The number displayed in the edit box next to this check box indicates the color this item is displayed with.

- Select Grid to view the grid. The number displayed in the edit box next to this check box indicates the color this item is displayed with.

- Select Top Surface to view the Top surface. When you select this check box, the Num edit box is displayed with the top surface number to be displayed. Either enter the number of the top surface to display or click Select to the right of the Num edit box. This button displays the Top Surface Librarian dialog box, where you can select any other top surface, if defined.

- Select Point codes to view the point codes. The number displayed in the edit box next to this check box indicates the color this item is displayed with.

- Select Template to view the template. The number displayed in the edit box next to this check box indicates the color this item is displayed with.

- Select ROW to view the right-of-way. The number displayed in the edit box next to this check box indicates the color this item is displayed with.

- Select Grid text to view the grid text. The number displayed in the edit box next to this check box indicates the color this item is displayed with.
4 Under **Grid Values**, enter the grid values for the following options:
- **Offset incr**: Enter a value in this edit box for the horizontal grid spacing.
- **Elevation incr**: Enter a value in this edit box for the vertical grid spacing.
- **Offset prec**: Enter a value in this edit box to set the precision for the displayed offsets.
- **Elevation prec**: Enter a value in this edit box to set the precision for the vertical grid text.

5 Under **Miscellaneous Values**, enter the view factors and text size:
- **Text size**: Enter a value in this edit box to set the relative text size in pixels. This is the height of the text in the display.
- **Vertical factor**: Enter a value in this edit box to set the vertical scale factor for the view. The vertical scale set in the drawing setup has no effect on the cross section view.
- **Zoom factor**: Enter a value in this edit box to set the scale factor for zooming in and out. For example, if you set a Zoom factor of 0.2, then the Zoom In (to increase the view size) option uses a scale factor of 1.2 and Zoom Out (to reduce the view size) a factor of 0.8. For more information, see “Zooming to Cross Sections” in this chapter.

**NOTE** If you set the zoom scale factor to one, then the Zoom In and Zoom Out options are not effective.

6 Click OK to close the Template View Settings dialog box.

## Zooming to Cross Sections

To zoom to cross sections

1. From the Cross Sections menu, choose View/Edit Sections to display the cross section for the first station and the following prompt:

   Actual/Design/Edit/Id/Next/Previous/eXit/Sta/View/Zoom <Next>:

2. Type **Z** for Zoom to display the following prompt:

   Zoom (All/In/Out/Point/eXit/View/Window) <In>:

3. Do one of the following to select a zoom option:
   - Type **A** for All to return the screen to the original size and location.
   - Type **I** for In to zoom in to the center point of the screen. This option uses the scale factor set in the view defaults to zoom in on the section.
   - Type **O** for Out to zoom out from the center point of the screen. This option uses the scale factor set in the view defaults to zoom out of the section.
   - Type **P** for Point, and then select a point to zoom to. When you select a point, this option moves the selected point to the center of the screen. Use the Point option to zoom in on any area of the section or pan around the section.
   - Type **X** for eXit to exit the Zoom option and return to the previous menu.
**Using the View/Edit Sections Command to Edit the Cross Sections**

- Type V for View to open the Template View Settings Editor, where you can change the zoom scale factor.
- Type W for Window, then select two points to define a window to zoom into.

**NOTE** If the zoom scale factor is set to one, then the Zoom In and Zoom Out options are not effective.

### Changing the Design Control Values for One Section

**To edit values pertaining to the current station**

1. From the Cross Sections menu, choose View/Edit Sections.
   
The following prompt is displayed:
   
   Actual/Design/Edit/Id/Next/Previous/eXit/Sta/View/Zoom <Next>:

2. Type Sta at the command prompt, and then enter a station value.
3. Type E for Edit to access the editing options.
   
The command displays the following prompts:
   
   Sta:  0+000  Section Edit & Display commands
   Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:

**NOTE** Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4. Type C for Control to display the Control Editor dialog box.

5. Select one of the following Design Control options:
   
   - **Template Control**: For more information, see “Changing the Template Control for One Section” in this chapter.
   - **Ditches**: For more information, see “Changing the Ditch Control for One Section” in this chapter.
   - **Slopes**: For more information, see “Changing the Slope Control for One Section” in this chapter.
   - **Benches**: For more information, see “Benching Notes” in this chapter.
Changing the Template Control for One Section

To change the template control for one section:

1. From the Cross Sections menu, choose View/Edit Sections.
   The following prompt is displayed:
   Actual/Design/Edit/Id/Next/Previous/eXit/Sta/View/Zoom <Next>:

2. Type Sta at the command prompt, and then enter a station value.

3. Type E for Edit to access the editing options.
   The command displays the following prompts:
   Sta:  0+000  Section Edit & Display commands
   Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:

   **NOTE** Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4. Type C for Control to display the Control Editor dialog box.

5. Click Template Control to display the Template Control dialog box.

![Template Control dialog box](image)

Any changes made to the settings using this option reprocesses the information for the affected station. The top frame of this dialog box shows the current station.

6. Select the template you want to use.

7. Enter the datum number.

8. Edit the template superelevation parameters, if necessary.

9. Edit the template transitions, if necessary.

10. Click OK to return to the Control Editor dialog box.
Editing the Template Transitions

As part of specifying the template parameters to use for processing cross sections, you must edit the transitioning for the template. You can choose to edit the transitions for a range of sections, or for one section at a time.

Changing the Template Transitions for One Section at a Time

NOTE To apply transitions, you need to define the transition regions on the template.

To edit the transition offset and elevation values for selected stations
1 From the Cross Sections menu, choose View/Edit Sections.

NOTE If you haven’t selected a current alignment, then you are prompted to select an alignment.

The following prompt is displayed:
Actual/Design/Edit/Id/Next/Previous/eXit/Sta/View/Zoom <Next>:

2 Move to the station you want to edit by using the Sta or Next options.
3 Type E to select the Edit option.
   The following prompt is displayed:
   Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:

NOTE Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4 Type C to select the Control option and display the Control Editor dialog box.
5 Click Template Control to display the Template Control dialog box.
6 Click Edit Transitions to display the Transitions dialog box.
The Transitions dialog box displays the left and right transition offset and elevation values:

- If you attach a horizontal alignment, then the offset value is listed in the First (or appropriate numbered) Offset edit box, for the right or left side accordingly.
- If you attach a vertical alignment, then the elevation value is listed in the First (or whatever number of profile attached) Elevation edit box, for the right or left side accordingly.

The Transitions dialog box supports up to eight transitions per side. The initial Transitions dialog box displays the first through fourth transition. Click More to work on the fifth through eighth transitions. The Subgrade transition elevation edit box in the Transitions dialog box records the elevation of the subgrade at the centerline at the specified station. To transition the subgrade elevation, you can draw a vertical alignment in profile view and define it as a vertical transition line. Then you can attach this alignment to the template using the Attach Profiles option of the Edit Design Control command.

7 Select and clear the offset distances and elevations using the check boxes. If you clear a check box, the transitioning is not applied when the sections are reprocessed.

8 Edit the values in the edit boxes to the right of each check box. If no offset alignments or profiles are attached earlier, you can select the appropriate offset/elev check boxes, and then edit the values to introduce transitions at this Station.

The offsets and elevations are used to control the points on the template that you defined as transition points. A negative offset distance value forces that offset to the opposite side of the centerline so that features such as medians can be forced across the centerline. These are actual rather than relative offsets.

9 Click OK to close the Transitions dialog box.
10 Click OK to close the Template Control dialog box.
11 Click OK to close the Control Editor dialog box.

Changing the Left and Right Transition Regions for One Section

To edit the left or right transition regions of the current station

1 From the Cross Sections menu, choose View/Edit Sections.
The following prompt is displayed:
Actual/Design/Edit/Id/Next/Previous/eXit/Sta/View/Zoom <Next>:

**NOTE**
If you haven’t selected a current alignment, then you are prompted to select an alignment.

2 Use the Sta or Next options to select the station you want to edit.
3 Type **E** for Edit to access the editing options. The following prompts are displayed:

```
Sta:  0+000    Section Edit & Display commands
Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:
```

**NOTE**
Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4 Type **T** for Transition.
The command displays the following prompts:
Actual/Control/Id/Ltrans/Rtrans/Subgrade/eXit/Undo/Zoom <eXit>:

5 Type **L** for Ltrans or **R** for Rtrans to graphically edit the eight left and eight right transition regions.
The regions must have been defined on the template using the Edit Template command. A different prompt is displayed depending on the transition you selected. For example, if you entered **L** in the previous step, the following prompt is displayed:

```
Left transition  (Actual/Control/Id/1/2/3/4/5/6/7/8/eXit/Undo/Zoom <eXit>:
```

6 Enter the number (1, for example) of the transition region you want to edit, or select one of the other options to exit the transition edit options.

Next, you are prompted to select the first left stretch position, if you have selected 1 in the previous step.

7 Pick the first left stretch position. The Resultant left offset and Resultant left elevation is displayed.

8 Accept the Resultant left offset and Resultant left elevation values by pressing ENTER, or enter new values.

You can retain the original value for either the offset or elevation by entering X at the appropriate prompt. If you change only the offset, then the reference grade as defined in the Edit Template command is held so the elevation may be
changed by the command automatically. Use this option so that the cross fall of features, such as the driving lane, does not change as the lane widens or narrows. The command edits the section and returns the prompt to the transition options.

9 Press ENTER twice to select any other station to edit and repeat steps 3-8, or press ENTER repeatedly until you have exited the View/Edit Sections command.

**Changing the Subgrade Transition Regions for One Section**

**To edit the subgrade transitioning for one section**

1 From the Cross Sections menu, choose View/Edit Sections.

   **NOTE** If you haven’t selected a current alignment, then you are prompted to select an alignment.

2 Use the Sta or Next options to move to the station you want to edit.

3 Type E for Edit to access the editing options.

   The following prompts are displayed:

   Sta:  0+000   Section Edit & Display commands
       Actual/Control/Ditch/Id/eXit/Transition/Undo/Zoom <eXit>:

   **NOTE** Any changes made using this option only affect the current station. To make changes that affect a whole range of stations, use the Edit Design Control command.

4 Type T for Transition.

   The following prompt is displayed:

   Actual/Control/Id/Ltrans/Rtrans/Subgrade/eXit/Undo/Zoom <eXit>:

5 Type S for Subgrade.

6 Select the new subgrade position for the crown of the subgrade surface.

   When working with a template that has had multiple subgrades defined, this is the elevation of the crown for the uppermost subgrade surface.

   The command displays the resultant elevation.

7 Accept the resultant elevation value, or enter a new one.

8 Press ENTER twice to select any other station to edit and repeat steps 3-7, or press ENTER repeatedly until you have exited the View/Edit Sections command.
Using the Cross Section Elements in a Plan Alignment

When you attach a transition or ditch line to the cross sections, you may find that you need to make edits to the offset and elevational data at specific sections. After editing the ditch and transition cross section information, you can use commands in the Ditch/Transition submenu on the Cross Sections menu to import this information into the plan or profile view, and then redefine the alignments.

In some cases, as with ditches, you can draw a vertical transition line in profile view to define the elevations, attach it to the cross sections, and then import the ditch out to the plan view.

Importing a Ditch or Transition from the Sections into the Plan View

**NOTE** If you are importing a transition line, you must first define the transition regions with the Edit Template command and attach a transition line to the cross sections either by using the Attach Alignments or through the Transitions dialog box.

If you are importing ditches, then the ditches must have been applied in the Edit Design Control command.

To import ditches or transitions

1. From the Cross Sections menu, choose Ditch/Transition ➤ Import Plan Lines.
   The following prompt is displayed:
   
   Horizontal line to draw (Left/Right):

2. Type L to specify the Left horizontal line, or type R to specify the Right horizontal line.
   The command prompts for the line you want to import. The type of prompt that is displayed is dependent on which horizontal line you’ve selected (right or left). For example, the following prompt is displayed if the left line is selected.

   Left horizontal line to draw (Ditch/1/2/3/4/5/6/7/8):

3. When you attach a transition line to a template with the Edit Design Control command, you specify which number to attach. You can also import the lines defined by all transition region points that are defined in the template using the Edit Template command. Because ditches are not attached to the template itself, they have their own category.

   Type the number of the transition line to import to plan view, or type D to import the ditch.

   The command prompts for the station range to import. The default is the beginning and ending station of the horizontal alignment.
Accept the default station range to import or enter new values.
The plan line is then imported. Repeat the command as needed for each horizontal alignment you need to import.
The transition or ditch lines are imported as straight line segments on the current layer. They do not become alignments automatically. Use the Define Plan Alignment command from the Ditch/Transition submenu to turn the entities into a defined horizontal alignment.

**Defining a Ditch or Transition as a Horizontal Alignment**

When you import a ditch or transition into the plan view, you can also define it as an alignment, if required, since the transitions and ditches are just imported as line entities. This step isn’t necessary if you imported the lines for viewing or plotting purposes only.

**To define a ditch or transition as a horizontal alignment**

1. From the Cross Sections menu, choose Ditch/Transition ➤ Define Plan Alignment.
   The following prompt is displayed:
   
   Select entity (or POints):

2. Do one of the following to define the alignment:
   - Pick the end of the alignment entity, and then use a crossing window to select the remaining entities.
   - Type PO to access the POints option and define the alignment by point entry.

3. Press ENTER after you have selected all of the entities.
   The command connects the entities and writes the data to an external database.
   The alignment may consist of any combination of spirals, arcs, and lines. If the alignment contains spirals, then the spirals must be polylines created using the spiral creation commands. The remaining entities must be simple lines and arcs.
Editing a Ditch or Transition Horizontal Alignment

After you have defined the ditch or transition as an alignment, use the Edit Plan Alignment command to edit it.

To edit a ditch or transition horizontal alignment

- From the Cross Sections menu, choose Ditch/Transition ➤ Edit Plan Alignment to display the Horizontal Alignment Editor with the current alignment data.

For more information, see “Using the Cross Section Elements in a Plan Alignment” in this chapter.

Using the Cross Section Elements in a Profile

Often you find that when you attach a transition or ditch line to the cross sections, you need to make edits to the offset and elevation data. You can use either the Edit Design Control command or the View/Edit Sections command to edit the transition values. After editing the ditch and transition cross section information, you can use commands in the Ditch/Transition submenu on the Cross Sections menu to import this information into the plan or profile view.

There are a number of reasons why you would import these lines into the plan or profile. For example, if you defined a ditch by profile elevations and a fixed side slope, then you can import the ditch lines into plan to view the location of the ditch. After these lines are imported, you can make any necessary edits, and then define them as a horizontal or vertical alignment. If the ditch or transition lines were originally attached to the cross sections from alignments, you can import these lines into the plan or profile to merge the changes into the
original definition then redefine the alignment. You can also import these lines strictly for plotting purposes.

If the outer edge of the superelevation region on the template was also defined as a transition point, then you can also import the left and right superelevation profiles onto the appropriate transition layers.

**NOTE**
The import lines are drawn as straight line segments between each section station. For horizontal alignments it may be necessary to replace some lines with arc segments.

### Importing a Ditch or Transition from the Sections into a Profile

To import a vertical transition or ditch line using information from the defined cross sections, use the Import Profile command. You can import any of the finished ground transitions or ditches as well as the left and right superelevation lines (LS and RS).

There are a couple of prerequisites to using this command, depending on whether you want to import ditch or transition lines:

- If you are importing a transition line to plan or profile, the transition must have been defined on the template with the Edit Template command.
- If you are importing ditches, then the ditches must have been applied to the with the Edit Design Control command.

**To import a ditch or transition profile**

1. From the Cross Sections menu, choose Ditch/Transition ➤ Import Profile.
2. Specify whether you want to import the left or right profile.
3. Select a vertical transition or ditch line.

   The type of prompt that is displayed depends on which profile is selected (right or left). For example, the following prompt is displayed if the left profile is selected:

   **Left profile to draw (Ditch/Super/1/2/3/4/5/6/7/8):**

   You are not limited to just importing transitions that were attached to the sections with the Edit Design Control command. You can import any of the eight transitions if they have been defined as part of the template with the Edit Template command. If the sections have been defined with ditches, then the ditch option can be used to import the profile.

   You can also import the outer edge of the superelevation region, but since the profile does not directly support superelevation definitions, you need to import it to a transition layer. You should select the transition that has been defined at the same location as the outer edge of the superelevation region.

4. Enter the beginning and ending stations.

   The transition, ditch, or superelevation is then drawn on the profile as straight line entities between sections on the layer specified with the profile EG Layers and FG Layers commands.
After you have imported the transition, ditch, or superelevation lines, you can edit them, redefine them with the Define Profile Alignment command, then reattach them to the cross sections using the Edit Design Control command.

**Importing the Superelevation into a Profile**

Profiles do not directly support superelevation because superelevation is based on grade, not elevation. However, you do have the option of converting the superelevation information to a transition so that you can import it to the profile.

By using this option you can either plot the superelevation for viewing purposes, or you can edit the profile and attach it to the template as a transition. To do this you need to have the transition point defined at the same location as the superelevation region point. Then, before you attach the profile transition to the sections, you need to turn off the Superelevation calculations toggle in the main Superelevation Parameters dialog (Cross Section ➤ Design Control ➤ Superelevation Parameters). This allows the outer edge of the superelevation region to be completely controlled by the transition profile elevations.

**To import the superelevation into a profile**

1. From the Cross Sections menu, choose Ditch/Transition ➤ Import Profile.
2. Specify whether you want to import the left or right profile.
   
   The type of prompt that is displayed depends on which profile is selected (right or left). For example, the following prompt is displayed if the left profile is selected.

   Left profile to draw (Ditch/Super/1/2/3/4/5/6/7/8):

3. If you specify S for Superelevation at step 3 while importing the ditch or transition from the sections into a profile, and if you specified Left at step 2, then the following prompt is displayed for the left side:

   Profile layer to use (L1/L2/L3/L4/L5/L6/L7/L8):

4. Specify the transition layer to use.

   These layer names represent the transition regions you define on the template with the Edit Template command. The superelevation control point and the transition control point have to be in the same location on the template in order for this to work. So, you must specify the number of the transition region that coincides with the outer left (or right depending on which side is imported) superelevation region point.

**Defining a Ditch or Transition as a Vertical Alignment**

After importing a vertical ditch or transition into the profile, you can define it as a profile alignment since the transitions and ditches are imported as line entities.
To define a ditch or transition as a vertical alignment

1. From the Cross Sections menu, choose Ditch/Transition ➤ Define Profile Alignment.
   
   The following prompt is displayed:
   
   Select profile (Center/Left/Right) <Center>:
   
2. Select the type of profile alignment you want to define by typing the appropriate letter.
   
   Type R or L for Right or Left to display a prompt similar to the following:
   
   Select left profile (Ditch/1/2/3/4/5/6/7/8) <1>:
   
3. Type D for Ditch, or enter the appropriate number for a transition.
   
   Next, the command turns off all layers except the finished ground layer, showing just the profile alignment line you specified.

   [NOTE] From the Profiles menu, choose DT Tangents ➤ Set Current Layer command to set the correct layer. If any of the entities are drawn on the incorrect layer, use the AutoCAD CHANGE command to fix them.

4. Pick the starting point of the alignment. This should be the point with the lowest station value on the finished ground alignment. The command sets the AutoCAD object snap to END automatically. The command then prompts for the objects that make up the alignment.

5. Select the entire alignment using window or crossing to complete the definition.

6. At the next Select objects prompt, press ENTER when all the entities that make up the alignment have been selected. The command connects the entities and writes the data to an external database.

**Editing a Ditch or Transition Profile Alignment**

You can use the Edit Profile Alignment command to enter the finished ground for the alignment, or to view and edit existing ground data created graphically with the Sample From Surface command in the Cross Sections menu.

1. From the Cross Sections menu, choose Ditches/Transitions ➤ Edit Profile Alignment.
   
   The following prompt is displayed:
   
   Select profile (Center/Left/Right) <Center>:
   
2. Select the type of profile alignment you want to define by typing the appropriate letter to display the select profile prompt.
   
   The type of prompt that is displayed depends on which profile is selected (right or left). For example, the following prompt is displayed if the left profile is selected:
   
   Select left profile (Ditch/1/2/3/4/5/6/7/8) <1>:
   
3. Select appropriate profile number or ditch option. The Vertical Alignment Editor is displayed.

4. Click OK to exit the dialog box.
### Outputting and Importing Template Points

You can use the commands on the Point Output submenu on the Cross Sections menu to import existing ground, top surface finished ground, datum points, or template point codes into the drawing. The points are imported as LDD point objects on the current layer. The template points are based on the defined datum or top surface points. Ditch and slope points are also can be imported.

**NOTE**

If you want to import top or datum surface points, you must first use the Edit Template command to define these points. If you want to import custom point codes, you must also place these points on the template with the Edit Template command.

The following prerequisites must be met before using any of the Point Output commands:

- Define an alignment
- Sample the existing ground profile from a surface or file
- Define a finished ground centerline
- For the existing ground, generate cross section data using the Existing Ground ➤ Sample From Surface, or the Existing Ground ➤ Sample From File command on the Cross Sections menu.
- For the finished ground, create a template and apply it to the existing ground using the Design Control ➤ Edit Design Control command on the Cross Sections menu.

### Importing the Template Points into a Drawing

Using the Point Output ➤ Tplate Points To DWG command on the Cross Sections menu, you can import existing ground, top surface finished ground, volume datum points, or template point codes into the drawing. The template points are based on the defined datum or top surface points.

The point codes can be any custom point codes you set on the template with the Edit Template command, or they can be the point codes that are automatically set.

**To import the template points into a drawing**

1. Select or define an alignment, if you haven’t done so already.
2. From the Cross Sections menu, choose Point Output ➤ Tplate Points To DWG. The command prompts for the range of stations to use. The default range is the beginning and ending stations of the alignment. The command brings in section points for every cross section station in the specified range. These points come in on the current layer.
3. Specify the beginning and ending range of points or accept the default station range points.
4 Specify the type of surface points to import:

- **Existing**: Bring in the points from the existing ground cross section data for specified swath width.

- **Datum**: Import the points defining the volume datum line, including the ditch and slope points. The Datum option prompts for the datum number. The default number is one (1).

- **Top**: Import points along the top surface of the applied template, including the ditch and slope points. The Top option prompts for the top surface number. The default number is one (1). In order to use a top surface, you must have defined one for your template.

- **Pcodes**: The point codes can be any custom point codes you set on the template with the Edit Template command, or they can be the point codes that are automatically set.

The command prompts you for the current point number.

5 Accept the default current point number, or enter a new number.

The command imports the points into the drawing.

The existing ground, top surface, and datum points are placed on the current layer and tagged as follows:

<table>
<thead>
<tr>
<th>Type of Point</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Existing Ground</td>
<td>(Specified Surface Name)</td>
</tr>
<tr>
<td>Top Surface</td>
<td>FG</td>
</tr>
<tr>
<td>Datum</td>
<td>Datum</td>
</tr>
</tbody>
</table>

The following illustration shows an example of using the Pcodes option to import points into the drawing:

![Imported finished ground points detail](image-url)
The following illustration shows imported finished ground points:

![Imported template point codes detail](image)

**Outputting the Template Point Data to a File**

To write the template points data to a file, use the Tplate Points To File command on the Cross Sections menu. This command creates an output that is 80 characters wide. The file contains the station, offset, and elevation information for each point.

**To write the template points data to a file that contains the station, offset, and elevation information for each point**

1. Configure the output settings, if you haven't done so already. The Tplate Points To File command ignores the Screen and File check boxes in the Output Settings dialog box because it always sends information to a file.
2. From the Cross Sections menu, choose Point Output ➤ Tplate Points To File. The command prompts you for an output file name.
3. Type an output file name, or press ENTER to accept the default.

   Type the path and give the file the extension *.txt, for example, c:\Program Files\Land Desktop R2\output.txt. The default is based on the file name entered in the output settings and the default folder, which is the install folder of Land Development Desktop.

   **NOTE** If you are using multiple surfaces, the Tplate Points To File command prompts for the existing ground surface name to process. From the Surface Selection dialog box, choose the name of the surface to process. The command then adds template points to the drawing when it is importing existing ground data. Otherwise, the command prompts for the points either on the existing ground or the finished ground surface, or both surfaces to write to a file. When there is only one existing ground surface, the Surface Selection dialog box does not display because the Autodesk Civil Design program selects the existing ground surface automatically.

4. Do one of the following to write to the file:
   - Type E to use the existing ground surface.
   - Type F to use the finished ground.
   - Type B to use both surfaces.

   If you are outputting existing ground information only, continue on. If you are outputting the points on either two surfaces or only the finished ground,
information, see “Outputting the Template Point Data to a File” or “Outputting Finished Ground Information” in this chapter.

The Tplate Points To File command prompts for beginning and ending stations to determine the range of the output. The default values indicate the entire alignment.

Accept the default beginning and ending stations to determine the range of the output, or enter new values. If the end station entered is less than the start station, then a message is displayed on the command line, stating: “the station range you entered is not valid. Press any key to continue...”

The information is written to an ASCII file using the file name indicated. You can view or edit this file using any ASCII text editor, such as Notepad or Wordpad.

**Outputting Finished Ground Information**

The command prompts for the finished surface points to write: either Datum or Top surface.

**To output finished ground information**

1. Specify the finished surface points to write:
   - Type **T** for top surface, then enter the top surface number when you are prompted to do so. You must have created a top surface.
   - Type **D** for datum, then enter the datum number when you are prompted to do so.
   - Type **P** for Pcodes, so that various points codes can be reported into a file.
   Use the Pcodes command to import the selected point codes into the drawing. When you type **P** to access this option, the Select Point Codes dialog box is displayed.
   Use this dialog box to use one of the following methods to select the point codes you want to import into the drawing: Select individual point codes with your pointing device. Click Select All to select all the point codes. The Clear All button clears all the point codes you have selected. Click OK when you have completed the selection set.

   These points make use of the Land Development description key feature if you have the description key option from the Point Creation Settings command selected, and the point code descriptions are defined in the description key file. With template point codes you can make use of more than one point code file. You can have one point code table with descriptions that are appropriate for plotting with Sheet Manager and you can set up another file with the descriptions modified to work with the description keys. All that is required is to use the Edit Point Code Table command to set the desired table name before importing the template points, or plotting the sections with Sheet manager.

The Tplate Points To File command prompts for beginning and ending stations to determine the range of the output. The default values indicate the entire alignment.
2 Accept the default beginning and ending stations to determine the range of the output, or enter new values.

If the end station entered is less than the start station, then a message is displayed on the command line, stating: “The station range you entered is not valid. Press any key to continue...”

The information is written to an ASCII file using the file name indicated. You can view or edit this file using any ASCII text editor, such as Notepad or Wordpad.

The following is a sample output template points file:

page 1
Hillsboro Bypass phase 2
Project: ROUTE202                              Tue Nov 2 16:37:15 1999
Cross Section Data File
---------------------------------------
Project: ROUTE202  Roadway: 202cl
Start station:            10+00
End station:              14+00
Maximum left offset:      175.000000
Maximum right offset:     175.000001
Maximum elevation:        823.212748
Minimum elevation:        734.379229
Total number of sections: 63
-----------------------------------------------------------------------
STATION                 OFFSET                 ELEVATION
-----------------------------------------------------------------------
10+00
Finish ground: Top Surface #1
-60.32                   751.30
-58.32                   751.30
-22.50                   760.25
-20.00                   760.88
-12.00                   761.36
 0.00                    761.60
 12.00                    761.36
 20.00                    760.88
 22.50                    760.25
 79.22                    746.07

Importing the Catch Points and Daylight Lines into the Drawing

A catch point is the point where a design slope matches into the existing ground surface. To bring these points into the drawing, use the Catch Points To DWG command on the Cross Sections menu.

The Catch Points To DWG command imports points at the location where existing and finish ground meet. It also imports the daylight lines connecting them.

NOTE Process the cross sections with the Edit Design Control command before using the Catch Points To DWG command.
To import the catch points and daylight lines into the drawing

1. Process the cross sections with the Edit Design Control command, if you haven't done so already.
2. From the Cross Sections menu, choose Point Output ➤ Catch Points To DWG.
3. Specify whether to import catch points and/or daylight lines in the next two prompts.
   The catch points and daylight lines are broken into separate prompts so you can bring them in together or individually.
4. Specify the range of stations to import for the catch points and/or daylight lines.
   The catch points are brought in for every cross section station within the specified range.
5. Enter the current point number. This is the point number the command uses as the starting point number for the imported points. The default is the current point number in the Point Settings dialog box. The command imports the catch points and/or daylight lines into the drawing.
   The daylight lines that connect the catch points are automatically placed on the DAYLIGHT layer and the catch points are placed on the current layer or the layer specified in the Description Key menu if description keys are used. The catch points are given the description CPT.

The following illustration details imported catch points and daylight lines:

---

**Outputting the Catch Point Data to a File**

The Tplate Points to File command produces an output file 80 characters wide. This file contains the station, offset, and elevation information for each catch point.

**To write the catch point data to a file**

1. Process the cross sections with the Edit Design Control command, if you haven't done so already.
2. Configure the output settings, if you haven't done so already.
   The Tplate Points To File command ignores the Screen and File check boxes in the Output Settings dialog box since it always sends information to a file.
3 From the Cross Sections menu, choose Point Output ➤ Catch Points To File.
4 Specify the range of stations for the catch points to be written to the file.

If the end station entered is less than the start station, then a message is displayed on the command line, stating: “The station range you entered is not valid. Press any key to continue...”

The catch points are written for every cross section station within the specified range. The starting station must be less than the end station. If the end station entered is less than the start station, then the command writes an empty file.

The command prompts you for the output file name.
5 Specify a name for the output file.

Type the path and give the file the extension of *.txt (i.e. c:\Program Files\Land Desktop R2\output.txt.

The information is written to an ASCII file using the file name indicated. You can view or edit this file using any ASCII text editor, such as Notepad or Wordpad.

The following is a sample of a catch point data output file:

<table>
<thead>
<tr>
<th>STATION</th>
<th>OFFSET</th>
<th>ELEVATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>10+00</td>
<td>-80.62</td>
<td>757.74</td>
</tr>
<tr>
<td>10+00</td>
<td>87.36</td>
<td>747.92</td>
</tr>
<tr>
<td>10+50</td>
<td>-80.32</td>
<td>758.14</td>
</tr>
<tr>
<td>10+50</td>
<td>89.25</td>
<td>748.16</td>
</tr>
<tr>
<td>11+00</td>
<td>-80.00</td>
<td>758.53</td>
</tr>
<tr>
<td>11+00</td>
<td>90.78</td>
<td>748.28</td>
</tr>
<tr>
<td>11+50</td>
<td>-79.71</td>
<td>758.93</td>
</tr>
<tr>
<td>11+50</td>
<td>91.49</td>
<td>748.13</td>
</tr>
<tr>
<td>12+00</td>
<td>-79.42</td>
<td>759.33</td>
</tr>
<tr>
<td>12+00</td>
<td>93.32</td>
<td>748.35</td>
</tr>
</tbody>
</table>
Plotting and Outputting the Cross Sections

The Section Plot submenu on the Cross Sections menu contains commands you can use to plot cross sections in the drawing and output finished design information. Use these commands to do the following: plot cross sections to a drawing; label various aspects of the cross sections; list information about selected cross section parameters; create a three-dimensional grid; and import points to the drawing or to a file.

Changing the Output Settings for Outputting Cross Sections

To change the output settings

1. From the Cross Section menu, choose Output Settings to display the Output Settings dialog box.

2. Under Output Options, select one of the following options to output the file:
   - Select the File check box to output the information to a text file.
   - Select the Screen check box to output the information to the screen.

3. Under Output Format, select or clear the following check boxes:
   - **Date**: Select this check box to place the date on the report:
     
- **Title**: Select this check box to place a title on the report.

  Horizontal Alignment PI Station Report.
  Alignment: Road1    Desc: Subdivision access road

- **Page Breaks**: Select this check box to place page breaks in the report. When you select this check box, and create a Screen report, the text window displays only the first page of the information, and then the command prompts you to press a key to continue. When you press a key, the next page of the report is displayed. If you do not select this check box, then the screen report does not stop at each page as the information is output. When you select this check box, and create a File report, the report is created with page breaks instead of having all the information displayed in one long list. If you select the Sub Headers check box and the Page Breaks check box, then sub headers are placed at the beginning of each page break as shown below:

  page 2
  Station & Offset Listing by Selection
  Point       Station           Offset          Elevation
  Description

- **Page Numbers**: Select this check box to place page numbers on a report. This setting applies to File output only.

- **Sub Headers**: Select this check box to place sub headers at the beginning of each new page of a report. This setting applies to File output only. You must also select the Page Breaks check box if you want sub headers to appear. The sub headers are placed at the beginning of each page break, as shown below:

  page 2
  Station & Offset Listing by Selection
  Point       Station           Offset          Elevation
  Description

- **Overwrite File**: To overwrite a file, select the Overwrite File check box to overwrite a file if it already exists. Clear the Overwrite File check box to append new information to the end of an existing file.
4 Under Output Format, specify the following information:
   - **Page Length**: Type the number of rows of type you want to have on each page in this box. The spacing is measured in characters. This setting only applies if the Page Breaks check box is selected and applies to File output.
   - **Page Width**: Type the number of characters you want to have across each page in this box. This setting only applies to File output. If the report is set up to report information in columns, this setting is ignored.
   - **Left Margin**: Type the number of characters you want to have as a left margin in this box. This setting only applies to File output.
   - **Right Margin**: Type the number of characters you want to have as a right margin in this box. This setting only applies to File output.
   - **Top Margin**: Type the number of characters you want to have as a top margin in this box. The margin is inserted between the page number (if you select the Page Numbers option) and the report title. This setting only applies to File output.
   - **Bottom Margin**: Type the number of characters you want to have as a bottom margin in this box. This setting only applies to File output.

5 Enter the Output File Name.

**NOTE** Each time you create a new report, be sure to change the default output file name so you do not overwrite or append the previous report.

6 If needed, you can click Output File Name to specify a folder for the output file. If you do not specify an output folder, then the file that is created is placed in the current project folder.

7 Click OK when you have finished changing the settings.
Changing the Cross Section Plotting Settings

To set the default layers and precision for cross sections

1. From the Cross Sections menu, choose Section Plot ➤ Settings to display the Cross Section Plotting Settings dialog box.

2. Select the Existing Ground, Template, Datum, Grid, Grid Text, and ROW lines check boxes to select the cross section elements to be plotted. Use the adjacent edit boxes to enter layer names.

   **NOTE** If you are plotting cross sections that are sampled from multiple surfaces, you can type an asterisk (*) in the Existing Ground Layer box after the name of the layer. This appends the surface name to the end of the layer name so that each plotted existing ground representation is placed on a separate layer. For example, if you sampled the existing ground from surfaces named Rock and Clay, and you typed XEG-* in the Existing Ground Layer box, then the existing ground surfaces in the plotted cross sections are placed on XEG-Rock and XEG-Clay.

3. Define the cross section layout settings.

4. Define the cross section page layout settings.

The following illustration shows the parameters used in plotting cross sections:

Parameters used in plotting cross sections
Changing the Section Layout Settings for Plotting Cross Sections

To change the section layout settings for plotting cross sections

1. From the Cross Sections menu, choose Section Plot ➤ Settings to display the Cross Section Plotting Settings dialog box.

2. Click Section Layout to display the Section Layout dialog box.

3. Use the increment edit boxes to adjust the increments for inserting the cross sections on the drawing.

   The four increments available affect the cross section grid that is overlaid on the cross section. Enter the following increments in drawing units:
   
   - **Offset incr**: Enter the distance between the vertical lines on the grid.
   - **Elevation incr**: Enter the distance between the horizontal lines on the grid.
   - **Offset lbl incr**: Enter the label increment. This increment determines which offset grid lines to label. If you set the label increment to one (1), then every grid line is labeled. If you set the label increment to 2, then every other line is labeled.
   - **Elevation lbl incr**: Enter the label increment. This increment determines which elevation grid lines to label. If you set the label increment to one (1), then every grid line is labeled. If you set the label increment to 2, then every other line is labeled.

4. Use the precision edit boxes to control the precision used for the labels placed on the cross section:

   - **Offset prec**: Enter the precision for labeling the cross section offset grid lines.
   - **Elevation prec**: Enter the precision for labeling the cross section elevation grid lines.
   - **FG lbl prec**: Enter the precision of the actual finished ground centerline elevation label text.
   - **EG lbl prec**: Enter the precision of the actual existing ground centerline elevation label text.

   **NOTE**: The precisions you enter in the FG lbl prec and EG lbl prec edit boxes do not affect the calculations used by the commands. All calculations use the highest internal precision.
5 Use the last two settings displayed in the Section Layout dialog box to control the rows below datum and rows above maximum. These values control how many extra grid cells are plotted with the cross section:

- **Rows below datum**: Enter the number of rows of grid cells that should be placed below the datum.
- **Rows above max**: Enter the number of rows of grid cells that should be placed above the highest point on either the existing ground or the template.

6 Click OK to return to the Cross Section Plotting Settings dialog box.

The following illustration shows the cross section grid:

Cross section grid

### Changing the Page Layout Settings for Plotting Cross Sections

To change the page layout settings for plotting cross sections

1 From the Cross Sections menu, choose Section Plot ➤ Settings to display the Cross Section Plotting Settings dialog box.
2 Click Page Layout to display the Page Layout dialog box.

3 You can change the following information in these edit boxes:

- **Sheet height**: Enter the height of a page of cross section in plotted units (inches or millimeters).
- **Sheet width**: Enter the width of a page of cross section in plotted units (inches or millimeters).
- **Left margin**: Enter the distance between the left edge of the sheet and the border in plotted units (inches or millimeters).
- **Right margin**: Enter the distance between the right edge of the sheet and the border in plotted units (inches or millimeters). The right margin is a
minimum. This value is keyed to the values entered for the offset increment and elevation increment in the previous section.

- **Top margin**: Enter the distance between the top edge of the sheet and the border in plotted units (inches or millimeters). The top margin is a minimum. This value is keyed to the values entered for the offset increment and elevation increment in the previous section.

- **Bottom margin**: Enter the distance between the bottom edge of the sheet and the border in plotted units (inches or millimeters).

- **Column spacing**: Enter the vertical spacing between sections. The column spacing is the number of "cells" placed horizontally between cross sections.

- **Row spacing**: Enter the horizontal spacing between sections. The row spacing is the number of cells placed vertically between the cross sections.

**NOTE**

The cell width is dependent on the offset increment. The cell height is dependent on the elevation increment. For example, if you set the offset increment to 10 and you set the column spacing to 4, there will be 40 units between columns of cross sections.

- **Vertical sheets**: Enter the number of sheets that will be drawn in the vertical direction when you use the Multiple option of the Page command. For more information on this option, see the Page command description.

The cross section output is dependent on the horizontal and vertical scale. Set these scales when you are setting up the drawing.

4 Click OK to return to the Cross Section Plotting Settings dialog box.

The following illustration shows column and row spacing for multiple cross sections plotting:

![Column and row spacing](image)

Column and row spacing
Changing the Text Size for the Plotted Section Labels

**NOTE** You can also use the Set Text Style command in Drawing Setup to change the text size for labels.

**To set the current text size for labels**

1. From the Cross Sections menu, choose Section Plot ➤ Set Text Style to display the Text Style dialog box.

2. To set a new style, select the style name.

3. Click OK to exit the Text Style Selection dialog box.

To use a style that is not on the list, create it with the AutoCAD STYLE command.

**Plotting a Single Cross Section**

When plotting cross sections, it is a good idea to begin a new drawing using the same project name and import the cross sections to that drawing. By doing this you can use a specific horizontal and vertical scale for plotting cross sections.

You can use the plotted cross sections for design purposes or for final plots.

**NOTE** If you sampled multiple surfaces with the Sample From Surface command, then the Single command brings in all of the surfaces.

**To plot a single cross section**

1. From the Cross Sections menu, choose Section Plot ➤ Single. You are prompted for a station.

2. Enter the station of the first section.

   The default is the first station in the sampled range. If the station you enter in response to this prompt is not a sampled section, but lies within the range of sampled stations, then the command draws the cross section of the next
station. If the station lies outside the range of sampled stations, then you are prompted to enter another station. In addition, a message is displayed at the command prompt, stating “Station entered is not within the alignment.”

You are prompted to pick the bottom insertion point.

3. Pick the bottom insertion point.

This is the point at the bottom of the cross section where the centerline of the alignment intersects the lowest elevation grid line (even if grids are not imported).

You are prompted for another station. The default is the next sequential station.

4. Enter another station if you want to plot another section. Press ENTER in response to both the Station prompt and the Pick bottom insertion point prompt to end the command.

The following illustration shows a single cross section:

![Single cross section](image)

**Plotting Multiple Cross Sections**

This command draws the cross sections in columns from bottom to top and left to right. The maximum number of vertical sheets is determined by the value in the plotting settings. If you used the Sample From Surface command to sample multiple surfaces, then the Page command brings in all of the surfaces.

**NOTE**
The current view must encompass the entire sheet or the option for plotting the sections to drawing files will not work.

To plot multiple cross sections

1. From the Cross Sections menu, choose Section Plot ➤ Page.

You are prompted to select a page import type.

2. Type S or M to import the page(s):
   - Type S for Single to import a single page.
   - Type M for Multiple to import multiple pages.

The command prompts for whether or not to import the page(s) into the current drawing.
3 Decide whether to import the page(s) into the current drawing by doing one of the following:

<table>
<thead>
<tr>
<th>If you ...</th>
<th>Then type...</th>
</tr>
</thead>
<tbody>
<tr>
<td>want to import pages into the current drawing</td>
<td>Y for Yes and enter a starting station. Enter a starting station and a sheet origin point. The starting station for the first plotted section and the lower left corner of the sheet are prompted for regardless of where the cross sections are being imported.</td>
</tr>
<tr>
<td>do not want to import pages into the current drawing</td>
<td>N for No and enter the drawing prefix. Enter the drawing prefix, the starting sheet number, a starting station and a sheet origin point. The drawing prefix can have a maximum of 5 characters. The name of the drawing is based on the drawing prefix entered and the sheet number. For example, if the drawing prefix is 202cl and the first sheet number is 1, the drawing containing the first page of cross sections is named 202cl001. These drawings are created in the Land Development Desktop's install folder.</td>
</tr>
</tbody>
</table>

**NOTE** If there are any drawing entities within the sheet boundary, then they are also written out.

The following illustration shows a single page of cross sections:
The following illustration shows a drawing with all the cross section pages imported:

![Multiple drawing file of cross section pages]

**Importing All Plotted Cross Sections into a Drawing**

The Section Plot ➤ All command draws the cross sections in columns from bottom to top and left to right. The command uses the sheet height from the plotting settings to determine the maximum height to plot the sections. If you sampled multiple surfaces with the Sample From Surface command, then the All command brings in all of those surfaces.

To create and import cross section plots for an entire alignment

1. From the Cross Sections menu, choose Section Plot ➤ All.
2. Enter the beginning and ending stations to plot.
3. Pick the sheet origin point.

The layer name for each existing ground surface is a combination of the prefix set with the Section Plot ➤ Settings command and the actual surface name.
The following illustration shows cross sections imported with the All command:

![Cross sections imported in one drawing](image)

**Erasing a Cross Section**

Each new cross section that you plot also has an accompanying definition block inserted with it. This block holds information such as layer names and vertical scales. Whenever you erase a cross section using an AutoCAD command, you should also erase the definition block. You can do this by using the Undefine Section command. If you do not use this command, then the cross section information is left in the drawing and could cause problems with some commands.

**To erase a cross section**

1. From the Cross Sections menu, choose Section Plot ➤ Undefine Section. The following prompt is displayed:

   Delete cross section definition block(s) for alignment <{Align name}> (Yes/No) <No>:

2. Do one of the following:
   - Type Y for Yes to delete all the cross section definition blocks for the selected alignment.
   - Press ENTER to exit the command without deleting the definition block.

**Section Utilities**

The Section Utilities menu contains commands to list and label areas on plotted cross sections. This menu also includes commands to move between views of the different plotted cross sections. These commands are for use with the cross sections that are created from the Cross Sections menu.

Plotted cross sections must exist in the current drawing before you can use any of these commands. If you have used the Undefine Section command on any of
the cross sections, then inaccuracies may occur when zooming to, listing information from, or labeling these cross sections.

NOTE Many of the Section Utilities commands require that a current cross section is set. Use Select by Station, Select by Point, Zoom to Station or Zoom to Point commands to set the current section.

Choosing the Current Cross Section by Entering a Station Number

You can use the Section Utilities ➤ Select By Station command to set the current cross section using an entered station. You must first plot cross sections in the current drawing before using this command.

To set the current cross section using an entered station

1 Plot cross sections in the current drawing, if you haven't done so already. For more information, see “Plotting Multiple Cross Sections” in this chapter.

2 From the Cross Sections menu, choose Section Utilities ➤ Select By Station. The command searches the current drawing for all defined sections. The following prompt is displayed:

Station:

3 Enter the number of the station you want to set as current. You must enter the exact station of the cross section. If you need to enter an odd station, then be sure to enter the station exactly. It may be easier to select cross sections of odd stations using the Select By Point command.

The command searches the defined sections for a correct match. If a match is made, the command displays the station number of the current cross section.

Choosing the Current Cross Section by Picking a Point

To set the current cross section using point selection

1 From the Cross Sections menu, choose Section Utilities ➤ Select By Point. The command searches the current drawing for all defined sections. The following prompt is displayed:

Select point within desired section:

2 Select the cross section by selecting a point anywhere within the boundary of the cross section grid.

This command recognizes any point within the boundaries of the grid even if the grid is turned off. You can define the grid boundaries with the Section Plot Settings command.

The command searches for the appropriate sections and displays the station number of the current cross section.
**Zooming to a Cross Section by Entering a Station Number**

To zoom to a cross section by entering a station number

1. From the Cross Sections menu, choose Section Utilities ➤ Zoom To Station. The command searches the drawing for defined sections.
   The following prompt is displayed:
   
   Station:

2. Enter the station number.
   
   A command prompt similar to the following prompt is displayed:
   
   Zoom height <6155.42737008>:

3. Enter the height of the zoom window. The default value is either the height of the previous cross section window or the vertical limit of the current drawing.
   
   The command zooms to the station at the specified zoom height.

**Zooming to a Cross Section by Picking a Point**

To zoom to a view of a cross section by picking a point

1. From the Cross Sections menu, choose Section Utilities ➤ Zoom To Point. The command searches the drawing for defined sections.
   The following prompt is displayed:
   
   Select point within desired section:

2. Select a point within the desired section.
   
   A prompt similar to the following prompt is displayed:
   
   Zoom height <6155.42737008>:

3. Enter the height of the zoom window. The default value is either the height of the previous cross section window or the vertical limit of the current drawing.
   
   The command zooms to the station at the specified zoom height.

**Listing the Offset and Elevation of Cross Section Points**

To list the offset and elevation of points selected on plotted cross sections

1. From the Cross Sections menu, choose Section Utilities ➤ List Offset/Elevation. The command lists the starting and ending stations, and the current section.
   The following prompt is displayed:
   
   Point:
2 Select the point to list, or enter the coordinates of the point. You can use object snaps to help you select the point. The command displays the offset and elevation of the selected point.
3 Select additional points to list, or press ENTER to end the command.

**Listing the Slope, Grade, and Elevational Difference on a Cross Section**

**To list the slope, grade, and elevational difference of points selected on plotted cross sections**

1 From the Cross Sections menu, choose Section Utilities ➤ List Slope/Grade. The command lists the starting and ending stations, and the current section. The following prompt is displayed:

   First point:

2 Select the points that define the slope to list, or enter the coordinates of the points. You can use object snaps to select the points.

   The command displays the slope, grade in percent, and elevation difference between the selected points.

3 Continue selecting slopes to list, or press ENTER to exit the command loop.

**Listing a Selected Area of a Cross Section**

When you use the List Area command, the command takes the vertical scale exaggeration into account. The AutoCAD AREA command does not consider the vertical exaggeration.

**To list areas defined on plotted cross sections**

1 From the Cross Sections menu, choose Section Utilities ➤ List Area. The command lists the starting and ending stations, and the current section. The following prompt is displayed:

   AREA first point:

2 Select the points that define the area. The command continues to display the Next point prompt.

3 Press ENTER in response to this prompt once all of the points have been selected. The command displays the calculated area.

   The AREA first point prompt is displayed again.

4 Press ENTER in response to this prompt after all of the areas have been listed.
Labeling Cross Sections

The defaults and actual prompt structures for the Label commands vary depending on whether or not you have run the commands previously in the drawing session. All of the Label commands use the default values and the options used the last time the command was run. Each of the command descriptions shown in this section describe the command prompts and defaults as they appear the first time you run the command during a drawing session.

Changing the Text Size for Cross Section Labels

To change the text size for cross section labels

1. From the Cross Sections menu, choose Section Utilities ➤ Set Text Style to display the Text Style dialog box. This dialog box shows all of the defined text styles.

   ![Text Style Dialog Box]

   The name of the current text style is displayed above the list.

2. Select the style name.

3. Click OK.

   To use a style that is not on the list, create it with the AutoCAD STYLE command.

   **NOTE** This affects only sections that have not yet been plotted to the drawing; existing section text is not modified.
Labeling the Offset of the Cross Section Points Automatically

To automatically label the offset of a selected point on a plotted cross section

1. From the Cross Sections menu, choose Section Utilities ➤ Label Offset. The command lists the starting and ending stations and the current section.

   The following prompt is displayed:
   
   Text rotation angle <0d0'0">:

2. Enter the text rotation angle for the offset label, or press ENTER to accept the default. If you enter a new value for a rotation angle, then this new value becomes the default for successive uses of the command.

   The following prompt is displayed:
   
   Type of text placement (Auto/Manual) <Manual>:

3. Type A to use the Auto option.

   The following prompt is displayed:
   
   Text orientation (Random/Linear) <Random>:

4. Specify the type of text orientation:
   - Type R to use the Random option, and then select a point to label. The label appears at the point you selected.
   - Type L to use the Linear option. Select a point to define the line (parallel to datum line) the label appears on, and then select a point to label. The label appears at the point of perpendicularity between the selected point to be labeled and label line defined above. All offset labels that are created are located along the imaginary line defined to place labels.

5. Pick any other point to label the offset or press ENTER to end the command.

   The following illustration shows a label placed using the Linear option:

   ![Offset label using the linear option](image-url)

   Offset label using the linear option
The following illustration shows the effect of using the Random option:

The following illustration shows the effect of using the Random option:

Offset label using the random option

**Labeling the Offset of the Cross Section Points Manually**

To label the offset of the cross section points manually

1. From the Cross Sections menu, choose Section Utilities ➤ Label Offset. The command lists the starting and ending stations and the current section.
   The following prompt is displayed:
   
   Text rotation angle <0d0'0">: 

2. Enter a rotation at which you want the label to appear, or press ENTER to accept the default. You can either pick two points to define a new rotation angle, or you can enter a numeric angle value at the prompt. If you enter a new value for a rotation angle, then this new value becomes the default for successive uses of the command.
   The following prompt is displayed:
   
   Type of text placement (Auto/Manual) <Auto>: 

3. Type M to use the Manual option.
   You are prompted for a point.

4. Select the point to be labelled.
   The following prompt is displayed:
   
   Insertion point (Rotation/Leader): 

Labeling Cross Sections

425
5 Specify the insertion options:

<table>
<thead>
<tr>
<th>If you...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>want to change the rotation angle of the label</td>
<td>type Rotation. Use the Rotation option to change the rotation angle of the label you are placing. If you do not specify anything for this option, a rotation angle entered in step 1 is used while labeling the offset. You can either pick two points to define a new rotation angle, or you can enter a numeric angle value at the prompt. After specifying the rotation angle, the following prompt is displayed: Insertion Point (Rotation/Leader):</td>
</tr>
<tr>
<td>want to change the label leader</td>
<td>type Leader. Use the Leader option to pick points and define the leader for the label. This option uses the point you chose in step 4 as the start of the leader. Press ENTER when you have selected the leader points, and the command places the label at the last point you selected.</td>
</tr>
<tr>
<td>do not want to specify these options</td>
<td>go to step 6.</td>
</tr>
</tbody>
</table>

6 Select the location for the label with the pointer, or continue on with additional options of Rotation or Leader.

7 Pick any other point to label the offset, or press ENTER to end the command.

The following illustration shows the rotation angle of a cross section label:
The following illustration shows the effect of the Point option:

![Point option illustration]

The following illustration shows the effect of the Leader option:

![Leader option illustration]

**Labeling the Elevation of the Cross Section Points Manually**

This command uses the same prompt structure as the Label Offset command. Instead of labeling points with offsets, the Label Elevation command places elevation labels.

**To label the elevation of cross section points**

1. From the Cross Sections menu, choose Section Utilities ➤ Label Elevation. The command lists the starting and ending stations and the current section.

   The following prompt is displayed:

   Text rotation angle <0d0’0“>:

2. Enter a rotation at which you would like the label to appear, or press ENTER to accept the default. You can either pick two points to define a new rotation angle, or you can enter a numeric angle value at the prompt. If you enter a new value for a rotation angle, then this new value becomes the default for successive uses of the command.

   The following prompt is displayed:

   Type of text placement (Auto/Manual) <Manual>: 
3 Type M to use the Manual option. You are prompted for a point.
4 Select the point to be labeled. The following prompt is displayed:
   Insertion point (Rotation/Leader):
5 Specify the insertion options:

<table>
<thead>
<tr>
<th>If you...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>want to change the rotation angle of the label</td>
<td>type Rotation. For more information, see “Labeling the Offset of the Cross Section Points Manually” in this chapter.</td>
</tr>
<tr>
<td>want to change the label leader</td>
<td>type Leader. For more information, see “Labeling the Offset of the Cross Section Points Manually” in this chapter.</td>
</tr>
<tr>
<td>do not want to specify these options</td>
<td>go to step 6.</td>
</tr>
</tbody>
</table>

6 Select the location for the label with the pointer, or continue with additional options of Rotation or Leader.
7 Pick any other point to label the offset, or press ENTER to end the command.

**Labeling the Elevation of the Cross Section Points Automatically**

**To automatically label the offset of a selected point on a plotted cross section**

1 From the Cross Sections menu, choose Section Utilities ➤ Label Elevation. The command lists the starting and ending stations and the current section. The following prompt is displayed:
   Text rotation angle <0d0'0”>:
2 Enter the text rotation angle for the offset label, or press ENTER to accept the default. If you enter a new value for a rotation angle, then this new value becomes the default for successive uses of the command. The following prompt is displayed:
   Type of text placement (Auto/Manual) <Manual>:
3 Type A to use the Auto option. The following prompt is displayed:
   Text orientation (Random/Linear) <Random>:
4 Specify the type of text orientation:
   - Type R to use the Random option, and then select a point to label. The label appears at the point you selected.
   - Type L to use the Linear option. Select a point to define the line (parallel to the X axis and passing through this point) on which the label will appear, and then select a point to label.

The label appears at the point of perpendicularity between the selected point to label and label line defined above. All offset labels that are created are located along the imaginary line defined to place labels.

5 Pick any other point to label, or press ENTER to end the command.

To view an illustration showing the effect of using the Random option, see “Labeling the Offset of the Cross Section Points Manually” in this chapter.

To view an illustration showing a label placed using the Linear option, see “Labeling the Offset of the Cross Section Points Manually” in this chapter.

**Labeling the Difference in Elevation Between Two Cross Section Points Manually**

This command takes the vertical exaggeration of a plotted cross section into account when labeling the differences. Where the Label Offset command prompts for one point to use for calculating offsets, the Label Depth command prompts for two points to use to calculate elevation differences. In addition, the Random option of the Auto option places the elevation difference labels at the first point selected and the Linear option of the Auto option places the elevation difference labels at the second point selected.

**To label the difference in elevation between two cross section points**

1 From the Cross Sections menu, choose Section Utilities ➤ Label Depth. The command lists the starting and ending stations and the current section.

   The following prompt is displayed:
   
   Text rotation angle <0d0'0”>:

2 Enter a rotation at which you would like the label to appear, or press ENTER to accept the default. You can either pick two points to define a new rotation angle, or you can enter a numeric angle value at the prompt. If you enter a new value for a rotation angle, then this new value becomes the default for successive uses of the command.

   The following prompt is displayed:
   
   Type of text placement (Auto/Manual) <Auto>:

3 Type M to use the Manual option.

   You are prompted to pick points.

4 Select two points on the screen between which the depth is to be labeled.

   The following prompt is displayed:
   
   Insertion point (Rotation/Leader):
5 Specify the insertion options:

<table>
<thead>
<tr>
<th>If you…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>want to change the rotation angle of the label</td>
<td>type Rotation. For more information, see “Labelling the Offset of the Cross Section Points Manually” in this chapter.</td>
</tr>
<tr>
<td>want to change the label leader</td>
<td>type Leader. For more information, see “Labelling the Offset of the Cross Section Points Manually” in this chapter.</td>
</tr>
<tr>
<td>do not want to specify these options</td>
<td>go to step 6.</td>
</tr>
</tbody>
</table>

6 Select the location for the label with the pointer, or continue with additional options of Rotation or Leader.

7 Pick any other point to label the offset, or press ENTER to end the command. For information on labeling the difference in elevation between two cross section points automatically, see “Labelling the Offset of the Cross Section Points Automatically” in this chapter.

---

**Labeling the Grade Between Two Cross Section Points**

**To label the grade between two cross section points**

1 From the Cross Sections menu, choose Section Utilities ➤ Label Grade. The command lists the starting and ending stations, and the current section. The following prompt is displayed:

   Type of text placement (Auto/Manual) <Auto>:

2 At the command prompt, do one of the following to specify the approximate label entry type:

   - Type Auto to place the grade label along the line defined by the grade selected.
   - Type Manual to display prompts for the rotation angle of the label text. Accept the default, or enter a new rotation angle.

   The command prompts for the selection of the two points that define the grade.

3 Pick the two points that define the grade, or enter coordinates. If you selected Automatic label placement in step 2, the label is placed on the cross section plot. If you selected the Manual option, the command prompts for the Leader start.

4 Pick a point, or enter coordinates if you selected the Manual option in step 2. If you press ENTER at the Leader start prompt, the following prompt is displayed:

   Insertion point (Rotation/Leader):
5 Specify the insertion options:

<table>
<thead>
<tr>
<th>If you...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>want to change the rotation angle of the label</td>
<td>type <strong>Rotation</strong>. For more information, see “Labelling the Offset of the Cross Section Points Manually” in this chapter.</td>
</tr>
<tr>
<td>want to change the label leader</td>
<td>type <strong>Leader</strong>. For more information, see “Labelling the Offset of the Cross Section Points Manually” in this chapter.</td>
</tr>
<tr>
<td>do not want to specify these options</td>
<td>go to step 6.</td>
</tr>
</tbody>
</table>

6 Pick a point for the Second leader point. The command prompt asks for the Next point.

7 Press ENTER when you have chosen all the points you want to make up the leader, and the label is placed.

8 Select additional points, or press ENTER to end the command.

**Labeling the Slope Between Two Cross Section Points**

This command uses the same prompt structure as the Label Grade command. Instead of labeling grades, the Label Slope command places slope labels.

**To label the slope between two cross section points**

1 From the Cross Sections menu, choose Section Utilities ▲ Label Slope. The command lists the starting and ending stations and the current section. The following prompt is displayed:

   **Type of text placement (Auto/Manual) <Auto>:**

2 At the command prompt, do one of the following to specify the label entry type:

   - Type **Auto** to place the slope label along the line defined by the slope selected.
   - Type **Manual** to display a prompt for the rotation angle of the label text. Accept the default, or enter a new rotation angle.

   The command prompts for the selection of the two points that define the slope.

3 Pick the two points that define the slope, or enter coordinates. If you selected Automatic label placement in step 2, the label is placed on the cross section plot. If you selected the Manual option, the command prompts for the Leader start.

4 Pick a point or enter coordinates if you selected the Manual option in step 2. If you press ENTER at the Leader start prompt, the following prompt is displayed:

   **Insertion point (Rotation/Leader):**
Specify the insertion options:

<table>
<thead>
<tr>
<th>If you...</th>
<th>Then...</th>
</tr>
</thead>
</table>
| want to change the rotation angle of the label | type Rotation.  
For more information, see “Labelling the Offset of the Cross Section Points Manually” in this chapter. |
| want to change the label leader | type Leader.  
For more information, see “Labelling the Offset of the Cross Section Points Manually” in this chapter. |
| do not want to specify these options | go to step 6. |

Pick a point for the Second leader point. The command prompt asks for the Next point.

Press ENTER when you have chosen all the points you want to make up the leader, and the label is placed.

Select additional points, or press ENTER to end the command.

**Labeling a Selected Area on a Cross Section**

To label an area on a plotted cross section

1. From the Cross Sections menu, choose Section Utilities ➤ Label Area. The command lists the starting and ending stations and the current section. The following prompt is displayed:
   
   Text rotation angle <0d’0’”>:

2. Enter the rotation angle for the area label. The following prompt is displayed:
   
   AREA first point:

3. Select the points that define the area to be labeled. The command continues to prompt for area points.

4. Press ENTER when all the points defining the area have been selected. The following prompt is displayed:
   
   Insert point (Rotation/Leader):

Specify the insertion options:

<table>
<thead>
<tr>
<th>If you...</th>
<th>Then...</th>
</tr>
</thead>
</table>
| want to change the rotation angle of the label | type Rotation.  
For more information, see “Labelling the Offset of the Cross Section Points Manually” in this chapter. |
| want to change the label leader | type Leader.  
For more information, see “Labelling the Offset of the Cross Section Points Manually” in this chapter. |
| do not want to specify these options | go to step 6. |
Select another area to label, or press ENTER to end the command. The label is placed on the current layer.

**Drawing Polylines on Plotted Cross Sections**

To draw polylines on plotted cross sections
- From the Cross Sections menu, choose Section Utilities ➤ Draw Polyline.

This command is identical to the Draw Template command from the Template menu. The only difference between the two commands is that the Draw Polyline command uses the vertical scale of the current cross section to define relative elevations, slopes, and grades.

**Calculating Cross Section Volumes**

You can calculate cross section volumes using the commands on the Total Volume Output and Surface Volume Output submenus. These commands apply expansion and compaction factors for volume calculations of template surfaces, existing subsurfaces, or strip surfaces. Also, you can calculate the cut and fill volumes of a range of cross sections and create a table of the data generated.

**Changing the Cross Section Volume Adjustment Factors**

Use the Design Control ➤ Volume Adjustment Factors command to apply expansion and compaction factors for volume calculations of template surfaces, existing subsurfaces, or strip surfaces.

The volume adjustment parameters set with this command are used when you select a volume output command. The cut adjustment factor is used by the Subsurface and Strip Surface commands. The fill adjustment factor is used by the Template Surface command. The Output to File command does not use this table, since it looks at the overall cut and fill areas and does not take into account the different subsurface materials.
To set the volume adjustment factors

1. From the Cross Sections menu, choose Design Control ➤ Volume Adjustment Factors to display the Volume Adjustment Editor dialog box.

![Volume Adjustment Editor dialog box](image)

The information generated in the Volume Adjustment Editor is stored in an ASCII file named after the current alignment with the .acn file extension. This file is saved in the \align subfolder of the project folder. You can edit the information saved in this file using any text editor, provided it is saved as ASCII text. You can also add comments to the data. Use a semi-colon (;) or a pound sign (#) to indicate the beginning of a comment.

2. Click Insert to position the cursor in the Surface portion of the editor.

3. Type the name of the different types of material for both existing and proposed surfaces.

4. Press ENTER to move to the Cut (Adj) column.

5. Type the cut adjustment.

   This value helps determine the actual volume of material that needs to be removed from the site. The value is applied to the Subsurface and Strip Surface commands.

   **NOTE**

   For a material that expands 15 percent, enter the value 1.15. Whereas, for a material that compacts to 93 percent of its original value, enter the value 0.93. A factor of 1.00 does not adjust the volumes.

6. Press ENTER to move to the Fill (Adj) column.

7. Type the fill adjustment. This value helps determine the actual volume of material that needs to be added to the site. This value is applied to the Template Surface command.

8. Use the navigation buttons to the right of the dialog box to move through the lines and pages of slope information.

9. Click Save to save your changes.

10. Click OK to exit the Volume Adjustment Editor dialog box.
Calculating the Volume Data and Displaying the Results in a Table

The Volume Table command calculates the cut and fill volumes of a range of cross sections and creates a table of the data generated.

To calculate the cut and fill volumes of a range of cross sections and create a table of the data generated

1 Generate the cross section areas using the Edit Design Control command, if you haven't done so already.
2 From the Cross Sections menu, choose Total Volume Output ➤ Volume Table.
   The following prompt is displayed:
   Volume computation type (Prismoidal/Avgendarea) <Avgendarea>:

3 Specify the volume computation type, Prismoidal or Avgendarea:
   - **Average End Area Calculation**: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.
   - **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.

   The prismoidal method calculation is:
   Total sum of cut (or fill) area at first station (A1), cut (or fill) area at second station (A2) plus the square root value of A1*A2. Divide the total sum by 3 and multiply by the distance between the two sections.

   A prompt is displayed asking if you want to use curve correction.

4 Specify whether to use curve correction:
   - Type **Y** to use curve correction.
   - Type **N** to skip this option.

   In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

   A prompt is displayed asking if you want to use volume adjustment factors.

5 Do one of the following to specify whether you want to use volume adjustment factors:
   - Type **Y** to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
   - Type **N** to skip this option.
NOTE
For a material that expands 15 percent, enter the value 1.15. For a material that shrinks to 93 percent of its original value, enter the value 0.93. A factor of 1.00 does not adjust the volumes.

6 Specify the range of stations. The defaults for the beginning and ending stations are based on the beginning and ending stations of the current alignment. Accept the default, or enter a different range of stations.

7 Select the insertion point of the table when you are prompted to do so. This is the upper left-hand corner of the table.

The following illustration shows a volume data table:

<table>
<thead>
<tr>
<th>STATION</th>
<th>AREAS</th>
<th>VOLUMES</th>
<th>CUMULATIVE VOLUMES</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>CUT</td>
<td>FILL</td>
</tr>
<tr>
<td>10+00</td>
<td>115.96</td>
<td>214.04</td>
<td>1089.38</td>
</tr>
<tr>
<td>10+50</td>
<td>115.20</td>
<td>212.75</td>
<td>1113.46</td>
</tr>
<tr>
<td>11+00</td>
<td>114.56</td>
<td>204.39</td>
<td>1165.34</td>
</tr>
<tr>
<td>11+50</td>
<td>106.18</td>
<td>195.79</td>
<td>1213.51</td>
</tr>
<tr>
<td>12+00</td>
<td>105.28</td>
<td>199.04</td>
<td>1237.42</td>
</tr>
<tr>
<td>12+50</td>
<td>109.69</td>
<td>193.97</td>
<td>1252.67</td>
</tr>
<tr>
<td>13+00</td>
<td>99.81</td>
<td>172.97</td>
<td>1374.61</td>
</tr>
<tr>
<td>13+50</td>
<td>87.60</td>
<td>151.06</td>
<td>1480.61</td>
</tr>
<tr>
<td>14+00</td>
<td>76.14</td>
<td>155.52</td>
<td>1597.12</td>
</tr>
<tr>
<td>14+12.86</td>
<td>73.02</td>
<td>857.43</td>
<td></td>
</tr>
<tr>
<td>14+50</td>
<td>66.10</td>
<td>95.26</td>
<td></td>
</tr>
</tbody>
</table>

Volume data table

Calculating the Volume Data and Displaying the Results on Screen

To calculate the volume data and display the results on screen

1 Generate the cross sections with the Edit Design Control command, if you haven't done so already.

2 From the Cross Sections menu, choose Total Volume Output ➤ To Screen. The following prompt is displayed:

Volume computation type (Prismoidal/Avgendarea) <Avgendarea>:

3 Specify the volume computation type: Prismoidal or Avgendarea:
   ■ Average End Area Calculation: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.
   ■ Prismoidal Calculation: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.
The prismatic method calculation is:
Total sum of cut (or fill) area at first station (A1), cut (or fill) area at second station (A2) plus the square root value of A1*A2. Divide the total sum by 3 and multiply by the distance between the two sections.

A prompt is displayed asking if you would like to use curve correction.

Specify whether to use curve correction:
- Type Y to use curve correction.
- Type N to skip this option.

In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

A prompt is displayed asking if you want to use volume adjustment factors.

Specify whether you want to use volume adjustment factors:
- Type Y to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
- Type N to skip this option.

NOTE For a material that expands 15 percent, enter the value 1.15. For a material that shrinks to 93 percent of its original value, enter the value 0.93. A factor of 1.00 does not adjust the volumes.

Specify the range of stations.
The defaults for the beginning and ending stations are based on the beginning and ending stations of the current alignment. Accept the default, or enter a different range of stations.

The To Screen command displays the cut and fill volume information on the screen, opening an AutoCAD text window. The display includes the station cut and fill areas, station cut and fill volumes, and cumulative volumes. The To Screen output pauses after each screen.

Press any key to view the next screen of information.

The following is a sample of the cutting and fill volume information output:

<table>
<thead>
<tr>
<th>Station</th>
<th>Cut Area (sqft)</th>
<th>Fill Area (sqft)</th>
<th>Cut Volume (yds)</th>
<th>Fill Volume (yds)</th>
</tr>
</thead>
<tbody>
<tr>
<td>10+00</td>
<td>204.48</td>
<td>581.87</td>
<td>374.53</td>
<td>1088.16</td>
</tr>
<tr>
<td>10+50</td>
<td>200.02</td>
<td>594.14</td>
<td>374.53</td>
<td>1088.16</td>
</tr>
<tr>
<td>11+00</td>
<td>191.64</td>
<td>606.82</td>
<td>362.64</td>
<td>1112.01</td>
</tr>
<tr>
<td>11+50</td>
<td>171.94</td>
<td>651.07</td>
<td>313.12</td>
<td>1213.69</td>
</tr>
<tr>
<td>12+00</td>
<td>166.23</td>
<td>659.71</td>
<td>336.64</td>
<td>1164.72</td>
</tr>
<tr>
<td>12+50</td>
<td>166.29</td>
<td>677.71</td>
<td>313.12</td>
<td>1213.69</td>
</tr>
<tr>
<td>13+00</td>
<td>149.38</td>
<td>718.56</td>
<td>257.14</td>
<td>1370.82</td>
</tr>
</tbody>
</table>

Calculating Cross Section Volumes
Calculating the Volume Data and Saving It to a Text File

You can write volume data to an ASCII text file using the To File command.

To calculate volume data and save it to a text file

1. Generate cross sections with the Edit Design Control command, if you haven’t done so already.
2. From the Cross Sections menu, choose Total Volume Output ➤ To File.
   
The following prompt is displayed:
   
   Volume computation type (Prismoidal/Avgendarea) <Avgendarea>: 

3. Specify the volume computation type: Prismoidal or Avgendarea:
   
   - **Average End Area Calculation**: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.
   
   - **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.

   The prismoidal method calculation is:
   
   Total sum of cut (or fill) area at first station (A1), cut (or fill) area at second station (A2) plus the square root value of A1*A2. Divide the total sum by 3 and multiply by the distance between the two sections.

   A prompt is displayed asking if you would like to use curve correction.

4. Specify whether to use curve correction:
   
   - Type Y to use curve correction.
   - Type N to skip this option.

   In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

   A prompt is displayed asking if you want to use volume adjustment factors.

5. Specify whether you want to use volume adjustment factors:
   
   - Type Y to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
   - Type N to skip this option.

   **NOTE**: For a material that expands 15 percent, enter the value 1.15. For a material that shrinks to 93 percent of its original value, enter the value 0.93. A factor of 1.00 does not adjust the volumes.
Specify the range of stations. The defaults for the beginning and ending stations are based on the beginning and ending stations of the current alignment. Accept the default, or enter a different range of stations.

You are prompted to enter a file name.

Specify an output file name.

Include the path and extension when entering the file name. The default path and filename is set in Output Settings. The To File command produces the output file.

The file lists the station cut and fill areas, station cut and fill volumes, station total volume, and the running mass ordinate.

The following is a sample of the volume data output file:

```
Page 1

Hillsboro Bypass phase
Alignment: 202cl
END AREA VOLUME LISTING WITH CURVE
Cut     Fill     Cut     Fill     Cut     Fill
Station   Area     Area  Volume  Volume  Tot Vol  Tot VOL  Mass
Ordinate
10+00  115.96   581.49  214.04  1089.38  214.04  1089.38  -875.34
10+50  115.20   595.04  212.75  1113.46  426.78  2202.84  -1776.05
11+00  114.56   607.50  204.39  1165.34  631.17  3368.18  -2737.01
11+50  106.18   651.07  195.79  1213.51  826.96  4581.70  -3754.73
12+00  105.28   659.52  199.04  1237.42  1026.01  5819.11  -4793.11
```

Creating a Mass Haul Diagram

To create a mass haul diagram

1 Generate cross sections with the Edit Design Control command, if you haven’t done so already.

2 From the Cross Sections menu, choose Total Volume Output ➤ Import Mass Haul.

The following prompt is displayed:

```
Volume computation type (Prismoidal/Avgendarea) <Avgendarea>:
```
3 Specify the volume computation type: Prismatic or Avgendarea:

- **Average End Area Calculation**: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.

- **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.

  The prismoidal method calculation is:

  Total sum of cut (or fill) area at first station \((A1)\), cut (or fill) area at second station \((A2)\) plus the square root value of \(A1 \times A2\). Divide the total sum by 3 and multiply by the distance between the two sections.

The following prompt is displayed:

Use of curve correction (Yes/No) <Yes>:

4 Do one of the following to specify whether to use curve correction:

- Type **Y** to use curve correction.
- Type **N** to skip this option.

In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

The following prompt is displayed:

Use of volume adjustment factors (Yes/No) <Yes>:

5 Specify whether you want to use volume adjustment factors:

- Type **Y** to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
- Type **N** to skip this option.

**NOTE** For a material that expands 15 percent, enter the value 1.15. For a material that shrinks to 93 percent of its original value, enter the value 0.93. A factor of 1.00 does not adjust the volumes.

The following prompt is displayed:

Pick insertion point:

6 Select the insertion point for the mass diagram plot.

The insertion point is the lower-left intersection of the station and mass ordinate plot lines.

7 Specify the range of stations. The defaults for the beginning and ending stations are based on the beginning and ending stations of the current alignment. Accept the default or enter a different range of stations.
The following prompt is displayed:

Vertical scale (cu. yds.) <1.00>:

Specify the vertical scale, depending on how much cut and fill the alignment has. The default value is local to the station range specified. The vertical scale is per plotted inch/millimeter based on the horizontal scale factor.

The command then draws the mass haul diagram. The volume balance line is placed on the MDBAL layer. The vertical and horizontal grid lines are placed on the MDGRID layer. The station labels and volume numbers are placed on the MDGRIDT layer.

The following illustration shows a sample mass haul diagram:

![Mass haul diagram](image1)

Mass haul diagram

The following illustration shows a close up of a mass haul diagram:

![Close-up of mass haul diagram](image2)

Close-up of mass haul diagram

**Calculating the Volume Data for Each Template Surface and Saving it to a Text File**

To calculate the volume of each template surface, use the Template Surface command. This command calculates volumes only for the surfaces that you drew on the template. For example, the surfaces that represent asphalt, granular material, and so on.

**NOTE** To calculate subsurface volumes use the Subsurface command.
To calculate the volume data for each template surface

1 From the Cross Sections menu, choose Surface Volume Output ➤ Template Surface.

The following prompt is displayed:

Volume computation type (Prismoidal/Avgendarea) <Avgendarea>:

2 Specify the volume computation type: Prismoidal or Avgendarea:

- **Average End Area Calculation**: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.

- **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.

  The prismoidal method calculation is:

  Total sum of cut (or fill) area at first station (A1), cut (or fill) area at second station (A2) plus the square root value of A1*A2. Divide the total sum by 3 and multiply by the distance between the two sections.

A prompt is displayed asking if you want to use curve correction.

3 Specify whether to use curve correction:

- Type Y to use curve correction.
- Type N to skip this option.

In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

The following prompt is displayed:

Use of volume adjustment factors (Yes/No) <Yes>:

4 Specify whether you want to use volume adjustment factors:

- Type Y to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
- Type N to skip this option.

**NOTE** The values you enter against these prompts are not used in calculating the template surface volumes. The adjustment factors entered in the Design Control ➤ Volume Adjustment Factors command are used exclusively. If no data is entered for any or all of the template surfaces, then the adjustment factor of 1 is applied.

The following prompt is displayed:

Output file name <alignment.txt>:

5 Specify an output file name. Include the path and extension when entering the file name. Default filename and path are set by the Output Settings command.
Specify the range of stations. The defaults for the beginning and ending stations are based on the beginning and ending stations of the current alignment. Accept the default or enter a different range of stations.

The command passes through sections determining surface conditions. The command reports the surfaces it is calculating as it is generating the report. The material volumes reported are based on the material description assigned to each surface when you defined the template. The report includes the area, volume, and total volume for each station. This information is written to an ASCII file that can be viewed or edited with any text editor.

The volumes for all surfaces with the same material description are combined. If a template surface was not assigned a material description, it is reported as "unclassified." The volume for each material is reported, and then a summary of all of the materials volumes is reported at the end.

The following is a sample template volume report:

```
page 1
Hillsboro Bypass Phase 2
Project: ROUTE202                         Tue Nov 2 17:00:00 1999
Alignment: 202CL
SURFACE: asphalt
TEMPLATE AVGENDAREA VOLUME LISTING WITH CURVE CORRECTION
Station  Area (sqft)   Volume (yds)   Tot Vol (yds)
--------------------------------------------------------------
10+00    7.92        14.67          14.67
10+50    7.92        29.33          44.00
11+00    7.92        58.67          88.00
11+50    7.92        73.33          102.67
12+00    7.92        14.67          14.67
12+50    7.92        29.33          44.00
13+00    7.92        44.00          58.67
```

**Calculating the Volume Data for Each Existing Ground Subsurface and Saving it to a Text File**

Use the Subsurface command to calculate the cut volumes for the subsurface materials that the template passes through.

**To calculate the volume data for each template subsurface and write it to a text file**

1. Create subsurfaces using multiple surfaces or Interpolation Control of existing ground cross section, if you haven’t done so already.
2. From the Cross Sections menu, choose Surface Volume Output ➤ Subsurface. The following prompt is displayed:

   `Volume computation type (Prismoidal/Avgendarea) <Avgendarea>:`

3. Specify the volume computation type: Prismoidal or Avgendarea:
   - **Average End Area Calculation**: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the
area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.

- **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.

  The prismoidal method calculation is:
  
  Total sum of cut (or fill) area at first station (A1), cut (or fill) area at second station (A2) plus the square root value of A1*A2. Divide the total sum by 3 and multiply by the distance between the two sections.

The following prompt is displayed:

```
Use of curve correction (Yes/No) <Yes>:
```

4 Specify whether to use curve correction:

- Type Y to use curve correction.
- Type N to skip this option.

In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result. The following prompt is displayed:

```
Use of volume adjustment factors (Yes/No) <Yes>:
```

5 Specify whether you want to use volume adjustment factors:

- Type Y to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
- Type N to skip this option

**NOTE**

The values you enter against these prompts are not used in calculating the subsurface cut volumes. The adjustment factors entered in the Design Control ➤ Volume Adjustment Factors command are used exclusively. If no data is entered for any or all of the subsurfaces, then an adjustment factor of 1 is applied.

6 Specify an output file name. Include the path and extension when entering the file name. The default filename and path are set by the Output Settings command.

7 Specify the range of stations. The defaults for the beginning and ending stations are based on the beginning and ending stations of the current alignment. Accept the default or enter a different range of stations.

The command passes through sections determining surface conditions. The command reports the surfaces it is calculating as it is generating the report. The command reports the area, volumes, and mass ordinate of cut for each existing subsurface. This information is written to an ASCII file that can be viewed or edited with any text editor.
The following example shows a typical subsurface volume report. A summary of the total volumes of cut for each existing subsurface is reported at the end of the file:

<table>
<thead>
<tr>
<th>Station</th>
<th>Area (sqft)</th>
<th>Volume (yds)</th>
<th>Tot Vol (yds)</th>
</tr>
</thead>
<tbody>
<tr>
<td>10+00</td>
<td>80.33</td>
<td>147.76</td>
<td>147.76</td>
</tr>
<tr>
<td>10+50</td>
<td>79.26</td>
<td>146.03</td>
<td>293.79</td>
</tr>
<tr>
<td>11+00</td>
<td>78.45</td>
<td>139.39</td>
<td>433.19</td>
</tr>
<tr>
<td>11+50</td>
<td>72.14</td>
<td>132.32</td>
<td>565.50</td>
</tr>
<tr>
<td>12+00</td>
<td>70.77</td>
<td>134.63</td>
<td>700.14</td>
</tr>
<tr>
<td>12+50</td>
<td>74.66</td>
<td>130.53</td>
<td>830.67</td>
</tr>
<tr>
<td>13+00</td>
<td>66.64</td>
<td>113.03</td>
<td>943.70</td>
</tr>
</tbody>
</table>

Calculating the Strip Volume Data for the Top Surface and Saving it to a File

The Strip Surface command reports the strip volumes of the top surface. This command can also report the strip volumes of all surfaces above a selected surface.

**To report the strip volumes of the top surface**

1. Create your subsurfaces using multiple surfaces or Interpolation Control of existing ground cross sections, if you haven't done so already.
2. From the Cross Sections menu, choose Surface Volume Output ➤ Strip Surface.
   The following prompt is displayed:
   ```
   Volume computation type (Prismoidal/Avgendarea) <Avgendarea>:
   ```
3. Specify the volume computation type: Prismoidal or Avgendarea:
   - **Average End Area Calculation**: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.
   - **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.

   The prismoidal method calculation is:
   Total sum of cut (or fill) area at first station (A1), cut (or fill) area at second station (A2) plus the square root value of A1*A2. Divide the total sum by 3 and multiply by the distance between the two sections.
The following prompt is displayed:

Use of curve correction (Yes/No) <Yes>: 

4 Specify whether to use curve correction:
- Type Y to use curve correction.
- Type N to skip this option.

In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

The following prompt is displayed:

Use of volume adjustment factors (Yes/No) <Yes>: 

5 Specify whether to use volume adjustment factors:
- Type Y to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
- Type N to skip this option.

**NOTE** The values you enter against these prompts are not used in calculating the Strip surface volumes. The adjustment factors entered in the Design Control ▶ Volume Adjustment Factors command are used exclusively. If no data is entered for any or all of the surfaces, then an adjustment factor of 1 is applied.

The following prompt is displayed:

Output file name <alignment.txt>: 

6 Specify an output file name. Include the path and extension when entering the file name. The default filename and path are set by the Output Settings command.

The following prompt is displayed:

Strip surface:

7 Select a strip surface. Enter either the top surface or the name of any subsurface. If you enter a subsurface name, the command calculates the strip volumes of the surface specified and all surfaces above it.

8 Specify whether you want the outer limits of the strip areas to be determined by the catch points of the match slopes or by the right-of-way offsets. Specify which limits to use at the Strip to Row/Catch) <Catch> prompt.

The command displays the surfaces being calculated as it generates the strip volume report. If several surfaces are being calculated, the volumes of each surface are reported separately.
Calculating Cross Section Volumes

The following is a sample temple volume report:

<table>
<thead>
<tr>
<th>Station</th>
<th>Area (sqft)</th>
<th>Volume (yds)</th>
<th>Tot Vol (yds)</th>
</tr>
</thead>
<tbody>
<tr>
<td>10+00</td>
<td>14.87</td>
<td>29.19</td>
<td>29.19</td>
</tr>
<tr>
<td>10+50</td>
<td>16.68</td>
<td>53.94</td>
<td>83.13</td>
</tr>
<tr>
<td>11+00</td>
<td>43.71</td>
<td>109.61</td>
<td>192.74</td>
</tr>
<tr>
<td>11+50</td>
<td>76.16</td>
<td>135.85</td>
<td>328.59</td>
</tr>
<tr>
<td>12+00</td>
<td>70.59</td>
<td>143.59</td>
<td>472.18</td>
</tr>
</tbody>
</table>

Calculating the Volume Data Between Two Existing Ground Surfaces

The Surface Volume Existing Ground command prompts for two surface names: the match surface and the datum surface. The match surface is the one that will be used as the original existing ground surface, and the datum surface is used as the new surface to compare against the match surface.

To calculate the volume data between two existing ground surfaces

1. From the Cross Sections menu, choose Surface Volume Output Existing Ground to display the Select Match Surface dialog box. This dialog box displays the names of all existing ground cross section surfaces that are defined for the current alignment.

   **NOTE** If there is only one existing ground surface, the Select Match Surface dialog box does not display. Instead, the following prompt is displayed:

   Only one existing ground surface exists. Nothing to do.

2. Pick the Match surface name, and then click OK. The match surface is the initial existing ground surface.

3. Select the Datum surface name, and then click OK. The datum surface is compared against the match surface to calculate the volumes.

   The following prompt is displayed:

   Volume region limits (Row/Catch/Extents) Catch:

4. Specify which option to use for the volume region limits.

   The outer limits of the volume areas are determined either by the right-of-way (Row) offsets, the Catch points of the match slopes, or the Extents of the cross section. The Extents option uses the complete existing ground sections limits defined by swath widths in calculating the volume.

   The following prompt is displayed:

   Volume computation type (Prismoidal/Avgendarea) Avgendarea:
5 Specify the volume computation type, Prismoidal or Avgendarea:

- **Average End Area Calculation**: For the average end method, the calculations for volumes take the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.

- **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.

  The prismoidal method calculation is:

  Total sum of cut (or fill) area at first station \((A1)\), cut (or fill) area at second station \((A2)\) plus the square root value of \(A1 \times A2\). Divide the total sum by 3 and multiply by the distance between the two sections.

  The following prompt is displayed:

  ```
  Use of curve correction (Yes/No) <Yes>: 
  ```

6 Specify whether to use curve correction:

- Type **Y** to use curve correction.
- Type **N** to skip this option.

  In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

  The following prompt is displayed:

  ```
  Use of volume adjustment factors (Yes/No) <Yes>: 
  ```

7 Specify whether to use volume adjustment factors:

- Type **Y** to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
- Type **N** to skip this option

**NOTE**

For a material that expands 15 percent, enter the value **1.15**. For a material that shrinks to 93 percent of its original value, enter the value **0.93**. A factor of **1.00** does not adjust the volumes.

The following prompt is displayed:

```
Output file name <alignment.txt>: 
```

8 Specify an output file name. Include the path and extension when entering the file name. The default filename and path are set by the Output Settings command.

9 Specify the range of stations to use. Enter the beginning and ending stations in the range.

  The command displays the surfaces being calculated as it generates the existing ground surface volume report. If several surfaces are being calculated, then the volumes of each surface are reported separately.
Creating a 3-Dimensional Grid Based on Cross Sections

The 3D Grid command imports the section surface data along the alignment as 3D faces on the layer RDGRID, and can assign the 3D grid a vertical exaggeration as it is imported. You can import the top, datum, and existing ground surfaces using this command. This command is useful when a 3D surface model needs to be generated (rendering, for example).

To create a 3-dimensional grid based on cross sections

1. From the Cross Sections menu, choose 3D Grid.
   
   The command lists the alignment name, number, description, and the starting and ending stations.
   
   The following prompt is displayed:
   
   Beginning station <1000.00>:
   
   The default is the beginning station of the current alignment.

2. Enter the beginning station number, or press ENTER to accept the default.
   
   A prompt similar to the following is displayed:
   
   Ending station <4213.94>:
   
   The default is the ending station of the current alignment.

3. Enter the ending station number, or press ENTER to accept the default.
   
   The following prompt is displayed:
   
   Surface points to import (Existing/Datum/Top):
   
   The datum and top surfaces include all ditch and slope surfaces.

4. Specify the points to import:
   
   - **Existing**: The Existing option uses the existing ground surface data along the alignment for the sampled swath width for the grid.
   
   - **Datum**: The Datum option uses the points defining the datum line to create the grid. If you select the Datum option, the command prompts for the Datum number to use. The default for this prompt is one (1).
   
   - **Top**: The Top option uses the points along the top surface of the applied template to create the grid. The command prompts for the top surface number to use. The default for this prompt is one (1). In order to use a top surface, one must have been defined with the Edit Template options.

   After you have specified the surface, the command prompts for the vertical scaling factor. The command uses this factor to stretch the grid in the vertical direction for relief magnification. This value defaults to <1>.

5. Enter a vertical scaling factor, or press ENTER to accept the default.
   
   The command processes the station information and creates the grid.
   
   Use the AutoCAD VPOINT or DVIEW commands to view the grid in three-dimensional perspective.
NOTE  The 3D grid is created on the RDGRID layer. If you want to create 3D grids for both existing and finished ground surfaces, then create the existing ground grid and move it to a different layer, such as EGRDGRID. Then create the finished ground grid.

Outputting the Section Data for Use in Other Software Programs

The ASCII File Output commands on the Cross Sections menu provide raw data for cross sections and volumes. Use the commands in this menu to create ASCII output files of information taken from cross sections and volume calculations.

There are a multitude of different output formats that exist worldwide. Some countries have standardized specific formats for profiles and cross sections while in other countries, the formats can vary greatly from region to region or even between corporations. With these ASCII files, add-on programs can be written to take the data generated and output it in any customized format.

All command descriptions and examples given in this chapter require that you set a current alignment using the Select Alignment command. The ASCII File Output commands all begin by displaying the current alignment name, number, and description.

NOTE  The files created by the commands in this menu are output in ASCII format only. These are data files and are not intended to be a report.

Changing the ASCII Output Settings for Outputting Section Data

You can use the ASCII File Output ➤ Output Settings command to view the current output settings.

To change the ASCII output settings for outputting section data

1 From the Cross Sections menu, choose ASCII File Output ➤ Output Settings to display the Output Settings dialog box.

2 Under Output Options, do one of the following to output the file:
   - Select File to output the information to a text file.
   - Select Screen to output the information to the screen.
3 Under Output Format, select or clear the following check boxes:

- **Date**: Select this check box to place the date on the report:
  

- **Title**: Select this check box to place a title on the report:
  
  Project: testing
  Horizontal Alignment PI Station Report.
  Alignment: Road1    Desc: Subdivision access road
  

- **Page Breaks**: Select this check box to place page breaks in the report.
  
  When you select this check box, and create a Screen report, the text window displays only the first page of the information and then the command prompts you to press a key to continue. When you press a key, the next page of the report is displayed. If you do not select this check box, then the screen report does not stop at each page as the information is output.

  When you select this check box, and create a File report, the report is created with page breaks instead of having all the information displayed in one long list. If you select the Sub Headers check box and the Page Breaks check box, then sub headers are placed at the beginning of each page break as shown below:

  page 2
  Project: subdivision
  Station & Offset Listing by Selection
  Point       Station           Offset          Elevation
  Description

- **Page Numbers**: Select this check box to place page numbers on a report. This setting applies to File output only.

- **Sub Headers**: Select this check box to place sub headers at the beginning of each new page of a report. This setting applies to File output only. You must also select the Page Breaks check box if you want sub headers to appear. The sub headers are placed at the beginning of each page break as shown below:

  page 2
  Project: subdivision
  Station & Offset Listing by Selection
  Point       Station           Offset          Elevation
  Description
Chapter 4     Working with Cross Sections

4 Under Output Format, specify the following information:

- **Overwrite File**: To overwrite a file, either select the Overwrite File check box to overwrite a file if it already exists, or clear the Overwrite File check box to append new information to the end of an existing file.

5 Enter the Output File Name in the text box next to the Output File Name button.

**NOTE**: Each time you create a new report, be sure to change the default output file name so you do not overwrite the previous report.

6 If needed, you can click Output File Name to specify a folder for the output file. If you do not specify an output folder, then the file that is created is placed in the current project folder.

7 Click OK to exit the Output Settings dialog box.

### Outputting the Section Data for a Range of Stations to an ASCII File

The Sections command outputs a station range of sectional data for a single alignment to an ASCII file. All of the data represents the existing ground, subsurface, and proposed template surfaces as applied.

**To output the section data for a range of stations to an ASCII file**

1 From the Cross Sections menu, choose ASCII File Output ➤ Sections.

A prompt similar to the following is displayed:

```
Directory to output to <c:\Land Projects R2\<project name>\align\>:
```

**NOTE**: If you do not currently have an alignment selected, you are prompted to select one. Press ENTER to display the Alignment Librarian dialog box, select an alignment, and then click OK to display the following prompt:

```
Directory to output to <c:\Land Projects R2\<project name>\align\>:
```
2 Specify the output folder for the information:
   - Accept the default, c:\Land Projects R2\<project name>\align
   - Enter a different folder

   The following prompt is displayed:
   Enter filename to output:

3 Specify the output file name.
   When entering the file name, be sure to include the extension. If the file already exists, a prompt is displayed asking whether or not to overwrite the file:
   - Type Y for Yes to overwrite the existing file.
   - Type N for No to have the command prompt for the folder and file name again.

   You are prompted to enter the beginning station and ending station in turn.

4 Specify the range of stations.
   The defaults for the beginning and ending stations are based on the beginning and ending stations of the current alignment. Accept the default or enter a different range of stations.

   The command calculates the sectional data for the stations and outputs it to the file.

   The following is a table listing the section codes used in the ASCII text file:

<table>
<thead>
<tr>
<th>Description</th>
<th>Codes</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Surface</td>
<td>Existing ground</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Finished ground</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Top surface</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>Datum surface</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>Template surface</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>Assembly surface</td>
<td>40</td>
</tr>
<tr>
<td>Points</td>
<td>Null point</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Existing point</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Template point</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td>Assembly point</td>
<td>3</td>
</tr>
</tbody>
</table>

   NOTE Angles are expressed in radians measured counterclockwise from a zero (0) x-axis.
To view samples of section data output files, see “Section Data for a Range of Stations – Sample Output File” in this chapter.

**Section Data for a Range of Stations - Sample Output File**

The following text shows the format for the ASCII text file. Any line beginning with either a number character (#) or semicolon (;) is a comment line:

Alignment name
internal sta, external sta, direction along align, skew angle of section
offset of ref pt, elev of ref pt, Northing of ref pt, Easting of ref pt
min offset, max offset, min elev, max elev
cut area, cut centroid, fill area, fill centroid, rad at sta, rad halfway to
next
surface type, number of surfaces of this type
surface type, surface name
number of points
pt code, offset, elevation.

The format for an ASCII text file is made up of the following components:

- The internal station is the original station value as the alignment was defined, before station equations are used.
- The external station is the current station value. If you haven’t used station equations, these values remain the same.
- The direction along align variable is the current direction of the alignment (in radians).
- The skew angle of the section is not used at this time.

The following is an example section output in the ASCII text file. Any line beginning with either a number character (#) or semicolon (;) is a comment line:

```
# Autodesk Civil Design Section Output 1.0 A
r1
1642.80000,3000.00000,6.182354,0.000000
0.000000,398.693823,4990.292780,4526.310407
-80.00000,80.00000,349.561417,363.032604
31.318067,-8.411033,79.780859,20.738300,0.000000,0.000000
0,1
0, eg
26
1,-80.000000,363.032604
1,-77.339769,362.952025
1,-66.440420,362.763712
1,-59.399991,362.572420
1,-43.908915,357.375230
1,-39.692378,355.966395
1,-32.385258,357.915349
1,-30.311426,358.467796
```
Outputting the Total Volume Data to an ASCII File

To output the total volume data to an ASCII text file

1. From the Cross Sections menu, choose ASCII File Output ➤ Total Volume. A prompt similar to the following is displayed:
   
   Directory to output to <c:\Land Projects R2\<project name>\align>:

   **NOTE** If you do not currently have an alignment selected, then you are prompted to select one. Press ENTER to display the Alignment Librarian dialog box, select an alignment, and then click OK to display the following prompt:
   
   Directory to output to <c:\Land Projects R2\<project name>\align>:

2. Specify the output folder for the information using one of the following methods:
   - Accept the default, c:\Land Projects R2\<project name>\align.
   - Enter a different folder. You are then prompted to enter a name for the file.

   The following prompt is displayed:
   
   Enter filename to output:

3. Specify the file name. When entering the file name, be sure to include the extension. If the file already exists, a prompt is displayed asking whether or not to overwrite the file.

4. On the command line, type Y or N:
   - Type Y for Yes to overwrite the existing file.
   - Type N for No to have the command prompt for the folder and file name again.

   The following prompt is displayed:
   
   Volume computation type (Prismoidal/Avgendarea) <Avgendarea>:

5. Specify the volume computation type, Prismoidal or Avgendarea:
   - **Average End Area Calculation**: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculates all data from the actual values, but the reported values are rounded to the volume precision of your choice.
   - **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.

   The prismoidal method calculation is:
   
   Total sum of cut (or fill) area at first station (A1), cut (or fill) area at second station (A2) plus the square root value of A1*A2. Divide the total sum by 3 and multiply by the distance between the two sections.
The following prompt is displayed:

Use curve correction (Yes/No) <Yes>:

6 Specify whether to use curve correction:
   - Type Y to use curve correction.
   - Type N to skip this option.

In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

The following prompt is displayed:

Use volume adjustment factors (Yes/No) <Yes>:

7 Specify whether to use volume adjustment factors:
   - Type Y to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
   - Type N to skip this option.

   NOTE For a material that expands 15 percent, enter the value 1.15. For a material that shrinks to 93 percent of its original value, enter the value 0.93. A factor of 1.00 does not adjust the volumes.

8 Specify the range of stations.
The defaults for the beginning and ending stations are based on the beginning and ending stations of the current alignment. Accept the default, or enter a different range of stations. The command calculates the data and outputs it to the file.

To see a sample output file, see “Total Volume Data – Sample Output File” in this chapter.

The following table lists the section codes used in the ASCII text file:

<table>
<thead>
<tr>
<th>Section Codes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
</tr>
<tr>
<td>Volume types</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Curve correction</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Adjustment factors</td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
Total Volume Data - Sample Output File

The following text shows the format for the ASCII text file:

Alignment name
volume type, curve correction, adjustment factors, cut factor, fill factor
int sta, ext sta, cut area, cut centroid, cut volume, cumulative cut vol,
fill area, fill centroid, fill volume, cumulative fill vol, mass ordinate,
radius, radius halfway to next station

The format for an ASCII text file consists of the following components:

- The internal station is the original station value as the alignment was
defined, before station equations are used.
- The external station is the current station value. If you haven’t used station
equations, then these values will be the same.

The following is an example of the total volume output in the ASCII text file.
Any line beginning with either a number character (#) or semicolon (;) is a
comment line.

# Autodesk Civil Design Volume Total Output 1.0A
r10,
1,1,1, 1.000000,1.000000
1642.800000,3000.000000,31.318067,-
8.411033,0.000000,0.000000,79.780859,20.738300,0.000000,0.000000,0.0000
00,0.000000,0.000000
1692.800000,3050.000000,0.000000,0.000000,28.998211,28.998211,182.08443
6,6.873386,242.467866,242.467866,-213.469655,0.000000,0.000000
1742.800000,3100.000000,0.000000,0.000000,0.000000,28.998211,560.185617
,-1.526858,687.287086,929.754951,-900.756741,0.000000,0.000000

Outputting the Volume Data for Surfaces to an ASCII File

The material volumes reported are based on the material description assigned to
each surface when you defined the template. The volumes for all surfaces with
the same material are combined. If a template surface was not assigned a
material description, then it is reported as unclassified.

To output the volume data for template surfaces to an ASCII file

1  From the Cross Sections menu, choose ASCII File Output ➤ Template Surface.
   A prompt similar to the following is displayed:
   Directory to output to <c:\Land Projects R2<project name>\align>:  

   **NOTE** If you do not currently have an alignment selected, you are prompted to
   select one. Press ENTER to display the Alignment Librarian dialog box,
   select an alignment, and then click OK to display the following prompt:

   Directory to output to <c:\Land Projects R2<project name>\align>:

2  Specify the output folder for the information:
   - Accept the default, c:\Land Projects R2<project name>\align
   - Enter a different folder.

   The following prompt is displayed:
   Enter filename to output:
3 Specify the file name. When entering the file name, be sure to include the extension. If the file already exists, a prompt is displayed asking whether or not to overwrite the file.

4 On the command line, type Y or N:
   - Type Y for Yes to overwrite the existing file.
   - Type N for No to show the command prompt for the folder and file name again.

   The following prompt is displayed:

   Volume computation type (Prismoidal/Avgendarea) <Avgendarea>:

5 Specify the volume computation type: Prismoidal or Avgendarea:
   - **Average End Area Calculation**: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.
   - **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.

   The prismoidal method calculation is:

   Total sum of cut (or fill) area at first station (A1), cut (or fill) area at second station (A2) plus the square root value of A1*A2. Divide the total sum by 3 and multiply by the distance between the two sections.

   The following prompt is displayed:

   Use curve correction (Yes/No) <Yes>:

6 Specify whether to use curve correction:
   - Type Y to use curve correction
   - Type N to skip this option

   In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

   The following prompt is displayed:

   Use volume adjustment factors (Yes/No) <Yes>:

7 Specify whether to use volume adjustment factors:
   - Type Y to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
   - Type N to skip this option.
The values you enter against these prompts are not used in calculating the template surface volumes. The adjustment factors entered in the Design Control Volume Adjustment Factors command are used exclusively. If no data is entered for any or all of the template surfaces, then an adjustment factor of 1 is applied.

Specify the range of stations.
The defaults for the beginning and ending stations are based on the beginning and ending stations of the current alignment. Accept the default, or enter a different range of stations.

The command calculates the data and outputs it to the file. To view a sample output file, see “Volume Data for Template Surfaces – Sample Output File” in this chapter.

The following table lists the section codes used in the ASCII text file:

<table>
<thead>
<tr>
<th>Description</th>
<th>Codes</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report types</td>
<td>Template volumes</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Strip volumes</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Subsurface volumes</td>
<td>2</td>
</tr>
<tr>
<td>Volume types</td>
<td>Average End Area</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Prismoidal</td>
<td>1</td>
</tr>
<tr>
<td>Curve correction</td>
<td>On</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Off</td>
<td>0</td>
</tr>
<tr>
<td>Adjustment factors</td>
<td>On</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Off</td>
<td>0</td>
</tr>
<tr>
<td>Catch/ROW</td>
<td>Catch points</td>
<td>1</td>
</tr>
<tr>
<td>(ignored by all volume types except strip)</td>
<td>Right of Way</td>
<td>0</td>
</tr>
</tbody>
</table>
Volume Data for Template Surfaces - Sample Output File

The following text shows the format for the ASCII text file:

Alignment name, report type, volume type, curve correction, adjustment factors, catch/ROW surface, int sta, ext sta, area, centroid, adjustment factor, volume, cumulative volume, radius, radius half way to next sta

The format for an ASCII text file consists of the following format:

- The internal station is the original station value as the alignment was defined, before station equations are used.
- The external station is the current station value. If station equations have not been used, these values will be the same.

The following is an example of the template volume output in the ASCII text file. Any line beginning with either a number character (#) or semicolon (;) is a comment line.

```
# Autodesk Civil Design Template Volume Output 1.0A
r1
0,0,1,1
pavement,-5000.000000,-5000.000000,16.800000,0.000000,0.960000,0.000000,0.000000,0.000000,0.000000
pavement,-4950.000000,-4950.000000,16.800000,0.000000,0.960000,29.866667,29.866667,0.000000,0.000000
pavement,-4900.000000,-4900.000000,16.800000,0.000000,0.960000,29.866667,59.733333,0.000000,0.000000
```

Outputting the Volume Data for Subsurfaces to an ASCII File

The ASCII File Output ➤ Subsurface command writes the area and volumes of cut for each existing subsurface to an ASCII text file.

**NOTE** In order to use this command, subsurfaces must exist through the use of multiple surfaces or Interpolation Control of existing ground cross sections.

To output the volume data for template subsurfaces to an ASCII file

1. From the Cross Sections menu, choose ASCII File Output ➤ Subsurface.
   A prompt similar to the following is displayed:
   ```
   Directory to output to <c:\Land Projects R2\<project name>\align>:
   ```

   **NOTE** If you do not currently have an alignment selected, you are prompted to select one. Press ENTER to display the Alignment Librarian dialog box, select an alignment, and then click OK to see the following prompt:
   ```
   Directory to output to <c:\Land Projects R2\<project name>\align>:
   ```

2. Specify the output folder for the information:
   - Accept the default, c:\Land Projects R2\<project name>\align
   - Enter a different folder.
The following prompt is displayed:

Enter filename to output:

3 Specify the file name.

When entering the file name, be sure to include the extension. If the file already exists, a prompt is displayed asking whether or not to overwrite the file.

4 On the command line, type Y or N:
   - Type Y for Yes to overwrite the existing file.
   - Type N for No to show the command prompt for the folder and file name again.

The following prompt is displayed:

Volume computation type (Prismoidal/Avgendarea) <Avgendarea>:

5 Specify the volume computation type, Prismoidal or Avgendarea:
   - **Average End Area Calculation**: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.
   - **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.

     The prismoidal method calculation is:
     
     Total sum of cut (or fill) area at first station (A1), cut (or fill) area at second station (A2) plus the square root value of A1*A2. Divide the total sum by 3 and multiply by the distance between the two sections.

The following prompt is displayed:

Use curve correction (Yes/No) <Yes>:

6 Specify whether to use curve correction:
   - Type Y to use curve correction.
   - Type N to skip this option.

   In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

   A prompt is displayed asking if you want to use volume adjustment factors.

7 Specify whether you want to use volume adjustment factors:
   - Type Y to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
   - Type N to skip this option.
The values you enter against these prompts are not used in calculating the subsurface volumes. The adjustment factors entered in the Design Control Volume Adjustment Factors command are used exclusively. If no data is entered for any or all of the surfaces, then an adjustment factor of 1 is applied.

Specify the range of stations.

The defaults for the beginning and ending stations are based on the beginning and ending stations of the current alignment. Accept the default or enter a different range of stations.

The command calculates the data and outputs it to the file. To view a table listing the section codes used in the ASCII text file, see “Outputting the Volume Data for Surfaces to an ASCII File” in this chapter. To view a sample output file, see “Volume Data for Subsurfaces – Sample Output File” in this chapter.

**Volume Data for Subsurfaces - Sample Output File**

The following text shows the format for the ASCII text file:

```
Alignment name
report type, volume type, curve correction, adjustment factors, catch/ROW surface, int sta, ext sta, area, centroid, adjustment factor, volume, cumulative volume, radius, radius half way to next sta
```

The format for an ASCII text file consists of the following components:

- The internal station is the original station value as the alignment was defined, before station equations are used.
- The external station is the current station value. If you haven’t used station equations, these values will be the same.

The following is an example of the subsurface volume output in the ASCII text file. Any line beginning with either a number character (#) or semicolon (;) is a comment line.

```
# Autodesk Civil Design Subsurface Volume Output 1.0A
adtest
2,0,1,1,1
exist,0.000000,0.000000,722.537923,-
82.891020,1.130000,0.000000,0.000000,0.000000,0.000000
exist,50.000000,50.000000,568.481711,-
25.797657,1.130000,1350.789061,1350.789061,0.000000,0.000000
exist,100.000000,100.000000,381.860925,-
37.192141,1.130000,994.339980,2345.129041,0.000000,0.000000
exist,150.000000,150.000000,205.512763,-
26.833585,1.130000,614.566914,2959.695956,0.000000,0.000000
exist,200.000000,200.000000,41.710082,-
40.862527,1.130000,122.997046,3377.076185,0.000000,0.000000
exist,250.000000,250.000000,57.032535,-
39.201386,1.130000,122.997046,3377.076185,0.000000,0.000000
exist,300.000000,300.000000,57.032535,-
7.861766,1.130000,103.314035,3480.390220,0.000000,0.000000
```
Outputting the Strip Volume Data for the Strip Surface to an ASCII File

The ASCII File Output ► Strip Surface command writes the strip volumes of the specified surface to an ASCII text file. This command can also write the strip volumes of all surfaces above a selected surface to an ASCII text file.

**NOTE**

In order to use this command, subsurfaces must exist through the use of Multiple Surfaces or Interpolation Control of existing ground cross sections.

**To output the strip volume data for the strip surface to an ASCII file**

1. From the Cross Sections menu, choose ASCII File Output ► Strip Surface.
   A prompt similar to the following is displayed:
   
   Directory to output to <c:\Land Projects R2\<project name>\align>:
   
   **NOTE**
   
   If you do not currently have an alignment selected, you are prompted to select one. Press ENTER to display the Alignment librarian dialog box, select an alignment, and then click OK to display the following prompt:
   
   Directory to output to <c:\Land Projects R2\<project name>\align>:
   
2. Specify the output folder for the information.
   Accept the default, c:\Land Projects R2\<project name>\align, or enter a different folder. You are then prompted to enter a name for the file.

3. Specify the file name.
   When entering the file name, be sure to include the extension. If the file already exists, a prompt is displayed asking whether or not to overwrite the file.

4. On the command line, type Y or N:
   - Type Y for Yes to overwrite the existing file.
   - Type N for No to display the command prompt for the folder and file name again.

   The following prompt is displayed:
   
   Volume computation type (Prismoidal/Avgendarea) <Avgendarea>:

5. Specify the volume computation type, Prismoidal or Avgendarea:
   - **Average End Area Calculation**: For the average end method, the calculations for volumes takes the area of cut or fill at one station plus the area of the cut or fill at the next station divided by two, multiplied by the distance between the stations. The commands calculate all data from the actual values, but the reported values are rounded to the volume precision of your choice.
   - **Prismoidal Calculation**: The prismoidal method of calculating volumes is more accurate than the average end area method. However, this technique involves a more complicated calculation and may take a longer time to process.
The prismoidal method calculation is:
Total sum of cut (or fill) area at first station (A1), cut (or fill) area at second station (A2) plus the square root value of A1*A2. Divide the total sum by 3 and multiply by the distance between the two sections.

A prompt is displayed asking if you want to use curve correction.

Specify whether to use curve correction:
- Type Y to use curve correction.
- Type N to skip this option.

In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for a more accurate result.

The following prompt is displayed:
Use volume adjustment factors (Yes/No) <Yes>:

Specify whether to use volume adjustment factors:
- Type Y to use volume adjustment factors. You are then prompted for the cut and fill adjustment factors.
- Type N to skip this option.

**NOTE**
The values you enter against these prompts are not used in calculating the Strip surface volumes. The adjustment factors entered in the Design Control > Volume Adjustment Factors command are used exclusively. If no data is entered for any or all of the surfaces, then an adjustment factor of 1 is applied.

You are prompted to enter the name of the strip surface.

Enter the name of the strip surface.

The outer limits of the strip areas are determined either by the right-of-way offsets (Row) or by the catch points of the match slopes (Catch). Specify which limits to use at the Strip to (Row/Catch) <Catch> prompt.

Specify the range of stations to process.

The defaults for the beginning and ending stations are based on the starting and ending stations of the current alignment. The command passes through the sections to determine the surface conditions. If several surfaces are being calculated, then the volumes of each surface are reported separately.

To view a table listing the section codes used in the ASCII text file, see “Outputting the Section Data for a Range of Stations to an ASCII File” in this chapter.

To view a sample output file, see “Stripping Volume Data for the Strip Surface – Sample Output File” in this chapter.
**Stripping Volume Data for the Strip Surface - Sample Output File**

The following text shows the format for the ASCII text file:

Alignment name

The format for an ASCII text file consists of the following components:

- The internal station is the original station value as the alignment was defined, before station equations are used.
- The external station is the current station value. If station equations have not been used, then these values will be the same.

The following is an example of the strip volume output in the ASCII text file. Any line beginning with either a number character (#) or semicolon (;) is a comment line:

```
# Autodesk Civil Design Strip Volume Output 1.0A
test
1, 0, 1, 1
exist, 0.000000, 0.000000, 4021.242891, -14.702350, 1.000000, 0.000000, 0.000000, 0.000000
exist, 50.000000, 50.000000, 4292.688725, -12.922645, 1.000000, 7698.084829, 7698.084829, 0.000000, 0.000000
exist, 100.000000, 100.000000, 5639.272001, -17.819769, 1.000000, 16894.34761, 16894.34761, 0.000000, 0.000000
exist, 150.000000, 150.000000, 5934.509847, -15.659002, 1.000000, 27610.80435, 27610.80435, 0.000000, 0.000000
exist, 200.000000, 200.000000, 6248.128912, -14.760196, 1.000000, 37850.373364, 37850.373364, 0.000000, 0.000000
exist, 250.000000, 250.000000, 6750.487383, -15.084208, 1.000000, 47511.860747, 47511.860747, 0.000000, 0.000000
exist, 300.000000, 300.000000, 5310.187178, -14.630508, 1.000000, 57741.916530, 57741.916530, 0.000000, 0.000000
exist, 350.000000, 350.000000, 4790.981494, -9.883894, 1.000000, 67489.916530, 67489.916530, 0.000000, 0.000000
exist, 400.000000, 400.000000, 400.000000, 400.000000, 3999.305317, -9.883894, 1.000000, 75629.079985, 75629.079985, 0.000000, 0.000000
exist, 400.000000, 438.651968, 400.000000, 400.000000, 3999.305317, -9.883894, 1.000000, 81877.199897, 81877.199897, 0.000000, 0.000000
```

**Using the Section Viewer**

You can view the cross section at the selected station at any time.

**To view a cross section using the section viewer**

1. From the Existing Ground Section Editor, choose the station for which you want to view the cross section.

   Click Prev or Next to move forward or back through the stations one at a time. Click Station to display the Station Entry dialog box where you can enter the number of the station you want to view.

2. Click Section View to display the Section Viewer dialog box. This dialog box is for display only.

3. Click OK to exit the Section Viewer dialog box.
5

Working with Hydrology Commands

Use the Hydrology commands to calculate runoff from watersheds and to design hydraulic structures for controlling watershed runoff. The types of hydraulic structures you can design include channels, culverts, orifices, weirs, and risers.

In this chapter

- Calculating channel values
- Calculating culvert size and shape
- Calculating pipe values
- Using Manning’s n, Darcy-Weisbach, and Hazen-Williams equations
- Calculating weir values
- Calculating riser values
- Calculating runoff from watershed areas
- Outputting hydrology data
Hydrology Overview

Autodesk Civil Design provides a set of tools you can use to perform a hydrological analysis of a site and to design hydraulic structures to control post-development runoff. You can use AutoCAD Land Development Desktop to create the terrain model and calculate the watershed subareas of the site, and then you can use one of four Autodesk Civil Design runoff calculation methods to determine the peak discharge and hydrograph for the chosen design storms.

As part of your stormwater management plan for the site, you can then determine how best to control the site runoff. You can use the pond grading and routing commands to design detention ponds for attenuating the runoff, and to design the inflow and outflow structures for the pond.

You can use the Autodesk Civil Design hydraulic-structure calculators to design the pond inflow and outflow structures, such as risers, orifices, and culverts, as well as to calculate channel flow for the time of concentration and time of travel calculations.

Hydrology and hydraulics is an inexact science that usually involves an iterative process of trial and error. You might begin with an estimate of where the stormwater control devices would best be placed on a site, and then calculate the runoff. From the runoff results, you can design your detention pond. You can use the Pond Outflow Design dialog box to add multiple-stage structures and make them active or inactive, so you can calculate the routed pond using several variations of structures until you get the results you need.

To help you learn how to use the hydrology commands, some sample files are installed in the c:\Program Files\Land Desktop R2\data\hd folder. These files include hydrograph files, intensity-duration files, and many others. For more information on these sample files, see the following section, “Sample Hydrology Files that are Included with Autodesk Civil Design.”

NOTE  For a list of references used for this section of the manual, see “Hydrology Bibliography” at the end of this chapter.

Sample Hydrology Files That Are Included with Autodesk Civil Design

When you install Autodesk Civil Design, sample hydrology files are installed into the c:\Program Files\Land Desktop R2\data\hd folder. You can use these files to help you learn how to use the Hydrology commands.

The following table lists the file names and descriptions. You can load these files into the appropriate dialog box (for example, load the sample.clt file into the Culvert Calculator) to see the data.
Calculating Hydraulic Values for Structural Components

Autodesk Civil Design provides calculator-type dialog boxes that you can use to automate your hydrology calculations. These calculators use standard hydrology equations to output design parameters for culverts, channels, pipes, risers, orifices, and weirs.

Hydrology calculator dialog boxes enable you to solve for an unknown value. In these dialog boxes, you can select the value you want to solve for, and then enter known values in the appropriate edit fields, or you can pick the values from the drawing or from another editor dialog box.

The calculator dialog boxes allow you to enter values as equations or in different units:

- You can enter values as mathematical equations. For example, if the required diameter is 36 in. and the required flow percentage in a particular channel is 75%, enter \(36 \times 0.75\), and the value 27.0 is displayed.
- You can also specify the value in any units and this value is converted automatically to the setting units. For example, if the units are in inches, enter 2\(ft\), and the value 24 is displayed.
- Calculator dialog boxes store the changes that you make to the current values. If you click OK when you exit a dialog box, the next time you enter the dialog box the last values used will be returned.
A message appears at the bottom of the dialog box if an error is made when entering data. If there is more than one error, an error message dialog box is displayed.

You can use the calculators in two different ways, independently or nested. Each calculator has its own command you can use to run the calculator and save the values to a file. In addition, you can access the required calculators from within other dialog boxes. For example, you can access all of the structure calculators from the Outflow Editor because you use the Outflow Editor to design inflow and outflow structures for your ponds. But you could use the calculators independently, save the values to files, and then load the files when you’re using the Outflow Editor.

**Calculating Channel Values**

Autodesk Civil Design has channel calculators that you can use to calculate channel dimensions, flow rates, slope, Manning’s n, and/or depths of flows, as well as to design inflow and outflow structures for ponds. You can design rectangular and trapezoidal channels, and you can design channels with user-defined radii and slope values with the Advanced Channel Calculator. The channel calculators use Manning’s n coefficients to define the channel friction factors.

**Calculating the Rectangular Channel Values**

Use the Rectangular Channel Calculator to solve for values for rectangular channels. The following illustration shows rectangular channel values:

![Rectangular channel values](image)
To calculate the rectangular channel values

1. From the Hydrology menu, choose Channels ➤ Rectangular to display the Rectangular Channel Calculator dialog box.

![Rectangular Channel Calculator](attachment:image)

2. From the Solve For list, select the channel value you want to calculate. The available values are: Flowrate, Slope, Manning’s n, and Depth of Flow.

   **NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

3. Select the Critical Depth Check check box to have a warning message box appear if the flow depth is below the critical depth.

4. In the Flowrate box, type a flow rate for the channel.

5. In the Slope box, type a slope for the channel. You can also click Select to specify the slope by selecting points on the drawing.

6. In the Manning’s n box, type a roughness value for the channel lining material. You can also click Select to select a coefficient from the Channel - Manning’s n dialog box.

7. In the Flow Depth box, type a flow depth for the channel.

8. In the Height box, type a height for the channel.
In the Bottom Width box, type a bottom width for the channel. The box in the top right area of the dialog box displays a graphic of the currently defined channel. Based on the values you entered, information about the channel is calculated and displayed below the channel graphic. This information is for display only and cannot be edited.

**NOTE**
If the data you entered has an error, the channel graphic image does not appear. Check for an error message at the bottom of the dialog box.

10 Click OK to exit the dialog box.

**Specifying a Coefficient**
In the calculator dialog boxes that use Manning’s formula, you can select a coefficient by clicking the Select button next to the Manning’s n text box.

**To specify a coefficient**
1 In the calculator dialog box, click the Select button next to the Manning’s n box to display the Manning’s n dialog box.
2 Use the navigation buttons at the right of the dialog box to move through the list of coefficients and their descriptions.
3 Place the cursor in the Coefficient column, and click anywhere in the text box that contains the coefficient you want to use.

**TIP**
You can add values to the table by clicking Insert.

4 Click OK to return to the calculator dialog box. The coefficient you selected is placed in the calculator’s field.
Displaying the Calculated Critical Values
Critical depth is the depth of flow in an open channel for which specific energy is at a minimum value. While in any of the channel calculator dialog boxes, you can view the calculated critical depth value of a channel by clicking the Critical button at the bottom of the dialog box.

To display the calculated critical values of a channel
1. Click Critical at the bottom of the Channel Calculator dialog box to display the Critical Information dialog box. This dialog box is for display only.

2. Click OK to return to the Channel Calculator dialog box.

Specifying a Slope
When using the hydrology calculators, you can either type a slope value or select a slope from the drawing.

To specify a slope from a hydrology calculator
1. In a calculator dialog box, click the Select button next to the Slope box. The calculator dialog box closes temporarily and the following prompt is displayed at the command line:
   Select first point (or Dtm):

2. Select the first point where you want the slope to begin or type Dtm, and then select a point. The elevation is determined from a terrain model surface. The following prompt is displayed:
   Select second point:

3. Select the second point where you want the slope to end.
   The calculator dialog box displays and the value of the slope you selected is displayed in the Slope box.
Outputting the Data to a Text or WK1 File
When you select either Rectangular, Trapezoidal, or Advanced on the Channels menu, the respective channel calculator dialog box is displayed. Each of these dialog boxes has an Output button located at the bottom. Click this button to output data to a file.

To output the data to a file
1. Click Output at the bottom of the channel calculator dialog box to display the Output format dialog box.
2. Choose your output type by clicking Text or Wk1.
   If you choose Text as your output type, data displays in a text editor. From here, you can edit or save it.

   **NOTE** When you click Text from a channel calculator, you can include the critical computations. Click Yes to include the critical computations with the output.

   If you choose Wk1, a file that you can import into a spreadsheet program, as your output type, a standard save dialog box is displayed. Enter a name for the Wk1 file, and click Save.
3. Click OK to exit the dialog box.
Displaying a Quick Graph of the Data

When you select either Rectangular, Trapezoidal, or Advanced on the Channels menu, the respective channel calculator dialog box is displayed. Each of these dialog boxes has a Plot button located at the bottom of the channel calculator. Click this button to display a graph of flow versus depth.

To display a quick graph of the data

1. Click Plot on the current dialog box. The graph displays in a separate dialog box. This information is for display only.

2. Click OK to return to the previous dialog box.
Displaying Depth Versus Flow Data on a Graph

When you select either Rectangular, Trapezoidal, or Advanced on the Channels menu, the respective channel calculator dialog box is displayed. Each of these dialog boxes has a Rating button located at the bottom of the channel calculator. Click this button to calculate and display the depth versus flow data.

To calculate and display the depth versus flow data

1. Click Rating from the current dialog box to display the Rating Table Setup dialog box.

![Rating Table Setup](image)

2. Enter a beginning depth, ending depth, and increment.

3. Click View to display the depth versus flow data graphically. The Rating Curve Display dialog box is displayed.

![Rating Curve Display](image)

4. Do one of the following:
   - Click Settings to change the appearance of the graph, such as the line colors.
   - Click Plot to plot the curve on a graph.
   - Click Output to output the data to a text editor or .wk1 file. A .wk1 file is a file that you can import into a spreadsheet program, such as Microsoft Access.

5. Click Close to return to the previous dialog box.
Calculating Trapezoidal Channel Values

Use the Trapezoidal Channel Calculator to solve for values for trapezoidal channels.

The following illustration shows trapezoidal channel values:

To calculate the trapezoidal channel values

1. From the Hydrology menu, choose Channels ➤ Trapezoidal to display the Trapezoidal Channel Calculator dialog box.

2. From the Solve For list, select the channel value you want to calculate. The available values are: Flowrate, Slope, Manning’s n, and Depth of Flow.
NOTE Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

3 Select the Critical Depth Check check box to have a warning message box display if the flow depth is below the critical depth.
4 In the Flowrate box, type a flow rate for the channel.
5 In the Slope box, type a slope for the channel. You can also click Select to specify the slope by selecting points on the drawing.
6 In the Manning’s n box, type a roughness value for the channel lining material. You can also click Select to select a coefficient from the Channel - Manning’s n dialog box.
7 In the Flow Depth box, type a flow depth for the channel.
8 In the Height box, type a height for the channel.
9 In the Bottom Width box, type a bottom width for the channel.
10 In the Left Slope box, type a left slope value.
11 In the Right Slope box, type a right slope value. You can also click Select to specify the slope values by selecting points on the drawing. These values can be zero.

The box in the top right area of the dialog box displays a graphic of the currently defined channel. Based on the values you entered, information about the channel is calculated and displayed below the channel graphic. This information is for display only and cannot be edited.

NOTE If the data that you entered has an error, then the channel graphic image does not display. Check for an error message at the bottom of the dialog box.

12 Click OK to exit the dialog box.

Calculating Channel Values With User-Defined Left and Right Radii and Slopes

Use the Advanced Channel Calculator to calculate hydraulic values for channels with user-defined left and right radii and slopes. You can solve for flowrate, slope, Manning’s n, and depth of flow. The following illustration shows an advanced channel:
To calculate the rectangular channel values

1. From the Hydrology menu, choose Channels ➤ Advanced to display the Advanced Channel Calculator dialog box.

2. From the Solve For list, select the channel value you want to calculate. The available values are: Flowrate, Slope, Manning’s n, and Depth of Flow.

   **NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

3. Select the Critical Depth Check check box to have a warning message box display if the flow depth is below the critical depth.

4. In the Flowrate box, type a flow rate for the channel.

5. In the Slope box, type a slope for the channel. You can also click Select to specify the slope by selecting points on the drawing.

6. In the Manning’s n box, type a roughness value for the channel lining material. You can also click Select to select a coefficient from the Channel - Manning’s n dialog box.

7. In the Flow Depth box, type a flow depth for the channel.

8. In the Height box, type a height for the channel.

9. In the Bottom Width box, type a bottom width for the channel.

10. In the Left Radius and Right Radius boxes, type a left and a right radius value. These values can be zero.
In the Left Slope and Right Slope boxes, type a left and a right slope value. You can also click Select to specify the slope values by selecting points on the drawing. These values can be zero.

The box in the top right area of the dialog box displays a graphic of the currently defined channel. Based on the values you entered, information about the channel is calculated and displayed below the channel graphic. This information is for display only and cannot be edited.

NOTE If the data that you entered has an error, the channel graphic image does not display. Check for an error message at the bottom of the dialog box.

Click OK to exit the dialog box.

Calculating Culvert Size and Shape

The Culvert Calculator can aid in designing a box or circular culvert comprised of single or multiple barrels. You may specify various end treatments, such as headwalls and wingwalls, and design for inlet and outlet control situations. Also, all runoff methods are accessible from the Culvert Calculator for use in determining design flows.

The following list summarizes a typical culvert design process:

<table>
<thead>
<tr>
<th>Steps</th>
<th>What to do</th>
</tr>
</thead>
</table>
| Determine the location of the culvert. This is often a natural stream bed. | Look at the drawing to determine where the culvert should be located.  
If needed, you can build a surface model using the Terrain Model Explorer. Use Slope Arrows to show the slopes of the surface and to determine where the natural flow occurs across the surface, and use the Watershed commands to delineate the catchment areas. |
| Calculate the runoff for the area using the design storm frequency required by state or local agencies, and develop the inflow hydrograph. | Use one of the four Autodesk Civil Design runoff calculation methods. You can use them independently, or you can run the commands from within the Culvert Calculator. |
| Determine culvert design parameters (refer to list below). | Use the Culvert Calculator. |
| Develop a preliminary culvert design, then use both inlet and outlet control calculations to determine the governing control factor. | Use the Culvert Calculator. |
Items you need to size a culvert:

- Tailwater (depth of water measured above the outlet invert)
- Length of culvert
- Diameter
- Flow
- Manning’s n
- Roadway elevation (used to check for roadway overtopping)
- Inlet elevation
- Outlet elevation
- Culvert entrance conditions

You can use the Culvert Calculator command to design circular and box culverts. You can include roadway overtopping in the calculations, and you can base the calculations on inlet, outlet, or optimum control. The Culvert Calculator uses Manning’s n coefficients to define the culvert friction factors.

**NOTE** For more information about the input and output variables, see the Federal Highway Administration (FHWA) Hydraulic Design Series #5 publication, *Hydraulic Design of Highway Culverts*.

The following illustration shows culvert values:
To calculate culvert size and shape

1 From the Hydrology menu, choose Culvert Calculator to display the Culvert Design dialog box.

![Culvert Design - None](image)

- **Barrel Shape**: CIRCULAR
- **Tailwater**: m = 3.0000
- **Length**: m = 24.0376
- **Diameter**: m = 1.5000
- **Width**: m = 1.0000
- **Flow**: cms = 3.9900
- **Manning's n**: 0.0130
- **Roadway Elev**: m = 244.0000
- **Inlet Elev**: m = 241.0000
- **Outlet Elev**: m = 240.0000
- **Headwater**: m = 242.0288
- **Slope**: m/m = 0.0162
- **Velocity**: mps = 0.5607

**TIP** Click Load to load an existing culvert file to view or modify it. Or, you can click New to clear existing data from the Culvert Design dialog box.

**NOTE** You should always check the culvert settings. This is where you specify if you want to check for inlet control, outlet control, or optimum. It is also how you specify the entrance condition for the culvert and specify the number of barrels that will be used.

2 Configure the culvert settings. For more information on configuring the culvert settings, see the following section, “Changing the Culvert Settings.”

**NOTE** Error messages are displayed at the bottom of the Culvert Calculator. You can see a summary of error messages by clicking the Messages button.

3 From the Barrel Shape list, select the type of culvert that you want to size. The available shapes are Circular and Box.

4 In the Tailwater box, type a tailwater depth. This is the depth of water above the outlet elevation.
   You can also click Select to display the Tailwater Editor dialog box.

5 In the Length box, type a length for the culvert.
   You can also click Select to specify the length by selecting points on the drawing.
6 In the Diameter box, type a diameter for circular culverts, or a height for box culverts.

You can also click Select and select a diameter height from a data table. The data table comes with preset settings that you can customize.

7 In the Width box, type a width for the box culvert.

You can also click Select and select a width from a data table. The data table comes with preset settings that you can customize.

**NOTE** This edit box is not available if you selected Circular as the culvert barrel shape.

8 In the Flow box, type a peak discharge value for the culvert.

You can also click Select to display the Runoff Editor dialog box.

9 In the Manning’s n box, type a Manning’s n roughness coefficient for the culvert.

You can also click Select and select a coefficient from the Culvert - Manning’s n dialog box. This dialog box displays a description of the culvert material and the roughness coefficient value of the material.

10 In the Roadway Elev box, type a roadway elevation for the bank above the culvert.

You can also click Select and define the elevation by selecting a point on the roadway in your drawing.

**NOTE** A surface from which to extract the elevation must be set as current in the drawing, or you must use an object snap when selecting the point from a 3D object.

11 In the Inlet Elev box, type an inlet elevation for the culvert.

You can also click Select and define the elevation by selecting a point on the inlet in your drawing.

**NOTE** An AutoCAD Land Development Desktop surface from which to extract the elevation must be set as current in the drawing or you must use an object snap when selecting the point from a 3D object.

12 In the Outlet Elev box, type an outlet elevation for the culvert.

You can also click Select and define the elevation by selecting a point on the outlet in your drawing.

**NOTE** You must set a surface from which to extract the elevation as current in the drawing or use an object snap when selecting the point from a 3D object.

The following values are calculated by the program:

- **Headwater**: The calculated headwater for this culvert
- **Slope**: The calculated slope for the culvert
- **Velocity**: The calculated velocity for this culvert

13 To include roadway overtopping values in the culvert calculation, click the Over-Top button.
14 Save and output the culvert data and view curves:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>save the culvert calculation</td>
<td>Save.</td>
</tr>
<tr>
<td>display a summary of the culvert</td>
<td>Input.</td>
</tr>
<tr>
<td>calculation</td>
<td></td>
</tr>
<tr>
<td>display a performance curve</td>
<td>P-Curve.</td>
</tr>
<tr>
<td>display a headwater vs. flow curve</td>
<td>Fit-Plot.</td>
</tr>
<tr>
<td>create an output report</td>
<td>Output.</td>
</tr>
</tbody>
</table>

15 Click OK to exit the dialog box.

**Changing the Culvert Settings**

You can change the general settings for your current culvert design, such as the flowrate range and the number of barrels for the culvert.

**To change the culvert design settings**

1 In the Culvert Design dialog box, click Settings to display the Culvert Settings dialog box.
2 Do one of the following to one of the three available control options:
- Select Inlet to calculate the culvert design for inlet control. For more information, see the following section, “Specifying the Inlet Control Type.”
- Select Outlet to calculate the culvert design for outlet control.
- Select Optimum to let the program determine which control is optimum for calculating the culvert design.

3 Under Outlet Control, type a coefficient in the Entrance Loss box.
You can also click Select to select a coefficient from the Culvert Entrance Loss Values dialog box. This dialog box describes entrance conditions for the culvert and associated entrance loss coefficients.

4 Under Flowrate Range, type a minimum flow rate, maximum flow rate, and a flow increment in the Minimum Flow, Maximum Flow, and Flow Increment boxes, respectively. These values are used when calculating the P-curve and the Fit-Plot.

5 Under Chart And Scale, click Select to select an inlet control type from the Inlet Control Types dialog box.
The design type determines the culvert’s chart type and scales. Pick the description that most closely matches your design conditions.

6 In the Number of Barrels box, type the number of barrels for this culvert.

7 Click OK to return to the Culvert Design dialog box.

**Specifying a Coefficient**
The Culvert Entrance Loss Values dialog box describes entrance conditions for the culvert and associated entrance loss coefficients.

To specify a coefficient from the dialog box
1 In the Culvert Settings dialog box, click the Select button next to the Entrance Loss box to display the Culvert Entrance Loss Values dialog box.

```
<table>
<thead>
<tr>
<th>Description</th>
<th>Coefficient</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concrete Pipe Projecting from Fil (no hood)</td>
<td></td>
</tr>
<tr>
<td>Socket end of pipe</td>
<td>0.20000000</td>
</tr>
<tr>
<td>Square cut end of pipe</td>
<td>0.50000000</td>
</tr>
<tr>
<td>Concrete Pipe with Headwall or Wingwalls</td>
<td></td>
</tr>
<tr>
<td>Socket end of pipe</td>
<td>0.10000000</td>
</tr>
<tr>
<td>Square cut end of pipe</td>
<td>0.50000000</td>
</tr>
</tbody>
</table>
```

2 Select a coefficient by placing your cursor in the appropriate column and clicking anywhere in the text box that contains the value you want to use.
Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and coefficients.
You can add entrance loss coefficients to the table by using the following guidelines:

- Click Insert to add a new row above the row you currently have selected.
- To add data, select an empty text box and type the new description and coefficient.

3 Click OK to return to the Culvert Settings dialog box.

**Specifying the Inlet Control Type**

From the Inlet Control Types dialog box, you can select an inlet control for the culvert, such as headwalls or wingwalls.

**To specify the inlet control type**

1 In the Culvert Settings dialog box, click the Select button next to the Design Type field to display the Inlet Control Types dialog box.

   ![Inlet Control Types Dialog Box](image)

2 Select a type by placing your cursor in the appropriate column and clicking anywhere in the text box that contains the type you want to use.

   **NOTE** Only the indented descriptions are available for selection. Descriptions are not highlighted when selected, but the cursor flashes on the currently selected row.

   Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and coefficients.

3 Click OK to return to the Culvert Settings dialog box.
Loading an Existing Culvert File
The Culvert Design dialog box has a Load button that you can click if you want to load an existing file into the dialog box.

To load an existing file into the dialog box
1 In the Culvert Design dialog box, click Load to display a standard file dialog box.

NOTE If you have changed the data in the dialog box, the Save Culvert Data dialog box is displayed, asking if you want to save the current data before loading another file. Click either Yes or No.

2 Select the file you want to load and click Open.

Saving the Data to a File
The Culvert Design dialog box has a Save button that you can click if you want to save culvert data from this dialog box.

To save culvert data from the culvert design dialog box
1 In the Culvert Design dialog box, click Save to display the Select Save Type dialog box.

   Select Save Type
   
   Performance Curve  Culvert Data  Cancel

2 Choose the type of data you want to save by clicking Performance Curve or Culvert Data to display a standard file save dialog box.
3 In the Save in list, select the folder in which you want to save the file.
4 In the File name box, type a name for the file and click Save.

NOTE Culvert data files end with a .CLT extension. Performance Curve data files end with a .RTC extension. Autodesk Civil Design includes the correct extension by default.

5 Click OK to exit the Culvert Design dialog box.

Specifying the Tailwater Depth
The Culvert Design dialog box has a Select button next to the Tailwater box that you can click if you want to specify the tailwater using the Advanced Channel Calculator dialog box or on a rating curve file that you saved when you previously used a channel calculator.
To specify the tailwater depth

1 In the Culvert Design dialog box, click the Select button next to the Tailwater box to display the Tailwater Editor dialog box.

2 Do one of the following to specify the tailwater:
   - Select Tailwater Only to specify a fixed number for the depth of flow at the tailwater, then enter the depth in the box. Note that this number is a relative depth above the outlet invert and elevation is not considered.
   - Select Downstream Channel to specify the tailwater depth by solving for the Depth of Flow in the Advanced Channel Calculator dialog box. Click Select to open the calculator. Here you enter data to approximate the shape of the channel at the culvert outlet. The culvert calculator then uses the flowrate and the channel properties to determine the depth of flow at the outlet. For more information, see “Calculating Channel Values With User-Defined Left and Right Radii and Slopes” in this chapter.
   - Select Tailwater Curve to base the tailwater depth on data from a rating curve file that you specify. When you calculate channel values using a channel calculator, you can save the results to a rating curve file. This is a data file that contains depths versus flowrates. This data file can be created using any of the channel calculators. After a Tailwater curve is specified, the culvert calculator uses the flowrate specified and the Tailwater curve to determine the depth at the outlet. Type the path to the data file in the edit box, or click Select to select the file from a standard file load dialog box.

3 Click OK to return to the Culvert Design dialog box.

Specifying the Culvert Length

You can specify a culvert length from the Culvert Design dialog box by selecting a beginning and ending point from your drawing.

To specify a culvert length

1 In the Culvert Design dialog box, click the Select button next to the Length box. The Culvert Design dialog box closes temporarily and the following prompt is displayed:
   Culvert length – First point (or Entity):

2 Select the first point from the drawing.
   The following prompt is displayed:
   Length – Second point:
3 Select the second point from the drawing.
4 Press ENTER when you want to stop selecting points. The Culvert Design dialog box displays and the value of the length you selected displays in the Length text box.
5 Click OK to exit the dialog box.

**Specifying the Culvert Diameter**

You can choose a diameter for circular culverts, or a height for box culverts, from a data table. The data table comes with default settings you can customize.

**To specify the culvert diameter**

1 In the Culvert Design dialog box, click the Select button next to the Diameter box to display the Pipe Selections dialog box.

2 In the Pipe Diameter column, select a diameter by clicking anywhere in a Pipe Diameter text box.

   Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and diameters.

   You can also add custom pipe sizes by using the following guidelines:

   - Click Insert to add a new row above the row you currently have selected.
   - To add a new pipe, select an empty text box and type the new description and diameter.

3 Click OK to return to the Culvert Design dialog box.
Specifying the Culvert Width

You can choose a width for box culverts from a data table. The data table comes with default settings that you can customize.

**NOTE**

This edit box is available only if you select Box as the culvert barrel shape.

To specify the culvert width

1. In the Culvert Design dialog box, click the Select button next to the Width box to display the Pipe Selections dialog box.
2. In the Pipe Diameter column, select a diameter by clicking anywhere in a Pipe Diameter text box.
   - Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and diameters.
   - You can also add custom widths by using the following guidelines:
     - Click Insert to add a new row above the row you currently have selected.
     - To add a new pipe, select an empty text box and type the new description and width.
3. Click OK to return to the Culvert Design dialog box.

Specifying the Flowrate for a Culvert

To specify the flowrate for the culvert, you can do any of the following:

- Type a value in the Flow box
- Click Select to load a runoff file that you have already calculated
- Click Select and use one of the runoff calculators to calculate the peak flow

To specify the flowrate for a culvert

1. In the Culvert Design dialog box, click the Select button next to the Flow box to display the Runoff Editor dialog box.
2 From the Runoff Editor dialog box, click Select button next to the File box to display the Runoff Method Selection dialog box.

3 Do one of the following to calculate flow:
   - Click Rational to load a .rat file or to use the Rational Method calculator. For more information, see “Calculating the Peak Runoff Flow for an Area Using the Rational Method” in this chapter.
   - Click Tabular to load a .tab file or to use the TR-55 Tabular Hydrograph Method calculator. For more information, see “Calculating the Peak Runoff Flow Using the TR-55 Tabular Method” in this chapter.
   - Click Peak Discharge to load a .gpm file or to use the TR-55 Graphical Peak Discharge Method calculator. For more information, see “Calculating the Peak Runoff Flow by Using the TR-55 Graphical Method” in this chapter.
   - Click Inflow Hydrograph to load a .hdc or .wk1 file. For more information, see “Specifying the Flowrate Using a Hydrograph (.hdc) File” in this chapter.
   - Click TR-20 Method to load an .scs file or to use the SCS Unit Hydrograph Method calculator. For more information, see “Calculating the Peak Runoff Using the TR-20 Method” in this chapter.

4 Click OK to return to the Runoff Editor dialog box. The flow value displays in the Runoff Editor’s Flow field.

5 Click OK to return to the Culvert Design dialog box. The flow value displays in the Culvert Design Flow field.

**Specifying the Flowrate Using a Hydrograph (.hdc) File**

You can choose a flowrate for a culvert using a hydrograph (.hdc) file from a data table. The data table comes with default settings that you can customize.

1 From the Runoff Editor dialog box, click the Select button next to the File box to display the Runoff Method Selection dialog box.
2 Click Inflow Hydrograph to display a standard load file dialog box.
3 Select the file you want to load. You can load either .hdc or .wk1 files.
4 Click OK to return to the Runoff Editor dialog box.
Specifying an Elevation
You can define the roadway, inlet, and outlet elevations by selecting a point on the roadway in your drawing.

NOTE A surface from which to extract the elevation must be set as current in the drawing, or you must use an object snap when selecting a 3D object.

To specify an elevation
1 In the Culvert Design dialog box, click the Select button next to the Roadway Elev, Inlet Elev, or Outlet Elev boxes. The Culvert Design dialog box closes temporarily and the following prompt is displayed:

   Select point (or Dtm):

2 Select the point or type Dtm to select a point from a terrain model surface. For more information, see “Selecting a Point from a DTM Surface” in this chapter.

   Use the following guidelines for selecting points:

   - For the roadway elevation, select a point on the roadway.
   - For the inlet elevation, select a point on the inlet.
   - For the outlet elevation, select a point on the outlet.

   The Culvert Design dialog box displays and the value of the length you selected is displayed in the elevation text box.

3 Click OK to exit the dialog box.

Selecting a Point from a DTM Surface
When you see the following prompt, you can either select a point from the drawing or select a terrain model surface and select a point from that surface:

   Select point (or Dtm):

Do one of the following:

   - Select the point to use. You can use object snaps to accurately select the point or points.
   - Type Dtm, select the surface from the Select Surface dialog box, click OK, and then select the point in the drawing.

The point’s elevation is determined from the surface you selected.

Displaying a Summary of the Culvert Calculations
In the Culvert Design dialog box, there is an Input button that you can click to display a summary of recent culvert data that you either entered or loaded into this dialog box.

To display a summary of the culvert data you’ve entered or loaded into the culvert design dialog box
1 In the Culvert Design dialog box, click Input to display the Input Data Display dialog box. The Input Data Display dialog box summarizes data for:

   - Inlet Control: Displays the culvert type and entrance geometry
   - Outlet Control: Displays the culvert entrance loss coefficient
- **Flow Range**: Displays the minimum, maximum, and increments for flow range
- **Barrel Data**: Displays the shape of the barrel, the Manning’s roughness coefficient, and the number of barrels for the culvert
- **Upstream Information**: Displays the design flow entering the culvert
- **Tailwater Information**: Displays the tailwater depth

2. Review the data, and then click OK to return to the Culvert Design dialog box.

### Input Data Display

| Chart 1: CONCRETE PIPE CULVERT; NO BEVELED RING ENTRANCE |
| Scale 1: SQUARE EDGE ENTRANCE WITH HEADWALL |

- **Outlet Control**
  - Entrance Coefficient: 0.0000

- **Flow Range**
  - Min: 0.0000 cfs  Max: 0.0281 cfs  Incr: 0.0005 cfs

- **Barrel Data**
  - Shape: CIRCULAR  Number of Barrels: 1
  - Roughness Coefficient: 0.0130

- **Upstream Information**
  - Design Flow: 0.0281 cfs

- ** Tailwater Information**
  - Tailwater Depth: 0.3144 m
  - Tailwater Only

- **Roadway Overtopping**: OFF

[OK]  [Help]
Changing the Overtop Flow Values to Use in the Culvert Calculations

You can include overtop flow values into the culvert calculations by using the Over-Top button. A sag curve on the roadway surface is treated as a broad-crested weir when overtopping is applied. You define the weir by defining a mid-section length and one or two sections above that mid-section.

The following illustration shows the lengths of the weir:

![Example of overtopping](image)

To change the overtop flow values to use in the culvert calculations

1. In the Culvert Design dialog box, click Over-Top to display the Culvert Weir Editor dialog box.

![Culvert Weir Editor](image)

2. Select or clear the OverTopping check box:
   - To use the data from the Culvert Weir Editor dialog box in the culvert calculation, select the OverTopping check box.
   - To keep the data but not use it in the current culvert calculation, clear the OverTopping check box.
3 Click in the first row to start entering the overtop flow values for this culvert calculation.

4 In the Length column, type a length for the roadway crest. This is the length of the mid-section, at the center of the sag curve.

You can also click Length and specify the length by selecting an object or points on the drawing. After you click Length, the Culvert Weir Editor dialog box closes temporarily and you are prompted to select the first point. Continue selecting points as you are prompted by moving the cursor crosshairs and clicking the left mouse button. After you finish picking points, press the right mouse button.

The Culvert Weir Editor dialog box displays and the value of the length you selected displays in the Length text box.

5 In the Elevation column, type an elevation for the roadway crest at the sag curve.

You can also click Elevation and specify the elevation by selecting a point on the drawing. After you click Elevation, the Culvert Weir Editor dialog box closes temporarily and you are prompted to select a point. Move the cursor crosshairs to the point you want to select and click the left mouse button.

6 In the Broad Crested Weir Coefficient column, type a coefficient applicable to a broad crested weir. Weir coefficients are usually between 2.5 and 3.3.

7 Define the next section using the same methods described above. For the length, enter the combined length of the sections to the left and right of the mid-section. For more information, see the preceding illustration on overtopping in the introduction of this topic.

8 Click OK to return to the Culvert Design dialog box.

**Displaying a Performance Curve for a Culvert**

In the Culvert Design dialog box, there is a P Curve button. Click this button to calculate and display the performance curve for the culvert on a graph. You can adjust the settings in the Performance Curve Display dialog box.

**NOTE** The Minimum Flow, Maximum Flow, and Flow Increment values used to calculate the P-curve are determined in the Culvert Settings dialog box.

**To display a performance curve for a culvert**

1 In the Culvert Design dialog box, click P-Curve to display the Performance Curve Display dialog box.

2 Click Settings to display the Graph Settings, such as line colors and scale.

3 Click Plot to change the settings for this plot.

4 Click Output to output the depth versus flow data to a text or .wk1 file.

5 Click OK to return to the Culvert Design dialog box.
Displaying a Headwater Versus Flow Curve for a Culvert

The Culvert Design dialog box has a Fit-Plot button. This command calculates and displays a headwater versus the flow curve for a culvert. You can adjust settings using the Fit Plot Display dialog box.

NOTE  The Minimum Flow, Maximum Flow, and Flow Increment values used to calculate the Fit-Plot are determined in the Culvert Settings dialog box.

To calculate and display a headwater versus flow curve for this culvert
1  In the Culvert Design dialog box, click Fit-Plot to display the Fit Plot Display dialog box.
2  Click Settings to display the Graph Settings, such as line colors and scale.
3  Select Plot to change the settings for this plot.
4  Click Output to output the depth versus flow data to a text or .wk1 file.
5  Click OK to return to the Culvert Design dialog box.

Displaying the Culvert Data in a Text Editor

In the Culvert Design dialog box, there is an Output button. This command displays the culvert data in a text editor.

To display the culvert data in a text editor
1  In the Culvert Design dialog box, click Output to display the Culvert Output dialog box.

   ![Culvert Output dialog box]

2  Under Output Report, do one of the following to include in the output:
   ■ Select Comprehensive to report the calculated summary table of the performance curve along with other data.
   ■ Select Summary to report only the input and calculated data.
3  Select the Messages check box to include in the data file any warnings or error messages regarding the calculation.
4  Click OK to display the Output Format in a text editor.
   From here, you can save or edit the output data.
Displaying the Culvert Calculation Messages
There is a Messages button in the Culvert Design dialog box. Use this command to display warnings or error messages data in your currently configured ASCII text editor.

To display the culvert calculation messages
1 In the Culvert Design dialog box, click Messages to display the messages in a text editor.

From here, you can save or edit the output data.

Clearing the Calculator
In the Culvert Design dialog box, there is a New button. Use this command to clear this dialog box and start a new calculation.

To clear a calculator dialog box and start a new calculation
1 Save the existing data, if necessary.
2 In the Culvert Design dialog box, click New to display the New dialog box.
3 Click Yes to confirm that you want to delete the old data from the calculator.

The text boxes in the Culvert Design dialog box clear, and you can start entering new data.

Calculating Pipe Values
You can use the pipe calculators to solve for unknown pipe values, such as flowrate and depth of flow. When calculating pipe values, a friction factor or roughness coefficient is used to compensate for the effect of the roughness of the pipe material. Autodesk Civil Design includes pipe calculators that use the following formulas: Manning’s, Hazen-Williams, and Darcy-Weisbach.

Choose the pipe calculator to use based on which equation you want to use and which shape of pipe you are calculating values for: circular, rectangular, elliptical, or custom.

To use the calculators, choose a value to solve for, and then type in all of the other known data:
Use Manning’s equation when you want to solve based on gravity for open flow conditions.

Use Hazen-Williams or Darcy-Weisbach when you want to solve for pressure flow conditions.

Calculating Pipe Flow and Other Hydraulic Values Using the Manning’s n Equations

The Manning pipe calculators calculate flowrates and other hydraulic variables for pipes. The Manning formulas are used to calculate velocity for both imperial and metric units.

The different menu items provide the variation for the shape of the pipe: Circular, Rectangular, Elliptical, or Custom (User).

Manning’s Formula

Use the commands in the Manning Calculators menu to calculate flows and other hydraulic variables for pipes. The Manning’s formula used to calculate velocity for both imperial and metric units are:

Imperial Units: \[ V = \frac{1.486}{n} R^{\frac{5}{3}} S^{\frac{1}{3}} \]

Metric Units: \[ V = \frac{1}{n} R^{\frac{5}{6}} S^{\frac{1}{2}} \]

where:

V = Fluid velocity

n = Manning’s number

R = Hydraulic radius, which is the area of flow divided by the wetted perimeter.

s = Slope
Calculating the Hydraulic Values for Circular Pipes Using Manning’s Equations

To calculate the hydraulic values for circular pipes using Manning’s equations

1. From the Hydrology menu, choose Pipes ➤ Manning Circular to display the Manning dialog box.

2. From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Slope, Manning’s number, Depth of Flow, and Diameter Full.

   **NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.
The following illustration shows circular pipe values:

![Circular pipe values diagram]

3 In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).
4 In the Slope box, type a slope for the pipe (unless you are solving for the slope). You can also click Select to specify the slope by selecting points on the drawing.
5 In the Manning’s n box, type a roughness value for the pipe (unless you are solving for the Manning’s n). You can also click Select to select a coefficient from the Channel - Manning’s n dialog box.
6 In the Depth of Flow box, type a flow depth for the pipe (unless you are solving for the depth of flow).
7 In the Diameter box, type the pipe’s diameter (unless you are solving for the diameter). You can also click Select to choose the diameter from a table.

The box in the top-right area of the dialog box displays a graphic of the currently defined pipe. Based on the values that you entered, information about the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

The Percent Full value is calculated using the following formula:

\[ \% \text{ full} = \frac{\text{flow depth}}{\text{height}} \times 100.0 \]

**NOTE** If the data that you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

8 Click OK to exit the dialog box.

**Specifying a Pipe Diameter**

You can use the Pipe Selections table to select appropriate diameters for the pipe calculation.

**To specify a pipe diameter**

1 In the Manning dialog box, click the Select button next to the Diameter text box to display the Pipe Selections dialog box.
2 Select a pipe material and diameter by placing your cursor in the appropriate column and clicking anywhere in the text box that contains the value you want to use. Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and coefficients.
You can add a new pipe diameter to the table by using the following guidelines:
- Click Insert to add a new row above the row you currently have selected.
- To add data, select an empty text box and type the new description and diameter.

3 Click OK to return to the Pipe Calculator dialog box.

**Calculating the Flow for Rectangular Pipes Using Manning’s Equations**

**To calculate the flow for rectangular pipes using Manning’s equations**

1 From the Hydrology menu, choose Pipes ➤ Manning Rectangular to display the Manning dialog box.

2 From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Slope, Manning’s n, Depth of Flow, and Width.

**NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.
The following illustration shows rectangular pipe values:

3 In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).
4 In the Slope box, type a slope for the pipe (unless you are solving for the slope).
   You can also click Select to specify the slope by selecting points on the drawing.
5 In the Manning’s n box, type a roughness value for the pipe (unless you are solving for the Manning’s n).
   You can also click Select to select a coefficient from the Pipe - Manning’s n dialog box.
6 In the Depth of Flow box, type a flow depth for the pipe (unless you are solving for the depth of flow).
7 In the Height box, type the pipe’s height.
8 In the Width box, type the pipe’s width (unless you are solving for the width).
   The box in the top-right area of the dialog box displays a graphic of the currently defined pipe. Based on the values that you entered, information about the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.
   The Percent Full value is calculated using the following formula:
   \[
   \%\text{ full} = \frac{\text{depth of flow}}{\text{height}} \times 100.0
   \]
   \[\text{NOTE}\]
   If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.
9 Click OK to exit the dialog box.
Calculating the Flow for Elliptical Pipes Using Manning’s Equations

To calculate the flow for elliptical pipes using Manning’s n equations

1. From the Hydrology menu, choose Pipes ➤ Manning Elliptical to display the Manning dialog box.

2. From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Slope, Manning’s n, and Depth of Flow.

   **NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

   **NOTE** The Critical button is not functional on this calculator when calculating for elliptical pipes. Elliptical pipes require more intense calculations than circular or rectangular pipes.
The following illustration shows elliptical pipe values:

Elliptical pipe values

3 In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).
4 In the Slope box, type a slope for the pipe (unless you are solving for the slope). You can also click the Select button to specify the slope by selecting points on the drawing.
5 In the Manning’s n box, type a roughness value for the pipe (unless you are solving for the Manning’s n). You can also click the Select button to select a coefficient from the Pipe - Manning’s n dialog box.
6 In the Depth of Flow box, type a flow depth for the pipe (unless you are solving for the depth of flow).
7 In the Minor Axis box, type a length for the vertical (Minor) axis.
8 In the Major Axis box, type a length for the horizontal (Major) axis.

The box in the top-right area of the dialog box displays a graphic of the currently defined pipe. Based on the values that you entered, information about the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

The Percent Full value is calculated using the following formula:

\[
\% \, full = \frac{\text{depth} - \text{of} - \text{flow}}{\text{height}} \times 100.0
\]

**NOTE** If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

9 Click OK to exit the dialog box.
Calculating the Flow for Custom Pipes Using Manning’s Equations

To calculate the flow for custom pipes by using Manning’s n equations

1. From the Hydrology menu, choose Pipes ➤ Manning User to display the Manning dialog box.

2. From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Slope, Manning’s number, Wetted Area, and Wetted Perimeter.

   **NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

3. In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).

4. In the Slope box, type a slope for the pipe (unless you are solving for the slope). You can also click Select to specify the slope by selecting points on the drawing.

5. In the Manning’s n box, type a roughness value for the pipe (unless you are solving for the Manning’s n). You can also click Select to select a coefficient from the Pipe - Manning’s n dialog box.

6. In the Area box, type an area for the pipe.

7. In the Wetted Area box, type the flow (wetted) area value (unless you are solving for the wetted area).

8. In the Wetted Perimeter box, type the wetted perimeter of the pipe (unless you are solving for the wetted perimeter).

   Based on the values that you entered, information about the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

   The Percent Full value for user-defined pipes is calculated using the following formula:

   \[
   \% \text{full} = \frac{\text{Area (wetted)}}{\text{Area (Actual)}} \times 100.0
   \]

   **NOTE** If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

9. Click OK to exit the dialog box.
Calculating Pipe Flow and Other Hydraulic Values Using the Darcy-Weisbach Equations

The Darcy-Weisbach pipe calculators calculate flowrates and other hydraulic variables for pipes. The Darcy-Weisbach formulas are used when the pipe is in a pressure flow situation.

The different menu items provide the variation for the shape of the pipe: Circular, Rectangular, Elliptical, or Custom (User).

Darcy-Weisbach Formula
There are two different Darcy-Weisbach equations that are used in the Darcy-Weisbach pipe calculators. One is used for circular pipes, the other is used for elliptical and rectangular pipes.

The Darcy-Weisbach pipe calculators use the following formula to calculate head loss due to friction in circular pipes:

\[ h_L = \frac{fLv^2}{2dg} \]

where:
- \( h_L \) = Head loss due to friction
- \( f \) = Friction factor
- \( L \) = Length of pipe
- \( v \) = Fluid velocity
- \( d \) = Diameter of pipe
- \( g \) = Acceleration due to gravity (32.174 ft/s² or 9.807 m/s²)

The Darcy-Weisbach formula used to calculate head loss due to friction in non-circular (rectangular and elliptical) pipes is as follows:

\[ h_L = \frac{fLv^2}{8Rg} \]

where:
- \( h_L \) = Head loss due to friction
- \( f \) = Friction factor
- \( L \) = Length of pipe
- \( v \) = Fluid velocity
- \( R \) = Hydraulic radius
- \( g \) = Acceleration due to gravity (32.174 ft/s² or 9.807 m/s²)
Calculating the Flow for Circular Pipes Using the Darcy-Weisbach Equations

To calculate the flow for circular pipes using the Darcy-Weisbach formula

1. From the Hydrology menu, choose Pipes ➤ Darcy-Weisbach Circular to display the Darcy-Weisbach Calculator dialog box.
2. From the Solve For list, select the value you want to calculate.
   The available values are: Flowrate, Length, Headloss, Friction Factor, and Diameter.

   **NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate. Also, if you are solving for diameter, you must enter a value in the Diameter edit box to start calculations.

The following illustration shows circular pipe values:

3. In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).

4. In the Length box, type a length for the pipe (unless you are solving for the length).
   You can also click Select to specify the length by selecting an object or points on the drawing. For more information, see “Specifying a Length” in this chapter.

5. In the Headloss box, type a value to account for headloss (unless you are solving for the headloss).
   You can also click Select to specify the headloss value by selecting an object or points on the drawing. For more information, see “Specifying a Headloss Value” in this chapter.

6. In the Friction Factor box, type a friction factor value for the selected pipe (unless you are solving for the friction factor).
   You can also click Select to display the Darcy-Weisbach Friction Factors dialog box and select a coefficient. This dialog box describes the pipe and its coefficient value. For more information, see “Specifying a Darcy Weisbach Roughness Coefficient” in this chapter.
7 In the Diameter box, type a value for the diameter of the pipe (unless you are solving for the diameter).
   You can also click Select and pick a diameter from the Pipe Selections dialog box.
   The box in the top right area of the dialog box displays a graphic of the currently defined pipe. Based on the values that you entered, information about the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

   **NOTE**
   If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

8 Click OK to exit the dialog box.

**Specifying a Length**
You can specify a pipe length by picking a beginning and ending point from your drawing.

   **To specify a pipe length**
   1 In the Darcy-Weisbach dialog box, click the Select button next to the Length box. The current dialog box closes temporarily and the following prompt is displayed:
      Length – First point (or Entity): 
   2 Select the first point from the drawing.
      The following prompt is displayed:
      Length – Second point: 
   3 Select the second point from the drawing.
   4 Press ENTER when you have finished selecting points in the drawing.
      The calculator dialog box displays and the value of the length you selected is displayed in the Length text box.
   5 Click OK to exit the dialog box.

**Specifying a Headloss Value**
You can specify a headloss value by selecting points or an object from your drawing. Headloss is the amount of energy, or head, that is lost due to friction factors.

   **To specify a headloss value**
   1 In the Darcy-Weisbach dialog box, click the Select button next to the Headloss text box.
      The current dialog box closes temporarily and the following prompt is displayed:
      Length – First point (or Entity):
   2 Do one of the following to select the headloss length:
      - Select two or more points to define the length, pressing ENTER when you have finished selecting points.
      - Type **Entity**, and then select the entity from the drawing.
The calculator dialog box displays and the value you selected is displayed in the Length text box.

**Specifying a Darcy-Weisbach Roughness Coefficient**

Use the Darcy-Weisbach Friction Factors table to select an appropriate friction coefficient from a table.

**To choose a Darcy-Weisbach friction coefficient from a table**

1. In the Darcy-Weisbach dialog box, click the Select button next to the Friction Factor box to display the Darcy-Weisbach Friction Factors dialog box.
2. Select a coefficient by placing your cursor in the appropriate column and clicking anywhere in the text box that contains the value you want to use.

Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and coefficients.

You can add a new friction factor value by using the following guidelines:
- Click Insert to add a new row above the row you currently have selected.
- To add data, select an empty text box and type the new description and coefficient.

3. Click OK to return to the Darcy-Weisbach pipe calculator dialog box.

**Calculating the Flow for Rectangular Pipes Using the Darcy-Weisbach Equations**

To calculate the flow for rectangular pipes using the Darcy-Weisbach equations

1. From the Hydrology menu, choose Pipes ➤ Darcy-Weisbach Rectangular to display the Darcy-Weisbach Calculator dialog box.
2. From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Length, Headloss, Friction Factor, and Width.

**NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.
The following illustration shows rectangular pipe values:

3 In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).

4 In the Length box, type a length for the pipe (unless you are solving for the length). You can also click Select to specify the length by selecting an object or points on the drawing. For more information, see “Specifying a Length” in this chapter.

5 In the Headloss box, type a value to account for headloss (unless you are solving for the headloss).

You can also click Select to specify the headloss value by selecting an object or points on the drawing. For more information, see “Specifying a Headloss Value” in this chapter.

6 In the Friction Factor box, type a friction factor value for the selected pipe (unless you are solving for the friction factor).

You can also click Select to display the Darcy-Weisbach Friction Factors dialog box and select a coefficient. This dialog box describes the pipe and the coefficient value of the pipe. For more information, see “Specifying a Darcy Weisbach Roughness Coefficient” in this chapter.

7 In the Height box, type a height for the pipe.

8 In the Width box, type a width for the pipe (unless you are solving for the width).

The box in the top-right area of the dialog box displays a graphic of the currently defined pipe. Based on the values that you entered, information about the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

**NOTE** If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

9 Click OK to exit the dialog box.
Calculating the Flow for Elliptical Pipes Using the Darcy-Weisbach Equations

To calculate the flow for elliptical pipes using the Darcy-Weisbach equations:

1. From the Hydrology menu, choose Pipes ➤ Darcy-Weisbach Elliptical to display the Darcy-Weisbach Calculator dialog box.

2. From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Length, Headloss, and Friction Factor.

   **NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

The following illustration shows elliptical pipe values:

3. In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).

4. In the Length box, type a length for the pipe (unless you are solving for the length).

   You can also click Select to specify the length by selecting an object or points on the drawing. For more information, see “Specifying a Length” in this chapter.

5. In the Headloss box, type a value to account for headloss (unless you are solving for the headloss).

   You can also click Select to specify the headloss value by selecting an object or points on the drawing. For more information, see “Specifying a Headloss Value” in this chapter.

6. In the Friction Factor box, type a friction factor value for the selected pipe (unless you are solving for the friction factor).

   You can also click Select to display the Darcy-Weisbach Friction Factors dialog box and select a coefficient. This dialog box describes the pipe and the coefficient value of the pipe. For more information, see “Specifying a Darcy Weisbach Roughness Coefficient” in this chapter.

7. In the Minor Axis box, type a length for the vertical (Minor) axis.
8 In the Major Axis box, type a length for the horizontal (Major) axis.

The box in the top-right area of the dialog box displays a graphic of the currently defined pipe. Based on the values that you entered, information about the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

NOTE If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

9 Click OK to exit the dialog box.

Calculating the Flow for Custom Pipes Using the Darcy-Weisbach Equations

To calculate the flow for custom pipes using the Darcy-Weisbach equations

1 From the Hydrology menu, choose Pipes ➤ Darcy-Weisbach User to display the Darcy-Weisbach dialog box.
2 From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Headloss, Friction Factor, Area, Perimeter, and Length.

NOTE Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

3 In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).
4 In the Headloss box, type a value to account for headloss (unless you are solving for the headloss).

You can also click Select to specify the headloss value by selecting an object or points on the drawing. For more information, see “Specifying a Headloss Value” in this chapter.

5 In the Friction Factor box, type a friction factor value for the selected pipe (unless you are solving for the friction factor).

You can also click Select to display the Darcy-Weisbach Friction Factors dialog box and select a coefficient. This dialog box describes the pipe and the coefficient value of the pipe. For more information, see “Specifying a Darcy Weisbach Roughness Coefficient” in this chapter.

6 In the Area box, type an area for the pipe (unless you are solving for the area).
7 In the Perimeter box, type a perimeter for the pipe (unless you are solving for the perimeter).
8 In the Length box, type a length for the pipe (unless you are solving for the length).

You can also click Select to specify the length by selecting an object or points on the drawing. For more information, see “Specifying a Length” in this chapter.

The box in the top-right area of the dialog box displays a graphic of the currently defined pipe. Based on the values that you entered, information about
the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

**NOTE** If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

9 Click OK to exit the dialog box.

Calculating Pipe Flow and Other Hydraulic Values by Using the Hazen-Williams Equations

The Hazen-Williams pipe calculators calculate flowrates and other hydraulic variables for pipes. The Hazen-Williams formula is used when a pipe is in pressure flow. The different menu items provide the variation for the shape of the pipe: Circular, Rectangular, Elliptical, or Custom (User).

**Hazen-Williams Formula**

The commands on the Hazen-Williams menu calculate piping values. The Hazen-Williams formula used to calculate head loss due to friction in circular pipes is:

**Metric**: \( V = 0.849cR^{0.63}S^{0.54} \)

**Imperial**: \( V = 1.318cR^{0.63}S^{0.54} \)

where:

- \( V \) = Fluid velocity
- \( c \) = Roughness coefficient
- \( R \) = Hydraulic radius
- \( S \) = Head loss due to friction

Calculating the Flow for Circular Pipes Using the Hazen-Williams Equations

To calculate circular piping values using the Hazen-Williams equations

1 From the Hydrology menu, choose Pipes ➤ Hazen-Williams Circular to display the Hazen-Williams dialog box.

2 From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Length, Headloss, Coefficient, and Diameter.

**NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate. Also, if you are solving for diameter, you must enter a value in the Diameter edit box to start calculations.
The following illustration shows circular pipe values:

![Circular pipe values](image)

Circular pipe values

3 In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).

4 In the Length box, type a length for the pipe (unless you are solving for the length).

You can also click Select to specify the length by selecting an object or points on the drawing. For more information, see “Specifying a Length” in this chapter.

5 In the Headloss box, type a value to account for headloss (unless you are solving for the headloss).

You can also click Select to specify the headloss value by selecting an object or points on the drawing. For more information, see “Specifying a Headloss Value” in this chapter.

6 In the Coefficient box, type a coefficient value for the selected pipe (unless you are solving for the coefficient).

You can also click Select to display the Hazen-Williams Roughness Coefficients dialog box and select a coefficient. This dialog box describes the pipe and the coefficient value of the pipe. For more information, see “Specifying a Hazen-Williams Roughness Coefficient” in this chapter.

7 In the Diameter box, type a value for the diameter of the pipe (unless you are solving for the diameter).

You can also click Select, and pick a diameter form the Pipe Selections dialog box. For more information, see “Specifying a Pipe Diameter” in this chapter.

The box in the top-right area of the dialog box displays a graphic of the currently defined pipe. Based on the values that you entered, information about the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

**NOTE** If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

8 Click OK to exit the dialog box.
**Specifying a Hazen Williams Roughness Coefficient**

In the Hazen-Williams dialog box, there is a Select button next to the Coefficient box. Use this command to display the Hazen-Williams Roughness Coefficients dialog box and specify a Hazen-Williams roughness coefficient from a table.

**To specify a Hazen-Williams roughness coefficient from a table**

1. In the Hazen-Williams dialog box, click the Select button next to the Coefficient box to display the Hazen-Williams Roughness Coefficients dialog box.
2. Select a coefficient by placing your cursor in the appropriate column and clicking by anywhere in the text box that contains the value you want to use.
3. Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and coefficients.
   - You can add a new roughness coefficient to the table:
     - Click Insert to add a new row above the row you currently have selected.
     - To add data, select an empty text box, and type the new description and coefficient.
4. Click OK to return to the Hazen-Williams dialog box.

**Calculating the Flow for Rectangular Pipes Using the Hazen-Williams Equations**

To calculate the flow for rectangular piping values using the Hazen-Williams equations

1. From the Hydrology menu, choose Pipes ➤ Hazen-Williams Rectangular to display the Hazen-Williams dialog box.
2. From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Length, Headloss, Coefficient, and Width.

**NOTE**

Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.
The following illustration shows rectangular pipe values:

3 In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).
4 In the Length box, type a length for the pipe (unless you are solving for the length).
   You can also click Select to specify the length by selecting an object or points on the drawing. For more information, see “Specifying a Length” in this chapter.
5 In the Headloss box, type a value to account for headloss (unless you are solving for the headloss).
   You can also click Select to specify the headloss value by selecting an object or points on the drawing. For more information, see “Specifying a Headloss Value” in this chapter.
6 In the Coefficient box, type a coefficient value for the selected pipe (unless you are solving for the coefficient).
   You can also click Select to display the Hazen-Williams Roughness Coefficients dialog box and select a coefficient. This dialog box describes the pipe and the coefficient value of the pipe. For more information, see “Specifying a Hazen Williams Roughness Coefficient” in this chapter.
7 In the Height box, type a height for the pipe.
8 In the Width box, type a width for the pipe (unless you are solving for the width).
   The box in the top-right area of the dialog box displays a graphic of the currently defined pipe. Based on the values that you entered, information about the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

   **NOTE** If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

9 Click OK to exit the dialog box.
Calculating the Flow for Elliptical Pipes Using the Hazen-Williams Equations

To calculate the flow elliptical piping values using the Hazen-Williams equations

1. From the Hydrology menu, choose Pipes ➤ Hazen-Williams Elliptical to display the Hazen-Williams dialog box.
2. From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Length, Headloss, and Coefficient.

NOTE  Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

The following illustration shows elliptical pipe values:

Elliptical pipe values

3. In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).
4. In the Length box, type a length for the pipe (unless you are solving for the length).
   You can also click Select to specify the length by selecting an object or points on the drawing. For more information, see “Specifying a Length” in this chapter.
5. In the Headloss box, type a value to account for headloss (unless you are solving for the headloss).
   You can also click Select to specify the headloss value by selecting an object or points on the drawing. For more information, see “Specifying a Headloss Value” in this chapter.
6. In the Coefficient box, type a coefficient value for the selected pipe (unless you are solving for the coefficient).
   You can also click Select to display the Hazen-Williams Roughness Coefficients dialog box and select a coefficient. This dialog box describes the pipe and the coefficient value of the pipe. For more information, see “Specifying a Hazen Williams Roughness Coefficient” in this chapter.
7. In the Minor Axis box, type a length for the vertical (Minor) axis.
8 In the Major Axis box, type a length for the horizontal (Major) axis.

The box in the top-right area of the dialog box displays a graphic of the currently defined pipe. Based on the values that you entered, information about the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

**NOTE** If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

9 Click OK to exit the dialog box.

**Calculating the Flow for Custom Pipes Using the Hazen-Williams Equations**

To calculate flow for custom pipes using the Hazen-Williams equations

1 From the Hydrology menu, choose Pipes ▶ Hazen-Williams User to display the Hazen-Williams dialog box.

2 From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Headloss, Coefficient, Area, Perimeter, and Length.

**NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

3 In the Flowrate box, type a flow rate for the pipe (unless you are solving for the flowrate).

4 In the Length box, type a length for the pipe (unless you are solving for the length).

You can also click Select to specify the length by selecting an object or points on the drawing. For more information, see “Specifying a Length” in this chapter.

5 In the Headloss box, type a value to account for headloss (unless you are solving for the headloss).

You can also click Select to specify the headloss value by selecting an object or points on the drawing. For more information, see “Specifying a Headloss Value” in this chapter.

6 In the Coefficient box, type a coefficient value for the selected pipe (unless you are solving for the coefficient).

You can also click Select to display the Hazen-Williams Roughness Coefficients dialog box and select a coefficient. A description of the pipe and the coefficient value of the pipe displays in this dialog box. For more information, see “Specifying a Hazen Williams Roughness Coefficient” in this chapter.

7 In the Area box, type an area for the pipe (unless you are solving for the area).

8 In the Perimeter box, type a perimeter for the pipe (unless you are solving for the perimeter).

A graphic of the currently defined pipe is displayed in the box in the top-right area of the dialog box. Based on the values that you entered, information about
the pipe is calculated and displayed at the bottom left of the dialog box. This information is for display only and cannot be edited.

**NOTE** If the data you entered has an error, the pipe graphic image does not display. Check for an error message at the bottom of the dialog box.

9 Click OK to exit the dialog box.

**Calculating Orifice Values**

Use the Orifice Calculator to calculate hydraulic values for orifices.

The following illustration shows orifice values:

![Orifice values](image)

The Orifice Calculator uses the following formula:

$$Q = cA\sqrt{2gH}$$

where:

- $Q$ = Design flow rate
- $c$ = Orifice coefficient
- $A$ = Cross-sectional area
- $g$ = Acceleration due to gravity (32.174 ft/s² or 9.807 m/s²)
- $H$ = Total head (Headwater minus Tailwater)
To calculate hydraulic values for orifices

1. From the Hydrology menu, choose Orifice Calculator to display the Orifice Calculator dialog box.

2. From the Solve For list, select the value that you want to calculate. The available values are: Flowrate, Coefficient, Area or Diameter, Headwater, and Tailwater.

   **NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate from the Solve For list, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

3. Under Use, select Diameter or Area to specify how to calculate the orifice size.
4. In the Flowrate box, type a flow rate for the orifice.
5. In the Coefficient box, type a roughness coefficient for the orifice.
   You can also click Select to specify a coefficient from the Orifice coefficient dialog box. This dialog box describes the orifice shape and the roughness coefficient value for the shape. For more information, see “Specifying an Orifice Coefficient” in this chapter.
6. In the Diameter box, type the diameter for the orifice.
   **NOTE** The diameter text box is available only if you selected Diameter in step 3.
   You can also click Select to specify the diameter by selecting points on the drawing. For more information, see “Specifying a Diameter” in this chapter.
7. In the Area box, type the area for the orifice.
   **NOTE** The area text box is available only if you select Area in step 3.
   You can also click Select to specify the area by selecting points on the drawing. For more information, see “Specifying an Area” in this chapter.
8 In the Headwater box, type the headwater depth above the orifice opening. The headwater is measured from the center of the opening. For more information, see the preceding illustration on orifice values in the introduction of this topic.

9 In the Tailwater box, type the tailwater depth above the orifice opening. Tailwater is also measured from the center of the opening. For more information, see the preceding illustration on orifice values in the introduction of this topic.

The Velocity label displays the computed flow velocity through the orifice. The box on the right side of the dialog box displays a graphic of the currently defined orifice. This information is for display only and cannot be edited.

**NOTE** If the data you entered has an error, then the orifice graphic image does not display. Check for an error message at the bottom of the dialog box.

10 Click OK to exit the dialog box.

**Specifying an Orifice Coefficient**

The Orifice Coefficient dialog box describes orifice shapes and associated frictional loss coefficients.

To select a coefficient from the dialog box

1 In the Orifice Calculator dialog box, click the Select button next to the Coefficient box to display the Orifice Coefficients dialog box.

2 Select a coefficient by placing your cursor in the appropriate column and clicking by anywhere in the text box that contains the value you want to use.

3 Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and coefficients.

You can add a new orifice coefficient:

- Click Insert to add a new row above the row you currently have selected.
- To add data, select an empty text box, and type the new description and coefficient.

4 Click OK to return to the Orifice Calculator dialog box.

**Specifying a Diameter**

You can specify a diameter from the Orifice Calculator dialog box by selecting a beginning and ending point from your drawing.

To specify an orifice diameter

1 In the Orifice Calculator dialog box, click the Select button next to the Diameter box. The Orifice Calculator dialog box closes temporarily and a prompt similar to the following is displayed:

   Diameter <12.0000 m>:

2 Select the first point of the diameter from the drawing.

   The following prompt is displayed:

   Second point:
3 Select the second point from the drawing.

The Orifice Calculator dialog box displays and the value of the diameter you selected is displayed in the Diameter text box.

**Specifying an Area**
You can specify an area from the Orifice Calculator dialog box by selecting points from your drawing.

**NOTE**
You must select the Area option under Use in the Orifice Calculator dialog box in order to specify an area.

**To specify an orifice area**
1 In the Orifice Calculator dialog box, click the Select button next to the Area box. The Orifice Calculator dialog box closes temporarily and the following prompt is displayed:

   Select polyline (or Draw):

2 Do one of the following:
   - Select a polyline in the drawing.
   - Type **Draw** to draw the area in the drawing. When you have drawn all but the last segment of the polyline, type **Close** to close the polyline back to its start point.

The Orifice Calculator dialog box displays and the value for the area you selected or drew displays in the Area text box.

**Calculating Weir Values**

Weirs are used as outlet devices for regulating the flow of water out of detention ponds or other water storage facilities. They can also be used as measurement devices in streams and constricted channels. Using the weir calculators, you can solve for the flowrate, depth of flow, weir coefficient, and height.

Autodesk Civil Design has commands you can use to design sharp-crested weirs in three shapes: Cipolleti (trapezoidal), rectangular, and triangular.

When you enter the weir parameters, the velocity, wetted area, area, and percent full values are also calculated for the weir. For Cipolleti and triangular weirs, the crested length is also reported.

**NOTE**
The weir coefficients that are provided with Autodesk Civil Design are samples only. You must determine the weir coefficient based on the geometry of the weir you are designing.
Calculating Cipolleti Weir Values

Use the Weirs ➤ Cipolleti command on the Hydrology menu to calculate weir values using the Cipolleti formula. A Cipolleti weir is trapezoidal in shape, and has side slopes of 4 vertical to 1 horizontal. For more information, see “Cipolleti Weir Formulas” in this chapter.

The following illustration shows Cipolleti weir values with the wetted width of \( T = b + \frac{1}{2} h \):

To calculate weir values using the Cipolleti formula

1. From the Hydrology menu, choose Weirs ➤ Cipolleti to display the Cipolleti Weir Calculator dialog box.
2 From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Width, Depth of Flow, Velocity Coefficient, and Discharge Coefficient.

**NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

3 In the Flowrate box, type a flow rate value for the weir.
4 In the Width box, type a wetted width (T value) for the weir.
5 In the Depth of Flow box, type a depth of flow value.
6 In the Height box, type a height for the weir.
7 In the Cv box, type the velocity coefficient.
   You can also click Select to display the Velocity Coefficients dialog box and select a coefficient. For more information, see “Specifying a Cv Value” in this chapter.

**NOTE** The weir coefficients that are provided with Autodesk Civil Design are samples only. You must determine the weir coefficient based on the geometry of the weir you are designing.

8 In the Cd box, type a discharge coefficient.
   The computed values for the weir display at the bottom left of the dialog box. The box at the top right area displays a graphic of the currently defined weir. This information is for display only and cannot be edited.

**NOTE** If the data you entered has an error, the weir graphic image does not display. Check for an error message at the bottom of the dialog box.

9 Click OK to exit the dialog box.

**Cipolleti Weir Formulas**

The Cipolleti Weir calculator uses the following formula to calculate the flow rate:

\[
Q = \frac{2}{3} C_d C_v \sqrt{2gT h_1^{1.5}}
\]

where:

- \(Q\) = Design flow rate
- \(C_d\) = Discharge coefficient
- \(C_v\) = Velocity coefficient
- \(g\) = Acceleration due to gravity (32.174 \text{ ft/s}^2 \text{ or } 9.807 \text{ m/s}^2)
- \(T\) = Wetted width of the weir
- \(h_1\) = height of weir
Calculating Weir Values

Specifying a Cv Value

The Velocity Coefficients dialog box describes the weir structure and the associated velocity coefficients of the weir.

To select a coefficient from the dialog box

1. In the Cipolletti Weir Calculator dialog box, click the Select button next to the Cv text box to display the Velocity Coefficients dialog box.

2. Select a coefficient by placing your cursor in the appropriate column and clicking anywhere in the text box that contains the value you want to use.

Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and coefficients.

You can add a new coefficient:

- Click Insert to add a new row above the row you currently have selected.
- To add data, select an empty text box and type the new description and coefficient.

3. Click OK to return to the Cipolletti Weir Calculator dialog box.

Calculating Rectangular Weir Values

The Weirs ➤ Rectangular command on the Hydrology menu calculates hydraulic values for suppressed and contracted rectangular weirs. For more information on the formulas that are used for the Rectangular Weir calculator, see “Rectangular Weir Formulas” in this chapter.
To calculate hydraulic values for rectangular weirs

1. From the Hydrology menu, choose Weirs ➤ Rectangular to display the Rectangular Weir Calculator dialog box.

2. From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Width, Depth of Flow, and Coefficient.

   **NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

3. Select the Contracted Ends check box to use the contracted weir formula for calculating the values.
   If you clear the Contracted Ends check box, then the suppressed weir formula is used to calculate the values.

4. In the Flowrate box, type a flow rate value for the weir.
5. In the Width box, type a width for the weir.
6. In the Depth of Flow box, type a depth of flow value.
7. In the Coefficient box, type a weir coefficient value.

You can also click Select to display the Rectangular Weir Coefficients dialog box and select a coefficient. For more information, see “Specifying a Rectangular Weir Coefficient” in this chapter.

   **NOTE** The weir coefficients that are provided with Autodesk Civil Design are samples only. You must determine the weir coefficient based on the geometry of the weir you are designing.
8 In the Height box, type a height for the weir.

The computed values for the weir display at the bottom left of the dialog box. The box at the top right area of the dialog box displays a graphic of the currently defined weir. This information is for display only and cannot be edited.

**NOTE** If the data you entered has an error, the weir graphic image does not display. Check for an error message at the bottom of the dialog box.

9 Click OK to exit the dialog box.

**Rectangular Weir Formulas**

You can use the Rectangular Weir Calculator to calculate hydraulic values for suppressed and contracted rectangular weirs.

The following formula is used to calculate the design flow rate for a suppressed weir.

\[ Q = \frac{2}{3} cL\sqrt{2g(H)^{1.5}} \]

The following formula is used to calculate the design flow rate for a contracted weir, including a correction (-0.2H) to the effective length to account for edge contractions.

\[ Q = \frac{2}{3} c(L - 0.2H)\sqrt{2g(H)^{1.5}} \]

where:

- \( Q \) = Design flow rate
- \( c \) = Weir coefficient
- \( L \) = Length of weir
- \( g \) = Acceleration due to gravity (32.174 ft/s\(^2\) or 9.807 m/s\(^2\))
- \( H \) = Weir head

**Specifying a Rectangular Weir Coefficient**

The Rectangular Weir Coefficient dialog box displays descriptions of weir structures and the associated velocity coefficients.

**To select a coefficient from the dialog box**

1 In the Rectangular Weir Calculator dialog box, click the Select button next to the Coefficient text box to display the Rectangular Weir Coefficient dialog box.

2 Select a coefficient by placing your cursor in the appropriate column and clicking anywhere in the text box that contains the value you want to use.

   Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and coefficients.

   You can add a new coefficient:

   - Click Insert to add a new row above the row you currently have selected.
   - To add data, select an empty text box, and type the new description and coefficient.

3 Click OK to return to the Rectangular Weir Calculator dialog box.
Calculating Triangular Weir Values

The Weirs ➤ Triangular command on the Hydrology menu calculates hydraulic values for triangular weirs.

For more information on the formula that is used to calculate triangular weir values, see “Triangular Weir Formula” in this chapter.

To calculate hydraulic values for triangular weirs

1. From the Hydrology menu, choose Weirs ➤ Triangular to display the Triangular Weir Calculator dialog box.

2. From the Solve For list, select the value you want to calculate. The available values are: Flowrate, Angle, Depth of Flow, and Coefficient.

   **NOTE** Do not enter the value for which you are solving. For example, if you select Flowrate in this step, leave the Flowrate text box at 0. After you enter the other values, the program solves for the Flowrate.

3. In the Flowrate box, type a flow rate value for the weir.
4. In the Angle box, type an angle for the weir.
5. In the Depth of Flow box, type a depth of flow value.
6. In the Coefficient box, type a weir coefficient value.

   You can also click Select to display the Triangular Weir Coefficients dialog box and select a coefficient. For more information, see “Specifying a Triangular Weir Coefficient” in this chapter.
NOTE  The weir coefficients that are provided with Autodesk Civil Design are samples only. You must determine the weir coefficient based on the geometry of the weir you are designing.

7  In the Height box, type a height for the weir. The computed values for the weir display at the bottom left of the dialog box. The box at the top right area of the dialog box displays a graphic of the currently defined weir. This information is for display only and cannot be edited.

NOTE  If the data you entered has an error, the weir graphic image does not display. Check for an error message at the bottom of the dialog box.

8  Click OK to exit the dialog box.

**Triangular Weir Formula**
The following formula is used to calculate the design flow rate for triangular weirs:

\[ Q = c \frac{8}{15} \sqrt{2g \tan\left(\frac{\theta}{2}\right)}H^{2.5} \]

where:

- \( Q \) = Design flow rate
- \( c \) = Weir coefficient
- \( g \) = Acceleration due to gravity \((32.174 \text{ ft/s}^2 \text{ or } 9.807 \text{ m/s}^2)\)
- \( \theta \) = Notch angle of weir
- \( H \) = Weir head

**Specifying a Triangular Weir Coefficient**
The Triangular Weir Coefficient dialog box describes weir structures and the associated velocity coefficients.

**To select a coefficient from the dialog box**

1  In the Triangular Weir Calculator dialog box, click the Select button next to the Coefficient text box to display the Triangular Weir Coefficient dialog box.

2  Select a coefficient by placing your cursor in the appropriate column and clicking anywhere in the text box that contains the value you want to use. Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and coefficients.

You can add a new coefficient:

- Click Insert to add a new row above the row you currently have selected.
- To add data, select an empty text box and type the new description and coefficient.

3  Click OK to return to the Triangular Weir Calculator dialog box.
Calculating Riser Values

Risers can be used as outlets (or principle spillways) for detention ponds or other water storage facilities. The goal when designing a riser is to size the riser and pipe diameters so that the peak discharge is less than the allowable rate for the chosen design storms. When you enter the required information into the Riser Calculator, the calculator determines the optimum riser and pipe diameters for you.

The Riser Calculator determines whether the top of the riser stand pipe is acting as a weir or a riser based on the flowrate. Use the Settings option in the Riser Calculator to define the weir and orifice coefficients to use in the calculations.

You can view the results of the riser calculation in a few different ways. The calculator dialog box itself reports diameter, flow, and head values for the riser and the pipe. The Output button creates a file that lists all of the information in the Riser Calculator dialog box, along with weir and orifice flowrates. In addition, you can view the results of the calculations as a rating curve.

Changing the Riser Settings

In the riser settings, you specify which orifice and weir coefficients are used in the riser calculations. You can also choose to enable a feature that checks to see that the riser diameter is at least 1.25 times greater than the pipe diameter.

To change the riser settings
1. From the Hydrology menu, choose Riser Calculator to display the Riser Calculator dialog box.
2. In the Riser Calculator dialog box, click Settings to display the Riser Settings dialog box.
3. In the Orifice Coefficient box, type an appropriate orifice coefficient.
4. In the Weir Coefficient box, type an appropriate weir coefficient.

NOTE: You must determine the weir coefficient based on the geometry of the weir you are designing.

5. To automatically check that the riser diameter is at least 1.25 times greater than the pipe diameter, select the Riser Diameter check box.
6. Click OK to return to the Riser Calculator dialog box.

Calculating Riser Values

Using the Riser Calculator, you can design a riser based on base flow, riser elevation, and several other values. After you input the required values, the Riser Calculator calculates diameter, flow, and head values for the riser and the pipe. For information on the Riser Head formula, see “Riser Head Flow Formula” and “Riser Equations and Steps Used to Calculate Riser Values” in this chapter.
The following illustration shows the riser values required for designing a riser:

**To calculate riser values**

1. From the Hydrology menu, choose Riser Calculator to display the Riser Calculator dialog box.

   **TIP** You can click Load to load an existing riser file, or click New to clear the calculator of its current values.

   **NOTE** When you input all of the riser data, the Riser Calculator determines the optimum riser and pipe diameters based on the defined riser and pipe diameters that are in tables called rsrdiam.dia and rsrpipe.dia. If you want to exclude a certain diameter from being used by the calculator, or add a new diameter, then click the Tables button. For more information, see "Customizing Riser Diameter and Pipe Diameter Tables" in this chapter.

2. In the Base Flow box, type a base flow value.

3. In the Riser Elev box, type a riser elevation. For more information about this value and other values in the Riser Calculator, see the preceding illustration on riser values in the introduction of this topic. You can also click Select, and select a point in the drawing to specify a riser elevation. For more information, see “Selecting Riser Points from a Drawing” in this chapter.

4. In the Invert In box, type an invert in elevation. You can also click Select, and select a point in the drawing to specify an invert in elevation. For more information, see “Selecting Riser Points from a Drawing” in this chapter.

5. In the Invert Out box, type an invert out elevation. You can also click Select, and select a point in the drawing to specify an invert out elevation.

6. In the Surface Elev box, type a surface elevation. This is the water surface elevation. You can also click Select, and select a point in the drawing to specify a surface elevation.

7. In the Spillway Crest box, type a spillway crest elevation. You can also click Select and select a point in the drawing to specify a spillway crest elevation.

8. In the Pipe Length box, type a pipe length. You can also click Select and select two points in the drawing to specify a pipe length.

9. In the Manning's n box, type a Manning's n coefficient for the pipe. You can also click Select to open the Pipe-Manning's n dialog box. Select a Manning's n value by placing your cursor in the appropriate column, and clicking OK.
10 In the Entrance Coef box, type an entrance coefficient. You can also click Select and choose a coefficient from the Pipe Entrance Coefficients dialog box. For more information, see “Specifying Pipe Entrance Coefficients” in this chapter.

11 In the Bend Angle box, type a pipe bend angle. This is the angle where the vertical section of the riser and the horizontal (pipe) section of the riser meet. The computed values for the riser display at the right of the dialog box. The box at the top right area of the dialog box displays a graphic of the currently defined riser. This information is for display only and cannot be edited.

NOTE If the data you entered has an error, the riser graphic image does not display. Check for an error message at the bottom of the dialog box.

12 Click Save to save the riser calculations. For more information, see “Saving Riser Data from the Riser Calculator” in this chapter.

13 Do the following to output the riser data:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>output the riser data to a text editor</td>
<td>Output</td>
</tr>
<tr>
<td>output and save a rating curve of the riser data</td>
<td>Rating</td>
</tr>
</tbody>
</table>

14 Click OK to exit the dialog box.

**Riser Head Flow Formula**

The Riser Calculator uses the following formula for calculating head flow:

\[
Q = a \sqrt{\frac{2gH}{1 + K_e + K_b + K_p L}}
\]

where:

- \(Q\) = Design flow rate
- \(a\) = Pipe cross-sectional area
- \(g\) = Acceleration due to gravity (32.174 ft/s\(^2\) or 9.807 m/s\(^2\))
- \(H\) = Elevation head differential
- \(K_e\) = Entrance loss coefficient
- \(K_b\) = Pipe bend loss coefficient
- \(K_p\) = Pipe friction coefficient
- \(L\) = Pipe length
Riser Equations and Steps Used to Calculate Riser Values

The following equations and steps are used by the Riser Calculator to calculate values.

Equations used: (From Chapters 3 and 6 in the SCS Engineering Field Manual)

**Friction flow:** \( Q_f = \frac{1.486}{n} \star R_h^{2/3} \star \text{slope}^{1/2} \star \text{Area} \)

**Head flow:** \( Q_h = \frac{(2 \star G_a \star \text{PipeHead})}{(1 + K_e + K_b + K_p \star \text{Length})}^{1/2} \)

**Weir flow:** \( Q_{\text{weir}} = \text{WeirCoefficient} \star \pi \star \text{Diameter} \star \text{RiserHead}^{3/2} \)

**Orifice flow:** \( Q_{\text{orifice}} = \text{OrificeCoefficient} \star \left( \frac{\text{Diameter}^2}{4} \right) \star \pi \star \left( 2 \star G_a \star \text{RiserHead} \right)^{1/2} \)

where:

- \( K_p = \frac{(5077 \star n^2)}{\text{Diameter}^{6/3}} \) Pipe friction coefficient. Diameter is in inches.
- \( K_b = \frac{(\text{Bend} \star n)}{3} \) (minor loss due to bend).
- \( K_e = \) Entrance Coefficient (minor loss due to entrance).
- \( \text{Area} = \) Area of pipe (use full) (\( \text{ft}^2 \)).
- \( \text{Length} = \) Length of pipe (ft).
- \( n = \) Manning’s roughness coefficient for pipe.
- \( R_h = \) Hydraulic radius (wetted area / wetted perimeter – use full flow in this case) (ft).
- \( G_a = \) Acceleration due to gravity 32.174 (\( \text{ft/sec}^2 \)).
- \( \text{Bend} = \) User input. Range 0-90 degrees (0 for no bend).
- \( \text{Slope} = \) Slope of Pipe (elevation difference / length) (ft).
- \( \text{PipeHead} = \) Spillway elevation – Outlet elevation (ft).
- \( \text{Diameter} = \) vertical pipe diameter from table (ft).
- \( \text{RiserHead} = \) Elevation difference between rim of vertical pipe and the water surface (ft).
- \( \text{WeirCoefficient} = \) User input (usually 3.33).
- \( \text{OrificeCoefficient} = \) User input (within range of 0.5–0.83).
- \( \pi = 3.14159 \)

For more information on the steps used to calculate riser values, see Autodesk Civil Design online Help.
Selecting Riser Points from a Drawing

In the Riser Calculator dialog box, you can click Select next to any of the first six text boxes to select riser points from the drawing.

To specify distances by selecting riser points from a drawing

1. In the Riser Calculator dialog box, click Select next to one of the first six text boxes. The Riser Calculator dialog box closes temporarily and the following prompt is displayed:
   Select point (or Dtm):

2. Select the point or type Dtm to select a point from a terrain model surface.

   NOTE: When selecting the Pipe Length, you are prompted to select a second point.

The Riser Calculator dialog box displays and the value you selected is displayed in the appropriate text box.

3. Click OK to exit the dialog box.

Specifying Pipe Entrance Coefficients

In the Pipe Entrance Coefficient dialog box, you can specify a pipe entrance coefficient.

To specify a pipe entrance coefficient

1. In the Riser Calculator dialog box, click the Select button next to the Entrance Coef text box to display the Pipe Entrance Coefficients dialog box.

2. Select a coefficient by placing your cursor in the appropriate column and clicking anywhere in the text box that contains the value you want to use. Use the navigation buttons on the right side of the dialog box to move through the list of descriptions and coefficients.

   You can add a new coefficient:
   - Click Insert to add a new row above the row you currently have selected.
   - To add data, select an empty text box, and type the new description and coefficient.

3. Click OK to return to the Riser Calculator dialog box.

Customizing Riser Diameter and Pipe Diameter Tables

When you click the Tables button on the Riser Calculator, you can access riser and pipe diameter tables that you can customize. The Riser Calculator uses these tables to determine which diameter sizes are available to solve for.

For example, if you don’t want the calculator to solve for a 12-inch diameter pipe, then you can delete that entry from the riser pipe table. The Riser Calculator uses another pipe diameter that is listed in the table.
Calculating Riser Values

535

NOTE

Unlike some other tables that you access in Autodesk Civil Design calculators, the Riser Table and Riser Pipe Table do not insert values into the calculator itself. The values in the table are used only by the Riser Calculator to solve for the optimum riser configuration.

To customize riser diameter and pipe diameter tables

1 In the Riser Calculator dialog box, click Tables to display the Table Selection dialog box.
2 To customize the riser diameter table, click Riser Table.
   If you want to customize the pipe diameter table, click Pipe Table to display the Riser Diameters or the Riser Pipe Diameters dialog boxes.
3 You can delete or add a diameter:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>delete a diameter from the table</td>
<td>place your cursor in the row for the diameter you want to remove, and then click Delete.</td>
</tr>
<tr>
<td>add a diameter to the table</td>
<td>place your cursor in the row above which you want to insert a row, and then click Insert.</td>
</tr>
</tbody>
</table>

4 Click OK to return to the Riser Calculator dialog box.

Saving Riser Data from the Riser Calculator

In the Riser Calculator dialog box, you can click Save to save riser data into the c:\Land Projects R2\<project name>\hd folder as an .rsr file.

To save riser data from the riser calculator dialog box

1 In the Riser Calculator dialog box, click Save to display the Save Riser File dialog box.
2 In the File name box, type a name for the file and click Save. The data is saved with an .rsr file extension in the c:\Land Projects R2\<project name>\hd folder.
   The Riser Calculator dialog box displays.
3 Click OK to exit the dialog box.
Outputting Riser Data to a Text File
You can use the Output button in the Riser Calculator to output all of the data in the Riser Calculator to a text file. In addition, the calculated weir and orifice flow are shown in this file.

To output riser data to a text file
In the Riser Calculator dialog box, click Output. The riser data is displayed in a text editor.

Creating and Saving a Rating Curve of Riser Data
You can use the Rating button in the Riser Calculator to create and save a rating curve of the riser data. You can specify which part of the rating curve to create by specifying beginning and ending depths. The increment you specify determines how many points are created on the curve.

To create a rating curve of riser data
1 In the Riser Calculator, click Rating to display the Rating Table Setup dialog box.
2 In the Begin Depth box, type the depth at which to start the rating curve.
3 In the End Depth box, type the depth as which to end the rating curve.
4 In the Increment box, type the increment at which to create points on the curve.
5 To view the rating curve, click View to display the curve in the Rating Curve Display dialog box.
6 You can do any of the following from the Rating Curve Display dialog box:
   ■ Click Settings to change the appearance of the graph, such as the line colors.
   ■ Click Plot to plot the curve on a graph.
   ■ Click Output to output the data to a text editor or .wk1 file.
7 Click Close to return to the Rating Table Setup dialog box.
8 Click Save to display the Save Rating Curve dialog box.
9 Type a file name for the riser rating curve, and then click Save.
   The file is saved with an .rtc file extension in the c:\Land Projects R2\<project name>\hd folder.
10 Click Close to return to the Riser Calculator dialog box.

List of Files for Hydrology
There are a number of different Hydrology data files. Some are created when you save data from various dialog boxes; others are shipped with the program. In the following list, data types without filenames (extensions only) are files that you create and name from dialog boxes. Data types shown with filenames come with the program; the files are stored in c:\Land Projects R2\<project name>\hd folder.

NOTE Some data files are compiled and cannot be viewed or edited.
### Hydrology Data Types

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Filename/Extension</th>
<th>Editable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel Calculator Manning’s n</td>
<td>channel.cof</td>
<td>Y</td>
</tr>
<tr>
<td>Culvert data</td>
<td>.clt</td>
<td>N</td>
</tr>
<tr>
<td>Culvert Diameter data</td>
<td>pipe.cof</td>
<td>Y</td>
</tr>
<tr>
<td>Culvert Manning’s n</td>
<td>culvert.cof</td>
<td>Y</td>
</tr>
<tr>
<td>Database .wk1 file data</td>
<td>.wk1</td>
<td>Y</td>
</tr>
<tr>
<td>Hydrograph Curve data</td>
<td>.hdc</td>
<td>Y</td>
</tr>
<tr>
<td>Hydrology Tools settings</td>
<td>.pdt</td>
<td>N</td>
</tr>
<tr>
<td>Hydrology Pond templates</td>
<td>.htp</td>
<td>N</td>
</tr>
<tr>
<td>Intensity Duration Frequency data</td>
<td>.idf</td>
<td>Y</td>
</tr>
<tr>
<td>Pond Outflow Editor data</td>
<td>.pda</td>
<td>N</td>
</tr>
<tr>
<td>Pond Shapes</td>
<td>.psp</td>
<td>Y</td>
</tr>
<tr>
<td>Rainfall Frequency data</td>
<td>county.rf</td>
<td>Y</td>
</tr>
<tr>
<td>Rating Curve data</td>
<td>.rtc</td>
<td>Y</td>
</tr>
<tr>
<td>Rational data</td>
<td>.rat</td>
<td>N</td>
</tr>
<tr>
<td>Runoff Curve Number</td>
<td>runoff.cof</td>
<td>Y</td>
</tr>
<tr>
<td>Stage Discharge Curve data</td>
<td>.sdc</td>
<td>Y</td>
</tr>
<tr>
<td>Stage-Storage data</td>
<td>.ssc</td>
<td>Y</td>
</tr>
<tr>
<td>Storage Indication Method data</td>
<td>.sim</td>
<td>N</td>
</tr>
<tr>
<td>Tabular data (compiled)</td>
<td>.dab</td>
<td>N</td>
</tr>
<tr>
<td>Tabular data (uncompiled)</td>
<td>.tbl</td>
<td>N</td>
</tr>
<tr>
<td>Tc Sheet Flow Manning’s n</td>
<td>sheet.cof</td>
<td>Y</td>
</tr>
<tr>
<td>TR-55 Detention Basin Storage data</td>
<td>.bsn</td>
<td>N</td>
</tr>
<tr>
<td>TR-55 Graphical Peak Discharge</td>
<td>.gpd</td>
<td>N</td>
</tr>
<tr>
<td>TR-55 Tabular Hydrograph</td>
<td>.tab</td>
<td>N</td>
</tr>
<tr>
<td>Tt Channel Manning’s n</td>
<td>tcchan.cof</td>
<td>Y</td>
</tr>
</tbody>
</table>
Data File Format for Hydrology Files

All data files must have a specific format in order for Autodesk Civil Design to recognize them. If you are editing an existing data file, do not alter the format. The following are examples of several types of data files:

**Hydrograph Data File (.hdc) Format**

```
#Units=Time,hrs,Flowrate,cfs
#Hydrograph Data
#Time - hrs Flowrate - cfs
#------------ ------------
0.0,0.0
0.1,37.0
0.2,123.0
0.3,170.0
0.4,120.0
0.5,65.0
0.6,36.0
0.7,20.0
0.8,11.0
0.9,6
1.0,3.8
1.1,1.9
1.2,0.0
```

**Stage-Discharge Curve Data File (.sdc) Format**

```
#Units=Elevation,ft,Flowrate,cfs
#Stage-Discharge Curve Data
#Stage - ft Discharge - cfs
#------------ ------------
0.00000000, 0.00000000
0.90000000, 10.00000000
1.40000000, 20.00000000
1.80000000, 30.00000000
2.20000000, 40.00000000
2.50000000, 50.00000000
2.90000000, 60.00000000
3.20000000, 70.00000000
3.50000000, 80.00000000
3.70000000, 90.00000000
4.00000000, 100.00000000
4.50000000, 120.00000000
4.80000000, 130.00000000
5.00000000, 140.00000000
5.30000000, 150.00000000
5.50000000, 160.00000000
5.70000000, 170.00000000
6.00000000, 180.00000000
6.40000000, 200.00000000
6.80000000, 220.00000000
7.00000000, 230.00000000
7.40000000, 250.00000000
```

**Stage-Storage Curve Data File (.ssc) Format**

```
#Units=Elevation,ft,Volume,ft3
#Stage-Storage Curve Data
#Stage - ft Volume - ft3
#------------ ------------
200.00000000, 396818.94668779
198.00000000, 293190.61072878
196.00000000, 199795.66466650
194.00000000, 116181.59585057
192.00000000, 41895.59585057
190.75000000, 0.00000000
```
Changing the Hydrology Output Settings

Several dialog boxes control values and settings associated with hydrologic analysis. You can access these dialog boxes by using the Drawing Settings command from the Projects menu, or you can access each dialog box individually using the appropriate menu items on the Hydrology menu.

Besides changing the hydrology units, precision, and graph settings, you can specify which ASCII text editor to use for viewing and editing hydrology files. You can also return the hydrology settings to the default program settings.

When you define these settings before you start your work, the settings you select apply to all subsequent tasks. You can also save these settings to a project prototype for use within future projects.

Changing the Hydrology Units Settings

The hydrologic input data that you need for your projects is sometimes in imperial units. Converting imperial unit scientific data to metric can be a challenging task.

Autodesk Civil Design allows you to mix imperial and metric units for hydrology calculations according to the data you have at your disposal. You can set hydrology units so that the program performs the conversion for you. In the Unit Types dialog box, you can select the units of measure for hydrology data.

To change the hydrology units settings

1. From the Hydrology menu, choose Settings to display the Hydrology Tools Settings dialog box.
2. Click Units to display the Unit Types dialog box.
3. Select the units to use for each type of measurement from the lists. For more information, see “Hydrology Units Settings” in this chapter.

NOTE

You change settings for Angle, Area, Elevation, Flow rate, Head, Length, Rainfall, Structural Area, Structural Dimensions, Time, Velocity, Volume, and Intensity. Click OK to return to the Hydrology Tools Settings dialog box.
Hydrology Units Settings

You can set the units to use for the several types of measurements. The following table lists the measurements and units of measure available for each.

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Units (Available Options)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Angle</td>
<td>Degrees and radians</td>
</tr>
<tr>
<td>Area</td>
<td>Square miles, square inches, square feet, square meters, square centimeters, square millimeters, acres, and hectares</td>
</tr>
<tr>
<td>Elevation</td>
<td>Feet, inches, meters, centimeters, millimeters, miles, and kilometers</td>
</tr>
<tr>
<td>Flowrate</td>
<td>Cubic foot per second (cfs), US gallons per day (gpd-US), Imperial gallons per day (gpd-IP), cubic foot per day (cfd), US gallons per minute (gpm-US), Imperial gallons per minute (gpm-IP), acre foot per day (acft/d), cubic meter per second (cms), liters per second (lps), liters per minute (lpm), Million Gallons per Day (MGD-IP), Million Gallons per Day (MGD-US) and Cubic Meter per Minute (m³/min)</td>
</tr>
<tr>
<td>Head</td>
<td>Feet, inches, meters, centimeters, and millimeters</td>
</tr>
<tr>
<td>Intensity</td>
<td>Inches per hour, inches per minute, feet per minute, feet per hour, millimeters per minute, millimeters per hour, centimeters per minute, and centimeters per hour</td>
</tr>
<tr>
<td>Length</td>
<td>Feet, inches, meters, centimeters, millimeters, miles, and kilometers</td>
</tr>
<tr>
<td>Rainfall</td>
<td>Inches, feet, meters, centimeters, and millimeters</td>
</tr>
<tr>
<td>Structural Area</td>
<td>Square feet, square inches, square meters, square centimeters, square millimeters, acres, hectares, and square miles</td>
</tr>
<tr>
<td>Structural Dimensions</td>
<td>Inches, feet, meters, centimeters, and millimeters</td>
</tr>
<tr>
<td>Time</td>
<td>Hours, seconds, minutes, days, and years</td>
</tr>
<tr>
<td>Velocity</td>
<td>Feet per second, meters per second, miles per hour, kilometers per hour, and knots</td>
</tr>
<tr>
<td>Volume</td>
<td>Cubic feet (ft³), gallons (gal-US), gallons (gal-IP), cubic meter (m³), cubic yards (yd³), acre-feet (acft), hectare-meter (ha-m), and liters (l)</td>
</tr>
</tbody>
</table>
Changing the Hydrology Precision Settings

Use the precision settings to set the decimal precision for all Hydrology commands including area, pipe coefficients, and volume. The Precision Settings dialog box enables you to select the number of significant digits for each parameter. The default setting is four significant digits after the decimal point.

NOTE These settings are for display precision only. For calculations, Autodesk Civil Design uses the highest internal precision allowable.

To change the hydrology precision settings
1 From the Hydrology menu, choose Settings to display the Hydrology Tools Settings dialog box.
2 Click Precision to display the Precision Settings dialog box.
3 Enter a precision value in the text boxes, or use the slider bar to select a value.

NOTE The precision value must be between 0 (zero) and 8.

4 Click OK to return to the Hydrology Tools Settings dialog box.

Changing the Hydrology Graph Settings

Use the Graph Settings dialog box to change the graph settings for all Hydrographs created using Hydrology commands. You can change settings such as axis scales and line colors for a hydrograph.

NOTE This dialog box is also accessible from rating curve and hydrograph dialog boxes by clicking the Settings button.

To change the graph settings for a hydrograph
1 From the Hydrology menu, choose Settings to display the Hydrology Tools Settings dialog box.
2 Click Colors to display the Graph Settings dialog box.
3 Specify colors for the following objects that display in the graph or in the drawing window by typing a color number in the text box or by clicking the color tile and selecting a color:
   - Highlight: Highlights the routed curve in the hydrograph.
   - Arrow: Highlights the arrows that represent direction of water flow.
   - Temp Display: Presents a temporary display of the hydrograph.
   - Background: Inserts the selected color in the background of the hydrograph.
   - Plot Curve: Highlights the plotted curve in the hydrograph.
   - Plot Border: Highlights the color of the plotted border in the hydrograph.
   - Horiz Reference: Determines the horizontal axis line of the hydrograph.
   - Vert Reference: Determines the vertical axis line of the hydrograph.
   - 2nd Vert Reference: Determines the second vertical axis line.
   - Text: Displays text in the selected color on the hydrograph axis.
   - Grid: Displays the grid lines in the color you choose.
In the Scales section, specify the scale settings for the X and Y axis by doing one of the following:

- Select Automatic to display the X or Y axis at the best possible scale for the specified increments.
- Select Linear to display the X or Y axis with a linear scale.
- Select Log to display the X or Y axis with a logarithmic scale.

Click OK to return to the Hydrology Tools Settings dialog box.

**Changing the Hydrology Plotting Settings**

In the Graphing Utility dialog box, you can modify the settings for rating curves, hydraulic element curves, hydrographs, and plotted cross sections. The settings let you customize every aspect of the graph.

This is a versatile utility that can be used to plot any data file to a graph, as long as the file is an ASCII file with X and Y values. There is also an option to manually enter the X and Y values.

You can also export the X and Y values to either an ASCII file or into a WK1 format file.

**NOTE**
The Graphing Utility dialog box is also accessible from rating curve and hydrograph dialog boxes by clicking the Plot button. Some of the options in this dialog box are only accessible when the dialog box is accessed from a graph dialog box.

To change the plotting settings

1. From the Hydrology menu, choose Settings to display the Hydrology Tools Settings dialog box.
2. Do one of the following to display the Graphing Utility dialog box:
   - Click Plot.
   - From the Hydrology menu, choose Output ➤ Graphing Plot Utility.

**NOTE**
The Graphing Utility dialog box is also accessible from rating curve and hydrograph dialog boxes by clicking the Plot button.

**TIP**
You can load previously saved plotting settings by clicking Load. For more information, see "Loading Previously Saved Hydrology Plotting Settings" in this chapter.

3. Under Preferences, set preferences for the plot by clicking any of the following six buttons:
   - **Main**: Change the Main Title settings, including titles, layer, color, and text height.
   - **X-axis**: Change the X axis format settings, including decimal precision, titles, layer, color, height, and data limits.
   - **Y-axis**: Change the Y axis format settings, including decimal precision, titles, layer, color, height, and data limits.
   - **Border**: Turn borders on or off and change the layer color in which the borders are displayed.
- **Grid**: Enable or disable the X and Y axes for a hydrograph.
- **Ticks**: Change the increment value between tick marks on the graph, and place the tick marks on the inside and outside of the axis lines.

4. Under Graphic Dimensions, enter the horizontal and vertical dimensions for the final plotted graph. Enter the dimension directly, or click Select to select it from the current drawing.

5. Under Curve Information, enter the curve information for the plot.

   The Individual Curve Preferences determine how the curve is illustrated on the graph, the layer to use, the color of the curve, and any symbols to be inserted.

6. Save the settings for the current plot by clicking Save. For more information, see “Saving the Current Hydrology Plotting Settings to a File” in this chapter.

7. Click Preview to see a preview of the plot.

   **NOTE** This option is only available when you access the Graphing Utility dialog box from a graph (such as a rating curve or hydrograph) dialog box.

8. Press Esc to return to the Graphing Utility dialog box.

9. Click Plot to insert the plot into the current drawing.

10. Click OK to exit the Graphing Utility dialog box.

---

**Loading Previously Saved Hydrology Plotting Settings**

To load previously saved hydrology plotting settings

1. From the Hydrology menu, choose Settings to display the Hydrology Tools Settings dialog box.

2. Do one of the following to display the Graphing Utility dialog box:
   - Click Plot.
   - From the Hydrology menu, choose Output ➤ Graphing Plot Utility.

   **NOTE** The Graphing Utility dialog box is also accessible from rating curve and hydrograph dialog boxes by clicking the Plot button.

3. Click Load to display the Save Plot Data dialog box.

4. Click Yes or No:
   - Click Yes to save old plot data.
   - Click No to discard old plot data.

   The Input format dialog box is displayed.

5. Do one of the following to load data:
   - Click Text File to load an ASCII text file. A standard AutoCAD file load dialog box is displayed.
   - Click Graph File to load a plot data file. A standard AutoCAD file load dialog box is displayed.

6. Click OK to exit the dialog box.
Saving the Current Hydrology Plotting Settings to a File

You can save the current hydrology plotting settings to a file that you can load when you want to restore the settings.

To save the current hydrology plotting settings to a file

1. From the Hydrology menu, choose Settings to display the Hydrology Tools Settings dialog box.
2. Do one of the following to display the Graphing Utility dialog box:
   - Click Plot.
   - From the Hydrology menu, choose Output ➤ Graphing Plot Utility.

   **NOTE** The Graphing Utility dialog box is also accessible from rating curve and hydrograph dialog boxes by clicking the Plot button.

3. Click Save to display the Save Plot Data dialog box.
4. From the Save in list, select the file to which you want to save the hydrology settings.
5. Click Save.
   
   The command saves the current hydrology settings to the selected file.
6. Click OK to exit the Graphing Utility dialog box.

Specifying Which ASCII Text Editor to Use for Viewing and Editing the Hydrology Files

You can specify which ASCII text editor to use for viewing and editing Hydrology files.

To specify an ASCII text editor

1. From the Hydrology menu, choose Settings to display the Hydrology Tools Settings dialog box.
2. Click Editor to display the Editor Settings dialog box.
3. Click Browse to display the Select Text Editor dialog box.
4. Choose the text editor you want to use. For example, to choose the Windows Notepad editor, use the Look in list to open the Windows folder, then pick NOTEPAD.EXE from the list of files. For more information, see “Choosing an Editor” in this chapter.
5. Click Open to return to the Editor Settings dialog box.
6. Click OK to return to the Hydrology Tools Settings dialog box.
Choosing an Editor

To choose a text editor
1 In the Editor Settings dialog box, click Browse to display the Select Text Editor dialog box.
2 Choose the text editor you want to use. For example, to choose the Windows Notepad editor, use the Look in list to open the Windows folder, then pick NOTEPAD.EXE from the list of files.
3 Click Open to return to the Editor Settings dialog box.
4 Click OK to return to the previous dialog box.

Returning the Hydrology Settings to the Default Prototype Settings

You can reset the hydrology settings back to the settings that are in the project prototype by using the Reset option.

**NOTE**
If you do not want to permanently lose your current settings, save them before proceeding with the following steps.

To clear the current hydrology settings and return to the default settings
1 From the Hydrology menu, choose Settings to display the Hydrology Tools Settings dialog box.
2 Click Reset to display the Clear Hydro Data dialog box.
3 Click Yes to confirm that you want to clear the settings.
4 Click OK to exit the dialog box.

Calculating the Runoff from Watershed Areas

Runoff is the amount of water that flows out of a watershed subarea as a result of a storm event. This value is equal to the amount of rainfall that occurs on the area, minus the amount of rainfall that is infiltrated by the ground, is intercepted by foliage, or is held in small depressions.

Runoff is calculated by examining rainfall intensity, duration, and distribution; soil conditions; antecedent moisture conditions (how much moisture is already present in the soil before the storm occurs), and land use. Sometimes a runoff volume amount within a specified time period is adequate for design purposes, but most likely a peak flow rate and even a hydrograph are needed.

Autodesk Civil Design provides the following methods for calculating peak runoff flow rates from watershed areas:

- Rational
- TR-55 Graphical Peak Discharge
- TR-55 Tabular Hydrograph
- TR-20

The graphical peak discharge and tabular hydrograph methods are based on Technical Release 55 (TR-55), Urban Hydrology for Small Watersheds. TR-55 was
first published by SCS (now NRCS) in 1975, and updated to its current form in 1986. TR-55 presents methods to calculate storm runoff volumes, peak discharge rates, and pre- and post-developed hydrographs. The methods apply to small watersheds (around 2000 acres or less) in the United States. TR-55 was originally developed to be a by-hand method, but with the advent of personal computers, it has been computerized in many forms.

The TR-20 method uses the procedures described in the SCS National Engineering Handbook, Section 4, Hydrology (NEH-4).

Autodesk implements these easy-to-use methods in the drafting environment and lets you analyze the before and after site hydrology, as well as develop graphs of the output information.

NOTE
It is important you have some familiarity with the methods and terminology described above. If you need more information about Urban Hydrology for Small Watersheds, review the SCS Technical Release 55 document, which you can obtain from your local SCS (now NRCS) or county Soil & Water Conservation District office, most college libraries, or the National Technical Information Service in Washington, D.C. It is also available in downloadable PDF format from www.ncg.nrcs.usda.gov/tech_tools.html.

Selecting a Runoff Calculation Method to Use
Autodesk Civil Design provides four different runoff calculation methods you can use to calculate pre- and post-development runoff for a site. Often local ordinances will dictate which methods should be used for given conditions. Before calculating runoff you should check with your local city or county for their applicable requirements. For a general guide refer to the following table:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then use…</th>
</tr>
</thead>
<tbody>
<tr>
<td>size a storm pipe or culvert</td>
<td>the Rational Method or TR-55 Methods for larger drainage areas.</td>
</tr>
<tr>
<td>calculate runoff from multiple subareas</td>
<td>the TR-55 Tabular Method.</td>
</tr>
<tr>
<td>create a hydrograph for a storm event with a 24 hour duration</td>
<td>the TR-55 Tabular Method or the TR-20 Method.</td>
</tr>
<tr>
<td>create a hydrograph for a storm event of different length than 24 hours</td>
<td>the TR-20 Method.</td>
</tr>
<tr>
<td>calculate runoff volume for designing storage facilities using the storage indication method (reservoir routing)</td>
<td>a hydrograph method, like the Tabular method or the TR-20 method.</td>
</tr>
<tr>
<td>calculate runoff for volume got designing storage facilities using the detention storage method for detention pond design</td>
<td>TR-55 methods.</td>
</tr>
</tbody>
</table>
Selecting the Rainfall Frequency for a County

When you use the TR-55 Graphical, Tabular, or the TR-20 method of calculating runoff for a site, you are required to input a rainfall amount. The rainfall amount is based on a 24-hour storm and the frequency you want to design for. Rainfall frequencies can be entered for the county in which the site is located. Autodesk Civil Design provides a Rainfall Frequency Editor which you can use to enter and look up these frequencies.

The rainfall frequency data that Autodesk Civil Design uses is stored in the county.rf file. This file is stored in the c:\Program Files\Land Desktop R2\land\prot\hd folder. By default, a sample county.rf file for the state of Maryland is provided with Autodesk Civil Design.

To obtain data for your state, you can use a county.rf file provided by the local SCS (now NRCS) office. Or, you can obtain the written data, and then use the Rainfall Frequency Editor to input the data into Autodesk Civil Design for easy look-up and retrieval.

For more information about adding the rainfall frequency values for your state into the Rainfall Frequency Editor, see “Viewing, Editing, and Defining Rainfall Frequency Values for Counties” in this chapter.

To select the rainfall frequency for a county

1. From the Hydrology menu, choose Runoff ➤ Rainfall Frequency to display the Define Rainfall-Frequency dialog box.

![Define Rainfall-Frequency dialog box](image)

**NOTE**

The Define Rainfall Frequency dialog box is available from within the TR-55 Tabular Hydrograph Method dialog box and the TR-55 Graphical Peak Discharge Method so you can easily look up and enter the values. One of the options in the dialog box, Apply Rainfall, is only available when you access the Define Rainfall-Frequency dialog box from within the TR-55 Tabular Hydrograph dialog box.
2 Click Select to display the County Selection dialog box.

3 From the County Selection dialog box, select the county, and then click OK. As you return to the Define Rainfall-Frequency dialog box, the county you selected displays in the County box.

4 From the Rainfall Frequency list, select a rainfall frequency. For example, for a 10-year storm event, select 10 years.

When you select the rainfall frequency, the Rainfall label shows the amount of rainfall for a 24-hour event of the frequency type you selected. For example, if you selected 10 years in the Rainfall Frequency list, then the Rainfall labels displays the amount of rain you could expect for that location in 24 hours in a 10-year storm event.

If you arrived at this dialog box by clicking Rainfall on the TR-55 Tabular Hydrograph Method dialog box, then an Apply Rainfall list is available. You can use this list to apply the rainfall amount that is shown in the Rainfall label to the watershed(s) in the TR-55 Tabular Hydrograph Method dialog box.

5 From the Apply Rainfall list, select All to apply the rainfall amount to all watershed subareas, or select Single to apply the rainfall amount to the single subarea.

   NOTE When you click OK, the rainfall value is added to the 24-hrs Rainfall In. column in the TR-55 Tabular Hydrograph Method dialog box. If you specify Single, then the value is added to the column of the row in which your cursor was located when you selected the Rainfall button. If you specify All, then the value is added to all of the columns of data.

   NOTE To access the Rainfall-Frequency Editor dialog box to edit and define new values, click the Edit button.

6 Click OK.
Editing and Defining Rainfall Frequency Values for Counties

When you use the TR-55 Graphical and Tabular methods of calculating runoff for a site, you are required to input the rainfall frequency for the county in which the site is located. Autodesk Civil Design provides a Rainfall Frequency Editor which you can use to enter and look up these frequencies.

The rainfall frequency data that Autodesk Civil Design uses is stored in the county.rf file. This file is stored in the \Program Files\Land Desktop R2\LAND\prot\hd folder. By default, a sample county.rf file for the state of Maryland is provided with Autodesk Civil Design.

The storm frequency you are designing for and the location of the site determine the rainfall amount that you use to calculate runoff. Typically, the municipality in which you are working provides requirements that your design must meet. To obtain data for your state, you can use a county.rf file provided by the local SCS (now NRCS) office. Or, you can obtain the written data, and then enter the data into the Rainfall Frequency Editor by using the following steps.

To edit and define rainfall frequency values for counties:

1. From the Hydrology menu, choose Runoff ➤ Rainfall Frequency Editor to display the Rainfall-Frequency Editor dialog box. The dialog box contains rainfall depths by county for various storm frequencies. These depths are in inches, and are for 24-hour time frames.
2. Edit the values as needed, using the following guidelines:

   If you want to... Then...

   change a county name or existing frequency data double-click within the cell and type the new value.

   add rainfall data for a new county place your cursor in the row you want to insert the new row above, and click Insert.

   delete the record for a county place your cursor in the row you want to delete and click Delete.

   locate a value use the navigation buttons.

The following describes the navigation buttons available in the Rainfall-Frequency Editor dialog box:

^ and v: To move up or down one row at a time.

PgUp and PgDn: To move up or down one screen at a time.

Home and End: To move to the beginning or end of the list.

NOTE: When you click in a row in this editor, the row is not highlighted. The position of the blinking cursor indicates the selected row.

3. Click OK.
Selecting the Rainfall Frequency for a County

Use the Define Rainfall-Frequency dialog box to select the rainfall depth for a particular storm frequency in a selected county.

To select the rainfall frequency for a county

1. In the Define Rainfall-Frequency dialog box, click Select to display the County Selection dialog box.
2. Select the county, and then click OK.
   The Define Rainfall-Frequency dialog box is displayed, and the county that you selected displays in the County text box.
3. From the Rainfall Frequency list, select a rainfall frequency. For example, for a 10-year storm event, select 10 years.
   When you select the rainfall frequency, the Rainfall label shows the amount of rainfall for a 24-hour event of the frequency type you selected. For example, if you selected 10 years in the Rainfall Frequency list, then the Rainfall labels displays the amount of rain you could expect for that location in 24 hours in a 10-year storm event.
4. Use the Apply Rainfall list to apply the rainfall amount that is shown in the Rainfall label to the watershed(s) in the TR-55 Tabular Hydrograph Method dialog box. From the Apply Rainfall list, select All to apply the rainfall amount to all watershed subareas, or select Single to apply the rainfall amount to the single subarea.

   **NOTE** When you click OK, the rainfall value is added to the 24-hrs Rainfall In. column in the TR-55 Tabular Hydrograph Method dialog box. If you specify Single, then the value is added to the column of the row in which your cursor was located when you selected the Rainfall button. If you specify All, then the value is added to all of the columns of data.

   **NOTE** You can access the Rainfall-Frequency Editor dialog box to edit and define new values by clicking the Edit button.

5. Click OK to return to the TR-55 Tabular Hydrograph Method dialog box.

Customizing the Rainfall Distribution File

Autodesk Civil Design provides data files for the following rainfall distributions: Type I, IA, II, III, and IV. The Type II distribution is the most widely applicable. While other distribution tables are in use, most have been developed to more closely map the rainfall in a specific area. Although Autodesk Civil Design cannot support all these methods, you can either edit the existing file to include the data for your area, or replace the file.

If you decide to edit the file, please keep the following cautions in mind:

- If the file is edited, Autodesk Civil Design is not responsible for erroneous data that may be entered and subsequently used.
- The file must be in the same format as the existing data files that store the rainfall distribution information.
The file name must remain the same. The provided names (Type I, IA, II, III, and IV) must be used although they reference the new data you have provided.

The rainfall distribution data files are located in the c:\Program Files\Land Desktop R2\land\prot\hd folder. These text files have the distribution name and a .tbl extension (for example, typei.tbl). These files contain the rainfall information in a specific format.

To use your local rainfall distribution tables with Autodesk Civil Design, you can either edit the appropriate .tbl file or replace it with a file that contains revised data but has the same file name.

**NOTE**

If you already ran Autodesk Civil Design and selected a distribution type, a binary format file (for example, typei.dab) was created in the c:\Land Projects R2\<project name>\hd folder. You must delete the .dab file before you can use the new table file. A new file is created only if the .dab file does not exist.

The following is the first line from the typei.dab file:

```
1,12,10,32,3
```

where:

I: Indicates the table type
12: Indicates the number of Tt
10: Indicates the number of Tc
32: Indicates the number of columns
3: Indicates the number of Ia/p

The next two lines in the file contains the Tt and Tc values. For example:

```
0.0,.1,.2,.3,.4,.5,.75,1.0,1.5,2.0,2.5,3.0
0.0,.1,.2,.3,.4,.5,.75,1.0,1.25,1.5,2.0
```

The third line in the file lists the hydrograph times. For example:

```
9.0,9.3,9.6,9.9,10.0,10.1,10.2,10.3,10.4,10.5,10.6,10.7,10.8
```

The fourth line in the file lists the Ia/p values. For example:

```
0.10,0.30,0.50
```
The remainder of the file, shown below, contains the tabular hydrograph unit discharge data referred to as qt (for more information see page 5-2 of the TR-55 manual).

| 30, 40, 56, 183, 337, 504, 326, 155, 122, 107, 93, 81, 73, 66, 60, 56, 54, 52, 49 |
| 26, 35, 48, 93, 153, 276, 428, 360, 223, 156, 123, 103, 88, 72, 65, 59, 56, 54, 51 |
| 23, 30, 41, 60, 82, 129, 227, 361, 360, 269, 194, 147, 118, 85, 71, 63, 58, 55, 53 |
| 22, 29, 39, 56, 73, 111, 188, 303, 291, 293, 227, 173, 136, 94, 75, 65, 60, 56, 54 |
| 18, 25, 34, 46, 53, 66, 96, 157, 255, 312, 300, 251, 199, 126, 90, 73, 64, 59, 56 |
| 18, 24, 32, 44, 50, 61, 84, 139, 248, 280, 293, 265, 221, 144, 99, 77, 66, 60, 56 |
| 14, 19, 25, 34, 38, 43, 49, 62, 88, 134, 190, 234, 252, 221, 116, 87, 71, 63 |
| 11, 14, 19, 26, 28, 31, 34, 38, 44, 52, 68, 98, 141, 222, 238, 191, 139, 101, 79 |
| 9, 10, 13, 17, 18, 20, 22, 25, 27, 30, 34, 38, 44, 74, 132, 191, 211, 190, 151, 101 |
| 6, 7, 9, 11, 12, 13, 14, 15, 16, 18, 20, 22, 24, 29, 38, 58, 97, 148, 193, 193, 141 |
| 4, 5, 7, 8, 9, 9, 10, 11, 12, 13, 14, 16, 19, 23, 29, 39, 58, 93, 154, 181, 147, 87 |
| 2, 3, 5, 6, 7, 8, 9, 10, 10, 11, 13, 15, 19, 23, 28, 29, 39, 72, 124, 170, 138, 86 |
| 0, 0, 0, 61, 195, 343, 232, 129, 113, 103, 91, 81, 76, 71, 66, 64, 62, 61, 59, 56, 54 |
| 0, 0, 0, 12, 45, 145, 277, 247, 169, 131, 112, 98, 87, 76, 70, 65, 64, 62, 60, 57, 55 |
| 0, 0, 0, 9, 33, 107, 220, 238, 192, 151, 125, 107, 94, 79, 71, 66, 64, 62, 61, 58, 56 |
| 0, 0, 0, 1, 6, 24, 79, 173, 216, 200, 168, 139, 118, 90, 77, 70, 66, 64, 62, 59, 57, 54 |
| 0, 0, 0, 1, 4, 17, 59, 135, 189, 196, 177, 152, 129, 97, 81, 72, 67, 64, 63, 60, 57, 54 |

### Selecting and Editing the Runoff Curve Numbers for Different Soil Groups and Cover Types

Use the SCS Curve Number Editor to select and edit the runoff curve numbers (CN) for various cover descriptions and soil groups. The CN values in the SCS Curve Number Editor are obtained from the TR-55 manual. A curve number expresses how much water will run off an area, based on soil and land use conditions.

The TR-55 manual categorizes soils into four infiltration groups. Group A has the fastest infiltration rate, while group D has the slowest. The U.S. Soils Survey map of your site shows specific soil types with codes. Appendix A of the TR-55 manual shows the absorption group for each soil type on the US Soils Survey.

All the curve numbers for hydrologic soil groups A, B, C, and D are already input and stored in the runoff.cof file in the c:\Program Files\Land Desktop R2\land\prot\hd folder. You can use the SCS Curve Number Editor command or any text editor to edit this file.

**NOTE**

The Runoff Curve Number Editor is available directly from the Runoff menu (as described in step 1 below), or from the TR-55 Graphical Peak Discharge Method dialog box, the TR-55 Tabular Hydrograph Method dialog box, and the SCS TR-20 Unit Hydrograph Method dialog box.
To select and edit the runoff curve numbers for different soil groups and cover types

1 From the Hydrology menu, choose Runoff ➤ SCS Curve Number Editor to display the Runoff Curve Number Editor dialog box.

The dialog box lists curve numbers for surface cover and conditions for soils types A, B, C, and D. These curve numbers are also provided in the TR-55 manual, Table 2-2.

**NOTE** Do not edit the surface cover and conditions descriptions or the curve number values unless you use non-standard curve numbers for your project area.

2 You can select and edit the CN values by using the following guidelines:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>locate a CN value</td>
<td>use the navigation buttons. For more information, see “Hydrology-Navigation” in this chapter.</td>
</tr>
<tr>
<td>select a CN value</td>
<td>double-click in the cell and click OK.</td>
</tr>
<tr>
<td>insert a row of CN values for a cover type</td>
<td>place your cursor in the row you want to insert the row above, and click Insert.</td>
</tr>
<tr>
<td>delete a row of information</td>
<td>place your cursor in the row to delete and click Delete.</td>
</tr>
</tbody>
</table>

3 Click OK.
Selecting the Runoff Curve Numbers for Different Soil Groups and Cover Types

Use the SCS Curve Number Editor to select the runoff curve numbers for various cover descriptions and soil groups. All the curve numbers for hydrologic soil groups A, B, C, and D that are presented in the TR-55 manual, Table 2-2, are already available from this dialog box.

To select a runoff curve number
1. In the SCS Curve Number Editor, locate the CN value to use by using the navigation buttons.
2. Double-click in the cell that contains the CN value you want to use.
3. Click OK.

Calculating a Composite (or Weighted) Curve Number for More Than One Watershed or Subarea

If a sub-drainage area contains a variety of different soil and cover types, then you can use the Composite CN Editor to calculate a composite curve number for the entire site. The composite runoff curve number (RCN) is a weighted average of the various Curve Numbers within the drainage area.

For more information on computing weighted CNs and other curve number limitations, see the SCS TR-55 manual, Chapter 2, “Estimating Runoff.”
To calculate a composite (or weighted) curve number for a watershed or subarea

1. From the Hydrology menu, choose Runoff ➤ Composite CN Editor to display the Composite Runoff Curve Number Calculator dialog box.

2. In the Description column, type the descriptions for the subareas for which you are calculating the composite curve number, one subarea per row.

3. In the Area column, enter the area values for the watershed subareas.

   You can either type the area values into the column, or click Select to specify the areas by drawing or selecting closed polylines from the drawing. For example, if you used the Terrain Model Explorer to calculate the watershed values for a TIN surface, then closed polylines may already exist in the drawing that you can select.

4. In the Curve Number column, enter the curve numbers for the watershed subareas.

   You can either type the curve number values into the column, or click Select to display the Runoff Coefficients dialog box, where you can select the CN value to use for the cover and soil type. Double-click the CN value you want to use, and then click OK to return to the Composite Runoff Curve Number Calculator dialog box.

   As you enter the information for the subareas, the program calculates the total area of the watershed subareas and the weighted curve number, and displays this information at the bottom of the dialog box.
5 You can edit and view the data by using the following guidelines:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>output the composite CN</td>
<td>click Output.</td>
</tr>
<tr>
<td>to a text file</td>
<td></td>
</tr>
<tr>
<td>insert a new row of data</td>
<td>place your cursor in the row you want to</td>
</tr>
<tr>
<td>for a subarea</td>
<td>insert the row above, and click Insert.</td>
</tr>
<tr>
<td>delete a row of</td>
<td>place your cursor in the row you want to</td>
</tr>
<tr>
<td>information</td>
<td>delete and click Delete.</td>
</tr>
</tbody>
</table>

6 Click OK.

NOTE When the Composite curve number displays in the runoff calculator it is rounded off to the nearest whole number value. This as per instruction in the TR-55 Manual.

**Time of Concentration and Time of Travel**

Autodesk Civil Design has calculators you can use to calculate both time of concentration and time of travel. Autodesk Civil Design uses the methods outlined in the TR-55 manual for calculating the time of concentration and travel time and are discussed in detail in Chapter 3, “Time of Concentration and Travel Time,” in the TR-55 manual.

These values are used in the TR-55 and TR-20 runoff calculation methods.

Time of concentration (Tc) is the time for runoff to travel from the hydraulically most distant point of the watershed to a point of interest within the watershed. Time of concentration influences the configuration of the runoff hydrograph. Developing (urbanizing) a watershed usually decreases the Tc and increases the peak discharge rate. Tc is made of up to 3 flow segments: sheet, shallow, and channel flows.

Travel time (Tt) is the time it takes water to travel (already flowing in shallow or channel flow) from one watershed subarea through another subarea that is downstream. Tt can be made up of shallow flow and channel flow. Sheet flow is not used when calculating Tt because Tt represents the time it takes for water that is already flowing (from an upstream subarea) to arrive at the point of outflow of the current subarea. Travel time for a subarea needs to be computed if drainage from an upstream drainage area is passing through it.

Factors such as surface roughness, channel shape and flow patterns, and surface slope affect the time of concentration and travel time.
Calculating the Watershed Time of Concentration

The time of concentration is the time it takes for runoff to travel from the hydraulically most distant point of the watershed subarea to a specified outflow point.

Tc can be a combination of three types of flow: Sheet, Shallow Concentrated, and Open Channel. Each type uses different equations and requires different input. For more information, see “Specifying the Sheet Flow,” “Specifying the Shallow Flow,” and “Specifying the Channel Flow” in this chapter.

**NOTE**
The TR-55 time of concentration method has the following limitations:

- The sheet flow length should not exceed 300 feet.
- The minimum Tc is 0.1 hours.
- The maximum Tc is 2 hours for the Tabular Hydrograph Method and 10 hours for the Graphical Peak Discharge Method.

For more information about the Tc equations and other limitations of TR-55, see the SCS TR-55 manual, Chapter 3, “Time of Concentration and Travel Time.”

To calculate the watershed time of concentration

1. From the Hydrology menu, choose Runoff ➤ Time of Concentration (Tc) to display the Time of Concentration Calculator dialog box.

2. In the Description box, type a description for the time of concentration calculation.

3. In the Sheet box, enter the sheet flow. You can either enter this value directly, or click Select to display the Sheet Flow Time Calculator dialog box. For more information, see “Specifying the Sheet Flow” in this chapter.
4 In the Shallow box, enter the shallow flow. You can either enter this value directly, or click Select to display the Shallow Flow Time Calculator dialog box. For more information, see “Specifying the Shallow Flow” in this chapter.

5 In the Channel box, enter the channel flow. You can either enter this value directly, or click Select to display the Channel Flow Time Calculator dialog box. For more information, see “Specifying the Channel Flow” in this chapter.

**NOTE** Normally only one length for each flow type is used, but you can enter up to two lengths for each type in the Time of Concentration calculator. This allows for differences in various flow types, such as different slopes.

Autodesk Civil Design calculates the sum of the sheet, shallow, and channel flow times and displays it as the Total Tc at the bottom of the Time of Concentration Calculator dialog box.

6 Click Save to save the current values as the new defaults for the Time of Concentration Calculator. This stores the calculated data so that when you access the Time of Concentration Calculator from a runoff calculation dialog box, you can load the defaults you saved by clicking Default.

The Default button is available only when the Time of Concentration Calculator is activated from another calculator (in which case defaults are not automatically loaded).

7 You can also output or clear the information from the dialog box by using the following guidelines:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>output the total time of concentration to a text file</td>
<td>Output.</td>
</tr>
<tr>
<td>clear all the boxes in the dialog box</td>
<td>Clear.</td>
</tr>
</tbody>
</table>

8 Click OK.

**Specifying the Sheet Flow**

Sheet flow is water sheeting over a plane surface, such as an even amount of water flowing over a parking lot. It is the first component of Tc and starts at the hydraulically most distant watershed point. Sheet flow normally occurs at a depth of 0.1 ft. or less, and the length of sheet flow rarely exceeds a few hundred feet. The maximum length of sheet flow is 300 ft.

To calculate sheet flow, you need the following information: a two-year rainfall amount; length of flow; average slope along flow path; and ground roughness over which the water is sheeting (measured in Manning's n factor).

The Sheet Flow Time Calculator dialog box is available from the following dialog boxes:

- Time of Concentration Calculator
- Time of Travel Calculator
To specify the sheet flow

1. In the Sheet Flow Time Calculator dialog box, type a description for the sheet flow segment in the Description box.

   ![Sheet Flow Time Calculator](image)

2. In the Manning’s n box, type the Manning’s n roughness coefficient for the sheet flow surface.

   You can also click Select to display the Sheet Flow – Manning’s n dialog box and select a coefficient from a list of typical sheet flow roughness values.

   **NOTE** These sheet flow Manning’s n values are significantly higher than typical channel roughness values. These n values are for very shallow depths of about 0.1 foot. The Sheet Flow – Manning’s n dialog box contains the setting values from SCS TR-55 manual, Table 3-1. These values are stored in the `c:\Program Files\Land Desktop R2\land\prot\hdsheet.cof` folder.

3. In the Flow Length box, type either the sheet flow length, or click Select to specify the length by selecting an object or points in the drawing.

4. In the Two-yr 24-hr Rainfall box, type the two-year, 24-hour rainfall depth. You can also click Select to select the rainfall depth from the Define Rainfall-Frequency dialog box.

   **NOTE** The two-year rainfall depth is always used, regardless of the storm frequency being analyzed.

5. In the Land Slope box, type the slope of the sheet flow segment. You can also click Select to calculate the slope by selecting contour lines in the drawing.

   When you specify all four values in the dialog box, the sheet flow time is displayed in the Sheet Flow Time field. When you click OK to return to the Time of Concentration calculator, this value is inserted into the Sheet box.

   **TIP** To display the sheet flow data in a text editor, click Output. From here, you can print the data to a file or printer.

6. Click OK.
Specifying the Shallow Flow

Shallow flow is water flowing in natural drainage depressions and swales, and usually begins after a maximum of 300 feet of sheet flow. The average velocity of shallow concentrated flow is determined by watershed slope and channel material (paved or unpaved). Typical areas where you have shallow flow are in swales between houses and the gutter section of a roadway.

To calculate shallow flow, you need the following information: flow length; average slope; and a determination of whether the surface is paved or unpaved. The Shallow Flow Time Calculator dialog box is available from the following dialog boxes:

- Time of Concentration Calculator
- Time of Travel Calculator

To specify the shallow flow

1. In the Shallow Flow Time Calculator dialog box, type a description for the shallow concentrated flow segment in the Description box.

2. Under Surface, select the appropriate surface condition: Paved or Unpaved.

3. In the Flow Length box, type the flow length of the shallow watercourse in feet. You can also click Select to specify the length by selecting either an object or points in the drawing.

4. In the Watercourse Slope box, type the slope of the shallow concentrated watercourse. You can also click Select to specify the slope by selecting contours on the drawing.

When you specify all three values in the dialog box, the following calculations are displayed:

- **Average Velocity**: The calculated average velocity of the shallow concentrated flow.
- **Shallow Flow Time**: The calculated shallow concentrated flow time. When you click OK to return to the Time of Concentration calculator, this value is inserted into the Shallow box.
To display the shallow flow data in a text editor, click Output. From here, you can print the data to a file or printer.

Click OK.

Specifying the Channel Flow

The open channel flow is water flowing in constructed channels. Open channels are assumed to begin where surveyed cross section information has been obtained, where channels are visible on aerial photographs, or where streams display on USGS quad sheets.

Manning’s equation or water surface profile information can be used to estimate average flow velocity. Average flow velocity is usually determined for bank-full elevation.

To calculate channel flow, you need the following information: geometry of the channel, Manning’s n for the channel, and average slope. The Channel Flow Time Calculator dialog box is available from the following dialog boxes:

- Time of Concentration Calculator
- Time of Travel Calculator

To specify the channel flow

1. In the Channel Flow Time Calculator dialog box, type a description for the channel flow segment in the Description box.

2. In the Cross Section Area box, type the channel cross sectional area for bank-full conditions (when the channel is filled to the bank).

3. In the Wetted Perimeter box, type the wetted perimeter of the channel. In cross section view, a channel has an approximate U-shape. The wetted perimeter is the length of this “U.”
4 In the Channel Slope box, type the slope of the channel. You can also click Select to calculate the slope by selecting contours on the drawing or by typing D for DTM and have the elevation interpolated from a DTM surface.

**NOTE** If you don’t know the wetted perimeter value or the channel slope value, but you do know other channel values, then you can click Channel to display the Advanced Channel Calculator dialog box. You can use this calculator to calculate channel parameters for this flow segment, and then you can type these values into the Channel Flow Time Calculator dialog box.

5 In the Manning’s n box, type the Manning’s n roughness coefficient for the channel. You can also click Select and select a value from the Channel Flow - Manning’s n dialog box.

6 In the Flow Length box, type the channel flow length. You can also click Select to specify the length by selecting either an object or points in the drawing. When you specify all five values in the dialog box, the following calculations are displayed:

- **Hydraulic Radius**: The calculated hydraulic radius of the channel.
- **Velocity**: The computed velocity of the channel.
- **Channel Flow Time**: The computed channel flow time. When you click OK to return to the Time of Concentration calculator, this value is inserted into the Channel box.

**TIP** To display the channel flow data in a text editor, click Output. From here, you can print the data to a file or printer.

7 Click OK.

### Calculating the Watershed Time of Travel

Travel time (Tt) is the time it takes runoff to travel (already flowing in shallow or channel flow) from one watershed subarea through another subarea as the runoff flows toward the composite watershed outflow point.

Tt can be a combination of two types of flow: Shallow Concentrated and Channel. Both flow types use different equations and require different values. For most cases, the travel time is composed of only channel flow segments with no shallow concentrated flow segments. For more information, see “Specifying the Shallow Flow” and “Specifying the Channel Flow” in this chapter.

The TR-55 travel time method has the following limitations:

- The maximum Tt allowed in the Tabular Hydrograph method is 3 hrs.
- A watershed with only one subarea does not have a Tt. Travel Time is computed only if the runoff from an upstream subarea passes through a subarea before it reaches the composite watershed outflow point.
- It is sometimes difficult to determine exactly where shallow concentrated flow ends and channel flow begins. Use your best judgment and/or consult your local Soil Conservation Services office.
For more information on the Tt equations and other limitations of TR-55, see the SCS TR-55 manual, Chapter 3, “Time of Concentration and Travel Time.”

To calculate the watershed time of travel

1. From the Hydrology menu, choose Runoff ➤ Time of Travel (Tt) to display the Time of Travel Calculator dialog box.

2. In the Description box, type a description for this segment. Select a description field and enter the description.

3. In the Shallow box, type the shallow flow time. You can enter this value directly, or click Select to calculate the shallow flow time from the Shallow Flow Time Calculator dialog box.

4. In the Channel box, type the channel flow time. You can enter this value directly, or click Select to calculate the channel flow time from the Channel Flow Time Calculator dialog box.

   Autodesk Civil Design calculates the sum of the shallow and channel travel time segments and displays this value as the Total Tt.

5. Click Save to save the current values as the new defaults for the Time of Travel Calculator. This stores the calculated data so that when you access the Time of Travel Calculator from the TR-55 Tabular Hydrograph Method dialog box, you can load the defaults you saved by clicking Default.

   The Default button is available only when the Time of Travel Calculator is activated from another calculator (in which case defaults are not automatically loaded).

6. You can also output or clear the information from the dialog box by using the following guidelines:

   **If you want to…**  
   **Then click…**

   | Output the total time of concentration to a text file | Output. |
   | Clear all the boxes in the dialog box | Clear. |

7. Click OK.
Calculating the Peak Runoff Flow for an Area Using the Rational Method

The Rational formula for runoff calculation is widely used to analyze smaller drainage areas to determine flows for pipe, inlet, and culvert sizing. The rational method determines peak runoff to a point. This is the easiest of all hydrologic analysis methods, but is considered the least accurate. For more information on the Rational formula, see “Rational Method Formula” in this chapter.

The Rational Method calculator simplifies the process of calculating runoff by interpolating rainfall intensities and doing the calculations for you. You enter the required data (runoff coefficient, frequency factor, adjustment factor, area, and time of concentration), and the calculator determines the peak flow value.

Data required when using the Rational formula includes the following:

- **Runoff Coefficient (C):** Factor that represents the land use. Values typically range from 0.10 to 0.95. Where 0.10 would be a wooded area and 0.95 would be a paved parking area.

- **Drainage area (A):** Area that is contributing to the point of concern measured in acres. The Rational calculator respects the current hydrology units settings. For example, if the current area units are set to Sq. Miles, then the calculator converts the area to acres to perform the calculations.

- **Rainfall Intensity (I):** Rainfall Intensity used for calculating the peak runoff. This value is based on the time of concentration and the rainfall frequency that you want to design for. When calculating flows using this method manually, you would refer to an IDF (intensity duration frequency) curve to determine the rainfall intensity, given the time of concentration and the design storm frequency. Using Autodesk Civil Design, the IDF curve can be entered online and values can be interpolated from it automatically.

The Rational Method uses an .idf file to store values of the intensity-duration frequency factors. Several sample .idf files are included with Autodesk Civil Design that you can load to examine how the Rational Method calculator works. You can obtain an .idf file for your local region from the local NRCS office.
To calculate the peak runoff flow for a watershed subarea using the rational method

1 From the Hydrology menu, choose Runoff ➤ Rational Method to display the Rational Method dialog box.

You can also click Load at the bottom of the dialog box and select a rational file that you have previously saved.

2 In the Description box, type a general description for the area.

3 Select the Rainfall Frequency. The Rainfall Frequency values are obtained from an intensity-duration frequency file (.idf file). Autodesk Civil Design does not automatically load an .idf file, however sample files are provided that you can load. You can obtain an .idf file from your local NRCS office and use the following steps to load it into the Rational Method dialog box.

In this calculator, each row represents a different drainage area. Peak flows are listed separately for each drainage area.

4 From the lower part of the dialog box, click the IDF button to display the Intensity-Duration Frequency Editor dialog box.

5 Click the Load button to display the Intensity-Duration File Selection dialog box. The Files of Type list displays *.idf as the file type.

6 Use the navigation tools to open the c:\Program Files\Land Desktop R2\Data\hd folder.

7 Select a sample .idf file, or select a file you have supplied for your local region, and click Open. The Intensity-Duration Frequency Editor dialog box is re-displayed, and now contains the intensity and duration values from the sample file.

There are a variety of viewing and editing tools you can use to examine and adjust the intensity-duration values.
If you want to... Then...

view and plot the idf curve click View.

insert a row of idf values place your cursor in the row above which you want to insert a row, and click Insert Row.

delete a row of idf values place your cursor in the row to delete and click Delete Row.

define a new frequency curve click Insert Frequency, then type the frequency; follow by defining the intensity-duration values.

For more information, see “Specifying the Rainfall Intensity” in this chapter.

8 Click OK to return to the Rational Method dialog box. Frequencies now display in the Rainfall Frequency list.

9 Select the appropriate rainfall frequency.

10 In the Area Description column, enter a short description of the area.

11 In the Drainage Area column, enter the drainage area value. You can also click Area at the bottom of the dialog box to calculate the drainage area by drawing or selecting a closed polyline in the drawing.

12 In the Coef. column, enter the runoff coefficient that represents the ratio of runoff to rainfall.

You can also click Coef at the bottom of the dialog box to select a value. After you click Coef, you can choose either Land Uses or Soil Types from which to select the runoff coefficient. After you select Land Uses or Soil Types, a dialog box is displayed from which you can select a value. To select a value, pick the field that contains the value you want, then click OK. The Rational Method dialog box is displayed, and the value is entered in the Coef. field.

**NOTE** If the watershed area has multiple land uses or soil types, then click CmpCoef to define a composite coefficient number. For more information, see “Specifying a Composite Runoff Coefficient” in this chapter.

Next, add an adjustment factor to the equation, if required. The adjustment factor is used to calculate peak flow from major storms.

**NOTE** The adjustment factor is not used in all areas. If you are not using this factor, then leave this field blank.

13 Click Factor at the bottom of the dialog box to display the Frequency Factor Editor dialog box.

14 Select the Use Frequency Factor check box to apply the frequency factor to the rational equation.

15 Enter the applicable adjustment factors into the Frequency (Years) column and the Factor column.

16 Click OK to return to the Rational Method dialog box. An adjustment factor is placed in the Adjustment Factor column. AutoCAD automatically calculates the correct adjustment factor based on the Rainfall Frequency you selected and the frequency factors you entered in the Frequency Factor Editor dialog box.
17 In the Time of Concentration column, enter a Tc. You can also click Tc at the bottom of the dialog box to calculate the area’s Tc.

**NOTE** If you enter a value in this field, the Rainfall Intensity value is reported from the IDF file. Enter zero (0) if you want to enter a value manually in the Rainfall Intensity field.

18 In the Rainfall Intensity column, enter the average rainfall rate.

If you loaded an intensity duration frequency file, and entered a time of concentration in the previous step, then this value is calculated automatically for you. For more information, see “Specifying the Rainfall Intensity” in this chapter.

After you have entered all of the required data for the rational equation, the Rational Method calculator displays the computed runoff flowrate for the area in the Flowrate column.

19 Click Save to save the information.

20 Click OK.

**Rational Method Formula**

The following formula is used to determine the peak discharge when you work with the Rational Method:

\[ Q = CC_f IA \]

where:

Q = Peak discharge (cfs)
C = Runoff coefficient, a ratio of runoff to rainfall
\( C_f \) = Frequency factor for use with major storms
I = Average rainfall intensity for a duration equal to the time of concentration, for a selected return period (in./hr)
A = Watershed drainage area (ac)
Specifying the Rainfall Intensity

**NOTE** If you have already defined Rainfall Frequencies, click Load and pick the file that contains this information.

To define rainfall intensity-duration information

1. From the Rational Method dialog box, click IDF to display the Intensity Frequency Factor Editor dialog box.

2. Click Insert Frequency to display the Add Frequency Curve dialog box.

3. In the Frequency box, type a frequency for which you will define various rainfall durations and corresponding intensities. For example, enter 10 to define the rainfall intensity duration information for a 10-year storm.

**NOTE** Just type the number; do not type "years" after typing the number.

4. Click OK to return to the Intensity Frequency Factor Editor.

5. Repeat steps 1 through 3 until you have added all the rainfall frequencies you want to define.

6. From the Intensity Frequency Factor Editor dialog box, pick a rainfall frequency from the Rainfall Frequency list.

7. In a Duration box, type the duration value for the rainfall frequency you selected. In the Duration column, pick a text box and enter a value (such as 0.5 for 30 minutes). You can define as many durations for the selected Rainfall Frequency as you need.
NOTE
When you are setting up the durations, enter the time in hours if your time units are set to hours. If time units are set to minutes then you can enter the time in minutes.

8 In an Intensity box, type the intensity value for the rainfall frequency you selected. In the Intensity column, pick a text box and enter a value (such as 2 for 2 inches/hour). You can define as many intensities for the selected Rainfall Frequency as you need.

9 Repeat steps 7 and 8 until you have entered duration and intensity data for all your Rainfall Frequencies.

10 Click Save to save your information and click OK to return to the Rational Method dialog box.

Other file options available from this dialog box include:
- **Insert Row**: Inserts a new row above the selected row.
- **Delete Row**: Deletes the selected row.
- **Delete Frequency**: Deletes a rainfall frequency value.
- **Load**: Opens an existing intensity-duration file. A standard AutoCAD file open dialog box is displayed.
- **New**: Clears the data from the dialog box.
- **View**: Display a rainfall intensity versus duration curve. Outputs the data to an ASCII .txt or .wk1 file, or plots the curve on a graph. For more information, see “Displaying a Graph of the Intensity-Duration Frequency Data” in this chapter.

### Displaying a Graph of the Intensity-Duration Frequency Data

The Intensity-Duration Frequency Curve graph displays the rainfall intensity versus duration curve for a particular rainfall frequency.

To display a graph of rainfall intensity versus duration

1 From the Intensity Frequency Factor Editor dialog box, select the rainfall frequency for which you want to plot a graph.
2 From the Rainfall Frequency list, select the rainfall frequency.
3 Click View to display the Intensity-Duration Frequency Curve dialog box which shows the rainfall intensity versus duration curve for the rainfall frequency you selected.
4 Click Plot to plot the curve on a graph, or click Output to output the data to an ASCII .txt or .wk1 file.
5 Click Settings to change the appearance of the graph, such as the line colors.
6 Click Close to return to the Intensity-Duration Frequency Editor.
7 Click OK twice to exit the dialog boxes.
Changing the Hydrology Plotting Settings

You can use the Hydrology Plotting Settings to customize every aspect of a hydrograph. You can also load, save, preview, and plot the current graph in the drawing.

**NOTE**

This dialog box is used for establishing settings before plotting and for changing settings while plotting, depending on what command you use to access it. Certain options are not available on this dialog box when you access it from the Hydrology Tools Settings dialog box.

To change the hydrology plotting settings

1. From the Hydrology menu, choose Settings, and then click the Plot button to display the Hydrology Plotting Settings dialog box.

   ![Graphing Utility Dialog Box]

   You can also access the Hydrology Plotting Settings dialog box by clicking Drawing Settings on the Projects menu. Select Civil Design from the Program list, select Hydro Graphs, and then click the Edit Settings button. This dialog box is also available when you click Plot from the hydrograph you are currently viewing.

2. Set preferences for the plot by doing any of the following:
   - Click Main to change the Main Title settings, including titles, layer, color, and text height. For more information, see “Changing the Main Title Settings” in this chapter.
   - Click X-Axis to change the X-axis format settings, including decimal precision, titles, layer, color, height, and data limits. For more information, see “Changing the X-Axis Settings” in this chapter.
   - Click Y-Axis to change the Y-axis format settings, including decimal precision, titles, layer, color, height, and data limits. For more information, see “Changing the Y-Axis Settings” in this chapter.
- Click Border to turn borders on or off and change the layer color you want the borders displayed in. For more information, see “Changing the Border Settings” in this chapter.
- Click Grid to enable or disable the X and Y axes for a hydrograph. For more information, see “Changing the Grid Settings” in this chapter.
- Click Ticks to change the increment value between tick marks on the graph. Also place the tick marks on the inside and outside of the axis lines. For more information, see “Changing the Grid Tick Settings” in this chapter.

3 Under Graphic Dimensions, enter the horizontal and vertical dimensions for the plot. Enter the dimension directly, or click Select to select it from the current drawing.

4 Using the Curve Information settings, enter the curve information for the plot. The Individual Curve Preferences determine how the curve will be illustrated on the graph, the layer to use, and the color of the curve. For more information, see “Changing the Individual Curve Preferences” in this chapter.

5 You can also load, save, plot, and preview the settings by using the following guidelines:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>load a previously saved plot settings file</td>
<td>Load.</td>
</tr>
<tr>
<td>save the settings so you can restore them in the future</td>
<td>Save.</td>
</tr>
<tr>
<td>clear the current settings so you can enter new settings</td>
<td>New.</td>
</tr>
<tr>
<td>preview how the graph will display when plotted</td>
<td>Preview.</td>
</tr>
<tr>
<td>insert the current hydrograph into the drawing</td>
<td>Plot.</td>
</tr>
</tbody>
</table>

**NOTE** The Preview option is only available when accessing the dialog box from a graph.

6 Click OK.

**Changing the Main Title Settings**

You can change the Main Title settings for a hydrograph, including titles, layer, color, and text height.

**To change the main title settings for a hydrograph**

1 Click the Plot button from the hydrograph you are currently viewing to display the Plot Settings dialog box.

**NOTE** You can view a hydrograph when you are using several different commands. For example, if you select Hydrology ➤ Runoff ➤ Rational, and then click the IDF button and the the View button to display a hydrograph.
2 Click Main to display the Main Title Settings dialog box.

![Main Title Settings dialog box](image)

3 Change the main title settings, as necessary, according to the following guidelines:

- **Title 1 and Title 2**: Enter the desired Title 1 and Title 2 settings. Title 1 is plotted on the first line; Title 2 is plotted underneath as the second text line.
- **Layer**: Type the name of the layer on which you want to insert the main title.
- **Color**: Type the number of the layer color that you want for the main title text, or pick the colored box and select the color from the standard AutoCAD Select Color dialog box.
- **Percent**: Define the text size as a percentage of the horizontal plot scale.
- **Height**: Define the text size as a fixed value. In the Height text box, type the desired text size, or click Select to define the height by graphically selecting points in the drawing.

4 Click OK.

**Changing the X-Axis Settings**

You can change the X-axis format settings, including decimal precision, titles, layer, color, height, and data limits for a hydrograph.

**To change the X-axis settings**

1 Click the Plot button from the hydrograph you are currently viewing to display the Plot Settings dialog box.

**NOTE** You can view a hydrograph when you are using several different commands. For example, if you select Hydrology ➤ Runoff ➤ Rational, and then click the IDF button, and then the View button, a hydrograph is displayed.
2 From the Plot Settings dialog box, click X Axis to display the X Axis Format Settings dialog box.

![X Axis Format Settings dialog box](image)

3 You can change the Label Preferences by specifying the following settings:

- **Format**: Select a format for the numbers on the graph. The available options are: Fixed - limits the number of decimal places; the default setting; Scientific - translates numbers into scientific notation; Currency - displays numbers as currency; Percent - displays numbers as percentages; Comma - displays the numbers with comma separation; and General - displays the numbers to the calculated accuracy.

- **Precision**: Enter the number of digits that you want to the right of the decimal point.

- **Title 1 and Title 2**: Enter the text for Title 1 and Title 2.

- **Units**: Open the Unit Selection dialog box, and then select the type of units from the Unit Types list. The available options are: Structural Dimensions, Angle, Area, Elevation, Flowrate, Intensity, Length, Rainfall, Structural Area, and Time. You can also select the unit or measurement from the Selection list. The options available vary depending on the Units Type that you select.

- **Layer**: Enter the name of the layer on which you want to place the text.

- **Color**: Enter the number of the layer color that you want the titles displayed in, or pick the colored box and select the color from the standard Select Color dialog box.

- **Percent**: Define the text size as a percentage of the horizontal plot scale.

- **Height**: Define the text size as a fixed value. Enter the text size in the Height text box, or click Select to define the height by graphically selecting points on the drawing.
4 You can change the Limits settings by specifying the following settings:
   - **Automatic**: Automatically sets the minimum and maximum data range to the actual limits of the data.
   - **Manual**: Manually sets the limits of the data range to the values that you enter in the Minimum and Maximum text boxes.
   - **Minimum**: Enter the lower limit of the data range to be plotted on the graph.
   - **Maximum**: Enter the upper limit of the data range to be plotted on the graph.
   - **Reset Limits**: Reset the limits to the program settings.
   - **Increments Number**: Enter the number of tick divisions between the labels on the X axis.

5 Click OK.

**Changing the Y-Axis Settings**

You can change the Y-axis format settings, including decimal precision, titles, layer, color, height, and data limits, for a hydrograph.

**To change the Y-axis settings**

1 Click the Plot button from the hydrograph you are currently viewing to display the Plot Settings dialog box.

**NOTE** You can view a hydrograph when you are using several different commands. For example, if you select Hydrology ➤ Runoff ➤ Rational, and then click the IDF button and the View button, a hydrograph is displayed.
2 From the Plot Settings dialog box, click Y Axis to display the Y Axis Format Settings dialog box.

![Y Axis Format Settings dialog box]

3 You can change the Label Preferences by specifying the following settings:

- **Format**: Select a format for the numbers on the graph. The available options are: Fixed - limits the number of decimal places; the default setting; Scientific - translates numbers into scientific notation; Currency - displays numbers as currency; Percent - displays numbers as percentages; Comma - displays the numbers with comma separation; and General - displays the numbers to the calculated accuracy.

- **Precision**: Enter the number of digits that you want to the right of the decimal point.

- **Title 1 and Title 2**: Enter the text for Title 1 and Title 2.

- **Units**: Open the Unit Selection dialog box, and then select the type of units from the Unit Types list. The available options are: Structural Dimensions, Angle, Area, Elevation, Flowrate, Intensity, Length, Rainfall, Structural Area, and Time. You can also select the unit or measurement from the Selection list. The options available vary depending on the Units Type that you select.

- **Layer**: Enter the name of the layer on which you want to place the text.

- **Color**: Enter the number of the layer color that you want the titles displayed in, or pick the colored box and select the color from the standard Select Color dialog box.

- **Percent**: Define the text size as a percentage of the horizontal plot scale.

- **Height**: Define the text size as a fixed value. Enter the text size in the Height text box, or click Select to define the height by graphically selecting points on the drawing.
4 You can change the Limits settings by specifying the following settings:
   - **Automatic**: Automatically sets the minimum and maximum data range to the actual limits of the data.
   - **Manual**: Manually sets the limits of the data range to the values that you enter in the Minimum and Maximum text boxes.
   - **Minimum**: Enter the lower limit of the data range to be plotted on the graph.
   - **Maximum**: Enter the upper limit of the data range to be plotted on the graph.
   - **Reset Limits**: Resets the limits to the program settings.
   - **Increments Number**: Enter the number of tick divisions between the labels on the Y axis.

5 Click OK.

**Changing the Border Settings**

You can change the graph borders for a hydrograph, including turning borders on and off, and changing the layer color you want the borders displayed in.

**To change the border settings for a hydrograph**

1 Click the Plot button from the hydrograph you are currently viewing to display the Plot Settings dialog box.

   **NOTE** You can view a hydrograph when you are using several different commands. For example, if you select Hydrology ➤ Runoff ➤ Rational, and then click the IDF button and the View button, a hydrograph is displayed.

2 From the Plot Settings dialog box, click Border to display the Border Settings dialog box.

   ![](Border_Settings.png)

3 Change the border settings by specifying the following settings:
   - **Left**: Turns the left border on and off.
   - **Right**: Turns the right border on and off.
   - **Top**: Turns the top border on and off.
   - **Bottom**: Turns the bottom border on and off.
**Time of Concentration and Time of Travel**

- **Layer**: Enter the name of the layer on which you want to place the borders.
- **Color**: Enter the number of the layer color in which you want the borders displayed, or pick the colored box and select the color from the standard Select Color dialog box.

4. Click OK.

**Changing the Grid Settings**

To change the grid settings for a hydrograph

1. Click the Plot button from the hydrograph you are currently viewing to display the Plot Settings dialog box.

   **NOTE** You can view a hydrograph when you are using several different commands. For example, if you select Hydrology ➤ Runoff ➤ Rational, and then click the IDF button and the View button, then a hydrograph is displayed.

2. From the Plot Settings dialog box, click Grid to display the Grid Settings dialog box.

3. You can change the grid settings by specifying the following settings:
   - **Both**: Displays the grid for both axes in your graph.
   - **X Axis Only**: Displays only the X axis grid.
   - **Y Axis Only**: Displays only the Y axis grid.
   - **None**: Eliminates both the X and Y axes grids.
   - **X Axis**: Adds intermediate grid marks to the X axis.
   - **Y Axis**: Adds intermediate grid marks to the Y axis.
   - **Layer**: Enter the name of the layer on which you want to place the grid.
   - **Color**: Enter the number of the layer color that you want the grid displayed in, or pick the colored box and select the color from the standard Select Color dialog box.

4. Click OK.
Changing the Grid Tick Settings

You can change the increment value between tick marks on a hydrograph. You can also place the tick marks on the inside and outside of the axis lines of a hydrograph.

To change the tick settings for a hydrograph

1. Click the Plot button from the hydrograph you are currently viewing to display the Plot Settings dialog box.

   **NOTE**
   You can view a hydrograph when you are using several different commands. For example, if you select Hydrology ➤ Runoff ➤ Rational, and then click the IDF button and the View button, a hydrograph is displayed.

2. From the Plot Settings dialog box, click the Ticks button to display the Tick Settings dialog box.

   ![Tick Settings Dialog Box]

   You can change the tick settings by specifying the following settings:
   - **Inside**: Places tick marks inside the X and Y axis lines.
   - **Outside**: Places tick marks outside the X and Y axis lines.
   - **Both**: Places tick marks on both the inside and outside of the X and Y axis lines.
   - **None**: Removes all tick marks from the graph.
   - **X Axis**: Adds intermediate ticks to the X axis.
   - **Y Axis**: Adds intermediate ticks to the Y axis.
   - **Layer**: Enter the name of the layer on which you want to place the tick marks.
   - **Color**: Enter the number of the layer color that you want the tick marks displayed in, or pick the colored box and select the color from the standard Select Color dialog box.

3. You can change the tick settings by specifying the following settings:
**NOTE** If you have not specified a layer name in the Layer text box, and select Main Mark, Intermediate Mark, Mid Mark, or Intermediate Number, the following error message is displayed:

Layer name is invalid.

- **Main Mark**: Enter a height for the main tick marks.
- **Intermediate Mark**: Enter a height for the intermediate tick marks.
- **Mid Mark**: Enter a height for the midpoint mark between units on the axis.

**NOTE** If an odd number of tick marks has been selected, it is not possible to have an even mid-mark.

- **Intermediate Number**: Enter the number of ticks between each number on the axis

4 Click OK.

**Changing the Individual Curve Preferences**

You can use the Individual Curve Preferences (located under the Curve Information section of the Plot Settings dialog box) to determine how a curve will be illustrated on a graph, the layer to use, and the color of the curve.

**NOTE** When you first open the Plot Settings dialog box, the Curve Information list is empty. After you create a curve (by clicking New under Curve Information), a curve name (Y1) displays in the list. If you create more than one curve, the curve you select from this list is considered the current curve.

To change the Individual preferences for a hydrograph curve

1 Click the Plot button from the hydrograph you are currently viewing to display the Plot Settings dialog box.

**NOTE** You can view a hydrograph when you are using several different commands. For example, if you select Hydrology ➤ Runoff ➤ Rational, and then click the IDF button and the View button, a hydrograph is displayed.
2 From the Plot Settings dialog box, select a curve from the Curve Information list. If no curves are listed in the list, refer to the preceding note.
3 Click Preferences next to the curve list. The Individual Curve Preferences dialog box is displayed for the curve you selected in step 1.

4 You can change the preferences for the curve by specifying the following settings:
   - **X-Y Line**: From this list, select a method for illustrating the curve on the graph. The available options are: X-Y Line - displays the curve as a line, Symbol - displays the curve as a series of symbols, X-Y Line & Symbol - displays the curve as a line and symbols, or Bar - displays the curve as a bar graph.
   - **Layer**: Enter the name of the layer on which you want to place the curve.
   - **Color**: Enter the number of the layer color that you want the curve displayed in, or pick the colored box and select the color from the standard Select Color dialog box.
   - **Symbol**: Enter the name of the symbol that you want to use to illustrate the curve, or click Select and select a symbol from the Select Block dialog box. The blocks must have a scale of one to one (1:1).

5 You can change the X and Y values for the curve by clicking Edit to display the Edit Data dialog box.
6 Click OK to return to the Plot Settings dialog box.

### Changing X, Y Data for an Individual Curve

You can change X and Y values for an individual curve.

**To change the X, Y data for an individual curve**

1 Click the Plot button from the hydrograph you are currently viewing to display the Plot Settings dialog box.

**NOTE** You can view a hydrograph when you are using several different commands. For example, if you select Hydrology ➤ Runoff ➤ Rational, and then click the IDF button and the View button, a hydrograph is displayed.
2 From the Plot Settings dialog box, select a curve from the Curve Information list.

**NOTE** When you first open the Plot Settings dialog box, the Curve Information list is empty. After you create a curve by clicking New, a curve name (Y1) displays in the list. If you create more than one curve, the curve that you select from this list is considered the current curve.

3 Click Edit to display the Edit Data dialog box.

4 Change the X and Y values of the current curve.

If you just created the curve with the New button, the data table in this dialog box will be empty. You can create a single curve by entering data into the X column and the Y1 column. To create multiple curves, enter data into the additional Y# columns. Add subsequent curves in order; do not skip from Y1 to Y3 or from Y2 to Y5.

Use the navigation keys (located to the right of the dialog box) to move through the data, if necessary.

**NOTE** Multiple curves plotted on one graph let you compare pre- and post-development hydrographs, various pipe sizes versus flow, and curves for different coefficients for a single pipe diameter. Hydrology Tools can take data and information from other sources and create multiple graphs in your drawing.

5 Click OK to return to the Plot Settings dialog box.
Changing the Hydrology Graph Settings

To change the graph settings for a hydrograph

1. From the Hydrograph dialog box, click Settings to display the Graph Settings dialog box.

   ![Graph Settings Dialog Box]

2. Specify colors for the entities that appear in the graph. Click the color square next to an entity to display the Select Color dialog box, then select a color. You can also type the color’s number directly, if you know the number. For example, the color blue corresponds to the number 5 and red corresponds to the number 2.

3. Specify the scale settings for the X and Y axis by selecting the following:
   - Automatic to display the X or Y axis at the best possible scale for the specified increments.
   - Linear to display the X or Y axis with a linear scale.
   - Log to display the X or Y axis with a logarithmic scale.

4. Click OK to save the graph settings and to exit the dialog box.
Specifying a Rational Runoff Coefficient
You can enter the runoff coefficient that represents the ratio of runoff to rainfall using the Rational Method dialog box.

To specify a rational runoff coefficient
1. From the Rational Method dialog box, click Coef to display the Rational Coefficient File Selection dialog box.

2. Select the file type to use (Land Uses or Soil Types). The Rational Coefficients dialog box is displayed for the file type you selected.

3. Select a value from the Rational Coefficients dialog box by clicking in a field that contains a value, and then click OK.

   Use the navigation keys (located to the right of the dialog box) to move through the data that isn't visible on the screen.

4. The value you selected from the Rational Coefficients dialog box is placed in the Coef. column of the Rational Method dialog box.

Specifying a Composite Runoff Coefficient
You can use the Composite Runoff Coefficient Calculator dialog box to select a composite runoff coefficient. This editor dialog box shows you runoff curve numbers for a variety of soil and land use combinations. You can edit the settings based on your personal standards.
To specify a composite runoff coefficient

1 From the Rational Method dialog box, click CmpCoef to display the Composite Runoff Coefficient Calculator dialog box.

![Composite Runoff Coefficient Calculator](image)

2 You can change the composite runoff coefficient settings by specifying the following settings:

- **Description**: Enter a descriptive title in this column.
- **Area**: Enter the area value in this column, or click Select to either select an area or define an area in the drawing.
- **Coefficient**: Enter a coefficient value in this column, or click Select to choose a coefficient.
- **Total Area**: Displays the calculated total area.
- **Weighted Coefficient**: Displays the calculated weighted coefficient.
- **Delete**: Removes the selected row.
- **Insert**: Inserts a new row above the selected row.
- **Output**: Displays the data in a text editor. From here, you can print the data to a file or printer.

3 Click OK to save the composite coefficient settings and exit the dialog box.
**Specifying a Frequency Adjustment Factor**

You can use the Frequency Factor Editor dialog box to select a frequency adjustment factor.

**To specify a frequency adjustment factor**

1. Click the Adjustment Factor box into which you want to place the adjustment factor. The Rational Method dialog box is displayed.
2. Click Factor.

   The Frequency Factor Editor dialog box is displayed.

3. In the Frequency column, enter the frequencies (in years). Select a text box and enter the value.
4. In the corresponding Factor column, enter an adjustment factor for each year. Select a text box and enter the value.
5. Select the Use frequency factor check box.
6. Click OK to return to the Rational Method dialog box.

   An adjustment factor is placed in the Adjustment Factor text box you selected in step 1. Autodesk Civil Design automatically calculates the correct adjustment factor based on the Rainfall Frequency you selected in the Rational Method dialog box and the frequency factors you entered in the Frequency Factor Editor dialog box.

---

**Using the TR-55 Graphical Method to Calculate the Peak Runoff Flow**

The Autodesk Civil Design Graphical Peak Discharge and Tabular Hydrograph Methods are based on Technical Release 55 (TR-55), Urban Hydrology for Small Watersheds. The Soil Conservation Service (SCS), now called the National Resources Conservation Service (NRCS), first published the TR-55 in 1975, and updated it to its current form in 1986. TR-55 was originally developed to be a
by-hand method, but with the advent of personal computers, it has been computerized in many forms.

The TR-55 presents methods to calculate storm runoff volumes, peak discharge rates, and pre- and post-development hydrographs. The methods apply to small watersheds (around 2000 acres or less) in the United States. You can use the TR-55 methods for larger drainage areas and storm water detention calculations. Both of the graphical peak discharge and tabular hydrograph methods use a 24-hour rainfall event to calculate runoff.

The Graphical and Tabular methods are roughly equal in their accuracy. Because they use a time of concentration value, they can be used for watersheds of any size. The Graphical Method is the simpler of the two TR-55 methods. Use the Graphical Method if you require a peak discharge value, but not a complete hydrograph. The Graphical Method is limited to calculations for one watershed subarea at a time. The Tabular Method can accommodate multiple watershed subareas and produces a peak discharge value as well as a complete hydrograph.

The following table can help you decide which TR-55 method to use:

<table>
<thead>
<tr>
<th>If...</th>
<th>Then use...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the watershed cannot be delineated as a single sub-area</td>
<td>the Tabular Method.</td>
</tr>
<tr>
<td>the watershed has multiple subareas</td>
<td>the Tabular Method.</td>
</tr>
<tr>
<td>you only require a peak discharge value</td>
<td>the Graphical Method.</td>
</tr>
<tr>
<td>you require a hydrograph</td>
<td>the Tabular Method.</td>
</tr>
</tbody>
</table>

**NOTE** It is important that you have some familiarity with the methods and terminology described above. If you need more information about Urban Hydrology for Small Watersheds, review the SCS Technical Release 55 document, which you can obtain from your local SCS (now NRCS) or county Soil & Water Conservation District office, most college libraries, or the National Technical Information Service in Washington, D.C.

To calculate runoff using the TR-55 tabular and graphical methods, you must assemble the following data:

- Rainfall distribution for the selected region
- Storm frequency
- Watershed area(s)
- CN number, or the composite (weighted) CN number
- Time of Concentration

Some of this information, such as CN number, is provided in look-up tables from within Autodesk Civil Design. You can use a Autodesk Civil Design calculator to calculate the Time of Concentration, based on the sheet, shallow, and channel flow lengths. You can calculate watershed areas from a TIN surface by using the Terrain Model Explorer, or you can delineate the watershed data by hand and draw the areas in your drawing as closed polylines.
You can obtain the rainfall distribution amounts from the local SCS office (now NRCS) in the form of a .rf file, or you can manually enter the data into the Rainfall Distribution Editor.

**Graphical Peak Discharge Method Formula**

The TR-55 Graphical Peak Method determines a peak discharge rate. Use this method for larger drainage areas and storm water detention calculations. This TR-55 Method uses a 24-hour rainfall event to calculate runoff.

The Graphical Peak Discharge Method formula is as follows:

\[ q_p = qu \cdot Am \cdot QFp \]

where:

- \( q_p \) = Peak discharge (cfs)
- \( qu \) = Unit peak discharge (cm/in)*
- \( Am \) = Drainage Area (mi²)
- \( Q \) = Runoff (in)
- \( Fp \) = Pond and swamp adjustment factor

* cubic feet per second per square mile per inch of runoff [cfs/mi² in]

**Calculating the Peak Runoff Flow by Using the TR-55 Graphical Method**

The Graphical Peak Discharge Method formula for runoff calculation is used to calculate peak discharge runoff for a watershed without creating a hydrograph. The TR-55 Graphical Peak Discharge Method calculator simplifies the process of calculating peak runoff by doing the calculations for you. You enter the required data (rainfall distribution type, runoff curve number, time of concentration, pond and swamp area adjustment factor, and 24-hour rainfall amount), and the calculator determines the peak flow value.

For more information on this method, see the SCS TR-55 manual, Chapter 4, “Graphical Peak Discharge Method.”
To calculate the peak runoff flow by using the TR-55 graphical method

1 From the Hydrology menu, choose Runoff ➤ TR-55 Graphical Method to display the TR-55 Graphical Peak Discharge Method dialog box.

<table>
<thead>
<tr>
<th>TR-55 Graphical Peak Discharge Method - None</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description:</td>
</tr>
<tr>
<td>Rainfall Distribution:</td>
</tr>
<tr>
<td>Drainage Area:</td>
</tr>
<tr>
<td>Runoff Curve Number:</td>
</tr>
<tr>
<td>Time of Concentration:</td>
</tr>
<tr>
<td>Pond and Swamp Areas:</td>
</tr>
<tr>
<td>Rainfall, P:</td>
</tr>
<tr>
<td>Unit Peak Discharge, cu</td>
</tr>
<tr>
<td>Initial abstraction, I:</td>
</tr>
<tr>
<td>I/Io:</td>
</tr>
<tr>
<td>Runoff, Q:</td>
</tr>
<tr>
<td>Pond/Spill Adjust. Fp:</td>
</tr>
<tr>
<td>Peak Discharge, cu:</td>
</tr>
</tbody>
</table>

**TIP** To load a runoff calculation that you previously saved, click Load.

2 In the Description box, type a description for the watershed area.

3 In the Rainfall Distribution list, select the rainfall distribution for the project location. The available types are: Types I, IA, II, and III.

**NOTE** See the map on page B-2 of the TR-55 manual, or contact your local NRCS, to determine the appropriate rainfall distribution for your project area.

4 In the Drainage Area box, type the watershed area, or click Select to specify the area by drawing a closed polyline or selecting a closed polyline from the drawing.

5 In the Runoff Curve Number box, type the curve number for the watershed, or click Select to select the watershed’s curve number from the Runoff Curve Number Editor. For more information, see “Specifying a Runoff Curve Number” in this chapter.

6 In the Time of Concentration box, type the Tc for the watershed, or click Select to calculate the watershed’s Tc.

7 In the Pond and Swamp Areas box, type the total area of ponds and swamps in the watershed, or click Select to specify the areas by selecting closed polylines from the drawing. This value is required if the ponds or swamps are scattered throughout the watershed and are not accounted for in the time of concentration calculation.
The % of Drainage Area label displays the calculated percentage of the watershed drainage area comprised of ponds and swamps.

8 In the Rainfall, P box, type the rainfall depth, or click Select to select the rainfall depth and frequency from the Define Rainfall-Frequency dialog box.

The Frequency label near the top of the dialog box displays the selected storm frequency (1, 2, 5, 10, 25, 50, or 100 years).

9 Review the calculated results for the drainage area at the bottom of the TR-55 Graphical Peak Discharge dialog box:

- **Unit Peak Discharge, qu**: Displays the computed unit peak discharge for the watershed.
- **Initial abstraction, Ia**: Displays the computed initial abstraction for the watershed.
- **Ia/P**: Displays the computed Ia/P (Initial abstraction/Precipitation) ratio.
- **Runoff, Q**: Displays the computed depth of runoff in inches of rain.
- **Pond/Swamp Adjust., Fp**: Displays the computed Pond and Swamp Area adjustment factor. The maximum Fp = 0.72 for 5% or greater pond and swamp areas.
- **Peak Discharge, qp**: This label displays the computed peak discharge for this drainage area.

10 You can save and output the calculation results, and view messages and warnings:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>save the calculation results</td>
<td>Save.</td>
</tr>
<tr>
<td>clear the calculator of its contents</td>
<td>New.</td>
</tr>
<tr>
<td>save the calculation results to a text file</td>
<td>Output.</td>
</tr>
<tr>
<td>view error messages</td>
<td>Messages.</td>
</tr>
</tbody>
</table>

11 Click OK to exit the dialog box.

**Specifying a Runoff Curve Number**

You can enter the curve number for a watershed from the Runoff Curve Number Editor dialog box when using the TR-55 graphical method.

To specify a runoff curve number

1 Click the Select button next to the Runoff Curve Number field to display the Runoff Coefficient dialog box.

2 Click Single RCN or Composite RCN from the Runoff Coefficient dialog box:

- **Single RCN**: Displays the Runoff Curve Number Editor.
- **Composite RCN**: Displays the Composite Runoff Curve Number Calculator.

3 Select the value you want to display in the TR-55 Graphical Peak Discharge dialog box:

To select a value from the Runoff Curve Number Editor dialog box, click in the field that contains the value you want to use, then click OK to return to the TR-55 Graphical Peak Discharge dialog box. The value is placed in the Runoff...
Calculating the Peak Runoff Flow by Using the TR-55 Tabular Method

The Tabular Method for runoff calculation is used to calculate peak discharge runoff and generate hydrographs for single or multiple watershed subareas.

The TR-55 Tabular Method calculator simplifies the process of calculating peak runoff by doing the calculations for you. You enter the required data (rainfall distribution type, drainage area, time of concentration, time of travel, downstream subareas, the 24-hour rainfall intensity, and the runoff curve number), and the calculator determines the peak flow value and creates a hydrograph.

To calculate the peak runoff flow by using the TR-55 tabular method

1. From the Hydrology menu, choose Runoff ‣ TR-55 Tabular Method to display the TR-55 Tabular Hydrograph Method dialog box.

![TR-55 Tabular Hydrograph Method](image)

TIP
To load a runoff calculation that you previously saved, click Load.
2. In the Description box, type a description for the calculation.

3. From the Rainfall Dist. list, select the appropriate rainfall distribution for the project location. The available values are Types I, IA, II, and III.

   **NOTE** See the map on page B-2 of the SCS TR-55 manual, or contact your local SCS (now NRCS) to determine the appropriate rainfall distribution for your project area.

4. Select the Ia/P Interpolation check box to interpolate the Ia/P ratio. Autodesk Civil Design uses lookup tables provided in the TR-55 manual to calculate this ratio. These tables are based on specific Ia values, such as .10 and .30. If the calculated Ia value is .21, and the Ia/P Interpolation check box is not selected, then Civil Design rounds the value up to .30. By selecting the Ia/P Interpolation check box, the Ia/P value is interpolated instead of rounded.

5. Select the Auto Calc check box to automatically calculate the Peak Discharge and Peak Time values after each change you make to the data. Clear this check box to calculate these values only when you click Compute.

6. In the Subarea Name column, enter a short description for each watershed subarea, using numbers or letters.

7. In the Drainage Area column, type the area of the watershed subarea. You can also click Area at the bottom of the dialog box to calculate the drainage area by drawing a closed polyline or selecting a closed polyline in the drawing.

8. In the Time of Concentration column, enter a Tc. You can also click Tc at the bottom of the dialog box to calculate the area’s Tc.

9. In the Travel Time column, enter a Tt. You can also click Tt at the bottom of the dialog box to calculate the area’s Tt.

10. In the Downstream Subareas column, type the list of the names of the downstream subareas (from the subarea name column). Separate each name with a comma. For example, if subarea 1 is upstream of subareas 2 and 4, then type 2,4 in the Downstream Subareas column for subarea 1.

   **NOTE** When you type the downstream subarea names into the Downstream Subarea columns, the Sum Tt column displays the computed Tt for these downstream subareas. The computed Tt is the time for the runoff to travel from a watershed subarea to the composite watershed outflow point. For example, if subareas 2 and 4 are downstream of subarea 1, and the Tt of subarea 2 is 4.0 and the Tt of subarea 4 is 3.0, then the sum Tt for subarea 1 is 7.0. You cannot edit the value in the Sum Tt field.

11. In the 24-hrs Rainfall column, enter the 24-hour rainfall depth for each watershed subarea.

    You can also click Rainfall at the bottom of the dialog box to enter rainfall depth.

    **NOTE** The 24-hour rainfall depth should be the same for all watershed subareas.

12. In the Runoff Curve Number column, enter a RCN. You can also click RCN at the bottom of the dialog box to display the Runoff Coefficient dialog box, then click Single RCN or Composite RCN to select or compute the RCN for each watershed subarea.
13 If the Auto Calc check box is not selected, then click Compute at the bottom of
the Tabular Hydrograph Method dialog box to calculate and update the Peak
Discharge and Peak Time values.

After you enter all your data, the Total Area, Peak Discharge, and Peak Time are
computed and displayed towards the bottom of the Tabular Hydrograph
Method dialog box. The Total Area label displays the sum of the areas of all
watershed subareas. The Peak Discharge label displays the calculated peak
discharge for the entire watershed. The Peak Time label displays the computed
time of peak discharge.

14 You can save and output the calculation results, and view messages and
warnings:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>save the calculation results to a</td>
<td>click Save. For more information, see “Saving TR-55 Tabular Runoff Calculations” in this chapter.</td>
</tr>
<tr>
<td>hydrograph file</td>
<td></td>
</tr>
<tr>
<td>clear the calculator of its contents</td>
<td>click New.</td>
</tr>
<tr>
<td>save the calculation results to a</td>
<td>click Output.</td>
</tr>
<tr>
<td>text file</td>
<td></td>
</tr>
<tr>
<td>view error messages</td>
<td>click Messages.</td>
</tr>
<tr>
<td>delete a row of subarea data</td>
<td>place your cursor in the row to delete and click Delete.</td>
</tr>
<tr>
<td>view the data in tabular format</td>
<td>click Tabular.</td>
</tr>
<tr>
<td>view the composite hydrograph</td>
<td>click Graph.</td>
</tr>
</tbody>
</table>

**NOTE** From the Composite Hydrograph dialog box, you can click Plot to plot the
curve, or click Settings to change the appearance of the graph, such as the
line colors.

15 Click OK to exit the dialog box.

**Saving TR-55 Tabular Runoff Calculations**

When you click Save to save the TR-55 Tabular Method runoff calculations, the
Select Save Type dialog box is displayed.

To save the TR-55 Tabular data

- Click Hydrograph to save the hydrograph data as an .hdc file. Use this option
  if you want to use the hydrograph for further calculations.
- Click Tabular to save the TR-55 Tabular data as a .tab file. Use this option to
  save your calculations so you can recall and edit them at a later time.

These files are stored in c:\Land Projects R2\<project name>\hd folder.
Displaying the Calculated Hydrograph Data for Each Subarea and the Entire Watershed

Using the TR-55 Tabular Method for calculating runoff, you can display the calculated hydrograph data for each subarea and the entire watershed.

After calculating the peak discharge value, you can click the Tabular button to display the discharges for each subarea per time increment.

For more information about the data that the Tabular button displays, see Figure 5-4 in Chapter 5, “Tabular Hydrograph Method” in the TR-55 manual. The data that is displayed in the Tabular Method Data dialog box is similar to the sample data shown on the right side of the Figure 5-4 worksheet.

To display the calculated hydrograph data for each subarea and the entire watershed

1. From the Hydrology menu, choose Runoff ➤ Tabular to display the TR-55 Tabular Hydrograph Method dialog box.
2. Click Tabular to display the Tabular Method Data dialog box.

The subarea descriptions display in the column on the left side of the dialog box. The time displays across the top. The individual subarea hydrograph ordinates are displayed in the middle columns, and the total watershed hydrograph is displayed across the bottom row.
Click Output. The data is displayed in a text editor, such as Notepad.

![Image of TR-55 Tabular Data](image.png)

Click OK to return to the TR-55 Tabular Hydrograph Method dialog box.

**Calculating Runoff With the TR-20 Method**

The SCS TR-20 Unit Hydrograph Method is one of the most sophisticated hydrologic analysis methods, allowing you to use variable length storm events. This method uses a dimensionless (or unit) hydrograph and a rainfall distribution curve to calculate peak discharge.

A dimensionless hydrograph represents the discharge of water that would occur during a storm that lasts 24 hours and creates a uniform 1 inch of depth of runoff. In this runoff calculation method, the dimensionless hydrograph is used to represent the average capacity of a watershed to discharge runoff. The unit hydrograph provided in the TR-20 Method was derived from a large number of natural unit hydrographs from watersheds varying widely in size and geographic location. If a natural unit hydrograph is available for the region
being investigated, then it might be more accurate to use the observed data rather than using a unit hydrograph based on such widely varying data.

Compared with the TR-55 methods, which are used for smaller, simpler watersheds, the TR-20 runoff calculation method has a broader range and can be used for larger and more complex watersheds. The TR-20 Method is best used for watersheds ranging from 2 to 400 square miles with subareas from 0.1 to 20 square miles.

The TR-20 Method provided in Autodesk Civil Design is a limited version intended to be used to calculate a single subarea. TR-20 is published by the Soil Conservation Service (now NRCS). The TR-20 Method uses TR-20 distribution curve tables (tr20t1 through tr20t7). These files are stored in the c:\Land Desktop R2\Data\hd folder and have a .dst extension.

**NOTE**

To see which calculations are used for the TR-20 method, see the "National Engineering Handbook: Section 4-Hydrology," in Chapter 16.

Distribution curves show the relationship between the fraction of rainfall that occurs and a given time period. The TR-20 distribution curve tables use both 24- and 48-hour time periods, and also include a table for emergency spillway conditions (table tr20t6). The different TR-20 distribution curve tables are based on different rainfall distribution types (I, IA, II, and III) that are described on page B-1 of the TR-55 manual.

**NOTE**

When you perform calculations using the TR-20 Method, it is recommended that the units be Imperial, the rainfall in inches and the area in square miles. If the units for rainfall are set to something other than inches, then the TR-20 distribution curve table (.dst file) must match the rainfall units.
Calculating the Peak Runoff by Using the TR-20 Method

To calculate the peak runoff using the TR-20 Method

1. From the Hydrology menu, choose Runoff ▶ TR-20 Method to display the SCS TR-20 Unit Hydrograph Method dialog box.

   ![SCS TR-20 Unit Hydrograph Method](image)

   - Description: "Phase III - Freezing Point"
   - Dimensionless Hydrograph: "scsdim"
   - Distribution: "tr20t2 Type 2, 24 hrs"
   - Antecedent Moisture Condition: "Type II"
   - Runoff Curve Number: "05"
   - Duration: "1.0000 hrs"
   - Drainage Area: "0.0000 m²"
   - Rainfall: "1.0000 in"
   - Time Increment: "0.0000 hrs"
   - Time of Concentration: "0.0000 hrs"
   - Peak Discharge: "0.0000 cfs"
   - Time to Peak: "0.0000 hrs"

   **TIP** To load a runoff calculation that you previously saved, click Load.

2. In the Description text box, enter a description for this watershed area.

3. From the Dimensionless Hydrograph list, select a dimensionless hydrograph. The SCS hydrograph, scsdim.dim, is supplied for you.

   You can also click Edit to display the Dimensionless Hydrograph Editor dialog box, where you can view and edit an existing dimensionless hydrograph file, or create a new file.

4. From the Distribution list, select a TR-20 distribution curve table: tr20t1, tr20t2, tr20t3, tr20t4, tr20t5, tr20t6, or tr20t7.

   You can also click Edit to display the Distribution Editor dialog box where you can edit the distribution values.
5 From the Antecedent Moisture Condition list, select the antecedent moisture condition. The Antecedent Moisture Condition (AMC) list displays three types of antecedent moisture conditions: Type I, Type II, and Type III:

<table>
<thead>
<tr>
<th>AMC Type</th>
<th>Soil moisture (dormant season)</th>
<th>Soil moisture (growing season)</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>less than 0.5 inches</td>
<td>less than 1.4 inches</td>
</tr>
<tr>
<td>II</td>
<td>between 0.5 and 1.1 inches</td>
<td>between 1.4 and 2.1 inches</td>
</tr>
<tr>
<td>III</td>
<td>greater than 1.1 inches</td>
<td>greater than 2.1 inches</td>
</tr>
</tbody>
</table>

6 In the Runoff Curve Number box, type an RCN.

You can also click the Select button next to the Runoff Curve Number field to display the Select RCN Type dialog box, then click Single RCN or Composite RCN to select or compute the RCN for each watershed subarea.

7 In the Duration box, type the duration of the storm. The duration must equal 1 hour for standard TR-20 distribution curves.

8 In the Drainage Area box, type the drainage area of the watershed. You can also click Select to calculate the drainage area by either drawing or selecting a closed polyline in the drawing.

9 In the Rainfall box, type a rainfall amount based on a storm-event type for the site location. You can also click Select and choose a value from the Define Rainfall-Frequency dialog box.

10 In the Time Increment box, type an appropriate value.

   **NOTE** The TR-20 method is limited to 300 points on the hydrograph. To reduce the number of points, use a larger time increment.

11 In the Time of Concentration box, enter a Tc value. You can also click the Select button next to the Time of Concentration field to calculate the area’s Tc. The calculated Peak discharge for the entire watershed and the computed time of peak discharge are located above the buttons at the bottom of the SCS TR-20 Unit Hydrograph Method dialog box.

12 You can save and output the calculation results, and view the hydrograph:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>save the calculation results</td>
<td>Save.</td>
</tr>
<tr>
<td>clear the calculator of its contents</td>
<td>New.</td>
</tr>
<tr>
<td>save the calculation results to a text file</td>
<td>Output.</td>
</tr>
<tr>
<td>view the hydrograph</td>
<td>Hydrograph.</td>
</tr>
</tbody>
</table>

13 Click OK to exit the dialog box.
Viewing and Editing the Dimensionless Hydrograph Values

A dimensionless unit hydrograph represents the runoff that occurs uniformly across a watershed. It shows the relationship of \( \frac{q}{qp} \) (peak discharge) to \( \frac{t}{tp} \) (time to peak), as shown in the following illustration:

The hydrograph uses one inch of rain as the rainfall amount, and assumes the rainfall occurs at a uniform rate for a specified duration.

The Soil Conservation Society (now NRCS) developed an average dimensionless hydrograph that the TR-20 Method is based on. Autodesk Civil Design provides this dimensionless hydrograph file, scsdim.dim. This file is stored in the c:\\Program Files\\Land Desktop R2\\Data\\hd folder.
To view and edit the dimensionless hydrograph values

1. From the Hydrology menu, choose Runoff ➤ TR-20 Method to display the SCS TR-20 Unit Hydrograph Method dialog box.

2. Click Edit next to the Dimensionless Hydrograph list to display the Dimensionless Hydrograph Editor dialog box.

3. You can use the options in this dialog box to review the values in an existing dimensionless hydrograph, to edit these values, and to view the dimensionless hydrograph curve. You can also load an existing dimensionless hydrograph file or create a new file.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>edit the existing values</td>
<td>use the navigation buttons to locate the line you want to edit, and then type new values.</td>
</tr>
<tr>
<td>create a new dimensionless hydrograph file</td>
<td>click New.</td>
</tr>
<tr>
<td>add a new range of time increments</td>
<td>click Range.</td>
</tr>
<tr>
<td>add a new row</td>
<td>place your cursor in the row you want to add a new row above, and click Insert.</td>
</tr>
<tr>
<td>delete a row</td>
<td>place your cursor in the row you want to delete, and click Delete.</td>
</tr>
<tr>
<td>view the dimensionless hydrograph curve</td>
<td>click View.</td>
</tr>
<tr>
<td>load an existing dimensionless hydrograph file</td>
<td>click Load.</td>
</tr>
<tr>
<td>make sure that each value in a column is greater than the next value</td>
<td>select the Ascend Check box.</td>
</tr>
</tbody>
</table>
When editing the dimensionless hydrograph, enter the time increment values in the t/tp (time to peak) column. Enter the flow discharge values in the q/qp (peak discharge) column.

4 Click Save to save your changes.
5 Click OK to return to the SCS TR-20 Unit Hydrograph Method dialog box.

**Adding a Range of Time Increments to a Dimensionless Hydrograph File**

To quickly add new rainfall distribution information to a new or existing dimensionless hydrograph file, you can add ranges. Ranges define the time increments you want to add information for. You can manually type each increment value in the Dimensionless Hydrograph Editor, but the Range option automates this process for you.

**To add a range of increments to a dimensionless hydrograph file**

1 From the Hydrology menu, choose Runoff ➤ TR-20 Method to display the SCS TR-20 Unit Hydrograph Method dialog box.
2 Click Edit next to the Dimensionless Hydrograph list to display the Dimensionless Hydrograph Editor dialog box.
3 Click Range to display the Range Settings dialog box.

![Range Settings Dialog Box](image)

4 Enter the time range values according to the following guidelines:
   - In the From box, enter the start of the range you want to add increments for. For example, if you want to create increments between 0 and 120 minutes, type 0 in the From box.
   - In the To box, enter the end of the range. For example, if you want to create increments between 0 and 120 minutes, type 120 in the From box. The To value must be greater than the From value.
   - In the Increment box, enter the increment. For example, if you want to add rainfall amounts to the dimensionless hydrograph file for every 30 minutes, type 30 in the Increment box.

5 Click OK to return to the Dimensionless Hydrograph Editor dialog box.

If you are editing an existing dimensionless hydrograph file, then a dialog box is displayed, asking if you want to delete the existing column data.
6 Click Yes or No:
- Click Yes to replace ALL of the data in the time column of the Dimensionless Hydrograph Editor dialog box with the values you just entered in the Range Settings dialog box.
- Click No to leave the existing values in the time column and append the new time values to the end of the time column.

7 Click OK to exit the dialog box.

**TR-20 Distribution Curve Conditions Tables**
The rainfall patterns in the United States can be described by four different types of dimensionless rainfall distribution curves. These distribution curves are referred to as I, IA, II, and III, and are described on page B-1 of the TR-55 manual. A distribution curve describes what fraction of the total 24-hour rainfall has occurred at any given time.

The TR-20 Method uses TR-20 dimensionless curve tables that are based on rainfall distribution curves I, IA, II, and III. Data is included for both 24-hour and 48-hour events. You can select a table from the Distribution list in the SCS TR-20 Unit Hydrograph Method dialog box, and you can also click the Edit button to add values or ranges or to view the distribution curve.

- **TR-20t1**: The standard SCS 24-hour, type I distribution, cumulative rainfall table. The values in this table are in 30 minute intervals.
- **TR-20t2**: The standard SCS 24-hour, type II distribution, cumulative rainfall table.
- **TR-20t3**: The standard SCS 24-hour, type IA distribution, cumulative rainfall table.
- **TR-20t4**: The standard SCS 48-hour, type I distribution, cumulative rainfall table.
- **TR-20t5**: The standard SCS 48-hour, type II distribution, cumulative rainfall table.
- **TR-20t6**: The standard SCS dimensionless distribution, emergency spillway for freeboard hydrographs, cumulative rainfall table.
- **TR-20t7**: 24-hour, type III distribution, cumulative rainfall table.

**NOTE** Type I, IA, II, and III 24-hour rainfall distributions are discussed in Appendix B of the TR-55 manual. Type IIA is the least intense and type II is the most intense short duration rainfall. Types I and IA represent the Pacific maritime climate with wet winters and dry summers. Type III represents Gulf of Mexico and Atlantic coastal areas where tropical storms bring large 24-hour rainfall amounts. Type II represents the rest of the country. Figure B-1, “SCS 24-hour rainfall distributions” in Appendix B of the TR-55 manual shows the different distribution curves for each of the four types. You can also view the distribution curves for the types when you select a table from the Distribution list in the SCS TR-20 Unit Hydrograph Method dialog box, click the Edit button, and then click the View button.
Viewing and Editing the Distribution Condition Values

If you want to preview a TR-20 distribution curve, or if you want to edit an existing distribution curve, then use the Distribution Editor.

To view and edit the distribution condition values

1. From the Hydrology menu, click Runoff ➤ SCS Method to display the SCS TR-20 Unit Hydrograph Method dialog box.
2. Select the TR-20 distribution condition you want to view or edit.
   Use the Distribution list to select one of the seven types of TR-20 distribution conditions available: tr20t1, tr20t2, tr20t3, tr20t4, tr20t5, tr20t6, and tr20t7.
3. Click Edit to display the Distribution Editor dialog box.

![Distribution Editor Dialog Box]

TIP
You can load a different .dst file to edit and view by clicking Load.
4 Click View to view the current distribution curve.

5 If you need to edit the distribution curve values, then use the navigation buttons to locate the line you want to edit, and then type new values. You can also use the following guidelines for editing the data:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new distribution curve file</td>
<td>click New.</td>
</tr>
<tr>
<td>add a new range of time increments</td>
<td>click Range.</td>
</tr>
<tr>
<td>add a new row</td>
<td>place your cursor in the row you want to add a new row above, and click Insert.</td>
</tr>
<tr>
<td>delete a row</td>
<td>place your cursor in the row you want to delete, and click Delete.</td>
</tr>
</tbody>
</table>

**NOTE** To make sure that each value in a column is greater than the next value, select the Ascend Check box.

6 Click Save to display the Select Save Type dialog box.

7 Specify how to save the file by using one of the following options:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>save the file as an .scs file so that you can load it again at a later time</td>
<td>SCS Data.</td>
</tr>
<tr>
<td>save the file as an .hdc file so that you can combine it with other hydrographs</td>
<td>Hydrograph.</td>
</tr>
</tbody>
</table>

8 Click OK to return to the SCS TR-20 Unit Hydrograph Method dialog box.
Combining Hydrographs

You can combine one or more hydrographs together to form a composite hydrograph which represents the combined rates of flow and volume. After performing runoff calculations with the TR-20 Method or the TR-55 Tabular Hydrograph Method, and saving the data to a hydrograph (.hdc file), you can use the Combine Hydrographs command to combine multiple hydrographs together.

To combine hydrographs

1 Generate hydrographs that you want to combine and save them as hdc files. These hydrographs can be determined from the TR-20 Method, TR-55 Method, or they can be hydrographs calculated from reservoir routing.

2 From the Hydrology menu, choose Runoff ➤ Combine Hydrographs to display the Combine Hydrographs dialog box.

3 Click Add to load an existing hydrograph file to display the Add Hydrograph File dialog box.

4 Select the hydrograph file that you want to add. Continue adding hydrograph files by clicking Add and selecting the files. To remove a file from the list, select the file name, then click Delete.

The names of the hydrograph files that you added are display in the Hydrograph Files column of the Combine Hydrographs dialog box.

The offset times to combine display in the Offset Time column. By default, these values are 0.
5 Double-click a value in the Offset Time column to change the offset time. This is the time it takes for the flow from the hydrograph’s drainage area to arrive at the point of concern.

The Hydrograph Offset dialog box is displayed.

6 Enter the offset time, and then click OK.

7 In the Time Increment box, type the time increment to use for the combined hydrograph.

8 If you want to include base flow in the hydrograph (flow from previous storms that is not accounted for in the current storm event), then type the base flow value in the Base Flow box. This base flow could be used to represent a constant flow in a stream that was occurring before the storm event. For example, if you enter a base flow of 5 cfs, then this amount is added to each time increment on the hydrograph.

9 Click View to view the combined hydrographs in the Combine Hydrograph Display dialog box.

Use the following options to change the appearance, output, or plot the data:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the graphing settings</td>
<td>Settings to open the Graph Settings dialog box.</td>
</tr>
<tr>
<td>plot the hydrograph in the drawing</td>
<td>Plot to open the Graphing Utility dialog box.</td>
</tr>
<tr>
<td>output the data to an ASCII text file</td>
<td>Output.</td>
</tr>
</tbody>
</table>

10 Click Close to return to the Combined Hydrograph Display dialog box.
11 Click Save to display the Save Hydrograph File dialog box.

12 Type a name for the combined hydrograph file, and then click Save. The hydrograph is saved as .hdc file.

13 Click Close to end the command.

**Outputting Hydrology Data**

You can use the HEC2 Output commands on the Hydrology menu to define, create, and plot cross sections based on elevations extracted from existing AutoCAD Land Development Desktop surfaces. Commonly used for analyzing stream or channel sections, the cross sections take advantage of the graphing utility, which lets you customize the graphing output options. You can plot the cross sections to a file in the standard HEC-2 file format, then perform post-processing in programs designed for HEC-2 calculations.

You can create sections that are perpendicular to the stream or channel centerline, or skewed sections. You can generate single and multiple HEC-2 sections, including sections at specific station increments ahead, and left and right of the centerline. You can then view the post-processed HEC-2 output files and generate graphs.
**Selecting the Current Surface to Use for HEC2 Output**

Use the Select Surface command to set the current surface for the drawing. The current surface is used to establish rim elevations and inverts for the pipe run nodes and to specify a surface for extracting section data for HEC output.

**NOTE** The surface stays current for the drawing session only. You must set a current surface each time you open the drawing.

**To select the current surface**

1. From the Hydrology menu, choose HEC2 Output ➤ Select Surface to display the Select Surface dialog box.
2. Select the surface you want to use, and then click OK. The surface you selected is now set as the current surface.

**Drawing a 2D Polyline to Use as a Cross Section Sampling Line**

To create a single cross section, you must first draw a section line with the Draw Sections command. Then you can select this 2D polyline when you are using the Plot Single Section command.

**To draw a 2D polyline for use as a cross section sampling line**

1. From the Hydrology menu, choose HEC2 Output ➤ Draw Sections.
   The following prompt is displayed:
   Specify start point:
2. Select a starting point for the polyline by picking it from your drawing.
   The following prompt is displayed:
   Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width/]:
3. Select at least one more point to create a polyline.
   You can draw an arc, for example, by typing Arc at the command prompt, pressing ENTER, and picking the arc’s endpoint. To undo the last point you picked, type Undo at the command prompt and press ENTER.
4. Press ENTER to end the polyline.

**Plotting Single Sections**

You can plot cross sections one at a time by using the Plot Single Section command. You can either define the cross section sampling lines by selecting two points on a surface, or by selecting an existing line, arc, or polyline.

**NOTE** You can use the Draw Section command to draw a cross section line.
To plot single sections

1. From the Hydrology menu, choose HEC2 Output ➤ Plot Single Section.

   **NOTE** If no current surface is in use, then the Select Surface dialog box is displayed. Select the surface on which to base the cross sections in the Select Surface box, and then click OK to continue.

The following prompt is displayed:

   *First point (or Entity):*

2. Do one of the following to select the cross section line:
   - Type Entity and press ENTER, and then select the cross section line.
   - Select the points to define the cross section line.

   The Plot X-Section dialog box is displayed.

3. Establish the settings for plotting the cross section data in a graph. For more information about the settings in this dialog box, see “Changing the Hydrology Plotting Settings” in this chapter.

   If you saved settings from a previous session and you want to use them for this graph, click Load and choose the file that contains the settings.

4. After you establish the settings, click Plot to plot the cross section in the drawing.

   **TIP** You can also click Preview to see what the graph looks like before actually plotting it.

5. Select an insertion point for the graph in the drawing.

   The graph is inserted in the drawing at the point you selected and the Plot X-Section dialog box displays. At this point, you can change the plotting parameters, if necessary, and plot the section again.

6. To plot another section, click Next Section or Close, and then select another section line, or press ENTER to end the command.

---

**Outputting Data in the HEC-2 Format**

The HEC-2 analysis program was designed to calculate water surface profiles for steady, gradually varying flow, in natural or man-made channels. Developed by the Hydrologic Engineering Center (HEC), HEC-2 analysis lets you include calculations to account for various obstructions such as bridges, culvert work, and other structures in the flood plain.

Using HEC-2 Output commands you can sample sections from an AutoCAD Land Development Desktop surface and output the data into a HEC-2 input file. You can then use these files in the HEC-2 program for analysis.

The data records (GR records) specify the elevation and station of each point in a cross section used to describe the ground profile, and are required for each X1 record unless NUMST(X1.2) is zero. The points outside the channel (referred to as the overbank) determine the subdivision of the cross section, which influences calculation of a discharge-weighted velocity head for the cross section.
section. A record is required for each cross section; this record is used to specify the cross section geometry and program options applicable to that cross section.

**NOTE** You must save the HEC-2 input file with a .dat extension if you want to import the section into a drawing.

### HEC-2 Data Structure

When using the HEC-2 Output commands, the data is written in the following data structure:

<table>
<thead>
<tr>
<th>GR Record – Cross Section Ground Line Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
</tr>
<tr>
<td>-------</td>
</tr>
<tr>
<td>0</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
</tbody>
</table>

You can continue adding GR records to describe the cross section. Stations must be in increasing order, progressing from left to right across the cross section. For more information, refer to the *HEC-2 Water Surface Profiles User's Manual, 1990*, U.S. Army Corps of Engineers, published by the National Technical Information Service of the U.S. Department of Commerce.

### X1 Record - General Items for Each Cross Section

The following record is required for each cross section. Use this record to specify the cross section geometry and program options applicable to that cross section:
<table>
<thead>
<tr>
<th>Field</th>
<th>Variable</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>IA</td>
<td>X1</td>
<td>Record identification numbers</td>
</tr>
<tr>
<td>1</td>
<td>SECNO</td>
<td>++</td>
<td>Cross section identification number</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-</td>
<td>Start new tributary backwater at this cross section</td>
</tr>
<tr>
<td>2</td>
<td>NUMST</td>
<td>0</td>
<td>Previous cross section is repeated for current section; GR records are not entered for this cross section</td>
</tr>
<tr>
<td></td>
<td></td>
<td>++</td>
<td>Total number of stations on the following GR records</td>
</tr>
<tr>
<td>3</td>
<td>STCHL</td>
<td>0</td>
<td>NUMST(X1.2) is 0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>++</td>
<td>The station of the left bank of the channel; must be equal to one of the STA(N) on next GR records</td>
</tr>
<tr>
<td>4</td>
<td>STCHR</td>
<td>0</td>
<td>NUMST(X1.2) is 0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>++</td>
<td>The station of the right bank of the channel; must be equal to one of the STA(N) on GR records and equal to or greater than STCHL</td>
</tr>
<tr>
<td>5</td>
<td>XLOBL</td>
<td>++</td>
<td>Length of left overbank reach between current cross section and next downstream cross section; Zero for first cross section if IDIR = 0</td>
</tr>
<tr>
<td>6</td>
<td>XLOBR</td>
<td>++</td>
<td>Length of right overbank reach between current cross section and next downstream cross section; zero for first cross section IDIR = 0</td>
</tr>
<tr>
<td>7</td>
<td>XLCH</td>
<td>++</td>
<td>Length of channel reach between current cross section and next downstream cross section; zero for first cross section if IDIR = 0</td>
</tr>
<tr>
<td>8</td>
<td>PXSECR</td>
<td>0</td>
<td>Cross section stations do not change by the factor PXSECR.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>++</td>
<td>Factor to modify the horizontal dimensions of a cross section. The distance between adjacent GR stations (STA) are multiplied by this factor to expand or narrow a cross section. The STA of the first GR point remains the same. The factor can apply to a repeated cross section or a current one. A factor of 1.1 increases the horizontal distance between the GR stations by ten percent. (See X2.9 for station adjustment to BT data.) This factor adjusts data from X3.</td>
</tr>
<tr>
<td>9</td>
<td>PSXECE</td>
<td>0</td>
<td>Cross section elevations do not change.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>+ or -</td>
<td>Constant to be added (+ or -) to GR elevation data (either previous or current); This factor also modifies sediment elevation data (X3.2) input at current cross section; (See X2.7 for elevation change to BT data); Does not adjust X4 records</td>
</tr>
<tr>
<td>10</td>
<td>IPLOT</td>
<td>0</td>
<td>Current cross section does not plot unless all cross sections were requested by J2 record.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1</td>
<td>Plot current cross section using all points</td>
</tr>
<tr>
<td></td>
<td></td>
<td>10</td>
<td>Plot current cross section using only those points up to the water surface elevation</td>
</tr>
</tbody>
</table>
Sampling the Cross Sections from the Current Surface and Output in the HEC-2 Format

Use the HEC2-Single command to sample cross sections from a surface and output the information to an ASCII file in the HEC-2 format. The HEC2-Single command provides functionality not found in the Plot Single command.

**TIP**
You can use the Entity option to create skewed sections. This is useful when dealing with stream, river, and floodplain cross sections, or any condition in which the cross sections are usually not perpendicular to the central channel.

**To sample cross sections from the current surface for output in HEC-2 Format**

1. From the Hydrology menu, choose HEC2 Output ➤ HEC2 – Single.

**NOTE**
If no current surface is in use, then the Select Surface dialog box is displayed. Select the surface on which to base the cross sections in the Select Surface box, and then click OK to continue.

The following prompt is displayed:

First point (or Entity):

2. Do one of the following to select the cross section sampling line:

   - Select two cross section sampling line endpoints in your drawing.
   - Type Entity to display the following prompt:

     Select (Entity/POints) <Entity>:

3. Press ENTER, and then select the entity from the drawing to use as the cross section sampling line.

   When you use the Entity option, only one entity per cross section is allowed. If you select a polyline, then the sampling for the cross section starts from the end closest to the initial polyline selection point.

   For a skewed cross section, you must select a two-segment, three-vertex polyline. When using this type of polyline, the second or middle vertex becomes the midpoint of the defined section. Depending on how it is drawn, you can have left and right reaches at different distances from the center. In this case, the cross section is not sampled from the start point to the endpoint, but instead is sampled from vertex to vertex. You can define the angle between the first and second segment of the polyline to create a skewed section of any configuration.

**NOTE**
If you need to create perpendicular sections that have varying reach distances on the left and right, make sure the angle between the segments is 180 degrees.

After you select the cross section sampling line, the following message is displayed:

Line added successfully.
This message indicates that the cross section has been selected correctly and is being held in memory. All the sections are processed concurrently when you end the selection process.

When you finish defining the cross sections, the HEC-2 Output Settings dialog box is displayed.

Changing the HEC-2 Output Settings

Because the purpose of HEC-2 calculations is to compute water surface elevations at specific cross section locations based on given flow values, the HEC-2 Output Settings dialog box provides you the options necessary to make these calculations.

To change the HEC-2 output settings

1 In the HEC-2 Output Settings dialog box, under Direction, select an appropriate direction so that computations start at a beginning or ending cross section of known or assumed starting conditions.

The Direction section has two options for determining the flow regime: Subcritical Start at Downstream and Supercritical Start at Upstream.

2 Under Start Computations, select the starting water surface elevation of the beginning or ending cross section.

4 Configure the output settings for the sections.

5 Click the Create File button to sample the HEC-2 sections and display the HEC-2 Input Data File in the currently configured ASCII text editor.

6 Save the file with a .dat extension.

7 Close the text editor to continue.
The Start Computations section has four options for specifying the starting water surface elevation of the beginning or ending cross section:

- **Starting Critical Depth**: Appropriate at cross section locations where critical or near critical conditions are known to exist for the computed range of discharges.

- **Start with Known Water Surface Elevation**: When selected, this check box lets you enter an appropriate value in the Starting Water Surface Elevation text box. You can also select a point from the current surface by clicking Select.

- **Rating Curve**: When selected, this check box lets you enter an appropriate value from an existing rating curve in the Starting Elevation text box associated with the Rating Curve option. You can also select a point from the current terrain model surface by clicking Select.

The next line of information associated with the Rating Curve option first lists the current rating curve file name, which, by default, is None. Three additional buttons are available when using the Rating Curve option:

- **Clear**: Clears the current rating curve data.
- **View**: Displays a specific rating curve in the Rating Curve Display dialog box.
- **Select**: Lets you select an existing rating curve file.

- **Slope-Area Method**: When selected, this check box lets you enter an appropriate estimated energy grade line slope value in the Est. Energy Slope text box. You can also select points from the current surface by clicking the Select button next to the Est. Energy Slope text box.

After you establish the flow regime and starting water surface elevation, enter a starting flowrate value in the Starting Flowrate text box.

**NOTE** If you are using the Start with Known Water Surface Elevation or Slope-Area Method of Start Calculations, you must first enter the Starting Water Surface Elevation.

4. In the Manning’s n box, enter a channel roughness coefficient value.

You can also click Select and choose one from the Channel - Manning’s n dialog box.

5. Select or clear the No Interpolated X-Sections check box:

   - Select the No Interpolated X-Sections check box to prevent interpolated cross sections from being generated as the HEC-2 calculations are made.
   - Clear the No Interpolated X-Sections check box, and then type a maximum change in velocity head value in the Max. Change in Vel Head text box. Interpolated cross sections are then generated when velocity head changes occur that match the specified parameters.

6. After you have established the required parameters, click Create File to display the compiled HEC-2 data in your currently configured ASCII text editor.

**NOTE** If you are using Windows 95 and Notepad is your default ASCII text editor, save the file by selecting Save As. Type quotes around the filename. For example, if you want to save the file as hydro.dat, choose Save As and enter the file name as “hydro.dat”. If you do not do this and choose Save, Notepad saves the file as <filename>.dat.txt.
Selecting a Rating Curve

To select a rating curve

1. Click Select to display a standard File Open dialog box.
2. In the File Name box, select the rating curve file.
3. Click Open to continue. If the rating curve contains more than 20 points, which exceeds the HEC-2 limit, the Rating Curve Output window displays, warning you that 20 points is the HEC-2 limit and that only 20 points will be used for the curve. Click OK to continue.

After you select a rating curve, the specified rating curve file name is listed with the Rating Curve option.

Sampling the Cross Sections Along an Alignment at Station Increments and Output in the HEC-2 Format

Use the HEC2-Multiple command to create multiple HEC-2 cross sections by sampling along an alignment at station increments that you specify. You can also specify sampling distance to the left and right of this alignment. All the cross sections that are sampled and created are perpendicular to the defined alignment.

NOTE Unlike the HEC2-Single command, where you select the cross section line you want to sample, the HEC2-Multiple command requires you to select an alignment, along which the section lines are sampled automatically at the station increment you specify.

NOTE In this topic, the term 'alignment' is used to refer to a line that you draw to define the cross sections that are created with the HEC2-Multiple command. The term is not used in reference to alignments that you create with the AutoCAD Land Development Desktop Alignments menu.

To sample cross sections along a defined alignment at station increments and output them in HEC-2 format

1. From the Hydrology menu, choose HEC2 Output ➤ HEC2 – Multiple.

NOTE If no current surface is in use, then the Select Surface dialog box is displayed. Select the surface on which to base the cross sections in the Select Surface box, and then click OK to continue.

The following prompt is displayed:

First point (or Entity):

2. Do one of the following to select the alignment along which cross sections will be sampled:
   - Select two endpoints in your drawing.
   - Type Entity to display the following prompt:

      Select (Entity/POints) <Entity>:
Press ENTER, and then select the entity from the drawing to use as the alignment.

**NOTE** The polyline should be drawn in the direction that HEC-2 analysis will be performed, typically from downstream to upstream.

When you finish defining the alignment, the HEC-2 Output Settings dialog box is displayed.

3 Configure the output settings.
4 Click Create File to sample the HEC-2 sections.

You are then prompted for a station increment with the setting increment displayed in brackets.

Station increment <50.000>:

5 Type the station increment you want to use, or press ENTER to accept the default value.

Next, you are prompted for the distances perpendicular to the alignment that you want to sample.

Left Distance <50.000 ft.>:
Right Distance <50.000 ft.>:

6 Type the distances you want to use, or press ENTER at each prompt to accept the default value.

The following message is displayed:

Retrieving cross sections...

When Autodesk Civil Design is finished sampling the cross sections, the HEC-2 Input Data File is displayed in the currently configured ASCII text editor.

7 Save the file with a .dat extension.
8 Close the text editor to continue.
Importing the HEC-2 Cross Sections into a Drawing

Use the Import HEC2-Sections command to import HEC-2 section output data (.dat or .ans files) into a drawing.

TIP A sample .dat file, hec205.dat, is included with Autodesk Civil Design in the c:\Program Files\Land Desktop R2\Data\hd folder.

To import HEC-2 cross sections into a drawing
1 From the Hydrology menu, choose HEC2 Output ➤ Import HEC2 - Sections to display the Load HEC-2 Data File dialog box.
2 In the File Name box, select the file to import, and then click Open to display the HEC-2 Cross Section dialog box.
3 Establish the settings for plotting the cross section data in a graph. For more information about the settings in this dialog box, see “Changing the Hydrology Plotting Settings.”
   If you saved settings from a previous session, and you want to use them for this graph, click Load, and then choose the file that contains the settings.
4 After you establish the settings, click Plot to plot the cross section in the drawing.
5 Select an insertion point for the graph in the drawing.
   The graph is inserted in the drawing at the point you selected and the HEC-2 Cross Section dialog box displays. At this point, you can change the plotting parameters, if necessary, and plot the section again.
6 To plot another section, click Next Section, and then select Plot to plot it in the drawing.
7 Continue to use the Next Section and Plot buttons to plot the sections, and then click Close to end the command.

Importing HEC-2 Profiles Into a Drawing

Use the Import HEC2 – Profiles command to import a HEC .ans file into the drawing.

NOTE Before importing HEC-2 profiles, you must have created one or more profiles (saved as an.ANS file) using the HEC-2 program (which is done outside of AutoCAD Land Development Desktop).

To import HEC-2 Profiles
1 From the Hydrology menu, choose HEC2 Output ➤ Import HEC2 - Profiles to display the Load HEC2 Data File dialog box.
2 From the Look in list, select the folder you want.
3 In the File Name box, select a file.
4 Click Open to continue to display the HEC2 ANS Selections dialog box.
Select the file type you want to work with. Four different .ans file views are available from this dialog box (although you may not find all four at all times):

- **Cross section**: For more information, see “Choosing a Cross Section File” in this chapter.
- **Profile number**: For more information, see “Choosing a Profile Number File” in this chapter.
- **Summary printout**: For more information, see “Choosing a Summary Printout” in this chapter.
- **Summary printout table**: For more information, see “Choosing a Summary Printout Table” in this chapter.

### Choosing a Cross Section File

**To choose a cross section file**

1. In the Load HEC2 Data File dialog box, select a cross section file name, and then click Open to display the HEC-2 Cross Section dialog box.

   The selected cross section displays in the image window in the upper-left corner of the dialog box, and includes:

   - **Flowrate label**: Displays the current flowrate.
   - **Water Elev**: Displays the current water elevation.
   - **Station – ft**: Displays cross section stations from the HEC-2 cross section. Move through the cross section stations using the navigation buttons on the right-side of the window.
   - **Elevation – ft**: Displays cross section surface elevations from the HEC-2 cross section corresponding with values from the Station - ft columns. Move through the cross section surface elevations using the navigation buttons on the right-side of the window.

2. Use the following guidelines to view or plot data:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then click...</th>
</tr>
</thead>
<tbody>
<tr>
<td>plot the cross section</td>
<td>Plot.</td>
</tr>
<tr>
<td>view the HEC-2 data in your currently configured ASCII text editor in standard HEC-2 format</td>
<td>View Files.</td>
</tr>
<tr>
<td>change the graph settings</td>
<td>Settings.</td>
</tr>
<tr>
<td>return to the HEC-2 ANS Selections dialog box and select a different file to view</td>
<td>Select.</td>
</tr>
</tbody>
</table>

3. Click Close to exit the dialog box.
Choosing a Profile Number File

To choose a profile number file

1 In the HEC-2 ANS Selections dialog box, select a PROFILE NO. file name, and then click Open to display the HEC-2 Cross Section dialog box.

HEC-2 data displays in the following columns:

- **Station**: The station at the cross section.
- **Width**: Width of floodway.
- **Section Area**: Cross section area.
- **Mean Velocity**: Mean velocity.
- **WSEL Floodway**: Water surface elevation with floodway.
- **WSEL**: Water surface elevation without floodway.
- **WSEL Difference**: Water surface elevation difference.

**TIP** You can see the descriptions from within the HEC-2 Cross Section dialog box by placing your cursor in a column and clicking the Description button. Use the navigation buttons on the right side of the window to move through the rows of data.

2 Use the following guidelines to view or plot data:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then click...</th>
</tr>
</thead>
<tbody>
<tr>
<td>plot the curve on a graph</td>
<td>Plot</td>
</tr>
<tr>
<td>view the HEC-2 data in your currently configured ASCII text editor in standard HEC-2 format</td>
<td>View Files.</td>
</tr>
<tr>
<td>return to the HEC-2 ANS Selections dialog box and select a different file to view</td>
<td>Select.</td>
</tr>
</tbody>
</table>

3 Click OK to exit the dialog box.

Choosing a Summary Printout

To choose a summary printout

1 In the HEC-2 ANS Selections dialog box, select a Summary Printout file name, and then click OK to display the HEC-2 Cross Section dialog box.

HEC-2 data displays in the following columns (not all columns are shown at all times):

- **SECNO**: Identifying cross section number
- **CWSEL**: Computed water surface elevation
- **WSELK**: Known water surface elevation
- **10*KS**: Slope of energy grade line (times 10,000)
- **K*CHSL**: Channel bed slope (times 1000)
- **VLOB**: Mean velocity in left overbank
- **VCH**: Mean velocity in channel
- **VROB**: Mean velocity in right overbank
- **ELMIN**: Minimum elevation in the cross section

Outputting Data in the HEC-2 Format
Chapter 5  Working with Hydrology Commands

- **TOPWID**: Width at the calculated water surface elevation
- **KRATIO**: Ratio of the upstream to downstream conveyance
- **IHLEQ**: Friction loss equation index

**TIP** You can see the descriptions from within the HEC-2 Cross Section dialog box by placing your cursor in a column and clicking the Description button. Use the >> and << buttons to see all of the columns.

2 Use the following guidelines to view or plot data:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>plot the curve on a graph</td>
<td>click Plot.</td>
</tr>
<tr>
<td>open a cross section message window, displaying information and warnings about a specific row in the HEC-2 Cross Section dialog box</td>
<td>place your cursor in the row and click Message.</td>
</tr>
<tr>
<td>view the HEC-2 data in your currently configured ASCII text editor in standard HEC-2 format</td>
<td>click View Files.</td>
</tr>
</tbody>
</table>

**TIP** Click Select to return to the HEC2 ANS Selections dialog box and select another HEC-2 Profile file to view.

3 Click Close to exit the dialog box.

**Choosing a Summary Printout Table**

To choose a summary printout table

1 In the HECS ANS Selections dialog box, select a Summary Printout Table file name, and then click Open to display the HEC-2 Cross Section dialog box. HEC-2 data is displayed in the following columns (not all columns are shown at all times):
   - **SECNO**: Identifying cross section number
   - **EGLWC**: Energy grade elevation computed assuming low flow
   - **ELLC**: Elevation of the bridge low chord
   - **EGPRS**: Energy grade elevation computed assuming pressure flow
   - **ELTRD**: Elevation of the top of roadway
   - **QPR**: Total pressure of low flow at the bridge
   - **QWEIR**: Total weir flow at the bridge
   - **CLASS**: Identification number for types of bridge/culvert flow
   - **H3**: Drop in water surface elevation from upstream to downstream
   - **DEPTH**: Depth of flow
   - **CWSEL**: Computed water surface elevation
   - **VCH**: Mean velocity in channel
   - **EG**: Energy gradient elevation for a cross section (CWSEL + HV)
   - **XLCH**: Distance in the cross section between the previous cross section and the current cross section
   - **ELMIN**: Minimum elevation in the cross section
- **Q**: Total flow in the cross section
- **CRIWS**: Critical water surface elevation
- **EG**: Energy gradient cross section for an elevation = CWSEL + HV
- **10*KS**: Slope of energy grade line (times 10,000)
- **AREA**: Cross section area
- **.01K**: Total discharge (index Q) computed assuming $S^{.5}=0.1$
- **DIFWSP**: Difference in water surface elevation for each profile
- **DIFWSX**: Difference in water surface elevation between sections
- **DIFKWS**: Difference in water surface elevation between known and computed
- **TOPWID**: Width at the calculated water surface elevation

**TIP** You can see the descriptions from within the HEC-2 Cross Section dialog box by placing your cursor in a column and clicking the Description button. Use the >> and << buttons to see all of the columns.

2 Use the following guidelines to view or plot data:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>plot the curve on a graph</td>
<td>click Plot.</td>
</tr>
<tr>
<td>open a cross section message window, displaying information and warnings about a specific row in the HEC-2 Cross Section dialog box</td>
<td>place your cursor in the row and click Message.</td>
</tr>
<tr>
<td>view the HEC-2 data in your currently configured ASCII text editor in standard HEC-2 format</td>
<td>click View Files.</td>
</tr>
</tbody>
</table>

**TIP** Click Select to return to the HEC2 ANS Selections dialog box and select another HEC-2 Profile file to view.

3 Click Close to exit the dialog box.
Hydrology Bibliography

The following is a listing of all the reference materials used to generate this manual. This list is included for further reading in the subjects covered in this manual.


Use the Pipes commands to create conceptual and finished draft plan and profile pipe runs. You can associate a pipe run with an existing alignment or you can create an alignment from the pipe run. Use the conceptual draft pipe commands when you are designing the pipe run. Use the finished draft pipe commands to import symbols and labels to represent and label the pipe runs.
Overview of Working With Pipes

You can draw two basic types of pipe runs with Pipes: conceptual and finish draft.

Conceptual pipe runs are single line representations of plan and profile view pipe runs. They serve as quick sketches of pipe run configurations, which you can use to check a particular pipe run for proper position and location.

Finish draft pipe runs are more complex representations of pipe runs in plan and profile views. You can select from a variety of annotation options when drawing finish draft pipe runs, and you can specify line types, flow direction arrows, and comprehensive labels.

The commands in the Pipes menu provide you with tools for designing and drafting pipe runs. You can use these tools to design and draft sewer systems, both sanitary and stormwater, in both plan and profile. You can define pipe runs in the drawing or import pipe runs from specified files, make graphical edits in plan or profile, use flow analysis tools to size the pipes, and automatically size and adjust the run variables with the run editor. You can then draft the finished design in plan or profile based on parameters that you define.

Changing the Pipe Settings

Use the Settings ➤ Edit command on the Pipes menu to open the Pipes Settings Editor, from which you can select a series of dialog boxes. Use these dialog boxes to edit an array of Pipes settings, including pipe and node drafting labels, layer data, node and pipe data values, structure library settings, and run editor settings.

Customizing the Pipe and Coefficient Tables

You can use the Coefficient Editor dialog box to enter pipe materials and their associated roughness coefficient to be used in the Pipes Run Editor for calculations.

The Pipes Run Editor lets you edit a pipe run, calculate design flow rates, and size pipes. From this dialog box, you can select various views that display selected columns of information about a pipe run. Sheet view is the default view. You can use sheet view to view all of the columns.
Customizing the Pipe Diameter and Slope Values Table

Use the Pipe Slope Control dialog box to create a list of available pipe sizes and associated slopes to be used as a look-up table. The Pipes Run Editor selects the next largest pipe size in the table automatically, if the design flow exceeds the current pipe size.

To customize the pipe diameter and slope values table

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.

![Pipes Settings Editor](image)

Customizing the Pipe and Coefficient Tables
2 In the Node and Pipe Data Values section, click Slope Control to display the Pipe Slope Control dialog box.

The Pipe Slope Control data is stored in a file called pipewks.slp. The file is stored in the \pipewks folder for the current project. When a new project is created, the pipewks.slp file is copied from a sample default file in the c:\Program Files\Land Desktop R2\land\prot\pipewks folder. You can use an ASCII text editor to modify this sample file as necessary.

3 Use the Diameter column to set the pipe diameter. Enter this value in either inches or millimeters.

4 Use the Min. Slope column to set the minimum slope for a specified pipe diameter.

For example, a 10% slope is entered as 0.10.

5 Use the Max. Slope column to set the maximum slope for a specified pipe diameter.

Use the / button to move the cursor up one row, the \ button to move the cursor down one row, the PgUp button to move the cursor up one page, and the PgDn button to move the cursor down one page. Use the Home button to move the cursor to the first cell, the End button to move the cursor to the last cell, and the Delete button to delete the row for the current cell.

By entering data for a new row and clicking OK, the new row is saved. Also, if you change a value and click OK, the pipewks.slp file is updated with the new information.

6 Click OK to exit the Pipes Settings Editor dialog box.
Customizing the Roughness Coefficient Tables

Use the Select Coefficient Table dialog box to enter pipe materials and their associated roughness coefficient. This is used in the Pipes Run Editor for calculations.

To customize the roughness coefficient tables

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.
2. In the Node and Pipe Data Values section, click the Material/Coeff. Button to display the Select Coefficient Table dialog box.

Each of the three buttons in this dialog box open the Manning’s n, Hazen-Williams Coefficient, and Darcy-Weisbach Friction Factor dialog boxes.

3. Click one of the following buttons to view specific information about changing each of the settings:
   - Manning’s n Formula
   - Hazen-Williams Coefficient
   - Darcy-Weisbach Friction Factor

For more information about any of these dialog boxes, see “Using the Manning’s n Formula,” “Using the Hazen-Williams Formula,” and “Using the Darcy-Weisbach Formula” in this chapter.
Using the Manning's n Formula

Use the Manning's n dialog box to enter a description and an associated Manning's n pipe coefficient value. These values are used by the Pipes Run Editor when calculating flow and sizing pipes.

To use the Manning's n formula dialog box

1. From the Select Coefficient Table dialog box, click the Manning's n button to open the Manning’s n dialog box.

For more information, see “Customizing the Roughness Coefficient Tables” earlier in this chapter. The Manning’s n data is stored in a file called mann.cof, located in the \pipewks folder for the current project. When you create a new project, the mann.cof file is copied from a sample default file in the c:\Program Files\Land Desktop R2\land\prot\pipewks program folder. You can use an ASCII text editor to modify this data file as necessary.

2. Use the Description field to type the pipe material description.

3. Use the Coefficient field to type the Manning’s n roughness coefficient value for the pipe material.

Use the / \ button to move the cursor up one row, the \ / button to move the cursor down one row, the PgUp button to move the cursor up one page, and the PgDn button to move the cursor down one page. Use the Home button to move the cursor to the first cell, the End button to move the cursor to the last cell, and the Delete button to delete the row for the current cell.

By entering data for a new row and clicking OK, the new row is saved. Also, if you change a value and click OK, the mann.cof file is updated with the new information.
Using the Hazen-Williams Formula

Use the Hazen Coefficient dialog box to enter a description and an associated Hazen-Williams pipe coefficient value. These values are used by the Pipes Run Editor when calculating flow and sizing pipes.

To use the Hazen coefficient dialog box

1. From the Select Coefficient Table dialog box, click Hazen-Williams Coefficient to display the Hazen Coefficient dialog box.

<table>
<thead>
<tr>
<th>Description</th>
<th>Coefficient</th>
</tr>
</thead>
<tbody>
<tr>
<td>Straight and Smooth Pipes</td>
<td>140.00000000</td>
</tr>
<tr>
<td>Very Smooth Pipes</td>
<td>130.00000000</td>
</tr>
<tr>
<td>Smooth Wood</td>
<td>120.00000000</td>
</tr>
<tr>
<td>Smooth Masonry</td>
<td>120.00000000</td>
</tr>
<tr>
<td>New Plated Steel</td>
<td>110.00000000</td>
</tr>
<tr>
<td>Vltile Clay</td>
<td>110.00000000</td>
</tr>
<tr>
<td>Old Cast Iron</td>
<td>100.00000000</td>
</tr>
<tr>
<td>Ordinary Brick</td>
<td>100.00000000</td>
</tr>
</tbody>
</table>

For more information, see “Customizing the Roughness Coefficient Tables” earlier in this chapter. The Hazen-Williams coefficient data is stored in a file called hazen.cof, located in the \pipewks folder for the current project. When you create a new project the hazen.cof file is copied from a sample default file in the c:\\Program Files\\Land Desktop R2\\land\\prot\\pipewks\\ program folder. You can use an ASCII text editor to modify this data file as necessary.

2. Use the Description field to type the description for the pipe material.

3. Use the Coefficient field to type the Hazen-Williams roughness coefficient value for the pipe material.

Use the \ button to move the cursor up one row, the / button to move the cursor down one row, the PgUp button to move the cursor up one page, and the PgDn button to move the cursor down one page. Use the Home button to move the cursor to the first cell, the End button to move the cursor to the last cell, and the Delete button to delete the row for the current cell.

By entering data for a new row and clicking OK, the new row is saved. Also, if you change a value and click OK, the hazen.cof file is updated with the new information.
Using the Darcy-Weisbach Formula

Use the Darcy Friction Factor dialog box to enter a description and an associated Darcy-Weisbach friction factor. These values are used by the Pipes Run Editor when calculating flow and sizing pipes.

To use the Darcy Friction Factor dialog box

1. From the Select Coefficient Table dialog box, click Darcy-Weisbach Friction Factor to display the Darcy Friction Factor dialog box.

   ![Darcy Friction Factor Dialog Box]

   For more information, see “Customizing the Roughness Coefficient Tables” earlier in this Chapter. The Darcy-Weisbach friction factors data is stored in a file called darcy.cof, located in the \pipewks folder for the current project. When a new project is created, the darcy.cof file is copied from a sample default file in the c:\Program Files\Land Desktop R2\land\prot\pipewks program folder. You can use an ASCII text editor to modify this data file as necessary.

2. Use the Description field to type the description of the pipe material.

3. Use the Coefficient field to type the Darcy-Weisbach friction factor for the pipe material.

   Use the / button to move the cursor up one cell, the \ button to move the cursor down one cell, the PgUp button to move the cursor up one page, and the PgDn button to move the cursor down one page. Use the Home button to move the cursor to the first cell, the End button to move the cursor to the last cell, and the Delete button to delete the row for the current cell.

   By entering data for a new row and clicking OK, the new row is saved. Also, if you change a value and click OK, the darcy.cof file is updated with the new information.
Changing the Exaggeration Factor Settings for Pipes and Nodes

Use the options in the Nodes and Pipes – Plan Exaggeration Factor dialog box to enlarge plotted details to ensure easy readability, especially on drawings that have large scales (for example, 50 ft/in) and pipe sizes with actual dimensions (for example, 8 in).

To change the exaggeration factor settings for pipes and nodes

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.
2. In the Node and Pipe Data Values section, click Scale Exaggeration to display the Nodes and Pipes - Plan Exaggeration Factor dialog box.

The File label displays the folder path and filename for the currently loaded Pipes settings file. The Current Drawing Scale label displays the current drawing scale.

The plan exaggeration factor concept works in the following manner. In a plan view, the symbol for the node (structure) is exaggerated, as is the pipe if it is plotted as a double line. In a profile view, the width of the lateral pipe ends are exaggerated. In a cross-section view, the width of the pipe section is exaggerated. For example, if a 40 ft/in scale drawing is assigned an exaggeration factor of 2, the node displays twice the size specified in the database and the pipes twice the specified diameter.

3. Set the plan exaggeration factor for the finished draft of specific features:

<table>
<thead>
<tr>
<th>Use the following option...</th>
<th>For drawings scaled...</th>
</tr>
</thead>
<tbody>
<tr>
<td>for drawings Scaled 01 to 20</td>
<td>between 1 and 20.</td>
</tr>
<tr>
<td>for drawings Scaled 21 to 40</td>
<td>between 21 and 40.</td>
</tr>
<tr>
<td>for drawings Scaled 41 to 80</td>
<td>between 41 and 80.</td>
</tr>
<tr>
<td>for drawings Scaled 81 to...</td>
<td>over 81.</td>
</tr>
</tbody>
</table>
4 Click OK to accept the plan exaggeration factor(s) and exit the Nodes and Pipes – Plan Exaggeration Factor dialog box.
5 Click OK to exit the Pipes Settings Editor dialog box.

### Changing the Pipe Run Editor Settings from the Settings Dialog Box

Use the Pipes - Run Editor Settings dialog box to establish settings for flow calculations, pipe roughness formula, pipe capacity, pipe length types, and hydraulic and energy grade line calculations.

**To change the pipe run editor settings**

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.
2. In the Editors section, click the Run Editor button to display the Pipes - Run Editor Settings dialog box.

![Pipes - Run Editor Settings](image)

The Calculate section has three options: Upstream to downstream, Downstream to upstream, and None.

3. Do one of the following:
   - Select Upstream to downstream to specify that pipe calculations are made from upstream to downstream.
   - Select Downstream to upstream to specify that pipe calculations are made from downstream to upstream.
   - Select None to turn off pipe calculations.
4 Under Calculate, do one of the following to control the sizing for each pipe run created:
   ■ Select the Automatic Pipe Resizing check box to resize the pipes each time calculations are performed.
   ■ Clear the Automatic Pipe Resizing check box to keep the size of the pipes the same. You can manually enter a pipe diameter for each pipe separately.

5 In the Design Settings section, use the Formula list to select one of three formula options: Manning, Hazen-Williams, and Darcy-Weisbach.

6 In the Design Point (% Full) text box, type a design point value or use the slide box to adjust the value.

7 In the Pipe Length Calculation Settings section, use the Length type list to select one of four pipe structure-to-structure length options: Top, Center, Bottom, and Maximum.

8 In the Hydraulic/Energy Grade Lines section, select the HGL/EGL Calculations check box to calculate hydraulic and energy grade line elevations simultaneously with all other pipe run calculations.

   NOTE In the Pipes HGL calculations, all of the junction loss calculations are based on the velocity calculated, assuming all pipes are flowing full.

9 In the Peak Factor Adjustment section, type the Peak Factor Adjustment value in the Peak Factor text box.

10 Click Range Set to display the Range Check Settings dialog box.

![Range Check Settings dialog box](image-url)
Establish the range check settings by selecting the Velocity Check, Slope Check, or Cover Check check boxes, then enter your new values in the Minimum and Maximum fields below the selected check boxes.

In the Cover section, select either Perpendicular to Pipe or Vertical to verify whether pipe cover is measured perpendicular to the pipe or vertically.

Click OK to exit the dialog boxes.

Changing the Range Check Settings for Pipes

Use the Range Check Settings dialog box to set minimum and maximum values for pipe flow velocity, pipe slope, and pipe cover. This dialog box also has a Cover section, with options to verify whether pipe cover is measured perpendicular or vertical to the pipe.

To change the range check settings for pipes

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.
2. In the Editors section, click the Run Editor button to display the Pipes– Run Editor Settings dialog box.
3. Click Range Set to display the Range Check Settings dialog box.
4 Select the Velocity Check, Slope Check, or Cover Check check boxes, then enter your new values in the Minimum and Maximum fields below the selected check boxes:

- **Velocity Check**: You can enter the minimum and maximum flow velocity for an individual pipe. If the pipe flow velocity falls out of this range, an error message is displayed in the Pipes Run Editor.

- **Slope Check**: You can enter the minimum and maximum pipe slope for an individual pipe. If the pipe slope falls out of this range, an error message is displayed in the Pipes Run Editor.

- **Cover Check**: You can enter the minimum and maximum cover depth for an individual pipe. If the cover depth falls out of this range, an error message is displayed in the Pipes Run Editor.
  
  Cover depth is the amount of fill material covering the pipe. To measure the fill material, select either the Perpendicular to Pipe or Vertical radio button in the Cover section of the Range Check Settings dialog box.

5 Click the OK buttons to exit the dialog boxes.

### Changing the Default Settings for Defining New Pipe Runs

The Settings ➤ Edit command displays a series of Pipes Settings dialog boxes. You can use these dialog boxes to edit an array of Pipes settings, including the default settings for pipe and node data.

### Changing the Default Pipe Data Settings

The pipe data settings are used as the initial values for pipes when defining a new pipe run.

**To change the default pipe data settings**

1 From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.

2 In the Node and Pipe Data Values section, click Pipe to display the Pipe Data Settings dialog box.
The File label displays the folder path and filename for the currently loaded Pipes settings file.

3 In the Pipe Diameter box, set the default size of the pipe to be used when defining a new pipe run.

To open a list of defined pipe sizes, click Select. When you click this button, the Pipe Slope Control dialog box is displayed. You can use this dialog box to select the pipe size from a defined list. For more information, see “Using the Pipe Slope Control Editor.”

4 In the Pipe Name box, type the descriptive label for the pipe.

5 In the Formula list, select either Manning, Hazen-Williams, or Darcy-Weisbach.

6 In the Pipe Material box, type the pipe material label.

To open a list of pipe materials, click Select to open either the Manning’s n, Hazen Coefficient, or Darcy Friction Factor dialog box. Use one of these dialog boxes to select the pipe material from a defined list. For more information on formula selection and pipe coefficient factors, see “Use the Coefficient Editor.”

7 In the Invert In depth below Rim box, type the depth of the invert coming into a structure below its rim.

Type this value using the current drawing units. The precision of this field is based on the precision set for the labeling plan and profile rim elevations.

8 In the Invert Out depth below Rim box, type the depth of the invert going out of a structure below its rim.

Type this value using the current drawing units.

**NOTE** The invert in and out depth values are used to calculate initial inverts for new pipe runs. Once defined, you can use the data editor or graphic editor to modify the invert elevations and slopes.

9 Click OK to exit the dialog box.
Changing the Default Node Data Settings

The Node Data Settings are used as the initial values for nodes (structures) when defining a new pipe run.

To change the default node data settings

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.
2. In the Node and Pipe Data Values section, click Node to display the Node Data Settings dialog box.

![Node Data Settings dialog box]

The File label displays the folder path and filename for the currently loaded Pipes settings file. The Setting Node Data section has options for establishing the structure settings.

3. In the Node Label text box, type the node label.
   This label is assigned to pipe run nodes in the database when a pipe run is created.
4. In the Structure Reference…Description section, select the structure to use from the list.
   Under Description, an associated description also displays to the right of the list.
   The structure reference is used for plotting the node in plan and profile views.
5. In the Node Head Losses section, type values in the In and Out edit boxes.
   Use these edit boxes to set the values for the minor head losses going into and out of the structure, respectively.
6. Click OK to exit the command.
Changing the Layer Settings for Pipes

The Settings ➤ Edit command displays the Pipes Settings Editor dialog box. Click the Plan button to display the Plan Layer Settings dialog box. In this dialog box, you can specify the overall layer prefix, conceptual plan layer, finish plan layer, and finish plan text layer.

Changing the Plan Layer Settings for Pipes

Use the Plan Layer Settings dialog box to specify the overall layer prefix, conceptual plan layer, finish plan layer, and finish plan text layer.

To change the plan layer settings for pipes

1 From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.
2 In the Layer Data section, click Plan to display the Plan Layer Settings dialog box.

The File label displays the folder path and filename for the currently loaded Pipes settings file.

3 To use a layer prefix, type it in the Layer Prefix box.

Entering an asterisk (*) automatically specifies the current run name as the prefix; this is the recommended procedure. If you do not use an asterisk as the layer prefix, runs could end up being drawn on the same layers, which could then inadvertently erase pipe run data.

NOTE Using the Import Run (Conceptual Plan), Import Run (Conceptual Profile), Delete (Conceptual Plan), or Delete (Conceptual Profile) command erases pipe run plan and profile information by layers. Specify layer names that differ from those set in this dialog box to retain pipe run plan and profile information that you want to keep.

4 In the Conceptual Plan Layer box, type the layer name for all plan figures.

These figures include all figures defined using commands that define a pipe run.
Using the Draw Pipes (Finished Draft Plan) command in the Finish Plan Layer box, type the layer name for all nodes and pipes that are imported.

5 Using the Draw Pipes (Finished Draft Plan) command in the Finish Plan Text Layer box, type the layer name for the text labels that are imported.

6 Click OK to exit the dialog box.

Changing the Profile Layer Settings for Pipes

Use the Profile Layer Settings dialog box to specify the overall layer prefix, conceptual profile layer, finish profile layer, and finish profile text layer.

To change the profile layer settings for pipes

1 From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.

2 In the Layer Data section, click Profile to display the Profile Layer Settings dialog box.

The File label displays the folder path and filename for the currently loaded Pipes settings file.

3 To use a layer prefix, type it in the Layer Prefix box.

Entering an asterisk (*) automatically specifies the current run name as the prefix; this is the recommended procedure. If you do not use an asterisk as the layer prefix, then all runs could end up being drawn on the same layers, which could result in the inadvertent erasure of pipe run data.

**NOTE** Using the Import Run (Conceptual Plan), Import Run (Conceptual Profile), Delete (Conceptual Plan), or Delete (Conceptual Profile) command erases pipe run plan and profile information by layers. Specify layer names that differ from those set in this dialog box to retain pipe run plan and profile information that you want to keep.

4 In the Conceptual Profile Layer box, type the layer name for all profile figures. These include all figures defined using commands that define a pipe run.
In the Finish Profile Layer box, type the layer name for the finish draft layer for all nodes and pipes that are imported using the Draw Pipes (Finished Draft Profile) command.

In the Finish Profile Text Layer box, type the layer name for the text labels that are imported using the Draw Pipes (Finished Draft Profile) command.

In the Hydraulic and Energy Gradeline Layer box, type the hydraulic gradeline layer name for the hydraulic and energy gradelines. These gradelines are drawn using the Hydraulic Gradeline and Energy Gradeline commands.

Click OK to exit the dialog box.

**Changing the Cross Section Layer Settings for Pipes**

Use the Cross Section Layer Settings dialog box to specify the overall layer prefix and cross section layer for pipes.

**To change the cross section layer settings for pipes**

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.
2. In the Layer Data section, click X-Section to display the Cross Section Layer Settings dialog box.

![Cross Section Layer Settings](image)

The File label displays the folder path and filename for the currently loaded Pipes settings file.

3. To use a layer prefix, type it in the Layer Prefix box.
   Entering an asterisk (*) automatically specifies the current run name as the prefix; this is the recommended procedure. If you do not use an asterisk as the layer prefix, all runs could end up being drawn on the same layers, which could then inadvertently erase pipe run data.

4. In the Cross Section Layer box, type the layer name for all pipes plotted on cross sections created using the Draw Pipes (Finished Draft Sections) command.

5. Click OK to exit the dialog box.
Changing the Label Settings for Finished Draft Pipes

The Settings ➤ Edit command displays the Pipes Settings Editor dialog box. Under Pipes Drafting Labels, you click Plan to display the Plan Pipe Drafting Settings dialog box. Use this dialog box to set the finish draft plan pipe settings. These settings are used by the Draw Pipes (Finish Draft Plan) command to label finish draft pipe runs with size, slope, material, and length information.

Changing the Label Settings for Finished Draft Pipes in Plan View

Use the Plan Pipe Drafting Settings dialog box to set the finish draft plan pipe settings. The Draw Pipes (Finish Draft Plan) command uses these settings to label finish draft pipe runs with size, slope, material, and length information.

To change the label settings for finished draft pipes in plan view

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.
2. In the Pipes Drafting Labels section, click Plan to display the Plan Pipe Drafting Settings dialog box.

![Plan Pipe Drafting Settings](image)

The File label displays the folder path and filename for the currently loaded Pipes settings file.

Use the options in this dialog box to set the settings for label placement in plan view. To label the finished draft pipe run, select the appropriate label check box.
for each item you want to label. These labels are automatically placed in the
finished draft pipe run when you create it.

3 Use the Pipe Label Position list to select the pipe label position. The available
label positions are: No Label, Above, Below, Middle, and Stacked.

4 Use the Line Type list to select the line types for drawing pipes in plan view.
The available line types are: Single Line, Single Line w/ Text, Double Line,
Double Line w/Text, Polyline, and Polyline w/Text.

When you select the Single Line, Double Line, and Polyline line types, the Line
Text box is unavailable, indicating you do not have the option to enter text.

When you select the Single Line w/Text, Double Line w/Text, and Polyline
w/Text line types, enter the accompanying text in the Line Text text box.

5 Select the Label slope in % check box to multiply the calculated slope value by
100 in order to label the slope as a percentage.

When this check box is cleared, the slope is labeled with a unit/unit
designation, usually ft/ft or m/m.

6 Select the Size check box to place pipe size labels in the finished draft, and then
specify the following settings:

■ In the Prefix box, enter the prefix for the pipe size label.
■ In the Suffix box, enter the suffix for the pipe size label.
■ Use the Precision slide box to set the precision for the pipe size label.

The value is used in conjunction with the PIPE_DIM field in the Pipeworks
database.

NOTE When entering a prefix or suffix, you can include a space to separate the
prefix and suffix from the value.

7 Select the Slope check box to place pipe slope labels in the finished draft, and
then do the following:

■ In the Prefix box, type the prefix for the pipe slope label.
■ In the Suffix box, type the suffix for the pipe slope label.
■ Use the Precision slide box to set the numerical precision value for the pipe
slope label.

The unit of measure for the slope label is m/m in metric units and ft/ft in
English units. You can also label the slope as a percentage.

8 Select the Material check box to place pipe material labels in the finished draft, and
then do the following:

■ In the Prefix box, type the prefix for the pipe material label.
■ In the Suffix box, type the suffix for the pipe material label.

9 Select the Label check box to place descriptive name labels for the pipe in the
finished draft, and then do the following:

■ In the Prefix box, type the prefix for the descriptive pipe label.
■ In the Suffix box, type the suffix for the descriptive pipe label.

10 Select the Arrow check box to place a flow direction arrow on the pipe run.
Select the Length check box to place pipe length labels in the finished draft, and then do the following:

- In the Prefix box, type the prefix for the pipe length label.
- In the Suffix box, type the suffix for the pipe length label.
- Use the Precision slide box to set the numerical precision value for the pipe length label.

Click OK to exit the Plan Pipe Drafting Settings dialog box.

Changing the Label Settings for Finished Draft Pipes in Profile View

The Draw Pipes (Finish Draft Profile) command uses the Label settings to label pipe runs with size, slope, material, and length information.

To change the label settings for finished draft pipes in profile view

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor.
2. In the Pipes Drafting Labels section, click Profile to open the Profile Pipe Drafting Settings dialog box.

Use the options in this dialog box to set the settings for label placement in the profile view. To label the finished draft pipe run, select the appropriate label check box for each item you want to label. These labels are automatically placed in the finished draft pipe run when you create it.

3. From the Pipe Label Position list, select the pipe label position to use. The label positions that are available are as follows: Above, Below, Middle, Stacked, and No Label.
4 To multiply the calculated slope value by 100 in order to label the slope as a percentage, select the Label slope in % check box. When cleared, the slope is labeled with a unit/unit designation, usually ft/ft or m/m.

5 To place pipe size labels in the finished draft, select the Size check box, and then specify the following:
   - In the Prefix box, type the prefix for the pipe size label.
   - In the Suffix box, type the suffix for the pipe size label.
   - Use the Precision slide box to set the numerical precision value for the pipe size label.

   The value is used in conjunction with the PIPE_DIM field in the Pipeworks database.

   **NOTE** When entering a prefix or suffix, you may include a space to separate the prefix and suffix from the value.

6 To control the placement of the pipe slope labels, select the Slope check box, and then do the following:
   - In the Prefix box, type the prefix for the pipe slope label.
   - In the Suffix box, type the suffix for the pipe slope label.
   - Use the Precision slide box to set the numerical precision value for the pipe slope label.

   The unit of measure for the slope label is m/m in metric units and ft/ft in English units. In addition, the slope can be labeled as a percentage.

7 To place pipe material labels in the finished draft, select the Material check box, and then do the following:
   - In the Prefix box, type the prefix for the pipe material label.
   - In the Suffix box, type the suffix for the pipe material label.

8 To place descriptive name labels for the pipe in the finished draft, select the Label check box, and then specify the following:
   - In the Prefix box, type the prefix for the descriptive pipe label.
   - In the Suffix box, type the suffix for the descriptive pipe label.

9 To place a flow direction arrow on the pipe run, select the Arrow check box.

10 To place pipe length labels in the finished draft, select the Length check box, and then do the following:
   - In the Prefix box, type the prefix for the pipe length label.
   - In the Suffix box, type the suffix for the pipe length label.
   - Use the Precision slide box to set the numerical precision value for the pipe length label.

11 Click OK to exit the command.
Changing the Label Settings for Finished Draft Nodes

You can label finished draft nodes with station and offset information, as well as pipe, sump, and rim elevational information. To change the label settings, use the Pipes Settings Editor to open the Pipes – Plan Node Label Settings dialog box.

Changing the Label Settings for Finished Draft Nodes in Plan View

In the Pipes - Plan Node Label Settings dialog box, you can label nodes with station and offset information, as well as pipe, sump, and rim elevational information.

To change the label settings for finished draft nodes in plan view

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.

2. In the Node Drafting Labels section, click Plan to open the Pipes - Plan Node Label Settings dialog box.
To place station labels for the finished plan structure in the finished draft based on the current alignment, select the Station check box and do the following:

- In the Prefix box, type the prefix for the plan structure label.
- In the Suffix box, type the suffix for the plan structure label.
- Use the Precision slide box to set the precision value for the plan structure label.

**NOTE** When entering a prefix or suffix, you can include a space to separate the prefix and suffix from the value.

In the Offsets section, select the Right or Left check box to place right or left perpendicular offset labels in the finished draft, and then do the following:

- In the Prefix box, type the prefix for the right or left perpendicular offset label for the current alignment.
- In the Suffix box, type the suffix for the right or left perpendicular offset label for the current alignment.
- Use the Precision slide box to set the precision value for both the right and left offset label.

Use the options to control the placement of the pipe, sump, and rim elevation labels.

**NOTE** These settings are used in conjunction with the station value, which is recalculated each time a run is labeled.

In the Elevations section, select the Pipe check box to place invert (in and out) pipe structure elevation labels in the finished draft, and then do the following:

- In the Prefix box, type the prefix for the profile pipe structure elevation label.
- In the Suffix box, type the suffix for the profile pipe structure elevation label.
- Use the Precision slide box to set the precision value for the profile pipe structure elevation label.
- In the Elev. In box, type the text for the invert in labels.
- In the Elev. Out box, type the text for the invert out labels.

To place sump elevation labels in the finished draft, select the Sump check box, and then do the following:

- In the Prefix box, type the prefix for the sump elevation label.
- In the Suffix box, type the suffix for the sump elevation label.
- Use the Precision slide box to set the precision value for the sump elevation label.

To place rim elevation labels in the finished draft, select the Rim check box, and then do the following:

- In the Prefix box, type the prefix for the rim elevation label.
- In the Suffix box, type the suffix for the rim elevation label.
- Use the Precision slide box to set the precision value for the rim elevation label.

Use the options to control the placement of the prefix and suffix for the node name label.
In the Node Name section, select the Label check box to place structure name labels in the finished draft, and then do the following:

- In the Prefix box, type the prefix for the structure name label.
- In the Suffix box, type the suffix for the structure name label.

Click OK to exit the command.

---

Changing the Label Settings for Finished Draft Nodes in Profile View

You can use the Pipes - Plan Node Label Settings to label nodes with station and offset information, as well as pipe, sump, and rim elevational information.

To change the label settings for finished draft nodes in profile view

1. From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor.
2. In the Node Drafting Labels section, click Profile to open the Pipes - Profile Node Label Settings dialog box.

---

![Pipes - Profile Node Label Settings](image)
3 Select the Station check box to place station labels for the finished profile structure, based on the current alignment, in the finished draft, and then do the following:
   - In the Prefix box, type the prefix for the profile structure label.
   - In the Suffix box, type the suffix for the profile structure label.
   - Use the Precision slide box to set the precision value for the profile structure.

   **NOTE** When entering a prefix or suffix, you can include a space to separate the prefix and suffix from the value.

4 In the Offsets section, do the following tasks to control the placement of left and right perpendicular offset labels for the current alignment:
   - Select Right to place right perpendicular offset labels for the current alignment in the finished draft.
   - In the Prefix box, type the prefix for the right perpendicular offset label for the current alignment.
   - In the Suffix box, type the suffix for the right perpendicular offset label for the current alignment.
   - Use the Precision slide box to set the precision value for both the right and left offset label.
   - Select Left to place left perpendicular offset labels for the current alignment in the finished draft.
   - In the Prefix box, type the prefix for the left perpendicular offset label of the current alignment.
   - In the Suffix box, type the suffix for the left perpendicular offset label of the current alignment.
   - Use the Precision slide box to set the precision value for both the right and left offset.

5 In the Elevations section, do the following tasks to control the placement of the pipe, sump, and rim elevation labels:
   - Select Pipe to place the invert (in and out) pipe structure elevation labels in the finished draft.
   - In the Prefix box, type the prefix for the profile pipe structure elevation label.
   - In the Suffix box, type the suffix for the profile pipe structure elevation label.
   - Use the Precision slide box to set the precision value for the profile pipe structure elevation label.
   - In the Elev. In box, type the label for the invert in labels.
   - In the Elev. Out box, type the label for the invert out labels.

   These settings are used in conjunction with the station value, which is recalculated each time a run is labeled.

6 Select the Sump check box to place sump elevation labels in the finished draft, and then do the following:
   - In the Prefix box, type the prefix for the sump elevation label.
   - In the Suffix box, type the suffix for the sump elevation label.
   - Use the Precision slide box to set the precision value for the sump elevation label.
7 Select the Rim check box to place rim elevation labels in the finished draft, and then do the following:
- In the Prefix box, type the prefix for the rim elevation label.
- In the Suffix box, type the suffix for the rim elevation label.
- Use the Precision slide box to set the precision value for the rim elevation label.

8 In the Node Name section, do the following tasks to control the placement of the prefix and suffix for the node name label:
- Select Label to place structure name labels in the finished draft.
- In the Prefix box, type the prefix for the structure name label.
- In the Suffix box, type the suffix for the structure name label.

9 In the Text Grouping list, set the profile node structure labeling position.
   The following positions are available: Vertical above, Vertical below, Horizontal above right, Horizontal below right, Horizontal above left, and Horizontal below left.
   The node structure text is placed as described, assuming the node structure is defined as displaying in the profile. For more information, see the following section, “Creating and Editing Node Symbols.”

10 When you have finished modifying the settings, click OK to exit the dialog box.

**Creating and Editing Node Symbols**

To create and edit node symbols

1 From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.
2 In the Structure Library section, click Structure Library Editor to display the Structure Library Editor dialog box.
You can use this dialog box to modify structures or create new ones to be used when nodes are drafted in the finish profile. The structure definitions are stored in the bldcor.pst and blkdef.pst files, located in the c:\Program Files\Land Desktop R2\land\prot\pipewks folder. You can define structures only through this dialog box.

3 Click Add to display the Structure Library Entity dialog box, in which you can add a new structure to the current structure library.

4 In the Enter Entity Name box, enter an entity name, and then click OK. You can also select an existing name from the Name list in the Library Reference section and make changes to it.

A copy of the current structure library entity is made, and the Structure Library Entity dialog box is displayed.

5 In the Library Reference section, set the names and descriptions of various structure library symbols that have been defined by doing the following:

- In the Name list, select the structures for representing the defined run nodes.
- In the Description box, type a brief description of the structure in the structure library.

Two special structures are available: null and null2. There are a number of conditions in which you could specify one of these null structures. The first is when you want no structure drawn at all. The second is when you need to eliminate overlapping structures—when a lateral joins an existing pipe run, for example. The third occurs when drawing a pipe run with a bend, or a multi-segment portion of a pipe run rounding a corner, where it is unnecessary to have a manhole at the end of each segment.

Specifying the null structure results in no structure being drawn in either plan or profile view, while the null2 structure is drawn on the profile but not the
Changing the Label Settings for Finished Draft Nodes

plan view. For more information on the appearance and configuration of structures in plan and profile views, see the commands on the Finished Draft Plan and Finished Draft Profile cascading menus.

**NOTE** When modifying structures or creating new ones, remember to click Save at the bottom of the Structure Library Editor dialog box to retain the changes.

6 In the Plan section, select the Symbol check box to place a symbol (block) in the plan view of the finished run, and then type the name of the symbol in the associated edit box.

You can use any defined block that has a diameter of one unit and is stored in the \Program Files\Land Desktop R2\land\dwg subfolder.

7 In the Profile section, you can customize the symbol to be placed in the finished draft of the pipe run profile by doing any of the following:
   - Select the Symbol check box to place a specific symbol type in the finished run profile.
   - Select a symbol shape from the list: Rectangular, Flared, Cone, Gutter, or Pipe end.
   - In the Rim box, type the rim width for the selected symbol.
   - In the Sump box, type the sump depth and width values.
     If you use a rectangular shaped symbol, the rim width is also used as the sump width and the Sump Width text box is unavailable.
   - In the Flare box, type the flare depth value for the Flared symbol.
   - In the Drain box, type the drain depth value for the Gutter symbol.

You can now make changes to the entity to customize it.

8 Click Save to retain any changes made to the entity, or click Delete to delete the current structure from the structure library.

If this is a new entity, then clicking Save saves it to the Pipeworks database.

9 Click OK to exit the dialog boxes.

**Choosing a Text Editor in Which to Display Pipe Data**

To choose a text editor in which to display pipe data

1 From the Pipes menu, choose Settings ➤ Edit to display the Pipes Settings Editor dialog box.

2 In the Editors section, click Text Editor to display the Editor Settings dialog box.

3 In the Editor box, type an appropriate text editor name.

You can also click Browse to display the Select Text Editor dialog box and locate the text editor that you want to use.
4 Click OK to exit the dialog boxes.

**Importing, Exporting, Resetting, and Auditing Pipe Settings**

To save custom pipes settings to external files and load them into other drawings, use the Export DFM File and Import DFM File commands.

After you have selected the pipe settings you want, use the Reset command to reset the Pipes Settings file (.dfm) to the original values when the program is installed. You can then search the drawing for all Pipeworks entities with attached extended entity data (EED) and check for an associated pipe run in the database.

Next, you can use the Audit command to search the drawing for all Pipeworks entities with attached EED and check for an associated pipe run in the database. EED is removed from entities that are not associated with a pipe run.

**Export a Pipes DFM File**

You can use the Export DFM File command to export the current pipe settings (as defined with the Settings ➤ Edit command) to a .dfm file. You can load this file into other drawings to restore the settings you saved. For example, you can save a .dfm file that contains settings for metric projects, and a file that contains settings for imperial (English) projects.

This command copies the pipes settings that exist in the current drawing's <drawing name>.dfm file to a new .dfm file. When you import this new .dfm file into another drawing, the settings are copied into that drawing's <drawing name>.dfm file.

**To export a pipes DFM file**

1 Use the Pipes ➤ Settings ➤ Edit command to configure the settings to export.
2 From the Pipes menu, choose Settings ➤ Export DFM File to display the Pipes Settings Files dialog box.
   This dialog box defaults to the current project's Pipeworks folder. The file name defaults to pipewks.dfm.
3 Accept the defaults or specify a different destination folder and/or name.
4 Click Save to save the .dfm file.

**Import a Pipes DFM File**

You can use the Import DFM File command to import a saved pipes .dfm file (a file which contains the pipes settings as defined with the Pipes ➤ Settings ➤ Edit command) into the current drawing. To do this you must first use the Export DFM File command to export the pipes settings to a file.
To import a pipes .dfm file
1. From the Pipes menu, choose Settings ➔ Import DFM File. A warning dialog box is displayed informing you that by loading settings from a .dfm file, the current settings will be lost.
2. Click Yes to continue.
3. Locate the .dfm file you want to import.
4. Click Open to import the file.

**Resetting the Pipes Settings to Their Original Values**

Use the Reset command to reset the Pipes Settings file (.dfm) to the original values when the program was installed.

**To reset the pipes settings to their original values**
1. From the Pipes menu, choose Settings ➔ Reset to display the Pipes Message dialog box.
2. Click Yes to reset the Pipes Settings file.

**Auditing the Pipe Database**

Use the Audit command to search the drawing for all Pipeworks entities with attached extended entity data (EED) and check for an associated pipe run in the database. EED is removed from entities that are not associated with a pipe run.

**To audit the pipe database**
1. From the Pipes menu, choose Settings ➔ Audit to display the Pipes Message dialog box.
2. Click Yes to remove EED from entities that are not associated with a pipe run in the database.

**Drawing and Defining Conceptual Pipe Runs**

Conceptual pipe runs are single line representations of plan and profile view pipe runs. They serve as quick sketches of pipe run configurations, which you can use to check a particular pipe run for proper position and location.

The following illustration shows a conceptual pipe run:

Conceptual pipe run

Drawing and Defining Conceptual Pipe Runs
**Drawing and Defining Pipe Runs**

The first step in drawing and defining a pipe run is to use the Draw Pipe Run command to locate the starting and ending points of individual pipe run segments. You can draw pipe runs in two ways: by station and offset from a defined horizontal alignment, or by manually selecting points.

You are prompted for a method for determining rim elevations. You can either use elevations from a surface or you enter these elevations manually.

**To draw and define pipe runs**

1. From the Pipes menu, choose Define Pipe Runs ➤ Draw Pipe Run. The following prompt is displayed:
   
   *Enter a new run name:*

2. Type a new pipe run name with a maximum of 30 characters. If defined surface files exist, then the Select Surface dialog box is displayed.

   If no surface is being used, then the rim elevations must be entered manually. You are prompted, one at a time, as the pipe run segments are drawn.

3. Continue with one of the following tasks:

   - Extract Rim elevations from a defined surface.
     
     For more information, see “Specifying the Elevation of Pipe Runs Using a Surface” in this chapter.
   
   - Manually input the rim elevations.

   For more information, see “Specifying the Elevation of Pipe Runs Manually” in this chapter.
Specifying the Elevation of Pipe Runs Using a Surface

To specify the elevation of pipe runs using a surface

1. From the Pipes menu, choose Set Current Surface to display the Select Surface dialog box.

2. Choose the appropriate surface, then click OK to continue. The Pipes dialog box is displayed.

3. Do one of the following:
   - Click On to use the current surface. The program uses the current surface to extract rim elevations for the pipe run at each node.
   - Click Off to not use the current surface.

Specifying the Elevation of Pipe Runs Manually

To specify the elevation of pipe runs manually

1. Complete steps 1–3 in the preceding section, “Specifying the Elevation of Pipe Runs Using a Surface.”

2. After you set the new pipe run name (and opened an appropriate surface, if necessary), the following prompt is displayed:
   eXit/Station/POint:
3 Type one of the following letters to draw the pipe run: by station and offset, or by point:
   - X for the eXit option, to end the Draw Pipe Run command without drawing the pipe run, and without saving any pipe run data.
   - S for the Station option, to draw the run based on a defined horizontal alignment by station and offset. You must set an existing defined horizontal alignment as current to use this option.
   - PO for the POint option, to draw the pipe run based on selected points, or manually enter Northing and Easting coordinates.
   - N to draw the pipe run by Northing and Easting coordinates.

4 Select an initial starting point for the pipe run:
   - If you select the Station option, enter a station and offset. If an alignment has not been set as current, you are prompted to select one.
   - If you selected the POint option, select a point.

   This starting point, now called the current pipe run node, is marked with an X, drawn with temporary vectors.

5 Type the rim elevation if no surface is available for elevation extraction.

   The following prompt is displayed:

   Move/eXit/Add:

6 Type one of the following to continue or end the pipe run:
   - M for the Move option, to relocate the current node. Enter either a new station and offset, or a selected point. The current station and offset are displayed as the default values.
   - X for the eXit option, to end the Draw Pipe Run command without drawing the pipe run or saving any pipe run data.
   - A for the Add option, to add the next node to the pipe run, using either a station and offset, or selecting another point.

   If you select the Add option, you are prompted for the next point. After you establish the second point in the pipe run, data for the pipe run name, length, and number of nodes is listed on the command line, reflecting the current status of the pipe run. The pipe run status is displayed each time another node is established in the pipe run.

   A further series of options are available when the next prompt is displayed:

   eXit/Next/Prev/Move/Delete/Undo/Save/Add <Add>:

7 Use these options to continue adding new points to the pipe run, to exit the command, or to move the current point. You can also type any of the following:
   - N for the Next option, to advance the X designating the current node in the pipe run to the next available node.
   - P for the Prev option, to move the X designating the current node in the pipe run back to the previous node.
- **M** for the Move option, to relocate the current node. Enter either a new station and offset, or a selected point. The current station and offset are displayed as the default values. Selecting this option displays the following prompt:

  `exit/station/point`:

- **D** for the DElete option, to remove the current node in the pipe run back to the previous node.

- **U** for the Undo option, to reverse any previous action taken in the pipe run drawing process, except for changes made to the node data in the Edit Table dialog box with the DBase option.

- **S** for the Save option, to save the pipe run data to the database. The Run Alignment Association dialog box is displayed.

```
Run Alignment Association

Run: drain
Current Alignment: None

- Use Current Alignment
- Create an Alignment from Run
- Use No Alignment
- Select an Existing Alignment

Alignment: [Select]

OK  Cancel
```

This dialog box lists the Run and the Current Alignment with which the pipe run is associated. There are four options listed: Use Current Alignment, Create an Alignment from Run, Use No Alignment, or Use an Existing Alignment.

- **A** for the Add option, to insert a new node ahead of the current node on the downstream side.

  8 Click Select, then do one of the following:

  - Select another existing alignment in the drawing.
  - Press ENTER to open the Alignment Librarian dialog box and choose an alignment from there.
  - Enter another existing alignment’s number.

  The new alignment should now display with the New Alignment label in the Run Alignment Association dialog box.

  9 Click OK to exit the dialog box.

  When you save the pipe run to the database, an additional option, Dbase, is added to the command line.

  Next/Prev/Move/Add/DElete/DBase/Undo/Save/exit <exit>:

To open the database, type **DB**. The Edit Run Node dialog box is displayed, depending on whether a pipe or node is current.
You can change values in this dialog box by highlighting the appropriate field, then entering the changes in the Edit text box. This editor is dynamically linked to the drawing. If you do make changes in the Edit Table dialog box, clicking OK results in the pipe run being redrawn to reflect those changes.

**Defining Polylines as Pipe Runs**

Use the Define By Polyline command to define a polyline as a pipe run, using the node and pipe data values set with the Edit command from the Settings menu. Before you can define the polylines as pipe runs, you must first confirm the following:

- A polyline must exist in the drawing for selection and definition as a pipe run.
- To retrieve surface elevations for node rim elevations, you must first set a current a surface with the Set Current Surface command.

**NOTE** If you selected a surface, the rim elevations are extracted from the surface. The pipe, invert, and conceptual sump elevations are automatically calculated based on the data settings established using the Edit (Settings) command.

To define polylines as pipe runs

1. From the Pipes menu, choose Define Pipe Runs ➤ Define By Polyline.
   The following prompt is displayed:
   **Select Polyline to define as a run:**

2. Select a point on the existing polyline.
   If a surface file exists, then the Select Surface dialog box is displayed and you can continue with step 3 below.
If you select a pipe run that you previously defined, then the Pipes Message dialog box is displayed with the default pipe run name (the same as the currently selected pipe run). To select previously defined pipe runs, click Yes to update the calculations, or No to cancel the command.

If the polyline vertices have changed, clicking Yes recalculates the invert elevations. If the polyline vertices have not changed, clicking Yes updates the data defaults.

3. Choose the appropriate surface, then click OK to continue.

The Pipes dialog box is displayed.

4. Do one of the following:
   - Click On to use the current surface. The rim elevations are extracted from the surface.
   - Click Off to not use the current surface.

5. At the next prompt, type a new run name.

You can now reverse the flow direction of the pipe run. By default, pipe runs defined by the Define By Polyline command are established with the flow in the direction the polyline was drawn. You should, therefore, draw the initial polyline starting from the upstream node. If you drew the polyline starting from the downstream node, the flow direction is reversed. If so, enter Yes at the Reverse Direction? prompt to correct the flow direction.

If a surface was specified, it is loaded now.
From the Run Alignment Association dialog box, select the alignment to use.

The new run name is listed at the top of the dialog box, along with the current associated alignment, which, by default, is None. At this step, you can do any of the following:

- Select the currently defined alignment in the drawing.
- Select another existing alignment.
- Create an alignment from the new pipe run.
- Use the default of None to not use any alignment.

Click OK to exit the dialog box.

Displaying the Conceptual Pipe Runs That Exist in a Drawing

The Display All Runs command highlights each run graphically, with arrows pointing in the direction of the flow for the pipe run.

To display the conceptual pipe runs that exist in a drawing

- From the Pipes menu, choose Display All Runs.
  - The following informational prompt is displayed:
    
    Displaying Conceptual runs found in drawing

    If the drawing has no conceptual pipe runs, then the following message is displayed:

    No Conceptual runs found in drawing
Checking for Defined Pipe Runs in a Drawing

To check for defined pipe runs in a drawing

1. From the Pipes menu, choose List Defined Runs to display the Defined Runs dialog box.

   ![Defined Runs Dialog Box]

   - Selection
     - Drain1
     - Upstr1

   - OK
   - Cancel
   - Help

2. In the Selection box, select a pipe run to set as current, then click OK to continue.

Identifying Pipe Runs in a Drawing

Use the Identify Run command to identify a selected pipe run in the drawing. When you select a run, a prompt displays its run, length, and number of nodes.

To identify pipe runs in a drawing

1. From the Pipes menu, choose Identify Run. The following prompt is displayed:

   Pick run:

2. Select a point on an existing pipe run.

   The following information is displayed:

   Run: {name}              length: {#}              nodes: {#}

   If the selected entity is not a pipe run, then the following message is displayed:

   Entity selected not attached to valid run.

Importing Conceptual Pipe Runs into a Drawing

You can import conceptual pipe runs into a plan or profile view.

Importing Conceptual Pipe Runs into Plan View

Use the Import Run command to import pipe runs from the database into the drawing.
To import conceptual pipe runs into plan view

1. From the Pipes menu, choose Conceptual Plan ➤ Import Run to display the Defined Runs dialog box.

2. From the Selection box, select the appropriate run, then click OK.

   The following informational prompt is displayed:
   
   Run: {name}              length: {#}              nodes: {#}

Importing Conceptual Pipe Runs into Profile View

Use the Import Run command to import pipe runs from the database into the drawing.

To import conceptual pipe runs into plan view

1. From the Pipes menu, choose Conceptual Profile ➤ Import Run to display the Defined Runs dialog box.

2. From the Selection box, select the appropriate run, and then click OK.

   The following informational prompt is displayed:
   
   Run: {name}              length: {#}              nodes: {#}
Associating Pipe Runs with Horizontal Alignments

Use the Change Run Alignment command to change an existing pipe run's alignment association.

To associate pipe runs with horizontal alignments

1. From the Pipes menu, choose Alignments ➤ Change Run Alignment.

   The following prompt is displayed:

   Pipe run:

2. Select the pipe run. Either graphically select the run, or press ENTER to open the Defined Runs dialog box and select the run, then click OK.

   The Run Alignment Association dialog box is displayed.

   ![Run Alignment Association dialog box]

   This dialog box lists the Run and the Current Alignment with which the pipe run is associated. Three options offer you the following options: Use Current Alignment, Use No Alignment, or Use an Existing Alignment.

3. Click Select, then do one of the following:

   - Select another existing alignment in the drawing.
   - Press ENTER to open the Alignment Librarian dialog box. Select an alignment.
   - Enter another existing alignment’s number.

   The new alignment should display with the New Alignment label in the Run Alignment Association dialog box.

4. Click OK to exit the dialog box.

Editing Conceptual Pipe Runs

Conceptual pipe runs are single line representations of plan and profile view pipe runs. They serve as quick sketches of pipe run configurations, which you can use to check a particular pipe run for proper position and location.

Drawing pipe runs is an iterative process. You must examine the layout and location of the pipe run to ensure that it meets the design requirements of the...
sewer district. Where the run does not meet those requirements, you need to edit the run before continuing with the design of your sanitary sewer system. The following illustration shows conceptual pipe run in plan view:

Conceptual pipe run in plan view

**Editing Conceptual Pipe Runs in Plan View**

To edit conceptual pipe runs in plan view

1. From the Pipes menu, choose Conceptual Plan ➤ Edit Graphical.

   The following prompt is displayed:
   
   Select run to edit:

2. Select a point on the pipe run near the node to be edited.

   An X, drawn with temporary vectors, marks the node nearest to the selection point. The following options are now available:

   Next/Prev /DElete /DBase /Undo /Save /Add /Move /eXit <eXit>:

   If an option that requires a rim elevation is selected, such as Move, then a dialog box is displayed prompting you to turn on the current surface.

3. Type any of the following:
   - N for the Next option, to advance the X designating the current node in the pipe run to the next available node.
   - P for the Prev option, to move the X designating the current node in the pipe run back to the previous node.
   - D for the DElete option, to remove the current node in the pipe run back to the previous node.
   - DB for the DBase option, to display the Edit Run Node dialog box, depending on whether a pipe or node is current. You can change values in this dialog box by highlighting the appropriate field, then entering the changes in the Edit text box. This editor is dynamically linked to the drawing. If you make changes in the Edit Table dialog box, then clicking OK results in the pipe run being redrawn to reflect those changes.
   - U for the Undo option, to reverse any previous action taken in the pipe run drawing process, except for changes made to the node data in the Edit Table dialog box with the DBase option.
   - S for the Save option, to save the pipe run data to the database. The Run Alignment Association dialog box is displayed. This dialog box lists the Run and the Current Alignment with which the pipe run is associated. There are
Editing Conceptual Plan Pipe Runs Using the Pipe Run Editor

Use the Edit Data (Conceptual Plan) command to open the Pipes Run Editor dialog box. Use this dialog box to make a variety of edits to selected pipe runs in plan view, including the calculation of design flow rates and automatic pipe sizing.

The Pipes Run Editor has a multitude of columns. You can select from a variety of views, which display selected columns of information. The default when you open up the editor is the Sheet view, which you can use to view all of the columns.

The editor dialog box can only display a few columns at a time. Use the > button to move to the other columns in each view.

Calculating Metric Pipe Sizes and Labeling

When calculating pipe sizes in metric units, especially in Canada, you need to do a hard conversion from imperial sizes to metric sizes—for example, 6 in. to 152.4 mm. However, once you have imported the finished draft profile or plan pipe runs into the drawing, the pipes are often labeled by a soft conversion—for example, 6 in. to 150 mm.

Two methods are recommended for handling this situation. The first is to run calculations in the Pipes Run Editor using the hard conversion values. Once you have satisfactory results, save the calculations to a specific file through the Pipes
Run Editor. Next, run calculations for the same pipe run in the Pipes Run Editor using the soft conversion values that closely approximate the hard conversion values. Use these calculated sizes for labeling the pipes. This gives you two files to work with, if further modifications to the pipe run are necessary.

The second method is to run calculations in the Pipes Run Editor using the hard conversion values as before, and then using these values to label the pipes. You then need to manually edit the pipe labels once they are imported into the drawing.

**Changing the Pipe Run Editor Settings**

To change the pipe run editor settings

1. From the Pipes menu, choose Conceptual Plan ➤ Edit Data.
   The following prompt is displayed:

   Pick run:

2. Do one of the following to select the run:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box. Under Selection, select the defined run, and then click OK.

All pipe runs are stored in a single Pipeworks database called pipeworks.mdb. After you select a run, the Pipeworks database is automatically searched for the run with the specified name.

**NOTE** The .mdb file is a Microsoft Access file, so you can view the .mdb file using Microsoft Access.

After the pipe run is found, the Pipes Run Editor dialog box is displayed with the selected pipe run data.
3 Click Settings to display the Pipes – Editor Settings dialog box.

![Image of Pipes – Editor Settings dialog box]

The Hydraulic Calculation section has three options: Upstream to downstream, Downstream to upstream, and None, and an Outflow water surface elevation option.

4 Select one of the following options:
   - Select Upstream to downstream to specify that pipe calculations are made from upstream to downstream.
   - Select Downstream to upstream to specify that pipe calculations are made from downstream to upstream. You must also enter an appropriate value in the Outflow water surface elevation text box to use the Downstream to upstream option for hydraulic and energy gradeline calculations. Enter an appropriate outflow water surface elevation in the text box, or click Select to select a point on a current surface to specify the elevation.
   - Select None to turn off pipe calculations.

5 In the Design Settings section, do the following:
   - Select one of three formula options: Manning, Hazen-Williams, or Darcy-Weisbach from the Formula list.
   - In the Design Point (% Full) text box, type a design point value, or use the slide box to adjust the value.

6 In the Pipe Length Calculation Settings section, select one of four pipe structure-to-structure length options from the Length type list: Top, Center, Bottom, or Maximum.

7 In the Current Surface section, click Select to set the current surface. If a current surface is set in the drawing, it is displayed in the Surface label.

8 In the Peak Factor Adjustment section, type a value in the Peak Factor text box.

9 Click OK to exit the dialog box.

For more information about the other controls in the Pipes Run Editor, see “Pipes Run Editor Controls” in this chapter.
10 Click the Calculate button if Hydraulic Calculation is set to None in the Pipes – Editor Settings dialog box.

The program automatically re-calculates the pipe design.

**Pipes Run Editor Controls**

The following are controls in the Pipes Run Editor dialog box:

- Click the Save button to save all edits you made to the current run in the Pipes Run Editor.
- Click the Settings button to display the Pipes – Editor Settings dialog box.
- Click the Edit button after you place the cursor in a field to display information about a particular pipe run.
- Click the Tools button after you place the cursor in a field to display the Run Editor Toolbox dialog box. You can copy or clear the contents of a cell or column in the Pipes Run Editor.
- Click the Runoff button after you select a row to display the Runoff dialog box, where you can specify the runoff flow into the current pipe.
- Click the Messages button to display the Messages dialog box. If design requirements have not been met, for example, maximum and minimum slopes have been exceeded, or maximum cover depth has been exceeded, then the default text editor displays the discrepancies.

**NOTE**  Settings pertain to those set in the Pipes – Editor Settings dialog box and the Range Check Settings dialog box.

**Changing the Precision Settings**

**To change the precision settings**

1. From the Pipes menu, choose Conceptual Plan ➤ Edit Data.

   The following prompt is displayed:

   **Pick run:**

2. Do one of the following to select a run:

   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box.
     Under Selection, select the defined run, and then click OK.

All pipe runs are stored in a single Pipeworks database called pipeworks.mdb. After you select a run, the Pipeworks database is automatically searched for the run with the specified name.

**NOTE**  The .mdb file is a Microsoft Access file, so you can view the .mdb file using Microsoft Access.

After the pipe run is found, the Pipes Run Editor dialog box is displayed with the selected pipe run data. For more information, see “Changing the Pipe Run Editor Settings” in this chapter.
3 Click Settings to display the Pipes - Editor Settings dialog box.
4 Click Precision to display the Precision Settings dialog box.

**Precision Settings**

<table>
<thead>
<tr>
<th>Option</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Area</td>
<td>0.00, 8</td>
</tr>
<tr>
<td>Perimeter</td>
<td>0.00, 8</td>
</tr>
<tr>
<td>Pipe Coefficients</td>
<td>0.00, 8</td>
</tr>
<tr>
<td>Flowrate</td>
<td>0.00, 8</td>
</tr>
<tr>
<td>Length</td>
<td>0.00, 8</td>
</tr>
<tr>
<td>Pressure Head</td>
<td>0.00, 8</td>
</tr>
<tr>
<td>Elevation</td>
<td>0.00, 8</td>
</tr>
<tr>
<td>Structural Dim</td>
<td>0.00, 8</td>
</tr>
</tbody>
</table>

5 In the appropriate text boxes, type a value, or use the slide box associated with each option to select the precision value you want.
6 After adjusting the settings, click OK to exit the dialog box.

### Calculating Hydraulic and Energy Gradelines

You can calculate hydraulic and energy gradelines within the Pipes – HGL/EGL Settings dialog box.

**To calculate hydraulic and energy gradelines**

1 From the Pipes menu, choose Conceptual Plan ➤ Edit Data. The following prompt is displayed:

   **Pick run:**

2 Do one of the following to select a run:
   - Select a run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box. Under Selection, select the defined run, and then click OK.

All pipe runs are stored in a single Pipeworks database called pipeworks.mdb. After you select a run, the Pipeworks database is automatically searched for the run with the specified name.

**NOTE** The .mdb file is a Microsoft Access file, so you can view the .mdb file using Microsoft Access.

3 Click the Settings button to display the Pipes - Editor Settings dialog box.
4 Click the HGL/EGL button to display the Pipes - HGL/EGL Settings dialog box.

5 Select the Calculate HGL/EGL check box to calculate hydraulic and energy
gradelines.

6 In the Outflow water surface elevation box, enter the outflow water surface
elevation, and then click OK.

To view the HGL/EGL values, go to the Pipes Run Editor and select Headloss in
the View list. For more information, see “Changing the Pipe Run Editor
Settings” in this chapter. You can then plot the hydraulic and energy grade
lines in your pipe run profile.

7 You can click Select to pick a point in the drawing on a current surface to
specify the elevation.

The following prompt is displayed:

Select point (exit/Dtm/Profile):

8 Do one of the following:

   ■ Type X for exit to exit the command.
   ■ Type D for Dtm, and then press ENTER to display the Select Surface dialog
     box. Select either Terrain Surface or Volume Surface. From the Select surface
     to open box, select a surface, and then click OK.
   ■ Type P for Profile, press ENTER, and then select a profile. If no current profile
     exists, then the Pipes Message dialog box is displayed. Click OK to exit the
     Pipes Run Editor, and then create a profile in your drawing.

9 Click OK to exit the dialog box.

Using Contributing Upstream Run Flow Data in
Pipe Calculations

To use contributing upstream run flow data in pipe calculations

1 From the Pipes menu, choose Conceptual Plan ➤ Edit Data.

The following prompt is displayed:

Pick run:
2 Do one of the following to select a run:
   ■ Select the run with your pointing device.
   ■ Press ENTER to open the Defined Runs dialog box. Under Selection, select
     the defined run, and then click OK.

All pipe runs are stored in a single Pipeworks database called pipeworks.mdb.
After you select a run, the Pipeworks database is automatically searched for the
run with the specified name.

   NOTE The .mdb file is a Microsoft Access file, so you can view the .mdb file using
Microsoft Access.

After the pipe run is found, the Pipes Run Editor dialog box is displayed with
the selected pipe run data. For more information, see “Changing the Pipe Run
Editor Settings” in this chapter.

3 Click Settings to display the Pipes - Editor Settings dialog box.
4 Click Upstream to display the Pipes - Upstream Settings dialog box.

5 Select the Upstream Run check box to use contributing upstream run flow data
in the Pipes calculations.
6 Do one of the following:
   ■ In the Run text box, enter an appropriate name.
   ■ Click Select to display the Defined Runs dialog box to select an existing run.
You can also type an invert elevation value in the Invert text box, and a flow value in the Flow text box.

7 Select the Use of zero elevations for upstream run and all laterals check box to accept zero elevation values from the upstream run.

**NOTE** Zero elevations accepted from upstream run contributions forces subsequent downstream inverts to adopt zero elevations as well.

8 After adjusting the settings, click OK to exit the dialog box.

**Editing Conceptual Pipe Runs in Plan View Using the Pipe Run Editor**

Use the Edit Data (Conceptual Plan) command to open the Pipes Run Editor dialog box. Use this dialog box to make a variety of edits to the selected pipe runs in plan view, including the calculation of design flow rates and automatic pipe sizing.

The Pipes Run Editor has a multitude of columns. You can select from a variety of views that display selected columns of information. The default when you open up the editor is the Sheet view, which you can use to view all of the columns. These columns are described below.

The editor dialog box displays a few columns at a time. You can use the > button to move to the other columns in each View.

The following illustration shows how pipe measurements are made based on top and center lengths:

![Top and center length pipe measurements](image)

Top and center length pipe measurements
The following illustration shows how pipe measurements are made based on bottom and maximum lengths:

**Bottom and maximum length pipe measurements**

The following illustration shows structure measurement parameters:

**Structure measurement parameters**
To edit conceptual pipe runs in plan view using the pipe run editor

1. From the Pipes menu, choose Conceptual Plan ➤ Edit Data.
   The following prompt is displayed:
   
   Pick run:

2. Do one of the following to select a run:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box. Under Selection, select the run, and then click OK.

All pipe runs are stored in a single Pipeworks database called pipeworks.mdb. After you select a run, the Pipeworks database is automatically searched for the run with the specified name.

The database has two tables, RunListTable and RunDataTable. RunListTable has a row of design data pertaining to each run in the project and the drawing and project name. RunDataTable has a row of design data for each node in each run in the project.

**NOTE** The .mdb file is a Microsoft Access file, so you can view the .mdb file using Microsoft Access.

After the pipe run is found, the Pipes Run Editor dialog box is displayed with the selected pipe run data.

For more information, see “Changing the Pipe Run Editor Settings” in this chapter.
3 Use the View list to select a view. Each view displays different columns of grouped pipe run data. The following views are available:

- **Sheet**: The Sheet view displays all the columns in the Pipes Run Editor dialog box. This is the default view when you first enter the Pipes Run Editor dialog box.
- **Node**: The Node view displays all columns that pertain to the node data. The first column is Node Label, and stays in that position as you move around the dialog box in the Node view.
- **Pipe**: The Pipe view displays all columns that pertain to pipe data. The first column is Pipe Label, and stays in that position as you move around the dialog box in the Pipe view.
- **Flow**: The Flow view displays all columns that pertain to pipe flow data. The first column is Pipe Label, and stays in that position as you move around the dialog box in the Flow view.
- **Lateral**: The Lateral view displays all columns that pertain to lateral run and associated lateral pipe flow data. The first column is Pipe Label, and stays in that position as you move around the dialog box in the Lateral view.
- **Run Design**: The Run Design view displays all columns that pertain to designing the pipe run. The first column is Pipe Label, and stays in that position as you move around the dialog box in the Run Design view.
- **Headloss**: The Headloss view displays all columns that pertain to head loss through the pipe run. The first column is Pipe Label, and stays in that position as you move around the dialog box in the Headloss view.
- **Length**: The Length view displays all columns that pertain to pipe length. The first column is Pipe Label, and stays in that position as you move around the dialog box in the Length view.
- **Critical**: The Critical view displays all columns that pertain to critical depth. The first column is Pipe Label, and stays in that position as you move around the dialog box in the Critical view.
4 Use the following navigational buttons to move through the columns of information:

<table>
<thead>
<tr>
<th>Navigational Buttons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Moves over one column to the left</td>
</tr>
<tr>
<td>&gt;</td>
<td>Moves over one column to the right</td>
</tr>
<tr>
<td>/\</td>
<td>Moves up one row</td>
</tr>
<tr>
<td>/\</td>
<td>Moves down one row</td>
</tr>
<tr>
<td>&gt;&gt;</td>
<td>Moves over one page (7 columns) to the right</td>
</tr>
<tr>
<td>&lt;&lt;</td>
<td>Moves over one page (7 columns) to the left</td>
</tr>
<tr>
<td>PgUp</td>
<td>Moves up 6 rows, and the PgDn button moves down 6 rows</td>
</tr>
<tr>
<td>&lt;Home</td>
<td>Moves the cursor to the first column in the table</td>
</tr>
<tr>
<td>End&gt;</td>
<td>Moves the cursor to the last column in the table</td>
</tr>
<tr>
<td>Home</td>
<td>Moves the cursor to the first cell in the table</td>
</tr>
<tr>
<td>End</td>
<td>Moves the cursor to the last cell in the table</td>
</tr>
</tbody>
</table>

5 Make any necessary edits to the information.

For a list of column headings and descriptions of the information they contain, see “Editing Conceptual Pipe Runs in Plan View – Column Headings” in this chapter.
## Editing Conceptual Pipe Runs in Plan View - Column Headings

<table>
<thead>
<tr>
<th>Column Headings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>% d/D</td>
<td>This column contains the percentage full value for the pipe at the design flow rate. The d represents the depth of flow, the D the pipe diameter. This value is determined by the current pipe configuration and flow calculation formula. You can make your own percentage full at the design flow rate calculations if necessary. Place your cursor in the % d/D column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Adjusted Length</td>
<td>This column contains the adjusted length value of the pipe segment.</td>
</tr>
<tr>
<td>Cen-Cen 2Dlength</td>
<td>This column contains the center-to-center 2D pipe length value, which is calculated based on the Northing and Easting values of the pipe segment’s starting and ending points.</td>
</tr>
<tr>
<td>Cen-Cen 3Dlength</td>
<td>This column contains the center-to-center 3D length value of the pipe segment.</td>
</tr>
<tr>
<td>Critical Depth</td>
<td>This column contains the critical depth value for the pipe segment.</td>
</tr>
<tr>
<td>Critical Slope</td>
<td>This column contains the critical slope value for the pipe segment.</td>
</tr>
<tr>
<td>Critical Velocity</td>
<td>This column contains the critical velocity value for the pipe segment.</td>
</tr>
<tr>
<td>D. Point Flow</td>
<td>This column contains the design point flow value, which is calculated for the current pipe segment based on the percent full value setting made in the Pipes - Editor Settings dialog box. You can make your own design point flow value calculations if necessary. Place your cursor in the D. Point column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Design Depth</td>
<td>This column displays the depth of flow value, d, for the design flow. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own depth of flow calculations if necessary. Place your cursor in the Design Depth column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Design Flow</td>
<td>This column contains the design flow value, which the Pipes Run Editor automatically calculates by adding the pipe flow, lateral flows #1 and #2, infiltration inflow, and upstream flow values.</td>
</tr>
<tr>
<td>Design Vel.</td>
<td>This column contains the design velocity flow value for the pipe segment. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own design velocity flow calculations if necessary. Place your cursor in the Design Vel. column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>East</td>
<td>This column contains the easting value of the node’s location point in the pipe run.</td>
</tr>
<tr>
<td>EGL Elev In</td>
<td>This column contains the energy grade line elevation in value for the pipe segment.</td>
</tr>
<tr>
<td>EGL Out</td>
<td>This column contains the energy grade line elevation out value for the pipe segment.</td>
</tr>
</tbody>
</table>
Pipe Runs in Plan View (continued)

<table>
<thead>
<tr>
<th>Column Headings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Finish Inv.</td>
<td>This column contains the finish invert elevation for the pipe segment. This value is also the invert in elevation of the next node. The finish invert elevation is calculated from the starting invert elevation using the pipe length and slope. Changing the slope changes the finish invert elevation as well as all invert elevations downstream of the finish invert. Invert elevations are changed by editing the slopes, node drops, or the first starting invert. When an invert elevation changes, all downstream invert elevations are updated based on the slope and node drop values. The starting invert elevation also changes if you enter a lateral that has an invert elevation lower than the previous finish invert elevation. The upstream invert elevation also affects the invert elevation values.</td>
</tr>
<tr>
<td>Flow Regime</td>
<td>This column contains the flow regime designation of critical, subcritical, or supercritical.</td>
</tr>
<tr>
<td>Froude Number</td>
<td>This column contains the Froude number for the pipe segment.</td>
</tr>
<tr>
<td>Full Area</td>
<td>This column contains the full-flow wetted cross-section area value for the pipe segment. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own full-flow wetted cross-section area calculations if necessary. Place your cursor in the Full Area column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Full Flow</td>
<td>This column contains the full-flow value for the pipe segment. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own full-flow calculations, if necessary. Place your cursor in the Full Flow column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Full Perim</td>
<td>This column contains the full-flow wetted perimeter value for the pipe segment. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own full-flow wetted perimeter calculations, if necessary. Place your cursor in the Full Perim column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Full Vel</td>
<td>This column contains the full-flow velocity value for the pipe segment. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own full-flow velocity calculations, if necessary. Place your cursor in the Full Vel column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>HGL Elev In</td>
<td>This column contains the hydraulic grade line elevation in value, which you use to draft the hydraulic gradeline. If a hydraulic grade line elevation in value is not entered, the Pipes Run Editor uses the default hydraulic grade line elevation in value from the Pipes settings.</td>
</tr>
<tr>
<td>HGL Elev Out</td>
<td>This column contains the hydraulic grade line elevation out value, which you use to draft the hydraulic gradeline. If a hydraulic grade line elevation out value is not entered, the Pipes Run Editor uses the default hydraulic grade line elevation out value from the Pipes settings.</td>
</tr>
<tr>
<td>Infilt. Inflow</td>
<td>This column contains the infiltration inflow value of the pipe segment.</td>
</tr>
<tr>
<td>Lateral Flow #1</td>
<td>This column contains the flow contribution to the pipe’s upstream node for the first lateral run. If a valid lateral run name is entered in the Lateral Name #1 column, this value is automatically calculated.</td>
</tr>
<tr>
<td>Lateral Flow #2</td>
<td>This column contains the flow contribution to the pipe’s upstream node for the second lateral run. If a valid lateral run name is entered in the Lateral Name #2 column, this value is automatically calculated.</td>
</tr>
<tr>
<td>Lateral Inv. #1</td>
<td>This column contains the invert elevation at the pipe’s discharge point run for the first lateral invert. If a valid lateral run name is entered in the Lateral Name #1 column, this value is automatically calculated.</td>
</tr>
<tr>
<td>Column Headings</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Lateral Inv. #2</td>
<td>This column contains the invert elevation at the pipe's discharge point run for the second lateral invert. If a valid lateral run name is entered</td>
</tr>
<tr>
<td></td>
<td>in the Lateral Name #2 column, this value is automatically calculated.</td>
</tr>
<tr>
<td>Lateral Name #1</td>
<td>This column contains the name of the first lateral run. The Pipes Run Editor searches for the .mdb file with the lateral run name, and if it</td>
</tr>
<tr>
<td></td>
<td>retrieves the lateral run file, the discharge flow and invert elevation are imported.</td>
</tr>
<tr>
<td>Lateral Name #2</td>
<td>This column contains the name of the second lateral run. The Pipes Run Editor searches for the .mdb file with the lateral run name, and if it</td>
</tr>
<tr>
<td></td>
<td>retrieves the lateral run file, the discharge flow and invert elevation are imported.</td>
</tr>
<tr>
<td>Node Drop</td>
<td>This column contains the node drop value, which represents the distance of the drop through the node structure. Modifying the node drop value</td>
</tr>
<tr>
<td></td>
<td>changes the node's invert out value and forces an automatic update of all downstream invert values.</td>
</tr>
<tr>
<td>Node Label</td>
<td>This column contains the node label for each upstream node in the pipe run. Each node can have a unique name, such as MH1, MH2, and MH3.</td>
</tr>
<tr>
<td>North</td>
<td>This column contains the northing value of the node's location point in the pipe run.</td>
</tr>
<tr>
<td>Offset</td>
<td>This column contains the offset value of the node's location point relative to the current alignment. If there is no currently referenced</td>
</tr>
<tr>
<td></td>
<td>alignment, this column is left blank.</td>
</tr>
<tr>
<td>Pipe Descr.</td>
<td>This column contains the pipe material description, which you can edit.</td>
</tr>
<tr>
<td>Pipe Drop</td>
<td>This column contains the pipe drop value, which the Pipes Run Editor automatically calculates by multiplying the pipe slope by the pipe length.</td>
</tr>
<tr>
<td>Pipe Flow</td>
<td>This column contains the pipe flow value associated with the pipe segment.</td>
</tr>
<tr>
<td>Pipe Label</td>
<td>This column contains the pipe label name for each segment of the pipe run. The pipe run segment occurs between the node in the same row as the</td>
</tr>
<tr>
<td></td>
<td>pipe label in the Pipes Run Editor, and the node in the next row down. Each pipe run segment can have a unique label. For example, you can</td>
</tr>
<tr>
<td></td>
<td>designate the segment between MH3 and MH4 with the label 3-4.</td>
</tr>
<tr>
<td>Pipe Size</td>
<td>This column contains the pipe size. You can enter any pipe size in this column; however, only pipe sizes that are defined in the Pipe Slope</td>
</tr>
<tr>
<td></td>
<td>Control Table can be automatically sized based on flow. If the pipe diameter is too small for the design flow, the Pipes Run Editor selects</td>
</tr>
<tr>
<td></td>
<td>the next available size that meets the design flow requirements.</td>
</tr>
<tr>
<td>Pipe Slope</td>
<td>This column contains the pipe slope value, entered as ft/ft or m/m. For example, enter the value 0.02 for a pipe slope of 2%. When you change</td>
</tr>
<tr>
<td></td>
<td>the pipe slope value, the Pipes Run Editor automatically recalculates the value for the finish invert elevation for the pipe segment, as</td>
</tr>
<tr>
<td></td>
<td>well as all of the downstream invert elevations.</td>
</tr>
<tr>
<td>Rim Elev.</td>
<td>This column contains the rim elevation of the node. Once you define the run, modifying the node's rim elevation does not affect the inverts in</td>
</tr>
<tr>
<td></td>
<td>or out.</td>
</tr>
<tr>
<td>Rough Coeff</td>
<td>This column contains the roughness coefficient value for the pipe segment for use in flow calculations, which you can edit. The roughness</td>
</tr>
<tr>
<td></td>
<td>coefficient used depends on which formula and method you use for pipe flow calculations: Manning, Darcy-Weisbach, or Hazen-Williams. You can</td>
</tr>
<tr>
<td></td>
<td>either enter a roughness coefficient value, or place your cursor in the Rough Coeff column and click Edit to open the appropriate Coefficient</td>
</tr>
<tr>
<td></td>
<td>Table dialog box.</td>
</tr>
</tbody>
</table>
Pipe Runs in Plan View (continued)

<table>
<thead>
<tr>
<th>Column Headings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Inv.</td>
<td>This column contains the starting invert elevation value for the pipe segment. This value is also the invert out elevation of the current node. You enter only the first starting invert elevation value; each subsequent starting invert through the pipe run is calculated by subtracting the structure drop from the finish invert of the previous pipe, which is the invert in elevation of the current node.</td>
</tr>
<tr>
<td>Station</td>
<td>This column contains the station value of the node's location point, relative to the current alignment. If there is no currently referenced alignment, this column is left blank.</td>
</tr>
<tr>
<td>Str-Str 3DLength</td>
<td>This column contains the structure-to-structure 3D length value of the pipe segment.</td>
</tr>
<tr>
<td>Struct Dim.</td>
<td>This column contains the structure diameter value of the node, which is taken from the Structure Library Editor dialog box. You cannot edit the structure diameter value.</td>
</tr>
<tr>
<td>Struct Type</td>
<td>This column contains the node's structure type. You can either enter the structure name, or select a structure from the Structure Library Editor. Place your cursor in this column, and then click Edit to open the Structure Library Editor dialog box.</td>
</tr>
<tr>
<td>Sump Drop</td>
<td>This column contains the sump drop value, which represents the structure's sump depth below the node's lowest invert elevation. The sump drop value is taken from the Structure Library Editor dialog box and cannot be edited.</td>
</tr>
<tr>
<td>Sump Elev</td>
<td>This column contains the node's sump elevation value, which is based on the lowest invert elevation and the sump drop. You cannot edit the sump elevation value.</td>
</tr>
<tr>
<td>Sump Fixed</td>
<td>This column contains the sump elevation's on/off value. By default, the Sump Fixed field is ON, which means the sump elevation is fixed and is dictated by the node structure's depth. If the Sump Fixed field value is OFF, then the sump elevation is variable and will not be reset by pipeworks.</td>
</tr>
<tr>
<td>Surface File</td>
<td>This column contains the surface runoff file name. For information about the Runoff option, refer to the section, Runoff, later in this command description.</td>
</tr>
<tr>
<td>Surface Flow</td>
<td>This column contains the surface runoff flow value for the node or pipe segment. For information about the Runoff option, refer to the section, Runoff, later in this command description.</td>
</tr>
</tbody>
</table>
Pipe Runs in Plan View (continued)

<table>
<thead>
<tr>
<th>Column Headings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Surface On/Off</td>
<td>This column contains the runoff file on/off value, with On represented by 1 and Off represented by 0 (zero). For information about the Runoff option, refer to the section, Runoff, later in this command description.</td>
</tr>
<tr>
<td>Thickness In</td>
<td>This column contains the structure wall thickness in value.</td>
</tr>
<tr>
<td>Thickness Out</td>
<td>This column contains the structure wall thickness out value.</td>
</tr>
<tr>
<td>Wet Area</td>
<td>This column contains the pipe cross section wetted area value based on the design flow calculation. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own pipe cross section wetted area calculations, if necessary. Place your cursor in the Wet Area column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Wet Perim.</td>
<td>This column contains the pipe cross section wetted perimeter value based on the design flow calculation. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own pipe cross section wetted perimeter calculations, if necessary. Place your cursor in the Wet Perim column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
</tbody>
</table>

Copying or Clearing the Fields and Columns in the Pipe Run Editor

To copy or clear the fields and columns in the pipe run editor

1. From the Pipes menu, choose Conceptual Plan ➤ Edit Data.
2. Do one of the following:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box, select the run, and then click OK.

All pipe runs are stored in a single Pipeworks database called pipeworks.mdb. After you select a run, the Pipeworks database is automatically searched for the run with the specified name.

NOTE
The .mdb file is a Microsoft Access file, so you can view the .mdb file using Microsoft Access.

After the pipe run is found, the Pipes Run Editor dialog box is displayed with the selected pipe run data. For more information, see “Changing the Pipe Run Editor Settings” in this chapter.
3 Click Tools to display the Run Editor Toolbox dialog box.

![Run Editor Toolbox](image)

Use the following buttons to copy and clear data from individual cells and columns in the Pipes Run Editor:
- Click Copy Down to copy the value in the highlighted cell down to the next cell in the column.
- Click Copy Column to copy the value in the highlighted cell down to all the cells in that column.
- Click Clear to clear the cell in which the cursor is located.
- Click Clear Column to clear all the cells in the column in which the cursor is located.

**NOTE** You cannot use the options in the Run Editor Toolbox dialog box in every column; you can use them only in columns that allow manual entry of Pipes data.

### Displaying Error Messages in the Pipe Run Editor

**To display error messages in the pipe run editor**

1. From the Pipes menu, choose Conceptual Plan ➤ Edit Data.
2. Do one of the following:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

All pipe runs are stored in a single Pipeworks database called pipeworks.mdb. After you select a run, the Pipeworks database is automatically searched for the run with the specified name.

**NOTE** The .mdb file is a Microsoft Access file, so you can view the .mdb file using Microsoft Access.

After the pipe run is found, the Pipes Run Editor dialog box is displayed with the selected pipe run data. For more information, see “Changing the Pipe Run Editor Settings” in this chapter.

3 Click Messages to display the status of the Pipes Run Editor calculations.

If any errors have occurred in the calculation process, then these errors are compiled and display in a Messages dialog box.
Adding Surface Runoff Contributions to Pipe Nodes or Segments

To add surface runoff contributions to pipe nodes or segments

1. From the Pipes menu, choose Conceptual Plan ➤ Edit Data.
2. Do one of the following:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

All pipe runs are stored in a single Pipeworks database called pipeworks.mdb. After you select a run, the Pipeworks database is automatically searched for the run with the specified name.

**NOTE** The .mdb file is a Microsoft Access file, so you can view the .mdb file using Microsoft Access.

After the pipe run is found, the Pipes Run Editor dialog box is displayed with the selected pipe run data. For more information, see “Changing the Pipe Run Editor Settings” in this chapter.

3. Place your cursor in the Surface Flow column, and then click Runoff to display the Runoff dialog box.

4. Select the Runoff check box.
5. Do one of the following to select a file:
   - In the File box, enter the filename of an existing surface runoff output file.
   - Click the Select button to display the Runoff Method Selection dialog box.
In the Runoff Method Selection dialog box, you can open five different methods for computing a runoff value by selecting one of the following from the Selection list:

- Select Rational Method to open the Rational Method dialog box to accommodate TR-20 method runoff calculations.
- Select TR-55 Tabular to open the TR-55 Tabular Hydrograph Method dialog box to accommodate TR-55 tabular hydrograph method runoff calculations.
- Select TR-55 Graphical to open the TR-55 Graphical Peak Discharge Method dialog box to accommodate TR-55 graphical peak discharge method runoff calculations.
- Select TR-20 Method to open the SCS TR-20 Unit Hydrograph Method dialog box to accommodate TR-20 method runoff calculations.
- Select Inflow Hydrograph to open the Input Hydrograph dialog box so you can select an existing inflow hydrograph file. The peak discharge from the hydrograph is extracted for use as the runoff flow value.

**NOTE** When performing run-off calculations using the TR-20 Method, the recommended units are Imperial. Input the rainfall in inches and the area in square miles or acres. If the units for rainfall are something other than inches, then the DST file must match the rainfall units.

Click OK to return to the Runoff dialog box. The runoff flow value displays in the Flow text box. You can add surface runoff flow contributions at each node or pipe segment.

Click OK to return to the Pipes Run Editor. The runoff flow value displays in the Surface Flow column. In addition, the corresponding Surface On/Off column displays the number 1 to indicate that the use of a surface runoff flow value is selected on. If a surface runoff flow value is not used, the number displayed in the Surface Flow column is 0 (zero).

### Displaying the Data in a Text Editor

**To display the pipe data in a text editor**

1. From the Pipes menu, choose Conceptual Plan ➤ Edit Data.
2. Do one of the following:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

All pipe runs are stored in a single Pipeworks database called pipeworks.mdb. After you select a run, the Pipeworks database is automatically searched for the run with the specified name.

**NOTE** The .mdb file is a Microsoft Access file, so you can view the .mdb file using Microsoft Access.

After the pipe run is found, the Pipes Run Editor dialog box is displayed with the selected pipe run data. For more information, see “Changing the Pipe Run Editor Settings” in this chapter.

3. Click the Print View button to display the current pipe run data in the ASCII text editor configured for your system.
Reversing the Direction of the Flow in a Pipe

Use the Reverse Flow command to globally reverse the flow of the current run by swapping both the invert in with the invert out and the label in and out. Use this command whenever you define a pipe run with the flow in the wrong direction.

To reverse the direction of the flow in a pipe
1. From the Pipes menu, choose Conceptual Plan ➤ Reverse Flow.
2. Do one of the following:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

After you select a run, the Pipeworks database is automatically searched for a file with the specified run name and an .mdb extension. The following prompts are displayed:

Run <{name}> deleted from database.
Conceptual Plan for run <{name}> erased from drawing.
Run <{name}.mdb> file deleted from project.
Run: {name} length: {#} nodes: {#}
Run <{name}> flow direction reversed.

The pipe run is deleted from the Pipes Run database, the conceptual pipe run plan is erased from the drawing, and the .mdb file is deleted from the project. The pipe run is then automatically redefined with the reverse flow direction.

Updating the Rim and Invert Elevations of a Pipe

Use the Recalculate Rim command to recalculate the rim, invert, and sump elevations. Use this command after you define a pipe run and the rim elevations need to be updated.

The rim elevation can be extracted from a surface. The invert and sump elevations are specified based on the new or existing rim elevation and the Invert depth below rim values set in the Pipes Data Settings.

To update the rim and invert elevations of a pipe
1. From the Pipes menu, choose Conceptual Plan ➤ Recalculate Rim.
2. Do one of the following:
   - Select the pipe run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

All pipe runs are stored in a single Pipeworks database called pipeworks.mdb. After you select a run, the Pipeworks database is automatically searched for the run with the specified name.

NOTE
The .mdb file is a Microsoft Access file, so you can view the .mdb file using Microsoft Access.
The Pipes Message dialog box is displayed.

3 Click Yes to recalculate the rim elevations and inverts, or No to cancel the command.

**Breaking a Pipe Run into Two Pipe Runs**

Use the Break command to break a pipe run at a node and make two new separate pipe runs. The separation point occurs at the node nearest to the point you select on the pipe run. The pipe run must have at least three nodes for the Break command to break the run.

To break a pipe run into two pipe runs
1 From the Pipes menu, choose Conceptual Plan ➤ Break.
2 Select the run by picking a point on the pipe run near the node break point.
3 Enter names for the new pipe runs.

The pipe run data at the node break point is duplicated in both runs. If you enter a new name for the first new pipe run, you can assign the original pipe run name (a maximum of 30 characters) to the second pipe run. If you use two new pipe run names, the original pipe run remains intact and can be used again.

**Joining Two Pipe Runs into One Pipe Run**

To join two pipe runs that share a common node
1 From the Pipes menu, choose Conceptual Plan ➤ Join.
2 Do one of the following:
   - Select the first pipe run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.
3 Do one of the following:
   - Select the second pipe run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

The flow direction of the second pipe run changes to match that of the first pipe run, if different. If the existing run continues past the connection point of a side run, you cannot join that side run to the existing run.
Deleting Conceptual Pipe Runs in Plan View

Using the Conceptual Plan ▶ Delete command, you can erase the graphic entities that comprise a pipe run from the drawing and delete the pipe run data from the Pipeworks database.

To delete conceptual pipe runs in plan view

1. From the Pipes menu, choose Conceptual Plan ▶ Delete.

   The following prompt is displayed:

   Pick run:

2. Do one of the following:

   - Select the run with your pointing device.
   - Press ENTER, select the run from the Defined Runs dialog box, and then click OK.

   The Delete Options for run dialog box is displayed.

3. Select the delete option you want to use.

   The Delete Options for run dialog box has the following options/check boxes:

   - **Plan**: Erases the graphic entities that comprise the conceptual plan pipe run. The pipe run definition remains in the Pipeworks database.
   - **Profile**: Erases the graphic entities that comprise the conceptual profile pipe run. The pipe run definition remains in the Pipeworks database.
   - **H Grade**: Erases the graphic entities that comprise the hydraulic gradeline.
   - **E Grade**: Erases the graphic entities that comprise the energy gradeline.
   - **.mdb file (All)**: Erases the graphic entities that comprise the conceptual plan and profile pipe runs, and deletes the pipe run data from the Pipeworks database.

   **NOTE** When you select the .mdb file (All) checkbox, the other options are available only if there are plan and profile runs and hydraulic and energy gradelines present in a drawing.

4. Click OK to delete the selected pipe run entities or files.
Updating the Conceptual Pipe Runs in Plan View

Use the Check Plan command to update the pipe run:

- After you edit the pipe run database in Microsoft Access, you can update the graphical representation of the pipe run.
- After you use AutoCAD commands to edit the graphical representation of the pipe run, you can update the pipe run database.

**NOTE**
The plan and profile pipe runs are automatically updated with any changes you make to the pipe runs in the Pipes Run Editor.

To update the conceptual pipe runs in plan view
1. From the Pipes menu, choose Conceptual Plan ➤ Check Plan to display the Defined Runs dialog box.
2. Click OK to continue.

Editing Conceptual Pipe Runs in Profile View

Conceptual pipe runs are single line representations of plan and profile view pipe runs. They serve as quick sketches of pipe run configurations, which you can use to check a particular pipe run for proper position and location.

This section shows you how to do the following:

- Edit conceptual pipe runs in profile view.
- Delete conceptual pipe runs in profile view.
- Edit conceptual pipe runs using the Pipe Run Editor.
- Edit conceptual pipe runs in profile view using the Pipe Run Editor.

Editing Conceptual Pipe Runs in Profile View

Use the Edit Graphical (Conceptual Profile) command to graphically edit both the pipes and the nodes of a selected conceptual pipe run in profile view. Use this command after importing the conceptual pipe run with the Import Run (Profile) command.

The following illustration shows a sample pipe run in profile view and selection points on the pipe run for editing pipes and nodes:

Pipe run in profile view
To edit conceptual pipe runs in profile view

1. From the Pipes menu, choose Conceptual Profile ➤ Edit Graphical. The following prompt is displayed:
Select run to edit:

2. Select a point on the pipe run near the node to be edited. An X drawn with temporary vectors, marks the node nearest to the selection point. You now have the following options:

Next/Prev /DElete /DBase /Undo /Save /Add /Move /eXit <eXit>:

If an option that requires a rim elevation is selected, such as Move, a dialog box is displayed prompting you to turn on the current surface.

3. Type any of the following:
- N for the Next option, to advance the X designating the current node in the pipe run to the next available node.
- P for the Prev option, to move the X designating the current node in the pipe run back to the previous node.
- D for the DElete option, to remove the current node in the pipe run back to the previous node.
- DB for the DBase option, to display the Edit Run Node dialog box, depending on whether a pipe or node is current. You can change values in this dialog box by highlighting the appropriate field, then entering the changes in the Edit text box. This editor is dynamically linked to the drawing. If you make changes in the Edit Table dialog box, then clicking OK results in the pipe run being redrawn to reflect those changes.
- U for the Undo option, to reverse any previous action taken in the pipe run drawing process.
- S for the Save option, to save the pipe run data to the database. The Run Alignment Association dialog box is displayed. This dialog box lists the Run and the Current Alignment with which the pipe run is associated. There are four options listed: Use Current Alignment, Create an Alignment from Run, Use No Alignment, or Use an Existing Alignment.
- A for the Add option, to add the next node to the pipe run, using either a station and offset, or selecting another point.
- M for the Move option, to relocate the current node. Enter either a new station and offset, or a selected point. The current station and offset are displayed as the default values. Selecting this option displays the following prompt:
eXit/Station/POint:
- X for the EXit option, to end the Move option, returning you to the previous set of options.
- S for Station, to specify a new location for the node based on a station and offset from the current alignment, if one is set as current. If an alignment has not been set, then a prompt is displayed to let you do so. After entering the station and offset, the node moves to the new location, and the previous set of options displays.
- PO for the POint option, to change the location of the node in one of three ways: use your pointing device to specify a new point; type .P to designate a point number as the new location; or type .N to enter northing and easting.
coordinates for the new location. After specifying the point, the node moves to the new location, and previous set of options displays.

**Deleting Conceptual Pipe Runs in Profile View**

Use the Delete (Conceptual Profile) command to erase the graphic entities that comprise a conceptual profile pipe run and delete the pipe run data from the Pipeworks database.

**To delete conceptual pipe runs in profile view**

1. From the Pipes menu, choose Conceptual Profile ➤ Delete.
2. Do one of the following:
   - Select the run with your pointing device.
   - Press ENTER to display the Delete Options for run dialog box, select the run, and then click OK.

**Editing Conceptual Profile Pipe Runs Using the Pipe Run Editor**

Use the Edit Data Conceptual Profile command to open the Pipes Run Editor dialog box. Use this dialog box to make a variety of edits to selected pipe runs in plan view, including the calculation of design flow rates and automatic pipe sizing.

The Pipes Run Editor has a multitude of columns. You can select from a variety of views, which display selected columns of information. The default when you open up the editor is the Sheet view, which you can use to view all the columns. Descriptions for these columns are below.

The Editor dialog box displays a few columns at a time. Use the > button to move to the other columns in each View.

**To edit conceptual pipe runs in profile view using the pipe run editor**

1. From the Pipes menu, choose Conceptual Profile ➤ Edit Data.
2. Do one of the following:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.
All pipe runs are stored in a single Pipeworks database called pipeworks.mdb. After you select a run, the Pipeworks database is automatically searched for the run with the specified name.

**NOTE**  
The .mdb file is a Microsoft Access file, so you can view the .mdb file using Microsoft Access.

After the pipe run is found, the Pipes Run Editor dialog box is displayed with the selected pipe run data.

For more information, see “Changing the Pipe Run Editor Settings” in this chapter.

3 Use the View list to select a view. Each view displays different columns of grouped pipe run data. The following views are available:

- **Sheet:** The Sheet view displays all the columns in the Design Pipes Run Editor dialog box. This is the default view when you first enter the Design Pipes Run Editor dialog box.
- **Node:** The Node view displays all columns that pertain to the node data. The Node Label column is the first column, and stays in that position as you move around the dialog box in the Critical view.
- **Pipe:** The Pipe view displays all columns that pertain to pipe data. The Pipe Label column is the first column, and stays in that position as you move around the dialog box in the Pipe view.
- **Flow:** The Flow view displays all columns that pertain to pipe flow data. The Pipe Label column is the first column, and stays in that position as you move around the dialog box in the Flow view.
- **Lateral**: The Lateral view displays all columns that pertain to lateral run and associated pipe flow data. The Pipe Label column is the first column, and stays in that position as you move around the dialog box in the Lateral view.

- **Run Design**: The Run Design view displays all columns that pertain to designing the pipe run. The Pipe Label column is the first column, and stays in that position as you move around the dialog box in the Run Design view.

- **Headloss**: The Headloss view displays all columns that pertain to head loss through the pipe run. The Pipe Label column is the first column, and stays in that position as you move around the dialog box in the Headloss view.

- **Length**: The Length view displays all columns that pertain to pipe length. The Pipe Label column is the first column, and stays in that position as you move around the dialog box in the Length view.

- **Critical**: The Critical view displays all columns that pertain to critical depth. The Pipe Label column is the first column, and stays in that position as you move around the dialog box in the Critical view.

4 Use the following navigational buttons to move through the columns of information:

<table>
<thead>
<tr>
<th>Navigational Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Button</strong></td>
</tr>
<tr>
<td>&lt;</td>
</tr>
<tr>
<td>&gt;</td>
</tr>
<tr>
<td>\ /</td>
</tr>
<tr>
<td>/ \</td>
</tr>
<tr>
<td>&gt;&gt;</td>
</tr>
<tr>
<td>&lt;&lt;</td>
</tr>
<tr>
<td>PgUp</td>
</tr>
<tr>
<td>&lt;Home</td>
</tr>
<tr>
<td>End&gt;</td>
</tr>
<tr>
<td>Home</td>
</tr>
<tr>
<td>End</td>
</tr>
</tbody>
</table>

5 Make any necessary edits to the information.

For a list of column headings and descriptions of the information they contain, see “Editing Conceptual Pipe Runs in Profile – Column Headings” in this chapter.
## Editing Conceptual Pipe Runs in Profile - Column Headings

<table>
<thead>
<tr>
<th>Column Headings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>% d/D</td>
<td>This column contains the percentage full value for the pipe at the design flow rate. The d represents the depth of flow, the D the pipe diameter. This value is determined by the current pipe configuration and flow calculation formula. You can make your own percentage full at the design flow rate calculations if necessary. Place your cursor in the % d/D column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Adjusted Length</td>
<td>This column contains the adjusted length value of the pipe segment.</td>
</tr>
<tr>
<td>Cen-Cen 2Dlength</td>
<td>This column contains the center-to-center 2D pipe length value, which is calculated based on the Northing and Easting values of the pipe segment’s starting and ending points.</td>
</tr>
<tr>
<td>Cen-Cen 3Dlength</td>
<td>This column contains the center-to-center 3D length value of the pipe segment.</td>
</tr>
<tr>
<td>Critical Depth</td>
<td>This column contains the critical depth value for the pipe segment.</td>
</tr>
<tr>
<td>Critical Slope</td>
<td>This column contains the critical slope value for the pipe segment.</td>
</tr>
<tr>
<td>Critical Velocity</td>
<td>This column contains the critical velocity value for the pipe segment.</td>
</tr>
<tr>
<td>D. Point Flow</td>
<td>This column contains the design point flow value, which is calculated for the current pipe segment based on the percent full value setting made in the Pipes - Editor Settings dialog box. You can make your own design point flow value calculations if necessary. Place your cursor in the D. Point column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Design Depth</td>
<td>This column displays the depth of flow value, d, for the design flow. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own depth of flow calculations if necessary. Place your cursor in the Design Depth column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Design Flow</td>
<td>This column contains the design flow value, which the Pipes Run Editor automatically calculates by adding the pipe flow, lateral flows #1 and #2, infiltration inflow, and upstream flow values.</td>
</tr>
<tr>
<td>Design Vel.</td>
<td>This column contains the design velocity flow value for the pipe segment. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own design velocity flow calculations if necessary. Place your cursor in the Design Vel. column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>East</td>
<td>This column contains the easting value of the node’s location point in the pipe run.</td>
</tr>
<tr>
<td>EGL Elev In</td>
<td>This column contains the energy grade line elevation in value for the pipe segment.</td>
</tr>
<tr>
<td>EGL Out</td>
<td>This column contains the energy grade line elevation out value for the pipe segment.</td>
</tr>
</tbody>
</table>
## Conceptual Pipe Runs in Profile (continued)

<table>
<thead>
<tr>
<th>Column Headings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Finish Inv.</td>
<td>This column contains the finish invert elevation for the pipe segment. This value is also the invert in elevation of the next node. The finish invert elevation is calculated from the starting invert elevation using the pipe length and slope. Changing the slope changes the finish invert elevation as well as all invert elevations downstream of the finish invert. Invert elevations are changed by editing the slopes, node drops, or the first starting invert. When an invert elevation changes, all downstream invert elevations are updated based on the slope and node drop values. The starting invert elevation also changes if you enter a lateral that has an invert elevation lower than the previous finish invert elevation. The upstream invert elevation also affects the invert elevation values.</td>
</tr>
<tr>
<td>Flow Regime</td>
<td>This column contains the flow regime designation of critical, subcritical, or supercritical.</td>
</tr>
<tr>
<td>Froude Number</td>
<td>This column contains the Froude number for the pipe segment.</td>
</tr>
<tr>
<td>Full Area</td>
<td>This column contains the full-flow wetted cross-section area value for the pipe segment. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own full-flow wetted cross-section area calculations if necessary. Place your cursor in the Full Area column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Full Flow</td>
<td>This column contains the full-flow value for the pipe segment. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own full-flow calculations, if necessary. Place your cursor in the Full Flow column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Full Perim</td>
<td>This column contains the full-flow wetted perimeter value for the pipe segment. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own full-flow wetted perimeter calculations, if necessary. Place your cursor in the Full Perim column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Full Vel</td>
<td>This column contains the full-flow velocity value for the pipe segment. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own full-flow velocity calculations, if necessary. Place your cursor in the Full Vel column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>HGL Elev In</td>
<td>This column contains the hydraulic grade line elevation in value, which you use to draft the hydraulic gradeline. If a hydraulic grade line elevation in value is not entered, the Pipes Run Editor uses the default hydraulic grade line elevation in value from the Pipes settings.</td>
</tr>
<tr>
<td>HGL Elev Out</td>
<td>This column contains the hydraulic grade line elevation out value, which you use to draft the hydraulic gradeline. If a hydraulic grade line elevation out value is not entered, the Pipes Run Editor uses the default hydraulic grade line elevation out value from the Pipes settings.</td>
</tr>
<tr>
<td>Column Headings</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Infilt. Inflow</td>
<td>This column contains the infiltration inflow value of the pipe segment.</td>
</tr>
<tr>
<td>Lateral Flow #1</td>
<td>This column contains the flow contribution to the pipe's upstream node for the first lateral run. If a valid lateral run name is entered in the Lateral Name #1 column, this value is automatically calculated.</td>
</tr>
<tr>
<td>Lateral Flow #2</td>
<td>This column contains the flow contribution to the pipe's upstream node for the second lateral run. If a valid lateral run name is entered in the Lateral Name #2 column, this value is automatically calculated.</td>
</tr>
<tr>
<td>Lateral Inv. #1</td>
<td>This column contains the invert elevation at the pipe's discharge point run for the first lateral invert. If a valid lateral run name is entered in the Lateral Name #1 column, this value is automatically calculated.</td>
</tr>
<tr>
<td>Lateral Inv. #2</td>
<td>This column contains the invert elevation at the pipe's discharge point run for the second lateral invert. If a valid lateral run name is entered in the Lateral Name #2 column, this value is automatically calculated.</td>
</tr>
<tr>
<td>Lateral Name #1</td>
<td>This column contains the name of the first lateral run. The Pipes Run Editor searches for the .mdb file with the lateral run name, and if it retrieves the lateral run file, the discharge flow and invert elevation are imported.</td>
</tr>
<tr>
<td>Lateral Name #2</td>
<td>This column contains the name of the second lateral run. The Pipes Run Editor searches for the .mdb file with the lateral run name, and if it retrieves the lateral run file, the discharge flow and invert elevation are imported.</td>
</tr>
<tr>
<td>Node Drop</td>
<td>This column contains the node drop value, which represents the distance of the drop through the node structure. Modifying the node drop value changes the node’s invert out value and forces an automatic update of all downstream invert values.</td>
</tr>
<tr>
<td>Node Label</td>
<td>This column contains the node label for each upstream node in the pipe run. Each node can have a unique name, such as MH1, MH2, and MH3.</td>
</tr>
<tr>
<td>North</td>
<td>This column contains the northing value of the node’s location point in the pipe run.</td>
</tr>
<tr>
<td>Offset</td>
<td>This column contains the offset value of the node’s location point relative to the current alignment. If there is no currently referenced alignment, this column is left blank.</td>
</tr>
<tr>
<td>Pipe Descr.</td>
<td>This column contains the pipe material description, which you can edit.</td>
</tr>
<tr>
<td>Pipe Drop</td>
<td>This column contains the pipe drop value, which the Pipes Run Editor automatically calculates by multiplying the pipe slope by the pipe length.</td>
</tr>
<tr>
<td>Pipe Flow</td>
<td>This column contains the pipe flow value associated with the pipe segment.</td>
</tr>
<tr>
<td>Pipe Label</td>
<td>This column contains the pipe label name for each segment of the pipe run. The pipe run segment occurs between the node in the same row as the pipe label in the Pipes Run Editor, and the node in the next row down. Each pipe run segment can have a unique label. For example, you can designate the segment between MH3 and MH4 with the label 3-4.</td>
</tr>
</tbody>
</table>
### Conceptual Pipe Runs in Profile (continued)

<table>
<thead>
<tr>
<th>Column Headings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pipe Size</td>
<td>This column contains the pipe size. You can enter any pipe size in this column; however, only pipe sizes that are defined in the Pipe Slope Control Table can be automatically sized based on flow. If the pipe diameter is too small for the design flow, the Pipes Run Editor automatically selects the next available size that meets the design flow requirements.</td>
</tr>
<tr>
<td>Pipe Slope</td>
<td>This column contains the pipe slope value, entered as ft/ft or m/m. For example, enter the value, 0.02, for a pipe slope of 2%. When you change the pipe slope value, the Pipes Run Editor automatically recalculates the value for the finish invert elevation for the pipe segment, as well as all of the downstream invert elevations.</td>
</tr>
<tr>
<td>Rim Elev.</td>
<td>This column contains the rim elevation of the node. Once you define the run, modifying the node’s rim elevation does not affect the inverts in or out.</td>
</tr>
<tr>
<td>Rough Coeff</td>
<td>This column contains the roughness coefficient value for the pipe segment for use in flow calculations, which you can edit. The roughness coefficient used depends on which formula and method you use for pipe flow calculations: Manning, Darcy-Weisbach, or Hazen-Williams. You can either enter a roughness coefficient value, or place your cursor in the Rough Coeff column and click Edit to open the appropriate Coefficient Table dialog box.</td>
</tr>
<tr>
<td>Start Inv.</td>
<td>This column contains the starting invert elevation value for the pipe segment. This value is also the invert out elevation of the current node. You enter only the first starting invert elevation value; each subsequent starting invert through the pipe run is calculated by subtracting the structure drop from the finish invert of the previous pipe, which is the invert in elevation of the current node.</td>
</tr>
<tr>
<td>Station</td>
<td>This column contains the station value of the node’s location point, relative to the current alignment. If there is no currently referenced alignment, this column is left blank.</td>
</tr>
<tr>
<td>Str-Str 3DLength</td>
<td>This column contains the structure-to-structure 3D length value of the pipe segment.</td>
</tr>
<tr>
<td>Struct Dim.</td>
<td>This column contains the structure diameter value of the node, which is taken from the Structure Library Editor dialog box. You cannot edit the structure diameter value.</td>
</tr>
<tr>
<td>Struct Type</td>
<td>This column contains the node’s structure type. You can either enter the structure name, or select a structure from the Structure Library Editor. Place your cursor in this column, and then click Edit to open the Structure Library Editor dialog box.</td>
</tr>
<tr>
<td>Sump Drop</td>
<td>This column contains the sump drop value, which represents the structure’s sump depth below the node’s lowest invert elevation. The sump drop value is taken from the Structure Library Editor dialog box and cannot be edited.</td>
</tr>
<tr>
<td>Sump Elev</td>
<td>This column contains the node’s sump elevation value, which is based on the lowest invert elevation and the sump drop. You cannot edit the sump elevation value.</td>
</tr>
<tr>
<td>Sump Fixed</td>
<td>This column contains the sump elevation’s on/off value. By default, the Sump Fixed field is ON, which means the sump elevation is fixed and is dictated by the node structure’s depth. If the Sump Fixed field value is OFF, then the sump elevation is variable and will not be reset by pipeworks.</td>
</tr>
<tr>
<td>Surface File</td>
<td>This column contains the surface runoff file name. For information about the Runoff option, refer to the section, Runoff, later in this command description.</td>
</tr>
</tbody>
</table>
Conceptual Pipe Runs in Profile (continued)

<table>
<thead>
<tr>
<th>Column Headings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Surface Flow</td>
<td>This column contains the surface runoff flow value for the node or pipe segment. For information about the Runoff option, refer to the section, Runoff, later in this command description.</td>
</tr>
<tr>
<td>Surface On/Off</td>
<td>This column contains the runoff file on/off value, with On represented by 1 and Off represented by 0 (zero). For information about the Runoff option, refer to the section, Runoff, later in this command description.</td>
</tr>
<tr>
<td>Thickness In</td>
<td>This column contains the structure wall thickness in value.</td>
</tr>
<tr>
<td>Thickness Out</td>
<td>This column contains the structure wall thickness out value.</td>
</tr>
<tr>
<td>Wet Area</td>
<td>This column contains the pipe cross section wetted area value based on the design flow calculation. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own pipe cross section wetted area calculations, if necessary. Place your cursor in the Wet Area column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
<tr>
<td>Wet Perim.</td>
<td>This column contains the pipe cross section wetted perimeter value based on the design flow calculation. This value is determined based on the current pipe configuration and flow calculation formula. You can make your own pipe cross section wetted perimeter calculations, if necessary. Place your cursor in the Wet Perim column and click Edit to open the appropriate Pipe Calculator dialog box.</td>
</tr>
</tbody>
</table>

Using Pipe Layer Tools

There are two types of Layer Tools, conceptual pipe run layer tools and finished draft pipe run layer tools. Layer tools allow a variety of ways for you to manipulate layers. Layers allow you to control the appearance of particular drawing elements, in this case, pipes.

Using the Conceptual Pipe Run Layer Tools

You can manipulate layers for conceptual pipe runs using the conceptual pipe run layer tools. These are single line representations of plan and profile view pipe runs. They serve as quick sketches of pipe run configurations, which you can use to check a particular pipe run for proper position and location.

Freezing the Plan Layers

To freeze a selected plan layer
1. From the Pipes menu, choose Conceptual Layers ▶ Plan Freeze.
2. Do one of the following to select the pipe run that is on the layer you want to freeze:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.
Thawing the Plan Layers

To thaw a selected plan layer
1. From the Pipes menu, choose Conceptual Layers ➤ Plan Thaw.
2. Select the pipe run.
3. Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

Turning On the Plan Layers

To turn on a selected plan layer
1. From the Pipes menu, choose Conceptual Layers ➤ Plan On.
2. Select the pipe run.
3. Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

Turning Off the Plan Layers

To turn off a selected plan layer
1. From the Pipes menu, choose Conceptual Layers ➤ Plan Off.
2. Do one of the following to select the pipe run:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

Freezing the Profile Layers

To freeze a selected profile layer
1. From the Pipes menu, choose Conceptual Layers ➤ Profile Freeze.
2. Do one of the following to select the pipe run:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

Thawing the Profile Layers

To thaw a selected profile layer
1. From the Pipes menu, choose Conceptual Layers ➤ Profile Thaw.
2. Select the pipe run.
3. Press ENTER to open the Defined Runs dialog box and select the run, then click OK.
Turning On the Profile Layers

To turn on a selected profile layer
1. From the Pipes menu, choose Conceptual Layers ➤ Profile On.
2. Select the pipe run.
3. Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

Turning Off the Profile Layers

To turn off a selected profile layer
1. From the Pipes menu, choose Conceptual Layers ➤ Profile Off.
2. Do one of the following to select the pipe run:
   - Select the run with your pointing device.
   - Press ENTER to open the Defined Runs dialog box and select the run, then click OK.

Using the Finished Draft Pipe Run Layer Tools

With the finished draft pipe run layer tools, you can manipulate layers for finish draft pipe runs. These are more complex representations of pipe runs in plan and profile views.

Deleting the Finished Draft Plan Layers

To delete the finish plan layers
1. From the Pipes menu, choose Finish Draft Plan ➤ Delete Layer.
2. Do one of the following:
   - Select the pipe run by graphically selecting the run with your pointing device
   - Press ENTER and select the run from the Define Runs dialog box, then click OK.

   The following prompt is displayed
   Delete Selected Pipe Run <{name}> Layers (Yes/No/Cancel)? <Yes>: 
3. Enter Yes to delete the layers for the selected pipe run.
   The following prompt is displayed:
   Erasing entities on layer <{name}> ... 
   Erasing entities on layer <{name}> ... 
   done!

   NOTE Because all entities on the pipe run layer are deleted by the Delete Layer command, you should place each pipe run on a unique layer when establishing the pipe run layer settings.
Deleting the Finished Draft Profile Layers

To delete the finish draft profile layers
1. From the Pipes menu, choose Finish Draft Profile ➤ Delete Layer.
2. Do one of the following:
   - Select the pipe run by graphically selecting the run with your pointing device
   - Press ENTER and select the run from the Defined Runs dialog box, then click OK.

   The following prompt is displayed:
   Delete Selected Pipe Run <{name}> Layers <Yes>: 
3. Enter Yes to delete the selected layers.
   The following prompt is displayed:

   Erasing entities on layer <{name}> ...
   Erasing entities on layer <{name}> ...
   done!

   **NOTE** Because all entities on the run layer are deleted, it is useful when setting up
   the layer settings to place each run on a unique layer.

Deleting the Finish Draft Section Layers

To delete the finish draft section pipe run layers
1. From the Pipes menu, choose Finish Draft Sections ➤ Delete Layer.
2. Do one of the following:
   - Select the pipe run by graphically selecting the run with your pointing device
   - Press ENTER and select the run from the Defined Runs dialog box, then click OK.

   The following prompt is displayed:
   Delete Selected Pipe Run <{name}> Layers <Yes>: 
3. Enter Yes to delete the layer.
   The following prompt is displayed:

   Erasing entities on layer <{name}> ...
   Erasing entities on layer <{name}> ...
   done!

   **NOTE** Because all entities on the run layer are deleted, it is useful, when setting up
   the layer settings, to place each run on a unique layer.
Freezing the Finish Draft Plan Layers

To freeze a selected finish draft plan layer
1 From the Pipes menu, choose Finish Draft Layers ➤ Plan Freeze.
2 Do one of the following:
   ■ Select the pipe run.
   ■ Press ENTER and select the pipe run from the Defined Runs dialog box.
3 Click OK to end the command.

Thawing the Finished Draft Plan Layers

To thaw a selected finish draft plan layer
1 From the Pipes menu, choose Finish Draft Layers ➤ Plan Thaw.
2 Press ENTER, and then select the pipe run from the Defined Runs dialog box.
3 Click OK to end the command.

Turning On the Finished Draft Plan Layers

To turn on a selected finish draft plan layer
1 From the Pipes menu, choose Finish Draft Layers ➤ Plan On.
2 Press ENTER and select the pipe runs from the Defined Runs dialog box.
3 Click OK to end the command.

Turning Off the Finished Draft Plan Layers

To turn off a selected finish draft plan layer
1 From the Pipes menu, choose Finish Draft Layers ➤ Plan Off.
2 Do one of the following:
   ■ Select the pipe run.
   ■ Press ENTER and select the pipe run from the Defined Runs dialog box.
3 Click OK to end the command.

Freezing the Finished Draft Profile Layers

To freeze a selected finish draft profile layer
1 From the Pipes menu, choose Finish Draft Layers ➤ Profile Freeze.
2 Do one of the following:
   ■ Select a pipe run.
   ■ Press ENTER and select the pipe run from the Defined Runs dialog box.
3 Click OK to end the command.
**Thawing the Finished Draft Profile Layers**

To thaw a selected finish draft profile layer
1. From the Pipes menu, choose Finish Draft Layers ➤ Profile Thaw.
2. Press ENTER, and then select the pipe run from the Defined Runs dialog box.
3. Click OK to end the command.

**Turning On the Finished Draft Profile Layers**

To turn on a selected finish draft profile layer
1. From the Pipes menu, choose Finish Draft Layers ➤ Profile On.
2. Press ENTER, and then select the pipe run from the Defined Runs dialog box.
3. Click OK to end the command.

**Turning Off the Finished Draft Profile Layers**

To turn off a selected finish draft profile layer
1. From the Pipes menu, choose Finish Draft Layers ➤ Profile Off.
2. Do one of the following:
   - Select a pipe run.
   - Press ENTER and select the pipe run from the Defined Runs dialog box.
3. Click OK to end the command.

**Freezing the Finished Draft Section Layers**

To freeze a selected finish draft section layer
1. From the Pipes menu, choose Finish Draft Layers ➤ Sections Freeze.
2. Do one of the following:
   - Select a pipe run.
   - Press ENTER and select the pipe run from the Defined Runs dialog box.
3. Click OK to end the command.

**Thawing the Finished Draft Section Layers**

To thaw a selected finish draft section layer
1. From the Pipes menu, choose Finish Draft Layers ➤ Sections Thaw.
2. Do one of the following:
   - Select a pipe run.
   - Press ENTER and select the pipe run from the Defined Runs dialog box.
3. Click OK to end the command.
**Turning On the Finished Draft Section Layers**

To turn on a selected finish draft section layer

1. From the Pipes menu, choose Finish Draft Layers ➤ Sections On.
2. Do one of the following:
   - Select a pipe run.
   - Press ENTER and select the pipe run from the Defined Runs dialog box.
3. Click OK to end the command.

**Turning Off the Finished Draft Section Layers**

To turn off a selected finish draft section layer

1. From the Pipes menu, choose Finish Draft Layers ➤ Sections Off.
2. Do one of the following:
   - Select a pipe run.
   - Press ENTER and select the pipe run from the Defined Runs dialog box.
3. Click OK to end the command.

**Working with Finished Draft Pipe Runs**

Finish draft pipe runs are more complex representations of pipe runs in plan and profile views. You can select from a variety of annotation options when drawing finish draft pipe runs, and you can specify line types, flow direction arrows, and comprehensive labels.

**Drawing Finished Draft Pipe Runs**

The Draw Pipes (Finish Draft Plan) command inserts and labels illustrative blocks, defined in the Structure Library, for each node in the run. It also draws and labels pipes between structures. The linetype of the run is changed to reflect the setting in the Plan Pipe Drafting Settings dialog box.
Creating Finished Draft Runs in Plan View

The Draw Pipes (Finish Draft Plan) command inserts and labels illustrative blocks, defined in the Structure Library, for each node in the run. It also draws and labels pipes between structures. The linetype of the run changes to reflect the setting in the Plan Pipe Drafting Settings dialog box.

The following illustration shows an imported finish draft plan detail:

---

To create finished draft runs in plan view

1. From the Pipes menu, choose Finish Draft Plan ➤ Draw Pipes.
2. Do one of the following:
   - Select the pipe run.
   - Press ENTER and select the run from the Defined Runs dialog box. Click OK.

If the finished draft plan pipe run has been previously drawn, then you can have the particular layers deleted automatically by responding Yes to the following prompt:

Delete Selected Pipe Run <{name}> Layers (Yes/No/Cancel)? <Yes>:
Erasing entities on layer <{name}FINPL> ...
Erasing entities on layer <{name}PLTXT> ...
Importing finish pipes for run <{name}>.

3. Place the structure label by selecting locations or by entering offsets:
   - Type P (for Picking) to specify the location for each structure label as the finished draft plan pipe run is drawn.
   - Type O (for Offset) to enter x and y offset distances relative to each structure for the subsequent location of all the structure labels.

The following informational prompts are displayed:

Processing...
Processing invert list.

You are then prompted whether or not to rotate the structures as they are drawn:

Rotate structures (Yes/No/Cancel)? <Yes>:
Pick rotation angle:
4 Enter Yes or No:
   ■ Enter Yes to specify the rotation angle for each structure in the run (useful for non-circular structure symbols such as catch basins).
   ■ Enter No to place all the structures with a rotation angle of 0 (zero) degrees.
5 If you chose the Picking option, prompts now display for locating each structure label as it is drawn.

Pick location for label:
6 Press ENTER twice to end the command.

**Creating Finished Draft Runs in Profile View**

Use the Draw Pipes (Finish Draft Profile) command to insert and label illustrative blocks, defined in the Structure Library, at the polyline vertices of the run. This command also draws and labels pipes between structures. The linetype of the run changes to reflect the setting in the Profile Pipe Drafting Settings dialog box.

Before using this command, a profile must exist in the drawing and be set as current. To verify that the pipe run is plotted on the correct profile, use the Set Current Profile command from the Profile menu to set the appropriate profile as current.

**To create finish draft runs in profile view**
1 From the Pipes menu, choose Finish Draft Profile ➤ Draw Pipes.
2 Do one of the following:
   ■ Select the pipe run.
   ■ Press ENTER and select the run from the Defined Runs dialog box.
3 Click OK to end the command. The command draws the finish draft profile pipe run.

**Creating Cross Sections of Finished Draft Pipe Runs**

**To create cross sections of finished draft pipe runs**
1 From the Pipes menu, choose Finish Draft Sections ➤ Draw Pipes.
2 Do one of the following:
   ■ Select the pipe run.
   ■ Press ENTER, select the run from the Defined Runs dialog box, and then click OK.
3 Enter the range of cross section stations on which to plot the run.
4 Press ENTER twice to end the command.
Creating Finished Draft Runs Using a Symbol Line Type

To create finished draft runs using a symbol line type

1. From the Pipes menu, choose Finish Draft Plan ➤ Special Lines to display the Special Lines dialog box.
2. From the Description box, choose the appropriate special line name, then click OK to continue. You can also double-click on the appropriate icon slide. These special lines are similar to the AutoCAD Land Development Desktop special lines, and are useful for drafting existing pipe run features.
3. Click OK to exit the dialog box.

Restoring the Appearance of a Profile After Erasing a Pipe Run

Use the Restore Text Areas command to restore the text area in a profile after you delete a run. If you do not use the Restore Text Areas command, then the next time a run is imported in the profile, the text is offset from the area where the previous text was located.

To restore the appearance of a profile after erasing a pipe run

1. From the Pipes menu, choose Finish Draft Profile ➤ Restore Text Areas. The command restores the appearance of a profile.

The following illustration shows restored profile text areas:

Creating Hydraulic Gradelines in Profile View

Use the Hydraulic Gradeline command to draw the hydraulic gradeline of the current pipe run in profile view. The hydraulic gradeline is a graphical representation of the sum of the static and dynamic heads versus the position along the pipeline. In a closed system, the gradeline is a line connecting the total head in the pipe from structure to structure.

The values used by the Hydraulic Gradeline command are calculated in the Pipes Run Editor, which you can modify to suit various needs.
To create hydraulic gradelines in profile view
1 From the Pipes menu, choose Finish Draft Profile ➤ Hydraulic Gradeline.
2 Do one of the following:
   ■ Select the pipe run.
   ■ Press ENTER and select the run from the Defined Runs dialog box, then click OK.

The hydraulic gradeline is drawn automatically on the profile view as a polyline on the {run name}HYD_GRD layer.

Creating Energy Gradelines in Profile View
Use the Energy Gradeline command to draw the energy gradeline of the current pipe run in profile view. The energy gradeline is a graphical representation of the total energy of the flow through the system in terms of potential energy. The vertical difference between the hydraulic gradeline and the energy gradeline is the kinetic energy of the fluid per unit weight, $V^2/2g$.

The values used by the Energy Gradeline command are calculated in the Pipes Run Editor which you can modify to suit various needs.

To create energy gradelines in profile view
1 From the Pipes menu, choose Finish Draft Profile ➤ Energy Gradeline.
2 Do one of the following:
   ■ Select the pipe run.
   ■ Press ENTER, select the run from the Defined Runs dialog box, and then click OK.

The energy gradeline is drawn automatically on the profile view as a polyline on the {run name}HYD_GRD layer.

Identifying and Labeling Areas on a Profile Where a Pipe Run Crosses an Alignment
To highlight and label areas on the profile where a pipe run crosses an alignment.

1 From the Pipes menu, choose Alignments ➤ Define from Polyline to define the pipe run that is to be checked for interference as an alignment.
2 From an existing surface, sample an existing ground profile for the alignment or run, or manually enter the existing ground data using the rim elevations.
3 Create a profile.
4 Import the finished draft of the pipe run to the profile.
5 From the Pipes menu, choose Finish Draft Profile ➤ Align/Run Interferences.
6 Do one of the following to select a pipe run:
   ■ Select the pipe run.
   ■ Press ENTER, select the run from the Defined Runs dialog box, and then click OK.
The area of interference is targeted with an ellipse. A vertical line, starting at the center of the ellipse and drawn upward, is flanked by vertically oriented labels designating the invert elevation at the crossing point and the pipe name. The Align/Run Interferences command uses the label settings established in the Pipes Settings Editor dialog box. If a pipe run structure is coincident with an alignment, the area of interference is also targeted with an ellipse and appropriate labels.

If an area of interference is found, prompts display showing the run name, alignment name, and number of interferences found.

Importing and Exporting Pipe Data

The Import/Export Runs commands import or export files from a variety of formats to this application. In general, you can import or export files to and from an ASCII, WK1 or DB format.

### Importing Pipe Files that are in ASCII (ASC) Format

To import Pipes files in ASCII (ASC) file format
1. From the Pipes menu, choose Import/Export Runs ➤ Import ASCII (ASC File) to display the Pipes Import File dialog box.
2. From the File Name box, select the appropriate file.
3. Click OK to end the command.

### Importing Pipe Files that are in WK1 Format

To import pipe files that are in WK1 format
1. From the Pipes menu, choose Import/Export Runs ➤ Import WK1 to display the Import WK1 File dialog box.
2. Select the appropriate file from the File Name box.
3. Click OK to end the command.

### Importing Pipe Files that are in DB Format

To import pipe files in DB file format
1. From the Pipes menu, choose Import/Export Runs ➤ Import DB to display the Import DB Runs dialog box.
2. Select the appropriate file from the File Name box.
3. Click OK to end the command.
Exporting Pipe Files to ASCII (ASC0 Format)

To export pipe files in ASCII (ASC) format
1. From the Pipes menu, choose Import/Export Runs ➤ Export ASC File.
2. Do one of the following:
   - Select a pipe run.
   - Press ENTER and select the run from the Defined Runs dialog box, then click OK.

After you select a run, an .asc file is created and the following informational prompt is displayed:
Creating run ascii file .. <drive>:\Land Projects R2\{project name}\pipeworks\{name}.asc

Exporting Pipe Files to ASCII Format

Use the Export ASCII command to export Pipes files in ASCII format.

To export pipe files in ASCII format
1. From the Pipes menu, choose Import/Export Runs ➤ Export ASCII.
2. The Pipeworks ASCII Output Dialog is displayed. The current run and ASCII file templates are displayed next to the Run label and Template labels.
3. In the Run section, click Select.
4. Do one of the following:
   - Select a pipe run.
   - Press ENTER, select the run from the Defined Runs dialog box, and then click OK.
5. In the Template section, click Select to display the Load ASCII File Template dialog box.
6. Select the appropriate file from the File Name box, then do one of the following:
   - Click Template Editor to display the Pipeworks Output Template Editor dialog box.
   - Click Print File to export the specified file to your configured printer.
   - Click Help to view information about this dialog box.
7. Click OK to exit the dialog boxes.

Exporting Pipe Files to WK1 Format

To export pipe files in WK1 format
1. From the Pipes menu, choose Import/Export Runs ➤ Export WK1 to display the Export WK1 File dialog box.
2. From the File Name box, click the appropriate file and then click OK.
Exporting Pipe Files to DB Format

To export Pipes files in db format.
1. From the Pipes menu, choose Import/Export Runs ➤ Export DB to display the Export DB Runs dialog box.
2. From the File Name box, click the appropriate file, and then click OK.

Changing the Order in Which Pipe Parameters Are Output

To change the order in which pipe parameters are output
1. From the Pipes menu, choose Import/Export Runs ➤ ASCII ASC File Settings to display the File Import Field Order dialog box.

<table>
<thead>
<tr>
<th>Node Label</th>
<th>In Loss</th>
<th>Out Loss</th>
<th>Pipe Name</th>
<th>Node Size</th>
<th>Pipe Mater.</th>
<th>Pipe Size</th>
<th>Str Lib Ref</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Use this dialog box to specify the order in which Pipes data parameters are to be output.
2. Type the appropriate value, 1 through 14, in the appropriate text box to fix the order.
3. Click Reset to restore the default settings.
Creating Templates for Outputting Pipe Data

To create templates for the output of specific pipes data

1. From the Pipes menu, choose Import/Export Runs ➤ ASCII Template Editor to display the Pipeworks Output Template Editor dialog box.

The Current Template label displays the currently defined Pipeworks output template.

2. In the Template Settings section, do the following:
   - In the Delimiter list, select one of three options: Comma, Space, or Column.
   - In the Comment Prefix list, select one of five options: Semicolon (;), Pound Sign (#), Asterisk (*), REM Statement, or Blank.
   - In the Description 1 box, enter the first description.
   - In the Description 2 box, enter the second description.

3. In the From box, select an output criterion, and then click Append or Insert. This option shows up in the Selection label and the To box. In addition, appropriate text strings display in the Header 1 and Header 2 text boxes, and appropriate units display in the Units list. You can enter new text strings in the Header 1 and Header 2 text boxes if you want, and choose new units from the Units list.
4 Click Delete to remove individual items in the To box. If you want to clear all the selections from the To box, click Delete All.

If the default value is incorrect, you can specify a different column width in the Column Width text box. You can also change the precision value in the Precision text box.

5 Click OK to exit the dialog box.

<table>
<thead>
<tr>
<th>List of Files for Pipes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Path</strong></td>
</tr>
<tr>
<td>&lt;pipewks&gt;</td>
</tr>
<tr>
<td>&lt;pipewks&gt;</td>
</tr>
<tr>
<td>&lt;pipewks&gt;</td>
</tr>
<tr>
<td>&lt;pipewks&gt;</td>
</tr>
<tr>
<td>&lt;pipewks&gt;</td>
</tr>
<tr>
<td>&lt;pipewks&gt;</td>
</tr>
<tr>
<td>&lt;pipewks&gt;</td>
</tr>
</tbody>
</table>

**Notes**

- `<pipewks>`: Represents the pipeworks subfolder of the project folder. For example: c:\Land Projects R2\proj1\pipewks.
- **File Archiving Importance**: Files listed with a P in the Type column are of primary importance and should be archived with all other information pertaining to the particular project. Some re-creation is required if these files are not archived. Files listed with a T are temporary and need not be archived with the project.
Creating and Plotting Sheets Using Sheet Manager

Use the Sheet Manager commands to create plan/profile, plan, profile, and cross section sheets that you can plot. These sheets can have any variety of labels, grids, blocks, or tables that annotate the sheets automatically. You can use sheet styles that are included in the program, or you can create your own, using frames and frame components.

You can use the Sheet Manager commands to create and plot sheets of plan, profile, and cross section design elements.

In this chapter

- Changing Sheet Manager preferences
- Changing cross section sheet preferences
- Generating plan/profile sheets
- Generating profile sheets
- Generating cross section sheets
- Working with sheet tools
- Plotting sheets
- Working with frames
- Working with labels and grids
Changing Sheet Manager Preferences

Sheet Manager Settings

Before generating a sheet series, use the Sheet Manager ➤ Settings command to change program options and set the preferences for layers, sheet series layout, and sheet generation.

The following illustration shows the Settings dialog box:

![Settings Dialog Box]

**NOTE** If you use a sheet style for sheet generation that is not located in the Style Database path, then you receive an error message. Be sure to set this path to the location of the sheet style for the current sheet series you want to generate.
Changing the View Definitions Layer

You can specify the layer the view definitions are placed on when you lay out a sheet series. A view definition is a rectangle that surrounds the part of the plan or profile that is displayed on one sheet in the series. View definitions are created when you lay out the sheet series.

To change the view definitions layer

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Under Layers, do one of the following to specify the view definitions layer:
   - Type the layer for the view definitions in the View Definitions edit box.
   - Click Select to open the Pick Layer Name dialog box, and then from the Layer Name list box, select the layer you want. If the specified layer does not exist, then it is created when needed.
3. Click OK to exit the Pick Layer Name dialog box.
4. Click OK to exit the Settings dialog box.

In the following illustration, the view definitions (rectangles) are displayed on the plan view of the alignment. You can move a view definition if it doesn't cover the area of the alignment that you want plotted on a sheet, as shown:

![View definitions in plan view](image)

Changing the Model Space Match Line Layer

You can specify which layer the model space match lines are placed on. If you select the option in the Sheet Manager Settings to Draw MS Match Lines, then match lines are drawn in model space along the alignment to indicate the divisions between sheets. The match lines indicate where the corresponding profile sheet begins and ends. These match lines are intended to be used as references for working with the sheet layout, but you can also plot them.
To change the model space match line layer

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Under Layers, do one of the following to specify the match lines:
   - Type the layer for the match lines in the MS Match Lines edit box.
   - Click Select to open the Pick Layer Name dialog box, and then from the Layer Name list box, select the layer you want. If the specified layer does not exist, then it is created when needed.
3. Click OK to exit the Pick Layer Name dialog box.
4. Click OK to exit the Settings dialog box.

The following illustration shows the view definitions (rectangles) and model space match lines that are created when you lay out the sheet series:
Changing the Label Frame Layer

You can specify which layer the frames that you create are placed on.

To change the label frame layer
1 From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2 Under Layers, do one of the following to specify the label frames:
   - Type the layer for the label frames in the Label Frames edit box.
   - Click Select to open the Pick Layer Name dialog box. In the Layer Name list box, select the layer you want. If the specified layer does not exist, then it is created when needed.
3 Click OK to exit the Pick Layer Name dialog box.
4 Click OK to exit the Settings dialog box.

Setting the Layout Page Setup Name

Within Sheet Manager, the Load and Generate commands create a new Layout automatically. Each Layout uses a Page Setup to specify plotting criteria. You can specify which Page Setup is used when Sheet Manager creates a new layout.

To create a Page Layout
1 From the File menu, choose Page Setup to display the Page Setup dialog box.
2 Configure Plot Device and Layout Settings as required for your plotter.
3 Click Add next to Page Setup Name to save your settings.
4 Click OK to exit the Page Setup dialog box.

NOTE For more information on this topic, see “Fast Track to Plotting Your First Drawing” in AutoCAD 2000 online Help.

To specify a Page Layout to use with Sheet Manager
1 From the Sheet Manager menu, choose Settings to display the Page Setup dialog box.
2 Under Sheet Options, select a Page Setup for Sheet Manager to use. A Page Setup must exist to display in the list.
3 Click OK to exit the Settings dialog box.
Basing the Sheet Layout on Profile or Plan Lengths

You can modify the display for the profile viewport by selecting the Use Fixed Profile Stations check box.

**To base the sheet layout on profile or plan lengths**

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Under Profile Sheet Options, you can select or clear the Use Fixed Profile Stations check box:
   - Select the Use Fixed Profile Stations check box to base the sheet series layout on the length of alignment that fits within the profile viewport. This option is selected by default.

   When this option is selected, the sheets are divided based on the length of the profile that fits within the profile viewport. Profile overlap is allowed with the profile overlap value that is entered in the Sheet Layout dialog box. The plan viewport is centered over the corresponding segment of the alignment. Adjusting the plan viewport does not modify the segment of profile that is displayed in the profile viewport.

   When the Use Fixed Profile Stations check box is selected, the profile stationing begins at the far left of the profile view frame (top frame). All labels associated with the profile view frame and stationing are placed according to the profile view frame.

   The following illustration shows a fixed profile. As shown, 0+000 in the plan view is directly below 0+000 in the profile view:

   ![Image of a fixed profile showing 0+000 in the plan view directly below 0+000 in the profile view]

   As shown in the preceding illustration, all labels associated with the profile view frame and stationing are placed according to the profile view frame.
Clear the Use Fixed Profile Stations check box to base the sheet series layout on the length of the alignment that fits within the plan viewport.

When this check box is cleared, the profile stationing does not begin at the far left of the profile view frame (top frame). The stationing is placed directly above the stationing in the plan view.

3 Click OK to exit the Settings dialog box.

The following illustration shows a non-fixed profile. As shown, the alignment stationing in the plan view frame does not line up with the profile stationing:

**Non-fixed profile**

### Drawing Model Space Match Lines

You can place model space match lines along the alignment in plan view to indicate where the corresponding profile sheet begins and ends.

**To draw match lines**

1 From the Sheet Manager menu, choose Settings to display the Settings dialog box.

2 Under Profile Sheet Options, you can select or clear the Draw MS Match Lines check box:
   - Select the Draw MS Match Lines check box to place match lines along the alignment in plan view to indicate where the corresponding profile sheet begins and ends. You can use these match lines to help lay out the plan and profile sheets. This option is selected by default.
   - Clear the Draw MS Match Lines check box if you do not want match lines placed along the alignment in plan view.

3 Click OK to exit the Settings dialog box.
Changing the Profile Station Offset
You can control whether the first profile sheet in a series is at a station other than the first station of the profile by specifying a profile station offset.

To change the profile station offset
1 From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2 Under Profile Sheet Options, type an offset value in the Profile Station Offset text box:
   - If you do not specify an offset, then the first profile sheet begins at the first station of the profile.
   - If you enter a negative value, then the first profile sheet begins at a starting point before the first profile station.
   - If you enter a positive value, then the first profile sheet begins after the first profile station. This offset value only affects the first sheet in the series, and does not cause overlap to occur in subsequent sheets.
3 Click OK to exit the Settings dialog box.

Returning to Model Space After Generating Sheets
You can force Sheet Manager to return to model space after you generate sheets.

To return to model space after generating sheets
1 From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2 Under Sheet Options, you can select or clear the Generate Sheets and Return to Model Space check box:
   - Select the Generate Sheets and Return to Model Space check box to automatically return to model space after generating sheets.
   - Clear Generate Sheets and Return to Model Space to remain in paper space after generating sheets.
3 Click OK to exit the Settings dialog box.

Controlling Grid Creation During Label Draw
If you have applied a grid style, you can have the grid redrawn during sheet generation or kept the same. By default, the program redraws the grid.

To control grid creation during label draw
1 From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2 Under Style and Label Options, select the Draw Grid on Label Draw check box.

**NOTE** If you clear the Draw Grid on Label Draw check box, the program does not redraw the grid, but keeps it the same when the sheets are generated.
Aligning Grids to Frame Contents

You can force grids to align themselves to the frame contents, aligning the first vertical grid line with the first vertical profile line or station in the frame.

To align grids to frame contents

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Under Style and Label Options, select the Adjust Grid to View check box.

   **NOTE** If you clear the Adjust Grid to View check box, then grid lines are drawn starting at the edge of the viewport, not at the location of the first vertical profile line or station in the frame.

3. Click OK to exit the Settings dialog box.

In the following illustration, the label on the left lines up with the grid (horizontal line) on the right. The grid begins at the first even increment elevation, as shown:

![Adjust grid to view](image-url)
In the following illustration, the label on the left does not line up with the grid (horizontal line) on the right. The grid begins at the bottom left edge of the profile view frame, as shown:

Non-adjust grid to view

**Changing the Block Search Path**

You can specify the default search path where Sheet Manager searches for blocks that you use with block labels.

**To change the block search path**

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Do one of the following to specify the search path:
   - Under Style and Label Options, type a search path in the Block Search Path edit box.
   - Click Browse to open the Select Block Search Path dialog box and select the path you want.
3 Click OK to exit the Settings dialog box.

If the Block Label command does not find the specified blocks in the search path, then it looks in the Civil Design search path. The Civil Design search path includes the current working folder, the current drawing folder (if different from the working folder) and the Civil Design environment variable path. One way to determine what Civil Design is using for the search path is to use the Civil Design INSERT command and enter a block name that doesn’t exist. A message dialog box is displayed with the search path that was used.

### Changing the Sheet Style Database Path

To copy or move your sheet styles into a different folder, you must manually change the sheet style database path or the Sheet Manager cannot locate the sheet styles.

Likewise, to save new sheet styles to the project folder, you must change the sheet style database path to reflect the new path you are using.

The sheet style folder stores the following items:

- Sheet styles
- Label and grid style information. This information is stored in a number of database files named <filename>.dbf.

This folder path is a project-wide setting. All drawings that access the same project use this folder setting. In a networked environment, you can set the folder to a network folder so other people can access it. The Style Database fully supports multi-user access to the label and grid styles. It uses a locking technique so two people can edit styles simultaneously, but cannot edit the same style at the same time. If two users edit the same style simultaneously, edits are saved for the last person to save his/her work.
To change the sheet style database path

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
   The Style Database section of the dialog box lists the current storage path for sheet styles.
2. Under Style DataBase, click the Set button to edit the Style Database folder path.
   The Style Database Path dialog box is displayed.

   ![Style Database Path dialog box]

   **NOTE** To define the style database path, you can use the Use STYDB check box and/or specify a path.

   Be sure to include a backslash (\) at the end of the path. For example, type `c:\Program Files\Land Desktop R2\data\sheets\`

   You can use either one or both of these options to generate the style database path:
   - When the STYDB check box is selected, part or all of the sheet database path is retrieved from the STYDB key in the sdsn.dfm file.
   - When the STYDB check box is cleared, the entire path is retrieved from the Path edit box. For more information, see “STYDB Key” in this chapter.

   The complete style database path is displayed at the bottom of the dialog box. If you are using both options of the Sheet Database Path dialog box, then verify that a valid folder path is displayed. The default setting is `\installed directory\data\sheets`.
3. Click OK to exit the dialog box and return to the Settings dialog box.
   After you create a new Style Database folder, you can start creating new label and grid styles or you can copy existing styles from another Style Database folder. You can also use the Import Style command to import specific styles from a different Style Database folder.
Sheet Manager Files
When creating a style sheet, Sheet Manager creates and uses three files:

- The .dwg files contain viewport information, paper space borders, frames, and frame component attachment information (where the label styles were placed on the sheet, which label styles the sheet contains).
- The .sdb files contain information related to the saved sheet such as the viewport sizes, categories, and scales as well as layer information.
- The .dbf files contain frame component information for text label, block label, distance label, and grid styles.

The three different file types are stored in the Sheet Style Database folder. The path is specified in the Sheet Manager Preferences and is stored in the project.dfm file.

NOTE Once .sdb and .dbf files are created using AutoCAD Land Development Desktop R2, they may not be used with an earlier version of the Desktop

STYDB Key
The Use STYDB key defined in SDSK.DFM file check box lets you control whether to use the .dfm file.

- Clear the Use STYDB key defined in SDSK.DFM file check box. Either enter or browse to a style database path location, such as J:\Sheets\.
- Select the Use STYDB key defined in SDSK.DFM file check box to use the path stored within the sdsk.dfm file. Specify the folder, such as \My Sheets, as the database path. This will append to the path in the SDSK folder, for example, J:\Sheets. The path now uses J:\Sheets\My Sheets.

NOTE Although the STYDB option was added to support multi-user environments, you can also use it for single-user systems.

Editing the sdk.dfm File
You can set the STYDB key value in your sdk.dfm file.

To set the STYDB key value in the sdk.dfm file
1 In the program root, such as the \Land Desktop folder, open the sdk.dfm file using NotePad.
2 In NotePad, search for the STYDB key. For example, STYDB=(J:\Sheets\, Sheet Manager Templates).
3 Change the setting to the desired folder.
4 Choose File ➤ Save to save the sdk.dfm file.

Path Edit Box
If necessary, type a path in the Path edit box. If you select the Use STYDB key defined in SDSK.DFM file check box, then the path in the Path edit box is combined with the path defined in the sdk.dfm file to create the entire sheet database path. Each person can use the Path edit box to set the portion of the path that is common to all.
If the Path edit box is empty, then the entire sheet database path is retrieved from the STYDB path.

**NOTE** When entering a folder path with the Path edit box, always include the ending \ (backslash) in the path. For example, \Sheets\.

<table>
<thead>
<tr>
<th>When the STYDB check box...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>is selected</td>
<td>all or a portion of the sheet database path is retrieved from the STYDB key in the sdsk.dfm file.</td>
</tr>
<tr>
<td>is cleared</td>
<td>the entire path is retrieved from the Path edit box.</td>
</tr>
</tbody>
</table>

### Changing Cross Section Sheet Preferences

You can use the Sheet Manager ➤ Settings command to control several cross section sheet preferences. These preferences control margins, scales, and volume calculation methods.

You must adjust many of the Cross Section Preferences prior to generating a cross section sheet series. The default options may not properly generate the sheets. For example, be sure that the Horizontal Scale is appropriate to the width of the cross sections that you sampled in your drawing. For example, in imperial units, if you set the horizontal scale to 50, a section that was sampled with a swath width of 200’ on the left and 200’ on the right would take up 8” on a paper space sheet (to cover the entire 400’).

Be sure to check the default Border Spacing and Internal Section spacing values. By default, these units are 1, which means that in metric units, 1 unit in paper space (one meter) is equal to 1 meter of model space. A more appropriate value would be something like .01.
Changing the Horizontal Scale

Section sheets are generated in paper space. The scaling values are based on the relationship between the section swath width and paper space units. For example, in imperial units, if you set the horizontal scale to 50, a section that was sampled with a swath width of 200" on the left and 200" on the right would take up 8" on a paper space sheet (to cover the entire 400").

To change the horizontal scale for section sheets

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Section Preferences button to display the Cross Section Preferences dialog box.

   ![Cross Section Preferences dialog box](image)

3. In the Cross Section Sheet Options section, type the horizontal scale for cross section plotting in the Horizontal Scale box.

   Be sure that the Horizontal Scale is appropriate to the width of the cross sections that you sampled in your drawing. If the scale value is too small, then you see an error message saying that the section is too large for the sheet when you attempt to generate the section sheet series.

4. Click OK to exit the Cross Section Preferences dialog box.
5. Click OK to exit the Settings dialog box.
Changing the Vertical Scale

Section sheets are generated in paper space. The scaling values are based on the relationship between the section height and paper space units. For example, in imperial units, if you set the vertical scale to 5, a section that is 20’ high would take up 4” in height on a paper space sheet (to cover the entire 20’).

To change the vertical scale for section sheets
1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Section Preferences button to display the Cross Section Preferences dialog box.
3. In the Cross Section Sheet Options section, type the vertical scale for cross section plotting in the Vertical Scale box. The Vertical Scale is commonly one-tenth the value of the Horizontal Scale.
   If the sections do not fit on the sheet either horizontally or vertically, then the section sheets are generated with no sections.
4. Click OK to exit the Cross Section Preferences dialog box.
5. Click OK to exit the Settings dialog box.

Snapping Sections to a Grid

If you have created a sheet style that has a grid style attached to the Section/View frame, then you can use the Snap Sections to Grid option to force the sections to snap to the grid lines when the sheets are generated. If you manually draw a grid on the sheet, then the Snap Sections to Grid option does not work.

To force cross sections to snap to a grid on a sheet
1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Section Preferences button to display the Cross Section Preferences dialog box.
3. In the Cross Section Sheet Options section, select the Snap Sections To Grid check box. When this check box is selected, the section sheet generation commands align the even elevations of the cross sections to the horizontal lines of the grid, and the even stations to the vertical lines of the grid. This option only applies if you are using a section sheet style that has been formatted to use a grid.
4. Click OK to exit the Cross Section Preferences dialog box.
5. Click OK to exit the Settings dialog box.

NOTE
If the grid does not match the spacing created by the scale and swath widths, the snapping does not occur. For example, if you create a grid that is 0.33” spacing vertically, the snapping does not occur for a section that is 1” = 50’ horizontally and 1” = 5’ vertically.
Changing the Column Spacing

To control the amount of space between columns of cross sections on a sheet

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Section Preferences button to display the Cross Section Preferences dialog box.
3. In the Cross Section Sheet Options section, type the amount of space between columns of cross sections on the plotted sheet in the Column Spacing box. Enter this value in paper space units, such as inches for Imperial units and meters for Metric units.
4. Click OK to exit the Cross Section Preferences dialog box.
5. Click OK to exit the Settings dialog box.

**NOTE**
The horizontal distance between sections is actually Column Spacing and Left/Right spacing. If you want 1 inch between sections, add column spacing and left/right spacing to see if the spaces equal 1 inch. Snap Sections to Grid may modify the left/right spacing to ensure that the section snaps match a user-defined grid with that style. For more information, see “Snapping Sections to a Grid” in this chapter.

The following illustration shows the Cross Section Preference settings that control the spacing and layout of the cross sections on a section sheet. This diagram relates to any spacings set with Cross Sections:

![Cross section sheet preference example](image)

Changing the Row Spacing

To control the amount of space between rows of cross sections on a sheet

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Section Preferences button to display the Cross Section Preferences dialog box.
3. In the Cross Section Sheet Options section, type the amount of space between rows of cross sections on the plotted sheet in the Row Spacing box. Enter this value in paper space units, such as inches for Imperial units and meters for Metric units.
Snap Sections to Grid may modify the left/right or top/bottom spacing to ensure that the section snaps match a user-defined grid with that style. For more information, see “Snapping Sections to a Grid” in this chapter. For an illustration, see “Changing the Column Spacing” in this chapter.

4 Click OK to exit the Cross Section Preferences dialog box.
5 Click OK to exit the Settings dialog box.

**Changing the Section Sheet Border Spacing**

You can specify the amount of space that Sheet Manager leaves as a border around the cross section sheet. This border spacing depends on the Left/Right and Top/Bottom settings you specify. For more information, see “Changing the Cross Section Sheet Preferences” in this chapter.

**To specify the amount of border space on a section sheet**

1 From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2 Click the Section Preferences button to display the Cross Section Preferences dialog box.
3 Under Section Sheet Border Spacing, type the top/bottom margin in the Top/Bottom box.

Enter this value in paper space units, such as inches for Imperial units and meters for Metric units. The margin is dependent upon the layout of the cross sections on the page that you set with the Horizontal and Vertical Layout options. If you specify that the cross sections are placed on the page starting at the bottom left corner, then the Top/Bottom margin is placed at the bottom of the sheet.

4 Under Section Sheet Border Spacing, type the left/right margin in the Left/Right box.

Enter this value in paper space units, such as inches for Imperial units and meters for Metric units. If you specify that the cross sections are placed on the page starting at the bottom left corner, then the Left/Right margin is placed at the left of the sheet.

For an illustration, see “Changing the Column Spacing” in this chapter.
5 Click OK to exit the Cross Section Preferences dialog box.
6 Click OK to exit the Settings dialog box.
Changing the Internal Section Spacing

You can add some space above and below the cross sections on the sheet by adding some space below the cross section datum line and above the maximum elevation of the cross section.

To control the amount of space that is placed above and below the cross sections

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Cross Section Preferences button to display the Cross Section Preferences dialog box.
3. Under Internal Section Spacing, type the amount of space to insert below the cross section in the Below Datum box. Enter this value in paper space units, such as inches for Imperial units and meters for Metric units.

   **NOTE** The Below Datum box controls how much space is inserted within the section view below the datum line. This is the Section – Section frame where the spacing displays. The "distance below datum" is the distance from the bottom of the Section – Section frame to the lowest graphical element on the cross section, whether it is finish ground or existing ground.

   For an illustration, see “Changing the Column Spacing” in this chapter.

4. Under Internal Section Spacing, type the amount of additional space to show above the highest point on that section view in the Above Max box. Enter this value in paper space units, such as inches for Imperial units and meters for Metric units. This allows for additional space for section labels.

   **NOTE** The Above Max and Below Datum values do not affect the row spacing value; they control the space inside the cross section area.

Changing the Horizontal Layout

You can specify whether Sheet Manager places cross sections on a sheet starting from either the left or the right of the sheet.

To control the horizontal layout of cross sections on a sheet

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Section Preferences button to display the Cross Section Preferences dialog box.
3. Under Horizontal Layout, you can select how to place cross sections:
   - Select the Left to Right option to place cross sections on the sheets beginning from the left side of the section/view frame.
   - Select the Right to Left option to place cross sections on the sheets beginning from the right side of the section/view frame.

   For an illustration, see “Changing the Column Spacing” in this chapter.

4. Click OK to exit the Cross Section Preferences dialog box.
5. Click OK to exit the Settings dialog box.
Changing the Vertical Layout
You can specify whether Sheet Manager places cross sections on a sheet starting from either the bottom or the top of the sheet.

To control the vertical layout of cross sections on a sheet
1 From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2 Click the Section Preferences button to display the Cross Section Preferences dialog box.
3 Under Vertical Layout, you can select how to place cross sections:
   - Select the Bottom to Top option to place cross sections on the sheets beginning from the bottom of the section/view frame.
   - Select the Top to Bottom option to place cross sections on the sheets beginning from the top of the section/view frame.
4 Click OK to exit the Cross Section Preferences dialog box.
5 Click OK to exit the Settings dialog box.

Changing the Volume Calculation Method
You can choose which volume calculation method is used for plotting cut and fill volumes on the section sheets.

To choose the volume calculation method
1 From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2 Click the Section Preferences button to display the Cross Section Preferences dialog box.
3 Under Volume Calculation Method, you can select the method for volume calculation:
   - Select Average End Area to use the Average End Area method of volume calculation. With this method, the average of adjacent cross section areas is multiplied by the distance between them. The commands calculate all data from the actual values, but the reported values are rounded to the desired volume precision for display purposes.
   - Select Prismoidal to use the Prismoidal method of volume calculation. This method is also known as the grid method. When using this method, a regular grid is overlaid on the two surfaces. The elevations on both surfaces are calculated at each grid intersection. The resulting face is then broken down into two triangular prisms.
4 Click OK to exit the Cross Section Preferences dialog box.
5 Click OK to exit the Settings dialog box.
**Using Curve Correction**

You can choose to use curve correction for volume calculations. In normal volume calculations, the length between the end areas on horizontal curves is taken from the length along the centerline curve. With curve correction in use, the length is taken from the path of the average centroid of the areas for more accurate results.

To use curve correction in volume calculations

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Section Preferences button to display the Cross Section Preferences dialog box.
3. Under Volume and Area Control, select the Use Curve Correction check box to use curve correction in volume calculations.
4. Click OK to exit the Cross Section Preferences dialog box.
5. Click OK to exit the Settings dialog box.

**Changing the Cut Correction Value**

To more accurately calculate cut volumes, you can specify a cut correction value. The cut and fill correction values are used when computing volumes to help determine the actual volume of material that needs to be removed from or added to the site. For a material that expands 15%, enter the value 1.15. Whereas, for a material that compacts to 93% of its original value, enter the value 0.93. A factor of 1.00 does not adjust the volumes.

To change the cut correction value

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Section Preferences button to display the Cross Section Preferences dialog box.
3. Under Volume and Area Control, type the cut correction value in the Cut Correction box.
4. Click OK to exit the Cross Section Preferences dialog box.
5. Click OK to exit the Settings dialog box.
Changing the Fill Correction Value

To more accurately calculate fill volumes, you can specify a fill correction value. For a material that expands 15%, enter the value 1.15. Whereas, for a material that compacts to 93% of its original value, enter the value 0.93. A factor of 1.00 does not adjust the volumes.

**To change the fill correction value**

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Section Preferences button to display the Cross Section Preferences dialog box.
3. Under Volume and Area Control, type the fill correction value in the Fill Correction box.

**NOTE** The cut and fill values are used when computing volumes to help determine the actual volume of material that needs to be removed from or added to the site.

4. Click OK to exit the Cross Section Preferences dialog box.
5. Click OK to exit the Settings dialog box.

Appending Surface Names to EG and Template Layers

The cross sections on a section sheet are actually created in paper space and are saved as part of the generated sheet. You can specify the layers on which you want Sheet Manager to create the paper space entities. These entities represent items like the existing ground surface, the template you used for the cross sections, and so on.

You can append the names of surfaces within your project to certain cross section sheet layer names for easier layer management. For example, if you specify EG as the layer for the existing ground, and the existing ground surface name in your project is Route 202, then the existing ground layer name in your cross section sheet is Route 202 - EG.

**To append surface names to layers**

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click the Section Preferences button to display the Cross Section Preferences dialog box.
3. Under Surface Layers, you can select one of the following check boxes:
   - Select the EG Layer check box to add the surface name to the existing ground layer name.
   - Select the Template Layer check box to add the surface name to the template layer name.

For example, if the template surface layer name is set to template and the Template Layer check box is cleared, then all template surfaces are drawn on the same layer, template. However, if the Template Layer check box is selected, each
Changing Cross Section Sheet Preferences

The cross sections on a section sheet are actually created in paper space and are saved as part of the generated sheet. You can specify the layers on which you want Sheet Manager to create the paper space entities. These entities represent items like the existing ground surface, the template you used for the cross sections, and so on.

**NOTE** Plan and profile views that are displayed on generated sheets are not paper space entities and are not saved as part of the sheet.

**Changing the Section Sheet Layer Settings**

The cross sections on a section sheet are actually created in paper space and are saved as part of the generated sheet. You can specify the layers on which you want Sheet Manager to create the paper space entities. These entities represent items like the existing ground surface, the template you used for the cross sections, and so on.

**NOTE** Plan and profile views that are displayed on generated sheets are not paper space entities and are not saved as part of the sheet.

**To set the surface layer settings**

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Click Section Preferences to display the Cross Section Preferences dialog box.
3. Under Surface Layers, click the Layer Settings button to open the Cross Section Preferences dialog box.
4. Set the layers for each part of the cross section that is generated on the sheet. Either type in a layer name or click the Select button in each row to display the Pick Layer Name dialog box, where you can choose the layer name.
5. Click OK to exit the Cross Section Preferences dialog boxes.
6. Click OK to exit the Settings dialog box.
Naming a Sheet Series

A sheet series is a group of sheets that is associated with a particular alignment in your project. You can create plan/profile sheet series, profile sheet series, and section sheet series. You can create plan-only sheet series by modifying a plan/profile sheet series.

The following steps outline the process of creating a sheet series:

1. Name the new series. When you name a sheet series, a folder for storing the series sheets is created with that name in c:\Land Projects R2\<project name>\cd\data. For more information, see “Naming a Plan/Profile Sheet Series” in this chapter.

2. Set up a sheet style for the series. The sheet style includes viewports for plan and profile, and frames for cross sections. It also includes frames and label styles for labeling the design data. For more information, see “Creating a New Plan/Profile Sheet Style” in this chapter.

3. Lay out the sheets to determine what views of the plan and profile is displayed on each sheet. For more information, see “Laying Out a Plan/Profile Sheet Series” in this chapter.

   NOTE You skip the layout step when creating section sheet series.

4. Generate the sheets. The sheets are automatically saved to the series folder. The sheets are sequentially numbered in the format s001.dwg, s002.dwg, starting with a specified number. There can be up to 999 sheets in any series. For more information, see “Generating a Series of Plan/Profile Sheets” in this chapter.

For plan and profile sheets, the saved sheets for a series are composed of the paper space components only: the border, title block, viewports and annotation. The design elements of the project that are in model space are not saved with the sheets. To work with a saved plan/profile or profile sheet, you need to be working in a drawing that contains the model space entities. Or, you can use XREFs to reference model space entities that exist in a drawing that is within the current project.

For section sheet series, the cross sections themselves are created in paper space, so you can specify new layers on which different parts of the cross sections are created. You do not need to have the site drawing available to view or plot the section sheets.

Naming a Plan/Profile Sheet Series

The first step in creating a new sheet series is to name the new series. When you name a sheet series, a folder for storing the series sheets is created with that name in c:\Land Projects R2\<project name>\cd\data.

Use the Set/Define Series command to define a name for a new plan/profile series. When you name a new series, a folder for storing the sheets is created in the folder c:\Land Projects R2\<project name>\cd\data.

You can also use this command to select an existing sheet series name for subsequent sheet functions.
To name a sheet series

1. From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Set/Define Series to display the Set Current Sheet Series Name dialog box.

   ![Set Current Sheet Series Name dialog box]

2. Select a series in one of the following ways:

   - To define a new sheet series, enter the name in the Current Series edit box, and then click OK.
   - To choose an existing sheet series as the current series, you can double-click its name in the Existing Series list box, or you can select its name, and then click OK.
   - If you have already performed a sheet series layout, then you can use the Pick Viewport Definition<< button to set the current series. Click the button, and then use your pointer to select a view definition of the series you want to set as current. The Set Current Sheet Series Name dialog box is redisplayed, with the selected sheet series listed as current. Click OK to exit the dialog box.

   **NOTE** The drawing must be set to model space in order to use the Pick Viewport Definition<< option.
**Naming a Profile Sheet Series**

Use the Set/Define Series command to define a name for a new profile series. When you name a new series, a folder for storing the sheets is created in `c:\Land Projects R2\<project name>\cd\data`.

**To name a sheet series**

1. From the Sheet Manager menu, choose Profile Sheets ➤ Set/Define Series to display the Set Current Sheet Series Name dialog box.

2. Select a series in one of the following ways:
   - To define a new sheet series, enter the name in the Current Series edit box, and then click OK.
   - To choose an existing sheet series as the current series, you can double-click its name in the Existing Series list box, or you can select its name, and then click OK.
   - If you have already performed a sheet series layout, then you can use the Pick Viewport Definition<< button to set the current series. Click the button, and then use your pointer to select a view definition of the series you want to set as current. The Set Current Sheet Series Name dialog box is redisplayed, with the selected sheet series listed as current.

3. Click OK to exit the dialog box.

**NOTE**

The drawing must be set to model space in order to use the Pick Viewport Definition<< option.
Naming a Section Sheet Series

Use the Set/Define Section Series command to define a name for a new section series. When you name a new series, a folder for storing the sheets is created in c:\Land Projects R2\<project name>\cd\.

To set the current series name

1. From the Sheet Manager menu, choose Section Sheets ➤ Set/Define Section Series to display the Set Current Sheet Series Name dialog box.

![Set Current Sheet Series Name dialog box](image)

2. Select a series in one of the following ways:
   - To define a new sheet series, enter the name in the Current Series edit box, and then click OK.
   - To choose an existing sheet series as the current series, you can double-click its name in the Existing Series list box, or you can select its name, and then click OK.
   - If you have already performed a sheet series layout, then you can use the Pick Viewport Definition<< button to set the current series. Click the button, and then use your pointer to select a view definition of the series you want to set as current. The Set Current Sheet Series Name dialog box is redisplayed, with the selected sheet series listed as current.

3. Click OK to exit the dialog box.
Laying Out a Plan/Profile Sheet Series

After you have defined your sheet styles, the next step for plan/profile and profile sheet series is to switch back to model space and lay out the sheet views (this step is not necessary when you are generating section sheets). Before laying out the sheet views, you must first select a sheet style and set a current alignment and profile.

The layout is performed in model space. The required plan and/or profile views must exist in the current drawing as either part of the drawing or as an XREF. When you perform a sheet series layout, rectangles are placed over the alignment in model space for plan and profile, as shown in the following illustration:

Sheet series layout

These rectangles represent the paper space viewports of the selected sheet style, and are referred to as view definitions. They are used to define the model view in a plan and/or profile viewport for a particular sheet. During the layout process, each view definition represents one sheet in a series as it appears when the series is generated. You can modify the exact location of these views before you generate the sheet series.

Changing Plan/Profile Series Layout Options

You can specify sheet layout options before laying out the sheet series.

NOTE  The dialog box that is displayed when you select this command is also displayed when you select the Layout Sheet Series command. You can set up the series options using either command.
To change the sheet layout options

1. From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Edit Sheet Series. The Set Current Sheet Series dialog box is displayed and lists the names of the sheet series that were defined with the Set/Define Series command.

2. Select the sheet series that you want to edit, and then click OK to display the Edit Sheet Series Data dialog box.

   ![Edit Sheet Series Data dialog box]

   The name of the current series is listed in the Series Name edit box.

3. Review the Alignment/Profile Data section information.

   If the wrong alignment, or none at all, is listed, then exit the command and use the Select Alignment and the Set Current Profile commands to set the current alignment and profile.

4. Select which sheet style you want the series to use.

5. Click the Set Style button to display the Select Current Sheet Style dialog box.

   Use this dialog box to set the sheet style, and then click OK to return to the Edit Sheet Series Data dialog box.

6. Type the starting sheet number.

   The sheets are numbered sequentially starting with the starting sheet number. When the sheet series is generated, the sheets are automatically saved to the sheet series folder in the format s001.dwg, s002.dwg, and so on, where 1 is the starting sheet number.

7. Type the sheet overlap distance.

   The sheet overlap distance controls how much each sheet in the series overlaps the following sheet in the sequence. Enter this distance in model space units (such as in alignment length units). If you select the Use Fixed Profile Stations option in the Sheet Manager Preferences dialog box, then the Sheet Overlap Distance value is the amount of overlap for the profile, not the amount of overlap for the horizontal alignment.

8. Click OK to save the settings, or Cancel to cancel the command.
Creating a Plan/Profile Sheet Series Layout

To determine what part of the plan and profile is on each sheet in the series, you need to lay out the series.

When you lay out a sheet series, rectangular view definitions are placed over the plan view of the alignment in model space. Each rectangle represents one sheet in the series. If the rectangle does not cover the alignment properly, you can move or rotate the rectangle so it covers the area of the alignment that you want to appear on the sheet. If the rectangles are the wrong size, change the viewport view scale.

The dimensions of the viewport and the scale factor associated with that viewport actually determine the size of the view definitions in model space. For example, if the scale of the viewport is 1"=50' and the dimension of the viewport is 10 in., then the view definition is 500'.

**NOTE** This is a model space command.

To lay out a sheet series

1. Change the Sheet Manager Settings, if necessary.
   The layout is affected by the Use Fixed Profile Stations setting in the Settings dialog box.

2. From the Sheet Manager menu, choose Plan/Profile Sheets ➔ Layout Sheet Series to display the Set Current Sheet Series Name dialog box.

3. Select a series.

   **NOTE** If there are existing layouts for a series, the Existing Sheet Series Detected dialog box is displayed, warning you that the existing series of layouts will be deleted.

4. Do one of the following:
   - To continue the series generation, click OK. The program deletes the existing layout.
   - To terminate the process to the command line, click CANCEL.

The presence of existing layouts is determined by comparing the characters in the series name to the first characters to the left side of the plus sign (+) delimiter of the layout name. For example, if the series name is ELM, then layouts named ELM+001 are deleted, while layout name ELM SAVE is not deleted. You can prevent some of the existing series layouts from being deleted by renaming the layout.
The Edit Sheet Series dialog box is displayed, where you can edit the sheet series settings if needed.

5. Click OK to exit the Edit Sheet Series dialog box. The command places rectangular view definitions along the alignment.

6. Edit the sheet layout to specify which view of the profile each sheet contains. You can also use the layout editing command to adjust the location and rotation of the plan view definitions.

**NOTE**
By default, all views of the profile in a plan/profile sheet series are created with the same datum elevation. You must edit the layout to specify the profile datum elevation for each sheet.

If the Settings option to Draw MS Match Lines is selected, then match lines are drawn in model space along the alignment to indicate where the corresponding profile view begins and ends.

**Adding a New Sheet to a Plan/Profile Sheet Series Layout**
You can add a sheet to the current series layout if necessary.

**NOTE**
This is a model space command.

**To insert a new sheet**

1. In the Settings dialog box, clear the Use Fixed Profile Stations check box. When the Use Fixed Profile Stations option is cleared, the profile view matches the plan view. When the Use Fixed Profile Stations option is selected, plan view automatically snaps to the nearest station based on the profile view length.

2. From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Insert Sheet Series to display the Set Current Sheet Series Name dialog box.
3. Select a series.

The sheet is placed into model space over the plan view as a dotted or solid line and numbered as the next sheet in the series. The corresponding profile viewport is also shown on-screen.

The Edit Sheet View Definition dialog box is displayed.

4. Click the Move by Point< button. The Edit Sheet View Definition dialog box closes.

5. Use your pointer to pick a new starting point for the view definition (based on the leftmost edge of the view definition).

The view definition is moved to the new starting point and the Edit Sheet View Definition dialog box is redisplayed.

6. In the Datum box, adjust the datum elevation of the view definition by typing a value.

7. Click OK to exit the command.

8. To insert another sheet, click Insert Sheet Series again and repeat steps 1–7.

9. Click OK to save your edits and exit the dialog box.

**NOTE**

If you use this command before laying out the series, then the first view definition area displays over the plan view of the current alignment as either a dotted or solid line, and numbered as the first sheet in the series.
**Editing a Plan/Profile Sheet Layout**

After you lay out the sheet series, you can adjust the position and rotation of the plan view definitions if the rectangles are not properly covering the horizontal alignment. You can also adjust the profile datum elevation so the correct view of the profile is displayed in the profile viewport of each sheet. The profile needs to be set current.

If the profile is not shown because layers are either turned off or frozen, then the profile view definition is displayed where the profile would be located.

**NOTE**  
You can also use the grips and/or the MOVE and ROTATE commands to modify the location of the plan view definitions.

**NOTE**  
This is a model space command.

**To adjust the sheet layout**

1. From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Edit Sheet Layout.  
The following prompt is displayed:

   **Select a Sheet Series View Definition (press Return to enter sheet number):**

2. Select a sheet series view definition. The view definition you selected is highlighted, and the corresponding profile view definition is drawn over the profile.
The Edit Sheet View Definition dialog box is displayed.

3 Change the scale in the View Scale edit box, if necessary.
This view scale defaults to the scale that you set the viewport to when you defined the sheet. If you change the view scale value, press ENTER to update the layout with the new scale.

**NOTE** This command does not modify the layout of any subsequent sheets based on this change.

4 You can edit the plan view definition to control what part of the plan is displayed on a sheet. For more information, see “Editing the Plan View Definition” in this chapter.

5 You can edit the profile view definition to control what part of the profile is displayed on a sheet.
For more information, see “Editing the Profile View Definition” in this chapter.

6 To edit the next sheet, click the Next Sheet> button. Click the <Prev Sheet button to move to the previous sheet in the series.

7 Click OK to exit the command and save the changes you have made.
Any changes that you make regarding the location and scale of the view definitions is reflected in subsequent plan/profile sheet generation functions.
If the section of the profile covered by the view definition has a great elevational change, then you may need to split the profile view and change the datum elevation of the split viewport with the Sheet Tools ➤ Profile View Tools ➤ Split Profile View command after the sheet is generated.

The following illustration shows the highlighted view definition over the plan view and the corresponding profile view area:

![View definition over the plan view](image)

**NOTE**

**Editing the Plan View Definition**

There are three ways to adjust the position of a plan view definition:

- **Changing the start station**: Type a new value in the Start Station edit box, and then press ENTER. The view definition is moved and the End Station value is updated to reflect the position.
- **Picking a new point**: Click the Move by Point< button, and then pick a new starting point for the sheet.
- **Rotating the view definition**: Click the Rotate< button, and then use your pointing device to set a new rotation angle.

If the Use Fixed Profile Station Option check box is selected in the Preferences dialog box, then this option does not modify the profile stations for the current sheet. It is just used to adjust the view of the alignment. If the Use Fixed Profile Station check box is cleared, then adjusting the plan view also modifies the profile view.

**Editing the Profile View Definition**

Use the Datum edit box to edit the datum elevation so the view definition contains the view you want. The minimum and maximum elevations for the profile surfaces are displayed as a reference you can use when adjusting the datum.
cleared then you can edit the start station. However, if this option is selected, then the start station is fixed and you are unable to edit it.

**Deleting a Plan/Profile Sheet Series Layout**

You can quickly delete the rectangular view definitions that were placed along the alignment when you laid out the sheet series.

**NOTE** This command does not delete the drawing files that were generated for the series. To completely delete a series and all related files, use the Delete Series command.

**To delete a sheet layout**

1. From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Delete Series Layout to display the Set Current Sheet Series dialog box.
2. Select the sheet series whose view definitions you want to delete, and then click OK.

The view definitions for the selected sheet series are erased from model space.

**NOTE** You can also use the ERASE command to erase the layout.

**Laying Out a Profile Sheet Series**

**Changing Profile Series Layout Options**

You can set up the default series options before laying out the series.

**NOTE** The dialog box that is displayed when you select this command is also displayed when you select the Layout Sheet Series command. You can set up the series options using either command.

**To set the sheet layout options**

1. From the Sheet Manager menu, choose Profile Sheets ➤ Edit Sheet Series to display the Set Current Sheet Series dialog box.
2. Do one of the following to select the sheet series:
   - In the Existing Series box, double-click the series name, and then click OK.
   - Click the Pick Viewport Definition<< button, select a view definition of the sheet series, and then click OK. Your drawing must be set to model space to use this option.
   - To define a new sheet series, type the new name in the Current Series box and then click OK. A new layout is created and used.

The Edit Sheet Series Data dialog box is displayed.

The name of the current series is listed in the Series Name edit box.
3 Review the Alignment/Profile Data section information. If the wrong alignment is listed, then exit the command and use the Select Alignment and the Set Current Profile commands to set the current alignment and profile.

4 Select a sheet style. Click the Set Style button to display the Set Current Sheet Style dialog box. Use this dialog box to set the sheet style, and then click OK to return to the Edit Sheet Series Data dialog box.

5 Type the starting sheet number. The sheets are numbered sequentially starting with the starting sheet number. When the sheet series is generated, the sheets are automatically saved to the sheet series folder in the format s001.dwg, s002.dwg, and so on, where 1 is the starting sheet number.

6 Type the sheet overlap distance. The sheet overlap distance controls how much each sheet in the series overlaps the following sheet in the sequence. Enter this distance in model space units (such as alignment length units). If you selected the Use Fixed Profile Stations option in the Sheet Manager Settings dialog box, then the sheet overlap distance value is the amount of overlap for the profile.

7 Click OK to save the settings, or Cancel to cancel the command.

Creating a Profile Sheet Series Layout

To determine what part of the profile is on each sheet in the series, you need to lay out the series. When you lay out a series, rectangular view definitions are placed over the profile view of the alignment in model space. Each rectangle represents one sheet in the series. The profile view definitions are all placed in model space at the same datum elevation. You may need to adjust the datum elevation of the view definitions so they cover the areas of the profile that you want to display on the sheet.

NOTE This is a model space command.
To lay out a sheet series

1. From the Sheet Manager menu, choose Profile Sheets ➤ Layout Sheet Series to display the Set Current Sheet Series Name dialog box.
2. Select a series.
   The Edit Sheet Series Data dialog box is displayed.
3. Change the sheet series options, if necessary.
4. Click OK to exit the Edit Sheet Series Data dialog box.
   The command lays out the view definitions over the profile. The dimensions of each rectangle reflect the dimensions of the profile viewport of the sheet style as well as the scale assigned to those viewports.
5. To edit the sheet series layout, including setting the datum for the profile viewports, use the Edit Sheet Layout command.
Adding a New Sheet to a Profile Sheet Series Layout

You can add sheets to the current profile series layout if necessary.

**To insert a new sheet into a profile series layout**

1. From the Sheet Manager menu, choose Profile Sheets ➤ Insert Sheet Series to display the Set Current Sheet Series Name dialog box.
2. Select a series.

   The sheet is placed in model space, numbered as the next sheet in the series, and the Edit Sheet View Definition dialog box is displayed.
Click the Move by Point< button. The Edit Sheet View Definition dialog box closes.

Use your pointer to pick a new starting point for the view definition (based on the leftmost edge of the view definition). The view definition is moved to the new starting point and the Edit Sheet View Definition dialog box is redisplayed.

In the Datum box, adjust the datum elevation of the view definition by typing a value.

Click OK to exit the command.

To insert another sheet, select the Insert Sheet Series command again and repeat steps 1–6.

**Editing a Profile Sheet Layout**

You can edit the position and scale of the view definitions that were placed over the profile during sheet series layout.

**To edit the sheet layout**

1. From the Sheet Manager menu, choose Profile Sheets ➤ Edit Sheet Layout.
2. Select the view definition.
The Edit Sheet View Definition dialog box is displayed.

3 Review the information displayed in the dialog box to verify if it is correct. This dialog box displays the sheet series name, the sheet number, and information about the plan and profile data.

4 Change the scale in the View Scale edit box, if necessary. This view scale defaults to the scale that you set the viewport to when you defined the sheet. If you change the view scale value, press ENTER to update the layout with the new scale.

**NOTE** This command does not modify the layout of any subsequent sheets based on this change.

5 In the Datum edit box, you can type a new value to change the datum elevation of the view definition. The minimum and maximum elevations for the profile surfaces are displayed as a reference that you can use when adjusting the datum.

6 To edit the profile view Start Station, clear the Use Fixed Profile Stations option in the Preferences command. If this option is selected, the start station is fixed and you are unable to edit it.

7 To edit the next sheet, click the Next Sheet> button. Click the <Prev Sheet button to move to the previous sheet in the series.

**NOTE** The Plan View Data area of the dialog box displays the plan view data for the corresponding profile view definition. If you are generating a sheet series with only profile views, then you do not need to change any information in this section of the dialog box.
Click OK to exit the command and save the changes you have made.

**NOTE**  If the section of the profile covered by the view definition has a great elevational change, then you may need to split the profile view and change the datum elevation of the split viewport after generating the sheet series. You can use the Split Profile View command to do this.

The following illustration shows the definitions as they appear when the series is laid out. The datum elevation of the leftmost view definition must be adjusted.

![Profiles before datum adjustment](image1.png)

Profiles before datum adjustment

The following illustration shows the leftmost view definition adjusted to a more appropriate datum elevation:

![Profiles after datum adjustment](image2.png)

Profiles after datum adjustment

**Deleting a Profile Sheet Series Layout**

Use the Delete Series Layout command to delete a sheet series layout. The Delete Series Layout command erases all existing view definitions for a specific sheet series from the current drawing. It does not delete the drawing files that were generated for the series. To completely delete a series and all related files, use the Delete Series command.
To delete a profile sheet layout

1. From the Sheet Manager menu, choose Profile Sheets ➤ Delete Series Layout to display the Set Current Sheet Series Name dialog box.
2. Select the sheet series, and then click OK. The view definitions for the selected sheet series is deleted from model space.
   You can also use the ERASE command to erase the view definitions from model space.

Generating a Plan/Profile Sheets Series

Sheet Series Generation
After laying out the sheet series, the next step is to generate a sheet series or an individual sheet. Autodesk Civil Design Release 2 provides the ability to generate a series of sheets in either a single layout or multiple layouts, as opposed to a single paperspace page in Civil Design Release 1.

You can now have multiple drawing sheets for plan, profile, and section sheets in one drawing. Each of the pages contain a sheet that has been extracted using the sheet creation tools in Sheet Manager. For more information, see “Using Sheet Tools” in this chapter.

The plan/profile and profile sheet generation commands load a sheet style into paper space, and then place the corresponding model space views into the viewports. Generating a sheet also updates the sheet labels and grids, and the resulting sheet is automatically saved to its series folder.

The cross section sheet generation command loads a sheet style into paper space, places cross sections on the page, adds the annotation, and saves the sheets to the series folder.

After you have generated the series, you can use the editing commands provided in the Sheet Manager menu to edit the sheets, and then use the batch plot commands to send the sheets to a plotter. For more information, see “Plotting Sheets” in this chapter.

You can generate one sheet at a time, the entire sheet series, or, for section sheets, a station range of cross sections. The command to generate an individual sheet is very useful when you are creating a sheet style template. You can use this command to view the label and grid styles that you have attached to the sheet style for a typical layout without having to generate the entire sheet series.
WARNING! If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

NOTE To avoid accumulating unwanted layers, design the sheets in a SHTMGR project. The SHTMGR project does not have any alignments or profiles and the drawings contain only the desired layers. When you apply the sheet style, only new layers are added to the drawing.

Generating a Single Plan/Profile Sheet

You can generate plan/profile sheets one at a time, or you can generate all the sheets in the series at once in either plan or model space.

To learn about the rules that apply to sheet generation, see “Rules for Sheet Generation” in this chapter.

To generate one plan/profile sheet at a time

1. Lay out the sheet series.
2. From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Generate Sheet – Individual. The following prompt is displayed:

   Select a Sheet Series View Definition (Press Return to enter a sheet number):
   Select objects:

3. Select a view definition using one of the following methods:
   - Select the view definition with your pointing device, and then press ENTER.
   - Press ENTER at the Select a Sheet Series View Definition prompt. The Set Current Sheet Series Name dialog box is displayed. In the Existing Series box, double-click the name of the sheet series you want to generate, and then click OK.

   The command determines the sheet number range for the series you specify, and displays a prompt similar to the following:

   Current Sheet Series Name: Sheet Manager
   Series: Sheet Manager, sheet number range: 1-3
   Enter sheet number:

4. Type the sheet number and press ENTER.

   The command loads the sheet style, switches to paper space (if currently in model space), and regenerates the drawing. The command searches for grid, distance, text, or block labels and attaches them to the frames.

   The resulting sheet is saved to the sheet series folder in the format S###, for example, S001.
NOTE An error message is displayed if there are no available layouts for sheet generation.

After the sheet is generated, the drawing either returns to model space, or remains in paper space.

Rules for Sheet Generation

Sheets are generated in a default layout named SHEET_MANAGER. As each sheet is generated, the sheet is saved to the sheet series folder in the format $###, for example, S001, and the contents of the SHEET_MANAGER layout tab are erased before generating the next sheet.

If the SHEET_MANAGER layout tab exists when you run the Generate Sheet command, the contents of the SHEET_MANAGER layout tab are erased and replaced with the contents of the new sheet.

To view each sheet in a series after the series is generated, you can load the sheet into the drawing using the Load Sheet command.

Generating a Series of Plan/Profile Sheets

Use the Generate Sheet - Series command to generate a series of sheets in a single layout or in multiple layouts.

To learn about the rules that apply to sheet generation, see “Rules for Sheet Generation” in this chapter.

To generate a sheet series

1 Lay out the sheet series.
2 From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Generate Sheet - Series to display the Set Current Sheet Series Name dialog box.
3 In the Existing Series box, select the sheet series to generate.

The command loads the sheet style that you specified during sheet series layout, switches to paper space, and regenerates the drawing. The command searches for labels and grids that you attached to the frame and places them into the frame, and then saves the resulting sheets to the sheet series folder.

NOTE An error message is displayed if there are no available layouts for sheet generation.

After the sheet is generated, the drawing either returns to model space, or remains in paper space.

To review how the sheets were generated and to make edits, use the Load Sheet - Individual command to load each sheet into paper space.
Generating a Plan/Profile Sheet Series Automatically

You can automatically generate sheets by using the Auto Generate Series Sheets command. This command automatically lays out the sheet series and generates the sheets. Sheet layouts with a matching series name are deleted and recreated.

**NOTE**
This is a quick way to generate sheets, but you do not have the ability to edit the layout in model space before the sheets are generated. However, you can edit the sheets after they are generated.

To learn about the rules that apply to sheet generation, see “Rules for Sheet Generation” in this chapter.

**To automatically generate sheets**

1. From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Auto Generate Series Sheets to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the series to generate, and then click OK to display the Edit Sheet Series Data dialog box.
3. Set the sheet series options.
4. Click OK to exit the Edit Sheet Series Data dialog box.

   The command places view definitions over the plan view in model space, and generates the sheet series. The sheets are automatically saved to the sheet series folder.

   To review how the sheets were generated and to make edits, use the Load Sheet - Individual command to load each sheet into paper space.
Saving a Plan/Profile Sheet

You can save a sheet that you have edited by using the Save Sheet - Individual command. This command saves the sheet to c:\Land Projects R2\<projname>\cd\data\<series> folder.

To save a sheet

1. From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Save Sheet - Individual to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the series name, and then click OK to display the Save Series Sheet dialog box.
3. Click Save to save the sheet with the default preferences, or specify different name and/or folder information.

The Save Sheet command saves only those edits made to the current sheet, not all the edits made to many sheets.

Loading a Generated Plan/Profile Sheet

To view and edit a generated sheet, use the Load Sheet - Individual command to load the sheet into the drawing’s paper space. After the sheet is loaded you can edit and update the labels and grids. You can also add additional labels or grids, and then plot the sheet.

To learn about the rules that apply to loading a sheet series, see “Rules for Loading a Sheet Series” in this chapter.

NOTE
If you make edits to a sheet, then use the Save Sheet - Individual command to save the sheet.
To load a generated sheet into paper space

1. From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Load Sheet - Individual to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the sheet series to load to display the Load Series Sheet dialog box. Open to the <projname>/cd/data/<series> folder.
3. Select the sheet you want to load, and then click OK.
The sheet is loaded into paper space.

Loading a Plan/Profile Sheet Series

Multiple sheets can be loaded into the drawing at one time. Each sheet is loaded in its own layout.

To learn about the rules that apply to loading a sheet series, see “Rules for Loading a Sheet Series” in this chapter.

To load a plan/profile sheet series

1. From the Sheet Manager menu, choose Plan/Profile Sheets ➤ Load Sheet – Series to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the series name, and then click OK.
The program loads the selected series and uses the series name to label the layout tabs.

Rules for Loading a Sheet Series

Each layout name is automatically generated by the program and has no user control.

If a single sheet is loaded then the program creates a layout called “SHEET_MANAGER”. If a “SHEET_MANAGER” layout exist, all contents of the layout are erased and the new sheet is loaded into the layout.

If a sheet series is loaded, the layout names are based on the series name and sheet number. The format for the name is <Series Name>+S###, for example,
Generating a Profile Sheet Series

Generating a Single Profile Sheet

You can generate profile sheets one at a time or you can generate the entire series.

To learn about the rules that apply to sheet generation, see “Rules for Sheet Generation” in this chapter.

To generate a sheet

1. Lay out the sheet series.
2. From the Sheet Manager menu, choose Profile Sheets ➤ Generate Sheet - Individual.

The following prompt is displayed:

Select a Sheet Series View Definition (Press Return to enter a sheet number):
Select objects:
Select the view definition of the sheet you want to generate.

The command loads the sheet style, switches to paper space, and regenerates the drawing. The command then searches for labels and places them into the frame, and saves the resulting sheet to the sheet series folder.

After the sheet is generated, the drawing either returns to model space, or remains in paper space.

---

**WARNING!** If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

---

**Generating a Series of Profile Sheets**

Use the Generate Sheet - Series command to generate all of the sheets in a series.

To learn about the rules that apply to sheet generation, see “Rules for Sheet Generation” in this chapter.

To generate a series of profile sheets

1. From the Sheet Manager menu, choose Profile Sheets > Generate Sheet - Series to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the sheet series that you want to generate, and then click OK.

The command loads the sheet style that you specified during sheet series layout, switches to paper space, and regenerates the drawing. The command then searches for labels, places them into the frame, and saves the resulting sheets to the sheet series folder. These sheets are named with the format `<Series Name>+S###`, such as ELM+S001, ELM+S002, and so on.

After the sheet is generated, the drawing either returns to model space, or remains in paper space.

To review how the sheets were generated and to make edits, use the Load Sheet - Individual command to load each sheet into paper space.

---

**WARNING!** If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.
Generating a Profile Sheet Series Automatically

You can generate sheets automatically by using the Auto Generate Series Sheets command. This command lays out the sheet series and generates a new layout for each sheet in a series. All the sheets are written to separate drawings in the project folder.

**NOTE**  This is a quick way to generate sheets, but you do not have the ability to edit the layout in model space before the sheets are generated. However, you can edit the sheets after they are generated.

**To automatically generate sheets**

1. From the Sheet Manager menu, choose Profile Sheets ➤ Auto Generate Series Sheets to display the Set Current Sheet Series Name dialog box.

   **NOTE**  Under AutoCAD Layout Control for Each Sheet, the option Use a Single “Sheet Manager” Layout Tab is selected by default. This is the preferred method for generating an individual sheet or series of sheets because performance is faster.

2. In the Existing Series box, select the series, and then click OK to display the Edit Sheet Series Data dialog box.

   ![Edit Sheet Series Data](image)

   - **Series Name:** Specify the series name.
   - **Sheet Style:** Specify the sheet style.
   - **Starting Sheet Number:** Specify the starting sheet number.
   - **Sheet Overlap Distance:** Specify the sheet overlap distance.
   - **Alignment/Profile Data:** Specify the alignment and profile data.

3. Set the options such as the sheet style, starting sheet number, and sheet overlap distance.

4. Click OK to exit the Edit Sheet Series dialog box.

   The command places view definitions over the profile view in model space, and then generates the sheet series. The sheets are automatically saved to the sheet series folder. These sheets are named with the format `<Series Name>+S##`, such as ELM+S001, ELM+S002, and so on.

   To review how the sheets were generated and to make edits, use the Load Sheet - Individual command to load each sheet into paper space.
WARNING! If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

Saving a Profile Sheet

Use the Save Sheet - Individual command after loading and editing a generated sheet. This command saves the sheet to the project series data folder.

To save a sheet

1. From the Sheet Manager menu, choose Profile Sheets ➤ Save Sheet - Individual to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the series, and then click OK to display the Save Series Sheet dialog box.
3. Click Save to save the sheet with the default preferences, or specify a different name and/or folder information.

The Save Sheet command saves only those edits made to the current sheet, not all the edits made to many sheets.
Loading a Generated Profile Sheet

To view and edit a generated sheet, use the Load Sheet - Individual command to load the sheet into paper space. After the sheet is loaded you can update the labels and grids, make modifications, and plot the sheet. The last active viewport is used. To set the plan viewport active, you must pick within the plan viewport.

To learn about the rules that apply to loading a sheet series, see “Rules for Loading a Sheet Series” in this chapter.

**NOTE** If you edit a sheet, then use the Save Sheet - Individual command to save the changes.

To load a generated sheet into paper space

1. From the Sheet Manager menu, choose Profile Sheets ➤ Load Sheet - Individual to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the series, and then click OK. The Load Series Sheet dialog box is displayed.
3. Select the sheet you want to load, and then click OK. The sheet is loaded into paper space.

**WARNING!** If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.
Loading a Profile Sheet Series

Multiple sheets can be loaded into the drawing at one time. Each sheet is loaded in its own layout.

To learn about the rules that apply to loading a sheet series, see “Rules for Loading a Sheet Series” in this chapter.

To load a profile sheet series

1. From the Sheet Manager menu, choose Profile Sheets ➤ Load Sheet – Series to display the Set Current Sheet Series Name dialog box is displayed.
2. In the Existing Series box, select the series name, and then click OK.

The program loads the selected series and uses the series name to label the layout tabs.

Deleting a Profile Sheet Series

You can delete a sheet series and all saved sheets in the series \<project name>\cd\data folder.

To delete a sheet series

1. From the Sheet Manager menu, choose Profile Sheets ➤ Delete Sheet Series to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the sheet series you want to delete, and then click OK. The following prompt is displayed:
   Warning ALL data and files for Sheet Series: <series name>, will be deleted. Delete Sheet Series: <series name> (Yes/No) <No>:
3. Type Y for Yes if you want to delete the series, or press ENTER to exit the command.

NOTE This command deletes only the sheets for the series you specify.

Generating a Cross Section Sheet Series

To create final sheets for plotting, you must generate the sheets. Use the Generate Section Sheets command to generate a new layout for each sheet in a series. All the sheets are written to separate drawings in the project folder.

You can either use a pre-defined section sheet style template to generate the section sheet series, or you can create a new cross section sheet style based on your own preferences.

To learn about the rules that apply to generating a section sheet series, see “Rules for Generating a Section Sheet Series” in this chapter.
To generate a section sheet series

1. From the Sheet Manager menu, choose Section Sheets ➤ Generate Section Sheets to display the Set Current Sheet Series Name dialog box.

   ![Set Current Sheet Series Name](image)

2. In the Existing Series box, select the series to generate, and then click OK. The Edit Section Sheet Series Data dialog box is displayed.

   ![Edit Section Sheet Series Data](image)

3. Review the Alignment information at the bottom of the dialog box. If the wrong alignment is listed, then exit the command and use the Select Alignment command to set the current alignment.

4. Click the Set Style button to display the Set Current Sheet Style dialog box. Use this dialog box to set the sheet style, and then click Open to return to the Edit Section Sheet Series Data dialog box.

5. Under Starting Numbers, type the starting sheet number in the Sheet Number box. The sheets are numbered sequentially starting with the starting sheet number. When the sheet series is generated, the sheets are automatically saved to the sheet series folder in the format s001.dwg, s002.dwg, and so on, where 1 is the starting sheet number.
6 Under Starting Numbers, type the starting section number in the Section Number box. The sections are numbered sequentially starting with the starting section number.

7 Set the Start Station and End Station. These default to the starting and ending stations of the alignment. If you don’t want to generate sections for the whole alignment, then use these edit boxes to limit the station range.

8 Click OK when you have set the sheet series options, or click Cancel to cancel the command.

   The command generates the section sheets, which are automatically saved to the series folder. Use the Load Sheet - Individual command to view each sheet.

**Rules for Generating a Section Sheet Series**

Sheets are generated in a default layout named SHEET_MANAGER. When you generate a section sheet series, the specified sheet style is loaded and the cross sections are placed on the sheet and labels are created. The resulting sheet is automatically saved to its series folder.

Each sheet is named based on the series name and sheet number. The format for the name is <Series Name>+S###, for example, ELM+S001. The plus symbol (+) is used as a delimiter between the series name and the sheet number. The S character is prefixed to the sheet number.
Saving a Section Sheet

Use the Save Sheet - Individual command after loading and editing a generated section sheet. This command saves the sheet to the project series data folder.

To save a sheet

1. From the Sheet Manager menu, choose Section Sheets ➤ Save Sheet - Individual to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the series, and then click OK.

The Save Series Sheet dialog box is displayed. The name of the current sheet is displayed in the File Name edit box.

3. Click Save to save the sheet under the existing filename and overwrite the existing sheet.

<table>
<thead>
<tr>
<th>If you...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>do not want to edit the filename</td>
<td>click OK. Click Yes to overwrite the existing file.</td>
</tr>
<tr>
<td>want to edit the filename</td>
<td>click No to return to the Save Series Sheet dialog box where you can enter a new filename.</td>
</tr>
</tbody>
</table>

The Save Sheet command saves only those edits made to the current sheet, not all the edits made to many sheets.
Loading a Generated Section Sheet

To view and edit a generated section sheet, use the Load Sheet - Individual command to load the sheet into the drawing’s paper space.

NOTE  On Section sheets, you can draw on top of the section sheets or manually create a label, but you cannot use the Update Labels options to update any labels.

To load a generated sheet into paper space

1. From the Sheet Manager menu, choose Section Sheets ➤ Load Sheet - Individual to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the series to load, and then click OK. The Load Series Sheet dialog box is displayed.

The dialog box is open to the folder where the sheets for the selected series were saved.
3. Select a sheet, and then click Open.
   The command loads the sheet into paper space.

WARNING! If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

Loading a Section Sheet Series

The Load Sheet – Series command is new in Autodesk Civil Design. This command is now available in each of the submenus for Plan/Profile Sheets, Profile Sheets, and Section Sheets on the Sheet Manager menu. You can now select one or more sheets for loading. Each sheet is loaded in its own layout.
To learn about the rules that apply to loading a sheet series, see “Rules for Loading a Sheet Series” in this chapter.

**To load a section sheet series**

1. From the Sheet Manager menu, choose Section Sheets ➤ Load Sheet – Series to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the series name, and then click OK.

The program loads the selected series and uses the series name to label the layout tabs.

**Deleting a Section Sheet Series**

You can delete an existing sheet series and all saved sheets in its `<project name>\data` folder.

**To delete a sheet series**

1. From the Sheet Manager menu, choose Section Sheets ➤ Delete Sheet Series to display the Set Current Sheet Series Name dialog box.
2. In the Existing Series box, select the sheet series, and then click OK.

The following prompt is displayed:

Warning ALL data and files for Sheet Series: `<series name>`, will be deleted. Delete Sheet Series: `<series name>` (Yes/No) <No>:

3. Type Y for Yes if you want to delete the series, or press ENTER to exit the command.

**NOTE** This command deletes only the sheets for the series that you specify.

**Creating Plan/Profile Sheets**

You can use Sheet Manager to create plan/profile sheets for plotting that show a length of the plan view of the alignment on one part of the sheet and the corresponding profile length on another part of the sheet. Both the plan and profile views can be labeled with information that is pertinent to your project.

An example of a plan/profile sheet is shown in the following illustration:

This is a sheet that was generated for a plan/profile sheet series. To create a sheet like this one in the above illustration, you must customize a sheet style, decide which design elements go on which sheet (the sheet layout process), and then generate the sheets.

The basic process of creating plan/profile sheets is outlined below. A brief explanation of each step is provided in the right column. For more detailed information about each step in the process, use the Find tab in the online Help file to look up “Overview of Plan/Profile Sheets.”
### Plan/Profile Sheets

<table>
<thead>
<tr>
<th>Step</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Design the roadway alignment and profile.</td>
<td>Plan and profile views must exist in your drawing in order to plot them with Sheet Manager, or you can use XREFs to reference the model space entities if they exist in the current project.</td>
</tr>
<tr>
<td>2 Set the Sheet Manager Settings.</td>
<td>The Settings control the sheet style database path, layers, display of match lines, and so on.</td>
</tr>
<tr>
<td>3 Set the current sheet style, and then load that sheet style into paper space to view it.</td>
<td>This step assures that you are using the correct sheet style. A sheet style is the basis of any sheet series. A sheet style includes a border, viewports for the plan and profile views, and frames for labels.</td>
</tr>
<tr>
<td>4 Name the new sheet series. For more information, see “Naming a Sheet Series” in this chapter.</td>
<td>Sheet Manager creates a folder with this name into which it places the generated sheets.</td>
</tr>
<tr>
<td>5 Switch to model space.</td>
<td>Switch to model space to set the profile current. You can set the alignment current in paper space by selecting it from the list of alignments. All sheets can be generated while in paper space or in model space; the routines switch to paper space if warranted.</td>
</tr>
<tr>
<td>6 Set the current alignment.</td>
<td>You must set the current alignment so the correct plan information is referenced.</td>
</tr>
<tr>
<td>7 Set the current profile.</td>
<td>You must set the current profile so the correct profile information is referenced.</td>
</tr>
<tr>
<td>8 Lay out the sheet series.</td>
<td>Laying out the series places rectangles over the alignment. Each rectangle represents one sheet in the series. For more information, see “Sheet Series Layout” in this chapter.</td>
</tr>
<tr>
<td>9 Adjust the layout, if necessary.</td>
<td>If the rectangles do not cover the area of the alignment correctly, you can move or rotate them with the Edit Sheet Layout command. You can also use this command to edit the profile datum elevation of the layout so that the correct part of the profile appears on each generated sheet.</td>
</tr>
<tr>
<td>10 Generate the sheet series.</td>
<td>This step creates the sheet annotation and saves the sheets to the sheet series folder. Only paper space entities are actually created. The generated sheets always reference the model space entities from the drawing itself.</td>
</tr>
<tr>
<td>11 Plot the sheets.</td>
<td>You can set up a batch file to plot the sheets sequentially. For more information, see “Plotting Sheets” in this chapter.</td>
</tr>
</tbody>
</table>
Creating Profile-Only Sheets

You can use Sheet Manager to create profile-only sheets for plotting that show a length of the profile on each sheet. The profile view can be labeled with a variety of information that is pertinent to your project. An example of a profile sheet is shown in the following illustration:

This is a sheet that was generated for a profile sheet series. To create a sheet like this one, you must customize a sheet style, decide which design elements go on which sheet (the sheet layout process), and then generate the sheets.

The basic process of creating profile sheets is outlined below. A brief explanation of each step is provided in the right column. For more detailed information about each step in the process, use the Find tab in the online Help file to look up “Overview of Profile-Only Sheets.” You can also find this topic on the Contents tab of the Help file.

<table>
<thead>
<tr>
<th>Step</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Design your plan and profile. A profile view must exist in your drawing in order to plot it with Sheet Manager, or you can use XREFs to reference the model space entities if they exist in the current project.</td>
</tr>
<tr>
<td>2</td>
<td>Set the Sheet Manager Settings. The Settings control the sheet style database path, layers, and so on.</td>
</tr>
<tr>
<td>3</td>
<td>Set the current sheet style, and then load that sheet style into paper space to view it. This step assures that you are using the correct sheet style.</td>
</tr>
<tr>
<td>4</td>
<td>Name the new sheet series. Sheet Manager creates a folder with this name into which it places the generated sheets.</td>
</tr>
<tr>
<td>5</td>
<td>Switch to model space. You must switch to model space to select the current profile.</td>
</tr>
<tr>
<td>6</td>
<td>Set the current profile. You must set the current profile so the correct profile information is referenced.</td>
</tr>
<tr>
<td>7</td>
<td>Lay out the sheet series. Laying out the series places rectangles over the profile. Each rectangle represents one sheet in the series. For more information, see “Sheet Series Layout” in this chapter.</td>
</tr>
<tr>
<td>8</td>
<td>Adjust the layout if necessary. If the rectangles do not cover the area of the profile correctly, you can edit the profile datum elevation of the layout so that the correct part of the profile appears on each generated sheet.</td>
</tr>
<tr>
<td>9</td>
<td>Generate the sheet series. This step creates the sheet annotation and saves the sheets to the sheet series folder. Only paper space entities are actually created. The generated sheets always reference the model space entities from the drawing itself. For more information, see “Sheet Series Generation” in this chapter.</td>
</tr>
<tr>
<td>10</td>
<td>Plot the sheets. You can set up a batch file to plot the sheets sequentially. For more information, see “Plotting Sheets” in this chapter.</td>
</tr>
</tbody>
</table>
Creating Plan-Only Sheets

You can create sheets for plotting that show lengths of the alignment in plan view. Although Sheet Manager does not have commands for specifically creating plan-only sheets, you can use the commands in the Plan/Profile Sheets menu to create plan-only sheets.

The process of creating plan-only sheets is similar to creating plan/profile sheets. There must be both a plan and a profile viewport (as well as plan and profile view frames) on the sheet style that you use in order for Sheet Manager to generate the sheet series. After the sheet is generated, you can erase the profile viewport.

An example of a plan-only sheet is shown in the following illustration.

When you set up the plan-only sheet style, draw a small profile viewport. After you generate the sheet series, you can load each sheet into paper space and erase the profile viewport. This illustration shows the plan sheet after the profile viewport has been erased.

The basic process of creating plan sheets is outlined below. A brief explanation of each step is provided in the right column.

<table>
<thead>
<tr>
<th>Step</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Create a new plan-only sheet style. A sheet style is the basis of any sheet series. A sheet style includes a border, viewports, and frames for labels. To create plan-only sheets, you must use a sheet style that includes a profile viewport. After the sheets are generated, you can erase the profile viewport. You must also define a profile/view frame for the profile viewport when you are setting up the sheet style. You should create the new sheet style in a separate drawing session; not in the drawing that contains your model space entities.</td>
</tr>
<tr>
<td>2</td>
<td>Open the drawing that you created the model space entities in. Plan and profile views of the alignment must exist in your drawing in order to plot them with Sheet Manager, or you can use XREFs to reference the model space entities if they exist in the current project.</td>
</tr>
<tr>
<td>3</td>
<td>Set the Sheet Manager Settings. The Settings control the sheet style database path, layers, display of match lines, and so on.</td>
</tr>
<tr>
<td>4</td>
<td>Set the current sheet style and then load that sheet style into paper space to view it. This step assures that you are using the correct sheet style.</td>
</tr>
<tr>
<td>5</td>
<td>Name the new sheet series. Sheet Manager creates a folder with this name into which it places the generated sheets. You must use the Set/Define Series command from the Plan/Profile sheet menu. For more information, see “Naming a Sheet Series” in this chapter.</td>
</tr>
</tbody>
</table>
### Plan-Only Sheets (continued)

<table>
<thead>
<tr>
<th>Step</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Switch to model space. You must be in model space to set the profile current, but you can set the alignment current in paper space.</td>
</tr>
<tr>
<td>7</td>
<td>Set the current alignment. You must set the current alignment so the correct plan information is referenced. You can set the alignment current in Paper Space.</td>
</tr>
<tr>
<td>8</td>
<td>Set the current profile. You must be in Model Space to set the profile current so the correct profile information is referenced. Even though the final sheets only contain plan views, the profile must be present in the drawing to properly generate the sheets.</td>
</tr>
<tr>
<td>9</td>
<td>Lay out the sheet series. Laying out the series places rectangles over the alignment. Each rectangle represents one sheet in the series. You must use the Layout Sheet Series command from the Plan/Profile sheet menu. For more information, see “Sheet Series Layout” in this chapter.</td>
</tr>
<tr>
<td>10</td>
<td>Adjust the layout if necessary. If the rectangles do not cover the area of the alignment correctly, you can move or rotate them so that the correct part of the alignment appears on each generated sheet. You must use the Edit Sheet Layout command from the Plan/Profile sheet menu to edit your plan-only layout.</td>
</tr>
<tr>
<td>11</td>
<td>Generate the sheet series. This step creates the sheet annotation and saves the sheets to the sheet series folder. Only paper space entities are actually created. The generated sheets always reference the model space entities from the drawing itself. You must use the Generate Sheet – Individual or Generate Sheet – Series commands from the Plan/Profile sheet menu.</td>
</tr>
<tr>
<td>12</td>
<td>Load each sheet into paper space. To create plan-only sheets, you must load each sheet into paper space, and then erase the profile viewport.</td>
</tr>
<tr>
<td>13</td>
<td>Erase the profile viewport.</td>
</tr>
<tr>
<td>14</td>
<td>Save each sheet.</td>
</tr>
<tr>
<td>15</td>
<td>Plot the sheets. You can set up a batch file to plot the sheets sequentially. For more information, see “Plotting Sheets” in this chapter.</td>
</tr>
</tbody>
</table>
Creating Section Sheets

You can generate sheets for plotting that contain section views sampled along an alignment. The placement of sections on a sheet is based on the following factors:

- The size of the sampled sections in model space units (for example, how wide a swath width you sample along the alignment)
- The horizontal and vertical scales you use for specifying how one unit in paper space represents one unit of model space
- The section spacing values determine the margin, row, and column spacing

This section sheet was created from the sdskssect.dwg sheet style. The Cross Section Preferences were set up so that 1” of paper space represents 20’ of model space in the horizontal scale.

On each section, the station number is labeled on top (in red), and the offsets from the centerline are labeled along the bottom (in yellow). The white annotation on the right side of each cross section is formatted to label the amount of cut and fill volume between existing and finished ground surfaces.

This is the sdskssect.dwg sheet style—the sheet style from which the above sheet was created. As you can see, a section sheet style is set up quite differently from plan and profile sheet styles. For more information about setting up a section sheet style, see “Creating a New Cross Section Sheet Style” in this chapter.

The basic process of creating section sheets is outlined in the following table. A brief explanation of each step is provided in the right column. For more detailed information about each step in the process, use the Find tab in the online Help file to look up “Overview of Section Sheets.” You can also find this topic on the Contents tab of the Help file.

Use the commands on the Profiles menu to design the roadway alignment. To create cross sections, plan and profile information must exist in the drawing.
Section Sheets

<table>
<thead>
<tr>
<th>Step</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Set the current alignment. You must set the current alignment so the correct plan information is referenced for the sections. This step must occur before you design the roadway alignment.</td>
</tr>
<tr>
<td>2</td>
<td>Process the cross sections. Process the cross sections with the Cross Sections ➤ Design Control ➤ Edit Design Control command.</td>
</tr>
<tr>
<td>3</td>
<td>Set the Cross Section Sheet Preferences, such as the horizontal and vertical scale. These settings control the layout of the cross sections on the sheet. If the cross sections do not appear correctly on the sheet (too small or too big), try adjusting these settings. The units specified in the Cross Section Preferences dialog box are in inches for imperial and meters for metric.</td>
</tr>
<tr>
<td>4</td>
<td>Set the current sheet style, and then load that sheet style into paper space to view it. This step assures that you are using the correct sheet style.</td>
</tr>
<tr>
<td>5</td>
<td>Name the new sheet series. Sheet Manager creates a folder with this name into which it places the generated sheets. For more information, see “Naming a Sheet Series” in this chapter.</td>
</tr>
<tr>
<td>6</td>
<td>Generate the sheet series. This step creates the sheet annotation and saves the sheets to the sheet series folder. The cross sections as well as the sheet annotation are saved as paper space entities. For more information, see “Sheet Series Generation” in this chapter.</td>
</tr>
<tr>
<td>7</td>
<td>Plot the sheets. You can set up a batch file to plot the sheets sequentially. For more information, see “Plotting Sheets” in this chapter.</td>
</tr>
</tbody>
</table>

Creating Single Sheets

To create one sheet using AutoCAD commands (without having to lay out and generate a sheet series), you can manually create a sheet that you can save and plot.

Saving a Single Sheet in Paper Space

After you load a sheet style and decide which views you want the viewports to contain, you can save a single sheet in paper space using the Single Sheet ➤ Save command.

Save a Sheet is designed to be used with Load Sheet. Sheets should never be opened as a drawing file. Rather, they should be loaded into Paper Space of the current working drawing (the one that contains the data shown through the sheet’s viewports).
To save a sheet
1. From the Sheet Manager menu, choose Single Sheet ➤ Load to load a sheet into paper space.
2. Edit the sheet by adding text, linework, modifying the viewport data.
3. Save the sheet using the Single Sheet ➤ Save command.

Loading a Single Sheet to Paper Space
The Load command can be used with any series of sheets. You can load a single sheet (only one sheet can be loaded into Paper Space at a time) from a series of sheets or from a single sheet. This command is intended for loading single sheets that you saved using the Single Sheet ➤ Save command.

To load a sheet you created in Autodesk Civil Design
1. From the Sheet Manager menu, choose Single Sheet ➤ Load to display the Sheet File Name To Load dialog box.
2. Select the sheet name to restore.
3. Click Open to restore the sheet. This restores the specified sheet to paper space.
4. To load a plan/profile, profile, or section sheet that you have generated, use the Load Sheet - Individual command from the appropriate submenu.

Working with Sheet Tools
Use the commands on the Sheet Tools submenu to do the following:
- Set the viewport view scale.
- Copy model or paper space entities to paper or model space.
- Move model or paper space entities to paper or model space.
- Erase all entities in paper space.
- Split, set, rotate, or restore the plan annotation.
- Split or change the profile view.
- Create a layer report.
Setting the Viewport View Scale
To change the scale of the drawing view within a viewport, you can use the Set View Scale command. This is useful if you want to restore a scale after using the ZOOM command.

NOTE This is a paper space command.

To set the viewport scale
1 From the Sheet Manager menu, choose Sheet Tools ➤ Set View Scale.
2 Enter the new scale and press ENTER.
3 Select the viewport(s) to scale. You can use the pickbox to select the viewport(s) or you can use a window or crossing to select them.
4 Press ENTER.
The drawing view in the viewport(s) is rescaled to the specified scale.

Copying Model Space Entities to Paper Space
When you generate a sheet series, some of the model space entities might be cut off or split between two sheets. For more information on ADE Data, see “ADE Data” in AutoCAD Map online Help.

NOTE This is a paper space command.

To copy model space entities
1 From the Sheet Manager menu, choose Sheet Tools ➤ Copy MSpace to PSpace.
2 Select the items inside the viewport that you want to copy to paper space. To activate a viewport, pick within that viewport.
3 Press ENTER to display the Confirm Export of ADE Data dialog box.
The command copies the entities to paper space. This function maintains the apparent model space view scale, the location of the entities, and the layers.

Moving Model Space Entities to Paper Space
To move selected entities from a model space viewport to paper space, use the Move MSpace to PSpace command. This function maintains the apparent model space view scale, the location of the entities, and the layers.
The Move MSpace to PSpace command is similar to the Copy MSpace to PSpace command, except that the items you move to paper space no longer exist in model space. You can use the Move PSpace to MSpace command to move the entities back to model space if necessary.

NOTE This is a paper space command.
To move model space entities
1. From the Sheet Manager menu, choose Sheet Tools ➤ Move MSpace to PSpace.
2. Inside a viewport, select the entities to move to paper space. To activate a viewport, pick within that viewport.
3. Press ENTER to display the Confirm Export of ADE Data dialog box.
   The command then moves the entities to paper space.

Copying Paper Space Entities to Model Space
To copy selected entities from paper space to model space, use the Copy PSpace to MSpace command. This function maintains the apparent paper space view scale, the location of the entities, and the layers. For example, you can copy labels to model space.

**NOTE**
This is a paper space command.

To copy paper space entities
1. From the Sheet Manager menu, choose Sheet Tools ➤ Copy PSpace to MSpace.
2. Select the viewport that contains the paper space entities that you wish to copy.
3. Select the items you want to copy to model space.

**NOTE**
You can draw a window around the items that you want to copy; only paper space entities are selected. Model space entities are ignored.

4. Press ENTER to display the Confirm Export of ADE Data dialog box.
   The command then copies the paper space entities to model space.

Moving Paper Space Entities to Model Space
To move selected entities from paper space to model space, use the Move PSpace to MSpace command. This function maintains the apparent paper space view scale, the location of the entities, and the layers.

**NOTE**
This is a paper space command.

To move paper space entities
1. From the Sheet Manager menu, choose Sheet Tools ➤ Move PSpace to MSpace.
2. Select the entities to move to model space.

**NOTE**
You can draw a window around the items that you want to copy; only paper space entities are selected. Model space entities are ignored.

3. Press ENTER to display the Confirm Export of ADE Data dialog box.
   The command then moves the entities to model space.
Erasing All Entities in Paper Space

To erase all the entities in paper space, you can use the Clean Paper Space command. You can use the UNDO command to restore the entities back to paper space, or use a Load Sheet command to restore a generated sheet.

To erase paper space entities
- From the Sheet Manager menu, choose Sheet Tools ➤ Clean Paper Space. The command erases all the entities in paper space.

Splitting the Plan View

If the plan view that is contained in the viewport definition is a curved or otherwise irregular segment, then you can use the Split Plan View command to split the viewport into two segments, and then set the plan view angle accordingly.

**NOTE**
This is a paper space command.

To split the plan viewport

1. From the Sheet Manager menu, choose Sheet Tools ➤ Split Plan View.
2. Select the viewport containing the plan view you want to split.
3. Press ENTER.

   The following prompt is displayed:

   Pick viewport split point (Station/MSpace/PSpace/eXit) <eXit>:

4. Select the split point for the viewport using one of the following methods:
   - At the Pick viewport split point prompt, you can pick the viewport split point graphically. At this selected point, the viewport splits vertically and regenerates.
   - To select the viewport split point by entering a station value, type S for Station at the prompt, and then type the station number.
   - You can switch back and forth between paper space and model space by typing PS or MS at the prompt. These options make it possible to reference a point in paper or model space. For example, if you want to split the viewport exactly in half, then you can go to paper space and pick the midpoint of the bottom of the viewport using an object snap.

When the viewport is split, the command rotates the plan view angle to best fit the alignment into the viewport. All plan frames are updated automatically. If you want to further adjust the plan view angle, then use the Set Plan View Angle command.
Setting the Plan View Angle

To make a change to the plan view angle in a viewport, use the Set Plan View Angle command. With this command, the last active viewport is used. To set the plan viewport active, you must select an area within the plan viewport.

**NOTE** This is a paper space command.

To set the plan view angle

1. From the Sheet Manager menu, choose Sheet Tools ➤ Set Plan View Angle.
   The following prompt is displayed:
   
   `Enter new view twist angle for viewport(s) (MSpace/PSpace/Match) <0d0'0>:`

2. Set the viewport angle using one of the following options:
   
   - If you know the angle you want to set for the viewport, then type the angle value at the prompt and press ENTER. You are then prompted to pick the viewport(s) you want to adjust. Pick the viewport, and then press ENTER. The plan view angle is adjusted and the screen redrawn.
   
   - To match the angle of the selected viewport to an existing viewport angle, type M for Match. The command prompts you to select a viewport to match. Pick the viewport with the pointing device. The command prompt displays the angle of the matched viewport. Either accept this new angle or enter another value and press ENTER. Finally, you are prompted to pick the viewport you want to adjust. Pick the viewport, and then press ENTER.
   
   - You can switch back and forth between paper space and model space by typing PS or MS at the prompt. These options make it possible to reference a point in paper or model space.

The paper space labels is redrawn according to the new location of the plan.

Rotating the Plan Annotation

If you have used text or blocks to annotate the plan view of your drawing in model space, then this annotation remains in the drawing when you generate the sheet series unless you freeze the layer it is on. When you generate a sheet series, the generate sheets commands automatically rotate the plan view of the drawing according to the layout of the sheet series. Because the plan view is rotated when you generate a sheet, you may find that the text you placed in model space is now rotated to an angle that is difficult to read.

You can use the Rotate Plan Annotation command to rotate the selected block or text entities 180 degrees so it is easier to read. The only block or text entities that are rotated are those that are upside down. In other words, the original rotation angle for the text places the text upside down for this current view. If you want to restore the annotation angle, then use the Restore Rotated Annotation command described in the next section.

**NOTE** To work in the viewports while in paper space, use the MSpace macro or double-click the PAPER button in the Windows status bar before using this command.
To rotate plan annotation

1. From the Sheet Manager menu, choose Sheet Tools ➤ Rotate Plan Annotation. The following prompt is displayed:

   Select text and/or blocks to rotate:
   Select objects:

2. Select the text or blocks you want to rotate with your pointing device pickbox, or use a window or crossing.

3. Press ENTER to complete the selection set. The text or blocks are rotated 180 degrees.

   **NOTE** If you need to make further edits to model space annotation, such as moving it to a different location, then you may want to use the Copy MSpace to PSpace command or the Move MSpace to PSpace command.

The following illustration shows a plan annotation:
The following illustration shows a rotated plan annotation:

![Rotated plan annotation](image)

**Restoring Rotated Plan Annotation**

You can restore the original rotation angle of the model space plan annotation by using the Restore Rotated Annotation command.

**NOTE**

To work in the viewports while in paper space, use the MSpace macro or double-click the PAPER button in the Windows status bar before using this command.

**To restore rotated plan annotation**

1. From the Sheet Manager menu, choose Sheet Tools ➤ Restore Rotated Annotation.

   The following prompt is displayed:

   ```
   Select text and/or blocks to restore original rotation:
   Select objects:
   ```

2. Select the text or blocks you want to restore with your pointing device pickbox, or use a window or crossing.

3. Press ENTER. The rotated plan annotation is restored to its original position.

**Splitting the Profile View**

If a viewport is not large enough to display the full extent of a profile, then you may want to split the profile viewport and readjust the datum elevation. To do this, use the Split Profile View command.

**NOTE**

This is a paper space command.
To split the profile viewport

1. From the Sheet Manager menu, choose Sheet Tools ➤ Split Profile View.
2. Use your pointing device to pick the profile viewport to split.
3. Press ENTER.
   The following prompt is displayed:
   
   Pick viewport split point (Station/MSpace/PSpace/eXit) <eXit>:

4. Pick the viewport split point using one of the following options:
   - Pick a point within the selected viewport. At this selected point, the viewport splits vertically and regenerates.
   - To select the viewport split point by entering a station value, type \texttt{S} for Station at the prompt, and then type the station number.
   - You can switch back and forth between paper space and model space by typing \texttt{PS} or \texttt{MS} at the prompt. These options make it possible to reference a point in paper or model space.

After the viewport is split vertically, a prompt similar to the following is displayed:

Profile: 202cl, Min Elev: 740.00, Max Elev: 826.70, Datum Elev: 750.00
Enter new Datum Elev <750.00>:

The current datum elevation for the second viewport is reflected in the brackets.

5. Type a new value for the datum elevation in order to fit the profile into the viewport as desired.
   All profile frames are updated automatically. If the datum needs further adjustment, then use the Chg Profile View Datum command.

Changing the Profile View Datum

To change the datum elevation of a profile viewport, use the Chg Profile View Datum command.

\textbf{NOTE} This is a paper space command.

To change the profile datum

1. From the Sheet Manager menu, choose Sheet Tools ➤ Chg Profile View Datum.
   The following prompt is displayed:
   
   Select a Profile view for datum elevation change:
   Select a Viewport:

2. Select the viewport that contains the profile view you want to change.
3. Press ENTER.
   A prompt similar to the following is displayed, indicating the current datum elevation:
   
   Profile: 202cl, Min Elev: 740.00, Max Elev: 826.70, Datum Elev: 750.00
   Enter new Datum Elev <750.00>:

4. Type the new datum elevation. The datum is adjusted and the view regenerated. All profile frames are updated automatically.
Creating a Layer Report

To create a report that lists all the layers in the current drawing as well as their current state (i.e. On, Off, Frozen, Thawed, Locked, Unlocked, Linetype, and Color Code), use the Create Layer Report command. This command creates the report in ASCII text format.

The following is a sample layer report:

| Drawing Name: |  |  |
|-------------|-------------|
| Report Date/Time: | 06-21-99 mon 11:52am |
| Current Layer: | 0 |
| Layers in drawing: | 153 |

State Legend: O = ON, F = FROZEN, L = LOCKED

Color Legend: 1 = Red, 2 = Yellow, 3 = Green
4 = Cyan, 5 = Blue, 6 = Magenta
7 = White, 8 = Grey, 9 = Lt Grey

<table>
<thead>
<tr>
<th>Layer Name</th>
<th>Color</th>
<th>State</th>
<th>LineType</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>7</td>
<td>On . .</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>1STAVE-PBASE</td>
<td>9</td>
<td>On . .</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>1STAVE-PEGC</td>
<td>3</td>
<td>On . .</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>1STAVE-PEGCT</td>
<td>3</td>
<td>.</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>1STAVE-PFGC</td>
<td>1</td>
<td>On . .</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>1STAVE-PFGCT</td>
<td>1</td>
<td>.</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>1STAVE-PGRID</td>
<td>9</td>
<td>. .</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>1STAVE-PGRIDT</td>
<td>9</td>
<td>. .</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>1STAVE-PVGRID</td>
<td>9</td>
<td>. .</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>2NDAVE-PBASE</td>
<td>9</td>
<td>On . .</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>2NDAVE-PEGC</td>
<td>3</td>
<td>On . .</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>2NDAVE-PEGCT</td>
<td>3</td>
<td>. .</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>2NDAVE-PFGC</td>
<td>1</td>
<td>On . .</td>
<td>CONTINUOUS</td>
</tr>
</tbody>
</table>
To generate a layer report
1 From the Sheet Manager menu, choose Sheet Tools ➤ Create Layer Report to display the Filename for Layer Report dialog box.
2 Type the report name.
3 Select the folder you want to save the report to.
4 Click OK.

A message similar to the following is displayed:

Printing 226 layers to file: c:\Land Projects R2\adtut\ layer.txt

The command saves the report to the file. This file can be opened with any text editor.

Plotting Sheets

You can plot sheets just like you plot any other AutoCAD drawing. You can send a single sheet to your plotter, or you can create a batch file that plots a group of sheets.

Creating a Layout Page Setup Name

To use Edit Batch Plot Job command you must first create a Layout Page Setup name in a paper space layout in the current drawing.

To create a Page Layout
1 From the File menu, choose Page Setup to display the Page Setup dialog box.
2 Configure Plot Device and Layout Settings as required for your plotter
3 Click Add next to Page Setup Name to save your settings
4 Click OK to exit the Page Setup dialog box.

NOTE For more information on this topic, see “Fast Track to Plotting Your First Drawing” in AutoCAD 2000 online Help.

Batching Plot Sheets

You can set up a batch plot job to send a group of sheets to the plotter at once.

To set up the Batch Plot Job
1 Create a Layout Page Setup name.
2 From the Sheet Manager menu, choose Plot ➤ Edit Batch Plot Job to display the Edit Batch Job dialog box.
3 Use the Edit Batch Job dialog box to enter the name for the plot job, and then click OK. This file is saved with a *.bpd extension.
   The Edit Batch Plot Job dialog box is displayed. Use this dialog box to add the Layout Page Setup name and to add sheets to the plot job.
4 To save the plot job under a different name, click Save as. Enter the new name in the Save Batch Job As dialog box and click Save.
5 Select the desired Layout Page Setup name. The name must exist in the current drawing.
6 Click Add File to add each sheet to the batch plot job.
   The Add Sheet to Plot Job dialog box is displayed. Use this dialog box to locate the sheets to plot.
7 Select the name of the drawing to plot, and then click Open. The Edit Batch Plot Job dialog box is redisplayed, and the drawing you selected is listed in the Sheet File List.
8 Click Add File and select additional drawings to add to the plot job, and then click OK. To remove a file, click Remove File.
9 Use the Run Batch Plot Job command to run the plot job.

**Running a Batch Plot Job**
Use the Run Batch Plot Job to send a plot job to a plotting device.

**To run the batch job**
1 Be sure that you are working within the drawing that contains the model space entities you want to plot.
2 From the Sheet Manager menu, choose Plot ➤ Run Batch Plot Job to display the Run Batch Plot Job dialog box.
3 Select the job (file extension of *.bpd), and then click Open to exit the dialog box.
   Each sheet in the batch job is loaded on screen, and then sent to the plotter.

**Hiding Lines for Plotting**
You can prevent hidden lines from being drawn when you plot by using the Hideplot option of the MVIEW or Create Viewport command. The Hideplot option of MVIEW affects only the plotted output, not the screen display.

**To hide lines for plotting**
1 From the Sheet Manager menu, choose Sheet Styles ➤ Create Viewport. The following prompt is displayed:
   ON/OFF/Fit/Hideplot/Lock/Object/Polygonal/Restore/2/3/4/<Fit>:
2 Type Hideplot.
3 Specify ON or OFF.
4 Select the viewport(s) to apply the Hideplot option to.
Working with Sheet Styles

To create sheets, you start with a sheet style. A sheet style is a 1:1 scale paper space drawing that typically contains a border, a title block, viewports, and labels and grids. A scale of 1:1 means that 1 unit of paper space plots as 1 unit on your final sheets. When you generate a sheet, the sheet style is used as a kind of template for the finished sheet. The sheet style controls the position of the plan, profile, and section views on sheets, and it also controls all of the labels and grids that are added to the sheets.

There are four main parts to a sheet style:

- The basic entities that are included with the sheet, such as borders, title block lines, static text and your company logo
- The viewports for plan and profile, or the view frame for sections
- The frames for labels and grids
- The labels and grid styles that you attach to the frames for labeling the design elements

For example, a plan/profile sheet style can be formatted to place a length of plan view on the top half of a sheet and the corresponding length of the profile view on the lower half of a sheet. It can also be formatted to label the stations along the plan and the elevations along the profile.

The following illustration shows a basic plan/profile sheet style:

![Plan/profile sheet style](image)

Properly setting up your sheet style is the most important part of creating sheets. Each type of sheet series requires a different type of sheet style. For example, you must use a different sheet style for plan/profile, profile-only, plan-only, and cross section sheets.

Sheet styles are stored outside of the Civil Design drawing in the path you set with the settings command. Sheet styles consist of a drawing file (*.dwg), an *.sdb binary file, and a *.dbf file. Several sample sheet style templates have been included with Sheet Manager. These sheet style templates are located in the c:\Program Files\Land Desktop R2\data\sheets\.

**NOTE** Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they cannot be used with an earlier version of the Desktop.

After you create and save a sheet style, you can use it with any project.
**Customizing Sheet Manager**

Creating sheets involves customizing a sheet style, planning which design elements go on which sheet (the sheet layout process), and then generating the sheets. The process is different for each of the four sheet types that you can create.

**Using a Sheet Style That Was Included with Sheet Manager**

A good way to start working with Sheet Manager is to use one of the sheet styles that was included with Sheet Manager—either as-is or with some modifications.

**To use an existing sheet style**

1. Set the database path.
2. Set the sheet style current.
3. Lay out a sheet series.
4. Generate a sheet series.

---

**WARNING!** If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.
Choosing the Current Sheet Style

Each sheet series that you generate can be based on a different sheet style. You must use different sheet styles for generating different types of sheet series, such as section sheets and plan/profile sheets.

To choose the current sheet style

1. From the Sheet Manager menu, choose Set Current Sheet Style to display the Select Current Sheet Style dialog box.

   ![Select Current Sheet Style dialog box]

This dialog box opens to the Sheet Style Database path defined in the Sheet Manager Setting dialog box. Sample sheet style templates that have been provided with Sheet Manager are stored in the c:\Program Files\Land Desktop R2\data\sheets\.

2. Select a folder and select the sheet style that you want to use. If you cannot see a preview of the sheet style you chose, then the sheet style database path is incorrect. You must update the Sheet Style Database path in the Sheet Manager Settings dialog box in order to use the sheet style.

3. Click Open to select the sheet style. You can edit the sheet style by loading it into your drawing.

Creating a New Sheet Style

There are several ways to begin creating a new sheet style:

- You can accept the default sheet style included with Sheet Manager, and then modify it as necessary.
- You can start with an empty drawing and begin creating the sheet.

You can alter an existing sheet style or a sheet style that was included with Sheet Manager, or you can create a new sheet style based on your requirements. After you create and save a sheet style, you can use it with any project.

**NOTE** Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they may not be used with an earlier version of the Desktop.
WARNING! If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

For easier management of the sheet style, we recommend that you create a new drawing for your sheet style. This makes it easier to edit the sheet style later and it also makes it easier to share the sheet style drawing with other people.

Creating a New Plan/Profile Sheet Style

You can begin creating a new plan/profile sheet by using an existing sheet style drawing and modifying it, or you can start from scratch by drawing a border, viewports, and frames. You can create a new sheet style in a separate drawing, or you can create a sheet style in the paper space of an existing drawing.

Creating a separate drawing for the sheet style can make it easier to edit the sheet in the future. It also makes transferring data to other people much easier. However, another person cannot use the sheet style from a new drawing.

In order for other people to use the sheet style, you must create a new drawing in a new project called Sheet Styles, for example. It is recommended that you create this drawing completely in Paper Space and include only the sheet information you want in your template. Save the drawing, and then use the Save Sheetstyle command to save the sheet style to a different folder, as specified in the Settings.

WARNING! If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

To create a new plan/profile sheet style
- Choose a Method for Creating, Opening, and Editing Sheet Style Drawings.

To create the sheet style in a separate drawing, see “Creating a New Plan/Profile Sheet In a Separate Drawing” in this chapter.
Creating a New Plan/Profile Sheet In a Separate Drawing

1. Create a new drawing in a new project. If the sheet is a plan and profile sheet at 50 scale, then you may want to name the drawing something like plpr50.dwg. The project name might be something like Sheet Styles.

2. Switch to paper space.

3. In Windows Explorer, create a unique folder under the c:\Program Files\Land Desktop R2\data\sheets folder for your new sheet style. You may want to name the folder after the client you are working for or the project you are working on, for example, Company X.

4. Change the sheet style path so it points to this new folder.

5. Draw the sheet border using the RECTANGLE command, or insert a pre-defined border block using the DDINSERT command. It is recommended that you create the sheet style at a 1:1 scale. For example, if you want a sheet to measure 24 by 36 inches, then make your sheet 24 by 36 units.

6. Use the MVIEW or the Create Viewport command to create the sheet viewports.

7. Set the viewport categories and the view scale. For a plan/profile sheet at 50 scale, you would set the scale of each viewport to 50.

8. Draw the frames where you want the labels to appear.

9. Draw the view frames around each viewport.

10. Use the File ➤ Save command to save the current sheet drawing. Save the drawing to the project folder you created when you started this new project. For example, if you created a Sheet Styles project, then save the drawing to the c:\Land Projects R2\Sheet Styles folder. You can modify this drawing if you need to make changes to the sheet.

11. From the Sheet Manager menu, choose Sheet Styles ➤ Save Sheet Style. This command creates the *.dwg, *.dbf, and *.sdb files associated with the sheet and places these files in the c:\Program Files\Land Desktop R2\data\sheets\Company X folder.

    To edit the sheet style, use File ➤ Open command to open the sheet style *.dwg file that is located in the c:\Land Projects R2\Sheet Styles\ folder.

    When you have finished making your edits, use the File ➤ Save command to save the drawing file, and then use the Sheet Styles ➤ Save Sheet Style command on the Sheet Manager menu. The Save Sheet Style command updates the files in the \data\sheets\Company X folder. For more information about editing a sheet style, see “Editing a Sheet Style” in this chapter.

WARNING! If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

NOTE Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they cannot be used with an earlier version of the Desktop.
Creating a New Plan/Profile Sheet in the Paper Space of an Existing Drawing

To create a plan/profile sheet in an existing drawing

1. Complete steps 1–11 of “Creating a New Plan/Profile Sheet In a Separate Drawing” in this chapter.
2. Choose File ➤ Open to open the existing drawing if it is not already open.
3. Switch to paper space.
4. Draw the sheet border using the RECTANGLE command, or insert a pre-defined border block using the DDINSERT command.
5. Use the MVIEW or the Create Viewport command to create the plan and profile viewports.
6. Set the viewport categories and set the viewport view scales. For more information, see “Setting the Viewport View Scales” in this chapter.
7. Draw the frames where you want the labels to appear. For more information, see “Working with Frames” in this chapter.
8. Draw the view frames around each viewport.
9. Attach label styles to the frames.

**WARNING!** If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

Creating a New Profile-Only Sheet Style

You can begin creating a new profile-only sheet by using an existing sheet style drawing and modifying it, or you can start from scratch by drawing a border, viewports, and frames. You can create a new sheet style in a separate drawing, which makes it easier to edit the sheet and transfer data to other people. For example, if you create a new drawing in a new project for your sheet style, then you can give the entire project folder to the person with whom you want to share the sheet style.

To create a new profile sheet style

1. Choose a method for creating, opening, and editing sheet style drawings. For more information, see “Creating a New Sheet Style” in this chapter.
2. You can create the sheet style in a separate drawing.
3. Create a new drawing in a new project. If the sheet is a profile sheet at 50 scale, then you may want to name the drawing something like prof50.dwg. The project name can be something like Sheet Styles.
4. Switch to paper space.
5. In Windows Explorer, create a unique folder under the c:\Program Files\Land Desktop R2\data\sheets folder for your new sheet style. You may want to name the folder after the client you are working for or the project you are working on, for example, Company X.
6 Change the sheet style path so it points to this new folder.

7 Draw the sheet border using the RECTANGLE command, or insert a pre-defined border block using the DDINSERT command. It is recommended that you create the sheet style at a 1:1 scale. For example, if you want a sheet to measure 24 by 36 inches, then make your sheet 24 by 36 units.

8 Use the MVIEW or the Create Viewport command to create the sheet viewport.

9 Set the viewport category and view scale. For a profile sheet at 50 scale, set the scale of the viewport to 50.

10 Draw the frames where you want the labels to appear.

11 Draw the view frames around each viewport.

12 Use the File ➤ Save command to save the current sheet drawing. Save the drawing to the project folder you created when you started this new project. For example, If you created a Sheet Styles project, then save the drawing to the c:\Land Projects R2\Sheet Styles\ folder. You modify this drawing if you need to make changes to the sheet.

13 When you have completed the sheet, click Sheet Styles ➤ Save Sheet Style on the Sheet Manager menu. This command creates the *.dwg, *.dbf, and *.sdb files associated with the sheet and places these files in the c:\Program Files\Land Desktop R2\data\sheets\Company X\ folder.

If you want to edit the sheet style, then use File ➤ Open command to open the sheet style *.dwg file that is located in the c:\Land Projects R2\Sheet Styles\ folder.

---

**WARNING!** If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

---

**NOTE** Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they cannot be used with an earlier version of the Desktop.

---

**Creating a New Plan-Only Sheet Style**

You can begin creating a new plan-only sheet by using an existing sheet style drawing and modifying it, or you can start from scratch by drawing a border, viewports, and frames. You can create a new sheet style in a separate drawing, which makes it easier to edit the sheet and transfer the data to other people. However, another person cannot use the sheet style from a new drawing. For example, if you create a new drawing in a new project (called Sheet Styles), then this drawing is done completely in Paper Space and includes only the sheet information that you want for your template. Then, you save the drawing. Next, use the Save Sheetstyle command to save the sheet style to a different folder specified in the Settings. This is the sheet that people use.
WARNING! If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

To create a new plan sheet style

1. Choose a method for creating, opening, and editing sheet style drawings. You can create the sheet style in a separate drawing. For more information, see "Creating a New Plan-Only Sheet In a Separate Drawing" in this chapter.

2. Create a new drawing in a new project. If the sheet is a plan sheet at 50 scale, then you may want to name the drawing something like plan50.dwg. The project name might be something like Sheet Styles.

3. Switch to paper space.

4. In Windows Explorer, create a unique folder under the c:\Program Files\Land Desktop R2\data\sheets folder for your new sheet style. You may want to name the folder after the client you are working for or the project you are working on, for example, Company X.

5. Change the sheet style path so it points to this new folder.

6. Draw the sheet border using the RECTANGLE command, or insert a pre-defined border block using the DDINSERT command. It is recommended that you create the sheet style at a 1:1 scale. For example, if you want a sheet to measure 24 by 36 inches, then make your sheet 24 by 36 units.

7. Use the MVIEW or the Create Viewport command to create the sheet viewports. You must create both a plan viewport and a profile viewport. The profile viewport must be at least 1 unit in height and should be the same width as the plan viewport. After generating the sheets, you can delete the profile viewport to show the plan view only.

8. Set the viewport categories and view scale. For a plan sheet at 50 scale, you would set the scale of each viewport to 50.

9. Draw the view frames around each viewport. You must draw both a plan/view and a profile/view frame around the appropriate viewports. Plan-only sheets require a profile/view frame to exist around the profile viewport as well as the plan viewport. You can delete the profile viewport and view frame after the sheets are generated.

10. Draw the frames where you want the labels to appear.

11. Use File ➤ Save command to save the current sheet drawing. Save the drawing to the project folder you created when you started this new project. For example, If you created a Sheet Styles project, then save the drawing to the c:\Land Projects R2\Sheet Styles\ folder. You modify this drawing if you need to make changes to the sheet.

12. When you have completed the sheet, Sheet Styles ➤ Save Sheet Style on the Sheet Manager menu. This command creates the *.dwg, *.dbf, and *.sdb files associated with the sheet and places these files in the c:\Program Files\Land Desktop R2\data\sheets\Company X\ folder.
Creating a New Sheet Style

If you want to edit the sheet style, then use File ➤ Open command to open the sheet style *.dwg file that is located in the c:\Land Projects R2\Sheet Styles\ folder.

**WARNING!** If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

**NOTE** Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they cannot be used with an earlier version of the Desktop.

Creating a New Cross Section Sheet Style

Section sheet styles are set up quite differently from a plan/profile or a profile sheet style. Frames control the placement of the sections on a page instead of viewports. You can create a new section sheet style, or you can customize a section sheet style that was provided with Sheet Manager.

You can create a new sheet style in a separate drawing, which makes it easier to edit the sheet and transfer the data to other people. However, another person cannot use the sheet style from a new drawing. For example, if you create a new drawing in a new project called Sheet Styles, the drawing is done completely in Paper Space and includes only the sheet information that you want for your template. Then, you can save the drawing. Next, use the Save Sheetstyle command to save the sheet style to a different folder specified in the Settings. This is the sheet that people use.

**WARNING!** If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

**NOTE** Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they cannot be used with an earlier version of the Desktop.

**NOTE** Do not ever open the sheet style. Instead, open the working drawing under the project called Sheet Styles. Also, do not ever load the working drawing; load the sheet style from the Settings path.
To create a new section sheet style
1 Choose a method for creating, opening, and editing sheet style drawings.
   ■ You can create the sheet style in a separate drawing. For more information, see the following section, “Creating a New Section Sheet In a Separate Drawing.”

Creating a New Section Sheet In a Separate Drawing

To create a new section sheet in a separate drawing
1 Create a new drawing in a new project. If the sheet is at 50 scale, then you may want to name the drawing something like sect40.dwg. The project name might be something like Sheet Styles.
2 Switch to paper space.
3 In Windows Explorer, create a unique folder under the c:\Program Files\Land Desktop R2\data\sheets folder for your new sheet style. You may want to name the folder after the client you are working for or the project you are working on, for example, Company X.
4 Change the sheet style path so it points to this new folder.
5 Draw the sheet border using the RECTANGLE command, or insert a pre-defined border block using the DDINSERT command. It is recommended that you create the sheet style at a 1:1 scale. For example, if you want a sheet to measure 24 by 36 inches, then make your sheet 24 by 36 units. Now, you draw the frames. For an overview of frames for section sheets, see “Drawing Frames for Section Sheets” in this chapter.
6 Draw a section/view frame. For more information, see “Drawing a Section/View Frame” in this chapter.
7 Draw a section/section frame. For more information, see “Drawing a Section/Section Frame” in this chapter.
8 You can draw the section/label frames. For more information, see “Drawing a Section/Label Frame” in this chapter.
9 You can draw the section/table frames. For more information, see “Drawing a Section/Table Frame” in this chapter.
10 You can attach styles to the frames for grids and labels.
11 Use File ➤ Save command to save the current sheet drawing to the project folder.
12 Use the Sheet Styles ➤ Save Sheet Style command to save the sheet style to the unique folder you created in step 4. This step creates the *.dwg, *.dbf, and *.sdb files associated with this sheet.

WARNING! Do not use the File ➤ Open command to open the *.dwg file in the \data\sheets\ folder.

To make your edits, use File ➤ Save, and then use the Sheet Manager ➤ Sheet Styles ➤ Save Sheet Style command.
WARNING! If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

NOTE Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they cannot be used with an earlier version of the Desktop.

The number of sections that fit on a sheet is determined by the size of the sections as well as the Cross Section Settings settings for plotted scale, and column and row spacing. Be sure to adjust these settings before generating the section sheet series.

Editing a Sheet Style

You can edit the viewports, frames, and label attachments of a sheet style.

To open the sheet style you want to edit, you can use one of two methods, depending on how you created and saved the sheet style. These methods are described in “Choosing a Method for Creating, Opening, and Editing Sheet Style Drawings” in this chapter.

WARNING! If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

Choosing a Method for Creating, Opening, and Editing Sheet Style Drawings

The following methods are recommended to manage your sheet style drawings:

- **Method 1**: You can create a sheet style and edit it in the paper space of a drawing you are already working in.
- **Method 2**: You can create a new drawing for the sheet style you want to create, and then use that drawing later if you need to edit the sheet style.

Depending on your preferences, you can choose either method.
**Method 1: Creating a Sheet Style in Paper Space of an Existing Drawing**

To create a sheet style in the paper space of an existing drawing:

1. From within an existing drawing, switch to paper space.
2. Load an existing sheet style using the Sheet Styles ➤ Load Sheet Style command on the Sheet Manager menu, and then make modifications to that sheet style. You can also start from scratch by drawing a border, setting up viewports, and attaching label styles.
3. Save the sheet style using the Sheet Manager ➤ Sheet Styles ➤ Save Sheet Style command. The sheet style is saved to the data\sheets folder by default. The Save Sheet Style command saves the sheet style as a *.dwg file and saves the information about the attached styles in *.dbf and *.sdb files.

   **NOTE** Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they cannot be used with an earlier version of the Desktop.

4. To edit the sheet style, use the Sheet Manager ➤ Sheet Styles ➤ Load Sheet Style command to load the sheet into paper space. Make the edits, and then use the Sheet Manager ➤ Sheet Styles ➤ Save Sheet Style command to save the sheet.

   **WARNING!** Do not use File ➤ Open command to open the sheet style *.dwg file from the data\sheets folder. You cannot edit a sheet style using this method.

When you create a sheet style from within an existing drawing (for example, a drawing that contains model space entities), you must always save and load the sheet style using Sheet Manager commands:

- To save the sheet style, you must use the Sheet Manager ➤ Sheet Styles ➤ Save Sheet Style command.
- You generate a *.dwg file for the sheet style in the \data\sheets folder when you save the sheet style, but you cannot directly edit this *.dwg file unless you use the Sheet Manager commands.
- You cannot use the File ➤ Open command to access the sheet style for editing, even though the sheet style has its own *.dwg file.
- To edit the sheet style, you must load the sheet into paper space by using the Sheet Manager ➤ Sheet Styles ➤ Load Sheet Style command.

   **WARNING!** If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.
Method 2: Creating a Sheet Style in a New Drawing

When you create a separate drawing file for the sheet style, you have more control over the sheet style, but an additional step is required. You create a separate drawing (which may also be in a separate project) for your sheet style.

Creating a new sheet style in a separate drawing makes it easier to edit the sheet style later and it also makes it easier to share the sheet style drawing with other people.

NOTE Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they cannot be used with an earlier version of the Desktop.

To create a sheet style in a new drawing

1 Create a new drawing in a new project (a new project is optional but recommended). When you save this drawing using File ➤ Save, the *.dwg file is saved to the project folder. Create a unique folder for the sheet style in Windows Explorer in the ...\sheets folder. When you save the sheet style using the Save Sheet Style command, the sheet style is saved to this folder.

2 Change the sheet style database path so that it points to this new folder.

3 Create the sheet in the paper space of the new drawing.

4 Click File ➤ Save. This step saves the sheet style drawing to the project folder. You can directly edit this *.dwg file if you need to change the sheet style.

5 From the Sheet Manager menu, choose Sheet Styles ➤ Save Sheet Style. This command creates the *.dwg, *.dbf, and *.sdb files associated with the sheet. These files are saved to the unique folder that you established in step 2.

You cannot directly edit the *.dwg file that is saved to this folder. You can, however, edit the *.dwg file that is saved to the project folder.

If you need to edit the drawing, then always use the File ➤ Open command to open the drawing from the project folder. Make your changes, then select File ➤ Save, and finish by selecting Sheet Manager ➤ Sheet Styles ➤ Save Sheet Style.

Creating a Viewport

On plan/profile and profile sheet styles, you must use viewports to display the model space views of the alignment and profile.

To create new viewports on a sheet, use the Create Viewport command. This command is the same as the MVIEW command.

NOTE This is a paper space command.

To create a new viewport

1 From the Sheet Manager menu, choose Sheet Styles ➤ Create Viewport. The following prompt is displayed:

ON/OFF/Hideplot/Fit/2/3/4/Restore/<First Point>:

2 Select two points on screen with your pointing device to draw the viewport (the lower-left and upper-right corners of the viewport).
You can use object snaps, such as endpoint or intersection, to accurately select the two corners of the viewport. The following illustration shows viewports:

![Viewports](image)

**NOTE** You can later edit the size of the viewports. When in paper space, pick on the viewport, and then pick on the corner you want to move. This activates the `STRETCH` command.

### Choosing a Viewport Category

Use the Set Viewport Category command to specify what each viewport contains when a sheet series is generated and what the view scale is.

You can classify viewports as either plan or profile. If you want to create a Plan/Profile sheet, for example, then use the Set Viewport Category command to define one viewport as plan and the other viewport as profile.

The view scale determines the relationship between model space entities and paper space representation. For example, if you set the paper space view scale to 50, then a model space entity that is 100 units long would appear as only 2 units in paper space.

**To set the viewport category**

1. From the Sheet Manager menu, choose Sheet Styles ➤ Set Viewport Category.
2. Select a viewport. Use your pointing device to pick the edge of the viewport, or use a window or crossing selection.
3 Press ENTER at the Select objects prompt to continue the command. The Edit View Data dialog box is displayed.

4 Set the viewport category by selecting either Plan or Profile from the scroll list.

5 Set the view scale. The viewport scale defaults to the current scale of the viewport. Changing the view scale affects the size of the view definitions that are placed over the plan view during sheet series layout, which, in turn, affects the amount of the plan or profile view that is placed on each series sheet.

   **NOTE** Changing the view scale does not redraw existing model space entities, like a profile, at a new scale. It only scales the entities for a paper space sheet based on their X, Y units.

6 Click OK to exit the command and save your changes.

   **NOTE** You do not define viewports for section sheets. The placement of sections on sheets is controlled through section view frames.

**Saving a Sheet Style**

If you load a sheet style and edit it or if you create a new sheet style, then use the Save Sheet Style command to save the format.

   **NOTE** Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they may not be used with an earlier version of the Desktop.

   **NOTE** When saving the sheet style, your drawing must be set to paper space. Make sure that you are viewing the complete drawing. If you are zoomed in on a portion of the drawing, then only that part is saved.
To save a sheet style

1 Switch to paper space if the drawing is currently set to model space.

2 From the Sheet Manager menu, choose Sheet Styles ➤ Save Sheet Style to display the Save Current Sheet Style dialog box.

3 Type a name for the sheet style.
   The name can have a maximum of eight characters.

4 Specify the drive and folder location where you want the sheet style saved, and then click Save to save the sheet.
   The following prompt is displayed:
   
   Enter Type of sheet (Planprof/Profile/Section) <Planprof>: 

5 Specify which type of sheet you are saving using one of the following methods:

   - Type R for a Profile-only sheet.
   - Type S for a Section sheet.

   All entities within the current layout are saved as part of the sheet style.

   After you specify a sheet type, the command saves the sheet style and regenerates the drawing. This command saves the sheet style under the Style Database folder that is specified in the settings dialog box.

   When you save a sheet style, a drawing file is created in the Style Database folder, along with a supporting <dwgname>.sdb file. The drawing file contains all of the paper space entities within the selected region, including the border lines, viewports and frames. The .sdb file contains information about the sheet style including the viewport size, category and scale for use in the Series Layout as well as the layer settings of the drawing.
WARNING! Do not use the File ➤ Open command to open the sheet style *.dwg file from the \data\sheets folder. You cannot edit a sheet style using this method.

Loading a Sheet Style

To customize an existing sheet style, load it into paper space and edit the sheet.

To load a sheet into paper space

1 From the Sheet Manager menu, choose Sheet Styles ➤ Load Sheet Style to display the Load Sheet Style dialog box.

   ![Load Sheet Style dialog box]

   **NOTE** If you select a sheet style with the Set Current Sheet Style command, then it is the default sheet style.

2 Accept the default style, or use the dialog box to locate the style you want to load.

3 Click Open to load the sheet into the drawing's paper space.

4 Edit the sheet style, if needed.

   **WARNING!** If you plan to use a sheet style with another project, then do not define a sheet style template in the current working drawing. Layers in the current working drawing are carried over to the next project in which you apply the sheet style. Once the layers exist in a project, it is difficult to remove them.

5 Save the sheet.
**Working with Frames**

Frames control where the labels and grids appear on the final generated sheets. Frames are also used instead of viewports to control the placement of cross sections on section sheets.

Some frames, such as label frames, require additional information from you if they are going to label anything. This additional information is created when you attach label and grid styles to the frames. Some frames do not require you to attach label and grid styles to them. For example, some of the frames on a section sheet style control the placement of the sections; attaching label styles is optional.

In this user’s guide, frames are referred to by their type and category. You must assign a type and category to a frame when you create it.

The following illustration shows the area in the Create/Edit Frame dialog box where you set the frame type and category:

- The frame type can be plan, profile, or section based on what type of design data the frame is associated with. For more information, see “Rules for Setting the Frame Type” in this chapter.
- The frame category defines what the frame contains: a label, a view of the design elements, a table (section sheets only), or a cross section (section sheets only). For more information, see “Rules for Setting the Frame Category for Plan and Profile Sheets” and “Rules for Setting the Frame Category for Section Sheets” in this chapter.

For example, to label something on a profile sheet, you would create a profile/label frame.

This is a plan/profile sheet style. Each white rectangle is a frame.

Two of the frames (the largest two) surround viewports. These types of frames are called view frames. The top view frame is the profile/view frame because it surrounds the profile viewport. The lower frame is the plan/view frame because it surrounds the plan viewport.

The other frames in this drawing include the smaller, vertical frames on either side of the top viewport and the two horizontal frames between the two viewports. These smaller frames would be used for labeling the design elements. The frame category is set to label for these frames.
To create the labels in this illustration, label styles were formatted and attached to the frames that exist on the sheet style, and then the sheet series was generated.

For example, in the lower viewport, the station label style was attached to the view frame that surrounds the plan viewport—the plan/view frame.

Text labels are not the only annotation that is controlled by frames. The grid in the upper viewport is placed on the generated sheet because a grid style was attached to the profile/view frame.

**Rules for Setting the Frame Type**

Use these rules for setting the frame type:

- If you are creating a plan-only sheet, always set the frame type to plan. You must also create Profile Viewports and frames. After the sheets are generated, erase the profile viewports and frames.
- If you are creating a profile-only sheet, always set the frame type to profile.
- If you are creating a cross section sheet, always set the frame type to section.
- If you are creating a plan/profile sheet, always set the frame type to plan for the view frame around the plan viewport and for any frames to label the plan view. Always set the frame type to profile for the view frame around the profile viewport and for any frames to label the profile view.

**Rules for Setting the Frame Category for Plan and Profile Sheets**

Use these rules for setting the frame category for plan/profile, plan, and profile sheets:

- Always create a view frame around the plan or profile viewport. Use this frame to label design-location-specific information.
- Always use label frames for labeling plan and profile information outside the viewport. A common use of these frames is for labeling the design elements using increments, such as elevation or station information.
- You cannot use the section or table categories for frames on plan/profile sheets.

**Rules for Setting the Frame Category for Section Sheets**

Use these rules for setting the frame category for Cross Section sheets:

- Always create a view frame on the sheet style to indicate the area on the sheet where you want the sections to appear (usually the entire area of the sheet, excluding space for margins, border, and title blocks). A section sheet can have only one view frame. You can attach labels or grids to this frame, but the labels must not be design-location specific, because multiple sections are placed inside this one frame.
- Always create a section frame on the sheet style. This frame informs Sheet Manager to place sections on the sheet when it is generated. When the series is generated, Sheet Manager copies this frame for each section. Do not create more than one section frame. Labels or grids can be attached to this frame, but they are optional.
Use table frames to label information that is not design-specific to sections, such as volume data. Table frames are optional. You must associate table frames with the section frame using the Assign Design Frame button in the Create/Edit Frame dialog box.

Use label frames to label information outside the region where the actual section is plotted. Label frames are optional. You must associate any label frames you create with the section frame using the Assign Design Frame button in the Create/Edit Frame dialog box.

For more information about frames for section sheets, see “Drawing Frames for Section Sheets” in this chapter.

**Drawing Frames for Section Sheets**

On a section sheet, frames are used for labeling sections but they also control the placement of the cross sections on the sheet style.

The following illustration shows the frames that are on a typical section sheet:

The names of these frames, section/view, section/section, section/label, and section/table, refer to the frame Type and Category you set with the Create/Edit Frame command.

On section sheets, Section is always the frame Type. Section frame Categories can be View, Section, Label, or Table.

The following illustration shows the area of the Edit Frame Data dialog box where you set the frame type and category:

The section/view and section/section frames control how the sections are placed on the sheets. They are required for a section sheet. The section/table and section/label frames are optional.
What Is a Section/View Frame Used For?
The section/view frame defines how much area of the sheet you want to use for the sections. This frame is required for a section sheet. There can be only one section/view frame on a sheet.

You can attach a grid style to this frame if you want a grid to be plotted on the sheet with your cross sections. Do not attach design-location specific label styles to this frame because it is not specific to any one cross section.

For more information, see “Drawing a Section/View Frame” in this chapter.

What Is a Section/Section Frame Used For?
The section/section frame places the sections on the sheet. This frame is required for a section sheet. There can be only one section/section frame on a sheet. This frame does not have to be drawn to exact size; it is adjusted for each cross section that is placed on the sheet.

Any label or grid style can be attached to this frame. For example, you can attach label styles to this frame for labeling design information or you could attach a grid style to this frame.

For more information, see “Drawing a Section/Section Frame” in this chapter.

What Is a Section/Label Frame Used For?
The section/label frames label design information. These frames adjust in size based on how large the cross section is.

Text label, block label, and grids can be attached to this frame; good for labeling elevations.

For more information, see “Drawing a Section/Label Frame” in this chapter.

What Is a Section/Table Frame Used For?
The section/table frames label cross section information that is not design-location specific, such as cut/fill volumes.

Table frames are good for labeling non-design-specific information. If you want to add a heading, you can do so from the Edit Text Format dialog box by adding text. This information is associated with the table frame and the accompanying text attachments and moves accordingly.

For more information, see “Drawing a Section/Table Frame” in this chapter.

Some of the Cross Section Preferences control the placement of cross sections on the sheet. These settings include the horizontal and vertical scale, the margin size, and the column and row spacing.

You only have to draw one set of frames per section sheet style. When Sheet Manager generates the sheet series, this set of frames is copied automatically for each section that fits within the sheet.
Drawing a Section/View Frame

A Section/View frame designates the area on the sheets in which to plot the sections. The Generate Section Sheets command uses the Section/View frame to calculate how much area is available on the sheet for plotting the cross sections.

To draw a section/view frame

1. From the Sheet Manager menu, choose Sheet Styles ➤ Create/Edit Frame.
2. Press ENTER to display the Edit Frame Data dialog box.

   ![Edit Frame Data](image)

3. Select Section as the frame Type.
4. Select View as the frame Category.
5. Click Pick Origin/Size << and draw the frame on the sheet.

   **NOTE** A section sheet style must have only one Section/View frame.

   **TIP** The Section/View frame is not specific to any given sections, so if you attach design-specific label styles to the frame, no labels are created.

   If you attach a Grid Style to the Section/View frame, then a grid is inserted on each sheet when you generate the series. In the Cross Section Preferences dialog box, select the Snap Sections to Grid check box to align the plotted sections with this grid.
Drawing a Section/Section Frame

Unlike plan/profile sheets, which use viewports to designate the locations on the sheet where the design elements appear, section sheets use a single Section/Section frame to place the sections on the sheets. This one frame works for all cross sections that are plotted per sheet. When the sheets are generated, this frame is replicated for each section that is plotted.

The size and shape of the sections usually vary from station to station. The Section/Section frame takes these variations into account and adjusts its size and dimension according to the section it contains, based on the horizontal and vertical scales you set in the Cross Section Preferences dialog box. Therefore, you do not need to draw the Section/Section frame with exact size and dimensions in mind.

**NOTE** For an illustration of a Section/Section frame, see “Drawing Frames on Section Sheets” in this chapter.

To draw a section/section frame

1. From the Sheet Manager menu, choose Sheet Styles ➤ Create/Edit Frame.
2. Press ENTER to display the Edit Frame Data dialog box.

   ![Edit Frame Data dialog box]

3. Select Section as the frame Type.
4. Select Section as the frame Category.
5. Click Pick Origin/Size<< and draw the frame.
6. You can attach label styles to the Section/Section frame. Some of the labels you may want to attach to this frame are point code labels or existing ground

Drawing Frames for Section Sheets 809
information. You can set up Text Label styles to label the template point codes with offsets and/or elevations.

7 Draw any related label frames around the Section/Section frame. When you generate a section sheet, the Section/Section frame is adjusted in length and height based on the size of each section. All of the related label frames adjust in length with the section/section frame.

8 Save the sheet style.

**Drawing a Section/Label Frame**

You can add any number of Section/Label frames to a section sheet style. Section/Label frames are optional, and are only necessary if you want to attach label styles to the sheets. Unlike the Section/View and Section/Section frames, they do not control the placement of the cross sections on the page.

The Section/Label frames are also adjusted automatically to fit the size and dimensions of the cross section. When the Generate Section Sheets command adjusts the Section/Section frame for the size of the sections it is plotting, it also adjusts the length or height of the Section/Label frames accordingly. The length of horizontal frames and the height of vertical frames are adjusted.

**NOTE** For an illustration of a Section/Section frame, see “Drawing Frames on Section Sheets” in this chapter.

**To draw a section/label frame**

1 From the Sheet Manager menu, choose Sheet Styles ➤ Create/Edit Frame.
2 Press ENTER to display the Edit Frame Data dialog box.
3 Select Section as the frame Type.
4 Select Label as the frame Category.
5 Click Pick Origin/Size<<.
6 Draw the Section/Label frame next to, above, or beneath the single Section/Section frame on the sheet style.
   The Generate Section Sheets command replicates the label frames for each section it plots on the sheet.
7 In the Edit Frame Data dialog box, click the Assign Design Frame button. This option associates the label frames with the Section/Section frame.
8 Use your pointing device to select the edge of the Section/Section frame. This associates the label frame with the section.
9 Repeat this process for each Section/Label frame.
10 Attach label styles to the label frame to label cross section data.
11 Save the sheet style.

**Drawing a Section/Table Frame**

You can add any number of table frames to a section sheet. Section/Table frames are used like Section/Label frames to label the cross section information. However, the Section/Table frame is intended for labeling information that is not specific to a design location, such as cut and fill volumes. The dimensions of the table frames remain fixed when the section sheets are generated, so you can draw them in rows and/or columns, like a table.
The following list describes some of the characteristics of Section/Table frames:

- Use the Section/Table frame to label information that is not visible in the design, such as cut and fill volumes.
- You can have any number of Section/Table frames on a section sheet.
- You must associate the Section/Table frame with the section data by using the Assign Design Frame option in the Create Frame dialog box.
- The size of the Section/Table frame remains constant and does not vary with the size of sections.
- Place the Section/Table frame to the right or the left of the Section/Section frames and Section/Label frames. You can also place a Section/Table frame above or below the other frames.

**NOTE**  
For an illustration of a Section/Section frame, see “Drawing Frames on Section Sheets” in this chapter.

To draw a Section/Table frame

1. From the Sheet Manager menu, choose Sheet Style ➤ Create/Edit Frame.
2. Press ENTER to display the Edit Frame Data dialog box.
3. Select Section as the frame Type.
4. Select Table as the frame Category.
5. Click Pick Origin/Size<< and draw the frame. See “Drawing Frames for Section Sheets” in this chapter for guidelines.

Draw the Section/Table frame next to the single Section/Section frame (and optional Section/Label frames) on the sheet style. Draw the table frame to the exact size that you want it to appear on the generated sheets.

**NOTE**  
The section sheet, .sdsksect.dwg that is provided with this program, has a table frame with a height of zero. The labels can exceed the frame.

The Generate Section Sheets command replicates the table frames for each section it plots on the sheet so you only need to draw one set of them.

Another step you must perform when you are setting up Section/Table frames is to associate the table frames with the Section/Section frame. To do this, you must use the Assign Design Frame option.

6. In the Edit Frame Data dialog box, click the Assign Design Frame button.
7. Use your pointing device to select the edge of the Section/Section frame. This associates the Section/Table frame with the cross section data.
8. Attach label styles to the table frame to label cross section data.

**NOTE**  
Use the Text Label command to format the label style, and then attach the label style to a Section/Table frame that is at the top of the column.

9. Save the sheet style.
Attaching Labels and Grids to Frames

To label design information, you must attach labels, such as text labels, to the frame. There is no limit to the number of label and grid styles that can be attached to a frame. You can control where the labels appear by choosing different placement options.

For example, to create the station labels on the plan view in this illustration, you would do the following:

1. Format the text label style so that it labels alignment|station.
2. Attach the label to the plan/view frame using Alignment|Station as the Design Data Point and using Design Incremental as the Label Location. In order for these label placement options to place labels at 50' increments, you must first set the label increment to 50.

By choosing Design Incremental as the Label Location, the labels are placed directly on the alignment. As the alignment curves, the rotation of the labels is adjusted to follow the curves.

You can perform the step 2 in the preceding list by using the Create/Edit Frame command. When you select Text under the Attached Labels section, the Edit Attached Text Labels dialog box is displayed. Use the Label Placement Data section of this dialog box to control the placement of the labels.

The following screen capture shows the the Edit Attached Text Labels dialog box:
In this dialog box, there are many variables to consider when creating frames and attaching label styles to them. One of the best ways to learn how to set up your own label styles and frames is to analyze existing label styles and placement options. For example, you can load one of the default sheets into paper space and use the Create/Edit Frame command to see which styles are attached to a frame and how they are attached to the frame.

**Frame Characteristics**
The following list describes some of the characteristics of frames:

- The actual frame does not have to be plotted. You can place the frame on a layer that is turned off for plotting.
- When you copy a frame with the COPY command, it maintains all of its label and grid styles. For example, when you draw a vertical frame on the left side of the profile to label the grid elevations, and then copy the frame to the right side of the profile grid, the frame maintains the elevation label style. You do not have to re-attach the label style to the copied frame.
- You can edit the frame properties and attachments of a generated sheet. However, if you edit a generated sheet, the changes only affect the current sheet, and do not affect any of the other generated sheets or the original sheet style template. To save the changes back to the sheet style, load the original sheet style, make the same edits, and then save the sheet style.
- You can edit the label and grids on a generated sheet, such as a Text Label or block. These edits are saved to the style database, which, in turn, affect the saved sheet style. To update the label style for a specific sheet, but not all generated sheets, use the Update Frame Labels command. This command is sheet-specific.
- If you rename a label or grid style, then delete the old style name from the frame’s attachment list, and then re-attach the new style name.
Drawing Frames for Plan/Profile and Profile Sheets

For plan/profile and profile sheets, a frame defines a rectangular region on a paper space sheet style which contains label and grid styles. For example, you can place a frame above or below a profile viewport for labeling station and elevations. You can place frames on either side of a profile viewport for labeling grid elevations. You can also place a frame around or inside a viewport for labeling the information directly on the view such as plan stations, curve information and profile finished ground, and pipe labels.

The following illustration shows plan/view, profile/view, and profile/label frames:

Creating a Frame

To draw a frame
1 Choose a method for creating sheet styles, and either create a new drawing for the sheet style or open an existing drawing.
   For more information, see “Editing a Sheet Style” in this chapter.
2 Switch to paper space.
3 From the Sheet Manager menu, choose Sheet Styles ➤ Create/Edit Frame.
   The following prompt is displayed:

   Select a Frame or (Press Return to create a new one):
4 Press ENTER to create a new frame. To edit a pre-existing frame, use your pointing device to select it. The Edit Frame Data dialog box is displayed.

![Edit Frame Data dialog box]

Use this dialog box to specify the frame type, contents, size and location, and frame entity properties.

5 Under Frame Properties, click the Pick Origin/Size<< button and pick two points to draw the frame.

6 You can also set the following settings to control how the frame is drawn:
   - **Layer**: Use this option to set the layer the frame is drawn on. You can type the layer name in the edit box, or you can access a list of existing layers by clicking the Select button to the right of the layer edit box. If you type in the name of a new layer, then it is created automatically when the sheets are generated.
   - **Linewidth**: Use this edit box to enter the polyline width for the frame. The frame is still plotted if you use a line width of zero. If you specify a width other than zero, then the line is plotted in current paper space units. For example, in imperial units, a linewidth of 0.10 is plotted as one tenth of an inch on a sheet of paper. For a metric drawing, the linewidth is in meters.
   - **Width**: Use this edit box to adjust the width of the frame. To place the frame on the sheet, and roughly define its size, click the Pick Origin/Size button.
   - **Height**: Use this edit box to adjust the height of the frame. To place the frame on the sheet, and roughly define its size, click the Pick Origin/Size button.
   - **Draw Vertical**: Select this check box to draw the frame with a vertical orientation. A typical vertical frame would be one along the left or right side of a profile that is used to label grid elevations.
Clear this check box to draw the frame with a horizontal orientation. A typical horizontal frame would be one below a profile that is used to label the profile stationing.

- **Pick Origin/Size**: Click this button to position the frame on the sheet. When you click this button, the dialog box closes and you are prompted to pick the lower left (origin) point and then the upper right point of the frame. After picking the points, the dialog box returns to the screen. If necessary, you can change the height and width by entering the new dimensions in the Width and Height edit boxes.

- **Draw Frame**: When you have finished setting the frame parameters, click the Draw Frame button. The frame is drawn on the specified layer. If the frame already exists in the drawing, then it is removed, and then redrawn. If the frame is not drawn in the right location, then use the Pick Origin/Size button to select a new origin point and/or size, and select the Draw Frame button again.

7. Under **Frame Style/Label Data**, you must select the type and category for the frame. The type and category determine what the frame contains:

- **The frame Type** determines whether the frame contains plan, profile, or section information.
- **The frame Category** determines whether the frame contains labels, a view of the design elements, a section, or a table:
  - **Label**: Select the Label option if the frame is to contain labels. This is for frames that are used to label information in either a row or column. Typically these are the frames above, below, left or right of the viewports or view frames, and are typically used to label information such as profile stations and elevations.
  - **View**: Select the View option if the frame surrounds a viewport or is otherwise placed inside of a viewport. The View option is also used for section sheets to define the area on the sheet where the sections are plotted. The View option is often used to label information at the design locations, such as vertical tangent grades or pipe information, but this option can also be used like a label frame to position labels along the top, middle, or bottom of the frame.
  - **Table**: Use the Table option for section sheets only. Use this option for frames on a section sheet that contain information that is not design location-specific, such as cut and fill volumes.
  - **Section**: Use the Section option if the frame is to contain a cross section. This option is used to define the section view and is the equivalent of using viewports for plan and profile. The size of this frame adjusts automatically to the size of each plotted section. A section sheet style should only have one of these section frames; a copy is made for each section that fits on the sheet when the sheets are generated.

8. Under **Attached Labels**, you can attach labels and grids to the frame.

9. Click OK to exit the dialog box.
Creating Labels and Grids

You can annotate sheets by using label and grid styles. These styles include text labels, block labels for creating symbols on sheets, distance labels for labeling dimensions, and grid styles for placing grids on sheets.

To create and edit label and grid styles, use the commands in the Frame Components section of the Sheet Styles submenu.

Several label styles are provided with Sheet Manager that you can use as is. To create customized label styles, you can copy the default styles and modify them, or you can create new styles from scratch.

To make the labels and grids appear on a generated sheet, you must attach the label or grid style to a frame on a sheet style, and then you must use that sheet style to generate a sheet series. The labels or grids are then created automatically for the specific design elements in your drawing.

For example, to create the station labels over the plan view in this illustration, you would:

1. Define a text label style that labels the stations of an alignment.
2. Attach this label style to the frame that surrounds the plan viewport on the sheet style (the plan/view frame).
3. Save the sheet style.
4. Use the sheet style to generate the sheet series.

The grid shown in the preceding illustration was created by using a grid style. To achieve this result, a grid style was set up to place a grid line every 1" horizontally and vertically, and then the style was attached to the profile/view frame on the sheet style.

The label and grid styles in Sheet Manager can automate what could be time-consuming. After you set up the sheet style with the frames and label and grid styles, you can use the sheet style repeatedly, not only for the current project, but for any future project as well. Label and grid styles can also be shared by multiple people on a network. This is because both the sheet style and the label and grid styles are stored in an external database. If you make revisions to the project data, or if you make revisions to a sheet style or to a label or grid style, you can immediately generate new sheets with the updated data.

Creating a Text Label

To label sheets, you can use Text Labels. A text label is used to label specific design information on the plan, profile, or section sheets. This includes, but is not limited to, stations, elevations, offsets, lengths, angles, and slopes.

When you format a text label, you must specify what design information you want it to label, as well as the text style, text size, justification, angle, and layer that the information is placed on. To specify what the Text Label labels, you specify a Code Category for the label. This can be something like Alignment if you are creating a label for alignments. You also need to specify a Code for the label. A Code is a subset of the Code Category. For example, when you choose...
Alignment as a Code Category, you must choose an alignment-related Code, such as Station.

After you have defined and saved a Text Label, you can control where the label appears on the sheet by attaching it to a label frame. You can attach text labels to label, table, or view frames. When you attach the labels to the frames, you can specify additional label placement data, such as whether you want the labels to appear at station increments along the alignment, or at a specific location, such as a point of tangency.

When you generate the sheets, the text labels are placed into the frames. They are created as paper space entities that are saved with the sheet .dwg files.

**To format a text label style**

1. From the Sheet Manager menu, choose Sheet Styles ➤ Text Label to display the Select Style dialog box.

   ![Select Style Dialog Box](image)

   The Style Type is listed as Text Label at the top of the dialog box.

2. Do one of the following:
   - Define a new style by typing the name of the text style in the Style Name edit box. The text style name can have a maximum length of 256 characters.
   - Edit an existing style by selecting it from the Style List.
3 Click Edit to display the Text Label Properties dialog box. Use this dialog box to control the style, justification, layer name, height, and rotation angle of the labels.

![Text Label Properties dialog box]

4 Under Text Entity Data, specify text style and justification, height, rotation, and layer. You can specify the following properties:
   - Text Style
   - Justify
   - Layer
   - Height
   - Rotation Angle

5 Under Text Label Format, click the Edit button to specify what type of information is labeled. For more information, see “Specifying Which Design Elements the Text Label Will Label” in this chapter.
Specifying Which Design Elements the Text Label Will Label

This section is a continuation of the previous section, “Creating a Text Label” and describes how to specify which design elements the label style labels.

**To specify which design elements the text label will label**

1. Display the Edit Text Format dialog box.

   ![Edit Text Format dialog box](image)

   The Text Format has the same name as the label style, and is listed at the top of the dialog box. To specify which design elements are labeled, you must set a Code Category and a Code. For more information, see “Example: Code Category” in this chapter.

2. Select the Code Category first because it determines which code options are available. See “Categories and Codes for Text, Block, and Distance Labels” in this chapter for a full list of available Code Categories and Codes.

3. Select the Code.

   To ensure logical combinations of categories and codes, the Codes scroll box lists different items depending on what you have selected as the Code Category. The codes specify individual features of each category, such as the station, elevation, grade break, or slope.

   You can have multiple Codes per label style.
4 Click the Add Code to Text Format button to place the category/code in the Text/Code/Formula Format Order list. Preview how the text appears by looking directly above this list at the Preview Formatted Text section.

5 You can define more than one code per category by choosing another code and clicking the Add Code to Text Format button. If you have more than one code defined, then use the <Move Left and Move Right> buttons to control the order of the codes as they appear in the labels.

**NOTE**
You can only use one Code Category per label style, but you can use more than one Code per label style if you want the label to identify more than one item, such as Station and Elevation.

6 To insert text into your label, such as unit designations, @ signs, or brackets, enter the text string into the Text Data edit box and click the Add button.

**NOTE**
You can create Text Labels in paragraph format by using the characters {} and \P. See “Creating Text Labels in Multi-Line Format” for more information on how to use this feature. To remove an item from the Text/Code/Formula Format Order list, select it and click the Delete button.

7 To set the numeric format of a label, click Numeric Format.

8 Click OK to exit the dialog box, or Cancel to cancel the command.

After you have formatted the Text Label style, use the Create/Edit Frame command to attach the Text Label to a frame. For more information, see “Creating a Text Label” in this chapter.
Setting the Numeric Format for a Text Label

This is a continuation of “Creating a Text Label” in this chapter. This section describes how the numbers in the labels appear.

To control the way that the codes, such as stationing or elevations, are formatted

1. In the Edit Text Format dialog box, click the Numeric Format button to display the Edit Numeric Format dialog box.

   ![Edit Numeric Format dialog box](image)

   The Preview section at the top of this dialog box reflects the changes you make to the numeric format. You can change the preview value by typing a new value in the Preview Value edit box.

2. Under Numeric Format Options, you can choose from the following options to control the way the numbers are displayed:
   - **Minimum display width**: Use this edit box to specify the total number of characters that will be displayed when the Show leading zeros option is selected.
     
     For example, if you enter a value of 6 in the Minimum display width edit box, and set the decimal precision at 2, and enter a value of 50.02 in the Preview Value, then the value 050.02 shows in the preview.
     
     This option includes the decimal point in the total number of characters: 050.02 has a width of 6. If the width you specified is less than the width of the number, then the number still displays in total, it just won’t have any leading zeros. For example, if you specify a width of 2 but the number is 50.02, then the number would display in the preview.
   - **Show leading zeros**: Select this check box to display leading zeros in front of the number. Clear this check box if you do not want leading zeros to be displayed.
     
     This setting works along with the Minimum display width setting. For example, a value of 50.02 would be displayed as 050.02 if Show leading zeros
is selected and the Minimum display width is set to 6 (the decimal point is counted as one character. A value of 50.02 would be displayed as 0050.02 if the Minimum display width is 7.

- **Use ( ) for negative values**: Select this check box to display negative values inside parentheses () signs. Clear this check box to display negative values with a minus sign.

- **Decimal precision**: Use this edit box to select how many characters are displayed to the right of the decimal point. For example, if you are using a decimal precision of 2, then 50.0210 is truncated to 50.02.

- **Decimal character**: Use this edit box to select the decimal character to use. For example, type a decimal point (.) to show decimal numbers as 50.02. Type a comma (,) to show decimal numbers as 50,02.

- **Drop decimal for even values**: Select this check box to display even numbers with the specified precision. For example, if you select this check box, and the precision is set to 2, a value of 10 is displayed as 10, not as 10.00.

3. Under Station/Chainage Numeric Format, you can choose from the following options to control the way stationing is performed:

- **Use Station Format**: Select this check box to display the station values with the station character and base value. For example, if you select this check box, then a Preview value of 50.02 is displayed as 0+50.02 if the station character is a plus sign (+). The decimal values are not truncated. To get a result of 50+02, you would enter 5002 as the Preview value.

The base value is also applied if the Use station format check box is selected. For example, if the station base value is 10, the Preview value of 50+02 would be displayed as 5+0.02. If the station base value is set to 1000, the result is 0+050.02.

- **Show Left/Right**: For more information, see “Example: Show Left/Right” in this chapter.

- **Station + character**: Use this edit box to specify what character you want to use when numbering stations. For example, a plus sign (+) is typically used for labeling stations.

- **Station base value**: Use this slider bar to control how the station numeric format is displayed. For example, if the base value is 10, the station + character is moved one position to the left of the decimal place.

4. Click OK to return to the Edit Text Format dialog box.

### Deleting a Text Label Style

**To delete a Text Label Style**

1. From the Sheet Manager menu, choose Sheet Styles ➤ Text Label to display the Select Style dialog box.

2. From the Style List, select the name of the Text Label you want to delete.

3. Click the Delete button.
Renaming a Text Label Style

To rename a Text Label Style
1. From the Sheet Manager menu, choose Sheet Styles ➤ Text Label to display the Select Style dialog box.
2. From the Style List, select the name of the text label you want to rename.
3. Click the Rename button to display the Style Name dialog box.
4. Type the new name for the style, and then click OK.

Copying a Text Label Style

The copy feature is useful if you want to create variations of an existing label.

To copy a Text Label Style
1. From the Sheet Manager menu, choose Sheet Styles ➤ Text Label to display the Select Style dialog box.
2. From the Style List, select the name of the text label you want to copy.
3. Click the Copy button to display the Style Name dialog box.
4. Type a name for the style you are copying, and then click OK.

Example: Justification Parameters

Use the Justify list to control the alignment location of the text. Select the justification based on how the Text Label is attached to the frame. You have the choice of Left, Center, and Right justification measured from three different locations: baseline, middle, and top. There is also a Middle option. These are AutoCAD standards. The following illustration shows justification parameters:

![Justification parameters](image)

Example: Rotation Angle

Use the Rotation Angle edit box to control the angle of the text. For the design aligned placement options, 0 degrees is aligned with the entity that the text is being placed on. Ninety degrees or 270 degrees is perpendicular. The following illustration shows these rotation parameters:

![Rotation parameters](image)
The following illustration shows the design incremental with text at a 0-degree rotation angle:

![0 rotation angle](image)

The following illustration shows the design incremental with text at a 270-degree rotation angle:

![270 rotation angle](image)

**Example: Text Label Format**
You can format text labels so that they label more than one value.

The following example shows a text format that is set up to label finished ground centerline profiles with both length and grade. Tangent length, tangent
grade, and static text strings (m @ and %) are combined to produce the following result: 100m @ 2.25%, as shown:

This example produces a label like the one shown in the following illustration:

You can use formulas to show alternate units, such as 100.00'[30.480m], or you can use formulas to change the value of a profile tangent grade from a percentage to a slope, such as changing 2% to 1 in 50.

You can label multiple codes as one line of information or you can label them in paragraph form by using special characters.

**Example: Code Category**

The Code Category list displays the design elements that can be labeled, such as the horizontal alignment, existing ground, finished ground profile, and pipe data.
The following illustration shows the Edit Text Format dialog box with the settings for multiple codes in a single label style displayed:

In the following illustration of the Edit Text Format dialog box, a label uses multiple codes in a single label style:

Multiple codes in a single label style
You can choose only one Code Category per label style. However, you can define multiple Codes per label style. For example, you can label the horizontal alignment (the Code Category) with Equation STA Back and Equation STA Ahead (which are two different Codes). You cannot format a label style to label the horizontal alignment and profile (both are Code Categories) with station information.

**NOTE**
Use the Profile category for labeling the grid elevations on the side of a profile only. Each specific part of the profile, such as existing ground or finished ground centerline, has its own unique category.

Instead of being part of the Sections category, each template point code has its own independent category. This makes it possible to label different variables of each template point code.

For more information, see “Creating Text Labels in Multi-Line Format” in this chapter.

**Example: Show Left/Right**
Use this scroll box to select whether to show the characters to the left and right of the station + character. There is an option to Show Full Station, which displays the entire number. There are also options to Drop Right Side and Drop Left Side.

For example, if the Preview value is set to 50.02 and the station base value is set to 100, then a preview of 0+50.02 is displayed with a Show Left/Right setting of Show Full Station. If you set the Show Left/Right option to Drop Right Side, then 0 is displayed. A setting of Drop Left Side displays 50.02.

The following illustration shows the Edit Numeric Format dialog box with the Show Full Station numeric format setting:
The Station/Chainage Numeric Format is set at Drop Right Side in the Edit Numeric Format dialog box, as shown in the following illustration:

Drop right side setting

The Station/Chainage Numeric Format setting is set at Drop Left Side in the following illustration of the Edit Numeric Format dialog box:
Creating Text Labels in Multi-Line Format

Often it is necessary to display a related group of values in a stacked, multi-line format. Some typical examples include horizontal curve information, vertical curves, or pipe structure inverts.

One method you can use to create a multi-line Text Label to combine the codes into one Text Label using special characters to designate the start and end of each line. This method is described in this section.

When you are using the Text Label command, use the Text Data edit field of the Edit Text Format dialog box to add the special characters in the Text Label format. The following characters are required to create a multi-line label:

The basic guidelines to create multi-line labels are as follows:

- The first line must start with `{`.
- The last line must end with `}`.
- To end one line and start the next line, use `\p{`.

**NOTE** The line break is not case-sensitive: you can use `\p` or `\P`.

- If a line is starting or ending with a descriptive text string, the text string and the multi-line control character can be combined when added to the format order. For example, if the first line starts with `L = `, then you can add the first line symbol, `{`, to the first line to make `{L =`.
- The Text Label is added to the drawing as MTEXT. For more information on MTEXT, refer to AutoCAD 2000 online Help.

Example: How To Create a Multi-Line Label

The following illustration describes how to create a multi-line label to display the length, k factor, and algebraic difference of a vertical curve:

```
L = 100m
K = 20
AD = 5%
```

Multi-line label
To create a multi-line label

1. Format the style for the label shown in the above illustration.
2. From the Sheet Manager menu, choose Sheet Styles ➤ Text Label to display the Select Style dialog box.
3. Type the name of the new style, Profile - FGC Vertical Curve, in the Style Name edit box.
4. Click the Edit button to display the Text Label Properties dialog box.

5. Use the Text Label Properties dialog box to specify the following text entity data:
   - Use the Standard text style.
   - Set a text height of .003 in metric units.
   - Set the justification to Middle Center.

6. In the Text Label Format section of the dialog box, click Edit to display the Edit Text Format dialog box.
7. In the Text Data edit box, type the text string \{L = , including a space after the = sign.
8. Under Text Data, click Add.
9. Set the Code Category to FG Centerline and set the Code to VC Length.
10. Click the Add Code to Text Format button.
11. In the Text Data box, type the text string \m\{K = , including a space after the = sign.
12. Under Text Data, click the Add button.
   - This ends the length on the first line with the meter unit character, and starts the next line with K =.
13. Set the Code to VC K.
14. Click the Add Code to Text Format button to add the vertical curve K factor.
15. In the Text Data box, type the text string \}p\{AD = , including a space after the = sign.
16 Under Text Data, click the Add button.
   This ends the second line, and start the next line with AD =.

17 Set the Code to VC A.D.

18 Click the Add Code to Text Format button to add the algebraic difference.

19 In the Text Data box, type the text string \%

20 Under Text Data, click the Add button.
   This ends the algebraic difference with the percentage sign and completes the
   last line.

Now you have completed formatting the text style. To label the profile view to
match the illustration shown at the beginning of this section, you must attach
this style to the Profile/View frame on a sheet style and generate a sheet.

The following illustration shows the Edit Text Format dialog box with the text
style formatting settings:
Converting Values With the Formula Data Option

When you are setting up the text formats for text label styles, you can apply formulas to any of the label codes. This is useful if you want to convert between metric and imperial units or to change a percent grade to a ratio slope, for example.

To modify a code value with a formula

1. From the Sheet Manager menu, choose Sheet Styles ➤ Text Label to display the Select Style dialog box.
2. Select an existing style or create a new style.
3. Click the Edit button to display the Text Label Properties dialog box.
4. Use the Text Label Properties dialog box to specify the text entity data.
5. Under Text Label Format, click the Edit button to display the Edit Text Format dialog box.
6. Set the Code Category and the Code with the scroll boxes.
7. Click the Apply Code to Formula button.

**NOTE** Because a category/code name can be quite long, the name is displayed in the Formula Data edit box as a numeric code within square brackets. Do not modify the value within the square brackets when defining the formula.

8. Enter the appropriate function into the Formula edit box.

**NOTE** See the following table, “Text Label Formula Function Symbols” in this chapter for a list of functions.

9. Click the Add button.

The modified Category/Code appears in the Text/Code/Formula Format Order list box.
Text Label Formula Function Symbols

You can use the following functions to convert values within labels.

<table>
<thead>
<tr>
<th>Symbols</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>addition</td>
</tr>
<tr>
<td>-</td>
<td>subtraction</td>
</tr>
<tr>
<td>*</td>
<td>multiplication</td>
</tr>
<tr>
<td>/</td>
<td>division</td>
</tr>
<tr>
<td>^</td>
<td>exponent</td>
</tr>
<tr>
<td>(</td>
<td>open parenthesis</td>
</tr>
<tr>
<td>)</td>
<td>closed parenthesis</td>
</tr>
<tr>
<td>ABS</td>
<td>absolute value of a number</td>
</tr>
<tr>
<td>ACOS</td>
<td>arccosine of a number</td>
</tr>
<tr>
<td>ASIN</td>
<td>arcsine of a number</td>
</tr>
<tr>
<td>ATAN</td>
<td>arctangent of a number</td>
</tr>
<tr>
<td>COS</td>
<td>cosine of a number</td>
</tr>
<tr>
<td>COSH</td>
<td>hyperbolic cosine of a number</td>
</tr>
<tr>
<td>EXP</td>
<td>e raised to the power of a number</td>
</tr>
<tr>
<td>LOG</td>
<td>logarithm of a number to a specified base</td>
</tr>
<tr>
<td>LOG10</td>
<td>base-10 logarithm of a number</td>
</tr>
<tr>
<td>POW10</td>
<td>number raised to a power of 10</td>
</tr>
<tr>
<td>ROUND</td>
<td>rounds to the closest integer</td>
</tr>
<tr>
<td>SIN</td>
<td>sine of a number</td>
</tr>
<tr>
<td>SINH</td>
<td>hyperbolic sine of a number</td>
</tr>
<tr>
<td>SQRT</td>
<td>square root of a number</td>
</tr>
<tr>
<td>SQR</td>
<td>square of a number</td>
</tr>
<tr>
<td>TAN</td>
<td>tangent of a number</td>
</tr>
<tr>
<td>TANH</td>
<td>hyperbolic tangent of a number</td>
</tr>
<tr>
<td>TRUNC</td>
<td>number truncated to an integer</td>
</tr>
</tbody>
</table>
Example: Using the TRUNC Function the formula

\[ \text{TRUNC(FG Center Line|V Tangent Length)} \]

converts the Finish Ground Center Line Tangent Length to a whole integer. For example, 900.02 becomes 900.

**Example: How to Convert Metric Units to Imperial Units in a Text Label**

This example explains how to create a text label for labeling the tangent length of an alignment for a metric project with both metric and imperial units.

**To convert metric units to imperial units**

1. From the Sheet Manager menu, choose Sheet Styles ➤ Text Label to display the Select Style dialog box.
2. Type the name of the new style, Alignment - Tangent Length, in the Style Name edit box.
3. Click the Edit button.
4. Use the Text Label Properties dialog box to specify the text properties.
5. Under Text Label Format, click the Edit button to display the Edit Text Format dialog box.
6. Under Text Format Data, set the Code Category to Alignment and the Code to Tangent Length.
7. Click the Add Code to Text Format button. The code defaults to Tangent Start Station.
8. Change the default back to Tangent Length before adding the code to the formula.
9. With the Code Category and Code still set to Alignment and Tangent Length, click the Apply Code to Formula button. This places the text string into the Formula edit box in the Formula Data section of the dialog box.
10 Click the Numeric Format button to the right of the format order list box to display the Edit Numeric Format dialog box.

![Edit Numeric Format dialog box]

11 In the Decimal Precision box, type 3.
12 Click OK to return to the Edit Text Format dialog box.
13 In the Formula box, move your cursor to the end of the numeric code, [100]1360.
14 To change the metric value to imperial units, you need to multiply the metric value by 3.28084. After the text string, type an asterisk (*) and then the value 3.28084.

**NOTE** See the previous table, “Text Label Formula Function Symbols” for a complete list of symbols to use.

15 Click the Add button to add this formula to the Text/Code/Formula Format Order list.
16 Click the Numeric Format button.
17 Type a Decimal Precision of 2.
18 Click OK.

The Tangent length code has now been added to the format order list box twice, once in its raw format and once with a formula applied to it.

Next, you create two text strings that accompany the formula. After the metric value, you insert an m followed by a space and an open bracket. After the imperial value, you insert a foot (’) sign and a closing bracket.

19 In the Text edit box, type m, a space, and a bracket [.
20 Click the Add button.
21 In the Text edit box, type a foot sign (’) and a closing bracket ].
22 Click the Add button. Both text strings now appear in the Text/Code/Formula Format Order List.
23 Put the items in the correct order using the <Move Left and >Move Right buttons. Look at the Preview Formatted Text area to see where each item is and where you need to move it.

The order should appear as follows:

1000.000 m [3,280.84']

To achieve this result, the items should be in the following order:

- Alignment|Tangent Length
- m [  
- Alignment|Tangent Length *3.28084
- ]

24 Click OK to save the text format.

**Example: How to Convert a Percentage Value to a Ratio in a Text Label**

This example explains how to create a label style for labeling the grade of a tangent with a rise/run ratio instead of a percentage value.

**To convert a percent to a ratio**

1. From the Sheet Manager menu, choose Sheet Styles ➤ Text Label to display the Select Style dialog box.
2. Type the name of the new style, FG Centerline - Vertical Tangent Grade, in the Style Name edit box.
3. Click the Edit button.
4. Use the Text Label Properties dialog box to specify the text properties.
5. Under Text Label Format, click the Edit button to display the Edit Text Format dialog box.
6. Under Text Format Data, set the Code Category to FG Center Line and the Code to V Tangent Grade.
7. Click the Apply Code to Formula button. This command places the numeric code, [116|1262], into the Formula edit box in the Formula Data section of the dialog box.

The FG Centerline|Vertical Tangent Grade appears in the Formula edit box as [116|1262]. To convert the percentage grade value to a rise/run ratio, you need to divide one-hundred (100) by the grade.

8. Type 100 and / (forward slash) in front of the text string and click the Add button. The formula appears in the Text/Code/Formula Format Order list box as 100/[FG Center Line|V Tangent Grade].

**NOTE** To display the absolute value of the vertical tangent grade, enclose the formula in parentheses () and apply the ABS function to the formula so that it appears as ABS(100/[116|1262]).

Next, you add a text string that describes the ratio.

9. In the Text edit box, type 1 in followed by a space.
10. Click the Add button. The text string 1 in appears in the Text/Code/Formula Format Order list box.
11 Modify the order of the items in the list box by clicking the <Move Left and >Move Right buttons so that the Preview Formatted Text area appears as follows: 1 in 1.00. A preview value of 100 is used for the code value when using formulas. This is based on the default imperial settings with two-decimal precision.
12 Click OK to save the Text Format.

Creating a Block Label Style

A block is a symbol or a group of objects that you can group as a single object and insert into a drawing. If you have a standard symbol or other annotation piece that you want to insert onto sheets, such as a PVI symbol, then you can use the Block Label command.

Blocks are placed on the sheet in paper space. The name of the block style can have a maximum length of 256 characters, and the block style definition is stored in the Bksty.dbf file that can be accessed by more than one defined sheet style. The actual AutoCAD block definition needs to be in the AutoCAD search path.

To define a Block Label Style

1 Set the block search path.
2 From the Sheet Manager menu, choose Sheet Styles ➤ Block Label to display the Select Style dialog box.

3 Do one of the following:
   ■ Define a new style by typing the name of the block style in the Style Name edit box.
   The block style name can have a maximum length of 256 characters.
   ■ Edit an existing style by selecting it from the Style List.
4. Click the Edit button to display the Block Style Properties dialog box.

![Block Style Properties dialog box]

To specify which design elements are labeled, you must set a Code Category and a Code.

5. Select the Code Category first, because it determines which code options are available. For more information, see “Example: Code Category” in this chapter.

6. Choose the Code.

**NOTE** The code is used for placing the blocks. For example, to insert a symbol on the profile at the beginning of a vertical curves, select FG Center Line as the Code Category, and select VC BVC Sta as the Code.

7. Under Block Entity Data, specify the following information:

- **Block Name and Location**: To choose the block to insert, you can type the block name in the Name edit box, or you can click the Block File button, and then choose the block from the Select Block File dialog box. This location defaults to the block search path set with the Settings command.

When you generate sheets using block styles, Sheet Manager looks for blocks in the following order:

- The blocks defined in the current drawing
- The path selected by the Block File button
- The style database path
- The block search path set with the Settings command

**NOTE** You can use blocks with attributes. However, to facilitate the automated generation of sheets, blocks are inserted with their default attribute value. You won’t be prompted for the attributes of each block as it is inserted.

- **Scale**: Use the Scale edit box to specify at what scale the symbol is placed into the frame. While determining the scale, keep in mind that the symbol is placed in paper space.
Rotation Angle: Use the Rotation Angle edit box to specify at what rotation angle the symbol is placed into the frame. This is the same rotation angle that is used by AutoCAD for block insertion. These rules vary, however, if you are using Design Aligned or Design Aligned Incremental as the frame placement options. For these two frame placement options, 0deg aligns the block that is being placed with the entity, and 90 or 270 degrees places the symbol at a perpendicular orientation.

Layer: Use the Layer edit box to specify the layer the symbol is placed on. Type the layer name or click the Select button to access the list of layers from which to choose.

Click OK to return to the Select Style dialog box.

Creating a Distance Label Style

To label dimensions on your sheets, use the Distance Label command to format distance label styles. A distance style is composed of the following elements:

- A Code Category and Code that specify what is being dimensioned
- A Text Label that specifies the entity information that is placed on the dimension
- The AutoCAD dimension style and layer

The following illustration shows an example of a vertical curve length labeled with a Distance Label:

![Vertical curve length with distance label]

As with all of the label and grid styles, distance labels are placed on the sheet in paper space. The style definition is stored in a database file that can be accessed by more than one defined sheet style. This database file is either stored in the *.sdb file or the *.dbf file.

NOTE Once .sbd and .dbf files are created using AutoCAD Land Development Desktop Release 2, they cannot be used with an earlier version of the Desktop.
To create a Distance Label Style

1. From the Sheet Manager menu, choose Sheet Styles ➤ Distance Label to display the Select Style dialog box.

2. Do one of the following:
   - Define a new style by typing the name of the distance style in the Style Name edit box. The distance style name can have a maximum length of 256 characters. For more information, see “Choosing a Text Label for a Distance Style” in this chapter.
   - Edit an existing style by selecting it from the Style List.
3 Click the Edit button to display the Distance Style Properties dialog box.

4 Select the Code Category first because it determines which code options are available. For more information, see “Example: Code Category” in this chapter.

5 Select the Code.

To dimension the length of an entity, you can select code that affects the placement of the label. For example, to label the vertical curve length with the Code Category set to FG Center Line, select any of the vertical curve codes. The vertical curve codes all begin with VC, such as VC PVI Sta. To label the finished ground centerline tangent with a dimension, select any of the V Tangent codes.

**NOTE**

Some of the available codes do not apply to distance styles. Options such as Station, Elevation or Grade Break cannot be dimensioned.

6 Under Distance Entity Data, specify the following:

- **Distance Dimension Style**: Dimension Styles are used in AutoCAD for saving specific dimension variable settings to a named style. Dimension style variables include the size of dimension components, such as arrow heads, the scale factor for the dimension, and the text style and size. You can use the DIMSTYLE and DDIM commands to create and edit dimension styles. Using named dimension styles, you can establish and enforce drafting standards for drawings.

**NOTE**
The dimension style that is created may not be available in the current working drawing (dimstyles are stored in the drawing file). However, the Bonus tools offer a solution to export a distance dimension style.
Layer: Set the layer for the dimension label. Type the name of the layer in the Layer box or access a list of the defined drawing layers by clicking the Select button next to the layer edit box.

7 Under Text Label, click Select to display the Select Style dialog box. Use this dialog box to select the label style that is used to label the distance. You can choose an existing style that you created earlier, or you can create a new style. For more information, see “Choosing a Text Label for a Distance Style.”

8 Click OK through the succession of dialog boxes to exit the command and save the distance label, or Cancel to exit the command without saving.

The following illustration is an example of a distance label:

**Example: Distance Label Style**
The following illustration shows a distance label style:

![Distance label style illustration]

To create the distance label style shown in the preceding illustration

1 From the Sheet Manager menu, choose Sheet Styles ➤ Distance Label to display the Select Style dialog box.

2 In the Style Name box, enter a name for your distance label. For example, enter Profile: Vertical Curve Distance in order to remember that you are creating a distance label for a vertical curve that will appear in the Profile View Frame. For more information, see “Choosing a Text Label for a Distance Style” in this chapter.
3 Click Edit to display the Distance Style Properties dialog box.

4 Set the Code Category to FG Center Line. The data is retrieved from the Finish Ground Profile.

5 Set the Code to VC BVC Sta. The label begins at the vertical curve, beginning vertical curve station.

6 From your drawing, select an available dimension style. If the style does not exist, you can either create the style or use the AutoCAD bonus menu to import the style from another drawing.

7 Select or enter a layer name.

8 Click Select to display the Select Style dialog box.

9 Create a style name, and then click Edit. The style name is then displayed for text within the distance label. For example, enter a name such as Profile: VC (PVI Sta, Elev, Length, Sag, Crest) to signify a text label for a Vertical Curve that will contain the PVI Station, Elevation, Curve Length, Sag and Crest data.

   The Text Label Properties dialog box is displayed.

10 Set the text style parameters, and then click Edit to display the Edit Text Format dialog box.

11 Set the Code Category to FG Center Line. The text labels Finish Ground Profile data.

12 In the Text Data box, enter \[VC PVI Sta=\]. The \{ and \} brackets denote the start and end of an item.

   NOTE You can only use one Code Category (FG Center Line, in this case) for each text label.
Creating a Distance Label Style

13 Under the Text Data frame, click Add. The text is placed in the Text/Code/Formula Format Order list box.

14 From the Codes list, select VC PVI Sta, and then click Add Code to Text Format.

The data is added to the Text/Code/Formula Format Order list box.

15 In the Text Data box, enter \P{VC PVI Elev=}, and click Add. The \P denotes a carriage return.

16 From the Codes list, select VC PCI Elev, and then click Add Code to Text Format.

17 In the Text Data list, enter \P{L=}, and then click Add.

18 From the Codes list, select VC Length, and then click Add Code to Text Format.

19 In the Text Data box, enter \P{K=}, and then click Add.

20 From the Codes list, select VC K, and then click Add Code to Text Format.

21 In the Text Data box, enter \P{AD=}, and then click Add.

22 From the Codes list, select VC A.D., and then click Add Code to Text Format.

23 In the Text Data box, enter %\P{Sag/Crest Sta. =}, and then click Add.

24 From the Codes list, select VC High Low Sta, and then click Add Code to Text Format.

25 In the Text Data box, enter \P{Sag/Crest Elev.=} , and then click Add.

26 From the Codes list, select VC High Low Elev, and then click Add Code to Text Format.

27 In the Text Data box, enter }, and then click Add. A preview is displayed in the Preview Formatted Text frame.

28 To exit the dialog boxes, click OK in the Edit Text Format, Text Label Properties, Select Style, Dimension Style Properties, and Select Style (for dimension style) dialog boxes.

To see an example of how to apply this distance label style to a sheet, see “Example: Apply a Distance Label Style to a Sheet” in this chapter.

Example: Applying a Distance Label Style to a Sheet

To apply a distance label style to a sheet

1 Load the sheet style.

2 Edit the Profile View frame.

3 In the Edit Frame Data dialog box, select Distance to display the Edit Attached Distance Labels dialog box.

4 Click Add to display the Select Style dialog box.

5 Select the Style name created in the topic “Example: Distance Label Style” in this chapter. Click OK to display the Edit Attached Distance Labels dialog box.

6 Set the Design Data Point to FG Center Line|VC BVC Sta. This is the point where the label begins.

7 Set the Label Location to Design, and then click OK.

8 In the Edit Frame Data dialog box, click OK.

9 Save your sheet style.

The distance label style is attached to your sheet. When you generate sheets with this style, the Finish Ground Vertical Curve dimension label is included where appropriate.
Choosing a Text Label for a Distance Style

For distance labels, you must create a Text Label style that is formatted to label some kind of measurable distance. For example, if you are formatting a Distance Label style to dimension vertical curves, you create a Text Label style that is formatted to label vertical curve information, such as Length, K value, and the algebraic difference of the grades, such as |grade in and grade out|.

The following example shows a typical distance label:

![Distance label]

If you select a Text Label style that is composed of information that is not related to the Distance Style Code Category and Code, then the values do not appear when you attach this label to a frame and generate the sheet. An instance of this would be if you selected a tangent Text Label style when you are formatting a vertical curve Distance Label style.

Exporting a Distance Dimension Style

Using the Bonus tools, you can export a distance dimension style.

To export a dimension style

1 Install the AutoCAD Map Express Tools from the Land Development Desktop install (these are available as an option if you add additional components or if you do a custom install).
2 Open the drawing that contains the dimension style that you want to export.
3 From the AutoCAD Map 2000 menu palette, choose Express ➤ Dimension ➤ Dimstyle Export to display the Dimension Style Export dialog box.
4 Select Browse to browse to a location for the dimension style. You may rename the file (the default is <drawing name>.dim), but should retain the suffix of *.dim.
5 Select the dimension style that you want to export.
6 Click Full Text Style Information, and then click OK.
7 To import this dimension style, open the drawing that currently does not contain this dimension style and choose Express ➤ Dimension ➤ Dimstyle Import from the AutoCAD Map 2000 menu palette.

8 Browse to the file that was created in step 4, and then click OK.

**Creating a Grid Style**

You can place grids on sheets by using Grid Styles. You can use grids with profiles or with sections. A section sheet can have one grid for the entire sheet or a grid for each section. If you do not want the grid to completely cover the label, use the Draw Line Marker option from the Edit Attached Text Labels dialog box.

The following illustration shows a grid on a profile-only sheet:

Grid on a profile-only sheet

You can also use a Grid Style to create incremental lines for label frames. For example, you could use a Grid Style with one vertical line that plots at a 50' spacing with a profile label frame, and attach text styles for labeling stations or elevations.
In the following illustration, there are three labels in the bottom Profile-Label frame. The label on the left of the vertical line is the Finish Ground text label. The label on the right of the vertical line is the Existing Ground text label and the vertical line is the grid label. The text labels use the horizontal offset to avoid text and grid interference, as shown:

<table>
<thead>
<tr>
<th></th>
<th>0+050</th>
<th>0+100</th>
<th>0+150</th>
<th>0+200</th>
</tr>
</thead>
<tbody>
<tr>
<td>259.57</td>
<td>278.76</td>
<td>277.76</td>
<td>276.76</td>
<td>275.76</td>
</tr>
<tr>
<td>265.45</td>
<td>264.54</td>
<td>263.90</td>
<td>262.98</td>
<td></td>
</tr>
</tbody>
</table>

Profile grid style

Grids are placed on the sheet in paper space. The style definition is stored in a database file that can be accessed by more than one defined sheet style.

NOTE

To use the Snap to Grid option in the Cross Section Preferences dialog box, a grid style must be defined.
To create a grid style

1 From the Sheet Manager menu, choose Sheet Styles ➤ Grid Style to display the Select Style dialog box.

2 Do one of the following:
   - Define a new style by typing the name of the grid style in the Style Name edit box. The grid style name can have a maximum length of 256 characters.
   - Edit an existing style by selecting it from the Style List.

3 Click Edit to display the Edit Grid Style dialog box.

The Grid Style name is listed on top.
4 Under Add/Edit Grid Lines, you can define how the grid appears by using the following options:

- **Horizontal**: Select this option to define a horizontal grid line.
- **Vertical**: Select this option to define a vertical grid line.
- **Spacing**: Use this edit box to select the spacing between grid lines.

Enter the spacing and line width values in paper space units. For example, if you want the grid spacing to be every 25 meters in a 1:500 drawing, the grid spacing should be 0.05 units. For a 50' spacing in a 1 = 40' drawing, the spacing would be 1.25 units. The determining factor is the Viewport Scale, not the drawing scale.

If you have a viewport scale of 1 paper space unit = 40 model space units, it requires 1.25 inches (or paper space units) to show 50 feet (50/40 = 1.25). If you want to place a vertical grid line every 100 feet, then set your grid spacing to 2.5 (100/40).

The vertical values (for profile elevations, for example) use 1/10 of the viewport scale. The same 1 paper space unit = 40 model space units requires 1 inch (or paper space unit) to show 4 feet (4/4). Therefore, if you want horizontal lines that display every 2 feet of elevation in the profile, create a horizontal grid with a spacing of 0.5 (2/4).

You can add additional grid lines with different spacing. For example, you could create both horizontal and vertical grid lines for 25m spacing then add another set for 5m spacing.

- **LineWidth**: The Line Width determines the thickness of the LWPOLYLINE created for each grid line. Type a line width in this edit box if you want to create the grid line with a given width in paper space units. All grids are created as LWPOLYLINES. The default of 0 still creates an LWPOLYLINE. For a complete description of polyline widths refer to AutoCAD 2000 online Help.
- **Layer**: Type the layer name for the grid lines in this edit box. You can also access a list of layers to choose from by clicking the Select button.

5 Click the Add button to place the grid line information into the Grid Lines list box.

6 To edit an existing grid line, select its name from the Grid Lines list box, make the changes in the edit boxes above, and then click the Change button.

**NOTE** You can delete an existing grid line definition by selecting its name and clicking the Delete button.

7 Click OK to save the Grid Style, or Cancel to exit the command.

To include the grid as part of a sheet style, attach the grid to the frame, and then save the sheet style.
Positioning Labels

Attaching Label and Grid Styles to a Frame

To attach a label or grid style to a frame

1. From the Sheet Manager menu, choose Sheet Styles ➤ Create/Edit Frame.
2. Select an existing frame or press ENTER to create a new frame. The Edit Frame Data dialog box is displayed.

![Edit Frame Data dialog box](image)

<table>
<thead>
<tr>
<th>Frame Properties</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Layer: PSPLAN_FR</td>
<td>Width: 33.000</td>
<td>Origin: 1.33.12.52</td>
</tr>
<tr>
<td>Linewidth: 0.000</td>
<td>Height: 9.7500</td>
<td></td>
</tr>
</tbody>
</table>

**NOTE**

Remember to verify that the correct frame Type and Category are set, such as Plan/View or Profile/Label.

3. Under Attached Labels, click one of the following four buttons to attach a label to the frame:
   - Click Text to attach a Text Label.
   - Click Block to attach a Block Label.
   - Click Distance to attach a Distance Label.
   - Click Grid to attach a Grid Style.
The appropriate Edit Attached Labels dialog box is displayed.

4 Under Design Data Point, choose the following options:
   If you accidentally set this to FG Center Line|VC High Low Sta, you do not receive any results.

5 Set the Design Data Point to FG Center Line|VC BVC Sta because this is what a Distance Label is intended to use as a design data point.
   To attach a label or grid, click the Add button.
   The Select Style dialog box is displayed. You can use this dialog box to either attach styles you have already defined with the Text Label, Grid Style, Distance Label or Block Label command, or you can use this dialog box to create new styles. The following description assumes that you are attaching an existing style. For more information about creating styles, see “Creating Labels and Grids” in this chapter.

6 Select the style to add, and then click OK. Repeat this process for each style you want to add.

7 Set the label placement data.

   NOTE Grid styles do not require you to specify label placement options.
Deleting a Label or Grid Style That is Attached to a Frame

You can delete label and grid styles from frames by using the Create/Edit Frame command.

To delete a label or grid style from a frame

1. From the Sheet Manager menu, choose Sheet Styles ➤ Create/Edit Frame.
2. Select an existing frame from which you want to delete the label or grid style. The Edit Frame Data dialog box is displayed.

   **NOTE** Remember to verify that the correct frame Type and Category are set, such as Plan/View or Profile/Label.

3. Under Attached Labels, click one of the following four buttons, depending on the style you want to delete:
   - Click Text to delete a text label.
   - Click Block to delete a block label.
   - Click Distance to delete a distance label.
   - Click Grid to delete a grid style.

   The Edit Attached Styles dialog box is displayed.

4. From the Currently Attached list, select the style name to delete, and then click Delete. When you delete a style from the Currently Attached list, the style is not permanently deleted from the style database. It is detached from the frame.
Controlling the Label Placement

This section is a continuation of “Attaching Label and Grid Styles to a Frame” in this chapter.

This section describes how to use the Label Placement Data section of the Edit Attached Styles dialog box to control the placement of the labels in relation to frames and to the viewports.

**NOTE** Grid styles do not require you to specify label placement options.

To control the label placement

1. Select a Design Data Point.
2. From the Label Location list, select a location for the label to position the label within a frame. You can choose among the following label location options:
   - **Intersection**: For more information, see “Example: Intersection” in this chapter.
   - **Incremental**: For more information, see “Example: Incremental” in this chapter.
   - **Design**: For more information, see “Example: Design” in this chapter.
   - **Design aligned**: For more information, see “Example: Design Aligned” in this chapter.
   - **Design incremental**: For more information, see “Example: Design Incremental” in this chapter.
   - **Fixed**: For more information, see “Example: Fixed” in this chapter.
3. If you chose Incremental, Fixed, or Intersection as the Label Location, select the Frame Justification.
4. If you chose Incremental or Design Incremental as the Label Location, specify an increment value in the Label Increment edit box.
   This value is the labeling increment between labels based on the Design Data Point. If you want stations labeled every 25.00 feet, then you should set the Design Data Point to Station, and specify 25.00 as the increment. If you are labeling an alignment and choose Incremental (for a profile view frame), you may choose 50 to label every 50’ station (not 50 feet apart in paper space). In the plan view, you may choose design incremental and use the same 50 to label every 50’ station along the alignment.
5. Select the Draw Line Marker check box to draw a line from the label style location in the frame to the design point you’re labeling.
6. Use the Horizontal and Vertical offset edit boxes to control where the labels are placed in relation to the calculated insertion point.
7. Click the Add button to add any additional styles.
8. Click OK.
9. Save the sheet style.
Choosing a Design Data Point
This section is a continuation of the topic “Controlling the Label Placement” in this chapter.

The Design Data Point works in conjunction with the Label Location to determine where the label is placed on the drawing. If you choose a Label Location that is based on increments, then the Design Data Point also determines what the increment value is related to, such as a station increment or elevation increment. For example, you may set the Design Data Point to station if you intend to label information at stations along an alignment.

The following illustration shows the Design Data Point scroll list under the Label Placement Data section of the Edit Attached Text Labels dialog box:

The options that appear in this list are determined by the Code Category and Code that you set for the style. For example, with a style that labels existing ground profile elevations there are three Design Data Point options:

- **Station**: Places elevations at a station increment; for example, every 50' along the profile.
- **Elevation**: Places the elevations at an elevation increment; for example, to place labels along the profile wherever an even 0.25' occurs.
- **Grade Break**: Places elevations along the profile where the existing ground grade breaks occur.

The Design Data Point option that you specify is not necessarily the information that is being labeled. For example, you would set the Design Data Point to Station in order to label an existing ground profile elevation at a station increment, but the label contains elevation information.
**Example: Intersection**

The Intersection Label Location option positions the label in the frame based on the Design Data Point's intersection with the frame. If you were to draw a line from the design point you are labeling, perpendicular to the frame, the line would intersect the frame at the intersection label location.

In the following example of the Intersection setting, the beginning of the vertical curve is the Design Data Point. The label is placed in the frame at the location where this point intersects with the frame beneath the viewport, as shown:

![Intersection setting](image)

For a horizontal label frame that is positioned below the viewport, the label is placed on the frame directly below the design point. For a vertical label frame that is positioned on the side of the viewport, the label is placed on the frame directly across from the design point.

You cannot use the Intersection option with all types of styles. Use this option for styles that have an exact location on the design such as the beginning or end of horizontal and vertical entities or section point codes.

The Design Data Point option you selected also determines which Label Locations should be used. For example, with an existing ground profile elevation style, if the Design Data Point option is set to Station, then you would need to use one of the incremental options. However, if the Design Data Point is set to Grade Break, then you would want to use the Intersection option.
The Edit Attached Text Labels dialog box shows the FG Center Line|VC BVC Sta is selected under Design Data Point. The Label Location is set at Intersection, as shown:
The Intersection setting labels the station for the beginning of the vertical curve in a profile label frame. In the following illustration, the label of the beginning vertical curve station is located within a circle:

![Intersection setting](image)

**Example: Incremental**

The Incremental Label Location option places the labels at specified increments, which you enter in the Label Increment edit box.

The following illustration shows an example of the Incremental setting:

![Incremental setting](image)

The incremental option only works with certain types of styles, based on the style Code and the Design Data Point option. For example, a style for Alignment/Station with Design Data Point set to Station would be set at an increment.
An incremental placement would not be used with a style that has a Code with a fixed position, such as Alignment/Tangent TC Sta.

How the incremental value is applied is based on the Design Data Point option. For example, for a style that labels existing ground profile elevations, there are three Design Data Point options: by Station, Elevation or Grade Break. For more information about the Design Data Point option, see “Choosing a Design Data Point” in this chapter.

NOTE The incremental option is typically used to place labels in a Label frame, such as at the bottom of a profile to label stations. To place labels in a View frame at an increment, such as a plan view frame to label stations along an alignment, use the Design Incremental option.

The following illustration shows the Edit Attached Text Labels dialog box. The Design Data Point is set at Profile|Elevation and the Label Location is set at Incremental, as shown:
The Incremental setting labels the elevations in 2' increments in a Vertical Profile Label Frame, as shown in the following illustration:

![Vertical profile label frame setting](image)

**Example: Design**

The Design Label Placement option positions the label at the location of the design point selected with the Design Data Point option.

The following illustration is an example of the Design setting:

![Design setting](image)

For example, to place a block style symbol on the profile at the beginning of a vertical curve, you would set the Label Location option to Design, and set the
Design Data Point to VC/BVC Sta. In another example, if you create a Text Label to label a curve radius, you can use Design location as the placement factor, and the label is placed on the curve radius.

You can set offset values from the design location with the Horizontal label offset and Vertical label offset edit boxes. You can use these offsets with any Design Data Point and Label location.

**NOTE** The Design placement option only works with frames that have been set to a View type.

The following illustration shows the Edit Attached Distance Labels dialog box. The Design Data Point is set at FG CenterLine|VC BVC Sta and the Label Location is set at Design, as shown:
The Design setting labels vertical curve information in a Profile View Frame. In the following illustration, the distance label has been given a design data point of the beginning of the vertical curve:

![Design data point at beginning of vertical curve](image)

**Example: Design Aligned**

The Design Aligned Label Placement option is similar to the Design placement option, except that the label is rotated so that it is aligned with the entity that it is being placed on before the style rotation is applied.

The following illustration is an example of the Design Aligned setting:

![Design aligned setting](image)

A style using the Design Aligned Label Placement option that has a rotation of 0 degrees is aligned with the entity. A style using the Design Aligned Label Placement option that has a rotation of 90 or 270 degrees is perpendicular to the entity.

**NOTE** The Design Aligned placement option only works with frames that have been set to a View type.

In the Edit Attached Text Labels dialog box, the Design Data Point is set at FG CenterLine\(\text{V Tangent Center Sta}\) and the Label Location is set at Design Aligned, as shown:
The Design Aligned setting labels the Finish Ground Centerline slope in the Profile View Frame, as shown in the following illustration:

Finish ground centerline slope in profile view frame
**Example: Design Incremental**

The Design Incremental Label Placement option places labels at an increment along the design object.

The following illustration is an example of the Design Incremental setting:

![Design incremental setting](image)

Design incremental setting

Specify the increment for the label in the Label Increment edit box. In plan view, a label with a 0 degree rotation is aligned with the entity if no additional rotation angle is specified for the label style. In profile view and on cross sections, the label is placed horizontally with a 0 degree rotation if no additional rotation angle is specified for the label style.

**NOTE**
The Design Incremental placement option only works with frames that have been set to a View type.
In the following Edit Attached Text Labels dialog box, the Design Data Point is set at Alignment|Station and the Label Location is set at Design Incremental, as shown:
The Design Incremental setting labels the station along the alignment at 50' increments in the Plan View Frame, as shown:

Alignment stationing
**Example: Fixed**

The Fixed Label Location option places the label at a fixed location specified on the frame. For example, use this option to insert a north arrow Block Label or the title block information. Use the Horizontal and Vertical offset edit boxes to specify the position based on offsets. Offset values are measured from the label insertion point.

In the following Edit Attached Text Labels dialog box, the text label type is fixed and there is no Design Data Point:
The Fixed setting labels the project name in a Plan Label Frame, as shown:

```
+-------------------+
|                   |
+-------------------+
                      
PROJECT NAME: subdivision
DRAWING NAME: Plan
ALIGNMENT NAME: loop
SHEET SERIES NAME: fixed-pp
```

Project name in a plan label frame

**Choosing the Frame Justification**

Use the Frame Justification scroll list to set the label insertion point in relation to the frame.

The following illustration shows the Frame Justification scroll list in the Edit Attached Text Labels dialog box:

```
Frame Justification: Frame Middle
```

The Frame Justification settings control the placement of the label in the frame. The three locations available vary depending on whether the Draw Vertical check box was selected when you drew the frame:

- If the frame is drawn at a vertical orientation, then the three placement locations are Frame Left, Frame Middle, and Frame Right.
- For horizontal frames, the three options are Frame Top, Frame Middle, and Frame Bottom.

The following illustration shows the insertion points for each of these placement options:

```
LEFT  MIDDLE  RIGHT
VERTICAL FRAME

TOP  MIDDLE  BOTTOM
HORIZONTAL FRAME
```

Insertion points

The label style's insertion point starts with this location and is then adjusted for the horizontal and vertical offset values.
For Text Labels, it is important to know the label style justification and rotation values when selecting the Frame Justification. For instance, if you define a text style that is left justified, then the text's alignment point is at the lower left corner of that text entity. If you specify Frame Top for the frame vertical justification, then the text's alignment point is placed at the top of the frame.

Remember to take into account the angle of the text rotation you set with the Text Label command when you are setting the justification. If the text was defined as right justified and set at an angle of 270 degrees, then specifying Frame Top places the text outside the frame, since the alignment point at the right end of the text block corresponds to the top of the frame.

**Drawing a Line Marker**

Select the Draw Line Marker check box to draw a line from the item you are labeling to the label.

In the following illustration, a line is drawn from the top of the label frame (at the bottom of the profile), to each grade break:

![Line drawn to each grade break](image)

A typical example of using this feature would be with an existing ground profile elevation label that has been attached to a label frame below the profile. The most common usage is to show the station values or the elevation values at specific stations in a Label Frame box. Draw Line Marker inserts a line from the Frame Justification (A) to the apparent intersection of the Design Data Point (B) and the frame.

**Setting Horizontal and Vertical Offset Values**

You can use the Horizontal and Vertical offset boxes to specify offset values for the labels.

For example, if you insert a template point code elevation on a section at the design location, and set the text to middle left justified with a rotation of 90 degrees, the text starts exactly on the design point. However, by applying a small vertical offset, the text appears above the design point.
The following illustration shows point code elevation labels with an offset of 0 horizontal and 0 vertical:

![0 horizontal and vertical offsets](image1)

A positive horizontal offset value offsets to the right, and a negative horizontal offset value offsets to the left. A positive vertical offset value offsets up, and a negative vertical offset value offsets down. The offset values are in paper space (or plotted) units. For example, in imperial units, an offset of 0.10 is plotted as one tenth of an inch on a sheet of paper. For a metric drawing, the offset is in meters.

![0 horizontal and 0.1 vertical offsets](image2)
The Horizontal and Vertical offset values are in paper space units.

Updating Labels and Grids

In some situations you may need to edit the frame label styles after you have generated a sheet. Instead of regenerating the sheet series to update the frames, you can use the Update Frame Labels command, the Update All Frame Labels command, or the Create/Edit Frame command to update the attached frame labels.

You should keep in mind that these commands only update the current sheet. To update the entire sheet series, you’ll need to save the sheet style with the changes you have made and regenerate the sheet series with the Generate Sheets - Series commands. For example, a grid inside a Section View Frame cannot be updated using any of these methods.

Updating Frame Labels With the Update Frame Labels Command

If you generate a sheet and, for example, the text style you chose was too small, then you can edit the text style and use the Update Frame Labels command to update the change. You can also use this command to add new styles to a generated sheet. This command updates the label and grid styles of all selected frames in the current drawing.

To update the frame labels with the Update Frame Labels command

1. From the Sheet Manager menu, choose Sheet Styles ➤ Update Frame Labels.
2. Pick the frames you want to update, and then press ENTER at the subsequent Select objects prompt.

The command updates the frame information.

Updating Frame Labels With the Update All Frame Labels Command

The Update All Frame Labels command updates the labels on all the frames on the visible sheet.

To update the frame labels with the Update All Frame Labels command

- From the Sheet Manager menu, choose Sheet Tools ➤ Update All Frame Labels.

The command updates all the labeling information attached to the frames.

Updating Frame Labels With the Create/Edit Frame Command

While making edits to the frame or the attachments with the Create/Edit Frame command, you can click the Draw Frame Contents button to update the frame.
To update the frame labels with the Create/Edit Frame command

1. From the Sheet Manager menu, choose Sheet Styles ➤ Create/Edit Frame.
2. Pick the frame you want to edit and press ENTER.
3. Use the Edit Frame Data dialog box to make any necessary edits to the attached styles. Click the Attached Styles button to display the Edit Attached Styles dialog box and edit the attached styles as needed.
4. Click the Draw Frame Contents button in the Edit Frame Data dialog box, and the command updates the frame information.

Editing a Label or Grid by Selecting It from Screen

After you generate a sheet series, you may need to edit some of the labels or grids on the sheet. Using the Pick Edit command, you can use your pointing device pickbox to select the label or grid that you want to edit.

To graphically select a label or grid to edit

1. From the Sheet Manager menu, choose Sheet Styles ➤ Pick Edit.
2. Select a style entity, such as a Text Label on one of the generated sheets, and then press ENTER.
   The Select Style dialog box is displayed, highlighting the style name you selected.
3. Click Edit to access the style editing features.
4. Make the necessary edits, and then click OK through the succession of dialog boxes.
   The command prompts for more style entities to edit.
5. Select another style to edit, or press ENTER to exit the command.

NOTE: Edits that you make to label or grid styles are saved to the database and affect any new sheets that are generated or any frames that are updated.

For information about how to update the sheets with the changes you have made to the styles, see “Updating the Labels and Grids” in this chapter.

Importing and Exporting Label and Grid Styles

Importing Label and Grid Styles from Another Database

The Text, Block, Distance and Grid Styles are stored in external database files. The files are stored in the Style Database folder along with the saved sheet styles. To import defined label or grid styles from another style database into the current database, use the Import Styles command.
To import styles

1. From the Sheet Manager menu, choose Sheet Styles ➤ Import Styles to display the Select Import Database Path dialog box. Use this dialog box to select the location of the label and grid styles that you want to import.
2. Select the correct drive and folder with the popup lists, and then click OK. The Select Style Type dialog box is displayed.

3. Click the button for the type of label or grid style you want to import. For example, click Block, to display the list of Block style components.
4. From the list of styles, select the style, and then click OK. If a style with the same name already exists, then you are prompted to overwrite the style definition.

Exporting Label and Grid Styles to Another Database

The Text, Block, Distance and Grid Styles are stored in external database files. The files are stored in the Style Database folder along with the saved Sheet Styles. To export defined styles from the current style database into another style database, use the Export Styles command.

To export styles

1. From the Sheet Manager menu, choose Sheet Styles ➤ Export Styles to display the Select Export Database Path dialog box.
   Use the Select Export Database Path dialog box to select the folder you want to export the style to.
2. Select the drive and folder, and then click OK to display the Select Style Type dialog box.
3. Select the button for the type of style you want to export. For example, click Grid to display the list of Grid style components.
4. From the list of styles, select the style to export, and then click OK.
Attaching Label and Grid Sheets to a Frame

Selecting Sheet Style Frames or Viewports

In a sheet style that has border lines, viewports, and frames, it is common to have multiple entities on top of one another. For example, one side of a label frame may be co-linear with one side of a viewport. When trying to select a viewport or a frame in this situation, it is not always possible to select the correct entity with the pickbox. In these cases, use AutoCAD Crossing or Window selection options.

Commands that prompt you to select a frame or a viewport filter out invalid selections. For example, if you are trying to select a frame and you use a Crossing selection and you select both a frame and a viewport, the viewport is filtered out.

If all edges of a frame that you want to select are bounded by other frames, then a window selection works better. For example, a profile view frame may have label frames on all sides. If you use the Window option and define a window region around the frame, without including any other frames within the window, then you select the correct frame.

The following illustration shows how to draw the selection window around the view frame:

If you are not sure that you have selected the correct frame, then check the frame attachments and the frame category to verify that you are working with the correct one.
**Updating Grids When Drawing Labels**

If you have a grid attached to a frame, then you can update the grid when the labels are updated by selecting the Draw Grid on Label Draw check box.

**To update grids when drawing labels**

1. From the Sheet Manager menu, choose Settings to display the Settings dialog box.
2. Under Style and Label Options, select the Draw Grid on Label Draw check box. If you clear this check box, then the grid is drawn when you generate a sheet and when you click the Draw Frame Contents button in the Create/Edit Frame command. However, the grid is not redrawn when you select the Sheet Styles Update Frame Labels or the Sheet Tools Update All Frame Labels commands.
3. Click OK to exit the Settings dialog box.

**Categories and Codes for Creating Labels**

**Categories and Codes for Text, Block, and Distance Labels**

When you are formatting Text Label, Distance Label, or Block Label styles for use with the Sheet Manager, you need to specify which items of your drawing you want to label by specifying a Code Category and a Code. The following tables list all possible categories and codes that you can use when formatting these labels.

The heading of each table lists the Code Category, followed by all the possible Codes available for that category.

<table>
<thead>
<tr>
<th>Code Category: Alignment</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Station</td>
<td>labels the station at an increment</td>
</tr>
<tr>
<td>Match Line</td>
<td>labels the sheet match line point</td>
</tr>
<tr>
<td>Equation Station</td>
<td>labels the station equations</td>
</tr>
<tr>
<td>Equation Sta Back</td>
<td>labels the station equation back</td>
</tr>
<tr>
<td>Equation Sta Ahead</td>
<td>labels the station equation ahead</td>
</tr>
<tr>
<td>Curve PC Sta</td>
<td>labels the station of the beginning of curve point</td>
</tr>
<tr>
<td>Curve Center Sta</td>
<td>labels the station of the curve center</td>
</tr>
<tr>
<td>Curve PT Sta</td>
<td>labels the station of the end of curve point</td>
</tr>
<tr>
<td>Curve Incremental Sta</td>
<td>labels the stations on the curve at an increment</td>
</tr>
<tr>
<td>Code</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>Curve Radius</td>
<td>labels the curve radius</td>
</tr>
<tr>
<td>Curve Length</td>
<td>labels the curve length</td>
</tr>
<tr>
<td>Curve Delta</td>
<td>labels the curve delta angle</td>
</tr>
<tr>
<td>Curve Chord Length</td>
<td>labels the curve chord length</td>
</tr>
<tr>
<td>Curve Start Angle</td>
<td>labels the curve start angle</td>
</tr>
<tr>
<td>Curve End Angle</td>
<td>labels the curve end angle</td>
</tr>
<tr>
<td>Tangent Start Sta</td>
<td>labels the tangent start station</td>
</tr>
<tr>
<td>Tangent Center Sta</td>
<td>labels the tangent center station</td>
</tr>
<tr>
<td>Tangent End Sta</td>
<td>labels the tangent end station</td>
</tr>
<tr>
<td>Tangent Incremental Sta</td>
<td>labels the stations on the tangent at an increment</td>
</tr>
<tr>
<td>Tangent Length</td>
<td>labels the tangent length</td>
</tr>
<tr>
<td>Tangent Direction</td>
<td>labels the tangent direction</td>
</tr>
<tr>
<td>Spiral Start Sta</td>
<td>labels the station of the beginning of spiral point</td>
</tr>
<tr>
<td>Spiral Center Sta</td>
<td>labels the station of the spiral mid point</td>
</tr>
<tr>
<td>Spiral End Sta</td>
<td>labels the station of the spiral end point</td>
</tr>
<tr>
<td>Spiral Incremental Sta</td>
<td>labels the station on the spiral at an increment</td>
</tr>
<tr>
<td>Spiral Length</td>
<td>labels the length of the spiral</td>
</tr>
<tr>
<td>Spiral End Radius</td>
<td>labels the spiral end radius</td>
</tr>
<tr>
<td>Spiral Radial Distance</td>
<td>labels the spiral radial distance</td>
</tr>
<tr>
<td>Spiral Delta</td>
<td>labels the spiral delta</td>
</tr>
<tr>
<td>Spiral Total Y</td>
<td>labels the spiral Y value</td>
</tr>
<tr>
<td>Spiral Total X</td>
<td>labels the spiral X value</td>
</tr>
<tr>
<td>Spiral Short Tangent</td>
<td>labels the spiral short tangent</td>
</tr>
<tr>
<td>Spiral Long Tangent</td>
<td>labels the spiral long tangent</td>
</tr>
<tr>
<td>Spiral A</td>
<td>labels the spiral A factor</td>
</tr>
<tr>
<td>Spiral P</td>
<td>labels the spiral P value</td>
</tr>
<tr>
<td>Spiral K</td>
<td>labels the spiral K value</td>
</tr>
</tbody>
</table>
### Code Category: Profile

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elevation</td>
<td>labels the incremental profile elevation on vertical frames</td>
</tr>
</tbody>
</table>

### Code Category: Cross Section

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offset</td>
<td>labels the offset at an increment</td>
</tr>
<tr>
<td>Elevation</td>
<td>labels the elevation at an increment</td>
</tr>
<tr>
<td>Station</td>
<td>labels the station value of the section</td>
</tr>
<tr>
<td>Number</td>
<td>labels the cross section number</td>
</tr>
<tr>
<td>Cut Area</td>
<td>labels the cut area</td>
</tr>
<tr>
<td>Cut Centroid</td>
<td>labels the cut centroid</td>
</tr>
<tr>
<td>Fill Area</td>
<td>labels the fill area</td>
</tr>
<tr>
<td>Fill Centroid</td>
<td>labels the fill centroid</td>
</tr>
<tr>
<td>Cut Volume</td>
<td>labels the cut volume</td>
</tr>
<tr>
<td>Fill Volume</td>
<td>labels the fill volume</td>
</tr>
<tr>
<td>Cumulative Cut Volume</td>
<td>labels the cumulative cut volume</td>
</tr>
<tr>
<td>Cumulative Fill Volume</td>
<td>labels the cumulative fill volume</td>
</tr>
<tr>
<td>Left Right of Way</td>
<td>labels the Right of Way offset on the right side</td>
</tr>
<tr>
<td>Right Right of Way</td>
<td>labels the Right of Way offset on the right side</td>
</tr>
</tbody>
</table>

### Code Category: SuperElevation

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left Runout</td>
<td>labels the runout point on a left-hand curve</td>
</tr>
<tr>
<td>Left Runoff</td>
<td>labels the runoff point on a left-hand curve</td>
</tr>
<tr>
<td>Left Crown Removed</td>
<td>labels the full crown point on a left-hand curve</td>
</tr>
<tr>
<td>Left Full Super</td>
<td>labels the full super point for a left-hand curve</td>
</tr>
<tr>
<td>Right Runout</td>
<td>labels the runout point on a right-hand curve</td>
</tr>
<tr>
<td>Right Runoff</td>
<td>labels the runoff point on a right-hand curve</td>
</tr>
<tr>
<td>Right Crown Removed</td>
<td>labels the full crown point on a right-hand curve</td>
</tr>
</tbody>
</table>
### Code Category: SuperElevation (continued)

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right Full Super</td>
<td>labels the full super point for a right-hand curve</td>
</tr>
<tr>
<td>Flat Surface (RevCrv)</td>
<td>labels the reverse curve, flat crown (0%) point</td>
</tr>
</tbody>
</table>

### Code Category: EG Center, EG Left, EG Right

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Station</td>
<td>labels the eg profile station at an increment</td>
</tr>
<tr>
<td>Elevation</td>
<td>labels the eg elevation at an increment</td>
</tr>
</tbody>
</table>

### Code Category: EG Sub Center, EG Sub Left, EG Sub Right

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Station</td>
<td>labels the eg subsurf profile station at an increment</td>
</tr>
<tr>
<td>Elevation</td>
<td>labels the eg subsurf elevation at an increment</td>
</tr>
</tbody>
</table>

### Code Category: FG Center Line, FG Left 1 - 8, FG Right 1 - 8

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut (FG &lt; EG)</td>
<td>labels the elevational difference computed as fg elevation - eg elevation</td>
</tr>
<tr>
<td>Fill (Fg &gt; EG)</td>
<td>labels the elevational difference computed as eg elevation - fg elevation</td>
</tr>
<tr>
<td>Station</td>
<td>labels the fg profile station at an increment</td>
</tr>
<tr>
<td>Elevation</td>
<td>labels the fg elevation at an increment</td>
</tr>
<tr>
<td>VC PVI Sta</td>
<td>labels the vertical curve pvi station point</td>
</tr>
<tr>
<td>VC PVI Elev</td>
<td>labels the vertical curve pvi elevation point</td>
</tr>
<tr>
<td>VC BVC Sta</td>
<td>labels the beginning of vertical curve station point</td>
</tr>
<tr>
<td>VC BVC Elev</td>
<td>labels the beginning of vertical curve station point</td>
</tr>
<tr>
<td>VC EVC Sta</td>
<td>labels the end of vertical curve station point</td>
</tr>
<tr>
<td>VC EVC Elev</td>
<td>labels the end of vertical curve station point</td>
</tr>
<tr>
<td>VC High Low Sta</td>
<td>labels the vertical curve high/low station point</td>
</tr>
<tr>
<td>VC High Low Elev</td>
<td>labels the vertical curve high/low elevation point</td>
</tr>
</tbody>
</table>
### Code Category: FG Center Line, FG Left 1 - 8, FG Right 1 – 8 (continued)

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VC Incremental Sta</td>
<td>labels the vertical curve stations at an increment</td>
</tr>
<tr>
<td>VC Incremental Elev</td>
<td>labels the vertical curve elevations at an increment</td>
</tr>
<tr>
<td>VC Length</td>
<td>labels the vertical curve length</td>
</tr>
<tr>
<td>VC K</td>
<td>labels the vertical curve K value</td>
</tr>
<tr>
<td>VC A.D.</td>
<td>labels the vertical curve algebraic difference</td>
</tr>
<tr>
<td>VC Passing Sight Distance</td>
<td>labels the vertical curve passing sight distance</td>
</tr>
<tr>
<td>VC Stopping Sight Distance</td>
<td>labels the vertical curve stopping sight distance</td>
</tr>
<tr>
<td>V Tangent Start Sta</td>
<td>labels the station of the vertical tangent start point</td>
</tr>
<tr>
<td>V Tangent Center Sta</td>
<td>labels the station of the vertical tangent mid point</td>
</tr>
<tr>
<td>V Tangent End Sta</td>
<td>labels the station of the vertical tangent end point</td>
</tr>
<tr>
<td>V Tangent Incremental Sta</td>
<td>labels the vertical tangent stations at an increment</td>
</tr>
<tr>
<td>V Tangent Incremental Elev</td>
<td>labels the vertical tangent elevation at an increment</td>
</tr>
<tr>
<td>V Tangent Start Elev</td>
<td>labels the vertical tangent start point elevation</td>
</tr>
<tr>
<td>V Tangent End Elev</td>
<td>labels the vertical tangent end point elevation</td>
</tr>
<tr>
<td>V Tangent Grade</td>
<td>labels the vertical tangent grade in percentage</td>
</tr>
<tr>
<td>V Tangent Length</td>
<td>labels the horizontal length of the vertical tangent</td>
</tr>
</tbody>
</table>

### Code Category: FG Left Ditch, FG Right Ditch

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Station</td>
<td>labels the left or right ditch profile station at an increment</td>
</tr>
<tr>
<td>Elevation</td>
<td>labels the left or right ditch elevation at an increment</td>
</tr>
</tbody>
</table>

### Code Category: SDSK Data

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawing Path</td>
<td>labels the folder of the generated sheet</td>
</tr>
<tr>
<td>Drawing Name</td>
<td>labels the generated sheet drawing name</td>
</tr>
<tr>
<td>Horizontal Scale</td>
<td>labels the drawing setup horizontal scale</td>
</tr>
<tr>
<td>Vertical Scale</td>
<td>labels the drawing setup vertical scale</td>
</tr>
</tbody>
</table>
**Code Category: SDSK Data (continued)**

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sheet Number</td>
<td>labels the sheet number</td>
</tr>
<tr>
<td>Previous Sheet Number</td>
<td>labels the previous sheet number</td>
</tr>
<tr>
<td>Next Sheet Number</td>
<td>labels the next sheet number</td>
</tr>
<tr>
<td>Sheet Series Name</td>
<td>labels the define sheet series name</td>
</tr>
<tr>
<td>Sheet File Path</td>
<td>labels the sheet style database path</td>
</tr>
<tr>
<td>Sheet File Name</td>
<td>labels the sheet style name</td>
</tr>
<tr>
<td>Alignment Name</td>
<td>labels the current alignment name</td>
</tr>
<tr>
<td>Project Name</td>
<td>labels the current AEC project name</td>
</tr>
</tbody>
</table>

**Code Category: Pipe Run Data**

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node Sta</td>
<td>labels the pipeworks structure station</td>
</tr>
<tr>
<td>Node Rim Elev</td>
<td>labels the pipeworks structure rim elevation</td>
</tr>
<tr>
<td>Node Sump Elev</td>
<td>labels the pipeworks structure sump elevation</td>
</tr>
<tr>
<td>Node Label</td>
<td>labels the pipeworks structure name</td>
</tr>
<tr>
<td>Node Northing</td>
<td>labels the pipeworks structure northing value</td>
</tr>
<tr>
<td>Node Easting</td>
<td>labels the pipeworks structure easting value</td>
</tr>
<tr>
<td>Node Dimension</td>
<td>labels the pipeworks structure dimension</td>
</tr>
<tr>
<td>Node Offset</td>
<td>labels the pipeworks structure centerline offset</td>
</tr>
<tr>
<td>Node HGL In</td>
<td>labels the pipeworks hydraulic grade line elevation in</td>
</tr>
<tr>
<td>Node HGL Out</td>
<td>labels the pipeworks hydraulic grade line elevation out</td>
</tr>
<tr>
<td>Node EGL In</td>
<td>labels the pipeworks energy grade line elevation in</td>
</tr>
<tr>
<td>Node EGL Out</td>
<td>labels the pipeworks energy grade line elevation out</td>
</tr>
<tr>
<td>Node Invert In Elev</td>
<td>labels the pipeworks structure invert in elevation</td>
</tr>
<tr>
<td>Node Invert Out Elev</td>
<td>labels the pipeworks structure invert out elevation</td>
</tr>
<tr>
<td>Node Lateral 1 Label</td>
<td>labels the pipeworks structure first lateral name</td>
</tr>
<tr>
<td>Node Lateral 1 Inv Elev</td>
<td>labels the pipeworks structure first invert elevation</td>
</tr>
</tbody>
</table>
### Code Category: Pipe Run Data (continued)

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node Lateral 1 Flow</td>
<td>labels the pipeworks structure first lateral flow value</td>
</tr>
<tr>
<td>Node Lateral 2 Label</td>
<td>labels the pipeworks structure second lateral name</td>
</tr>
<tr>
<td>Node Lateral 2 Inv Elev</td>
<td>labels the pipeworks structure second invert elevation</td>
</tr>
<tr>
<td>Node Lateral 2 Flow</td>
<td>labels the pipeworks structure second lateral flow value</td>
</tr>
<tr>
<td>Node Rim to Sump Depth</td>
<td>labels the distance from rim elevation to sump elevation</td>
</tr>
<tr>
<td>Node Rim to Invert In Depth</td>
<td>labels the distance from rim elevation to invert in elevation</td>
</tr>
<tr>
<td>Pipe Center</td>
<td>labels the center of node (structure)</td>
</tr>
<tr>
<td>Pipe Label</td>
<td>labels the pipe label name</td>
</tr>
<tr>
<td>Pipe Length (2D)</td>
<td>labels the two-dimensional length of the pipe measured from center of node (structure) to center of node.</td>
</tr>
<tr>
<td>Pipe Diameter</td>
<td>labels the pipe diameter</td>
</tr>
<tr>
<td>Pipe Slope</td>
<td>labels the pipe slope in percentage</td>
</tr>
<tr>
<td>Pipe Coefficient</td>
<td>labels the pipe roughness coefficient</td>
</tr>
<tr>
<td>Pipe Flow</td>
<td>labels the pipe flow value</td>
</tr>
<tr>
<td>Pipe Material</td>
<td>labels the pipe material</td>
</tr>
<tr>
<td>Pipe Length (3D)</td>
<td>labels the three-dimensional length of the pipe measured from center of node to center of node.</td>
</tr>
<tr>
<td>Pipe Length (Str-Str)</td>
<td>labels the three-dimensional length of the pipe measured from edge of structure to edge of structure</td>
</tr>
<tr>
<td>Pipe Length (Adj Str-Str)</td>
<td>labels the length the user selected from the Pipe Run Editor</td>
</tr>
<tr>
<td>Pipe Full Flow</td>
<td>labels the full pipe flow</td>
</tr>
<tr>
<td>Pipe Full Velocity</td>
<td>labels the full pipe flow velocity</td>
</tr>
<tr>
<td>Pipe Design Flow</td>
<td>labels the pipe design flow</td>
</tr>
</tbody>
</table>

### Code Category: XS Pnt #1 (Centerline)

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point Code Offset</td>
<td>labels the point code offset value</td>
</tr>
<tr>
<td>Point Code Elevation</td>
<td>labels the point code elevation value</td>
</tr>
<tr>
<td>Point Code EG Elevation</td>
<td>labels the existing ground elevation at the point code</td>
</tr>
<tr>
<td>Point Code Placement Marker</td>
<td>labels the point code position for blocks or static text</td>
</tr>
</tbody>
</table>
### Code Category: Point Code

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>XS Pnt #1 (Centerline)</td>
<td>labels the template finished ground reference point</td>
</tr>
<tr>
<td>XS Pnt #2 (Connection)</td>
<td>labels the template connection points</td>
</tr>
<tr>
<td>XS Pnt #3 (Ditch)</td>
<td>labels the inner ditch points</td>
</tr>
<tr>
<td>XS Pnt #4 (Ditch Width)</td>
<td>labels the outer ditch points</td>
</tr>
<tr>
<td>XS Pnt #5 (Bench)</td>
<td>labels the inner slope bench points</td>
</tr>
<tr>
<td>XS Pnt #6 (Bench Width)</td>
<td>labels the outer slope bench points</td>
</tr>
<tr>
<td>XS Pnt #7 (Stepped)</td>
<td>labels the stepped slope points</td>
</tr>
<tr>
<td>XS Pnt #8 (Stepped Width)</td>
<td>labels the outer stepped slope bench points</td>
</tr>
<tr>
<td>XS Pnt #9 (Surface)</td>
<td>labels the surface slope points</td>
</tr>
<tr>
<td>XS Pnt #10 (Surface On)</td>
<td>labels the surface slope intermediate bench points</td>
</tr>
<tr>
<td>XS Pnt #11 (Surface Width)</td>
<td>labels the outer surface slope bench points</td>
</tr>
<tr>
<td>XS Pnt #12 (Subsurface Apex)</td>
<td>labels the template subgrade crown point</td>
</tr>
<tr>
<td>XS Pnt #13 (Subsurface Median)</td>
<td>labels the template subgrade inner superelevation break points</td>
</tr>
<tr>
<td>XS Pnt #14 (Subsurface Break)</td>
<td>labels the template subgrade outer superelevation break points</td>
</tr>
<tr>
<td>XS Pnt #15 (Subsurface Inter)</td>
<td>labels the template subgrade/side slope intersection points</td>
</tr>
<tr>
<td>XS Pnt #16 (Catch)</td>
<td>labels the slope to eg match points</td>
</tr>
</tbody>
</table>

There are 16 pre-defined point codes. Point code numbers 17–24 are not currently used. Point codes from 25–100 are user defined and can represent any position on the template.

When you are formatting a Text Label, Distance Label, or Block Label, you can specify any of the cross section template point codes as the Code Category. Each point code shares the same Codes, which are listed beneath the first point code number below.
Appendix A

Autodesk Civil Design File List

This appendix contains lists of files that are created when you use Civil Design commands.
### Autodesk Civil Design File List

<table>
<thead>
<tr>
<th>Feature</th>
<th>File</th>
<th>Location</th>
<th>Description</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ponds</td>
<td>&lt;pond&gt;.psp</td>
<td>&lt;project&gt;\Hd</td>
<td>Pond shape definition file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;pond&gt;.pda</td>
<td>&lt;project&gt;\Hd</td>
<td>Pond outflow data</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&lt;slope&gt;.htp</td>
<td>&lt;project&gt;\Hd</td>
<td>Slope template definition file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>hd.lk#</td>
<td>&lt;project&gt;\Hd</td>
<td>Multi-user coordination lock file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;drawing&gt;.dfm</td>
<td>&lt;project&gt;\Dwg</td>
<td>Drawing specific settings</td>
<td>ASCII text file</td>
</tr>
<tr>
<td>Profiles</td>
<td>&lt;alignment&gt;.vrt</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Profile definition file</td>
<td>binary data file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.lk#</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Multi-user coordination lock file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;drawing&gt;.dfm</td>
<td>&lt;project&gt;\Dwg</td>
<td>Drawing specific settings</td>
<td>ASCII text file</td>
</tr>
<tr>
<td>Cross</td>
<td>&lt;alignment&gt;.dcn</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Depth slope definition</td>
<td>ASCII text file</td>
</tr>
<tr>
<td>Sections</td>
<td>&lt;alignment&gt;.pcn</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Stepped slope definition</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.scn</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Surface slope definition</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.xsd</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Existing ground cross section data file</td>
<td>binary data file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.xsp</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Existing ground section data pointer file</td>
<td>binary data file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.icn</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Subsurface interpolation control</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.smp</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Sampled station list</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.tcp</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Template control data pointer file</td>
<td>binary data file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.tcd</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Template control data file</td>
<td>binary data file</td>
</tr>
</tbody>
</table>
### Autodesk Civil Design File List (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>File</th>
<th>Location</th>
<th>Description</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cross Sections (continued)</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.tdf</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Additional template control definition file for commands like View and Edit Sections</td>
<td>binary data file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.sed</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Superelevation data file</td>
<td>binary data file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.err</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Cross section process error log</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;alignment&gt;.lk#</td>
<td>&lt;project&gt;\Align&lt;alignment&gt;</td>
<td>Multi-user coordination lock file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;drawing&gt;.dfm</td>
<td>&lt;project&gt;\Dwg</td>
<td>Drawing specific settings</td>
<td>ASCII text file</td>
</tr>
<tr>
<td><strong>Hydrology</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.inp</td>
<td>&lt;project&gt;\hd</td>
<td>Adjustment factors</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>channel.cof</td>
<td>&lt;project&gt;\hd</td>
<td>Channel calculator: Manning’s n data file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>pipe.cof</td>
<td>&lt;project&gt;\hd</td>
<td>Culvert diameter data file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>culvert.cof</td>
<td>&lt;project&gt;\hd</td>
<td>Culvert calculator: Manning’s n data file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.clt</td>
<td>&lt;project&gt;\hd</td>
<td>Culvert data</td>
<td>binary data file</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.wk1</td>
<td>&lt;project&gt;\hd</td>
<td>Hydro data file</td>
<td>wk1 database file</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.hdc</td>
<td>&lt;project&gt;\hd</td>
<td>Hydrograph curve data</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.pdt</td>
<td>&lt;project&gt;\hd</td>
<td>Hydrology and pond settings file</td>
<td>binary data file</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.idf</td>
<td>&lt;project&gt;\hd</td>
<td>Intensity duration frequency factors data file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>county.rf</td>
<td>&lt;project&gt;\hd</td>
<td>Rainfall frequency data</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.rtc</td>
<td>&lt;project&gt;\hd</td>
<td>Rating curve data file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.rat</td>
<td>&lt;project&gt;\hd</td>
<td>Rational Method data file</td>
<td>binary data file</td>
</tr>
<tr>
<td></td>
<td>runoff.cof</td>
<td>&lt;project&gt;\hd</td>
<td>Runoff curve number</td>
<td>ASCII text file</td>
</tr>
<tr>
<td>Feature</td>
<td>File</td>
<td>Location</td>
<td>Description</td>
<td>Format</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------</td>
<td>--------------</td>
<td>------------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Hydrology</td>
<td>&lt;name&gt;.sdc</td>
<td>&lt;project&gt;\hd</td>
<td>Stage discharge curve data file</td>
<td>ASCII text</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.ssc</td>
<td>&lt;project&gt;\hd</td>
<td>Stage-storage curve data file</td>
<td>ASCII text</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.sim</td>
<td>&lt;project&gt;\hd</td>
<td>Storage indication method data file</td>
<td>binary data</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.dab</td>
<td>&lt;project&gt;\hd</td>
<td>Rainfall distribution table file</td>
<td>binary data</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.tbl</td>
<td>&lt;project&gt;\hd</td>
<td>Rainfall distribution table file</td>
<td>ASCII text</td>
</tr>
<tr>
<td></td>
<td>sheet.cof</td>
<td>&lt;project&gt;\hd</td>
<td>Tc Sheet flow: Manning’s n data file</td>
<td>ASCII text</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.bsn</td>
<td>&lt;project&gt;\hd</td>
<td>TR-55 detention basin storage data file</td>
<td>binary data</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.gpd</td>
<td>&lt;project&gt;\hd</td>
<td>TR-55 graphical peak discharge</td>
<td>binary data</td>
</tr>
<tr>
<td></td>
<td>&lt;name&gt;.tab</td>
<td>&lt;project&gt;\hd</td>
<td>TR-55 tabular hydrograph</td>
<td>binary data</td>
</tr>
<tr>
<td></td>
<td>tcchan.cof</td>
<td>&lt;project&gt;\hd</td>
<td>Tt channel: Manning’s n data file</td>
<td>ASCII text</td>
</tr>
<tr>
<td></td>
<td>hd.lk#</td>
<td>&lt;project&gt;\hd</td>
<td>Multi-user coordination lock file</td>
<td>ASCII text</td>
</tr>
<tr>
<td></td>
<td>&lt;drawing&gt;.dfm</td>
<td>&lt;project&gt;\Dwg</td>
<td>Drawing specific settings</td>
<td>ASCII text</td>
</tr>
<tr>
<td>Pipes</td>
<td>pipeworks.mdb</td>
<td>&lt;project&gt;\Pipewks</td>
<td>Pipe runs database</td>
<td>Microsoft Access database</td>
</tr>
<tr>
<td></td>
<td>pipewks.slp</td>
<td>&lt;project&gt;\Pipewks</td>
<td>Pipe size and slope data file</td>
<td>ASCII text</td>
</tr>
<tr>
<td></td>
<td>blkcor.pst</td>
<td>&lt;project&gt;\Pipewks</td>
<td>Structure library correlation file</td>
<td>binary data</td>
</tr>
<tr>
<td></td>
<td>blkdef.pst</td>
<td>&lt;project&gt;\Pipewks</td>
<td>Structure library definition file</td>
<td>binary data</td>
</tr>
<tr>
<td></td>
<td>mann.cof</td>
<td>&lt;project&gt;\Pipewks</td>
<td>Mannings coefficients data file</td>
<td>ASCII text</td>
</tr>
<tr>
<td></td>
<td>hazen.cof</td>
<td>&lt;project&gt;\Pipewks</td>
<td>Hazen-Williams coefficients data file</td>
<td>ASCII text</td>
</tr>
</tbody>
</table>
### Autodesk Civil Design File List (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>File</th>
<th>Location</th>
<th>Description</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pipes (continued)</td>
<td>darcy.cof</td>
<td>&lt;project&gt;\Pipewks</td>
<td>Darcy-Weisbach friction factor file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>pipewks.lk#</td>
<td>&lt;project&gt;\Pipewks</td>
<td>Multi-user coordination lock file</td>
<td>ASCII text file</td>
</tr>
<tr>
<td></td>
<td>&lt;drawing&gt;.dfm</td>
<td>&lt;project&gt;\Dwg</td>
<td>Drawing specific settings</td>
<td>ASCII text file</td>
</tr>
<tr>
<td>Sheet Manager</td>
<td>&lt;series&gt;.sdb</td>
<td>&lt;project&gt;\cd\data&lt;series&gt;</td>
<td>Sheet series data file</td>
<td>binary data file</td>
</tr>
<tr>
<td></td>
<td>&lt;drawing&gt;.dwg</td>
<td>&lt;project&gt;\cd\data&lt;series&gt;</td>
<td>Individual sheet drawing AutoCAD drawing file</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&lt;drawing&gt;.sdb</td>
<td>&lt;project&gt;\cd\data&lt;series&gt;</td>
<td>Individual sheet data file</td>
<td>binary data file</td>
</tr>
</tbody>
</table>
Appendix B

Help Files and Tutorials

In this chapter

- Refreshing the online help Contents page
If you install AutoCAD Land Development Desktop and run the online Help or the tutorials before installing Autodesk Civil Design, then the Autodesk Civil Design Help files and tutorial will not appear on the Help contents page.

**To refresh the Help contents page**

1. Locate the hidden files acad.gid and land.gid in the `c:\Program Files\Land Development R2\Help` folder.

   **NOTE** The option to show hidden system files must be active in order to view .gid files. To show hidden files on your system, open Windows Explorer and select `View ➤ Options`, then select the option to Show All Files. Likewise, clear the option to Hide MS-DOS file extensions for file types that are registered.

2. Delete the acad.gid and land.gid files.

3. Restart the online Help.

   The contents page should be updated with links to the Autodesk Civil Design Help and tutorial files.
Index

appearance settings, grading, 42
ASCII text files (ground profiles), 242
  file format, 245
  settings, 244
ASCII text files (pipe data)
  pipe parameters, 708
audit pipe database, 651
average end area volume computation (avgendarea)
  mass haul diagram, 439, 441
  strip surface, 463, 464
  subsurfaces, 460
  template surface, 441, 442, 443, 457, 459
bench settings for ponds, 90
benches in roadway cross sections, 351
block labels, 838
borehole data, surfaces, 266
breaklines
  3D polyline, 79
  calculating daylighting, 72
  creating from a grading object, 62
  vertices and daylight points, 79
calculating grading object volumes, 45, 63
calculations, 469
  length of curve, 205
  orifice values, 519
  passing sight, 200
  stopping sight, 202
calculations (formulas)
  rational method (peak runoff), 567
  riser head flow, 532
  triangular weir, 529
calculators for hydrology. See also
  hydrology calculators, 469
  pipe values, 497
  runoff from watershed areas, 545
centerline (finished ground profiles), 190
  vertical alignment tangents, 191, 192, 193
  vertical alignments, 190
  vertical curves, 197
channel calculators, 470
  rectangular channel values, 470, 471
  trapezoidal channel values, 477
Cipolletti Weir calculator, 524
  velocity coefficients, 525
  weir values, 523
circular pipe calculations
  Hazen-Williams equations, 513
  headloss value, 508
  length, 508
Civil Design files, 884, 885, 886, 887
code category for sheet labels, 826
coefficient tables (pipes), 622
coefficients (friction)
  channels, 470, 471, 477, 478, 479
  culverts, 481, 483
  Hazen-Williams roughness, 515
  Manning's n roughness, 472
  orifices, 519, 520
coefficients (pipe flow)
  circular pipes, 507
  custom pipes, 512
  elliptical pipes, 511
  rectangular pipes, 509
coefficients (velocity)
  weirs, 523, 525
conceptual pipe runs, 622, 651
  draw and define, 652
  importing into drawing, 659
  layer tools, 695
conceptual pipe runs (plan view), 661
  editing, 663
  layer settings, 636
conceptual pipe runs (profile view)
  deleting, 688
  editing, 686
  layer settings, 637
contours (ponds)
  report data, 125, 128
  settings, 107
corner treatments, 33, 37
  chamfer, 36
Index

- stge-storage curve data file format (.ssc), 538
- data output. See outputting data, 605
- daylighting
  - daylight lines, 405, 406
  - defining pond bottom, 105
- daylighting, calculating, 72
- DB format (import/export files), 708
- dbf files, 723
- define pipe runs, 652
  - polylines, 656
- define ponds, 99
  - defining slopes. See also pond slopes, 102
  - from contours, 100
- define subassemblies, 284
  - drawing the subassembly, 291
- define templates, 301
- deleting pipe runs (conceptual), 688
- depth of flow in weirs
  - rectangular weirs, 525, 526
  - triangular weirs, 528
- depth slope (cross sections)
  - benches, 351, 352
  - defining benches, 351
- design control (cross sections), 326, 384
  - changing control values, 389
  - depth slopes, 326
  - ditches, 379, 381, 382, 383
  - editing, 341
  - match slope, 384
  - outputting control values, 375
  - slopes, 326, 347, 348, 349, 350
  - superelevations, 354
  - transitions, 343, 344
- design pipe settings, 622
  - label settings (finished draft), 639, 643
  - layer settings, 636
  - pipe run editor, 630
  - pipe runs (defining), 633
  - slope and coefficient tables, 622
- detention basins in ponds, 131
  - drainage area, 135
  - peak outflow, 135, 136
- diameters in culverts, 489
- ditches (cross sections), 338, 340, 379
  - ditch slope, 381
  - offset and depth, 383
  - width, 382, 383
- ditches and transitions, 216
  - current layer, 216
  - defining as vertical alignments, 231
  - vertical alignment editor, 169
  - vertical alignment tangents, 216
  - vertical curves, 222
- ditches and transitions (cross sections), 395
  - importing into profiles, 397
- drafting settings, 639, 643
- draw pipe runs, 652
  - finished draft, 702, 703, 704
- drawing template (roadway cross sections), 270
- edit cross sections, 384
  - changing control values, 389
  - changing slope control, 378
  - changing template control, 390
  - ditches, 379
  - identifying points, 386
  - match slope, 384
  - selecting a section, 386
  - viewing sections, 386
- edit design control (cross sections), 341, 384
  - ditches, 346, 347, 379, 381, 382, 383
  - horizontal alignment transitions, 338
  - roadway transitions, 332
  - roadway transitions, 333
- edit pipe run data (conceptual plan), 663, 670
  - upstream run flow data, 668, 669
- edit pond outflow data, 155
- edit subassemblies, 292
  - top surface, 298
  - vertices, 294, 295
- edit templates, 307
  - connection points, 321, 322
  - point codes, 317, 318
  - roadway transitions, 332, 333, 338, 340
  - superelevations, 354
  - surfaces, 313, 314, 315, 322, 323
  - vertices, 311
- edit vertical alignments (ground profiles)
  - creating existing ground data, 214
  - ditches and transitions, 235
  - generating vertical alignment reports, 173
  - vertical curves, 172
- elevations (grading points), 5
  - stratum, 7
- elevations in culverts
  - point from DTM surface, 492
- elevations in ground profiles, 212
  - finished ground centerline, 211
- elevations in roadway cross sections
  - labeling, 427, 429
- elliptical pipe calculations
Darcy-Weisbach equations, 511
energy loss in pipe runs, 670
equations in calculating hydrology data, 469, 533
existing ground (profiles), 158, 169
   alignment data folder, 158
   creating vertical alignment data, 212
   generating vertical alignment reports, 173
   sampling from multiple surfaces, 166
   vertical alignment editor, 170, 171, 172, 173, 214, 215
existing ground section editor, 253
   borehole data, 266
existing ground surface (stratum), 7
export pipe data files, 706
   ASCII ASC format, 707
   ASCII format, 707
   DB format, 708
   WK1 format, 707
extended entity data (EED) in pipe database, 651
filename extensions (hydrology), 536
files in Civil Design, 884, 885, 886, 887
finished draft pipe runs
drawing, 701
   layer tools, 697
   profile view, 703, 704, 705
   special lines, 704
finished grade labels, 2
finished ground (profiles), 158
   alignment data folder, 158
   layer settings, 162, 163
finished ground centerlines (profiles), 190
   current layer, 191
   vertical alignment editor, 209
   vertical alignment tangents, 191
   vertical curves, 197
finished ground cross sections, 275, 326
   outputting values, 375
   roadway slopes, 326
finished ground surfaces (grading), 2, 7
   calculating slope daylighting, 72
   stratum, 7, 8, 9
flow rates in channels
   left and right radii and slopes, 478
flow rates in culverts
   overtop, 494, 495
   performance curve, 495
flow rates in pipe runs (editing), 670
flow rates in weirs
   Cipolleti Weir calculator, 523
footprint
   base elevation, 21
   coordinates, 21
   direction to grade, 21
   settings/properties, 20
   using grips to edit, 50
formulas (calculations)
   length of curve, 205
   orifice, 519
   passing sight, 200
   rational method (peak runoff), 567
   rectangular weir, 527
   riser head flow, 532
   stopping sight, 202
   triangular weir, 529
frames, 804
   creating, 814
   selecting, 874
   updating label and grids, 871
frames (category), 805
   cross section sheets, 805
   plan and profile sheets, 805
frames (type), 805
   cross section, 807, 808, 809, 810
   plan/profile, 814
   profile, 814
friction factors (pipes)
   Darcy-Weisbach equations, 506
generate sheet series
   plan/profile sheets, 753, 754, 755
   profile sheets, 759, 760
grades in roadway cross sections
   labeling, 431
grading, 2
   daylighting, 72, 81
   grade labels, 2, 4
   grading points. See also grading points, 5
   ponds. See also grading ponds, 118
   stratum, 7
grading files, 884, 885, 886, 887
grading object, 15
   calculating statistics, 45
   color, 43
   creating, 16, 17
   creating breaklines from a grading object, 62
   creating surfaces from a grading object, 58
   editing, 46, 47, 48, 50, 51, 52
   editing individual corners, 37
   editing individual target regions, 28
   exploding, 48
footprint, 15
functionality in other AutoCAD versions, 57
grip visibility, 43
grips, 50, 51, 53
layer, 42, 43
linetype, 43
locking, 47
saving as different versions of AutoCAD, 57
settings/properties, 19, 20, 29, 42
target, 23, 27, 28, 29
volumes, 45
grading points, 5
elevations, 5, 6, 7, 10, 11
stratum, 7
grading ponds, 118
defining ponds, 99
labeling, 124
listing information, 121
perimeters, 91, 99
settings, 85, 86, 87, 88, 89, 90
slopes, 102
graph settings, 541
dimensional hydrograph values, 599
hydrograph data file (.hdc), 538
calculating pond routing, 138
calculating reservoir routing values, 139
graphical method (TR-55), 585
hydrographs (plotting)
border settings, 576
grid settings, 577
main title settings, 571, 572
settings, 582
hydrology, 468
list of data files, 536
outputting data, 605
outputting pond data. See also pond output, 125
routing. See also pond routing, 131
TR-55 methods, 585
hydrology calculators, 469
list of data files, 536
pond runoff, 137
pond storage volume, 129
riser values, 530
runoff from watershed areas, 545
runoff time and travel, 556
hydrology files, 884, 885, 886, 887
hydrology settings, 539
culvert settings, 484, 486
pond settings, 85
riser settings, 530
hydrology tools settings, 539
plotting settings, 543, 544
import, 299, 300
catch points and daylight lines, 406
ditch or transition, 398
HEC2 profiles, 615
pipe runs (conceptual), 659
template points, 401
import pipe data files, 706
WK1 format, 706
increment settings, 39, 40
inflow calculations, 469
inflow structures for ponds. See also pond outflow editor, 146
information lists on ponds. See also list information about ponds, 121
interpolating surfaces for cross sections, 266
invert in/out (pipe runs)
settings, 633, 634
label styles, 817
block labels, 838
horizontal alignments (roadway cross sections), 250, 338
Hazan-Williams equations
custom pipes, 518
roughness coefficient, 515
head flow calculator, 532
headlight sight distance, 204, 227
headloss value in pipes
editing pipe runs, 670
Hazan-Williams equations, 517
HEC2 output, 605
formatting data files, 607
sample cross sections, 610, 613
labeling areas on plotted cross sections, 423
labeling ponds, 121
labels (cross sections), 423
labels (finished grade), 2
settings, 2
labels (frames), 804
settings, 715, 785
updating labels, 871
labels (ground profiles), 238
finished ground tangents, 239
settings, 163, 164
vertical curves, 230
labels (nodes), 643
labels (pipes), 639
metric units, 663
labels (sheets), 817
block labels, 838
converting values, 834
distance labels, 840
multi-line format, 832
text labels, 817, 818
labels (vertical alignments), 238
layers (pipes), 636
conceptual pipe runs, 695
finished draft pipe runs, 697
pipe layer tools, 695
layers (sheets)
frames, 715
layer report, 784, 785
ms match lines, 714
MS match lines, 713
view definitions, 713
layout (sheets)
cross section sheets, 724
plan/profile sheets, 741
length of culverts, 488
length of curve formula (profiles), 205
list areas on plotted cross sections
offset and elevation of points, 421
slope, grade, and elevational difference, 422
zoom to a cross section, 421
list information about ponds, 121
contour area, 122
contour perimeter, 122
properties, 121
slope and grade, 123
list vertical alignment information
(profiles), 238
finished ground tangent data, 240
Mannings formula
circular pipes, 499
custom pipes, 505
elliptical pipes, 503
rectangular pipes, 501
roughness coefficient, 472, 612
match line. See also slope daylighting, 72
match slope in cross sections, 384
material tables, 278
model space, 778
multiple surfaces in ground profiles
(sampling), 166
node and pipe settings, 622
node data settings, 635
pipe runs (defining), 633
roughness coefficient tables, 625
slope control, 623, 624
node label settings (finished draft), 643
plan view, 643
profile view, 645
nodes (pipes)
editing in plan view, 670
surface runoff contributions, 681
normal surface template, 271
asymmetrical, 274
symmetrical, 273
orifice calculator, 520
area, 522
coefficients, 521
diameter, 521, 522
outflow calculations, 469
outflow structures for ponds. See also pond
outflow editor, 146
outlet structures (pond)
deleting, 152
editing, 152
outlets. See also riser calculator, 530
output data (cross sections)
section sampling line, 606
strip volume data, 463
total volume data, 455
volume data, 438
output data (pipes)
templates, 709
output profile data, 242
ASCII file format, 245
ASCII output settings, 244
output settings, 539
graphing utility, 544
plotting, 542
precision settings, 541
units settings, 539
outputting data, 605
HEC2 format, 607, 610
plotting sheets, 785
pond data. See also pond output, 125
settings, 539
paper sheets for plotting, 785
paper sheets for plotting. See also sheets, 711
paper space, 777, 778
loading single sheets, 776
parameters. See also hydrology tools
settings, 539
passing sight distance in vertical curves (calculating), 200
peak runoff (calculating)
  frequency adjustment factor, 585
  TR-20 method, 594, 595, 596, 597
perimeters for ponds, 91
pipe label settings (finished draft), 639
  plan view, 639, 640
  profile view, 641
pipe layer settings, 636
pipe layer tools (conceptual), 695
pipe layer tools (finished draft), 695, 697
pipe run editor, 664
  conceptual plan pipe runs, 663, 670
  controls, 666
pipe runs, 622
  importing/exporting, 706
  layer tools. See also pipe layer tools, 695
  setting defaults, 633
pipe runs (conceptual plan), 661
  editing, 663
  editing data, 670
  layers, 695
  precision settings, 666, 667
pipe runs (conceptual profile)
  deleting, 688
  layers, 695
pipe runs (conceptual), 651
  horizontal alignments, 661
  importing into drawing, 659
  layer tools, 695
pipe runs (finished draft plan), 701
  layer tools, 697
pipe runs (finished draft profile), 701
  cross sections, 703
  label settings, 641
  layer tools, 697
pipe settings, 622
  audit pipe database, 651
  editing. See also pipe settings editor, 622
  layers, 636
pipe settings editor, 622
  label settings (finished draft), 639, 643
  layer settings, 636
pipe runs (defining), 633
  slope and coefficient tables, 622
  structure library editor, 647, 649
text editor, 649, 650
pipes, 622
  importing/exporting pipe runs, 659, 706
  layer settings, 636
  layers (conceptual pipe runs), 695
  layers (finished draft pipe runs), 697
  pipe runs, 651, 701
  settings. See also pipe settings, 622
pipes files, 884, 885, 886, 887
plan pipes (conceptual), 661
  editing, 663
  layers, 695
  settings, 636, 639, 641, 643, 644
plan pipes (finished draft), 701
  layers, 697
plan sheets, 772
  frames, 804
  setting frame category, 805
  viewports, 799, 800, 801
plan/profile sheet series, 734
  layout options, 738, 739
plan/profile sheets, 769
  frames, 804, 805
plotting, 785
  settings, 570, 571, 572, 573, 574, 575, 576, 578
  sheets, 711, 785
  single sections, 607
plotting cross sections, 408
point codes, 280
  importing into drawing, 401
point of vertical intersection (PVI)
  ditches and transitions, 219, 220, 221
  finished ground, 194, 195
points (grading), 5
  elevations, 80
  stratum, 7
points (template), 401
polyline footprint. See also slope
daylighting, 72
polylines on plotted cross sections, 433
pond outflow editor, 137, 146
  changing data, 155
  deleting inflow and outflow structures, 152
  displaying data about current pond, 153
  editing inflow and outflow structures, 152
  rating curve, 154
  stage-discharge curve, 155
pond output, 125, 126, 127, 128, 129
  data types, 127
  hydrograph data file (.hdc), 138
  stage-discharge curve file (.sdc), 139
pond perimeters, 91
  2D to 3D, 96
  defining from existing polylines, 99
  defining slopes. See also pond slopes, 102
  drawing, 91, 92
pond routing, 131
  storage indication method, 137, 138, 139
pond settings, 85
pond slopes, 102
  defining pond bottom, 105
  linear, 103, 104
  multiple linear slopes, 107, 108, 109
  templates, 111, 114, 116
ponds, 84, 468
  defining perimeters or contours, 99
  detention basin outflow hydrograph, 131
  labeling, 121
  listing information, 121
  outputting data. See also pond output, 125
  perimeters, 91
  routing values (calculating), 137
  settings, 85
  shaping. See also shaping ponds, 118
  storage volume, 132, 133, 134
profile, 158, 179, 180, 181
  data files, 158
profile pipes (conceptual)
  settings, 637
profile pipes (finished draft)
  energy gradelines, 705
  hydraulic gradelines, 705
  settings, 641, 645, 646, 647
profile settings (ground), 159
  existing ground layers, 160
  finished ground layers, 162, 163
  labels and prefix, 163, 164
  sampling, 159, 160
  values, 165, 166
profile sheet series, 734
  layout options, 746
profile sheet settings
  fixed profile stations, 716, 717
  profile station offset, 718
profile sheets, 771
  frames, 814
setting frame category, 805
profiles (ground), 158, 178
  ASCII output files, 242
changing settings. See also profile settings, 159
creating profiles, 169, 179
ditches and transitions, 216, 231
finished ground centerlines, 190, 191, 197
horizontal alignment data folder, 158
labeling and listing vertical alignments, 238
sampling existing ground data, 212
surfaces, 166
profiles (roadway transitions), 340
profiles files, 884, 885, 886, 887
prototype settings for hydrology project, 539
rainfall distribution file, 550
rainfall frequency in counties
  TR-55 method, 550
rational method calculator, 564, 567
  rational method formula, 567
  runoff coefficient, 583
rectangular channel calculations
  Mannings formula, 472
rectangular pipe calculations
  Darcy-Weisbach equations, 509
  Hazen-Williams equations, 515
rectangular weir calculations
  coefficient, 527
  formula, 527
reports (vertical alignment), 173
  settings, 173
  station and vertical curve, 177
reports on pond data. See also pond output, 129
reservoir (calculating routing values), 137, 139
right-of-way. See also transitions, 338
rim elevation in pipes
  editing, 686
riser calculator, 530, 531
  equations and steps, 533
  head flow formula, 532
  pipe entrance coefficients, 534
  riser and pipe diameter tables, 534
roadway, 250
  slopes, 326
  superelevations, 354
  templates, 250
transitions, 332
roughness coefficients, 472, 515
routing values (ponds), 137, 139
runoff, 545, 546
calculating from watershed areas, 545
channel flow, 561, 562
rainfall frequency, 549, 550
shallow flow, 560, 561
sheet flow, 558, 559
soil groups and cover types, 553
time of concentration (tc), 556
time of travel (tt), 556
sample data (ground cross sections)
editing, 264
multiple surfaces, 254, 255
settings, 259, 260
sample data (ground profiles), 166
multiple surfaces, 167, 168
settings, 159, 160
saving, 293
pipe settings, 650
pond perimeter, 97
scale, 724
sdb files, 723
sdsk.dfm file, 723
editing, 723
section data for a range of stations, 452
section plot, 408
section sheets, 724, 774
sections. See also cross sections, 250
settings for ground profiles, 159
settings for hydrology output, 539
settings for pipes. See also pipe settings, 622
sewer system pipes, 622
editing for design requirements, 661
shaping ponds, 118
benching, 90, 91
bottom polyline, 119, 120
contours, 85, 86, 87, 99, 118, 119, 127, 147
perimeters, 91
slope control lines, 88, 89, 90, 119
sheet manager, 711
cross section sheets, 774
customizing, 788
plan sheets, 772
plan/profile sheets, 769
plotting sheets, 785
profile sheets, 771
settings, 712, 713, 724, 875
single sheets, 775
sheet manager files, 884, 885, 886, 887
sheet series, 734, 738
layout settings, 724
rules for loading, 758
sheet styles, 787
database path, 721, 722, 723
editing, 797
file types, 723
frames, 804, 874
plan/profile, 790
plan-only, 793
viewports, 874
sheet styles (labels)
block labels, 838
numeric format, 822
sheet tools, 776
plan view angle, 780
rotate plan annotation, 780, 781
sheets, 711, 785
managing sheets, 776
sheets (settings), 712
cross section sheets, 724
model space, 718
profile sheets, 717
shoulders. See subassemblies, 283
single-line pipe runs. See also pipe runs (conceptual), 651
site design, 2
sketches of pipe run configurations, 651
slope daylighting (calculating), 72
breaklines, 78, 79, 80
slope grading
daylight lines, 72
overview, 15
slope tags
using grips to edit, 51
slopes
settings/properties, 29
slope tags, 29, 51
slopes in channels
rectangular, 470, 471
trapezoidal, 477
slopes in ponds, 102
slopes in roadway cross sections, 326
benches, 351
changing in sections, 378
changing settings, 326
spillways. See also riser calculator, 530
stage-discharge curve data file (.sdc), 139, 538
calculating reservoir routing values, 139
stage-storage curve for ponds, 129
calculating reservoir routing values, 139
stopping sight distance in vertical curves (calculating), 202
storage facility (calculating routing values), 137
storage indication method (pond routing), 137
    formula, 137
    hydrograph data file (.hdc), 138
    reservoir or storage facility, 139
    stage-discharge curve file (.sdc), 139
    stage-storage curve file (.ssc), 138
storage volume, 129
    detention basin (calculating), 131
    plotting storage curve for ponds, 129
    stage-storage curve data file (.ssc), 538
stormwater management, 131, 468
    designing pipe systems, 622
stratum, 7, 8
structure library editor
    nodes in conceptual pipe runs, 670
styles (sheet labels), 817
    block labels, 838
    label placement, 854
styles (sheets), 787
    cross section, 724
    database path, 723
    file types, 723
    frames, 804
    profile-only, 792
subareas in watersheds. See also watershed subareas, 545
subassemblies, 283
    defining, 284, 285
    drawing, 291
    finished ground cross sections, 275
    surface material table, 278, 279
    template shoulder, 319
    templates, 270
subassemblies (editing), 292
    vertices, 294, 295
subgrade surface template, 271
    asymmetrical, 274
    symmetrical, 274
subsurface data from boreholes, 266
subsurface data in ground profiles, 158
subsurface profile, 182
sump values in pipe runs, 670
    elevations, 683, 684
superelevate
    complex compound curves, 372
    complex reverse curves, 375
    compound curves, 368, 370
    reverse curves, 372, 373
    superelevation data for curve 2, 370
    superelevations in roadway templates, 354
curves, 362, 363, 364
surface (template), 270
    drawing, 272, 273, 312
    normal and subgrade, 271
surfaces
    adding breaklines to, 62
    as grading target, 25
    calculating slope daylighting, 72
    creating from a grading object, 58
    grading surfaces, 2
    labeling surface elevations, 2
    sampling in creating ground profile, 166
stratum, 7
surfaces (cross sections), 278
    surface material table, 278
    symmetrical template, 273
table frames, 810, 811
tables, 278
    material tables, 278
    rainfall distribution, 550, 551
    riser and pipe diameter, 534
    tabular method (TR-55), 585
    rainfall frequency, 550
target regions
    adding/deleting, 26
    editing individual grading targets, 28
    using grips to edit, 51
targets
    settings/properties, 23
template points (cross sections), 401
template volume report, 443
templates, 300
    defining templates, 301
    pond slopes, 111, 112, 114, 115, 116
    template points, 401
templates (cross sections), 270
ditches, 379
    editing template transitions, 391
    material tables, 278
    point codes, 280, 401
    redefining, 307
    roadway transitions, 332, 333
    subassemblies, 284, 291, 292
templates (editing), 307
datum lines, 319
    roadway transitions, 332, 333, 338, 340
    subgrade depth, 315
    superelevations, 354
    surfaces, 312, 316
    vertices, 308, 309, 310
templates (finished ground), 275, 326
design control, 326, 342, 343
    roadway slopes, 326
superelevation parameters, 345
surface material table, 278
templates (normal surfaces), 271
attaching subassemblies, 291
editing subassemblies, 292
templates (subgrade surfaces), 271
editing, 315, 316
text editor, 682
viewing and editing hydrology files, 544
text labels in sheets
converting values, 834
format, 825
multi-line format, 830
time of concentration (calculating runoff), 556
time of travel (calculating runoff), 556
TR-20 method
distribution curve, 601, 602, 603
TR-55 methods, 586
graphical peak discharge method, 587, 588
peak runoff flow, 590
rainfall frequency, 547, 548, 550
time of concentration, 556
time of travel, 556
transitions (editing), 391
left or right transition regions, 393
transition offset and elevation values, 391
transitions (roadway), 332
attaching to cross sections, 338, 340
defining on template, 333
dynamic or pinned, 336
triangular weir calculations
coefficient, 529
formula, 529
velocity coefficients, 524
vertex in subassemblies, 294, 295
vertical alignment reports, 173
station and vertical curve report, 177
vertical alignments
horizontal data files, 158
labeling, 238
vertical alignments (ditches and transitions), 216, 231
vertical alignments (existing ground profiles), 169
sampling existing ground, 212
vertical alignments (finished ground profiles), 190
centerlines, 190, 191
vertical alignments (roadway cross sections), 340
vertical curves (ditches and transitions), 222
curve length, 222
design velocity, 228, 229
labeling, 231, 238
minimum K value, 223
passing sight distance, 224
stopping sight distance, 225
vertical intersection, 229
vertical curves (finished ground profiles), 197
curve length, 197, 198
design velocity, 206
minimum K value, 198
passing sight distance, 199, 200
stopping sight distance, 201, 202
viewing cross sections, 386
zooming in and out, 388
viewports
selecting, 874
volumes
calculating, 45, 63
volumes (calculating)
cross sections, 433
watershed subareas
calculating runoff, 545, 556
composite (or weighted) curve number, 555
rainfall frequency, 550
weir calculators, 522
triangular weir values, 528
wetted area, 505
pipe run values, 670
wetted perimeter, 505
pipe run values, 670
width of culverts, 490
WK1 format (import/export files), 707
zooming into and out of cross sections, 388