AutoCAD®
Land Development
Desktop

GETTING STARTED GUIDE
Contents

Chapter 1  Introduction 1

  What is AutoCAD Land Development Desktop?  2
  AutoCAD Land Development Desktop Features  3
  Who Should Use AutoCAD Land Development Desktop?  4
  What’s New in AutoCAD Land Development Desktop Release 2  6
  Upgrading from Autodesk S8 Civil/Survey Products  7
  Where Can You Find the Autodesk S8 Commands You Use Frequently?  9
  Customizing AutoCAD Land Development Desktop with the Object
Model Interface  11
  Using AutoCAD Land Development Desktop to Complete a Project  12
  Collecting Data  13
  Organizing Data  13
  Relationships Between the Project and the Drawings  14
  Relationships Between Drawings  15
  Inputting Data into a Drawing and Project  16
  Defining Data to Databases  17
  Compiling Data to Build Surfaces  19
  Outputting and Evaluating Data  20
  Design Documents  21
  How to Use the Documentation Set  21
  Recommendations for New Users  22
  Path Naming Conventions  23
  How to Use This Guide  23
  Finding Information  24
  How to Use Online Help  25
  How to Use the Online Tutorial  29

Chapter 2  Getting Started with AutoCAD Land Development Desktop  31

  Introduction  32
  Starting AutoCAD Land Development Desktop  32
  The AutoCAD Land Development Desktop Drawing Environment  34
Chapter 3 Working with COGO Points 95

Introduction 96
  Point Appearance: Markers and Labels 97
  Points and CAD Commands 98
Upgrade Information About Points for Users of S8 Civil/Survey 98
Working with the Project Point Database 100
  Setting Up the Point Database 101
Establishing Point Settings 102
  Changing the Point Creation Settings 103
  Changing the Point Marker Settings 104
Working with Points 105
  Creating Points 105
  Importing Points 106
  Setting Up ASCII Files to Import 111
  Exporting Points 112
  Selecting Points by Using Point Filters 112
  Editing Points 114
  Drawing Point and Project Point Synchronization 115
  Performing Geodetic Transformations on Points 116
  Calculating State Plane Coordinates from a Known Latitude and Longitude 117
Managing Points 121
  Controlling Which Points are in the Drawing and Project 121
  Locking and Unlocking Points 122
  Working with Point Groups 123
  Working with Description Keys 126
  Working with External Data References (XDRefs) 132

Chapter 4 Working with Drawing and Editing Tools 137

Introduction 138
Working in Model Space and Layout Mode 138
  Model Space 138
  Paper Space and Layout Mode 140
  Controlling the Display in Floating Viewports 141
Working with AutoCAD Land Development Desktop Drawing Tools to Create
Lines and Curves 142
  Drawing Spiral Curves 143
  Special Lines 144
Working with Basic AutoCAD Commands to Create Objects 145
  Lines 145
  Construction Lines 146
  Polylines 146
  Curved Objects 148
  Curved Lines 148
  Hatch Patterns 149
Working with the Symbol Manager 152
Working with Text 153
  Working with Curved Text 154
  Attaching Notes to Objects 156
  Adding Leaders to a Drawing 157
Digitizing 158
  Choosing a Digitizing Method 159
Working with Editing Tools 160
  Creating a Selection Set with Filters 161
  Editing with Grips 162
  Correcting Mistakes 164
Modifying Drawing Objects 165
  Copying Objects 165
  Moving Objects 166
  Resizing Objects 166
  Inserting Breaks in Objects 167
  Using the Utilities Edit Commands 168
Grouping Objects Together 169
  Creating Blocks 169
Attaching External Drawings 171

Chapter 5 Working with Surfaces 173

Introduction 174
  Using Point, Contour, Breakline, and Boundary Data in Surfaces 175
  Surface Accuracy 176
Working with the Terrain Model Explorer 176
Creating Surface Data 178
  Creating Breaklines to Use in Surface Generation 179
  Creating Contours to Use in Surface Generation 181
  Creating Boundaries to Use in Surface Generation 182
Building Surfaces 183
   Specifying Data for Surfaces 183
   Building a Watershed Model 186
Creating Finished Ground Data for Surfaces 190
Editing Surfaces 191
   Edit History 192
Working with Surface Output and Visualization Tools 192
   Viewing Surface Statistics 193
   Dynamically Viewing Elevation Characteristics of a Surface 193
   Viewing Quick Sections of a Surface 194
   Creating Contours 196
   Creating Contours from a Surface 197
   Using a Surface Boundary to Contour Around a Building or Pond 199
Comparing Two Surfaces to Calculate Volumes 201
Presenting Cut/Fill Results 203
Creating a 3D Map to Present Elevation Conditions 204
Projecting 2D Lines onto a 3D Grid 206

Chapter 6 Creating Cadastral Information 207
Introduction 208
Working with Alignments 208
   Multi-User Alignment Database 209
   Backwards Compatibility with Single-User Alignment Databases 210
   Drawing Alignment Geometry 210
   Defining an Object as a Road Alignment 212
   Making an Alignment Current 213
   Editing a Road Alignment 215
   Deleting and Importing Alignments 216
   Drafting Road Results 218
Working with Parcels 221
   Drawing Parcel Geometry 221
   Defining Parcels to the Parcel Database 223
   Managing Parcels 225

Chapter 7 Listing and Annotating Plans 227
Introduction 228
Listing Object Data 228
   CAD-Based Inquiry Commands 228
   AutoCAD Land Development Desktop Inquiry Commands 229
Chapter 8  AutoCAD Map and AutoCAD Land Development Desktop  239

Introduction  240
Using the AutoCAD Map Project Workspace  241
Map Project Workspace Shortcut Menus  242
Dragging Files  242
Map Projects and Drawing Sets  243
When to Create Drawing Sets  243
Drawing Sets and AutoCAD Land Development Desktop Projects  244
Data Storage  244
Defining Queries  248
The Purposes of Queries  249
Saving Queried Data  252
Inserting Geo-Referenced Images  254
Digitizing Maps  257
Cleaning up Maps  258
Using the Cleanup Command to Break Parcel Lines  259
Checking a Drawing for Crossing Breaklines  261
Assigning Data to Objects in a Drawing  263
Exporting Object Data  263
Performing Zone Conversions Using AutoCAD Map  267
Creating Topologies  269
Node Topologies  269
Network Topologies  270
Polygon Topologies  270
Creating Polygon Topologies and Assigning Data to the Polygons  271
Creating Overlay Topologies  273
Plotting Maps  276

Index  277
Introduction

Using AutoCAD Land Development Desktop, you can create, maintain, output, and analyze all of the data in your land development projects.
What Is AutoCAD Land Development Desktop?

AutoCAD Land Development Desktop Release 2 is part of the Land Development Solutions II suite of applications for professionals in the land planning and development industries. The Land Development Solutions II suite includes:

- **AutoCAD® Land Development Desktop Release 2**: This is the AutoCAD for Land Development professionals. It provides a base level of functionality that meets the needs of everyone in the land development process, including land planners, surveyors, civil engineers, drafters, and anyone who creates supporting documents. AutoCAD Land Development Desktop provides an Application Programming Interface (API), so that other add-on products can be designed to work with AutoCAD Land Development Desktop.

- **Autodesk® Survey Release 2**: An add-on to AutoCAD Land Development Desktop that provides a streamlined ability to communicate survey data to and from the field.

- **Autodesk® Civil Design Release 2**: An add-on to AutoCAD Land Development Desktop that provides transportation and site engineering tools, and hydrology and hydraulics design and analysis.

This guide introduces you to AutoCAD Land Development Desktop. For more information about Autodesk Survey and Autodesk Civil Design, see the *Autodesk Survey User’s Guide* and the *Autodesk Civil Design User’s Guide*.
AutoCAD Land Development Desktop Features

AutoCAD Land Development Desktop provides the core functionality for the land development professional, including project management, points, geometry creation, plan alignments, terrain modeling, volumes calculations, labeling, and much more.

The following illustration shows some AutoCAD Land Development Desktop features.
Who Should Use AutoCAD Land Development Desktop?

The land development industry is very broad. It includes all professionals who manage, analyze, or alter the land, specifically surveyors, civil engineers, land planners, environmental designers, forest managers, hydrologists, GIS analysts, landscape architects, resource managers, and more.

Land development professionals may require different tools to do their jobs. The following table shows these requirements and which programs in Land Development Solutions suite meet these requirements.

### Requirements of land development professionals

<table>
<thead>
<tr>
<th>Professional</th>
<th>Requirements</th>
<th>Land Desktop</th>
<th>Autodesk Survey</th>
<th>Autodesk Civil Design</th>
</tr>
</thead>
<tbody>
<tr>
<td>Land Planner</td>
<td>The ability to view data, terrain models, plans, maps, images, and drawings. The ability to do analysis through queries and topologies to determine land use, development trends, and buildable areas.</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Drafter/CAD Technician</td>
<td>More than what is in standard AutoCAD in order to draft directly from the project data created by other team members.</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Surveyor</td>
<td>Land Desktop plus the data input and collection options in Autodesk Survey.</td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Surveying Technician</td>
<td>Land Desktop plus the data input and collection options in Autodesk Survey.</td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Site Designer</td>
<td>Land Desktop and the grading, hydrology, and piping functionality in Autodesk Civil Design.</td>
<td></td>
<td></td>
<td>x</td>
</tr>
</tbody>
</table>
### Requirements of land development professionals (continued)

<table>
<thead>
<tr>
<th>Professional</th>
<th>Requirements</th>
<th>Land Desktop</th>
<th>Autodesk Survey</th>
<th>Autodesk Civil Design</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roadway Engineer</td>
<td>Land Desktop and the profile and cross-sectional capabilities of Autodesk Civil Design.</td>
<td>❌</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Transportation Engineer</td>
<td>Land Desktop and the profile, cross-sectional, grading, and hydrology capabilities of Autodesk Civil Design.</td>
<td>❌</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Hydrologist</td>
<td>Land Desktop and the run-off analysis capabilities of Autodesk Civil Design.</td>
<td>❌</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Storm Water Manager</td>
<td>Land Desktop and the run-off, pipe layout, pipe design, and drafting capabilities of Autodesk Civil Design.</td>
<td>❌</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Landscape Architect</td>
<td>May require only Land Desktop. May also need grading options and symbols from Autodesk Civil Design.</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Utilities Designer or Analyst</td>
<td>May require only Land Desktop. If gathering field data for existing utilities, will need Autodesk Survey. If designing proposed sewer or storm drain systems or designing a power generation site (such as a hydro-electric dam), will need Autodesk Civil Design.</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Site Grading Engineer</td>
<td>Land Desktop and the grading, ponds, and run-off capabilities of Autodesk Civil Design.</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
What’s New in AutoCAD Land
Development Desktop Release 2

General
- Bug fixes (over 300 deferred defects from R1.0)
- AutoCAD 2000 CAD functionality
- Integrated installation with AutoCAD Map with electronic registration
- DBX support allows interoperability with other AutoCAD programs such as 3D Studio Viz
- Migration of R1 style databases (option during installation)
- Migration of drawings/projects to Release 2, from Release 1 and S8 products
- Backward data compatibility with R1
- ActiveX Object Model Interface that you can use to create custom projects, points, contours, terrain, and alignments commands

Points
- Point Group Manager and List Points display both the FULL and RAW descriptions
- Point objects can be rotated and leaders can be turned off

Alignments
- Multiple-user alignment database

Grading
- Migration of certain grading commands from the Civil Design Grading menu to the Points and Terrain menus

Labels
- “Unretired” Building Offset Label added to Labels menu
Utilities

- Object Viewer includes 3D Orbit interface
- Set Text Style replaced with standard AutoCAD Text Style command
- Layer Manager now supports AutoCAD 2000 lineweights and plot styles
- Build Selection Set dialog box now includes Lineweight
- Curve Solver added to Utilities menu
- Join 3D Polyline command moved to the Terrain menu

Upgrading from Autodesk S8 Civil/Survey Products

This section is for people who are upgrading from Autodesk S8 civil/survey products. Much of the AutoCAD Land Development Desktop technology is based on the Autodesk S8 suite of Civil/Survey products. The Autodesk S8 products have a modular approach, and are add-ons to AutoCAD 14, as shown in the following illustration.
The Land Development Solutions suite of products has much of the same functionality. However, the “AutoCAD” part of the equation (AutoCAD Land Development Desktop) now contains substantial base-level Autodesk S8 Civil/Survey functionality that was in COGO, DTM, Earthworks, Design, and Advanced Design.

The eight Autodesk S8 modules were redesigned to meet the needs of different land development professionals. The commands used by everyone in the design process were added to AutoCAD Land Development Desktop. Release 2 of AutoCAD Land Development Desktop is based on AutoCAD 2000 and AutoCAD Map 2000 functionality.

The survey and civil engineering commands were moved to two add-on products, Autodesk Survey and Autodesk Civil Design. The following illustration shows the new strategy and indicates the new functionality that was added to the suite for Release 1.
Where Can You Find the Autodesk S8 Commands You Use Frequently?

The following table shows where you can find your familiar Autodesk S8 commands:

**NOTE** Some Autodesk S8 commands, such as Change Programs, are no longer needed.

<table>
<thead>
<tr>
<th>If you used in Autodesk S8 Civil/Survey....</th>
<th>The commands are in this program...</th>
<th>In this menu...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced Design Alignment commands</td>
<td>AutoCAD Land Development Desktop</td>
<td>Alignments</td>
</tr>
<tr>
<td>Advanced Design Alignment Point commands</td>
<td>AutoCAD Land Development Desktop</td>
<td>Points</td>
</tr>
<tr>
<td>Advanced Design Spiral commands</td>
<td>AutoCAD Land Development Desktop</td>
<td>Lines/Curves</td>
</tr>
<tr>
<td>Advanced Design Profiles commands</td>
<td>Autodesk Civil Design</td>
<td>Profiles</td>
</tr>
<tr>
<td>Advanced Design Sections commands</td>
<td>Autodesk Civil Design</td>
<td>Cross Sections</td>
</tr>
<tr>
<td>Advanced Design/Design Sheet Manager</td>
<td>Autodesk Civil Design</td>
<td>Sheet Manager</td>
</tr>
<tr>
<td>AEC Tools</td>
<td>AutoCAD Land Development Desktop</td>
<td>Projects, Utilities</td>
</tr>
<tr>
<td>COGO</td>
<td>AutoCAD Land Development Desktop</td>
<td>Points, Lines/Curves, Labels</td>
</tr>
<tr>
<td>Design Lots commands</td>
<td>AutoCAD Land Development Desktop</td>
<td>Parcels</td>
</tr>
<tr>
<td>Design Pipes commands</td>
<td>Autodesk Civil Design</td>
<td>Pipes</td>
</tr>
<tr>
<td>If you used in Autodesk S8 Civil/Survey....</td>
<td>The commands are in this program...</td>
<td>In this menu...</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Design Intersections and Cul-de-sacs commands</td>
<td>Autodesk Civil Design</td>
<td>Layout</td>
</tr>
<tr>
<td>DTM</td>
<td>AutoCAD Land Development Desktop</td>
<td>Terrain</td>
</tr>
<tr>
<td>Earthworks Volumes commands</td>
<td>AutoCAD Land Development Desktop</td>
<td>Terrain</td>
</tr>
<tr>
<td>Earthworks Grading commands (daylighting, stratum points)</td>
<td>Autodesk Civil Design</td>
<td>Grading</td>
</tr>
<tr>
<td>Earthworks Grading commands (points, 3D polylines, contours)</td>
<td>AutoCAD Land Development Desktop</td>
<td>Points, Terrain</td>
</tr>
<tr>
<td>Hydrology Pond commands</td>
<td>Autodesk Civil Design</td>
<td>Grading, Hydrology</td>
</tr>
<tr>
<td>Hydrology Structure, Runoff, and Output commands</td>
<td>Autodesk Civil Design</td>
<td>Hydrology</td>
</tr>
<tr>
<td>Landscape</td>
<td>AutoCAD Land Development Desktop, Autodesk Civil Design</td>
<td>Some symbols have been added to the Symbol Manager in the Utilities menu. Some commands are in the Autodesk Civil Design Layout menu.</td>
</tr>
<tr>
<td>Listing commands</td>
<td>AutoCAD Land Development Desktop</td>
<td>Inquiry</td>
</tr>
<tr>
<td>Autodesk Survey Command Line commands</td>
<td>Autodesk Survey</td>
<td>Data Collection/Input</td>
</tr>
<tr>
<td>Autodesk Survey Data Collection commands</td>
<td>Autodesk Survey</td>
<td>Data Collection/Input</td>
</tr>
<tr>
<td>Autodesk Survey Fieldbook commands</td>
<td>Autodesk Survey</td>
<td>Data Collection/Input</td>
</tr>
</tbody>
</table>
Cross referencing Autodesk S8 and AutoCAD Land Development Desktop commands (continued)

<table>
<thead>
<tr>
<th>If you used in Autodesk S8 Civil/Survey....</th>
<th>The commands are in this program...</th>
<th>In this menu...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autodesk Survey Figure commands</td>
<td>Autodesk Survey</td>
<td>Analysis/Figures</td>
</tr>
<tr>
<td>Autodesk Survey Traverse and Sideshot commands</td>
<td>Autodesk Survey</td>
<td>Analysis/Figures</td>
</tr>
</tbody>
</table>

If you are upgrading to AutoCAD Land Development Desktop from Autodesk S8, then use to look up “What’s New in AutoCAD Land Development Desktop” in the online Help.

Customizing AutoCAD Land Development Desktop with the Object Model Interface

The Object Model Interface, or OMI, exposes AutoCAD Land Development Desktop objects through an ActiveX® interface. You can program these objects using the Visual Basic® for Applications programming environment, AutoCAD Development System® (ADS), Visual LISP™, Visual Basic®, Visual C++® or any other programming language that supports ActiveX Automation.

The OMI lets you manage your Land projects, drawings and settings, and gives you access to the data in your Land projects such as COGO points, point groups, surfaces, and alignments. Because it is built on COM (the Component Object Model), you get interoperability with other Windows® applications, such as Microsoft Excel® and Microsoft Word®. And because the OMI is fully integrated with the AutoCAD object model, you get a complete API for developing anything from simple utilities to complete add-on applications.

For more information about the Object Model Interface, use to look up “Object Model” in the online Help.
Using AutoCAD Land Development Desktop to Complete a Project

The process of land development is highly iterative. AutoCAD Land Development Desktop makes it easy to add new data at any step of the project. A typical project begins with capturing data in the field. Back in the office, you can use AutoCAD Land Development Desktop to set up an organizational structure for the project, and then you can input the data into the project and drawing.

After you input the raw data, you can define and transform it so that the definitions are saved to external databases. You can then build a surface that represents the terrain of the job site. You can analyze data in a variety of ways to determine if the site is sufficient. If so, you can create design documents by labeling and plotting out the drawings. If not, you can input more data, edit existing data, and then recompile the surface data.

You can edit data all along, at each step. You can output results, input more data, and then output new results. The following diagram is a simplified representation of the flow of a typical project that you can do with AutoCAD Land Development Desktop.
Collecting Data

Points are the most common form of data. While AutoCAD Land Development Desktop cannot help you collect data, it provides easy ways for you to import and create points in the drawing. Autodesk Survey has the data collector support built in, as well as support for our standard .fbk (fieldbook) format. Points are saved automatically to the project point database when you create or import them.

Other data sources can include contour maps and raster images. To make this data useful, you may need to digitize it with one of the AutoCAD Land Development Desktop digitizing tools.

Organizing Data

AutoCAD Land Development Desktop is structured around projects. You create AutoCAD .dwg files, as well as create and maintain many project files stored outside the drawing files. This management system allows many people to share the same project data.

AutoCAD Land Development Desktop uses projects to help you organize all the drawing files, support data files, and settings associated with each job that you work on. You must assign every drawing you create to a project in order to run AutoCAD Land Development Desktop commands.

When you create a project, a folder is created in Windows Explorer under the project folder. Database files and drawings are stored here.
When you install AutoCAD Land Development Desktop, a project folder (c:\Land Projects R2 by default) is created. Each project is represented by a subfolder of this root project folder. For example, if you create a project named NEWPROJ, then AutoCAD Land Development Desktop creates a \Land Projects R2\newproj folder.

Within the project folder, sub folders are created by the program for storing data. For example, inside the \cogo folder, the point database is stored, and an \alignments folder is created when you define an alignment in your project. We suggest that you store your drawing files for a project within the \dwg folder in the project folder.

**Relationships Between the Project and the Drawings**

You can associate many different drawings with the same project data. The following diagram shows the project and drawing relationship. Drawings 1, 2, and 3 are part of the same project.

![Diagram](image)

Many databases are saved outside of drawings in the project folder, so that each drawing in the project can access the information. For example, all the point data is stored in points.mdb. By keeping the point database at the project level, multiple people working on a project can access the point information.

When you start a new drawing in the project, you can quickly update that drawing with all the project data by inserting points from the project point database, importing alignments and parcels that are defined to the project, and by opening surfaces in the project.

For more information about projects, see “Working with Projects” in Chapter 2, “Getting Started with AutoCAD Land Development Desktop.”
Relationships Between Drawings

Another way to organize your data, on the drawing-level, is to use the built-in AutoCAD Map functionality to attach drawings to the Map project by using AutoCAD Map’s Attach command.

NOTE The AutoCAD Map “project” is a drawing file that lists and controls the items that are defined for the current work session. It does not manage the AutoCAD Land Development Desktop project data based on the current Land Desktop project that you are working in, and is not project-specific.

A group of drawings attached to the Map project is called a drawing set. By creating a drawing set and running queries, you can work with information from more than one drawing at a time while viewing all the information in the Map project.

The following diagram shows how you can copy information from Drawings 1, 2, and 3 into the Map project using queries. Drawings 1, 2, and 3 are referred to as source drawings. When you are working in the Map project, you can use the information from the other drawings as references, or edit the objects and save the edits back to the source drawings.

For more information about drawing sets, see “Map Projects and Drawing Sets” in Chapter 8, “AutoCAD Map and AutoCAD Land Development Desktop.”
Inputting Data into a Drawing and Project

The most common way to input data into a project is to import or create points. Other methods include digitizing, drawing geometry, and using xrefs (a drawing attached to another drawing).

When you import or create points, the point data is always stored in the point database (points.mdb). You can insert points into the drawing when you create or import the points, or you can insert them at a later time when you need to work with them. The points do not need to be in the drawing for you to reference the point objects or build a surface based on the points.

The other data input methods involve creating objects directly in the drawing and referencing external databases.

The following diagram shows the type of information you can input, and where the data is created (in the project, the drawing, or both). For example, if you import points, you can import them into the project only, or into the drawing and the project.
Defining Data to Databases

By default, points are always saved to the project point database. But there are other objects that you must define to databases yourself, transforming simple geometry to objects with extended entity data. You can also assign data to objects in your drawing using the AutoCAD Map functionality, and organize topologies in order to analyze spatial relationships.

Objects that you can define to databases include alignments, parcels, and breaklines. For example, to create an alignment, you first draw the alignment geometry, such as lines and curves. These are simple CAD objects stored in the drawing file.

Next, you must define the alignment to the alignment database, which saves information about the points of intersection, stations, and so on, in an external file, which you can edit in the Horizontal Alignment Editor.

![Horizontal Alignment Editor](image)

Using AutoCAD Land Development Desktop to Complete a Project
If you want to create maps that show spatial relationships, you can define regions and objects as parts of topologies. In the following illustration, the alignment is actually a dividing boundary between buildable land and wetlands. Using the AutoCAD Map topology features, you can assign object data to polygonal areas and query the total area of buildable land.
Compiling Data to Build Surfaces

The end result of data collection and input is often a surface model like a TIN (Triangulated Irregular Network) that represents the surface of a parcel of land in three dimensions. This surface is invaluable to anyone evaluating a site. From this surface, you can perform slope analysis and generate watershed models, contour maps, and volumes.

To build a surface, you must choose the objects to use for creating the surface, such as points, contours, breaklines, and boundaries. You can then build the surface as shown in the following diagram.

After you build the surface, you can edit the TIN lines, add new lines or points, and flip triangle faces. You can build the surface again, if needed, and apply the same edits as before, which are saved to the surface’s Edit History folder.
Outputting and Evaluating Data

AutoCAD Land Development Desktop has several commands that you can use to list and report object data for evaluation. Surfaces have the greatest variety of analysis and outputting options.

After you create a surface, you can use several different methods to evaluate the surface that is created, as illustrated below.

For evaluating the surface, you can generate contours and label them. You can create quick cross sections and profiles that display in their own dialog box, or you can create final cross sections to plot. Watershed models, waterdrop trails, and slope arrows can help you evaluate the need for site runoff control. The 3D viewing tools, including the object viewer, can help you visualize the surface in 3D. You can perform volume calculations if you want to compare two surfaces to calculate cut, fill, and net volumes.

Other output options include parcel and alignment reports, tracking the elevation of a surface as you pass your cursor over it, and listing geodetic information about points and lines.
Design Documents

After your project is completed, you can create final labels and plot the drawing. If your project is based on AutoCAD Map you can configure the plotter to print the maps in tiles. You can also create legends for the maps that you print. Using Autodesk Civil Design, you can also create automated plan/profile and section sheets for road alignments and profiles with the Sheet Manager commands.

To annotate a drawing, you can label Coordinate Geometry features such as lines, curves, spirals, and points. If desired, you can create tables in a drawing that list the details of the geometry.

You can label geometry with either dynamic or static labels. Dynamic labels are automatically updated if the objects or the label styles change—this is a big time-saver because you do not need to manually update each label if the drawing objects are edited or if the label style changes.

Other labeling options include alignment station labels and contour labels.

For more information about working with AutoCAD Land Development Desktop, see Chapter 2, “Getting Started with AutoCAD Land Development Desktop.”

How to Use the Documentation Set

The documentation set for AutoCAD Land Development Desktop includes both online Help files and printed documentation. Because AutoCAD Land Development Desktop combines the technology of AutoCAD and AutoCAD Map along with the Land Desktop features, the online AutoCAD and AutoCAD Map documentation is also included in the documentation set.
AutoCAD Land Development Desktop documentation provides help with commands in the Projects, Points, Lines/Curves, Alignments, Parcels, Labels, Terrain, Inquiry, and Utilities menus.

AutoCAD documentation provides help with commands in the File, Edit, View, Insert, Format, Tools, Draw, Dimension, and Modify menus.

AutoCAD Map documentation provides help with commands in the AutoCAD Map menu.

Your AutoCAD Land Development Desktop documentation set includes the following documents:

- AutoCAD Land Development Desktop Installation Guide (printed).
- AutoCAD Land Development Desktop Getting Started Guide (printed).
- AutoCAD Land Development Desktop User’s Guide (printed and online).
- AutoCAD Land Development Desktop Tutorial (online).
- AutoCAD Land Automation Reference Help (online).
- AutoCAD Learning Assistance™ (online).
- A complete set of online AutoCAD documentation.
- A complete set of online AutoCAD Map documentation.

NOTE: See your Read This First card for information about ordering printed copies of the AutoCAD User’s Guide and the AutoCAD Map User’s Guide.

Recommendations for New Users

This guide—the AutoCAD Land Development Desktop Getting Started Guide—is a good introduction to the main concepts and functionality of the program.

The AutoCAD Land Development Desktop Tutorial is an excellent way to become familiar with tasks that you can perform with the programs. The tutorial has step-by-step lessons that you can do independently of each other.

Autodesk Official Training Courseware (AOTC) is available for more in-depth study of Autodesk AEC products and their applications, and gives you the chance to work through a project using the software. For information about how to order AOTC materials, go to www.autodesk.com/aotc.
How to Use This Guide

If you have never used AutoCAD, then you may want to start by using the AutoCAD Learning Assistance CD to learn the CAD basics of AutoCAD Land Development Desktop.

AutoCAD Land Development Desktop has an AutoCAD Map menu that contains all the functionality of AutoCAD Map 2000. If you have never used AutoCAD Map 2000, then you may want to start learning the program by using the mapping tutorials in the AutoCAD Map User’s Guide.

Path Naming Conventions

When referring to the AutoCAD Land Development Desktop program folder, the documentation uses the following convention to represent the program path:

`c:\Program Files\Land Desktop R2`

Of course, if you installed the program on another drive or if you used another folder name, please substitute that path for the path described in the documentation.

When you install the program, a folder for storing your project data is also created. The documentation uses the following convention for the project path:

`c:\Land Projects R2`

If you installed the program on another drive, or you renamed the project folder, please substitute that path for the path described in the documentation.

How to Use This Guide

This guide introduces you to AutoCAD Land Development Desktop. Each chapter focuses on one or two areas of the land development process. Each topic in a chapter describes how you can use one or more commands to complete a project task. This is not a reference manual that describes in detail how to use each command in each menu. However, this guide can give you an overall idea of how to use AutoCAD Land Development Desktop to complete your land development projects.

You can use this guide along with the online Help, the online tutorial, the user’s guide, and the courseware to learn how to use AutoCAD Land Development Desktop.
The following sections describe terms that this guide uses when referring to Help files, how to access Help and the tutorials, and what each file looks like.

**Finding Information**

In many sections of this guide, you are referred to topics in the online Help for more information. For example:

![Book Icon]

For more information about alignments, use ![Find Icon] to look up “Overview of Horizontal Alignments” in the online Help.

In the example, the Book icon ![Book Icon] represents that you can find more general information in a Help file. The Find icon ![Find Icon] represents the Find tab on a Help Contents window. You can use the search mechanism on the Find tab to locate specific topic titles or topics that match certain keywords.

Some sections in this guide have numbered steps that you can perform to complete a task, such as setting up the point database. To the right of certain steps in a task are titles of relevant Help topics. For example:

<table>
<thead>
<tr>
<th>Step</th>
<th>Use ![Find Icon] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>From the Points menu, choose Point Management ➤ Point Database Setup to display the Point Database Setup dialog box.</td>
</tr>
</tbody>
</table>

This example shows that you can use the Find tab in the online Help to locate the topic, “Change the Point Database Settings.”
# How to Use Online Help

You can access Help files for AutoCAD Land Development Desktop by using the following methods:

<table>
<thead>
<tr>
<th>Method</th>
<th>Result</th>
<th>Benefits</th>
</tr>
</thead>
<tbody>
<tr>
<td>From the AutoCAD Land Development Desktop R2 program group, select the AutoCAD Land Development Desktop R2 Online Help icon.</td>
<td>Displays a Contents tab that lists the Help files and the tutorial for AutoCAD Land Development Desktop. Includes links to AutoCAD Help and AutoCAD Map Help.</td>
<td>This Help file displays a combined index and table of contents, as well as a combined search mechanism so you can find the Help topics you need.</td>
</tr>
<tr>
<td>From within AutoCAD, choose Help Topics from the Help menu, type <code>Help</code> on the command line, or press F1.</td>
<td>Same result as described above.</td>
<td>Same benefits as described above.</td>
</tr>
<tr>
<td>Move your pointer over a command in a menu using the up and down keyboard arrows and press F1.</td>
<td>Displays the Help topic that describes the commands in the menu.</td>
<td>This topic has links to specific Help topics for the commands in the menu.</td>
</tr>
<tr>
<td>From a dialog box, click a Help button.</td>
<td>Displays the Help topic that describes how to use the dialog box.</td>
<td>This topic provides the information you need without having to search for it.</td>
</tr>
<tr>
<td>From within AutoCAD, choose AutoCAD Learning Assistance from the Help menu.</td>
<td>Displays AutoCAD Learning Assistance.</td>
<td>The Learning Assistance is a multimedia tutorial you can use to learn AutoCAD concepts.</td>
</tr>
</tbody>
</table>

**NOTE** You must insert the Learning Assistance CD-ROM into your CD-ROM drive in order to run the Learning Assistance.
When you open a Help file from either the Help menu or the Help icon, the Help Topics window is displayed, as shown in the following illustration.

This window has three tabs: Contents, Index, and Find.

- Click the Contents tab to view the Table of Contents. This tab has books with topic pages listed below each book. To view a topic, double-click the page, or select the page and click Display. You can select a book and click Print to print the all the pages in that book if you would rather have a paper copy of the information.
- Click the Index tab to view an index of Help topics. You can double-click any index entry to view the topic for that entry. If more than one topic shares the same index entry, then you can choose the topic that you want to view.
- Click the Find tab to perform a search on specific words, for example, to search for Help topic titles that are listed in this guide.
The following illustration shows a typical Help topic.

When you view a Help topic, you can use the menus and buttons to control options and to navigate. You can also access a shortcut menu by right-clicking in the Help window.

**Key Concepts**

- When a topic is open, you can move to other relevant topics or definitions by selecting the green, underlined text.

- You can click **Back** to move to the previous topic that you viewed.

- You can click **Help Topics** to return to the Help Topics window.

- To print a topic that is displayed in a popup window (a Help window that has no menu options and disappears if you click elsewhere on your screen), right-click to display a shortcut menu, and click **Print**.
The following task shows you how to locate a topic title in the Help file.

**To use the online Help to locate a topic title**

**Steps**

1. Start Help by using one of the methods listed in the Accessing Help Files list in “How to Use Online Help” in this chapter.

2. Click **Find**.

   The Help window appears as shown in the following illustration.

   ![Help window with Find tab](image)

   **NOTE** If you have not previously used the Find tab, then the Find Setup Wizard prompts you to create a word search database. Click Next to proceed through the wizard. When the wizard has created the database, the Find tab is displayed.

3. In the first edit box on the Find tab, type the Help topic title that you want to find. Each topic that has similar keywords is displayed in the third box on the dialog box.

4. Scroll down to the topic title you are searching for.

5. Click the name of the topic, and then click Display to view the Help topic.

6. You can print the topic by selecting Print; you can view relevant topics by clicking the green, underlined text; or you can return to the Find tab by clicking Help Topics.
How to Use the Online Tutorial

AutoCAD Land Development Desktop has an online tutorial that you can use to learn the program’s concepts. The online tutorial is an excellent way to become familiar with the program.

You can access the tutorial using the following methods:

- From the AutoCAD Land Development Desktop R2 program group, select the AutoCAD Land Development Desktop R2 Online Help icon.
- From within the program, choose Help Topics from the Help menu.

When the online Help is displayed, open the AutoCAD Land Development Desktop tutorial book and select the AutoCAD Land Development Desktop Tutorial page.

The tutorial is displayed in a small window that you can keep open on top of your screen while you perform the steps. The tutorial is set up in lessons that you can perform sequentially or non-sequentially.

If you want to hide the window while you perform the steps, then choose Not on Top from the Options ➤ Keep Help On Top menu.
Getting Started with AutoCAD Land Development Desktop

To start working with AutoCAD Land Development Desktop, you need to know the basics of operating the program. These basics include menu palettes, and project, prototype, and drawing management.
Introduction

This chapter describes how to get started using AutoCAD Land Development Desktop. It explains how to:

- Start the program
- Access commands
- Establish settings
- Work with drawings
- Work with projects and prototypes

This chapter also covers basic CAD management tools and utilities, such as:

- Layer management
- Transparent commands
- Text window
- Profiles
- Zoom and Pan
- Object Snaps
- Drawing and screen views
- Plotting
- Saving and exiting

Starting AutoCAD Land Development Desktop

To start AutoCAD Land Development Desktop, select the AutoCAD Land Development Desktop R2 icon in the AutoCAD Land Development Desktop R2 program group or from the Windows desktop.
When you start AutoCAD Land Development Desktop, the Start Up dialog box is displayed, as shown in the following illustration.

If you do not want to see this dialog box every time you open AutoCAD Land Development Desktop, then clear the Show this dialog at startup check box. To redisplay this dialog box, use the User Preferences command on the Projects menu.

To use AutoCAD Land Development Desktop, you must be working in a project. If you do not create a new drawing or open an existing drawing when you start up the program, then you are prompted to select or create a project the first time that you select an AutoCAD Land Development Desktop command.

**NOTE** You can run multiple sessions of AutoCAD Land Development Desktop Release 2 on one computer. However, within each session, only one drawing can be open at a time.
The AutoCAD Land Development Desktop Drawing Environment

After you initialize AutoCAD Land Development Desktop, the drawing environment appears as shown in the following illustration:

The menus that are displayed by default are the menus in the AutoCAD Land Development Desktop menu palette. For more information about menu palettes, see “Selecting a Menu Palette” in this chapter.
The AutoCAD Map Project Workspace is shown by default. You can use the Project Workspace to attach drawings to the current Map "project" (which is the current drawing), to define queries, and attach databases. For more information see “Using the AutoCAD Map Project Workspace” in Chapter 8, “AutoCAD Map and AutoCAD Land Development Desktop.”

The following topic, “Accessing AutoCAD Land Development Desktop Commands” describes how to access AutoCAD Land Development Desktop commands by using menu palettes, shortcut menus, toolbars, the status bar, and the command line.

### Accessing AutoCAD Land Development Desktop Commands

You can access AutoCAD Land Development Desktop commands in a variety of ways. All the commands are available from the pull-down menus, and you can select some commands from toolbars, shortcut menus, or by typing them on the command line. Many AutoCAD Map commands are available from shortcut menus in the Map Project Workspace, as well as from the Map pull-down menu. With a little practice, you can find the method that works best for you.

You can control which pull-down menus and toolbars are displayed by selecting a menu palette. To use AutoCAD Land Development Desktop commands, use the Land Desktop R2 menu palette (loaded by default when you start the program). You must load the Survey R2 menu palette to access the Autodesk Survey commands, and you must load the Civil Design R2 menu palette to access the Autodesk Civil Design commands.

You can also customize your own menu palettes. For more information about menu palettes, see “Selecting a Menu Palette” and “Customizing a Menu Palette” in this chapter.

### Key Concepts

- When you run a command, prompts and messages appear on the command line. You can view the history of what has appeared on the command line since you started the current drawing session by displaying the AutoCAD text window that records the commands. For more information, see “Text Window” in this chapter.
- To quit a command at any time, press ESC.
AutoCAD Land Development Desktop has additional context-sensitive menus that you can access by selecting an object and right-clicking. For more information, see “Shortcut Menus” in this chapter.

For more information about accessing commands, use the find tool to look up “Understanding the AutoCAD Window” in the online Help.

For more information about the Map Project Workspace, see “Using the AutoCAD Map Project Workspace” in Chapter 8, “AutoCAD Map and AutoCAD Land Development Desktop.”

**Pull-Down Menus**

You can access most commands and dialog boxes by using the pull-down menus on the menu bar at the top of the AutoCAD Land Development Desktop window.

**Key Concepts**

- After you select a pull-down menu, choose a command by clicking its name.
- Shaded command names on pull-down menus are not available at that point in the drawing session.
- Ellipses ( . . . ) following a command name indicate that further options are displayed in a dialog box.
- An arrow ( ➤ ) following a command name indicates that another menu is displayed.
You can access pull-down menus and commands in the following ways:

- Select a pull-down menu by clicking the menu name to display a list of commands, or press ALT and the underlined letter of the menu name. For example, to access the Points menu, hold down the ALT key and press the s key (hereafter: ALT + s).
- Select a command on a pull-down menu by clicking its name.
- You can run some commands by typing the whole command name at the Command prompt. For more information, see “Command Line” in this chapter.

Selecting a Menu Palette

When you first start AutoCAD Land Development Desktop, the menu bar appears as shown in the following illustration.

This is the default AutoCAD Land Development Desktop menu palette. This menu palette contains all AutoCAD Land Development Desktop commands, as well as the AutoCAD Map commands and the AutoCAD File, Edit, and View menus.

To change the group of menus, you can select a different menu palette.

To select a menu palette

Steps

1. From the Projects menu, select Menu Palettes to display the Menu Palette Manager.

Select a Menu Palette
To select a menu palette (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use \texttt{F4} to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Choose a menu palette to load.</td>
</tr>
<tr>
<td>3</td>
<td>Under Description, the names of the pull-down menus in that selected menu palette are displayed.</td>
</tr>
<tr>
<td>4</td>
<td>After you have selected the menu palette, click Load.</td>
</tr>
</tbody>
</table>

A quicker way to load a menu palette is to use a macro. For more information about menu palette macros, look up “AutoCAD Land Development Desktop Macros” in the online Help.

For more information, use \texttt{F4} to look up “Overview of Menu Palettes” in the online Help.

Customizing a Menu Palette

To customize a menu palette, you can add other menus to an existing menu palette, or you can create a new menu palette. For example, if you own Autodesk Civil Design, then you could add the Autodesk Civil Design Grading menu to the AutoCAD Land Development Desktop menu palette so that you always have access to the Grading commands.

To create a menu palette, load the menus that you want to save to the menu palette by using the MENULOAD command, and then use the Menu Palette Manager to save the palette.

**NOTE** In AutoCAD Land Development Desktop Release 2, toolbars cannot be saved as part of menu palettes.

Create a Custom Menu Bar

You can customize the menu bar and create your own menu palettes to contain commands that you use often. For example, you can set up an Annotation menu palette that contains the AutoCAD Dimension menu and the AutoCAD Draw menu. If you create a new menu palette, then you can name and save it so that you can recall it and use it at any time.
To create a menu palette

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use F1 to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>On the command line, type <strong>menuload</strong> to display the Menu Customization dialog box. <strong>MENULOAD Command</strong></td>
</tr>
<tr>
<td>2</td>
<td>Click the Menu Bar tab, and under Menu Group choose a menu name from the list. For example, if you want to add AutoCAD menus to the menu bar, then choose ACAD.</td>
</tr>
<tr>
<td>3</td>
<td>Under Menus, choose a pull-down menu from the list.</td>
</tr>
<tr>
<td>4</td>
<td>Under Menu Bar, select a menu name on the list before which you want to place the menu from the Menus list. The order of the Menu Bar list duplicates the order from left to right of the menus on the menu bar.</td>
</tr>
<tr>
<td>5</td>
<td>Click Insert &gt;&gt;. <strong>NOTE</strong> You can also remove menus from the Menu Bar list by clicking &lt;&lt;Remove.</td>
</tr>
<tr>
<td>6</td>
<td>After you finish adding the menus to the menu bar, click Close.</td>
</tr>
<tr>
<td>7</td>
<td>To save this customized menu bar as a palette, select Menu Palettes on the Projects menu. <strong>Save a Menu Palette</strong></td>
</tr>
<tr>
<td>8</td>
<td>In the Menu Palette Manager, click Save. <strong>Change the Name or Description of a Menu Palette</strong></td>
</tr>
<tr>
<td>9</td>
<td>Type the name and description of the new palette, and click OK.</td>
</tr>
</tbody>
</table>
**Toolbars**

When you start AutoCAD Land Development Desktop, the following toolbars are displayed:

- AutoCAD: Modify and Draw
- AutoCAD Map: Drawing Set and Map

To learn how to display the AutoCAD Land Development Desktop toolbars, see the task at the end of this topic.

You can display other toolbars with various tool categories. Each toolbar contains a set of tools that represents specific commands in a category. Start a command by clicking a tool. To identify a tool, move your pointer slowly over the tool. A small label, or ToolTip, displays the tool name.

**Key Concepts**

- You can work with toolbars from three categories: the standard AutoCAD toolbars, AutoCAD Map toolbars, and AutoCAD Land Development Desktop toolbars.
- Toolbars can float within the graphics area, or you can organize them as needed by docking them at the top, bottom, or sides of the graphics area.
- To turn a toolbar on or off, select or clear the check box next to its name in the Toolbars dialog box. You can also close a toolbar by clicking the Close button in the toolbar's upper-right corner.
- You can customize a toolbar by adding and removing tools or creating new tools.
- You can enhance an existing toolbar by creating a flyout toolbar.

Tools in the flyout toolbar are nested under the Flyout icon (indicated by a black triangle in the lower-right corner). You can replace the Flyout icon with any icon, and then associate a toolbar with it.
To display AutoCAD Land Development Desktop toolbars

**Steps**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use (\text{Frd}) to look up</th>
</tr>
</thead>
</table>
| 1     | From the View menu, select Toolbars. \(\text{TOOLBAR Command}\)  
You can also move your cursor over any toolbar and then right-click to display a shortcut menu, and then select Customize. |
| 2     | In the Toolbars dialog box, under Menu Group, select Land to display specific Land Development Desktop toolbars. |
| 3     | Under Toolbars, select a check box on the list to display that toolbar.  
To close or hide the toolbar, clear the check box. |

For more information, use \(\text{Frd}\) to look up “Creating and Deleting Toolbars” in the online Help.

**Status Bar**

The status bar at the bottom of the AutoCAD Land Development Desktop window displays the \(X,Y\) coordinates of the current cursor location and the status of frequently used modes.

![Status Bar](image)

**Key Concepts**

- You can view the coordinate values of your current cursor location in the left section of the status bar. There are three display options for coordinates. For more information, see “Displaying Coordinates of the Current Cursor Location” in the online Help.
- Double-click the drawing aids SNAP, GRID, ORTHO, POLAR, OSNAP, OTRACK, and LWT to turn them on and off.
- If you have not specified any running object snaps before selecting a command, then you can specify the object snap settings by double-clicking OSNAP to display the Drafting Settings dialog box. For more information, see “Transparent Commands” in this chapter.

Accessing AutoCAD Land Development Desktop Commands
Double-click MODEL/PAPER to switch between paper space and model space when the drawing is in Layout mode. For more information, see “Working in Model Space and Layout Mode” in Chapter 4, “Working with Drawing and Editing Tools.”

For more information, use to look up “Understanding the AutoCAD Window” in the online Help.

Shortcut Menus

Shortcut menus provide quick access to display, editing, and labeling commands. AutoCAD Land Development Desktop shortcut menus are context sensitive and display different commands, depending on the type of object selected. For example, if you select a polyline and then right-click, a shortcut menu with specific options for lines is displayed, as shown in the following illustration.
Key Concepts

- AutoCAD Land Development Desktop has a shortcut menu for grip editing. Select an object in the drawing to display the grips, select a grip, and then right-click to display the shortcut menu. For more information, see “Working with Editing Tools” in Chapter 4, “Working with Drawing and Editing Tools.”
- While you are using real-time panning and zooming, you can right-click to display shortcut menus with specific options for those commands.

To display the default drawing tools shortcut menu, hold down the SHIFT key and right-click. The shortcut menus are displayed at the cursor location. For more information, see “Using Shortcut Menus” in the online Help.

Command Line

You can access commands from menus or toolbars by typing them on the command line. At the Command prompt, enter either the whole command name or the abbreviated name called a command alias, and then press ENTER, the SPACEBAR, or right-click.

To use the same AutoCAD command consecutively, type `multiple` before the command name. For example, if you plan to draw more than one identical circle, type `multiple circle`.

During the drawing session, pay attention to the command line. Many commands display prompts with further options, and other commands display a dialog box. If you want to respond to prompts on the command line and suppress the display of a dialog box, then enter a hyphen (`-`) before the command name or command alias. For example, if you enter `osnap` on the command line, then the Drafting Settings dialog box is displayed. If you enter `-osnap`, then you can set the object snap modes on the command line. There are slight differences between command line options and dialog box options.
For more information about dialog box options available on the command line, see “Switching from Dialog Box to Command Line” in the online Help.

For a list of abbreviated command names, use \[fnf\] to look up “AutoCAD Land Development Desktop Macros” and “Command Aliases” in the online Help.

**Transparent Commands**

You can use the command line to access a second command without leaving the first command. To use a command transparently, type an apostrophe (') before the command name on the command line. For example, if you are using LINE to draw a line, you can type `zoom ('z)` or `pan ('p)` to change the view of the drawing and the LINE command remains active. After you have finished using a command transparently, the suspended command continues.

**NOTE**

The only commands that you can use transparently are commands that do not select or create objects or regenerate or end drawings.

**Key Concepts**

- You can use a command transparently by selecting it from a menu or toolbar.
- Whenever a command name is documented with a leading apostrophe, you can use the command transparently.
- Drafting commands, such as `snap`, `grid`, and `ortho`, are often used transparently.
- After you enter a transparent command name on the command line, double-angle brackets (>>) precede the prompts to indicate that the command is being used transparently.

For more information, use \[fnf\] to look up “Using Commands Transparently” in the online Help.
Text Window

The text window expands from the command line and you can view a complete history of commands that you used for the current drawing session. You can also use the text window to select options.

Press F2 to open the text window, and then press F2 again to return to the drawing window. The text window also displays information whenever you use inquiry commands.

For more information, use Help to look up “Working with the Text Window” in the online Help.
Using AutoCAD Land Development Desktop with Windows

You can use several commands in the Standard toolbar to edit objects in drawings. You can copy or remove an object from a drawing to the Clipboard and then paste the object from the Clipboard into another document.

The following table lists the Windows tools and how you can use them in AutoCAD Land Development Desktop. For example, use Print Preview to view a full page of the plotted drawing in a WYSIWYG window. For more information, see “PREVIEW Command” in the online Help.

NOTE Some Windows tools behave differently in AutoCAD Land Development Desktop. For example, COPYCLIP is not the same as the AutoCAD COPY command and CUTCLIP is not the same as ERASE, and so on. For more information, see “Standard Toolbar” in the online Help.

<table>
<thead>
<tr>
<th>Windows tools</th>
<th>Tool</th>
<th>Shortcut Key</th>
<th>Command Line</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ctrl+n</td>
<td>new</td>
<td>Displays the AutoCAD Land Development Desktop New Drawing - Project Based dialog box.</td>
<td>For more information about setting up a drawing that is associated with a project, see “Creating New Drawings” in this chapter.</td>
</tr>
<tr>
<td></td>
<td>ctrl+o</td>
<td>open</td>
<td>Displays the AutoCAD Land Development Desktop Open Drawing - Project Based dialog box.</td>
<td>For more information, see “Opening Drawings” in this chapter.</td>
</tr>
</tbody>
</table>
### Windows tools (continued)

<table>
<thead>
<tr>
<th>Tool</th>
<th>Shortcut Key</th>
<th>Command Line</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![save icon]</td>
<td>ctrl+s</td>
<td>save</td>
<td>Saves the current drawing.</td>
</tr>
</tbody>
</table>
| ![plot icon] | ctrl+p | plot | Displays the Plot dialog box.  
For more information, see “Plotting Your Drawings” in this chapter. |
| ![preview icon] | preview | Displays a preview of the drawing as it would appear on a sheet of paper.  
Press ESC to return to the drawing. |
| ![find icon] | find | Displays the Find and Replace dialog box, which you can use to search for text strings and replace them. |
| ![cut clip icon] | ctrl+x | cutclip | Removes the block from the drawing to the Clipboard. You can retrieve the block by using the Pasteclip tool.  
**WARNING!** This tool does not start the ERASE command. See “Using AutoCAD Information in Other Applications” in the online Help. |
| ![copy clip icon] | ctrl+c | copyclip | Copies the selected object to the Clipboard as a block. You can retrieve the block by using the Pasteclip tool.  
**WARNING!** This tool does not start the COPY command. See “Using AutoCAD Information in Other Applications” in the online Help. |
| ![paste clip icon] | ctrl+v | pasteclip | Inserts a block from the Clipboard.  
**WARNING!** This tool is not the same as WBLOCK or the INSERT command. |
### Windows tools (continued)

<table>
<thead>
<tr>
<th>Tool</th>
<th>Shortcut Key</th>
<th>Command Line</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![matchprop]</td>
<td>matchprop</td>
<td>Copies the properties of one object to one or more objects.</td>
<td></td>
</tr>
<tr>
<td>![ctrl+z]</td>
<td>undo</td>
<td>Reverses the last action.</td>
<td></td>
</tr>
<tr>
<td>![ctrl+y]</td>
<td>redo</td>
<td>Restores the most recent change made by the Undo command.</td>
<td></td>
</tr>
</tbody>
</table>

For more information, use to look up “Standard Toolbar” in the online Help.

### Establishing Settings

Early in a project you should establish the following settings:

- User Preferences
- Drawing Settings
- Prototype Settings
- Data File Settings

**NOTE** When you start a new drawing, you will also set up the drawing for units, zone, sheet size, and so on. For more information, see “Setting Up Drawings” in this chapter.
User Preferences

The User Preferences control three main aspects of the program.

File Paths

You can control file paths that include the path for storing menu palettes, prototypes, setup files, and speed tables, among others. To use these items, you must store them in the locations specified in the File Locations settings. For example, to use a speed table to calculate a spiral, the speed tables must be located in the path that you specify for speed tables.

NOTE  When you install AutoCAD Land Development Desktop, these paths are set up automatically. You need to change these paths only if you move any items, such as drawing setup files, to a different folder.

AutoCAD Overrides

If you want to use the basic AutoCAD Startup, New, and Open commands, instead of AutoCAD Land Development Desktop commands, then you can change the AutoCAD override settings.
If you clear the Use Land Development Startup check box, then the AutoCAD Startup dialog box is used. If you clear the “New” drawing dialog or “Open” drawing dialog check boxes, then the AutoCAD New and Open dialog boxes are used, as shown in the following illustrations.

The following illustrations show the AutoCAD Land Development Desktop Startup, New, and Open dialog boxes.

These dialog boxes are project-based, allowing you to create new drawings in existing projects, or open existing drawings in existing projects.
First Time Drawing Setup

The First Time Drawing Setup setting controls what happens when you create a new drawing. You can use the New Drawing Wizard, the Drawing Setup dialog box, or you can automatically load a setup file whenever you create a new drawing. The following illustrations show the New Drawing Wizard, the Drawing Setup dialog box, and an example of the contents of a setup file.

Drawing Settings

The Edit Settings dialog box is a centralized location from which you can edit settings that are specific to each drawing. To display the Edit Settings dialog box, select the Drawing Settings command on the Projects menu.
The settings are arranged by program so you can more easily locate the settings that apply to your project. There are settings for AutoCAD Land Development Desktop, Autodesk Civil Design, and Autodesk Survey.

These settings are all available elsewhere in the program. The Edit Settings dialog box provides an easy way to change different settings simultaneously and then save them back to a prototype. By saving the settings to a prototype, the settings are used automatically whenever you create a new drawing in a project that is based on that prototype. You can establish the settings once and then apply them to each new drawing.

**Key Concepts**

- The drawing settings are controlled on a drawing-by-drawing basis unless you save them back to the prototype on which the project is based. This is designed so that individual drawings in a project can have different settings.
- The default drawing settings are based on the project prototype that you select when you create a project. For more information, see “Working with Drawings” in this chapter.
- If you change the drawing settings, then you can save them back to the prototype and use them for new drawings that you create.
- If you change the drawing settings for a drawing, only new objects are affected. Existing objects are not updated with the new drawing settings.

**Prototype Settings**

Every AutoCAD Land Development Desktop project must be based on a prototype. A prototype stores drawing settings. These settings are copied to each drawing that is created in the project. AutoCAD Land Development Desktop includes a prototype for meters and a prototype for feet.
The Prototype Settings dialog box is a centralized location from which you can edit prototype settings. To display the Prototype Settings dialog box, select Prototype Settings from the Projects menu, select the prototype you want to edit, and then click OK.

You can establish the prototype settings in two ways: You can use the Edit Prototype Settings dialog box, or you can use the Drawing Settings command to establish settings and then save them to a prototype.
Data File Settings

You can use the Edit Data Files dialog box to access data files for AutoCAD Land Development Desktop, Autodesk Civil Design, and Autodesk Survey. This dialog box provides a centralized location from which you can access and edit Import/Export formats, Speed Tables, Label Styles, the Tag Styles, and Contour Styles. To display the Edit Data Files dialog box, choose Data Files from the Projects menu.

1. Choose the program.
2. Select the data file that you want to edit.
3. Click the Edit Data button.
4. The data file is opened so you can edit or create new data files.
Establishing Settings

If you have Autodesk Survey, you can edit:

- Command synonyms
- Equipment settings
- Figure Prefix Library

If you have Autodesk Civil Design, you can edit

- Sheet Manager label and grid styles

Setting Up the Drawing Environment

After you install AutoCAD Land Development Desktop, you may want to customize the settings in the Options (formerly Preferences) dialog box. To access the dialog box, select Options on the Tools menu, or type OPTIONS on the command line.

The settings are grouped under tabs in the Options dialog box as shown in the following illustration.
This table gives a brief overview of the settings.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Specifies the directories in which AutoCAD searches for support, driver, menu, and other files. Also specifies optional, user-defined settings such as which dictionary to use for checking spelling.</td>
</tr>
<tr>
<td>Display</td>
<td>Customizes the AutoCAD display.</td>
</tr>
<tr>
<td>Open and Save</td>
<td>Controls options that relate to opening and saving files in AutoCAD.</td>
</tr>
<tr>
<td>Plotting</td>
<td>Controls options related to plotting.</td>
</tr>
<tr>
<td>System</td>
<td>Controls AutoCAD system settings.</td>
</tr>
<tr>
<td>User Preferences</td>
<td>Controls options that optimize the way you work in AutoCAD.</td>
</tr>
<tr>
<td>Drafting</td>
<td>Specifies a number of general editing options.</td>
</tr>
<tr>
<td>Selection</td>
<td>Controls settings that relate to object selection methods.</td>
</tr>
<tr>
<td>Profiles</td>
<td>Controls the use of profiles. A profile is a configuration you define.</td>
</tr>
</tbody>
</table>

**IMPORTANT** You can restore custom options in a saved profile by making that profile current. However, when you choose Set Current, the operation is immediate. It is recommended that you copy and save the original AutoCAD Land Development Desktop profile settings before you make changes in the Options dialog box.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>AEC Editor</td>
<td>Controls settings that are not applicable to AutoCAD Land Development Desktop.</td>
</tr>
</tbody>
</table>

For more information, use \[ Fnd \] to look up “Modifying the AutoCAD Environment” in the online Help.
**Window Display Options**

When you start AutoCAD Land Development Desktop for the first time, the screen colors and other settings conform to the Display settings in the Windows Control Panel. You can change the display colors, fonts, and other settings in the Options dialog box.

### To change the window display options

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use and to look up</th>
</tr>
</thead>
</table>
| 1 From the Tools menu, choose Options to display the Options dialog box, and then click the Display tab. | OPTIONS Command  
Display Tab (Options Dialog Box) |
| 2 Under Window Elements, click Colors to display the Color Options dialog box. | |
| 3 Under Window Elements, select Model tab background. | |
| 4 From the Color list, select a basic color for the Model tab background, and then click Apply & Close to return to the Display tab. | |
| 5 Click Fonts to display the Command Line Window Font dialog box. | |
| 6 Select a font style and then click Apply & Close to return to the Display tab. | |
| 7 Click OK to exit the dialog box. | |
**Saving a Profile**

You can customize profiles to accommodate different projects and different users. When you change settings in the Options dialog box, the group of settings is automatically saved as the default profile. Any changes that you make are immediate. You have no warning before you lose the default profile settings. To avoid having to reinstall AutoCAD Land Development Desktop to restore the original settings, copy and save them as a backup profile (named, for example, LAND) before you make any changes.

**IMPORTANT**  The Reset button sets the currently selected profile to the base AutoCAD 2000 settings, removing access to additional functionality from the selected profile. It is recommended that you copy and save the original AutoCAD Land Development Desktop profile settings before you make changes in the Options dialog box.

For more information, use **Find** to look up “Profiles Tab (Options Dialog Box)” in the online Help.
Using the World Coordinate System for Creating Data

When you begin a new drawing in AutoCAD Land Development Desktop using one of the default drawing templates, you are automatically in the World Coordinate System (WCS); the X axis is horizontal, the Y axis is vertical, and the Z axis is perpendicular to the XY plane.

When you are in the WCS, the AutoCAD UCS icon displayed at the lower-left corner of the graphics screen looks like this:

If the coordinate system is set to anything other than World, the W disappears.

If the coordinate system is set to anything other than World when you create data in AutoCAD Land Development Desktop, that data will NOT be processed correctly.

To change the coordinate system to World, you can type UCS on the command line, and then type World.

**WARNING!** When you are creating data with AutoCAD Land Development Desktop, it is very important that the coordinate system be set to world (WCS).

Working with Projects

Each AutoCAD Land Development Desktop drawing must be associated with a project. This section describes in more detail the function of projects and how to manage them.

- Projects are required if you want to work with AutoCAD Land Development Desktop commands. However, you can run AutoCAD or AutoCAD Map command without having a project selected.
You can assign a drawing to only one project, but you can re-associate the drawing if you want to associate it with a different project later by using the Reassociate Drawing command from the Projects menu.

- Projects can contain multiple drawings.
- All the drawings in a project share the data files, such as the point database.
- If you open an existing drawing that is not assigned to a project, then you are prompted to select a project. This assignment is saved when you save the drawing.

Creating Projects

You can create a new project when you create a new drawing, or you can create a new project from the Project Manager. When creating a new project, you establish the project name, description, and keywords, as well as the prototype to base the drawing settings on and the location for storing the drawing files, in the Project Details dialog box.
Basing a Project on a Prototype

When you create a new project, you must specify a prototype (default settings for the project) and a name for the project. AutoCAD Land Development Desktop uses prototypes as a convenient way for you to maintain standard drawing settings for your project drawings. These standards are important and probably vary from project to project. For example, the standards that you use for state projects may be significantly different from the standards for local or town-related jobs.

When you create a new project, you can select a prototype to use for the default drawing settings. All the settings from the prototype are copied into the drawings that are associated with the project.

Project Description and Keywords

When you create a project, you can also add a description and any keywords to help you identify the project. The description and keywords can be helpful if you have multiple projects. You can search on the keywords to find a particular project, and check the description to make sure it is the project that you are looking for.

Project Drawing Location

Each project must have a location for storing the project’s drawings. This location is for all the drawing files that you create within a project. It is recommended that you store the drawing files in the project’s \dwg folder, for example, c:\Land Projects R2\newproj\dwg. However, you can also establish a different, fixed, path for the drawing storage location.

By saving the drawings in the project drawing folder, you keep the drawings and the project files together, which makes the project easier to archive or transfer to someone else.

Managing Projects with the Project Management Dialog Box

As you work with more and more projects, you may need to delete an old project, copy a project, rename an existing project, view project locks, or change an inaccurate description. You can do all this and more from the Project Management dialog box.
To display the Project Management dialog box, choose Project Manager from the Projects menu.

![Project Management dialog box]

From the Project Management dialog box, you can:

- Create new projects. If you are a CAD Manager, then you may want to create the projects from within the Project Management dialog box so that others on the system can start their drawings and reference the same project data.
- Create new project paths. By default, the project path is `c:\Land Projects R2`, but you can create new project paths if desired.
- View the project details, including project description, keywords, and drawing storage location.
- View and manage the file locks. On a network, you can view the file locks to see who has files open.
- Copy, rename, and delete projects. It is recommended that you use the Project Management dialog box for copying, renaming, and deleting project data.

For more information about creating and maintaining projects, use the [Help] to look up “Overview of the Project Manager” and “Overview of Project Locks” in the online Help.
Managing Prototypes with the Prototype Management Dialog Box

You may need to maintain different prototypes for different clients. You can copy, delete, and rename prototypes by using the Prototype Management dialog box. To display the Prototype Management dialog box, choose Prototype Manager from the Projects menu.

Default prototypes for feet and meters are included with AutoCAD Land Development Desktop. If you delete the default prototypes, then they are recreated, using the default system settings, the next time that you start AutoCAD Land Development Desktop.

When you installed AutoCAD Land Development Desktop, a prototype folder (c:\Program Files\Land Desktop R2\data\prototypes by default) was created. Each default prototype, and each prototype that you create, is represented by a subfolder of this root prototype folder. For example, if you create a prototype named MYPROTO, then a c:\Program Files\Land Desktop R2\data\prototypes\myproto folder is created.

For more information about creating and maintaining prototypes, use Find to look up “Overview of the Prototype Manager” in the online Help.
Working with Drawings

All AutoCAD Land Development Desktop documents that you work with are called drawings. They are AutoCAD drawings that are saved with a .dwg file extension. This section explains how to create drawings, establish the drawing settings, and open drawings.

Creating New Drawings

You can create a new drawing from either the Startup dialog box or by selecting the New command from the File menu.

When you create a new drawing, you name it and you associate it with a project. Every time you create a new drawing, you are automatically prompted to set up the drawing. Depending on which option you select for “First Time Drawing Setup” (see “User Preferences” in this chapter) either the New Drawing Wizard or the Drawing Setup dialog box is displayed, or a setup file is loaded automatically.

The New Drawing Wizard steps you through each setting that you must establish for a drawing. The Drawing Setup dialog box contains all the settings available in the New Drawing Wizard, but does not step you through the setup process.

Whenever you set up a drawing, you can save the drawing setup options to a file that you can load later. AutoCAD Land Development Desktop includes several existing setup files. If you use a setup file, then you do not have to step through drawing setup each time you create a new drawing.

Key Concepts

- When you create a new drawing, you must name the drawing and select or create a project.
- When you create a new drawing, you can create a new project.
- You can base a new drawing on a drawing template. Template files store all the settings for a drawing and can also include predefined layers, dimension styles, and views. For more information about using drawing templates, look up “Using Templates” in the online Help.
To create a new drawing

Steps | Use ▼ to look up
--- | ---
1. From the AutoCAD Land Development Desktop R2 program group, choose the AutoCAD Land Development Desktop R2 icon.  
   The Startup Dialog box is displayed.  
   Or, if AutoCAD Land Development Desktop is already running, choose New from the File menu.  
   **Overview of Starting a Drawing Session**
2. Click New to display the New Drawing: Project Based dialog box, as shown in the following illustration.  
   **Start a New Drawing**

For more detailed information on setting up a drawing after naming it and selecting a project, see the following section, “Setting Up Drawings.”
Setting up Drawings

To create a new drawing without using a Wizard, or to change drawing settings while working on an open drawing, you can use the Drawing Setup dialog box. To display the Drawing Setup dialog box, choose Drawing Setup from the Projects menu.

You can use this dialog box to select the current zone, and to adjust the drawing units, the horizontal and vertical scales, the current text style, and other settings.

Key Concepts

- You should set up the drawing units and scale based on your plot scale.
- You can insert custom borders into your drawings.
- The precision values in the Drawing Setup dialog box control displayed information and plotted labels, not the actual values that are stored in the database, which are calculated to the highest internal precision.
- After you modify the settings for a drawing, you can use the Load/Save Settings tab to save the setup to a name so that you can use the same settings for each drawing in a project.
Drawing Setup Example: Setting a Base Point and North Rotation

Before you bring points into your drawing, you may want to set the drawing orientation. The drawing orientation settings include a base point and north rotation. These two settings control the drawing's coordinate system. You can adjust both the base point so that it ties into a known coordinate system (that you can specify on the Zone tab of the Drawing Setup dialog box), and the north rotation so that all your project points fit within the boundaries of your plot sheet.

AutoCAD Land Development Desktop uses two coordinate systems for locating points: X,Y and northing/easting. When you start a new project, these values all default to 0 so that the Y coordinate is the same as the northing, and the X coordinate is the same as the easting.

You can set up a base point to assign a specific northing and easting value to a fixed X,Y location. For example, if your drawing points begin at northing and easting coordinates of 5000,5000, then you can set a new base point to translate these coordinates so they will fit onto your drawing screen.

By default, North is always represented in a drawing as the top of the screen. But you can define a different orientation of North if the drawing layout requires it. You should typically set the north rotation when you create a new drawing, but you can change it at any time.

You can give different drawings attached to the same project different north rotations. This provides different views of the project point data relative to the X,Y coordinates.
To set up the base point and north rotation

Steps

1. From the Projects menu, choose Drawing Setup. Use **Find** to look up

   *Set Up a Drawing Using the Drawing Setup Command*

2. Click the Orientation tab.

3. Under Base Point, type X, Y coordinates for the base point, or click Pick and select a point from the drawing.

   *Change the Base Point for a Drawing*

   Setting a different base point affects the view of the project data only in the current drawing and does not alter the point database coordinates. All project data files store their information as northing/easting coordinates.
To set up the base point and north rotation (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>4 Under Northing and Easting, type the northing and easting coordinates to associate with the X,Y base point.</td>
<td>Change the North Rotation for a Drawing</td>
</tr>
<tr>
<td>For example, if X,Y is 0,0 (the lower-left corner of your drawing screen), then you can specify the local northing/easting coordinates that were used in a survey of the site, such as 5000,5000. This makes 0,0 equivalent to northing/easting of 5000,5000.</td>
<td></td>
</tr>
<tr>
<td>5 Under North Rotation, select Angle and type a rotation angle, or select Define by Points and click Pick Rotation to define the rotation angle. Under Points Represent, select the angle that rotation angle represents. In an AutoCAD drawing, North is always straight up. By changing the North rotation, you can orient your site however you want. Changing the north rotation affects only the commands that use a northing/easting coordinate system. It does not rotate the X,Y angular base.</td>
<td></td>
</tr>
<tr>
<td>6 From the Inquiry menu, choose Track North/East to display a box that tracks the northing and easting of your pointer as you move it across the screen.</td>
<td>Track Northing and Easting Coordinates</td>
</tr>
</tbody>
</table>
To select the coordinate zone for a drawing

Steps | Use ^ to look up
--- | ---
1. From the Projects menu, choose Drawing Setup. | Change the Current Zone for a Drawing

2. Click the Zone tab.

3. From the Categories list, select the geodetic zone category you want to choose a zone from. Categories include Lat/Longs, different countries, and different states in the United States.

4. Select a zone by clicking on it. The zone details are listed in the lower half of the dialog box.

   If you don’t want to base the drawing on a coordinate zone, then leave the CS Code box blank.

5. Click OK.

For more information about setting up drawings, use ^ to look up “Overview of Setting Up Drawings” in the online Help.

For more information about performing coordinate zone transformations, see “Working with Points” in Chapter 3 “Working with COGO Points.”
Opening Drawings

You can open an existing drawing using the Startup dialog box, or open a new drawing by selecting the Open command from the File menu. The Most Recently Used list in the Startup dialog box lists the four drawings that you most recently worked on.

If you open a drawing that was created with Autodesk S8 Civil/Survey programs and the project exists, then the drawing is linked automatically to that project and the point database and alignment database are converted. If you open a drawing that is not associated with a project, then you must select a project or create a new project for the drawing in order to work with AutoCAD Land Development Desktop commands.

For more information about opening drawings, use [Help] to look up “Open an Existing Drawing from the Start Up Dialog Box” in the online Help.

Opening Drawings in Other Flavors of AutoCAD

Some of the objects that are created in AutoCAD Land Development Desktop are called ARX Objects. These objects include points, contours, and labels, among others. You cannot edit these ARX objects if you open an AutoCAD Land Development Desktop drawing in another flavor of AutoCAD, like AutoCAD, AutoCAD Map, or AutoCAD Mechanical Desktop.

You can use three options for displaying ARX objects in another flavor of AutoCAD. You can view the objects as proxies, you can install the Object Enabler, or the AutoCAD Land Development Desktop user can use the EXPLODE command before giving you the drawing.

- Install the Object Enabler from your AutoCAD Land Development Desktop CD-ROM. This program allows people who do not own AutoCAD Land Development Desktop, but who do own a copy of an AutoCAD flavor, to view the custom AutoCAD Land Development Desktop objects.
- Use the EXPLODE command from within AutoCAD Land Development Desktop to explode the ARX objects to polylines that anyone using AutoCAD can view and edit.
Substitute proxy objects so that you can view the objects that were created in AutoCAD Land Development Desktop.

When someone opens an AutoCAD Land Development Desktop drawing in another flavor of AutoCAD, the Proxy Information dialog box is displayed.

The Proxy Information dialog box lists the missing application and the number of proxy objects in the drawing. It also gives you three options:

- **Do not show proxy graphics**: Does not show the proxy graphics.
- **Show proxy graphics**: Displays custom ARX objects as proxy graphics.
- **Show proxy bounding box**: Displays a bounding box around custom ARX objects.

**Viewing Drawings**

A drawing’s position, orientation, or magnification level is known as the view. The direction from which you view the drawing is called the viewpoint. To access standard AutoCAD viewing tools, select 3D Views from the View menu to display a submenu with viewing options. For quick access to view options, display the View toolbar in the ACAD menu group.
**Key Concepts**

- You can view the drawing or object from a side viewpoint, such as right, left, top, or bottom; from isometric angles; and in an elevation view.
- To view the drawing in 2D planes (X and Y planes), use plan view in which you view the drawing as if you were directly above and looking down on the drawing.

  **NOTE** A benefit of plan view is its fail-safe property. If you have been working in 3D and want to reorient yourself and the drawing, you can always return to plan view.

- You can view an object in perspective by using the Object Viewer or Camera, located on the Utilities menu.
- You can rotate an object by using either the Navigation tool or entering a rotation angle.
- You can view a 3D object with different surfaces, such as wireframe, rendered, and shaded surfaces. In the wireframe view, you can also hide interior lines.

  For more information about viewpoints, use the PAd to look up “Options for Viewing in 3D” in the online Help.

**Using the Object Viewer**

The Object Viewer is a view window that displays any objects you select within AutoCAD. The viewer lets you shade and reorient your view quickly. You can use the Object Viewer to display objects in your drawing in 2D or 3D plan view, as well as reorient the AutoCAD view to match the orientation in the viewer.

**Key Concepts**

- The view in the Object Viewer is the same as the drawing view.
- If the drawing is in plan view, the objects in the Object Viewer are in 2D plan view.
- If you are viewing your drawing in 3D, then the objects are displayed in 3D.
- Shading is supported in the Object Viewer, but rendering is not.
To view an object in the Object Viewer

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use ___ to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Utilities menu, choose Object Viewer.</td>
<td>Use the Object Viewer</td>
</tr>
<tr>
<td>2 Select the object you want to view in the Object Viewer.</td>
<td></td>
</tr>
<tr>
<td>3 Press ENTER to display the Object Viewer dialog box.</td>
<td></td>
</tr>
<tr>
<td>4 Use the tools in the Floating Viewer to adjust your view.</td>
<td>Overview of the Floating Viewer</td>
</tr>
</tbody>
</table>

For more information about the Object Viewer, use \_\_\_ to look up “Use the Object Viewer” in the online Help.

Using Zoom and Pan

The basic display commands, ZOOM and PAN, work much like a lens on a camera that can magnify or reduce the image of an object. Use ZOOM to enlarge or shrink the drawing and use PAN to move the “camera” eye from side to side, up and down, and so on.

After you select Zoom from the View menu, or type zoom on the command line, you have several options, as shown in the following table:

<table>
<thead>
<tr>
<th>Zoom options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
</tr>
<tr>
<td>Realtime</td>
</tr>
<tr>
<td>All</td>
</tr>
<tr>
<td>Center</td>
</tr>
</tbody>
</table>
**Zoom options (continued)**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dynamic</td>
<td>Display the drawing within a view box that you can adjust. After you specify the extents of the box, press ENTER and that area becomes the new display.</td>
</tr>
<tr>
<td>Extents</td>
<td>Enlarge the drawing to the tightest zoom possible of everything in the drawing file.</td>
</tr>
<tr>
<td>Previous</td>
<td>Restores the prior view. You can select up to 10 previous views in succession.</td>
</tr>
</tbody>
</table>

**NOTE** If you want to zoom or pan in real time without using commands, select Aerial View from the Tools menu. The drawing is displayed in a separate, smaller window that remains open while you work, and in which you can navigate around the drawing quickly. For more information, see “Using Aerial View” in the online Help.

For more information, use [F1] to look up “Using Zoom and Pan” in the online Help.

**Scaling Views**

When you work on the drawing in model space, you work at full scale. In paper space, you must specify a drawing scale that is determined by the size limits of the sheet of paper, or by how you want the drawing views to display.

You can scale the drawing in two ways. You can specify a scale factor at plot time, relative to the paper size, or you can scale the views in paper space floating viewports. Scaling in floating viewports provides instantaneous feedback about whether the drawing view fits on the sheet of paper.

**TIP** You can use the DIST command to measure the model drawing to help you determine the scale.
Key Concepts

- To scale a view relative to the current view, use the Scale (X/XP) option of the ZOOM command. Add x after the value that you enter. For example, enter 2x to double the image size.
- To scale a drawing relative to paper space units, use the Scale (X/XP) option of the ZOOM command, and then enter the “xp” (“times paper space”) factor. For example, if you want 1 inch in paper units to equal 1 foot in drawing units, then 1 in. = 1 ft. Enter the scale factor 12xp at the prompt.
- Use MVSETUP to scale viewports independently or as a group.

For more information, use Find to look up “Scaling Views Relative to Paper Space” in the online Help.

Using Named Views

As you work on a drawing, you will find that you frequently return to the same views. For example, you may zoom repeatedly into a particular area in the drawing. Rather than using the ZOOM command every time you want to view this area, you can name this view, and recall it when you need it. From the View menu, select Named Views to display the View dialog box in which you can create, save, delete, or restore a view.
Key Concepts

■ When you save a view, both the viewing position, such as a specific pan or zoom position, and scale are saved.
■ If you work in tiled viewports in model space, then only the view in the current viewport is saved. If you work in paper space, you can save the entire layout, including one or more floating viewports.
■ When you restore a named view in model space, it replaces the active viewport. In paper space, however, the restored view replaces the entire layout, including one or more floating viewports.

For more information about viewports, see “Working in Model Space and Layout Mode” in Chapter 4, “Working with Drawing and Editing Tools.”

For more information, use [Ctrl] to look up “Using Named Views” and “Saving Views” in the online Help.

Saving Drawings as Bitmap Files

You can save a view so that it can be inserted in a document. For example, if you save a viewport as a bitmap file, you can insert it into a Word document.

To save a drawing as a bitmap

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [F3] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Tools menu, choose Display Image ➤ Save.</td>
<td>Saving a Viewport Rendering</td>
</tr>
<tr>
<td>2 In the Save Image dialog box under Format, select BMP.</td>
<td></td>
</tr>
<tr>
<td>3 Accept the full screen size or specify a different size, and click OK.</td>
<td></td>
</tr>
<tr>
<td>4 In the Image File dialog box, enter a file name and location for the drawing file.</td>
<td></td>
</tr>
</tbody>
</table>
Redrawing and Regenerating

When the drawing is cluttered with blips or temporary markers, you can clean up the current viewport quickly by using the REDRAW command. It refreshes the screen and redraws objects without updating the drawing database. If you use more than one viewport, you can use the REDRAWALL command.

You can also update the drawing screen by regenerating the drawing. The REGEN command reads all the data in the database and calculates the screen coordinates of each object on the screen. Because regenerating a complex drawing is time consuming, you usually redraw.

NOTE To reduce regeneration time, you can freeze layers to keep data from being regenerated.

For more information use to look up “Refreshing the Screen Display” in the online Help.

Organizing Drawings with Layers

All drawing objects in AutoCAD Land Development Desktop are assigned a layer. Drawing layers are like sheets of clear acetate that are positioned one over the other. Layers help you organize drawing data, control the drawing display, and what is plotted or printed. You can make objects on a layer invisible and prevent them from being plotted, by freezing the layer or turning it off. You can lock a layer to prevent it from being edited.

Key Concepts

- You can group and organize drawing layers by function and other categories. For example, put minor contours on one layer and major contours on another.
- Each drawing can have its own layer structure, or hierarchy. You can also set up a layer configuration and then save it as a drawing template to enforce linetype, lineweight, color, and other standards when you create new drawings.
- Assign layers a color, linetype, and/or lineweight to distinguish them from other layers. Layer 0 is always present and all other layers are layers that you create.
By turning layers on and off, you can plot the same drawing to serve different purposes.

In lists, layers are sorted alphabetically by name. If you choose layer names carefully, you can sort layers by groups. For example, if you have a set of layers that start with CONTOUR, such as CONTOUR01, CONTOUR02, and so on, then you can sort for CONTOUR to display a list with only those layers.

For more information, use $\text{F1}$ to look up “Working with Layers” in the online Help.

### Changing Properties of Layers and Objects

You can make changes to objects and layers by using the Object Properties toolbar.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Makes the selected object's layer the current layer." /></td>
<td>Makes the selected object's layer the current layer.</td>
</tr>
<tr>
<td><img src="image" alt="Displays the Layer and Linetype Properties dialog box in which you can manage layers." /></td>
<td>Displays the Layer and Linetype Properties dialog box in which you can manage layers.</td>
</tr>
<tr>
<td><img src="image" alt="Turns layers on and off. Layers that are turned off are invisible and not plotted." /></td>
<td>Turns layers on and off. Layers that are turned off are invisible and not plotted.</td>
</tr>
<tr>
<td><img src="image" alt="Freezes and thaws layers in all viewports. Frozen layers are invisible and all objects are ignored. You can freeze layers to save regeneration time when zooming, panning, or selecting a viewpoint in a complex drawing. As you thaw a layer, AutoCAD Land Development Desktop regenerates the drawing." /></td>
<td>Freezes and thaws layers in all viewports. Frozen layers are invisible and all objects are ignored. You can freeze layers to save regeneration time when zooming, panning, or selecting a viewpoint in a complex drawing. As you thaw a layer, AutoCAD Land Development Desktop regenerates the drawing.</td>
</tr>
</tbody>
</table>
## Object Properties toolbar (continued)

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Lock Layer" /></td>
<td>Locks and unlocks layers. To prevent objects on a layer from being modified, lock the layer. The objects remain visible, and you can use commands that do not alter the objects.</td>
</tr>
<tr>
<td><img src="image" alt="Plot Layers" /></td>
<td>Controls the whether layers are plotted.</td>
</tr>
<tr>
<td><img src="image" alt="Color Layer" /></td>
<td>Displays the color assigned to a layer.</td>
</tr>
<tr>
<td><img src="image" alt="ByLayer" /></td>
<td>Makes a color current, displays the color of a selected object, and changes the color of a selected object. The drop-down list contains the colors used most recently. Click Other to display the Select Color dialog box for additional color selections.</td>
</tr>
<tr>
<td><img src="image" alt="ByLayer" /></td>
<td>Makes a linetype current, displays the linetype of a selected object, and changes a selected object’s linetype.</td>
</tr>
<tr>
<td><img src="image" alt="ByLayer" /></td>
<td>Makes a lineweight current, displays the lineweight of a selected object, changes the lineweight of an object, and makes a lineweight current.</td>
</tr>
<tr>
<td><img src="image" alt="ByLayer" /></td>
<td>Controls the plot style of objects. By modifying an object’s plot style, you can override that object’s color, linetype, and lineweight for plotting. You can also specify end, join, and fill styles as well as output effects such as dithering, gray scale, pen assignment, and screening.</td>
</tr>
</tbody>
</table>

For more information, use the Help button to look up “Using the Object Properties Toolbar” in the online Help.
Working with the Layer Manager

In the Layer Manager, you can create, organize, sort, and group layers, as well as save and coordinate layering schemes. You can also implement layering standards to better organize your drawing layers.

Key Concepts

- You can use the Layer Manager to create and manage new layers.
- You can use the Layer Manager to make a layer current.

To make a layer current

Steps

1. From the Utilities menu, choose Layer Manager.

2. In the right pane of the Layer Manager, click the layer that you want to make current and click Make a Layer Current.

3. Click OK.

To create a new layer

Steps

1. From the Utilities menu, choose Layer Manager.

2. In the Layer Manager, click Create a New Layer.

3. In the New Layer dialog box, select Non Standard to create a non standard layer, or select another layer standard. Create a New Nonstandard Layer

4. Type a name for the new layer.
### To create a new layer (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>5. Select the Make Current check box to make the new layer current.</td>
<td></td>
</tr>
<tr>
<td>6. Enter a description, color, and linetype for the new layer.</td>
<td></td>
</tr>
<tr>
<td>7. Click OK.</td>
<td></td>
</tr>
</tbody>
</table>

For more information about layer management, use to look up “Overview of Layer Management” in the online Help.

## Working with Layer Groups

You can use groups of layers to create working views and backgrounds from large drawings. In the Layer Manager, you can create user-defined groups and assign layers to them, and you can create filter groups whose layers are assigned to them automatically, based on filter criteria that you set for the group. If there are any layers in external reference files associated with the current drawing, an xref group will contain those layers. One group, the All group, is always present and lists all the layers and other layer groups in the drawing.

### Key Concepts

- Use layer groups to create working views and backgrounds from data sets.
- Create user groups to which you can assign any layer and filter groups. Layers are assigned automatically based on criteria you set.
- Filter groups can be static or dynamic. Dynamic filter groups automatically update when you change the properties of the layers in them but static filter groups do not.
### To create a user group

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Utilities menu, choose Layer Manager.</td>
<td>Overview of Creating a Layer Group</td>
</tr>
<tr>
<td>2 In the left pane of the Layer Manager, right-click, and select New Group ➤ User.</td>
<td></td>
</tr>
<tr>
<td>3 Type a name for the new layer group.</td>
<td></td>
</tr>
<tr>
<td>4 To add layers to the new layer group, select a layer in the right pane of the Layer Manager and drag it into the layer group.</td>
<td></td>
</tr>
</tbody>
</table>

### To create a filter group

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Utilities menu, choose Layer Manager.</td>
<td></td>
</tr>
<tr>
<td>2 In the left pane of the Layer Manager, select a layer group, right-click, and select New Group ➤ Filter.</td>
<td>Overview of Creating a Filter Group</td>
</tr>
<tr>
<td>3 Type a name for the new filter layer group.</td>
<td></td>
</tr>
<tr>
<td>4 In the Layer Filter Properties dialog box, select Dynamic or Static.</td>
<td></td>
</tr>
<tr>
<td>5 Set the filter criteria.</td>
<td></td>
</tr>
<tr>
<td>6 After you finish setting the filter criteria, click OK.</td>
<td></td>
</tr>
</tbody>
</table>

For more information about layer management, use to look up “Overview of Layer Management” in the online Help.
Working with Layer Snapshots

By saving layer and view information in snapshots, you can quickly recall specific layer and view configurations from complex data sets. For example, a land surveyor might create snapshots of individual site plans and buildings, boundaries, and contours to separate this information from a complete site layout. After you create a layer snapshot, you can add and delete individual layers in the snapshot and import it into new drawings to automatically set up a layering scheme.

Key Concepts

- Create layer snapshots to save and reuse specific layer configurations from large data sets.
- Import a layer snapshot to quickly set up layers in a new drawing.
- You can edit a layer snapshot by adding and deleting layers.

To create a snapshot of a layer group

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use ? to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Utilities menu, choose Layer Manager. (\text{Create a Snapshot of a Layer Group})</td>
<td>(\text{Create a Snapshot of a Layer Group})</td>
</tr>
<tr>
<td>2 In the left pane of the Layer Manager, click (\text{Display all the layer groups in your drawing.})</td>
<td>(\text{Display all the layer groups in your drawing.})</td>
</tr>
<tr>
<td>3 Click the layer group that you want to save as a snapshot, right-click, and select Save as Snapshot.</td>
<td>(\text{Save as Snapshot.})</td>
</tr>
<tr>
<td>4 In the Snapshot dialog box, type a name for the new snapshot.</td>
<td>(\text{Type a name for the new snapshot.})</td>
</tr>
<tr>
<td>5 Click OK to create the snapshot.</td>
<td>(\text{Click OK to create the snapshot.})</td>
</tr>
</tbody>
</table>

For more information about layer snapshots, use \(\text{to look up}\) “Overview of Changing an Existing Layer Group” in the online Help.
Using Drafting Settings

Several AutoCAD Land Development Desktop tools help you draw with accuracy. For example, for maximum control over your drawing, you can set up a background grid that limits points you specify to points on the grid (snaps). You can also restrict location points on objects, such as the midpoint of a line and the center of a circle (object snaps). You can constrain cursor movement to the vertical and horizontal (Ortho mode), and you can turn on display markers and highlights for reference.

Settings for these drawing modes are in the Drafting Settings dialog box, which you can access by selecting Drafting Settings from the Tools menu.
The following table describes the drafting settings.

<table>
<thead>
<tr>
<th>Drafting setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snap</td>
<td>Restricts cursor movements to measured intervals, or invisible &quot;snap&quot; points. You can specify snap distances and whether to display a grid that corresponds to the snap points.</td>
</tr>
<tr>
<td>Grid</td>
<td>Displays a web of visible dots that you can use as a guide. The dots are spaced according to the value that you specify in the Snap section of the Drafting Settings dialog box. The following illustrations show the grid turned on. In the illustration on the left, Snap is turned off. The cursor does not snap to the grid points. In the illustration on the right, Snap is turned on. The cursor snaps to the grid points.</td>
</tr>
<tr>
<td>Polar Tracking</td>
<td>Sets the angles used with polar tracking and sets options for object snap tracking. Sets the basis by which polar tracking alignment angles are measured. The following illustration shows an example of polar tracking:</td>
</tr>
<tr>
<td>Object Snap</td>
<td>Controls running object snap settings and object snap tracking. Running object snaps automatically snap to points in your drawing when using a command. For more information see “Object Snaps” in this chapter.</td>
</tr>
</tbody>
</table>

For more information, use \( \text{F1} \) to look up “DSETTINGS Command” in the online Help.
Using Reference Points in the Drawing

AutoCAD Land Development Desktop provides tools to help you specify points precisely for accurate placement of objects and for reference.

Object Snaps

You can use object snaps (osnaps) to move the cursor to defined points on objects, for example, the center of a circle, the midpoint of a line, or the intersection of two lines. For example, you can start a new line from the exact endpoint of another line. Set the Object snaps you want to use in the Drafting Settings dialog box, which is displayed when you select Drafting Settings on the Tools menu.

During a drawing session, if you do not want to use an osnap that you set, you can turn it off temporarily before you select a point. Double-click OSNAP on the status bar, or press F3 to turn the settings off. Double-click again or press F3 to turn the same settings back on. If you have not specified any object snap modes, then the Drafting Settings dialog box is displayed so you can specify the osnap modes to use.
The Object Snap tab also controls the use of object snap tracking. With object snap tracking the cursor can track along alignment paths based on other object snap points when specifying points in a command. For more information, see “Object Snap Tab” in the online Help, and “AutoTrack” in this chapter.

You can use the Object Snap shortcut menu, shown in the following illustration, to specify a specific object snap to use for a point, even when running Osnap are not turned on.

![Object Snap shortcut menu]

To display the object snap shortcut menu, run a drawing command like LINE, then press the SHIFT key and right-click.

For more information, use the Find tool to look up “Snapping to Points on Objects” in the online Help.
AutoSnap

After you set snap point locations in the Osnap Settings dialog box, you can select AutoSnap™ options to preview and confirm locations during a drawing session before using the pointing device to specify a point. To access the AutoSnap settings, choose Options from the Tools menu and click the Drafting tab.

When the cursor moves over an object snap location, a marker is displayed (when the Marker check box is selected). If you pause, a ToolTip shows the name of the location (when the Display AutoSnap tooltip check box is selected).
The following illustration shows the marker that is displayed over the endpoint, and the ToolTip that explains which snap point the cursor is snapped to.

AutoSnap works even when you set multiple object snaps. Press TAB to cycle through the snap points on an object.

For more information, see “Changing Object Snap Settings” in the online Help.

**AutoTrack**

AutoTrack™ is another way to specify a point in relation to existing points by using the pointing device. AutoTrack helps you draw objects at specific angles or with specific relationships to other objects in the drawing.

When you turn on AutoTrack, temporary alignment paths help you create objects at precise positions and angles. AutoTrack includes two tracking options: polar tracking and object snap tracking. You can turn AutoTrack on and off with the Polar and Otrack buttons on the status bar.

Use polar tracking to track the cursor along temporary alignment paths defined by polar angles relative to a command's From or To points. Polar tracking is used only when ORTHO mode is turned off. For an illustration of polar tracking, see “Using Drafting Settings” in this chapter.

Object snap tracking works in conjunction with object snaps. You must set an object snap before you can track from an object's snap point. The AutoSnap aperture settings control how close you must be to the alignment path before the path is displayed.
To use AutoTrack for object snap tracking

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Start by drawing a line or polyline in your drawing, such as the line shown here.</td>
<td><img src="image1.png" alt="Image of line" /> You will use AutoTrack to draw another line based on the snap points of this line.</td>
</tr>
<tr>
<td>2 Turn on a running object snap like ENDPOINT by using the Drafting Settings command on the Tools menu.</td>
<td><img src="image2.png" alt="Image of endpoint" /></td>
</tr>
<tr>
<td>3 Turn on AutoTrack by depressing the OTRACK button on the Status Bar.</td>
<td>Using AutoTrack</td>
</tr>
<tr>
<td>4 Run a drawing command, like LINE.</td>
<td><img src="image3.png" alt="Image of cursor and line" /></td>
</tr>
<tr>
<td>5 When you are prompted to select a point, hold your cursor over one end point on the original line you drew in step 1, but do not click. A small plus sign (+) is displayed over the point.</td>
<td><img src="image4.png" alt="Image of cursor and plus sign" /></td>
</tr>
<tr>
<td>6 Move your cursor to a second end point on the original line you drew in step 1, but do not click. A small plus sign (+) is displayed over the second point.</td>
<td><img src="image5.png" alt="Image of cursor and plus sign" /></td>
</tr>
<tr>
<td>7 Move your cursor to locate an alignment point, as shown in the following illustration:</td>
<td><img src="image6.png" alt="Image of cursor and alignment point" /></td>
</tr>
</tbody>
</table>
| 8 Click to place the start point of the line at this location that AutoTrack identified. | Using Drafting Settings

91
Plotting Your Drawings

When you are ready to plot a drawing, set up a layout and configure the settings in the Plot dialog box. These settings include the printer or plotter you want to use, the plot style table, which layout(s) to plot, the plot area, scale, orientation, and other parameters.

Plotting has changed significantly for AutoCAD 2000-based programs such as AutoCAD Land Development Desktop Release 2. Additional Help topics and videos have been added to the documentation. When you select the Plot command on the File menu, the Plot dialog box is displayed, and the following message dialog box is displayed:

If you click Yes, the Help topic that is displayed has links to details about how to plot using the AutoCAD 2000 plotting features.

To set up a drawing to plot, you work in a layout (also known as paper space). You can click the Model and Layout tabs at the bottom of the drawing screen to switch between model space and paper space. You use the Layout mode to set up the view that you want to plot by configuring viewports. You can have multiple layouts set up within one drawing to plot different views of the drawing. For more information about model space and paper space, see “Working in Model Space and Layout Mode” in Chapter 4, “Working with Drawing and Editing Tools.”
Key Concepts

- A plot style, a new object property, can change the way a plotted drawing looks. By modifying an object’s plot style, you can override that object’s color, linetype, and linewidth. You can use plot styles if you need to plot the same drawing in different ways.
- Plot settings are now saved in the drawing. After you establish the settings, you can plot using the same settings the next time you open the drawing.
- The Layout configuration is affected by the following plot settings: paper size, printable area, plot area, plot scale, and plot offset. If you modify the plot settings from the Plot dialog box, the layout paper image reflects the new plot settings after your drawing has been plotted.

For more information, use Find to look up “Layout and Plotting Guide” and “Fast Track to Plotting Your First Drawing” in the online Help.

Exiting AutoCAD Land Development Desktop

You can exit AutoCAD Land Development Desktop by using the following methods:

- From the File menu, choose Exit.
- Type exit or quit.
- Click the close box in the upper-right corner of the AutoCAD Land Development Desktop window.

Key Concepts

- When you exit a drawing, you are prompted to save any surfaces that you have edited but not yet saved.
- To allow multi-user read/write access to the point database and the alignment database, the point and alignment information is written directly to the databases, so they never need to be saved.
COGO points are used in almost every project to identify locations in space. COGO points contain northing, easting, elevation, and description information that is stored in an external point database.
Points that identify locations, by using northing, easting, and elevation, are the basis of almost every land development project. The more accurate and thorough your point data is, the more accurate anything that you generate from the points are, such as surfaces, geometry, and so on.

Points that AutoCAD Land Development Desktop creates are called COGO points. COGO stands for “Coordinate Geometry.” COGO points are stored in an external database, and are organized by their point numbers. COGO points have extended entity data that is associated with the points. This data includes point number, point name, description, and elevation. All but the point number are optional.

COGO point data is stored in an external database file called points.mdb. All drawings in the project reference this database. Because all the project points are stored externally, you can reference the points without them being drafted in the drawing, and multiple people can access the point data on a network.

To add points to the point database, you can create points in the drawing, import ASCII files, import data from a Microsoft Access database file, or download from a data collector.

The following diagram illustrates several ways to add points to a project.

The Points menu contains most of the point commands that you use to set point settings, add points to your project, and edit points in AutoCAD Land Development Desktop.
Point Appearance: Markers and Labels

When you create points, you have the option of displaying point markers, point labels, or both. Think of point markers as a working mode for points. Then when you are ready to label the points and insert description key symbols, use point labels.

Point markers can stay the same size relative to the AutoCAD graphics window, or they can be a fixed size in the drawing. The following illustration shows point markers that are sized relative to the graphics window zoom level.

Point markers include a point marker node and point marker text for point number, description, and elevation. While you must use labels to achieve full description key substitution, you can substitute full descriptions for raw descriptions using point markers.

In contrast, point labels can label any number of items. You can customize point labels to display any type of information about points you like. You can label points with data from external databases by using External Data References (XDRefs). You can also set up point label styles that perform description key substitution.

For more information about point markers, see “Changing the Point Marker Settings” in this chapter. For more information about description keys and point labels, see “Working with Description Keys” in this chapter.
Points and CAD Commands

The commands in the Points pull-down menu create COGO point objects that have extended entity data. These objects differ from the simple CAD point nodes that you can create with the POINT command. The following illustration shows a CAD point node created with the POINT command on the left. On the right is a COGO point object created with a command on the Points pull-down menu.

The COGO points are typically assigned description and elevation data as well as the required point number. This point data is stored in the point database. In contrast, a point node exists only in the drawing file, and only has X, Y, and Z data associated with it.

If desired, you can convert CAD point nodes to COGO points. Use the Convert from AutoCAD Points ➤ Point Utilities menu.

Upgrade Information About Points for Users of S8 Civil/Survey

For those familiar with Autodesk S8 Civil/Survey programs, this section summarizes the new point features that were added to AutoCAD Land Development Desktop.

- A COGO point is now an object instead of a block with attributes. All point features are now placed on the same layer, the current layer, unless you use description keys or point labels. The point object can stay the same size regardless of the zoom level magnification you use.
You can create leaders for the points by dragging the point grip away from the point node, or you can turn off this option in the Point Settings dialog box so that leaders aren’t created when you move the markers (a new option in Release 2).

- The point database is now a Microsoft® Access database that you can sort and print from within Microsoft Access.
- You can now label points by using point labels. You can label the number, name, description, and elevation, as well data from external databases. For example, you can label a point with different elevations obtained from borehole data.
- You can set up external references (or XDRefs) to external databases for points by using the XDRef Manager, which allows you to display extended point data, or use the point object as a database display object for information other than the point data.
- You can create point groups, which makes it much easier to manage large groups of points, by using the Point Group Manager.
- You can “override” point database values with either fixed information or information from an external database when you reference points in a point group.
- The Description Key Manager was developed for creating and managing description keys. Description key definitions are now stored in databases. You can have multiple description key files per project.

For more information about changes to points for Release 2, see “What’s New in AutoCAD Land Development Desktop Release 2” in Chapter 1, “Introduction.”
Working with the Project Point Database

AutoCAD Land Development Desktop uses a project point database to store the point information for a project. This file is named points.mdb and is stored in the project’s \cogo folder. (For example, c:\Land Projects R2\newproj\cogo\points.mdb.) You are prompted to set up this point database whenever you start a new project.

The AutoCAD Land Development Desktop Points commands, and any Autodesk Civil Design or Autodesk Survey commands that create points, add the points to the point database. If you use Autodesk Survey to import a fieldbook file, then the point data is added to the point database and the observation data is added to the observation database.

This point database is important because:

- All programs in the Land Development Solutions suite—AutoCAD Land Development Desktop, Autodesk Survey, and Autodesk Civil Design—use it.
- You can set it up so that multiple people can access it over a network.
- It stores all the point information outside the drawing and keeps drawing size small.

Because all the point information for a project is stored in this one file, it is much easier to manage the point data for a project. This is especially true when you work on a large project that contains several different drawings or when you work on the same project with other people over a network.

All commands that use point data, such as when you draw a line between points, refer to the point database, not to the drawing. Therefore, you can perform these functions even when the points are not drafted in your drawing. This gives you added flexibility when you work on large projects with thousands of points. By keeping the points out of the drawing, you can speed up screen redraw time significantly.
Because all the point information is stored in the database, you can create a new drawing and insert only the project points that meet specific criteria, such as region, point number range, or description. For example, you can insert points with descriptions associated with the boundary, like iron pipes, corner points, or fence points.

You can limit access to the point database to one person or share it with other people. If you share the point database with other people, then you can use the Lock Points command in the Points menu to protect against unwanted edits to the database.

Key Concepts

- All drawings in a project share a single point database file.
- AutoCAD Land Development Desktop protects against duplicate point numbers. You are prompted for how you want to resolve any duplicates that may arise.
- For users of Autodesk S8 products: The point database project.pdf is now called points.mdb, a file you can open, sort, and print with Microsoft® Access.

Setting Up the Point Database

When you start a new AutoCAD Land Development Desktop project, you are prompted to create the point database before placing any points in the drawing.

Creating the point database involves

- Setting the character limit for point descriptions (2 to 254).
- Choosing whether or not to use point names, and then setting the character limit for point names (2 to 254).
After you create the point database, you can choose the database “open” mode by running the Point Database Setup command. To run this command, select the Point Database Setup command from the Points ➤ Point Management menu.

You can open the database so that only you have write access to it, or you can open it in multi-user mode so that multiple people can open and write to the point database.

If other people are using the point database, then you cannot switch from multi-user to single-user mode until the other people close the point database. To identify which users are currently using the point database, click the Other Users button.

Establishing Point Settings

Before you create or import any COGO points into a drawing, you should set up the point settings. Most importantly, before creating any points, you should establish the Point Creation Settings.

The point settings include:

- Point creation settings
- Point insertion settings
- Point update settings
- Point coordinate settings
- Description key settings
- Point marker settings
- Point text settings
- Point preferences
Changing the Point Creation Settings

The Point Creation settings affect how COGO points are created in a project, and what information you are prompted for when you create points. For example, you can create points with automatic elevations, or you can choose to be prompted for elevations. You can create points that are numbered sequentially, or you can choose to manually number the points that you create.

To display the Point Settings dialog box, choose Point Settings from the Points menu.

When you import points, certain point settings, such as elevation, point number, and description, are not applied. The Import from File command uses the information in the ASCII file that you are importing. However, the Insert To Drawing As Created setting is used for importing points.

If more than one person working on a project over a network is placing points, then each person can adjust the current point number to avoid confusion. One person could set “100” as the current point number, and another person could set “200” as the current point number. The same point number cannot be used twice in a project.
Changing the Point Marker Settings

When you create, insert, or import points into a drawing, the appearance of the points varies depending on the Point Marker settings.

You can choose a custom marker style for the point node.

The point marker settings control how your points appear in the drawing. When you are ready to plot, you can create point labels that can label data from external databases and that can perform description key substitution.

Key Concepts

- If you set the point marker size to a percentage of the screen, then the points are always the same size on screen regardless of the zoom level.
- To change the AutoCAD POINT node style, use the DDPTYPE command.
- By default, AutoCAD Land Development Desktop uses northing and easting coordinates to represent points in space. A northing coordinate is equivalent to a Y coordinate; an easting is equivalent to an X coordinate. From the Coords tab in the Point Settings dialog box, you can choose a different method of coordinate display.

For more information about point settings use Find to look up “Overview of Changing the Point Settings” in the online Help.
Working with Points

After you establish the point settings, you can add COGO point data to a project. To add point data to the point database, you can create points, or you can import points either from ASCII text files or from database files.

To make it easier to select points to reference, AutoCAD Land Development Desktop includes point filters that you can use to select points using one of three methods: from the graphics screen, by typing northing/easting coordinates, or by typing the point number.

Point filters can help you to select the points that you want to edit. The point editing commands automatically update both the drawing and the project with any edits to the points.

Creating Points

AutoCAD Land Development Desktop point creation commands include commands you can use to create points by northing/easting, along an object, by turned angle, and many more. You can create points at intersections, on a slope, on alignments, by referencing a surface, and by interpolating.

Key Concepts

- Points that you create using the commands on the Points menu are always added to the point database.
- Point prompts are different, depending on how you set up the Point Creation Settings. These settings allow you to assign elevations and descriptions to points.
- To create points by referencing geodetic directions, you must first choose the current zone for the drawing from the Drawing Setup dialog box.
To create points by northing/easting

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use ( \text{Fed} ) to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Points menu, choose Point Settings.</td>
<td>Overview of Creating Points</td>
</tr>
<tr>
<td>2 Click the Point Creation tab to change the Point Creation settings. These settings determine what pieces of information you are prompted for, what information is created automatically for the points, and whether the points you create are inserted into the drawing.</td>
<td>Overview of Changing the Point Creation Settings</td>
</tr>
<tr>
<td>3 From the Points menu, choose Create Points ➤ By Northing/Easting.</td>
<td>Create Points at Northing/Easting Coordinates</td>
</tr>
<tr>
<td>4 Type the northing of the point you want to create.</td>
<td></td>
</tr>
<tr>
<td>5 Type the easting of the point you want to create.</td>
<td></td>
</tr>
<tr>
<td>6 Type the description and elevation for the point if you are prompted for them.</td>
<td></td>
</tr>
<tr>
<td>7 Continue to type northings and eastings for additional points, or press ENTER to end the command.</td>
<td></td>
</tr>
</tbody>
</table>

**Importing Points**

A quick and effective way to place points in a project is to import them. You can use the Import Points command to import point ASCII files, import data from a Microsoft® Access database file, and import points from another project’s point database.

For example, if a surveyor collected point data by using a data collector, the data can be downloaded as an ASCII file and then imported into the AutoCAD Land Development Desktop project.

To do this:

- Download the point data from a data collector as an ASCII text file using data collector software.
- Create an import/export format that specifies what information is in the ASCII file.
- Import the points using the import/export format.
  All points you import are added to the project point database.
Coordinate Zone Transformations

You can perform coordinate zone transformations while importing points. For example, if you import points based on lat/longs into a drawing that uses a UTM zone, then you can specify which zone the points are being imported from. When the points are imported, they are converted to the drawing's coordinate zone. For more information about performing coordinate zone transformations see “Performing Geodetic Transformations on Points” in this chapter.

To create an import/export format and import points

Steps

1. From the Points menu, choose Import/Export Points ➤ Format Manager to display the Format Manager dialog box.

Several default import/export formats are available for you to use. You can select one and click View to see how the format is set up.
To create an import/export format and import points (continued)

Steps

2. Click the Add button to display the Select Format Type dialog box.

![Select Format Type dialog box]

3. Choose which type of import/export format you want to create. For example, to import an ASCII file, select User Point File and click OK.

The Point File Format dialog box is displayed.

![Point File Format dialog box]
To create an import/export format and import points (continued)

Steps

4 Click the column headings (the <unused> buttons) to establish the format.

The Select Column Name dialog box is displayed.

5 Select the name of the column. For example, if the first column in an ASCII file contains the point number, then the first column must be set up for point numbers.

Each column must be unique—after you use one column name option, it is removed from the list of available column names.

TIP If you can’t remember the order of the information in the ASCII file, then click the Load button to load the ASCII file into the dialog box so you can see the information that it contains.

6 Click OK to return to the Point File Format dialog box.

7 Select the Delimit check box and choose the file delimit method. For example, if you set up the ASCII file so that each piece of information is separated by commas, then type a comma (,) in the Delimit box.

8 Name the format and close the dialog box.
To create an import/export format and import points (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
<th>to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>9</td>
<td>From the Points menu, choose Point Settings and click the Create tab.</td>
<td>Add Points to the Drawing as Points Are Created</td>
</tr>
<tr>
<td></td>
<td>If you want to import the points into the database only, then clear the Insert to Drawing as Created check box. This significantly increases the speed of the import. You can specify which points you want to bring into the drawing from the project point database later using the Insert Points to Drawing command from the Points menu.</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>From the Points menu, choose Import/Export Points ➤ Import Options to display the COGO Database Import Options dialog box.</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Use the options in the COGO Database Import Options dialog box to determine how to resolve duplicate incoming points, what to do when point numbers are assigned by the source file, and what to do when point numbers need to be assigned.</td>
<td>Change the COGO Database Import Options</td>
</tr>
</tbody>
</table>
To create an import/export format and import points (continued)

Steps

12 From the Points menu, choose Import/Export Points ➤ Import Points to display the Format Manager - Import Points dialog box.

13 Select the source format and the file that you want to import.

14 Select the Add Points to Point Group check box to add the imported points to a point group, then select or create a point group.

15 Click OK to import the points.

For more information about import/export formats use Find to look up “Overview of Importing and Exporting Points” in the online Help.

Setting Up ASCII Files to Import

If you want to set up your own ASCII text files to import, then you can use Notepad. When you type the point information into Notepad, be sure that the information for each point has its own line. You can separate or “delimit” the information for each point using commas or spaces.

All AutoCAD Land Development Desktop points require point numbers. If the ASCII text file or Microsoft Access database that you import has no point numbers, then AutoCAD Land Development Desktop automatically numbers the points sequentially.
Exporting Points

To export points from the COGO point database to an ASCII text file, you must set up an import/export format. The export format should reflect the point information that you want to export. For example, you can set up an export format to export point number, northing and easting, elevation, description, and latitude and longitude to an ASCII text file.

You can export points from the project point database in order to either create reports of the project point data or to upload to a data collector.

Selecting Points by Using Point Filters

When you are using any AutoCAD Land Development Desktop command that prompts you to select a point in the drawing, you can

- Select any point on the screen by using object snaps or by typing X,Y coordinates.
- Use an AutoCAD Land Development Desktop point filter.

Point filters make it easy for you to accurately retrieve coordinate points from the point database or to select points from the drawing. Point filters are simply a letter, preceded by a period, that you can type at any “Select Points” prompt. For more information, see “Using Point Filters to Select Points” in the online Help.

- You can type .P and then type a specific point number.
- You can type .G and then select the point in the drawing.
- You can type .N and then type the point’s northing and easting coordinates.

For example, you could use the .G graphical selection filter to pick any part of a point object on screen. This retrieves the exact coordinates of the point object from the point database.
Key Concepts

- Point filters remain active until you turn them off by typing the filter again, or until you select another filter.
- You can use the .P filter to select points that are in either the drawing or in the project database.
- Points must be displayed in your drawing in order to use the .G graphical selection filter.

To use point filters

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Select a command that prompts you to select points. For example, from the Lines/Curves menu, choose Line.</td>
<td>Draw a Line by Selecting Start and End Points</td>
</tr>
<tr>
<td>2 At the Starting point prompt, type .P to turn on the point number filter. The command line changes to a prompt for a Point number.</td>
<td>Use Point Filters to Select Points</td>
</tr>
<tr>
<td>3 Type the number of the point at which you want to start the line. The command line prompts you for another point number.</td>
<td>Selecting Objects that Are Close Together</td>
</tr>
<tr>
<td>4 If you want to select the next point by selecting it from the screen, then type .G. The command line prompts you to select a point object, and the cursor turns into a pickbox.</td>
<td></td>
</tr>
<tr>
<td>5 Select the next point from the screen using the pickbox.</td>
<td></td>
</tr>
<tr>
<td>6 Continue to select points, or press ENTER to end the command and draw the line.</td>
<td></td>
</tr>
</tbody>
</table>

**NOTE** You can turn off a point filter by retyping the same filter on the command line.
Editing Points

You can edit COGO points in two ways. The method that you use depends upon your preferences, as well as whether the points are in the point database only or located in the drawing as well.

The recommended method is to use the Edit Points commands on the Points menu. These commands update the project point file, as well as the points in the drawing. Use these commands if you want the point database to be automatically updated to match the graphic changes, or if the points that you want to edit are in the project point database but are not visible in the drawing.

You can use the CAD commands that you already know, such as MOVE or ERASE, to edit the points in your drawing. When you are ready to update the project point database, you can use the Modify Project command from the Points ➤ Check Points menu.

Key Concepts

- The commands in the Edit Points menu, such as Points ➤ Edit Points ➤ Erase, change both the drawing and database simultaneously. CAD editing commands, like ERASE, change only the drawing, not the database.
- You can lock points to protect them against unwanted edits by selecting Points ➤ Lock/Unlock Points ➤ Lock Points. You can select the points to lock either by selecting them from the drawing, or by typing a range of point numbers.
- You can select the “Allow Points to be MOVE’d in Drawing” check box on the Update tab in the Point Settings dialog box if you want to use the AutoCAD MOVE command to edit points. To update the project point database when you use the MOVE command, you must also select the “Update Point Database After MOVE Command” check box.
### To edit points using AutoCAD Land Development Desktop commands

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [F3] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 With points in the drawing (or in the point database only), select a point editing command, such as Move, from the Points ➤ Edit Points menu.</td>
<td>Overview of Editing Points</td>
</tr>
<tr>
<td>2 Select the points you want to move.</td>
<td></td>
</tr>
<tr>
<td>3 Select a base point and a point of displacement to move the point(s).</td>
<td></td>
</tr>
</tbody>
</table>

### To edit points using CAD commands

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [F3] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 With points in the drawing, select a CAD editing command like ERASE.</td>
<td>ERASE Command</td>
</tr>
<tr>
<td>2 After you edit the points, choose Modify Project from the Points ➤ Check Points menu to update the project with the changes that you made to the points in the drawing.</td>
<td>Update the Project Point Database with Drawing Point Information</td>
</tr>
</tbody>
</table>

### Drawing Point and Project Point Synchronization

The project points may not match the drawing points in several situations. For example, the project database won’t match the drawing points if you do any of the following:

- Use CAD commands such as ERASE or COPY to modify the points.
- Edit points in the drawing and database, and then quit the drawing without saving it.
- Restore an old version of a drawing.
- Edit points in one drawing and then open another drawing that contains the same points.
Whenever you want to change the drawing so that it matches the project point database, or if you want to change project points to match the drawing, you can use the Check Points commands on the Points menu. These commands are invaluable for managing the project point database and drawing points. You can use these commands to

- Add project points to the drawing.
- Remove drawing points from the project.
- Modify drawing points to match the project.
- Add drawing points to the project.
- Remove project points from the drawing.
- Modify project points to match the drawing.

**Performing Geodetic Transformations on Points**

AutoCAD Land Development Desktop has geodesy commands that you can use to relate survey data to mathematical models of the earth. Using the geodesy commands you can

- Calculate the latitude and longitude, State Plane, or UTM coordinates of a point.
- Convert point data that is in another coordinate zone into the current drawing's coordinate zone when you import points.
- Convert point data in your project from one coordinate system to another.

You can choose the current zone from over 350 different zones. These zones include UTM projections, and NAD27 and NAD83 State Plane grids. Commands are also provided for you to edit zones and create new zones.

You can use geodetic calculations, related to the current zone, whenever you have any high-order survey calculations to complete, or if you must tie a survey into either state plane coordinates or UTM map projections.

You can also set the transformation settings for the whole drawing. These relate the assumed local northing/easting coordinates of your survey to the selected current zone.
Key Concepts

- The State Plane coordinates are expressed as grid northing and grid easting coordinates.
- Local northing and local easting coordinates, the assumed coordinates, are equivalent to the COGO point coordinates in the point database.
- The Geodetic Calculator supplies “missing” information related to the current zone. For example, if you know the latitude and longitude of a point, then you can type this information into the calculator to compute the grid northing/easting coordinates. You can then use this information to set the Transformation Settings for the whole drawing.
- After you set the Transformation Settings for a drawing, you can enter the local northing/easting coordinates into the Geodetic Calculator to compute either the grid coordinates or latitude and longitude of any point.
- You can create and edit all data used to create various projections.

Calculating State Plane Coordinates from a Known Latitude and Longitude

You can use the Geodetic Calculator to relate local northing and easting coordinates to a State Plane coordinate system by using a known latitude and longitude that you collect using a Global Positioning System (GPS) receiver.

After you calculate the grid coordinates, you can set the transformation settings for the whole drawing. This lets you calculate the grid coordinates or latitude and longitude of any point in your survey.

The following task supposes that you took two separate GPS latitude/longitude readings on two different points, and also recorded these two points’ local northing and easting readings.
To calculate State Plane coordinates from GPS data

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. From the Projects menu, choose Drawing Setup to display the Drawing Setup dialog box.</td>
<td>Change the Current Zone for a Drawing</td>
</tr>
<tr>
<td>2. Click the Zone tab and select the current zone for the drawing.</td>
<td></td>
</tr>
<tr>
<td>3. From the Points menu choose Point Utilities ➤ Geodetic Calculator to display the Geodetic Calculator dialog box.</td>
<td></td>
</tr>
<tr>
<td>4. Type the latitude and longitude of the first point that you observed with your GPS into the dialog box.</td>
<td>Use the Geodetic Calculator</td>
</tr>
</tbody>
</table>

The calculator automatically displays the grid northing and grid easting coordinates for the point, related to the current zone that you selected in step 2. Make a note of these coordinates.
To calculate State Plane coordinates from GPS data (continued)

### Steps

5. Type the latitude and longitude of the second point that you collected and make a note of the grid northing and grid easting coordinates.

You can now use these grid northing and easting coordinates to set the transformation settings for the drawing.

6. From the Projects menu choose Transformation Settings to display the Geodetic Transformation Settings dialog box.

#### Transformation Settings

<table>
<thead>
<tr>
<th>Zone Description</th>
<th>WGS 1984 UTM Zone 19 North, Noise</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image.png" alt="Image" /></td>
</tr>
</tbody>
</table>

- **Grid Scale Factor**: Change the Geodetic Zone Transformation Settings
- **Reference Point**: Point Number
- **Grid Northing**: 0.0000
- **Grid Easting**: 0.0000
- **Rotation to Grid North**: 0.0000
- **Grid Azimuth**: [Field](field.png)

7. Select the Apply Transform Settings check box.
To calculate State Plane coordinates from GPS data (continued)

Steps

8 Into the Reference Point section, type the grid northing and grid easting coordinates for the first point that you calculated with the Geodetic Calculator.

Type the local northing and easting coordinates for the same point. Or, if you already placed that point in your drawing, you can click the Reference Point button and select the point from your drawing. You can also type the point number to retrieve the local northing and easting coordinates.

9 Repeat step 8 using the second set of grid northing and easting coordinates, but enter the information in the Rotation Point section.

10 Click OK to apply the transformation settings.

11 From the Points menu choose Point Utilities ➤ Geodetic Calculator.

Now you can use the Geodetic Calculator to query the grid northing/easting and latitude/longitude of any point in your survey.

12 Type the local northing and easting coordinates, and the grid coordinates and latitude/longitude are calculated automatically.

NOTE For more information about performing zone conversions, see “Performing Zone Conversions Using AutoCAD Map” in Chapter 8, “AutoCAD Map and AutoCAD Land Development Desktop.”
Managing Points

After you create or import points into the project, you can manage the points in several different ways:

- To control which points are in the drawing and project, you can check for discrepancies between the project points and the points in the drawing.
- Whenever you want to view the project points, you can insert them into the drawing using a variety of selection methods.
- To prevent points from being edited, you can lock selected points.
- To make it easier to select points to insert, edit, or use for a surface, you can create point groups.
- To associate a symbol and a full description with a point, you can set up description keys. Description keys translate a point’s existing description and they can place a symbol at the point node, place the symbol on a layer, and place the point on a layer.
- To override data in point groups, or to label points with information other than what exists in the point database, you can create External Data References (XDRefs) to Microsoft Access database files.
- For surveying, you can generate stakeout reports.

Controlling Which Points are in the Drawing and Project

To control which points are in the drawing and in the project, you can use the insert/remove points commands and the check points commands.

- When you create and import points, you can either add them to the drawing or not, but they are always added to the point database. You can add points to a drawing from the point database at any time by using the Insert Points to Drawing command from the Points menu.
- To remove points from the drawing, use the Remove Points from Drawing command from the Points menu. When you remove points from the drawing, they are not deleted from the point database.
If more than one person is working on the project and adding points to the point database, then the points in your drawing may not match the project points. You can update the drawing with the project points by using the Modify Drawing command from the Points ➤ Check Points menu. The following illustration shows the options available when you use this command:

![Modify Drawing Points from Project Database](image)

If you have points in a drawing that do not exist in the project, or if you have used the ERASE command to erase points in a drawing, then you can update the point database by using the Modify Project command from the Points ➤ Check Points menu.

**Locking and Unlocking Points**

If you have control points such as benchmarks in a project, then you may want to use the Lock Points command from the Points ➤ Lock/Unlock Points menu to lock those points to prevent them from being changed. For example, you may want to lock points that were collected with a GPS (Global Positioning System) receiver.

At a later time, if you discover that the datum elevation of the survey was miscalculated, then you can unlock the points using the Unlock Points command, edit the datum elevation, and then lock the points again.
**Working with Point Groups**

Point groups are named collections of point numbers that you can select when editing and inserting points, and when choosing points to add to a surface. By saving a collection of points with a name, you do not need to manually select the points each time you perform an operation. A point group does not store point information; the point database always handles point storage. The point group feature lets you organize the points into smaller, more manageable groups.

Point groups can override existing point data that is contained in the point database. For example, you can create a point group, and establish a fixed description for all points in that group in order to identify the group in the drawing. Or, you can reference an external database file to override the information in the point database. This information can be different for each point. For example, you can substitute different elevations for all the points to create a point group of borehole data.

The following diagram shows how the data is taken from the project point database. Then, if any overrides are defined, either manually or by linking with a user database, the overrides are applied to the points as they are inserted or imported as a group. No substitution is ever applied to the point database itself.
To create and use point groups

Steps

1. From the Points menu, choose Point Management ➤ Point Group Manager to display the Point Group Manager dialog box.

2. From the Manager menu, choose Create Point Group or click to display the Create Point Group dialog box.

3. Type a name for the point group.
To create and use point groups (continued)

Steps

4  Click Build List to display the Point List dialog box.

5  Use the selection options to build the list. There are simple options and advanced options for building a point list. To use the advanced options, click the Advanced button.

6  Click OK twice to create the point group and then close the Point Group Manager.

7  From the Points menu, choose Lock/Unlock Points ➤ Lock Points.

   The following prompt is displayed:

   Points to Lock (All/Numbers/Group/Selection/Dialog) ? <All>:

8  Type Group.
To create and use point groups (continued)

Steps

9  Type the name of the group that you just created, or type Dialog to display the Select a Point Group dialog box, from which you can select the point group.

The points in the group that you selected are now locked.

10 From the Points menu, choose Lock/Unlock Points ➤ Locked #s to see the list of points that were locked.

For more information about point groups use to look up “Overview of Point Groups” in the online Help.

Working with Description Keys

You can use description keys to associate symbols with points and to control point and symbol layers. You define the description keys, and then any time you create or import a point with a description that matches the key, the point is placed in the drawing with the symbol, and the point and symbol are placed on the specified layers.

When you create points, you are prompted for the point number, point elevation, and point description. A description key is essentially a replacement for the point description. For example, for a tree, you can enter TREE as the description. If TREE has been defined as a description key, and has a symbol associated with it, then a tree symbol is created for that point.

By associating points with a “key” and a symbol, you can easily

- Insert a symbol along with the point in order to visually distinguish the different types of points in your drawing.
- Specify the layers on which to insert the point and the symbol.
- Scale and rotate the symbol that is inserted with the point.
AutoCAD Land Development Desktop includes many symbols that you can use for description keys. These symbols are stored in the `c:\Program Files\Land Desktop R2\data\symbol manager\cogo` folder. You can also create a custom symbol to use in your drawing, and then use the `WBLOCK` command to save the block to the symbol folder.

If you edit description keys, you can update the drawing with the new settings by using the Modify Drawing command from the Points ➤ Check Points menu.

**The Relationship Between Description Key Usage and Point Markers and Point Labels**

To fully implement description key substitution, you must format and use a label style that is set up to use description keys. The label style may insert only a symbol, or it can label the point with point number, full description, and any other point value.

When using point markers, the full description can be substituted for the raw description, but symbols are not inserted unless you use a point label style.

The following illustration shows the relationship between point markers, point labels, and description keys.
The point label style controls whether description key matching is on or off, whether full descriptions are substituted for raw descriptions, and whether description key symbols are inserted. The following illustration shows the options on the Point Label Styles tab (select Labels ➤ Edit Label Styles) that control the description keys.

### Description Keys and Point Settings

If you set points manually, and you want to use description key substitution, then you should select the Manual option under Descriptions on the Create tab of the Point Settings dialog box, unless all of the points have the same description key code. When you are prompted for a point’s description, type the description key code. You do not need to select this setting if you are importing points from a file.

### Key Concepts

- All drawings within a project can use the description keys that you set up, so multiple people working across a network all have access to the same key codes.
- Description keys are saved to external files. Each project can have multiple description key files.
- You can save description key files to prototypes so that you can load them into new projects.
- You can use wild card characters when you create description keys. Wild cards expand the flexibility of description keys. For example, if you create a description key named T*, then any point whose description starts with T, such as Topo, T-1, T2, is assigned the description key symbol.
Adding a Utility Pole Description Key

The following example shows how you can create a description key using a symbol included with AutoCAD Land Development Desktop.

The scenario: You want to create points that represent utility poles and use a prefix of “UP” for all these points. For example, UP5A, UP4B, and so on.

By using wild card characters, you do not need to create a description key for each point description—you just create a description key that references the “UP” prefix.

**Steps**

1. From the Points menu choose Point Settings to display the Point Settings dialog box.
2. Click the Insert tab.
3. Under Search Path for Symbol Block drawing files, click Browse, and locate the following folder.
   `c:\Program Files\Land Desktop R2\data\symbol manager\cogo`
4. Click OK.
5. From the Points menu, choose Point Management ➤ Description Key Manager to display the Description Key Manager dialog box.

---

---

**To create description keys**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
<th>to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
To create description keys (continued)

Steps

6 From the Manager menu, choose Create Description Key or click to display the Create Description Key dialog box.

7 For this example, type UP* as the DescKey Code.

   The asterisk (*) matches any point description that starts with UP. For example, UP5A, UP5B.

8 Type $* as the Description Format.

   These wildcard characters keep the point description the same as when you enter it, so you can distinguish between UP5A and UP4B. However, you can assign a new, full description if desired—this description is then used for all the utility poles.

9 Type PTS_UP as the Point Layer. This places the point objects on the PTS_UP layer.

10 From the Symbol Block Name list, select U_POLE.

11 In the Symbol Layer box, type the layer for the symbol.
To create description keys (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use Find to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>12 Click OK, and then close the Description Key Manager dialog box.</td>
<td></td>
</tr>
<tr>
<td>13 From the Labels menu, choose Edit Label Styles and then click the Point Label Style tab.</td>
<td></td>
</tr>
<tr>
<td>14 In the Name box, type Desckey style.</td>
<td></td>
</tr>
<tr>
<td>15 In the Data list, choose Point Number and click the Text button.</td>
<td></td>
</tr>
<tr>
<td>16 After (Number) in the text box, press ENTER to insert a carriage return.</td>
<td></td>
</tr>
<tr>
<td>17 In the Data list, choose Description and click the Text button.</td>
<td></td>
</tr>
<tr>
<td>18 Under Description Keys, select the DescKey Matching On check box, select the description key file, and select the Insert DescKey Symbol check box.</td>
<td></td>
</tr>
<tr>
<td>19 Click Save and then click OK.</td>
<td></td>
</tr>
<tr>
<td>20 From the Labels menu, choose Show Dialog Bar and make the Desckey point label style the current point label style.</td>
<td></td>
</tr>
<tr>
<td>21 From the Points menu, choose Point Settings.</td>
<td></td>
</tr>
<tr>
<td>22 Click the Insert tab and select the Use the Current Point Label Style When Inserting Points check box.</td>
<td>Change the Point Insertion Settings</td>
</tr>
<tr>
<td>23 Click the Create tab.</td>
<td></td>
</tr>
<tr>
<td>24 Under Description, select the Manual option.</td>
<td></td>
</tr>
<tr>
<td>25 Click OK.</td>
<td></td>
</tr>
<tr>
<td>26 From the Points menu, choose Create Points ➤ Manual.</td>
<td>Create Points at Selected Coordinates</td>
</tr>
</tbody>
</table>
To create description keys (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [Find] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>27</td>
<td>Pick the location for a new point.</td>
</tr>
<tr>
<td>28</td>
<td>When you are prompted for the description, type UP1A. The description, UP1A, and the utility pole symbol are placed with the point, and the point and the symbol are placed on the specified layers.</td>
</tr>
</tbody>
</table>

For more information about description keys use [Find] to look up “Overview of Description Keys” in the online Help.

Working with External Data References (XDRefs)

If you want to override data that is in the point database when using point groups, or if you want to label points with information other than what is available in the point database, then you can use External Data References, or XDRefs. An XDRef is a link to a column of data in a Microsoft® Access database.

For example, if you have borehole data that you want to label your points with, you can add the data to an Access file, create the XDRefs, and then label the points with the data. Or you can use the point object as a database display object for information other than point data. For example, you can label the point or override point data with database information such as the abutting names and addresses, or parcel areas. You must create an XDRef for each column of data that you want to use.
**Key Concepts**

- Data substitution in point groups with XDRefs is limited to point name, point label style, description, and elevation. However, you can add any data you want to point labels.
- XDRefs never actually change the point database information. They only substitute information for what exists in the database or append data to the labels. However, if you use elevations from an external file, then those elevations are used when creating a surface, not the elevations within the point database.
- XDRefs can be made only to Microsoft Access databases.
- The XDRef database, XDRefs.mdb, which contains the links to the columns in external databases, is stored in the `c:\Land Projects R2\<project name>\cogo` folder and is used for all XDRefs in the project.

**To use XDRefs to label points**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use <code>F4</code> to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Populate the sample user database in the current project with some information that you can experiment with. To do this, use Microsoft Access to open the SampleUserDB.mdb in the <code>c:\Land Projects R2\&lt;project name&gt;\cogo\User Db</code> folder. This sample file is copied into every new project that you create.</td>
<td>Create an External Point Database with Microsoft Access</td>
</tr>
<tr>
<td>2 Add some sample data to SampleTable1, such as elevations and descriptions.</td>
<td></td>
</tr>
<tr>
<td>3 Save the file and exit Microsoft Access.</td>
<td></td>
</tr>
<tr>
<td>4 Create a new project and a new drawing in AutoCAD Land Development Desktop.</td>
<td></td>
</tr>
<tr>
<td>5 From the Points menu, choose Point Management ➤ XDRef Manager to display the XDRef Manager dialog box.</td>
<td></td>
</tr>
</tbody>
</table>
To use XDRefs to label points (continued)

Steps | Use 
--- | ---
6 From the Manager menu, choose Create XDRef to display the Create External Data Reference dialog box. | Create an External Point Data Reference

| Create External Data Reference |
| Name: | 
| Database Name: | 
| Table Name: | 
| Column Name: | 

7 Type a name for the external data reference. This name should indicate what type of information you are linking to. For example, if you are linking to description data for boreholes, you can name the XDRef “Borehole-Desc1.”

8 Click to select the database to use. The database you are linking to can be located anywhere on your system.

9 Select SampleUserDB.mdb in the following folder.
   c:\Land Projects R2\<project name>\cogo\User Db
   After you select the database, the Table Name and Column Name fields become active.

10 From the Table Name list, select SampleTable1. This list shows all the tables that exist in the database that you selected.
### To use XDRefs to label points (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use Find to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>From the Column Name list, select Desc1. This list shows all the columns that exist in the table that you selected. The dialog box should appear as shown in the following illustration.</td>
</tr>
<tr>
<td><img src="image" alt="Create External Data Reference dialog box" /></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Click OK to create the external reference.</td>
</tr>
<tr>
<td>13</td>
<td>From the Labels menu, choose Edit Label Styles.</td>
</tr>
<tr>
<td>14</td>
<td>Click the Point Label Styles tab.</td>
</tr>
<tr>
<td>15</td>
<td>In the Name box, type a new name to create a new label style, such as Borehole.</td>
</tr>
<tr>
<td>16</td>
<td>From the XDRef list, select the name of the XDRef that you just created in step 6, such as “Borehole-Desc1.”</td>
</tr>
</tbody>
</table>
### To use XDRFs to label points (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use <a href="#">Find</a> to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>17</strong> Click the Text button to add that XDRF to the label style.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>For a borehole label, you may want to label the points with multiple descriptions and elevations. You can also add any other point data, such as point number, to the label style.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
|   The upper-left section of the dialog box should appear similar to the following illustration: | ![Illustration](image)
| 18 Click Save to save the style, then exit the dialog box. |  |
| **19** From the Points menu, choose Point Settings. Click the Insert tab, and verify that the Use Current Point Label Style When Inserting Points check box is selected. |  |
| **20** From the Labels menu, choose Show Dialog Bar. |  |
| **21** Select the Borehole style as the current point label style. |  |
| **22** Create a point. | The point is labeled and the XDRF information is added to the label. |
|  
| For more information about XDRFs, use [Find](#) to look up “Overview of Using External Point Data References” in the online Help. |  |
To increase your productivity, take some time to learn the AutoCAD Land Development Desktop drawing and editing tools. You can work in different modes, snap to objects for accuracy, and use grips to edit objects quickly.
Introduction

This chapter describes how to use the geometry creation and editing tools in AutoCAD Land Development Desktop. Some of the topics include:

- Working in paper and model space
- Working in floating viewports
- Using drawing tools to create geometry
- Capturing data by digitizing paper drawings or raster images
- Editing objects and correcting mistakes
- Creating blocks

Working in Model Space and Layout Mode

To enhance your productivity, you need to know when to use model space and when to use a layout, also known as paper space. Model space is where you draw design elements, and paper space is where you configure drawing views for plotting.

You can control whether your drawing screen shows a model space view or a paper space view by using the Model and Layout tabs at the bottom of the AutoCAD drawing window.

Model  Layout1  Layout2

Click a Layout tab to view a layout, and click the Model tab to return to model space.

Model Space

When you start a drawing, typically you begin in a single model space viewport. Model space is the environment in which you normally design and create 2D or 3D drawings. At any time while you are working with drawings in model space, you can switch to a layout to set up a drawing sheet for plotting or printing.
In model space you can work in one or multiple Viewports. To make it easier to work on more than one portion of a drawing without having to constantly zoom or restore views, you can configure model space to use multiple, or tiled, Viewports. Only one Viewport is active at a time. Click a Viewport to make it active and to work in it.

**Steps**

1. From the View menu, choose Viewports ➤ New Viewports to display the Viewports dialog box.
2. Select the name of the Viewport configuration that you want to use.
3. Click OK to return to the drawing.
4. With the pointing device, select a Viewport to make it current.

---

**Using Tiled Viewports**
Paper Space and Layout Mode

After you complete your drawing in model space, you can arrange a layout of the drawing views to be printed or plotted. Switch to a layout by clicking a Layout button at the bottom of the drawing screen, or by clicking MODEL on the status bar. In a layout, you can create and arrange floating viewports that contain views of the drawings that you created in model space.

Tiled viewports differ from the viewports arranged in paper space. Paper space viewports, also known as floating viewports, are used to establish a final layout for a drawing. They can overlap and be plotted at the same time. For more information about paper space viewports, use the Find tab to look up “Creating Floating Viewports” in the online Help.

When you choose a Layout tab for the first time in a drawing session, a single viewport is displayed, and a sheet with margins indicates the paper size of the currently configured plotter and printable area of the paper. AutoCAD Land Development Desktop displays the Page Setup dialog box, in which you specify layout and plot device settings. Setting the plot settings and using Preview, you can visualize the resulting layout without actually plotting. The layout settings you specify are stored with the layout.

You use the same commands from the View menu by choosing Viewports ➤ New Viewports, to create viewports in a layout mode as you do in model space, but you can also create irregular shaped polygonal viewports in a layout.

Key Concepts

- You can place floating viewports anywhere on the drawing sheet in paper space. By default, each new layout has one floating viewport that fills the entire display, or you can design a layout sheet with multiple viewports.
- When you use paper space to create text and dimensions, you can apply the correct scaling relations between drawing objects and text and dimensions.
To create an irregular viewport in paper space

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use ( \text{Fnd} ) to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>To change to a layout in paper space, click a layout tab or click MODEL on the status bar.</td>
</tr>
<tr>
<td>2</td>
<td>From the View menu, choose Viewports ➤ Polygonal Viewport.</td>
</tr>
<tr>
<td>3</td>
<td>Draw the viewport shape on the layout. You can use straight line segments or curves to draw the viewport.</td>
</tr>
<tr>
<td>4</td>
<td>Type Close to join the last segment of the viewport boundary with the viewport start point.</td>
</tr>
<tr>
<td>5</td>
<td>Model space is regenerated and the drawing objects become visible in the layout viewport.</td>
</tr>
</tbody>
</table>

For more information, use \( \text{Fnd} \) to look up “Working with Layouts” in the online Help.

Controlling the Display in Floating Viewports

After you create floating viewports in the paper space layout, you can control the visibility of objects in the viewports in several ways. For example, you can freeze and thaw layers, hide lines, and use different views of the drawing, such as different magnification, orientations, or viewpoints.

After you create a floating viewport on the drawing sheet you can move it, resize it, and overlap it with other viewports. You can use a view of tiled viewports within one floating viewport, and then arrange it with other viewports on the layout page.

Key Concepts

- You can edit the contents of the floating viewport by returning to model space. To do this, click PAPER on the status bar. For more information, see “Switching to Model Space” in the online Help.
- Objects that are created in paper space, for example, a border, are visible only in paper space and cannot be edited in model space.
If you plan to plot viewports with different scales, it is recommended that you add dimensions in paper space.

- You can put dimensions and annotations on another layer, and you can make that layer visible or invisible.
- You can turn off viewports that you do not want to plot. You can also turn off a viewport when you move or resize it to avoid regeneration of the drawing.

For more information, use \textit{Find} to look up “Controlling Visibility in Floating Viewports” in the online Help.

\section*{Working with \textsc{AutoCAD Land Development Desktop Drawing Tools} to Create Lines and Curves}

You can use several methods to draw lines and curves in your drawing. For example, you can use:

- \textsc{AutoCAD Land Development Desktop} Line, Curve, and Spiral commands on the Lines/Curves menu. By using these commands, you can reference points in the COGO point database.
- Commands like LINE, ARC, and POLYLINE to draw simple objects. For more information, see “Working with Basic \textsc{AutoCAD} Commands to Create Objects” in this chapter.
- Autodesk Survey Command Line commands (if you have the Autodesk Survey program installed).
- Special Lines.

Using \textsc{AutoCAD Land Development Desktop} Line and Curve commands, you can draft lines and arcs in your drawing by referencing the COGO points that are in the project point database. Therefore, you can use the point filters to select points by number or from the graphics screen.

Line and Curve creation commands run from the simple to the complex. For example, there is a command to draw a line by selecting two points, as well as a more complex line command to draw a best fitting line between points using the least squares adjustment method.
Drawing Spiral Curves

Spiral curves are often used in roadway design to achieve more gradual transitions. Instead of having a constant rate of curvature like an arc, the spiral’s curvature is adjusted throughout—a more gradual curvature at the beginning, and then increasing the curvature until the SC (spiral-to-curve) intersection is reached.

AutoCAD Land Development Desktop supports four types of spirals: Clothoid, Quadratic, Cosinusoidal, and Sinusoidal. Each spiral type has a different rate of curvature, as shown in the following illustration.
For most purposes, you can use the Clothoid spiral. However, when designing for extremely high-speed travel, such as for the high-speed rail systems of Europe and Japan, use spirals with quadratic, cosinusoidal, or sinusoidal curvature functions.

**Key Concepts**

- Do not try to create spiral curves from the ARC or POLYLINE commands. You must use the spiral commands to create spirals.
- You can create spiral curves using Speed Tables. A certain amount of superelevation information, such as the e value, is associated with the spirals created from speed tables. You can use this superelevation data in Autodesk Civil Design when designing superelevated roads.

**Special Lines**

To help you visually distinguish property features, such as fence and tree lines, AutoCAD Land Development Desktop has a Special Lines command that you can use to draw lines or curves using symbol linetypes. The following illustration shows the treeline special line.

![Special Line](image)

**Key Concepts**

- It often does not matter which method you use to draw objects—use the commands that work best for you. The exception is when you are drawing vertical curves or spirals in designing a roadway. To draw spirals, use AutoCAD Land Development Desktop spiral commands and to draw vertical curves, use the Autodesk Civil Design vertical curves commands.
- After you draw the geometry, you can use the AutoCAD Land Development Desktop database definition commands to define the geometry to databases. For example, you can use these objects to define parcels or roadway alignments.
Working with Basic AutoCAD Commands to Create Objects

You use basic AutoCAD drawing tools to create lines, polylines, curved objects, hatched areas, and text.

Key Concepts

- In general, each basic drawing tool displays prompts for specifying a start point and an endpoint. You can specify these points with the pointing device or by entering coordinate values on the command line.
- As you use the drawing tools, it is important that you pay attention to the command line. Many commands prompt for more options.
- You can use basic objects for reference. For example, polylines can define boundaries, and construction lines can define limits.

Lines

The most basic and functional drawing object is the line. You can draw a line as a single segment or multiple segments, and line segments can contain arcs. You can draw multiple parallel lines and freehand sketch lines. You can draw lines in a variety of styles by using different linetypes and colors. Each line segment is a single object. To draw a series of line segments as a single object, use a polyline. For more information, see “Polylines” in this chapter.

Key Concepts

- Draw a line segment by specifying a start point and an endpoint. A line can be composed of one segment or a series of connected line segments. One option in the LINE command is to close the line segments: the start point of the first line segment joins the endpoint of the last segment.
- You can draw lines accurately by entering coordinate values on the command line.
As you draw lines, use drafting settings such as object snaps or grid snaps. Use ORTHO mode to ensure true horizontal and vertical lines and 90-degree corners.

Press ENTER or ESC to end the LINE command at any time. If you press ENTER twice, the LINE command is interrupted, and you can start a new line.

For more information, use to look up "Drawing Lines" in the online Help.

Construction Lines

You can use construction lines as visual references when creating and placing other drawing objects. The construction line passes through a specified point and extends infinitely in one or two directions.

Two types of constructions lines, Xline and Ray, extend from a specified point to infinity. Xlines extend in two directions. You can place them vertically, horizontally, at an angle, at an offset, or as an angle bisector. Ray extends from a specified start point in one direction only.

You may want to place construction lines on a separate layer with a distinct linetype and color. When you print or plot the drawing, you can freeze or turn off the layer.

For more information, use to look up "Drawing Construction Lines" in the online Help.

Polylines

Polylines are objects whose line segments are connected at vertices, or intersections. Unlike standard line segments, polyline segments can be straight or curved, thin or wide, and even tapered. The segments of a polyline are not separate objects. When you edit a polyline, you change all its line segments at once instead of one at a time. After you select the polyline’s start point, you are prompted to select the following polyline options:

Specify start point:
Current line-width is 0.00
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]:

Chapter 4  Working with Drawing and Editing Tools
146
Key Concepts

■ To make a curved segment in the polyline, select the Arc option and then use the pointing device to specify the arc endpoints. To return to drawing straight line segments, type L (Line) on the command line.

■ To change the width of the polyline segment, select the Width option and specify a width greater than 0. You can also taper the width within each polyline segment by selecting the Halfwidth option. Specify a width at both the start point and the endpoint of the segment.

   NOTE To draw a solid wide line, make sure that the Apply solid fill option on the Display tab of the Options dialog box is selected, or enter fill on the command line and select ON.

■ Specify the start point and endpoint of the polyline segments with the pointing device or by entering coordinate values. To close a polyline (the start point of the first line segment joins with the endpoint of the last segment) use the Close option.

■ You can also create a polyline from the boundaries of overlapping objects or from an object that was drawn using lines and arcs by using the Boundary command.

■ To modify an existing polyline, select Polyline from the Modify menu, or type pedit on the command line to display options for editing polylines. For more information about these options, see “Editing Polylines” in the online Help.

   For more information, use \Find to look up “Drawing Lines” in the online Help.
Curved Objects

You can use various methods to create curved objects, such as circles, arcs, ellipses, and donuts. The method you use depends on the information that you have available.

Key Concepts

- Create a circle by specifying a center point, radius or diameter, or tangent points. Choose a method to create circles depending on how you want to control the sequence of point selection.
- There are several ways to create an arc, but one of the points that you specify is either the center point or the start point. Arcs are drawn counterclockwise from the start point.
- To draw an ellipse, you can specify center points or endpoints. The size of the ellipse is determined by its major (long) axis and its minor (short) axis. After you create the ellipse, you can move the cursor along one or both axes to adjust its size.
- You can draw an elliptical arc by specifying endpoints and axis distance as if you were drawing a full ellipse. A start angle and an end angle that you specify define the arc's start point and endpoint.
- To create either filled rings or solid-filled circles, you can create donuts, which are closed polylines that have widths. Create a donut by specifying the inside and outside diameter and the center.

Curved Lines

You can draw a smooth curve passing though or near specified points in the drawing by drawing a spline-fit polyline.

To draw a curved line

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use \text{F1} to look up</th>
</tr>
</thead>
</table>
| 1 From the Draw menu, choose Spline. You are prompted to select a polyline object or specify a point. | Drawing Spline Curves  
SPLINE Command |
| 2 Specify points along a path where you want to create the curved line. | |

Chapter 4  Working with Drawing and Editing Tools
To draw a curved line (continued)

Steps

3 Press ENTER, and you are prompted for the start tangent and end tangent. These points determine how the spline is displayed.

4 Return the cursor to the start point of the spline to locate the start tangent point, and then do the same for the end tangent point.

You may have to experiment with the placement of the start and end tangent points. After you draw a spline curve, you can edit it with grips.

For more information, use \textit{F1} to look up “Drawing Curved Objects” in the online Help.

Hatch Patterns

In a complex drawing, you can distinguish some areas from other areas with hatch patterns.

Key Concepts

- To control the visibility of hatch patterns, put them on their own layers.
- You can choose from a variety of predefined hatch patterns, or you can define your own.
- You can define the area to be hatched either by specifying a point inside a boundary, or by selecting an object to be hatched, if it is a closed object.
To create complex boundaries for hatching, create a closed polyline or region, or any closed object. You can use advanced hatching options to detect any areas (islands) inside the boundary and control whether they are hatched.

When you edit the hatch boundary, the hatch object adjusts to fit.

### To hatch an area

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use — to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Draw menu, choose Hatch to display the Boundary Hatch dialog box.</td>
<td>Creating an Associative Hatch</td>
</tr>
</tbody>
</table>

![Boundary Hatch dialog box](image)
To hatch an area (continued)

Steps

1. Use [find] to look up

2. In the Boundary Hatch dialog box, click the pattern that is displayed in the Swatch box.

   The Hatch Pattern Palette dialog box is displayed.

   ![Hatch Pattern Palette](image)

   - Select a pattern, and then click OK to return to the Boundary Hatch dialog box.
   - To hatch enclosed areas, click Pick Points. To hatch objects, click Select Objects.

3. Specify a point inside a closed boundary, or select an object.

4. In the Boundary Hatch dialog box, click Apply.

   For more information, use [find] to look up “Hatching Areas” in the online Help.
Working with the Symbol Manager

There are over 700 symbols accessible via the Symbol Manager that you can insert into your drawings. Symbols are an important element in the preliminary design phase, in site drawings, and in completed as-built road plans. As a working tool, symbols, such as fire hydrants and benchmarks, can be placed in a site plan to produce the finished drawing.

Key Concepts

- Symbol palettes and symbol blocks based on APWA (American Public Works Association) symbol standards have been added to AutoCAD Land Development Desktop.
- Within the Symbol Manager, symbols are organized into three levels: sets, categories, and palettes.
- Before you add symbols to your drawing, you can preview them in the Symbol Manager.
- You can add symbols and create new symbol sets. You can create new symbols by editing existing symbols or by creating your own symbols.

To access symbols in the Symbol Manager

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use ( \text{F4} ) to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. From the Utilities menu, choose Symbol Manager.</td>
<td>Overview of Symbol Management</td>
</tr>
<tr>
<td>2. In the Symbol Manager, locate a symbol to insert by selecting a Symbol Set, Category, and Palette.</td>
<td></td>
</tr>
<tr>
<td>3. Select the symbol either graphically or from the list.</td>
<td></td>
</tr>
<tr>
<td>4. Click OK to insert the symbol into your drawing.</td>
<td></td>
</tr>
</tbody>
</table>

For more information about symbol management, use \( \text{F4} \) to look up “Overview of Symbol Management” in the online Help.
Working with Text

An important part of drawing documents is information that you can add to it, such as specifications, labels, titles, and other annotation. To create text in AutoCAD Land Development Desktop, you can choose different fonts in addition to the STANDARD font style. Each font has associated styles, heights, and any special effects, such as inserting text upside down or backwards.

Choose the settings for the text styles in the Text Style dialog box which you can access by selecting Text Style from the Format menu. As you select different fonts, you can view a sample of the text in the Preview section of the dialog box.

To create text in the drawing using the text style you selected, select the Single Line Text or Multiline Text command from the Draw ➤ Text menu.

Key Concepts

- You can adjust the text height, its width (compressed or expanded), and whether you want special effects such as text to display upside down, backwards, or vertical.
- The text can be rotated at an angle to align with angled lines in the drawing.
You can adjust the slant of the text by specifying the oblique settings for the text. For example, you can place text on a line drawn at a 30-degree angle by entering 30 for the oblique value of the text.

When you want to insert short, simple text entries, use single-line text (TEXT command).

Use multiline text (MTEXT command) for longer text entries. You are prompted to define a rectangular area to indicate the text’s position in the drawing. You can customize the text appearance in the Multiline Text Editor dialog box.

Working with Curved Text

A curved text object is called AEC Curvetext, or CText for short. You can create, edit, or move curved text on any curve or circle object in your drawing.

Key Concepts

- You can select the CText grip and move it to rotate the label around the curve. CText always remains legible. If necessary, the text is flipped automatically so that you can read it in plan view.
- You can use the AutoCAD EXPLODE command to explode the CText to individual text objects.
- If you change the position of the curve or circle on which you have placed the text, the text adjusts its position accordingly.
## To create text on a curve

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [F1] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>From the Utilities menu, choose Curve Text ➤ Draw Curve Text, or type <code>ctext</code> on the command line. <strong>Draw Text on a Curve</strong></td>
</tr>
<tr>
<td>2</td>
<td>Select the curve or circle object that you want to label.</td>
</tr>
<tr>
<td>3</td>
<td>Press ENTER to display the Curve Text Editor dialog box.</td>
</tr>
<tr>
<td>4</td>
<td>In the Text Above box, type the text you want placed above the curve.</td>
</tr>
<tr>
<td>5</td>
<td>In the Text Below box, type the text you want placed below the curve.</td>
</tr>
<tr>
<td>6</td>
<td>Select a Text Style. If you select a zero-height style, then also specify a text Height.</td>
</tr>
<tr>
<td>7</td>
<td>Specify an Offset. The offset value is a factor that is multiplied by the text height to produce an offset distance.</td>
</tr>
<tr>
<td>8</td>
<td>Click OK to draw the text on the curve.</td>
</tr>
<tr>
<td>9</td>
<td>Change the position of the label using grips if necessary. If you change the position of the curve that you have placed the text on, the text adjusts its position accordingly.</td>
</tr>
</tbody>
</table>

For more information about drawing text on curves, use [F1] to look up “Overview of Working with Curve Text” in the online Help.
Chapter 4  Working with Drawing and Editing Tools

156

Attaching Notes to Objects

Using Notes, you can attach either text or an external reference document to any AutoCAD object in a drawing. In the Notes dialog box, select the Text Notes tab to attach text to an object and select the Reference Documents tab to attach an external reference document.

Key Concepts

■ You can use the Notes command to add detailed information to a selected AutoCAD object.
■ You can use the Notes command to attach an external reference file (document, spreadsheet, image, or photo) to any AutoCAD object.

To attach text to an object

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use \texttt{Fnd} to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Utilities menu, choose Notes.</td>
<td>Attach Text to an Object</td>
</tr>
<tr>
<td>2 Select the object in your drawing to which you want to attach a note.</td>
<td></td>
</tr>
<tr>
<td>3 Press ENTER to display the Notes dialog box.</td>
<td></td>
</tr>
<tr>
<td>4 Under Text Notes, type the text you want to attach to the object.</td>
<td></td>
</tr>
<tr>
<td>5 Click OK to attach the text to the selected object in your drawing.</td>
<td></td>
</tr>
</tbody>
</table>
Adding Leaders to a Drawing

Leaders are lines that you add to drawings to connect annotation with drawing objects. You can insert leaders that have text or symbols attached to them. There are two methods for adding leaders to your drawing. You can define the attributes of a leader with the annotation settings and then insert the leader in your drawing, or you can insert a predefined leader.

Key Concepts

■ You can insert a leader with attributes that you define by changing the Leader Settings.
■ You can insert a leader with text, describing the properties of an object.
■ You can insert a leader with predefined styles.

To insert a leader that you define

Steps | Use \( \text{Frd} \) to look up
--- | ---
1 From the Utilities menu, choose Leaders ➤ Leader Settings to make changes to the default leader attributes. | Change the Leader Settings
2 From the Utilities menu, choose Leaders ➤ Text Leader, and then select which type of leader you want to insert. | Insert a Leader with Text
3 Specify a start point and endpoint for the leader.
4 Do one of the following:

   If you are inserting a text leader, enter the text that you want to be displayed at the end of the leader.

   If you are inserting a symbol leader, enter any symbol attributes that you want to be displayed in the leader symbol.
To insert a predefined leader

Steps | Use to look up
--- | ---
1. From the Utilities menu, choose Leaders ➤ Predefined Leaders to display the Leaders dialog box. | Insert Leaders with Variable Pointers

2. Select the leader that you want to insert and click OK.

3. Depending on the leader that you select to insert, specify the leader attributes.

For more information about leaders, use to look up “Overview of Using Leaders” in the online Help.

Digitizing

Digitizing paper documents or raster images, such as bitmap files, can make it much easier to input all your project data. Digitizing is synonymous with vectorizing—the process of creating CAD vectors by tracing paper documents or raster lines.

Vector objects are produced when you draw objects in AutoCAD Land Development Desktop. For example, a line you draw with the LINE command is a vector object. Vector objects are described by a set of mathematical equations, whereas raster data is made up of pixels. Raster data is produced when you scan a paper drawing or photograph with a document scanner. AutoCAD Land Development Desktop cannot recognize raster lines and arcs as separate objects.
For example, if you have a raster image of contour lines, then you can insert the image into the drawing (at world coordinates and correct scale) and then use the Digitize Contours command on the Terrain ➤ Contour Utilities menu to trace the raster image on screen. If you have a paper contour map, then you can use a tablet and a digitizer puck to trace the contours, creating polylines on screen that you can later turn in to contour objects that you can use when building an existing ground surface.

**Choosing a Digitizing Method**

- For contours, you can use the Digitize Contours command. This command draws straight line segments only. You can assign an elevation to the contour as you digitize it, and you can make this elevation relative to other contours you draw. For more information, see “Digitize Contours” in the online Help.
- You can digitize by using polylines, lines, and arcs. For more information, see “Creating Objects” in the online Help.
- You can set up AutoCAD Land Development Desktop to use a tablet to digitize. For more information, see “About Digitizing and Importing” in the online Help.
- Autodesk CAD Overlay® has two advanced digitizing tools that you can use to digitize raster images. One method employs snapping tools you can use to snap to existing raster lines. The other follows lines automatically until it reaches a stopping point. For more information about CAD Overlay, contact your authorized Autodesk dealer.
Key Concepts

- You can rubber-sheet vectors using the Map ➤ Tools ➤ Rubber Sheet command if their source (raster image or paper drawing) is distorted. For example, you can match points on the new vectors you created to control points in your drawing. You can also match points on an image frame (a vector object) to points in the drawing. For more information see “To Rubber Sheet an Object” in the online Help.
- Converting raster objects to vector objects makes it easier to modify the drawing, and may reduce your project’s total file size.

For more information, use go to look up “About Digitizing and Importing” in the online Help.

Working with Editing Tools

To edit objects in the drawing, you can choose from two options. One is to select the editing command first and then select the objects that you want to edit. The other option is noun–verb selection, where you select the objects first and then select the editing command.

Whether you choose the editing command first or later, you must distinguish objects that you want to edit from others by creating an object selection set.

Key Concepts

- A selection set can contain one or more objects.
- You can group objects in a selection set according to properties such as color, linetype, lineweight, or layer.
- You can apply more than one editing command to the same selection set.
- You can name and save a selection set, known as a group.
- When you select one member of a group, all members are selected.
- To use the noun–verb selection method to select objects and then select the editing command, the PICKFIRST variable must be set to 1.

For more information, use go to look up “Selecting Objects” in the online Help.
Creating a Selection Set with Filters

Using the Build Selection Set command, you can create a selection set by setting up object property filters to specify which objects in your drawing you want to include in your selection set. Objects in your current drawing that do not satisfy the filter criteria will not be a part of your selection set.

Key Concepts

■ You can specify the object properties that you want to include in the filter by name.
■ You can select objects in the current drawing with the object properties that you want to include in your filter.

To filter objects by specifying properties

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use \Find to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Utilities menu, choose Build Selection Set to display the Build Selection Set dialog box.</td>
<td>Overview of Creating a Selection Set with Filters</td>
</tr>
<tr>
<td>2 Under Names in Drawing, click the button that corresponds to the property type that you want to include in your filter.</td>
<td></td>
</tr>
<tr>
<td>3 Select the property that you want to include in your selection set.</td>
<td></td>
</tr>
<tr>
<td>4 Click OK.</td>
<td></td>
</tr>
<tr>
<td>5 Click Build Selection to add all the objects in the current drawing that meet the filter criteria to the selection set.</td>
<td></td>
</tr>
<tr>
<td>6 Click Apply to accept the current selection set.</td>
<td></td>
</tr>
</tbody>
</table>
Editing with Grips

The standard way to select objects in the drawing is to use grips. Grips are small boxes displayed at various points on a selected object that you can use as “handles” to edit the object. Each AutoCAD Land Development Desktop object contains grips that you can use to stretch, copy, move, rotate, and change the height of an object.

**NOTE** To make sure that grips are turned on, choose Options from the Tools menu, and then click the Selection tab. Under Grips, select Enable Grips. To help you distinguish between dormant and active grips, specify different colors for Unselected grips and Selected grips.

The following illustration shows the grip points on objects and text.
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use Ctrl to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 To display grips, press ESC twice to clear any commands.</td>
<td>Selecting Objects First</td>
</tr>
<tr>
<td>2 Click the object that you want to edit, and then click the specific grip with which you want to work.</td>
<td>Grip Mode Cursor Menu</td>
</tr>
<tr>
<td>3 Right-click to display the grip editing shortcut menu, and choose an editing command. <strong>NOTE</strong> Some commands prompt you to enter further options on the command line.</td>
<td></td>
</tr>
<tr>
<td>4 After you finish editing, press ESC twice.</td>
<td></td>
</tr>
</tbody>
</table>

For more information see “Editing with Grips” in the online Help.
Correcting Mistakes

You can correct errors in several ways. Most editing commands require that you select drawing objects either before or after the editing process. However, the Undo, Redo, and Oops commands rely only on the previous actions that you have taken. The following table describes the most frequently used methods of correcting mistakes.

<table>
<thead>
<tr>
<th>Command</th>
<th>Access</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>undo</td>
<td>Edit ➤ Undo, or type u on the command line.</td>
<td>Reverses the most recent action in the current drawing session. You can move back through as many actions as you want by entering a number on the command line. However, a more accurate way is to step back incrementally by entering 1 at the prompt. For more information about Undo options, see “UNDO Command” in the online Help.</td>
</tr>
<tr>
<td>redo</td>
<td>Edit ➤ Redo, or type redo on the command line.</td>
<td>Reverses the UNDO command to reverse the most recent undo action.</td>
</tr>
<tr>
<td>erase</td>
<td>Modify ➤ Erase, or type erase on the command line.</td>
<td>Removes selected objects from the drawing. Use any method to specify the objects to be erased. For more information, see “Erasing Objects” in the online Help.</td>
</tr>
<tr>
<td>oops</td>
<td>Type oops on the command line.</td>
<td>Restores objects that were removed by Erase.</td>
</tr>
</tbody>
</table>
Modifying Drawing Objects

In AutoCAD Land Development Desktop, you can easily revise drawings. You can either use the commands on the Modify menu, or you can use several editing commands in combination with grips. Select a specific grip, and then right-click to display the grip editing shortcut menu. By using the shortcut menu, you can move, mirror, rotate, scale, and stretch objects. The following sections describe the most common commands used to modify objects.

Copying Objects

You can copy objects to any location in the drawing independent of, or in relation to, the original object. To copy one or more objects, select one or more objects or a block, and then specify a start point (base point) and an endpoint (point of displacement).

Key Concepts

- You can copy selected objects multiple times in succession by entering `m` (Multiple) on the command line.
- To mirror an object, create a mirror line by specifying two points. The new object is placed along the line in a mirror image of the original object. You can either keep or delete the original object.
- You can offset a copy of an object a specified distance from the original object. You can offset objects such as lines, arcs, circles, 2D polylines, ellipses, and so on. The offset object has the same linetype, color, and layer properties as the original object.
- You can create an array of identical objects (multiple copies of an original) in a rectangular or circular (polar) arrangement. For a rectangular array, you can specify the number of rows and columns.
- In a polar array, you place objects around the circumference of a circle or arc. You specify the center of the circle, the number of identical objects that you want in the array, and the angle, or rotation, of each object from the center.

For more information, use `F1` to look up “Copying Objects” in the online Help.
Moving Objects

To move objects, select the objects and specify a start point (base point) and an endpoint (point of displacement).

Key Concepts

- The MOVE command is similar to the basic COPY command, but it does not leave the original object in place.
- You can use various methods to move objects accurately in the drawing, such as snaps, coordinate values, and object snaps.
- You can move objects without changing their size or orientation.
- You can rotate objects using the ROTATE command after you specify a start point (base point around which the object rotates), and a relative or absolute rotation angle. You can use the pointing device to position the object, or you can enter an exact angle value on the command line.

For more information, use to look up “Moving Objects” in the online Help.

Resizing Objects

You can use commands on the Modify menu to change the size of objects by stretching, scaling, extending, lengthening, and trimming them.

Key Concepts

- To stretch an object, select it with a crossing selection, and then specify a base point and a point of displacement. To stretch an object accurately, use the Stretch grip mode in combination with object snaps or grid snaps, or enter relative coordinate values. For more information about using the crossing selection method, see “Using Selection Windows” in the online Help.
- You can use various methods to scale objects with the same scale factor in the X and Y directions. You can enter a scale factor, or you can scale in relation to an existing object. When you use an object as a reference, you can either enter a scale factor or you can select two points to drag the object to the scale you want and then click to select it.
If you want an object to end precisely at an implied boundary (construction line) or another object, you can extend the object.

You can cut an object so that it does not overlap another object by trimming it to the first object. To define the edge at which you want to trim the object, select a line, polyline, arc, circle, or other object.

You can alter the length of objects in various ways, such as specifying the distance to lengthen in units or as a percentage, entering the total length of the object, or dragging the object’s endpoint.

For more information, use Find to look up “Resizing Objects” in the online Help.

Inserting Breaks in Objects

You can erase a specified portion of objects such as lines, circles, arcs, polylines, ellipses, splines, and construction lines. After selecting the BREAK command, you can choose one of two ways to break an object.

- Using the pointing device, select the object at the first break point, and select the second break point.
- Select the whole object, enter $f$ to select the first point, and then select the second point.

In arcs and circles, the BREAK command always removes the specified part in a counterclockwise direction.

For more information, use Find to look up “Inserting Breaks in Objects” in the online Help.
Using the Utilities Edit Commands

With the Utilities Edit commands, you can change blocks, text, and properties of objects. You can also perform a quick scale of an object or a layer, as well as erase all objects on a layer.

Key Concepts

- You can make blocks and text in your drawing smaller or larger.
- You can change Z coordinates of selected objects to a specified value.

To rescale blocks and text

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [F1] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Utilities menu, choose Edit ➤ Rescale Blocks/Text.</td>
<td>Overview of Editing Blocks</td>
</tr>
<tr>
<td>2 Type the scale factor or reference that you want the block or text to appear and press ENTER.</td>
<td></td>
</tr>
<tr>
<td>3 Type the rotation angle and press ENTER.</td>
<td></td>
</tr>
<tr>
<td>4 Select the objects that you want to rescale.</td>
<td></td>
</tr>
</tbody>
</table>

To set the Z coordinate of an object to a new elevation

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [F1] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Utilities menu, choose Edit ➤ Flatten Z Values.</td>
<td>Overview of Editing Blocks</td>
</tr>
<tr>
<td>2 Select the objects whose Z values you want to adjust.</td>
<td></td>
</tr>
<tr>
<td>3 Type a new elevation for the objects.</td>
<td></td>
</tr>
</tbody>
</table>
Creating Blocks

A block is a group of objects that you can define as one object, or block definition. For example, you could use individual objects such as lines and curves to draw a symbol, and then you can define those objects as a block that you can reuse from drawing to drawing. If at some point you must edit the individual objects within the block, then you can explode the block.

Key Concepts

- Use the BLOCK command to define blocks to exist in the current drawing only. Use the WBLOCK command to define blocks as .dwg files that are independent of the current drawing.
- You can create a library of blocks, each a frequently used combination of objects.
- You can create custom blocks and save them as external files to use as symbols.
- If you change the original block definition, then all references to the block definition are updated automatically. However, if you import a block definition from another file and that file is not attached as an xref, any changes you make to the block definition are not updated in the current file.
- After you insert a block, you can scale, rotate, or explode it. Exploding a block breaks it down into its component objects. You can then modify the objects or redefine the block.

You can use AutoCAD block creation and definition tools as shown in the following tasks.
Chapter 4  Working with Drawing and Editing Tools

To create a block definition

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [Find] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. From the Draw menu, choose Block ➤ Make to display the Block Definition dialog box.</td>
<td>Defining Blocks</td>
</tr>
<tr>
<td><img src="image" alt="Block Definition dialog box" /></td>
<td></td>
</tr>
<tr>
<td>2. In the Name box, type a name for the block.</td>
<td></td>
</tr>
<tr>
<td>3. Click Select Objects. Use any object selection method to select the objects that you want to include in the block definition, and then press ENTER to return to the Block Definition dialog box.</td>
<td>Selecting Objects, Choosing the Command First</td>
</tr>
<tr>
<td>4. Select Convert to Block to convert the original objects to a block definition. You can also select Retain to keep the original objects in the drawing, or select Delete to remove the objects from the drawing.</td>
<td></td>
</tr>
<tr>
<td>5. Click Pick Point to define an insertion base point for the block.</td>
<td>Inserting Blocks</td>
</tr>
<tr>
<td>6. Click OK. The block is defined as an internal block, and exists in the current drawing only.</td>
<td></td>
</tr>
</tbody>
</table>

For more information about defining blocks within a drawing and as separate drawing files, use the \[Find\] to look up “Defining Blocks” in the online Help.
To insert a block

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Insert menu, choose Block.</td>
<td>Inserting Blocks</td>
</tr>
<tr>
<td>2 In the Insert dialog box, click Block to insert an internal block, or click File to insert a block that has been saved as a drawing file.</td>
<td>DDINSERT Command</td>
</tr>
<tr>
<td>3 Specify the insertion point, scale, and rotation, and then press ENTER to insert the block.</td>
<td>INSERT Command</td>
</tr>
</tbody>
</table>

**TIP** To view the insertion point for the block, enter `blipmode` on the command line.

For information, use `?` to look up "Working with Blocks" in the online Help.

## Attaching External Drawings

You can link another drawing to the current drawing by using the xref (external reference) option. If you insert a drawing as a block, the block definition is stored in the current drawing, but it is not updated if the original drawing changes. However, if you attach a drawing as an external reference, then the current drawing is updated if the original changes.

### Key Concepts

- You can either attach or overlay an externally referenced drawing.
- During a drawing session, you can keep your current drawing updated while changes are being made to an attached xref drawing by periodically reloading the xref.
- You can completely remove, or detach, an xref drawing from your current drawing.
- To save memory and increase speed, you can unload an xref drawing that you are not using. The pointer to the xref drawing remains and you can reload it when you need it.
- You can make an xref drawing a permanent part of your current drawing by binding it. Binding converts an xref to a block that is no longer updated when the original drawing changes.
To attach an xref drawing

Steps

1. From the Insert menu, choose External Reference to display the Select Reference File dialog box.
   Use **Find** to look up **Attaching Xrefs**

2. Select the drawing file, and then click Open to display the External Reference dialog box.
   Use **External Reference Dialog Box**

3. Select Attachment and specify the external reference parameters, and verify that under Insertion point, the Specify On-screen check box is selected.

4. Click OK to select the insertion point in the drawing.
   Use **Find** to look up **XCLIP Command**

   **NOTE** If you do not use all the xref drawing in the current drawing, then enter xclip (clipping boundary) to remove a portion of an xref drawing from the display.

For information, use **Find** to look up “Using External References” in the online Help.
5

Working with Surfaces

You can use points, contours, breaklines, and boundaries to generate a model of the earth’s surface for a particular parcel of land. From this model, you can create contours and sections, and by comparing two models, you can calculate volumes.
Introduction

After you have input data into a project, you can create a surface model from that data. A surface model is a three-dimensional geometric representation of the surface of an area of land. Surface models in AutoCAD Land Development Desktop are made up of triangles, which are created when AutoCAD Land Development Desktop connects the points that make up the surface data.

The triangles form a “triangulated irregular network” (TIN) surface. A “TIN line” is one of the lines that makes up the surface triangulation, as shown in the following illustration.

To create the TIN lines, AutoCAD Land Development Desktop connects the surface points that are closest together. These TIN lines interpolate surface elevations, filling in the gaps for which no survey data or contour data is known, to create an approximation of the surface.
Using Point, Contour, Breakline, and Boundary Data in Surfaces

Random point data, points taken at a variety of elevations and coordinates as opposed to interpolated contour data, often makes the best surface data. To use points for a surface, you can select point groups or import point files. You can create point groups from the points in the COGO point database. Point files can be ASCII text files or Microsoft® Access database files. If you have blocks or lines at elevations in a drawing, then their coordinates can also be selected as point data to use in surfaces.

In addition to using points, you can also build surfaces from contour, breakline, and boundary data. You can have the contours treated as individual points where the contour vertices are used as surface points, or you can have the contours treated as breaklines which prevents triangulation lines from crossing the contours. Surface TIN lines typically do not cross contour lines.

You usually need to provide more information than only points and contours to accurately build a surface. For example, TIN lines by default always connect the points that are closest to each other. However, if the closest point to another point is across a streambed, then the elevations that are interpolated from such a TIN line are inaccurate. To prevent surface triangulation from occurring across features like roads or streams, you can define breaklines. Breaklines are constraint lines used by the model that represent abrupt changes in the surface. TIN lines can be drawn to and from breakline vertices, but they do not cross the breakline.

NOTE In Autodesk S8 Civil/Survey products, breaklines were called faults.

By including boundaries in the surface definition, you can control how the surface extends to its outer limits, and you can mask internal areas to prevent triangulation from occurring. Boundaries act like breaklines, but they can either force retriangulation, like regular breaklines, or they can clip the surface lines that cross the boundary.
**Surface Accuracy**

When gathering data for the surface model, you need to be very thorough so that the model you create is accurate enough for your intended purpose.

At the beginning of a project, you can make a quick surface model by digitizing a contour map of the existing site, and create the surface model based on the contours only. If the project is more advanced, and you already have survey data, then you can use the point data from that survey to create a more accurate surface model.

If you do not have enough surface data, then the surface elevations may not be interpolated correctly. By being thorough, you can better ensure that the surface output—such as contours, volumes, watershed models, profiles, and cross sections—is as accurate as possible.

**Working with the Terrain Model Explorer**

The Terrain Model Explorer consolidates all the surface creation and management features in one place. You can use the Terrain Model Explorer to create, open, build, and view surfaces.

The Terrain Model Explorer contains a Terrain and a Volume folder. To create a new surface, right-click the Terrain folder and select Create New Surface. When you create a surface, a surface folder is created below the Terrain folder. Open this folder to use the surface data icons. You can right-click the folders and icons in the left pane of the Terrain Model Explorer to access commands.
Use the shortcut menus to add the surface data to the surface folder, and then build the surface.

In the Volume folder, the Terrain Model Explorer stores information about grid and composite volume surfaces that are created from the volume calculations commands on the Terrain menu. Using the Terrain Model Explorer, you can view properties about the volume surfaces, as well as open, close, and view volume surfaces.
You can keep the Terrain Model Explorer open while you use other commands. Use the buttons in the upper-right corner of the dialog box to minimize, maximize, and close the Terrain Model Explorer.

When the Terrain Model Explorer is maximized, the buttons in the upper-left corner appear as shown in the following illustration:

Use the first button to minimize the window, use the middle button to return the window to its default state, and use the last button to close the window.

When the Terrain Model Explorer is minimized, the buttons appear as shown in the following illustration:

Use the first button to return the window to its default state, use the middle button to maximize the window, and use the last button to close the window.

## Creating Surface Data

Before you can build a surface, you must create surface data or add the surface data to the surface folder in the Terrain Model Explorer by using the shortcut menu commands, like Add Point Group.
Creating Surface Data

When you add the surface data into the Terrain Model Explorer, you are determining which objects to include in the current build of the surface. These objects can be point groups, point files, breaklines, contours, and boundaries.

Key Concepts

- To create or import point data you must either have point groups defined and points in the COGO point database, or an external point file to import.
- When you import a point file into the Terrain Model Explorer, the point data is not added to the point database. The data is used exclusively for building the surface.
- To add contour data to a surface, you must have contour objects or polylines in your drawing.
- To add breaklines, you must use the commands on the Breaklines shortcut menu in the Terrain Model Explorer.

Creating Breaklines to Use in Surface Generation

Breaklines are constraint lines that represent abrupt changes in a surface such as retaining walls, stream banks, and curbs; or objects with known elevations, such as contours. You can use breaklines to prevent surface triangulation from occurring across these objects.

Breaklines can be either “destructive” or “non-destructive.” All the Breakline commands create destructive breaklines. A destructive breakline prevents TIN lines from crossing the breakline. This is essential if the breakline represents a constant elevation—you do not want to interpolate elevations across such a breakline. The breakline also forces retriangulation of the surface based on the breakline vertices.
The following illustration shows a surface triangulation that does not accurately interpolate the surface elevations, as shown by the cross sections cut from different locations. By defining breaklines, you can control how the triangulation will occur with regard to abrupt changes in the terrain.

You can define three types of breaklines.

- **Proximity breaklines**: Defines breaklines using the points in the database nearest to the breakline that you draw. You do not have to snap to exact points.
- **Wall breaklines**: Defines the elevations of a wall-type object on both sides of the wall. For example, triangulation is linked to the bottom of the wall on one side, and then begins again from the top of the wall on the other side.
- **Standard breaklines**: Defines the breaklines using the exact points or polylines that you select.
Creating Contours to Use in Surface Generation

You can use vector contours, either polylines or contour objects, in surface generation. However, information obtained from a contour map differs greatly from data taken randomly in the field. Since contour map data is interpolated, the information may be less accurate than direct field data. The accuracy of the final surface model depends on the quality of both your contour map and the contour interval.

Unlike breaklines, which you create directly from within the Terrain Model Explorer, contours (as contour objects or polylines) must already exist in the drawing in order to select them as surface data.

You can use contour data either as breaklines or as points when you add the contour data to the Terrain Model Explorer. When you add contour data to the surface folder, the Contour Weeding dialog box is displayed.

When the Create as contour data check box is selected, the contours are treated as breakline data, so no triangulation occurs across contours. When the Create as contour data check box is cleared, the contour vertices are treated as point data for the purposes of triangulation.
Creating Boundaries to Use in Surface Generation

Boundaries can help eliminate certain surface editing tasks.

- Boundaries control how the surface TIN lines extend to the surface’s outer limits.
- Boundaries mask internal areas of the surface to prevent triangulation from occurring.

For example, if a pond exists on the surface, you can either build the surface and then delete the triangulation lines that cross the pond, or you can create a boundary around the pond before building the surface so that the area of the pond is not triangulated. The same applies to outer surface boundary lines—you can either delete the TIN lines that extend beyond the survey limits after you build the surface, or you can create a boundary around the survey limits before building the surface to prevent the lines from being created in the first place.

Boundaries can clip the surface lines that cross the boundary, or they can act like non-destructive breaklines, as shown in the following illustration.
Building Surfaces

After you choose which information to include in a surface, you can build the surface. When you build a surface, all the surface data is processed and the program calculates the surface triangulation. The triangulation is calculated by combining the breakline, contour, and boundary data with the surface point data and interpolating the results.

Specifying Data for Surfaces

Not all data in your drawing and project must be used in a surface model. You can choose which points, contours, breaklines, and boundaries to include. Everything that you add to the surface folder in the Terrain Model Explorer can be used in a surface, but you can exclude certain data from build to build to examine different results.

Key Concepts

- You can have an unlimited number of surfaces in a project or drawing.
- Surfaces are stored in the c:\Land Projects R2\<project name>\dtm folder.
- You can access surfaces simultaneously across a network. The first user who opens the surface has read/write access to it. All other users have read-only access.
## To build a surface

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Terrain menu, choose Terrain Model Explorer to display the Terrain Model Explorer dialog box.</td>
<td>Create a New Surface</td>
</tr>
<tr>
<td>2 Right-click the Terrain folder and choose Create New Surface.</td>
<td></td>
</tr>
<tr>
<td>3 Open the new surface folder to display the data tree.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Terrain" /> <img src="image" alt="Surface1" /></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="TIN Data" /> <img src="image" alt="Point Groups" /> <img src="image" alt="Point Files" /> <img src="image" alt="Contours" /> <img src="image" alt="Breaklines" /> <img src="image" alt="Boundaries" /> <img src="image" alt="Edit History" /> <img src="image" alt="Watershed" /></td>
<td></td>
</tr>
<tr>
<td>4 Add the data that you want to include in the surface. This data can be points, contours, boundaries, or breaklines. To add a point group to the surface, Right-click the Point Groups icon and select the point group.</td>
<td>Add Point Groups to the Surface Folder to Use in Surface Generation</td>
</tr>
<tr>
<td>To add contour data to the surface, Right-click the Contours icon and generate the contour data.</td>
<td></td>
</tr>
</tbody>
</table>
To build a surface (continued)

Steps | Use vertical to look up
--- | ---
5 After you add all the surface data, Right-click the surface name and choose Build Surface to display the Build Surface dialog box. **Build a Surface**

![Build Surface dialog box]

6 Type a description for the surface.

7 Choose which surface data to use in the surface by modifying the Surface Data Options. You can also choose to build the watershed model, calculate extended statistics, and create an error file when building the surface.

8 Click OK to build the surface. A message box is displayed when the surface has been built. Click OK to continue.
Building a Watershed Model

You can build a watershed model of the current surface either while building the surface or after building the surface. The program uses the surface TIN lines to calculate the channels where water would flow along the surface.

From these channels, the command then determines the watershed subareas, also known as catchment areas or regions. You can import boundaries into the drawing to delineate and number the watershed subareas, and you can determine the color of each type of watershed boundary by changing the color of the layer that the polyline boundary is assigned to.

After you build the watershed model, you can draw slope arrows to show the surface slopes, and use the Waterdrop command to draw polyline representations of the path that water would flow along the surface toward channels. If the channel splits, then new polylines are drawn to follow each water drop path.
Watershed subareas can have different types of drain targets. Drain targets of some subareas can be based on a boundary point, the point where the channel of water would drain off the surface. Drain targets of other subareas can be depression areas where the water will flow.

**Key Concepts**

- If the Watershed command determines that water from one TIN surface triangle could flow into more than one watershed subarea, then it splits the TIN triangle to make two triangles. This ensures that each watershed consists of complete triangles, and that the boundary of each watershed consists solely of TIN edges.
- If you use contour data to build the surface, then be sure to use the Minimize flat triangles resulting from contour data option in the Build Surface dialog box to minimize the number of flat triangles that make up the TIN surface, and thus make the watershed model more accurate.

### To build a watershed model

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. From the Terrain menu, choose Terrain Model Explorer to display the Terrain Model Explorer dialog box. Create and build a surface model if one does not exist.</td>
<td>Build a Surface</td>
</tr>
<tr>
<td>2. Open the surface folder to display the data tree.</td>
<td>Overview of Creating Watershed Models</td>
</tr>
<tr>
<td>3. Right-click the Watershed icon and choose Calculate Watershed.</td>
<td>Overview of Creating Watershed Models</td>
</tr>
</tbody>
</table>
To build a watershed model (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Set the watershed model options. You can specify a minimum depression and minimum area to ignore.</td>
</tr>
<tr>
<td>5</td>
<td>Click OK to calculate the watershed.</td>
</tr>
<tr>
<td>6</td>
<td>Right-click the Watershed icon and choose Import Watershed Boundaries to display the Watershed Display Settings dialog box.</td>
</tr>
</tbody>
</table>

**Draw the Watershed Boundaries on the Surface**

![Watershed Display Settings](image)

**Chapter 5  Working with Surfaces**

188
To build a watershed model *(continued)*

<table>
<thead>
<tr>
<th>Steps</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
<td>Use the options in the upper part of the dialog box to control the appearance of the watershed boundaries that are imported. Select Fill With Solids to import solid fill areas, or leave this check box unselected to import polyline boundaries. When you import polyline boundaries, you may also want to select the Display ID Numbers check box to insert the watersheds' ID numbers within the polyline boundaries.</td>
</tr>
<tr>
<td>8</td>
<td>Select options for layers, and click OK to draw the boundaries on the surface. <strong>TIP</strong> Make the colors of each of these layers different so you can easily distinguish what type of watershed is outlined.</td>
</tr>
<tr>
<td>9</td>
<td>To show how a drop of water would flow across the surface, you can trace that path in your drawing by choosing the Water Drop command from the Terrain ➤ Surface Utilities menu. Select a point on the surface, and the Water Drop command draws a polyline that represents the path that water would take as it flows from that point toward the drain target. <strong>Draw Water Drop Paths on the Current Surface</strong></td>
</tr>
</tbody>
</table>
Creating Finished Ground Data for Surfaces

AutoCAD Land Development Desktop has many commands that you can use for creating finished ground data to use for surfaces. The following table summarizes a few of the point, 3D polyline, and contour grading methods you can use for creating finished ground surface data.

<table>
<thead>
<tr>
<th>Methods for creating finished ground surface data</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Point Grading</strong></td>
</tr>
<tr>
<td>Create points at the vertices of a 3D polyline</td>
</tr>
<tr>
<td>Create points where two slopes or grades intersect</td>
</tr>
<tr>
<td>Interpolate points between two selected points, based on total distance</td>
</tr>
</tbody>
</table>

When you are ready to create the surface based on this grading data using the Terrain Model Explorer, you must add the surface data to the surface folder. The following table shows how to process each type of grading data.

<table>
<thead>
<tr>
<th>Processing different types of surface data</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Object</strong></td>
</tr>
<tr>
<td>2D Polylines</td>
</tr>
<tr>
<td>3D Polylines</td>
</tr>
<tr>
<td>Points</td>
</tr>
</tbody>
</table>
After building a surface, you should evaluate its accuracy. Did the TIN lines generate as expected? If not, you can go back and define new surface data like points, breaklines, and boundaries. Or, if the changes are small, you can edit the surface TIN directly.

For example, you can:

- Flip the faces of triangles to match ridges or depression areas
- Add TIN lines to force retriangulation
- Delete TIN lines that extend beyond survey boundaries
- Add, delete, move, and edit points
- Add non-destructive breaklines
- Paste surfaces together
- Change the overall elevation of the surface by an increment

For example, you can add a TIN line, which forces the other TIN lines that it crosses to retriangulate. You can add points to a surface, which also forces the surface to retriangulate. You can also trim out surface TIN lines that are drawn across a building pad or pond. The following illustration is an example of flipping TIN faces.

If you have two or more surfaces that you want to combine into one surface, then you can paste them together. For example, you can create a surface that represents only a part of the site—which contains the grading data for a building pad, for example. After you build this surface, you can paste it into the existing ground surface to create a finished ground surface that represents the entire site.
Edit History

Whenever you rebuild a surface, you must reapply the edits that you made to it. To save time, all edits that you make to a surface are saved in the Edit History folder in the Terrain Model Explorer.

The Edit History folder stores all the edits that you make to a surface so you can automatically repeat them later, when you rebuild the surface.

You can open the Edit History folder to view the edits you have made to a surface, as shown in the following illustration.

When you select the Apply Edit History check box when rebuilding the surface, all the edits that you made previously are repeated in the order that you made them. You can also change the edit history list—if you do not want to repeat a step in the edit history, then delete the item from the list.

Working with Surface Output and Visualization Tools

After you build a surface, you can use many different methods to output, display, and visualize the surface. For example, you can

- Generate contours for the surface
- View cross sections and profiles of the surface
- Output volumes
- Create a 3D rendering of the surface for presentation
- Create a slope-defined model that shows areas color-coded by slope range, indicating unbuildable land due to excessive slope.
- Create a model showing elevational banding of flood plain lines.

The surface TIN lines must be in the drawing in order for you to use the Edit Surface commands. Use the Import 3D Lines command at the top of the Edit Surface menu to import surface lines you can edit. Be sure to make the surface you want to work with the current surface. Only the data for the current surface is used when editing.
**Viewing Surface Statistics**

Statistics for each surface are visible by clicking the surface name icon in the Terrain Model Explorer.

The following illustration shows the statistics for a surface, including the Extended Statistics.

![Surface Statistics Table]

If you want a dynamic display of the elevational characteristics of a surface, see the following section, “Dynamically Viewing Elevational Characteristics of a Surface.”

**Dynamically Viewing Elevational Characteristics of a Surface**

When a surface is open, it is loaded into memory. Therefore, you can retrieve elevational information as you move the pointing device across the surface. This is an excellent way to analyze surface characteristics without actually drafting objects into the drawing.
Key Concepts

- The surfaces does not need to be drafted in the drawing to obtain elevational information from it.
- Make sure that the proper surface is set as current.
- The elevation values are displayed in the status bar at the bottom of the screen.

To dynamically display surface elevations

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
<th>to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Terrain menu, choose Set Current Surface to make the desired surface model current.</td>
<td></td>
<td>Make a Surface Current</td>
</tr>
<tr>
<td>2 From the Inquiry menu, choose Track Elevations.</td>
<td></td>
<td>Track Elevations</td>
</tr>
<tr>
<td>3 As you move the pointing device to a point, the elevation at that point is displayed on the status bar.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Viewing Quick Sections of a Surface

When you need to examine the elevational characteristics of a surface along a straight line, you can create quick sections and profiles. You can use these sections and profiles as visualization tools to help you determine where you may need to modify the surface, or to review the elevational relief of the site.

Each section is defined by a section line that you draw across the surface. Selecting two points to draw the line creates a section. Selecting multiple points creates a profile. These sections and profiles are displayed in their own window on screen. The following illustration shows a profile that was created by selecting three points.
You can use commands in the section window’s Section menu to save the sections as Windows metafiles, copy the sections to the clipboard, and modify the section properties, such as vertical exaggeration, tick increment, and colors.

You can also access commands from the section shortcut menu by selecting the section line in the drawing and right-clicking.

**Key Concepts**

- If you grip edit the section line, the quick section views are dynamically updated. If you edit the surface, then you can update the section views using the Update Section Views command from the Terrain ➤ Sections menu.
- You can display more than one quick section at a time.
- To save the view, you can use the Save As command from the Section menu (on the section window) to save the section to a Windows metafile.
- When you are ready to plot sections of the surface, use the Define Sections, Process Sections, and Import Sections commands from the Terrain ➤ Sections menu. These commands plot series of sections in the drawing.

**To view a section of a surface**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use ➢ to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Select the current surface.</td>
<td>Make a Surface Current</td>
</tr>
<tr>
<td>2 From the Terrain menu, choose Sections ➤ Create Section View.</td>
<td>Create Quick Surface Sections and Profiles</td>
</tr>
<tr>
<td>3 Select two or more points on the surface to draw the section line.</td>
<td></td>
</tr>
<tr>
<td>4 Press ENTER to cut the section and to display the section in the window.</td>
<td></td>
</tr>
<tr>
<td>5 You can continue to cut sections by selecting points on your surface. Each section that you cut is placed in its own window.</td>
<td></td>
</tr>
</tbody>
</table>

If you select more than two points, a profile or long section is created.
To view a section of a surface (continued)

Steps | Use to look up
--- | ---
6 To display a different section view, you can move an existing section line using grips. | Grip Edit Quick Section Lines

Click a section line to display the grips, select a grip, and then move it to a new location to edit the section line. The section in the window is updated automatically.

Creating Contours

Contours make it easy to recognize the elevational values of a surface at a glance. You can use AutoCAD Land Development Desktop to create existing ground or finished ground contours. To create contours, you can:

- Generate contours from the current surface model.
- Vectorize contours on a raster image, and then convert the polylines to contours.
- Copy contours.
- Convert polylines to contours.
- Digitize a paper contour map.
- Offset contours.

NOTE Contours can be used to represent features other than elevations. For example, they can represent rainfall intensity, soil contamination lines, and so on.
Creating Contours from a Surface

When you create contours from a surface, you use a contour style that controls how the contour and contour labels appear. For example, a contour style controls smoothing, grip display for editing contours and their labels, the text style used for labels, and the label position.

When you create contours, you choose a style to use and you can also specify elevation ranges, contour intervals, and whether to create the contours as AEC contour objects or polylines. All contour definition, editing, and labeling commands work on both contour objects and polylines.

NOTE Because AEC contour objects are custom objects, they must be exploded if you want to edit them in a flavor of AutoCAD other than AutoCAD Land Development Desktop. Or, you must install the Object Enabler, which is available on your AutoCAD Land Development Desktop CD-ROM.

When you create contours from a surface, you base the contours on a contour style. Use the Contour Style Manager to define and edit contour styles.

Key Concepts

- Contour styles store groups of settings in the drawing so you can use them again without having to manually reset the settings you want to use.
- You choose a contour style to use when you run the Create Contours command on the Terrain menu.
You can use the Manage Styles tab to save contour styles to an external file and also to load contour styles from an external file. This is helpful when you want to use the same contour styles in more than one drawing or in different projects.

You can click in the Preview window on the Contour Style Manager and adjust the view angle of the previewed contours by moving your pointing device.

To create contours from a surface

Steps | Use \[\text{Tab}\] to look up

--- | ---
1 From the Terrain menu, choose Create Contours to display the Create Contours dialog box. | Create Contours from a Surface

![Create Contours dialog box]

2 Select the surface for which you want to create contours. By default, the current surface is displayed in the Surface box.

3 Specify the elevation range for which you want to create contours.

4 Specify at which vertical scale you want to create contours.

5 Specify the minor and major contour intervals.
To create contours from a surface (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use Help to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>6 Under Properties, choose whether you want to create contour objects or polylines.</td>
<td>Overview of Managing Contour Styles</td>
</tr>
<tr>
<td>7 Under Properties, click Style Manager to display the Contour Style Manager dialog box.</td>
<td>Overview of Managing Contour Styles</td>
</tr>
<tr>
<td>8 Use the Contour Style Manager dialog box to smooth contours, and to specify the contour appearance, the text style for contour labels, and the label position. You can also use this dialog box to save contour styles and load styles from other drawings.</td>
<td>Overview of Managing Contour Styles</td>
</tr>
<tr>
<td>9 Click OK to return to the Contour Style Manager dialog box and then click OK to generate the contours.</td>
<td>Overview of Labeling Contours</td>
</tr>
<tr>
<td>10 You can label the contours using the commands in the Terrain ➤ Contour Labels menu.</td>
<td>Overview of Labeling Contours</td>
</tr>
</tbody>
</table>

Using a Surface Boundary to Contour Around a Building or Pond

You typically do not draft contours inside of a building foundation or water-filled pond. One way to prevent contours from being drafted within these features is to trim everything within the feature by deleting the surface lines in these areas.

Another method is to hide portions of the surface model using a surface boundary. By hiding certain areas, you can prevent the hidden areas from being contoured. When you create an internal boundary, the surface faces remain intact. They are hidden only until you remove the boundary.
**Key Concepts**

- No elevational information for the surface is available while an area is hidden by a boundary.
- Depending on how well the surface follows the boundary polygon, you may want to make the surface boundary act as a non-destructive breakline in order to trim the triangles exactly at the edge of the boundary.

**To contour around a pond by using a surface boundary**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [Fed] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the current surface.</td>
<td>Make a Surface Current</td>
</tr>
<tr>
<td>2. If the pond that you want to define as a boundary is not outlined by a polyline, then use the PLINE command to draw the boundary.</td>
<td>PLINE Command</td>
</tr>
<tr>
<td>3. From the Terrain menu, choose Edit Surface ➤ Surface Boundaries.</td>
<td>Define Surface Boundaries After Building a Surface</td>
</tr>
<tr>
<td>4. Type Add to add a boundary, press ENTER, and then type No to not remove any existing boundaries.</td>
<td></td>
</tr>
<tr>
<td>5. Select the polyline boundary.</td>
<td></td>
</tr>
<tr>
<td>6. You can specify that anything inside the polyline is hidden (Hide) or shown (Show). For this example, specify Hide, because you want to hide the area inside the pond polyline.</td>
<td></td>
</tr>
<tr>
<td>7. You are prompted whether you want to create breaklines along the edges.</td>
<td>By typing Yes, a non-destructive breakline is created around the polygon boundary area. The breakline trims the faces along the edge of the boundary.</td>
</tr>
</tbody>
</table>
To contour around a pond by using a surface boundary (continued)

Steps

8 Press ENTER at the Select polyline for boundary prompt to end the command.

The vertices on the boundary are added to the triangulation. The elevations for the breakline are retrieved from the surface model.

9 Use the Create Contours command on the Terrain menu to create contours from the surface. As the contours are generated, you can see that they are not drafted within the polygonal boundary.

Comparing Two Surfaces to Calculate Volumes

You can calculate volumes or depths between surfaces by comparing them. For example, you may want to compare existing ground surface data with as-built data. Or, if you have borehole data, then you may want to calculate the volumes that exist between the top surface and rock, for example.

AutoCAD Land Development Desktop includes three volume calculation methods:

- Grid method: Based on a grid that compares elevational information between the first and second surface. This method creates a volume surface.
- Composite method: Creates a volume surface that includes all the surface points from the first and second surface. The Z values in the new surface are the elevational difference between the first and second surface.
- Section method: Calculates volumes based on sampled cross sections.

You can also calculate parcel volumes, which are based on parcels that exist within the larger site.

In all cases, you need two surface models. From these two surfaces, you must define a stratum, which specifies which two surfaces are used in volume calculations. Before you can calculate volumes, you also need to define a site, which represents the area of the stratum that you want to calculate volumes for.
Key Concepts

- The volume results are only as good as the surface definitions. The more complete the surface data, the better the volume calculations.
- The grid method offers a quick volume result. Because it is a grid, however, you can potentially miss surface irregularities, such as a curb or depressions, which would affect your volume results. This method creates a volume surface that you can view and manage from the Terrain Model Explorer.
- The composite method uses all the data from the first and second surfaces. This method creates a volume surface, and the results are the exact surface difference total. This method creates a volume surface that you can view and manage from the Terrain Model Explorer.
- The section method interpolates cross sections from the two surfaces of the current stratum, and generates volumes using one of two methods: Prismoidal or Average End Area. This gives you sections that you can plot in order to verify areas and submittals. This method does not create a volume surface.

To calculate volumes

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [F1] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Define at least two surfaces, such as existing ground and proposed ground.</td>
<td>Build a Surface</td>
</tr>
<tr>
<td>2 From the Terrain menu, choose Select Current Stratum to create a stratum that defines the two surfaces that you compare.</td>
<td>Define a Stratum</td>
</tr>
<tr>
<td>3 From the Terrain menu choose Site Definition ➤ Define Site to define the site area.</td>
<td>Define a Site for Volume Calculations</td>
</tr>
</tbody>
</table>

A site is essentially a rectangular area in which all volume calculations are performed. It also defines the grid size that is used when creating a grid surface.

| 4 To calculate volumes using the section method, select Terrain ➤ Section Volumes ➤ Sample Sections to generate the cross section data. | Sample Section Data for Volume Calculations |
To calculate volumes (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use F5 to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Calculate cut/fill volumes for the site. Volumes are calculated based on the method that you choose.</td>
</tr>
<tr>
<td></td>
<td>To use the grid method, select Terrain ➤ Grid Volumes ➤ Calculate Total Site Volume.</td>
</tr>
<tr>
<td></td>
<td>To use the composite method, select Terrain ➤ Composite Volumes ➤ Calculate Total Site Volume.</td>
</tr>
<tr>
<td></td>
<td>To use the section method, select Terrain ➤ Section Volumes ➤ Calculate Volume Total.</td>
</tr>
<tr>
<td>6</td>
<td></td>
</tr>
<tr>
<td></td>
<td>You can create volume reports, print the volume results, or include volume results in a table in the drawing by using commands from the Terrain ➤ Volume Reports menu.</td>
</tr>
<tr>
<td></td>
<td>If you used the section volume calculation methods, then you can plot the cross sections in the drawing by selecting Terrain ➤ Section Volumes ➤ Plot Single.</td>
</tr>
<tr>
<td></td>
<td>Create a Total Volume Table for a Site</td>
</tr>
<tr>
<td></td>
<td>Plot a Single Volume Section</td>
</tr>
</tbody>
</table>

Presenting Cut/Fill Results

You can create presentation graphics to help highlight cut/fill areas in your site. When you use the composite or grid surface volume calculation methods to calculate the volumes between two surfaces, a third, volume surface is made. This surface is the difference between the two surfaces, which you can use to demonstrate the cut/fill areas.

Key Concepts

- You can view and manage volume surfaces from within the Terrain Model Explorer.
- You can view a grid of ticks and labels that indicate the cut/fill depth throughout the site.
You can create a range map that displays the cut areas in one color and the fill areas in another.

You can create cut/fill contours on a volume surface. The volume surface Z value is the cut/fill depth instead of an elevational value.

**To present volumes results**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
<th>to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Select the volume surface as the current surface.</td>
<td>Make a Surface Current</td>
<td></td>
</tr>
<tr>
<td>2 From the Terrain menu, choose Create Contours to create cut/fill contours.</td>
<td>Create Contours from a Surface</td>
<td></td>
</tr>
<tr>
<td>3 If you used the grid method to calculate volumes, then select Terrain ➤ Grid Volumes ➤ Grid Volume Ticks to draw grid ticks that display the elevation difference between existing and proposed ground.</td>
<td>Create a Grid of Ticks That Show Cut and Fill Areas on Volume Surfaces</td>
<td></td>
</tr>
</tbody>
</table>

**Creating a 3D Map to Present Elevation Conditions**

After you create a surface, you can use several tools to help you visualize the surface in 3D. For example, you can use the Elevation and Slope range commands on the Terrain ➤ Surface Display menu to insert 3D faces into the drawing. These commands place surface triangles that fall within a defined elevation or slope range onto specific layers. You can then make each layer a different color. For example, you can put any portions of the site that fall within an elevation range of 100' to 105' on a blue layer to visually distinguish the elevation range.
Key Concepts

- You can draw the range view as 2D solids or 3D faces, and you can view the faces in plan or 3D perspective.
- When using the banding methods, the program automatically splits surface triangles to properly match the range that you define. In other words, if you created the triangle between points that range from 90' - 120', then the program would break this into individual faces at 90', 100', 110', and 120'. This ensures that the elevational banding is properly presented. This does not modify the surface, but it only breaks the plotted faces to match the elevational criteria.

To create an elevational range view

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use - Text - to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Select the current surface.</td>
<td>Make a Surface Current</td>
</tr>
<tr>
<td>2 From the Terrain menu, choose Surface Display ➤ Elevation Settings to define the elevational ranges, layers, and layer colors. Where there is minimal elevational exaggeration, you can also define vertical scaling to help see site features.</td>
<td>Change the Surface Elevation Shading Settings</td>
</tr>
<tr>
<td>3 Generate the range view by selecting an elevational range view command. From the Terrain menu, choose Surface Display ➤ Average - 3D Faces or Banding - 3D Faces.</td>
<td>Create 2D Solids Using the Banding Method that Shows the Elevations of a Surface Create 3D Faces Using the Banding Method that Shows the Elevations of a Surface</td>
</tr>
<tr>
<td>4 To manage the layers on which you created the range views, select Terrain ➤ Terrain Layers ➤ Range Layers.</td>
<td>Manage the Range Layers</td>
</tr>
</tbody>
</table>
### Projecting 2D Lines onto a 3D Grid

You can project 2D objects such as lines, curves, and polylines from a flat drawing plane onto a 3D surface grid. This is an effective way to present information such as a road location, building outline, or property boundary.

#### Key Concepts
- You can project lines, curves, and polylines onto the grid.
- The objects are drawn on a separate layer.
- For a smoother site, set the number of “facets” per grid face to a higher number.
- If the site contains details such as walls or curbs, you should use the 3D Faces command on the Terrain ➤ Surface Display menu. This option imports all the surface triangles as 3D faces. All surface details show up on the imported faces.

#### To project objects onto a grid

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use $F3d$ to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Select the current surface.</td>
<td>Make a Surface Current</td>
</tr>
<tr>
<td>2 Make sure you are working in plan view.</td>
<td>PLAN Command</td>
</tr>
<tr>
<td>3 From the Terrain menu, choose Surface Display ➤ Grid of 3D Faces to create a grid of 3D faces. You have complete control over grid location, size, vertical exaggeration, and facets per grid face.</td>
<td>Create a Surface Grid of 3D Faces</td>
</tr>
<tr>
<td>4 Select all lines, curves, and polylines that to be projected, and specify a layer to draw them on.</td>
<td></td>
</tr>
<tr>
<td>5 To view the site in 3D, use either the DVIEW or VPOINT command, or use the Object Viewer from the Utilities menu.</td>
<td>DVIEW Command VPOINT Command Use the Object Viewer</td>
</tr>
</tbody>
</table>
Creating Cadastral Information

Creating cadastral information with AutoCAD Land Development Desktop is a two-step process. First, you create the geometry—such as the roadway centerlines and parcel boundaries—and then you define the geometry as alignments and parcels.
Introduction

You can draft horizontal alignments and parcels at any time during the project process. The project does not need existing surfaces before you create alignments or parcels.

You begin by drawing simple objects, like lines, curves, spirals, or polylines to represent the geometry of the alignment or parcel. You then define the alignment or parcel to a database. All the data is stored in an external database, so all drawings in the project can access that data.

Because of the external database, you do not need to draft the alignments or parcels in the drawing in order to reference them. After defining them, you can delete the objects from the drawing if desired. Then, if you must visually reference the alignments or parcels, you can import them into the drawing.

Working with Alignments

The plan view of roadway geometry is called the horizontal alignment. For alignments, you can define roadway centerlines and create offsets that represent lanes, shoulders, and rights-of-way. You can create station labels along the alignment, and generate stakeout reports for surveyors.
Because the alignment definitions are stored outside the drawing in a database, you have added flexibility when managing alignments:

- If other projects contain alignments that you want to include in the current project, then you can merge the alignment databases and import the alignments into the drawing.
- If someone over a network needs write access to the alignment you have set as current, then you can close the alignment database or select a different current alignment while keeping your drawing open.
- It is not necessary to keep the alignment objects in the drawing. You can delete them and import the alignments only when needed.

You can edit the data in the alignment database by using the Alignment Editor. Any edits that you make to an alignment in the Alignment Editor are updated in the drawing. The Alignment Editor can also generate reports.

Autodesk Civil Design provides advanced roadway design capabilities, such as profile and cross section design. For more information about Autodesk Civil Design, contact your authorized Autodesk dealer.

**Multi-User Alignment Database**

New in AutoCAD Land Development Desktop Release 2, the alignment database is multi-user enabled. Previously, only the first person to access the alignment database received write access to all of the project’s alignments. Now, locking is accomplished on a per-alignment basis. Over a network, one person can obtain write access to one alignment, and another person can obtain write access to another alignment.

The new alignment database is named alignment.mdb.
Backwards Compatibility with Single-User Alignment Databases

To share the alignment database with someone using Release 1 of AutoCAD Land Development Desktop, you can save the alignment database as a project.adb file, the previous format of the alignment database. To do this, use the Save as .adb command on the Alignments ➤ Alignment Commands menu.

For more information about the alignment database, use to look up “Overview of the Horizontal Alignment Database” in the online Help.

Drawing Alignment Geometry

Alignment design begins by drawing alignment geometry. You need to draw only the alignment centerline—you can create offsets later by using an automated offset routine. To draw the alignment centerline, you can use the line, arc, and spiral commands in the Lines/Curves menu, as well as CAD commands such as ARC, LINE, PLINE, and FILLET. You can also draw alignments as Autodesk Survey Figures either in the field using the Autodesk Survey Command Language to input the data in a data collector, or on the Autodesk Survey Command Line.

When you draw the alignment, use object snaps to ensure that no gaps exist between each object that makes up the alignment.

You can use a polyline to draw an alignment if you need to create only simple lines and arcs. However, if you define an alignment from a polyline, then you cannot graphically select it to make it current or to identify it.
To create spirals, use the Spiral commands on the Lines/Curves menu. If you know the intended speed for the alignment, then you can draw spirals using an AASHTO or user-defined speed table, which automatically calculates superelevation information for the alignment.

**Key Concepts**

- If you use the Lines/Curves menu commands instead of PLINE or LINE, then the lines, curves, and spirals are drawn tangent to their adjacent object.
- You can define more than one alignment from the same alignment geometry.

---

### To create alignment geometry

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use ❯ to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Create a layer on which the alignment centerline is to be drawn. Use a name like “CL” for Centerline.</td>
<td>Creating and Naming Layers</td>
</tr>
<tr>
<td>2 Use one of the line drawing options in the Lines/Curves menu.</td>
<td>Draw a Line Tangent to a Line or Curve</td>
</tr>
<tr>
<td>3 To add curves, you can use the curve commands in the Lines/Curves menu. You can add a curve between two tangents, off the end of a tangent, and more. These options ensure that the curve is drawn tangent to the selected lines.</td>
<td>Overview of Drawing Curves</td>
</tr>
<tr>
<td>4 If you need a spiral, then use one of the spiral commands in the Lines/Curves menu.</td>
<td>Overview of Drawing Spirals</td>
</tr>
</tbody>
</table>
Defining an Object as a Road Alignment

By defining figure geometry as an alignment, all the individual geometric components (lines, arcs, and spirals) become linked as a single object, and the alignment data is saved to the database in the project folder.

By storing this data in an external database, you can access the alignments from all drawings in the project. After you define an alignment, it is not necessary to draft the alignment in your drawing. All commands that refer to the alignment geometry reference the database.

When you define an alignment, point data is not added to the point database. The alignment data is added only to the alignment database. You can place points along the alignment using the Create Points - Alignments commands on the Points menu.

To define an alignment

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use * # to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Draw the alignment geometry.</td>
<td></td>
</tr>
</tbody>
</table>
| 2. If you drew your alignment geometry using lines, curves, and spirals, then select Define From Objects from the Alignments menu to define the alignment. If you drew your alignment using a polyline, then select Define From Polyline from the Alignments menu. When you define the alignment, you are prompted for essential information such as the alignment name, description, starting station, and objects that comprise the alignment. | Define an Alignment from Objects
Define an Alignment from a Polyline |
Making an Alignment Current

When you work with alignments, always make sure that the correct alignment is current. Alignment commands work only with the current alignment. Only one alignment can be current at a time. When you define an alignment, it automatically becomes the current alignment.

You can select the current alignment either from the drawing, from the Alignment Librarian, or by alignment number. The following illustration shows the Alignment Librarian.

Key Concepts

- When you make an alignment current, a lock file is created for the alignment so no one else can obtain write access to that alignment.
- You can view the alignment locks by using the Project Manager command on the Projects menu. Click the File Locks button to view the project locks.
To release a lock on the current alignment, you can make a different alignment current, or you can use the Close Database command on the Alignments ➤ Alignment Commands menu to close the database and release the lock.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [F1] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Alignments menu, choose Set Current Alignment. Your cursor turns into a pickbox.</td>
<td>Make an Alignment Current</td>
</tr>
<tr>
<td>2 Select the alignment using one of the following methods: If the alignment is drafted in the drawing, then click the alignment with the pickbox.</td>
<td></td>
</tr>
<tr>
<td>3 Press ENTER when prompted to select an alignment, and then select the alignment from the Alignment Librarian. Press ENTER when prompted to select an alignment, click Cancel to close the Alignment Librarian, and then type the number of the alignment to make current.</td>
<td>Select the Current Alignment from the Librarian Dialog Box</td>
</tr>
</tbody>
</table>
Editing a Road Alignment

To edit an alignment, you can either edit the geometry and redefine the alignment, or edit the alignment data from within the Horizontal Alignment Editor.

Use the Horizontal Alignment Editor to edit individual curve, tangent, and spiral geometry, and to generate reports based on the alignment. When you save changes, drawing objects are automatically updated, so you do not need to redefine the alignment geometry.

Key Concepts

- The Horizontal Alignment Editor is dynamically linked to the drawing. Changes that you make in this editor update the alignment in the drawing automatically.
- You can use the Horizontal Alignment Editor to edit PIs (Points of Intersection) and alignment curves and spirals.
- The editor is similar to a spreadsheet. You must select inside the cell that you want to edit.
- To change the alignment properties, such as the alignment layer, color, linetype, or description, use the Modify Properties command from the Alignments ➤ Alignment Commands menu.
To edit a road alignment

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Select the current alignment.</td>
<td>Make an Alignment Current</td>
</tr>
<tr>
<td>2 From the Alignments menu, choose Edit to display the Horizontal Alignment Editor dialog box.</td>
<td>Overview of Editing Horizontal Alignments</td>
</tr>
<tr>
<td>3 To edit a curve, place your cursor in a cell where there is a curve point of intersection (PI), and then click the Edit Curve button.</td>
<td>Edit a Horizontal Alignment Curve</td>
</tr>
<tr>
<td>4 To edit a spiral, place your cursor in a cell where there is a spiral point of intersection, and then click the Edit Spiral button.</td>
<td>Edit a Horizontal Alignment Spiral</td>
</tr>
<tr>
<td>5 After you have finished editing, click OK to save all changes in the database and update the graphics.</td>
<td></td>
</tr>
</tbody>
</table>

Deleting and Importing Alignments

If you do not want to view an alignment in your drawing at all times, then you can do the following:

■ Turn off or freeze the layer that it is on.
■ Erase the alignment using the ERASE command.
■ Use the Delete command on the Alignments menu.

Erasing the alignment does not remove the alignment database definition. To redisplay the alignment in the drawing, import the alignment.

Using the Delete command, you can delete the alignment from the drawing only, the equivalent of using the ERASE command, or delete the alignment from the database as well. If you delete the alignment from the drawing, then you can use the Import command on the Alignments menu to import it back into the drawing.

If you delete the alignment from the database, then you can redefine the alignment from the drawing objects, if necessary. However, if you delete the alignment from both the drawing and the database, then you cannot restore the alignment.
Use the Import command when you want to bring a defined alignment into a drawing. For example, if you start a new drawing in a project, then you can use the Import command to bring the project’s alignments into the drawing. You can also use the Import command to bring alignments into the drawing after you have merged alignments from another project into the current project’s alignment database.

To delete or import multiple alignments at a time, then use the Multiple Selections command on the Alignments ➤ Alignment Commands menu.

**To delete multiple alignments from the drawing**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
<th>to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Alignments menu, choose Alignment Commands ➤ Multiple Selections to display the Multiple Alignments Librarian.</td>
<td>Make an Alignment Current</td>
<td></td>
</tr>
<tr>
<td>2 Select the alignments that you want to delete. Each selected alignment is marked with an asterisk (*). To de-select an alignment name, click its name again to remove the asterisk.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### To delete multiple alignments from the drawing (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>3 Select one or more Delete Options. You can delete the alignment from the screen, the database, or both. You can also delete any vertical files that are associated with the alignment. These are the alignment's profile and cross section files that are created with Autodesk Civil Design.</td>
<td>Delete Multiple Horizontal Alignments</td>
</tr>
<tr>
<td>4 Click Delete to delete the selected alignments. A confirmation dialog box is displayed. Click Yes to confirm the deletion.</td>
<td></td>
</tr>
<tr>
<td>5 If you want to set an alignment current before you close the Multiple Selections dialog box, then select the alignment name you want to set as current, and then click Select.</td>
<td></td>
</tr>
</tbody>
</table>

### Drafting Road Results

You can complete the final drafting of the alignment for base map creation by adding roadway offsets, roadway stationing, and station and offset spot labels.

You may also want to use the AutoCAD Map commands to create a network topology of the alignments. You can use these to calculate the shortest paths to destinations, or show graphically the volumes of traffic that travel along each alignment.

### Key Concepts

- All the annotation is based on the current alignment in the database.
- To station or create offsets for an alignment, the alignment must be defined to the database.
To draft road results

Steps

1. Select the current alignment.  
   Use Make an Alignment Current to look up

2. From the Alignments menu, choose Create Offsets to display the Alignment Offset Settings dialog box.
   Offset Alignments

3. Select the offsets that you want to create and enter names for them.

4. To define offsets to the Horizontal Alignment Database when they are created, select the Define offset alignments check box.

5. Click OK to create the offsets.
To draft road results (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use ( \text{Fed} ) to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>From the Alignments menu, choose Station Display Format. Change the Station Display Format</td>
</tr>
<tr>
<td></td>
<td><img src="image1.png" alt="" /></td>
</tr>
<tr>
<td>7</td>
<td>Select the station format options and click OK. Change the Alignment Label Settings</td>
</tr>
<tr>
<td>8</td>
<td>From the Alignments menu, choose Station Label Settings to change the station label settings. Change the Alignment Label Settings</td>
</tr>
<tr>
<td></td>
<td><img src="image2.png" alt="" /></td>
</tr>
<tr>
<td>9</td>
<td>From the Alignments menu, choose Create Station Labels to create station labels. Create Station Labels on an Alignment</td>
</tr>
</tbody>
</table>

Chapter 6  Creating Cadastral Information

220
Working with Parcels

When you create base maps or do subdivision work, you define parcels of land. Parcel boundaries define the area and the limits of each parcel. You can define parcels from survey figures, points, lines, curves, or polylines. If you are creating parcels by area, then you can use the Parcel Sizing commands to create parcels of exact areas.

Like alignments, parcel definitions are stored in an external database so multiple people can access them. Because their definitions are stored externally, you can delete the geometry in the drawing and still reference the parcel.

When defining parcels, you have the option of labeling the parcels with a parcel number, area, and description. To manage parcels, use the Parcel Manager command on the Parcels menu. You can use this command to report mapcheck and inverse data, as well as to import, delete, and rename parcels.

After you define a parcel, you can calculate its volumes using the grid and composite volume methods.

You may want to use the AutoCAD Map commands to create a database of parcel numbers, owners, cost, and so on to help manage parcel maps. For more information, see Chapter 8, “AutoCAD Map and AutoCAD Land Development Desktop.”

Drawing Parcel Geometry

To draw the parcel boundaries, you can use the commands in the Lines/Curves menu, or other CAD commands such as LINE or PLINE. You can also define parcel boundaries from points.

NOTE  Do not use spirals in parcel boundaries. Spirals cause incorrect areas to be reported.

If you have Autodesk Survey, then you can also draw parcel boundaries as Autodesk Survey Figures either in the field using the Autodesk Survey Command Language to input the data in a data collector, or on the Autodesk Survey Command Line.

NOTE  Be sure to draw the parcels as closed regions. If any of the joining lines has a break, then you cannot calculate areas.
If you use polylines to draw parcel geometry, then you must break crossing polylines before defining the parcels. Also, delete any duplicate lines that you may have drawn where two parcels abut each other. You can break crossing lines and erase duplicate lines by using the AutoCAD Map Cleanup command. For more information, see “Cleaning Up Maps” in Chapter 8, “AutoCAD Map and AutoCAD Land Development Desktop.”

**Draw Parcel Geometry Based on Area**

To draw a parcel so that it is a specific area, use the Parcel Sizing commands. Simply draw the parcel with only one open segment, and then use one of the parcel sizing commands to draw the closing segment.

The following illustration shows how a parcel is defined by using the Slide Bearing command.

![Parcel Geometry Diagram](image)

Depending on the parcel settings, these commands can define the parcel to the parcel database, and they can also label the parcel that is calculated.

You cannot use the Parcel Sizing commands to edit a parcel that is already defined to the parcel database. To change a parcel definition, you must delete the existing parcel definition and redefine the parcel. For more information about deleting parcels, see “Managing Parcels” in this chapter.
Defining Parcels to the Parcel Database

As with alignments, you must define parcels to the parcel database so that the individual geometric components points, lines, arcs, or polylines, become linked as a single object. This parcel data is stored in a database in the project folder.

When you define parcels to the database, you can label them and perform mapcheck calculations on them, depending on what you specify in Parcel Settings.

To define parcels to the parcel database

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use - to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Draw a parcel using the PLINE command. (Draw Parcels)</td>
</tr>
<tr>
<td>2</td>
<td>From the Parcels menu, choose Parcel Settings to display the Parcel Settings dialog box. (Change the Parcel Settings)</td>
</tr>
<tr>
<td>3</td>
<td>Under Options, select the Label parcels as defined check box and Automatic Label Placement.</td>
</tr>
</tbody>
</table>

Working with Parcels 223
To define parcels to the parcel database (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
<th>to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>4 Under Parcel Numbering, select the Sequential on check box. This option numbers the parcels sequentially. If you clear this check box, then you are prompted for the parcel number each time you define a parcel. You can use alpha-numeric characters for parcel numbers.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5 Under Parcel Numbering, select the Labels on check box. This option labels each parcel with its number.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6 Under Square Feet/Meters Labeling, select the Labels on check box. This option labels each parcel with its area.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7 Click OK.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8 From the Parcels menu, choose Define from Polylines.</td>
<td>Define a Parcel from a Polyline</td>
<td></td>
</tr>
<tr>
<td>9 Select the polyline that represents the parcel. The parcel is then defined to the parcel database.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Managing Parcels

You can use the Parcel Manager to import, delete, and rename parcels, as well as report area, inverse, and mapcheck information.

Key Concepts

- Use the Rename option to assign alpha-numeric names to the parcels.
- You can import parcels into a drawing if you have either erased the parcel lines or want the parcels to be visible in a different project drawing. Erasing the parcels with the ERASE command does not remove the parcel database definitions. To redisplay the parcels in the drawing, import them with the Parcel Manager.
- To permanently delete the parcels from the drawing, use the Delete option in the Parcel Manager. This option deletes the parcel from the parcel database.
- You can report parcel information such as Area, Perimeter, Mapcheck, and Inverse results. You can review the results and either print them, or save them in a text file to use in final reports.
- If you created a parcel definition from an Autodesk Survey figure, then you can report additional data about the parcels by using the Autodesk Survey figure display, inverse, mapcheck, and perimeter closure commands.
## To report parcel areas

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Define the parcel to the parcel database.</td>
<td>Overview of Defining Parcels</td>
</tr>
<tr>
<td>2 From the Parcels menu, choose Parcel Manager to display the Parcel Manager dialog box.</td>
<td>Overview of Managing Parcels</td>
</tr>
<tr>
<td>3 In the Select Parcel list, select one or more parcels about which you want to report information. When you select a parcel, it is marked with an asterisk. In the following illustration, the parcels named lot1 and lot2 are selected.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Selected parcels" /></td>
<td></td>
</tr>
<tr>
<td>4 Click the Output Settings button and select the report options, such as the report name and destination.</td>
<td>Change the Output Settings</td>
</tr>
<tr>
<td>5 Click the Area button to create an area report.</td>
<td>Report Parcel Area, Inverse, or Map Check Data</td>
</tr>
<tr>
<td>6 You can either print the results or save them to an ASCII text file.</td>
<td></td>
</tr>
</tbody>
</table>
7

Listing and Annotating Plans

To check object characteristics, you can perform inquiries which list object data at the command line or in a dialog box. To label objects with selected information, you can create dynamic and static labels, and you can create object tables that list detailed information about tagged objects in the drawing.
Introduction

In a drawing, geometry can be difficult to interpret if it is not given a context, especially when you receive a drawing from someone else. To check object characteristics, you can perform an inquiry on a drawing object. An inquiry shows you information about the selected object on the command line, the status bar, or in a tracking window.

If you want a more permanent solution for identifying drawing objects—especially when you are ready to plot the drawing—you can label the drawing objects at any time during the drawing process. AutoCAD Land Development Desktop can create dynamic labels which update whenever you edit the drawing objects. However, if you do not want labels to update automatically, then you can create static labels.

If you want to annotate your drawing manually, then you can create TEXT, MTEXT (multi-line text), or CTEXT (text on a curve). TEXT and MTEXT do not move or update when your drawing changes. However, if you edit a curve, the CTEXT moves with it. For more information about creating text, see “Working with Text” in Chapter 4, “Working with Drawing and Editing Tools.”

Listing Object Data

To quickly view data about objects, use the Inquiry commands. AutoCAD Land Development Desktop has two types of inquiry commands:

- CAD-based
- AutoCAD Land Development Desktop-specific

CAD-Based Inquiry Commands

These commands include the following commonly used commands that you can select from the Tools ➤ Inquiry menu:
### Inquiry commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distance</td>
<td>Measures the distance between two points.</td>
</tr>
<tr>
<td>Area</td>
<td>Calculates the area and perimeter of objects or defined areas.</td>
</tr>
<tr>
<td>Mass Properties</td>
<td>Calculates and displays the mass properties of regions or solids.</td>
</tr>
<tr>
<td>List</td>
<td>Displays database information of selected objects.</td>
</tr>
<tr>
<td>ID Point</td>
<td>Displays the coordinate values of a location.</td>
</tr>
<tr>
<td>Time</td>
<td>Displays the date and time statistics of a drawing.</td>
</tr>
<tr>
<td>Status</td>
<td>Displays drawing statistics, mode, and extents.</td>
</tr>
<tr>
<td>Set Variable</td>
<td>Lists or changes the values of system variables.</td>
</tr>
</tbody>
</table>

### AutoCAD Land Development Desktop Inquiry Commands

To query AutoCAD Land Development Desktop-specific objects, use one of the AutoCAD Land Development Desktop Inquiry commands. You can use these commands to query points, geometry, distances, areas, slopes, and elevations.

Most commands are list-based, meaning that the information is displayed on the command line. However, Track North/East, uses a dynamic tracking window that updates when you move the pointing device.

AutoCAD Land Development Desktop has several other specific reporting and listing commands. For example, you can:

- List which raster images are inserted into a drawing and locate the source files by using the Manage command on the Map ➤ Image menu.
- List which alignments are defined in the project by using the List Defined command on the Alignments ➤ Alignment Commands menu.
List which breaklines are defined in the project by using the List Breaklines command from the Breaklines shortcut menu in the Terrain Model Explorer.

Show statistics for a surface model in the Terrain Model Explorer.

Create alignment, stakeout, volume, and parcel reports.

---

### To track the elevation of a surface

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Build a surface.</td>
<td>Build a Surface</td>
</tr>
<tr>
<td>2. Make that surface the current surface.</td>
<td>Make a Surface Current</td>
</tr>
<tr>
<td>3. From the Inquiry menu choose Track Elevation.</td>
<td>Track Elevations</td>
</tr>
<tr>
<td>4. Move the pointing device over the surface.</td>
<td></td>
</tr>
</tbody>
</table>

The surface elevation is displayed on the status bar. If you move the pointing device outside the surface area, then an out of bounds message is displayed.

---

### To list the station and offset of a location in relation to the current alignment

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Define an alignment.</td>
<td>Overview of Defining Alignments</td>
</tr>
<tr>
<td>2. From the Inquiry menu, choose Station/Offset Alignment.</td>
<td>List the Station and Offset of a Location in Relation to the Current Alignment</td>
</tr>
<tr>
<td>3. Select a location on screen that is adjacent to the current alignment.</td>
<td></td>
</tr>
</tbody>
</table>

The station and offset of the location is listed on the command line.
To list which alignments are defined in the project

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Define at least one alignment.</td>
<td>Overview of Defining Alignments</td>
</tr>
<tr>
<td>2 From the Alignments menu, choose Alignment Commands ➤ List Defined.</td>
<td>List the Alignments that are Defined in the Current Project</td>
</tr>
<tr>
<td></td>
<td>The defined alignments are listed in the AutoCAD Text Window.</td>
</tr>
<tr>
<td>3 Press any key to continue.</td>
<td></td>
</tr>
</tbody>
</table>

Labeling Objects

You can label the lines, curves, spirals, and polylines in your drawings by using the AutoCAD Land Development Desktop labeling commands. Each object can have more than one label. You can customize your own label styles to apply to the drawing labeling objects, or you can use one of the pre-defined label styles included with AutoCAD Land Development Desktop. You can include the information either along an object, at a point next to the object, or in a table.

Depending on your requirements, you can choose from three different labeling methods:

- **Dynamic labels**: Creates labels that update automatically.
- **Static labels**: Creates labels that never change if you move the object or edit the style.
- **Tag labels**: Tags each object with a tag label and places detailed information in a table.

All methods require you to select a label style and then label the object.

Label Styles

To control the appearance of labels, and to specify which type of information is labeled, you can set up label styles. For example, you can set up a label style to label the distance and direction of a line on top of the line, using the current text style for the label. If you label
the objects with dynamic labels, then whenever you edit the style, the labels are updated to reflect the edited style.

Point label styles control the use of description keys for points, and they can also be formatted to label points with information that is located in external Microsoft Access databases.

For more information about label styles see “Editing Label Styles” in this chapter.

**Accessing Labeling Commands**

You can access the labeling commands in one of three ways. You can select commands from the Labels pull-down menu, use the Object shortcut menu, or use the Style Properties dialog bar.

**Object Shortcut Menu**

The object shortcut menu gives you quick access to the labeling commands. You can select the objects that you want to label, right-click, and then select the labeling command that you want to use.
**Style Properties Dialog Bar**

You can use the Style Properties dialog bar to choose the current label styles, to switch between tag and normal label styles, to change the label settings, and to edit label styles.

![Style Properties Dialog Bar](image)

To display the Style Properties dialog bar, select Show Dialog Bar on the Labels menu. You can dock the dialog bar either on the top or bottom of the graphics window if desired, but not to the side.

**TIP**
If you want to move the dialog bar up into the menu area or into the command line area but you do not want to dock it, then hold down the CTRL key while you move the dialog bar.

**Key Concepts**

- You can label objects individually or as a group, and you can label any combination of lines, curves, spirals, and polylines simultaneously.
- Polylines use the current line label style for straight segments, and the current curve style for curved segments. Only lightweight polylines can be labeled.
- You can control the label details such as arrows, spacing, alternate units, and angle units when you set up the label styles.
- To label alignments, contours, and parcels, use the labeling commands in the Alignments, Terrain, and Parcels menus.

---

**To label lines with dynamic labels**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use <code>Help</code> to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Use the LINE command to draw some lines.</td>
<td><strong>LINE Command</strong></td>
</tr>
<tr>
<td>2 From the Labels menu, choose Show Dialog Bar to display the Style Properties dialog bar</td>
<td><strong>Select the Current Label Style from the Preferences Dialog Box</strong></td>
</tr>
</tbody>
</table>
To label lines with dynamic labels (continued)

Steps

3 Verify that the icon is displayed. When this icon is visible, only regular label styles are displayed in the Current Label Style list.

If the icon is displayed, the list of styles shows only tag label styles. You can click the tag icon to display the labels icon.

4 Click the Line tab.

5 Select a style from the list, like direction above, distance below.

6 Click to display the Label Settings dialog box.

7 Click the General tab.

8 Verify that the Update Labels When Style Changes and the Update Labels When Objects Change check boxes are selected.

These check boxes control whether the labels are updated if you edit an object or label style.

The Update Labels When Objects Change check box must be selected if you want to create dynamic labels.

9 Click OK to return to the drawing.

10 Select the lines that you want to label.

11 Right-click to display the shortcut menu.

12 Select Add Dynamic Label.

13 Click a grip on one of the lines and drag it out to lengthen the line.

The label is updated with the new distance and angle.
To label lines with tag labels and create a table

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Use the LINE command to draw some lines.</td>
</tr>
<tr>
<td>2</td>
<td>From the Labels menu, choose Show Dialog Bar to display the Style Properties dialog bar.</td>
</tr>
<tr>
<td>3</td>
<td>Verify that the icon is displayed. When this icon is visible, only tag label styles are displayed in the Current Label Style list. If the icon is displayed, then the list of styles shows only regular label styles. You can click the label icon to display the tag icon.</td>
</tr>
<tr>
<td>4</td>
<td>Click the Line tab.</td>
</tr>
<tr>
<td>5</td>
<td>Select the Tag Number style.</td>
</tr>
<tr>
<td>6</td>
<td>Select the lines that you want to label.</td>
</tr>
<tr>
<td>7</td>
<td>Right-click to display the shortcut menu.</td>
</tr>
<tr>
<td>8</td>
<td>Select Add Tag Label.</td>
</tr>
<tr>
<td>9</td>
<td>From the Labels menu, choose Add Tables ➤ Line Table to display the Line Table Definition dialog box. By default, the Column Definitions are set up to place line number, line length, and bearing in the table.</td>
</tr>
<tr>
<td>10</td>
<td>Click OK to create the table.</td>
</tr>
<tr>
<td>11</td>
<td>Select an insertion point for the table. This is the upper-right corner of the table. The table is placed in the drawing.</td>
</tr>
</tbody>
</table>

Labeling Objects 235
Editing Label Styles

AutoCAD Land Development Desktop includes several different default default label styles. You can edit these styles if needed, and you can create new styles.

A label style controls the appearance of the label text, such as the style, label offset, text layer, and text justification.

A label style also controls what pieces of information the label contains, such as direction and distance. These are called data elements.

To edit a line label style

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. From the Labels menu, choose Edit Label Styles to display the Edit Label Styles dialog box.</td>
<td>Overview of Label Styles</td>
</tr>
<tr>
<td>2. Click the Line Label Styles tab.</td>
<td>Edit Line Label Styles</td>
</tr>
</tbody>
</table>

Edit Label Styles dialog box:
- **Line Label Style**: Select the style to edit.
- **Text Properties**: Adjust height, offset, style, and layout.
- **Data**:
  - Length
  - Direction
  - Start Point
  - Start Ending
  - Text Above
  - Text Below
- **Units**:
  - Linear
  - Angular

The "100.00" preview values depicted above are numeric place holders and do not necessarily represent the actual values.
To edit a line label style (continued)

Steps

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>From the Name list, choose the name of the Label Style that you want to edit.</td>
</tr>
<tr>
<td>4</td>
<td>When you select a style, the Text Above and Text Below sections of the dialog box display the selected data elements. The box on the right shows you a preview of this label. If you want to edit any elements of the selected style, then you can type modifications in the Text Above and Text Below boxes, or delete existing text in these boxes. You can also select different data elements to place in the label.</td>
</tr>
<tr>
<td>5</td>
<td>If you want to add an arrow, tick marks, or crows feet to the objects you are labeling, then select the appropriate check boxes.</td>
</tr>
<tr>
<td>6</td>
<td>Under Text Properties, select a text style, specify an offset, select a layer, and specify the justification method for the label.</td>
</tr>
<tr>
<td>7</td>
<td>Click Save to save the label.</td>
</tr>
<tr>
<td>8</td>
<td>Click OK.</td>
</tr>
</tbody>
</table>
AutoCAD Map and AutoCAD Land Development Desktop

Using the AutoCAD Map commands, you can work with the data in more than one drawing at a time by performing queries. You can digitize and clean up maps, and you can assign data to drawing objects to perform spatial analysis of the data on your project.
Introduction

AutoCAD Land Development Desktop incorporates the full functionality of AutoCAD Map® 2000. All mapping commands are located in the Map menu. You can use the AutoCAD Map commands to create, manage, analyze, and plot plans that include geographical as well as statistical data.

Using the AutoCAD Map commands, you can

- Access, query, and edit data from multiple drawings, and then save the changes back to the original drawings.
- Work with other users on the same drawing without interfering with their work.
- Digitize and clean up maps, for example, to break crossing lines, and clean up overshoots and undershoots.
- Link maps to external databases.
- Convert drawings from one coordinate system to another.
- Add intelligence to your drawing objects by creating topologies, which you can use to analyze the map features.
- Create node, network, and polygon topologies, buffer areas, and dissolve overlaps.
- Convert the attribute information in blocks to database entries.
- Create thematic maps that show land suitable for building, the range of parcel prices within a subdivision, or those of a certain size or soil type.
- Plot map books.

This chapter introduces you to the features of the AutoCAD Map commands, and how you can use them in your AutoCAD Land Development Desktop projects. This chapter has several references to the online Help, where you can find more detailed information about the AutoCAD Map commands.

For more information about the main features of AutoCAD Map, use find to look up “Introducing AutoCAD Map 2000” and “Main Features of AutoCAD Map 2000” in the online Help.
Using the AutoCAD Map Project Workspace

You can use the AutoCAD Map Project Workspace to manage attached drawings, queries, databases, topologies, and link path names in the current Map project.

**NOTE** In AutoCAD Map, the current drawing is called a project. A Map project is a drawing file that lists and controls the items that are defined for the current work session. It does not manage the AutoCAD Land Development Desktop project data based on the current Land Desktop project that you are working in.

When you start AutoCAD Land Development Desktop, the AutoCAD Map Project Workspace is docked to the left side of your drawing window by default, as shown in the following illustration.
Map Project Workspace Shortcut Menus

Each item in the workspace has its own shortcut menu where you can access commonly used commands. For example, if you click on the Drawings folder and then right-click, the following shortcut menu is displayed.

![Shortcut Menu Example](image)

You can place your cursor inside the workspace window, right-click, and select Docked to undock the workspace and move it.

To hide the Project Workspace, right-click in the Project Workspace and then select Hide. To redisplay the Project Workspace, select Project Workspace on the Map ➤ Utilities menu.

Dragging Files

You can drag drawing files and database files into the Project Workspace from Windows Explorer. When you drag and drop a drawing into the Project Workspace, the drawing is added to the current Map project. When you drag and drop a database, the database is connected to the current Map project.

For more information about using the Map Project Workspace, use to look up “AutoCAD Map Options dialog box” in the online Help.
Map Projects and Drawing Sets

When you use the Map commands, you can work with your drawings in two different ways. Sometimes you open .dwg files directly and work on them. Other times you can attach other drawings to the Map project to create a drawing set. Then you can query objects from the drawing set into the Map project.

NOTE
In AutoCAD Map, the current drawing is referred to as a project. To avoid confusion between drawings and the AutoCAD Land Development Desktop project system, this documentation uses the term Map project to refer to the current AutoCAD Map drawing.

When you work with a drawing set, you can view and edit the objects in more than one drawing at a time by performing queries. For example, you can define a query that inserts all objects in the source drawings that are on layer WATER into the Map project.

When to Create Drawing Sets

If you want to perform an action that requires information from other drawings, then create a new drawing and attach source drawings to create a drawing set. You must use drawing sets if you do any of the following:

- Perform queries from other drawings or databases
- Work with drawings that were created using different coordinate zones
- Edit objects that are in source drawings
- Plot map sets

If you want to perform an action that does not need objects in any other drawing, then use the Open command on the File menu to open that drawing. You cannot work in a drawing set when you do any of the following:

- Add object data to the drawing objects
- Digitize
- Clean up maps
- Create topologies (except overlay topologies)
Drawing Sets and AutoCAD Land Development Desktop Projects

Attached drawings can be associated with any AutoCAD Land Development Desktop project. For example, you can attach Drawing A in Project A and Drawing B in Project B to the same Map project. For example, if you are working on a job that contains two or more AutoCAD Land Development Desktop projects, then you can create a drawing set that shows the drawings in both projects so you can see an overall view of the job.

Data Storage

In AutoCAD Map, a drawing stores much more than objects and coordinates. All the associated data is also stored in the drawing. However, you can also link a drawing to an SQL database. In that case, the data is stored outside the drawing.

Key Concepts

- A drawing set does not automatically bring objects from other drawings into the Map project. You must define a query to bring the objects into the Map project.
- AutoCAD Map uses one default location for the source drawings that you can attach to the Map project, c:\. To attach drawings that are in different locations, you must define a drive alias. A drive alias points to the drive where your drawings are stored.
- You can activate or deactivate drawings that are attached to the Map project. In order to edit the objects or to perform queries, however, the drawings must be active.
# To set up a Map project

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Create a new drawing.</td>
<td>Start a New Drawing</td>
</tr>
<tr>
<td><strong>NOTE</strong> Have at least two existing drawings that you can use as source drawings for this exercise.</td>
<td></td>
</tr>
<tr>
<td>2. From the Map menu, choose Drawings ➤ Define/Modify Drawing Set to display the Define/Modify Drawing Set dialog box.</td>
<td>Create a Project</td>
</tr>
</tbody>
</table>

![Define/Modify Drawing Set dialog box](image-url)
To set up a Map project (continued)

Steps

3. Click Attach to display the Select Drawings to Attach dialog box.

4. To attach a drawing, it must be located in a drive alias location. The default drive alias is your c:\ drive. If the drawings that you want to attach are located on another drive, then you must set up an alias.
To set up a Map project (continued)

Steps | Use
---|---
5 Click the Create/Edit Aliases button, as shown below, to display the Drive Alias Administration dialog box.

![Create/Edit Aliases](image)

6 Define the drive alias. For detailed instructions about how to define the alias, click the Help button on the dialog box.

7 Click OK to return to the Select Drawings to Attach dialog box.

8 Open the folder where the drawings are stored.

9 Select the drawing name and then click Add.
   Repeat this step for each drawing that you want to attach.

10 Click OK to return to the Define/Modify Drawing Set dialog box.

11 Verify that each drawing is active.

12 Click OK to exit the dialog box.

13 Save the Map project.

Map Projects and Drawing Sets 247
You can now create a query to bring objects from the attached drawings into the Map project. For more information, see “Defining Queries” in this chapter.

For more information about Map projects, use \( \text{Find} \) to look up “About Projects” in the online Help.

**Defining Queries**

A query is a retrieval method. You define what you want to bring into a Map project, and the query brings that data into the drawing from other drawings or databases. For example, to work in more than one drawing at a time, you create a Map project, attach the drawings, and then perform queries. You perform queries when you want to combine information from two or more drawings, create thematic maps, and perform zone conversions.

To perform queries, you must be working within a Map project. You can perform object, topology, and thematic queries.

**Key Concepts**

- **Object queries** bring objects into the Map project, based on different selection methods. For example, you can query either objects from one layer or objects that you select, such as the soil lines from one drawing and contours from another drawing into your subdivision layout drawing.

- **Topology queries** bring topologies into the Map project. For example, one drawing may contain the soils map, and another the parcel map topology. By performing a topology query, you can see what areas are affected by poorly drained soil.

- **Thematic queries** create thematic maps. A thematic map is a map in which continuous or discrete categories of data are hatched or shaded, or otherwise associated with a symbol, so you can easily determine visually what categories you are looking at. For example, these can be parcels that are below minimum standards, or areas that are too steep to build on.
The Purposes of Queries

When should you perform a query?

■ When you want to work on data contained in more than one drawing at the same time.

You can create a Map project and query the objects from two or more drawings. This type of object query actually copies the source objects into the Map project. You can then edit the objects from different drawings simultaneously, and save the edits back to the source drawing if you want.

■ When you have two or more drawings that were created in different coordinate zones.

You can create a Map project and assign to it the coordinate zone in which you want to work. You can then query the other drawings, and the drawings' information is converted to the zone of the Map project when it is brought in.

■ When you have two or more drawings that were created using different units.

You can create a Map project and then perform an object conversion when you query the other drawings. The object conversion can scale the source drawings so that their units match when you bring them into the Map project.

■ When you want to create a thematic map.

A thematic map shows map features by either continuous or discrete categories. For example, you can perform a thematic query to show wetlands and buildable areas, using different colors to indicate the different regions.

Key Concepts

■ You can create legends for thematic maps. Legends describe the symbols and colors that are used in a thematic map.

■ There are several ways to query objects. You can query objects by location, layer name, block name, elevation, color, line type, and so on.

■ You can alter object properties, such as line width and scale, during queries.
The following task describes how to bring objects into a Map project from the source drawings.

**To define an object query**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. <strong>Create a new drawing. This is your Map project.</strong></td>
<td>Create a Project</td>
</tr>
<tr>
<td>2. <strong>Attach the source drawings to the Map project. These drawings should contain at least one object that you can query.</strong></td>
<td>Attach Drawings</td>
</tr>
<tr>
<td>3. <strong>From the Map menu, choose Drawings ➤ Zoom Drawing Extents.</strong> This command zooms to the extents of all the drawings attached to the Map project, even though the drawing objects are not yet visible on screen.</td>
<td>ADEZEXTENTS</td>
</tr>
<tr>
<td>4. <strong>From the Map menu, choose Drawings ➤ Quick View Drawings.</strong> This command shows you the contents of all the drawings attached to the Map project as temporary lines.</td>
<td>Quick View Drawings dialog box</td>
</tr>
<tr>
<td>5. <strong>From the Map menu, choose Query ➤ Define Query</strong> to display the Define Query dialog box.</td>
<td>Define a Query</td>
</tr>
</tbody>
</table>

6. You can use many different methods to select the objects you want to query. This example describes how to use a simple window selection. | Find All Objects in a Specified Location |

---

Chapter 8  AutoCAD Map and AutoCAD Land Development Desktop

250
To define an object query (continued)

Steps | Use Find to look up
--- | ---
7 Click Location to display the Location Condition dialog box. | Location Condition dialog box

![Location Condition dialog box](image)

8 Under Boundary Type, select Window. | Boundary Type Area

9 Click Define and draw a window around the objects that you want to query. The Define Query dialog box is displayed.

10 Under Query Mode, select Draw. | Choose a Query Mode

**NOTE** You can click Preview to create temporary objects, or you can click Report to create a report.

11 Click Execute Query. The objects are copied into the Map project. You can now use any editing command to work directly on the objects.

For more information about queries, use Find to look up “About Queries” in the online Help.

Defining Queries 251
Saving Queried Data

When you work within a Map project, you can save any edits that you made to the back source drawings. The items that you choose to save back are called a Save Set.

NOTE This topic describes the save options for only the AutoCAD Map commands, not for the entire AutoCAD Land Development Desktop program.

Key Concepts

- The data that you query from source drawings is readable and writable by default. If you edit the source drawing data while working in the Map project, then you can save the objects back to the source drawings.
- If you never want to save the objects back to a save set, then select Don’t Add Objects Automatically in the AutoCAD Map Options dialog box.
- If you want objects added to the save set automatically, then select Add Objects Automatically Without Prompting in the AutoCAD Map Options dialog box.

To save back objects to the source drawing

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use F6 to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Define a Map project and attach drawings. One of the source drawings should have an object that you can experiment with, such as a line or arc.</td>
<td>Create a Project</td>
</tr>
<tr>
<td>2 Define a query that will bring the objects from the source drawings into the Map project. For more information, see “Defining Queries” in this chapter.</td>
<td>Define a Query</td>
</tr>
<tr>
<td>3 From the Map menu, choose Options to display the AutoCAD Map Options dialog box.</td>
<td>AutoCAD Map Options dialog box</td>
</tr>
</tbody>
</table>
To save back objects to the source drawing (continued)

Steps

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>4</strong> Click the Save Back tab.</td>
<td><strong>Use</strong> to look up</td>
<td></td>
</tr>
</tbody>
</table>

![AutoCAD Map Options](image)

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>5</strong> Under Save Set, select Add Objects Automatically Without Prompting.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>6</strong> Under Save Back to Source Drawings, clear the Erase Saved Back Objects check box.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

This keeps a copy of the objects in the Map project when you save the objects. If you clear this check box, then any time you save the drawing, the edited objects are removed from the drawing.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>7</strong> Click OK.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>8</strong> Use grips, or any other editing method, to edit one of the objects that you queried from the source drawing.</td>
<td><strong>Editing With Grips</strong></td>
<td></td>
</tr>
</tbody>
</table>

The Confirm Save Back dialog box is displayed.

Saving Queried Data

253
To save back objects to the source drawing (continued)

Steps  Use \text{F10} to look up

9  Click Yes to add the object you just edited to the Save Set.

You see the message, “1 object(s) added to save set.”

10  From the File menu, choose Save.

The Save Objects to Source Drawings dialog box is displayed.

11  Click OK to save the objects back to the source drawings.

For more information about saving, use \text{F10} to look up “About Save Options” in the online Help.

Inserting Geo-Referenced Images

You can use the Insert command on the Map ➤ Image menu to insert geo-referenced images into your drawing. Geo-referenced images are images that are saved with real-world coordinates. These coordinates can be used as a correlation source when you insert the image into a drawing. Correlation controls the location, scale, and rotation of the image.

Key Concepts

- Some images, like GeoTIFFs, store correlation within the image file itself, so you can choose Image File as the correlation source.
- Other image types are saved with world files that store the correlation information, and if a world file was saved for the image, you can select the world file as the correlation source.
To insert a Geo-TIFF image into a drawing

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From the Map menu, click Image ➤ Insert to display the Insert Image dialog box.</td>
<td>Insert Image dialog box</td>
</tr>
<tr>
<td>2 Locate the file you want to insert, and verify that the Modify Correlation check box is selected, as shown in the following illustration.</td>
<td></td>
</tr>
</tbody>
</table>

In this example, the image that is selected is a GeoTIFF, an image that has correlation data stored within the image file.
To insert a Geo-TIFF image into a drawing (continued)

Steps

3 Click Open to display the Image Correlation dialog box.

4 Select Image File as the correlation source. Or you can change the Insertion Values if required.

5 Click OK to insert the image into the drawing. You may need to use the Extents option of the ZOOM command to locate the image in the drawing.
Digitizing Maps

Before you can create a map topology and analyze a map, you must create the underlying map geometry if it doesn’t already exist. To do this, use the Digitize command. Digitizing is the process of creating vector lines by tracing non-vector geometry. The geometry can be supplied in the form of a paper map that you trace using a tablet and a digitizer puck, or in the form of a raster image, such as an aerial photo of a parcel map or a government soils map.

You are not confined to using the Digitize command to create vectors. You can use the LINE or PLINE commands. However, by using the Digitize command, you can attach object data to the objects as you draw them. For more information, see “Assigning Data to Objects in a Drawing” in this chapter.

For more information about other methods of digitizing, see “Digitizing” in Chapter 4, “Working with Drawing and Editing Tools” in this guide.

Key Concepts

- The Digitize command creates 2D or 3D polylines for soil lines, streams, power/utility lines, and so on.
- If you are digitizing contours, then you may want to use the Digitize Contours command from the Terrain ➤ Contour Utilities menu. This command creates contour objects at elevations.
- Use the AutoCAD TABLET command to calibrate your tablet for digitizing. For more information about tablets, use the Find tab to look up “TABLET Command” in the online Help.

To digitize a raster image

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use Find to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Create a new drawing.</td>
<td>Start a New Drawing</td>
</tr>
<tr>
<td>2. Insert a raster image into the drawing. For more information see “Inserting Geo-referenced Images” in this chapter.</td>
<td>Insert Images</td>
</tr>
</tbody>
</table>

**NOTE** For digitizing purposes, binary (2-color) images are easiest to use.
To digitize a raster image (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [\text{F1}] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>3 From the Map menu, choose Data Entry ➤ Digitize Setup. For digitizing lines, select the Linear option. For digitizing nodes, select the Nodes option. Click the Help button in the dialog box for more detailed information about the settings.</td>
<td>Set Up for Digitizing Digitize Links and Nodes</td>
</tr>
<tr>
<td>4 From the Map menu, choose Data Entry ➤ Digitize.</td>
<td>MAPDIGITIZE</td>
</tr>
<tr>
<td>5 Select points (or vertices of polylines if you are digitizing lines) on the raster image.</td>
<td></td>
</tr>
<tr>
<td>6 Continue to select points or vertices until the image is digitized.</td>
<td></td>
</tr>
</tbody>
</table>

For more information about digitizing maps, use \[\text{F1}\] to look up “About Digitizing and Importing” in the online Help.

Cleaning up Maps

Sometimes when you are digitizing, you may unintentionally digitize the same object twice. Or you might draw lines that are too long (overshoots) or too short (undershoots). Before you can create a topology to perform map analysis, you must perform a map cleanup. A map cleanup identifies the problem areas in your drawing so you can go back and fix them. Or, you can choose to have the Cleanup command fix the problems for you automatically.

Along with deleting duplicate objects and shortening and lengthening lines, the Cleanup command also locates (and breaks) lines that cross. This makes digitizing easier, because you do not have to draw discrete lines for every object that you want to represent, such as parcels.
Using the Cleanup Command to Break Parcel Lines

In order to define a parcel with the Parcel commands, or to create a parcel topology, the parcel lines in your drawing cannot cross each other. You must break any parcel lines that cross.

For example, the following illustration shows how you might have digitized two adjacent parcels. Polyline A (dashed line) goes around the outer boundaries of both parcels. Polyline B (solid line) is the boundary between the parcels. However, if you want to create a topology or define the polygons as parcel objects, then Polyline A cannot be a boundary for both Parcel 1 and Parcel 2. You must break Polyline A so that both parcels do not share the same polyline.

NOTE: The boundary, Polyline B, can be shared between both parcels.
To break the polylines, use the Cleanup command. The following illustration shows how the polyline was broken when using the Cleanup command.

Polyline A was broken up at the locations marked by X’s so that Parcel 1 and Parcel 2 are made up of discrete polylines. To obtain this result, run the Cleanup command and select both the option to Break Crossing Objects and the option to Correct Automatically.

**Key Concepts**

- You should always repeat the Cleanup command until the command no longer locates any problems with the objects.
- You can convert 3D polylines, lines, or arcs to 2D polylines when you clean up the drawing. You can also convert circles to arcs.
- Remove duplicate lines from a drawing before you create a topology or analyze the map. For example, in the preceding illustration, Polyline B is shared between both parcels. You do not want two lines or polylines representing this boundary. You can select a cleanup option to delete duplicate lines.
- If your parcel linework was comprised of lines and arcs, then you can clean up the drawing and convert the parcel lines to polylines. To do this, use the Create Closed Polylines command from the Map ➤ Tools ➤ Topology menu. You then can use the Define from Polyline command on the Parcels menu to define the polylines as parcels.
Checking a Drawing for Crossing Breaklines

Use the Cleanup command to check an AutoCAD Land Development Desktop drawing for breaklines that may cross each other. Breaklines that cross each other at the same elevation should not cause any problems when you build a surface. However, if breaklines cross at different elevations, the surface may not be built properly.

To check the drawing for crossing breaklines

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Clean Up a Drawing</td>
</tr>
<tr>
<td></td>
<td>ADEDWGCLEAN</td>
</tr>
</tbody>
</table>

1. From the Map menu, choose Map Tools ➤ Drawing Cleanup to display the Drawing Cleanup dialog box.

2. Click the Object Selection button to display the Object Selection dialog box.

3. Using a selection method, select the breaklines. The easiest method is to select the layer where the breaklines are located.

   To do this, select the Select Automatically option, select the Filter Selected Objects check box, and then select the layer on which the breaklines are located.
To check the drawing for crossing breaklines (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use Help to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Click OK to return to the Drawing Cleanup dialog box.</td>
</tr>
<tr>
<td>5</td>
<td>Click the Cleanup Options button to display the Cleanup Options dialog box.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Cleanup Options dialog box" /></td>
</tr>
<tr>
<td>6</td>
<td>Under Edit Geometry, select the Break Crossing Objects check box.</td>
</tr>
<tr>
<td>7</td>
<td>Under Correction Method, select the Correct Manually option.</td>
</tr>
<tr>
<td></td>
<td>This method does not change anything in your drawing, it only places markers where it locates problems.</td>
</tr>
<tr>
<td>8</td>
<td>Click OK to return to the Drawing Cleanup dialog box.</td>
</tr>
<tr>
<td>9</td>
<td>Click Proceed.</td>
</tr>
<tr>
<td></td>
<td>If the command locates crossing objects, then the following prompt is displayed.</td>
</tr>
<tr>
<td></td>
<td>Crossing: breakAll/ examineEach/ Highlight/ drawMarkers/&lt;eXit&gt;:</td>
</tr>
</tbody>
</table>
To check the drawing for crossing breaklines (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use \key{F10} to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 Type <strong>M</strong> to draw markers where the command found crossing objects.</td>
<td></td>
</tr>
</tbody>
</table>

You can then use the other command line options to break the objects, examine each crossing object, and highlight the markers.

For more information about cleaning up maps, use \key{F10} to look up “About Preparing Maps” in the online Help.

Assigning Data to Objects in a Drawing

In order to use the map analysis tools, you must assign data to the map objects in your drawing. This data is textual in nature and is stored in a database table. Tables define the categories of information that you want to associate with an object. For example, for each parcel, you may want to know the parcel number, owner’s name and street address, and percentage of buildable land.

**NOTE** Before you can assign object data to polygons, you must create centroids for the polygons. Centroids are points that contain the object data for the polygons. For more information, see “Creating Topologies” in this chapter.

Exporting Object Data

After you assign data to objects, you can create a report of the object data. Because the data can be viewed with the Data View window, you can export, print, or send the data to an OLE-compatible software program such as Microsoft® Word or Microsoft® Excel for custom reporting. For more information about Data View, use Find to look up “About Data View” in the online Help.

Additionally, because the data is in ODBC format, you can paste it into Microsoft® Access to create an .mdb file. You can import any data that is in a Microsoft® Access.mdb file as point data. Therefore, you can bring in any object data that you assign to objects as point data.
For example, define object data for a parcel map and then create a report. Paste the report into Microsoft® Access, and then create point objects in the center of each parcel. You can then use the point labels to label the points with parcel number, soil type area, and area of buildable land.

**Key Concepts**

- You can assign data to objects as you digitize them or later.
- Object data tables that you create are stored in the drawing. However, you can also attach data from an external database. For more information about attaching data from external databases, see “Accessing External Databases” in the online Help.

### To assign object data to points, lines, arcs, or polylines

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [Fed] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Digitize the lines, arcs, or polylines.</td>
</tr>
<tr>
<td>2</td>
<td>From the Map menu, choose Object Data ➤ Define Object Data to display the Define Object Data dialog box.</td>
</tr>
</tbody>
</table>

![Define Object Data dialog box](image)

(No object data tables are present.)
To assign object data to points, lines, arcs, or polylines (continued)

Steps

<table>
<thead>
<tr>
<th>Use</th>
<th>Field to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>Click New Table to display the Define New Object Data Table dialog box. ADEDEFDATA</td>
</tr>
<tr>
<td>4</td>
<td>In the Table Name box, type a name for the table. Table Name box</td>
</tr>
<tr>
<td>5</td>
<td>Under Field Definition, type a field name. For example, if you want to assign parcel numbers to a parcel map, type NUMBER as the field name. Field Definition area</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> This name must have no spaces in it.</td>
</tr>
<tr>
<td>6</td>
<td>From the Type list, choose what type of data you enter. For example, if the field is NUMBER, then select Integer as the type. If the field is NAME, then select Character as the type.</td>
</tr>
<tr>
<td>7</td>
<td>In the Description box, type a description for the field, for example “The parcel number.”</td>
</tr>
<tr>
<td>8</td>
<td>Click Add to add the field to the data table. The field appears in the Object Data Fields list.</td>
</tr>
<tr>
<td>9</td>
<td>Continue to add fields as needed, and then exit the command.</td>
</tr>
</tbody>
</table>

Assigning Data to Objects in a Drawing 265
**To assign object data to points, lines, arcs, or polylines (continued)**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use <strong>Find</strong> to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 From the Map menu, choose Object Data ➤ Attach/Detach Object Data to display the Attach/Detach Object Data dialog box.</td>
<td>Attach Data to an Object</td>
</tr>
<tr>
<td>11 From the Table list, select the table that you created.</td>
<td></td>
</tr>
<tr>
<td>12 Under Object Data Field, select the field that you want to enter information for, such as “The parcel number.”</td>
<td></td>
</tr>
<tr>
<td>13 In the Value box, type the value for that field, such as Parcel 123.</td>
<td></td>
</tr>
<tr>
<td>14 Under Action, choose the Attach to Objects button.</td>
<td></td>
</tr>
<tr>
<td>15 Select the object to which you want to attach the data. If you want to attach the data to a polygon, then select the centroid of the polygon. For more information about creating centroids, see “Creating Polygon Topologies and Assigning Data to the Polygons” in this chapter.</td>
<td></td>
</tr>
</tbody>
</table>

For more information about object data, use **Find** to look up “About Object Data and Tables” in the online Help.
Performing Zone Conversions Using AutoCAD Map

You may at times receive drawings of the same region that were created in different coordinate zones. For example, one drawing was created in NAD83 metric, the other in NAD83 feet. To get both of the drawings to line up correctly, you can perform a zone conversion by setting up a Map project, and then specifying the coordinate zones for the source drawing and the Map project.

Key Concepts

- This is a quick way to convert zones. However, it is recommended that you establish one coordinate zone for all the drawings for a job.
- Zone conversions respect the base point and north rotation of the source drawings. As drawing information is extracted from one drawing through a query and brought into the Map project, its zone is read and converted to the Map project zone—causing the data to be displayed in the current zone. When saving data back to the source drawing, the process is reversed. The data that is saved back is converted back to the zone of the source drawing.
- The current zone in AutoCAD Land Development Desktop is used as the current Map project zone. If you change either the settings or the zone by using AutoCAD Map commands, then the zone is updated automatically in AutoCAD Land Development Desktop to ensure consistency.

To perform zone conversions

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Create a new drawing. This is your Map project.</td>
<td>Start a New Drawing</td>
</tr>
<tr>
<td>2 Attach the drawing(s) whose coordinate system you want to convert.</td>
<td>Create a Project</td>
</tr>
</tbody>
</table>

NOTE: The drawings that you are converting must have previously been assigned a coordinate zone.
To perform zone conversions (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use [ Feed ] to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>3 From the Map menu, choose Tools ➤ Assign Global Coordinate System to display the Assign Global Coordinate System dialog box.</td>
<td>Assign a Coordinate System to a Drawing or Project</td>
</tr>
</tbody>
</table>

![Assign Global Coordinate System dialog box](image1)

<table>
<thead>
<tr>
<th>4 Under Active Project, click Select Coordinate System to display the Select Global Coordinate System dialog box.</th>
<th>Select Global Coordinate System dialog box</th>
</tr>
</thead>
</table>

![Select Global Coordinate System dialog box](image2)

<table>
<thead>
<tr>
<th>5 Select the coordinate system that you want to use and click OK to return to the Assign Global Coordinate System dialog box.</th>
<th></th>
</tr>
</thead>
</table>

This is the coordinate system that you want to convert your existing drawing(s) to.

<table>
<thead>
<tr>
<th>6 Under Source Drawings, click Select Drawings to display the Select Drawings to Assign Coordinate System dialog box.</th>
<th></th>
</tr>
</thead>
</table>
Creating Topologies

A topology shows the relationships between objects. A topology describes how lines and polygons connect and relate to each other, and forms the basis for advanced GIS functions, such as network tracing and spatial analysis.

You can create node, network, and polygon topologies.
Node Topologies

Node topologies are made up of point nodes. You can create a node topology for borehole data, and then perform a thematic query that shows the core materials at a depth of 10 feet, for example.

Network Topologies

Network topologies are made up of lines and arcs that are associated with each other, such as a street map or stream network.

For example, you can create a network topology out of all the roads in a city. A network topology is composed of nodes (points where three or more lines intersect) and links (the lines that link the nodes together). For example, you can create a network topology of sanitary sewer pipes and control the direction of flow. Likewise, you can define which roads in a road network topology are one-way, have congested traffic, and so on. You can then use this information to trace the shortest route to a destination.

Polygon Topologies

Polygon topologies are made up of lines and arcs that define enclosed areas, where each area forms a polygon. For example, you can define the areas within closed polylines, such as parcels, as a polygon topology. Any common boundaries between polygons are shared between both polygons. When you create a polygon topology, centroids are created for the polygons. The centroids store the object data for the polygons.

Key Concepts

- You can perform a path trace or flood trace on network topologies. A path trace can show the shortest route from one point on a map to another. A flood trace traces out from a point in all directions, to a maximum specified distance. For example, you can use a flood trace to show all the parcels within a 500 meter radius of a proposed community well location.
- Each object in your drawing can be in more than one topology.
- You can create buffers around objects in topologies. For example, you can create buffers around point objects or streams. When you create buffers, the end result is a polygon, because the buffer is a polyline that surrounds an enclosed area.
### Creating Polygon Topologies and Assigning Data to the Polygons

Unlike points and linear objects, a polygon is an enclosed area that is defined by lines, arcs, or polylines. It is not an object in and of itself and therefore, you cannot assign object data directly to it. However, when you create a polygon topology, centroids are created for the polygons. This centroid acts as the polygon object. After the centroids are created, you can assign object data to the polygons.

You can create centroids from existing blocks (and you can create object data from block attributes), or you can create “missing” centroids when you generate a link topology for the polygons. The following task shows how to create a topology that creates centroids.

#### To create a polygon topology

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Draw or digitize the polygons using lines, arcs, or polylines.</td>
<td>Use</td>
<td>Set Up for Digitizing</td>
</tr>
<tr>
<td>2. Clean up the drawing to check for any duplicate or crossing lines.</td>
<td>Use</td>
<td>Clean Up a Drawing</td>
</tr>
<tr>
<td>3. From the Map menu, choose Topology ➤ Create to display the Create Topology dialog box.</td>
<td>Use</td>
<td>MAPCREATE</td>
</tr>
<tr>
<td>4. Type a name for the topology.</td>
<td>Use</td>
<td>MAPCREATE</td>
</tr>
<tr>
<td>5. From the Type list, select Polygon.</td>
<td>Use</td>
<td>MAPCREATE</td>
</tr>
</tbody>
</table>

---

Creating Topologies

271
To create a polygon topology (continued)

Steps

Use to look up

6 Under Topology Objects, click the Link Objects button to display the Link Objects dialog box.

[Link Objects dialog box]

7 Under Object Selection, use one of the selection methods to select the polygon geometry. Click Help for more detailed information about selecting objects.

8 Click OK to return to the Create Topology dialog box.

9 Under Polygon Options, select the Create Missing Centroids check box.

10 Click Proceed to create the topology.

For more information about topologies, use to look up “About Topologies” and “About Editing Topologies” in the online Help.
Creating Overlay Topologies

Overlay topologies show how topologies relate to each other. For example, you can overlay a parcel map topology with a soils map topology. Then, basing your calculations on soil type, you can determine the buildable area on each parcel.

An overlay topology includes a source topology and an overlay topology. The results of the overlay topology depend on which topology you choose as the source topology. For example, the results of the Identity, Erase, and Clip operations will vary, based on which topology you choose as the source and overlay topologies. You can create several different types of overlay topologies:

- **Intersect**: Only the areas that appear in both topologies are saved to the resulting overlay topology.
- **Union**: Areas that appear in either topology are saved to the resulting overlay topology.
- **Identity**: Acts like a union topology. The boundary of the source topology, however, controls the limits of the resulting topology. If an item in the overlay topology is outside the boundary of the source topology, then it is not saved to the resulting overlay topology.
- **Erase**: Erases everything in the source topology covered by the overlay topology.
- **Clip**: The overlay topology acts like a clipping boundary. Everything in the source topology not covered by the overlay topology is clipped.
- **Paste**: Pastes all areas in the overlay topology into the source topology.
Key Concepts

- After you create an overlay topology, you can shade or hatch specific areas by creating a thematic map. For more information, see “About Thematic Maps” in the online Help.
- You can create reports on your overlay topologies that you can edit in Microsoft® Excel or Microsoft® Access. You can then paste the reports into the drawing.

To create an overlay topology

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Create a soils map topology. For more information, see “Creating Topologies” in this chapter.</td>
</tr>
<tr>
<td>2</td>
<td>Create a parcel map topology. For more information, see “Creating Topologies” in this chapter.</td>
</tr>
<tr>
<td>3</td>
<td>Create a Map project, and then attach the drawing(s) that contain the topologies.</td>
</tr>
<tr>
<td>4</td>
<td>From the Map menu, choose Topology ➤ Overlay to display the Overlay Topology dialog box.</td>
</tr>
</tbody>
</table>

![Overlay Topology dialog box](image)
To create an overlay topology (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>Under Input Topology, click Load to display the Load Topology dialog box.</td>
</tr>
<tr>
<td>6</td>
<td>Under Topology Location, select the Source Drawings option.</td>
</tr>
<tr>
<td>7</td>
<td>Under Topology Name, select the name of the topology that you want to use as the source topology. All the currently defined topologies in the Map project are listed in the Name list, regardless of which source drawing they are located in.</td>
</tr>
<tr>
<td>8</td>
<td>Click OK to return to the Overlay Topology dialog box.</td>
</tr>
<tr>
<td>9</td>
<td>Click Load to display the Load Topology dialog box.</td>
</tr>
<tr>
<td>10</td>
<td>Select the name of the topology that you want to use as the overlay topology.</td>
</tr>
<tr>
<td>11</td>
<td>Click OK to return to the Overlay Topology dialog box.</td>
</tr>
<tr>
<td>12</td>
<td>Under Input Topology, select the overlay Operation that you want to perform. For more information, see the descriptions at the beginning of this topic.</td>
</tr>
</tbody>
</table>
To create an overlay topology (continued)

<table>
<thead>
<tr>
<th>Steps</th>
<th>Use \text{F1} to look up</th>
</tr>
</thead>
<tbody>
<tr>
<td>13</td>
<td>Under Result Topology, specify a name, description, and layer for the resulting topology.</td>
</tr>
<tr>
<td>14</td>
<td>Click Proceed to create the overlay topology.</td>
</tr>
</tbody>
</table>

For more information about topologies, use \text{F1} to look up “Overlay Two Topologies” in the online Help.

Plotting Maps

To plot maps, you must create a plot map set. This set contains all the information you need to plot a map or a series of maps. This set includes a plot query, map boundary definitions, and a plot layout block.

**NOTE** This topic describes the plotting options for only the AutoCAD Map commands, not for the entire AutoCAD Land Development Desktop program.

To plot using the AutoCAD Map plotting commands, you must

- Create a Map project, attach the map drawings that you want to plot, and then query the objects in those drawings. You can execute this query in preview mode.
- Create a drawing that contains the map boundary definitions. You can draw a boundary definition as a closed polyline. For example, to create map tiles, create a new drawing, and then draw a polyline for each tile of the map. You can attach the map and do a preview query to see where to draw the boundaries. Each boundary must have a name. To create a name, create a data table and attach object data to the boundary polylines.
- Create a plot layout block. This block defines how each plot in the plot set is laid out. This block must contain at least one floating viewport.

For more information about plotting map sets, use \text{F1} to look up “About Plotting” in the online Help.
Index

alignments, 208  
current, 213  
deleting and importing, 216  
editing, 215  
geometry, 210  
making into one object, 212  
offsetting, 218  
stationing, 218  
annotation, leaders, 157  
APWA symbol standards, 152  
arcs, 142, 148  
ASCII text files, 111  
AutoCAD Land Development Desktop, 2  
accessing commands, 35  
documentation, 22  
exiting, 93  
filepath naming conventions, 23  
options settings, 55  
preference settings, 48, 55  
project structure, 12  
projects, 59  
starting, 32  
upgrading from Autodesk S8 Civil/Survey, 7  
AutoCAD Map, 240  
data storage, 244  
drawing sets, 243  
project workspace, 241  
shortcut menus, 242  
AutoCAD options  
drawing environment, 55  
window display, 57  
AutoCAD preferences  
drawing environment, 55  
window display, 57  
Autodesk S8 commands, accessing, 9  
AutoSnap, 89  
AutoTrack, 90  
bitmap files  
creating from drawings, 77  
digitizing, 158  
blocks  
definition, 169  
scaling, 168  
symbols, 152  
brakes in surfaces, 179  
bends, creating in objects, 167  
circles, 148  
cleanup  
braking parcel lines, 259  
crossing breaklines, 261  
maps, 258  
COGO (coordinate geometry) points.  
See points  
command history, viewing, 45  
commands, accessing, 35  
command line, 43  
pre-defined menu palettes, 37  
pull-down menus, 36  
shortcut menus, 42  
toolbars, 40  
transparent commands, 44  
construction lines, 146  
coordinate zone transformations, 107  
copy objects, 162, 165  
cross sections  
quick views, 194  
crossing breaklines, 261  
Ctext, 154  
curved  
lines, 148  
objects, 148  
text, 154  
custom objects  
and proxy graphics, 72  
data  
assigning to objects, 263  
saving queried data, 252  
database, points, 100  
dialog bar  
label style properties, 233  
digitizing  
images, 158
digitizing (continued)
  maps, 257
  methods, 159
donuts, 148
drag and drop functions
  project workspace, 242
drawing aids, 85
  construction lines, 146
  hatch patterns, 149
  reference points, 87
  snap points, 87
drawing objects, 145
  block definition, 169
  curved objects, 148
  lines, 145
  polylines, 146
text, 153
drawing sets, 243
drawing settings
  points, 102
  prototypes, 61
drawing tools
  lines and arcs, 142
  special lines, 144
  spiral curves, 143
text, 153
drawings
  adding external drawings, 171
  cleaning up, 258
  correcting mistakes, 164
  creating, 64
  opening, 71
  organizing layers, 78
  paper space, 141
  regenerating and redrawing, 78
  saving as bitmap files, 77
  setup, 66
  using named views, 76
  viewpoints, 72
editing tools, 160
  correcting mistakes, 164
  creating selection sets, 161
  using grips, 162
  utilities commands, 168
ellipses, 148
exiting the programs, 93
external
  data references (xrefs), 132
  drawings (xref), 171
filters
  for layer groups, 82
  in selections sets, 161
floating viewports, 140
  display, 141
  drawing scale, 75
  folders for prototypes, 63
  font styles, in text, 153
  geo-referenced images, 254
  grips
  editing objects, 162
  hatch patterns, creating, 149
Help
  accessing, 25
  printing entire file, 26
  printing single topic, 28
  history of commands, viewing, 45
  inquiry commands, 228
labels, 231
  accessing label commands, 232
  editing, 236
  label styles, 231
layers, 81
  changing properties, 79
  creating groups, 82
  Layer Manager, 81
  saving in snapshots, 84
  using in drawings, 78
layout mode, 138
leaders, annotation, 157
lines, 142, 145
  construction lines, 146
  curved, 148
  drawing, 142
  polylines, 146
  special lines, 144
Map project
  attached drawings, 244
maps
  cleaning up, 258
  digitizing, 257
  plotting, 276
menus
  custom menu bar, 38
  loading, 37
  pull-down, 36
mistakes, correcting in drawings, 164
model space, 138
modifying objects, 165
  breaks, 167
  copying, 165
  moving, 162, 166
  resizing, 166
network topologies, 270
node topologies, 270

Index

278
INDEX

notes, 156
object data
  exporting, 263
  listing, 228
Object Enabler, 71
object snaps, 87
Object Viewer, 73
objects
  and proxy graphics, 72
  assigning data, 263
  changing properties, 79
  custom, 72
  editing, 160
  labeling, 231
  modifying, 165
online Help
  accessing, 25
  printing entire file, 26
  printing single Help topic, 28
options, profiles, 58
options, AutoCAD
  drawing environment, 55
  window display, 57
overlay topologies, creating, 273
paper space, 138, 140, 141
parcels, 221
  cleaning parcel lines, 259
  geometry, 221, 222
  managing, 225
  parcel database, 223
plotting maps, 276
points
  AutoCAD POINT command, 98
  creating, 105
  creation settings, 103
  database, 114
  editing, 114
  exporting, 112
  importing, 106
  managing, 121
  marker settings, 104
  point database, 100, 101
  point filters, 112
  settings, 102
polygon topologies, 270
polylines, 146
preference settings, 49
  AutoCAD overrides, 49
  data files, 54
  drawing setup, 51
  drawings, 51
preference settings (continued)
  file paths, 49
  profiles, 58
  prototype, 52
preferences, AutoCAD
  drawing environment, 55
  window display, 57
printing
  entire Help file, 26
  single Help topic, 28
profiles, saving settings, 58
project workspace, 241
  drag and drop functions, 242
  shortcut menus, 242
projects
  drawing setup, 66
  file locks, 61
  introduction, 59
  managing, 61
  prototypes, 52
  renaming, 61
  structure, 12
properties
  object and layers, 79
prototypes
  introduction, 61
  managing, 63
  settings, 52
proxy objects, 71
queries
  defining, 248
  objects, 229
  saving, 252
redraw and regenerate drawings, 78
reference material, 26
reference points, 87
  tracking, 90
resize objects, 162, 166
roadway alignment, 208
  defining objects, 212
  deleting and importing, 216
  editing, 215
  offsetting, 218
  stationing, 218
rotate objects with grips, 162
running object snaps, 87
scale
  drawing in floating viewports, 75
sections
  quick views of surface, 194
selection sets, using filters, 161

Index

279
settings
  drawing environment, 55
  point marker, 104
  points, 102
  profiles, 56
  prototypes, 52, 61
  window display, 57
shortcut menus, 42
  labels, 232
  Map workspace, 242
snaps, 87
spiral curves, 143
spline, 148
starting
  AutoCAD Land Development
  Desktop, 32
  stretch objects with grips, 162
subdivisions
  parcels, 221
surface
cutting cross sections of, 194
data, 178
ing, 191
masking regions, 199
projecting 2D lines onto 3D grid, 206
viewing in 3D, 204
viewing information about, 193
visualizing, 192
watershed model, 186
surface models, 174
using Terrain Model Explorer, 176
surfaces, 183
  breaklines, 179
  creating, 174
symbols, accessing, 152
Terrain Model Explorer, 176, 193
text
  ASCII files, 111
  attaching notes, 156
  curved, 154
  inserting, 153
  multiline, 154
  text window, 45
tiled viewports, 138
TIN (triangular irregular networks), 174
toolbars, 40
topologies
  creating, 269
  overlay topologies, 273
  polygon, 270
tracking, 90
transparent commands, 44
tutorials, accessing, 26, 29
typologies
  network, 270
upgrading, 7
viewports
  display, 141
  floating, 140
tiled, 138
views
  Object Viewer, 73
  saving, 84
  scaling, 75
  using named views, 76
  viewpoints, 72
  zoom and pan, 74
volumes
  calculating cut and fill, 201
  cut and fill tick marks, 203
  waterdrop path, 186
watershed model
  channel network, 186
  creating, 186
  drain targets, 186
  watersheds, 186
window
  display options, 57
  Help topics, 26
  Object Viewer, 73
xdrefs. See external data references
xref. See external drawings
zone conversions, 267
zoom options, 74